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Getting Started

Getting Started
About this Documentation
This document was output from the online help, which is topic driven and not meant to be read
in a linear fashion. Therefore, the PDF might not be organized as smoothly as a typical book.
However, searching the PDF should yield the information you need.

Introducing DB/TextWorks
Inmagic® DB/TextWorks® is a database and text retrieval system that administrators can use to
build networked and standalone textbases for managing diverse types of information including
documents, images, and multimedia. Users can be given different levels of access to the
information, so they can search for and display the information they need.
DB/TextWorks is part of the DB/Text® Library Suite, which is designed for information
professionals within workgroups managing single-site and multi-site libraries that want a single
catalog covering multiple collections. The Library Suite includes the following components:
DB/TextWorks: A specialized database and text retrieval system.
DB/Text WebPublisher Pro: A Web publishing system that provides the ability to deploy,
access, and maintain textbases on the Web.
Inmagic Genie: A Web-based integrated library system (ILS).

SQL and non-SQL Platforms
You may be running DB/Text on either the SQL or non-SQL platform. Both platforms provide the
same features and functionality, but some menus and dialogs differ slightly. The main difference
is that DB/Text for SQL includes an Administration program, which provides functionality
exclusive to the SQL platform, including Backup, Restore, and Upgrade.
The SQL platform also includes the Inmagic DB/Text Importer, which runs as a Windows
service to import records in the background. (The non-SQL platform does not include the
Importer, but it is available upon request to customers who purchased WebPublisher Pro.)
For more information, see DB/TextWorks for SQL.

Starting DB/TextWorks
Click the Start button and choose Programs>Inmagic
Applications>DBTextWorks>DBTextWorks. When you start the software, only a few menu
options are available on the Main window. To see more options, create or open a textbase.
Note: The first time you open this application, the User File Path dialog box opens so you can
specify a location for your personal user files.

Opening a Textbase
To open a textbase
After starting DB/TextWorks, choose File>Open. Use the resulting dialog box to specify
the location of the textbase that you want to open, select a textbase, and click Open.
The first time that you open a textbase, you may be asked for the user file path.
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When you open a textbase that does not yet contain records, you will be prompted to
create records. When you open a textbase that contains records, the Query window
appears, so you can begin searching for records.
To open a textbase using a menu screen
If a menu screen appears when you start the software, click an item on the menu to
open the associated textbase.
To open a sample textbase
The software comes with two sample textbases that you may have installed during Setup. You
can open and use these textbases as you learn how to use the software. The textbases,
Sample1 and Sample2, are located by default in the SAMPLE subfolder of the installation folder
(for example, C:\DBTEXT\SAMPLE). There may also be a Sample Textbases icon or program
item in the Inmagic Applications group on your Windows desktop.
To create shortcuts for opening textbases
You can create a shortcut on the desktop for each sample textbase, or add items to the
Programs list. Each shortcut should point to the executable file DBTEXT32.EXE and a textbase
file name. For example, to open the Sample1 textbase, your shortcut might look like this:
C:\DBTEXT\DBTEXT32.EXE C:\DBTEXT\SAMPLE\SAMPLE1
To create shortcuts for loading menu screens
To use a specific menu screen when you start the software, use the /m switch to include the
menu screen name. The following example loads a menu file called MYMENU.TBM:
C:\DBTEXT\DBTEXT32.EXE /M C:\DATA\MYMENU
A menu screen can list several textbases, so you may find it more convenient to create one
shortcut to a menu screen than to create multiple shortcuts to different textbases.

Getting Help from Inmagic, Inc.
Inmagic, Inc. provides many resources to help you learn and use the software:
Online help. To open the help, start the application and press F1 or choose Help>Help
Topics from the DB/TextWorks menu bar. Use the Help on this Window button
for a
topic specific to that window. For context-sensitive help, click
on the toolbar, then
click a menu command or toolbar button. See also Printing Help Topics.
Knowledgebase and Web site. Choose Help>Inmagic on the Web to access options
including Knowledgebase, the Inmagic web site, and the Support Page.
Error messages textbase. The textbase DBTMSG.TBA is in the DB/TextWorks
installation folder. It lists error messages and solutions.
README file. An HTML file that lists new features and known and resolved issues.
Installation and Upgrade Notes. A PDF document that explains how to install or
upgrade the software.
HTML help pages for WebPublisher PRO. Web_Begin.HTM, Web_IChoices.HTM,
and Web_Msg.HTM are in the HELP subfolder of the WebPublisher PRO folder.
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Contacting Inmagic, Inc.
If you have tried the resources listed above and you still need help, you can contact
Inmagic, Inc. or your local Inmagic dealer.
If you have a maintenance agreement, please have the customer ID ready, and try to be at your
computer when you call. If that is not possible, note exactly what you were doing when you
encountered the problem, the exact text of any error messages you received, and your software
version and serial number (choose Help>About DB/TextWorks to look it up). If you do not
have a maintenance agreement, you can contact Customer Service to purchase one.
Inmagic, Inc.
200 Unicorn Park Drive
Fourth Floor
Woburn, MA 01801 U.S.A.
Tel: 781-938-4444 or 800-229-8398
Fax: 781-938-4446
http://www.inmagic.com
support@inmagic.com

technical support questions

CustomerSvc@inmagic.com

general company, product, and services questions

sales@inmagic.com

sales, product pricing, and custom solution questions

wishlist@inmagic.com

feature requests

If your message is intended for a particular person at Inmagic, Inc. (for example, a Technical
Support representative who is expecting the message or files), please include the name of that
person in the subject and the message.

Communicating with Other Users
You can participate in user-to-user discussions through an Inmagic forum on the Web. Note that
the forums are not an official customer or technical support channel for Inmagic products. To
participate in a forum, go to the Inmagic Customer Extranet at
http://support.inmagic.com/downloads/extranet.html.

Printing Help Topics
To print a help topic, follow the instructions below.
Internet Explorer: Use the Print button on the help toolbar. Or choose File, Print
Preview in the browser, use the drop-down list at the top of the window to indicate which
frame(s) you would like to print, then click the Print icon.
Firefox: Right-click the topic, choose This Frame, Print Frame.

Navigating
DB/TextWorks Windows
The following list describes the most frequently used DB/TextWorks windows:
The Main window is the first window that you see when you start DB/TextWorks.
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The Query window allows you to search for records.
The Report window displays multiple records found by a search.
The Display window shows one record at a time.
The Edit window lets you edit one record at a time.
The Images window displays images referenced in the textbase.
You can open the Report, Display, Edit, and Images windows at the same time and display a
different record in each window, or you can synchronize the windows so they all show the same
record.
The way the records appear in the Report, Display, and Edit windows or in printed reports
depends on the forms that are currently selected. You can use the Form Designer to create your
own forms. To help you get started, DB/TextWorks automatically generates Basic forms that
you can use until you design your own. To see which forms are in use, choose Display>Select
Forms.
The appearance of the query window depends on which query screen is currently selected
(Search>Select Query Screen).

Navigating in the Query Window
The query window appears when you open a textbase or choose Search>Query Screen. The
query screen includes boxes that search fields. You can navigate between boxes and within a
box, as explained in Navigating in Boxes.

Navigating in the Display and Edit Windows
The Display and Edit windows show one record at a time.
To

Do this

Move up or down

Press Ctrl+Page Up or Ctrl+Page Down to move up or down one
page, or
Use the window scroll bars.

Navigate between
records

Choose a Display menu option (Next Record, Previous Record, First
Record, Last Record)
Click the arrow buttons on the toolbar.

Change forms

Choose Display>Select Forms, or
Click the Select Form for this Window toolbar button.

Display a report

Choose Display>Display Report.

The Display and Edit windows consist of information in one or more boxes. If the boxes have
borders and scroll bars, this is obvious. If the borders and scroll bars are turned off, it is not so
obvious. The appearance of each window is determined by the form selected for the window. To
navigate in and among boxes, see Navigating in Boxes.
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Navigating in the Report Window
The Report window displays multiple records after you execute a query or load a set.
To

Do this

Move up or down

Press Page Up or Page Down to move up or down one page, or use
the window scroll bars.
Use the Display menu (Next Record, Previous Record, First
Record, Last Record), or

Navigate between
records

Use the arrow buttons on the toolbar, or press Tab (to move forward)
or Shift+Tab (to move backwards).
Go to beginning or end of Press Home or End.
the selected record
Go to first or last record

Press Ctrl+Home or Ctrl+End.

Display the selected
record

Choose Display>Display Record.

Edit the selected record

Choose Records>Edit Record.

Change forms

Choose Display>Select Forms, or
Click the Select Form for this Window toolbar button.

Navigating between Windows
To navigate between DB/TextWorks windows, use one of these methods
Click a window.
Choose a window from the list at the bottom of the Window menu.
Press Ctrl+F6.
Press Ctrl+Tab to cycle through each open window.
To arrange open windows
Use the options on the Window menu.
To close a window
Choose Window>Close.
To synchronize open windows so they show the same record
Choose Window>Synchronize Windows. When the option has a checkmark next to it,
all open windows will show information from the same record. When the option is not
checked, you can display a different record and/or image in every window.
To resize a window to the selected form or query screen
DB/TextWorks preserves window size and position. To quickly resize a window after
selecting a different form or query screen, choose Window>Fit Window to Form or
click the Fit Window to Form toolbar button.
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Navigating in Boxes
In many windows, DB/TextWorks uses boxes to show information. You can navigate within a
box and between multiple boxes in almost every window except the Report window.

Between Boxes
To

Do this

Go to the next or previous box

Press Tab or Shift+Tab.

Go to a specific box

Click in a box or choose Edit>Go to Box.

Within a Box
To

Do this

Scroll through information

Use the arrow keys or box scroll bars

Display previous or next "page" of
information in a box

Press Page Up or Page Dn

Go to beginning or end of current line Press Home or End
Go to beginning or end of information Press Ctrl+Home or Ctrl+End
in a box
Go to next or previous word

Press Ctrl+Right Arrow or Ctrl+Left Arrow

Go to beginning of next or previous
entry (in the Edit window, in a box
that
contains multiple entries)

Press Ctrl+Up Arrow or Ctrl+Down Arrow
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Selecting Information
You can select information and then use the Edit menu to copy, cut, paste, or delete the
information. You can copy information from any window in which you can insert the cursor,
except the Designers. You can cut, paste, or delete information in any editable box. When you
cut or delete information, the box does not shrink until you save and redisplay the record.
To

Do this

Select characters Drag the mouse cursor over the text, or
Hold down the Shift key while pressing any of the keys used to navigate
within a box, or Click where you want to begin the selection and Shift+click
where you want to end.
End a selection

Release the mouse button or Shift key.

Select one word Double-click the mouse, or
Press Ctrl+Shift+Right Arrow or Ctrl+Shift+Left Arrow.
Select one entry Position the cursor anywhere within an entry and press Ctrl+F7, or
in the
Choose Edit>Select Entry, or
Edit window
Triple-click the mouse.
Deselect a
selection

Click the mouse or press any navigational key (for example, arrow key).

Replace selected Type alternate text.
text

Single Selection Lists
In some lists, you can select only one item, using either method:
Click to select the item, or
Double-click to select the item and, in many cases, close the dialog box.
While an item is selected in the list, you can type a single letter to jump to the next entry in the
list that begins with the letter you typed.

Multiple Selection Lists
In some lists, you can select multiple items, using either method:
Drag the mouse or Shift+click to select multiple items that are next to each other, or
Ctrl+click to select (or deselect) multiple items that are not next to each other.
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Keyboard Shortcuts
Menu
File

Edit

Records

Command
New Textbase
Open
Close Textbase
Print
Exit
Undo
Redo
Cut
Copy
Paste
Paste Entry
Browse Choices
Browse Files
Find
New Entry
Insert Entry Mark
Delete Entry
Select Entry
Insert Current Date
Insert Current Time
New Record
Edit Record
Edit Secondary Record
Save Record (Ctrl+S also saves content

Quick Keys
Ctrl+N
Ctrl+O
Ctrl+W
Ctrl+P
Alt+F4
Ctrl+Z
Ctrl+A
Ctrl+X
Ctrl+C
Ctrl+V
Ctrl+Shift+V
F3
Shift+F3
Ctrl+F
F7
F11
Shift+F7
Ctrl+F7
F4
Shift+F4
Ctrl+F2
F2
Alt+F2
F5 or Ctrl+S

of active window)

Display

Search
Sets
Inmagic.net
Tools
Window
Help

Duplicate Record
Next Record
Previous Record
Next Highlighted Term
Previous Highlighted Term
New Query
Omit Record
Place Order
Spell Check
Refresh
Help Topics
Context Help
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Shift+F2
Ctrl+R
Ctrl+Shift+R
F6
Shift+F6
Ctrl+Q
Alt+O
Shift+F8
F8
F9
F1
Shift+F1
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Mouse Operations
Action

Explanation

Click

Press and release the mouse button quickly

Double-click Press and release the mouse button twice in rapid succession
Shift+click

Hold down the Shift key and press and release the mouse button quickly

Drag

Press and hold down the mouse button while you move the mouse
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Customizing and Configuring
Configuring DB/TextWorks
You can run the DB/TextWorks Setup program to change the configuration settings. This takes
only a minute or two. Configuration information is saved in the DBTEXT.INI file, which is located
in the DB/TextWorks installation folder.
Note: Additional configuration can be performed by editing various INI files.

Languages for Month and Day Names
DB/TextWorks can recognize month and day names in more than one language. The
language(s) it recognizes depend on those specified during Setup. If you specify more than one
set of month or day names, all of them will be recognized in a date, but only the first set is used
for dates generated by the software (for example, Edit>Insert>Current Date) or reformatted by
a form.

Default Stop Word and Leading Article Lists
When you create a new textbase, DB/TextWorks supplies a default list of leading articles and
stop words. Run the DB/TextWorks Setup program to change the default lists. You can edit the
lists for an existing textbase by editing the textbase structure. The default lists are shown below.
Stop words: a an and by for from in of the to
Leading articles: a an the

Year 2000 Compliance
Four-digit years (1957, 2011, and so forth) are always interpreted correctly.
Two-digit years (for example, 4-12-01) are set by default to be Year 2000 compliant up to the
year 2039. To extend beyond that date, you can modify the CenturyYear0= setting in the
[Dates] section of DBTEXT.INI to specify a starting year to indicate a 100-year range into which
two-digit years will be mapped. For information, see 2-digit Years. See also Date Formats for
Year 2000.

Textbase-user Identification
If you select the Track who has textbase open check box on the Track Textbase Access
dialog box, each time a user opens a textbase, their machine name and login name will be
written to a line in the textbase .SLT file (providing that they have write-access to the folder
containing the textbase). When the user closes the textbase, that line will be cleared. At any
time, you can look at the textbase .SLT file (open it with any text editor) to see who has the
textbase open.
This configuration setting permits you to specify that all textbases opened with this copy of
DB/TextWorks will have this information recorded. When you select the Track who has
textbase open check box, the EnableSlotLog= parameter is added to the [Advanced] section of
the DBTEXT.INI file so that all textbases opened with the software are tracked. Alternatively,
you can leave this check box cleared, and turn on tracking in any specific textbase by adding
the EnableSlotLog= parameter to the [Advanced] section of the <textbase>.INI file.
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Single-User and Multi-User Environments
DB/TextWorks allows for single or shared access to a textbase. There are several features that
help control access to a textbase:
Indexing mode. To organize and retrieve information, DB/TextWorks builds indexes for
field information. When you add, edit, and delete record information, the software
updates the indexes to reflect the changes. You can select an indexing mode to
determine when the indexes are updated.
Password protection. You can assign passwords to protect your textbases on a fieldby-field basis, to control who can view and edit information. For example, hide the Salary
field and make all other fields read-only. Assign a Silent password that allows anyone to
open a textbase (even without knowing a password), while still protecting your
information by locking out the features you specify. You can also specify record-level
security to restrict access to individual records.
Maximum number of users. To enhance performance, limit the number of times a
textbase can be opened simultaneously. (This is independent of the number of licensed
users, which can never be exceeded.)
User files. Each person who uses a textbase can save forms, query screens, sets, and
record skeletons in a private file, to which no other users have access. See also:
Textbase Elements and User Files

Customize Toolbar command (Tools menu)
You can customize the DB/TextWorks toolbars that appear in each window. A toolbar is a row of
buttons most often displayed across the top of a window. The buttons provide a quick way to
access frequently used menu options. Toolbar buttons are grouped together by relative function
and are separated by spaces (called separators). You can customize toolbars with buttons and
separators any way you want. Some toolbar buttons provide access to choices not available on
any menu. These include:
Select Form for this Window
Help on this Window
Center text
Right Justify text
Left Justify text
Toolbar customizations are user-specific and apply to all textbases opened by a particular user.
Your custom toolbar settings are stored in the Windows Registry. Using the Customize Toolbars
command, you can customize the toolbar for the Current Window and the Main Window.

Applications menu
You can add an additional Applications menu to DB/TextWorks. This menu can contain links to
HTML pages or other files, including PDF, Microsoft Word, and Microsoft Excel documents. You
can control which choices appear on the Applications menu.
Choosing one of the options on this menu does the following, depending on the type of file you
want to open:
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HTML files. Opens the HTML page in a window inside DB/TextWorks. All of the normal
HTML behavior will work in this window (for example, JavaScript, links).
Other file types. Uses local drive mappings to open another software program to
display a document (for example, it opens Microsoft Word to display a Word document).

Controlling which choices appear on the Applications
menu
In the <textbase>.INI file, the [DBTW_Apps] section controls which choices appear on the
Applications menu for that textbase.
AppCnt= indicates the number of choices on the menu. Each menu choice has a numbered pair
of appName and appFSpec settings, starting with number zero (0).
appName designates the text that appears on the menu; precede any shortcut key with an
ampersand (&)
appFSpec identifies the URL or file location of the document to open. If just a file name is
specified (for example, readme.htm or sales.doc), the software looks for the file in the textbase
folder.
EXAMPLE
[DBTW_Apps]
AppCnt=3
appName0=&Inmagic home page
appFSpec0=http://www.inmagic.com
appName1=&Textbase Help File
appFSpec1=catalog.htm
appName2=&Company Policy Handbook
appFSpec2=d:\Documents\policy.doc

Textbase-Specific Help
For each textbase that you create, you can supply one compiled Windows Help file that
describes any topics you want. For example, you can explain the purpose of a textbase and
provide tips on how to search, edit, and generate useful reports. Textbase-specific help
supplements, not replaces, the DB/TextWorks help. Users can continue to access the
DB/TextWorks help in the usual ways. To see an example of textbase-specific help, open the
DBTMSG textbase that was installed with DB/TextWorks (located by default in the same
directory as DB/TextWorks) and choose Help>Textbase-Specific Help.
To supply supplemental online Help for a particular textbase
1. Open the DB/TextWorks Help menu. If Textbase-Specific Help is disabled,
DB/TextWorks does not detect a textbase-specific Help file (for example, a Help file with
the same name and location as the associated textbase, or with the name/location
specified in the <textbase>.INI file).
2. Create a compiled Windows help file using software from Macromedia (RoboHelp),
ComponentOne (Doc-to-Help), or another supplier.
3. Place the compiled Help file in the same folder as the textbase OR in the location
specified in the <textbase>.INI file. By default, a textbase-specific Help file must be in
the same folder as the textbase and have the same name as the textbase. For example,
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the Help file for a textbase called Loans must be called LOANS.HLP. To change this
behavior, specify the name and path of the textbase-specific Help file in the [Help]
section of the <textbase>.INI file. The <textbase>.INI file must be located in the same
folder as the textbase. You may have to create this file yourself. For example, to point to
a help file called C:\DEMO\LIBRARY.HLP, add these lines:
[Help]
HelpFilePath=c:\demo
HelpFileName=library

For the HelpFileName= line, an extension of .HLP is assumed. Do not include the .HLP
extension. If the Help file is located in the same folder as the textbase, you can omit the
HelpFilePath= line.
This feature is especially useful when you want multiple textbases to point to a single
Help file, or if the Help file has a different name/location than its associated textbase.
4. When you open the textbase, you can access the Help by choosing Help>TextbaseSpecific Help. The command is enabled whenever you open a textbase that has a Help
file associated with it.

Application Options (Copy Special)
Use the Copy Special>Application options to pass record-specific information to other
applications by way of the Windows Clipboard. Other applications must poll the Windows
Clipboard and activate when they find something they recognize.
If you want to sort record-specific information before passing it to the Windows Clipboard, you
can edit the <textbase>.INI file. You can also specify the exact wording that will appear on the
Copy Special menu. For example, instead of the default wording Application (1), you can use
the wording Pass to LiveNote. These options are explained below.
To enable the Copy Special function
1. Add information to the software initialization file, DBTEXT.INI, describing the signature
text which each target application will use for recognition. This .INI file is located in the
DB/TextWorks installation folder.
Note: The DBTEXT.INI file shipped with DB/TextWorks already includes lines for several
applications commonly used with DB/TextWorks (IPRO, LiveNote, Invzn, Discovery,
Launch).
For each target application, add a parameter to the [SpecialVendor] section of
DBTEXT.INI. The name of the parameter is the application name you will use for
reference in the <textbase>.INI file (described in step 2). Make up any name you wish: it
need not bear any relation to the name of the target EXE. Follow this name with an equal
sign (=) and three text strings separated by vertical bars (|). The first string is the
beginning text, the second is the field entry separator, and the last is the ending text.
When information from the field is copied to the Clipboard, it is preceded by the beginning
text and concludes with the ending text. If multiple entries are copied, they are separated
by the field entry separator text. Typically, the target application polls the Clipboard,
looking for the beginning text as its signal. It then uses the other added text to parse out
the information it needs.
The text strings can include control characters using standard C notation. For example, a
line break (carriage return-linefeed pair) is denoted by \r\n.
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Example
This example specifies two applications, Launch and LiveNote:
[SpecialVendor]
launch=dbtext=|\r\ndbtext=|\r\n
LiveNote=LiveNote Command\r\nOpenLRL\r\nmode=exclusive\r\n||

If the Launch application is specified in the <textbase>.INI file, a field containing
CONTR001.DOC would be copied to the Clipboard in the following format:
dbtext=CONTR001.DOC

If, instead, the LiveNote application is specified in the <textbase>.INI file, the Clipboard
would contain this information:
LiveNote Command
OpenLRL
mode=exclusive
CONTR001.DOC

2. Create or edit a <textbase>.INI file, specifying which field in the textbase will be the
source of the information, and which of the applications described in DBTEXT.INI is the
target. You can specify up to two source/target options, using sections called
[SpecialVendor] and [SpecialVendor2]. The <textbase>.INI file has the same name
and location as the textbase (for example, a textbase called PRODUCT uses a file called
PRODUCT.INI).
Two parameters are required in each [SpecialVendor] section, and three are optional.
The first parameter, Vendor, names the target application (as it was named in the
DBTEXT.INI file).
The second, SpecialField, names the field from which the information will be copied
when the Copy Special toolbar button or menu choice is clicked.
The third parameter, MultipleRecs, is optional. Type MultipleRecs=0 if you want to
copy information only from the record that is selected in the Report window. Omit this
parameter if you want to copy information from all of the records in the set if the Copy
Special button is clicked.
Note: If the Display or Edit window is active when you use Copy Special>Application,
information is copied from a single record only.
The fourth parameter, Sort, is optional. To send sorted information to the Windows
Clipboard, add the line Sort=1. Information will be sorted based on the sort option
specified for the current Report window.
Note: You must display the report for the sort to occur. Sorting occurs only when
information is copied from multiple records (MultipleRecs=1). If you do not want to sort
records before passing them to the Windows Clipboard, type Sort=0 or omit the Sort
parameter altogether.
The fifth parameter, Menu, is optional. Add a line in the format Menu=<text> to indicate
the text you want to display in the Copy Special menu, instead of the default text
("Application (1)" or "Application (2)"). To specify an accelerator character, precede it with
an ampersand (&). Be sure not to use E or O for an accelerator, since these are used for
Copy Special>Record and Copy Special>Report. For example, type Menu=&Launch
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Application to place the option Launch Application on the Copy Special pull-right
menu, instead of one of the Application commands.
The following examples show two Copy Special application options. You do not
necessarily have to define two. You can define just one, if that is all you need.
Example 1:
In Example 1, Launch is the target application, Document Name is the field in your
structure that contains the information you want to pass to the Windows Clipboard, all
records will be passed to the target application (MultipleRecs=0 is omitted), the records
will be sorted (Sort=1), and the wording in the Copy Special menu will change to Pass to
Launch.
[SpecialVendor]
Vendor=launch
SpecialField=Document Name
Sort=1
Menu=Pass to Launch

Example 2:
In Example 2, LiveNote is the target application, Annotation is the field in your structure
that contains the information you want to pass to the Clipboard, and the wording in the
Copy Special menu changes to Pass to LiveNote.
[SpecialVendor2]
Vendor=LiveNote
SpecialField=Annotation
MultipleRecs=0
Menu=Pass to LiveNote

3. [Optional] As described above, you can use the Copy Special application commands
that are already on the Edit menu, and you can change their text if you want to.
Additionally, you may want to add Copy Special toolbar buttons to the DB/TextWorks
main toolbar. To do this, start DB/TextWorks and choose Tools>Customize
Toolbar>Main. In the Available buttons list, double-click Copy Special (1) or (2) to add
the button to the Toolbar buttons list. Then close the dialog box.
4. Now you are ready to use Copy Special. Be sure both DB/TextWorks and the other
application are running before testing the Copy Special function.
5. If you need more information about how to use Copy Special after it has been properly
set up for your textbase, consult the vendor or developer of the connecting application.
Tip! You can also use a script to launch another application or set up DB/TextWorks so that it
can detect a recognizable URL, e-mail link, or file link in text in a box and convert it to a
hypertext link.

Setting User Options
Options are maintained separately for each user. They are not textbase-specific. All options
except the Read/write extended characters in MS-DOS format option on the General tab)
persist across sessions, and are saved in the INMAGIC.INI file located on the computer where
the change was made.
Choose Tools>Options to open the Options dialog box.
Options are categorized within tabs, based on their purpose.
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General Tab
Options Group-General Tab (Tools>Options)
Use these options to specify how the software displays information.
Insert date using long format. This option determines how dates appear in the Edit
window when inserted using Edit>Insert>Current Date or Edit>Insert>Series. Changing
this preference does not change the appearance of dates already pasted. Select the box
if you want to use the long format (December 02, 2010) instead of the short format
(12/02/10). The Regional settings of the Windows Control Panel determine the
appearance of long and short date formats. You can use forms to change the
appearance of dates in the Display Record window and reports.
Insert date as new entry. This option determines how the software enters dates in the
Edit window when inserted using Edit>Insert>Current Date or by pressing F4. When
you select this option (DB/TextWorks standard default setting), when you press F4, the
software inserts the date as a new entry. If you clear this option, the software inserts the
date at the cursor position as part of the current entry.
The following examples illustrate how this option works. In the first illustration, an entry is
made in the Date field.

In the next illustration, with the Insert date as new entry option selected (DB/TextWorks
standard default), a date for the meeting was entered as a new entry. Note that each
entry is preceded by a bullet.

In the last illustration, with the Insert date as new entry option cleared, a date for the
meeting was entered as part of the current entry.

Recently used file list. Select or clear this check box to control whether the software
displays a list of recently used textbases at the bottom of the File menu. You can specify
the maximum number listed by entering a number, up to a maximum of 15 entries. This
option is useful if you work with the same textbases over and over and want to easily
open a textbase. If you clear this option, the software automatically reduces the number
of displayed textbases to 0.
Notify when opening empty textbase. This option determines whether a message
notifies you when you open a textbase that does not contain any records (for example,
when you create a new textbase).
By default, this check box is selected. A notification message appears when you
open an empty textbase. When you click OK to dismiss the message, the Edit New
Record window opens so you can add records.
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Note: If the empty textbase is specified as read-only, you will be notified that it is
empty, but the Edit New Record window will not open. This is because you do not
have permission to add records. No window opens.
If you clear this check box, you are not notified when you open an empty textbase
(including a textbase that is read-only). The Query window opens, unless you use a
menu screen box with a different initial action specified.
Read/write extended characters in MS-DOS format. DB/TextWorks can interpret
extended characters (codes above ASCII 127, such as é, £, and ¥) according to
Microsoft Windows or MS-DOS specifications. Select this check box if you are importing
from or exporting to an MS-DOS application. Clear the check box if the source is a file
created using a Windows application.
Note: The Read/write extended characters in MS-DOS format option is reset (cleared)
each time you open DB/TextWorks.
Save new forms, etc. in Textbase File (Public) by default. When you save a new
form, query screen, record skeleton, or set, you can specify whether to save it in your
User File (for your own private use) or the Textbase File (where others can use it as
well). This option determines which file is selected by default.

Report Options Group-General Tab (Tools>Options)
On the Options dialog box, General tab, use the Print using drop-down list to specify the
source of the form you want to use when you print a report.
Select Report Printing Form if you want to use the form specified through the Select
Forms dialog box (Display>Select Forms).
Select Form for current window if you want to use the form for the selected window at
printing time.
DB/TextWorks will do the following when you choose File>Print when a record window is
active:
If the selected report printing form and the form that is currently showing in the display
window are the same, the Print dialog box displays.
If the selected report printing form and the form that is currently showing in the display
window are different, the software displays the Form Used to Print Report dialog box.
This lets you specify which of these two forms to use for printing.
Note: You can select Always use this option without asking on the Form Used to Print
Report dialog box to use the selected form type without being prompted. By selecting this
option, you are selecting the source of the form you want to use to print, not a specific
form to use to print.

Deferred Indexing Group-General Tab (Tools>Options)
Use these settings to specify deferred indexing options for reports.
Show deferred changes in reports and display. Select this box to see the new
versions of any records with deferred updates when you display records or create
reports. (In other words, you see the deferred changes.) This option also affects sorting.
The Display and Report window titles say "(new version)" if a record with deferred
updates is displayed.
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Clear this box to see the old versions of records. If a search retrieves records that have
deferred changes, you will not see the changes when you display records or create
reports. The Display and Report window titles say "(old version)" if a record with deferred
updates is displayed.
Note: Regardless of this preference setting, you always see the new version of a record
in the Edit window, and you always see records waiting to be deleted (the Display and
Report window titles say "deleted").
If indexes are busy. The options in this drop-down list are useful if you are sharing a
textbase on a network and using Shared Immediate indexing. Select an option to
indicate what to do if Shared Immediate indexing is temporarily unavailable when you try
to save a record.
Save record deferred and display message. Changes will be saved as deferred
updates, and a message will inform you of this. Your indexing mode will continue to
be Shared Immediate.
Save record deferred with no message. Changes will be saved as deferred
updates, without any message. Your indexing mode will continue to be Shared
Immediate.
Do not save record. You will have to try saving your changes again later OR
change to Deferred indexing (File>Change Indexing Mode) and save your
changes.

Passwords Group-General Tab (Tools>Options)
Select an option from the Primary and Secondary textbase drop-down lists to determine what
happens when you open a primary or secondary textbase that has a Silent password.
Note: Once a textbase is opened, you can choose File>Use Different Password>Primary
Textbase/Secondary Textbase to select a different password.
Use Silent password and show warning. When you open a textbase that has a Silent
password, a message will inform you that some operations may be restricted. This is the
standard DB/TextWorks default option for primary textbases.
Note: Textbases which do have passwords assigned, but do not have Silent passwords,
will always prompt you for a password, regardless of this setting.
Use Silent password and do not show warning. When you open a textbase that has a
Silent password, no message will appear. This is the standard, DB/TextWorks default
option for secondary textbases.
Always prompt for password. You will be prompted to enter a password.

User Options Group-General Tab (Tools>Options)
The User file directory box displays the path to the folder in which your user files are located.
This folder is typically local to your machine. To change the path, click the Browse button.
Note that if you change the user file directory, your existing user files will be automatically
moved to the new location (if they are not found there already). In addition, your Inmagic.INI file
and your user dictionary for Spell Check will also be moved to the new location.
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Search Tab
Search Tab (Options)
Use the settings on the Search tab (choose Tools>Options>Search) to set options that affect
the search appearance and behavior of DB/TextWorks. All the settings are listed in the Options
group on this tab. The settings are:
Support multiple page TIFF images. When this option is selected, DB/TextWorks is
able to display and print all the images in multi-image TIFF files. For example, a file
called PROPOSAL.TIF might contain ten separate pages. This feature may cause a
slight performance degradation when displaying and printing images, so you should
clear this option if you do not have any multi-image TIFF files.
Display and Print Highlighting
Use inclusive search option for multiple fields
Allow tabbing to Boolean query buttons
Ignore accents on extended characters

Display and Print Highlighting-Search Tab (Tools>Options)
Use the Display highlighting drop-down list to specify how words and terms that you search
for should appear in the Report and Display windows after a search, as well as when you
choose Send Report as Mail and Write Report to File in HTML or RTF format. This option
determines how highlighting appears. The current form determines if highlighting appears
(Tools>Form Properties>General in the Form Designer). Basic forms always highlight search
items. You can choose from the following options:
Reverse Video. The area around the words or terms you searched for is highlighted and
the text is white.
Color. The words or terms you searched for are displayed in color. To select the
highlight color you want, click the Set Highlight Color button (which is enabled when
you select this option) to access the Color dialog box.
None. Words or terms you searched for are not highlighted.
DB/Text WebPublisher: This option affects expanded display on the Web. Also note that
reverse video appears as bold in Web browsers.
Use the Print highlighting drop-down list in much the same as the Display highlighting dropdown list, except that this drop-down list affects how search items appear in printed reports on
the desktop, or in Report forms used on the Web.
Bold. Words or terms that you searched for appear like this.
Italic. Words or terms that you searched for appear like this.
Bold Italic. Words or terms that you searched for appear like this.
Underline. Words or terms that you searched for appear like this.
None. Words or terms that you searched for appear like this.
Note: In both Display highlighting and Print highlighting, None overrides the setting
specified in Highlight search items (Tools>Form Properties>General). This is useful, for
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example, if you want to use the same form for display and printing, but only want search items
highlighted for display.

Use inclusive search option for multiple fields-Search Tab
This option affects query boxes that search multiple fields. It also affects Command queries that
search multiple fields for multiple items in one statement (for example, Author/Title CT Smith &
Mary). For more information, read about using the inclusive search option.
Select this option to specify that a search for an intersection of terms in a combination of fields
be satisfied as if the fields were one field. For example, the search for Smith & Mary shown
above or a search for Smith & Mary in a query box that searches the Author and Title fields is
satisfied if both words appear somewhere in the specified fields (search the Author or Title field
for Smith AND the Author or Title field for Mary).
If this option is not selected, both words must appear in the same field (search the Author field
for both Smith and Mary OR the Title field for both Smith and Mary).

Allow tabbing to Boolean query buttons (Search Tab)
Select this check box if you want the Tab key to include Boolean buttons on a query screen.
Clear this check box if you want the Tab key to skip Boolean buttons. If you choose to skip
Boolean buttons, you can use the Tab key to move to another query box with fewer keystrokes.
Users who cannot, or prefer to not, use a mouse should select this option.
To toggle a Boolean button between AND, OR, and NOT, you must use the mouse or press the
Spacebar.

Ignore accents on extended characters-Search Tab
Select Ignore accents on extended characters on the Search tab (choose
Tools>Options>Search) if you want to search for extended characters without having to type
the accent. For example, to find mañana, type manana. Equivalence is based on the region
selected on the Windows Control Panel and applies only to single characters. If you clear this
check box, you cannot find mañana by searching for manana.
Note also that if you select this check box it means that searches on Code fields will be caseinsensitive. However, sorts will still be case-sensitive.

Display Tab
Display Tab (Options)
Use the settings on the Display tab to set options that affect the appearance of how
DB/TextWorks displays record information and also to specify default form and query screen
settings. There are three options group on the Display tab:
Options group
Form defaults group
Designer settings group

Options Group-Display Tab (Tools>Options)
Use these options to specify 3-D box borders; field entry delimiters; and the default window in
which to display records; and to convert URLs, e-mail links, and file links into live hypertext
Inmagic DB/TextWorks v13 Printed Help

29

Customizing and Configuring
links; to specify the size of toolbar buttons; and to sort field lists alphabetically. All of the settings
affect how DB/TextWorks displays information.
3-D box borders. Select this check box to create boxes with 3-D borders for the query,
display, and edit windows. The following illustration shows a box with a 3-D border.

Note: 3-D borders appear only on boxes that already have borders (choose Tools>Box
Properties>Labels). They will not appear on any boxes that have no borders.
Field entry delimiter. Use this drop-down list to specify the character used to designate
multiple (repeating) entries in a field in Edit windows. Be sure to select a character that
will never appear in your data when editing records. The default is a bullet character
(·).The following example shows two entries separated by bullets:

After a search, view records in. Use this drop-down list to specify the default window
in which to display records found after a search or when loading a set. After you execute
a search, the Select Search Results Window dialog box opens with the window choice
you selected last automatically selected. At this point, you can choose a different window
in which to view the retrieved records. If you change the setting at this point, the new
choice becomes the default setting.
Always use this option without asking. Select this check box to ensure the
window you select will be the default window used to display records, or when you
know you will always want to view search results in a particular window. When you
select this option, the Select Search Results Window dialog box does not open after
a search or when loading a set.
Detect URLs, e-mail links, etc. and convert to hypertext links. Select this check box
to detect a recognizable URL, e-mail link, or file link in text in a box and convert it to a
hypertext link. By enabling this option, you can click on the link and go directly to your
Web browser, e-mail program, or appropriate file application. For example,
http://www.inmagic.com launches your Web browser, mailto:janedoe@inmagic.com
launches your e-mail program, and file://c:\docs\sales.doc launches the appropriate word
processor. Be sure to enclose file names and URLs containing spaces in angle brackets
(for example, <file://c:\sales\monthly report.doc>).
Note: This option is ignored in editable boxes in an Edit window and script input boxes in
any window. Note also that the software converts only the first 512 characters to a
hypertext link.
Tip! If you want to use the file name as a hypertext link to the document when the record
is displayed, open the form in the Form Designer and enter file://as beginning text in the
box containing the filename.
Large buttons on toolbars. Select this check box to use large buttons on all toolbars in
DB/TextWorks. This check box is cleared by default, meaning toolbar buttons are
standard size. If you select this check box, only toolbar buttons on new windows will be
affected during the current DB/TextWorks session. To have the larger buttons appear on
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the Main toolbar, you must quit DB/TextWorks and restart the program. To have the
larger buttons appear on any other window that is open at the time, close the window
and re-open it.
Sort textbase field lists alphabetically. Select this check box to have field names
listed on many dialog boxes within DB/TextWorks appear in alphabetical order. If the list
includes secondary fields, they will be interfiled with the primary fields. For example, if
you select this check box, the field lists on the Box Properties dialog boxes in the Query
Screen Designer, Menu Screen Designer, and Form Designer appear alphabetically. By
default, this check box is not selected. This option does not apply to the following field
lists:
The Fields list on the Edit Textbase Structure dialog box.
The Field Name list on the Edit Field dialog box.
The Field list on the Query Choices Browser dialog box for query boxes. (You can
still use field order in the query box to control which field's index appears first when
you open the dialog box.)
Note: The Field list is sorted alphabetically on the Query Choices Browser dialog box
when doing a Command Query.
The Associated Field list on the Link Definition tab of the Edit Fields dialog box.
(Applies to Link fields only.)
The field lists on the Field Access Passwords and Silent Password tabs on the
Textbase Passwords dialog box.

Form Defaults Group-Display Tab (Tools>Options)
Use these options to customize default form, query screen, and menu screen settings. You can
specify custom text and label default font settings, as well as other custom default settings (See
More Defaults below).
Set Text Font. Click this button to specify the fonts DB/TextWorks uses for new forms,
Basic Record forms, Basic Report forms, new and Basic Query screens, and box text on
menu screens. The font that you select will also be used for the Textbase Information
window, printed definitions of textbase elements; and printed lists (validation,
substitution, stop words, leading articles, indexes).
Set Label Font. Click this button to select the font to use for box labels in forms and
query screens.
More Defaults. Click this button to access the Form Defaults dialog box. This dialog box
contains six tabs from which you can specify other default settings for the Basic Record
form, the Basic Report form, the Basic Query screen, new forms, new query screens,
and new menu screens.

Designer Settings Group-Display Tab (Tools>Options)
Use the Number of undo levels option to set the maximum number of actions that can be
undone using Edit>Undo in the designers (form, query screen, and menu screen).
The default is 4. The minimum allowed is 0 (which disables the undo feature) and the maximum
is 50.
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Undo states are retained in memory, so if you have unusually large form definitions, many
applications running simultaneously, or a modest amount of system memory, consider
constraining the number of undo levels.

Imaging Tab (Options)
Use the settings on the Imaging tab to specify how DB/TextWorks handles searching for images
and image display.
Image drive(s). Type up to twelve drive letters to indicate where you want
DB/TextWorks to look for image files referenced in records. Do not include spaces or
punctuation between drive letters. For example, to look on the C:, D:, and H: drives, type
"cdh" (without quotation marks). List drives in the order that you want DB/TextWorks to
look. If you leave this box blank, the software will look for images on the drive where the
textbase resides or the current drive.
Note: If an image name in a record includes a drive letter (for example, C:\DOG.TIF),
DB/TextWorks ignores the Image drive(s) setting and looks for the image only in the
location specified in the record.
Tip! You can also specify an optional volume ID field for each textbase to specify how
DB/TextWorks handles searching for images.
Support multiple page TIFF images. When this option is selected, DB/TextWorks is
able to display and print all the images in multi-image TIFF files. For example, a file
called PROPOSAL.TIF might contain ten separate pages. This feature may cause a
slight performance degradation when displaying and printing images, so you should
clear this option if you do not have any multi-image TIFF files.
Support only short filenames for images. In most cases, you should clear this option
to ensure that long file names in Image fields are interpreted properly. Check this check
box if you want to include comments after the name of some image files without
surrounding the image file name with quotation marks. (This option is useful if you added
comments to image file names with v1 DB/TextWorks.) Counters after image file names
(for example, MEMO.TIF 3) are interpreted correctly regardless of this option setting.
However, if a long file name in an Image field contains numbers that might be
misinterpreted as a counter, enclose the file name in double quotation marks ("Form
1040 Schedule 12"). If you are using a counter to increment image names, place the
counter outside of the quotation marks ("Form 1040 Schedule 12" 3).
Fit Image to Window. The options in this drop-down list determine if and how images
are scaled when displayed in the Images window. They do not affect printing.
Scale proportionally if necessary. Proportionally fit each image to the window,
scaling images up or down if necessary.
Leave original size. Do not scale images.
Stretch horizontally to fit. Stretch images horizontally to fit the window.
Stretch vertically to fit. Stretch images vertically to fit the window.
Leave small images original size. Select this box to allow images to be scaled
down but not up when you choose Fit to Window (Images menu). A small image is
one that is smaller than the Images window, such as a business card. Original size
means the actual size of the image.
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E-mail Tab
Use the settings on the E-mail tab to designate how to access mail services for the Send Report
as Mail feature. You have two options:
MAPI (Messaging Application Program Interface). MAPI (which is a program
interface that lets you send e-mail from within Windows programs) uses the e-mail
program already installed on your computer to access mail services. If you experience
problems trying to use MAPI, then you should use SMTP instead.
Important! MAPI users must also designate their e-mail program as their default simple
MAPI client. To do so, please consult the documentation provided with your e-mail
program as each one is different.
Tip! To show an example of how to designate an e-mail program as your default simple
MAPI client, this is what you would do if you use the Qualcomm Eudora Pro V4.1
program: Open the program, choose Tools>Options, and select the MAPI category. In
the User Eudora MAPI Server section, select either the When Eudora Is Running option
or the Always option. Click OK.
SMTP (Simple Mail Transfer Protocol). SMTP accesses mail services directly, without
the need to use an e-mail program. To use this option, you must provide the name or IP
address of your mail server.
Note: If you use SMTP, the maximum amount of text that you can place in the body of an
e-mail message is 32,000 characters.
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Planning Your First Textbase
Planning is the most important part of textbase development. Before you start creating
textbases, determine what kinds of information you want to track and whether that information
should be in one textbase or several.
If you put the information in several textbases, and those textbases contain related information,
you may want to link them. For example, you may want to put employee names and addresses
in one textbase, then access that information from several other textbases. By linking textbases,
you only have to maintain common information in one place.
Before you create your first textbase, try creating one or more pilot textbases to test your ideas.
Then design a few forms to display the results. Perform queries, sort records, and print reports
to see what kinds of results you get. You can experiment and take chances with a pilot textbase
that you might not want to try with a real textbase. A few minutes practicing on a pilot textbase is
time well spent.
It is often a good strategy to start with something that can be produced rapidly. For example,
create a small pilot textbase that may eventually be turned into a larger, real textbase. A pilot
textbase of 10 or 20 records can introduce potential users to textbase possibilities. If you are
designing textbases that others will use, enlist their support by including them in the design
process. It is easier to give people what they want if you know their requirements and
preferences from the start.
Testing the reactions of users is important even if you have limited time. Let people see the
results of what they have said they want, before you invest time and effort in finishing the
project. Seeing a search carried out and the results of a search printed or displayed provides
immediate feedback and is a necessary part of the refinement process.
Here are some issues to consider before you start creating a textbase:
Will some of the information that you are tracking be common to several textbases, or
common to a number of records in one textbase? For example, are there names and
addresses that you may want to access from multiple textbases? If so, consider linking
the textbases.
Which fields should each record include?
What type of information will each field hold and how will each field be indexed? The
settings that you select for each field as you create the textbase will determine how the
information can be retrieved, sorted, and printed.
Will you apply validation to any of the fields to control the information that is allowed into
the textbase? If so, what type of validation will you apply?
Will you assign passwords for security? You might want to restrict some fields or
individual records so they are read-only or hidden. Even if the information is not
confidential, you may want to impose some limitations on who can do what to a
textbase. In a shared environment, most textbases have a Master password that
protects the textbase structure from being changed.
How will you get the record information into the textbase? The most efficient method is
to prepare a text file that you can import. The alternative is to type each record by hand.
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Will you publish the textbase to the Web (using DB/Text WebPublisher PRO)? If so,
consider what HTML features you want to give query screens, forms, and menu screens
(for example, whether you want URLs to be detected and turned into hypertext links that
can launch a Web site or application).
An Example
Assume you work for an environmental consulting firm that submits proposals to prospective
clients. To keep track of the proposals, you create a textbase called Proposal.
The textbase contains client names and addresses, document titles, authors, dates, and
telephone notes recorded after important conversations. It also includes the full text of each
proposal, imported in one simple operation, so you can search for any word or phrase in the
document. It includes image file names, associated with photographs, drawings, and scanned
faxes or memos, so you can view and print images along with the other data.
By organizing these materials into a textbase, you can now do a quick search for all proposals
written in 2002 for a study of wetlands in the Florida panhandle. Or for all proposals written by
Hector Thoreau. You can design reports to print the information you want, formatted the way
you want it. For example, you can print a summary of proposal titles and dates, or the full text of
one or more proposals, or a set of architectural site drawings, or generate mailing labels for your
client list.
One of the most important considerations in creating a textbase is deciding what will constitute
records and fields. For this pilot textbase, each proposal constitutes a record. Each field
represents a shared characteristic of all proposals, such as Title, Client Company, and Street
Address. Here is a partial list of fields used in the textbase, followed by a summary of suggested
indexing and validation settings:
Field Name - Field Type, Indexing, Validation and/or Special Filing
Title - Text, Term and Word, Field Entry Required
Client Company (to whom the proposal was sent) - Text, Term, Use Validation List
ID - Automatic Number, Term
Street Address - Text, Word
City - Text, Term & Word
State - Text, Term, Use Validation List
Country - Text, Term, Use Validation List
Postal Code - Text, Term, clear Numbers File Numerically
Contact Name - Text, Term & Word, clear Ignore Leading Articles, clear Use Stop Word List
Phone - Text, Term, uncheck Ignore Leading Articles, clear Numbers File Numerically
EMail - Code, Term
Authors - Text, Term & Word, clear Ignore Leading Articles, clear Use Stop Word List
Date Completed - Date, Term, Require Strictly Correct Type, Allow Trailing Text
Awarded - Text, Term, Use Validation List (Yes/No/Pending), Field Entry Required
Expenses - Number, Term
Summary - Text, Term & Word
Telephone Notes - Text, Term & Word
Full Text (OCR proposal text) - Text, Word
Images (scanned photos and drawings) - Image, Term
Record Created - Automatic Date (when record is created), Term
Record Modified - Automatic Date (when record is created or last modified), Term
As you plan the textbase, keep in mind that each field can hold multiple (repeating) entries of
the same type of information. You do not need to create separate fields for each entry. For
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example, if a particular client has a home phone, business phone, and fax number, make each
number a separate entry in the Phone field (by pressing F7 when editing the record). Each entry
can be searched and formatted separately, based on the indexing choices that you select.
Be sure that the field names you assign are clear and unambiguous. For example, will a field
called Date hold the date a project was begun or completed? To avoid ambiguity, call the field
Date Completed or Date Started, depending on the information it will hold.
After creating the textbase and entering records into it, test it. Search for records, display them
in various windows, and then print some reports using forms that you have designed.
Despite the most careful planning, you may find that you need to make some changes.
DB/TextWorks is flexible enough to allow you to change most aspects of the textbase structure
at any time. For example, you can add, rename, or delete fields and change how they are
indexed. Knowing in advance that you have this kind of flexibility, you can experiment, and
refine your textbases until they provide the results that you want.

Creating a Textbase
1. Choose File>New Textbase, specify a name and location for the new textbase, and
click Save.
2. In the Create Textbase Structure dialog box, select Define New Textbase and click OK.
Note: You do not have to create a textbase from scratch. You can copy or import a
textbase structure. To do this, select one of the other options on the Create Textbase
Structure dialog box, as appropriate.
3. In the Edit Fields dialog box, add a field by typing a name in the Field Name box and
clicking Add. Field names can be up to 20 characters and can include letters, digits,
spaces, hyphens, and underbars. Do this for each field you want to add. The fields you
add appear in the Field Name list.
4. Select a field from the Field Name list.
5. On the Type and Indexing tab, specify the appropriate field type, indexing, and Special
Filing options for that field, then click the Change button.
6. On the Validation tab, when applicable, specify the appropriate validation options for the
selected field, then click the Change button.
7. Depending on the type of field selected, one of the following tabs may appear on the
Edit Fields dialog box. Specify the options you want, as appropriate, then click the
Change button.
Text Options tab. For Text fields, specify whether to use a substitution list and type
the entries you want in the list. For Text and Code fields, specify whether to connect
a thesaurus textbase to the field.
Automatic Number Definition tab. For Automatic Number fields, specify how
numbers appear, including number increment and whether thousand separators are
used.
Automatic Date Definition tab. For Automatic Date fields, specify when dates are
updated, as well as whether both date and time appear, and in what format.
Computed Number Definition tab. For Computed Number fields, specify the
formula you want to use, as well as how computed numbers are formatted.
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Computed Date Definition tab. For Computed Date fields, specify the formula you
want to use, as well as how computed dates are formatted.
Link Definition tab. For Link fields, specify a secondary textbase and its
associated field.
8. Repeat steps 4-7 for each field in the Field Name list.
9. Click Finish on the Edit Fields dialog box to return to the Edit Textbase Structure dialog
box.
10. Specify Textbase Options by clicking the following buttons on the Edit Textbase
Structure dialog box:
Passwords
Sort Order
Stop Words
Leading Articles
Log File
Maximum Users
XML Match Fields
11. Click OK to close the Edit Textbase Structure dialog box, then click OK in response to
the confirmation message that appears.
12. A message tells you that the textbase is empty. Click OK to open the Edit window. (This
window lets you add new records to the textbase.)
Note: If you do not want to be notified when you open an empty textbase, clear the
Notify when opening empty textbase check box on the General tab of the Options
dialog box (choose Tools>Options>General).
13. To create a record, fill in the boxes and choose Records>Save Record. Choose
Records>New Record each time you want to add another record. If you do not want to
type information into one record at a time, you can import multiple records from a text
file.
To make changes to the textbase structure
Choose Maintain>Edit Textbase Structure.
To see information about the textbase
Choose Display>Textbase Information.
To change the appearance of the information in your textbase
Choose Display>Design Form to create forms for the Report, Display, and Edit
windows.
Or, if you have already designed forms or there are designed forms available:
Choose Display>Select Forms and select the form(s) you want to use.
Technical Specifications for a Textbase
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Maximum number of records per textbase: Depends on average record size (two
gigabytes available for records storage)
Maximum number of fields per textbase: 250
Maximum number of entries per field: Unlimited
Maximum size of each record, field, and entry: Up to two gigabytes (total)

Textbase Information
Choose Display>Textbase Information to see detailed information about the textbase.
The Textbase Information window displays a list of fields and their settings, information about
validation, indexing mode, textbase defaults, user file folder, lists of public elements and those
currently selected, serial number, number of licensed users, and other information. It also
displays the contents of the DBTEXT.INI file and the optional <textbase>.INI file. This
information is especially useful in diagnosing problems with Copy Special or Textbase-Specific
Help.
Note: If the Edit Secondary Record window is active when you choose Textbase Information,
you see information about the secondary textbase. If any other window is active, you see
information about the primary textbase.
You can resize or move the window to a more convenient location.
While the Textbase Information window is open, it is not updated as the textbase status
changes. To refresh the window, choose Textbase Information again.
To search for information, use Edit>Find.
To copy information to the Windows Clipboard, select the information and use Edit>Copy.
To print textbase information, click the Print button in the Textbase Information window toolbar
or choose File>Print while the Textbase Information window is active.

Field Type and Indexing
Field Type
Each field in a textbase has a field type that indicates the type of information it will hold. Choose
a field type before selecting indexing information, because changing the field type resets any
indexing or Special Filing options that you have already made for that field.
To define or change the field type
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. Select the field for which you want to change or define field type from the Field Name
list.
4. On the Type and Indexing tab, select one of the following field types from the Field Type
drop-down list:
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Field Type
Text

Used for fields that will hold
Any text or combination of alphanumeric characters, punctuation,
spaces, and line breaks (carriage returns).

Number

A series of digits that may be calculated or sorted as a value.
Sorts negative numbers before positive numbers.

Date

Dates, in any of the many formats that the software recognizes.

Automatic Number

A unique number generated by the software, which cannot be
edited.

Automatic Date

The current date or current date at the time a record is saved and
time when a record is saved. The field cannot be edited.

Automatic ID

An automatically generated sequence of characters, representing
the next value in a series. The field can be edited.

Computed Number

An automatically generated value derived from a formula that you
specify. The field cannot be edited.

Computed Date

An automatically generated date derived from a formula that you
specify. The field cannot be edited.

Image

The name(s) of associated image file name(s).

Link

Text that will be matched against a corresponding field in another
textbase, in order to associate information in that textbase with
this one.

Code

Any items in which case and punctuation should be considered
significant during searches and sorts, such as chemical names or
scientific formulas.

UDC

Universal Decimal Classification numbers, used for the
classification and retrieval of documents.

Access Control

Record class designations for records in a textbase to which you
want to restrict access (Full Access, Read-Only, or Hidden).

5. Depending on the field type that you select, the dialog box may change to show
an additional tab for you to specify more information related to that field type. For
example, if you select Link from the Field Type drop-down list, the Link
Definition tab appears. Use this tab to specify the secondary textbase and
associated field for the Link field.
6. Click the Change button. Notice that the changes you made are reflected in the
Field Name list.
Note: Before you add records to a textbase, you can freely change the field type. When
you change the field type, all validation, indexing, and Special Filing settings for that field
revert to the default settings. If a textbase contains records, changing the field type might
leave non-conforming information in the textbase. For example, if you change a Number
field to a Date field, the software will attempt to interpret existing numbers as dates.
Changes in field type cause any affected indexes to be rebuilt automatically.
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Require Strictly Correct Type
On the Type and Indexing tab of the Edit Fields dialog box, you can select the Require Strictly
Correct Type check box for Number, Date, or Link fields. A strict field accepts information only
if it conforms to the field type for that field. Before you add records to a textbase, you can
change a field from strict to non-strict. When a textbase contains record information, changing
from non-strict to strict might leave non-conforming information in the textbase.
Strict
Date

Requirements
Accepts any entry that appears to be a date. Does not accept text other than day or
month names, or numbers that do not appear to be dates.
See Also: Entering Information in Strict Date Fields

Number Accepts any entry that appears to be a numeric value.
See Also: Entering Information in Strict Number Fields
Link

Accepts information only if it matches existing information in the associated field in
the secondary textbase. A strict Link field prevents users from typing entries that do
not match entries in the associated field, by requiring that the matching record in the
secondary textbase exist before you can fill in the Link field in the primary textbase.
If you clear the Require Strictly Correct Type check box, users can create the
matching record in the secondary textbase after filling in the Link field, or leave the
field without a match.

Selecting the Require Strictly Correct Type check box enables the Allow Trailing Text check
box for Number and Date fields. Link fields cannot have trailing text.

Entering Information in Strict Date Fields
If you want a Date field to accept date information only, make it strict by selecting the Require
Strictly Correct Type check box on the Type and Indexing tab of the Edit Fields dialog box. A
strict Date field will accept information only if it appears to be a date. Words other than day or
month names, and numbers that do not appear to be dates will not be allowed.
Select the Allow Trailing Text check box to allow text to follow the date, while still having the
date interpreted as a date. If the field allows trailing text, you can append text after a date and
the date will still be interpreted correctly. Here are some examples of trailing text:
10-Dec-1998, draft submitted
November 3, 2002 Set up meeting
March 2003 by the author
Trailing text that follows a partial date should not begin with a number or word that looks like the
abbreviation for a month, date, or year because DB/TextWorks might assume that the trailing
text is part of the date. For example, 12/03, may ship product yields a date of May 12, 2003.
Similarly, the entry Feb 1998, 40 units does not index as a date because Feb. 40, 1998 is not a
valid date.
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Entering Information in Strict Number Fields
A strict Number field accepts only the characters listed below.
Allowed in a strict Number field

Examples

Digits 0-9

250

Decimal separator (usually . or ,)

3.5

Thousand separators (usually . or ,)

1,000

Parentheses or leading minus sign

-3 or (3)

Currency symbol such as $, £, ¥, kr, €

$15.00 or £19 or 200¥

You can include no more than one embedded decimal separator. The characters used for the
currency symbol, thousand separator, and decimal separator are determined by the currency
and number formats selected in the Regional settings of the Windows Control Panel at the time
you start DB/TextWorks.
Note: If you create a textbase using a particular currency format and later change to another
format, you might have problems manipulating numbers already typed in the textbase, due to
the way decimal separators and thousand separators are represented.
If the Allow Trailing Text check box is selected for a strict Number field (on the Type and
Indexing tab of the Edit Fields dialog box), you can append text after a number, and the number
will still be interpreted as a value. Here are some examples of numbers with trailing text:
$330. (estimated by H.R. Perkins)
500 sold
1549 Ordered by MIS Department

Allow Trailing Text
Trailing text is text that follows a strict date or number. The purpose of trailing text is to let you
require a strict date or number, but still allow comments and other text after it.
To allow trailing text
1. Select a field with a Date or Number field type (choose Maintain>Edit Textbase
Structure>Edit Fields).
2. On the Type and Indexing tab, select the Require Strictly Correct Type check box.
This enables the Allow Trailing Text check box, if trailing text is applicable for the
selected field type. For example, Link fields cannot have trailing text.
3. Select the Allow Trailing Text check box.
4. Click the Change button.
Here are some examples of Date and Number fields that include trailing text:
6/6/57 first published in USA
July 1994 - dismissed
1500 (estimated number of items to be shipped)
256 ordered in error
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Selecting Term and/or Word Indexing
Use the Type and Indexing tab on the Edit Fields dialog box to select Term and/or Word
indexing for the currently selected field. You can also specify more specific indexing choices by
setting Special Filing Options.
An index is a sorted list of information in a field, conceptually similar to an index in the back of a
book. DB/TextWorks uses indexes when searching.
Every field in a textbase can have a Term index, a Word index, both, or neither. When you
create a textbase, you decide how each field should be indexed. Based on your choices,
DB/TextWorks may place each word or term in a field into an index. Each word or term in an
index is called a key.
If you Term index a field, every complete entry (term) in that field is placed in the index. Note
that DB/TextWorks actually indexes only the first 250 significant characters of each entry. A
significant character is one that is retained in the index and which affects the filing order. For
example, punctuation characters are significant in Code and UDC fields but are not significant in
other field types. Alphanumeric characters are significant in all field types.
If you Word index a field, every word in that field is placed in the index (except stop words, if
Use Stop Word List is selected for that field on the Type and Indexing tab). A word is defined
as a consecutive series of alphanumeric characters. A space or punctuation character signals
the end of a word. The exception is a decimal symbol followed by a number (for example, 3.5),
which is considered part of the word.
For example, look at the Term and Word indexes for a Text field called Title, which contains the
entries Complete User's Guide, Product Guide, and Reference Manual.
Term Index

Word Index

Complete User s Guide
Product Guide
Reference Manual

complete
guide
manual
product
reference
s
user

In the previous example, punctuation is not retained in the Term index because punctuation is
not significant in a Text field. For example, User's appears without the apostrophe in the Term
index. It appears as two words in the Word index (user and s) because punctuation signals the
end of a word. The way information is indexed does not affect how the information appears in
the textbase. Information in the textbase is retained exactly as it was entered.
If you do not index a field, DB/TextWorks does not place the contents of the field in an index, so
you cannot search the field. Unindexed fields do not appear on the query screen. However, you
can still see the information in the field when you display or edit records, sort, or print. If you
expect that you will never search a field, you should not index it. If you change your mind, you
can always index the field at a later time. By not indexing, you save disk space and indexing
time.
One of the benefits of indexing a field is that when you search a textbase, you can display the
indexes by pressing F3 or choosing Edit>Browse Choices. To ensure accurate searches, you
can paste words or terms from the index into the field, then search for those items.
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To decide how a field should be indexed, consider what types of operations you want to be able
to perform on the field, as shown in the following table. Choosing both Term and Word indexing
gives you the most flexibility but requires more disk space and often may not be necessary.
Note that a Number or Date field with no trailing text does not need a Word index. A Text field
that holds an abstract or description does not need a Term index.
This operation

Requires this type of index

Browsing and pasting terms
Term search
Comparison search
Range search
Determining which records match during an import
Ability to select an Associated field when defining a Link field *
Ability to specify Unique Entries Only validation
Browsing and pasting words
Proximity search
Word or Phrase search

Term
Term
Term
Term
Term
Term
Term
Word
Word
Word

* Only Term indexed fields appear in the Associated Fields list on the Link Definition tab for a
Link field.

Special Filing Options
Use the Type and Indexing tab on the Edit Fields dialog box to specify Special Filing Options for
the currently selected field.
The default Special Filing settings depend on the field type and whether the Term Indexed
and/or Word Indexed check boxes are selected. In certain situations, DB/TextWorks
determines the best choices and disables some or all of the Special Filing Options.
All of the Special Filing Options (except Use Stop Word List), affect the filing order, which is
the set of rules governing the order in which items are Term-indexed and sorted. You can see
the indexes when you press F3 in a box on the query screen. The field type for each field also
determines filing order. Filing order for extended characters is governed by the Regional
settings of the Windows Control Panel.

Word by Word
Select the Word by Word check box to index and sort each entry in a Term-indexed field word
by word instead of letter by letter. Spaces sort before letters in Word-by-Word indexing. If you
clear the Word by Word check box, DB/TextWorks ignores spaces and alphabetizes entries by
comparing each letter in sequence.
Letter by Letter

Word by Word

Newark
New Haven
New London

New Haven
New London
Newark
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Ignore Leading Articles
Select the Ignore Leading Articles check box if you want the field to use the current leading
article list. Words in the list that occur at the beginning of an entry in a Term-indexed field (such
as A, An, and The) are ignored when information is sorted and indexed for searching purposes.
Ignore Leading Articles is the default setting for a Text field. If you use a Text field to hold
information such as a Library of Congress number, clear this option. Note that you would not
use a Code field for Library of Congress numbers because they require numeric filing.

Numbers File Numerically
Select the Numbers File Numerically check box if you want a series of one or more digits not
immediately preceded by a letter to be indexed and sorted numerically. Clear the check box if
you want them sorted alphabetically.
Numbers filed numerically

Numbers filed alphabetically

1
1
2
121
13
13
121
2
When numbers are filed numerically, they are indexed and sorted as values, and truncation
searches may not find the anticipated records. For example, the search 2* will not find 20.
When numbers are filed alphabetically, they are indexed and sorted as if they were words, and
truncation searches do find the desired records.
In a Text field where numbers are filed numerically, parentheses or a minus sign are interpreted
as punctuation and are not considered for filing. For example, -2 is the same as 2, and is filed
between 1 and 3. In a Number field, negative numbers file before zero (-2, -1, 0, 1, 2).
Both types of filing can be useful, depending on the situation. For example:
Use numeric filing for publication volume or issue numbers in a Text field, so that
Memoirs Vol. 2 will file before Memoirs Vol. 13.
Use alphabetic filing for SICs (Standard Industry Codes) in a Text field so you can do
truncation searches, such as SIC=12*.
Use alphabetic filing for telephone numbers, Social Security Numbers, postal codes, or
any sequence of digits not meant to be filed as numbers in a Text field. If you use
numeric filing, leading zeros are removed in the Term indexes, so the phone number
(02) 555-0089 would be indexed as 2 555 89.

Use Stop Word List
Select the Use Stop Word List check box for a Word-indexed field if you want the field to use
the current stop word list. Using a stop word list can save disk space and indexing time,
because words in the list will not be included in the Word index when information is added to the
field.
As a result, a word or proximity search for words included in the stop word list will not find any
records. Phrase searches will find records (as long as the phrase includes at least one
unstopped word).
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Text Fields
Use a Text field to hold text (for example, names and descriptions), as well as numbers that do
not indicate quantities and/or will not be used in a calculation (for example, telephone numbers).
Select the Type and Indexing tab on the Edit Fields dialog box to specify Text as the field type
(choose Maintain>Edit Textbase Structure>Edit Fields).
A Text field can hold letters, digits, and any other keyboard or extended characters, including
any combination of alphanumeric characters, punctuation, spaces, and line breaks. Like other
field types, a Text field is unlimited in size. It might hold one word or a 40-page deposition.
For telephone numbers, Social Security Numbers, postal (ZIP) codes, or any sequence of digits
not meant to be calculated, use a Text field with alphabetic filing (clear the Numbers File
Numerically check box in the Special Filing Options group on the Type and Indexing tab). If you
do not make this change, leading zeros will be removed in the Term index, so a phone number
such as (02) 555-0089, will be filed as 2 555 89.
If you plan to do truncation searching on numbers in a Text field (for example, 25*), you should
also file numbers alphabetically (that is, clear the Numbers File Numerically check box).

Creating Substitution Lists for Text Fields
To make data entry easier, you can specify that a Text field should use a substitution list during
data entry and imports. After you create a substitution list and you start editing records, you can
type a substitution code from the list. For example, type vt and the word Vermont will appear
when you move the cursor off the field. You can choose Edit>Browse Choices or press F3 to
see the substitution list (if any) for the current field and paste entries from the list into the field if
desired. During import or batch modify, substitutions are made automatically for fields that have
a substitution list.

Specifying Thesauri for use as Validation Lists
To provide a way to share a single list of approved terms among any number of fields and
textbases, and therefore make data entry easier, you can connect one thesaurus textbase per
field, which users can use as a validation list. Once a thesaurus textbase has been connected to
a field, all your users can populate that field from the same list. Note that you can connect a
different thesaurus to each field, or you can connect the same thesaurus to each field, or any
combination thereof. However, remember that you can connect only one thesaurus to a field.

How Numbers in Text Fields are Handled
Numbers in a Text field file numerically by default (Special Filing). In other words:
Numbers at the beginning of a field or preceded by a space file numerically (Vol 999 before
Vol 1000), except when the number includes punctuation (Vol 1,000 before Vol 999).
Numbers directly preceded by text file alphabetically (B12 files before B2).
Numbers alone or numbers that come first in the field (4 units) can contribute that value
to a calculation. Numbers that are preceded by other text (Sold 4 units) cannot
contribute a value to a calculation.
Negative numbers (-50) are treated as positive values for filing purposes. If you want
negative numbers sorted before positive numbers, use a Number field.
To make numbers in a Text field file alphabetically, use Special Filing. This is important
for fields that will hold telephone numbers, as described at the beginning of this topic.
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Number Fields
Use a Number field to hold digits that are intended to be used in calculations, such as quantities
and amounts (for example, currency). Select the Type and Indexing tab on the Edit Fields dialog
box to specify Number as the field type (choose Maintain>Edit Textbase Structure>Edit
Fields).
You can perform calculations on Number fields, such as adding invoice amounts, either by
using forms or by referencing a Number field in a formula for a Computed field.
You can use a form to change the appearance of the numbers (for example, to make the
number 35 appear as $35.00 or 35,00 F depending on the currency and number formats
selected on the Microsoft Windows Control Panel.
Number fields are the only field type that can accommodate negative numbers for sorting and
indexing purposes as well as calculations.
Entries in a Number field are always sorted numerically. For example, Sold 2 models sorts
before Sold 12 models.
You can prohibit non-numeric information in a Number field by making it strict (select the
Require Strictly Correct Type check box on the Type and Indexing tab). Select the Allow
Trailing Text check box to allow text to follow the number, while still having the number
interpreted correctly.
A non-strict Number field will accept any information that you type into it, even if the information
is not a number. For example, you can type Joe Smith in a Number field. However, the entry will
not be sorted numerically (it will be sorted at the end) and will have a value of zero in any
calculations or computations.
Tip! Do not use a Number field for telephone numbers or other information that is not intended
to be calculated. Numbers that are not values should be stored in a Text field with alphabetic
filing (clear the Numbers File Numerically check box in the Special Filing Options group on the
Type and Indexing tab).

Date Fields
Use a Date field to hold dates. Select the Type and Indexing tab on the Edit Fields dialog box to
specify Date as the field type (choose Maintain>Edit Textbase Structure>Edit Fields).
To prohibit non-date information, select the Require Strictly Correct Type check box on the
Type and Indexing tab. This is called making the field strict. If you do not make the field strict,
users will be able to type non-date information in the field (for example, Fred), but that entry
cannot be sorted chronologically or used in a calculation.
Characteristics of Date Fields
Dates are sorted chronologically, which can be useful in reports. For example, you can sort
invoices by date, in chronological or reverse-chronological order. You can perform calculations
on a Date field by using forms or by referencing a Date field in a formula for a Computed field.
For example, you can add 10 days to the date.
Editing Information in Date Fields
During editing, you can enter full or partial dates in almost any recognizable format. To ensure
accurate interpretation of dates, separate date components with spaces, punctuation, or both.
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To ensure accurate chronological sorting, an entry cannot include more than one day, month, or
year.
Here are some acceptable date formats:
10-2-12; 10/02/12; Oct 2, 2012; October 2, 12; October 2012; 20121002;
2012

Here are some formats that are not acceptable:
May/June 2012 (only one month permitted); 1975-1977 (only one year
permitted); June sixth, 2012 (day must be numeric); 10-40-12 (not a valid
date)

You can include the letter c before a year to indicate "copyright" and the date will be sorted
correctly. The letter c is the only character that can precede a date and still have the date file
correctly. The letter c must immediately precede the year (for example, c1998), and no month or
day is permitted.
You can include AD or BC after a year alone and the date will be sorted correctly (267 BC).
Case and punctuation do not matter. If you omit the letters, the date is interpreted as A.D. (for
example, 267 means 267 AD). BC and AD are accepted when used with years only, not dates
including months or days. Therefore, a date such as January 1200 BC will not be accepted as a
strict date unless you allow trailing text. If a date includes a month or day, the letters BC are
treated as trailing text, not as part of the date.
When you are editing records, we strongly recommend that you enter years using four digits
instead of just two, to avoid any ambiguity. You can run the Setup program or edit DBTEXT.INI
directly to specify how two-digit years should be interpreted across century boundaries.
DB/TextWorks recognizes month and day names in the language(s) specified in the
DBTEXT.INI file. If more than one set of month or day names is specified, all of them will be
recognized in a date, but only the first set is used for dates generated by the software (for
example, when using Edit>Insert>Current Date) or reformatted in a report.
Date formats are interpreted using the Windows Control Panel settings in effect when the date
is indexed. For example, 12-6-02 may be interpreted as month-day-year or day-month-year.
Dates in Non-U.S. Formats
The Date Format selected in the Regional settings of the Windows Control Panel at the time the
date is indexed determines how date formats are interpreted. For example, if a day-month-year
format is selected, DB/TextWorks interprets dates such as 12-6-10 as day-month-year instead
of month-day-year. Month and day names are interpreted based on configuration information
supplied during the DB/TextWorks installation process.
Changing How Dates Appear
You can design forms to make all dates appear in a consistent format when displayed or
printed, regardless of how they were entered. For example, you can make all dates appear with
the month spelled out. Date fields are sorted chronologically, regardless of how they are
displayed in the form. For example, May 2011 and 5/11 come before December 2011.
Searching for Dates
DB/TextWorks is flexible when searching for dates. The format you use in a query can differ
from the format stored in the textbase, and retrieved dates may include day names or trailing
text. For example, a search for June 2012 finds June '12, June 3, 2012, and JUN-2012.
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Automatic Number Fields
Use an Automatic Number field if you want a unique number generated by the software to be
assigned to each record, starting with a value that you specify. Select the Type and Indexing tab
on the Edit Fields dialog box to specify Automatic Number as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
Automatic Number fields can provide a way of identifying records, by making sure that each one
has a unique number. Automatic Number fields are Term indexed by default.
Automatic Number fields are maintained by the software. You cannot change Automatic
Number values in existing records and you cannot dictate what the value will be in a new
record.
The unique number is assigned to the record when it is created, not when it is indexed. Gaps
created by deletions and similar situations, are not filled in. For example, if records are
numbered 1, 2, 3, 4, and you delete record 3, that number will not be reassigned. The next
number assigned will be 5.
To specify how automatic numbers appear, use the options on the Automatic Number Definition
tab. Note that this tab appears on the Edit Fields dialog box when you select Automatic
Number from the Field Type drop-down list.
Next Number. The value displayed indicates the number that will be assigned to the
next record added to the textbase. Normally, you start with 1. Each time you add or
import records the software assigns each incoming record a unique number, starting
with the number shown, and increments the number in the Next Number box
accordingly.
Note: The value in the Next Number box is not an accurate indicator of how many
records are in the textbase, because there may be numbering gaps due to deletions and
other situations.
Increment By. Specify how much to increment each value. For example, if your starting
value is 1 and you increment by 1, records will be numbered 1, 2, 3, 4. If you increment
by 2, records will be numbered 1, 3, 5, 7.
Include Thousand Separators. Select this check box if you want the thousand
separator to be included in automatic numbers above 999. For example, a number might
be shown as 1,000 or 1000 depending on whether this option is selected. The Number
Format in the Regional settings of the Windows Control Panel determines which
character is used for the thousand separator (for example, a comma or period).
Do not select this check box if this textbase will be used by people with different regional
settings, because different countries may use different characters to represent
separators.

Automatic Date Fields
Use an Automatic Date field if you want DB/TextWorks to place the current date or current date
and time in this field when you create and/or modify the record. Select the Type and Indexing
tab on the Edit Fields dialog box to specify Automatic Date as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
By using an Automatic Date field, you can identify when each record was created or edited,
without requiring the user to type the current date or time information.
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The date, or date and time, are assigned to the record when it is saved, not when it is indexed.
This fact is important to note if you are using Deferred indexing, because the date and time will
not reflect when the updates were posted.
Automatic Date fields are maintained by the software. You cannot change Automatic values in
existing records and you cannot dictate what the value will be in a new record.
To specify how and when automatic dates are saved, use the options on the Automatic Date
Definition tab. Note that this tab appears on the Edit Fields dialog box when you select
Automatic Date from the Field Type drop-down list.
1. Specify when the field will be updated, by selecting an option button in the Update Entry
group:
When Record is Created. The date, or date and time, will be inserted when the
record is created, and will not be changed again. Use this option if you want to
know when the record was created.
Note: If records already exist in a textbase and you add an Automatic Date field
with this option button selected, when you modify an existing record with an empty
Automatic Date field, that field will be populated when you save the record. The
record does not have to be new for the new field to be populated, just empty.
When Record is Created or Modified. Use this option if you want to know when
the record was last saved or edited. The date, or date and time, will be updated
whenever the record is saved. Note that the record does not actually have to be
modified, just saved.
2. Specify the date components that will appear in the field, by selecting an option button in
the Automatic Date Components group:
Both Date and Time. The date and time that the record was created or modified
will be inserted.
Date Only. The date that the record was created or modified will be inserted.
3. Specify the format of the date by selecting an option button in the Date Format group:
Short Date Format. For example, 4/18/2003.
Long Date Format. For example, Friday, April 18, 2003.
Long Date Format without Day. For example, April 18, 2003.
Note: The actual format is governed by the Regional settings of the Windows Control
Panel.
4. If the field will include the time, specify the format of the time by selecting an option
button in the Time Format group:
24 Hour Time
12 Hour Time with AM or PM

Automatic ID Fields
Use an Automatic ID field if you want if you want an editable, automatically generated number
with optional surrounding text and/or punctuation inserted in the field. Select the Type and
Indexing tab on the Edit Fields dialog box to specify Automatic ID as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
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An Automatic ID field contains editable values generated by the software. The values can
include text, numbers, punctuation, spaces, and leading zeros. This type of field is commonly
used in combination with unique validation to generate a unique alphanumeric ID for each
record.
When you open a textbase, the software automatically extracts the highest value in the
Automatic ID field (including case and punctuation). The first time you create a new record,
DB/TextWorks automatically increments this value (by 1) and fills in the Automatic ID box. You
can edit this value if you like. For each new record you create thereafter during a session, the
software will increment the last value saved. So you could, for example, have one user creating
new records with values in the format LW-0001 and another in the format DH-0001.
In the above, "during a session" means until you close the textbase. The "last-saved" value
during a session is stored in your computer's memory (not anywhere "permanent"). When you
close the textbase (or close DB/TextWorks) and re-open it, the software reads the starting value
from the end of the index for the Automatic ID field.

Automatic IDs: Creating New Records in the Edit Window
The first time you choose Record>New Record after opening a textbase, DB/TextWorks
increments the last value in the index by 1. Thereafter, the software increments the last-saved
value by 1. You can accept or change the value. For example, if the number 050 is generated
and you change it to 051, the next generated value will be 052. If you enter alphabetic
characters only, a value will be appended. For example, ABC is incremented as ABC1, ABC2,
and so forth. If you enter a combination of numbers and letters, only the number is incremented.
For example, DJH-003 becomes DJH-004, 1997-Oct becomes 1998-Oct, and G50A becomes
G51A.
The Edit form must include a box for the Automatic ID field. If the Edit form does not include a
box for the Automatic ID field, an ID will not be generated for new records.
To ensure that unique values are assigned, use Unique Entries Only validation.

Automatic IDs: Editing Records in the Edit Window
When you open an existing record in the Edit window, DB/TextWorks does not touch the
Automatic ID value, unless it is empty. If you edit an Automatic ID in an existing record, the
software does not do anything unless that field has unique validation and the value already
exists. In such a case, DB/TextWorks auto-increments the ID until it finds a unique value.

Automatic IDs: Adding Records Outside of the Edit Window
The following information applies to records that are added to a textbase during an import, by
scripts, or via a Web browser with WebPublisher PRO: If an incoming record does not include
an Automatic ID value, DB/TextWorks does not generate one for a new record. If an incoming
record includes an Automatic ID value, the software handles it as if you had typed the value in
the Edit window: it either accepts the value or auto-increments it until a unique value is found.

Automatic IDs: Validation
Single Entry Only validation is applied and cannot be turned off. You can add other validation
as needed.
If you select Unique Entries Only validation, DB/TextWorks increments the last-saved value
until a unique key is found. Therefore, a user who does not recall where a series left off can type
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a low value, and the software will substitute the next available value. For example, if you are
using a numeric series (001, 002, 003 …), and you have forgotten whether the last record was
098 or 099, type any lower value and the software will assign the next unique number in the
series. The auto-increment happens when you move the cursor to another field, or press F9, or
save the record.
If the field does not have Unique Entries Only validation, the software increments the last
number by 1, even if that entry has already been used. This can result in duplicate entries
throughout the textbase.

Automatic IDs: Deferred Indexing
Post deferred updates frequently if you are using Automatic ID fields and Deferred indexing.
DB/TextWorks cannot check uniqueness of new entries against unposted updates, so duplicate
values may be assigned. These duplicates will be detected and rejected when you post deferred
updates (assuming the Automatic ID field has Unique Entries Only validation). You can edit
the rejected deferred records to give them unique values (choose Maintain>Deferred
Updates>Get Deferred Updates, edit the record, then enter a low value in the Automatic ID
field and it will be auto-incremented), then post updates again.

Computed Number Fields
Use a Computed Number field to construct a number based on information in another field in
the current record. Select the Type and Indexing tab on the Edit Fields dialog box to specify
Computed Number as the field type (choose Maintain>Edit Textbase Structure>Edit Fields).
Use the Computed Number Definition tab to specify the formula you want used to compute the
number, as well as the formatting for it. A formula for a Computed Number field can include field
names (from the primary textbase only) and arithmetic operations, and must yield a number. For
example, this formula subtracts the contents of two fields:
ordered - shipped

The result (a number) will appear in the Computed Number field:
13

You cannot directly edit information in a Computed Number field. Computed Number fields are
calculated by DB/TextWorks when the record is saved or when information referenced in the
formula changes. Use quotation marks around field names that include spaces ("quantity
ordered" - "quantity shipped") or that are numbers (for example, "250"). A Computed Number
field will be left blank if any field used in the calculation formula is blank.
To specify a formula for a Computed Number field
1. Select the Computed Number Definition tab on the Edit Fields dialog box.
2. Type a formula in the Formula box, or click the Enlarge button to open a larger,
resizable text editor dialog box instead. When you click OK on the text editor dialog box,
your text appears in the Formula box on the Computed Number Definition tab.
3. Specify the options you want, as applicable, in the Number Format group. See examples
below.
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Examples for Computed Number Fields
Computes this

This formula
quantity * price * 1.05

The total cost of an order, including sales tax (at a 5% rate).

"completion date" - "starting
date"

The difference between the contents of two Date fields to
determine the number of days required to complete a project.
Note that the result is a number, not a date. Use quotation
marks around field names that include spaces.

FCOUNT ("sales person")

The number of entries in the Sales Person field in the current
record.

FMIN (price)

The lowest value in the Price field in the current record.

FTOTAL (expenses)

The sum of all entries in the Expenses field in the current
record.

FAVG (cost)

The average of all entries in the Cost field in the current
record.

Formula Components for Computed Number Fields
A Computed Number formula can include one or more of the following components:
Component

Description

Fields

Any combination of fields from the primary textbase, containing a number or
date value. For example, you can calculate the difference between two date
fields to yield a number of days. If a field contains multiple entries, only the first
entry is used (except in the case of Field Functions).
If a field name is a number or includes spaces, surround it with single or
double quotation marks ('2' or "date of birth").

Numbers

Any whole or fractional number, such as 3 or 1.5.

Field Functions FCOUNT, FMIN, FMAX, FTOTAL, and FAVG perform a calculation across
entries in a specified field. For example, FMIN (price) finds the lowest value in
the Price field.
Note: A Computed Number field will be left blank if it references a field that is empty. (The
exception is FCOUNT on an empty field, which returns a value of 0.) If an entry in a referenced
field does not start with a number, zero will be used for that value in the computation.

Arithmetic Operations for Computed Number Fields
You can use the following operators to connect components in a Computed Number formula:
Operator Usage
+

Addition

-

Subtraction or negative numbers

*

Multiplication

/

Division

()

Surround field names or expressions that follow functions, or for grouping items
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Calculations are performed using the standard order of arithmetic operations. Operations
enclosed in parentheses are performed first. Multiplication (*) and division (/) are performed
second. Addition (+) and subtraction (-) are performed last. Among equally ranked operations
(such as multiplication and division), operations are performed from left to right. To avoid
ambiguity, use parentheses to ensure that the calculation produces the desired results. For
example:
(price - cost) / (number * 12)

Settings for Computed Number Fields
Once you have specified a formula on the Computer Number Definition tab, select settings to
indicate how the computed number should appear.
Number Format. Specify whether numbers should appear as currency or numbers. If
you select Currency, numbers will be formatted using the currency format in the
Regional settings of the Windows Control Panel. If you select Number, specify the
settings described below.
Number of Decimal Places. Type the number of decimal places you want displayed.
Formatting. Select Include Thousand Separators if you want the thousand separator
to be included in computed numbers above 999. Select Include Leading Zero in
Decimal if you want decimals to include a leading zero (for example, 0.25 instead of
.25). The Number Format in the Regional settings of the Windows Control Panel
determines which characters are used for the thousand separator and decimal
separator.
Show Negative Numbers With. Indicate how negative numbers should be represented.

Computed Date Fields
Use a Computed Date field to construct a date based on information in another field in the
current record. Select the Type and Indexing tab on the Edit Fields dialog box to specify
Computed Date as the field type (choose Maintain>Edit Textbase Structure>Edit Fields).
Use the Computed Date Definition tab to specify the formula you want used to compute the
date, as well as the formatting for it. A formula for a Computed Date field can include field
names (from the primary textbase only) and arithmetic operations, and must yield a date. For
example, this formula adds 90 days to the date in the Invoiced field:
invoiced + 90

The result (a date) will appear in the Computed Date field:
12/15/2002

You cannot directly edit information in a Computed Date field. Computed Date fields are
calculated by the software when the record is saved, or information referenced in the formula
changes. A Computed Date field will be left blank if any field used in the calculation formula is
blank or a Date field included in the formula does not contain a date.
When the software performs a computation, it ignores entries that do not start with a date. For
example, if the Invoiced field contains the entry On or about 8-2-98, the computation cannot be
performed, and the Computed Date field is left blank. Numbers in Date fields are interpreted as
dates, which can cause unexpected results. Incomplete dates (such as 2001) may also yield
unexpected results.

Inmagic DB/TextWorks v13 Printed Help

53

Creating and Editing Textbases
To specify a formula for a Computed Date field
1. Select the Computed Date Definition tab on the Edit Fields dialog box.
2. Type a formula in the Formula box, or click the Enlarge button to open a larger,
resizable text editor dialog box instead. When you click OK on the text editor dialog box,
your text appears in the Formula box on the Computed Date Definition tab.
3. Specify the options you want, as applicable, in the Date Format group.
Examples for Computed Date Fields
Computes this

This formula
Due - 14

The date two weeks before the scheduled deadline.

"check out date" + "borrowing
period"

The sum of the values in a Date field (check out date) and
a Number field (borrowing period) to yield a date. Note
the use of quotation marks for field names that include
spaces.

FMIN (published)

The earliest date in the Published field in the current
record.

FMAX ('ship date') + 3

The date 3 days after the most recent ship date in the
current record.

FMAX ("contact date") + 30

When Telesales should next contact a customer by
adding 30 days to the most recent contact date.

Formula Components for Computed Date Fields
A formula for a Computed Date field can include one or more of the following components.
Component
Fields

Description
Any combination of fields from the primary textbase, containing a number or
date. If a field name includes spaces or is a number, surround it with quotation
marks ('2' or "Ship Date"). If any of the fields in a formula contain multiple
entries, only the first entry is used, unless you use FMIN or FMAX to request
the earliest or most recent date in the field. A computation uses information
from the specified field only from the current record. A formula can include
Text or Number fields, as long as the result of the entire formula yields a date.
If a field in the formula is a Date, Computed Date, or Automatic Date field, the
software looks for a date at the beginning of the field and uses that value in the
computation. If no valid date is found, the calculation cannot be evaluated. For
any other type of field used in a formula, the software looks for a number at the
beginning of the field. If none is found, zero is used in the computation.

Numbers

Any number of days, such as 7 or 14 or 365.

Field
Functions:
FMIN and
FMAX

FMIN and FMAX are intended to be used with fields that contain multiple
entries. Follow FMIN or FMAX with a field name in parentheses. For example,
FMIN (sold) finds the earliest date in the Sold field in the current record. For
the specified field in the current record, FMIN finds the earliest date and FMAX
finds the most recent date.
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Arithmetic Operations for Computed Date Fields
You can use the following arithmetic operators in a Computed Date field.
Operator

Usage

+

Addition

-

Subtraction or negative numbers

()

Surround field names that follow functions

Image Fields
Use an Image field if one or more records will have associated images. Select the Type and
Indexing tab on the Edit Fields dialog box to specify Image as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
When you add records to the textbase, you can include the name of one or more images in the
Image field. A textbase can include more than one Image field.
Image fields are Term indexed by default, so you can search for image names. If you do not
plan to search the field, you can clear the Term Indexed check box on the Type and Indexing
tab. You cannot apply validation to an Image field.
You can view images when you display or edit the record, and you can print images by selecting
File>Print when the Images or Thumbnail window has focus.
An Image field can contain multiple entries. Each entry can reference one or more images. For
example, the two field entries below reference four images (DRAG.001, DRAG.002, DRAG.003,
ROADSTR1.BMP):
c:\model\drag.001 3
c:\model\roadstr1.bmp

You can see the images by choosing Display>Show Record Images then using the image
options to zoom, rotate, display multiple images in a thumbnail view, and so forth.
Images can be stored on external storage devices, such as CD-ROMs or DVDs or any local or
network drives. You can specify the drive letter(s) where images are stored by choosing
Tools>Options>Imaging. You may want to avoid including the drive letter as part of the image
name in the Image field, if the images are on a removable disk or a mapped drive.
If you are not storing images on external storage devices, we recommend you store images in
the same folder as the textbase. By doing this, you can freely move the textbase and its
associated images without having to modify records. This is because the software looks for
image files in the textbase folder if no path is specified.
However, if necessary, you can store images in a different location than the textbase folder. If
you do this, you must specify the full or partial path as part of the image name in a record.
Specify a full folder path, starting with a backslash (\MEMOS\LTR.JPG). If you omit the
backslash at the beginning of the path, the software looks in the subfolder of the current folder.
If you do not specify a path in the image name (LTR.JPG), the software looks for the image in
the textbase folder or the current folder on the drive(s) listed in the Imaging options.
Note: You can also include images on forms (for example, a logo) by using a picture box.

Inmagic DB/TextWorks v13 Printed Help

55

Creating and Editing Textbases

Link Fields
Use a Link field in a textbase if you want to access information from more than one textbase at
the same time. Select the Type and Indexing tab on the Edit Fields dialog box to specify Link as
the field type (choose Maintain>Edit Textbase Structure>Edit Fields).
Every Link field has one associated field in a secondary textbase. When information in the Link
field matches information in the associated field, a link is made, and you have access to
information in the secondary textbase. For more information, read about linking textbases.
Note that more than one Link field can link to the same textbase, with the same associated field
or different ones. There is no limit to the number of Link fields, except that you cannot define
links to more than four different secondary textbases.
To define a Link field
1. Open the primary textbase.
2. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
3. Click the Edit Fields button to open the Edit Fields dialog box.
4. Add a field or select an existing field and select Link from the Field Type drop-down list
on the Type and Indexing tab.
5. The Link Definition tab automatically appears. Click the Specify Textbase button.
Note: If you want to edit an existing Link field, select it from the Field Name list, then
select the Link Definition tab. The tab will only appear when the Link field is selected.
6. On the Link to Inmagic DB/TextWorks Textbase dialog box, select the secondary
textbase to which you want to link and click Open.
Note: There may not be room on the Link Definition tab to show the full path to the
textbase. Use your mouse pointer to hover over the textbase name to see the full path
appear in balloon text.
7. On the Link Definition tab, select the field in the secondary textbase that contains the
same information as the Link field in the primary textbase. The field you select is called
the associated field. For best results, the associated field should be unique and nonrepeating or should be an Automatic Number field.
8. [Optional] Select the Type and Indexing tab and specify the options you want:
Require Strictly Correct Type. Select this check box if you want the Link field to accept
information only if it matches existing information in the secondary textbase. Making a
Link field strict prevents people from typing entries that do not have matching records
already in the secondary textbase. If you clear this check box, someone can create the
matching record in the secondary textbase at a later time.
Note that when you edit a record, you can press F3 in the Link field to browse entries
from the Term index of the associated field in the secondary textbase. Pressing F3 in
this situation essentially acts like a validation list for the Link field, and is especially
useful when the Link field is strict.
Note: You cannot select the Allow Trailing Text check box. There is no such thing as
trailing text in a Link field.
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Indexing Information. A Link field is automatically Term indexed. You cannot change
this setting, because the Term indexes of the Link and associated fields are used to
achieve the match. You can select the Word Indexed check box if you want to be able
to do word, phrase, and proximity searching in a Link field.
Use Stop Word List. If the Link field is Word indexed, you can select or clear this check
box. You cannot change any of the Special Filing options of the Term index, because a
Link field "borrows" the filing rules of its associated field to ensure matching consistency.
Validation. The software automatically assigns Single Entry Only validation to Link
fields to ensure that they contain only one entry. The only additional validation you can
apply is Field Entry Required and/or Unique Entries Only.
9. In the Edit Fields dialog box, click Add if you are adding a field or click Change if you
are editing a field.
10. Click the Finish button to return to the Edit Textbase Structure dialog box.
11. Click OK on the Edit Textbase Structure dialog box, then click OK to dismiss the
confirmation message that appears.

Code Fields
Use a Code field if you want punctuation and case to be considered when searching and
sorting. Select the Type and Indexing tab on the Edit Fields dialog box to specify Code as the
field type (choose Maintain>Edit Textbase Structure>Edit Fields).
A Code field treats case and punctuation as significant for filing purposes (indexing and sorting).
For more information, see Searching Code and UDC Fields.
Code fields can be useful when you are working with information in which case and punctuation
are important (for example, chemical names, scientific formulas, and e-mail addresses). Code
fields are also useful for URLs, when using DB/Text WebPublisher to publish textbases on the
Web.
You can connect a thesaurus textbase to a Code field and optionally use the thesaurus as a
validation list.
A Code field is Term indexed by default, but you cannot specify Special Filing options because
the software determines the appropriate settings. Spaces sort first, then punctuation. Numbers
come before letters and are sorted alphabetically, not numerically (for example, the numbers 1,
2, and 15 would be sorted to appear 1, 15, 2). Upper case letters sort before lower, and case
variations are retained in the index. Lowercase characters file immediately after their uppercase
equivalents (A, a, B). Leading articles are never ignored.
You can Word index a Code field. However, only case, not punctuation, is significant in the
Word index. Punctuation is retained in the Term index only.
Stop words are not ignored when searching a Code field.
The software sorts Term entries in a Code field in the following ways. Notice that the entire list
below is sorted as it would be in a Code field.
Term Index

Explanation

0 Rn

Spaces sort first.

0.Rn

Punctuation sorts next.
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1
15
2

Numbers come before letters and are sorted alphabetically, not
numerically.

Pi
pi

Uppercase letters sort before their lowercase equivalents and case
variations are retained in the index.

Ra (226)
Sb (121-75)

Punctuation is retained in the Term index but not in the Word index.

The Periodic Table of
Elements

Leading articles are never ignored.

UDC Fields
Use a UDC field if you want to sort fields according to the Universal Decimal Classification
System, an international numerical system used for classifying and retrieving documents. Select
the Type and Indexing tab on the Edit Fields dialog box to specify UDC as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
DB/TextWorks sorts Term entries in a UDC field in the order shown in the list below. You can
type any of these characters in a UDC field. You can also include other information in a UDC
field and still retain the proper filing, as long as the information comes after the UDC code and is
preceded by a space. Information after the space is not interpreted as part of the UDC code. For
more information, see Searching Code and UDC Fields.
A UDC field is Term indexed by default. A UDC field retains punctuation in a Term index. The
punctuation shown below is significant when you search a UDC field. Other punctuation is
ignored and case is ignored.
UDC Sort Order
+
/
:
[]
::
=
(0...)
(1/9)
(=...)
"..."
*
A/Z
.00
-0/-9
.0
,
.1/.9
0/9
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Note: DB/TextWorks can also sort information for other classification systems, such as Library
of Congress and Dewey Decimal. Unlike UDC, those systems do not require a separate field
type. Instead, use a Text field and clear the Special Filing option Ignore Leading Articles. If
you retain a Word index, also clear the Use Stop Word List option.

Access Control Fields
Use an Access Control field to restrict access to particular records. Select the Type and
Indexing tab on the Edit Fields dialog box to specify Access Control as the field type (choose
Maintain>Edit Textbase Structure>Edit Fields).
The Access Control field type lets you assign records to a class. Then, using passwords, each
class can have the following record-level security settings specified for it:
Full Access. Users have full access to records. Records can be viewed, edited, deleted,
searched, printed, imported, and exported.
Read-Only. Records can be viewed, searched, printed, and exported. They cannot be
edited, deleted, or imported.
Hidden. Records cannot be seen, making them invisible to users.
To specify record-level security, you designate a field in your textbase as an Access Control
field, then set up "record classes" by adding them to a special validation list for the Access
Control field.
Once that is done, you can "classify" the records to which you want to restrict access by
populating the Access Control field in those records with one of the record classes you set up.
You can also set up a series of Field Access passwords and/or enable the Silent password to
grant appropriate permissions for each class of records.
For example, a library with multiple branches can give each branch access to the textbase used
for cataloging, but restrict access to particular records within it. That means you can allow all
branches to view all of the records, but only allow a branch to be able to alter its own records,
not those of other branches.
Security settings are specified on the Record Level Security Settings dialog box. To access this
dialog box, click the Record Level Security Settings button on the applicable password tab
(Field Access Passwords tab or Silent Password tab) of the Textbase Passwords dialog box
(choose Maintain>Edit Textbase Structure>Passwords).
There are several attributes associated with Access Control fields:
Only one Access Control field is allowed per textbase.
Only single entries are accepted.
Access Control fields are always Term indexed.
Overriding and user-updates are not allowed for the special validation list.
The only way to add additional record classes is to edit the textbase structure (choose
Maintain>Edit Textbase Structure), as the special validation list for the Access Control
field is not available through Maintain>Edit Lists>Validation Lists. Note that when you
edit the textbase structure, other users will not be able to access the textbase.
If the Access Control field was modified using Deferred indexing to make a record more
secure, you can still see and edit the record if you do not have the Show deferred
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changes in reports and display check box selected (choose
Tools>Options>General) when you do the search.
Note: When users whose passwords restrict them from seeing particular records use the Query
Choices Browser (F3) to paste items for which to search, an item in the list may show more hits
than the number of records actually retrieved. One reason for this is that some of the records
are in a record class marked Hidden for that password, and thus are not retrieved for that user.

Validation and Substitution
Specifying Validation
Validation rules determine what information will be allowed in a field during data entry, import,
and batch modify operations to ensure consistency and reduce typographical errors. If
information does not meet the validation criteria, the software informs the user and does not
permit the change to be made (unless content validation overrides are allowed).
Applying validation is optional. You can specify validation rules for each field in a textbase
except Automatic Number, Automatic Date, Computed Number, Computed Date, and Image
field types. Note that some validation is implicit if the field type is strict.
You can specify validation when you create the textbase, or later by editing the textbase
structure. If you change validation in a textbase that contains records, the changes are not
applied retroactively to existing records.
To apply validation to a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. Select a field from the Field Name list, then select the Validation tab.
4. Specify the Entry Validation options you want:
Field Entry Required. Select this check box to indicate that this field cannot be left blank
when information is added to the textbase. When adding or editing a record, the user will
not be able to save the record until information is entered in this field. During import, the
record will be rejected. Some typical uses include fields that will hold purchase order
numbers, part numbers, library classification numbers, or Bates numbers for documents.
Note: A field that has this option selected is called a Required field. Requiring a field entry
can affect the ability to add records to a textbase. To add a record, you must have full
write access to all fields that require a field entry. The current password determines
whether you have write access. Also, the form that you use when adding records cannot
omit any fields that require a field entry.
Unique Entries Only. Select this check box to specify that each entry in the field must be
different from any other entries in the field in the other records in the textbase. For
example, you could make the Product field unique to ensure that you have only one
record per product. To determine whether an entry is unique, the software checks the
Term index for the field. Therefore, you can select this option only for fields that have a
Term index. A field to which you plan to link should be specified as Unique Entries Only
(or be an Automatic Number field). If it is not, a link will retrieve the first matching record
that is found.
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Note: To determine uniqueness, the software checks the field's Term index to see if the
term has been used before. DB/TextWorks cannot detect if a term has been used in
deferred updates (if any). In this case, uniqueness is verified when deferred updates are
posted, by checking the deferred updates against the Term index.
Single Entry Only. Select this check box to specify that this field is non-repeating (cannot
hold multiple entries). For example, you might want a field called Primary Contact to
accept only one name. The software prevents users from adding more than one entry or
rejects the record during an import.
Note: Link fields, Automatic ID fields, and Access Control fields are set to Single Entry
Only and cannot be changed.
5. Specify the Content Validation options that you want:
No Content Validation. Select this option button to specify that information will not be
validated during data entry, import, or batch modify operations. Anything will be allowed in
the field, unless it is a strict Date, Number, or Link field.
Use Range and/or Mask. Select this option button if you want to specify range
restrictions (for example, minimum 1, maximum 10) and/or a mask (for example, ###
requires three digits). When you select this check box, the Range and Mask group on the
Validation tab is enabled for you to enter maximum, minimum, and mask information.
Use Validation List. Select this option button to specify that the field entries must appear
in the validation list. When you select this option button, the Edit List button is enabled so
you can create a list of entries allowed in a field.
Use Thesaurus as Validation List. Select this option button to specify that the thesaurus
connected to the selected field should be used as the validation list. This option is
enabled after you specify a new or existing thesaurus textbase on the Text Options tab.
6. [Optional] If you want to allow entries into the field that do not match the validation list,
or which violate range and/or mask validation, select the User May Override Content
Validation check box. Users will be prompted at data entry time if they type an entry
that does not match the validation. At that time, they can click Accept to allow the entry
into the field even though it violates validation, or click Cancel to return to the record
and change the entry to match the validation.
7. [Optional] If you want to allow entries into the field that do not match the validation list
or which violate range and/or mask validation, and want those entries to be added
automatically to the validation list, select the User May Update Validation List with
Override Value check box (after you have already selected the User May Override
Content Validation check box). Users will be prompted at data entry time if they type
an entry that does not match the validation. At that time, they can click Accept &
Update List to allow the entry into the field even though it violates validation and add
the entry to the validation list, or click Cancel to return to the record and change the
entry to match the validation.
Note: If you specified a thesaurus as a validation list, the option to update the
validation list with the override value is not available.
8. Click the Change button.
Note: You can also add a new field, specify a field type that allows validation, and then specify
validation options on the Validation tab.
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Range and Mask
Use the Range and Mask group on the Validation tab of the Edit Fields dialog box to specify
range and/or mask Content Validation.
Type the appropriate values in the Minimum, Maximum, and/or Mask boxes.

Range
Type the minimum and/or maximum values allowed in the field.
Examples:
For a Number field, if you enter 1 in the Minimum box and 100 in the Maximum box, the
field will accept values in that range only (inclusive).
For a Text field, if you enter L in the Minimum box and ZZZ in the Maximum box, that
field will accept items starting with L through Z. Note that using Z as the maximum
instead of ZZZ rejects Zebra.
For a Date field, if you enter 1/1/2003 in the Minimum box and 1/31/2003 in the
Maximum box, that field will accept dates in that range (inclusive). You can type dates in
any recognizable format.

Masks
A mask is a pattern that determines what information will be accepted in a field. You can include
the characters shown below, plus any keyboard characters. Spaces and other characters
embedded in a mask will be required during data entry or import. Information that does not
match the mask will be rejected. Case is automatically corrected during data entry or import to
match the validation. For example, the mask M*. !* will change mr. jones to Mr. Jones.
!

Uppercase letter

^

Lowercase letter

#

Digit (0 through 9)

?

Any single keyboard or extended character, including spaces. Cannot omit.

*

Any series of zero or more characters, including spaces. Can omit.

To include a mask character as a literal character, precede it with a backslash (\). For example,
if the field entry must begin with a question mark, use \?* as the mask. To include the backslash
character as part of the mask, use two backslashes (\\).
Examples of Masks
Ace* accepts Ace alone or followed by any number of characters (Ace Corp., Ace 123, Acetate).
!* requires a capital letter followed by any number of characters or words.
! requires a capital letter only. It cannot be followed by any other characters.
###-##-#### requires a number such as 187-33-2627 (dashes are required).
(###)###-#### requires the punctuation and space shown and digits for each # symbol, such as
(617) 123-4567.
##/##/#### requires a numeric date with a four-digit year, such as 08/26/2000 (slashes and
leading zero are required).
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^^ ???? requires two lowercase letters, followed by a space, followed by any four characters.
##\# requires any two digits followed by a # symbol, such as 15# or 38#. The backslash
preceding a mask character tells the software to interpret the mask character literally.

Allowing Users to Override Content Validation
If a field has range and/or mask validation or uses a validation list, you can allow users to
override content validation during data entry and import. Select one or both of the following
check boxes, located on the Validation tab of the Edit Fields dialog box:
User May Override Content Validation. If you select this check box, the field will
accept entries that are not in the validation list, or which violate range and/or mask
validation, upon confirmation by the user.
User May Update Validation List with Override Value. If you select this check box,
the field will accept entries that are not in the validation list, but the new entry will be
added automatically to the validation list. You can select this box only if the field uses a
validation list (other than a thesaurus used as a validation list) and the User May
Override Content Validation check box is selected. This provides a convenient way of
keeping a list up to date. However, it introduces the risk of allowing unwanted items into
a list.
Clearing this check box introduces a different risk—that users might accept an entry into
the field, but the list will not be updated with the entry. As a result, the field could end up
containing items that are not in the validation list.
Note that if you specified a thesaurus as a validation list, then the option to update the
validation list with the override value is not possible.
Note: Field Access or Silent passwords may prohibit users from changing validation lists,
even if this option is checked.

Edit Lists>Substitution Lists command (Maintain menu)
A substitution list is a list of short codes that you type in place of longer words or phrases to
reduce keystrokes and typographical errors when editing records. You can create a different
substitution list for each Text field in a textbase. For example, here is a substitution list for
countries:
can:Canada
mex:Mexico
usa:United States of America
Spaces at the beginning or end of a code or substitution are removed automatically. Spaces
within codes or substitutions remain. The code is not case-sensitive, so capitalization does not
matter. For example, the user can type either dc or DC to get the same substitution, District of
Columbia. The substitution appears exactly as it is specified in the list.
Substitution lists are used during data entry and import:
Data entry. When editing a record, type a code (for example, can). When you move off
the entry, the substitution (Canada) occurs.
During import. If the import file has the item can in a field that has this substitution list
applied, the word Canada will be substituted.
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Note that substitution only works when the entire field entry matches the code. For example, if
you type only can in the field, the software substitutes Canada when you press the Tab key to
move out of the field. However, it will not substitute can if you type Manitoba, can because the
entry (Manitoba, can) does not match the code (can).
During data entry, you can choose Edit>Browse Choices or press F3 to see the substitution
list (if any) for the current field. You can paste entries from the list into the field, if desired.
If you type an item that is not in the substitution list, the software accepts it (assuming it meets
validation, if any). Substitution lists are not used for validation. However, if the field has
validation, the entry is validated after the substitution is made.
Substitution lists are saved in the textbase, not as separate files.
To create a substitution list for a Text field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. Select a Text field from the Field Name list.
4. On the Text Options tab, select the Use Substitution List check box, then click the
Change button.
5. Click the Edit List button.
6. Use the Edit Substitution List dialog box to specify which items should be in the list. Type
a code, a colon, and the word or phrase you want to substitute, then press Enter or click
the Add button. For example, type nh:New Hampshire. When you are done, click OK to
return to the Edit Fields dialog box.
To edit a substitution list for a Text field
1. Choose Maintain>Edit Lists>Substitution Lists to open the Choose Substitution List
dialog box.
2. Select a field from the list and click the Edit List button.
3. Use the Edit Substitution List dialog box to make changes to the list.
Note: Field Access or Silent passwords may prohibit you from editing substitution lists.

Edit Validation or Substitution List Dialog Box
Use one of the following methods to access the dialog box you want:
Edit Validation List dialog box
Choose Maintain>Edit Lists>Validation Lists.
Choose Maintain>Edit Textbase Structure>Edit Fields, select a field, select the
Validation tab, and click the Edit List button. This method requires you have
exclusive access to the textbase.
Note: Validation lists are applicable to Text and Code field types only.
Edit Substitution List dialog box
Choose Maintain>Edit Lists>Substitution Lists.
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Choose Maintain>Edit Textbase Structure>Edit Fields, select a Text field, select
the Text Options tab, and click the Edit List button. This method requires you have
exclusive access to the textbase.
Note: Substitution lists are applicable to Text field types only.
You can type items in any order. The software alphabetizes the items automatically. Each item
can consist of up to 250 characters.
Use the buttons on the Edit Validation List and Edit Substitution List dialog boxes when creating
or editing a list.
Button

Action

Add

To add an item, type it in the Entry box, then press Enter or click the Add button.

Change

To edit an item (for example, to correct a typo), select it, edit it, and click the Change
button.

Delete

To delete an item, select it, then click the Delete button.

Find

To move quickly to an item, type the first one or more letters, then click the Find
button. This method is especially useful when you are editing very long lists.

Clear All

To remove all items from the list, click the Clear All button.

Print List

To print a list, click the Print List button. To save it as a text file, select Print to file
in the Print dialog box. Saving a list as a text file is a way of sharing lists among
textbases.

Merge File
into List

This option provides a way of importing a text file and merging it into the current list.
Click the Merge File into List button, then specify the location of the text file that
you want to import. This is how you combine two lists (duplicates are removed). To
retain a copy of the current list before merging it, first click the Print List button to
save it as a text file.

Replace List This option provides a way of importing a text file to replace the current list. Click the
Replace List with File button, then specify the location of the file that you want to
with File
import. To retain a copy of the current list before replacing it, first click the Print List
button to save it as a text file.
If you select the Update Records check box, any terms that are changed in this dialog box will
be changed accordingly in any records containing the old term in the selected field, AND any
terms deleted in this dialog box will be removed in records containing them in the selected field.
Note that the Update Records feature only applies if you accessed the dialog using
Maintain>Edit Lists>Validation Lists (not when using Maintain>Edit Textbase
Structure>Edit Fields).
Note: Field Access or Silent passwords may prohibit you from editing validation and/or
substitution lists.

Passwords
Creating and Editing Passwords
To create or edit passwords: Choose Maintain>Edit Textbase Structure>Passwords.
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Use the Textbase Passwords dialog box to assign passwords that restrict certain activities and
protect important information. A password will be requested or applied when the textbase is
opened. After you assign passwords, you can print the textbase structure to see all passwords.
If you ever forget a password, you can refer to the printout. Although passwords are encrypted
against casual view, the record information is not encrypted in the textbase and can be seen by
file-browsing software. If you have a critical need to control unauthorized access, explore
additional system security procedures.
Master Password. The Master password allows full access to all operations. Every
textbase can be protected by a Master password. A Master password must be assigned
before you can create any other passwords.
Field Access Passwords. You can create individual Field Access passwords that you
can provide to different users, giving each user different rights to the textbase. For
example, one password can prevent a user from editing validation and substitution lists.
Another password can hide some fields and make other fields read-only.
Silent Password. Enable a Silent password to allow users to open a textbase without
knowing a password, while still protecting information in the textbase, including the
textbase structure.
Example #1
You want to deny everyone access to the textbase, unless they have called and received a
password from you.
Solution: Add a Field Access password (optionally hide fields, if desired), and do not assign a
Silent password.
Example #2
You want everyone to have access to the Personnel textbase, but you want to hide confidential
information from unauthorized users: Salary and Date of Birth.
Solution: Add a Silent Password that hides those two fields. Add a Field Access password that
does not hide the fields (just accept the default settings). When the Personnel Director types
the Field Access password, she will be able to search and display the hidden fields (assuming
the query screen and reports include them). When anyone else opens the textbase, they will not
be able to search the hidden fields, and in reports will be unaware that the hidden fields exist.

Master Password
For each textbase, you can assign one Master password, which grants full access to all
operations. A Master password must be defined before you can create any other passwords.
The Master password allows you to:
Edit the textbase structure (including changing and creating new passwords).
Use any of the operations on the Manage Textbases menu.
Copy the textbase structure.
Change textbase default forms, query screen, and record skeleton.
Discard deferred updates.
Change the default indexing mode.
Delete the log file from within DB/TextWorks.
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To assign the Master password
1. Choose Maintain>Edit Textbase Structure and click the Passwords button.
2. On the Master Password tab, type a password in the Master Password box, then click
Add or Change. The Master password can include up to 15 alphanumeric characters,
including spaces and punctuation. Case is not significant (ABC is the same as abc).
To change or delete the Master password
1. You must be using the Master password in order to have the right to change or delete it.
If necessary, choose File>Use Different Password>Primary Textbase and enter the
Master password.
2. Choose Maintain>Edit Textbase Structure and click the Passwords button.
3. On the Master Password tab, do the following, depending on what you want to do:
To change the Master password, edit it, then click Add or Change. Changing the
Master password has no effect on any Field Access or Silent passwords.
To delete the Master password, click Clear. Clearing the Master password deletes
all Field Access and Silent passwords, too.

Field Access Passwords
To create or edit Field Access passwords: Choose Maintain>Edit Textbase Structure, then
click the Passwords button to open the Textbase Passwords dialog box, and select the Field
Access Passwords tab. Note that you must have a Master password to be able to select this
tab.
A Field Access password is a password with an associated set of permissions, granting or
denying read or read-write access to particular fields, or to the textbase itself (including textbase
elements). If you use an Access Control field type in a textbase to restrict access to particular
records, you can use a Field Access password to control the access the password user will
have to the various classes or records. You can create up to 255 individual Field Access
passwords that you can assign to different users, giving each user different rights.

Access Password
Type the password you want to assign in the Access Password box, click the Add button, and
select the settings you want. Each Field Access password can consist of up to 15 alphanumeric
characters, including spaces and punctuation. Case is not significant (ABC is the same as abc).
To edit a password, select it from the list, then make the changes.
To delete a password, select it from the list and click Delete.

Textbase Settings for This Password
These settings affect the textbase as a whole, when it is opened using the currently selected
password. Select one or more of the following settings:
Textbase is Read-Only. Make all fields read-only (and disable the next four options).
User May Edit Validation, Substitution Lists. Allow a user to change validation and
substitution lists.
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User May Save Forms, etc. in Textbase File. Allow a user to save, change, and delete
forms, query screens, sets, and record skeletons in the textbase file. If you clear this
check box, the password will allow the user to save elements in the user file only, for
private use.
Exclusive (Immediate) Access Permitted. Allow a user to change the indexing mode
to Immediate (as long as no other users are currently in the textbase). To prevent a user
from locking others out of the textbase, clear this check box.
User May Annotate Images. Allow a user to add, edit, or remove image annotations. If
you clear this check box, anyone using this password will be denied access to
commands such as Annotate Current Image, Remove All Annotations, and the Manage
Image Annotations commands that involve writing to an annotation list (clear, replace,
merge). Note that if you clear this check box, users will still be able to show or hide
annotations.

Field Settings for This Password
Select one or more fields in the list, then specify a Field Security setting.
Note: If the textbase includes a Link field, it appears in the list followed by the item <Linked
Information>. You can select settings for the Link field and/or for the linked information from the
secondary textbase.

Field Security Settings
For the currently selected field(s), select an option to specify how you want to protect the field.
Full Access. No security restrictions. Field entries can be viewed, edited, deleted,
searched, printed, imported, and exported.
Read-Only. Field entries can be viewed, searched, printed, and exported. They cannot
be edited, deleted, or imported. If you make any field read-only, a user with that
password will not be able to delete records. If you make a Required field read-only, a
user with that password will not be able to add records to the textbase.
Hidden. Field entries cannot be seen, so they cannot be modified in any way and cannot
be printed. From the user's standpoint, it is as if the hidden fields do not exist. You
cannot hide all of the fields in a textbase. At least one field must be visible. You can hide
an Access Control field without affecting record-level security.
Note: A hidden field appears in a form as a blank area if the box containing the hidden
field has a minimum height setting greater than zero (0) lines. This can serve as an
unintended cue to the user that the hidden field exists. To avoid this situation, set the
box's minimum height to zero (0) in the Form Designer.
If you hide any field in the textbase, a user with that password will not be able to delete
records. If you hide a Required field, a user with that password will not be able to add
records to the textbase.

Record Level Security Settings Button
Click the Record Level Security Settings button to open the Record Level Security Settings
dialog box. Note that the current textbase must already have an Access Control field, or the
software will display an error message.
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Silent Password
To enable or disable a Silent password: Choose Maintain>Edit Textbase Structure, then click
the Passwords button to open the Textbase Passwords dialog box, and select the Silent
Password tab. Note that you must have a Master password to be able to select this tab.
If you want to allow users to open a textbase without knowing a password but you still want to
protect information in the textbase, you can enable a Silent password (one per textbase). When
a textbase has a Silent password assigned, anyone can open the textbase without typing a
password, but the textbase structure cannot be edited and fields will be protected per your
specifications. If you use an Access Control field type in a textbase to restrict access to
particular records, you can use a Silent password to control the access everyone will have to
the various classes or records.

Enable Silent Password
To assign a Silent password, select the Enable Silent Password check box, then specify the
settings you want, and click OK. These settings determine what rights a user has when the
textbase is opened without entering a password. To disable the Silent password, clear the
Enable Silent Password check box.

Textbase Settings for Silent Password
These settings affect the textbase as a whole, when it is opened using the Silent password.
Select one or more of the following settings:
Textbase is Read-Only. Make all fields read-only (and disable the next four options).
User May Edit Validation, Substitution Lists. Allow a user to change validation and
substitution lists.
User May Save Forms, etc. in Textbase File. Allow a user to save, change, and delete
forms, query screens, sets, and record skeletons in the textbase file. If you clear this
check box, a person who opens the textbase using the Silent password will be able to
save elements in a user file only, for private use.
Exclusive (Immediate) Access Permitted. Allow a user change the indexing mode to
Immediate (as long as no other users are currently in the textbase). To prevent a user
from locking others out of the textbase, clear check box.
User May Annotate Images. Allow a user to add, edit, or delete image annotations. If
you clear this check box, anyone using the Silent password will be denied access to
commands such as Annotate Current Image, Remove All Annotations, and the Manage
Image Annotations commands that involve writing to an annotation list (clear, replace,
merge). Note that if you clear this check box, users will still be able to show or hide
annotations.

Field Settings for Silent Password
Select one or more fields in the list, then specify a Field Security setting.
Note: If the textbase includes a Link field, it appears in the list followed by the item <Linked
Information>. You can select settings for the Link field and/or for the linked information from the
secondary textbase.
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Field Security Settings
Select an option button to specify how you want to protect the currently selected field, when the
textbase is opened using the Silent password.
Full Access. No security restrictions. Field entries can be viewed, edited, deleted,
searched, printed, imported, and exported.
Read-Only. Field entries can be viewed, searched, printed, and exported. They cannot
be edited, deleted, or imported. If you make any field read-only, a user with that
password will not be able to delete records. If you make a Required field read-only, a
user using the Silent password will not be able to add records to the textbase.
Hidden. Field entries cannot be seen, so they cannot be modified in any way and cannot
be printed. From the user's standpoint, it is as if the hidden fields do not exist. You
cannot hide all of the fields in a textbase. At least one field must be visible.
Note: A hidden field appears in a form as a blank area if the box containing the hidden
field has a minimum height setting greater than zero (0) lines. This can serve as an
unintended cue to the user that the hidden field exists. To avoid this situation, set the
box's minimum height to zero (0) in the Form Designer.
If you hide any field in the textbase, a user who opens the textbase with the Silent
password will not be able to delete records. If you hide a Required field, a user with the
Silent password will not be able to add records to the textbase.

Record Level Security Settings Button
Click the Record Level Security Settings button to open the Record Level Security Settings
dialog box. Note that the current textbase must already have an Access Control field, or the
software will display an error message.

Specifying Record-Level Security
When using record-level security to restrict access to particular records in a textbase, use the
Record Level Security Settings dialog box to specify the type of access for each record class,
based on the password used. To access this dialog box, click the Record Level Security
Settings button on the Field Access Password and/or Silent Password tabs on the Textbase
Passwords dialog box. Note that the current textbase must already have an Access Control
field, or the software will display an error message.
It is possible to define both field-access permissions and record-access permissions for the
same password. If this is done, the most restrictive permission applies. For example, a hidden
field remains hidden in a read-only or full-access record.
Note: The settings specified below apply to the password selected on the Textbase Passwords
dialog box. The password is displayed in the title bar of the Record Level Security Settings
dialog box.
1. Select an option button to specify the Default Record Access for This Password. The
type of access you specify here (Full Access, Read-Only, or Hidden) will be used for
records that do not have a record class specified in their Access Control fields and as
the default for new record classes entered into the special validation list (unless you
specify otherwise in step 3).
2. Select a record class from the Record Class Settings list. You can use Shift+click to
select multiple record classes at one time.

70

Inmagic DB/TextWorks v13 Printed Help

Creating and Editing Textbases
Note: The items in this list are defined in the special validation list for the Access Control
field in this textbase (choose Maintain>Edit Textbase Structure>Edit Fields, then
select the Access Control field from the Field Name list and click the Edit List button on
the Validation tab).
3. Specify the type of access for the selected record class by selecting an option from the
Record Access group. The option specified here will apply when the specified password
is used.
Full Access. Users have full access to records. Records can be viewed, edited, deleted,
searched, printed, imported, and exported.
Read-Only. Records can be viewed, searched, printed, and exported. They cannot be
edited, deleted, or imported.
Hidden. Records cannot be seen, making them invisible to users.
Default. Selected by default when a new record class is added to the special validation
list. The option specified as the Default Record Access for This Password in step 1 will
be used.
4. Repeat steps 2 and 3 for each record class in the Record Class Settings list.
5. Click OK to return to the Textbase Passwords dialog box.

Edit Textbase Structure
Use the Edit Textbase Structure dialog box (choose Maintain>Edit Textbase Structure) to
make changes to the textbase structure. If the textbase has passwords, you must use the
Master password to edit the structure (choose File>Use Different Password).
Editing the textbase structure requires exclusive access to the textbase.
Item
Fields list

Explanation
Shows all of the fields in the textbase.

Edit Fields

Opens the Edit Fields dialog box to change field type, indexing, Special
Filing, and validation.

Description

Describes the textbase. A description can be up to 80 characters including
spaces and punctuation.

Created

Shows the date and time the textbase was created.

Modified

Shows the date and time of the most recent structure edit.

Default indexing
mode

Shows the default indexing mode (shared immediate, deferred, immediate)
when users open the textbase.

Passwords

Assign passwords to protect the textbase structure, fields, records, public
forms, validation lists, substitution lists, image annotations, and exclusive
access settings.

Sort Order

Indicate the order in which records should appear in reports if no other sort
is specified.

Stop Words

Specify a list of words that can be excluded from the Word index created
for a field. If you add, change, or remove words from a stop word list, the
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software does not automatically rebuild indexes.
Leading Articles

Specify a list of leading articles (a, an, the) to be ignored during indexing,
sorting, and searching. If you add, change, or remove articles from a
leading article list, the software does not automatically rebuild indexes.

Log File

Enable or disable a log file to record textbase changes, specify field(s) to
identify records in log file.

Maximum Users

Specify how many times a textbase can be open simultaneously.

XML Match Fields If you plan to edit/delete records over the Web, specify the field(s) on
which you want to match. The software uses match fields to uniquely
identify the appropriate record to modify. Note that editing over the Web
requires WebPublisher PRO version 7.0 or later.
Print Structure

Print the structure definition on paper or save it in a file.

Export Structure

Create an ASCII text file that contains all of the information specified in the
Edit Textbase Structure dialog box and all of its subdialog boxes.

OK

Save a new textbase or save changes to an existing textbase.

Cancel

Do not save changes. Abandon work done in this dialog box and all dialog
boxes accessed from it.

Adding Fields
Add a field to hold a specific category of information, such as a name. A general rule is to add
one field for each piece of information that you may want to search, sort, or print independently.
To add a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. Type a name in the Field Name box and click the Add button. Field names can be up to
20 characters and can include letters, digits, spaces, hyphens, and underbars.
4. On the Type and Indexing tab, specify the options you want, then click the Change
button.
Field Type
Require Strictly Correct Type (optional)
Allow Trailing Text (optional)
Indexing Information
Special Filing Options (optional)
5. On the Validation tab, specify the validation options you want, then click the Change
button.
Entry Validation
Content Validation
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6. Depending on the field type you specified, one of the following tabs may appear on the
Edit Fields dialog box. Specify the options you want, as appropriate, then click the
Change button.
Text Options tab. For Text fields, specify whether to use a substitution list and type
the entries you want in the list. For Text and Code fields, connect a thesaurus to the
field.
Automatic Number Definition tab. For Automatic Number fields, specify how
numbers appear, including number increment and whether thousand separators are
used.
Automatic Date Definition tab. For Automatic Date fields, specify when dates are
updated, as well as whether both date and time appear, and in what format.
Computed Number Definition tab. For Computed Number fields, specify the
formula you want to use, as well as how computed numbers are formatted.
Computed Date Definition tab. For Computed Date fields, specify the formula you
want to use, as well as how computed dates are formatted.
Link Definition tab. For Link fields, specify a secondary textbase and its
associated field.
7. Click Finish to return to the Edit Textbase Structure dialog box.
8. Click OK on the Edit Textbase Structure dialog box, then click OK to dismiss the
confirmation message box that appears.
Note: Fields that you add to an existing structure are fully accessible under existing passwords,
unless the textbase is read-only. After adding fields, you may want to edit password definitions
(click the Passwords button in the Edit Textbase Structure dialog box before clicking OK).

Renaming, Copying, Reordering, and Deleting Fields
Use the Edit Fields dialog box to rename, copy, reorder, or delete fields in the textbase
structure.
To rename a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. From the Field Name list, select a field that you want to rename.
4. Type a new name in the Field Name box and click the Change button.
You can freely rename fields. However, if the field that you rename is referenced in the formula
for a Computed field or a form calculation definition, change the formula or calculation to reflect
the new field name. If the field name is referenced in a saved set, change the query criteria to
reflect the new field name. Form and screen scripts in this and other textbases may also use
specific field names, and thus need to be updated.
Renaming a Link field in the primary textbase or an associated field in a secondary textbase
does not affect the link in any way, and is safe to do.
Because link definitions are stored internally based on field position, not name, avoid changing
the associated field’ s position in a secondary textbase structure. If you do move the associated
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field, open the primary textbase and redefine any affected Link fields. If you re⌀order any fields
in the secondary textbase structure, you may also need to fix any forms for the primary textbase
that include secondary textbase fields (redefine Box Properties).
Forms, query screens, record skeletons, and sets that were exported using Maintain>Manage
Textbase Elements contain field names in them. If you rename fields, you can still import
elements into the textbase, but the imported elements may contain "undefined" information.
Records that have been exported to a file often contain field names, too. You can use a text
editor to rename fields in exported tagged files (and sometimes in delimited files) before
importing them.
To copy a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. From the Field Name list, select a field that you want to copy.
4. Type a new name in the Field Name box and click the Add button. The new field
appears at the bottom of the Field Name list.
5. [Optional] Change the field type, indexing, validation, and other settings for the new field
by using the tabs on the Edit Fields dialog box. Click the Change button to apply the
changes.
The new field has the same field type, indexing, and validation settings as the field from which it
was copied. If the field that you copy has a validation or substitution list, those options are
copied, but the contents of the validation or substitution list are not copied. You must edit the
validation or substitution list for the new field.
To re-order fields
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. From the Field Name list, select a field that you want to move.
4. Use the Up and Down buttons to change the order of the field.
You can freely re-order fields among a set of new fields added to the end of an existing
structure, even if the textbase contains records or has existing forms, screens, or skeletons.
You can also re-order fields if the textbase file does not contain any records, forms, query
screens, or skeletons. Re-ordering fields may cause problems with forms, query screens, or
skeletons saved in a user file.
You cannot re-order fields (except among a set of new fields added to the end of an existing
structure) if the textbase contains records, or if you have already saved forms, query screens, or
record skeletons in the textbase file. You also cannot re-order fields if you created the textbase
by copying an existing structure and you selected the Copy Textbase Elements check box. In
these cases, the Change Order buttons are disabled.
Note: Field order should not be a concern, because you can use forms and query screens to
make fields appear in any order. Note that you can also specify that fields be listed
alphabetically on various dialog boxes (choose Tools>Options>Display).
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Avoid re-ordering fields in a secondary textbase, because link definitions are stored internally
based on field position, not field name. If you move the position of an associated field in a
secondary textbase, open the primary textbase and redefine the Link field. If you re-order any
fields in a secondary textbase, you may need to fix any forms for the primary textbase that
include secondary textbase fields (choose Tools>Box Properties and redefine the box
contents).
To delete a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. From the Field Name list, select a field that you want to delete.
4. Click the Delete button and respond to the confirmation message.
If the deleted field is referenced in the formula for a Computed field, a form calculation definition,
or the query criteria for a saved set, you must change the formula, calculation, or search so it no
longer references the deleted field. Form and screen scripts in this and other textbases may
also use specific field names, and thus need to be updated.
Careful! If you delete a field in a textbase that contains records, you permanently delete all of
the information in that field in all of the records in the textbase. The deletion occurs when you
click OK in the Confirm Textbase Structure Update dialog box.
If a textbase does not yet contain records and textbase elements have not yet been defined,
you can delete fields freely. You can also delete fields among a set of new fields added to the
end of an existing structure.
Note that forms, query screens, sets, and skeletons that were exported using Manage
Textbase Elements contain field names in them. If you delete fields, you can still import
elements into the textbase, but the imported elements may contain "undefined" information.
When you delete a field in a textbase that contains records or textbase elements, the field slot
remains in the internal definition of the textbase, and appears as <Deleted> in the Field Name
list. Additional fields that you add to a textbase will appear after any existing fields, including
<Deleted> fields.
You can rename a deleted field, if desired, so you can use it to store information. For example,
you can rename <Deleted> to Company Name. You cannot rename a deleted field during the
current textbase editing session because the information in the deleted field has not yet been
purged from the textbase. Information is purged when you click OK in the Confirm Textbase
Structure Update dialog box. You can edit the textbase structure again to rename the deleted
field.
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Linking Textbases
You can link a textbase to one or more other textbases to access the combination of information
that you need. By linking textbases, you reduce or eliminate duplication of effort and conserve
disk space. You can access information from several textbases at once, but you only have to
maintain the information in the textbase where it is stored.
For example, store telemarketing sales notes in Textbase A. Store customer names and
addresses in Textbase B. Link the two textbases. Now when Textbase A is open, you can see,
search, sort, print, and edit information from Textbase B as well.

Learning about Linking
There are several basic tasks involved in linking textbases.
First, you define a Link field in the primary textbase structure. When you define a Link field, you
specify the secondary textbase and associated field to which you want to link.
Second, you add or edit records to ensure that you have matching terms in the Link field and its
associated field.
Third, you design forms for the primary textbase that include fields from the secondary textbase,
so you can see the secondary textbase information. Then you design a query screen for the
primary textbase that includes fields from the secondary textbase, so you will be able to search
secondary textbase fields.

Why Link Textbases?
The main reason to link textbases is to avoid having to replicate information that is common to
many records or to more than one textbase. By storing the common information in one textbase,
you can reference it from other textbases, and keep it up-to-date in one place. For example,
keep customer names and addresses in one textbase, so you can access the information from
other textbases.
Deciding which textbases to link is an important, but not difficult, decision. Typically, you use
linking to model a many-to-one relationship between different types of records. For example:
A manufacturer has multiple products that are supplied by a particular supplier.
A legal firm has many tasks related to one trial.
A library has several books on loan to a given patron.
In each of these cases, you would create two textbases: one for the "many" instances and
another for the "one." For example, create one textbase that tracks products and another that
contains vendor (supplier) names and addresses. By linking the Vendors textbase to the
Products textbase, you can see, search, sort, and print vendor information from within the
Products textbase.
In the simplest case, a many-to-one relationship can be accomplished without linking, simply by
using multiple entries in a field. For example, many phone calls to a particular customer can be
logged in a single field in each record. However, linking gives you the ability to track specific
information separately (for example, date of call, the person initiating the call, summary of the
discussion). In this case, create a record in Textbase A for each call made or received, and link
these records back to the customer in Textbase B. Then it is easy to track how many calls were
made in a particular week, how many were made by a particular staff member, and so forth.
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Which Textbase Should be the Primary?
Part of the decision about linking textbases is to determine which textbase should be the
primary and which should be the secondary. You can most easily edit information in the primary
textbase, so make the primary textbase the one that you will be working in most frequently.
Make the secondary textbase the one that contains information that does not need to be revised
very often. When accessed from a primary textbase, the secondary textbase is read-only,
except when you use Edit Secondary Record or open the secondary textbase directly.
For example, you may be adding and editing records in the Calls textbase daily, making notes
about who called, what the call was about, date of call, and so forth. Make this textbase the
primary one. Customer names and addresses are less likely to change on a regular basis, so
make that the secondary textbase.

How is a Link Made?
Linking is done dynamically, by comparing information in a Link field with information in an
associated field in another textbase. If both textbases contain the same information in the
specified field, a link is made for a particular record, and information from the secondary
textbase becomes accessible.
Example
Primary textbase called Telephone Notes contains information about outgoing sales calls.
This textbase contains a Link field called "ID" that contains the entry "Acme."
Secondary textbase called Company Info contains names, addresses, phone numbers,
and other information about companies. This textbase contains an associated field called
"ID" that also contains the entry "Acme."
When you open the primary textbase, you have access to the Company information for
every record that contains a matching entry in the Link and associated fields.
Important! To see the information, you must be using a form that includes those fields
from the secondary textbase.
DB/TextWorks evaluates a link dynamically by working in the background searching the
associated field in the secondary textbase whenever needed. When information in the
associated field matches information in the Link field, the record in the secondary textbase is
retrieved so it can be accessed from within the primary textbase.
When you edit information in a Link or associated field, that information determines whether a
link will be made for that particular record.
If you type an entry in a Link field that is not in the associated field in the secondary
textbase, no record will be linked.
If you change an entry in a record in the secondary textbase so that the matching fields
no longer match, the record will no longer be linked.
By way of a given Link field, only one record in a secondary textbase can be associated with a
record in the primary textbase. The software automatically assigns Single Entry Only validation
to Link fields, to ensure that they contain only one entry. This entry is used to determine a
match. If multiple records in the secondary textbase contain the same information in the
associated field, only one record is used.
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The @ Link Indicator
A secondary textbase field is referenced by a combination of the secondary textbase field name,
an @ symbol, and the name of the Link field in the primary textbase. For example, this field:
Street Address@Vendor

means "Street Address field from a secondary textbase, accessed by a Link field called Vendor
in the primary textbase."
You will see this convention used in various situations, for example when selecting fields from
lists while designing query screens or forms.

Characteristics of Link Fields
A Link field can have the following characteristics, all of which you define in the Edit Fields
dialog box when editing the textbase structure (Maintain>Edit Textbase Structure).
A Link field is Term indexed by default. You cannot change this setting, because the
Term indexes of the Link and associated fields are used to achieve the match.
A Link field can be Word indexed, if you want to be able to do word, phrase, or proximity
searches.
A Link field has Single Entry Only validation applied, to ensure that only one entry will
be used to determine a match with a record in the secondary textbase. You cannot
change this setting,
A Link field can be strict (Require Strictly Correct Type), in which case the field will
accept information only if it matches existing information in the associated field. Make a
Link field strict if you want to prevent users from typing entries that do not have a
matching record in the secondary textbase.
Tip! Do not use strict links if you will be using the textbase with the DB/Text Importer.
A Link field cannot have trailing text.
A Link field uses the same Special Filing rules as its associated field, to ensure matching
consistency. You cannot select different filing rules. If you change the filing rules of the
secondary textbase associated field, you should redefine the link so that the primary
textbase can retrieve the new filing information.
Every Link field has one associated field. However, more than one Link field can link to the
same textbase, with the same associated field or different ones. There is no limit to the number
of Link fields, except that you cannot define links to more than four different secondary
textbases.

Characteristics of Associated Fields
To determine a match, DB/TextWorks compares Term index entries in the associated and Link
fields. Fields that are not Term indexed do not appear in the list of fields in the Link Definition
dialog box. In this way, the software protects you from linking to a field that does not have a
Term index.
For best results, the associated field in a secondary textbase should have unique and nonrepeating validation or should be an Automatic Number field.

78

Inmagic DB/TextWorks v13 Printed Help

Linking Textbases

If the associated field is:
Unique and non-repeating
or Automatic Number

You will:
Link to a record when information in the Link field matches
information in the associated field.

Repeating (has multiple entries) Link to a record if any of the entries in the associated field
match the entry in the Link field.
Not unique

Link to the first matching record that is found.

Using Intermediate Textbases
Typically, secondary textbases contain information that does not need to be revised very often.
However, in some situations, you may need to make and break relationships between two
relatively static textbases, such as Books and Patrons, shown below. For example, circulation of
library materials involves loaning items (connecting a book with a borrower) and checking them
back in (severing the connection).
Books - This textbase tracks information about titles, authors, publishers, and ISBN
numbers. Each record represents one book.
Patrons - This textbase tracks information about borrowers, including names, addresses,
and phone numbers. Each record represents one patron.
Where is the best place to record the transaction information? The most efficient approach is to
set up a third textbase that contains information about transactions. This intermediate textbase
will link to both of the other textbases, with additional fields for information about the transaction,
such as loan date and due date. Each record in the textbase will represent one transaction
(borrowed and returned). This approach protects the other textbases from inadvertent changes,
and is more efficient because less information is being processed when records are edited.

How to Link Textbases
You link two textbases together by defining a Link field defined in the primary textbase structure.
Every Link field has a "partner" field in another textbase. The partner is called an associated
field. The textbase that contains the associated field is called the secondary textbase. To
summarize this important relationship:
The primary textbase contains a Link field. A Link field contains text that will be matched
against a corresponding field in another textbase, in order to associate information in
that textbase with information in the primary textbase.
The secondary textbase contains an associated field. The terminology associated field is
just a convenient way of referring to the "partner" field in the secondary textbase. The
associated field can be any type (for example, Text or Number). You do not have to do
anything in the secondary textbase’ s structure to indicate that the field is associated
(except ensure that the field has a Term index). The link definition is done solely in the
primary textbase, and only the primary textbase is aware that the link exists.
Both fields hold the same information, such as company names.
When you define the Link field in the primary textbase, you indicate the secondary textbase and
associated field.

Inmagic DB/TextWorks v13 Printed Help

79

Linking Textbases
To determine a link, DB/TextWorks will compare Term index entries in the associated and Link
fields. To protect you from linking to a field that does not have a Term index, the associated field
list includes only those fields that have a Term index.
The two fields (Link and associated) should hold the same information. For example, the Vendor
field in the primary textbase and the Vendor Name field in the secondary textbase both contain
company names. When information in the Link field matches information in the associated field,
a link is made, and you have access to information in the secondary textbase.
By way of a given Link field, only one record in the secondary textbase can be associated with a
record in the primary textbase. If you change information in the Link or associated field so the
information no longer matches, a link will no longer exist for that particular record.

Link Fields
Use a Link field in a textbase if you want to access information from more than one textbase at
the same time. Select the Type and Indexing tab on the Edit Fields dialog box to specify Link as
the field type (choose Maintain>Edit Textbase Structure>Edit Fields).
Every Link field has one associated field in a secondary textbase. When information in the Link
field matches information in the associated field, a link is made, and you have access to
information in the secondary textbase. For more information, read about linking textbases.
Note that more than one Link field can link to the same textbase, with the same associated field
or different ones. There is no limit to the number of Link fields, except that you cannot define
links to more than four different secondary textbases.
To define a Link field
1. Open the primary textbase.
2. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
3. Click the Edit Fields button to open the Edit Fields dialog box.
4. Add a field or select an existing field and select Link from the Field Type drop-down list
on the Type and Indexing tab.
5. The Link Definition tab automatically appears. Click the Specify Textbase button.
Note: If you want to edit an existing Link field, select it from the Field Name list, then
select the Link Definition tab. The tab will only appear when the Link field is selected.
6. On the Link to Inmagic DB/TextWorks Textbase dialog box, select the secondary
textbase to which you want to link and click Open.
Note: There may not be room on the Link Definition tab to show the full path to the
textbase. Use your mouse pointer to hover over the textbase name to see the full path
appear in balloon text.
7. On the Link Definition tab, select the field in the secondary textbase that contains the
same information as the Link field in the primary textbase. The field you select is called
the associated field. For best results, the associated field should be unique and nonrepeating or should be an Automatic Number field.
8. [Optional] Select the Type and Indexing tab and specify the options you want:
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Require Strictly Correct Type. Select this check box if you want the Link field to accept
information only if it matches existing information in the secondary textbase. Making a
Link field strict prevents people from typing entries that do not have matching records
already in the secondary textbase. If you clear this check box, someone can create the
matching record in the secondary textbase at a later time.
Note that when you edit a record, you can press F3 in the Link field to browse entries from
the Term index of the associated field in the secondary textbase. Pressing F3 in this
situation essentially acts like a validation list for the Link field, and is especially useful
when the Link field is strict.
Note: You cannot select the Allow Trailing Text check box. There is no such thing as
trailing text in a Link field.
Indexing Information. A Link field is automatically Term indexed. You cannot change
this setting, because the Term indexes of the Link and associated fields are used to
achieve the match. You can select the Word Indexed check box if you want to be able to
do word, phrase, and proximity searching in a Link field.
Use Stop Word List. If the Link field is Word indexed, you can select or clear this check
box. You cannot change any of the Special Filing options of the Term index, because a
Link field "borrows" the filing rules of its associated field to ensure matching consistency.
Validation. The software automatically assigns Single Entry Only validation to Link
fields to ensure that they contain only one entry. The only additional validation you can
apply is Field Entry Required and/or Unique Entries Only.
9. In the Edit Fields dialog box, click Add if you are adding a field or click Change if you
are editing a field.
10. Click the Finish button to return to the Edit Textbase Structure dialog box.
11. Click OK on the Edit Textbase Structure dialog box, then click OK to dismiss the
confirmation message that appears.

Searching Secondary Textbase Fields
From within the primary textbase, you can search any field in the primary or secondary
textbase. See Searching a Textbase that Contains Link Fields for more information.
To search secondary textbase fields, design a query screen for the primary textbase that
includes fields from the secondary textbase. For example, load the Basic query screen into the
Query Screen Designer (Search>Design Query Screen), add boxes that search fields from the
secondary textbase, and save the screen under a new name.
You can browse the indexes of a secondary textbase field and paste terms or words into the
current query box, just as you would browse any field. On the query screen, position the cursor
in a field and press F3 or choose Edit>Browse Choices.
Records retrieved by a search are always from the primary textbase, even when you search a
field from a secondary textbase. Here is what happens when you search a secondary textbase
field:
1. DB/TextWorks searches the secondary textbase for records that match the specified
criteria. Multiple records may be found.
2. For each record found, the software compares the information in the associated field
against the information in the Link field.
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3. The software retrieves records in the primary textbase whose information in the Link field
matches information in the associated field.
As a result, the only records that you retrieve are from the primary textbase. A record in the
secondary textbase might match zero, one, two, or more records in the primary textbase. If it
does not match any records, no records are retrieved. This behavior explains why you
sometimes retrieve fewer records than expected.
Consider the following situation in a legal firm:
The primary textbase is called Tasks. Each record represents one task to be performed,
for example, attending a deposition.
The secondary textbase is called Case. Each record represents one case, for example
Smith vs. Jones.
If a case does not have any tasks entered for it yet, searching a secondary textbase field will not
retrieve any records. For example, if you are planning to search for Smith vs. Jones, you press
F3 on the query screen in a secondary textbase field to browse indexes, where you see one
Smith vs. Jones listed.
However, when you perform the search, you do not retrieve any records, because the primary
textbase does not contain a record (task) for Smith vs. Jones.

Displaying Information from a Secondary Textbase
To see secondary textbase information from within the primary textbase, you must design a
form for the primary textbase that includes fields from the secondary textbase. Use the Form
Designer tools to add and position boxes, specify box content and label text, and perform other
formatting.
A field in a secondary textbase is referenced by a combination of the field name, the @ symbol,
and the name of the Link field in the primary textbase. For example, a field called Street
Address@Vendor means "Street Address field from a secondary textbase, accessed by a Link
field called Vendor in the primary textbase."
Fields from a secondary textbase are represented in this way in various lists and dialog boxes,
for example, when you define box content in the Form Designer and Query Screen Designer.
Whenever you see a field represented in this way, you know that it is a field from a secondary
textbase, and you can also tell the field in the primary textbase by which it is linked.
When you design a form, note that there is no need to include both the associated field and the
Link field in the form, because they contain the same information. A form that includes both
shows redundant information, which can be confusing. Generally, just show the associated field,
since the Link field will not necessarily show punctuation.
When the form is used, it will display information from the secondary textbase fields that you
included in the form, whenever a match occurs between the Link and associated field. If a
match does not exist for a particular record, that record will not show the secondary textbase
information.
To edit information in a secondary textbase, open the secondary textbase directly, or use Edit
Secondary Record.
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Creating or Editing a Secondary Record
While working in the primary textbase, you can create and edit records in a secondary textbase;
choose Records>Edit Secondary Record. This command is intended to supplement your
editing activities in the primary textbase, should you find that information in a secondary
textbase is incorrect or missing. It is not intended for large-scale data entry in a secondary
textbase. If you have many records to add or change, open the secondary textbase directly.
To create or edit a secondary textbase record, from within the primary textbase
1. Open the primary textbase.
This feature is designed to help you in the following situation: What typically happens is
that you begin adding or editing records in the primary textbase, and you notice that a
record in the secondary textbase contains incorrect information. Or you notice that a
record does not yet exist in the secondary textbase (for example, if you are recording a
new sale in the primary textbase and the customer is not listed in the secondary
textbase). By displaying a primary textbase record in the Edit window, you will be able to
open or create a corresponding record in the secondary textbase.
2. Perform one of the following:
To create a new record in the primary textbase, choose Records>New Record,
and go to step 4.
To edit a record in the primary textbase, find the record and choose Records>Edit
Record.
3. Choose Records>Edit Secondary Record. The Edit Secondary Record window
appears.
Note that the option may be disabled if the primary textbase has multiple Link fields.
Put the cursor in the Link field for the textbase you want to edit.
If the Link field contains information (in the primary textbase record), the
corresponding record in the secondary textbase appears in the Edit Secondary
Record window, so you can edit it.
If the Link field is empty, a blank Edit form is presented so you can create a new
record in the secondary textbase.
4. Add or edit record information, then choose Records>Save Record.
If you created a record (that is, the Link field was empty when you chose Records>Edit
Secondary Record), or you modified the contents of the associated field, the value that
you entered in the associated field is automatically copied into the Link field in the primary
textbase, to ensure that the records are linked.
Important! The information can be copied only if the Link field is included on the Edit
form currently used for the primary textbase, and the box containing the Link field is
editable.

More about Adding or Editing Secondary Records
Troubleshooting
If you cannot choose Records>Edit Secondary Record, be sure that:
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The Edit window is open and active.
The cursor is in a box that contains only one Link field or only field(s) from one
secondary textbase record. The Edit Secondary Record command is inactive if there is
any ambiguity about which secondary textbase record should be accessed (for example,
if the textbase contains more than one Link field, or a box contains multiple Link fields).
You are using a secondary textbase password that permits editing (see below).

Forms and Record Skeletons
The Edit Secondary Record window uses the form that was most recently selected. The same is
true for record skeletons; the last-used skeleton is used. You can select a different edit form
using the Select Form for this Window toolbar button on the Edit Secondary Record window (if
present). There is no similar support for selecting a different record skeleton.

Passwords
If a secondary textbase has passwords, you can select a different password from within the
primary textbase. Choose File>Use Different Password>Secondary Textbase. You may have
to do this if the current secondary textbase password restricts access to certain fields, either by
hiding them or making them read-only. Settings in Tools>Options>General control whether
you are prompted for a secondary textbase password when the primary textbase is opened, or
whether the Silent password is used.

Indexing Mode
Changes to secondary textbases are always made in Shared Immediate indexing mode,
regardless of the selected indexing mode.

Multiple Links among Textbases
If the secondary textbase contains links to yet another textbase, the third textbase is never
opened from the primary. For example, you have three textbases, where:
A has a link to B, and
B has a link to C.
If your primary textbase is A, textbase C will not be opened. If the link to C is strict (Require
Strictly Correct Type), you cannot edit the strict Link field in textbase B; and if it is also required,
you cannot use choose Records>Edit Secondary Record to create records in textbase B.

Browsing Link Fields while Editing a Record
When you add and edit records in the primary textbase, you nearly always want to establish a
match so you will have access to record information from the secondary textbase. To establish
a match, you need to make sure that information in the Link field in the primary textbase
matches information in the associated field in the secondary textbase.
You could type information in the Link field and hope it matches information in the associated
field. To guarantee a match, position the cursor in a Link field and press F3 or choose
Edit>Browse Choices. The Query Choices Browser dialog box appears. It shows terms from
the associated field in the secondary textbase. You can paste a term from the list into the
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current field in the record you are editing. This guarantees a match, so you have access to the
secondary textbase information for a particular record.
See Linking Textbases for more information.

Refreshing Linked Information while Editing a Record
When information in the Link field in the primary textbase matches information in the associated
field in the secondary textbase, a link is made, and you can access information from the
secondary textbase. If you change information in a Link field, you can access a different record
in the secondary textbase.
Important! The form you are using for the Edit window should include fields from the secondary
textbase. Otherwise, even if a match is made, you will not see secondary textbase information.
When you are editing a record, fields from a secondary textbase are automatically updated
when you change information in the Link field then move the cursor off of the Link field. To see
updated information from the secondary textbase without moving the cursor off the Link field,
press F9 or choose Window>Refresh.

Change Secondary Password
To access this dialog box: Open a primary textbase and choose File>Use Different
Password>Secondary Textbase.
The Change Secondary Password dialog box enables you to select a different secondary
textbase password while using the primary textbase. For example, you may want to use a
secondary textbase password that provides write-access to all fields. You can access this dialog
box only when the primary textbase is linked to more than one secondary textbase.
Select a textbase from the list of Secondary Textbases with Passwords, click the Change
Password button, and specify the secondary textbase password that you want to use.
Note: To control whether you are prompted for secondary textbase passwords when you open
a primary textbase, set the initial password handling for secondary textbases (choose
Tools>Options>General).
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New Record command (Records menu)
To create a new record, choose Records>New Record, or press Ctrl+F2, or use the New
Record button on the toolbar. You see the Edit window, which uses the currently selected
Record Edit form.
Each box typically represents one field. Click in the box where you want to begin typing, or
press Tab or Shift+Tab to move from box to box. You can also use Edit>Go to Box or the
standard navigation keys.
Type or paste information in the boxes, using the techniques summarized below.
To:

Do this:

Type one entry

Type information in a box.

Create multiple entries

Press F7 in a field that already contains an entry or choose
Edit>New Entry, then type or paste information. For
example, to add three entries to the Synonyms field, type
Cruise ship, press F7, type Sailboat, press F7 and type Boat.

Paste an entry from a validation
or substitution list

Press F3 in a field that has a validation or substitution list.

Paste a term from the associated Press F3 in a Link field.
field in a secondary textbase
A record can include any keyboard or extended character. To type an extended character, use
the Alt key and the numeric keypad. For example, you might type 0233 while holding down the
Alt key to create the character é.
To save a record and continue displaying it, press F5 or choose Save Record on the Records
menu or click the Save Record button in the Edit window toolbar.
To save a record and begin creating a new record (following a confirmation message), press
Ctrl+F2 or choose New Record from the Records menu or use the New Record button.
If you perform certain operations without having saved a record, for example if you try to close
the textbase, DB/TextWorks asks if you want to save the changes before proceeding.

Edit Record command (Records menu)
To edit a record
1. Do a search or load a set to find the record you want to edit.
2. Select a record in the Report window and/or display the record (Display>Display
Record).
3. Choose Records>Edit Record, or press F2, or click the Edit Record toolbar button.
4. If a record has deferred changes, DB/TextWorks asks if you want to edit the changed
version of the record. Click Yes if you want to edit the changed version of the record
(you will see the pending changes), or No to cancel.
5. The record appears in the Edit window. Add and/or edit information, as applicable.
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6. To determine how records appear in the Edit window, choose Display>Select
Forms>Record Edit. To be sure you are seeing all fields, select the Basic Record form
or use a form designed especially for editing.
7. To save changes, press F5 or choose Records>Save Record.

Checking Spelling
There are two ways to check a record to eliminate possible typographical errors. You can run a
spell check on a record after you have finished typing or editing it, or you can choose to have
your spelling checked as you type in the record. You can check spelling in the following
windows: Edit Record, Edit Secondary Record, Record Skeleton Editor.
The spell checker helps you identify possible misspellings by comparing the text to a dictionary
of accepted spellings. You can add, edit, and delete items in the dictionary.
To set up the spell checker
1. Decide which fields to check and which to skip. By default, DB/TextWorks checks Text
fields only. To check other types of fields, choose Tools>Spell Check Setup and use
the arrows to indicate which fields to check and which fields to skip. Because they are
not editable fields, Automatic and Computed Date and Number fields can never be
checked (but Automatic ID fields can be).
2. [Optional] Select the Check spelling as you type check box in the Spell Check Setup
dialog box. Note that if you have the Edit window open when you select this option, it will
not take effect until you close and re-open the Edit window.
3. Click OK.
Note: If you want to change the spell check settings while in the Edit Record, Edit Secondary
Record, or Record Skeleton Editor window, close the window before specifying the new settings
on the Spell Check Setup dialog box. If you do not, the changes will not apply to the record or
record skeleton in the active window.
To run the spell checker
1. Open a record in the Edit window, or Edit Secondary Record window, or a skeleton in
the Record Skeleton Editor window.
2. Select a form that includes all the fields that you want to spell check. For example, click
the Select Form for this Window button
Basic Record form.

on the Edit window toolbar and choose the

3. Place your cursor in the box in which you want to begin the spell check, or select the text
that you want to spell check.
4. Choose Tools>Spell Check, press F8, or click the Spell Check button on the Edit
window toolbar.
5. Use the Check Spelling dialog box to correct spelling errors. Click the Help button in that
dialog box for more information. DB/TextWorks checks editable boxes only. It skips:
Fields that do not appear on the Edit form.
Fields that are marked read-only by the current password.
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Uneditable boxes (boxes that contain automatic and computed date or number
fields, variables, more than one field, and so forth).
Fields in the Skip these Fields list on the Spell Check Setup dialog box.
To check spelling as you type
1. Create a new record or open a record for editing in the Edit window, or Edit Secondary
Record window, or a skeleton in the Record Skeleton Editor window. As you type, words
the spell checker considers misspelled will turn red.
2. Choose a method for correcting spelling errors. You can make corrections when a red
word appears, or when you are done typing.
Right-click a red word. A list of suggested alternatives appears on the shortcut
menu, as does commands to Ignore All (to skip the misspelled word and all other
instances of it in the record) and Add (to add the word to your spell check
dictionary). Choose an alternative word, if applicable, and the spell checker will
replace the red text with the new word, and make the text color black. Note that if
you have moved the cursor out of the box containing the red word, you must use
the left mouse button (left-click) in the box before you right-click the red word in it.
Note: Once you make a selection from the list of alternatives (or select the Ignore
All or Add commands), the standard shortcut menu that opens when you right click
appears. Click away from it to make it disappear.
Select the red word and type the correct word, if the word is one for which you do
not need an alternative suggested (for example, you typed hte instead of the). The
new word will appear black if it is spelled correctly.
Note: Double-clicking a word does not highlight the entire word when using the
Check spelling as you type option. You must highlight the word with your mouse
to select it.
Continue typing and run the spell checker when you are done. Choose
Tools>Spell Check, press F8, or click the Spell Check button on the Edit window
toolbar. The spell checker will provide alternative spellings for each red word, one
at a time, on the Check Spelling dialog box and turn each misspelled word black, if
an alternative is selected to replace it.
Note: If you choose to check spelling as you type, note that the text you type will
only appear red or black, no matter what color text you specify for the record.
Words spelled correctly while typing will appear black and misspelled words will
appear red. Words chosen from alternative lists will be changed from red to black.
This applies to alternatives provided by right⌀clicking a red word, or in the Check
Spelling dialog box. To keep records looking uniform, you should use black text
when typing records in the Edit window, or Edit Secondary Record window, or
skeletons in the Record Skeleton Editor window, if you are using the Check
spelling as you type option.

Duplicate Record command (Records menu)
You can copy an existing record, then edit the copy to make it unique. Duplicating a record can
save you valuable editing time if the record you plan to add is very similar to an existing one.
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To duplicate a record
1. Select a record in the Report window (or in the Display or Edit window).
2. Choose Records>Duplicate Record. If a record has changes made with Deferred
indexing, DB/TextWorks informs you that updates are pending and asks if you want to
edit (copy) the changed version. Click Yes to copy the changed version, or No to cancel.
Note: If you copy a record that has been edited but not saved, the software asks if you
want to save the record. If you click Yes, the changes are saved, and the copied record
includes the changes. If you click No, the changes are not saved, and the copied record
does not include the changes. If you click Cancel, you return to the original record.
3. Edit the new record.
4. Save the new record by pressing F5 or choosing Records>Save Record.

Notes about Duplicate Record
Only fields included in the Edit form are copied. If the Edit form omits any fields that have Field
Entry Required validation, the software will force you to use the Basic Record form when you
duplicate a record. If necessary, choose Display>Select Forms>Record Edit and select an
Edit form that includes all of the fields that you want copied and all fields that have Field Entry
Required validation.
If you are using a password, it must provide full access to all fields that have Field Entry
Required validation.
The following table shows how information is handled when you duplicate a record.
If the original record includes:

Then:

Automatic Number fields or
Automatic ID fields

The new record is assigned the next automatic value,
just as if you had chosen Records>New Record.

Automatic Date fields

The date or date and time in the new record indicates
when the copy was made.

Hidden or read-only fields

Those fields are not copied.

Computed fields

Those fields are updated in the copy.

Fields omitted by the current Edit form Those fields are not copied.

Record and Report Options (Copy Special)
You can copy information to the Windows Clipboard so you can paste it into another application.
The form selected for the active window is used. If the active window is not a record window,
Copy Special>Report uses the form selected for the Report Window. Only the information that
is displayed by the current form will be copied. The copied information uses plain text format;
form layout is retained but font, color, picture boxes, and so forth are ignored. Only the first 64K
(approximately 64,000) characters are copied.
If you plan to copy records and reports to the Windows Clipboard regularly, you may want to
create forms that have the following attributes, and select the appropriate form before copying a
record or report:
Courier New 10 point (Tools>Box Properties>Labels and Tools>Box
Properties>Format>Font, Color)
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Vertical units set to Lines (Tools>Form Properties>General)
Top Position Offset for boxes set to whole increments of lines, such as 1 or 2, not .5
(Tools>Box Properties>General).
To copy a record
Do a search or load a set, select a record in the Report window or display a record in the
Display or Edit window, then choose Edit>Copy Special>Record. The form selected for the
active window is used.
To copy a report
Do a search or load a set, then choose Edit>Copy Special>Report. The form selected for the
Report window is used.

Browsing Choices
Press F3, or choose Edit>Browse Choices, or use the Browse Choices button on the Main
window toolbar to display a list of items that you can paste in a box. The contents of the list
depend on the operation that you are performing.
In the Query window or Command Query window, you see the Query Choices Browser,
which shows a list of terms, words, thesaurus terms, and/or saved sets.
In the Edit window, you see the Editing Choices Browser, which shows the validation list,
substitution list, links (terms from the associated field in the secondary textbase), and/or
thesaurus.
To:

Press F3:

Browse Term and Word indexes or a
thesaurus

In a query box when searching

Browse saved search sets

In a sets box when searching

Construct Command queries and browse
Term and Word indexes or thesauri

In the Command Query window when searching

Browse a validation list, or a substitution
list, or links, or a thesaurus

When adding or editing a record

Note: If you have a WebPublisher product, you can specify that your end users be able
to browse choices when searching and editing over the Web. See the Using Validation
on the Web topic for more information.

Delete Record command (Records menu)
You can permanently delete records from a textbase. If the textbase has passwords, the
current password must provide full access to all fields. If necessary, choose File>Use Different
Password>Primary Textbase and/or File>Use Different Password>Secondary Textbase
and use a different password.
To delete a record
1. Search for the record that you want to delete and select it in the Report window (or in the
Edit or Display window). The record currently selected in the active window is the record
that will be deleted.
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2. Choose Records>Delete Record.
3. On the confirmation message, click Yes to confirm deleting the record or click No to
cancel the deletion request.

Batch Modify command (Records menu)
To change information in more than one record at once, you can batch modify all of the records
in the current set. For example, you can change a word, phrase, or entry in all of the records in
the set.
To change more than one record at a time
Tip! Before you begin, consider exporting the set of records to an ASCII file, in case you need
to restore the information later.
1. Perform a search or load a set that contains the records you want to modify. You may
want to view the records in either the Report or Display windows to verify that they are
the ones you want to modify.
2. To remove a record from the set so it will not be modified, select it and choose
Sets>Omit Record or press Alt+O. Omitting a record does not delete it from the
textbase; it simply removes it from the set so it will not be affected by the batch
modification.
3. Choose Records>Batch Modify to open the Batch Modify Records in Set dialog box
and specify how records should be changed.
4. Click OK to confirm your settings.
5. A confirmation message appears. Read it carefully before you click Yes to begin the
process. Clicking No returns you to the dialog box so you can make additional changes.
6. At the end of the batch modification process, a message indicates how many records
were modified, how many were not, and why. If you want more information at that time,
choose Maintain>View Log File.

Importing and Exporting Records (Summary of
Operations)
You can copy record information into and out of a textbase, by importing and exporting text files.
Importing and exporting is a way of sharing information among textbases or other applications,
and of backing up and restoring record information.
Option
Export

Menu
File

Purpose
Writes copies of updated versions of all records in the current set or
textbase to a text file. You can choose whether to include linked
fields (from a secondary textbase). Records are exported as if
deferred updates had already been posted. You can load the text
file into another application or an Inmagic textbase.

Import

File

Loads records from a text file into a DB/TextWorks textbase. This is
how you move records from another source into your textbase.

Import
Document

File

Loads full text from documents into a field. This is how you import
text from letters, faxes, e-mail messages, and other documents.
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Dump Textbase

Manage
Textbases

Writes copies of all records in the textbase to a text file, not
including pending updates. Deferred additions, changes, and
deletions are ignored. The Image annotation list is retained. This is
how you back up records, as part of a regular maintenance routine.

Load New
Textbase

Manage
Textbases

Intended primarily as a recovery mechanism to load records into a
new empty textbase. No validation or duplicate record checking is
done. Leaves Automatic and Computed fields intact (exactly as
they are in the import file).

Recover
Textbase

Manage
Textbases

Intended for use as a single-step recover textbase mechanism.
Recovering a textbase involves dumping the contents to an ASCII
file, making an empty copy of the textbase, and loading the ASCII
file into the new textbase. Compare with the multi-step recover
textbase procedure.

The import and export options allow you to share records with any application that can import or
export standard delimited text files.
The file that you import or export may contain extended characters such é, ñ, and £. Microsoft
Windows and DOS have different extended character sets. To ensure that the characters are
interpreted properly when sharing files among DOS and Windows applications, choose
Tools>Options>General before you import or export and select or clear Read/write extended
characters in MS-DOS format. The default is the Windows format.

Export Options
Choose File>Export to access the Export Options dialog box, to specify how records should be
exported.

File Format tab
Select an option to specify the format of the export file:
Inmagic Tagged Format. A text format for sharing files among Inmagic applications.
Delimited ASCII Format. A text format in which values are separated by commas, tabs,
or other characters. If you select this option, the dialog box expands so you can specify
which characters to use to indicate field separators and other delimiters. Select delimiter
options from the lists or type keyboard characters. {CR}{LF} denotes a carriage return
and line feed. {LF} denotes a line feed only. {TAB} indicates a Tab character. To specify
another control character, type its ASCII value inside curly braces; for example, {29}.
XML. Exports Extensible Markup Language, used for structured documents on the Web.
If you selected Delimited ASCII Format, specify the Delimiter Options:
Record Separator. Indicates where each record ends. The default is {CR}{LF}.
Entry Separator. Indicates where each entry ends. The default is a vertical bar ( | ).
Quote Character. Encloses field information. For example, a double quotation mark (")
is used in this example: "Jones","15 Elm Street","Smalltown","CA"
Select {NONE} if you do not want to set off field information, as shown in this example:
Jones,15 Elm Street,Smalltown,CA
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Field Separator. Indicates where each field ends. Commas are commonly used to
separate fields, but {TAB} or another character can be used.
Comment. This option is disabled, because DB/TextWorks always uses an exclamation
point (!) to indicate comment lines. Comment lines provide information, such as the
source or purpose of the file, and are ignored during an import into DB/TextWorks.
If you selected Delimited ASCII Format, specify whether to Store Field Names in First Row.
Some applications require this format for import.

Records to Export tab
Export Current Record Set. Exports only those records in the current set. If you did not
perform a search or load a set, or if the set contains 0 records, this option is disabled.
Export Entire Textbase. Exports all records in the textbase.
If you want to export records using the currently selected, user-specified sort, select the
Use Current Sort check box. This check box is disabled if there is no user-specified
sort. If this box is not selected, records will be exported in unsorted order.

Fields to Export tab
Export All Fields. Exports all of the information in the records you are exporting
(primary textbase fields only).
Export Subset of Fields. Exports information only from the fields that you select.
Optionally, check Include Linked Fields if you want fields from linked textbases
(secondary fields) to be available in the list of fields that can be exported.
If you select the Export Subset of Fields option, you must specify which fields you want
to export. Use the arrow buttons to move fields from the Available Fields list to the
Fields to be Exported list. Fields will be exported in the specified order.

Inmagic Tagged Format (Import/Export)
Use the Import and Export options to share record information between Inmagic textbases.
Inmagic tagged files are text files in a format specific to Inmagic textbases. A file can include
one or more records. Each record includes at least one field name followed by one or more
entries in that field. Field names that include spaces are surrounded by quotation marks. A
dollar sign on a line by itself indicates the end of a record.
Example
! Comment lines are ignored during an import
! This is the first record
AUTHOR Dennis, Susan
TITLE Online Help
SUBJECT Illustration of Inmagic tagged text import format
; The word SUBJECT in the previous line is a field name.
; Each field name is followed by a space, then content.
Continuation lines within an entry (such as the one you
are reading now) start with a space or a tab.
; Use a semicolon for each additional field entry.
Repeating field entries are a unique DB/TextWorks
feature. This is the fourth entry in the SUBJECT field.
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"Short Abstract" This field name is surrounded by
quotation marks because it contains a space.
> A line starting with a "greater than" sign indicates
a paragraph break to be retained in the data. A dollar
sign on a line by itself indicates end-of-record.
$
! This is the second record
AUTHOR Dwayne, Mark
TITLE Chuck Sawyer
SUBJECT A tale of two boys
"Short Abstract" This is the story of two boys on an
adventure.
$

Characters at the beginning of a line indicate certain items, explained below.
Item at beginning of line

Description

!

Comment line (ignored during an import)

Field name

Field names can start with and include letters, digits, hyphens,
and underbars. Field names that include spaces must be
enclosed in quotation marks ('single' or "double").

;

Additional entry in previously-named field

>

Line break to be retained in the data for previously-named field

Space or Tab

Continuation line for previously-named field (permits wrapping)

$

A dollar sign on a line by itself indicates the end of a record

Any other character

An error, which causes the record to be rejected

To create a text file in Inmagic tagged format, use any text editor or use DB/TextWorks (Dump
Textbase or the Export feature). If you use Dump Textbase or Export, you can be sure that the
file is in the proper Inmagic format. If you create the file yourself using a text editor or word
processor, follow these guidelines:
Field names that include spaces must be surrounded by quotation marks. Capitalization
is ignored.
A line cannot exceed 65,534 characters. If you want to force a line wrap, press Enter
and begin the next line with a space or Tab. This is called a continuation line.
Continuation lines are interpreted properly during an import, even if you strip leading
spaces. A tab character will be changed to a space during an import (whether it is at the
beginning of a line or embedded in a line).
Note: Export and Dump Textbase automatically wrap lines at 80 characters.
Do not include a space or Tab before any of the characters used to represent multiple
entries, paragraph breaks, comment lines, or the end of a record (; > ! $). If you do, they
will be interpreted as text in the field.
Blank lines and comment lines are ignored during an import. Use comment lines to
include useful information such as the textbase into which the file should be loaded.
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Records do not have to include every field that is in the textbase structure—just the fields
that you want to modify. Fields can appear in any order. They do not have to be in the
same order as the structure.
Do not include a field name more than once in a record. Use a semicolon (;) at the
beginning of a new line to indicate multiple entries.
You can include any number of records in the file.
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Query Methods
DB/TextWorks provides the two query methods listed below. Note: If you are using
WebPublisher PRO, please see Creating query screens for Web Use.
Query Window. This is the easiest and most common query method. When you open a
textbase that contains records, you see a query screen, which consists of multiple
boxes. Each box represents one or more fields that you can search. You can also have
boxes containing items you cannot search, such as fixed text and pictures. Type criteria
into the boxes, then execute the query. You can design your own query screens to
search the fields you want.
Command Query. Type criteria in this window as a statement, using a particular syntax.
This method is especially useful when specifying complex criteria.
To execute either type of query, choose Search>Execute Query or press Enter.

Terminology
Depending on how a field is indexed, you can search for a word, phrase, or term:
A word is a group of characters that does not contain spaces or punctuation (except a
decimal symbol in a number).
A phrase is two or more words separated by spaces or, in some cases, punctuation,
such as local area networks or MS-DOS.
A term is a word or phrase that is also a complete entry in a field. Date and Number
fields typically are Term indexed, as are fields that hold discrete pieces of information,
such as book titles.
A search item is a single word, phrase, or term that you want to find in the textbase.
You can specify one or more search items in a query box. A search item can also be a
single comparison, range, or proximity search request. For example, here are three
search items:
>100
1999:2003
red p3 dog

You can connect search items with Boolean symbols (&, /, !), either within a box or across
boxes. For example, to find correspondence about cars and boats, you can type cars &
boats in a query box.
Search criteria refers to multiple search items or the entire search request.
A successful query finds a set of one or more records. You can display, sort, print, edit, and
perform other operations on the records in the set. You can save a query set so you can use it
again later, for example, in the Saved Queries window.

Toggling between Query Windows
You can toggle between the Command Query window and the Query window. The software
minimizes the Query window that is not being used.
To open the Query window, choose Search>Query Screen.
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To open the Command Query window, choose Search>Command Query.
A quick way to learn Command query syntax is to fill in the Query window with criteria, then
open the Command Query window. This converts the query criteria to a Command query.
If you open the Query window after typing a Command query, the software fills in the query
screen with the search criteria specified in the Command Query window. If the Command query
includes fields or combinations of fields that do not appear on the query screen, or is too
complex for the current query screen, or includes the getDeferred command, the software
displays a message, then fills in as much of the query screen as possible. The message is
intended to alert you that part or all of the query has not been filled in on the query screen.
If only part of a query can be represented in the Query window, the title bar contains the text
"partial" to alert you that some criteria may be missing.
There are two other types of queries that cannot be represented in the Query window: find all
records and get deferred records. If you use Command queries or menu options to find all
records or get deferred records, the title bar of the Query window will include the text "all
records" or "get deferred updates."

Saved Search Sets (Overview)
Records found by a search are called a set. You can save a set to use again later. A set is not a
collection of records, nor is it a separate textbase. It is a list of records, together with the search
criteria that found those records. When you reuse a saved set, DB/TextWorks looks at the list to
find records in the textbase.
The ability to save and reuse sets makes it easy to return to different sets of information
extracted from a textbase, without having to retype the query. You can:
Save sets to keep a permanent record of search criteria and records found by the search
Load a set to access the records without re-executing the search and retaining
omissions
Combine sets with other searches, using Sets boxes and Boolean symbols and
commands
Specify that execution of the query criteria in a saved set be the first action performed
when you open a textbase from a menu screen
Refresh sets to make sure the set contains the most up-to-date results
Browse sets by pressing F3 in a sets box on the query screen
Copy, rename, delete, export, import, or print sets by choosing Maintain>Manage
Textbase Elements
Cause a list of saved queries to appear when you start DB/TextWorks
Include saved queries on a menu screen (DB/Text WebPublisher)
Specify how many query sets should be retained on the server (DB/Text® WebPublisher)
In most situations, the status bar shows the name of the current set and the number of records
the set contains.
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Managing Search Sets
A set is a list of records found in a search, together with the criteria that were used to perform
the search. You can perform the following operations on a saved set.

Renaming a Set
1. Choose Sets>Manage Sets to open the Manage Sets dialog box.
2. From the Currently Saved list, select the set you want to rename.
3. Click the Rename button to open the Rename Set dialog box.
4. In the New Name box, type a new name. The name can include up to 20 characters,
including spaces and punctuation. Set names cannot include curly braces ({ }).
5. Click OK to change the name and close the Rename Set dialog box.
6. The new name appears in the Currently Saved list on the Manage Sets dialog box. Click
Close.

Deleting a Set
You can delete one or more sets at a time. If you delete a set from your user file, you will not be
able to use that set again. Note that when you delete a set, you delete the query criteria and list
of found records, not the actual records in the textbase.
1. Choose Sets>Manage Sets to open the Manage Sets dialog box.
2. From the Currently Saved list, select the set(s) you want to delete.
3. Click the Delete button.
4. When prompted, click Yes to confirm the deletion, then click OK.
5. Click Close to close the Manage Sets dialog box.

Exporting and Importing Sets
There are several reasons why you might want to export or import sets:
To share sets with other users. For example, you can export sets saved in your user file,
and other people can import those sets into their user files.
To use with another DB/TextWorks textbase that has the same fields.
To back up sets as part of your regular maintenance routine, in case the originals are
accidentally damaged or deleted.

Exporting a Set
You can export multiple sets to a file (for example, you can export sets called Loaned Books
and Loaned Periodicals to a file called CIRCULATING.XPS). When you export a set, only its
name, description, and search criteria are exported. Exporting a set does not export a list of
records found. The default file extension used during the export of sets is .XPS.
1. Choose Sets>Manage Sets to open the Manage Sets dialog box.
2. From the Currently Saved list, select the set(s) that you want to export.
3. Click the Export button to open the Export Set As dialog box.
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4. Specify a file name and location, then click Save.
5. Use the Save in drop-down list to navigate to the location where you want the file
exported, then enter a name for the file in the File name box.
6. Click Save. DB/TextWorks performs the export and displays a message when done
indicating how many sets were successfully exported. Click OK to dismiss the message.
7. Click Close to close the Manage Sets dialog box.

Importing a Set
You can import multiple sets from a file. The default file extension used during the import of a
set is .XPS. If duplicate names are detected during an import, DB/TextWorks adds a suffix that
consists of an underline and a sequential number (for example, MySet_1).
An imported set has no list of records found. It consists only of the query criteria. To generate a
list of records found, you have to refresh or load and execute the set. You will not know whether
the imported query criteria are valid until you execute the query. If the query references fields
not defined for this textbase, an error message will appear when you execute the query.
1. Choose Sets>Manage Sets to open the Manage Sets dialog box.
2. Click the Import button to open the Import Set dialog box.
3. Use the Look in drop-down list to navigate to the location of the file you want to import.
4. Click Open.
5. DB/TextWorks performs the import and displays a message when done indicating how
many sets were successfully imported. Click OK to dismiss the message.
6. Click Close to close the Manage Sets dialog box.
7. After an import, you should choose Sets>Refresh Sets to execute or refresh the query.

Printing a Set Definition
You can print a description of a set or save it in a text file. You can print multiple definitions at
once, or save multiple definitions in one text file. A definition includes the set name, textbase
name, description, creation date, number of records found, and Command equivalent of the
search criteria that produced the set. It does not include record information. Note: A definition
printed to a file is not formatted for import, and therefore is not a way of backing up or sharing
sets among users. To back up or share sets, use the Export and Import buttons on the
Manage Sets dialog box. Or, to export copies of the records in a set, load the set then use
File>Export.
1. Choose Sets>Manage Sets to open the Manage Sets dialog box.
2. From the Currently Saved list, select the set(s) for which you want to print a definition.
3. Click Print to open the Print dialog box, then do one of the following:
To send the definition(s) to a printer, select the desired print options, then click OK.
To save the definition(s) in a text file, select the Print to file check box and click
OK. In the Save File As dialog box, specify a location and a file name. The file
extension .TXT is used by default. Click Save.
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Copying a Set
You can copy a set by saving it under a new name.
1. Choose Sets>Load Set to open the Load Set dialog box.
2. From the Currently Saved list, select the set you want to copy. Note that the number of
records in each set is indicated in square brackets after the set name. If you want to see
the query criteria that generated the set, click the Show Query button.
3. Click OK to load the set and open the Select Search Results Window dialog box.
4. [Optional] Select an option button to view the records in the Report or Display window,
then click OK. Note: You can choose not to display the records.
5. Choose Sets>Save Set As to open the Save Set As dialog box.
6. In the Name box, type a new name. You can also optionally change the description of
the set in the Description box.
7. Click OK.

Changing the Description of a Set
To change the description of a set, follow the same procedure for copying, but do not change
the name in the Name box on the Save Set As dialog box.

Using the Query Window
To perform a query, type or paste information in the boxes on the query screen, and click the
Boolean AND, OR, or NOT buttons between the boxes to combine multiple requests. To
indicate which fields to search and what to search for, type or paste information into the
boxes that reference the fields you want to search. To indicate how to search, you can include
symbols that specify truncation, comparisons, ranges, proximity, and Boolean logic, and click
the Boolean buttons to indicate how to combine the criteria.
The appearance of the Query window depends on which query screen is selected. If the current
screen does not include the boxes for fields you want to search, you can use the Search menu
to add and delete boxes or select a screen that was saved previously.
To perform a query
1. Choose Search>Query Screen.
2. Place the cursor in the box whose field(s) you will search. Each query box searches one
or more fields, depending on how the query screen is designed. For example, a box
labeled Subject might search two fields: Subject and Description. When a query box
searches multiple fields, an implicit OR is used between the fields (search the Subject
OR Description field for the specified item). Unindexed fields cannot be searched, so
they cannot be included in a query box.
3. Type information in the box or press F3 to browse and paste words or terms from the
indexes, and toggle the Boolean AND, OR, or NOT button to combine criteria, as
described below.
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To:

Do this:

Find a word or phrase In a Word indexed field, type the word or phrase. For example,
type urgent or rush order. You can also press F3 and paste from
the Word index.
Find a term

In a Term indexed field, type the term preceded by an equal sign
(=john smith). The equal sign tells the software to search the
Term index for an exact match, except for punctuation and case.
You can also press F3 and paste from the Term index.

Find parts of items
(truncation)

Type an asterisk at the end of a word, phrase, or term to find text
that begins with the specified characters. For example, tel* finds
telex and telephone repair.

Use comparisons and Use comparison and range operators (=, <, >, <=, >=, :) in a
ranges
Term indexed field. For example, <1998 finds all dates before
1998, and 100:300 finds values between 100 and 300
(inclusive).
Find words near each Use the proximity operators w# and p# in a Word indexed field.
other
For example, red w3 boat finds red within 3 words of boat. Red
p3 boat finds red preceding boat by 3 words or fewer.
Use Boolean logic

Type Boolean operators (& / !) between search items in a box to
represent AND, OR, and NOT. For example, type cars & boats in
the Subject box to find records that contain both words (cars and
boats) in the Subject field. Type cars / boats to find records that
contain either word (cars or boats). Type cars ! boats to find
records about cars but not boats.
Toggle the Boolean button in front of a box (AND, OR, NOT) to
combine multiple requests. If no buttons appear, look at the
status bar to see whether the current box uses AND, OR, or
NOT.

Include current date

Use the @DATE search variable to include the date the search
is executed as part of the query criteria. You can also use date
arithmetic operators.
Example: <@DATE+7

4. To start the query, press Enter or choose Search>Execute Query, or click the Execute
Query button in the Query window toolbar. (Note that Execute Query is disabled unless
a Query window is selected.)
5. The software tells you how many records were found and displays the Select Search
Results Window dialog box. Select how you want to display the results of the search.
Tip! After you select a window in this dialog box, DB/TextWorks maintains this setting
until you do another search and choose a different window. The software then maintains
the new setting. To prevent this dialog box from appearing every time you do a search,
select Always use this option without asking. If you want to change your window
selection, and you have selected Always use this option without asking, choose
Tools>Options>Display to reset your default.
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6. Optionally, perform operations on the set of records found by the search.
To:

Do this:

Navigate in the
Report window

Choose Display>Next Record, Display>Previous Record,
Display>First Record, or Display>Last Record, or use the
equivalent buttons on the Report window toolbar.

Display one record Select a record in the Report window and choose Display>Display
Record.
Edit records

Select one record in the Report window and choose Records>Edit
Record.
To edit all of the records in the set, use Batch Modify.

Delete records

Select one record in the Report window and choose
Records>Delete Record.
To delete all of the records in the set, use Batch Delete.

Omit a record

Choose Sets>Omit Record to remove the selected record from the
current set. Omitting a record does not delete it from the textbase.

Sort records

Choose Display>Sort Report.

Print a report

Choose File>Print.

Print one record

Open the Display or Edit window then choose File>Print.

Send Report as
Mail

Choose File>Send Report as Mail. The Send Report as Mail dialog
box appears and you have two options. You can send the whole
report as mail to one or more people. Or, you can send each record
in the report to the e-mail address specified in a field in the record.

Write Report to
File

Choose File>Write Report to File.

Export records

Chose File>Export to export records to a file in Inmagic tagged,
delimited ASCII, or XML format.

Save the search

Choose Sets>Save Set to save the current search results and
criteria.

7. The Query window remains on the screen until you close it. To perform another query,
edit the criteria and execute the new search. To clear the criteria from the window,
choose Search>New Query. Starting a new query closes all record and image windows.
Each time you execute a query, DB/TextWorks re-evaluates all of the search criteria, not
just the criteria you added or changed since you last executed the query.

Interrupting a Query
DB/TextWorks executes most queries almost instantaneously. When a search takes more than
a few seconds, you see an Executing Query progress dialog box. To safely interrupt a query,
click the Stop Executing Query button on the Executing Query dialog box or press the Esc
key.
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Query Screen Syntax (Summary)
You can use these search techniques in the Query window.
To:

Do this:

Find a word or phrase

In a Word indexed field, type the word or phrase. For example, type
urgent or rush order. Or press F3 and paste from the Word index.

Find a term

In a Term indexed field, type the term preceded by an equal sign
(=john smith). Or press F3 and paste from the Term index.

Find parts of items (truncation) Type an asterisk at the end of a word, phrase, or term (tel* finds
telex and telephone repair).
Use comparisons and ranges

Use = < > <= >= : in a Term indexed field. For example, <1998 finds
all dates before 1998. 100:300 finds values between 100 and 300
(inclusive).

Find words near each other

Use the proximity operators w# and p# in a Word indexed field. For
example, red w3 boat finds red within 3 words of boat. Red p3 boat
finds red preceding boat by 3 words or less.

Find a field with anything in it

Type =* in a Term indexed field or type * in a Word indexed field.

Find an empty field

Same as above, but also toggle the Boolean button to NOT.

Include a date variable

Use @DATE to represent the current date (the date on which the
search is performed) in search criteria. You can include date
arithmetic operators. For example, type =@DATE-7 to search for the
date one week before the date on which the search is performed.
@DATE is especially useful for saved queries used in menu screens
(for example, for use on the Web with a WebPublisher product) or
the Saved Queries window.

Use Boolean logic

Type Boolean operators (& / !) between items in a box to represent
AND, OR, and NOT. For example, cars & boats finds records only if
they contain both words (cars and boats). Cars / boats finds records
that contain either word (cars or boats). Cars ! boats finds records
about cars but not boats.
Toggle the AND, OR, NOT button in front of a box to combine
multiple requests.

Execute a query

Press Enter or click the Execute Query button ("Go") in the query
toolbar or choose Search>Execute Query.

Find all records

Click the Find All Records button or choose Search>Find All
Records.

Expand Thesaurus terms

To retrieve records containing preferred or related terms when
searching for a thesaurus term in a field connected to that
thesaurus, use this syntax: = " ~ term"
The leading tilde triggers the expansion. The quotation marks and
equals sign are required. If multiple fields are being searched for the
given term, they will all be searched for the added terms, as well.
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Customizing the Query Screen
There are two methods of customizing a query screen.
Make temporary changes
To make temporary changes to the current query screen, you can add and delete boxes "on the
fly" using Add Query Box, Add Sets Box, or Delete Box on the Search menu. This provides a
quick way of being able to search the desired fields or remove unnecessary boxes without
having to enter the Query Screen Designer. Changes are not saved unless you load the current
screen into the Query Screen Designer and save the screen.
You can add two types of boxes to a query screen using this method: query boxes and sets
boxes.
Use the Query Screen Designer
Use the Query Screen Designer to create permanent, customized screens. The Query Screen
Designer provides all the tools you need to truly customize and save a screen. Besides adding
and deleting boxes, you can move, resize, and format boxes, change label text, change fonts,
add instructions, and make other edits. When you are done, save the screen, then select the
new screen for the Query window.

Query Screen Designer Editing Techniques
Use these features to design screens for queries.
Action

Menu command

Add a box to search fields

Edit>Add>Query Box

Add a box for saved sets

Edit>Add>Sets Box

Add instructions

Edit>Add>Text Box

Add pictures

Edit>Add>Picture Box

Add script buttons

Edit>Add>Script Button

Add a script input box

Edit>Add>Script Input Box

Delete boxes

Edit>Delete Box

Select boxes

UseClick, Shift+click, Tab, Shift+Tab, or drag a lasso, or
Edit>Go to Box, or
Edit>Select All and click the type of box you want to select.

Cut, copy, and paste boxes Edit>Cut, Edit Copy, Edit Paste. To access the Paste Here
command, click the right mouse button to display the shortcut menu.
Change box contents

Tools>Box Properties

Show or hide buttons

Tools>Screen Properties>General

Set button state
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Tools>Box Properties>Labels, or
Click the button to toggle between AND, OR, and NOT; or
Tab to button and press the space bar
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Move boxes

Change box height

Tools>Box Box Properties>Position (change Coordinates or
Offset values), or
Select and drag, or
Select and use the arrow keys, or
Select and use the Ctrl+arrow keys.
Tools>Box Properties>Position (Minimum / Maximum height)

Change box width

Tools>Box Properties>Position, or
Drag resizing handle right or left (only one box can be selected)

Align boxes

Tools>Align Boxes.

Float or anchor boxes

Tools>Box Properties>Position, or
Tools>Align Boxes>Anchor and Top

Borders, labels, scroll bars

Tools>Box Properties>Labels, or
Tools>Box Properties>Font, Color (for text boxes)

Text font and color

Tools>Box Properties>Font, Color, or
Tools>Box Properties>Caption (for script buttons)

Tab Order

Tools>Tab Order

Units

Tools>Screen Properties>General

Grid

View>Grid Settings

Show or hide dashed lines
(while designing)

Check or uncheck View>Boundaries

Prepare a screen for
Internet/Intranet use

Choose Tools>Screen Properties>HTML and/or Tools>Screen
Properties>Logos and/or Tools>Box Properties>HTML and specify
settings. Then use Screen Operations>Export Query Screen to
HTML.

Prepare a screen to search Use Tools>WebPublisher Multiple Textbase Query to specify
multiple textbases
textbases, select forms, and create a field name map.
Print a screen definition

Screen Operations>Print Definition

Save a screen

Screen Operations>Save Query Screen

Close Query Screen
Designer

Screen Operations>Close Query Screen Designer

Query Screen Properties
When designing a query screen, choose Tools>Screen Properties to specify options that
apply to the query screen. The Query Screen Properties dialog box contains the following tabs:
General: Show or hide query buttons, set background color, specify units.
Logos: Add images to a query screen to be used on the Web. The images will only
appear in the exported HTML page for WebPublisher PRO.
HTML: Specify properties for a query screen to be used on the Web. The properties only
apply to the exported HTML page for WebPublisher PRO.
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Scripts in Forms or Screens
When you are designing a form or screen, you can also design a script for use with that form or
screen. The script can perform certain operations when the form or screen is opened or closed,
when buttons on the form or screen are clicked, when you leave a box, or in other situations.
For example, a script can fill in a box on a query screen or perform extra validation on the
contents of a field in an edit form. You can use script buttons to bring up field-specific help on an
edit form, open a document in its native application from a record display, or move or copy
information among boxes on a form. You can write scripts in either JavaScript (JScript) or Visual
Basic Scripting Edition (VBScript).
To open the Form Script dialog box so that you can create a script for the form you are currently
designing, choose Tools>Form Script.
To open the Screen Script dialog box so that you can create a script for the menu screen or
query screen you are currently designing, choose Tools>Screen Script.
Important! A script is part of a form or screen. If the form or screen closes, the script stops
running. This means, for example, that a script running in a query screen cannot perform a
search, open the Edit window, and then make changes in the record in the Edit window.
Also note that a script can only work within its DB/TextWorks desktop session through the
objects documented in this help file. The DB/TextWorks desktop session has no knowledge of
what is happening inside a script.
Important! Scripts are not applicable to forms and screens used on the Web with WebPublisher
PRO.

Query Choices Browser
The Query Choices Browser displays information that you can paste as search criteria. Pasting
is often quicker and more accurate than typing. To access this dialog box, press F3 from the
query screen or Command Query window, or choose Edit>Browse Choices, or click the
Browse Choices toolbar button.

What the Dialog Shows
With the cursor in a query box on the query screen. The dialog box shows the Term
or Word index for each field searched by the current box, or the thesaurus connected to
a field. The Term or Word index is actual indexed information from the textbase. Pasting
information normally guarantees a match, so you will find the records you want.
Note: If you are viewing the Word index for a text-like field (that is, a field that is not a
Number or Date field), the Choices List will automatically scroll past any numeric entries
to the first alphabetic entry.
With the cursor in a sets box on the query screen. The dialog box shows a list of
saved sets, which you can combine with other criteria.
With the cursor in the Command Query window. The dialog shows the Term or Word
index for each indexed field in the primary and all secondary textbases, or the thesaurus
connected to a primary field. This provides an easy way of building Command queries.
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Dialog Box Options
Find. To quickly find an entry, type one or more characters in the Find box. For
example, type p to move to Plymouth Prowler, and then type o to move to Porsche. To
move to an entry that starts with different characters, delete the characters in the Find
box and type new characters.
Choices List. For a Terms List or Words List only, the number at the beginning of each
line indicates the number of records that contain the word or term shown. Because the
word or term may appear more than once in each record, this number does not reflect
the total number of occurrences in the textbase. Thesaurus entries do not include this
information.
Note: If the textbase is large, the administrator may have turned on an option which
omits the number of hits for each key to improve performance.
To paste a term or word into a query box, double-click an item in the Choices List, or
select an item and click Paste. Pasted terms or thesaurus entries are preceded by an
equal sign (=), to indicate a Term search. If the query box already contains query criteria,
pasted items appear after the existing items, preceded by a forward slash (/), which
represents Boolean OR.
Note: When you browse a sets box, the Choices List shows the names of saved search
sets. The number in square brackets after the set name indicates the number of records
in the set.
Number of entries pasted. Shows the number of entries that you just pasted into the
current box. Resets to zero when you click in a different box.
List Shows. If the field is both Term and Word indexed, you can specify which index you
want to see: Select the Terms List option button to see every term in this field in the
textbase, or select the Words List option button to see every word in this field in the
textbase (except stop words). If the field has a thesaurus connected to it, select the
Thesaurus option button to see all its entries. The List Shows options are disabled when
browsing a sets box.
Note: When a field has a Word index but no Term index and has a thesaurus connected
to it, the thesaurus entries are also not available (meaning the Words List option button
is available on the Query Choices Browser but Terms List and Thesaurus are not).
Fields that have only a Word index do not support = searches.
Field. If the query box searches multiple fields, you can specify which field's index(es) or
thesaurus you want to see by using the Field drop-down list.
Note: Regardless of which field you use to paste into the query box, all fields in that box
are searched. If the query box contains a field from a secondary textbase, the field is
indicated by the @ character (for example, Description@Name) and the Choices List
shows terms from the secondary textbase.
The Field drop-down list is disabled when browsing a sets box.
Note: The Inclusive Search Option (Tools>Options>Search) controls how a search for
an intersection of terms operates across multiple fields within one query box.
Paste. Click the Paste button to paste the selected item from the Choices List into the
query box. Pasted terms or thesaurus entries are preceded by an equal sign (=), to
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indicate a Term search. See Choices List for more information. Note that if you paste a
thesaurus term with a USE reference, the preferred term is pasted.
Properties. If you want more information about a thesaurus entry, click the Properties
button to open the Thesaurus Entry Properties dialog box.
Search. If you want to search the thesaurus textbase connected to the field, to display a
shorter list of terms, click the Search button to open the Search Thesaurus dialog box.
Print List. To print the current index or thesaurus or save it in a text file, click the Print
List button and select the desired options in the Print dialog box. Be sure to select the
Print to file check box if you want to create a text file, then name the file when
prompted. Print List prints or writes out the entire index, thesaurus, or list of saved sets,
not just the section that is currently displayed in the Query Choices Browser. The
printout includes information such as the current date and time, type of index or
thesaurus, field name, and total number of keys (words or terms) in the index (for an
index only, not for a thesaurus). Note that printing a thesaurus from this dialog box
produces a list of preferred terms and non-preferred terms with USE references. Other
cross-references (for example, BT, RT) are not included. If you want to print a more
complete thesaurus listing, open the thesaurus directly, submit a search, and use one of
the provided forms to print.

Selecting a Query Screen
Select the query screen that you want to appear in the Query window. The selected screen will
be used until you choose a different one or revert to the default query screen.
Screens are listed alphabetically (Basic screen first, then screens saved in the user file, and
then screens saved in the textbase file, which are indicated by the word (public)). If no query
screens have been created, the Basic screen is the only one that appears in the list.
To select a query screen
Choose Search>Select Query Screen, or click the Select Query Screen button in the
Query window toolbar. To use the textbase default query screen, click the Revert to
Default button instead of selecting a screen from the list.
To select a default query screen
Choose Maintain>Change Textbase Defaults>Query Screen. If the textbase has
passwords, this option is disabled unless you are using the Master password.
To resize the window
To quickly resize a window after selecting a different query screen, choose Window>Fit
Window to Form or click the Fit Window to Form toolbar button.

Exporting Query Screens to HTML
Before you can use a query screen on the Web, you must export it to HTML.
To export a query screen to HTML.
1. In the Query Screen Designer, open the query screen you designed for use on the Web.
2. Choose Screen Operations>Export Query Screen to HTML.
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3. A message box appears asking if you want to use Cascading Style Sheets (CSS) to
preserve formatting. Click Yes to preserve formatting (such as, box position and box
background color); click No if you want WebPublisher PRO to use simple HTML to
format the screen (for example, all boxes will appear left-justified).
4. A message box asks if you want to use Alternate Search Syntax in this query screen.
Click Yes to enable users to type the words they want to find without Boolean AND
symbols (&). Click No if you want to use the original WebPublisher PRO query syntax.
5. On the Save File As dialog box, name the file when prompted and click Save.
6. Click OK to dismiss the completion message.
Notes about Exporting Query Screens to HTML
Buttons labeled Submit Query and Reset, and a Help icon are added automatically
during the export.
Sets boxes, script input boxes, and script buttons added in the Query Screen Designer
are not exported.
Tab Order specified in the Query Screen Designer is preserved during the export.
You can put the resulting HTML page anywhere accessible to the HTTP server. Be sure
to provide clients with a way to access the page, for example by providing a link on your
home page that jumps to the HTML search page.

Performing Command Queries
Command queries are an alternative to using the Query window. You type the query as a
command statement, using a particular syntax. Command queries allow all of the same
operations as queries (Boolean, range, comparison, word and term searching, and so forth), but
you can also perform searches that are not possible using the Query window (for example,
complex nested Boolean queries).
To perform a command query
1. Choose Search>Command Query to open the Command Query dialog box.
2. Type a command using the Command query syntax or press F3 to select items from a
list. Using F3 eliminates guesswork because you can browse and paste actual indexed
words and terms.
3. To execute the query, press Enter or choose Search>Execute Query or click the
Execute Query button on the Command Query window toolbar.
Tip! A good way to learn the Command query syntax is to type criteria in the Query window
then open the Command Query window (choose Search>Command Query). This converts the
query to its Command query equivalent. You can toggle between the two Query windows by
choosing Search>Query Screen or Search>Command Query.
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Command Query Syntax (Summary)
Choose Search>Command Query, then use these search methods. For more information, see
the complete Command Query Syntax.
Search method

Examples

Contains word or phrase

subject ct fax
subject ct fax machine

Proximity (p# or w#)

red p3 boat finds red preceding boat by 3 words or fewer.
red w3 boat finds red within 3 words of boat.

@DATE

due date=@DATE-7:@DATE

Equal to (exact match)

subject =local area networks
corporate author =john smith / =fred jones

Greater than
Greater than or equal to
Less than
Less than or equal to

date >2008
price >=500
date <1-Jan-2010
last name <=miller

Within range (:)

founded =1998:2010 OR founded ct 1998:2010
(equivalent methods)

Truncation (*)

description ct pric* w3 manufactur*

Boolean AND OR NOT

ingredient ct chocolate & nuts
ingredient ct chocolate / nuts
ingredient ct chocolate ! nuts
company = models inc / = toys ltd
author / recipient = john smith
author / recipient ct smith & jones
type=memo and author/recipient = smith not description ct pricing

Find all records

findall
findall not author ct smith
findall not author =* (records with empty Author field)

Saved search sets

{2010 invoices}

Secondary textbase fields description@name ct auto* & cam*
(searches "Description " field in secondary textbase)
"date and time"@customer id <15-Jan-2010
(searches "Date and Time" field in secondary textbase)
Press F3

Browse and paste entries from Word and Term indexes

Find deferred records

getdeferred new
getdeferred modified
get deferred new modified deleted
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Command Query Syntax (Complete)
Choose Search>Command Query to search with commands. A Command query consists of
one or more search statements connected with Boolean commands (AND, OR, NOT), optionally
beginning with the word FIND. For a Quick Reference, see Command Query Syntax
(Summary).
A good way to learn the Command syntax is to specify criteria in the Query window, then open
the Command Query window. The query will be converted to its Command equivalent.

Command Query Syntax
Search Statements

Explanation

field-name(s) search-relation searchitems
Examples:
author =john smith / =fred jones
order date <2009
description ct pric* w3 manufactur*
author/recipient ct smith

The field name is equivalent to a query box that
searches a field. The search relation and search items
are equivalent to the information that you would type in
a query box (except that you must include the CT
relation when doing a word, phrase, or proximity
search). Follow the same guidelines as you would
when constructing a query.

FindAll

Finds all records in the textbase. Can be followed by
NOT statements.

{saved-search-set}
Example: {2008 invoices}

To include a set in the search criteria, type the name of
a saved set surrounded by curly braces. You can use
Boolean symbols (& / !) to join multiple set names, and
you can combine set names with other criteria.

getDeferred [options]
Example: getdeferred new modified

Finds records that were added, changed, or deleted
using Deferred indexing. Must be followed by any
combination of the words new, modified, deleted.

Command Query Methods
You can use the following methods when you construct a Command query.
Use F3 (Browse Choices) to build the query.
Include or omit the word FIND preceding a search command.
Place each statement on a separate line using Ctrl+Enter.
Use single or double quotation marks to surround a field if the field name contains a
word that might be misinterpreted as part of the search syntax. For example, the
following command searches a field called Date and Time.
"date and time" <15-Jan-2009

It is never wrong to enclose a field name in quotation marks, even if the name consists of
only one word. If you prefer, you can always use quotation marks, which aid in clarity and
help avoid ambiguity. You can also use quotation marks for clarity in search items. For
example, to find the phrase up and down without having the word and interpreted as a
Boolean command, place quotation marks around the phrase:
subject ct "up and down"
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Use Boolean logic (AND, OR, NOT) between search statements and Boolean symbols
(&, /, !) between field names or search criteria.
Use search relations (CT, =, >, >=, <, <=, :) to describe a relationship. For example, type
subject ct invoice to search the Subject field for the word invoice. Type price >500 to
search the Price field for values greater than 500.
Use proximity operators (w# and p#) to find words near each other. Proximity operators
are used with CT (for example, subject ct blue w3 bird or subject ct red p2 bird).
Use @DATE to include the current date (when the search is executed) in the query
criteria.
Use the truncation character (*) to find word stems (for example, subject ct tele*) or to
truncate terms.
Search fields in linked textbases as well as in the primary textbase.
Use parentheses for clarity or to influence evaluation order.
Use any combination of uppercase or lowercase letters. The only time that case is
significant is when you are specifying search items in a Code field.
Incorporate saved sets in your search.
Toggle between the Query and Command Query windows, to see how the same query
appears in each window.
Search for records with deferred updates, and combine them with other criteria.

Building Command Queries Using F3
Typing search criteria in the Command Query window can be fast and efficient, if you know the
field names and information that you want to search for. To make building Command queries
even easier, you can use the Query Choices Browser to paste search criteria into the Command
Query window. The Query Choices Browser shows indexed fields from the primary textbase and
any secondary textbases. Primary textbase fields are listed first.
To build a Command query using F3
1. Choose Search>Command Query to open the Command Query window.
2. Press F3, choose Edit>Browse Choices, or click the Browse Choices toolbar button on
the Main window to open the Query Choices Browser. The Query Choices Browser
shows the index for the first indexed field defined in the textbase structure.
3. Select the field you want to search from the Field drop-down list.
4. In the List Shows group, select either the Terms List or Words List option button,
depending on whether you want to see the field's Term or Word index. You can switch
between the indexes, as needed. Note that some fields may not have both indexes, so
one of the options may be unavailable.
Note: If you are viewing the Word index for a text-like field (that is, a field that is not a
Number or Date field), the Choices List will automatically scroll past any numeric entries
to the first alphabetic entry.
5. Select an item from the Choices List and click Paste to paste it into the Command Query
window. (You can also double-click the word or term to paste it.)
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Note: To find and select items in long lists, type one or more characters in the Find box.
To paste the item, double-click it or click Paste or press Enter.
Both the field name and the word or term are pasted into the Command Query window.
Pasted terms are preceded by an equal sign (=) to tell the software to search for an exact
match. If the first item that you paste is a word, it is preceded by CT. If you paste multiple
words or terms, each item after the first is preceded by a forward slash (/), representing
Boolean OR.
6. To include another field as part of the search criteria, select a different field from the
Field drop-down list, then paste one or more words or terms into the Command Query
window. Each additional field that you search is preceded by the Boolean AND
command. You can change the AND to an OR or NOT, to specify how the search
statement should be combined with previous criteria.
7. The Query Choices Browser remains open until you close it or execute the query. To
close the dialog without executing a query, press Esc while the dialog box is active or
click Close.
8. To execute the query, click the Execute Query button in the Command Query window
or choose Search>Execute Query. If the Command Query window is active, you can
also press Enter to execute the query.
Note that the Command Query window cannot contain more than 4000 characters. If you
attempt to type or paste more than 4000 characters, the software produces beeps (if sound is
enabled on your computer).

Advanced Search Topics
Searching a Textbase that Contains Link Fields
A textbase that contains a Link field is called a primary textbase. The presence of a Link field
indicates that the textbase is linked to a secondary textbase. To see if the current textbase
contains a Link field, and to see the name of the secondary textbase and associated field,
choose Display>Textbase Information.
When a primary textbase is open, you can search any indexed fields in the primary or
secondary textbase. Records retrieved by a search are always from the primary textbase, even
when you search a field from a secondary textbase.
For more information, see Searching Secondary Textbase Fields.
Example
You have two textbases:
Orders contains information about orders placed with your company. Includes a Link
field called Customer ID.
Customers contains names and addresses of customers. Includes an associated field
called Customer ID.
The Customer ID field in Orders is linked to the Customer ID field in Customers. When
information in this field is the same in both textbases, a link is made for that record, and
information about that secondary record is accessible from the primary textbase.
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Now you want to know how many orders were placed by customers in New York. Open the
primary textbase, Orders, and search the secondary textbase for NY to find customers in New
York. You do this by typing criteria in a box that searches the State field in the secondary
textbase.
DB/TextWorks searches the State field in the secondary textbase for NY. It finds four customers
in New York, and remembers their Customer IDs. DB/TextWorks then searches the Customer
ID field in the primary textbase for records with a matching ID (orders placed by any of these
four customers). Three such orders are found. Those three orders make up the set of retrieved
records.
The following illustration shows how the search takes place. As you can see, there is not
necessarily a one-to-one correspondence between information in linked textbases. Records in a
secondary textbase might be referenced by zero, one, two, or more records in the primary
textbase.

Records that are found can be displayed in the Report window. The form that is selected for the
Report window determines which fields are shown from the primary and secondary textbases.
The current query screen determines which fields can be searched. To search fields from a
secondary textbase, use a query screen that contains boxes that search fields from a secondary
textbase. The Basic Query Screen does not show fields from secondary textbases. You can add
one or more boxes to the Basic Query Screen and save the screen under a new name.
The current query screen also determines how fields are labeled. By default, boxes that you add
to search fields from a secondary textbase are indicated by the @ symbol. However, you can
use the Query Screen Designer tools to change these labels.

Browsing Secondary Textbase Fields
When you search a textbase that contains a Link field, you can browse and paste from the Link
field just as you would browse and paste from any field in the primary textbase. You can also
browse and paste from the indexes of fields in secondary textbases. If you paste an item from
the browse list for a secondary textbase field, you will find records (if any) in the primary
textbase with links to secondary textbase records which meet the criteria.
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For example, to see information about orders placed with The Model Company, browse fields in
the primary textbase (Orders). To see information about customers, browse fields in the
secondary textbase (Customers).
When you browse a secondary textbase field, remember that the number in front of each word
or term in the Query Choices Browser indicates the number of times that the word or term
appears in the secondary textbase. This number will often differ from the number of records
retrieved when you search for that item, because you are retrieving records in the primary
textbase.

Searching Code and UDC Fields
Code fields retain case in the Term and Word indexes. They also retain punctuation in the Term
index. When you search a Code field, the search criteria must exactly match the record
information as indexed. If you do not capitalize letters correctly or include the proper
punctuation, you will not find the record. For example, a search for abc will not find ABC and a
search for =A 123 will not find =A-123.
UDC fields retain punctuation in the Term index, so punctuation is significant when searching.
Note that truncation searches are allowed in either field type. For example, a search for A* will
find both ABC and A-123.
If you want an asterisk, backslash, or quotation mark to be interpreted literally, precede it with a
backslash. For example, to search for ab* type ab\*. If you omit the backslash in this example,
the software interprets the asterisk as a truncation symbol. If you type a single backslash and
follow it with anything other than an asterisk, backslash, or quotation mark, the backslash is
ignored. For example, a search for on\line finds online.
Code and UDC fields often include characters that the software interprets as having special
meanings. These characters include the Boolean symbols (& / !), comparison and range
indicators (<> = :), and proximity operators (w# and p#). To search for these characters without
having them misinterpreted as part of the search syntax, place quotation marks (' ' or " ") around
the search item. For example, type "A/Z" to search for A/Z without having the forward slash
interpreted as a Boolean OR. If you are doing a Term search, do not include the equal sign in
the quotation marks. For example, search for ="A/Z".
Note that although Boolean symbols such as & are treated as standard characters when they
appear inside a quoted item, the same is not true of asterisks. Asterisks at the end of words
inside quoted items still signify truncation. To search for the literal asterisk character, precede it
with a backslash.
A good way to ensure that you find the desired records when searching a Code or UDC field is
to press F3 to browse and paste from the indexes. When you paste information from a Code or
UDC field index, the software includes any necessary quotation marks or backslashes.
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The following table provides several examples for how to search Code and UDC fields. In the
last example, note that the UDC listing 622.341.1-78 does not contain any characters that can
be misinterpreted, therefore quotation marks and a backslash are not necessary.
To find

In a

Search for

d52-60

Code field

d52-60 or do a truncation search for d5*

ABC*

Code field

=ABC\*

017:63

UDC field

"017:63"

431.3"2"

UDC field

431.3\"2\"

339.5(931)

UDC field

"339.5(931)"

629.12(*58)

UDC field

"629.12(\*58)"

622.341.1-78

UDC field

622.341.1-78

Searching for Numbers
Numbers can be treated two different ways in the DB/TextWorks indexes: as numeric quantities
or as alphabetic words. Treated numerically, they file according to the number they represent: 2,
12, 100. Treated alphabetically, they file as words: 100, 12, 2.
Numbers are always indexed alphabetically in a Word index. Their treatment in a Term index
depends upon field type and Special Filing options. In Number, Computed Number, Automatic
Number, or Text fields using default filing options, numbers are filed numerically. (Also, negative
numbers file before zero in Number or Computed Number fields only. Otherwise, the negative
symbol is ignored.)
You can use truncation to search for numbers filed alphabetically. For example, you can search
the Amount field for 35*. However, truncation does not work with numbers filed numerically. For
example, the search =35* will not find 357.
The comparison operators (>, >=, <, <=) also function differently depending on how the number
is filed. In a Number, Computed Number, or Automatic Number field, -20 is less than 3. In a
Text field using default filing options, -20 is treated like 20, which is numerically greater than 3.
In a Text field using alphabetic number filing, -20 is treated like 20, which is alphabetically less
than (before) 3.

Searching for Dates
DB/TextWorks is flexible when searching for dates. The format you use in a query can differ
from the format stored in the textbase, and retrieved dates may include day names or trailing
text. For example, a search for June 2009 finds these entries:
June '09
June 3, 2009
JUN-2009
2009, June
Tuesday, June 23, 2009 meeting with Sales staff

Do not use a forward slash to separate date components in a query (3/4/2009). The slash is
interpreted as a Boolean OR symbol and will not find the right records. Instead, use spaces,
quotation marks, or punctuation that cannot be mistaken for Boolean symbols (do not use & / !):
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3 4 2009
3-4-2009
"3/4/2009"

Note: A setting in the INMAGIC.INI file determines whether spaces are required around a
Boolean or range symbol (for example, whether you should search for ant / bee or ant/bee. For
more information about this issue in Boolean and range searches, see Spaces around Search
Symbols.
Avoid using word, phrase, proximity, and truncation searches in Date fields, except to find
alphabetic information in trailing text after dates.
To include the current date in a calculation that retrieves records based on dates, use @DATE.
You can add or subtract a number to represent an offset from today's date. For example, the
following search would retrieve records created on the date one week prior to the date the
search is performed. This type of search is particularly useful if you are saving the query to be
performed again on a different day (for example, a saved query specified as an initial action in a
menu screen).
=@DATE-7

Searching for Full or Partial Dates
To find all dates in a certain month or year, type the partial date in any recognizable format. To
find a particular date with or without trailing text, include the month, day, and year as part of the
criteria. To retrieve only the date you specify, precede the date with an equal sign (=).
This search
2009

Finds
All full or partial dates in 2009 (year, month and year, day month and year)

October 2009

All dates in October 2009

Oct 10 2009

That date with or without trailing text

=2009

That year alone

=October 2009

Dates that contain that month and year, but no specific dates

=Oct 10 2009

That date with no trailing text

=@DATE-7

The date one week before today

To search for the current date, press F4 or choose Edit>Insert>Current Date or type @DATE.

Finding Dates Before and After Other Dates
To find a date before or after another date, use <, <=, >, or >=. When used with a partial date,
these operators search from the beginning of the date item (first day of the month or first day of
the year). For example, <June 2010 finds all dates before June 1, 2010.
If dates in the textbase have trailing text or the textbase contains a mixture of full and partial
dates, use < and >= rather than > or <=. For example, a search for >Oct-23-2010 ("greater than
Oct 23, 2010") finds the date October 23, 2010 only if it contains trailing text. To include Oct-232010 without trailing text in your search results, search for >=Oct-23-2010 instead.
The following examples show how different operators affect a search.
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This search

Finds

>Oct-10-2010

October 10, 2010 sent letter

>=Oct-11-99

All dates on or after October 11, 1999

>Oct 2010

All dates on or after October 1, 2010, but does not find "Oct 2010"

>=Oct 98

All dates on or after October 1, 1998, including "Oct 98"

<2007

All dates before January 1, 2007

Note: If the 2-digit Years option is set to 1901 or greater (default is 1940), a search for >0 in a
date field will retrieve dates after the year 2000 (>January 1, 2000). To retrieve all records with
contents in a date field, use =* rather than >0.

Finding Dates within a Range
To find dates that fall within a particular range, use a colon (:). The software finds all dates in the
range, including both ends of the specified range. When you indicate a partial date,
DB/TextWorks uses the beginning of the low date and the end of the high date.
This search

Finds

25-Mar-2010:28-Mar2010

All dates that fall within the range (inclusive)

Oct 2009:Dec 2009

All dates in the fourth quarter of 2009 (inclusive)

2009:2010

All dates from January 1, 2009 through December 31, 2010
(inclusive) as well as either year alone

@date-7:@date

All dates within the past week

Converting a Form to a Query Screen
You can use an existing Record form (any form designed for the Display or Edit window) as the
basis for a query screen.
Method #1: Open an Existing Record Form in the Query Screen Designer:
1. Use one of the following methods to access the Open Query Screen dialog box:
Choose Search>Design Query Screen.
In the Query Screen Designer, choose Screen Operations>Open Query Screen.
2. From the Start With list, select Existing Record Form, then select a form from the
Currently Saved list and click OK.
The form is copied and converted to query screen format and loaded into the Query Screen
Designer, where you can edit and save it.
Content information and formatting that is not supported in the Query Screen Designer, such as
added text, item numbering, calculations, and variables, is removed during the conversion. You
will almost certainly need to make some changes in the Query Screen Designer after the
conversion.
For example, Boolean query buttons do not appear until you select the option by choosing
Tools>Screen Properties>General. Depending on the form you started with, you may also
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want to use the Labels tab on the Box Properties dialog box to show borders, labels, and scroll
bars, and to make sure that the labels clearly indicate which fields will be searched.
Method #2: Copy and paste boxes from a form to a query screen:
1. Open a form by choosing Display>Design Form. In the Start With list in the Open
Form dialog box, select Existing Form and then select the form you want to open from
the Currently Saved list. Click OK.
2. Select the boxes on the form that you want to replicate in the query screen.
3. Choose Edit>Copy. Close the Form Designer by choosing Form Operations>Close
Form Designer.
4. Choose Search>Design Query Screen. In the Start With list in the Open Query Screen
dialog box, select Blank Query Screen. Click OK.
5. Choose Edit>Paste. DB/TextWorks pastes the boxes from the form into the query
screen.
6. Save the query screen and close the Query Screen Designer.
Note: When using a Blank Query Screen as your design starting point, Boolean buttons are on
by default, so your layout may be altered to make room for the buttons. Also, if you paste boxes
with content (such as, variables and/or calculations) into a Blank Query Screen, they will be
emptied out. This means they may appear in the designer, but not when you use the query
screen.
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Sorting Records
You can sort and subsort records to make them appear in a logical order in reports and when
exporting records. You can use a variety of sort options to order the records precisely the way
you want. For example, you could sort records alphabetically by name, then subsort by region,
then by date in reverse chronological order. If you do not sort records, they appear in the
approximate order that they were added to the textbase.
There are several ways to apply a sort:
After a search. Do a search, then choose Display>Sort Report. This is called a userspecified sort. You can change it at any time, to sort the records in a different order.
As part of a form. This is called a compulsory sort. It is defined as part of a form, and is
typically used when a report contains calculations or subtotals that rely on a specific sort
order. If you do not like the sort order, select a different form for the Report window.
While the form is in use, that is the only way records can be sorted. You cannot
sort records in any other way unless you select a form that does not have a compulsory
sort.
As the textbase default. A sort that is defined in the textbase structure, and which is
used only when no other sort is specified.

Sort Options
Select sort options to determine record order in reports.
Use. Select an option button from the Use group to specify whether to use the sort order
specified by you, sort in descending order of relevance, use the textbase default sort, or
revert to unsorted order.
Note: If you are defining a Textbase Default Sort, you can specify your own sort method
or sort records in descending order of their relevance. The textbase default sort and the
unsorted order methods are not available.
Available Fields and Sort Fields. To indicate which field to sort on, select a field in the
Available Fields list and click the right arrow button (>) to move it into the Sort Fields list.
Repeat to specify subsorts. Use the Change Order buttons to move a field in the Sort
Fields list up or down (affects the sort order).
To change or undo a sort, select a field in the Sort Fields list and click the left arrow
button (<) to move it back into the Available Fields list. Use the double arrow button (<<)
to remove all fields from the Sort Fields list.
Sort in Reverse Order. Optionally, sort the currently selected Sort Field in reverse order
(Z to A, highest to lowest value, or most recent to oldest date).
Exploded Sort. (Not available when defining a textbase default sort.) Optionally, select
the Exploded Sort check box for the currently selected Sort Field, so the record will
appear in the report multiple times (once for each entry in the sort field). Without an
exploded sort, each record appears only once, sorted by the first entry in the sort field.
Note: The Exploded Sort option is ignored for a form used on the Web (DB/Text
WebPublisher), because it can change the perceived number of records retrieved.
However, if you set the WebAllowExplode=1 option in the DBTWPub.INI (or
ICSWeb.INI) file to permit exploded sorts, all records are displayed on one page to avoid
paging issues when changing the perceived number of records in the report.
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Primary Sort Field Options. Optionally specify what should occur if a sort field is
empty.
Interfile. (Not available when defining a textbase default sort.) Optionally, interfile up to
five fields with the primary sort field. The Interfile option is ignored for a form used on the
Web (DB/Text WebPublisher), because it can change the perceived number of records
retrieved.

Notes
Textbase filing options (textbase structure) also affect sort order.
If the form being used has a compulsory form sort, your sort will be ignored.
If the textbase has a textbase default sort, you can use the sort options to temporarily resort the records.

Sorting Records after a Search
You can sort records after you do a search or load a set. This is called a user-specified sort.
The sort determines the order in which records appear in the Report window and printed
reports. The sort remains in effect until you close the textbase or sort again.
Note: If the form in use has a compulsory sort, your user-specified sort will be ignored.
To sort records after a search
1. Perform a search or load a set.
2. Choose Display>Sort Report to open the Specify Sort Order dialog box.
3. Select the sort method you want to use from the Use group:
Sort Order Shown Below. Uses the sort you specify in this dialog box.
Relevance-Ranked Order. Sorts records in descending order of their relevance,
with the most relevant records appearing first. For example, if you search for the
word computer, the records with the most instances of the word will appear first,
followed by records with fewer instances, in descending order. Note that relevance
ranking can be used with word, phrase, and proximity searches, but it is not
applicable to term searches. If the Relevance-Ranked Order option is selected
and cannot be applied, records will display in unsorted order.
Textbase Sort Order. Reverts to the default sort order.
Unsorted Order. Speeds up the report display, if you do not care whether records
are sorted.
4. If you selected Relevance-Ranked Order, Textbase Sort Order, or Unsorted Order,
the remaining selections in the Specify Sort Order dialog box are disabled. Click OK to
confirm your sort order selection.
5. If you selected Sort Order Shown Below, select a field in the Available Fields and click
the right arrow button (>) to move the field into the Sort Fields list. The field at the top of
the Sort Fields list is the primary sort field (Sort Level 1). You can subsort by up to four
more fields (Sort Levels 2-5). This is a way of doing more refined sorts, such as
alphabetically by region, then by name. You can use the Change Order buttons to
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reorder the fields and use the left arrow button (<) or double left arrow button (<<) to
remove fields.
Optionally, specify the sort options you want.
Click OK.

Compulsory Form Sort
A compulsory form sort is one that is defined as part of a form. When that form is used for a
report, that is the only order in which records can appear. Avoid compulsory form sorts except
when necessary, because they prevent records from being sorted in any other order.
Typically, you use a compulsory form sort when a report includes a Sort Header or Sort Footer
that depends on a specific sort order. For example, if a report contains subtotals that require a
sort on a specific field (such as Total Sales by Region), a compulsory form sort will prevent the
records from being sorted in any other order. Compulsory form sorts are also commonly used
for forms designed for printing, such as mailing labels, which you always want sorted by ZIP
Code.
Important! For more information about specifying a sort as part of a form, read about Sort
Keys.
To define a Compulsory Form Sort
1. Open the Form Designer and open the desired form (Display>Design Form).
2. Choose Report Options>Compulsory Sort.
3. Select the sort method you want for the form from the Use group:
Sort Order Shown Below. Uses the sort you specify in this dialog box.
Relevance-Ranked Order. Sorts records in descending order of their relevance,
with the most relevant records appearing first. For example, if you search for the
word computer, the records with the most instances of the word will appear first,
followed by records with fewer instances, in descending order. Note that relevance
ranking can be used with word, phrase, and proximity searches. It is not applicable
to term searches. If the Relevance-Ranked Order option is selected and cannot be
applied, records will display in unsorted order.
Textbase Sort Order. Reverts to the default sort order.
Unsorted Order. Speeds up the report display, if you do not care whether records
are sorted.
4. If you selected Relevance-Ranked Order, Textbase Sort Order, or Unsorted Order,
the remaining selections in the Specify Sort Order dialog box are disabled. Click OK to
confirm your sort order selection.
5. If you selected Sort Order Shown Below, define the compulsory sort by choosing
options from the Sort Specification group. Select a field in the Available Fields and click
the right arrow button (>) to move the field into the Sort Fields list. The field at the top of
the Sort Fields list is the primary sort field (Sort Level 1). You can subsort by up to four
more fields (Sort Levels 2-5). This is a way of doing more refined sorts, such as
alphabetically by region, then by name. You can use the Change Order buttons to
reorder the fields and use the left arrow button (<) or double left arrow button (<<) to
remove fields.
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Optionally, specify the sort options you want.
Click OK.
Save the form (Form Operations>Save Form).

Textbase Default Sort
You can specify a default sort order for records to appear in reports if no other sort is specified.
For example, you might sort alphabetically by last name, chronologically by date, or by the
relevance of the records. You are not limited to the textbase default sort order, as you can sort
records after a search by choosing Display>Sort Report, and you can still define sorts for
forms.
To define a Textbase Default Sort
1. Choose Maintain>Edit Textbase Structure.
2. In the Edit Textbase Structure dialog box, click the Sort Order button.
3. In the Specify Textbase Sort Order dialog box, select a sort method from the Use group.
Sort Order Shown Below. Uses the sort you specify in this dialog box.
Relevance-Ranked Order. Sorts records in descending order of their relevance,
with the most relevant records appearing first. For example, if you search for the
word computer, the records with the most instances of the word will appear first,
followed by records with fewer instances, in descending order. Note that relevance
ranking can be used with word, phrase, and proximity searches. It is not applicable
to term searches. If the Relevance-Ranked Order option is selected and cannot be
applied, records will display in unsorted order.
4. If you selected Relevance-Ranked Order, the remaining options on the dialog box are
disabled. Click OK to confirm you sort order selection.
5. If you selected Sort Order Shown Below, define your sort by choosing options from the
Sort Specification group:
Select a field in the Available Fields list and click the right arrow button (>) to
move it into the Sort Fields list. You can subsort on up to four additional fields,
but this is not recommended for a textbase default sort, because it can slow
down the display.
[Optional] Select the Sort in Reverse Order check box to have the selected field
sorted in reverse order (Z to A, highest to lowest value, or most recent to oldest
date).
[Optional] Click the Primary Sort Field Options button to specify what should
occur if the primary sort field is empty.
Click OK.

How to Determine if a Sort Exists Currently
Follow the steps below to find out if a sort applies to the current Report window or printed report.
To determine if a textbase default sort or user-specified sort exists
1. Choose Display>Textbase Information to open the Textbase Information window.
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2. Scroll down to the Textbase Defaults section. Or choose Edit>Find, type the word sort
in the dialog box, then click the Find Next button.
3. The sort fields, if any, are listed in the Textbase Defaults and Currently in Use sections.
If no sort exists, the word <none> appears.
To determine if a compulsory form sort exists
If a form has a compulsory form sort and you want to know which fields make up the sort, use
this procedure to print the form definition.
Tip! If you are working in the Form Designer, you can choose Report Options>Compulsory
Sort in the Form Designer to determine if a sort exists, rather than use this procedure.
1. Choose Maintain>Manage Textbase Elements.
2. Choose a form from the Currently Saved list, then click Print.
3. Select the appropriate options in the Print dialog box, then click OK. Click Close.
4. The sort fields, if any, are listed in the Compulsory Form Sort Order section near the end
of the form definition. If no sort exists, the words <none specified> appear.

Notes about Sorting
The purpose of a sort is to group information and/or assist the person who will be
navigating through the report. It is not helpful to sort by a field that does not appear in
the report--either explicitly or as a Sort Key.
The software follows this sorting order: First it does the compulsory sort for the selected
form (if any), then it does the sort for the current user-specified sort, specified using Sort
Report (if any), then it does the textbase default sort (if any), finally the unsorted order.
If a sort includes an exploded sort, alternate primary sort fields, or interfiled fields, you
should use Sort Keys as box contents because they extract the appropriate field or field
entry.
If a form has more Sort Header/Footer levels than there are Sort Key fields defined, the
additional Sort Header/Footer levels do not appear in the report.
The records in a set are not actually sorted until they are displayed in the Report window
or printed in a report. If you display or edit a record before displaying the report, the
records will not appear in sorted order in the Display or Edit windows.
For sorting purposes, DB/TextWorks uses approximately 250 characters of the
combined primary sort field and subsort fields. For example, if you sort by a long Name,
subsort by a long Title, and subsort next by Volume Number, the combined sort fields
may exceed the character limit before the sort reaches the Volume Number.
If Options are set so that new versions of records with deferred changes appear in
reports, then these records are the versions that are sorted. If you display a report, then
modify some of the records and redisplay the report, the order in which the records
appear may change as well.
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A DB/TextWorks thesaurus is a textbase that lets you maintain a controlled vocabulary (also
called an authority list) of terms and the relationships among terms. DB/TextWorks comes with
a template that you can use to create thesaurus textbases; see Set Up Thesaurus.
Note the following about DB/TextWorks thesaurus textbases:
Important! You must not rename or remove the original fields in a thesaurus textbase.
As well, do not change the information in the Status field, as it contains information used
by the thesaurus engine.
You should always use the Maintain Thesaurus window to add or modify individual
thesaurus terms. Using this window assures that relationships are established when
necessary (which will not happen if you try to add or modify a thesaurus term by editing
the thesaurus textbase directly).
You can add more fields to a thesaurus, but keep in mind that they will not appear on
any thesaurus window.
You can add a Master password to a thesaurus in order to protect the ability to make
changes to the textbase structure, but you must also include a Silent password to grant
users full write access to all thesaurus fields.
Thesauri can be shared across fields and non-thesaurus textbases. You can use a
DB/TextWorks thesaurus to do the following:
Add new terms that you expect to use in bibliographic or other kinds of records. You can
add terms by importing a file or by typing each one into the thesaurus using the Maintain
Thesaurus window.
Add relationships, a scope note, and general notes.
Modify a thesaurus term and its relationships, scope note, and general notes.
Delete a term.
Reconcile terms and relationships using a Rebuild Thesaurus function.
Access and navigate (browse) a thesaurus from within a textbase.
Select terms while browsing and paste them into a Query window or an Edit window.
This topic also provides you with the basic concepts and program construction rules for a
DB/TextWorks thesaurus.

Basic Concepts
A DB/TextWorks thesaurus has the following characteristics:
It is a monohierarchical thesaurus.
The software uses a JavaScript-created user interface to facilitate the addition and
maintenance of thesaurus records. Using this interface gives you the benefit of a great
deal of error and validation checking that helps preserve thesaurus integrity. For
example, the program automatically adds and edits reciprocal relationship records,
checks for uniqueness of a term, and more.
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Thesaurus records, called term records, are stored in a DB/TextWorks textbase. Each
record represents one term, either a preferred term or a non-preferred term. A term may
be a subject, product, trade name, company, and so forth.
Each term record also contains information about the other terms that are semantically
related. The relationships allowed in a DB/TextWorks thesaurus are:

You can create a complete term record and the program will automatically create the
record for the reciprocal term(s) if they are not present in the thesaurus. Or, when a
relationship between two terms is changed on one record, the program automatically
updates the record for the reciprocal reference.
A thesaurus can have an unlimited number of terms.
You use the Set Up Thesaurus dialog box to associate a thesaurus with a field in a
textbase. You also use the Set Up Thesaurus dialog box to create a new thesaurus.
You can connect one or more thesauri to a textbase, up to the number of fields listed for
that textbase. Only Text and Code fields may have associated thesauri. For example, if
you have five fields in a textbase, you can connect a thesaurus to each of these fields.
You can connect a different thesaurus to each field, or you can connect the same
thesaurus to each field, or any combination thereof. However, keep in mind that you can
connect only one thesaurus per field.

Thesaurus Construction Rules
The following rules (general rules, for preferred terms, and for non-preferred terms) are applied
by the program during thesaurus record creation, editing, or deletion.

General Rules
Each term must be unique. When you attempt to add a term that already exists, even if
the new term is a unique concept, the program will prevent the new term from being
added. You must edit one or all of the terms to make each unique. For example, in the
case of a homograph you might add parenthetical qualifiers to distinguish one from the
other(s):
Mercury (planet)
Mercury (metal)
Mercury (Roman deity)
When you add a term to the thesaurus, the program creates reciprocal records to that
term or edits them as necessary to reflect the correct relationship.
When you edit a term record or a relationship to a term, the program automatically
updates all relationship records, or creates them if they are not present in the thesaurus.
Take, for example, the following pair of records:
Term: Brakes
NT: Antilock brake system
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Term: Antilock brake system
BT: Brakes
If you remove "Antilock brake system" as a narrower term (NT) of "Brakes," the program
will automatically remove "Brakes" as a broader term (BT) of "Antilock brake system,"
leaving only the two main terms with no relationships.
When you delete a term, you are deleting the term record only. The program will
automatically update all the reciprocal term records to reflect the changed/canceled
relationships, but it does not delete any other records. Relationships may be canceled,
but term records may only be deleted explicitly by the user.

Preferred Terms
The following statements apply to preferred terms in a DB/TextWorks thesaurus.
A preferred term may have only one broader term (BT).
It may have unlimited narrower terms (NT), related terms (RT), and equivalent terms
(UF).
It may only use other preferred terms for narrower, broader, and related relationships.
It may have a scope note and one other note of unlimited length.
It is allowed to exist in the thesaurus with no relationships, scope note, and so forth. This
term will, by definition, be designated a preferred term.

Non-Preferred Terms
The following statements apply to all non-preferred terms in a DB/TextWorks thesaurus.
Non-preferred terms are defined by the presence of a USE reference in the term record.
A non-preferred term can have only one relationship, the USE reference.
Only one USE reference is allowed for a non-preferred term.

Set Up Thesaurus
Note: You can open this dialog box only when you have a non-thesaurus textbase open. You
cannot connect a thesaurus to another thesaurus.
Use the Set Up Thesaurus dialog box to connect one or more thesauri to a textbase, up to the
number of appropriate fields in that textbase. Only Text and Code fields are listed. If you have
five fields in a textbase, you can connect a thesaurus to each of these fields. You can connect a
different thesaurus to each field, or you can connect the same thesaurus to each field, or any
combination thereof. However, keep in mind that you can connect only one thesaurus to a field.
You also use the Set Up Thesaurus dialog box to create a new thesaurus.
Once you have connected a thesaurus to a field, when you use the Query window or the Edit
window for the textbase, you can browse the thesaurus for the connected field. With your cursor
in the field, press F3, or choose Edit>Browse Choices, or click the Browse Choices toolbar
button to open the applicable Browse Choices window.
To connect an existing thesaurus to a field
1. Select a field from the Fields list.
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2. Click Connect to Existing Thesaurus to open the Select DB/TextWorks Thesaurus
Textbase dialog box. Select a thesaurus textbase, then click Open to return to the Set
Up Thesaurus dialog box. Notice that the thesaurus textbase name appears next to the
field name in the Fields list.
3. Click OK.
To create a thesaurus and connect it to a field
1. Select a field from the Fields list.
2. Click the Connect to New Thesaurus button to open the Specify New Thesaurus
Textbase dialog box. Specify a name and location for the new thesaurus textbase, then
click Save to return to the Set Up Thesaurus dialog box. DB/TextWorks creates a new
empty thesaurus textbase in the specified location.
Note: If you create your thesauri in the same folder as your textbase you can more
easily move all of them to a new location. If thesauri are in a different location than the
textbase, you may need to re-specify the connections if you move them.
3. Click OK to dismiss the confirmation message.
4. Use the Maintain Thesaurus window to populate your new thesaurus.
Note: You should always use the Maintain Thesaurus window to add or modify
individual thesaurus terms. Using this window assures that relationships are established
when necessary (which will not happen if you try to add or modify a thesaurus term by
editing the thesaurus textbase directly).
To disconnect a thesaurus from a field
1. Select the field from the Fields list that is connected to the thesaurus you want to
disconnect.
2. Click the Disconnect Thesaurus button. The name of the thesaurus no longer appears
next to the field name in the Fields list.
Note: You cannot disconnect a thesaurus that is used as a validation list. You must edit
the textbase structure to remove this setting before you can disconnect the thesaurus.

Maintain Thesaurus
Choose Maintain>Maintain Thesaurus to open the Maintain Thesaurus window to add or
modify a thesaurus term, including its relationships. Note that if you have more than one
thesaurus connected to your textbase, the Select Thesaurus to Maintain dialog box opens first.
If you have a thesaurus textbase open, the Maintain Thesaurus window for that thesaurus
opens.
Note: You should always use the Maintain Thesaurus window to add or modify individual
thesaurus terms. Using this window ensures that relationships are established when necessary
(which will not happen if you try to add or modify a thesaurus term by editing the thesaurus
textbase directly).
Only one person is allowed to maintain a thesaurus at one time, as individual changes can
cause the modification of many related-term records in a thesaurus textbase. If anyone has the
thesaurus textbase open directly (by choosing File>Open), Maintain Thesaurus cannot be used
until the textbase is closed. The only exception to this is if the textbase has been opened read-
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only (select the Open as read-only check box on the Open Inmagic DB/TextWorks Textbase
dialog box).
To see if you have a thesaurus textbase (a textbase containing all the necessary fields) open,
choose Display>Textbase Information. If "Thesaurus textbase" appears under the textbase
name, you do.
Click the Help button on the Maintain Thesaurus window for more information.

Rebuild Thesaurus
You use the Rebuild Thesaurus function when you want the software to examine thesaurus
entries and establish links when found to be necessary. For example, to establish reciprocal
thesaurus links (for example, if Apple BT Fruit, then Fruit NT Apple) after you import thesaurus
data from an external system where they did not exist, use the Rebuild Thesaurus function.
To open the Rebuild Thesaurus window, open a thesaurus textbase directly in DB/TextWorks,
choose Maintain>Maintain Thesaurus to open the Maintain Thesaurus window, then click the
Rebuild button.
Note that if records could not be automatically repaired through this function, you should view
the broken records so you can fix them individually. A broken record is a record whose
relationships may not all be reciprocal. When the software tries to fix a broken record, it wants to
make all of a broken record's relationships reciprocal, if possible. This may not always be
possible. For example, a broken thesaurus record cannot be fixed if it would create incompatible
references, such as USE and RT under the same term.

Use Thesaurus as a Validation List
Text and Code fields can use a thesaurus as a validation list. This means that you can give your
users the ability to browse through a network of semantically related terms. A validation list is a
list of entries allowed in a field. A validation list provides a way of screening information to be
added to a textbase. Only entries in the list are allowed during data entry or import. When you
have specified a thesaurus as a validation list, users cannot enter a term that is not found in the
thesaurus. Even if no term relationships are required, you can use a thesaurus for validation
purposes to provide a way to share a single list of approved terms among any number of fields
and textbases.
To connect a thesaurus to a textbase field for use as a validation list
Tip! If you are not planning to use a thesaurus as a validation list, you can use Maintain>Set
Up Thesaurus to connect and disconnect thesauri.
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. Select a Text or Code field from the Field Name list.
4. On the Text Options tab, connect a new or existing thesaurus to the field.
To connect to an existing thesaurus, click the Connect to Existing Thesaurus button to
open the Select DB/TextWorks Thesaurus Textbase dialog box. Select a thesaurus
textbase, then click Open to return to the Edit Fields dialog box. Notice that the thesaurus
textbase name appears above the Connect to Existing Thesaurus button.
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To create a new thesaurus, click the Connect to New Thesaurus button to open the
Specify New Thesaurus Textbase dialog box. Specify a name and location for the new
thesaurus textbase, then click Save. Click OK to dismiss the confirmation message. The
software creates a new empty thesaurus textbase in the specified location. Notice that
the thesaurus textbase name appears above the Connect to Existing Thesaurus button.
Use the Maintain Thesaurus function to populate your new thesaurus.
Note: If you create your thesauri in the same folder as your textbase, you can more
easily move all of them to a new location. If thesauri are in a different location than the
textbase, you may need to respecify the connections if you move them.
5. Click the Change button.
6. Depending on what you want to do, you can use the thesaurus as the validation list for
the designated field, or you can leave it as a look-up list for the field.
To make the thesaurus the validation list, select the Validation tab and in the Content
Validation group, select the Use Thesaurus as Validation List option button. Notice that
if you previously had a separate validation list associated with this field, the software will
ask you if you want to clear that validation list. Click Yes. Click the Change button.
To leave the thesaurus as a look-up list for the field, go to step 8.
7. [Optional] On the Validation tab, select the User May Override Content Validation
check box to let users override content validation. Click the Change button.
8. Click Finish.
9. Click OK on the Edit Textbase Structure dialog box, then click OK to confirm your
changes.
To disconnect a thesaurus from a field
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
2. Click the Edit Fields button to open the Edit Fields dialog box.
3. From the Field Name list, select the field that is connected to the thesaurus you want to
disconnect.
4. On the Validation tab, select the No Content Validation option button. Note that the
software will not let you disconnect a thesaurus that has the Use Thesaurus as
Validation List option button selected.
5. On the Text Options tab, click the Disconnect Thesaurus button. Notice that the name
of the thesaurus no longer appears above the Connect to Existing Thesaurus button.
6. Click the Change button.
7. Click Finish on the Edit Fields dialog box.
8. Click OK on the Edit Textbase Structure dialog box, then click OK to confirm your
changes.
To use a thesaurus validation list
1. While adding or editing a record, place the cursor in a field that uses a thesaurus as a
validation list and press F3, or choose Edit>Browse Choices, or click the Browse
Choices toolbar button to open the Editing Choices Browser dialog box.
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2. Browse and paste entries from the validation list into the current field.
When you are adding or editing records, you do not have to display the validation list. If you are
fairly sure about what a field will accept, just type the entry. If you type an entry that is not in the
list, the Content Validation Mismatch dialog box will open to help you.
Note that case is corrected automatically to match the validation during data entry or import. For
example, if the validation list contains the entry Urgent, and you type urgent in the field, it will be
corrected to Urgent. If you type a term with a USE reference, the entry is replaced with the
preferred term.
To convert an existing validation list to a thesaurus
Once you convert an existing validation list to a thesaurus, you can share the thesaurus among
several textbases by connecting it to those textbases.
Note: You can use the method in the following set of steps to populate a thesaurus (and not
have to use the Maintain Thesaurus window) because there are no cross-references that have
to be made reciprocal.
1. Open the textbase that has a validation list that you want to convert to a thesaurus.
2. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog
box.
3. Click the Edit Fields button to open the Edit Fields dialog box, and select the field that
has the validation list you want to convert into a thesaurus.
4. On Validation tab, click the Edit List button to open the Edit Validation List dialog box.
5. Click the Print List button to open the Print dialog box, and select the Print to file check
box. Click OK to open the Save File As dialog box, and name and save the file (which
will be saved with a .TXT extension by default).
6. Close the Edit Validation List dialog box.
7. With the same field still selected, select the Text Options tab and click the Connect to
New Thesaurus button to open the Specify New Thesaurus Textbase dialog box.
Decide where to place the new thesaurus, name the new thesaurus, and save it. Click
OK to dismiss the completion message.
8. Click the Change button on the Edit Fields dialog box.
9. On the Validation tab, select the Use Thesaurus as Validation List option button. Click
Yes to confirm clearing the validation list.
10. Click the Change button on the Edit Fields dialog box, then click the Finish button to
return to the Edit Textbase Structure dialog box. Click OK to close the Edit Textbase
Structure dialog box, then click OK to confirm your textbase structure updates.
11. Choose File>Open and open the newly created thesaurus textbase, which opens the
Edit window. Close this window.
12. Choose File>Import to open the Select Import File dialog box and select the .TXT file
created in step 5. The software opens the Import Options dialog box.
13. On the File Format tab:
In the Import File Format group, select the Delimited ASCII Format option button.
In the Delimiter Options group:
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Ensure that {CR}{LF} is selected from the Record Separator drop-down list.
Select {TAB} from the Field Separator drop-down list (to retain commas in the
validation list terms).
Select {NONE} from the Comment and Quote Character drop-down lists (in case
either of the default characters appears in validation terms).
In the Field Names group, select the Specify Order in which to Import Fields option
button, then move Term from the Available Fields list to the Import Fields list. It should be
the only field in the Import Fields list.
Click OK to proceed, then click Yes to dismiss the confirmation message.
14. Click OK to dismiss the completion message.
15. If you want to share this thesaurus among several textbases and incorporate their
validation terms as well, repeat the steps above with the following exceptions:
In step 7, connect to this thesaurus rather than a new one (so click the Connect to
Existing Thesaurus button instead).
In step 13, after you are done with the File Format tab, select the Add/Replace
Options tab and specify how the incoming information will affect existing records:
Select the Check for Matching Records check box.
In the If Match is Found group, select the Reject New Record option button.
Move Term to the Incoming Records Must Match list.
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Printing a Report
You can print a formatted report using the currently selected Report Printing form or the form for
the active window.
The default printer selected in Windows will be used, unless you select a different printer.
Certain printer-specific options affect the output, such as page orientation (portrait or
landscape), paper size, and available fonts. Before printing, you may want to change these
settings using either the Setup button on the Print dialog or the Print Setup command on the
File menu.
Note: To create a file in Plain Text, RTF, or HTML format, choose File>Write Report to File.
To print a report
1. Select a printing form (choose Display>Select Forms>Report Printing).
2. Search for the records you want to print. The Select Search Results Window dialog box
opens. You do not have to view records, although you may want to.
Important! If the Display or Edit window is selected, only the current record will be
printed.
3. [Optional] To omit a record from the report, select it in the Report or Display window and
choose Sets>Omit Record. (This does not delete the record from the textbase.)
4. [Optional] Choose Display>Sort Report to sort records in a particular order.
Note: If the form used for printing (which is not necessarily the Report Printing form) has
a compulsory sort, that is the only order in which records can appear.
5. [Optional] Choose File>Print Preview. For information about Print Preview, see Print
Preview command (File menu). If you do open the Print Preview window, you can
choose to print the report by clicking the Print button, and skip step 6. If you do not want
to print at this point, click the Close button.
6. Choose File>Print. For information about what may happen when you invoke the Print
command, see Print command (File menu). When the Print dialog box opens, the name
of the print form appears on the status bar.
7. Select the print options you want on the Print dialog box and click OK to begin printing.
8. [Optional] If you are printing labels, the Specify Starting Label dialog box appears. If
applicable, you can specify the starting label.
To print just one record
1. Search for the record you want to print. The Select Search Results Window dialog box
opens. Choose to display the records in the Display or Edit window.
2. Choose File>Print. For information about what may happen when you invoke the Print
command, see Print command (File menu).
3. Select the print options you want and click OK to begin printing,
Troubleshooting
You may see the following message when you try to print a report:
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Some information may not appear in the printed report. Possible reasons:
form dimensions do not match page dimensions or boxes appear in the nonprintable area. Continue?

This message indicates that the form dimensions do not match the page dimensions, or that
one or more Margin boxes appear in the non-printable area of the page. The non-printable area
is the area around the edges of a sheet of paper into which the printer cannot write. On a laser
printer, this area is usually ¼ inch or less.
Respond Yes to print the report or No to cancel the report printing.
To correct the problem:
Move the Margin Area boxes away from the page edges. Open the form in the Form
Designer and move the boxes. To access the Margin Area, choose Report
Options>Work in Margin Area.
Change the form dimensions. Open the form in the Form Designer and choose
Report Options>Set Up Page.

Sending a Report as Mail
1. Open a textbase and retrieve one or more records. All of the records in the current set
will be included.
2. Choose File>Send Report as Mail, then select a message format from the drop-down
list:
Plain text in message body. Inserts report as text into Message area of your email program. Retains as much formatting as possible, including some
approximation of side-by-side boxes. Does not retain font or color. Note: If you use
SMTP to access mail services, the maximum amount of text that you can place in
the body of an e-mail message is 32,000 characters.
HTML in message body. Inserts HTML-formatted report into Message area of your
e-mail program.
Plain text attachment. Inserts the report as an attachment with a .TXT extension.
The attachment retains as much formatting as possible, including some
approximation of side-by-side boxes. Does not retain font or color.
Rich Text Format (RTF) attachment. Inserts the report as an attachment with an
.RTF extension. Saves as much formatting as possible by converting it to
instructions that most word processing and layout packages can read and interpret.
HTML attachment. Inserts the report as an attachment with an .HTM extension.
Writes formatted record information to a file in Hypertext Markup Language (HTML),
the document formatting language used by Web browsers. Note: With MAPI and
certain e-mail clients, the HTML may appear in the body of the message instead of
as an attachment.
3. Make sure the Mail to addresses specified in records check box is not selected.
4. [Optional] Click the Specify Form for Report button if you want to select a different form
from the one shown on the Send Report as Mail dialog box. When done with the Select
E-mail Report Form dialog box, click OK.
5. Do the following, depending on how you access mail services:
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If you use MAPI: Click OK on the Send Report as Mail dialog box. A new message
window for your default e-mail program appears. Specify who should receive the
report and fill in the other fields your e-mail program may have. Optionally, specify
file attachments using your e-mail program. Click your e-mail program's Send
button.
If you use SMTP: Fill in mailing information on the Send Report as Mail dialog box.
You must enter a valid e-mail address (for example, name@domain.com) in the
From box. Optionally, click the Select File Attachment button to specify a file to
attach to the e-mail, then click Open. Do this for each file you want to attach. Note:
Because file attachments are recorded in your textbase .IDI file, the attachments
from your previous Send Report As Mail sessions are automatically listed. This
makes it easier to send the same attachment to multiple recipients. File attachment
lists are textbase-specific. To remove a file from the File attachments list, select it
and click the Remove Attachment button. Click OK on the Send Report as Mail
dialog box to send the e-mail.
6. Click OK to dismiss the confirmation message box that appears.
Another way to use this feature is to create a textbase that contains a field that identifies a
recipient (or recipients) for a record. Then when you use the Send Report as Mail feature, you
can quickly and easily send each record (or a notice containing information pertinent to that
record) to its identified recipients.

Sending Each Record as Mail
Instead of sending a report as mail, you can send each record (or a notice containing
information pertinent to that record) as mail to its identified recipients.
1. Open the textbase and retrieve one or more records.
2. Choose File>Send Report as Mail, then select a message format from the list:
Plain text in message body. Inserts report as text into Message area of your email program. Retains as much formatting as possible, including some
approximation of side-by-side boxes. Does not retain font or color. Note: If you use
SMTP to access mail services, the maximum amount of text that you can place in
the body of an e-mail message is 32,000 characters.
HTML in message body. Inserts HTML-formatted report into Message area of your
e-mail program.
Plain text attachment. Inserts the report as an attachment with a .TXT extension.
The attachment retains as much formatting as possible, including some
approximation of side-by-side boxes. Does not retain font or color.
Rich Text Format (RTF) attachment. Inserts the report as an attachment with an
.RTF extension. Saves as much formatting as possible by converting it to
instructions that most word processing and layout packages can read and interpret.
HTML attachment. Inserts the report as an attachment with an .HTM extension.
Writes formatted record information to a file in Hypertext Markup Language (HTML),
the document formatting language used by Web browsers. Note: With MAPI and
certain e-mail clients, the HTML may appear in the body of the message instead of
as an attachment.
3. Select the Mail to addresses specified in records check box.
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4. Select the Send one e-mail per record check box to include information from one
record in each e-mail message. Clear this check box to include all records sent to the
same recipient(s) in a single e-mail message.
5. Select a field name from the Field containing 'To:' address drop-down list that contains
e-mail addresses in the correct address format (for example, tjones@crafts.com,
tmallory@carriers.com). Note: If a record has multiple e-mail addresses, they must be in
repeating entries.
6. Do the following, depending on how you access mail services:
If you use MAPI: Type appropriate text in the Subject box.
If you use SMTP: Fill in mailing information. Note that you must enter a valid e-mail
address (for example, name@domain.com) in the From box.
7. [Optional] Click the Specify Form for Report button if you want to select a different form
from the one shown on the Send Report as Mail dialog box. When done with the Select
E-mail Report Form dialog box, click OK.
8. [Optional] Click the Select File Attachment button to specify a file to attach to the email, then click Open. Do this for each file you want to attach.
Note: Because file attachments are recorded in your textbase .IDI file, the attachments
from your previous Send Report As Mail session are automatically listed. This makes it
easier to send the same attachment to multiple recipients. File attachment lists are
textbase-specific. To remove a file from the File attachments list, select it and click the
Remove Attachment button.
9. Click OK on the Send Report as Mail dialog box to send the messages.
10. Click OK to dismiss the confirmation message box that appears.
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You have a great deal of flexibility in how you approach form design. Use the order below as a
guide. Some of the steps are optional, and some may be performed in a different order.
To create a form
1. Search and retrieve records. It helps to have at least a few records in the textbase
before you start designing forms, so you can see actual record information as you lay
out the form. Remember that you can access the query screen at any time before or
after opening the Form Designer.
2. Set form defaults. Choose Tools>Options>Display to specify default settings for the
forms you create. This is especially helpful if you will be creating many forms that will
use the same settings.
3. Open the Form Designer. Choose Display>Design Form and select a form to edit or
to use as the basis of a new form.
4. Select form properties. Choose Tools>Form Properties to specify settings that affect
how information will appear when the form is used, either on the desktop, an intranet, or
the Internet.
5. View records. Periodically change between Display>View Records and Display>View
Content, to toggle between viewing actual record information and content descriptions.
Viewing record information is like previewing the form. (To see record information, you
must execute a query or load a set.) Viewing content descriptions reveals how the form
is constructed.
6. Show or hide box boundaries and anchoring indicators. Check and uncheck
View>Boundaries, to show or hide dashed lines around boxes to help you lay out the
form.
7. Perform design tasks. The first task below is required. The remaining tasks are
optional and may be performed in any order. Use the Edit and Tools menus to perform
these tasks:
Add and edit boxes. Add form, text, and/or picture boxes and specify their
contents (for example, fields, variables, text, images). You can also add script input
boxes and script buttons. Each form box can include one item or several items
(such as two fields and a variable). Delete any unwanted boxes or script buttons.
(This does not delete record information.) Edit box content if needed (for example,
to change the field that a box contains). You can also cut, copy, and paste a box or
group of boxes.
Format box text. Specify how each content item in a box appears, including font,
case, color, number and date formatting, and numbering, and whether extra text or
punctuation appears (for example, make a field bold and italic, and number each
entry).
Change box size and position. Move and resize boxes and determine whether
the box position will be anchored or floating. (Most boxes should float.) You should
find the Tools>Align Boxes commands especially helpful.
Show label, border, and scroll bars. Show or hide labels, borders, and scroll
bars, and specify label text, font, and color.
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Format paragraphs. Specify paragraph breaks, justification, and indentation, to
affect all of the content items in the box. For example, make entries appear on
separate lines.
Specify Web-specific properties. If you plan to use the form on the Web with
WebPublisher PRO, add logos to the top and/or button of the form, include
hypertext links, add an expand record link (if the form is a report form), and specify
other HTML attributes.
8. Select report options. If the form will be used for multiple-record reports, use the
Report Options menu to specify these optional attributes:
Compulsory Sort. Specify that records be sorted in a certain way each time that
form is used. A compulsory sort is typically used when a report contains subtotals
and totals that rely on a specific sort order. It is also used to sort records on the
Web, when using WebPublisher PRO.
Add Headers and Footers. Use a Report Header, which appears only once, at the
beginning of the report. It typically contains variables, prompted text, fixed text, or a
combination of these items. Use a Report Footer, which appears only once, at the
end of the report. It typically contains summary calculations, such as grand totals
and averages. Use a Sort Header as a group heading under which one or more
records are listed. Use a Sort Header as a group heading under which one or more
records are listed. Use a Sort Footer to hold a count, subtotal, or other summary
calculation for the current sort group.
Set Up Page. Specify the size, margins, orientation, and page breaks for the form
when used for printing.
Hide Margin Area and Work in Margin Area. Hide the Margin Area from view or
show the Margin Area and work in it. Information in the Margin Area is only used
when printing on the desktop.
9. Save the form. When you save a form for the first time (or use Save Form As), you
specify the operations for which the form can be used (for example, Display window, Edit
window, Report window, printing, or for use on the Web). You also specify if the form
should be saved in the user file or the textbase file. While you are first learning to design
forms, you may not want your early, experimental forms to be seen by others. If this is
the case, save the forms in your user file. Others who share the textbase will not see
them in selection lists or have access to them. If you later want other to be able to see a
form, use Save Form As and save it as public. If you plan to use the form on the Web
with WebPublisher PRO, it must be saved as public.
Note: You can save up to 450 forms in the textbase file and an additional 450 in your
user file.
10. Select the form. After designing a form, choose Display>Select Forms and select the
forms to use for various operations.

Areas of a Form
A form has two areas in which you can add boxes:
Margin Area. Information in this area appears on every page of a printed report. This is
useful for including page numbers and the current date. You cannot add script buttons in
the Margin Area as they are not appropriate for printing. You can place boxes on all
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sides of the Margin Area. The Display, Edit, and Report windows do not show boxes
placed in the Margin Area. Use Print Preview to see Margin boxes.
Record Area. Information in this area is used primarily for record information (fields). In a
report, records appear one after the other, sorted as specified. The Record Area can
also include a title on the first page, Sort Headers, a grand total on the last page, and so
forth.
In the Form Designer, you can toggle between the Margin Area and Record Area as needed
and place boxes in either area.

Record Area Boxes
The Record Area can include the box types listed below. The design of your report determines
which box type you should use. When a form is used, Record boxes will appear in the Display,
Edit, and Report windows and in printed reports. Header and Footer boxes will appear only in
reports, as well as with Send as Mail, Write Report to File, and in WebPublisher reports.
To add a Record box, choose Edit>Add>Form Box while working in the Record Area.
To add any other type of box, choose Report Options>Headers and Footers while working in
the Record Area.
Note: You can also use text and picture boxes as header/footer boxes. See Changing the Box
Type for more information.
Use this box...

In the Record Area, when you want the contents to appear...

Record box

Once for each record in the report. A Record box can contain record
information, such as names, or other content items, such as calculations
and record images

Report Header box

Once at the beginning of the report. Typically used for report search
criteria, prompted text, report title.

Sort Header box

Throughout the report whenever a new group of records begins. A Sort
Header box typically has a Sort Key (Sort Level 1 through 5) as its
content. However, it can contain other content items, such as fixed text.

Sort Footer box

Throughout the report whenever a group of records ends. A Sort Footer
box is paired frequently with a corresponding Sort Header box. For
example, you pair a Sort Header Level 1 with a Sort Footer Level 1.
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Normally, a Sort Footer box contains a subtotal or other computed value
for the current group.
Report Footer box

Once at the end of the report. Typically used for report grand totals,
counts, and averages.

DB/TextWorks: Form Design Tips
You can specify the following uses for forms when you save them:
Report Window. Display multiple records after a search.
Display Window. Display one record at a time.
Edit Window. Add or edit one record at a time.
Report Printing. Print records found by a search (for example, financial reports, mailing
labels, and so forth).
Web. For Internet/intranet use, with WebPublisher PRO.
Web only. Excludes a form from desktop form lists. Forms saved with this check box
selected can only be used on the Internet/intranet, with WebPublisher PRO.
The following sections provide guidelines for designing each type of form.
Note that some form components do not appear in certain windows. For example, scroll bars
rarely appear on boxes in the Report window. They only appear under the following
circumstances:
If a box with unlimited maximum height in a Report window contains extremely lengthy
contents.
If the text typed by a user into a script input box on the Report window exceeds the
minimum height of the script input box.
Click here to see a chart that summarizes this information.

Report Window
Typically, you design at least one form for the Report window to summarize the records found
by a search. Here are some tips to help you design forms for the Report window:
Summarize search results by showing just a few of the most important fields. The fewer
fields you show, the more records can be seen at once. Decide which fields you can
omit without confusing users. For example, if most people search by Name, then the
form should probably include that field.
To conserve space, combine multiple content items in one box (Address, City, State or
Province, Postal Code). Choose Tools>Box Properties>Paragraphs and select No
added paragraph breaks from the Paragraph breaks drop-down list (so items are not
stacked in a column). Choose Tools>Box Properties>Format>Added Text and use a
comma and a space as added text after the appropriate content item (for example, 123
South St., Dallas, TX 01234).
Consider turning off box labels or specifying that label position is to the left of the box
(choose Tools>Box Properties>Labels).
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If you start with the Basic Record form, decide whether to turn off borders and scroll bars
(choose Tools>Box Properties>Labels). If you start with the Basic Report form, they
are turned off by default. Note that scroll bars seldom appear on boxes in the Report
window.
If you start with the Basic Record form, decide whether to increase the height of some
boxes from the default (Tools>Options>Display) to unlimited by selecting the box(es)
and choosing Tools>Box Properties>Position and increasing the Maximum height
setting. Otherwise, only the default number of lines worth of information will appear. Note
that if you start with the Basic Report form, the Maximum height setting is set to
unlimited by default. In the same dialog box, set Minimum height to zero (0) to make
boxes disappear when empty.
Use Tools>Form Properties>General to set the distance between records.
Number records by adding a box whose only content is the RECORD NUMBER
variable.
Preview the form to see how it really looks. The Form Designer shows only one record at
a time and does not omit empty boxes, so you cannot see how it really looks until you
preview it.
Decide whether to turn search highlighting on or off (Tools>Form Properties>General
in the Form Designer). Highlighting words in reverse video or color
(Tools>Options>Search) can be a help or a hindrance.
Note that you can use the same form for both the Report window and for printing reports.
These forms are also used for the Send Report as Mail, Write Report to File, and Copy
Report to Clipboard operations.

Display Window
The Display window shows one record at a time, when you choose Display>Display Record.
Note that the Display window does not show header/footer boxes or sort keys. Design at least
one form for the Display window that shows detailed information about one record at a time.
Here are some tips for designing forms for the Display window:
Start with the Basic Record form. Include most or all of the fields, as users displaying a
record usually expect to see them.
Use Tools>Box Properties>Position to increase the height (Maximum height) of
some or all boxes from the default (Tools>Options>Display>More Defaults) to a larger
value and set Minimum height to zero. These recommendations were explained in the
previous section about designing Report window forms.
Turn scroll bars on for boxes that may contain large amounts of text. This is because, in
Display and Edit windows, boxes are never taller than the window—even if the Maximum
height box setting is set to unlimited.
Decide whether to turn search highlighting on or off (Tools>Form Properties>General
in the Form Designer). Highlighting words in reverse video or color
(Tools>Options>Search) can be a help or a hindrance.

Edit Window
The Edit window opens when you add or edit a record. Here are some tips for designing a form
to be used in the Edit window:
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Start with the Basic Record form. This shows all fields, with all boxes having borders and
scroll bars.
Place fields that you edit most frequently at the top of the form. Move fields that you
seldom edit to the bottom of the form. Then choose Tools>Tab Order and click the
Reset to Default Tab Order button to reset the tab order to match the order in which
boxes appear in the form.
Increase the height of boxes that include large amounts of text. Choose Tools>Box
Properties>Position and increase the Maximum height setting to show enough text to
provide adequate context. If you started with the Basic Report form, use the Labels tab
to show scroll bars (they are on by default for the Basic Record form).
Place only a single field in a box or you will not be able to edit it. The field must be from
the primary textbase and cannot be hidden or marked read-only by a password. Any
other type of content can be seen but not edited. Note that in some cases you may want
to include information even if it is not editable, such as Automatic or Computed fields, or
information from a linked textbase. Using a different font or color for non-editable
information or removing the border from the box can assist the user.
Be sure the form includes a box for every field that has Field Entry Required validation.
Put each field in its own box. If each required field does not have its own editable box,
you cannot use the form in the Edit window. To see which fields have Field Entry
Required validation, choose Display>Textbase Information, then choose Edit>Find to
search for the word required.
Be sure the form includes an editable box for any Automatic ID fields. Otherwise, the
fields will not be populated.
If the Check spelling as you type feature will be used on the edit form, use a black text
font in editable boxes.
When a form is used in the Edit window, the following attributes apply for editable boxes,
no matter how the form was designed:
Entry delimiters (bullet character by default) appear and each paragraph or entry
has hanging indentation, so you can differentiate between line wrapping, paragraph
breaks, and entries.
All formatting except font and color is removed, so you can tell the difference
between record information and formatting. All you see is the actual field
information.
Boxes never disappear when empty (unless the box contents are hidden by a
password), even if Minimum height is set to zero on the Position tab of the Form
Box Properties dialog box. This behavior permits you to add information to empty
fields.
Note: If you are using WebPublisher PRO to modify (add, edit, delete) records via the Web, you
can design an edit form, export it to HTML, and then use it to add records to your textbase via
the Web. To enable the Export Editing Form to HTML command, you must first save the form
for use in the Edit window.
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Printed Reports
Printed reports can include page numbers, titles, calculations, Sort Headers (such as Sales by
Territory), and many other sophisticated formatting techniques. Here are some tips for designing
a form to be used for printing:
Read about designing forms for the Report window (above). Many of the same
recommendations apply.
Use the Report Options menu to specify print-specific settings, including the page size,
page breaks, and other attributes that affect how the report will appear when printed.
Use the Margin Area to add information that will repeat on every page, such as page
numbers. Use the Record Area to specify how record information appears in the body of
the report. Carefully consider where to place the different report components and what
type of box to use (for example, text box, form box, Header/Footer box).

WebPublisher PRO Reports
If you have WebPublisher PRO, you can design forms to be used with textbases that you
publish on the Web. Internet or intranet users can use a Web browser to retrieve records, then
choose one of the reports that you designed to change the appearance of the information that
was retrieved. For more information, see Creating Forms for Web Use.

Using a Form in Multiple Windows/Reports
Some form components are omitted from display when the form is used in a specific window or
operation.

Edit
Window

Display
Window

Box scroll bars appear

yes

yes

no

Header/Footer boxes
appear

no

no

Sort Keys appear

no

Margin boxes appear

Form Component

Report
Window

Printed
Report

Mail
Each
Record
to a
Send
Different
Report as
Address
Mail

no

no

no

yes

yes

yes

no

no

yes

yes

yes

no

no

no

no

yes

no

no

Empty boxes will
disappear if Box Minimum
Height = 0

no

yes

yes

yes

yes

yes

Items found in a search
can be highlighted

no

yes

yes

yes

yes

yes

Picture boxes/images

yes

yes

yes

yes

no

no

Sorting

no

no

yes

yes

yes

no
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Scroll bars appear only when needed to view information in a box. If the information fits in
the box "as is," scroll bars do not appear.
Scroll bars only appear in the Report window for boxes with extremely lengthy content, or
when the text typed in a script input box by a user exceeds the minimum height of the box.
If you choose File>Print while the Display or Edit window is active, only the record shown
in that window is printed, and headers, footers, and sort keys are omitted from the printed
report.
For Send Report as Mail, search highlighting appears only for RTF and HTML.
Records in the Edit/Display windows are only sorted if you display the Report window first.

Using a form on the Web
When using forms on the Web, different form components apply based on the use of the form.
Form Component

Web Report

Web Expanded Display

Web Edit Form

Box scroll bars appear

no

no

yes

Header/Footer boxes appear

yes

yes

yes

Sort Keys appear

yes

yes

yes

Margin boxes appear

no

no

no

Empty boxes will disappear if
Box Minimum Height = 0

yes

yes

no

Items found in a search can
be highlighted

yes

yes

no

Picture boxes/images

yes

yes

yes

Scroll bars only appear if the maximum height of the box is greater than one (>1).
Only picture boxes appear on a Web edit form. Inline images and image links appear as
plain text.

Form Defaults Group-Display Tab (Tools>Options)
Use these options to customize default form, query screen, and menu screen settings. You can
specify custom text and label default font settings, as well as other custom default settings (See
More Defaults below).
Set Text Font. Click this button to specify the fonts DB/TextWorks uses for new forms,
Basic Record forms, Basic Report forms, new and Basic Query screens, and box text on
menu screens. The font that you select will also be used for the Textbase Information
window, printed definitions of textbase elements; and printed lists (validation,
substitution, stop words, leading articles, indexes).
Set Label Font. Click this button to select the font to use for box labels in forms and
query screens.
More Defaults. Click this button to access the Form Defaults dialog box. This dialog box
contains six tabs from which you can specify other default settings for the Basic Record
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form, the Basic Report form, the Basic Query screen, new forms, new query screens,
and new menu screens.

Form Properties (Form Designer)
In the Form Designer, choose Tools>Form Properties to specify how information will appear
when the form is used, either on the desktop or the Web. The Form Properties dialog box has
the following tabs:
General: Set properties for forms used on the desktop and on the Web. For example,
turn search highlighting on or off and set the distance between records.
Logos: Specify images to be included on forms used on the Web.
HTML: Set properties that will be used for forms used on the Web, or when writing a
report to HTML, or sending a report as mail in HTML format.

Distance Between Records
To specify the distance between records on a form
1. Choose Tools>Form Properties to open the Form Properties dialog box with the
General tab active.
2. In the Measurements group, type a value for the Distance between records. If a box at
the top of the form has a top offset (Tools>Box Properties>Position), that value is
added to the distance between records.
3. Click OK.
The value you specify determines the amount of vertical space between records in a report,
such as .15 inches or 1 line. To omit space between records, set the distance to 0.
The unit (inches, millimeters, points, or lines) is based on what is selected from the Vertical
units drop-down list in the Measurements group.
Note: If you define the form's vertical unit of measure to be lines, the font size can affect the
record spacing.
The distance between records is measured from the bottom of the lowest box in the first record
to the top of the highest box in the next record. The Top Offset (Tools>Box
Properties>Position) can affect record spacing. For example, if you specify .15 inches
between records, and the first box has a .05 inch Top Offset, you will see .2 inches between
the first record and the top box in the second record.
Tip! You can design a report to show summary information only, by making each box a sort
footer or report footer. To avoid large gaps in such a report, set the distance between records to
zero.

Basic Forms
DB/TextWorks automatically generates simple forms, called Basic forms, which you can use for
operations, such as display, edit, and print. Use Basic forms before you have created any of
your own, or whenever you want to see all fields in a record (except fields hidden by
passwords). Basic forms show every field in the primary textbase structure (except fields hidden
by passwords).
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There are two types of Basic forms:
The Basic Record form is for single-record display.
The Basic Report form is for multiple-record display and printing.
Basic forms are not stored in the textbase and are not separate files, but are generated "on-thefly" as needed. When you add, rename, or delete fields in the textbase, the Basic forms reflect
those changes automatically.
To specify which fonts are used in Basic forms, choose Tools>Options>Display and click the
Set Text Font or Set Label Font button. To control other Basic form attributes (for example,
form colors, box width), click the More Defaults button.
To see which forms are currently selected, or to select a different form, choose Display>Select
Forms.
To create a new form, you may want to start with a Basic form, make edits, and save it under a
new name (start by choosing Display>Design Form). You cannot overwrite, hide, or delete a
Basic form.

Opening a Form
To access this dialog box: Open a textbase and choose Display>Design Form (this is how you
enter the Form Designer). If the Form Designer is already open, choose Form
Operations>Open Form.
Existing Form. Select a form from the Start With list to load into the Form Designer, so
you can modify it. Forms that have the word (public) after them are saved in the
textbase file, so anyone who opens the textbase can use them. Forms without the word
(public) are saved in your personal user file, so only you have access to them. You
determine where forms are stored when you save the form. If no forms have been
created, you cannot select the Existing Form option.
Basic Form. This is often the easiest way to begin designing a form. The Basic forms
provide one box for each field in the textbase. You can add, format, and delete boxes in
the Form Designer. Select one of the Use These Defaults options to determine how the
form will appear initially in the Form Designer.
Blank Form. A blank form does not contain any boxes. Starting with a blank form can be
useful when your textbase contains many fields but you want to the form to include only
a few fields. The first thing you should do in the Form Designer is add one or more
boxes (Edit menu).
New Label Form. Select a label format from a list of standard label stocks. This is the
way you begin designing address labels, catalog cards, rotary cards, and so forth. If the
desired stock number does not appear in the list, select what you guess to be the closest
stock type. Then, in the Form Designer, choose Report Options>Set Up Page to
change the position and size of the labels.
New Tabular Form. Create a table, to present information in rows and columns. Tabular
forms are useful when displaying information on the Web with WebPublisher PRO.
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Box Types
A form consists of one or more boxes. To add a box to a form, choose Edit>Add and select the
type of box you want. You can add the following box types:
Form box. A box that contains field information, variables, and other information.
Text box. A box that contains static, informational text, such as a title or instructions.
Picture box. A box that contains static images or images referenced in a field in the
record.
Script input box. A box that lets the user type in information that will be used during the
processing of a script.
Script button. A button you place on a form that gives you the ability to call functions you
have written in the Form Script dialog box.
You arrange information on a form by adding and editing these boxes. Every form must contain
at least one box with contents.

Changing the Box Type
There are several reasons why you might want to change the box type when designing a form.
For example:
When you add a Header/Footer box, DB/TextWorks adds a form box. You can also
make text boxes, picture boxes, script input boxes, and script buttons into Headers
and/or Footers, but you first must add them to the form and then change them to Header
or Footer boxes. In order to change a text box, picture box, script input box, or script
button into a Header or Footer box, add it using Edit>Add. Then use Report
Options>Headers and Footers to change the box to the appropriate type of header or
footer.
Occasionally, as you add and define boxes, you may find that you have inadvertently
specified the wrong box type. Rather than having to delete the box and start over, you
can change a Header or Footer box to a Record box, and vice versa.
To change a box type
1. While working in the Record Area, select the box to be changed.
2. Choose Report Options>Headers and Footers to open the Headers and Footers
dialog box.
3. Depending on the change you want to make to the box, do the following:
To change the selected box to a Header or Footer box, select the box type you
want from the Header/Footer list. If you select Sort Header or Sort Footer, select a
level from the Sort Level drop-down list. Click the Change to Header/Footer
button.
To change from a Header or Footer box to a Record box, click the Change to
Record Box button.

Adding Boxes to a Form
A form consists of one or more boxes. Each box determines what information will be displayed
when the form is used. The different box types and operations are described below.
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Adding a box to the Record Area or Margin Area
The area of the form that is active when you add a box determines whether the box appears in
the Record Area or the Margin Area. To display and work in the different areas, use Show
Margin Area / Hide Margin Area / Work in Margin Area (Report Options menu).
Adding headers or footers
Ensure that you are working in the Record Area. Then choose Report Options>Headers and
Footers.
To modify a box
Use Tools>Box Properties to modify a box, or use the mouse to move or resize it.
To add a form box
To add a form box, choose Edit>Add>Form Box. When the Form Box Properties dialog box
opens, use the subtabs on the Contents tab to specify the contents of the selected form box.
After specifying box content, choose Tools>Box Properties>Labels to add a label. Use the
other tabs to specify box position settings, formatting settings, paragraph settings, and HTML
settings.
To add a text box
To add informational text such as instructions or a title, choose Edit>Add>Text Box. When the
Text Box Properties dialog box opens, type the text you want in the Text box on the Text tab.
Use the other tabs to specify box position coordinates and offsets, anchoring settings, font
attributes, the appearance of box borders, box background color, text justification properties
within the box, and HTML options.
To add a picture box
To add static images or images referenced in a field in the record, choose Edit>Add>Picture
Box. A square, gray box appears on the Form Designer and the Picture Box Properties dialog
box opens. Use the Picture tab to specify the type of image you want to appear on the form
(fixed image or record image). Use the Position tab to specify box position coordinates and
offsets, anchoring settings, and image size attributes.
To add a script input box
To add a script input box, choose Edit>Add>Script Input Box. When the Script Input Box
Properties dialog box opens, use the Position, Labels, and Font, Color tabs to specify attributes
for text and labels for the script input box. Script input boxes are for desktop use only; they are
not applicable to forms used on the Web.
Note: You must also define a script to use with your form.
To add a script button
To add script buttons to a form, choose Edit>Add>Script Button. When the Script Button
Properties dialog box appears, use the Caption tab to specify the text that will appear on the
button and to set font attributes for the text. Use the Position tab to specify box position
coordinates and offsets, anchoring settings, and button width. Script buttons are for desktop use
only; they are not applicable to forms used on the Web.
Note: You must create a script to handle the click of the button (Tools>Form Script).
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Moving Boxes in a Form
Use the methods below to move selected boxes in the Form Designer. When you reposition a
box, other boxes in the form may move depending on their position and anchoring.

Moving Boxes Using the Mouse or Keyboard Keys
In the Form Designer, you can manually move one or more boxes using one of the following
methods.
Drag a box using the mouse. A ghost image of the selected box appears so you can
position it on the screen. Release the mouse button at the position you want. When you
release the mouse button, the boxes below the selected box move down to
accommodate the repositioned box, if necessary.
Select a box, then press Ctrl+Arrow to move the box in the direction of the arrow key.
This simulates the mouse method. Release the Ctrl key at the position you want.
Select a box, then press an arrow key to move the box. This method cannot move a box
"across" another box. For example, when you move a box up, it will not go any higher
than the box above it. However, when you move a box down, the boxes below it move
down.
Use the Cut and Paste commands.
The distance the box moves each time you press an arrow key is based on the measurements
for Horizontal and Vertical grid settings selected as View>Grid Settings.

Moving Boxes Using Offsets or Coordinates
In the Form Designer, you can move a box by changing its Offsets or Coordinates settings on
the Position tab of the Box Properties dialog box.
1. In the Form Designer, select one or more boxes.
Note: The boxes you select do not necessarily have to be the same type. You can select
different type boxes (for example, picture box and text box). When different type boxes
are selected, the Multiple Selection Properties dialog box appears.
2. Choose Tools>Box Properties>Position.
3. Change the Offsets or Coordinates values, then click Apply.
Note: The units of measurement used for offsets and coordinates are determined by the
settings in Tools>Form Properties>General.
Offsets. Position offsets indicate the relative position of a box to the form or
another box.
To move a box left or right, change the value for Left. For floating boxes or boxes
anchored to the form, the left offset indicates the distance from the left edge of the
selected box to the left margin, or the page edge if the box is in the Margin Area. For
boxes anchored to another box, the left offset indicates the distance from the left edge of
the selected box to the right edge of the box to which it is anchored. When you change
the left offset of a box on the left side of an anchored pair, the box(es) on the right move
accordingly.
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To move a box up or down, change the value for Top. For floating boxes, the top offset
represents the distance from the top of the selected box to the bottom of the box above it,
or the distance to the top of the form if there are no boxes directly above it. For boxes
anchored to the form, the top offset represents the distance from the top of the selected
box to the top of the form, or the page edge if the box is in the Margin Area. For boxes
anchored to another box, the top offset represents the distance from the top of the
selected box to the top of the box to which it is anchored.
Coordinates. Coordinates indicate the absolute position of the box on the form.
To move a box left or right, change the value for X. The X coordinate indicates the
distance from the left edge of the selected box to the left margin, or the page edge if
working in the Margin Area.
To move a box up or down, change the value for Y. The Y coordinate indicates the
distance from the top edge of the selected box to the top margin edge if the box is in the
Record Area, or the page edge if the box is in the Margin Area.

Anchored and Floating Boxes
All types of boxes in the Form Designer can be anchored or floating.
Because DB/TextWorks allows variable-length fields, form boxes can shrink or grow to
accommodate the current information. For example, the Notes field might hold one sentence in
one record and three paragraphs in another record. As the height of a box changes, it can affect
the position of the boxes below it. Because you can resize picture boxes, and text boxes grow
with the amount of text they contain, the size of these boxes can vary as well. You can control
how the boxes below react by determining whether they are:
Floating
Anchored to the form
Anchored to another box
Note: A script input box will not grow to accommodate text on Report window forms. However,
the above applies to script input boxes in the Query, Display, and Edit windows, as well as on
menu screens. See Changing Script Input Box Height for more information on how to
accommodate lengthy text in script input boxes in Report window forms.

Floating boxes
When a box is floating, the vertical position of the box varies depending on the height of the
box(es) directly above it. As one box grows or shrinks, the floating boxes beneath it
automatically float down or up. When all boxes are floating, you can be sure that information in
one box will never overwrite information in another box.
A floating box is dependent on any box located above it if the boxes overlap in horizontal
dimensions (if they are stacked above one other). They do not have to touch. If a box above a
floating box grows or shrinks, the floating box moves beneath the lowest box above it.
By default, all boxes added in the Record Area are floating. Floating boxes move up or down
automatically, depending on the amount of information that is displayed in the box(es) above
them. Only the vertical (up and down) position of a floating box is affected, not the horizontal
(right and left) position. By allowing boxes to float, you ensure that as one box grows to display
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information, any floating boxes beneath it automatically move down so they do not overlap.
Similarly, when a box shrinks, floating boxes beneath it move up.
To make a box float
1. In the Form Designer, select one or more boxes.
2. Choose Tools>Box Properties to open the applicable Box Properties dialog box.
3. On the Position tab, select the Floating option button from the Anchoring group, and
click Apply.

Anchoring Boxes to the Form
When you anchor a box to the form, the box remains fixed in its current position, regardless of
what the other boxes do. The box can still shrink and grow, but the top left position will not
change. Boxes that are anchored to the form always remain in an absolute position. This can be
useful when you want to fix a box position, for example, if you are laying out information to print
on a preprinted form, such as an invoice.
By default, the first box added in the Margin Area is anchored to the form because it usually
contains information, such as a title, that you want in a fixed position.
To anchor a box to a form
1. In the Form Designer, select the box you want to anchor.
2. Choose Tools>Box Properties to open the applicable Box Properties dialog box.
3. On the Position tab, in the Anchoring group, select the Anchor to form option button.
4. Click Apply.
5. Because the position of an anchored box is fixed to the form, information in the box
might be obscured if a box above it grows. To avoid this situation, be sure to limit the
maximum height for any boxes above the anchored box.

Anchoring a Box to Another Box
A box can be horizontally anchored to another box (side-by-side), so they always move up or
down together. This is useful when you want two or more boxes to float up or down together.
This keeps the boxes in the same relative position, even as the amount of information above or
below those boxes shrinks or grows.
Anchoring a box does not restrict its size; it can still shrink and grow vertically.
The View>Boundaries command turns display of anchor-to-box arrows on or off in the Form
Designer.
To anchor a box to another box
1. In the Form Designer, select the box that you want to anchor. Note: To anchor boxes,
you select one box, then anchor it to a box on its left. The boxes must not overlap in
horizontal dimensions. In other words, they cannot be stacked above one another.
2. Choose Tools>Box Properties>Position.
3. On the Position tab, select Anchor to Box in the Anchoring group.
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Note: The Anchor to Box option is disabled if more than one box is selected or if the
current box cannot be anchored to any boxes. To align and anchor multiple boxes, select
the boxes and choose Tools>Align Boxes>Anchor and Top.
4. From the drop-down list, select the box to which you want to anchor (it can be a floating
box, anchored to the form, or anchored to another box.) Only boxes to the left of the
current box appear in the list. Boxes are identified by their labels. Boxes without label
text are identified by the first content item, shown in angle brackets, such as
<field=Product>.
5. Click Apply.
6. To adjust the distance between the box(es), use the Left Offset setting on the Position
tab in the Box Properties dialog box.

Adding Textbase Fields to a Form Box
You can select a field from the primary or secondary textbase to be added to the form box. For
example, if you select a field called Title, you will see the field contents (for example, Myths and
Magic) in this box when you use the form.
Fields from a secondary textbase are called linked fields and are designated by the link indicator
(@). For example, the field Client name@Assignment ID is a linked field. Accessible linked
fields in the textbase are listed after fields in the primary textbase in the Fields list.
Note: If you have selected the Sort textbase fields alphabetically check box on the Display
tab of the Options dialog box (choose Tools>Options>Display), the secondary textbase fields
will be interfiled with the primary fields.
Add a linked field whenever you want to see information from a secondary textbase. You cannot
add linked fields unless the primary textbase contains at least one Link field.
To add textbase fields to a form box
1. In the Form Box Properties dialog box, select the Fields subtab on the Contents tab.
From the Fields list, select the primary or secondary textbase field you want.
2. [Optional] In the If empty use box, type the text you want to appear in the form box if the
field you specified is empty. For example, if the Edition field is empty, you might want the
word unknown to appear. The text you specify does not appear when the field contains
information. Because the text is part of the form, it does not appear when you edit a
record, nor can you search for it.
3. Click Add.
The buttons on the Fields subtab perform the following actions:
Add. Adds the item selected in the Fields list to the form box. The item is placed at the
bottom of the Contents list and positioned last in the form box.
Replace. Replaces the currently selected item in the Contents list with the item shown in
the Fields list. Typically, you would select an item in the Contents list, select a field or
change the data in the If empty use box, then click Replace.

Adding Variables to a Form Box
A variable is an item with a value that varies, unrelated to information in the record, depending
on certain factors. For example, the DATE variable displays the current system date.
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Some variables are intended to be used in a specific area of the form. For example, PAGE
NUMBER only makes sense in the Margin Area, while RECORD NUMBER only makes sense in
the Record Area. If you place a variable in the Margin Area of a form, the variable will be visible
only when the report is printed.
You can change the variable's appearance by choosing Tools>Box Properties>Format and
using the subtabs.
To add a variable to a form box
1. On the Form Box Properties dialog box, select the Variables subtab on the Contents tab.
2. Select a variable from the list. See below for an explanation for each item on the list.
3. Click the Add button to move your selection to the Contents list.
4. Click Close.
The buttons on the Variables subtab perform the following actions:
Add. Adds the item selected in the Variables list to the form box. The item is placed at
the bottom of the Contents list and positioned last in the form box.
Replace. Replaces the currently selected item in the Contents list with the item selected
in the Variables list. Typically, you would select an item from the Contents list, select an
item from the Variables list, then click Replace.

About the Variables list
You can select one of these variables:
Current Date or Time. The DATE and TIME variables display the system date and time.
Use them to indicate when a report was generated or printed. To make the date and/or
time appear on every printed page, place one or both variables in a box in the Margin
Area. Date and time formats are controlled by the formats selected in the Regional
settings of the Windows Control Panel. By default, the DATE variable appears in the
short date format (for example, 7/25/2002 in the United States). You can change the
format of the date (choose Tools>Box Properties>Format>Numbers, Dates), if you
want.
Page Number. The PAGE NUMBER variable generates page numbers in a printed
report. Put the PAGE NUMBER variable in a box in the Margin Area, so it prints on every
page. Each page is numbered with Arabic numerals, starting with page number 1 or
another number you specify. Because the page number appears in the Margin Area, you
would not include the PAGE NUMBER variable in a form not used for printing.
Record Number. The RECORD NUMBER variable numbers each record sequentially in
a report. The records are numbered in the order in which they appear in the report
(determined by the sort order). Use the RECORD NUMBER variable in the Record Area
of a form, typically in a separate box to the left of the record information.
Record Count. The RECORD COUNT variable displays the total number of records in
the set. Note that the count may be different than the number of records that appear in
the report, if certain sort options are used. Use the RECORD COUNT variable in a
Report Header or Report Footer box in the Record Area of a report form.
Note: When you do an exploded sort, the RECORD NUMBER counts up to the total
number of records in the report, but the RECORD COUNT variable shows the number of
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records in the set, so if you use these two variables together you could see something
like Record 106 in a set of 53 records. In this situation, use a COUNT(1) calculation
instead of the RECORD COUNT variable. (Note that this only works in Report Footers.
However, you can use it in Sort Footers, but it only counts the total in the Sort Key, not
the report.)
Textbase Name. The TEXTBASE NAME variable displays the name of the current
textbase. You may find it useful to display the textbase name in a Report Header box of
a printed report. For example, a Report Header box might include the textbase name,
record count, date, and search strategy.
Search. The SEARCH variable displays the criteria of the search that generated the set
of records in the report. The SEARCH variable is typically used in a Report Header box
in a report. The SEARCH variable shows the search criteria in Command query format,
regardless of whether you used the query screen or the Command query window.
Criteria typed in different query boxes appear on separate lines, for example:
find (Type =Letter)
and (Date >=2003-Jan-15)

You may want to precede the SEARCH variable with text (for example, Strategy:), which
you can enter as beginning text (through the Format tab, on the Added Text subtab).

Adding Calculations to a Form Box
You can specify a calculation as the content of a form box. When you use the form, the software
performs the calculation and displays the result in that box. Calculations operate on numeric
and date information. You can also count entries in text fields.
You can use calculations to perform addition, subtraction, multiplication, and division on numeric
information. Calculations can also compute averages, subtotals, and grand totals, find the
highest or lowest value in a field or group of records, and supply other useful information. With
dates, you can subtract two dates (to yield a number of days), or add or subtract a number from
a date (to yield another date).
Case is not significant when you type the formula for a calculation. For example, if a field is
called Date Ordered, you can refer to it as "date ordered" in the calculation. Field Functions and
Record Functions are shown in this section in capital letters for clarity only.
A few examples of the many types of calculations are shown below.
This calculation

Does this

ordered - shipped

Calculates how many units are backordered by subtracting the
quantity shipped (Shipped field) from the quantity ordered (Ordered
field). The result is a number (such as 20).

"invoice date" + 90

Calculates when an account is overdue by adding 90 days to the
first date found in the Invoice Date field. The result is a date (such
as 10/12/2002).

MIN(price)

Calculates the lowest value in the Price field in a group of records.

FAVG(score)

Calculates one student's grade point average by averaging all
entries in the Score field in the current record. The result is a
number (such as 85).
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The results of a numeric or date calculation are formatted based on the Number and Date
Formats in the Regional settings of the Windows Control Panel, and the Numbers, Dates
options you select for this content item by choosing Tools>Box Properties>Format>Numbers,
Dates). By default, numbers appear without decimal digits, and dates appear with the short date
format (for example, 7/25/2002 in the United States).
Note: A calculation specified in a form cannot be searched or sorted, because it is not a field. If
you want to be able to search for or sort by computed information, edit the textbase structure to
add a Computed Number or Computed Date field. Computed field formulas cannot include
secondary fields or @DATE, like form calculations can.

Where to Place a Calculation in a Form
You typically place a calculation in one of three box types within the form's Record Area:
Record box. Use a Record box to perform a calculation on information in the current
record. The calculation is performed once for each record. For example, if each order is
a record, the calculation (qty * price) * (1 + tax) determines the invoice amount. Typically,
a calculation in a Record box involves four-function arithmetic and, perhaps, Field
Functions.
Sort Footer box. Use a Sort Footer box for subtotals or other summary calculations.
When you place a calculation in a Sort Footer, it appears only below the last record in
the group sharing the sort key at the specified Sort Level. Typically, a calculation in this
box involves Record Functions.
Report Footer box. Use a Report Footer box for grand totals or other summary
calculations. When you place a calculation in a Report Footer, it appears only once at
the end of the report. Typically, a calculation in this box involves Record Functions.
Counts and totals for multiple field entries within the current record should be put in Record
boxes. Counts and totals across records in a group should be put in a Sort Footer box. Counts
and grand totals for all records in the report should be put in a Report Footer box.
In reports, calculations that are Record Functions operate within the current Sort Level if placed
in a Sort Footer. They operate across all records if placed in a Report Footer. For example, if
TOTAL(cost) is placed in a Sort Footer, and the report is sorted by product, the calculation finds
subtotals by product. The result might be $300 in the Widgets category and $500 in the Gadgets
category. If TOTAL(cost) is placed in a Report Footer box, the result is a grand total ($800 in
this example).
To add a calculation to a form box
1. In the Form Designer, select an existing form box or add a new box.
2. On the Form Box Properties dialog box, select the Calculations subtab on the Contents
tab.
3. Type a calculation in the Calculation formula box, or click the Enlarge button to open a
larger, resizable text editor dialog box instead. When you click OK on the text editor
dialog box, your text appears in the Calculation formula box on the Calculations subtab
automatically.
4. Click the Add button.
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Calculation Components and Operators
A calculation can include one or more of the following components.
Description

Component
Fields

Any combination of fields from the primary or secondary textbases
containing number or date values. A field may not contribute more than
one number to a computation. If a field contains multiple entries, only
the first entry is used (except in the case of Field Functions, which are
intended to be used with multiple-entry fields).

Numbers

Any whole or fractional number, such as 3 or 1.5

Today's Date

The current date, specified as @DATE

Field Functions

FCOUNT, FTOTAL, FMIN, FMAX, and FAVG are used with fields that
contain multiple entries. Follow a Field Function with a field name in
parentheses.

Record Functions

COUNT, TOTAL, MIN, MAX, and AVG operate across records in a
group. These functions are intended to be placed in a Report Footer or
Sort Footer box. Follow a Record Function with a field name in
parentheses.

To connect components in a calculation, you can use the following arithmetic operators.
Operator
+
*
/
()

Used for
Addition
Subtraction or negative numbers
Multiplication
Division
Surrounding field names or expressions that follow functions, or grouping
items

Calculations are performed using the algebraic order of arithmetic operations. Operations
enclosed in parentheses are performed first. Multiplication (*) and division (/) are performed
second. Addition (+) and subtraction (-) are performed last. Among equally ranked operations
(such as multiplication and division), operations are performed from left to right. To avoid
ambiguity, use parentheses to ensure that the calculation produces the desired results. For
example, this calculation subtracts Cost from Price before dividing the result by the product of
the Number field and 12:
(price - cost) / (number * 12)

Without the parentheses, this calculation would yield a different result, because it would divide
Cost by Number, multiply the result by 12, and subtract that result from Price.
Note that a calculation interprets the result of division by zero to be zero.

Using Dates in a Calculation
When you subtract two dates, the result is a number of days. If you add or subtract a number of
days from a date, the result is a date. DB/TextWorks looks for a date in a Date, Computed Date,
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or Automatic Date field. In any other field, it looks for a number. Dates in any other field type are
interpreted in a calculation as a number. For example, consider this calculation:
notes + 30

If the Notes field is a Text field (or any other non-date field) and it contains the date 3/10/03, the
date will be interpreted as the number 3, to yield a result of 33.
Do not include a static date as part of a calculation. For example, 12/10/02 + 1 is not a valid
calculation. To include dates in a calculation, reference a Date field ("date sold" + 1) or use
@DATE, as explained below.

Using Today's Date
You can include @DATE in a calculation to represent the current system date. For example, if
you place the calculation @DATE in a form box, that box will always show the current date. Be
careful when using @DATE as part of a calculation, because the date generated changes daily.
For example, @DATE + 14 yields a different date on June 1 than it does on June 2.
To generate a constant date, add an Automatic Date field to the textbase structure and specify
that the entry should be updated only when the record is created (not modified). Then you can
design a form that includes a calculation based on that static date. For example, the calculation
"date borrowed" + 14 could be used to show the due date for a library book.
The decision to reference an Automatic Date field or use @DATE in a calculation depends on
how you use your textbase, and what results you are trying to achieve.

Using Fields in a Calculation
A calculation can include any field from the primary or secondary textbases that contains a
number or date. To indicate a primary textbase field, use the actual field name in the textbase.
To indicate a secondary textbase field, use the @ symbol field name.
Note: The FCOUNT functions can also be used on other text information.
If a field name is a number or includes spaces, surround it with single or double quotation
marks, such as '24' or "date sold" or "customer discount"@"customer phone number". In the
following example, the calculation computes the customer discount amount by multiplying a field
in the primary textbase (price) by the discount amount in the secondary textbase ("customer
discount"@"customer ID").
price * "customer discount"@"customer ID"

If only one part of a secondary textbase field name is a number or includes spaces, you need
quotation marks for that part only.
price * discount@"customer ID"

When a calculation references any non-date field, the software looks for a number at the
beginning of that field. For example, in this calculation, DB/TextWorks expects to find a number
at the beginning of the Price field:
price * 2

The number in the field can be preceded by a space, a currency symbol ($, £, and so on), a
minus sign (-), or a left parenthesis, and it can contain an embedded thousand separator and
decimal separator. The number cannot be preceded by any other characters. For example, 345
is a number, and so is $345.00, but Commission $345 is not.
If the field is empty or if it does not start with a number, zero (0) is used in the calculation.
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Only one number from a field is used in a calculation. If the field starts with a number and
contains other information after it, the other information is ignored. This means that only the first
entry in a multiple-entry field will be used in a calculation (unless you use a Field Function). For
example, DB/TextWorks sees only the number 12 in the following multiple-entry field.
12 units ordered and 8 shipped
6
10

Use a Field Function to include values from multiple entries in a field in the calculation. For
example, if the Quantity field contains three entries (12, 6, 10), the calculation quantity + 5 adds
5 only to the first entry, to yield a result of 17. To add 5 to the total of all the entries in a field,
use FTOTAL(quantity) + 5 to yield a result of 33.

Using Functions in a Form Calculation
The functions that you can use in a calculation are summarized in the following tables.
Examples of how to use the functions follow the table. Functions that begin with the letter "F"
are Field Functions. Functions that do not begin with "F" are Record Functions. Note that
function names are shown in capital letters for clarity only. You can use any case when typing
them.
Note: All the Field Functions are similar to Record Functions with the exception of FCOUNT
and COUNT. While the other functions look only at numbers or dates in the field, FCOUNT
counts all entries, even alphabetic ones. COUNT looks at nonzero numbers only.

Field Functions
Field Functions are used for summary calculations on the entries in a field in the current record.
A Field Function must be followed by the name of a field in parentheses. For example, FMIN
(price) finds the lowest value in the Price field in the current record.
Field Function

Description

FMIN(field)

Determines the lowest value of all entries (numbers and dates only) in
the specified field for the current record.

FMAX (field)

Determines the highest value of all entries (numbers and dates only)
in the specified field for the current record.

FAVG(field)

Averages all values in the specified field for the current record. Only
numbers (not dates) can be averaged.

FCOUNT(field)

Counts the number of entries in the specified field for the current
record. Can be used with textual information, as well as numbers and
dates. FCOUNT used on an empty field returns a value of zero (0).

FTOTAL(field)

Determines the sum of all entries in the specified field in the current
record. Only numbers (not dates) can be totaled.

Record Functions
Record Functions only make sense when used in a report, because they operate across
multiple records in a group. A group refers to all of the records in the current report or Sort
Level. See Where to Place a Calculation.
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Record Functions are always followed by a parenthetical expression, such as MIN (cost), which
finds the lowest value in the first entry in the Cost field in all records in the current report or Sort
Level.
Unlike Field Functions, the information in parentheses is not limited to a field name. It can be an
entire expression. For example, AVG (FMAX (price - FMIN (price)) shows the average price
spread.
Record Functions only look at the first entry in each record, unless they are combined with a
Field Function. For example, the calculation TOTAL (price) only totals the first price in each
record's Price field. The calculation TOTAL (FAVG (price)) totals the average price in each
record.
Record Function

Description

MIN (field)

Determines the lowest value in a group of records (numbers and
dates only).

MAX (field)

Determines the highest value in a group of records (numbers and
dates only)

AVG (field)

Averages numbers across a group of records (numbers only).

COUNT (field)

Counts the non-zero numbers in a group of records.

COUNT (1)

Counts all records, even if they do not start with a number.

TOTAL (field)

Finds the sum of the numbers in a group of records.

Finding the Lowest Value
Use MIN and FMIN to find the lowest number or earliest date, within the guidelines presented in
the Field Function and Record Function tables.
Examples
MIN (price) finds the lowest price among first entries in the Price field in a group of records.
FMIN (price) finds the lowest price in all entries in the Price field in the current record.
MIN (FMIN (price)) finds the lowest value in any entry in the Price field in the group of records.

Finding the Highest Value
Use MAX and FMAX to find the highest value or most recent date, within the guidelines
presented in the Field Function and Record Function tables.
Examples:
MAX("order date") finds the most recent date that a product was ordered, by looking at
the first entry in the Order Date field in all the records in the group. Note that a field
name that contains a space must be surrounded by quotation marks.
FMAX(contact) determines when a customer was most recently contacted.
MAX(FMAX (contact)) finds the most recent date any customer in the group was
contacted.
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Finding Averages
Use AVG and FAVG to determine averages, within the guidelines presented in the Field
Function and Record Function tables.
Note that there are several ways to compute the average value of a field. The calculation
AVG(field) produces an average value across all records—even those containing no number or
the number zero in the field. However, the calculation TOTAL(field) / COUNT(field) averages
only the numbers greater than zero.
To average:
Multiple entries in a field

Do this:
Use FAVG. For example, place the calculation FAVG(score) in a
box. If John Jones has three test scores in the Score field (80,
81, 85), the calculation will produce his average: 82.

The first (or only) value in a Use AVG in a Sort Footer or Report Footer. For example, use
field in a group of records
AVG(price) in a Sort Footer to find the average price of records in
a sort level. Use AVG(price) in a Report Footer box to find the
average price of records in a set. Use AVG(price * quantity) to
find the average sale amount.
All entries in a field in a
group of records

Use AVG(FAVG (field)) in a Sort Footer or Report Footer. For
example, to find the average of all entries in the Price field in the
current group, use AVG(FAVG(price)).

Counting Records and Field Entries
Use COUNT to determine the number of records that start with a non-zero number in the
specified field in a group of records.
Use FCOUNT to count the number of entries in the specified field in the current record,
regardless of what the entry contains (text, numbers, dates). FCOUNT used on an empty field
returns a value of zero (0).
Use COUNT(1) in a sort footer box to count all records in that Sort Level. Use COUNT(1) in a
report footer box to count all records in the report.
Note: In an exploded sort, COUNT counts each occurrence of a record (a record that appears
more than once in the report). So the numbers of records counted is almost always greater than
the number of records in the set.
Examples:
COUNT (price) counts the number of records that start with a non⌀zero number in the
first entry of the Price field, to yield a number, such as 12. If the Price field in a record
starts with text or does not contain a number, it is not included in the count.
COUNT (1) counts the number of records in the report or in the Sort Level group.
FCOUNT (author) counts the number of entries in the Author field in the current record.
TOTAL (FCOUNT (author)) counts the number of entries in the Author field in all records
in the report.
COUNT (FCOUNT (author)) tells you how many records have at least one author.
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Producing Summary Calculations
You typically place subtotals and similar summary calculations in a Sort Footer box and grand
totals in a Report Footer box. Some examples are listed below.
Examples:
TOTAL ("total price") in a Sort Footer box totals the price of each order in the
corresponding Sort Level group (for example, the total price of all orders in this Region).
TOTAL ("total price") in a Report Footer box totals the price of all orders in the report.
AVG (@DATE - "invoice date") in a Report Footer box shows the average age of your
receivables.
COUNT (1) in a Sort Footer box shows how many records are in that Sort Level group.

Using Numbers in a Calculation
A calculation can include any whole number or fraction. The number is interpreted as a value or
a number of days, depending on whether the calculation references a Number or Date field. For
example, consider this calculation:
sold + 30

If Sold is a Number field (quantity sold), the calculation adds 30 to the quantity to yield a
numeric value. If Sold is a Date or Automatic or Computed Date field (date sold), the calculation
adds 30 days to yield a date.

Adding Fixed or Prompted Text to a Form Box
Use the Text subtab on the Contents tab to add fixed or prompted text to a form box.

Fixed Text
Fixed text is text that always appears in the form box exactly as you type it in the Text box.
Fixed text can include text, numbers, spaces, line breaks, and extended characters. It cannot
include the Tab character.
You can combine fixed text with other content items, such as inserting Page in front of the
PAGE NUMBER variable to achieve an effect such as Page 1. One space is added
automatically after each content item in a box, so items do not run together. You can suppress
the space by clearing Separate items or entries with spaces on the Paragraphs tab (choose
Tools>Box Properties>Paragraphs).
Because fixed text is a content item, it always appears when this form is used. For example, if
you place the text Written by in front of the Authors field, Written by will appear in the box even if
the Authors field is empty. Compare this to added text, which does not appear if a field is empty.
For more information, see the recommendations about when to use or avoid fixed text.
You can add an unlimited number of fixed text items to a single box (type text, click Add, type
new text, click Add again). Each item can be formatted individually (choose Tools>Box
Properties).
To add fixed text to a form box
1. In the Form Designer, add a form box OR select an existing form box and choose
Tools>Box Properties to open the Form Box Properties dialog box.
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2. On the Text subtab, select the Fixed text option button.
3. Type the text you want in the Text box, or click the Enlarge button to open a larger,
resizable text editor dialog box instead. When you click OK on the text editor dialog box,
your text appears in the Text box on the Text subtab automatically.
4. Click Add. Optionally click the Up or Down buttons on the Contents tab to position the
fixed text in the Contents list.

Prompted Text
Prompted text is a question or an instruction, such as Enter your initials, that appears in a dialog
box when you use the form. The user's typed response to the prompt appears in the specified
form box when the form is displayed, printed, and so forth.
Prompted text gives you the ability to display information that can only be obtained from the
user. For example, you could prompt for the user's initials, department, or the name of the field
by which the report is sorted. If you place the form box in the Margin Area, the response
appears on each page of the printed report.
To add prompted text to a form box
1. In the Form Box Properties dialog box, add a form box OR select an existing form box
and choose Tools>Box Properties to open the Form Box Properties dialog box
2. On the Text subtab, select the Prompted text option button.
3. Type the text you want in the Text box, or click the Enlarge button to open a larger,
resizable text editor dialog box instead. When you click OK on the text editor dialog box,
your text appears in the Text box on the Text subtab automatically. For example, type
Enter your initials.
Note: Avoid using the ampersand character (&), as it does not appear and the next
character us underlined.
4. Click Add.
To respond to the prompt when the form is used
1. Type the requested information in the Information Needed dialog box.
2. Click OK.

Added Text
Added text is text and/or punctuation that appears with box contents when a particular form is
used. For example, you can use beginning text to make the words Written by appear in front of
the Author field: Written by John Brown.
Added text takes on the same font attributes as the content item to which it is applied, and does
not appear when a content item is missing. For example, if a field is empty, its added text does
not appear.
Tip! You can use HTML as added text to wrap around the data in the field specified as the box
contents.
To specify added text
1. In the Form Designer, select one or more form boxes.
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2. Choose Tools>Box Properties>Format>Added Text.
3. From the Contents list, select the item you want to format, or select <all> to apply the
formatting to all content items in the selected box.
4. Select the type of added text you want to add, then type what you want to appear in the
appropriate box, or click its Enlarge button to open a larger, resizable text editor dialog
box instead. When you click OK on the text editor dialog box, your text appears in the
appropriate box on the Added Text subtab automatically.
5. Click Apply. Then click Close.
You can add the following type of text:
Beginning text. Type text or punctuation to appear before the content item. Include a
space at the end of the beginning text if you want a space before the information that
follows. If a field contains multiple entries, beginning text precedes only the first entry. If
beginning text is added to an item that is also numbered, item numbering starts
immediately after the beginning text. (To align numbered items in a list in this situation,
press Enter at the end of the beginning text.)
Tip! To enclose an item in parentheses, use beginning text to add a left parenthesis in
front of the item, and ending text to add the right parenthesis after the item.
Ending text. Type the text or punctuation you want to appear after the content item.
Ending text is commonly used to add commas between several items in a box. If the
content item is a multiple-entry field, the ending text follows only the last entry. If the field
is empty, the ending text does not appear. If you want spaces between the text and the
information that precedes it, include a space before the ending text (type a space as the
first part of the ending text).
For example, if a box contains several address fields (for example, Street, City), you can
use ending text to add commas after each field:
254 Elm Street, Anytown, VT

Ending punctuation. Type punctuation to appear after the content item. A common use
is to add a period at the end of a field. If a content item already ends with punctuation,
the ending punctuation does not appear. This avoids duplication of punctuation and is
what distinguishes ending punctuation from ending text (which always appears after
non-empty fields).
Example:
Two book titles appear as follows, before any formatting is applied (the exclamation point is
part of the record information):
Let's Learn French!
The Case of the Missing Scarab

If you specify a period as ending punctuation, the result is as follows. Notice that the
period is not added after the existing punctuation:
Let's Learn French!
The Case of the Missing Scarab.

Ending punctuation always appears before ending text.
Separator text. Use separator text to visually distinguish between multiple entries in a
field. The separator text that you specify follows each entry except the last. If a field has
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only one entry, the separator text does not appear. Separator text appears only for
fields, not for other content items.
Type the text or punctuation you want in the Separator text box. A comma or semicolon is commonly used to separate entries when No added paragraph breaks is
selected from the Paragraph breaks drop-down list. For example, if your field appears
like this without separator text:
Red Yellow Blue

You can use a comma and space as the separator text to make the entries appear like
this:
Red, Yellow, Blue

Separator text appears regardless of paragraph breaks. For example, if the Paragraph
breaks drop-down list is set to Make each item or entry a paragraph, the entries would
appear like this:
Red,
Yellow,
Blue

Separator text can be a combination of text and punctuation. For example, a space
followed by the word and and another space looks like this:
Red and Yellow and Blue

Using HTML as Added Text
You can use HTML as beginning, ending, and/or separator text on forms designed for use with
DB/Text WebPublisher. Use HTML to wrap around the contents of a form box.
For example, you can create a hyperlink on your form that, when clicked, will display an image
from a field containing an image file name. (The image will correspond to the record being
displayed in the form.) To do this, type the following HTML code in the appropriate boxes on the
Added Text subtab of the Format tab on the Form Box Properties dialog box.

Note: The ending text begins with the closing quotation mark for the Image name.

More about Separator Text
Here are some hints and tips about specifying separator text as added text.
In the Edit window, multiple entries are separated by the field entry delimiter specified in
Tools>Options>Display.
If you do not specify separator text, a single space separates entries in display windows and
reports when the Paragraph breaks drop-down list is set to No added paragraph breaks
(choose Tools>Box Properties>Paragraphs and accept the default setting of one space
between content items).
To get a blank line between entries, press Enter twice.
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You can use separator text to create a check list effect before each entry. Select No added
paragraph breaks, from the Paragraph breaks drop-down list to specify an underbar (_) as
beginning text, and specify a line break (press Enter) and an underbar (_) as the separator text:
__ M. Pierce
__ R. LaCivita
__ N. Chen

Adding Text and Punctuation to Field Information
There are several ways to add text and punctuation to field information in a form:
Define it as fixed text (Tools>Box Properties>Contents>Text).
Define it as added text (Tools>Box Properties>Format>Added Text).
Add it as a box label (Tools>Box Properties>Labels).
Each method can be useful, depending on your purpose, as shown in the table below:
Objective

Fixed text
(Content)

Added text
(Format)

Box label
(Labels)

Text will disappear if the field is
empty

No

Yes

Yes*

No space between text and the
field

Yes**

Yes

No

No

Yes

No

No

Yes

Text and boxes for multiple boxes No
will be aligned

No

Yes

Text will be a different font or color Yes
than the field
The fixed text will be visible in
editable boxes in an Edit form

*The box label will disappear only if the box is empty and the minimum box height is 0 lines.
**Use fixed text only if you have cleared the Separate items or entries with spaces check box
on the Paragraphs tab in the Box Properties dialog box.

Using fixed text
Use fixed text (choose Tools>Box Properties>Contents>Text) when you want to specify text
that should always appear in a form box, such as the title of a printed report. You can also use
fixed text when you want the text to be a different font from the other box contents and using a
box label is not appropriate. In the following example, the words and punctuation Record ID: are
a normal font, while the Record ID field is a bold font.
Record ID: 0123

Be careful when using fixed text to specify punctuation, because a space is inserted by default
between content items. For example, if you specify parentheses as fixed text around the Title
field, there will be spaces between the parentheses and the title.
( The Sun Also Rises )
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To avoid this extra space, use text formatting (choose Tools>Box Properties>Format>Added
Text) instead to add the parentheses; or choose Tools>Box Properties>Paragraphs and clear
the Separate items or entries with spaces check box.
Fixed text always appears, even if other content items in the same box do not appear. For
example, if you specify parentheses as fixed text around the Title field, and the Title field is
empty for a record, the form box will display empty parentheses.
( )

A box that contains fixed text will never disappear (even if its minimum height is set to zero),
because it will never be empty.

Using added text
Use added text (choose Tools>Box Properties>Format>Added Text) when you want to add
text or punctuation that appears only when the field contains information. When the field is
empty, the added text does not appear. For example, you may not want the words Written by to
appear if the Author field is empty.
Added text has the same font as the content item it modifies. Any formatting, except the font,
that you add (including text or punctuation) temporarily disappears while you are editing a
record, to make the record content easy to identify. For example, if you insert Due Date: in front
of a field, those words disappear while you are editing the record. When you display the record
in a non-Edit window, the formatting appears again.
Tip! You can use HTML as added text to wrap around the data in the field specified as the box
contents.

Using a box label
To identify what is in a field, you can use a box label (choose Tools>Box Properties>Labels)
as an alternative to fixed text or added text. A box label is the method that should be used in the
Edit window when one or more of the following conditions exist:
The field is the only content item in the box or the label is appropriate for everything in
the box.
You want the label text to appear in a different font or color than the content.
You want both the label text and box contents for a series of boxes to be aligned (for
example, the box labels will be aligned right and the box contents will be aligned left.
Label

Contents

Name
Leslie Jaynes
Address
144 Maple Ave.
City, State, ZIP
Newtown, Mississippi 62541

You want the label text outside the box border, if a border is present.
If you use a box label to add text or punctuation, and the minimum box height is set to zero, the
box label disappears when the field is empty in a non-Edit window.

Adding Column Headings to a Form
You can add column headings to any form. For non-tabular forms, column headings are
typically text boxes or form boxes containing text. For tabular forms, use box labels. The design
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of your form determines where you place the column headings. Typically, you would add
column headings after you add and size the corresponding Record boxes.
To place a column heading:

Do this:

At the top of every printed page

Add a text box in the Margin Area

At the top of the first page only or at Add a text box in the Record Area and convert it to a
the beginning of a displayed report Report Header box.
At the top of a tabular form

Use box labels (Tools>Box Properties>Labels).

Consider the form usage when planning column headings. If you place a column heading in a
Margin box in the Margin Area, it will appear on every page of a printed report. Column
headings placed in the Margin Area do not appear if the same form is used in the Report
window, for Send Report as Mail, and so forth. If you place a column heading in a Report
Header box, it will appear once at the beginning of the report. If you create a column heading
using a box label in a tabular form, it will appear once at the beginning of the displayed report,
or at the top of each printed page.
Tip! In a tabular form, the box labels are the column headings. They print on every page.
To create column headings on every printed page (non-tabular forms)
1. The Margin Area must be visible and active. To show it, choose Report Options>Show
Margin Area. To activate it, choose Report Options>Work in Margin Area.
2. Click the Add Text Box button on the toolbar or choose Edit>Add>Text Box.
3. On the Text Box Properties dialog box, type a column heading in the Text box. Click
Apply.
4. Move and size the box, as needed.
5. Repeat steps 2– 4 for each column heading you want to add.
6. Format the box contents using the tabs of the Box Properties dialog box.
7. Click Apply, then Close.
Tip! To help align boxes for column headings, select the boxes at the top of all columns in the
Record Area, copy them (Edit>Copy), switch to the Margin Area, and paste the boxes. Then,
change the contents of each box.
To create column headings at the top of the first printed page or displayed report
1. The Record Area must be active. To activate it, choose Report Options>Work in
Record Area.
2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, type a column heading in the Text box. Click Apply.
4. Choose Report Options>Headers and Footers to open the Headers and Footers
dialog box.
5. From the Header/Footer list, select Report Header.
6. Click the Change to Header/Footer button.
7. Move and size the box, as needed.

Inmagic DB/TextWorks v13 Printed Help

167

Designing Forms
8. Repeat steps 2– 7 for each column heading you want to add.
9. Format the box contents using the other tabs of the Box Properties dialog box.

Underlining Column Headings
You may want to underline text, especially when creating column headings. By default, an
underline is length of the text. However, you can use spaces to extend the underline beyond the
text in either direction.
To underline text
1. Select the box.
2. Choose Tools>Box Properties to open the Form Box Properties dialog box.
3. On the Font, Color subtab of the Format tab, click the Set Font button to open the Font
dialog box.
4. Select the Underline check box in the Effects group, then click OK.
5. Click Apply, then Close.
Note: For tabular forms, to underline the column headings, choose Tools>Box
Properties>Labels, then click the Set Font button and follow steps 4 and 5 above.
To extend an underline beyond the text
Follow the steps to create column headings, except when you type the column heading, use the
spacebar to add spaces before and/or after the text. As a result, when you apply the underline,
it will extend to include the spaces you add.
Tip! If you have used form boxes for column headings, you can avoid having to count the exact
spaces to the edge of the box. Choose Tools>Box Properties>Position, set the Maximum
height to 1, and then type several spaces. This setting will cause any spaces that wrap to the
next line to be truncated.

Formatting Numbers and Dates
You can control the appearance of numbers and dates at the beginning of content items. The
selected content item's field type (Date or Number) determines whether you see date or number
formatting options on this subtab.
To specify number or date format
1. In the Form Designer, select one or more form boxes. If you want to apply date
formatting, you must only select one box.
2. Choose Tools>Box Properties>Format>Numbers, Dates.
3. From the Contents list, select the item you want to format, or select <all> to apply the
formatting to all content items in the selected box. Note that if you select <all>, you will
only be able to select number formatting options.
4. Select formatting options.
5. Click Apply, then Close.
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Number format group
The options in the Number format group affect how all numbers appear in the selected content
items. The formatting options for numbers are only enabled if the selected content item is not a
date (that is, not a Date field, Automatic Date field, or Computed Date field; a DATE variable; or
a date calculation).
Note: The characters used for the decimal and thousand separators are determined by the
Number Format selected in the Regional settings of the Microsoft Windows Control Panel.
Use the Number format drop-down list to specify the formatting options you want.
None. Numbers appear exactly as they were entered into the textbase, along with any
other text formatting options you specify. By default, calculations and variables appear
without decimal digits.
Currency. All numbers in the field appear as currency (as shown in the Examples box).
Note that the Omit text check box is enabled when you select Currency from the
Number format drop-down list. Select the Omit text check box if you do not want
trailing text (text that follows the number) to appear. If you select this option and the field
contains text but no value, zero currency appears in the form box. For example, a field
that contains only the text Letter of Credit appears as $0.00 in the form.
The characters used for the currency symbol and decimal/thousand separators are
determined by the Currency and Number Formats selected in the Windows Control Panel
at the time you start the software. For example, the number 75.5 could appear in U.S.
dollars as $75.50 or in French Francs as 75,50 F.
Number. Specify the following options to determine how numbers appear:
# of decimal places. Type a number to indicate how many decimal places you
want to display after the decimal point. For example, 2 causes the number 25.5 to
appear as 25.50. If there are too few decimal places, numbers will be rounded
when necessary. For example, if you request zero (0) decimal places, 25.4
becomes 25. The default is 0 decimal places.
Negative numbers use. From the drop-down list, select the option that indicates
how you want negative numbers to appear: leading minus sign, trailing minus sign,
or enclosed in parentheses.
Thousand separators. Select this option if you want numbers to include a
thousand separator, such as a comma, in the appropriate place. For example:
1,523.
Include leading zero in decimal. Select this option if you want a zero to appear
before a number with only decimal digits. For example, .75 appears as 0.75.
Omit text. Check this box if you do not want trailing text to appear. If you select this
check box and there is no number in the field—only text—a zero appears in the form
box. For example, if the field only contains the text none, and this option is selected,
a zero (0) appears in the form box instead.

Date format group
Date format options are enabled only for a Date field, Computed Date field, Automatic Date
field, the DATE variable, or a calculation that results in a date. The available date formats are
based on the Date Format selected in the Regional settings of the Windows Control Panel.
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Note: If you select multiple boxes or select <all> from the Contents list, the Numbers, Dates
subtab shows number formatting options. If you want to format multiple date fields, format each
field individually.
Date format. Select the date format you want from this drop-down list. Dates in the field
will appear as shown in the Example section of the dialog box.
None. Dates appear exactly as they were entered into the textbase, along with any
other text formatting options you specify, and the DATE variable appears with the
short date format (for example, 7/5/2002 in the United States).
Short. Dates appear numerically (for example, 7/5/2002 in the United States).
Long. Dates appear in the long date format with the day included (for example,
Monday, July 05, 1999).
Long without day. Dates appear in long date format without the day included (for
example, July 05, 1999).
Omit text. Select this check box if you do not want trailing text to appear. If you select
this check box and there is no recognizable date at the beginning of the field—only
text—an asterisk appears in the form box. For example, if the field only contains the text
unknown, an asterisk appears in the form box instead.
The Example section of the dialog box shows how dates will appear. Note that the
formats are based on the format selected in Regional settings of the Windows Control
Panel. For example, if a day-month-year format is selected, the DB/TextWorks Long date
format would display with days and months written out, such as Friday, 14 March 2003
and the Short date format would display numerically, such as 03/14/2003. Use the
Control Panel settings to specify exactly how you want long- and short-format dates to
appear.

Formatting Paragraphs
You can apply paragraph formatting settings to text in form and text boxes. For form boxes, use
the settings on the Paragraphs tab of the Form Box Properties dialog box to specify paragraph
formatting options. For text boxes, use the Font, Color tab of the Text Box Properties dialog box
to specify a justification option.
Before you begin formatting paragraphs, you may want to:
Define the box contents (choose Tools>Box Properties).
View actual record information. On the Display menu, if there is a View Records option,
select it. If it is present but not available, you have to perform a search first. If the menu
has a View Content option, you are already viewing records.
Note that the distance between records is controlled by the Tools > Form Properties
dialog.
To apply paragraph formatting to a form box
1. Select a form box and choose Tools>Box Properties to open the Form Box Properties
dialog box.
2. On the Paragraphs tab, specify formatting settings:
Paragraph breaks. Select an option from this drop-down list to specify how
paragraphs in the form box are presented (for example, as is, with a paragraph
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break after each content item or field entry, or after each word). Select or clear the
Separate entries or items with spaces check box to specify whether multiple
items in a paragraph should be separated with spaces by default.
Justification. Select Left, Center, or Right from this drop-down list to specify
paragraph justification. The default is Left.
Indent first line by. Specify a value to indent or outdent the first line of each
paragraph. The default is zero.
Note: These options affect all paragraphs in the selected form box.
3. Click Apply.
To apply paragraph formatting to a text box
1. Select a text box and choose Tools>Box Properties to open the Text Box Properties
dialog box.
2. On the Font, Color tab, select an option (Left, Center, or Right) from the Justify text
drop-down list.
3. Click Apply.

Formatting Text in Form Boxes
You can apply different formatting to every content item in a form box. For example, if a form
box contains two fields, you can use different font and color settings for each field. However,
form box text formatting is not just about fonts and colors. You can add text, such as the word
Written by in front of the Author field; and punctuation, such as parentheses around the Date
field. You can also specify numbering options and date and currency options.
To format form box text
1. In the Form Designer, select one or more boxes.
2. Choose Tools>Box Properties>Format.
3. From the Contents list, select the item you want to format, or select <all> to apply the
formatting to all content items in the selected box.
4. Select a subtab:
Numbering. Number each of the field entries or content items.
Font, Color. Change the font, color, and case for the selected item(s). The same
attributes will be applied to any added text. Select box background color, which
applies to the box as a whole.
Numbers, Dates. Specify a number or date format.
Added Text. Specify text and/or punctuation to precede or follow an item; and
specify separator text (such as a semicolon) to appear between multiple entries in a
field.
5. Click Apply to save changes, and Close to close the dialog.
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Formatting Text in Text Boxes
You can apply different formatting to text box content, as well as change the background color
of the text box for impact. Use the Font, Color tab on the Text Box Properties dialog box
(choose Tools>Box Properties) to specify font attributes, text box border display, text box
background color, and justification settings for text box content.
Font attributes can affect the height of text boxes, so it is most efficient to decide on a font early
in the form design. Before designing a new form, you may want to choose
Tools>Options>Display and set the default fonts. Default fonts determine how new forms
appear. They do not affect existing forms.
To format text in text boxes
1. In the Form Designer, select one or more text boxes.
2. Choose Tools>Box Properties to open the Text Box Properties dialog box.
3. On the Font, Color tab, specify the text and box background formatting options you want
in the Text attributes group. The options are explained below.
4. Click Apply.

Text attributes group
Set Font. Click the Set Font button to open the Font dialog box and specify the font,
style, size, and color you want used for text. Click OK to close the Font dialog box.
Note: The fonts that appear in the Font list depend on the currently selected printer.
Printer fonts are preceded by a printer icon. If you choose a printer font, and
subsequently use the form to print to a different printer which does not support that font,
the report may not appear as you expect. To change your printer selection, choose
File>Print Setup.
Show border. Select this check box to display the text box border.
Background color. Select this check box to choose a color to use for the form's
background. Click the Select Color button to specify the color (including custom colors).
Use this option if you always want the form to use the specified color, regardless of any
colors specified using Tools>Options>Display>More Defaults>Colors.
Justify text. Use the Justify text drop-down list to justify text within the text box. If you
find that you regularly justify text, you can add the appropriate text justification button to
the toolbar by choosing Tools>Customize Toolbar>Current Window.
Tip! To center a title on a form, type the text you want as the title in the text box, and
choose Tools>Align Boxes>Center.

Formatting Text in Script Input Boxes
You can apply different formatting to script input box content, as well as change the background
color of the script input box for impact. Use the Font, Color tab on the Script Input Box
Properties dialog box (Tools>Box Properties) to specify font attributes and background color.
Font attributes can affect the height of script input boxes, so it is most efficient to decide on a
font early in the form design. Before designing a new form, you may want to choose
Tools>Options>Display and set the default fonts. Default fonts determine how new forms
appear. They do not affect existing forms.
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To format text in script input boxes
1. In the Form Designer, select one or more script input boxes.
2. Choose Tools>Box Properties>Font, Color.
3. Use the options on this tab to format the text and box background color.
4. Click Apply.

Text attributes group
Set Font. Click Set Font to specify the font, style, size, and color you want used for text.
Click OK to close the Font dialog box. To see the font you specified for your script input
box, type some text into the box. A script input box is the only box type that lets you type
text into it while in the designer.
Note: The fonts that appear in the Font selection list depend on the currently selected
printer. Printer fonts are preceded by a printer icon. If you choose a printer font, and
subsequently use the form to print to a different printer which does not support that font,
the report may not appear as you expect. To change your printer selection, choose
File>Print Setup.
Background color. Select this check box to choose a color for the background of a
script input box. Click the Select Color button to specify the color (including custom
colors). Use this option if you always want the form to use the specified color, regardless
of any colors specified using Tools>Options>Display>More Defaults>Colors.
To format the label text used on a script input box, see the Labels tab on the Script Input Box
dialog box or choose Tools>Box Properties>Labels.

Formatting Text on Script Buttons
You can type any text you want on script buttons, as well as format the text.
To format script button text
1. In the Form Designer, select a script button.
2. Choose Tools>Box Properties>Caption.
3. In the Caption box, type the caption as you want it to appear on the script button, to a
maximum of 50 characters.
4. Click Set Font to specify the font, style, and size you want. If multiple buttons with
different caption fonts are selected, the Font selection list is empty and the other settings
show the default values. Click OK to close the Font dialog box.
5. Click Apply, then Close.

Paragraph Breaks
To access this option, select one or more form boxes in the Form Designer, and choose
Tools>Box Properties>Paragraphs. The Paragraph breaks drop-down list specifies how
multiple field entries or content items appear in a form box.
Tip! If the options do not seem to work as expected, it could be because the record includes line
breaks inserted with the Enter key. Open the record in the Edit window to see if there are any
unwanted line breaks, and remove them. You can see where line breaks occur in the data
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because the next line is outdented without a bullet character, which indicates a new entry, or the
entry ends with a blank line, which looks like a blank line after the text.
Select one of the following options from the Paragraph breaks drop-down list:
No added paragraph breaks. Do not add any line breaks between content items or
multiple entries. For example, three entries in a field would appear like this:
Brick Stucco Concrete

Note: This option does not remove line breaks that exist in the record information or that
were added with added text, so entries or content items still may appear in a vertical list.
To help distinguish between entries when you use this option, choose Tools>Box
Properties>Format>Added Text and specify separator text, such as a comma and
space:
Brick, Stucco, Concrete

Separate Items or entries with spaces. When you choose No added paragraph
breaks from the Paragraph breaks drop-down list, this check box is enabled. Select the
Separate items or entries with spaces check box to specify that items in a paragraph
be separated with spaces. (This is the default choice.) If separator text is specified as
added text between entries, this option is ignored. When this check box is cleared, no
additional spacing is added between entries. The ability to suppress spaces between
fields is particularly useful if you want full control over their appearance. For example,
you may want to show a file path from one field next to a file name from another field
with no added space between them.
Another example of this feature is when you want to format two fields in the same box
and need added text and space formatting to define their relationship. For example, you
may want the Title and Subtitle fields in the same box so they display results as Title:
Subtitle, with a colon preceding the Subtitle field and no space preceding the colon.
However, you do not want the colon to appear at all if there is no subtitle. To do this,
select No added paragraph breaks and clear the Separate items or entries with
spaces check box. Add a colon followed by a space to the Subtitle field as beginning text
(Format>Added Text).
School Reform: What It Means to You and Your Child

Tip! This option is also useful when formatting text that will be interpreted as HTML,
especially "canned queries" or any text where spacing (or lack thereof) is important.
Make each item or entry a paragraph. Add a break after each content item or field
entry in the form box. This can be useful for generating a list, such as in the following
example:
Brick
Stucco
Concrete

Make each word a paragraph. Place each word in the form box on a separate line. This
is useful when for printing information such as Library of Congress classification
numbers in a columnar format. If you want two words to stay together on a line, connect
the words with a non-breaking space (Alt+0160).
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Paragraph Indentation
To access this option, enter the Form Designer, select one or more form boxes, and choose
Tools>Box Properties>Paragraphs.
In the Indent first line by box, enter a positive value to indent the first line of each paragraph in
the selected form box. This is a good choice for blocks of text, such as long paragraphs (from
the Paragraph breaks drop-down list, select No added paragraph breaks).
If you want to outdent the first line of each paragraph (hanging indentation), enter a negative
value in the Indent first line by box. This is a good choice for lists (from the Paragraph breaks
drop-down list, select Make each item or entry a paragraph). It is also useful for numbered
lists (when using the Numbering subtab on the Format tab).
The unit of measure is based on the Horizontal units setting (choose Tools>Form
Properties>General).

Paragraph Justification
To access this option, in the Form Designer, select one or more form boxes, then choose
Tools>Box Properties>Paragraphs. The justification option that you select affects all
paragraphs in the selected form box.
Left
Left justification is commonly used for
text. This paragraph is left justified.
Right
You can use Right justification to align
numbers:
10
100
1,000
Center
You can use Center justification
for report titles and column
headings. This paragraph is center
justified.
Note: To justify text in text boxes, select the text box and choose Tools>Box Properties>Font,
Color. Select an option from the Justify text drop-down list.

Numbering Entries and Items in Form Boxes
You can number field entries or content items within a form box, using Arabic or Roman
numerals or letters of the alphabet. A period and a non-breaking space are automatically
included after the number or letter. Numbering always starts with 1 or A. Numbers or letters
appear even if the box includes only one entry or item.
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To specify numbering settings
1. In the Form Designer, select one or more form boxes.
2. Choose Tools>Box Properties>Format>Numbering.
3. From the Contents list, select the item you want to format, or select <all> to apply the
formatting to all content items in the selected box.
4. Select numbering options, then click Apply and Close.
Item numbering. Use this drop-down list to specify the format in which you want
numbering to appear. Item numbering always starts with 1 if numbered numerically,
or with A, if numbered alphabetically.
None (entries are not numbered)
1, 2, 3 (Arabic numerals)
I, II, III or i, ii, iii (uppercase or lowercase Roman numerals)
A, B, C or a, b, c (uppercase or lowercase letters of the alphabet)
Continuous numbering across content items. Select this check box to have
numbering continue across content items. The following example shows the effect
of continuous and non-continuous numbering on a box that contains two fields,
Dogs and Cats.
Continuous

Non-Continuous

1. Doberman
2. Rotweiller
3. Poodle
4. Siamese
5. Manx

1. Doberman
2. Rotweiller
3. Poodle
1. Siamese
2. Manx

Numbering Records in Forms
To include numbers (1, 2, 3) before each record in a report, add the RECORD NUMBER
variable in a box in the Record Area of a form. The records are numbered in the order in which
they appear in the report, determined by the sort order. An exploded sort (which can include a
record more than once) numbers each instance of a record, not just each record.
You can place the RECORD NUMBER variable in the same box as the record information.
However, if you want to right-justify the numbers or align the subsequent information (as shown
in the following example), put the variable in its own box.
1. Aluma Streetstar 82 (version 1.0A)
2. The Desmond DesertKraft (version 2.0A)
3. Lady Blue Sailboat (version 1.0C)

To number records in a report
1. Choose Report Options>Work in Record Area. (If the command does not appear on
the menu, you are already working in the Record Area.)
2. Choose Edit>Add>Form Box to add a form box for the record number. The Form Box
Properties dialog box opens. Omit this step if you want the record number to be in the
same box as the record information.
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3. On the Contents tab, select the Variables subtab. From the Variables list, select
RECORD NUMBER and click Add.
4. Choose Tools>Box Properties>Labels and make sure the Label and Border check
boxes are cleared.
5. If you added a box to hold the record number, position it to the left of the box that
contains the record information. Select both boxes and choose Tools>Align
Boxes>Anchor and Top.
6. [Optional] Select the box that contains the RECORD NUMBER variable. Choose
Tools>Box Properties>Paragraphs and select Right from the Justification drop-down
list.
7. [Optional] Add a period as ending punctuation after the RECORD NUMBER variable using
the Added Text subtab on the Format tab.

Numbering Pages
You can number pages in a report by adding a box anywhere in the Margin Area and specifying
its contents as the PAGE NUMBER variable. Each page is numbered with Arabic numerals,
starting with 1. To change the starting page number, choose Report Options>Set Up Page.
You can choose Tools>Box Properties>Format and use the subtabs to change the
appearance of the number (for example, you can change the font or add fixed text, such as
Page, before the page number).
If you open the Basic Report form, a box for the page number appears automatically at the
bottom of the page in the Margin Area. You can change the appearance of this page number, or
you can delete the box.
To add a page number in the Margin Area.
1. Choose Edit>Add>Form Box or click the Add Form Box toolbar button.
2. On the Form Box Properties dialog box, select the Contents tab and do the following:
Select the Variables subtab.
From the Variables list, select PAGE NUMBER.
Click Add.
3. Use the tabs on the Form Box Properties dialog box to format the box and its contents.
To add the word "Page" before a page number
1. Select the box containing the page number. If the box is at the bottom of the page, use
either the Tab key, Edit>Go To Box, or the vertical scroll bar to locate it.
2. Choose Tools>Box Properties to open the Form Box Properties dialog box.
3. On the Format tab, select the Added Text subtab and type Page in the Beginning text
box. Note that if you want a space after the word or any punctuation, you should include
it.
Tip! If you want to surround the page number with text, such as a dash before and after
the number (-1-), enter the preceding dash as beginning text and the succeeding dash as
ending text.
4. Use the tabs on the Form Box Properties dialog box to format box contents.
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5. Click Apply.
To delete the page number box
Select the box containing the page number and press the Delete key on the keyboard or
choose Edit>Delete Box.

Designing Tabular Forms
Design a tabular form to present information as a table, in rows and columns. Each row in the
table represents a record. Each column represents a field. Each cell in a row contains one or
more fields or other content items (variables, calculations, and so forth). Use tabular forms to
display a summary of records found by a search, showing just a little information from each
record: Author, Title, Subject, Date.
Tip! Tabular forms are especially useful for forms that will be used on the Web with
WebPublisher PRO.
Creating a Table
1. Outside of the Form Designer, choose Display>Design Form, or from within the Form
Designer, choose Form Operations>Open Form.
2. From the Start With list, select New Tabular Form.
3. On the Choose Initial Tabular Form Fields dialog box, specify which fields you want to
include in the table, by moving fields from the Available Fields list to the Initial Fields list.
4. Click OK.
A table appears, consisting of the fields that you selected. Within the Form Designer, a table
consists of one row, which represents one record. The row contains multiple cells, each of
which contains a content item (a field, a variable, fixed text, and so forth). Rows are records.
Columns are fields. When you use the form, the table will consist of multiple rows, each of which
represents a record retrieved.
Adjusting Table Appearance
For the most part, use the Form Designer options as you would to design a non-tabular form.
For example, to change the size of a cell in the table, click a cell and choose Tools>Box
Properties>Position. To add a cell to the right of the selected cell, choose Edit>Add and click
the type of box you want to add. To delete a cell, choose Edit>Delete Box. You can drag a box
to a new horizontal position using the mouse.
Note that tabular forms are available only for reports, which do not permit scrolling within a box.
Therefore, choose Tools>Box Properties>Position and specify a Maximum height large
enough to accommodate a reasonable amount of text.
To add column headings, choose Edit>Select All>Form Boxes, then choose Tools>Box
Properties>Labels. From the Show group, select the Label check box and click Apply. Default
label text is used. To change the text, select an individual cell then use Tools>Box
Properties>Labels.
Form Designer options that are not supported in a table have been removed from the menus or
disabled. For example, you cannot specify tab order, or that a tabular form be used for single
record display or editing.
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Designing Tabular Forms for Use on the Web
If you have WebPublisher PRO, you can design tabular forms for Internet/intranet use. Here are
some issues specific to use on the Web:
Choose Tools>Form Properties>HTML to specify attributes for forms used on the Web
or File>Write Report to File or File>Send Report as Mail in HTML format. These
options are ignored for forms used on the desktop.
Choose Tools>Box Properties>HTML to treat the contents of a particular field as
hypertext links. Each entry in the specified field generates a separate link.
Box width is ignored in the Web browser. The browser expands the width of each cell as
necessary.
An important, though optional, part of designing a tabular form for the Web is to give the
user a way to see a detailed view of each record. Choose Tools>Box
Properties>HTML and select Expand record link from the Treat content item as
drop-down list.
To include images in a table, use a picture box (choose Edit>Add>Picture Box). An
alternative method of including images in a table is to specify the contents of a particular
cell as the Image field that holds the image you want to display (images should be in a
format supported by the Web browser, such as JPEG or GIF). Images included in a table
can be displayed inline or as a link, depending on the Treat content item as setting
(choose Tools>Box Properties>HTML). For more information about images on the
Web, see the WebPublisher PRO: Images topic.
For related information, see WebPublisher PRO: Form Design Tips.

Designing Labels - Overview
You can create a variety of labels, such as address, shipping, file folder, rotary card, library
catalog card, book label sets, or any custom, user-defined format. DB/TextWorks includes many
blank label formats reflecting the dimensions for various stock numbers from numerous
companies, including Avery, Gaylord, and University Products. To design custom labels, open a
blank label format, change the layout, and save it under a new name.
Important! When you first open the Form Designer to design a new label or label set,
DB/TextWorks displays internal lines in the Form Designer window, indicating the layout and
location of the new label(s). These lines only appear this one time, during the first layout
session, so it is very important that you lay out the boxes you want to use during this first design
session.
You can design the following types of labels:
Standard Label and Card Forms
Customized Label and Card Forms
Label Sets

Designing Label and Card Forms
To design label and/or card forms, open a New Label Form in the Form Designer, add boxes,
and define the box content. The boxes that you define are used for all labels or cards on the
page. The Form Designer window represents one label (or card).
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A black border indicates the outside edge of a single label or label set. For multi-label sets, inner
lines also appear to show dimensions of each label in the set. These inner lines are available
only for new label forms when you first open the Form Designer. Therefore, you should lay out
all the boxes before closing the new form.

When to Use One Box versus Multiple Boxes
Because DB/TextWorks fields are unlimited in length and can include multiple entries and
information which exceed the label height (and are cut off), designing a label form involves
some planning. Issues to consider include:
What type of box (or combination of boxes) to use. Form boxes, text boxes, and picture
boxes are all perfectly acceptable on labels.
Whether to use one box or multiple boxes for the label information.
Whether to set a maximum height for each box.
For example, if any of the fields you are adding to a box have multiple lines of information, such
as the Address field, you may want to put those fields in separate boxes, and set a maximum
height for each box, such as 2 lines. This will prevent the information in one field from growing
and possibly causing information in another field at the bottom of the label to be truncated. If
you use multiple boxes, you should set the minimum height of each box to zero (0) lines, so that
empty boxes do not appear. You should also set the Top Offset of all boxes, except the first, to
zero (0), so that the maximum amount of information can fit onto the label.
If you are sure that the information in your label will not exceed the label height, you can place
all fields in one box. Note that whatever does not fit on the label when it is printed is omitted.
To design a label or card
1. Open the Form Designer by choosing Display>Design Form.
2. On the Open Form dialog box, from the Start With list, select New Label Form.
3. From the Stock Number list, select the label format you want to use (for example, Avery
5662), then click OK.
The Form Designer window opens and displays a black border indicating the label's
height and width. For multi-label sets, the inner lines are displayed only for new label
forms. If you close the Form Designer and open the form to edit it at a later date, the
inner lines will not appear. The lines for the outer box, however, are always displayed.
4. Add one or more boxes, define and format the box content.
5. Choose Form Operations>Save Form As. Type a form name and that clearly identifies
the form's purpose.
Before you print labels, you may want to preview them, then print one or two pages on plain
paper and check their layout against the actual label or card stock. You print labels or cards the
same way you print reports. However, printing labels requires you to specify the starting label,
which means you can print on partially used label sheets, when applicable.
To preview all the labels or cards on the page before printing a report
1. Save the form, but keep the Form Designer open. (Doing this lets make adjustments to
the form, if necessary, after previewing it.)
2. Open the Query window and perform a search.
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3. Select the form you saved as your Report Printing form (choose Display>Select
Forms).
4. Chose File>Print Preview to preview how the labels or cards on the page will look when
printed.

Designing Customized Label and Card Forms
Follow these instructions to design a label or card (for example, catalog card, rotary card) for a
stock that is not listed in the Open Form dialog box.
To design a custom label or card
1. Open a label form in the Form Designer to use as a basis for the custom label form.
2. Choose Report Options>Set Up Page.
3. In the Set Up Page dialog box, change the dimensions to correspond with your custom
label stock.
Page Width and Page Height. The dimensions of the label or card stock
Left Margin. Distance from the left edge of the page to the left edge of the first
label or card
Top Margin. Distance from the top edge of the page to the top edge of the first
label or card
Page Orientation. Placement of the labels or cards relative to the page. Portrait is
a vertical page orientation that prints across the narrower dimension of a
rectangular sheet of paper. Landscape is a horizontal page orientation that prints
"sideways."
Label Width. The horizontal distance from the left edge of the first label, card, or
label set to the left edge of the next label, card, or label set. If the label sheet is one
across, this value is the width of one label.
Label Height. The vertical distance from the top edge of the first label, card, or
label set to the top edge of the next label, card, or label set
Number Across. Number of labels, cards, or label sets that appear across the
page
Number Down. Number of labels, cards, or label sets that appear down the page
4. Click OK.
5. Add one or more boxes, and define and format the box content.
6. Choose Form Operations>Save Form As. Type a form name and a description that
corresponds to your custom label or card stock.
7. Preview and then print the labels. You will be asked to specify the starting label,
meaning you can print on partially used label sheets, when applicable.

Designing Label Sets
A label set contains multiple labels for one textbase record. When you open a label set, such as
the University Products book label set, the Form Designer window represents the area of all
labels in a set.
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Important! When the Form Designer opens, inner lines representing the label set boundaries
appear. These lines only appear when you open a new label form. If you close and save the
form and then re-open the form to edit it, the boundaries disappear. Therefore, it is very
important to position boxes during your first session in the Designer.
In the following example, the label set comprises three labels.

Unlike a standard label, a label set typically contains fields that appear more than once. In this
sample label set form, the Classification number is repeated in three boxes, and the Author
field, and the Title field are repeated in two other boxes.

Designing a Report Form
A report form is a form that is designed to display or print multiple records. A report contains
multiple records which appear one after the other, sorted and formatted as specified. Reports
can be printed and/or viewed in the Report window, written to a file in a variety of formats, sent
as e-mail, or used by WebPublisher.

Features of Report Forms
A report form is just like any other form except that it can include some additional features, such
as sorting and numbering records, that would not make sense for single-record display.
When designing a report form, there are two areas in which you can add form boxes:
The Record Area. The body of the report, consisting mainly of record information.
Information in the Record Area appears in displayed and printed reports.
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The Margin Area. The section of a report where you specify information to be printed on
every page, such as page numbers. Information in this area repeats on every page in a
printed report but does not appear at all in a displayed report.
The Record Area is always visible. The Margin Area is visible when you choose Report
Options>Show Margin Area. To hide the Margin Area, choose Report Options>Hide Margin
Area. Before you can add and edit boxes, you have to activate the area in which you want to
work. Do this by choosing Report Options>Work in Margin Area or Report Options>Work in
Record Area.

Task Overview
There are several tasks involved in designing a report form. Some tasks are optional.
To

Do this

Create a report
form

Choose Display>Design Form and select a form to start with an existing
form, the Basic Report form, an blank form, a label form, or a tabular
form.

Change the page
size and margins

Choose Report Options>Set Up Page, and set the page size, margins,
starting page number, and page breaks.
Tip! For printed reports, specify the page size and printer before you start
adding boxes.

Add record
information

With the Record Area active, choose Edit>Add and select Form Box to
add a Record box. Define and format the box contents using Tools>Box
Properties. Repeat for each Record box you want in the Record Area.
Record boxes typically show field content.

Create column
headings

Add and size boxes for record information first, then add column
headings, so the boxes can be aligned vertically. Note that if you are
designing a tabular form, the box labels function as column headings.

Specify a
compulsory form
sort

If you want information to be grouped and subtotaled by specific fields,
choose Report Options>Compulsory Sort. If a compulsory sort is not
specified, users can sort records by any field they want. If your report
form includes Sort Headers and Footers, consider using a compulsory
sort to prevent users from sorting records any other way.

Add Report

While working in the Record Area, choose Report Options>Headers
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Headers at the
beginning of the
report

and Footers, add a Report Header box, and specify its contents. Report
Headers are information that appears once at the beginning of the report
(useful for textbase name, search criteria, or prompted text).

Add grand totals
at the end of the
report

While working in the Record Area, choose Report Options>Headers
and Footers, add a Report Footer box, and specify its contents as a
calculation.

Add headers
before each group
of records

While working in the Record Area, choose Report Options>Headers
and Footers, select a Sort Header and Level, add the box, and specify
its content as a Sort Key and/or text.

Add subtotals
after each
group of records

While working in the Record Area, choose Report Options>Headers
and Footers, select a Sort Footer and Level, add the box, and specify its
content as a calculation.

Print information
in the
margin of every
page

While working in the Margin Area, choose Edit>Add and select Form
Box to add as a Margin box. Define and format the box contents using
Tools>Box Properties.

Choose Tools>Form Properties>Logos or
Create a form for
Internet/intranet use Tools>Form Properties>HTML. This applies to forms used on the Web.

Setting Up the Report Page
When you are designing a form for a printed report, you should set up the page before you
begin adding boxes. In the Form Designer, choose Report Options>Set Up Page and select
the settings listed below.

Size group
Page Size. Type values for the report Width and Height which correspond to the
dimensions of the paper on which you are printing. In the United States, the default is
8.5 by 11 inches.
Note: The unit of measure for the Page Size and Margins is based on the Measurements
setting for Horizontal units and Vertical units selected on the General tab of the Form
Properties dialog box (Tools>Form Properties).

Margins group
Margins. Type values to create the Margin Area for printed reports.

Settings group
Orientation. Portrait is a vertical orientation. Landscape is a horizontal orientation.
Starting Page Number. Change this value if you want to start numbering pages at a
number greater than 1.
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Page Breaks group
Specify how to break pages. If no method is selected, DB/TextWorks breaks a page when the
printed lines reach the bottom of the Record Area. This fits as much information on a page as
possible and allows pages to break in the middle of a record or form box.
Break after Each Record. Start a new page after the end of each record. If a record is
too large to fit on a single page, DB/TextWorks continues the record on the next page,
but the subsequent record will be placed on a new page.
Break if Record Does Not Fit. Start a new page when the contents of a record cannot
fit on the current page.
Break before Sort Header Level 1. Start a new page when the contents of the Sort
Header Level 1 change. For example, if the Sort Header Level 1 box content is the Dept
field, each time the information in the Dept field changes (for example, Sales, Marketing,
MIS), the Sort Header Level 1 and the first record in the new group start on a new page.

Setting the Tab Order in the Form Designer
Tab order is the order in which the Tab key cycles through the boxes on forms used in the Edit
and Display windows and on edit forms that are exported to HTML for Web use. If you notice
that the Tab key does not appear to move through boxes in a logical order, or if you want the
Tab key to skip certain boxes (such as uneditable boxes), you can change the Tab order.
Note: Picture boxes and text boxes are skipped by default in the Tab order. For example, in an
Edit form you would normally skip text boxes that hold a title or instructions, and uneditable
boxes containing information, such as computed fields or fields from a secondary textbase.
The Tab order determines:
The box in which the cursor first appears when you display or edit a record.
The order in which the Tab key moves from box to box for navigational purposes.
To change the Tab order
1. In the Form Designer, choose Tools>Tab Order.
2. Specify the Tab order you want:
To reset the Tab order to match the order in which boxes appear on the screen,
click the Reset to Default Tab Order button. This is helpful if you have re-ordered
boxes and you want to quickly reset the Tab order.
Note: The default order will list boxes in top-to-bottom order. However, there is no
guarantee that boxes positioned next to each other will appear in left-to-right
order.
To manually reorder boxes, select a box from the Current Tab Order list and use
the Change Order buttons to move the box up or down. The Tab key will start at the
first box in the list and cycle through boxes in the specified order.
Note: The first unskipped box in the list is the one the cursor will be in when you
display or edit a record using this form.
Select the Skip this Box check box if you want the Tab key to skip the selected
box. For example, you could skip an uneditable box in a form used in the Edit
window. You often skip boxes that hold any content except fields, unless they are
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script input boxes. For example, skip a text box that holds fixed text, a form box that
holds a variable, or a picture box that holds an image.
3. Click OK.
Boxes are identified in the Current Tab Order list on the Tab Order dialog box by their labels.
Boxes without label text are identified by the first content item, shown in angle brackets, such as
<field=Customer Number>.
You can specify the following settings on the Tab Order dialog box:
Change Order. Select an item from the list, then use the Up or Down button to move
the selected item up or down in the list. The position of a box in the list determines the
Tab order.
Skip this Box. Select this check box if you want the Tab key to skip the selected box.
For example, you would probably want to skip an uneditable box in a form used in the
Edit window, such as a Customer ID field that is automatically numbered. You will still be
able to access the box by clicking in it or choosing Edit>Go to Box.
Reset to Default Tab Order. Click this button to reset the Tab order to match the order
in which boxes appear on the screen.

Adding a Report Title
A report title typically consists of a text box in the Margin Area. If you open the Basic Report
form, a box for the report title appears automatically, containing the fixed text <Report Title
Goes Here>. You can either change this title to correspond to the report you are designing or
delete the box. If you delete the box, you can add a box at any time. Use the Box Properties
dialog box to format the text.
Tip! The Margin Area appears only in printed reports. If you design a form for another use (for
example, Report Window or Send Report as Mail), and you want a report title to appear, place
the title in a Report Header box in the Record Area.
To add a report title in the Margin Area
1. Choose Edit>Add>Form Box to add a form box and open the Form Box Properties
dialog box.
2. On the Contents tab, select the Text subtab and do the following:
a.

Select Fixed text.

b.

Type a report title in the Text box.

c.

Click Add.

3. Format the box and its contents using the tabs on the Form Box Properties dialog box.
Note: You can also add a report title by choosing Edit>Add>Text Box. Type the report
title in the Text box on the Text tab of the Text Box Properties dialog box. Format the box
and its contents using the tabs on the Text Box Properties dialog box.
To change the Basic Report title
1. Select the box that contains the report title.
2. Choose Tools>Box Properties>Contents>Text. The Fixed text option button is
selected by default.
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3. In the Text box, type the report name you want to appear; for example, Monthly Sales,
and click Replace.
4. Format the box and its contents using the tabs of the Form Box Properties dialog box.
To delete a report title box
Select the box containing the report title and press the Delete key on the keyboard or
choose Edit>Delete Box.

Adding Headers and Footers (Report Options menu)
To access this dialog box: In the Form Designer, choose Report Options>Headers and
Footers. If the command is grayed out, choose Report Options>Work in Record Area first.
Headers and footers are form boxes. Sort header/footer boxes appear with a group of records
based on the specified Sort Level. Use the Headers and Footers dialog box to add a header or
footer or change the box type (change to header/footer or change to record box).

Header/Footer List
Select an item from the Header/Footer list to indicate what you want to insert or to which type of
header/footer box you want to change the currently selected box.
Report Header. Appears only once, at the beginning of the report, and typically contains
one or more of the following:
A variable, such as the current date, time, textbase name, or search criteria
Prompted text that was entered by the user, such as the name of the person who is
generating the report
Fixed text, such as a report title for a form used in the Report window, or a report
distribution list
Sort Header. Appears at the beginning of a group of records sharing a Sort Key at
the specified Sort Level. Sort Headers typically contain the key by which the records
are sorted.
Sort Footer. Appears at the end of a group of records sharing a Sort Key at the
specified Sort Level. Sort Footers typically contain summary calculations for the group of
records, such as subtotals.
Report Footer. Appears only once, at the end of the report, and typically contains
summary calculations, such as grand totals and averages. For example:
a grand total of a numeric field (calculation)
an average of a field (calculation)
the total number of records (RECORD COUNT variable or, if an exploded sort is
use, the COUNT(1) variable)
the current date, time, textbase name, or search criteria (variables) or fixed text

Sort Level
Select a Sort Level from the drop-down list for the Sort Header or Sort Footer that you will
insert. You can select a Sort Level only if you selected Sort Header or Sort Footer from the
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Header/Footer list. The Sort Level that you select will always refer to the current record sort,
which may be a compulsory form sort (defined in the form), or a user-specified Sort (specified
by choosing Display>Sort Report after a search), or the textbase default sort (defined in the
textbase structure).

Insert Header/Footer
Click this button to insert the type of item selected in the Header/Footer list.
A box is added to the Record Area and the Form Box Properties dialog box opens so you can
specify a content item. In the case of a Sort Header, the appropriate Sort Key has already been
added. You can accept this item, add to it, or change it.

Change to Header/Footer
Click this button to change the selected box on the form to the type of Header or Footer
selected in the Header/Footer list. If you select Sort Header or Sort Footer, select a Sort Level
before clicking the Change to Header/Footer button.

Change to Record box
Click this button to change the selected Header or Footer box on the form to a Record box (a
box in the Record area that typically contains record information or calculations).

Adding Sort Headers and Footers (Report Options menu)
Adding Sort Headers
Use a Sort Header box to hold a Sort Key field. A Sort Header serves as a group heading under
which one or more records are listed.
To understand how Sort Headers work, it may help to review the concept of sorting. Sorting is a
way of grouping records by a particular category. The fields that you sort by are referred to as
Sort Keys. You can designate up to five fields per sort (Sort Levels 1 through 5). Do not feel
compelled to use all 5 levels. It is often sufficient to specify 1, 2, or 3 levels.
Note: If you do a Relevance-Ranked Order sort, Sort Keys do not exist, and Sort Header and
Sort Footer boxes do not appear.
To add a Sort Header
1. Choose Report Options>Work in Record Area. If you do not see that option, you are
already working in the Record Area.
2. Choose Report Options>Headers and Footers to open the Headers and Footers
dialog box.
3. Select Sort Header from the Header/Footer list, then select the Sort Level whose field
contents you want to use. Remember that Sort Levels always refer to the current sort,
which may be a compulsory form sort, a user-specified sort, or the textbase default sort.
4. Click the Insert Header/Footer button. A form box is added to the Record Area and the
Form Box Properties dialog box opens. Footer boxes are added below all Record boxes,
but you can move them.
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5. Format the box label and contents using options on the Form Box Properties dialog box.
For example, hide the box label, border, and scroll bars.

Adding Sort Footers
Use a Sort Footer box to hold a count, subtotal, or other summary calculation for the current sort
group. When you add a Sort Footer box, you select its Sort Level. Enter a calculation, such as
TOTAL(quantity*"price per unit"), as the box contents.
Typically, you pair a Sort Footer with Sort Header, using the same Sort Level for both. For
example, you may want to subtotal sales by region, and you may also want to subtotal sales by
customer.
Note: If you want to pair other information for a Sort Level with a calculation, both boxes must
be Sort Footers. You cannot put a Sort Header "next to" a Sort Footer in a report. You can put
them next to each other in a form, but when you use the form, the boxes will not align.
To add a Sort Footer
1. Choose Report Options>Work in Record Area. If you do not see that option, you are
already working in the Record Area.
2. Choose Report Options>Headers and Footers to open the Headers and Footers
dialog box.
3. Select Sort Footer from the Header/Footer list, then select the Sort Level whose field
contents you want to use. Remember that Sort Levels always refer to the current sort,
which may be a compulsory form sort, a user⌀specified sort, or the textbase default sort.
4. Click the Insert Header/Footer button. A form box is added to the Record Area and the
Form Box Properties dialog box opens.
5. On the Contents tab, select the Calculations subtab, type the calculation you want in the
Calculation formula box, then click Add.
6. On the Labels tab, format the box label and contents. For example, hide the box label,
border, and scroll bars.
Related Topic
Adding Calculations to a Form Box

Emulating Inmagic Tagged Format with a Form
Ordinarily, you can use File>Export to copy record information to a file in Inmagic tagged
format. However, if you want to combine fields, change field names, write out secondary fields,
or make other changes, you can emulate Inmagic tagged format with a form. Follow the
guidelines below to design a DB/TextWorks form. Then write the information to a file by
choosing File>Write Report to File and selecting Plain Text.

Box Contents
Place everything in a single form box (start with a blank form and add one box).
On the Contents tab of the Box Properties dialog box, add each field that you want to
export.
End with the dollar sign end-of-record indicator as fixed text.
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Box Size and Position, Labels and Borders
Choose Tools>Box Properties>Position to set Maximum height to unlimited, set the
Top and Left Offset to zero (0), and the Width to the size you want (for example, 6 or 8
inches).
On the Labels tab, turn off the label (borders and scroll bars are ignored by Write
Report to File>Plain Text).

Paragraph Formatting
From the Paragraph breaks drop-down list, select No Added Paragraph Breaks
(choose Tools>Box Properties>Paragraphs).
Set Indentation to -.10 inches (hanging indentation).

Added Text (apply to each field)
Use added text to specify the following items for each field:
Beginning text. Type a field name followed by a space. If the field name includes
spaces, enclose the name in single or double quotation marks (for example, "Image
Name").
Ending text. Add a line break (press Enter) for each field.
Separator text. Separate entries with the following text: Line break (press Enter),
semicolon, and space.
As long as you are not combining fields, you can select <all> from the Contents list when
specifying ending text and separator text, then undo the ending text for the $ marking the end of
each record.
Tip! To combine fields, omit the added text from one or more items. For example, to combine
the Last Name and First Name fields, omit the added text from the First Name field. Substitute a
comma for the line break as ending text after the Last Name field (Smith, John).

Usage
When saving the form, select the Report Window check box.
Example
AU Linkset, Marvin
TI New Manufacturing
Standards
SUBJ Consumer protection
; Product safety
; Standards
; Toy industry
"Image Name" MFG001.TIF
$
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View Records / View Content
When you design a form, you can toggle between viewing content descriptions and record
information.
When you view content, you see the item(s) specified as box content in the Form Designer.
For example, you may see that a box contains a field and a variable. View the content when you
want to see what content items a box contains. For example, a date (10/27/02) could be field
information, a variable, or a calculation. The content description would tell you which it is.
When you view records, you see actual records from the textbase, with any formatting and
other options applied. Note that you must have done a search first, so you have records to view.
This gives you a good idea of how the form will look when used. The Form Designer shows one
record at a time. While you are viewing records, you may want to display other records in the
set using the options on the Display menu (Next Record, Previous Record, and so forth) or the
arrow buttons on the Form Designer toolbar.
To view record information or content description
1. Perform a search or load a set. If you do not have any records in the set, the View
Records option is not available, and you can only select View Content.
2. In the Form Designer, select Display>View Records or Display>View Content, or click
the View Records/Content button on the Form Designer toolbar.

Showing or Hiding Boundaries (Forms, Query Screens,
and Menu Screens)
While you are designing a form, menu screen, or query screen, you can show or hide box
boundaries by checking or unchecking View>Boundaries. This option affects the designers
only. Boundaries never appear when you use the form, menu screen, or query screen.
Boundaries are dashed lines that indicate the size of each box in a form, menu screen, or query
screen. Boundary color is determined by the highlight color on the Microsoft Windows Control
Panel.
Showing boundaries can be helpful as you position boxes, especially for boxes that do not have
borders. Hiding boundaries can help you get a better idea of what the final form, menu screen,
or query screen will look like.
Form Designer and Query Screen Designer: When you show or hide boundaries, you also
show or hide the arrows that indicate which boxes are anchored to another box. You cannot
anchor boxes on a menu screen.
Note: Dashed lines indicate boundaries. Solid lines indicate selected boxes.

Showing or Hiding Empty Boxes (Form Designer)
Depending on the purpose of the form, you might want to hide empty boxes. A form box might
be empty for several reasons. Some common reasons are:
The box contains a field that does not have any entries.
The box contains a field that is hidden by a password.
The box contains a field from a secondary textbase for which there is no matching
record.
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Here are some guidelines to help you decide whether to hide empty form boxes:
Form used in the Display or Report windows. Hide empty boxes so the user does not
have to look at blank lines.
Form used in a Printed Report. Hide empty boxes to make a printed report shorter and
more legible. In some cases, you might want to show an empty box if you want to draw
attention to the lack of content.
Form used in the Edit window. Empty boxes for single fields are never hidden in the
Edit window, even if you set Minimum height to zero, unless the field is hidden by a
password. The Edit window needs to show empty boxes so users can enter information
when creating or editing a record.
Any form type. Hide empty boxes if they contain a field that may be hidden by a
password. Otherwise, a user whose password hides a field will see an empty area on
the form where that field would have appeared. If the form box has a label, it may
unintentionally identify the hidden information.
To show an empty box
On the Position tab on the Form Box Properties dialog box, set Minimum height to any
value greater than zero.
When the form is used, the number of lines you specified for Minimum height appears as blank
lines. If the box has a border or label, it will appear.
To hide an empty box
On the Position tab on the Form Box Properties dialog box, set Minimum height to zero
(0).
When the form is used, the box will disappear when it is empty. You will not see its label,
border, or scroll bars (if any). For example, if you place the Co-Authors field in a box, and that
field is empty for a particular record, the form box will disappear completely in that record.
However, if the Minimum height is greater than zero and a form box is empty, the form box will
still appear but it will be blank. If it has a border or label, you will see it.
Note: While you are working in the Form Designer, boxes never disappear (unless their
contents are hidden by the current password). If they did, you could not edit them. To see how a
form looks with disappearing boxes, choose Display>Preview, and display a record with an
empty field in a box with Minimum height set to zero (0).
When a box disappears, any floating boxes below it automatically move up.

Showing Sort Keys in a Form Box
A Sort Key is a field by which records are sorted in a report. When you sort records, you can
specify up to five Sort Levels (Level 1 through Level 5).
Sort Keys are used primarily in a Sort Header box or Sort Footer box in a report (choose Report
Options>Headers and Footers). When you insert a Sort Header or Footer, the Sort Key level
you select is automatically added to the form box. You do not have to select it in the Form Box
Properties dialog box (Content tab, Sort Keys subtab). You can, however, use the Form Box
Properties dialog box to change the Sort Key setting, add other information to a box, and so on.
Note: Sort Keys do not appear when a form is used in the Display or Edit windows because
those windows display just one record at a time. They also do not appear if you use the Send
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Report as Mail>Mail each record to a different address feature because you are sending
only one record in each message.
To add Sort Keys to a form box
1. On the Form Box Properties dialog box, select the Sort Keys subtab on the Contents
tab.
2. Select a Sort Level from the Sort Keys list, and click Add.
Sort Levels are determined by the current sort order. For example, if you sort by
Department and subsort by Date, the Department field is Sort Level 1 and the Date field
is Sort Level 2. If you later sort by Subject then Date, the Subject field is Sort Level 1.
The buttons on the Sort Keys subtab perform the following actions:
Add. Adds the item shown in the Sort Keys list to the form box. The item is placed at the
bottom of the Contents list and positioned last in the form box.
Replace. Replaces the currently selected item in the Contents list with the item shown in
the Sort Keys list. Typically, you would select an item in the Contents list, use the Sort
Keys list to select a different Sort Key level, then click Replace.

HTML Preview command (Display menu)
Choose Display>HTML Preview while designing a form or query screen to see what it would
look like if you exported it to HTML. This command is only enabled if:
In the Query Screen Designer, there is at least one box on the screen.
In the Form Designer, there is at least one box in the Record Area, a set of records to
display in the preview window, and no Margin Area visible. To preview an edit screen, be
sure it is saved with Edit Window selected on the Save Form As dialog box.
When you choose Display>HTML Preview, you may be asked to save your changes. You will
also be asked whether you want to use Cascading Style Sheets (CSS) to control box
positioning.
Note: This feature does not show controls typically added by WebPublisher PRO when a form
or screen is exported to HTML, such as navigation buttons and form selection drop-down lists.

Preview command (Display menu)
The Preview window shows one record at a time, so you can preview forms from within the
Form Designer. Note: This is different than File>Print Preview, which enables you to view a
report prior to printing.
To preview a record
1. Perform a search or load a set.
2. In the Form Designer, choose Display>Preview.
3. You see the first record in the set. To display additional records, use the options on the
Display menu or the arrow buttons on the Preview window toolbar.
4. Choose Display>Close Preview.
Note: The recommended way to see how a form looks is to select it for the appropriate window.
For example, if you are designing a Report form, save it even if it is in a preliminary stage. Then
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select it for the Report window by choosing Display>Select Forms. Keep the Report window
open while you work in the Form Designer. Each time you save the form, the Report window will
be refreshed using that form, so you have constant visual feedback.

Print Preview command (File menu)
After you design and save a form for use in a printed report, you can preview the report to see
how it will look when it is printed. You can see information in the Record Area and Margin Area,
as well as headers, footers, page breaks, and other report components.
To preview a report
1. Select the form you want to preview (Display>Select Forms>Report Printing).
2. Perform a search that finds at least one record. Retrieving several records will give you a
more realistic preview. The Select Search Results Window dialog box opens.
3. Select the No window (do not display records) option button or click the Cancel
button.
4. Choose File>Print Preview. Note that depending on what type of form you are
previewing, the following may happen:
If you are previewing a non-label form, the Preview window opens.
If you are previewing a label form, the Specify Starting Label dialog box opens. If
applicable, you can specify the starting label. Click OK to open the Preview window.
To navigate through the pages, use the toolbar buttons or press the PgUp and PgDn
keys on your keyboard.
5. To exit from Print Preview, click Close on the toolbar.
Note: Print Preview is not available when the Images or Thumbnail window has focus.

Print command (File menu)
Choose File>Print to print reports, labels, single records, textbase information, the contents of
the textbase log file, the contents of an Inmagic.net window, and so forth. You can also print the
Image(s) associated with a record or set.
To print the contents of the Textbase Information window or an Inmagic.net window,
choose File>Print. The Print dialog box opens for you to choose your printer settings.
To print a report of all the records in the current set, print while the Report window is
active or when no record windows are active. If an Edit or Display window is active, only
the record shown in that window is printed. DB/TextWorks will do the following when you
choose File>Print:
If the selected report printing form and the form that is currently showing in the record
window are the same, the Print dialog box displays.
If the selected report printing form and the form that is currently showing in the record
window are different, the Form Used to Print Report dialog box opens. You can select:
Report printing form. Select this option to use the Report Printing form selected in
the Select Forms dialog box.
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Form for current window. Select this option to use the form displayed in the current
window. For example, if you are in the Report window, DB/TextWorks will use the
selected Report window form.
Always use this option without asking. Select this option to prevent the Form
Used to Print Report dialog box from appearing the next time you print.
Note: If you are printing labels, you will be asked to specify the starting label, which
means you can print on partially used label sheets, when applicable.
To print a definition for a form, query screen, menu screen, set, or record skeleton, see Printing
Element Definitions.
Other information stored in a textbase can be printed by pressing the appropriate button on a
dialog box. For example, you can print an index from the Query Choices Browser dialog box.
The Print dialog box appears when you initiate a print operation. Some controls may be disabled
if the feature is not supported by the selected printer. Use the context-sensitive help feature on
the dialog box to learn about the settings in the Print dialog box.

Printer Settings
The following are typical printer settings. Depending on your brand of printer, you may have
other printer settings.
Print Quality. Specify the desired print quality.
Print to file. Select this check box to send the output to a disk file rather than to a
printer. See Printing to a file.
Printer Name or Setup or Properties. Select a different printer, or configure the current
printer. See Print Setup.
Print Range. If desired, specify a range of pages to print. This control is effective only if
you are printing records, images, lists, textbase information, and so forth. The page
numbers you specify are counted from the beginning of the report, and bear no relation
to whether or not pages are numbered in the form being used, or where the numbering
begins. The default setting is All pages.
Copies. Specify the number of copies to print.
Collate copies. If you are printing multiple copies of the report, specify whether you
want the pages collated. If you collate the pages, a 2-copy 3-page report is printed in this
order: 1,2,3,1,2,3. If you do not select this check box, the pages appear in this order:
1,1,2,2,3,3.

Printing a Report
You can print a formatted report using the currently selected Report Printing form or the form for
the active window.
The default printer selected in Windows will be used, unless you select a different printer.
Certain printer-specific options affect the output, such as page orientation (portrait or
landscape), paper size, and available fonts. Before printing, you may want to change these
settings using either the Setup button on the Print dialog or the Print Setup command on the
File menu.
Note: To create a file in Plain Text, RTF, or HTML format, choose File>Write Report to File.
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To print a report
1. Select a printing form (choose Display>Select Forms>Report Printing).
2. Search for the records you want to print. The Select Search Results Window dialog box
opens. You do not have to view records, although you may want to.
Important! If the Display or Edit window is selected, only the current record will be
printed.
3. [Optional] To omit a record from the report, select it in the Report or Display window and
choose Sets>Omit Record. (This does not delete the record from the textbase.)
4. [Optional] Choose Display>Sort Report to sort records in a particular order.
Note: If the form used for printing (which is not necessarily the Report Printing form) has
a compulsory sort, that is the only order in which records can appear.
5. [Optional] Choose File>Print Preview. For information about Print Preview, see Print
Preview command (File menu). If you do open the Print Preview window, you can
choose to print the report by clicking the Print button, and skip step 6. If you do not want
to print at this point, click the Close button.
6. Choose File>Print. For information about what may happen when you invoke the Print
command, see Print command (File menu). When the Print dialog box opens, the name
of the print form appears on the status bar.
7. Select the print options you want on the Print dialog box and click OK to begin printing.
8. [Optional] If you are printing labels, the Specify Starting Label dialog box appears. If
applicable, you can specify the starting label.
To print just one record
1. Search for the record you want to print. The Select Search Results Window dialog box
opens. Choose to display the records in the Display or Edit window.
2. Choose File>Print. For information about what may happen when you invoke the Print
command, see Print command (File menu).
3. Select the print options you want and click OK to begin printing,
Troubleshooting
You may see the following message when you try to print a report:
Some information may not appear in the printed report. Possible reasons:
form dimensions do not match page dimensions or boxes appear in the nonprintable area. Continue?

This message indicates that the form dimensions do not match the page dimensions, or that
one or more Margin boxes appear in the non-printable area of the page. The non-printable area
is the area around the edges of a sheet of paper into which the printer cannot write. On a laser
printer, this area is usually ¼ inch or less.
Respond Yes to print the report or No to cancel the report printing.
To correct the problem:
Move the Margin Area boxes away from the page edges. Open the form in the Form
Designer and move the boxes. To access the Margin Area, choose Report
Options>Work in Margin Area.
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Change the form dimensions. Open the form in the Form Designer and choose
Report Options>Set Up Page.

Printing Labels (Specify Starting Label)
When printing labels, you can specify the label on which to start printing. This means you can
print on partially used label sheets, when applicable.
To specify a starting label and print
1. Type the number of the label on which you want to start printing. Labels are ordered
from left to right, starting from the top row, as shown in the Specify Starting Label dialog
box.
2. Click OK.
Note: Depending on the label form created through Display>Design Form, the Specify Starting
Label dialog box will only let you specify a starting label number up to the maximum on the
sheet. The default starting label number on the Specify Starting Label dialog box is 1, meaning
the printing will start with the top left label in the first row, unless you specify another number.

Print Definition command (Form Operations menu)
After you create or edit a form, you may want to print a definition of the form. A form definition
includes information about the form, such as the form name, textbase name, date and time
created, usage (Display, Edit, Report windows; printed report; and/or on the Web), form
properties, settings for each box, compulsory sort (if any), and the page dimensions.
You can print a definition from within the Form Designer by choosing Form Operations>Print
Definition. You can also print a definition by choosing Maintain>Manage Textbase Elements
and clicking the Print button.
Important! A definition printed to a file is not a backup. It is only a description of form attributes.
To back up or share forms, use Export or Import on the Manage Textbase Elements dialog box
(choose Maintain>Manage Textbase Elements).

Managing Forms
Follow the instructions below to back up, delete, rename, and perform other operations.

Converting Forms to Query Screens
You can convert a Display or Edit form to a query screen. Choose Search>Design Query
Screen, and select Existing Record Form from the Start With list.

Backing up and Sharing Forms
Forms are not separate files. They are saved in the textbase or user file. To back up forms
saved in the textbase, back up the textbase. For example, if you copy the textbase Sales to a
network drive, you will automatically back up any forms saved in that textbase. To back up
forms saved in a user file, back up the user file. User files have the same name as the textbase
with the extension . TBU. To see where your user files are located, choose Display>Textbase
Information.
To export forms to a file (an alternative way to back up forms) or to share forms with other
users, choose Maintain>Manage Textbase Elements, then select Forms from the Now
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Managing drop-down list. Select one or more forms from the Currently Saved list and click the
Export button. Name the file when prompted. All of the selected forms will be written to that file.
If you ever need to restore the forms (for example, if you accidentally delete or damage them),
you can use the Import button on the Manage Textbase Elements dialog box.
Tip! Export all forms saved in the textbase to one file. Note that you can tell which forms are
saved in the textbase because they have the word (public) after the form name. Then export all
forms saved in the user file to another file. You can easily restore each set of forms to its proper
place, if need be.

Deleting Forms
To delete a form, choose Maintain>Manage Textbase Elements, then select Forms from the
Now Managing drop-down list. Select one or more forms from the Currently Saved list, click the
Delete button, then respond to the prompt. Note that you will not be able to delete a form stored
in the textbase if the password you are using does not allow you to save forms.

Renaming Forms
To rename a form, choose Maintain>Manage Textbase Elements, then select Forms from the
Now Managing drop-down list. Select a form from the Currently Saved list, click the Rename
button, then respond to the prompt. Note that you will not be able to rename a form stored in the
textbase if the password you are using does not allow you to save forms.

Changing Form Information
To change a form's description or purpose (for example, Edit, Display), open it in the Form
Designer and choose Form Operations>Save Form As. You can also change the form's name
and/or location (user file or textbase file), but this will save an additional copy of the form with
the new name and/or location. Note that your password may prevent you from changing form
information.

Selecting Forms
To select a form, choose Display>Select Forms. The forms that you choose will be used until
you select different ones or revert to the textbase defaults. To change textbase default forms,
choose Maintain>Change Textbase Defaults>Forms.
To select forms for most operations
1. Choose Display>Select Forms to open the Select Forms dialog box. The forms you are
using are listed on the dialog box.
2. Specify which forms will be used for various operations:
To assign the textbase default forms for all operations, click the Revert to Defaults
button.
To select a form for a particular operation, click one of the four buttons: Record
Display, Record Edit, Report Window, or Report Printing. A dialog box for that
operation opens. (Note that each operation has its own dialog box.) Do the
following, depending on the form you want to use:
From the Currently Saved list, select a form to use with the operation and click OK.
Forms are listed alphabetically within type. Basic forms are listed first, then forms
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saved in the current user file, and then forms saved in the textbase file, which are
identified by the word (public). The form currently in use is highlighted in the dialog
box.
Note: When you saved a form, you specified the operations for which it could be
used (Display, Edit, Report, printing). Your decision at that time determines which
forms appear in each list now. If you do not see a form you want to use in the current
list, open the form in the Form Designer and use the Save Form As option to
change the uses of the form.
Click the Revert to Default button to assign the current textbase default form for
the operation and click OK.
To select a form for the current window
1. With a Display, Edit, or Report window open and active, choose Display>Select Forms.
Note: You can also click the Select Form for this Window button on the window's
toolbar or click the Select Report Printing Form button on the Main window toolbar. This
is the only way to select a form for the Edit Secondary Record window.
2. From the Currently Saved list, select a form for the current window (or for printing) or
click the Revert to Default button to use the current textbase default form. Click OK.
3. To quickly resize the window to fit the form, choose Window>Fit Window to Form or
click the Fit Window to Form toolbar button.
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Menu screens and DB/TextWorks
A menu screen consists of a list of links to commonly-used textbases. Clicking a link opens the
textbase. This provides an alternative to using File>Open, so users do not have to remember
the location of multiple textbases.
Menu screens also provide a starting environment for users, with each listed textbase having a
default set of forms, a query screen, and a record skeleton (these are known collectively as
initial elements). Each listed textbase can also result in an initial action occuring when the link is
clicked.
A menu screen can also point to other menu screens, if you want to "branch" users from one
menu to another. For example, the initial menu screen can list the top five textbases, plus a link
to another menu screen that lists additional textbases.
When a textbase is open, the menu screen is no longer visible. To redisplay the menu screen,
close the textbase.
To create or select a menu screen, close any open textbase, then use the options on the Menu
Screens menu.

Using menu screens on the Web
If you have WebPublisher PRO you can create menu screens and export them as HTML to use
on the Web. Menu screens used on the Web are quite different from menu screens used within
DB/TextWorks. Each menu screen for the Web contains predefined searches. When the page is
displayed in a Web browser, the searches look like regular links (for example, Find recent
documents). When the link is clicked, a query is performed and records are displayed in the
Web browser.
To specify a predefined search, use DB/TextWorks to perform a query and save it as a public
set. Then create a menu screen that includes the search. Each search is a textbase box with an
initial action. The menu screen also specifies which Report form and Expanded Display form to
use by default (initial elements). Export the menu screen to HTML, then place the HTML page
on the HTTP server, for use on the Internet or an intranet.

Creating Menu Screens
A menu screen is a list of the most commonly-used textbases. Clicking an item opens the
textbase or brings up another menu screen. Every menu screen consists of boxes. A typical
menu screen can include the following types of boxes:
Textbase boxes. Add at least one textbase box for each textbase that you want to
access from the menu screen.
Menu Screen boxes. Add a menu screen box for each menu screen you want to access
from the current menu screen.
Text boxes. Add a text box for instructions or a title (for example, Click the textbase you
want to open).
Picture boxes. Add a picture box to hold static images (for example, a company logo).
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Script input boxes. Add a script input box to let the user type in information that will be
used during the processing of a script. Note that although a script input box can be
added to a menu screen, it is not commonly used.
Script buttons. A script button allows you to call functions you have written in the Menu
Screen Script dialog box. For example, you can launch a script that opens another menu
screen and dismisses the current one.
You cannot create a menu screen until you have created at least one textbase. Create the
textbases first, then list them on the menu screen.
To create or edit a menu screen
1. Start DB/TextWorks. If a textbase is open, choose File>Close.
2. Choose Menu Screens>Design to open the Open Menu Screen dialog box.
3. Select the appropriate option, depending on what you want to do:
Open Current Menu Screen File. Opens the currently selected menu screen.
Create a New Menu Screen File. Opens a blank menu screen (no boxes). When
prompted, specify a name and location for the new menu screen file. The extension
.TBM is added automatically. Note: If you name the file DBTEXT.TBM, it can be
used by default at startup time.
Open an Existing Menu Screen File. Select a previously saved menu file (.TBM)
to edit.
4. Click OK.
5. Now you are working in the Menu Screen Designer. You can perform these operations:
Add boxes to a menu screen
Perform other operations available on the Menu Screen Designer menus

Operations on the Menu Screen Designer Menus
Once you have added boxes to a menu screen you can use the menus in the Menu Screen
Designer to modify the menu screen. Note that you must select a box in order to change its
size, position, or attributes.
Use the:

To:

Menu Operations menu Open or save a menu screen; print a definition of a menu screen;
export a menu screen to HTML for use on the Web; or close the
designer.
Edit menu

Add and delete boxes. When you add a box, you use its Box Properties
dialog box to specify its attributes, including contents, text, picture,
position, font attributes, icon usage, initial elements, initial actions, and
so forth. Use the Cut, Copy, and Paste commands to cut, copy and/or
move boxes within a menu screen or between menu screens.

Tools menu

Change box properties, including size and position; show or hide box
borders (for text boxes and script input boxes only); specify a
background color for boxes; align boxes; change Tab order; set menu
screen properties, including HTML options for use on the Web; specify
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script code for the menu screen.
Note: Be sure to specify the menu screen properties, especially Path
Settings.
View menu

Show or hide box boundaries in the Menu Screen Designer and
designate units of measure for moving boxes.

Mouse or the Tools
menu

Change box size or position.

To use a menu screen
After closing the Menu Screen Designer and saving the menu screen, you need to select it by
choosing Menu Screens>Select.

Specifying Initial Elements (Menu Screen Designer)
To access this dialog box: In the Menu Screen Designer, select a textbase box and choose
Tools>Box Properties>Initial Elements.

DB/TextWorks
For the selected textbase box, specify which forms, query screen, and record skeleton will be
loaded when the textbase is opened by clicking this menu item:
Click Forms to specify which forms are used for the Report window, report printing,
Display window, and Edit window.
Click Query Screen to specify which query screen appears when the textbase is
opened.
Click Record Skeleton to specify which "template" is used for creating new records in
the Edit window.
By specifying initial elements, you can set up a starting environment without requiring the user
to select forms, query screens, and so forth. This can be especially useful if you perform
multiple tasks using the same textbase. For example, you could create a menu screen that lists
the same textbase several times:
Serials Check-in
Serials Claiming
Serials Routing

Each item opens the same textbase (Serials), but uses a different set of forms, query screen,
and record skeleton appropriate to the specified task (check-in, claiming, or routing).
Note: You can change the forms, query screen, and/or record skeleton during a DB/TextWorks
session (choose Display>Select Forms, Search>Select Query Screen, and/or
Records>Select Record Skeleton, respectively). However, once you close the textbase and
open it again from the menu screen, the initial elements specified on the Initial Elements tab are
used.

WebPublisher PRO
Menu screens that you export to HTML to use on the Internet or on an intranet ignore all initial
elements, except the forms specified for Record Display and the Report Window. The Report
Window form will be used in the Web browser to display records found by a search. The
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Record Display form will be used for expanded display of a single record (when a user clicks
the expand record link from a report).

Organizing Menu Screen Files
Many people use just one menu screen, which contains the names of all of their textbases or a
single top-level menu screen with menu items that open other menu screens. However, you
may want to create several different menu screens. To switch between the various menu
screens, choose Menu Screens>Select.
You can also use Microsoft Windows to create separate shortcuts, each of which references a
different menu screen file, using the /m command-line switch. When you specify the shortcut
properties, include the full path name of the DB/TextWorks executable file (DBTEXT32.EXE)
followed by the /m switch and the name of the menu screen file. For example, to open a menu
screen called SAMPLE1, use this command:
C:\ DBTEXT\DBTEXT32.EXE /M SAMPLE1

Because DB/TextWorks accepts both / and - in command line arguments, menu screen names
containing a hyphen must be enclosed in quotation marks. For example, to open a menu screen
called SALES-NH, use this command:
C:\ DBTEXT\DBTEXT32.EXE /M "SALES-NH"

If the software is installed on a network server, and all of the workstations will be accessing the
same set of textbases that are also located on the server, the administrator may want to create
one menu screen file, named DBTEXT.TBM, and place it in the software installation folder on
the server. This special feature allows all users to share the same menu screen file.
If the software is installed on your local hard disk, or if you typically use textbases stored on
your local hard disk, a personal DBTEXT.TBM file can be created in the Start In folder
associated with the program icon or shortcut.

Where DB/TextWorks Looks for Menu Screen Files
Menu screen files have the extension .TBM. You can move, copy, or delete them just as you
would any other file (for example, using Windows Explorer). You can rename menu screen files
freely, and move or copy them from one location to another. If you move a menu screen file,
and the Path setting property is set to Do not retain path, then all of the files (for example,
textbases and images) should also be moved to the new menu screen file location.
When you start DB/TextWorks, the software attempts to find a menu screen file (.TBM) to use:
If a menu file has been specified on the command line, that menu is used.
If no menu file has been specified on the command line, the software looks in the
INMAGIC.INI file to find the menu file that was most recently selected.
If the INMAGIC.INI file does not contain a menu screen selection, the software looks for
a file called DBTEXT.TBM in the Start In folder associated with the icon or shortcut used
to start the software.
If there is no DBTEXT.TBM file in the working folder, the software looks for the file in the
folder in which the software was installed.
If all of these steps fail, a menu screen will not be used.
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Selecting a Menu Screen
Select a menu screen if you want it to appear whenever you start DB/TextWorks:
1. Start DB/TextWorks but do not open a textbase. (If a textbase is open, close it.)
2. Choose Menu Screens>Select.
3. Use the Select Menu Screen dialog box to choose a menu screen.
Tip! If you inadvertently close the Menu Screen window, choose Menu Screens>Display
Current to select the last-used menu screen.
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When you are designing a form or screen, you can also design a script for use with that form or
screen. The script can perform certain operations when the form or screen is opened or closed,
when buttons on the form or screen are clicked, when you leave a box, or in other situations.
For example, a script can fill in a box on a query screen or perform extra validation on the
contents of a field in an edit form. You can use script buttons to bring up field-specific help on an
edit form, open a document in its native application from a record display, or move or copy
information among boxes on a form. You can write scripts in either JavaScript (JScript) or Visual
Basic Scripting Edition (VBScript).
To open the Form Script dialog box so that you can create a script for the form you are currently
designing, choose Tools>Form Script.
To open the Screen Script dialog box so that you can create a script for the menu screen or
query screen you are currently designing, choose Tools>Screen Script.
Important! A script is part of a form or screen. If the form or screen closes, the script stops
running. This means, for example, that a script running in a query screen cannot perform a
search, open the Edit window, and then make changes in the record in the Edit window.
Also note that a script can only work within its DB/TextWorks desktop session through the
objects documented in this help file. The DB/TextWorks desktop session has no knowledge of
what is happening inside a script.
Important! Scripts are not applicable to forms and screens used on the Web with WebPublisher
PRO.

Form Script and Screen Script Dialog Boxes
To define a script
1. Choose Tools>Form Script or Tools>Screen Script to access the Form Script dialog
box or Screen Script dialog box, depending on which designer you are in.
2. Use the Script tab to specify which scripting language to use and to insert the script in
the box provided.
3. Use the Names tab to designate a script name for each box in the form you will use in
your program. The script is able to read the contents of the box (and, if permitted, modify
it and write it back). Note that if you have added script buttons to the form, each needs to
be assigned a name in order to access the script.
4. Click OK.

Specifying Script Language and Program
Use the Script tab to choose a scripting language and to insert the script. You can paste the
script here if you constructed it in a different environment.
1. From the Script language drop-down list, select either JScript (JavaScript) or VBScript
(Visual Basic Scripting Edition) as the scripting language used by the program.
2. Type your script for the form in the Script box (or paste it in).
3. Click OK when you are done.
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For scripting purposes, you must also use the Names tab to assign names to the boxes in the
form or screen.

Assigning Names to Boxes for Scripting
Use the Names tab to assign names to the boxes in the form or screen for scripting purposes.
Note that the script cannot access boxes that have no script names assigned to them.
1. From the Boxes list, select the box to which you want to assign a name.
2. Type the new name in the Box Name box.
Note: The name must begin with a letter and may consist of up to 20 alphanumeric
characters (and may include the underbar character [ _ ]). Box names are case-sensitive
(while textbase field names are not). Use the same case in the name that you will use in
referencing the box in the script.
3. Click Change. The assigned name appears next to the box in the Names list.
4. Repeat this process for as many boxes as needed.
5. Click OK when you are done.
You must also use the Script tab to choose a scripting language and to insert the script in the
box provided.

Troubleshooting Scripts
There is no "error checking" in scripts. If your script is broken, it may fail to execute, it may hang
DB/TextWorks, or it may cause DB/TextWorks to exit abnormally. If you encounter problems
with your scripts, review the following troubleshooting tips:
Make sure that your case is consistent (for example, if you name a function moveEntry,
you cannot refer to it as moveentry). JavaScript (JScript) is case sensitive; Visual Basic
Scripting Edition (VBScript) is not.
Make sure you have selected the appropriate scripting language on the Script tab.
Do not forget to name the boxes you will be working with. Do this on the Names tab.
Make sure to test for empty strings, missing boxes, errors, and so forth.
(For example, Sample JavaScript Script 1: Add a script button to swap the contents of
two fields assumes the boxes are present and named. Sample JavaScript Script 5: Copy
first word of one field to another field (if the second field is empty) when the record saved
is more defensive, and less likely to fail if the form is changed such that the needed
boxes are renamed or absent.)
Review your script for general syntax errors.
If you add a button to a form or screen, do not forget to create a script that must run
when someone clicks the button. Conversely, if you create a script to work when a
button is clicked, do not forget to add the button to the form or screen.
Keep in mind that scripts are limited to 30,000 characters.
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Script Events
You can attach a script to a form. There can be multiple functions in the script to respond to
various events, such as the clicking of a button or on saving a record. An event triggers a script
to do something. Events let you manipulate information in boxes on a form or screen,
manipulate information in records in the current set or a new set, and call certain menu
commands.
The following events are available in form or screen scripts:
onFormOpen()
onFormClose()
onFormClear()
onQueryExecute()
onQueryExecuted()
onRecordOpen()
onRecordSave()
onRecordSaved()
onRecordNew()
onRecordDelete()
onRecordOmit()
onRecordDuplicate()
onReportInitialize()
<buttonName>_onClick() (where <buttonName> is the name of a script button that you
have added to your screen or form) This event triggers when the button is clicked.
<boxName>_onFocus() (where <boxName> is the name of a box on the screen or form)
This event triggers when the specified box receives focus. Note that menu commands such
as Spell Check set the focus to each box to be checked, in turn. That change in focus can
trigger this event if it is present in a script in an Edit form.
<boxName>_onBlur() (where <boxName> is the name of a box on the screen or form) This
event triggers when the specified box loses focus. Note that menu commands such as Spell
Check set the focus to each box to be checked, in turn. That change in focus can trigger this
event if it is present in a script in an Edit form.
Where it makes sense (for example, onRecordSave), the event function returns a Boolean to
permit the operation to proceed. Specifically, returning false from the onRecordSave() event
handler function will prevent the record from being saved, and leave the form in the state it was
in before the save was attempted. Not returning a value is the same as returning true, permitting
the operation.

onFormOpen()
This event function, which is available for form or screen scripts, can be used in a menu screen,
query screen, Edit window, Display window, or Report window.
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Note: This function is called before any form boxes are created, so this is not a good function
for populating boxes with preset information. Use this function to set global variables that will be
used elsewhere in your script.
Example
This script sizes the window to fit the form dimensions when the form is first opened.
function onFormOpen()
{
Command.fitWindowToForm();
}

onFormClose()
This event function, which is available for form or screen scripts, can be used in a menu screen,
query screen, Edit window, Display window, or Report window.

onFormClear()
This event function is called when New Query is used or when the screen is opened. It is not
called when the Query window is already up and a different screen is selected. This is a good
function to use to prepopulate query boxes.
This event function is only appropriate in a query screen; therefore, you should use it only in a
screen script.
Example
The script below, running in a query screen, initializes the content of a query box having the
script name "boxType" when you open the query screen or press the New Query button. For
more examples of onFormClear(), see Sample JavaScript 2: Prepopulate a query screen for
new queries and Sample JavaScript 11: Reset button for all query boxes to AND when you click
New Query.
function onFormClear()
{
Form.boxes("boxType").content = "book";
}

onQueryExecute()
This event function is only appropriate in a query screen; therefore, you should use it only in a
screen script.
Note: This function is called before the query is executed. If your function returns false, it will
prevent the query execution from proceeding.
Example
This script forces a query box having the script name "boxType" and the visible label "Type" to
be filled in before the query can proceed.
function onQueryExecute()
{
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if (Form.boxes("boxType").content == "")
{
Application.message("Please fill in the Type box.");
return false;
}
else
return true;
}

onQueryExecuted()
This event function is only appropriate in a query screen; therefore, you should use it only in a
query screen script. Use onQueryExecuted() if you want to capture the search terms, the
number of records retrieved, or other search⌀specific information.
Note: This function is called after the query is executed.
Example
This script logs information about every search done with this query screen to a separate
textbase.
function onQueryExecuted()
{
var nrs = Application.newRecordset("logSearch", "c:\\DBTlog\\", "");
var today = new Date();
if (nrs)
{
nrs.Open("");
nrs.AddNew();
nrs.Fields("Date").Value = today.toString();
nrs.Fields("Textbase").Value = Application.activeTextbase.name;
nrs.Fields("Query").Value = Form.boxes("QBox").content;
nrs.Fields("RecsFound").Value =
Application.activeTextbase.currentRecordset.RecordCount;
nrs.Update();
nrs.Close();
}
}

onRecordOpen()
This function triggers after the boxes have been populated with information, but before they are
displayed. It can be used in an Edit window, Display window, Report window, or printed report.
A common use for this function would be to modify the contents of a box. Note that the box must
exist or have a minimum height greater than zero (0) in order to be modified. For example, a
box in a Display window or report that has minimum height set to 0 lines and is empty because
it contains a field not present in the current record may not "exist" for the purposes of script
manipulation.
See Box object for notes about the contents of a box on a form.
Note: This function is called after onFormOpen(), for new as well as existing records. For new
records, onRecordOpen() is called before onRecordNew().
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Example
This script supports the design of a non-tabular report with header information that will appear at
the top of the report when displayed in the Report window, or at the top of each page when
printed. The script removes the second set of headers that would otherwise appear on the first
page of the printed report.
Create the report by laying out the headers in the margin area, then selecting the header boxes
as a group and copying them to the page area and changing them to report header boxes. The
script below empties out the report headers when the report is printed, so that only one set of
headers appears to the user. The report header boxes have been given script names
boxHead1, boxHead2, and boxHead3. (Note that the script is setting the contents of each
header box to a single space. They could be set to an empty string instead, as long as each box
is assigned a minimum height of 1 line.)
function onRecordOpen()
{
// if printing, suppress the report headers
if (Window.type != "Report")
{
Form.boxes("boxHead1").content = " ";
Form.boxes("boxHead2").content = " ";
Form.boxes("boxHead3").content = " ";
}
}

onRecordSave()
This event function is only appropriate in an Edit window; therefore, you should use it only in a
form script.
Note: This function is called before the record is saved. It can return false to cause the record
not to be saved. Compare with onRecordSaved().
Example
This script illustrates a more sophisticated validation rule that can be enforced by a script in an
edit screen. The script prohibits a record from being saved if the Requestor field has information
in it but the RequestedBy field is empty. "boxRequestor" and "boxRequestedBy" are the script
names assigned to the respective boxes on the edit form.
function onRecordSave()
{
if (Form.boxes("boxRequestor").content != "")
{
if (Form.boxes("boxRequestedBy").content == "")
{
Application.message("Please fill in the RequestedBy field.");
return false;
}
}
return true;
}
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onRecordSaved()
This event function is only appropriate in an Edit window; therefore, you should use it only in a
form script.
You could use this function in a script to bring up the next record in the Edit window after the
current record has been saved.
Note: This function is called after the record is successfully saved. Compare with
onRecordSave().
Example
This script automatically brings up the next record in the set in the Edit window after the current
record has been saved.
function onRecordSaved()
{
Command.nextRecord();
}

onRecordNew()
This event function is only appropriate in an Edit window; therefore, you should use it only in a
form script.
Note: This function is called after onRecordOpen() for a new record.

onRecordDelete()
This event function is only appropriate in an Edit, Display, or Report window; therefore, you
should use it only in a form script.

onRecordOmit()
This event function is only appropriate in a Display or Report window; therefore, you should use
it only in a form script.

onRecordDuplicate()
This event function is only appropriate in an Edit window; therefore, you should use it only in a
form script.
Example
This script erases the content of some of the boxes in an Edit screen when a record is
duplicated, retaining only the information likely to be replicated in the copy. The boxes to be
emptied are declared in an array, so that it is easy to customize the script for use in different
situations. Note that the names in the array must match script names assigned to each of the
boxes to be emptied.
var boxNames = new Array("box1", "box2");
function onRecordDuplicate()
{
var tgtBox; // box to be cleared
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var i; // loop index
// clear the contents of each box named in the array
for (i = 0; i < boxNames.length; i++)
{
tgtBox = Form.boxes(boxNames[i]);
if (tgtBox) // ensure that the box exists
tgtBox.content = ""; // and clear its contents
}
// now set focus to the first box listed
tgtBox = Form.boxes(boxNames[0]);
if (tgtBox)
tgtBox.setFocus();
}

onReportInitialize()
This event function is only appropriate in the Report window; therefore, you should use it only in
a form script. Note that this function is similar to onFormOpen(), except that it is also called
when the report is being repainted; for example, when Refresh is chosen or the sort is changed.

Script Objects
DB/TextWorks exposes a series of objects accessible to scripts.
Within a form script, there are the following "top-level" objects: Application, Form, Command,
and Window.
The following topics detail the implemented objects, collections, properties, and methods
(properties are generally read-only, unless otherwise noted):
Application Object
Box Object
Command Object
Error Object
ExportDescriptor Object
ImportDescriptor Object
Field Object
Form Object
Recordset Object
SendMailDescriptor Object
SortDescriptor Object
Store Object
Textbase Object
Window Object
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Application Object
Properties
applicationTitle

A string.

applicationVersion

A string.

activeTextbase

A Textbase object.

entrySeparator

A string consisting of the unique internal character used to separate
entries within a field. This character may appear in box.content strings
when accessing editable boxes in the Edit window, or Fields.value
strings when accessing information directly from the textbase. In a
script, the JavaScript string.split() and array.join() methods may be
used to manipulate entries:
var es = Application.entrySeparator;
var fieldString = Form.boxes("someName").content;
var entryArray = fieldString.split(es);
// entryArray is an array of entry strings
// ... do something to the entries ...
var newFieldString = entryArray.join(es);
Form.boxes("someName").content = newFieldString;

sessionStore

A Store object that persists for the duration of a DB/TextWorks session.

userStore

A permanent Store object associated with the user. Written to the
INMAGIC.TBS file in the user file folder when DB/TextWorks exits.

currentMenuPath

Exposes the path of the current menu screen.

currentMenuName

Exposes the file name of the current menu screen.

Methods
message (string)

Puts up an OK message box displaying the string.

messageOkCancel
(string)

Puts up an OK/Cancel message box, returns true if OK is clicked.

messageYesNo
(string)

Puts up a Yes/No message box, returns true if Yes is clicked.

promptForInput
(string)

Prompts the user for input and returns the character string that is typed
in response. The argument string is the text that appears on the
Information Needed dialog box.

statusMessage
(string)

Puts a message in the status bar.

shellExecute
(appFile, docFile)

Executes appFile, with docFile as argument. To open the document
with the application associated with it in the registry, pass the file name
as the first argument, and an empty string "" as the second argument:
shellExecute(docFile, "").

newRecordset
(name, path,

Returns a new Recordset object opening textbase "name" in the "path"
folder using the specified password.
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password)
appWindow (URL)

Opens the Application window and navigates to the specified URL.

Box Object
Properties
name

A string, the name assigned to the box.

content

A string, the text content of the box (read/write). This is the default value of
the Box object.

booleanValue

A number, meaningful only for a box in a query screen. It can have any of
the values listed below. Note that these properties are read-only, for use as
constants with booleanValue.

BooleanOR

Represents OR

BooleanAND

Represents AND

BooleanNOT

Represents NOT

Methods
setFocus()

Changes focus (the text input cursor) to this box.

Note: The content of a form box depends upon the type of box and the window in use. For
example, a box in an Edit window may contain field information you can modify with a script.
The content of a "box" on a menu screen is the text you see, not the textbase or menu you
select. You cannot access the content of a box without a script name, and you cannot provide a
script name for text or picture boxes.
Keep in mind that if you access the contents of a box in a Report window, it is likely to include
formatting codes. These codes ensure that font and highlighting information is retained as the
user scrolls back and forth in a report. If a script is comparing the contents of a box against
some other text, the formatting codes should be removed first.
A formatting signal consists of a 0x1b character (which appears as a hollow rectangle) followed
by a code letter, 10 digits, and a 0x1c character. For example, in an Application.message dialog
box (which you may use for diagnostic purposes), it might look like this:
. The
following fragment of sample code in JavaScript strips a formatting sequence off the beginning
of the contents of a box:
var boxText = Form.boxes("boxName").content;
if (boxText.charAt(0) == "\x1b")
boxText = boxText.substr(13);

Command Object
The methods in this object provide access to many of the DB/TextWorks menu commands. In
each case, calling the method simulates selecting the command from the menu. If the user
would normally be asked to supply additional information, the appropriate dialog box appears.
Control is returned to the script immediately after the command is initiated. Subsequent code in
the script will proceed to execute, even as the specified command is interacting with the user
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(dialog boxes, and so forth) or performing its functions. Note that this can have unintended
consequences, particularly if the command is one that closes the form hosting the script that is
still executing. (Examples of commands that can close a form include closeTextbase(),
closeWindow(), and selectFormsEx().)
If a script attempts to execute a menu command that is currently disabled in DB/TextWorks,
nothing happens.

Methods
Method

Associated Menu Command

batchDelete()

Records>Batch Delete

batchModify()

Records>Batch Modify

browseChoices()

Edit>Browse Choices

browseFiles()

Edit>Browse Files

cascadeWindows()

Window>Cascade

changePrimaryPassword()

File>Use Different Password>Primary Textbase

changeSecondaryPassword()

File>Use Different Password>Secondary Textbase

closeTextbase()

File>Close

closeWindow()

Window>Close

commandQuery()

Search>Command Query

copy()

Edit>Copy

copyRecord()

Edit>Copy Special>Record

copyReport()

Edit>Copy Special>Report

copySpecial1()

Edit>Copy Special>Application (1)

copySpecial2()

Edit>Copy Special>Application (2)

cut()

Edit>Cut

deleteEntry()

Edit>Delete Entry

deleteRecord()

Records>Delete Record

displayRecord()

Display>Display Record

displayReport()

Display>Display Report

duplicateRecord()

Records>Duplicate Record

editRecord()

Records>Edit Record

editSecondaryRecord()

Records>Edit Secondary Record

executeQuery()

Search>Execute Query
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exportData()

File>Export

find()

Edit>Find

findAll()

Search>Find All Records

firstRecord()

Display>First Record

fitWindowToForm()

Window>Fit Window to Form

importData()

File>Import

importDocument()

File>Import Document

InmagicNETCatalogWeb()

Inmagic.net>Catalog Web Pages

inmagicNETConfigure()

Inmagic.net>Configure

inmagicNETPlaceOrder()

Inmagic.net>Place Order

insertDate()

Edit>Insert>Current Date

insertEntryMark()

Edit>Insert Entry Mark

insertSeries()

Edit>Insert>Series

insertTime()

Edit>Insert>Current Time

lastRecord()

Display>Last Record

loadSet()

Sets>Load Set

maintainThesaurus()

Maintain>Maintain Thesaurus

newEntry()

Edit>New Entry

newQuery()

Search>New Query

newRecord()

Records>New Record

nextHit()

Display>Next Highlighted Term

nextRecord()

Display>Next Record

omitRecord()

Sets>Omit Record

openTextbase()

File>Open

paste()

Edit>Paste

pasteEntry()

Edit>Paste Entry

prevHit()

Display>Previous Highlighted Term

prevRecord()

Display>Previous Record

print()

File>Print

printPreview()

File>Print Preview

redo()

Edit>Redo
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refreshSets()

Sets>Refresh Sets

refreshWindow()

Window>Refresh

replace()

Edit>Replace

savedQueries()

Search>Saved Queries

saveRecord()

Records>Save Record

saveSet()

Sets>Save Set

saveSetAs()

Sets>Save Set As

scanImage()

Records>Scan Image

selectEntry()

Edit>Select Entry

selectForms()

Display>Select Forms

selectMenuScreen()

Menu Screens>Select

selectPrintForm()

(toolbar button only)

selectQueryScreen()

Search>Select Query Screen

selectWindowForm()

(toolbar button only)

sendMail()

File>Send Report as Mail

setupThesaurus()

Maintain>Set Up Thesaurus

showImages()

Display>Show Record Images

sortReport()

Display>Sort Report

spellCheck()

Tools>Spell Check

textbaseHelp()

Help>Textbase-Specific Help

tileHorizontal()

Window>Horizontal Tile

tileVertical()

Window>Vertical Tile

undo()

Edit>Undo

writeReportToFile()

File>Write Report to File

The following methods support menu commands that can have parameters set by the script:
exportDataEx (ExportDescriptor) exports a file as specified by the ExportDescriptor.
importDataEx (ImportDescriptor) imports a file as specified by the ImportDescriptor.
newExportDescriptor() returns a new, empty ExportDescriptor object.
newImportDescriptor() returns a new, empty ImportDescriptor object.
newSendMailDescriptor() returns a new, empty SendMailDescriptor object.
selectFormsEx (displayForm, editForm, reportForm, printForm) specifies the forms to
select for the Display window, Edit window, Report window, and printing, respectively. If any
of the arguments is an empty string or null, the form previously selected for that window or
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purpose is unchanged. selectFormsEx returns true if the selection succeeds, false if any
one of the forms cannot be selected (for example, if it does not exist). If a form selection fails,
the previously selected form is left unchanged. The exception to this is if the form exists but
is not saved for use in that window, then the Basic form is selected and the function returns
true. Note that only public forms should be selected if the script is intended to be shared with
other users. Note also that this command changes the forms shown on the Select Forms
dialog box.
selectMenuScreenEx (menuScreen) specifies the menu screen to select for the Menu
Screen window. If the path is omitted, DB/TextWorks will look in the folder containing the
currently selected menu screen. selectMenuScreenEx returns true if the selection succeeds,
false if the menu screen cannot be selected (for example, if it does not exist).
selectQueryScreenEx (queryScreen) specifies the query screen to select for the Query
window. If the argument is an empty string or null, the query screen previously selected is
unchanged. selectQueryScreenEx returns true if the selection succeeds, false if the query
screen cannot be selected (for example, if it does not exist). If a query screen selection fails,
the previously selected query screen is left unchanged. The exception to this is if the query
screen exists but is not saved for use in that window; then the Basic query screen is selected
and the function returns true. Note that only public query screens should be selected if the
script is intended to be shared with other users.
sendMailEx (SendMailDescriptor) sends a report as mail, with parameters set in the
SendMailDescriptor object.

Error Object
Properties
Description

A string, the textual description of the error.

Number

Numeric error code.

Source
A string, the name of the object that generated the error.
Note: To find more about the error messages that can be returned from the Recordset object,
see the DBTMSG textbase.

ExportDescriptor Object
Note: Using the ExportDescriptor object does not use or change the last-used settings on the
Export Options dialog box.

Properties
Unless otherwise specified, the properties at the first indentation level are read/write. Some of
them can be set to specific values only. These values are available as read-only properties,
shown at the second indentation level.
Note that you do not need to set all properties. If a property is omitted, DB/TextWorks uses the
defaults (for example, Inmagic tagged format, Export All Fields, and so forth). The only required
property is exportFileName.
exportFileName
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formatFlag

Numeric flag indicating the format of the file (Inmagic tagged,
delimited ASCII, or XML) can be set to any of these values:
FormatFlagTAGGED Flag indicating Inmagic tagged format. This
is the default value if not set by the script.
FormatFlagDELIMITED Flag indicating delimited ASCII format.
FormatFlagXML Flag indicating XML format.

exportAllRecs

Boolean, true if the entire textbase should be exported, false if
only the current set should be exported. Note that "current set"
refers to the current DB/TextWorks session, not any Recordset
created by the script. Defaults to false if there is a set, true
otherwise. You cannot sort the report being exported unless you
are exporting a set.

sortRecs

Boolean, true if the records should be sorted before being
exported. Note that the current sort will be used (as specified
within the DB/TextWorks session). This applies only if there is a
current set and exportAllRecs is false. The default value is false.

exportFieldNames(n)

A string specifying the name of a field to be exported. Fields will
be exported in the order specified. Note that n must not exceed
MaxEXPORTFIELDS - 1.
Example (presented in correct syntax for JavaScript):
exportFieldNames(0) = "Author";
exportFieldNames(1) = "Title";
exportFieldNames(2) = "Date Acquired";

MaxEXPORTFIELDS

Numeric, contains the maximum number of fields you can export
(currently 250, the same as the maximum number of fields that
can be defined in a textbase).

RecordCount

(READ-ONLY) Numeric, contains the number of records exported
after the operation is completed.

RejectedCount

(READ-ONLY) Numeric, contains the number of records not
successfully exported after the operation is completed.
The following properties apply only to delimited ASCII imports:
storeFieldNames

Boolean, specifies that field names should be exported in the first
line of the delimited ASCII file. The default value is false.

recordSeparator

String containing the character(s) used to separate records in the
delimited ASCII export file. Example in JavaScript: \r represents a
carriage return, \n represents a linefeed, and \t represents a tab.
The default separator is \r\n.

fieldSeparator

String containing the character(s) used to separate fields in the
delimited ASCII export file. The default separator is the comma
character (,).

entrySeparator

String containing the character(s) used to separate field entries in
the delimited ASCII export file. The default separator is the pipe or
bar character (|).
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quoteCharacter

String containing the character used to surround field information in
the delimited ASCII export file. The default is the double quotes
character (").
See Also: Sample JavaScript Script 9: Export all records in textbase in delimited ASCII format

ImportDescriptor Object
Note: Using the ImportDescriptor object does not use or change the last-used settings on the
Import Options dialog box.

Properties
Unless otherwise specified, the properties at the first indentation level are read/write. Some of
them can be set to specific values only. These values are available as read-only properties,
shown at the second indentation level.
Note that you do not need to set all properties. If a property is omitted, DB/TextWorks uses the
defaults (for example, Inmagic tagged format, interruptible, no matching, default exception file
name, and so forth).
importFileName

(Required) Text string containing the full name of the file to be
imported.

formatFlag

Numeric flag indicating the format of the incoming file (Inmagic
Tagged, delimited ASCII, or XML) can be set to any of these values:
FormatFlagTAGGED Flag indicating the import file is in Inmagic
tagged format. This is the default value if not set by the script.
FormatFlagDELIMITED Flag indicating that the import file is in
delimited ASCII format.
FormatFlagXML Flag indicating that the import file is in XML
format.

xslFileName

Name of file containing a style sheet to use when importing XML.
Used only with FormatFlagXML. Include the full path and file name. If
this property is not set or is set to an empty string (" ") when
FormatFlagXML is used, the automatically generated default style
sheet will be used instead.

methodFlag

Numeric flag specifying whether Express or Interruptible import will
be used, can be set to either of these values:
MethodFlagINTERRUPTIBLE Flag indicating that the import
method should be interruptible. This is the default value if not set by
the script. MethodFlagEXPRESS Flag indicating that the import
method should be express.

matchFlag

Numeric flag specifying whether incoming records will be matched
against records already in the textbase, and what action should be
taken if a match is found.
Note: It is the script author's responsibility to avoid conflicting option
settings. No error is returned if a conflict occurs, but the behavior
may not be what is expected. For example, if matchFlag is set to
MatchFlagREJECT and noMatchFlag is set to
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NoMatchFlagREJECTNEWRECORD, then noMatchFlag is ignored.
Can be set to any one of these values:
MatchFlagNONE Flag indicating that the records should be
imported with no matching. This is the default value if not set by the
script.
MatchFlagREJECT Flag indicating that when a match is found, the
incoming record should be rejected.
MatchFlagDELETERECORD Flag indicating that when a match is
found, the textbase record should be deleted and the incoming
record discarded.
MatchFlagAPPENDFIELD Flag indicating that when a match is
found, the incoming record and the textbase record should be
merged, with incoming field entries appended to the entries already
in the textbase record.
MatchFlagREPLACEFIELD Flag indicating that when a match is
found, fields in the incoming record should replace the equivalent
fields in the textbase record.
MatchFlagREPLACERECORD Flag indicating that when a match
is found, the incoming record should replace the textbase record.
noMatchFlag

Numeric flag specifying what action should be taken if matching has
been turned on, and no match is found.
NoMatchFlagADDNEWRECORD Flag indicating that when no
match is found, the incoming record should be imported into the
textbase. This is the default value if not set by the script.
NoMatchFlagREJECTNEWRECORD Flag indicating that when no
match is found, the incoming record should be rejected.

matchFieldNames(n) A string specifying the name of a field to be used to match incoming
records against textbase records. Maximum number of entries is
MaxMATCHFIELDS.
MaxMATCHFIELDS

(READ-ONLY) Numeric, the maximum number of fields that can be
used to match incoming records against records in the textbase
(currently 5).

trimFlag

Numeric flag used to specify whether leading spaces should be
removed from field entries on import. Can optionally be set to:
TrimFlagSTRIPLEADINGSPACES Flag indicating that leading
spaces should be stripped from field entries on import. This flag is off
by default.

validationFlag

Numeric flag specifying what should happen if an incoming record
contains fields that violate content validation.
ValidationFlagREJECT Flag indicating that records that do not
meet validation will be rejected, even if the field allows users to
override content validation. This is the default value if not set by the
script.
ValidationFlagACCEPT Flag indicating that if an incoming record

Inmagic DB/TextWorks v13 Printed Help

221

Scripting
meets all field validation criteria except those for which user overrides
are permitted, the record will be accepted into the textbase.
ValidationFlagACCEPTANDUPDATE Flag indicating that if an
incoming record meets all field validation criteria except those for
which user overrides are permitted, the record will be accepted into
the textbase, and validation lists will be updated to include the new
values where permitted by the field definition, and passwords.
logFlag

Boolean, true if the import process should copy rejected records to
an exception file. This flag is on by default. If it is left on and no
logFileName is specified, the exception file name will be derived
from the import file name in the usual way, with an extension of the
form .X01, .X02, and so forth, as needed to be unique.

logFileName

String, name of exception file (if used). If file already exists, it is
replaced.

RecordCount

(READ-ONLY) Numeric, contains the number of records imported
after the operation is completed.

RejectedCount

(READ-ONLY) Numeric, contains the number of records rejected
after the operation is completed.

ReplacedCount

(READ-ONLY) Numeric, contains the number of records changed
(using matching) after the operation is completed.

The following properties apply only to delimited ASCII imports:
fieldOrderFlag

Flag used when the import file is in delimited ASCII format, to
specify how the software will determine what fields are being
imported and in what order. Can be set to any of these values:
FieldOrderFlagTEXTBASE Flag indicating that fields in a
delimited ASCII file should be imported in the order in which they
are defined in the textbase structure. Do not use this option if there
are fewer fields in the import file than in the textbase structure. This
is the default value if not set by the script.
FieldOrderFlagFIRSTROW Flag indicating that the first row or
record in the delimited ASCII import file specifies the order in which
fields will be imported.
FieldOrderFlagSPECIFY Flag indicating that the order of fields in
a delimited ASCII import file is specified by the importFieldNames
property.

importFieldNames(n)

A string specifying the name of a field to be imported from a
delimited ASCII file. Note that importFieldNames(0) is the first field
in the import record, importFieldNames(1) is the second, and so
forth. This property should be used when fieldOrderFlag has been
set to FieldOrderFlagSPECIFY. The maximum size of the array is
MaxIMPORTFIELDS. Note also that n must not exceed
MaxIMPORTFIELDS - 1.
Example (presented in correct syntax for JavaScript):
var nid=Command.newImportDescriptor( );
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nid.importFieldNames(0) = "Author";
nid.importFieldNames(1) = "Title";
nid.importFieldNames(2) = "Date Acquired";

MaxIMPORTFIELDS

Numeric, the maximum number of fields that can be imported
(currently 250, the same as the maximum number of fields that can
be defined in a textbase structure).

recordSeparator

String containing the character(s) used to separate records in a
delimited ASCII import file. Example in JavaScript: \r represents a
carriage return, \n represents a linefeed, and \t represents a tab.
The default separator is \r\n.

fieldSeparator

String containing the character(s) used to separate fields in a
delimited ASCII import file. The default separator is the comma
character (,).

entrySeparator

String containing the character(s) used to separate field entries in a
delimited ASCII import file. The default separator is the pipe or bar
character (|).

quoteCharacter

String containing the character used to surround field information in
a delimited ASCII import file. Fields containing field delimiter
characters as part of the data should be surrounded with quotation
marks. The default is the double quotes character (").

commentCharacter

String containing the character used to indicate a comment in a
delimited ASCII import file. Everything between the
commentCharacter and the next record separator will be ignored.
The default is the exclamation character (!).
See Also: Sample JavaScript Script 8: Import file using delimited ASCII format

Field Object
Properties
Name

A string, the name of the Field.

Value

A string, the text content of the Field (read/write).This property is the default
value of the object.

The following properties are read-only.
type

String, returns the field type. May have the values Text, Number,
Date, Automatic Number, Automatic Date, Automatic ID, Computed
Number, Computed Date, Image, Link, Code, UDC, Access Control,
or unknown.

isWriteable

Boolean, true if field can be updated.

isTermIndexed

Boolean, true if field has a term index.

isWordIndexed

Boolean, true if field has a word index.

isValidList

Boolean, true if field has a validation list.

isValidListUpdate

Boolean, true if field has a validation list that can be updated when
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the record is saved.
isValidMask

Boolean, true if field has mask validation.

isValidOverride

Boolean, true if field has validation that can be overridden.

isValidRange

Boolean, true if field has range validation (minimum and/or
maximum).

isValidRequired

Boolean, true if field is required.

isValidSingle

Boolean, true if field accepts single entries only.

isValidUnique

Boolean, true if field entries must be unique.

Form Object
Collections
boxes A collection of Box objects; supports Count property and Item method.
Form.boxes.Count returns the number of boxes in the form.
Form.boxes.Item("Title") returns the box object named Title.
Because Item is the default, Form.boxes("Title") is equivalent.

Recordset Object
Collections
Fields

A collection of Field objects. Supports Count property and Item method.
Recordset.Fields.Count returns the number of fields in the recordset.
Recordset.Fields.Item ("Title") returns the Field object named Title. (Because Item
is the default, Recordset.Fields("Title") is equivalent.)
Recordset.Fields.Item(n) returns the nth field in the textbase (zero-origin).

Errors

A collection of Error objects. Supports Count property and Item and Clear methods.
Recordset.Errors.Count returns the number of errors in the current collection.
Recordset.Errors.Clear() clears the current error collection.
(Collection is automatically cleared at the start of any operation that may generate
an error.)
Recordset.Errors.Item(n) returns the nth Error object in the current collection
(zero-origin). Because Item is the default, Recordset.Errors(n) is equivalent.

Properties
The following properties are read-only.
textbase

The associated Textbase object.

isOpen

Boolean, true if the Recordset is open.

BOF

Boolean, means positioned before first record.

EOF

Boolean, means positioned after last record.
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RecordCount

Number of records in Recordset.

AbsolutePosition

1-origin ordinal number of current record in Recordset (read/write):
-1=unknown, -2=BOF, -3=EOF

The following property is read/write.
validationFlag

Numeric flag that dictates how validation rules should be treated during an
update operation. It can have any of the following values, which are readonly:
ValidationFlagNORMAL Flag indicating that all validation rules should
apply during an update operation.
ValidationFlagOVERRIDE Flag indicating that an update operation can
forego validating data in fields for which validation may be overridden.
ValidationFlagOVERRIDEUPDATE Flag indicating that an update
operation can forego validating data in fields for which validation may be
overridden, AND the validation list for a field should be updated to reflect
any new entries if permitted for that field.

Methods
Open (QueryString)

Execute the query and make the Recordset available. If the
supplied query string is empty (""), the Recordset is opened with an
empty set. Note that a Recordset must be opened before records
can be added.

Close()

Close the Recordset (may be re-opened with a new query).

AddNew()

Creates a new, empty record (added to the textbase when Update()
is called).

Update()

Writes the current record back to the textbase, with any changes.

Delete()

Deletes the current record from the textbase.

Move (NumRecords)

Move current record pointer NumRecords (from present position,
may be negative).

MoveFirst()

Moves the current record pointer to the first record.

MoveLast()

Moves the current record pointer to the last record.

MoveNext()

Moves the current record pointer to the next record.

MovePrevious()

Moves the current record pointer to the previous record.

NewSortDescriptor()

Returns a new, empty SortDescriptor object.

Sort (SortDescriptor)

Sorts the Recordset, using the parameters in the SortDescriptor
object.

OmitCurrentRecord()

Omits the current record from the set and automatically does a
MoveNext().

Example
This script inserts a new entry in the ClaimDate field in all of the records in the current set. The
entry contains the current date followed by " (sent claim letter)". The script is performing the
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same function as batch modify but with many fewer keystrokes. The script is invoked by clicking
a script button having the name "btnUpdate" in a query screen.
var gMonths = new Array ("Jan", "Feb", "Mar", "Apr", "May", "Jun",
"Jul", "Aug", "Sep", "Oct", "Nov", "Dec");
//====================================================
// Function: strToday
// Purpose: return string containing current date
// Parameters: // Returns: date string
//====================================================
function strToday()
{
var now = new Date();
var mnumber = now.getMonth();
var dateString= "" + now.getDate() + "-" + gMonths[mnumber] + "-" +
now.getYear();
return dateString;
}
//====================================================
// Function: btnUpdate_onClick()
// Purpose: insert date and comment in ClaimDate field
// in all records in the current set
// Parameters: // Returns: //====================================================
function btnUpdate_onClick()
{
var crs = Application.activeTextbase.currentRecordset;
var es = Application.entrySeparator;
var claimField, newEntry;
// Proceed only if there is a nonempty current set.
if ((crs != null) && (crs.RecordCount > 0))
{
// Construct the new entry - today's date plus the status information.
newEntry = strToday() + " (sent claim letter)";
// Initialize for walking through the records in the set.
crs.MoveFirst();
// Loop through the records in the set.
while (crs.EOF == false)
{
// Get the current value of the ClaimDate field.
claimField = crs.Fields("ClaimDate").Value;
// If there is information already in that field, precede it with
// an entry separator.
if (claimField.length > 0)
claimField = es + claimField;
// Now insert the new entry at the beginning.
crs.Fields("ClaimDate").Value = newEntry + claimField;
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// Save the updated record.
crs.Update();
// And move to the next record in the set.
crs.MoveNext();
}
}
}

SendMailDescriptor Object
Properties
Unless otherwise specified, the properties at the first indentation level are read/write. Some of
them can be set to specific values only. These values are available as read-only properties,
shown at the second indentation level.
formatOpt

Numeric flag indicating the format of the message, can be set
to any of these values:

FormatOptBODYTEXT

Flag indicating plain text in message body (default).

FormatOptATTTEXT

Flag indicating plain text attachment.

FormatOptATTRTF

Flag indicating Rich Text Format (RTF) attachment.

FormatOptATTHTML

Flag indicating HTML attachment.

sendMessagePerRecord

Boolean, specifies that each record is to be sent to a different
address extracted from the record or a linked record.

sendMessagePerGroup

Boolean, specifies that records being sent to the same email
address (extracted from a field in the record or linked record)
be grouped into a single email.

The following property applies only if each record is sent to a different address:
emailAddressField

Name of the field to get the e-mail address from (primary or linked
textbase). For example: EMailAddr or EMailAddr@StaffID

The following properties apply only to reports sent to one address:
emailTo

String, should be set to the recipient of the e-mail.

emailCC

String, should contain address(es) to which the e-mail should be copied.
Note that it is ignored if sendMessagePerRecord=true.

The following properties apply to all reports:
emailFrom

String, should be set to the sender of the e-mail. (Ignored
for MAPI.)

emailBCC

String, should contain address(es) to which the e-mail
should be sent as a blind-copy.

emailSubject

String, should contain the subject of the e-mail.
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reportFormName

String, should contain name of the report form to use. If the
script does not specify the report form name, the current
Report Window form will be used by default.

reportFormFlag

Numeric value specifying whether the form is Public or
Private, can be either of these values:

ReportFormFlagPUBLIC

Flag indicating public form. This is the default if no flag is
set.

ReportFormFlagPRIVATE

Flag indicating private form. Must be specified if the form is
private.

SendCnt (READ-ONLY)

Numeric, set to the number of messages sent after the
operation is completed.

SendFailCnt (READ-ONLY)

Numeric, set to the number of messages that could not be
sent after the operation is completed.

SendEmptyCnt (READONLY)

Numeric, set to the number of messages that could not be
sent because the e-mail address field was empty.

Methods
addAttachment
(filename)

Adds the named file to the list of attachments.

See Also: Sample JavaScript Script 12: Send report as mail with attachments

SortDescriptor Object
Using the SortDescriptor object changes the current user-specified sort, the sort shown on the
Sort Report dialog box.

Properties
The following properties are read/write. Note: Only fields in the primary textbase can be used
for sorting.
sortFlags

Numeric flags governing the overall sort. See SortFlagX (for
example, SortFlagEMPTIESFIRST) properties.

sortFieldName(n)

A string specifying the name of a field to sort by. Note that
sortFieldname(0) is the primary (most significant) sort field,
sortFieldName(1) is the first subsort field, and so forth. Note also
that n must not exceed MaxSORTFIELDS - 1.

sortFieldFlags(n)

Numeric flags governing the sorting properties of the nth sort field.
See FieldFlagX properties (for example, FieldFlagREVERSE).

alternateFieldName(n)

A string specifying the name of an alternate field to sort by. If the
field specified in sortFieldName(0) is absent in a record, the
software looks for alternateFieldName(0), then
alternateFieldName(1), and so forth. Note that n must not exceed
MaxALTFIELDS - 1.

alternateFieldFlags(n)

Numeric flags governing the sorting properties of the nth alternate

228

Inmagic DB/TextWorks v13 Printed Help

Scripting
sort field. See FieldFlagX properties (for example,
FieldFlagREVERSE).
mergeFieldName(n)

A string specifying the name of a field to interfile with the top-level
sort. The order in which these fields are specified is not relevant.
Note that n must not exceed MaxMERGEFIELDS - 1.

mergeFieldFlags(n)

Numeric flags governing the sorting properties of the nth merge
field. See FieldFlagX properties (for example,
FieldFlagREVERSE).

The following ten properties are read-only. They are intended to be used to set numeric values
in the properties listed above.
MaxSORTFIELDS

Maximum number of sort fields (currently 5).

MaxMERGEFIELDS

Maximum number of merge fields (currently 4).

MaxALTFIELDS

Maximum number of alternate fields (currently 4).

These sort flags are mutually exclusive. You may assign any one of them to the sortFlags
property:
SortFlagEMPTIESFIRST

Records having nothing in the primary or alternate sort fields
appear first.

SortFlagOMITEMPTIES

Records having nothing in the primary or alternate sort fields
do not appear.

SortFlagTEXTBASESORT

Flag indicating that the textbase default sort should be used.
If this value is set, the rest of the properties in the
SortDescriptor object are ignored.

SortFlagRELEVANCESORT

Flag indicating that a relevance-ranked sort should be used.
If this value is set, the rest of the properties in the
SortDescriptor object are ignored.

SortFlagNOSORT

Flag indicating that no sort should be used. If this value is
set, the rest of the properties in the SortDescriptor object are
ignored.

The following sort flags can be combined. Specify both by setting the appropriate property to
the sum of these values.
FieldFlagREVERSE

Sort by this field in reverse (or descending) order.

FieldFlagEXPLODE

ort by each separate entry of this field.

Store Object
Properties
The following property is read/write.
value
(key)

A string. Key is a string. Value is the default property of Store, so Store (key) is
equivalent to Store.value(key). A non-existent entry returns a null string; writing
a null string ("") deletes the entry.
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The following properties are read-only.
entryCount

A number, the number of entries currently in the Store.

currentKey

A string, current key while iterating.

currentValue

A string, current value while iterating.

Methods
beginIteration()

Starts an iteration. Returns false if Store empty, true otherwise.

nextIteration()

Sets currentKey and currentValue to next entry in Store. Returns false if
no next entry (past end). Sample syntax:
var store = Application.sessionStore;
store.beginIteration();
while ( store.nextIteration() )
{
// do stuff with store.currentKey and store.currentValue
}

Example 1
This code saves a value. "keyName" represents the key string you will later use to retrieve the
value and "boxName" is the script name given to a box on a form.
Application.userStore.value("keyName") = Form.boxes("boxName").content;

Example 2
This code retrieves a previously saved value. "boxName" is the script name given to a box on a
form and "keyName" represents the name of the key under which the value was stored.
Form.boxes("boxName").content = Application.userStore.value("keyName");

Textbase Object
Properties
name

A string.

path

A string.

currentRecordset

A Recordset object. This property is the default value of the Textbase
object.

recordCount

The number of records in the textbase.

textbaseStore

A permanent Store object associated with the textbase and the user.
Written to the <textbase name>.TBS file in the user file folder when you
close the textbase.

Methods
printReport
(formName)
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Prints the current set using the specified form, returns false on failure (for
example, there is no current set). The form name must match exactly the
name of a form accessible for printing. If it does not, the Basic form will be
used instead.
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Window Object
The methods in this object provide access to information about the current window.

Properties
type

A string, the type of window this script is executing in. Possible values: "Query",
"Display", "Report", "Edit", "EditLinked", "Menu", "MenuCascade",
"HTMLApplication", "unknown".

formName

Exposes the name of the form or query screen being used in the current
window. Not available for Menu Screen window; use
Application.currentMenuName and Application.currentMenuPath instead.

Methods
appendToTitle(string)

Appends the specified text string to the window's title bar.

Menu choices on the Applications menu open the DBTW Application window. Within a DHTML
(Dynamic Hypertext Markup Language) page running in the DBTW Application window,
window.external returns the same top-level objects that a form sees. (There is no Form object
in the Application window.) Specifically, window.external.Application returns the Application
object, window.external.Form returns the form from which the DHTML page was invoked
(where applicable), window.external.Window returns the window containing the DHTML page,
and window.external.Comand returns the Command object.

Sample JavaScript Scripts
The following topics provide sample JavaScript scripts. You may copy and modify them for your
own use. For more sample scripts, visit the Inmagic Web site (http://www.inmagic.com).
Note: Scripts are limited to 30,000 characters.
Sample JavaScript script 1: Add a script button to swap the contents of two fields
Sample JavaScript Script 2: Prepopulate a query screen for new queries
Sample JavaScript Script 3: Add buttons to a query screen to print the current set using either of
two report forms
Sample JavaScript Script 4: Add a "help" button next to a box on an edit screen, telling the user
what to type in that field
Sample JavaScript Script 5: Copy the first word of one field to another field (if the second field is
empty) when the record is saved
Sample JavaScript Script 6: Launch document(s) in a field in the Edit, Display, or Report
window in its native application
Sample JavaScript Script 7: Add button to report to sort by a specific field exploded
Sample JavaScript Script 8: Import file using delimited ASCII format
Sample JavaScript Script 9: Export all records in textbase in delimited ASCII format
Sample JavaScript Script 10: Specify forms for use with an individual query screen
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Sample JavaScript Script 11: Reset the buttons for all query boxes to AND when you click New
Query
Sample JavaScript Script 12: Send report as mail with attachments

Sample JavaScript Script 1: Add a script button to swap the contents
of two fields
function button1_onClick()
{
var temp = Form.boxes("name1").content;
Form.boxes("name1").content = Form.boxes("name2").content;
Form.boxes("name2").content = temp;
}

Sample JavaScript Script 2: Prepopulate a query screen for new
queries
function onFormClear()
{
Form.boxes("name1").content = ">=@date - 7";
Form.boxes("name1").setFocus()
}

Sample JavaScript Script 3: Add buttons to a query screen to print the
current set using either of two report forms
function button1_onClick()
{
if (!Application.activeTextbase.printReport("name of first form"))
Application.message("There are no records to print.");
}
function button2_onClick()
{
if (!Application.activeTextbase.printReport("name of second form"))
Application.message("There are no records to print.");
}

Sample JavaScript Script 4: Add a "help" button next to a box on an
edit screen, telling the user what to type in that field
function button1_onClick()
{
Application.message("Type the last name followed by a comma and the first
name.");
}

Sample JavaScript Script 5: Copy first word of one field to another
field (if the second field is empty) when the record saved
function onRecordSave()
{
var srcBox = Form.boxes("name1");
if (srcBox) // be sure there is a box with the given name
{
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var srcText = srcBox.content;
if (srcText != "") // proceed only if the first box is nonempty
{
var tgtBox = Form.boxes("name2");
if (tgtBox && tgtBox.content == "") // second box must exist and be empty
{
var allWords = srcText.split(" "); // allWords is an array of words
tgtBox.content = allWords[0];
}
}
}
}

Sample JavaScript Script 6: Launch document(s) in field in the Edit,
Display, or Report window in its native application
This script will open each of the documents listed in a field using its native application. This
script can be used in the Edit, Display, or Report window, as long as the documents are shown
in a single box on the form, and are separated by the same sequence of characters (such as
semicolon-space).
This script makes the following assumptions:
The box containing the document or file names has the script name "doc", has no
content other than the document names, uses no added paragraph breaks, and
separates the entries in the field with semicolon-space (in a display or report).
The button used to open the documents has the script name "launch".
The document names are in separate field entries.
You may copy and modify the script as needed to accommodate your situation.
function launch_onClick()
{
// Substitute your field separator for the semicolon-space
// shown in quotes below.
//
var docSeparator = "; ";
var editSeparator = Application.entrySeparator;
// Substitute the script name for your form box for the
// word shown in quotes below.
//
var docBox = Form.boxes("doc");
if (docBox)
{
var dispDocs = docBox.content.split(docSeparator);
var editDocs = docBox.content.split(editSeparator);
var docs;
if (editDocs.length > 1)
docs = editDocs;
else if (dispDocs.length > 1)
docs = dispDocs;
else
docs = editDocs;
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for (var i=0; i<docs.length; i++)
{
if (docs[i] != "")
Application.shellExecute(docs[i], "");
}
}
}

Note: If you start with a Basic form and add this script, or if you choose to display the document
names in a list, specify "\r" as the docSeparator.

Sample JavaScript Script 7: Add button to report to sort by a specific
field exploded
function subj_onClick()
{
var crs = Application.activeTextbase.currentRecordset;
var sd = crs.newSortDescriptor();
sd.sortFieldName(0) = "Subject";
sd.sortFieldFlags(0) = sd.FieldFlagEXPLODE;
crs.Sort(sd);
Command.refreshWindow();
}

Sample JavaScript Script 8: Import file using delimited ASCII format
This script shows a simple example of using the ImportDescriptor object. It Imports the file
"c:\data\import.add" using delimited ASCII format, Express Import, and accepts content
validation overrides and updates validation lists. It displays a completion message at the end.
function button_onClick()
{
var nid = Command.newImportDescriptor();
nid.importFileName = "c:\\data\\import.add";
nid.formatFlag = nid.FormatFlagDELIMITED;
nid.methodFlag = nid.MethodFlagEXPRESS;
nid.validationFlag = nid.ValidationFlagACCEPTANDUPDATE;
Command.importDataEx(nid);
var addct = nid.RecordCount;
var rejct = nid.RejectedCount;
var repct = nid.ReplacedCount;
Application.message("Import done.\r"+addct+" added\r"+rejct+"
rejected\r"+repct+" replaced");
}

Sample JavaScript Script 9: Export all records in textbase in delimited
ASCII format
This script shows a simple example of using the ExportDescriptor object. It exports all records in
a textbase in delimited ASCII format to "c:\data\export.dmp". It displays completion message at
the end.
function export_onClick()
{
var ned=Command.newExportDescriptor();
if (ned)
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{
ned.exportFileName="c:\\data\\export.dmp";
ned.formatFlag=ned.FormatFlagDELIMITED;
ned.exportAllRecs = true;
Command.exportDataEx(ned);
Application.message("Exported "+ned.RecordCount+
" records.\nDidn't export "+ned.RejectedCount+
" records.");
}
else
Application.message ("Failed to get an export descriptor.");
}

Sample JavaScript Script 10: Specify forms for use with an individual
query screen
This script specifies forms for use with an individual query screen. When you open the query
screen, the desired forms are selected. The script displays an error message if one or more of
the forms does not exist.
function onFormOpen()
{
if (!Command.selectFormsEx("Display Form","Edit Form","Short
Report","Print Summary"))
Application.message("Problem selecting a form");
}

Sample JavaScript Script 11: Reset the button for all query boxes to
AND when you click New Query
This script resets the Boolean operator buttons back to AND for all query boxes when you click
New Query.
Note: All of the query boxes must have unique script names for it to work. Any name can be
used.
function onFormClear()
{
var bcount = Form.boxes.Count;
for (var i=0; i < bcount ; i++)
{
Form.boxes(i).booleanValue = Form.boxes(i).BooleanAND;
}
}

Sample JavaScript Script 12: Send report as mail with attachments
This script makes it possible for a user to click a button to send a report as e-mail with two
attachments without further interaction. Note that this sample script assumes that you are using
SMTP (Simple Mail Transfer Protocol).
function button_onClick()
{
if (Application.activeTextbase.currentRecordSet.RecordCount > 0)
{
var smDesc = Command.newSendMailDescriptor();

Inmagic DB/TextWorks v13 Printed Help

235

Scripting
smDesc.formatOpt = smDesc.FormatOptATTHTML;
smDesc.emailFrom = "\"Library\" <library@domain.com>";
smDesc.emailTo = "username@domain.com";
smDesc.emailSubject = "The book you ordered is here";
smDesc.addAttachment("c:\\docs\\toc.rtf");
smDesc.addAttachment("c:\\docs\\abstract.txt");
smDesc.reportFormName = "Books Here";
smDesc.reportFormFlag = smDesc.ReportFormFlagPRIVATE;
Command.sendMailEx(smDesc);
var sendCnt = smDesc.SendCnt;
var failCnt = smDesc.SendFailCnt;
Application.message("Send Mail operation done.\r"+
sendCnt+" messages sent,\r"+
failCnt+" messages not sent.");
}
else
Application.message("There is no current set.");
}

See Also
SendMailDescriptor Object

Sample Visual Basic Scripting Edition (VBScript) Scripts
Sample Visual Basic Scripting Edition Scripts
The following topics provide you with sample Visual Basic Scripting Edition (VBScript) scripts
You may copy and modify them for your own use.
Note: Scripts are limited to 30,000 characters.
Sample VBScript Script 1: Add a script button to swap the contents of two fields
Sample VBScript Script 2: Add buttons to a query screen to print the current set using either of
two report forms

Sample VBScript Script 1: Add a script button to swap the contents of
two fields
Sub button1_onClick()
dim temp
temp = Form.boxes("Box1").content
Form.boxes("Box1").content = Form.boxes("Box2").content
Form.boxes("Box2").content = temp
End Sub
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Sample VBScript Script 2: Add buttons to a query screen to print the
current set using either of two report forms
Sub button1_onClick()
If Not Application.activeTextbase.printReport("DAILY") Then
Application.message("There are no records to print.")
End If
End Sub
Sub button2_onClick()
If Not Application.activeTextbase.printReport("MONTH END") Then
Application.message("There are no records to print.")
End If
End Sub
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Working with Images
Your textbases can include color, grayscale, and black and white images in over 30 of the most
common image file formats, such as GIF and JPG. You can search for, display, and print these
images, and annotate them using text and graphics.
Only the image names are stored in the textbase. The actual image files are stored in external
locations, such as network servers or your local hard drive.
To associate images with records, add an Image field to the textbase structure, then populate
that field with image file names (either by editing individual records or by importing a text file).
To display images, do a search and display the records in the Report, Display, or Edit window,
then choose Display>Show Record Images. The Window>Synchronize Windows command
determines whether the image and record display remains synchronized.

Finding Images
To find images, use either of these methods
Search an indexed Image field just as you would search any other type of field. For
example, press F3 and paste image file names from the index.
Search for a particular record or set of records, some or all of which happen to include
image references (names of images) in an Image field.
To find all records with an entry in an Image field
Type =* in a Query box that searches a particular Image field.
To find all records where the Image field is empty
Type =* but change the Boolean button in front of the box to NOT.
After you retrieve records, you can display the images in the Images window (display records in
the Report, Display, or Edit window then choose Display>Show Record Images). From the
Images window, you can use the image options to zoom, rotate, display multiple images in a
thumbnail view, and perform other display operations.

Displaying Images
After you find records that contain images, you can view the images by displaying them in the
Images window. The Images window shows all of the images referenced in all of the records in
the current set (one at a time). You can navigate among images, zoom in and out, see a
Thumbnail view of all images at once, and perform other display operations.
To display images
1. Retrieve records that contain image references.
2. Select a record in the Report window or display a record in the Edit or Display window.
You must open one of these windows if you want to display images. The record that is
selected or displayed determines which image you will see first.
Note: If you start displaying images while your cursor is in an Image field in an Edit or
Display window, you can see images from that field only. Otherwise, you can see all
images associated with all records in the set.
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3. Click the Show Record Images toolbar button or choose Display>Show Record
Images.

Thumbnail View
The Thumbnail window displays all of the images in the current record or field, at a reduced
size, providing a quick way to find and view a particular image.

Opening the Thumbnail Window
To display images in the Thumbnail window, you must first access the Images window by
choosing Display>Show Record Images. Then click the Thumbnail button on the Images
window toolbar or choose Images>Thumbnail.
The cursor placement when you access the Images window determines whether the Thumbnail
window displays images in the current record or field. If the cursor is in an Image field in an Edit
or Display window when you access the Images window, the Thumbnail window shows images
in the current field, not the current record.

Thumbnail Operations
While the Thumbnail window is active, you can perform the following operations:
View an image full size. The Thumbnail window shows multiple images at once. When
you find the one you are looking for, you can view it full-size in the Images window. You
can double-click the image in the Thumbnail window. Or you can select the image, then
click the Show Selected Image button, or choose Thumbnail>Show Selected Image.
Change the number of images displayed at one time. Click the Set Rows and
Columns button or choose Thumbnail>Set Rows and Columns. When prompted, type
the number of rows and columns you want. This setting persists until you change it.
Show or Hide Annotations. Choose Thumbnail>Show Annotations or Hide
Annotations to make annotations appear or not appear.
Annotate images. Choose Thumbnail>Annotation Current Image. The Image
Annotation window appears with a floating drawing tools toolbox.
Sharpen black and white images. Click the Scale to Gray button or choose
Thumbnail>Scale to Gray. This setting persists until you change it. This setting also
affects the Images window. It does not affect the image file itself, nor does it affect
printing.
View images in the next or previous record. Click the Next Record or Previous
Record button.

Scanning Images
If you have a TWAIN compliant scanner, you can scan an image to a file while editing a
DB/TextWorks record, and DB/TextWorks will insert the file name in the Image field. Only
TWAIN-compatible scanners are supported. Check your scanner documentation to see if a
TWAIN scanner driver is available.
While editing a record, place the cursor in an Image field and choose Records>Scan Image.
The Scan Image dialog box appears. If you have multiple scanners, use the Select Source
button to choose a scanner. Click the Scan Image button to continue.
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The next dialog box that appears is provided by the TWAIN driver for the selected scanner.
Supply the requested information and begin scanning. After the scan is completed, close the
dialog box.
When the Save File As dialog box appears, specify a name for the image file and select a file
type (TIF, BMP, and so forth). The file will be saved to disk and the file name inserted in the
DB/TextWorks Image field. The path will be omitted if it is the same as the textbase path. If the
Image field already contains information, a new entry is created.
Note: The Scan Image command does not support automatic document feeders or
compressing a series of image names using the shortcut representation, such as IMG001.TIF
(3).

Printing Images
To access this dialog box: With the Images window, Thumbnail window, or Image Annotation
window active, choose File>Print. On the Select Images to Print dialog box, select a Print
Range option, and click OK. Use the standard Print dialog box to specify the desired printing
options and click OK.
Print Current Image. Print the image currently displayed in the Images or Image
Annotation window or selected in the Thumbnail window.
Print Images in the Current Record. Print all images referenced in the field(s)
highlighted in the Select Image Fields list, in the current record.
Print Images in the Current Set. Print all images referenced in the field(s) highlighted
in the Select Image Fields list, in the current set of records.

Notes
The Show/Hide Image Annotations command (Images menu) determines whether
images are printed with or without annotations.
Rotate, Despeckle, and Deskew affect printing. All other image display options (for
example, zoom, scale to gray, and so forth) do not affect printing.
When printed, images are scaled to fit the Paper Size selected in the Print Setup dialog
box.
Because image files are complex, they generally take longer to print than a page of text.
While images are printing, progress indicators show the total number of images printed
and the percentage of the current image printed. You get a completion message when
the job is done.
To increase the speed at which images print, select a non-Postscript printer driver in the
Print dialog box. Another way to increase printing speed is to modify the [Imaging]
section of the INMAGIC.INI file to include the line FastPrint=1. This option works only
with certain kinds of printers and images. If you receive printer errors, change the line
back to FastPrint=0.
To stop printing images, click the Cancel button on the printing progress dialog box.
Before the printer can stop, it must finish printing any images that are already in its
memory.
Some Postscript printer drivers include a “Print as negative image” option.
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Adding Image Names to Records
How to Get Image File Names into Records
If you plan to reference just a few images in your textbase, you can type the image file names
directly in the Image field of each appropriate record.
If you plan to reference many images, it is more efficient to import image file names from a text
file.
If you have a TWAIN compatible scanner, you can scan images while editing records, and insert
the file name(s) directly into an Image field.

Image File Names and the Counter Shortcut
An Image field in a record can contain one or more image file names. Make each file name a
separate field entry (use F7). For example:
LETTER1.JPG
LETTER2.JPG

If you have several consecutively named files, you can reference multiple image files in one
entry by using a counter at the end of the entry. For example, the following entry references
three image files (FILE1.JPG, FILE2.JPG FILE3.JPG):
FILE1.JPG 3

DB/TextWorks does not use the file extension to recognize the file type. This gives you more
freedom in naming your image files. For example, a file could be called LETTER.001.
Important! Do not use this shortcut if you plan to use inline images or image links with a
DB/Text WebPublisher product.

Image Drive and Path
A general guideline when specifying image file names in a field is to include the folder path,
starting with a backslash, but not the drive letter. For example, an Image field might include this
entry:
\MEMOS\LETTER.JPG

If you omit the backslash at the beginning of the path, DB/TextWorks looks for the image in the
subfolder of the current folder:
MEMOS\LETTER.JPG

If you prefer, you can specify just the image file name (no path), and DB/TextWorks will look for
the image in the textbase folder or current folder on all drives specified in
Tools>Options>Imaging:
LETTER.JPG

To specify which drives DB/TextWorks should look on, choose Tools>Options>Imaging and
specify up to 12 drive letters.
Note: If the drive is included in the image file name in a record, DB/TextWorks ignores the
Image drive(s) option for that image, and looks for images on the drive specified in the record.
Tip! You can also specify an optional volume ID field for each textbase to specify how
DB/TextWorks handles searching for images.

Inmagic DB/TextWorks v13 Printed Help

241

Working with Images

Long File Names
If you used DB/TextWorks prior to version 1.2 and your Image fields contain comments after
image file names, those entries could be misinterpreted as long file names. For example, the
entry MEMO.TIF Revision is interpreted as a valid file name, instead of an image file name
followed by a comment. To prevent this problem, enclose the file name in double quotation
marks ("MEMO.TIF" Revision) or choose Tools>Options>Imaging and select the Support
only short filenames for images check box.

Specifying the Image Drive and Path
A general guideline when specifying image file names in a field is to include the folder path but
not the drive letter. For more information, see Adding Image Names to Records.

Specifying a Path
For best results, specify the image file name using a full folder path, starting with a backslash
(for example, \SALES\MEMO.TIF). If you omit the backslash at the beginning of the path,
DB/TextWorks looks for the image in the subfolder of the current folder. If you do not include a
path (for example, MEMO.TIF), DB/TextWorks looks for the image in the same folder where the
textbase is located.

Specifying a Drive
Image files may be stored on local drives, shared network drives, external storage devices such
as CD-ROMs, or other locations. For this reason, avoid including a drive letter as part of the
image file name in a record. To indicate the drives on which DB/TextWorks should look for
images, choose Tools>Options>Imaging and specify one or more drive letters.
Note: If the drive is included in the image file name in a record, DB/TextWorks ignores the
Image Drives user preference for that image, and looks for images on the drive specified in the
record.

Using Counters to Reference Multiple Image Files in One
Entry
Note: Do not use this shortcut if you plan to use the images with a DB/Text WebPublisher
product, or in picture boxes in DB/TextWorks.
An entry in an Image field can be a file name or a file name followed by a counter. Using a
counter can be more efficient than specifying each file name as a separate entry.
When an image file name is followed by a counter, DB/TextWorks expects to find additional
image files. To determine the additional image file names, DB/TextWorks increments the last
number found in the file name (including the extension). You can include parentheses or other
punctuation around or before the image counter in an Image field: LETTER1.JPG (3)
You can use counters in text files that you plan to import. In the import file, type the name of the
image followed by a number that indicates the total number of images in the sequence, the
same as you would type it in an Image field.
Example 1: ENG.001 3 references three images (ENG.001, ENG.002, ENG.003).
Example 2: FAX1.TIF 2 references two images (FAX1.TIF, FAX2.TIF).
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Following Long File Names with Counters
Windows supports long file names, which can contain spaces. If the last word in an Image field
entry is a number, DB/TextWorks looks for a number earlier in the entry. If it finds one, it
assumes that the final number is a counter. Otherwise, the entire field entry is assumed to be a
single file name. To avoid confusion, you can enclose the file name in double quotation marks.
Note that you can follow a quoted file name with a counter (see Example 4).
Example 1
Auto Diagram 2 is interpreted as a valid file name and is not incremented.
Example 2
Auto Diagram 29 2 references two images (Auto Diagram 29, Auto Diagram 30).
Example 3
"Form 1040 Schedule 12" is interpreted as a valid file name and is not incremented. If you omit
the double quotation marks, the name is incorrectly interpreted as 12 images (Form 1040
Schedule, Form 1041 Schedule, and so forth).
Example 4
"Form 100" 2 references two images (Form 100, Form 101).

Supported Image File Formats
DB/TextWorks supports color, grayscale, and black and white images in the file formats listed
below. If you do not see a particular format listed, you can contact Inmagic, Inc. to find out if that
format has recently been added or will be supported in the future.
Supported File Formats
Amiga IFF

HALO Cut

Pixmap (XPM)

ATT (G4)

ICO

RLE

BMP

IOCA

Showpartner GX2

Brooktrout

JPEG

Sun Raster

CALS

Kodak Photo CD (read only)

TARGA

CLP

Kofax

TIFF*

DCX

LaserData (LV)

WMF (raster only)

DIB

MAC Paint

WPG (raster only)

EPS (screen preview only)

Microsoft Paint MSP

Xbitmap (XBM)

G3

PCX

XWD

G4

PDF

GEM IMG

Photoshop

GIF

PICT (raster only)

*There is a user option that controls whether DB/TextWorks displays and prints all the images in
multi-image TIFF files.
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Annotating Images
Annotations are text and graphics that you can add to an image to mark it up, as if the image
were a sheet of paper. You and other users of the textbase can display and print images with or
without annotations. Annotations do not change the image file itself. Annotations are stored as
separate files, with the default extension .ANN. The annotation layer sits "on top of" the image
for display or printing.

Image Annotation Window
Use the Image Annotation window to add or edit annotations.
Note: You cannot annotate images if a textbase is opened as read-only, or if the current
password prohibits annotation.
To open the Image Annotation window
1. Search for records that contain images.
2. With the Report window active, or with a record displayed in the Edit or Display window,
choose Display>Show Record Images.
3. Choose Images>Annotate Current Image.

Adding Annotations to an Image
You can add text and graphic annotations to an image, such as the arrow and sticky note shown
below. The image file itself is not altered, because annotations are stored as a separate file with
the default extension .ANN.

To add image annotations
1. Search for records that contain references to the images you want to annotate.
2. With the Report window active, or with a record displayed in the Edit or Display window,
choose Display>Show Record Images.
3. Navigate to the image you want to annotate.
4. Choose Images>Annotate Current Image to open the Image Annotation window.
Note: You cannot annotate images if a textbase is opened as read-only, or if the current
password prohibits annotating images.
5. Use the drawing tools on the Annotations menu or in the floating toolbox to add
annotations. To show or hide the toolbox, choose Annotations>Show Annotations
Toolbox or Annotations>Hide Annotations Toolbox.
Note: You can add annotations anywhere on the image. If an image is not too large, you
can also add annotations to the right of or below the image, but you may have to resize
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the Image Annotation window first. You cannot add annotations above or to the left of an
image.
6. Edit annotations to change the appearance of the selected object(s), using any of the
following methods:
Use the Annotation Properties dialog box (choose Annotations>Annotation
Properties).
Double-click text to enter editing mode, so you can retype the text.
Move or resize an object using the mouse.
7. Save annotations by choosing Annotations>Save Annotation.
8. Close the Image Annotation window.
To show or hide annotations during display and printing
With the Images window active, choose Images>Show Image Annotations or Images>Hide
Image Annotations to show or hide all image annotations during display and printing. After
turning annotation display on or off, you can print images as you normally would (make an
image window active and choose File>Print).

Annotation Drawing Tools
Use the drawing tools to add annotations to an image. You can choose a tool from the floating
toolbox shown below, or from the Annotations menu. To show or hide the floating toolbox,
choose Annotations>Show Annotations Toolbox or Annotations>Hide Annotations
Toolbox.
Use the Annotation Properties dialog box (choose Annotations>Annotation Properties) to set
the defaults for the following properties: font, line style, line thickness, foreground color and
background color. Notice that any object selected while you make your settings will be affected.

Editing Annotations
Use the Image Annotation window to add or edit annotations. If necessary, navigate to the
image that you want to annotate.
Note: You cannot edit annotations if a textbase is opened as read-only or if the current
password prohibits editing annotations.
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Selecting Objects
You must select an object in order to edit it. You can use Shift+click to select multiple objects,
or you can lasso them.

Changing Object Attributes
Use the Annotation Properties dialog box (choose Annotations>Annotation Properties) to
change the appearance of the selected object(s). You can change the font, line style, line
thickness, and foreground and background colors for text and objects, where applicable. Note
that property changes made on the Annotation Properties dialog box set the default properties
for the tools and affect any currently selected objects and new annotation objects you add.

Navigational shortcut menu
Click the right mouse button to display a navigational control shortcut menu that gives you the
option to move to the next image, previous image, or to jump to a particular image. This menu
does not appear if you are in editing mode on a Text or Sticky Note object; a text editing
shortcut menu appears instead.

Editing Text
To edit text or sticky note text, double-click it. A blinking cursor indicates that you are in editing
mode, and you can retype the text. To exit editing mode, click anywhere not on the text.
Click the right mouse button while in editing mode on a Text or Sticky Note object to display a
text editing shortcut menu containing these commands: Undo, Cut, Copy, Paste, Delete,
Select All.

Moving Objects
To move a selected object, position the cursor over a selected object (but not over a handle), so
the cursor appears as a four-headed arrow. Drag and release the mouse. If you decide that you
do not want to move the object, press the Esc button on your keyboard while you are moving
the object to return it to its original position.

Resizing Objects
To resize a selected object, click a handle, then drag and release. When a handle is clicked, the
cursor changes to a two-headed arrow, indicating that you are in "resizing" mode. Drag from a
corner of a bounding box to maintain proportions. Drag from a side to change proportions.

Edit menu (Annotations)
When the Image Annotation window is active, you can use the Edit menu to perform the
following actions on the selected object(s).
Delete. Deletes the selected annotation object(s). Deleted objects are not copied to the
Windows Clipboard. Therefore, you cannot paste a deleted object.
If you delete all of the annotation objects and then save the annotation, the image will no
longer be annotated, and the annotation file (default extension .ANN) will be deleted.
Tip! You can also press the Delete key on your keyboard to delete the selected object(s).
Select All. Selects all annotation objects for the current image.
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Images menu
Use the Images menu options and toolbar buttons listed below to display images in any of the
records in the set.
Note: If you started displaying images with the cursor in an Image field in an Edit or Display
window, you can navigate among images from that field only.
To see:
The next image in the current
record*

Do this:
Click the Next Image button or choose Images>Next
Image.

The previous image in the current Click the Previous Image button or choose
Images>Previous Image.
record*
A specific image in the current
record*

Choose Images>Jump to Image. When prompted, type
the number of the image you want to see.

All images in the current record*

Click the Thumbnail button or choose Images>Thumbnail.

The first image in the next record

Click the Next Record button.

The first image in the previous
record

Click the Previous Record button.

*Read "current field" instead of "current record" if your textbase has multiple Image fields, and
the cursor was positioned in a particular Image field when you accessed the Images window.
Note: To show or hide the toolbar on the Images window, use the View menu.

Navigational Control Shortcut Menu (Annotations)
Click the right mouse button in the Image Annotation window to display a shortcut menu that
lets you perform the actions listed below. Note that if you right-click while in editing mode on a
Text or Sticky Note object, you will see a text editing shortcut menu instead.
Next Image. Moves to the next image. If you have not saved your current annotation,
you will be prompted to do so.
Previous Image. Moves to the previous image. If you have not saved your current
annotation, you will be prompted to do so.
Jump to Image. Opens the Jump to Image dialog box so you can specify the image to
which you want to jump. If you have not saved your current annotation, you will be
prompted to do so.

Text Editing Shortcut Menu (Annotations)
To access this menu, double-click text to activate editing mode (indicated by a blinking cursor),
then click the right mouse button.
Undo. Select to undo the last operation. Selecting it again performs a Redo operation.
Cut, Copy, Paste. These commands make use of the Windows Clipboard. The Paste
command is available only after you cut or copy text. The pasted text appears at the
cursor position. Note that the standard shortcut keys (Ctrl+X, Ctrl+C, and Ctrl+V) do not
work-- you must use the shortcut menu.
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Delete. Deleted text is not copied to the Windows Clipboard. Therefore, you cannot
paste deleted text. However, you can undo a deletion. Note that you can also delete text
by selecting it and pressing the Delete key on your keyboard.
Select All. Select all of the text in the selected object.

Redacting Images
To "redact" an image means to black out parts of an image to hide them from sight. For
example, you can hide a signature on a document. You can do this by adding a black highlight
or other opaque annotation object. See Adding Annotations for instructions.
Annotations do not alter the image file, so the information is not permanently hidden.
Also, anyone who opens the textbase can turn off image annotation display, so areas that you
have hidden can easily be seen. Because you cannot guarantee that redacted areas will always
be hidden, redaction is useful mainly for printing and then distributing hard copies of images.
For example, after blacking out a signature, print the image and then distribute that hard copy.

Saving Annotations
Annotations do not alter the original image. Each set of annotations is saved as a separate file
(with the default extension .ANN). The objects in the annotation file are "layered" on top of the
associated image for display and printing.
Each image referenced in a textbase can have one annotation file associated with it. You save
annotations for one image at a time, by choosing Annotations>Save Annotation while the
Image Annotation window is active. You are prompted to specify a file name and location. The
default extension is .ANN but you can use a different extension if you prefer.
When an Image window is active, the name of the current annotation file appears on the status
line, in angle brackets, after the image file name.
If an image is used several times in one textbase, every instance of that image in that textbase
will have the same annotations. If the same image is referenced in a different textbase, it can
have different annotations. For example, if Textbase A references MAP.TIF in several different
records, every instance of that image will have the same annotations. If Textbase B references
the same image (MAP.TIF), it may not have the same annotations.

Notes
Annotations are "tracked" in a table, or list, that relates image file name to annotation file
name. To print, back up, clear, merge, or replace annotation lists, choose
Maintain>Manage Image Annotations. These operations affect annotations for all
images in the textbase.
To remove annotations from a particular image and optionally delete the image
annotation file, open the image in the Images window, then choose Images>Remove
All Annotations.
All of the annotations for a single image are stored in one file (default extension .ANN)
outside of the textbase. Annotations for different images are in different files. You supply
the file name when you save the annotations. Be sure to back up these files when you
back up your other important information.
If you rename, move, or delete annotation files, DB/TextWorks will not be able to display
the annotations for that image. If you rename or move the files, you can export, edit, and
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re-import the annotation table to make it match the new annotation file names and
locations. To export a list, choose Maintain>Manage Image Annotations, click the
Back Up Annotation List button, and then name the file. Open it in a text editor and
make changes. To re-import the list, choose Maintain>Manage Image Annotations
and click the Replace Annotation List with File button, then select the edited file.
Annotation list information (but not the actual .ANN files) is included when you use the
Manage Textbases>Dump Textbase command. The list is restored when you use
Manage Textbases>Load New Textbase.

Show or Hide Image Annotations
With the Images window active, choose Images>Show Annotations to show annotations
during display and printing. If an annotation file cannot be found (for example, if an .ANN file has
been deleted), the image is displayed unannotated with no message.
Choose Images>Hide Annotations make annotations not appear during display and printing.
These commands affect all images that have annotations (not just the current image).

Using Passwords to Prevent Users from Editing Annotations
To prevent users from adding, editing, or removing annotations, choose Maintain>Edit
Textbase Structure>Passwords. Enable a Silent password, and clear the User May Annotate
Images check box. You can also assign Field Access passwords that prevent users from editing
annotations.
Anyone who uses this password will not have access to commands such as Annotate Current
Image, Remove All Annotations or any of the Manage Image Annotations commands that
involve writing to an annotation list (clear, replace, merge).
Users will still be able to show or hide annotations.

Remove All Annotations
To remove annotations from the image currently displayed in the Images window, choose
Images>Remove All Annotations. This command breaks the connection between an image
and its annotation file, and gives you the option of deleting the annotation file (default extension
.ANN).
Note that this command is disabled if the current password prohibits annotating images, or if the
textbase was opened as read-only.
When you choose Images>Remove All Annotations, a message appears asking you to
confirm the removal action as well as giving you an opportunity to delete the annotation file.
Click Yes to delete the annotation file (this is the default).
Click No to retain the annotation file and all of its contents, but to disassociate the file
from the current image. The file will no longer be associated with the current image, so
the image will not appear to have annotations. This command is useful if other images
(for example, in a different textbase) share the same annotation file.
Click Cancel to close the message dialog box without any action.
To remove annotations from all images in the textbase
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In a non-Images window, choose Maintain>Manage Image Annotations and click the
Clear Annotation List button.

Manage Image Annotation Lists (Print, Back Up, Clear, Merge,
Replace)
To keep track of image annotations, DB/TextWorks creates a table, or list, to indicate which
annotations go with which images. An annotation list does not contain the actual annotation
objects (arrows, rectangles, text, and so forth). It is a list of "pointers" relating each image file to
its annotation file. Annotation files have the default extension .ANN.
Choose Maintain>Manage Image Annotations to print, back up, clear, merge, or replace lists.
These operations affect all images in the current textbase. For related information, see Saving
Annotations.
Note: If the current password prohibits annotating images or the textbase was opened as readonly, you cannot clear, merge, or replace annotation lists.
Print Annotation List. Print a list of images which contain annotations, and the names
of the annotation files associated with those images.
Back Up Annotation List. Back up the annotation list to a text file, using the default
extension .IAB (Image Annotation Backup). If the original annotation list is lost or
damaged, you can click the Replace Annotation List with File button to import this list
and restore the annotation pointers.
This command also provides a way of sharing annotation files among textbases that
reference some or all of the same images. For example, if Textbase A and B reference
the same image files, and you annotate images in Textbase A, the images in Textbase B
will not be annotated. You could back up the list for Textbase A, then open Textbase B,
choose Maintain>Manage Image Annotations, and click the Merge File into
Annotation List button. Images in both textbases would then share the same
annotations.
Clear Annotation List. Remove all entries from the annotation list for this textbase.
Annotation files are not deleted. Rather, the "links" between images and annotation files
are broken. This command provides a way of removing all annotations from all images in
a textbase.
To remove annotations from a single image, open the image in the Images window, then
use Remove All Annotations.
Note: If you want to delete annotation files after clearing the list, do so manually using
Windows Explorer. You may find it helpful to print the annotation list first, then clear the
list, then delete the annotation files (referring to the printed list, if necessary, to
determine file names and locations). Before deleting annotation files, be sure that no
other textbase uses those same files.
Merge File into Annotation List. Import an annotation list (default extension .IAB) into
the current annotation list. This is a way of merging two annotation lists.
Replace Annotation List with File. Replace the current annotation list with the
annotation list in the specified file (default extension .IAB). This is a way of associating
annotation files with images.
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Backing Up Textbases
To protect against accidental loss or damage, be sure to make backups on a regular basis. You
may want to back up daily or weekly, depending on how often you add, edit, and delete records.
Step 1. Back up Textbase Files.
Use one of the following methods, depending on which version of DB/TextWorks you are using:
If you are using DB/TextWorks, choose Manage Textbases>Copy Textbase, or use
Windows Explorer to back up all of the textbase files (all files with a given name, such as
SALES.*). This backs up the complete textbase, including all records, indexes, structure
information, stop word and leading article lists, validation and substitution lists, elements
stored in the textbase (forms, query screens, sets, and record skeletons), and the
annotation list (which maps annotations to images). If the textbase is ever damaged, you
can restore it using these files.
If you are using DB/TextWorks for SQL, start the Administration program and choose
Back Up & Restore>Back Up Textbases. This copies records, indexes, and other
information from the specified textbase into a .DAT file and creates a copy of all the
textbase files (.CAC, .CBA, .CBS, .INI, and .LOG) in the specified location.
Step 2. Back up User Files, Menu Screens, Images, and Annotations.
In addition to backing up textbase files, you must back up files residing outside of the textbase,
as described below:
User files. User files have the same filename as the textbase, with the extension .TBU
(or .CBU if used with DB/TextWorks for SQL). Each user of the textbase can have his or
her own user file (one per user per textbase). To see where your own user files are
stored, choose Display>Textbase Information. To back up user files, use Windows
Explorer. User files provide a way to store textbase elements outside of the textbase, so
they are only available to an individual user.
Menu screen files. Menu screen files have the extension .TBM (or .CBM if used with
DB/TextWorks for SQL) and are located in the directory you specified when you created
them. To back up menu screen files, use Windows Explorer. If you want a printed
description of a menu screen file, open each menu screen in the Menu Screen Designer
and choose Menu Operations>Print Definition.
Image and annotation files. If your textbase includes references to image files, back up
the image files, using Windows Explorer. If the images are annotated, back up the
annotation files as well. Each annotated image has its own annotation file (default
extension .ANN) stored outside of the textbase. You supply the file name and location
when you save the annotations.
There are other files that you may also want to back up:
Textbase-specific files (.IDI). Located in the user file directory, these files contain
position information about all of the windows and parameters used by operations such
as import and batch⌀modify that are "remembered" from the last time you performed
such an operation.
INMAGIC.INI file. This file contains the options you specify using Tools>Options.
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Step 3. Supplemental procedures [OPTIONAL]
The procedures outlined below can provide an additional measure of security, in case your
backups are corrupted or damaged.
Open a textbase, choose Maintain>Edit Textbase Structure and click the Print
Structure button, then use the Print dialog box to print the structure or save it as a file.
This ensures that you have a description of the fields and settings that make up the
textbase. This file is only a description of the structure, and cannot be used as the basis
of a new textbase. Note: Printing the structure is the only way to see the passwords that
have been defined.
Use Maintain>Edit Textbase Structure, and click Export Structure to write the
textbase structure definition to a text file, which you can use as the basis of a new
textbase. This file contains structure information, not record data.
Use Manage Textbases>Load New Textbase, or Manage Textbases>Dump
Textbase, or File>Export to write records to a text file. You can use Import to load the
records into a new textbase, if necessary. Dump Textbase also includes the image
annotation list in the resulting file.
Choose Maintain>Manage Textbase Elements to export definitions of forms, query
screens, sets, and record skeletons to text files. If an element is accidentally damaged or
deleted, you can import it from the exported file.
Use Print to File to print stop word, leading article, validation, and substitution lists to text
files. If necessary, you can import the lists into a new textbase.
Back up the image annotation list. The image annotation list maps image files to
annotation files. Choose Maintain>Manage Image Annotations and click Back Up
Annotation List. This creates an Image Annotation Backup file (.IAB) which you can
restore using the Merge or Replace buttons in the Manage Image Annotations dialog
box..
Print textbase information. For a summary of information about a textbase, including
the name, creation date, number of records, number of deferred changes, field list,
textbase default settings, and your current user preferences, choose Display>Textbase
Information, then click the Print button in the toolbar or choose File>Print.
Keep a log of textbase activity. A log file records changes to the textbase. A log file
has the same name and location as its textbase, with the extension .LOG. To enable a
log file, edit the textbase structure. To view the log file, choose Maintain>View Log File.
Note that information is continually appended to the log file. Periodically, after reviewing
changes and/or printing the log file, you may want to delete it by choosing
Maintain>Delete Log File. Deleting a log file clears the file contents but leaves an
empty log file in place to record subsequent activity.
Monitor passwords. If you are using passwords to manage different levels of access,
establish a process to monitor password assignments. To see the currently assigned
passwords and settings, print the textbase structure (Maintain>Edit Textbase
Structure>Print Structure).
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Exporting and Importing a Textbase Structure Definition
Note: Exporting the structure definition does not back up record information.
You can export the textbase structure definition to a text file (extension .TBB for DB/TextWorks,
or .CBB for DB/TextWorks for SQL) that describes all of the structure information specified on
the Edit Textbase Structure dialog box and its subdialog boxes. This includes the textbase
name, description, passwords (encrypted), field names, field types, indexing settings, special
filing information, sort order, stop words, leading articles, log file information, maximum users,
validation settings, validation lists, and substitution lists.
You can use the textbase structure definition file as the basis of a new textbase. This is
especially convenient if your original textbase has been damaged. The definition file also
provides a human-readable record of your textbase settings.
Important! Exporting a structure definition is not a substitute for backing up your textbase. You
must either use Manage Textbases>Copy Textbase or Windows Explorer to back up all of the
textbase files (all files with a given name, such as SALES.*); or, if you are using DB/TextWorks
for SQL, start the Administration program and choose Back Up & Restore>Back Up
Textbases. Additionally, you must back up files residing outside of the textbase, such as menu
screens and images. For complete information, see Backing Up Textbases.
To export the structure definition
1. Open a textbase.
2. If the textbase has passwords, enter the Master password when prompted.
3. Choose Maintain>Edit Textbase Structure and click the Export Structure button.
4. When prompted, supply a name for the textbase structure backup file. The file has an
extension of .TBB (or .CBB if you are using DB/TextWorks for SQL).
To import a structure definition
1. Choose File>New Textbase.
2. Assign a name to the new textbase when prompted.
3. On the Create Textbase Structure dialog box, select Import from Textbase Structure
Definition File and click OK.
4. On the Textbase Structure Backup dialog box, select the .TBB or .CBB file that you want
to use as the basis of the new textbase.
5. Now you have a new, empty textbase:
To populate the textbase, use Load New Textbase.
To import forms, query screens, and other elements, choose Maintain>Manage
Textbase Elements.

Dump Textbase command (Manage Textbases menu)
The Dump Textbase command:
Exports (copies) all of the records in the primary textbase, including image annotation
information (the image annotation list, not actual .ANN files).
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Does not include deferred updates, thereby providing a way of backing up a textbase
prior to posting deferred updates. Note: You can print deferred updates to a file to
preserve them.
Creates a text file in Inmagic tagged format. You can load this "dump file" into a new,
empty textbase using the Load New Textbase command.
Dump Textbase is the easiest way to back up records and should be used as part of your
regular maintenance routine. Dump Textbase is also a way of retrieving records if you are
unable to open a damaged textbase. Every attempt is made to extract field information from as
many records as possible. Indexes are not involved in the dump process, nor are user files.
DB/TextWorks needs to be able to open only these files: .TBA, .ACF, .DBS, .DBR, .DBO.
If you are dumping a textbase because you were unable to open a damaged textbase, you
should copy the textbase structure after dumping, load the dumped records into the new empty
textbase, then delete the damaged textbase. If the textbase is open, close it by choosing
File>Close.
To dump records
1. Choose Manage Textbases>Dump Textbase.
2. Select the textbase whose records you want to dump, then click Open.
Note: If the textbase has passwords assigned, you are prompted for the Master
password.
3. On the Specify Dump File dialog box, specify the name and location of the file that will
be created, then click Save to begin the process.

Load New Textbase command (Manage Textbases menu)
Use Load New Textbase to load records into a new empty textbase without checking for
duplicate records or validation. Load New Textbase is intended primarily as a recovery
mechanism, to be used on an empty textbase or in situations where you are sure records will
not be duplicated. If you load into a textbase that contains records, you run the risk of having
duplicate records.
Load New Textbase is normally used to load a "dump file" created with Dump Textbase, to
reconstruct a damaged textbase without changing the contents of any records.
If the textbase is open, close it by choosing File>Close.

Features of Load New Textbase
Adds all of the records to the textbase without checking for matching records
Adds all of the records without checking validation or strict record types
Loads Computed and Automatic fields as if they were text (does not change incoming
values or create new values)
Restores the image annotation list from the dump file.
Assumes the file is in Inmagic tagged format
Uses the Express Import indexing method to ensure the fastest loading
Uses Exclusive textbase access, locking others out of the textbase during the load
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Uses Immediate indexing, locking others out of the textbase during the load [does not
apply to SQL platform]
Places records rejected for structural problems (invalid or duplicate field names, and so
forth) in an exception file, which you can edit and reload
To load records into a new, empty textbase
1. If you have a textbase open, close it by choosing File>Close. All other users must also
close the textbase.
2. Choose Manage Textbases>Load New Textbase to open the Load Inmagic
DB/TextWorks Textbase dialog box.
3. Select a new empty textbase, then click Open.
Note: If the textbase has passwords, you are prompted for the Master password.
4. On the Select Dump File dialog box, select a file to load. The software looks for files with
the extension .DMP, but you can specify a different extension, such as .TXT or .ASC.
Then click Open.
5. [SQL platform only] On the SQL Server Bulk Insert Options dialog box, specify the
maximum records buffer and the SQL Server location. If the SQL Server is located on
another computer, you also need to specify a folder on or accessible to that machine,
where temporary files will be stored during the import.

Recover Textbase command (Manage Textbases menu)
Recovering a textbase involves dumping the contents to an ASCII file, making an empty copy of
the textbase, and loading the ASCII file into the new textbase. You can perform the necessary
steps individually (multi-step recovery), or, if you have enough disk space, the software can
perform them for you (single-step recovery).
Either way, before you begin, post deferred updates in the original textbase and/or export them
to a file (Maintain>Deferred Updates). The Dump Textbase and Recover Textbase
commands ignore any deferred updates.
Here are reasons to use the multi-step recovery procedure instead of the single-step recovery
procedure:
The damage is in the .TBA file (for example, a public form). You need to clear the Copy
Public Textbase Elements check box.
You need to modify the structure before loading the records.
You have insufficient disk space to use the single-step recovery.

Analyze Textbase command (Manage Textbases menu)
The Analyze Textbase command analyzes each record in the specified textbase and generates
a tabular report listing the following information about each field in the textbase:
Max Entries. The maximum number of entries in a single record.
Max Entry Length. The maximum length of a single entry.
Max Record Length. The maximum length of this field in a single record.
The report also includes other information about a textbase, including the total textbase size.
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If any textbase is open, close it by choosing File>Close.
To analyze a textbase
1. Choose Manage Textbases>Analyze Textbase to open the Analyze Inmagic
DB/TextWorks Textbase dialog box.
2. Use the Look in drop-down list to navigate to the folder in which the textbase is located,
select it, then click Open.
3. If the textbase has passwords, you are prompted for the Master password. Type the
password in the Password box, then click OK. You must use the Master password and
have exclusive access to the textbase to analyze it.
4. On the Specify Text File dialog box, do the following:
In the File name box, type a name for the report to be generated.
Navigate the Save in drop-down list to the location where you want to save the
report.
Click Save.
5. Wait while DB/TextWorks analyzes the textbase. While the textbase is being analyzed,
the Analyze Textbase Operation Status dialog box opens.
Note: If you want to stop the process before it is completed, click the Stop Analyze
Textbase Operation button.
6. A completion message appears, detailing the number of records analyzed and the
location of the resulting report. Click OK to open the report.
If you want to view the report again later, use a text editor (for example, Microsoft Notepad) to
open the report file, located in the folder you specified in step 4 (for example, C:\PROGRAM
FILES\INMAGIC\DBTEXTWORKS).

Check Textbase
You can check a textbase to detect and repair problems in the textbase and the user file.
Checking a larger textbase can take a considerable amount of time Before checking a textbase,
you must close it (File>Close).
To check a textbase and optionally repair problems
1. Choose Manage Textbases>Check Textbase.
2. Specify a textbase to check and click Open. If the textbase has passwords, you will have
to supply the Master password. You must also have exclusive access to the textbase.
3. Select Check User File Only if you are having problems using a form, query screen,
set, or record skeleton saved in your user file, and you do not have the time to also
check the textbase. Checking only the user file is much faster than checking a textbase.
4. Select Repair Structural Problems to fix problems in the textbase and user file. See
the Note about repairing user files. Check Rebuild Damaged Indexes to rebuild indexes
found to be damaged during the check, so they accurately reflect information in the
textbase. Rebuilding an index can take a considerable amount of time. Specify a value
between 1 and 100 to indicate the maximum number of Term and/or Word indexes to
rebuild. This setting prevents the rebuilding of indexes if too many are damaged.
Note: You cannot rebuild a damaged index if Check User File Only is selected.
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5. Specify a name and location in the Specify Problem Report File dialog box for the report
file that will be created (default extension .CHK).
6. After the check is done, DB/TextWorks displays the report file, which describes any
problems found and suggests how to fix the problems. Perform the suggested repair
activities using DB/TextWorks and run Check Textbase again, to ensure the textbase is
sound.
7. If the report file lists serious errors that it could not fix, you may need to recover the
damaged textbase.

What Can and Cannot be Fixed
One of the things that Check Textbase reports is if the keys in any index are out of
sequence. This may help you detect changes in international filing. In the example
below, <key> represents the entry which is out of order:
***Term index node 5, field 'SUBJ', key 53=<key>
key is not sorted in correct sequence. Index rebuild recommended.

Choose Maintain>Rebuild a Field Index and rebuild the Term and/or Word index for
that field, or run Check Textbase again with the Rebuild Damaged Indexes check box
selected.
Repair Structural Problems can clear the abort message "The textbase files are in an
inconsistent state due to an abort..." This message occurs every time you open a
textbase if the computer was rebooted or lost power while maintenance activities were
being performed on that textbase. You should not perform any maintenance activities
(for example, editing, importing, batch modify) until the problem has been resolved.
The only way to eliminate this message is by running Check Textbase and selecting the
Repair Structural Problems option. If no problems are found, the "abort" message will
be removed. You may have to rebuild some indexes and run Check Textbase again in
order to clear the message.
Some problems cannot be repaired. If there are any problems that have not been fixed,
you may need to recover the textbase.
Check Textbase does not check the contents of records or textbase elements or the
validity of index keys.

A note about repairing user files
If you suspect that a user file is damaged, you can restore the user file (.TBU) from a backup.
If a recent, good backup is not available, run Check Textbase and select both the Repair
Structural Problems and Check User File Only options. If the report file generated by Check
Textbase indicates that the number of problems and the number of repairs is the same, all of
the problems have been corrected and you can continue to use your user file.
If Check Textbase is unable to repair the user file, and you do not have a good backup, choose
Maintain>Manage Textbase Elements, and export all private elements (any element in the list
that is not followed by the word "public") to a file. Do this separately for each type of element
(forms, query screens, and so forth). Then close the textbase and delete the damaged user file.
Open the textbase again, choose Manage Textbase Elements, and import the exported files
into the new empty user file (which was created automatically when you opened the textbase).
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Dead URL Link Checker
Use the Dead URL Link Checker to check the status of URL links recorded in a textbase. You
can do this for a set of records in a textbase or for the whole textbase. Status information about
whether a URL link still works is written to another field in the same textbase. From the
information provided after running the Dead URL Link Checker, you may do whatever you deem
appropriate (for example, you may have to correct the URL address or you may decide to delete
a non-working address).
To check the status of URL links recorded in a textbase
1. Open the textbase for which you want to check the status of the URLs recorded in that
textbase.
2. If you only want to check a subset of records, find those records by doing a query first.
3. Choose Tools>Dead URL Link Checker to open the Dead URL Link Checker dialog
box.
4. In the Field containing URL to check box, select the field that contains the URLs you
want checked. Note: The Dead URL Link Checker assumes that each entry in the field
is a separate URL.
5. In the Field to receive URL status box, select the field to which status information
about a URL link should be written. Note: This field cannot have validation.
6. Depending on if you have a subset of records or want to check all the records in the
textbase, select either Check Current Record Set or Check Entire Textbase.
7. Depending on whether you want to retain or replace previous information in the status
field, select either Add to Existing Status or Replace Existing Status.
8. Click OK, then click Yes to confirm the requested action.
9. Wait while the Dead URL Link Checker performs the requested action. Note that if your
textbase or set is large and has many URL links to check, this process may take a while.
10. Review the message box that displays summary information for the completed action (or
canceled action, if you stopped the process before it completed). Click OK to dismiss the
message box.
11. To see the status of the URL links checked by the Dead URL Link Checker, look at the
field in the textbase that you designated to receive URL status information (step 5). Note
that each time you perform this check for a textbase, the software adds the latest status
information as a new entry at the beginning of that field or replaces the information in the
field, depending on your selection in step 7.

About the status message
Each status message tells you the following:
URL checked by the Dead URL Link Checker
Date and time the URL was checked
The status of the checked URL
Details for the status of the checked URL
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Examples:
URL: 'http://www.inmagic.com'
Checked: 12/1/2008 2:29:56 PM
Status: Live
Details: HTTP status 200 - Usual success response
URL: 'http://www.inmgc.com'
Checked: 12/5/2008 3:19:01 PM
Status: Error
Details: Failed to send HTTP request (WinHttpSendRequest)
The following table lists the status values that the Dead URL Link Checker can return:
Status

Details

Explanation

(Note that these are only examples of some of the detail messages you may receive.)
Dead

HTTP status 404 - Not found

The link is not usable.

Error

Failed to send HTTP request
(WinHttpSendRequest)
Failed to establish HTTP
connection (WinHttpConnect)

The link has errors that prevent successful testing.
Typically, this indicates syntax errors.

Live

HTTP status 200 - Usual success The link is live and usable.
response
HTTP status 204 (Not Content) Success code group

Live but
restricted

HTTP status 401 - Not authorised The link is live and usable, but requires HTTPS, or
HTTP status 403 - Forbidden;
forbids GET/POST, and so forth.
server refused request
HTTP status 405 - Request
method (POST or GET) is not
allowed on the requested
resource
HTTP status 406 - Not accepted

Moved

HTTP status 301 - Moved
HTTP status 302 - Moved
temporarily

The link exists, but has moved (redirected). You may
want to substitute the new URL.

Problem
reported

HTTP status 500 - Server error

The link may be live, but an HTTP error was
reported.

Tip! We suggest you recheck records that have a status of "Error" or "Problem reported" if the
records were in a larger set of records. Status results for individual records within a large set of
records may be inaccurate because of other factors (for example, if your Internet connection is
busy). Try again with a smaller set of records or just the individual records.
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Copying a Textbase
Use the Copy Textbase dialog box to copy a textbase to a different folder, or within the same
folder under a different name. This operation requires exclusive access to a textbase (no one
else can have it open), and the Master password, if the textbase has passwords.
To copy a textbase
1. Close the textbase (File>Close).
2. Choose Manage Textbases>Copy Textbase.
3. In the Copy Textbase dialog box:
Existing Textbase. Specify the full path and name of the textbase you want to copy.
New Textbase. Specify the full path and name of the textbase you want to create.
Note: The Copy Textbase command will not create a new folder for you. If you type the
name of a folder that does not exist, a textbase by that name will be created. For
example, if you type C:\OOPS, a textbase called OOPS will be created. Also note that
you cannot overwrite an existing textbase.
Click OK.
Note: If you gave the textbase a new name, and a user file of that name does not exist, the
software copies the user file to the local user file folder.
Example #1 - Copy in the same folder
Copy a textbase called Sales in C:\DIR to Sales2 in C:\DIR.
Existing Textbase: C:\DIR\SALES
New Textbase: C:\DIR\SALES2
Example #2 - Copy to a different folder
Copy a textbase called Sales from the folder C:\DIR to the folder C:\BAK.
Existing Textbase: C:\DIR\SALES
New Textbase: C:\BAK\SALES

Renaming a Textbase
Before renaming a textbase, you must close it (File>Close).
To rename a textbase
1. Choose Manage Textbases>Rename Textbase.
2. In the Rename Textbase dialog box:
Existing Textbase. Specify the full path name of the textbase that you want to rename.
For example, to rename a textbase called Old, type: C:\DIR\OLD
New Textbase. Specify the new full path name. For example, to call the new textbase
New, type: C:\DIR\NEW
Click OK, then respond to the confirmation prompts.
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3. If you renamed a secondary textbase, open the primary textbase (the one that
contains the Link field), and edit the textbase structure to redefine the link definition.
This command automatically renames the local textbase user file. If a textbase is on a network
and is used by others, remind anyone else who uses the textbase to rename their
corresponding user file, using Windows commands. User files are stored locally, so each user
must rename his/her own user file.
Note: This command cannot be used to move a textbase to a different drive or server.

Deleting a Textbase
Before deleting a textbase, you must close it (File>Close).
To delete a textbase
1. Choose Manage Textbases>Delete Textbase.
2. In the Delete Textbase dialog box, type the full path and name of the textbase you want
to delete or click the Browse button to navigate to the textbase.
3. Decide whether to delete the user file. User files contain locally-stored forms, query
screens, sets, and skeletons:
Select the Delete user file for this textbase (privately stored forms, query screens, sets, &
skeletons) check box if you want to delete the user file.
Clear the Delete user file for this textbase (privately stored forms, query screens,
sets, & skeletons) check box to preserve the user file. For example, if you just copied a
textbase to a new location, and you are now deleting the old textbase, do not delete its
user file.
Click OK, then respond to the confirmation message and completion message that
appear.

List Textbases
This command pertains only to DB/TextWorks for SQL.
Use this command to list each textbase on the current SQL Server. The Textbase List window
displays the location and name of each textbase and the corresponding SQL database name.
The Textbase List window also displays information about the current SQL Server. Note that
more detailed information about the SQL Server is available using the Textbase Information
command.
To display a list of textbases on your SQL Server
1. Choose Manage Textbases>List Textbases. The Textbase List window opens, listing
the textbases on your SQL Server.
2. Use the toolbar buttons in the Textbase List window to:
Find information in the list. Click the Find button to locate any text or numeric
information in the list, such as a textbase, folder, or SQL Server database name.
Print the list. Click the Print button to print the list to a printer.
Save the list to a file. Click the Print button and print the list to a text file (.txt).
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Clear Textbase Record Locks (Manage Textbases menu)
This command pertains only to DB/TextWorks for SQL.
Clear Textbase Record Locks should be run as part of routine maintenance. This function
checks for records left locked by SQL Server when a user aborted or lost power or connection
while editing a record, and unlocks the records. For example, if the power goes out while you
have records open in the Edit Window, those records will remain locked by SQL Server.
Clearing locks is safe because this function requires exclusive access to the textbase, meaning
you cannot clear a lock on a record held by another user.
If you do not clear locks, a user attempting to edit a locked record will be denied access,
whether it is an active lock held by another user editing that record, or a non-active lock that
was not previously released. In the latter case, that record remains locked for 20 minutes, at
which time the lock is automatically cleared. You can change the default 20-minute value by
adding the RecordLockInterval= parameter to the [Advanced] section of the InmCSrv.INI
file. The time must be entered in milliseconds (the default is RecordLockInterval=1200000).
To unlock records in a textbase
1. If the textbase is open, choose File>Close.
2. Choose Manage Textbases>Clear Textbase Record Locks to open the Select
Inmagic Textbase dialog box.
3. Select the textbase whose record locks you want to clear, then click Open. You must
have exclusive access to the textbase.
Note: If the textbase has a Master password, you will be prompted for it before the
records can be unlocked. If you are using Windows Authentication, you must also have
either sysadmin privileges or be a member of the SQL Server fixed database role of
db_owner.
3. If the textbase has any locks to clear, a confirmation message appears. Review the
message, then click Yes to unlock the record(s).
4. Click OK.

Organizing Menu Screen Files
Many people use just one menu screen, which contains the names of all of their textbases or a
single top-level menu screen with menu items that open other menu screens. However, you
may want to create several different menu screens. To switch between the various menu
screens, choose Menu Screens>Select.
You can also use Microsoft Windows to create separate shortcuts, each of which references a
different menu screen file, using the /m command-line switch. When you specify the shortcut
properties, include the full path name of the DB/TextWorks executable file (DBTEXT32.EXE)
followed by the /m switch and the name of the menu screen file. For example, to open a menu
screen called SAMPLE1, use this command:
C:\ DBTEXT\DBTEXT32.EXE /M SAMPLE1

Because DB/TextWorks accepts both / and - in command line arguments, menu screen names
containing a hyphen must be enclosed in quotation marks. For example, to open a menu screen
called SALES-NH, use this command:
C:\ DBTEXT\DBTEXT32.EXE /M "SALES-NH"
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If the software is installed on a network server, and all of the workstations will be accessing the
same set of textbases that are also located on the server, the administrator may want to create
one menu screen file, named DBTEXT.TBM, and place it in the software installation folder on
the server. This special feature allows all users to share the same menu screen file.
If the software is installed on your local hard disk, or if you typically use textbases stored on
your local hard disk, a personal DBTEXT.TBM file can be created in the Start In folder
associated with the program icon or shortcut.

Where DB/TextWorks Looks for Menu Screen Files
Menu screen files have the extension .TBM. You can move, copy, or delete them just as you
would any other file (for example, using Windows Explorer). You can rename menu screen files
freely, and move or copy them from one location to another. If you move a menu screen file,
and the Path setting property is set to Do not retain path, then all of the files (for example,
textbases and images) should also be moved to the new menu screen file location.
When you start DB/TextWorks, the software attempts to find a menu screen file (.TBM) to use:
If a menu file has been specified on the command line, that menu is used.
If no menu file has been specified on the command line, the software looks in the
INMAGIC.INI file to find the menu file that was most recently selected.
If the INMAGIC.INI file does not contain a menu screen selection, the software looks for
a file called DBTEXT.TBM in the Start In folder associated with the icon or shortcut used
to start the software.
If there is no DBTEXT.TBM file in the working folder, the software looks for the file in the
folder in which the software was installed.
If all of these steps fail, a menu screen will not be used.

Manage Textbase Elements (Copy, Delete, Export, and so
forth)
Forms, query screens, sets, and record skeletons are referred to as textbase elements. Choose
Maintain>Manage Textbase Elements to:
Rename an element
Delete an element
Export and import elements
Print an element definition
The Now Managing list determines whether the Currently Saved list shows forms, screens, sets,
or skeletons.
Related Operations
To perform these other operations, use the appropriate Save As dialog box:
Copy or move elements
Change the description or location
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Printing Element Definitions
You can print a description of a form, screen, set, or skeleton, or save it in a text file that you
can view or print using a text editor or word processor. You can print multiple definitions at once,
or save multiple definitions in one text file. Definitions provide a way of seeing and saving
information about an element, and are especially helpful for analyzing problems in a form or
query screen.
Important! A definition printed to a file is not formatted for import, and therefore is not a way of
backing up or sharing elements among users. To back up or share elements, use the Export
and Import buttons in the Manage Textbase Elements dialog box.
Definitions include information such as the element name, textbase name, optional description,
and creation date and time. Elements saved in the textbase file include the word (public) after
the name. Query screen definitions also include screen preference settings and a list of boxes
and their attributes. Form definitions contain similar information, including the form's purpose
(display, edit, report window, and/or printing). Record skeleton definitions contain a list of fields
with record skeleton information in them. Set definitions include the number of records found
and the Command equivalent of the search criteria that produced the set.
Note that a set definition does not include record information. To export copies of the records in
the set, load the set, then use Export from the File menu to export the current record set.
To print a definition
1. Choose Maintain>Manage Textbase Elements.
2. Select an element type in the Now Managing drop-down list.
3. Select one or more items from the Currently Saved list.
4. Click Print to open the Print dialog box.
To send the definition(s) to a printer, select the print options you want, then click
OK.
To save the definition(s) in a text file, select the Print to file check box and click
OK. In the Save File As dialog box, specify a location and a file name. The file
extension .TXT is used by default. Click Save.
Note that you can also print a definition from within the appropriate designer.
In the:

Choose:

Form Designer

Form Operations>Print Definition

Query Screen Designer

Screen Operations>Print Definition

Record Skeleton Editor

Record Skeletons>Print Skeleton

Menu Screen Designer

Menu Operations>Print Definition

Print to File / Sharing Information
You can use various commands to copy record and non-record information to a file, or to copy it
to the Windows Clipboard so you can paste it into another application.
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Non-Record Information
To print non-record information to a text file, use the commands shown in the table below, and
check Print to file in the Print dialog box, then name the file when prompted. When you print to
a file, no font information is included.
To Print:

Choose:

Validation lists

Maintain>Edit Lists>Validation Lists>Edit List>Print List

Substitution lists

Maintain>Edit Lists>Substitution Lists>Edit List>Print List

Stop word lists

Maintain>Edit Textbase Structure>Stop Words>Print List

Leading article lists

Maintain>Edit Textbase Structure>Leading Articles>Print List

Textbase structure

Maintain>Edit Textbase Structure>Print Structure

Log files

Maintain>View Log File, then File>Print

Image annotation list

Maintain>Manage Image Annotations>Print Annotation List

Textbase information

Display>Textbase Information, then File>Print

Deferred updates

Maintain>Deferred Updates>Print Deferred Updates

Field indexes

With cursor in query box, choose Edit>Browse Choices>Print
List

Descriptions of menu
screens

Menu Screens>Design, select menu screen, then Menu
Operations>Print Definition

Descriptions of forms,
query screens, sets,
and record skeletons

Maintain>Manage Textbase Elements>Print

Printing to a file does not always produce a file that you can import into another textbase. The
following table indicates backup commands where necessary.
To Back Up:

Choose:

Textbase structure

Maintain>Edit Textbase Structure>Back Up Structure

Image annotation list

Maintain>Manage Image Annotations>Back Up Annotation
List

Descriptions of forms,
query screens, sets,
and record skeletons

Maintain>Manage Textbase Elements>Export

Formatted Record Information
To copy formatted record information to a file as Plain Text, RTF, or HTML using the currently
selected Report window form, use File>Write Report to File. You can import the resulting file
into another application, or put the HTML page on your Web site.
To copy a report to the Windows Clipboard as Plain Text so you can paste it into another
application, use Edit>Copy Special>Report.
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To copy a record to the Windows Clipboard as Plain Text so you can paste it into another
application, use Edit>Copy Special>Record.
To create a file containing printer codes for the destination printer, which you can later copy to
that device, do a search that finds the desired record(s), and choose File>Print. In the Print
dialog box, select the destination printer and check the Print to file box. Name the file when
prompted. This is useful when your computer is not connected to a printer. In general, the
resulting file cannot be imported into another application or printed on a different printer,
because the file contains specific printer codes.
Note: To ensure that extended characters such as accented letters are translated properly,
choose Tools>User Preferences and check or clear Read/write extended characters in MSDOS format.

Unformatted Record Information
To copy unformatted record information to a file as Plain Text (ASCII), use File>Export. You
can import the resulting file into another textbase or application.
To combine fields, change field names, and make other changes, you can emulate Inmagic
tagged format with a form, instead of using Export.
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Initialization Files
You can use initialization (INI) files to customize DB/TextWorks on both the desktop and the
Web:
DB/TextWorks requires Inmagic.INI and DBText.INI (or INMCSRV.INI if you have the
SQL platform). You can optionally use <textbase>.INI for individual textbases.
WebPublisher PRO requires only DBTWPub.INI (or ICSWeb.INI if you have the SQL
platform). You can optionally use Inmagic.INI, DBText.INI (or INMCSRV.INI), and
<textbase>.INI for individual textbases.
Each INI file has a specific purpose:
Inmagic.INI. Includes settings for both DB/TextWorks and WebPublisher PRO. It is
stored in each user's personal user file path folder and includes personal customizations
and preference settings. To affect WebPublisher PRO, a copy of this file must reside in
the WebPublisher PRO installation folder. Note: Platform-specific section names for the
SQL or non-SQL version of the software are different where they need to coexist in the
same file, e.g., [Window Placements] vs. [Content Server Window Placements].
DBText.INI (or INMCSRV.INI if you have the SQL platform). Includes configuration
settings for the software (for example, date settings). It is stored in the DB/TextWorks
installation folder. It also contains some settings that can be used with WebPublisher
PRO; however, a copy of this file must be placed in the WebPublisher PRO installation
folder for the settings to apply on the Web.
DBTWPub.INI ( or ICSWeb.INI if you have the SQL platform). Stores information
specific to WebPublisher PRO, including where it looks for textbases and images. The
file is located in the WebPublisher PRO installation folder.
Textbase.INI Files. Each textbase can have its own <textbase>.INI file with the same
name and location as the textbase. For example, the Loans textbase can have a
Loans.INI file. You can create or edit this file using a text editor.
WPEngMsg.INI. Lists all of the WebPublisher PRO messages that can be copied to
another INI file and modified. It is located in the WebPublisher PRO installation folder.
Most parameters can be set to either 1 (on) or 0 (off).

Inmagic.INI
Inmagic.INI is stored in each user's personal user file path folder and includes personal
customizations and preference settings.
The following table lists parameters by section. Entries that must be set by editing the
Inmagic.INI file (when DB/TextWorks is not open) are in italics; other options can be set using
DB/TextWorks controls and menu options.
For options that are set equal to a value, =1 turns the option on, =0 turns it off.
Important! If you have a dual-boot machine, make sure the Inmagic.INI file for each operating
system has the same user file directory, and other settings you want to share across platforms
(for example, SpacedRelOps=).
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Tip! For WebPublisher PRO, you can use the Options dialog box in DB/TextWorks to select
most of the desired settings, then copy the Inmagic.INI file to the WebPublisher PRO installation
folder on the HTTP server machine and restart IIS (the World Wide Web Publishing Service)
using the Services option through the Computer Management window.
These settings only affect DB/TextWorks unless otherwise noted.
Note for SQL platform: Platform-specific section names for the SQL or non-SQL version of the
software are different where they need to coexist in the same file, e.g., [Window Placements] vs.
[Content Server Window Placements].

[Inmagic DB/TextWorks] or [Inmagic Content Server]
The following options always appear in this section of Inmagic.INI:
Parameter

Purpose

AutoReport=

Controls the Always use this option without asking setting (choose
Tools>Options>Display in DB/TextWorks).
0 = Display the Select Search Results Window dialog box (default)
1 = Use the selected window automatically without asking

AutoReportOpt=

Controls the After a search, view records in setting (choose
Tools>Options>Display).
0 = Report window (default)
1 = Edit window
2 = Display window
3 = Do not display records

AutoURLDetect=

Controls the Detect URLs, e-mail links, etc. and convert to
hypertext links setting (choose Tools>Options>Display).
0 = Do not convert to hypertext links
1 = Convert to hypertext links (default)

CustomColor1=
through
CustomColor16=

Stores the 16 colors that appear on the Custom Colors dialog box.

Edge3D=

Controls the 3-D box borders setting (choose
Tools>Options>Display).
0 = Do not use 3-D borders (default)
1 = Use 3-D borders

EmptyTBNotify=

Controls the Notify when opening empty textbase setting (choose
Tools>Options>General).
0 = Do not display message when opening empty textbase
1 = Display message when opening empty textbase (default)

ExportQBEtoHTMLOption= Controls whether exported HTML query and menu screens use
<noscript> sections with links instead of buttons, to make the pages
accessible to the visually impaired. This parameter affects commands
such as Next Record, New Search, and so forth.
0 = Normal query and menu screen
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1 = No scripts
2 = Normal section and <noscript> section
There are other ADA compliance settings for WebPublisher PRO that
you can specify in the DBTWPub.INI (or ICSWeb.INI) file.
This option does not appear in Inmagic.INI unless you add it explicitly
using a text editor.
ExpressImportBuffer=

Normally, Express Import appropriates about 5MB of memory to
provide maximum speed. However, if you find Windows is swapping a
lot when using Express Import, you can set the size of the import buffer.
For example, if you specify ExpressImportBuffer=4096, then the buffer
will be 4096 KB (4MB) even if there is more memory available (and less
if that much memory is not available). You can also specify more than
5MB if you find that it improves load speed on your computer. This
option does not appear in Inmagic.INI unless you add it explicitly using
a text editor.

IgnoreAccents=

Controls the Ignore accents on extended characters setting (choose
Tools>Options>Search).
0 = Do not ignore accents when searching (default)
1 = Ignore accents when searching
This setting affects DB/TextWorks and WebPublisher PRO.

Inclusive=

Controls the Use inclusive search option for multiple fields setting
(choose Tools>Options>Search).
0 = Do not use the inclusive search option
1 = Use the inclusive search option (default)
This setting affects DB/TextWorks and WebPublisher PRO.

InitialWindow=

Controls which window appears when you open a textbase (unless the
menu screen in use specifies a different initial window).
1 = Query window (default)
2 = Command Query window
3 = Saved Queries window
4 = Edit: New Record window
Note: If the textbase contains no records, DB/TextWorks opens the
New Record window regardless of which initial window is specified
(unless EmptyTBNotify=0).
Controls the Insert date as new entry setting (choose
Tools>Options>General).
0 = Insert date at cursor position
1 = Insert date as new entry (default)

InsertNewEntry=

LargeButtons=

Controls the Large buttons on toolbar setting (choose
Tools>Options>Display).
0 = Do not use large buttons (default)
1 = Use large buttons

LDate=

Controls the Insert date using long format setting (choose
Tools>Options>General).
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0 = Use the short date format (default)
1 = Use the long date format
LinkP=

Controls the Secondary textbase password setting (choose
Tools>Options>General).
0 = Use the Silent password and do not show warning (default)
1 = Always prompt for password

MaxMRU=

Controls the Recently used file list setting (choose
Tools>Options>General). The default is 4. This affects the number of
recent textbases on the File menu.

NewData=

Controls the Show deferred changes in reports and display setting
(choose Tools>Options>General).
0 = Show old version of record (default)
1 = Show record with deferred changes

PrintUsing=

Controls the Always use this option without asking setting (choose
Tools>Options>General).
0 = Display the Form Used to Print Report dialog box if the Report,
Display, or Edit window is active (default)
1 = Use the selected print form automatically without asking

PrintUsingOpt=

Controls the Print using setting (choose Tools>Options>General).
0 = Use the Report Printing form
1 = Use the form for the active Report, Display, or Edit window

RptBorderWidth=

Sets the width of the selection box in the Report window. If you use this
feature, the tops of characters may be "whited out" when you move the
selection box off a record. A value somewhere between 3 and 5 will
increase the visibility of the selection box without obscuring the records
in the report. This option does not appear in Inmagic.INI unless you add
it explicitly using a text editor.

SilentP=

Controls the Primary textbase password setting (choose
Tools>Options>General).
1 = Use the Silent password and show warning (default)
2 = Use the Silent password and do not show warning
3 = Always prompt for password

SortFieldLists=

Controls the Sort textbase field lists alphabetically setting (choose
Tools>Options>Display).
0 = Field lists appear in textbase structure order (default)
1 = Field lists are sorted alphabetically

SMTPServerName=

Specifies the name of SMTP server.

SMTPIPAddress1=
SMTPIPAddress2=
SMTPIPAddress3=
SMTPIPAddress4=

Specifies the four parts of the SMTP Server IP address.

SMTPUsername=
SMTPPassword=

Specifies the username and password to pass to an SMTP server that
requires authentication. This option does not appear in Inmagic.INI

270

Inmagic DB/TextWorks v13 Printed Help

DB/TextWorks Files
unless you add it explicitly using a text editor.
SpacedRelOps=

Controls whether spaces are required around search operators (colon,
slash, ampersand, and so forth).
0 = Characters are always interpreted as search operators, for
example, Boolean OR (default)
1 = Characters are only interpreted as search operators if surrounded
by spaces
We recommend setting this parameter =1, so users can search for
dates such as 12/31/98 and URLs such as http://www.inmagic.com
without having to use the surrounding quotes.
This setting affects DB/TextWorks and WebPublisher PRO.
This option does not appear in Inmagic.INI unless you add it explicitly
using a text editor.

SwitchDeferredOption=

Controls the If indexes are busy setting (choose
Tools>Options>General, the Deferred Indexing group). This setting
tells DB/TextWorks what to do if it cannot save a record using Shared
Immediate indexing.
1 = Do not save record and suggest switch to Deferred indexing
2 = Silently save record using Deferred indexing
3 = Save record using Deferred indexing and display message
(default)

SynchWin=

Controls the Synchronize Windows setting on the Window menu.
0 = Do not synchronize windows (default)
1 = Synchronize windows

TabToHTMLBoolean=

Controls whether the Tab order on Web query screens includes
Boolean drop-down lists:
0 = The Tab order skips AND/OR/NOT drop-down lists. The only way
to change the state of the drop-down list is with the mouse.
1 = Tab behavior corresponds to the Allow tabbing to Boolean
query buttons setting (choose Tools>Options>Search). (default)
2 = Tab goes to AND/OR/NOT drop-down lists.
If you want to modify this setting, you must edit the Inmagic.INI file
when DB/TextWorks is not running, before you use the Export Query
Screen to HTML command.
When TabToHTMLBoolean=1, any query screen that has already been
exported to HTML must be re-exported if you change the Allow
tabbing to Boolean query buttons setting (choose
Tools>Options>Search).

TabToQBEButton=

Controls the Allow tabbing to Boolean query buttons setting (choose
Tools>Options>Search).
0 = Pressing the Tab key skips AND/OR/NOT buttons. The only way
to change the state of the buttons is with the mouse.
1 = Pressing the Tab key moves to AND/OR/NOT buttons. Press the
spacebar (in DB/TextWorks only) to change the state of a button.
(default)
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If you accept the default setting of TabToHTMLBoolean=1, then the Tab
order in exported HTML query screens for use with WebPublisher PRO
is controlled by TabToQBEButton= parameter.
TBMenu_Path=
TBMenu_File=

The folder and file name for the current menu screen.

UseSMTP=

Controls the Access e-mail services using setting (choose
Tools>Options>E-mail).
0 = Use MAPI (default)
1 = Use SMTP

[FormSettings]
The default form and query screen settings (for example, form and box background colors) are
specified using the Form Defaults dialog box (choose Tools>Options>Display>More Defaults
in DB/TextWorks).
These settings affect DB/TextWorks and WebPublisher PRO.
Parameter

Purpose

BoxBkgColor=

Specifies the box background color if no color is specified in the form or
screen. Applies to reports, expanded displays, edit/delete pages, query
screens, and text boxes on menu screens. Type R,G,B (Red, Green, Blue)
values separated by commas (for example, 255,255,128 for yellow).

FormBkgColor=

Specifies the page background color if no explicit color is specified in the
form or screen. Type R,G,B (Red, Green, Blue) values separated by
commas (for example, 255,255,128 for yellow).

ApplyBkgOpt=

Controls whether FormBkgColor= and BoxBkgColor= are applied to forms
and screens with no explicit background colors.
1 = FormBkgColor and BoxBkgColor are applied to saved forms with no
explicit background color
2 = FormBkgColor and BoxBkgColor are used when creating new forms
and query screens in the Form Designer, Query Screen Designer, or Menu
Screen Designer

UndoLevels=

Specifies the number of Undo/Redo levels supported in the Form Designer
and Query Screen Designer. Set it to 0 (zero) to turn off the Undo feature.
Default is 4; maximum is 50.

UndoBufferInitSize= Specifies the initial size of the memory buffer that holds each snapshot of
the form state to support Undo and Redo. Each time the memory buffer
size needs to increase to accommodate the form state, it grows by this
number of bytes. Default is 4096.

[Highlight]
Parameter Purpose
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Display=

Controls the Display highlighting setting (choose Tools>Options>Search in
DB/TextWorks).
1 = Reverse Video (default)
2 = Color (in this case, a Color= line also appears)
3 = None
This parameter affects search highlighting behavior of the single-record display for
both DB/TextWorks and WebPublisher PRO. It also affects multi-record display for
DB/TextWorks. Note that in WebPublisher PRO, reverse video equates to bold.

Printing=

Controls the Print highlighting setting (choose Tools>Options>Search).
1 = Bold (default)
2 = Italic
3 = Bold Italic
4 = Underline
5 = None
This parameter also affects the search highlighting behavior on multi-record reports
in WebPublisher PRO.

[Entry Mark Format]
The numeric value for the delimiter selected using the Field entry delimiter setting (choose
Tools>Options>Display in DB/TextWorks).

[Box Font]
The Text Font settings (choose Tools>Options>Display).

[Title Font]
The Label Font settings (choose Tools>Options>Display).

[Designers]
The location on the screen of the dialog boxes in the designers.

[Imaging]
Entries in italics must be set by editing the Inmagic.INI file (when DB/TextWorks is not open).
Other options can be set using various DB/TextWorks controls and menu options.
Parameter

Purpose

Despeckle=10

This number can be anywhere from 0 to 100, and specifies how aggressive
the despeckling procedure should be. Higher numbers take out more
extraneous dots, but may wind up taking out some real ones too if the image
was not sharp to begin with.

FastPrint=0

Controls fast image printing.
0 = Do not use fast image printing (default)
1 = Use fast image printing
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May cause printer errors or problems with certain images or printers. If you
receive printer errors, change the line back to FastPrint=0.
Controls the Image drive(s) setting (choose Tools>Options>Imaging).

ImageDrive=

MultiplePageImage= Controls the Support multiple page TIFF images setting (choose
Tools>Options>Imaging).
0 = Only first image is displayed
1 = All images are displayed (default)
PreferenceFlags=0

Causes the Thumbnail window to use less memory. Aspect ratios may not be
preserved.

ScaleToGray=1

Specify if Scale to Gray is selected for the Images, Thumbnail, and Image
Annotation windows.
0 = Scale to Gray is not selected
1 = Scale to Gray is selected

ThumbNailColumns= The Columns value specified using the Set Rows and Columns setting in the
Thumbnail window.
ThumbNailRows=

The Rows value specified using the Set Rows and Columns setting in the
Thumbnail window.

Win3xFileName=

Controls the Support only short filenames for images setting (choose
Tools>Options>Imaging).
0 = Image file names can contain spaces (default)
1 = Image file names cannot contain spaces
Set this parameter =1 only if the Image fields contain text other than the
number of images after the image file name.

WinFitFlags=

Controls the Fit image to window setting (choose
Tools>Options>Imaging). The default value is 2, which corresponds to
Scale proportionally if necessary with the Leave small images original
size check box cleared.

XipPrint=1

Takes advantage of Xionics XipPrint enabled printers.

The following options reflect the current settings of the matching options on the Annotation
Properties dialog box in the Image Annotation editor:
Parameter

Purpose

BackColor=

Background Color

FontFace=

Font (default is Times New Roman)

FontParams=

Other font information, including size. DB/TextWorks makes a "best guess" for
the font size the first time you annotate an image, then saves the specified font
size.

ForeColor=

Foreground Color

LineStyle=

Line Style

LineThickness= Line Thickness
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[Window Placements] or [Content Server Window Placements]
This section is called [Content Server Window Placements] if you have the SQL platform, or
[Window Placements] for the non-SQL version. These settings control the window size, position,
and maximization settings for windows that are not textbase-specific (for example, the Menu
Screen window or the List Textbases window).

[WebPublisher] or [ICSWeb]
The [WebPublisher] section, or [ICSWeb] for the SQL platform, must be added manually. The
parameters in this section affect WebPublisher PRO and the Export Query Screen/Menu
Screen/Editing Form to HTML commands in DB/TextWorks.
If you plan to use any of the following parameters, be sure to either place a copy of the
INMAGIC.INI file in the WebPublisher PRO root folder, or modify the copy already located there.
Important! If you change any of the following parameters after query or edit pages have been
exported to HTML from within DB/TextWorks, you must re-export those pages. For edit pages
that are dynamically generated by WebPublisher PRO, you must restart your World Wide Web
publishing service after changing a parameter.
Parameter

Purpose

AutoIncludeValidationLinks= On edit forms, controls whether the box labels for fields with
validation lists are turned into hypertext links that display the
validation list. For this parameter to affect static HTML edit forms,
it must be set when DB/TextWorks is not running (and before you
export the edit screen to HTML).
0 = Only boxes with Validation specified in the Web box
treatment drop-down list on the HTML tab (choose Box
Properties>HTML) in the Form Designer have validation list
links
1 = All boxes containing a field with a validation list or a Link field
have validation list links (default)
BoxHighlighting=

Controls whether the current box on Web query/edit forms has a
selection box. For this parameter to affect exported HTML query
and/or edit screens, it must be set when DB/TextWorks is not
running (and before you export them to HTML).
0 = No selection box
1 = Selection box displayed (default)

BrowseChoicesText=

Controls the text for the Browse Choices button. This must be set
before you export a query screen to HTML. Type your text after
the = sign. For example: BrowseChoicesText=Consult

WebLinkINM=

Controls the appearance of the Inmagic logo and hypertext link
(that is, the "Powered by DB/Text WebPublisher, from Inmagic"
attribution line). This setting affects pages exported to HTML using
DB/TextWorks, and WebPublisher PRO.
0 = The Inmagic logo in the attribution line is a hyperlink to the
Inmagic Web site. (default)
1 = The Inmagic logo does not appear. In its place is plain text
that is not a hyperlink: Inmagic, Inc. (www.inmagic.com).
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WebHideINM=1

Completely remove the attribution line and the accompanying
horizontal rule.

WebEditValidation=

Controls whether validation lists can be overridden and/or new
terms can be added when users edit records over the Web.
none = Validation rules cannot be overridden and new terms
cannot be added to validation lists. (default)
override = Validation rules can be overridden, but new terms
cannot be added to validation lists.
update = Validation rules can be overridden and new terms can
be added to validation lists.

WebDocType=

Specifies the DOCTYPE declaration for emitted XHTML.
If this parameter is absent, the following default DOCTYPE is
used:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0
Transitional//EN" "http://www.w3c.org/TR/xhtml1/DTD/xhtml1transitional.dtd">
Note: WebPublisher PRO output may not match the specified
DOCTYPE.

DBText.INI (or INMCSRV.INI)
The DBText.INI file (or INMCSRV.INI if you are using the SQL platform) contains information
about software configuration settings, and is located in the DB/TextWorks installation folder. If it
is absent, default settings are used. You can change some of this information (the first four
bulleted items) by running the DB/TextWorks Setup program and choosing Configure. To
make other changes, you can edit the DBText.INI file directly using a text editor, such as
Microsoft Notepad.
Important! To ensure that settings are also applied to WebPublisher PRO, we strongly
recommend you place a copy of DBText.INI (or INMCSRV.INI) in your WebPublisher PRO
installation folder on the server. Whenever you make date-related changes to this file (either
directly or via DB/TextWorks Setup), you should copy the modified file to the WPP installation
directory, so the two copies remain identical.
The DBText.INI (or INMCSRV.INI) file contains information such as:
Language(s) used for month and day names
Default leading article and stop word lists
Setting for interpreting 2-digit years
Settings for tracking textbase activity
Information about the Copy Special Application commands
The following tables list the various sections and parameters.

[Dates]
Parameter

Purpose

CenturyYear0= For interpreting 2-digit years, specifies the first year in the current century. For
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example, if you specify 1940, "96" means "1996" and "35" means "2035". The
default is 1940.

[defaults]
Parameter

Purpose

dfltDays=

Lists the primary day names that DB/TextWorks will recognize.
These day names are also used when displaying formatted dates.
Type seven day names in order, starting with Sunday, separated by spaces.

dfltMonths=

Lists the primary month names that DB/TextWorks will recognize.
These month names are also used when displaying formatted dates.
Abbreviations of these months are used when displaying date fields in the
Query Choices Browser (for query screens used on the desktop) and the
Inmagic Choices Browser (on Web query screens).
Type 12 month names in order, starting with January, separated by spaces.

dfltDays2=

Lists the alternate day names that DB/TextWorks will recognize.

dfltMonths2=

Lists the alternate month names that DB/TextWorks will recognize.

sShortDate=

Controls short date format (for example, dd/mm/yyyy).

sLongDate=

Controls long date format, primarily for displaying formatted dates (for example,
dddd, MMMM dd, yyyy)

iDate=

Controls the order of date components for interpreting dates.
0=M-D-Y
1=D-M-Y
2=Y-M-D

indexDateFmt= Controls the format of date indexes shown in the Query Choices Browser (for
query screens used on the desktop) and the Inmagic Choices Browser (on Web
query screens). The default format is YYYY-Mmm-DD.
The sShortDate=, sLongDate= and iDate= parameters are an alternative to making the user
account (the account used by WebPublisher PRO) a member of the group Users so that its
Regional Settings are retained and used.

[Advanced]
Parameter

Purpose

EnableSlotLog=

Add this parameter and set it equal to 1 to have DB/TextWorks write
a line to the textbase .SLT file every time it opens the textbase, and
clear the line every time it closes the textbase. You can open the
.SLT file with a text editor.
To have this parameter apply to the Web component as well, you
must place a copy of the DBText.INI file in the WebPublisher PRO
installation folder.
To use this feature, the account used by WebPublisher PRO must
have Full access to the .SLT file, which resides in the same folder as
the textbase.
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If you want to track users for some textbases but not for others, you
can use this parameter in individual <textbase>.INI files.
RecordLockInterval=

[SQL platform only]
Add this parameter to specify the amount of time you want non-active
locks to remain active before the software automatically clears them.
The default value is 20 minutes.
The value you specify must be entered in milliseconds.

LockTimeout=

[SQL platform only]
Add this parameter to specify the amount of time you want the
software to wait for an existing lock to be cleared before, for example,
displaying a message. The default value is 60 seconds.
The value you specify must be entered in milliseconds.

CSErrorDump=

[SQL platform only, in either INMCSRV.INI or the textbase INI file]
This parameter tracks SQL server errors that occur in a textbase or
on a workstation. Set the value to 0 (off) or 1 (on).
0 or 1

OptimizedPhraseSearch= [SQL platform only]
Add this parameter and set it equal to 1 to optimize phrase
searching. Doing this increases the speed of phrase searching, but
places some restrictions phrase recognition.
If OptimizedPhraseSearch=1, searches cannot recognize phases in a
textbase that have more than one punctuation or space character
between words (for example, a period and a space, two spaces, a
colon and a space, and so forth).
To search for phrases that have multiple characters between words
(such as, Mr. Jones), use a proximity search or the truncation symbol
(*). Note that proximity searches (for example, submit mr p1 jones to
find Mr. Jones) will not find phrases that include stop words, and the
truncation symbol may find phases in addition to the one you want
(for example, Mr* Jones would find Mr. Jones and Mrs. Jones).
The default setting is 0, which is the traditional phrase searching
without the restriction on punctuation and spaces.

[Special Vendor]
If you plan to pass record-specific information to other applications by way of the Windows
Clipboard, you must specify those applications in the [Special Vendor] section. The name of the
parameter is the application name you will use for reference in the <textbase>.INI file. Several
vendors are included in the default DBText.INI file. See the Application Options (Copy Special)
topic for detailed information.

DBTWPub.INI (or ICSWeb.INI)
The DBTWPub.INI file (or ICSWeb.INI if you are using the SQL platform) contains settings that
are specific to WebPublisher PRO. This file is required for the Web component to run. Write
access is recommended for this file.
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Note for SQL platform: Section names that include "WebPublisher" are shortened to "Web" in
ICSWeb.INI. Examples: [WebPublisher Defaults] vs. [Web Defaults], and [WebPublisher] vs.
[ICSWeb].
Use a text editor to edit the file, to adjust the WebPublisher-specific settings listed below:
Where the Web component looks for textbases and images used in reports, singlerecord displays, and on edit and delete pages.
How many temporary query sets are retained.
Whether Cascading Style Sheets (CSS) are used to format report/display/edit pages.
Whether WebPublisher PRO messages are translated/modified.
Whether each page has a New Search button next to the Next/Previous buttons.
Whether expand record links and edit/delete pages open in a new browser window.
ADA Compliance settings.
The total number of records WebPublisher PRO displays for each search.
Whether severe error messages are logged.
Default Includes in output.
XML settings including how to enable or disable XML for textbases and how to specify
the total number of records displayed on the Web.
Whether navigational buttons appear on Web pages.
Whether exploded sorts are supported on the Web.
Whether hit navigation is enabled for records displayed on the Web.
Whether query logging is turned on for queries performed over the Web.

Textbase Log Files
For each textbase, you can enable a log file to record textbase activity. A log file is a standard
ASCII text file. It is saved in the same location as the textbase and has the same file name as
the textbase, with the extension .LOG. You can enable, view, print, or delete a log file from
within DB/TextWorks.
Note: A log file does not record activity performed using Manage Textbase Elements.
To enable a textbase log file
1. Choose Maintain>Edit Textbase Structure>Log File.
2. In the Textbase Log File dialog box, select Enable Logging to File.
3. In the First Identifying Field list, select a field. Its name and contents (first 250 characters
only) will appear in the log file to identify records that have been added, changed, or
deleted. Select a field with short, unique contents (such as an Automatic Number field or
other unique identifier).
4. If you want to use two fields as identifiers, select a field in the Second Identifying Field
list. Use a second identifying field if one field does not uniquely identify a record, or if you
need a second field for clarity.
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5. To revert to the default settings, click Reset to Default. The default settings are the first
field defined in the textbase structure for the First Identifying Field and <none> for the
Second Identifying Field.
To record user activity in the textbase log file
You can add a Details = parameter to the [LogFile] section of the <textbase>.INI file if you want
the textbase log file to record who is opening the textbase, editing records, and locking records.
Example:
[LogFile]
Details = 2

You can set this to one of the following:
0 - No enhanced logging
1 - Logs when a user opens or closes the textbase
2 - Logs when a user modifies records (and opens/closes the textbase)
3 - Logs when a user locks/unlocks record (and opens/closes the textbase
or modifies records)

To disable a textbase log file
1. Choose Maintain>Edit Textbase Structure>Log File.
2. In the Textbase Log File dialog box, clear the Enable Logging to File check box.
To view a textbase log file
Choose Maintain>View Log File to examine the log file for the current textbase. DB/TextWorks
automatically scrolls to the end of the log file so you can see the most recent information.
Information is continually appended to the log file. Periodically, after reviewing changes and/or
printing the log file, you may want to delete it by choosing Maintain>Delete Log File. A new log
file will be created automatically to record subsequent activity.

Query Log Files
For each textbase, you can enable query logging. By default, queries on the textbase will be
logged to <textbase>_query.log in the folder containing that textbase. Users searching the
textbase need write-access to that folder.
If you prefer to use a different location, specify a QueryLogPath. Use the UNC path if the folder
is on a network drive, and ensure that users have write-access to the folder.
To enable a query log file
Open the <textbase>.INI file and add QueryLog = 1 to the [LogFile] section. Optionally,
specify a QueryLogPath. Example:
[LogFile]
QueryLog = 1
QueryLogPath = \\servername\logfolder\
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Textbase.INI Files
Each textbase can have its own <textbase>.INI file with the same name and location as the
textbase. For example, the Loans textbase can have a Loans.INI file. You can create or edit this
file using a text editor.
A <textbase>.INI file contains textbase-specific settingsfor the following purposes:
Control which choices appear on the Applications menu
Configure Copy Special
Configure Textbase-Specific Help
Configure performance settings for the Query Choices Browser and Inmagic Choices Browser
Record user activity in a textbase log file
Textbase and Query log files
Track who has the textbase open (EnableSlotLog)
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Textbase Files (non-SQL platform)
A textbase consists of a number of files with the same name as the textbase but different
extensions. For example, the textbase Sales consists of SALES.TBA, SALES.ACF, etc.
Note for SQL platform: If you are using DB/TextWorks for SQL, see Textbase Files (SQL platform).
Extension

Description

.ACF

Access control file; controls simultaneous access to the textbase by multiple
users or software instances, or applications (for example, DB/Text PowerPack).

.ACS

File used with the optional record-level security feature. Created if the textbase
has an Access Control field with a populated special validation list.

.BTX

Contains the Term and Word indexes.

.DBO

Contains a directory to the records in the .DBR file.

.DBR

Contains records (including deferred).

.DBS

Textbase structure file, contains field definitions and other information.

.IXL

Indexed list file, contains the validation and substitution lists.

.OCC

Contains the lists of records indexed by the terms and words in the .BTX file.

.SDO

Contains a directory to records with deferred updates in the .DBR file.

.TBA

Primary textbase definition file, which also contains textbase elements (for
example, forms, query screens, sets, record skeletons) stored in the textbase.

.HLP

Optional textbase-specific help file.

.INI

<textbase>.INI is an optional file used with Copy Special applications, TextbaseSpecific Help, the ODBC driver, and the Applications menu.

.LOG

Optional textbase log file; lists changes to records and the textbase structure.

.SLT

Optional file to indicate who has a textbase open, if EnableSlotLog=1 in the
[Advanced] section of DBTEXT.INI or <textbase>.INI.

.TML

Thesaurus maintenance locking file, prevents more than one person at a time
from modifying records in a thesaurus. Does not need to be backed up.
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Textbase Files (SQL platform)
A DB/TextWorks for SQL textbase consists of a number of files with the same name as the textbase,
but different extensions. For example, Sales consists of SALES.CAC, SALES.CBA, etc.
Important! Records, indexes, and other important files reside inside SQL server. Backing up
the textbase files shown below does not provide a complete backup. For more information, see
Back Up Textbases (Back Up & Restore menu).
Extension
.CAC

Description
Access control file; controls simultaneous access to the textbase by multiple
users or software instances, or applications.

.CBA

Primary textbase definition file, which also contains textbase elements (for
example, forms, query screens, sets, record skeletons) stored in the textbase.

.CBS

Textbase structure file, contains field definitions and other information about the
structure of the textbase.

.HLP

Optional textbase-specific help file.

.INI

<textbase>.INI is an optional file used with Copy Special applications, TextbaseSpecific Help, and the Applications menu.

.LOG

Optional textbase log file; lists changes to records and the textbase structure.

.SLT

Optional file that is created when EnableSlotLog=1 appears in the [Advanced]
section of the INMCSRV.INI or <textbase>.INI file. This option can be set in
INMCSRV.INI during Setup using the Track Textbase Access button on the
Configuration dialog box. The machine name and login name of each user who
has a textbase open is recorded in the .SLT file. The line is cleared when each
user closes the textbase.

TML

Thesaurus maintenance locking file, prevents more than one person at a time
from modifying records in that thesaurus textbase. TML files do not have to be
backed up. The software automatically creates them if they do not exist.

User Files
A user file is a file in which you can save textbase elements, as an alternative to saving them in
the textbase. DB/TextWorks creates one user file for each textbase that you open. For example,
a textbase called Sales has a user file called SALES.TBU.
User files provide a "private" place to store elements. Only you have access to elements in your
user file. User files are intended for convenience, not security. For example, if you are practicing
designing forms and you do not want other users to see your early or not finished attempts,
save the forms in your user file.
User files for all of the textbases that you open are kept in the same location on your local hard
drive, or some other location not shared by other users. To see your user file path, choose
Display>Textbase Information.
The location for user files is determined the first time you run the software, when you are asked
to specify a User File Path. You can accept the suggested path or specify a different one. If you
specify a different location, be sure you have full (read/write/delete) access to it.
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You can change the location for user files at any time by selecting Tools>Options.
Here is a typical example of how one textbase can have multiple user files:
There is one textbase on a shared network drive: \\SERVER\VOL1\PUBLIC\SALES.
Betsy's user file is on her local hard drive: C:\PROGRAM FILES\INMAGIC\SALES.TBU.
John's user file is on his local hard drive: D:\DBTEXT\USERFILE\SALES.TBU.
Richard's user file is on a shared network drive:
\\SERVER\VOL1\USERS\RICH\SALES.TBU.

Saving Elements in User Files
Elements are not saved as separate files. They are saved as elements within a user or textbase
file. When you save an element, the Save As dialog box asks where to store the element:
User File (Private). Elements saved in the user file are available only to that particular
user. This is the default option.
Textbase File (Public). Elements saved in the textbase file are available to all users.
Elements saved in the textbase file are followed by the notation (public) when they
appear in selection lists. The notation (public) is not part of the element name.
Elements of a given type can have the same name if one is stored in the textbase and the other
in the user file. For example, a form called Summary can be saved in both the user file and the
textbase file. The form saved in the textbase file appears as Summary (public) when it appears
in a selection list.

User File Collisions
When specifying a user file path on a network drive, be sure to specify a folder that no one else
uses for their user files. Otherwise, you run the risk of overwriting each other's elements in the
user files. (The whole user file is not overwritten; just individual elements that are actually
changed and saved, such as forms or query screens.)
Because all of your user files are stored in one place, you should not give two textbases the
same name, even if they are in different directories or on different computers, because they will
be given identical user file names. For example, if you open C:\COMPANY\SALES, a user file
called C:\USERFILES\SALES.TBU will be created. If you then open C:\BACKUP\SALES, the
same user file will be used.
When the software detects a potential collision, it displays this message:
The last textbase you opened with this name was in C:\COMPANY\ rather than
C:\BACKUP\. If you have different textbases with the same name, information stored in your
user file may be incompatible with one of them. Continue?
If you click Yes to continue, the user file will be changed to reference the new path.
Elements stored in the user file may not work with the current textbase.
If you click No, the textbase will not be opened. To avoid future user file collisions, you
have to decide which textbase the user file belongs to and rename the other textbase, so
you do not have two textbases with the same name.
Tip! For more information, open the Messages textbase (DBTMSG, normally located in the
same folder as DB/TextWorks) and search for the message "The last textbase you opened with
this name..."
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Note: In addition to user files, there are some files that are both textbase-specific and userspecific that are located in the user file folder. These include the .TBS file, which stores
persistent scripting information, and the .IDI file, which stores last-used settings (for example,
window size and position, batch modification settings).

Temporary Files
Like most Windows applications, DB/TextWorks creates temporary files during certain
operations. Under normal circumstances, the software deletes these temporary files when you
exit the software, so you will not see them. However, if you reboot while the software is running,
temporary files may remain. To free up disk space, you can safely delete these temporary files.
DB/TextWorks temporary files are named ~DTnnnn.TMP, where n represents digits; for
example, ~DT2345.TMP, and are saved in the folder specified by the TEMP environment
variable.

Text File Extensions
The extensions listed below are recommended but not required for text files used with
DB/TextWorks. For example, when you export records, the extension .DMP is assigned by
default, but you can change this extension in the Export File As dialog box.
Extension

Description

.ADD or .DMP

Records to be imported

.CHK

Check Textbase problem report file

.DMP

Exported records

.IAB

Image annotation list backup file

.TBB or .CBB

Textbase structure definition (.TBB for non-SQL, .CBB for SQL
platform)

.TXT

Information printed to a file (validation lists, textbase elements, etc.)

.X01, .X02, etc.

Exception files

.XPF

Exported form definitions

.XPK

Exported record skeleton definitions

.XPQ

Exported query screen definitions

.XPS

Exported set definitions
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Inmagic.net
Inmagic.net gives you the ability to connect to the Inmagic server from within a DB/TextWorks
session to accomplish the following tasks:
Order your information resources (for example, books) online. From the
Inmagic.net menu you can place an order.
Catalog Web pages for easy searching. From the Inmagic.net menu you can access a
Web site and catalog information from it to a textbase, including its URL.
Configure Inmagic.net to be able to accomplish these tasks and others.
Note that Inmagic.net is an evolving feature. New functionality may be presented periodically.
For the latest information, see the on-screen text for the function pages. You may also see a
Help button on the toolbar and/or the page.
To print the contents of an Inmagic.net window, choose File>Print.
To use Inmagic.net to order information resources
To place an order, choose Inmagic.net>Place Order. A browser window opens within
your current DB/TextWorks session and goes to the Web page for your chosen
information resources supplier. If you need help on this page, use the supplier's online
help resource.
Note: If you have not designated a supplier beforehand, select one by clicking a logo on
the Place Order page. To designate a preferred supplier, choose
Inmagic.net>Configure to open the Configure page.
To configure Inmagic.net (for example, to designate a preferred online information
resources supplier), choose Inmagic.net>Configure. The Inmagic.net Configure page
appears. For more information about this page, see the page.
To use Inmagic.net to catalog a Web page
Choose Inmagic.net>Catalog Web Pages. A browser window opens within your current
DB/TextWorks session. For more information about this page, see the page.
Note: If you have not already specified the fields in your textbase into which you want to
catalog information from a Web site, open the textbase, then choose
Inmagic.net>Configure to open the Configure page.

Configure (Inmagic.net menu)
Choose Inmagic.net>Configure to configure Inmagic.net (for example, to designate a
preferred online information resources supplier, to map fields in a textbase for Web page
cataloging on the desktop, or to configure support for WebPublisher features such as check box
forms, RSS feeds, or SOAP applications. Note that before you attempt to map fields in a
textbase, you must have the textbase open.

Navigating in the Inmagic.net Window
The Inmagic.net window appears when you select a command from the Inmagic.net menu.
For example, when you choose Inmagic.net>Place Order, a browser window opens within
your current DB/TextWorks session and goes to the Web page for your chosen information
resources supplier. You can navigate within the Inmagic.net window:
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To go back to the previous Web page (when applicable), choose Display>Back or click
the Back button on the toolbar for the Inmagic.net window.
To go forward one Web page (when applicable), choose Display>Forward or click the
Forward button on the toolbar for the Inmagic.net window.
To stop the display of a Web page, choose Display>Stop or click the Stop button on the
toolbar for the Inmagic.net window.
To find specific text within a Web page, choose Edit>Find or click the Find button on the
toolbar for the Inmagic.net window.

Place Order (Inmagic.net menu)
Choose Inmagic.net>Place Order to go to the Web page for your chosen information
resources supplier.
Note: If you have not designated a supplier beforehand, select one by clicking a logo on the
Place Order page. To designate a preferred supplier, choose Inmagic.net>Configure to open
the Configure page.

Catalog Web Pages
Choose Inmagic.net>Catalog Web Pages to go to the Inmagic.net Catalog Web Pages
browser window so that you can access one or more Web pages and catalog information from
them into a textbase, including URL, title, keywords, and selected page content.
To catalog information, follow the on-screen instructions on the Inmagic.net Catalog Web Pages
browser window, then click the Catalog Current Web Page toolbar button.
Note: If you have not already specified the fields in your textbase into which you want to catalog
information from a Web site, open the textbase, then choose Inmagic.net>Configure to open
the Configure page.

Reload command (Inmagic.net)
Choose Display>Reload to reload the current page.
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What is WebPublisher PRO?
WebPublisher PRO is a server version of DB/TextWorks that enables you to publish textbases
on the Internet or an intranet. Web users can search the textbases using any supported
browser, and can add, edit, and delete records. WebPublisher PRO is used together with
DB/TextWorks, which is the "buildware" for creating and maintaining searchable textbases.
Because it supports Extensible Markup Language (XML) and Simple Object Access Protocol
(SOAP), WebPublisher PRO enables you to integrate your DB/TextWorks textbases with other
applications using standard third-party tools.
WebPublisher PRO accepts queries submitted over the Web and returns search results as
formatted HTML reports. For the Webmaster, there is no user interface, and no icon on the
desktop or option in the Start menu. Clients point their Web browser to a page on your Web site,
where they can search for information by doing a query.
WebPublisher PRO is ideal for publishing text-intensive information that is likely to change on a
regular basis, including:
Catalogs and other information products on an intranet or the Web.
Intranet publishing, such as Human Resource policies and competitive intelligence
documents.
Customer or prospect services, such as Help Desk, knowledgebase, and product
catalogs.
Research and resources for a company project, to which users can add URLs of
relevant Web sites they discover.

How Do They Work Together?
You can place information in a DB/TextWorks textbase, and put that textbase on your server, so
users who go to your Web site can search your textbases to find the information they need.
WebPublisher PRO can run in an intranet or Internet environment. A typical LAN/WAN topology
is illustrated below.
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The following components are involved:
Web browser. The only client requirement is a Web browser that supports JavaScript.
HTTP Server Software. Passes information between the browser and WebPublisher
PRO.
WebPublisher PRO. Processes client queries and returns formatted results in HTML or
XML format.
DB/TextWorks. The buildware, a database application used to create and maintain
textbases, forms, and HTML search and edit screens.

How Do I Publish a Textbase on the Web?
Publishing a textbase involves a textbase designer and a Webmaster:
1. The textbase designer uses DB/TextWorks to perform these tasks:
Create a textbase and populate it with records. This is the "text database" that
WebPublisher PRO will search.
Create forms. Forms determine how records appear in the Web browser. Using the
Form Designer within DB/TextWorks, design the forms that will be used to display
records in the browser. You should design one or more Report forms for displaying
multiple records retrieved, and one or more Display forms for expanded display of
one record at a time. If you have WebPublisher PRO version 7.0 or later, you may
also want to design one or more Edit forms for adding, editing, and deleting records
over the Web.
Create a query screen and export it to HTML. This is the HTML page that clients
will use to submit queries. Note that a query screen can allow clients to search
multiple textbases.
[Optional] Create a menu screen and export it to HTML. This is an HTML page
that contains links. Clicking a link runs a predefined query.
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[Optional] Create an edit form and export it to HTML. This is an HTML page that
lets you and/or your clients add records directly from a Web browser. (This edit
screen can be accessed by a URL and does not require a search be submitted
first.)
2. The designer passes the files to the Webmaster, who mounts them on a server. The
Webmaster sets up a link that points to the HTML search page. When preparing to
publish a textbase, the designer and Webmaster need to coordinate the following issues:
Textbase file locations. DB/TextWorks and WebPublisher PRO need access to
the textbase. The textbase can be in a shared location, or you can store the
textbase locally copy it up to the HTTP server whenever you make changes.
HTML and image file locations. Clients need access to the HTML search pages
you created and any images referenced in these pages or reports.
Initialization files. Many WebPublisher PRO settings are controlled by initialization
(INI) files stored on the HTTP server. From time to time, you may need to edit these
files. In addition, you can override the settings in these files by including special
parameters in the HTML query screen or the XML sent to WebPublisher PRO.
Intranets. If you are publishing on an intranet, you can provide access to document
or image file names specified in records using HTTP or network file addressing
protocols.
3. Before allowing the textbase to be searched by clients, test it thoroughly to ensure you
can successfully perform a search and any other operations you have allowed, such as
adding or editing records.

How Do Clients Use WebPublisher PRO?
Clients can point a Web browser to the HTML query screen and submit a query. An HTML
query screen includes boxes where clients can type query criteria. It may also include Choices
Browser buttons or links and/or choices drop-down lists, so clients can select items from a list.
These query methods eliminate guess-work, to make searching easier and more intuitive.
If the textbase designer supplied a menu screen, clients can click links to run queries. Used on
the Web, a menu screen is an HTML page that includes one or more predefined queries. To the
client, the predefined queries look like regular hypertext links. Clicking a link submits a query
directly to WebPublisher, which processes the query and returns results.
Note: The textbase designer can specify that search results are returned in Extensible Markup
Language (XML) format instead of HTML.
The client's Web browser displays the results of the search. The client can use the standard
browser controls to navigate. Other controls, such as navigation buttons on the report, are
provided by the software. Record appearance is controlled by forms that were designed with
DB/TextWorks. Clients can change record appearance dynamically by selecting different forms
from a drop-down list in the browser.
Forms that display multiple records (search results) often include a hypertext link to a singlerecord display. Clients can click the link to see a detailed view of one record at a time. This is
called expanding a record. After expanding a record, the client can perform some or all of these
tasks:
Display the next or previous record using the Next/Previous navigation buttons.
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Select a different form from the drop-down list to change the record's appearance.
Return to the report (multi-record display) by clicking the Rewind (<<) button.
Print the page, using the currently selected form to format the output.

WebPublisher PRO Directory Structure
WebPublisher PRO uses the directory structure illustrated below. Additional subdirectory levels
are not shown.
Important! A DBTW-WPD virtual directory is required for the software to function properly. To
learn how to set up a virtual directory for various HTTP servers, see the Inmagic
DB/Text WebPublisher PRO Installation Notes.
Note for SQL platform: The virtual directory for the SQL platform is ICS-WPD. Also, the SQL
platform uses ICSWeb.INI, not DBTWPub.INI.

Desktop vs. Internet Use
If you have WebPublisher PRO, you can use DB/TextWorks to create textbases, forms, query
screens, and menu screens for desktop as well as Web use.
As a general rule, you should design separate forms, query screens, and menu screens for
desktop and Web use. Some things that you can do on the desktop are not fully supported by
HTML. On the other hand, you can do things in the HTML version of a form or screen, such as
add hypertext links, that do not function on the desktop.
Most of the features that are specific to Web use are located on tabs in the Screen Properties
dialog box and Box Properties dialog box. To access the Screen Properties dialog box in each
designer, choose Tools>Screen Properties in the Menu and Query Screen Designers and
Tools>Form Properties in the Form Designer. Web settings are found on the Logos and HTML
tabs in all three designers.
To access the Box Properties dialog box in each designer, select a box and choose Tools>Box
Properties. Not all box types in each designer support HTML settings. The HTML tab (with
HTML-related settings) only appears on the Box Properties dialog box when you select a box
that can be successfully exported to HTML.
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In the Query Screen Designer, a query screen can be designed to search more than one
textbase by choosing Tools>WebPublisher Multiple Textbase Query and specifying the
textbases and fields to be searched simultaneously. (Note that this feature is not available for
XML input/output or for editing over the Web.)
HTML properties take effect only when the form or screen is used with a textbase on the
Internet or an intranet.
Query screens and menu screens, as well as edit screens that you want to be able to access
directly on the Web (for example, a registration form), have to be exported to HTML for Internet
use. Forms used to display, edit, and delete information after a search do not. You establish
form usage in the Save Form As dialog box in the Form Designer. If you select the Web check
box, the form will appear in the WebPublisher drop-down list. The Web Only check box
prevents a form from appearing in lists on the desktop.
The Form Designer, Query Screen Designer, and Menu Screen Designer contain several menu
options intended specifically for publishing textbases on the Web. Some options apply to all
three designers, while others are specific to individual designers. Those options are listed in the
following table.
All Designers
Tools>Form/Screen
Properties>Logos

Specify image files to be used at the top and/or bottom
of the page. Especially useful in conjunction with
tabular forms.

Tools>Box Properties>HTML

Treat contents of box as HTML links. In the Form
Designer, each entry in the field can generate a
separate link (for example, URL or "See also" link.)

File>Write Report to File>HTML

Write a formatted report to an HTML file that you can
publish on the Web. This provides a way of producing
static reports.

Menu Screen Designer
Tools>Screen Properties>HTML

Specify position of navigation buttons, whether form
lists appear, the number of records per page, and the
use of background images for the screens.

Menu Operations>Export Menu
Screen to HTML

Save a menu screen as an HTML page for use on the
Web.

Form Designer
Tools>Form Properties>General

Specify search highlighting settings, how to show
underbars on forms, background color for form, and
the distance between records.

Tools>Form Properties>HTML

Specify whether to use record separators and/or a
background image for the form when used on the
Web. Click the Advanced Options button to add
information to the <head> section of the HTML report
and to specify Includes for one or more seams of the
HTML report.

Form Operations>Save Form (As)

Specify whether a form will appear in Web browser
drop-down lists and/or desktop drop-down lists.

292

Inmagic DB/TextWorks v13 Printed Help

WebPublisher PRO

Form Operations>Export Editing
Form to HTML

Save an editing form as an HTML page to use to add
records to a textbase via the Web.

Query Screen Designer
Tools>Screen Properties>HTML

Specify whether to show Boolean drop-down lists
(AND, OR, NOT), whether to use background images
for the screens, the initial forms used (report, display,
and edit forms), whether form lists appear, the number
of records per page, and the position of navigation
buttons.

Screen Operations>Export Query
Screen to HTML

Save a query screen as an HTML page for use on the
Web.

Tools>WebPublisher Multiple
Textbase Query

Specify which textbases to search if more than one is
being searched from a single query screen. Select
report and display forms, and create a field name map.

Tools>Box Properties>HTML

Add Choices Browsers and/or choices drop-down lists
to query boxes; or turn a query box into a password
box.

How to Publish Textbases on the Web
To publish textbases, you need DB/TextWorks and WebPublisher PRO. The basic steps for
publishing a textbase are summarized below.
1. Create the textbases. Use DB/TextWorks to create textbases that Internet/intranet
users will search. Put the textbases anywhere that WebPublisher PRO can access them.
The textbases can be in a shared location, or you can store the textbase locally and
copy it up to the HTTP server whenever you make a change.
2. Specify the path to the new textbase in the [WebPublisher Textbase Paths] section of
your DBTWPub.INI (or the [Web Textbase Paths] section of the ICSWeb.INI file if you
are using the SQL platform) file, so WebPublisher PRO can find the textbase. The INI
file is located in your WebPublisher PRO installation folder. This example shows the
path to the "test1" textbase set to the default installation path. Change the path to match
your situation: test1=C:\Program Files\Inmagic\WEBPUB\Textbase\
3. Create the forms. Use the Form Designer to create forms that will be used to display
records in the Web browser. You should design one or more Report forms for displaying
multiple records retrieved, and one or more Display forms for expanded display of one
record at a time. If you have WebPublisher PRO, you may also want to design one or
more Edit forms for adding, editing, and deleting records over the Web.
In the Form Designer, be sure to choose Tools>Box Properties>HTML and
Tools>Form Properties>Logos/HTML and specify HTML attributes.
Note: If you want to provide users direct Web access to an edit screen from which they
can add records (for example, a registration form for an event), create an Edit form and
export it to HTML. Edit forms are the only type of form that can be exported to HTML.
3. Save the forms. When you save each form in the Form Designer, select these options:
Save in Textbase File (Public). This ensures that when you place the textbase
files on the server the forms will be there too.
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Web from the Use For group.
One or more of the following, depending on the purpose of the form:
Display Window. Select this check box to have this form appear in the expanded
display form lists on the Web.
Report Window. Select this check box to have this form appear in report form lists
on the Web.
Edit Window. Select this check box to enable the form to be used to add, edit, and
delete records over the Web.
Note the following:
Forms are not separate files. They are saved in the textbase, so you do not have to
take any extra steps to place forms on the server, nor do you have to convert them
to HTML.
Note: If you want to provide users direct Web access to an edit screen from which
they can add records (for example, a registration form for an event), create an Edit
form and export it to HTML. Edit forms are the only type of form that can be
exported to HTML.
Use Tools>Screen Properties>HTML for query screens, and Tools>Box
Properties>Initial Elements for menu screens to specify which Report, Display,
and Edit forms to use initially in the Web browser.
Printed reports use whichever form is displayed in the browser when the browser
Print command is used.
4. Create an HTML query screen and export it to HTML. A query screen is a search
form that users type query criteria into, in order to search for records. Use the Query
Screen Designer to design a query screen, then export it as HTML. Place the resulting
HTML page anywhere on your Web site.
5. [Optional] Create an HTML menu screen and export it to HTML. You can use a menu
screen instead of, or in addition to, a query screen.
A menu screen is a list of one or more predefined searches. The searches appear to a
Web user as a list of hypertext links. Clicking a link generates a search and returns
records to the Web browser. Use menu screens when you want to "protect" users from
having to specify query criteria, or when many users are likely to want to perform the
same searches. Use the Menu Screen Designer to create a menu screen and export it to
HTML.
6. Give users a way to get to the query screen or menu screen. Put the HTML page
anywhere accessible to the HTTP server. Then make sure that Web users have a way to
get to that page. For example, add a hypertext link to a page on your Web site that
jumps to the HTML page. Or make your home page the query screen or menu screen
itself. If you are publishing multiple textbases, a page on your Web site could include a
list of the textbases, with each item being a jump to the appropriate HTML query screen.
7. Test your textbases. Before you make your textbases widely available on the Internet
or an intranet, test them locally to be sure that everything works the way you intended.
For example, point your Web browser to http://localhost/dbtw-wpd/textbase/testqs.htm,
where localhost is your Web server name. Note for SQL platform: The SQL platform
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uses ics-wpd instead of dbtw-wpd. Enter search criteria in one of the boxes and click
Submit Query.
Tip! If you receive an error when trying to retrieve records, ensure that the correct
permissions and access rights are assigned for both the WebPublisher PRO folder tree
and its mapped virtual directory. Details about these permissions/access rights are
supplied in the Installation Notes.

Publishing on an Intranet
You can publish textbases on a local or wide-area network (LAN or WAN) to make information
available within an organization across a variety of platforms.Typical applications include
publishing company policy and procedures manuals, tracking sales and expenditures, and
providing access to image files such as scanned photographs or scanned documents.
Publishing textbases on an intranet is the same as publishing on the Internet, with two
differences:
You can use HTML file references in a form to launch applications, if your Web clients
have the appropriate access to the needed application(s) and files. For example, a click
from a user can start a demo or open a document in Microsoft Word.
If your textbases contain image references, you can select the Use file:// reference for
image option when designing a form (that is, open the Form Designer, then choose
Tools>Box Properties>HTML).

WebPublisher PRO: Linking to Other Pages
A form, query screen, or menu screen designed for use on the Web with WebPublisher PRO
can include links to other HTML pages.
For Query Screens
1. Choose Search>Design Query Screen, and create a new screen or load an existing
one.
2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
4. On the HTML tab, from the Treat text as drop-down list, select URL.
5. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
6. Click Apply, then click Close.
7. [Optional] If you want users to be able to add new records to the textbase from the query
screen, add a New record link.
8. Save the query screen.
9. Export the query screen to HTML.
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For Forms
1. Choose Display>Design Form, and create a new form or load an existing one.
2. Select the form box with the content item that contains the link destination and choose
Tools>Box Properties to open the Form Box Properties dialog box.
3. On the HTML tab, from the Contents list, select the content item that contains the link
destination, then do the following:
a. From the Treat content item as drop-down list, select URL.
b. [Optional] Select the Use alternate link text check box, then, in the Text box
below it, enter the text you want to appear as the hypertext link. (This check box
becomes enabled after you select URL from the Treat content item as drop-down
list.)
4. Click Apply, then click Close.
5. Save the form.
Approaches that you can use when designing forms
Add a hypertext link to a report form so users can jump to an expanded display of one
record at a time.
Add a hypertext link to a report and/or display form so users can jump to an edit screen
to add, edit, or delete a record. Note that editing over the Web requires WebPublisher
PRO version 7.0 or later.
Use settings from the Treat content item as drop-down list on the HTML tab (choose
Tools>Box Properties>HTML) to generate hypertext links. These settings include: Raw
HTML, URL, e-mail link, HTML file reference, Expand record link, "See Also"
search link, Inline image, Image link, New record link, Edit record link, Delete
record link.
For Menu Screens
1. Close any open textbase.
2. Choose Menu Screens>Design, and create a new screen or open an existing one.
3. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
4. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
5. On the HTML tab, from the Treat text as drop-down list, select URL.
6. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
7. Click Apply, then click Close.
8. Save the menu screen.
9. Export the menu screen as HTML.
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Launching Applications with WebPublisher PRO
If you are publishing textbases on an intranet, you can use WebPublisher PRO to launch other
applications, such as a video clip or a spreadsheet, from within a form, query screen, or menu
screen. You do this by including the name of the file you want to open in a field in the textbase,
or as fixed text in a text box on a query or menu screen.
When the user clicks the file name or other text that you supply, the application associated with
that file is launched to open the file. The file extension (defined in the Windows Registry or
browser preferences) dictates what application is used.
In general, you should provide links which launch applications only across an intranet where you
know the users have access to the software and hardware needed to run the application(s)
associated with the referenced files.
Important! All intranet users will have access to the files (documents, spreadsheets, and so
forth) to which you provide a link. If you do not want users to be able to edit files, place the files
in a read-only folder or link to .PDF files.
Be sure that the target file is set up properly on the server to be accessible to all users. One of
the following conditions must be true:
The end user is capable of opening the target file using the associated application
software from his or her desktop using network file access protocols, OR
The end user is capable of running the associated application, and can access the target
file using HTTP addressing protocols.
In the first case, it is advisable to use the UNC filename to specify the file path, to avoid conflicts
over logical drive mappings. Place the file information in a box on the form or screen, and select
the HTML tab on the Box Properties dialog box. Select HTML file reference from the Treat text
as or Treat content item as drop-down list (as applicable). If you want to show alternate text
instead of the file name, select the Use alternate link text check box and type in the text you
wish to substitute. Example:
file name:

\\server\vol1\docs\myfile.doc

alternate text:

Click here

result in report:

<a href="file:////server/vol1/docs/myfile.doc">Click here</a>

In the second case, use an HTTP-formatted path specification.
For example, on a query screen, menu screen, or form, add a text box that contains this text:
http://test/myfile.doc

On the Text Box Properties dialog box, select the HTML tab and select URL from the Treat text
as drop-down list. To specify alternate text for the link on the screen, select the Use alternate
link text check box, then type the text you want in the Text box below it (for example, type Click
here).
file name:

http://test/myfile.doc

alternate text

Click here

result in report:

<a href="http://test/myfile.doc">Click here</a>
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If you use an HTTP-formatted path specification on a form, you can create the link with a form
box instead of with a text box. Add a form box and specify the field content or another content
item (for example, Fixed Text) whose content you want to use as the link. On the Form Box
Properties dialog box, select the HTML tab and select URL from the Treat content item as
drop-down list. To specify alternate text for the link on the screen, select the Use alternate link
text check box, then type the text you want in the Text box below it (for example, type Click
here).

Using Passwords on the Web
When designing query and edit screens for use on the Web with WebPublisher PRO, you can
add a box to the screen in which users can enter a password.
This can be useful on intranets, where the textbase administrator can assign passwords to allow
certain users access. This can also be useful on the Internet for limiting access to a textbase on
your Web site, perhaps if you are charging for services offered. Only those users who request
and obtain a password can gain access to the textbase.
Be careful when assigning passwords, especially on the Internet. Inadvertently assigning a
password may guarantee that no one will be able to search the textbase. (This would be the
case only if no Silent password was defined. If a Silent Password exists, it will be used.)
Passwords are defined in the textbase structure.
If a textbase has a Silent password assigned, and you do not put a password box on the query
or edit screen, the Silent password is used.
If the query screen has a password box but the user does not type anything in it, the Silent
password is used. If the textbase has any passwords assigned, no Silent password has been
defined, and there is no password box on the query screen, no one will be able to gain access
to the textbase from that screen.
When you use a query screen with a password box on the Web, the software automatically
retains the password throughout your current browser session. For example, if a user submits a
search, edits a record, then clicks the Rewind (<<) button to return to the query screen, the
password box will still be populated with the password.
Important! For the password to be remembered during the current browser session, cookies
must be enabled.
WebPublisher PRO honors the passwords defined in the textbase structure (that is, Master,
Field Access, and Silent passwords). You can use them to restrict access to a textbase, to
certain fields, and/or to individual records.
To add a password box to a query screen
1. In the Query Screen Designer, add a query box (choose Edit>Add>Query Box) to the
query screen you plan to use on the Web. Do not add any contents to the box.
2. On the Query Box Properties dialog box, select the Labels tab and do the following:
a. In the Label box, enter the label you want to appear on the box. For example,
type Enter Password.
b. From the Label position drop-down list, select an option to specify where the
label appears (for example, Left or Top center.)
3. On the HTML tab, check Treat query box as, and select the Password option.
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4. Click Apply, then Close.
To add a password box to an edit screen
1. In the Form Designer, add a form box (choose Edit>Add>Form Box) to the edit form
you plan to use on the Web.
2. On the Form Box Properties dialog box, select the Labels tab and check the Label box,
enter a label, such as “Enter Password”, then specify a label position.
3. Save the form for use in the Edit Window on the Save Form As dialog box (choose
Form Operations>Save Form As). The form must be saved for use in the Edit
Window for the Web box treatment drop-down list (see the next step) to be enabled.
4. On the HTML tab, from the Web box treatment drop-down list, select Password.
5. Click Apply, then Close.

WebPublisher PRO Images
WebPublisher PRO handles image files in the ways described below, for any textbases that you
publish on the Web. You may use the following types of images with WebPublisher PRO:
Logos. Image files (typically, your organization's logo) placed at the top and/or bottom of
a query screen, menu screen, or form. To add a logo, open the appropriate designer and
choose the Tools menu, the appropriate Properties command (for example, Form
Properties), and select the Logos tab. Type the name of the image file name (for
example, COMPANY.JPG) for the leading and/or trailing logo, as appropriate.
Backgrounds. Image files used as the page background for a form, query screen, or
menu screen used on the Web. To specify a background image, open the appropriate
designer, choose the Tools menu and then the appropriate Properties command (for
example, Form Properties), select the HTML tab, then choose an image file name.
Picture boxes. A picture box is a box that contains a static image or an image
referenced in an Image field in the record. For example, use a picture box to display a
company logo on a form. If the specified Image field contains multiple entries, only the
first image is shown. When specifying the name and location of the image you want to
display, you cannot use the image filename shortcut (for example, image.001 (3)).
Inline images/image links. Image file names specified in textbase records and included
as Inline images or image links in a form. If you want to use text other than the image
name for the image link, use alternate link text.

Images Referenced in Records
A textbase may include Image fields that hold the names of image files. For example, a field
called Schematics might contain the entry DIAGRAM1.JPG. To control how images should
appear in the Web browser, you can:
Add a picture box to display the image. Using a picture box leaves CSS on by default,
and lets you resize the image by changing the dimensions of the picture box. If you use
a picture box on a Web form with CSS, the file path is used to determine the size of the
image in order to preserve the aspect ratio or prevent text from overlapping the image.
Display an Inline image. In the Form Designer, choose Tools>Box Properties>HTML
and select Inline image from the Treat content item as drop-down list. This option
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allows you to display multiple images, if more than one is referenced in the Image field.
The image size is as specified by the software used to create the image file. Turns off
CSS.
Display a link that opens the image on a new page. In the Form Designer, choose
Tools>Box Properties>HTML and select Image link from the Treat content item as
drop-down list.
Note: If you are publishing textbases on an intranet using file:// references for images, the
images have to be accessible to the Web clients by way of a network file system.

Image File Locations
When adding a background image or logo to a query screen, menu screen, or exported edit
screen, the software expects the images to be located in /DBTW-WPD/IMAGES (or /ICSWPD/IMAGES for the SQL platform). If you are storing these images elsewhere, you must
specify the location for the images using a path which includes a forward slash (/).
For images added to a form, the software expects the images to be in a location specified in
DBTWPub.INI (or ICSWeb.INI), unless a Web path to the image has already been specified (for
example, /dbtw-wpd/pics1/img1.gif). For more information about adding logos, background
images, and other types of images to forms, see Specifying Where WebPublisher PRO Looks
for Images.

WebPublisher PRO Query Screens
If you have WebPublisher PRO, you can design query screens for use on the Web. A query
screen is a page that users fill in to perform a search. You can design a query screen for each
textbase that you want to publish on the Web, or you can design a single query screen to
search multiple textbases simultaneously.
The following steps provide a general overview on how to design a query screen for use with
WebPublisher PRO.
1. Use DB/TextWorks to open the textbase that you will publish, then open the Query
Screen Designer.
Note: If you plan to search multiple textbases from your query screen, open the textbase
you want as the lead textbase.
2. Use the Query Screen Designer to specify which fields can be searched. Only query
boxes, text boxes, and picture boxes should be used. (Sets boxes, script input boxes,
and script buttons are for desktop use only and will be ignored when you export the
query screen to HTML.)
3. Specify HTML properties for the query screen and/or the boxes on that screen. For
example, you can show or hide Boolean drop-down lists and limit the number of records
displayed per page.
Choose Tools>Screen Properties>HTML and specify HTML screen options.
Select a box and choose Tools>Box Properties>HTML to specify HTML box
properties for query boxes and text boxes.
4. [Optional] If the textbase has passwords, add a query box and change it to a password
box (choose Tools>Box Properties>HTML). If the textbase has no Silent password,
this step is required.
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5. [Optional] Specify multiple textbases to search. Choose Tools>WebPublisher Multiple
Textbase Query to specify more than one textbase to be searched from your query
screen, select report and display forms for those textbases, and create a field name
map. (Note that this feature is not available for XML input/output.)
6. Save the query screen. Choose Screen Operations>Save Query Screen, and save the
screen in the textbase file or your user file. If the query screen is being used to search
multiple textbases on the Web, it must be saved in the textbase file.
7. Export the query screen to HTML. Choose Screen Operations>Export Query Screen
to HTML and name the HTML file when prompted. Place the HTML page anywhere on
your Web site.

Web Multiple Textbase Query
When you publish textbases on the Web with WebPublisher PRO, you can design a query
screen so users can search more than one textbase from it. Typically, the textbases being
searched are similar in structure, with similar fields.
Searching multiple textbases from a single query screen is helpful when users are searching for
information that is kept in different textbases. For example, you may have product sales
information in separate textbases for each year. Creating a query screen to search multiple
textbases will let users search the data from all years (or whatever years you specify) from a
single query screen.
If your information resources (for example, books, serials, electronic journals) are in separate
textbases, designing a query screen to search multiple textbases will let users search records
from all of your information resources at once.
To set up a Web query screen to search multiple textbases
When you design a query screen for use on the Web with WebPublisher, you can specify more
than one textbase to be searched from the query screen. For more information, see Query
Screens: Overview.
1. Open the textbase you want as a lead textbase. In the Query Screen Designer, choose
Tools>WebPublisher Multiple Textbase Query to view the WebPublisher Multiple
Textbase Query dialog box.
Note: The textbase chosen as the lead textbase is typically the one that has fields you
want to search but do not want to explicitly map to other textbases. It may also have
secondary fields you want to search, or be the textbase with the index you want
displayed in a Choices Browser. A Choices Browser can only be used to show the index
for the lead textbase.
2. Select the Lead Textbase for WebPublisher Multiple Textbase Query check box to
specify the textbase you have open as the lead textbase.
3. Add the textbases you want searched from the query screen. Click Add and choose a
textbase from the Open Inmagic DB/TextWorks Textbase dialog box. Do this for each
textbase you want to search from your query screen. The textbases will appear in the
Textbases to Search list. Note the following:
Textbases must have different names. For example, you could not add three
textbases named Catalog, but could use all three if you rename them Catalog1,
Catalog2, and Catalog3.
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Search textbases must either have no passwords assigned to them, or a Silent
password that provides the level of access you want. Note that the lead textbase
can have a password assigned. However, if the lead textbase has a password and
you add a password box to the query screen, the password only applies to the lead
textbase.
To remove a textbase from the query screen, select it from the Textbases to Search
list and click the Remove button.
Records found through multiple-textbase searches are displayed by textbase.
Records retrieved from the lead textbase will be displayed first, followed by records
from the next textbase added, then records from the third textbase, and so on.
4. Specify how search results will be displayed for each textbase when a query is
processed through this HTML query screen. Select a textbase in the Textbases to
Search list, then click:
Initial Report Form to access the Select Report Form dialog box to specify which
Report form to use when the user retrieves records. The selected form will be used
every time a new query is submitted. Click OK when done.
Initial Display Form to access the Select Record Display dialog box to specify
which Display form to use when the user expands a record in the browser. This
form determines the appearance of single-record display. Click OK when done.
Do this for each search textbase. Note that you specify the forms for the lead textbase on
the HTML tab by choosing Tools>Screen Properties>HTML. Note that you do not have
to specify an initial edit form, as you cannot edit records over the Web when searching
multiple textbases.
Note: If you do not specify initial forms, the textbase default forms will be used (if they
were saved as Web forms). If the textbase default forms are not saved as Web forms,
and no form is selected at export time, a Basic form will be generated automatically,
showing all non-hidden primary textbase fields, with minimal formatting.
Important! Do not mix tabular forms and non-tabular forms in a single multiple-textbase
report.
Records from each textbase will be displayed in the form designated for that particular
textbase. Some form attributes behave differently when used in a multiple-textbase
query. See Web Multiple Textbase Query Reports for more information.
5. Click Create Field Name Map to open the Create Field Name Map dialog box and
specify which fields will be searched in each textbase when a user submits a query.
When done with this dialog box, click OK to return to the WebPublisher Multiple
Textbase Query dialog box.
6. Click OK on the WebPublisher Multiple Textbase Query dialog box when done.
7. Choose Screen Operations>Save Query Screen As and name your query screen.
Note: You must also save your query screen as public by selecting the Textbase File
(Public) option button on the Save Query Screen As dialog box, before you can export it
to HTML.
8. Export the query screen to HTML by choosing Screen Operations>Export Query
Screen to HTML. Name the query screen file, and designate a location for it anywhere
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that is accessible to the HTTP server. Click Save in the Save File As dialog box when
done.

Browsing Indexes on the Web
When designing a Web query screen, you can make the indexes available with a Choices
Browser or a choices drop-down list, by using the HTML tab of the Query Box Properties dialog
box. Note that you can use both methods on the same search screen.
A box without a Choices Browser or drop-down list can still be searched. However, users cannot
see a list of available choices, so they may not know what to search for.
To see the Choices Browser or drop-down list in use, export the query screen to HTML and
view it on the Web.
Choices Browser
A Choices Browser:
Displays indexed information from the textbase.
Is intended for boxes containing one or more fields.
Is a Web application, which requires .NET.
Lets you specify whether the browser is accessed with a button or link on the query
page. If using a button, you can specify button text.
Is attached to a regular searchable box, so users can type or paste multiple search
criteria. For example, users can type search criteria and paste items from the indexes.
Lets users toggle between the Term and Word indexes.
Lets users select which field to browse, for boxes that search multiple fields.
Does not require the query screen to be re-exported if you add a Word or Term index for
a field, or if you remove an index.
Requires that a valid password be entered to view the index, if the textbase has
passwords.
Choices Drop-down List
A choices drop-down list:
Is intended for a query box containing only one field which is term indexed. The field
should contain a short list of items that does not change (for example, a field called
State/Province that contains a list of states and provinces in the United States and
Canada).
Displays a static list of choices, generated when the query screen is exported to HTML.
The list is saved as part of the HTML file. If the index changes (if you edit that field in the
textbase), the query screen must be re-exported to HTML (or the HTML file be manually
edited).
Shows entries from the Term index. If there is no Term index, the drop-down list shows
entries from the Word index. It does not allow users to toggle between the Term and
Word indexes (if both exist).
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Shows entries only from the first field in the box, if the box searches multiple fields. Field
order within a box has no effect on search results, so you can freely re-order fields using
Tools>Box Properties>Fields in the Query Screen Designer.
Allows users to select only one item.
Does not allow users to type in the box.
Lets users leave a box empty (for example, not specify search criteria) if they select the
blank line from the top of the drop-down list.
Has a default of unlimited entries. If you choose to limit, the default is 1,000 and the
maximum is 65,000 (However, we recommend you use a choices drop-down list for
fields with fewer entries.)

HTML Query Box Properties (Query Screens): HTML tab
Use the HTML tab on the Query Box Properties dialog box when designing a query screen to be
exported to HTML for use on the Web with WebPublisher PRO. You can allow users to browse
field indexes for a particular query box (with the Choices Browser or choices drop-down list) or
make the query box a password box.
To add HTML properties to a query box
1. In the Query Screen Designer, select a query box and choose Tools>Box Properties.
2. On the HTML tab of the Query Box Properties dialog box, check Treat query box as.
Note: By default, this check box is cleared, so users will not see a Choices Browser or
choices drop-down list, nor will they be able to enter a password in the box. However,
users can still search the field on the Web by typing a word, phrase, or term.
3. Select one of the following buttons:
Index box, use. Select this button to include a Choices browser, so users will be able to
browse indexes on the Web. (Your selection will not appear until the query screen is
exported to HTML and viewed over the Web.) Then select one of the following options
from the drop-down list to specify how the user will access the choices:
Choices Browser (button). Displays a Browse Choices button in the Web
browser (to the right of the query box) that, when clicked, opens the Inmagic
Choices Browser. The user can paste terms or words from the index into the
search box, switch fields, and so forth. Note: For more information, se
Choices Browser (link). Turns the query box label into a hypertext link in the
Web browser that, when clicked, opens the Inmagic Choices Browser. The user
can paste terms or words from the index into the search box, switch fields, and
so forth.
Choices drop-down list. Adds a drop-down list to the selected box when the
query screen is exported to HTML. When a user clicks the down arrow on the
drop-down list, a list of indexed terms will appear. (If there is no term index, they
will see a list of words.) The user can select an item from the list and search for
that item.
Drop-down lists are most often used with boxes that search fields that contain
short (for example, less than 200 items) and unchanging lists. For example, you
may want to use a choices drop-down list with a field called Size that contains
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the entries Large, Medium, and Small. A drop-down list is typically not used with
lengthy field entries or fields having many different entries.
If you selected Choices Browser (button or link), you can check Show terms by
default if you want the Choices Browser to show terms instead of words initially.
If you selected Choices drop-down list, you can check the Restrict number of
entries box, then type the maximum number of entries that you want to appear in
the list. This provides a way of limiting the list for a field that contains many
entries. For example, if you specify 20 for a field containing names, only the first
20 names in the index will be listed. The default value is 1,000. For best
performance, we recommend you accept the default or specify a lower number.
Password box. Select this button to turn the selected query box into a password box. A
user may enter a password in the box before clicking the Submit Query button. (They
may also need to enter a password before opening the Inmagic Choices Browser or
clicking a New record link on the query screen.) The password can restrict access to the
textbase entirely, to specific fields, or to specific records. Note that if the textbase has
passwords, but has no Silent password, the user must specify a password to access the
textbase.

Choices Browser Illustration
The Inmagic Choices Browser allows users to select an entry from a list when browsing indexes
on a Web query page or when browsing validation lists on a Web edit page. Note that the
appearance of the Inmagic Choices Browser varies, depending on whether you are searching or
editing. The entry you select can be pasted into a query box or edit box, as appropriate.
The designer of the Web query page can specify that the Inmagic Choices Browser be
accessed by a link or a button. On an edit page, the Inmagic Choices Browser can only be
accessed by a link.
This image shows the Inmagic Choices Browser for browsing indexes on a Web query page:

This image shows the Inmagic Choices Browser for browsing validation lists on a Web edit page:
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This image shows the Inmagic Choices Browser for browsing a thesaurus used as a
validation list on a Web edit page:

Choices Drop-down List Illustration
Here is a picture of a Web search screen with a choices drop-down list. Drop-down lists are
appropriate for boxes that search fields that contain short, unchanging lists (for example, 2 to 15
items), such as a field called Size that contains the entries Large, Medium, and Small. A dropdown list is not intended to be used with lengthy field entries or fields having many different
entries.
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Launching Applications (WebPublisher PRO)
If you are publishing textbases on an intranet, you can use WebPublisher PRO to help you
launch other applications, such as a video clip or a spreadsheet or word processing program,
from within a form, query screen, or menu screen. You do this by including the name of the file
you want to open in a field in the textbase, or as fixed text in a text box on a query or menu
screen.
When the user clicks the file name or other text that you supply, the application associated with
that file is launched to open the file. The file extension (defined in the Windows Registry or
browser preferences) dictates what application is used.
In general, you should provide links which launch applications only across an intranet where you
know the users have access to the software and hardware needed to run the application(s)
associated with the referenced files.
Important! All intranet users will have access to the files (documents, spreadsheets, and so
forth) to which you provide a link. If you do not want users to be able to edit files, place the files
in a read-only folder or link to .PDF files.
Be sure that the target file is set up properly on the server to be accessible to all users. One of
the following conditions must be true:
The end user is capable of opening the target file using the associated application
software from his or her desktop using network file access protocols, OR
The end user is capable of running the associated application, and can access the target
file using HTTP addressing protocols.
In the first case, it is advisable to use the UNC filename to specify the file path, to avoid conflicts
over logical drive mappings. Place the file information in a box on the form or screen, and select
the HTML tab on the Box Properties dialog box. Select HTML file reference from the Treat text
as or Treat content item as drop-down list (as applicable). If you want to show alternate text
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instead of the file name, select the Use alternate link text check box and type in the text you
wish to substitute. Example:
file name:

\\server\vol1\docs\myfile.doc

alternate text:

Click here

result in report:

<a href="file:////server/vol1/docs/myfile.doc">Click here</a>

In the second case, use an HTTP-formatted path specification.
For example, on a query screen, menu screen, or form, add a text box that contains this text:
http://test/myfile.doc

On the Text Box Properties dialog box, select the HTML tab and select URL from the Treat text
as drop-down list. To specify alternate text for the link on the screen, select the Use alternate
link text check box, then type the text you want in the Text box below it (for example, type Click
here).
file name:

http://test/myfile.doc

alternate text

Click here

result in report:

<a href="http://test/myfile.doc">Click here</a>

If you use an HTTP-formatted path specification on a form, you can create the link with a form
box instead of with a text box. Add a form box and specify the field content or another content
item (for example, Fixed Text) whose content you want to use as the link. On the Form Box
Properties dialog box, select the HTML tab and select URL from the Treat content item as
drop-down list. To specify alternate text for the link on the screen, select the Use alternate link
text check box, then type the text you want in the Text box below it (for example, type Click
here).

Using Command Queries on the Web
You can use the QY parameter to specify WebPublisher PRO search criteria in Command
Query format.
This feature permits users to do searches using fields that do not appear on the query screen,
and to do that are not possible using a query screen, such as complicated nested Booleans or
searches using set names.
You must use the QY parameter for queries submitted using XML input.
You can use this option to make creating canned queries simpler, instead of including all the
QB0/QF0/QI0 parameters.
Examples
<a href="/dbtw-wpd/exec/dbtwpub.dll?QY=find+name+ct+ford&MR=10&
TN=Cars&DF=Images+and+Text&RF=Prices&DL=1&RL=1&EL=1&NP=3&AC=QBE_QUERY">QY
Example</a>

Or, you can permit your end users to enter Command Queries using the Web. For example, you
could replace the query boxes with the following:
<b>Command Query:</b><br>
<input type="text" name="QY" size="82"><p>
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Because users type Command Queries (for example, features ct glass) in this box, they will
need to know field names and, if they want to do word, phrase, or proximity searches, how to
use CT.
Note: You cannot have Command Query boxes (QY) and normal query boxes (QB0/QI0/QF0)
on the same query screen.

Exporting Query Screens to HTML
Before you can use a query screen on the Web, you must export it to HTML.
To export a query screen to HTML.
1. In the Query Screen Designer, open the query screen you designed for use on the Web.
2. Choose Screen Operations>Export Query Screen to HTML.
3. A message box appears asking if you want to use Cascading Style Sheets (CSS) to
preserve formatting. Click Yes to preserve formatting (such as, box position and box
background color); click No if you want WebPublisher PRO to use simple HTML to
format the screen (for example, all boxes will appear left-justified).
4. A message box appears asking if you want to use Alternate Search Syntax in this query
screen. Click Yes to enable users to type the words they want to find without Boolean
AND symbols (&). Click No if you want to use the original WebPublisher PRO query
syntax.
5. On the Save File As dialog box, name the file when prompted and click Save.
6. Click OK to dismiss the completion message.
Notes about Exporting Query Screens to HTML
Buttons labeled Submit Query and Reset, and a Help icon are added automatically
during the export.
Sets boxes, script input boxes, and script buttons added in the Query Screen Designer
are not exported.
Tab Order specified in the Query Screen Designer is preserved during the export.
You can put the resulting HTML page anywhere accessible to the HTTP server. Be sure
to provide clients with a way to access the page, for example by providing a link on your
home page that jumps to the HTML search page.

WebPublisher PRO Help Files in HTML Format
WebPublisher PRO includes several HTML pages that describe how to perform a query and
display results. The pages are intended primarily for clients, but are also helpful to the textbase
designer and Webmaster.
WEB_BEGIN.HTM. Explains how to perform a query and display results. Clients can
access this page by clicking the Help icon on an HTML query screen in the Web
browser.
WEB_MSG.HTM. An alphabetical list of error messages. Intended primarily for
administrators, although you may allow client access. Clients can access this page from
links provided on the previous two pages.
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WEB_ICHOICES.HTM. Explains how to use the Inmagic Choices Browser window when
browsing validation lists on a Web edit screen. Clients can access this page by clicking
the Help button on the Inmagic Choices Browser window.
You are free to edit the help pages, with the following caveats:
WEB_BEGIN.HTM includes links to other pages.
HTML query screens include a Help icon that points to WEB_BEGIN.HTM. Do not move
or rename WEB_BEGIN.HTM.
The Inmagic Choices Browser window contains a Help button that points to
WEB_ICHOICES.HTM. Do not move or rename WEB_ICHOICES.HTM.
Edits you make will apply universally to HTML query screens on the server unless you
copy and rename the help files or move them to a different location. If you copy or move
pages, edit the HTML query screen source to point to the correct destination.
After making changes, check all links in a browser to make sure everything works as you
intended.

HTML Query Screen Properties
HTML Query Screen Properties
A query screen designed for Web use can include the properties listed below. These properties
only affect query screens exported to HTML for use on the Web with WebPublisher PRO. They
are ignored for query screens used on the desktop. To specify these properties, choose
Tools>Screen Properties in the Query Screen Designer and select the Logos and HTML tabs.
After specifying the desired properties, click the OK button.
Logos tab
Leading/Trailing Logo. Add a logo or other image to the top or bottom of a query
screen. Tip! You can also use picture boxes to add images to query screens.
HTML tab
Show Boolean operators. Show or hide a Boolean drop-down list (AND, OR, NOT) for
searchable boxes.
Use background image. Specify an image file for the page background. Tip! You can
also use Background color on the General tab to specify a page background color.
Initial Report Form. Specify which Report form to use when the user retrieves records.
The selected form will be used every time a new query is submitted.
Initial Display Form. Specify which Display form to use when the user expands a
record in the browser. This form determines the appearance of single-record display.
Initial Edit Form. Specify which Edit form to use when the user adds, edits, or deletes a
record in the browser. Note that editing over the Web requires WebPublisher PRO.
Show form list on report page. Specify whether drop-down lists will appear in reports.
Show form list on display page. Specify whether drop-down lists will appear in an
expanded display page.
Show form list on edit page. Specify whether drop-down lists will appear on edit
screens. Note that editing over the Web requires WebPublisher PRO.
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Records per page. Limit the number of records displayed at one time, and specify
where the navigation buttons appear.
Navigational controls. Specify whether navigational buttons and form drop-down lists
appear on reports, expanded display pages, and edit screens and where on the page
they are placed.

HTML Query Screen Properties: Logos tab
Choose Tools>Screen Properties in the Query Screen Designer and select the Logos tab if
you want to include an image, such as a logo, at the top and/or bottom of an HTML query
screen to be used on the Web. The images will only appear in the exported HTML page for
WebPublisher PRO. They are ignored for query screens used on the desktop.
Leading Logo. In the Leading Logo box, type the file name, including extension, of the
image file to display at the top of the query screen. You can also use the Browse button
to find the location of the image you want to use. For example, type NEWLOGO.JPG.
Trailing Logo. In the Trailing Logo box, type the file name, including extension, of the
image file to display at the bottom of the query screen. You can also use the Browse
button to find the location of the image you want to use. For example, type
MYLOGO.GIF.
WebPublisher PRO expects to find the logos in /DBTW-WPD/IMAGES (the HTTP equivalent to
C:\PROGRAM FILES\INMAGIC\WEBPUB\IMAGES). For example, if you type MYLOGO.GIF in
this dialog box, a URL such as this one might be used:
http://www.inmagic.com/dbtw-wpd/images/mylogo.gif

If your logos are stored in a different location (that is, not /DBTW-WPD/IMAGES), you must type
a path that includes a forward slash (/) in the Leading Logo and/or Trailing Logo box. Here
are some examples:
http://www.myco.com/logos/mylogo.gif
/jones/mrs.gif
pictures/me.gif

A logo or image location that starts with a forward slash is relative to the server root. A location
without a leading "http://host" or "/" is relative to the location of the query screen.

Query Screen Properties: HTML tab
Choose Tools>Screen Properties in the Query Screen Designer and select the HTML tab if
you want to specify the following properties for an HTML query screen to be used on the Web.
These properties are only for query screens that will be used on the Web with WebPublisher
PRO.
Query page group
Show Boolean operators. Select this check box to specify that DB/TextWorks display
Boolean drop-down lists (AND, OR, NOT) associated with each query box when a query
screen is exported to HTML.
Use background image. Select this check box to display a static image to use as the
query screen background.
Note: You can also specify a query screen background color (choose Tools>Screen
Properties>General).
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Form settings group
Initial Report/Display/Edit Form. Click these buttons to specify which forms should be
used initially in the Web browser, when a query is processed through this HTML query
screen. If you do not specify initial forms, the textbase default forms will be used (if they
were saved as Web forms by selecting the Web check box on the Save Form As dialog
box). If the textbase default forms are not saved as Web forms, and no form is selected
at export time, a Basic form will be generated automatically, showing all non-hidden
primary textbase fields, with minimal formatting.
Show form list on report page. This option determines whether users will be able to
change report forms in the Web browser. If you select this check box, the form dropdown list will appear in the Web browser.
Show form list on display page. Check this box box if you want users to be able to
change expanded display forms in the Web browser. An expanded display form shows
detailed information about one record at a time.
Show form list on edit page. This option determines whether users will be able to
change edit forms in the Web browser. Note that editing over the Web requires
WebPublisher PRO. An edit form lets users add a new record or modify or delete an
existing one. When you save the form, specify that it can be used for the Edit Window
and the Web, and that it should be saved in the Textbase File (Public).
Records per page. Use this option to specify the maximum number of records to be
displayed on each page, so records meeting search criteria can be viewed in batches.
Navigational controls. Specify whether you want navigation buttons and form dropdown lists to appear on the top of the page, the bottom of the page, or both. The
navigation buttons will appear in the Web browser on the page of records found after
users do a search. Tip! If this option is grayed out, type a number in the Records per
page box (type over the word "unlimited") and click OK.

HTML Query Screen Properties: Show Boolean Operators (HTML tab)
Use this HTML property when designing a query screen for use on the Web with WebPublisher
PRO, to show or hide Boolean drop-down lists.
When a query screen is exported to HTML, the Boolean operator (AND, OR, NOT) associated
with each box is used in the HTML query screen.
If you want Web users to be able to change the Boolean operator, select the Show Boolean
operators check box. Selecting this check box causes a Boolean drop-down list (AND, OR,
NOT) to be added for all query boxes on the HTML query screen. This gives a user the ability
to specify how to combine search criteria in multiple boxes. The Boolean operator selected for a
box determines how the search criteria in that box will be combined with criteria already
evaluated.
Note: This option affects Web use only, and is implemented when the query screen is exported
to HTML. To control Boolean operators for the desktop, use Tools>Screen
Properties>General. Because there are separate controls for desktop and Web use, the same
query screen can have Boolean controls when used on the desktop and not on the Web, and
vice versa.
Deciding on Boolean Operators

312

Inmagic DB/TextWorks v13 Printed Help

WebPublisher PRO
As a general rule, set all boxes to the same Boolean operator (AND or OR). If you decide to
show Boolean operators, Internet/intranet users can change the Boolean operator at search
time. For example, the user may decide to set a box to NOT, to exclude certain records.
OR searches find records if any of the criteria are met. This generally results in more records
being found. For example, the following search finds information about any college OR about
New York:
OR School college
OR State new york
AND searches find records only if all of the criteria are met. This generally results in fewer
records found. For example, the following search finds colleges located in New York:
AND School college
AND State new york

HTML Query Screen Properties: Use Background Image (HTML tab)
Use this HTML property when designing a query screen for use on the Web with WebPublisher
PRO.
Select the Use background image check box to specify an image as the page background.
You can use the Browse button to find the location of the image you want to use. Most Web
browsers handle GIF and JPEG files only. Select another file type only if you are sure that all of
your users can view that image type. For example, if you are publishing on an intranet,
everyone in your company may have a plug-in that can display TIFF files.
WebPublisher PRO expects to find the background image file in /DBTW-WPD/IMAGES (the
HTTP equivalent to C:\PROGRAM FILES\INMAGIC\WEBPUB\IMAGES). For example, if you
type MYLOGO.GIF in this dialog, a URL such as this one might be used:
http://mydomain.com/dbtw-wpd/images/mylogo.gif

Note: The SQL platform uses a the ics-wpd directory instead of dbtw-wpd.
To specify a different location, type a path that includes a forward slash (/) in the Image file box.
Here are some examples:
http://www.myco.com/logos/mylogo.gif
/jones/mrs.gif
pictures/me.gif

A location that starts with a forward slash is relative to the server root. A location without a
leading "http://host" or "/" is relative to the location of the query.
Note: You can also use Tools>Screen Properties>General to specify a page background
color for query screens.
Using images and background color
If you are using a background image that is transparent, you can also specify a background
color for the query screen and have both appear. Background colors on a form or screen are
transparent.
Note, however, that if you specify color for the background of boxes on the screen, you will not
be able to see the page background image where the boxes are located. This is because box
background colors are not transparent.
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HTML Query Screen Properties: Records per page (HTML tab)
Select these HTML properties when designing a query screen for use on the Web with
WebPublisher PRO.
Records per page. Type the maximum number of records you want displayed on one
report page after a search, or select unlimited from the drop-down list. Limiting the
number of records displayed per page lets users view the records matching their search
criteria in batches. This option controls how many records can be displayed at one time.
It does not restrict the number of records that can be retrieved.
Note: In addition to setting the maximum number of records per report page, you can
limit the number of records displayed in total after a search. To do this, add the
TotalRecords= parameter to the [WebPublisher] section of the DBTWPub.INI file (or the
[Web] section of the ICSWeb.INI file, if you are using the SQL platform).
Navigational controls. Specify whether you want the Next and Previous buttons to
appear on the top of the page, the bottom of the page, or both. The buttons appear in
the Web browser on the page of records found after users do a search. This setting also
controls the location of form drop-down lists, the Back (<) and Rewind (<<) buttons, the
optional New search button, and, if you have specified that expanded display pages
open in a separate window, the optional Close button.

HTML Query Box and Text Box Properties
HTML Query Box Properties (Query Screens): HTML tab
Use the HTML tab on the Query Box Properties dialog box when designing a query screen to be
exported to HTML for use on the Web with WebPublisher PRO. You can allow users to browse
field indexes for a particular query box (with the Choices Browser or choices drop-down list) or
make the query box a password box.
To add HTML properties to a query box
1. In the Query Screen Designer, select a query box and choose Tools>Box Properties.
2. On the HTML tab of the Query Box Properties dialog box, check Treat query box as.
Note: By default, this check box is cleared, so users will not see a Choices Browser or
choices drop-down list, nor will they be able to enter a password in the box. However,
users can still search the field on the Web by typing a word, phrase, or term.
3. Select one of the following buttons:
Index box, use. Select this button to include a Choices browser, so users will be able to
browse indexes on the Web. (Your selection will not appear until the query screen is
exported to HTML and viewed over the Web.) Then select one of the following options
from the drop-down list to specify how the user will access the choices:
Choices Browser (button). Displays a Browse Choices button in the Web
browser (to the right of the query box) that, when clicked, opens the Inmagic
Choices Browser. The user can paste terms or words from the index into the
search box, switch fields, and so forth. Note: For more information, se
Choices Browser (link). Turns the query box label into a hypertext link in
the Web browser that, when clicked, opens the Inmagic Choices Browser.
The user can paste terms or words from the index into the search box,
switch fields, and so forth.
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Choices drop-down list. Adds a drop-down list to the selected box when
the query screen is exported to HTML. When a user clicks the down arrow
on the drop-down list, a list of indexed terms will appear. (If there is no term
index, they will see a list of words.) The user can select an item from the list
and search for that item.
Drop-down lists are most often used with boxes that search fields that
contain short (for example, less than 200 items) and unchanging lists. For
example, you may want to use a choices drop-down list with a field called
Size that contains the entries Large, Medium, and Small. A drop-down list
is typically not used with lengthy field entries or fields having many different
entries.
If you selected Choices Browser (button or link), you can check Show terms by
default if you want the Choices Browser to show terms instead of words initially.
If you selected Choices drop-down list, you can check the Restrict number of
entries box, then type the maximum number of entries that you want to appear in
the list. This provides a way of limiting the list for a field that contains many entries.
For example, if you specify 20 for a field containing names, only the first 20 names
in the index will be listed. The default value is 1,000. For best performance, we
recommend you accept the default or specify a lower number.
Password box. Select this button to turn the selected query box into a password box. A
user may enter a password in the box before clicking the Submit Query button. (They
may also need to enter a password before opening the Inmagic Choices Browser or
clicking a New record link on the query screen.) The password can restrict access to the
textbase entirely, to specific fields, or to specific records. Note that if the textbase has
passwords, but has no Silent password, the user must specify a password to access the
textbase.

HTML Text Box Properties (Query Screens): HTML tab
When designing a query screen for use on the Web with WebPublisher PRO, use the Treat text
as drop-down list to determine whether and how text box content will be interpreted as HTML.
You can specify whether text acts as a link, launches an application, or opens a Web edit
screen to add records to the textbase.
To specify HTML properties for a text box on a query screen
1. Select a text box and choose Tools>Box Properties to open the Text Box Properties
dialog box.
2. On the HTML tab, select an option from the Treat text as drop-down list, then click
Apply.
Do not alter. Use this option for boxes that contain information that you do not want
to be interpreted as HTML by the client's Web browser, such as titles and
instructions. The text will appear in the browser exactly as it appears in the text box.
The Web browser will not attempt to interpret any characters as HTML tag
delimiters.
Raw HTML. Use this option when the selected text box contains HTML that you
want passed through to the user's Web browser. When the HTML query screen is
used on the Web, the Web browser will attempt to interpret the text in that box as
HTML. For example, if you add a text box that contains this text:
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<a href="myquery.htm" target="_blank>Click here to search.</a>

the Web user will see the following text in the browser: Click here to search.
Clicking the text will bring up the specified query screen (MYQUERY.HTM) in a new
browser window.
URL. Use this option for a text box containing a single URL. The software will add
the necessary HTML tags to turn this into a link. The URL appears as the text as
well as the target of the link, by default. For example: http://www.inmagic.com
becomes:
<a href="http://www.inmagic.com">http://www.inmagic.com</a>

If you want to use different text for the link use alternate text.
E-mail link. Use this option if a text box contains an e-mail address and you want it
turned into a "mailto" link. The text appears as the text as well as the target of the
link, by default. For example: Inmagic@Inmagic.com becomes:
<a href="mailto:Inmagic@Inmagic.com">Inmagic@Inmagic.com</a>

If you want to use different text for the link, use alternate text.
HTML file reference. Use this option to enable users to launch applications on a
suitably configured intranet. Select a text box that contains a file URL and select
HTML file reference from the drop-down list. The text in the selected box will
appear in the Web browser as a hypertext link. When the intranet user clicks the
link, the application associated with the file (by means of the Windows Registry or
browser preferences) will be launched and the file will be opened. For example, if
you add a text box that contains this text:
\\server\vol1\public\tutorial.avi
that text will appear as a link in the browser, and clicking the text will run the video
clip. If you want to use different text for the link use alternate text.
New record link. Use this option to make the text appear on the Web as a link that,
when clicked, opens an editing screen so users can add a new record. The New
record link will use the Initial Edit Form specified for the query screen (choose
Tool>Screen Properties>HTML), or the textbase default edit form if no Initial Edit
Form is specified and the textbase default is a Web edit form. If the textbase default
is not a Web edit form, then a Basic form will be used. Note that this option requires
WebPublisher PRO.

WebPublisher PRO Menu Screens
If you have WebPublisher PRO, you can create menu screens and export them to HTML to use
on the Web. Menu screens used on the Web are quite different than menu screens used within
DB/TextWorks. Each menu screen for the Web contains predefined searches. When the page is
displayed in a Web browser, the searches look like regular links. When the user clicks a link, a
query is performed and records are displayed in the Web browser.

Guidelines for Using Menu Screens on the Web
Create menu screens for the Web when you want to set up frequently performed queries for
your users, so they don't have to specify query criteria.

316

Inmagic DB/TextWorks v13 Printed Help

WebPublisher PRO
A menu screen can include a hypertext link to an HTML search page that you have designed.
In the Menu Screen Designer, use a text box to provide the link. To make sure the text is
interpreted as HTML, choose the following options in the Menu Screen Designer: Select a text
box, choose Tools>Box Properties>HTML. From the Treat text as drop-down list, select URL,
then specify alternate link text.
If you have too many queries to fit on one screen, you can design a Web page that includes a
number of jumps to a number of different menu screens.
You can use a menu screen as a Web page all by itself, or you can add surrounding HTML text.
For example, one link on the page could run a predefined query. Other links could be standard
hypertext links to static HTML pages.
To add a predefined search to a Web page that was created outside of DB/TextWorks, design a
standard page, perhaps using HTML-authoring software. Then use DB/TextWorks to create a
menu screen that consists of the search(es) that you want to add to the Web page. Export the
menu screen to HTML, then use any text editor to copy the appropriate lines from the HTML
menu screen file to the HTML Web page file. You can omit the <title> information.

Instructions
A menu screen created for Web use typically includes a title, some explanatory text, a logo, and
a list of predefined searches (textbase boxes with initial actions). It may also specify which
Report form, Expanded Display form, and Edit form to use by default with each search (initial
elements). You export the menu screen to HTML, then place the HTML page on the server.
1. Create the saved sets.
To specify a predefined search, you use DB/TextWorks to perform a query and save it as a set.
Start the software, open a textbase, and create one or more saved sets. To create a set,
perform a query, choose Search>Save Set, name the query, and save it as Textbase File
(Public). For example, search for Child* & Shoe* then save the set as Children's Shoes. Repeat
to create additional saved queries. These are the predefined queries that you will "attach" to an
item on the menu screen.
2. Open the Menu Screen Designer.
If a textbase is open, close it (choose File>Close). Then choose Menu Screens>Design. On
the Open Menu Screen dialog box, select an option button to specify how you want to begin:
Open Current Menu Screen File. Open the currently selected menu screen file (.TBM).
Create a New Menu Screen File. Start with a blank menu screen, to which you can add
boxes that hold textbase names and descriptive text. When prompted, specify a name
and location for the new menu screen file. The extension . TBM is added automatically.
Open an Existing Menu Screen File. Select a previously saved menu file (.TBM),
which you can edit and save, or save under a new name.
Click OK to open the Menu Screen Designer.
3. [Optional] Add titles and other text.
To add text such as a title or brief instructions, choose Edit>Add>Text Box. Using the Text Box
Properties dialog box, specify the text on the Text tab. For example, type Welcome to the
Bayside Kids Catalog! Position and size the box with the mouse, or use the Position tab.
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4. Specify saved queries and initial forms for displaying results.
In this step, you will specify which textbase to open, which saved query to use, and which forms
to use initially in the browser to display search results. A saved query is always associated with
a particular textbase. In the Menu Screen Designer, choose Edit>Add>Textbase Box to add a
textbase box and open the Textbase Box Properties dialog box. Use the tabs on the dialog box
to specify the options you want. Note that not all of the options available on the tabs of the
Textbase Box Properties dialog box are applicable to menu screens used on the Web.
Contents tab. Click the Specify Textbase button and select the textbase to search (for
example, CATALOG. TBA). In the Description box, type the text that users can click to
initiate the search (for example, Children's Shoes).
Position tab. Only the Top offset setting applies to menu screens exported to HTML for
use on the Web. All other settings on this tab are ignored.
Font, Color tab. The settings on this tab do not apply to textbase boxes on menu
screens exported to HTML for use on the Web. While you can format font style, size and
color for text boxes, the text in a textbase box appears as a standard Web link, created
automatically by the software.
Icon tab. The settings on this tab do not apply to menu screens exported to HTML for
use on the Web. Icons (.BMP files) do not translate to the Web.
Initial Elements tab. Select a Report form, Record Display form (for expanded display),
and a Record Edit form. These forms will be used initially to display and modify records
found by the search. If you do not specify these elements, the textbase default forms will
be used (if they were saved for use on the Web). All other initial elements are ignored for
a menu screen used on the Web.
Initial Action tab. Specify a saved query that will be performed, by selecting one of the
queries that you saved in step 1. All other initial actions do not apply to menu screens
used on the Web.
Repeat this step for each search that you want to list on the menu.
5. Specify HTML settings.
Choose Tools>Screen Properties>General, Tools>Screen Properties>Logos,
Tools>Screen Properties>HTML and/or Tools>Box Properties>HTML and specify the
settings listed below. These settings only affect menu screens exported to HTML for use on the
Web. They are ignored for menu screens used on the desktop.
Logos (Tools>Screen Properties>Logos). A menu screen can include a logo or other
graphic at the top and/or bottom of the page.
Background image. Use an image file for the page background.
Background Color. Specify a color to use as the page background.
Show form list on report page. This option determines whether users will be able to
change report forms in the Web browser. If you select this box, the form drop-down list
will appear in the Web browser.
Show form list on display page. Select this check box if you want users to be able to
change expanded display forms in the Web browser. An expanded display form shows
detailed information about one record at a time.
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Show form list on edit page. Select this check box if you want users to be able to
change edit forms in the Web browser.
Records per page (Tools>Screen Properties>HTML). You can limit the number of
records displayed on one page after a search, so records meeting search criteria can be
viewed in batches. Also, you can specify the location of the navigation controls.
HTML Box Properties (Tools>Box Properties>HTML). You can specify whether text in
a text box on the menu screen is interpreted as a URL or HTML. The most common use
is to create a hypertext link to another Web page.
6. Adjust menu screen appearance.
Continue editing the menu screen by moving, resizing, and changing the attributes of boxes.
Here are some guidelines:
You must select a box in order to make changes to it.
Use the Edit menu to add, copy, paste, and delete boxes.
Use the Tools menu to change the attributes of the selected box and specify menu
preferences.
You may prefer to do most of the editing in an HTML editor after exporting the menu screen to
HTML, because some DB/TextWorks features do not get exported to HTML.
7. Save the menu screen.
Choose Menu Operations>Save Menu Screen.
8. Export the menu screen to HTML.
The menu screen that you want to export should be open in the Menu Screen Designer. Choose
Menu Operations>Export Menu Screen to HTML. When prompted, name the file and click
OK. Use the default extension .HTM, or .HTML if you prefer.
The only items that are exported are text boxes, picture boxes, and textbase boxes whose initial
action is a Saved Query (choose Tools>Box Properties>Initial Action). The export process
ignores any textbase box that does not have a Saved Query specified as the initial action, and
ignores icons.
9. Give users a way to access the menu screen.
Put the HTML file in any location accessible to the HTTP server.
Give Internet/intranet users a way to access the menu screen. For example, include a jump to it
from some other page on your Web site.
If you are using the menu screen "as is," place the HTML page on the server wherever you
keep HTML pages.

WebPublisher PRO: Menu Screen Design Tips
If you have WebPublisher PRO, you can publish textbases on the Web, and use menu screens
to provide a way to access those textbases. Here are some tips to help you design menu
screens for Internet/intranet use:
Use compatible versions of DB/TextWorks and WebPublisher.
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Consider adding explanatory text to a menu screen (use a text box) to describe the
textbase or your organization. If you have a great deal to say, include a link to another
Web page that you author. If you want to give users the ability to specify their own
queries, include a link to an HTML query screen.
Consider adding a title (use a text box) and logos or other graphics (choose
Tools>Screen Properties>Logos). The size of the graphic is determined by the
application used to generate the image. The position of the graphic is flush left on the
page. To change the position, edit the exported HTML file.
If you are publishing multiple textbases, a page on your Web site can include a list of the
textbases, with each item being a jump to a separate menu screen. Each menu screen
can then include a number of predefined queries. Even if you publish only one textbase,
a Web page can jump users to their choice of menu screens and/or query screens.
The Web browser ignores the position settings (choose Tools>Box
Properties>Position), except for Top offset. Set the Top offset to zero (0) to avoid
excess space between boxes.
Menu screens that contain side-by-side boxes will export to HTML successfully, but the
boxes will appear in a list, rather than side by side.
The Web browser controls typeface, font style, size, and hypertext link color for textbase
boxes that are exported to HTML. However, you can control font color, style, and size for
text boxes.
After exporting a menu screen to HTML, you can modify the HTML to add text and
images and perform other editing.
When you export to HTML, the Report Form, Display Form, and Edit Form are the only
initial elements that are used. All other initial elements (printing form, query screen,
record skeleton) are ignored.
When you export to HTML, the only items that are exported are text boxes, picture
boxes, and textbase boxes that have a Saved Query specified as the initial action
(choose Tools>Box Properties>Initial Action). The export process ignores any
textbase box that does not have Saved Query specified as the Initial Action. Icons
(.BMP files) are also ignored.

Differences between Menu Screens for DB/TextWorks and WebPublisher PRO
Menu screens designed for use with DB/TextWorks are intended to open textbases and provide
a particular starting environment (by using Initial Elements). Menu screens for Internet/intranet
use are intended to provide a way of doing predefined searches. The following list explains the
different ways that certain features of menu screens are interpreted, depending on whether the
menu is being used with DB/TextWorks or WebPublisher PRO.
Tools>Box Properties>Contents. A textbase box on a menu screen for WebPublisher
PRO determines which textbase will be opened and which query (initial action) will be
performed. Textbase boxes that do not have a saved query defined as the initial action
(choose Tools>Box Properties>Initial Action) will not be exported to HTML.
Tools>Box Properties>Icon. Icons on a menu screen (.BMP files) are ignored when
the screen is exported to HTML.
Tools>Box Properties>Initial Elements. For WebPublisher PRO, specify initial
elements (forms) for the Report, Display, and Edit Window. Those forms will be used
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when records are displayed in the Web browser. All other initial elements are ignored for
Internet/intranet use.
Tools>Box Properties>Initial Action. For WebPublisher PRO, this is the option that
you use to specify which query is performed when a menu item is clicked.
Tools>Tab Order. Tab order has no effect on an HTML menu screen.
Tools>Screen Properties>General (Path setting). WebPublisher PRO ignores the
Path setting.
Tools>Screen Properties>Logos. These options are specific to WebPublisher PRO.
They are ignored for menu screens used with DB/TextWorks.
Tools>Screen Properties>HTML. These options are specific to WebPublisher PRO.
They are ignored for menu screens used with DB/TextWorks.
Menu Operations>Export Menu Screen to HTML. To use a menu screen on the Web,
you must export it to HTML. The only items that are exported are textbase boxes that
have a Saved Query (Initial Action) specified, text boxes, and picture boxes. Other boxes
are ignored for export purposes.
Displaying a menu screen at startup. DB/TextWorks users can specify a particular
.TBM file (menu screen) to use when the software starts. This has no equivalent in
WebPublisher PRO.

HTML Menu Screen Properties
A menu screen designed for WebPublisher PRO use can include the HTML properties listed
below. To specify these settings, use the Logos and HTML tabs on the Menu Screen Properties
dialog box (choose Tools>Screen Properties>Logos/HTML) in the Menu Screen Designer.
These settings only affect menu screens when they are exported to HTML for use on the Web.
They are ignored for menu screens used on the desktop.

Logos tab
Logos. Add a logo or other image to a menu screen.

HTML tab
Use background image. Specify an image file for the page background.
Show form list on report page. Determines whether users can change forms used to
display information on the report page.
Show form list on display page. Determines whether users can change forms used to
display information on the expanded display page.
Show form list on edit page. Determines whether users can change forms on the edit
page.
Records per page. Limits the number of records that can be displayed at one time after
a search.
Navigational controls. Specify placement of navigation buttons and form drop-down
lists.
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Menu Screen Properties: HTML tab
Use the HTML tab when designing a menu screen for use on the Web with WebPublisher PRO.
Use background image. Select this option to specify an image to use as the
background for the menu screen. Most Web browsers support only .JPG and .GIF files.
Note: You can also use Tools>Screen Properties>General to specify background
color.
Show form list on report page. This option determines whether users will be able to
change report forms in the Web browser. If you select this check box, the form dropdown list will appear in the Web browser.
Show form list on display page. Select this check box if you want users to be able to
change single-record display forms in the Web browser.
An expanded display form is a form that shows detailed information about one record at
a time. To create a form for expanded display, use the Form Designer to create a form
that includes information from most or all fields in the textbase. When you save the form,
specify that it can be used for the Display Window and the Web, and that it should be
saved in the Textbase File (Public).
Show form list on edit page. This option determines whether users will be able to
change edit forms in the Web browser. Note that editing over the Web requires
WebPublisher PRO version 7.0 or later.
An edit form lets you add a new record or modify or delete an existing one. When you
save the form, specify that it can be used for the Edit Window and the Web, and that it
should be saved in the Textbase File (Public).
Records per page. Use this drop-down list to specify the maximum number of records
to be displayed at one time, so records meeting search criteria can be viewed in
batches. This option controls how many records can be displayed on each page. It does
not restrict the number of records that you can retrieve. The number you specify will
apply to all predefined searches referenced in this menu screen.
If you select unlimited, a query will display all records that meet the search criteria in
one batch. This can result in significant delays when many records are retrieved.
If you specify a value (by typing a number right over the word "unlimited"), that number
of records will be displayed at one time, and a Next button will appear on the screen (for
example, Next 10 Records). To view the next batch of records, the Internet/intranet user
can click the button. At that point, a Previous button appears (for example, Previous 10
Records), so the user can display the previous batch.
Navigational controls. Specify whether you want navigation buttons and form dropdown lists to appear on the top of the page, the bottom of the page, or both. The
navigation buttons will appear in the Web browser on the page of records found after
users do a search.
Tip! If this option is grayed out, type a number in the Records per page box (type right
over the word "unlimited") and click the OK button.

Menu Screen Properties: Logos tab
Use the HTML settings on the Logos tab to include a graphic at the top and/or bottom of a menu
screen to be used with WebPublisher PRO. Most Web browsers support only JPEG and GIF
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files. The size of the graphic is determined by the application used to generate the image. The
position of the graphic is flush left on the page.
Leading Logo. In this box, type the file name, including extension, of the image file to
display at the top of the menu screen. For example, type NEWLOGO.JPG.
Trailing Logo. In this box, type the file name, including extension, of the image file to
display at the bottom of the menu screen. For example, type MYLOGO.GIF.
WebPublisher PRO expects to find the logos in /DBTW-WPD/IMAGES (the HTTP equivalent to
C:\PROGRAM FILES\INMAGIC\WEBPUB\IMAGES). For example, if you type MYLOGO.GIF in
this dialog box, a URL such as this one might be used:
http://www.inmagic.com/dbtw-wpd/images/mylogo.gif

Note for SQL platform: The SQL platform uses ics-wpd instead of dbtw-wpd.
If your logos are stored in a different location (that is, not /DBTW-WPD/IMAGES), you must type
a path that includes a forward slash (/) in the Leading Logo and/or Trailing Logo box. Here
are some examples:
http://www.myco.com/logos/mylogo.gif
/jones/mrs.gif
pictures/me.gif

A logo or image location that starts with a forward slash is relative to the server root. A location
without a leading "http://host" or "/" is relative to the location of the menu screen.

HTML Menu Screen Properties: Number of Records (HTML tab)
Use these HTML settings when designing a menu screen for use on the Web with
WebPublisher PRO.
Records per page. Specify the maximum number of records to be displayed at one
time, so records meeting search criteria can be viewed in batches. This option controls
how many records can be displayed at one time. It does not restrict the number of
records that you can retrieve. The number you specify will apply to all predefined
searches referenced in this menu screen.
If you select unlimited, a query will display all records that meet the search criteria in
one batch. This can result in significant delays when many records are retrieved.
If you specify a value (by typing a number right over the word "unlimited"), that number of
records will be displayed at one time, and a Next button will appear on the screen (for
example, Next 10 Records). To view the next batch of records, the Internet/intranet user
can click the button. At that point, a Previous button appears (for example, Previous 10
Records), so the user can display the previous batch.
Navigational controls. Specify whether you want navigational controls to appear on the
top of the page, the bottom of the page, or both. The navigational controls will appear in
the Web browser on the page of records found after users do a search and on
display/edit pages. This setting controls the location of navigational controls, such as the
Next/Previous buttons, form/screen drop-down lists, Back (<) and Rewind (<<) buttons,
and the optional New Search button.
Tip! If this option is unavailable, type a number in the Records per page box (type right
over the word "unlimited") and click OK.
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WebPublisher PRO: Linking to Other Pages
A form, query screen, or menu screen designed for use on the Web with WebPublisher PRO
can include links to other HTML pages.
For Query Screens
1. Choose Search>Design Query Screen, and create a new screen or load an existing
one.
2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
4. On the HTML tab, from the Treat text as drop-down list, select URL.
5. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
6. Click Apply, then click Close.
7. [Optional] If you want users to be able to add new records to the textbase from the query
screen, add a New record link.
8. Save the query screen.
9. Export the query screen to HTML.
For Forms
1. Choose Display>Design Form, and create a new form or load an existing one.
2. Select the form box with the content item that contains the link destination and choose
Tools>Box Properties to open the Form Box Properties dialog box.
3. On the HTML tab, from the Contents list, select the content item that contains the link
destination, then do the following:
a. From the Treat content item as drop-down list, select URL.
b. [Optional] Select the Use alternate link text check box, then, in the Text box
below it, enter the text you want to appear as the hypertext link. (This check box
becomes enabled after you select URL from the Treat content item as list.)
4. Click Apply, then click Close.
5. Save the form.
Approaches that you can use when designing forms
Add a hypertext link to a report form so users can jump to an expanded display of one
record at a time.
Add a hypertext link to a report and/or display form so users can jump to an edit screen
to add, edit, or delete a record. Note that editing over the Web requires WebPublisher
PRO version 7.0 or later.
Use settings from the Treat content item as drop-down list on the HTML tab (choose
Tools>Box Properties>HTML) to generate hypertext links. These settings include: Raw
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HTML, URL, e-mail link, HTML file reference, Expand record link, "See Also"
search link, Inline image, Image link, New record link, Edit record link, Delete
record link.
For Menu Screens
1. Close any open textbase.
2. Choose Menu Screens>Design, and create a new screen or open an existing one.
3. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
4. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
5. On the HTML tab, from the Treat text as drop-down list, select URL.
6. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
7. Click Apply, then click Close.
8. Save the menu screen.
9. Export the menu screen as HTML.

Launching Applications (WebPublisher PRO)
If you are publishing textbases on an intranet, you can use WebPublisher PRO to help you
launch other applications, such as a video clip or a spreadsheet or word processing program,
from within a form, query screen, or menu screen. You do this by including the name of the file
you want to open in a field in the textbase, or as fixed text in a text box on a query or menu
screen.
When the user clicks the file name or other text that you supply, the application associated with
that file is launched to open the file. The file extension (defined in the Windows Registry or
browser preferences) dictates what application is used.
In general, you should provide links which launch applications only across an intranet where you
know the users have access to the software and hardware needed to run the application(s)
associated with the referenced files.
Important! All intranet users will have access to the files (documents, spreadsheets, and so
forth) to which you provide a link. If you do not want users to be able to edit files, place the files
in a read-only folder or link to .PDF files.
Be sure that the target file is set up properly on the server to be accessible to all users. One of
the following conditions must be true:
The end user is capable of opening the target file using the associated application
software from his or her desktop using network file access protocols, OR
The end user is capable of running the associated application, and can access the target
file using HTTP addressing protocols.
In the first case, it is advisable to use the UNC filename to specify the file path, to avoid conflicts
over logical drive mappings. Place the file information in a box on the form or screen, and select
the HTML tab on the Box Properties dialog box. Select HTML file reference from the Treat text
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as or Treat content item as drop-down list (as applicable). If you want to show alternate text
instead of the file name, select the Use alternate link text check box and type in the text you
wish to substitute. Example:
file name:

\\server\vol1\docs\myfile.doc

alternate text:

Click here

result in report:

<a href="file:////server/vol1/docs/myfile.doc">Click here</a>

In the second case, use an HTTP-formatted path specification.
For example, on a query screen, menu screen, or form, add a text box that contains this text:
http://test/myfile.doc

On the Text Box Properties dialog box, select the HTML tab and select URL from the Treat text
as drop-down list. To specify alternate text for the link on the screen, select the Use alternate
link text check box, then type the text you want in the Text box below it (for example, type Click
here).
file name:

http://test/myfile.doc

alternate text

Click here

result in report:

<a href="http://test/myfile.doc">Click here</a>

If you use an HTTP-formatted path specification on a form, you can create the link with a form
box instead of with a text box. Add a form box and specify the field content or another content
item (for example, Fixed Text) whose content you want to use as the link. On the Form Box
Properties dialog box, select the HTML tab and select URL from the Treat content item as
drop-down list. To specify alternate text for the link on the screen, select the Use alternate link
text check box, then type the text you want in the Text box below it (for example, type Click
here).

Exporting Menu Screens to HTML
To use a menu screen on the Web with WebPublisher PRO, you must export the menu screen
to HTML.
1. Close any textbase that may be open, then open the menu screen you want to export in
the Menu Screen Designer (choose Menu Screens>Design).
2. Choose Menu Operations>Export Menu Screen to HTML.
3. Name the file and specify a location in which to save it, then click OK. You can save the
HTML page anywhere accessible to the HTTP server.
Notes about exporting menu screens to HTML
Designing a menu screen for Web use is different from designing one for the desktop. Some of
the options you can specify are only applicable to the Web, while others are for desktop use
only. The following list provides some of the differences. For more information, refer to the
related topics listed below.
The only items that are exported are text boxes, picture boxes, and textbase boxes
whose initial action is a Saved Query (choose Tools>Box Properties>Initial Action).
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The export process ignores any textbase box that does not have Saved Query specified
as the initial action. Icons are also ignored.
Text in a textbase box does not retain the font, font style, font size, and color attributes
specified in DB/TextWorks. When exported to HTML, the software automatically formats
text in textbase boxes to appear as a standard hypertext link.

WebPublisher PRO Forms
Creating Forms for Web Use
The following topics contain information about designing forms for use on the Web with
WebPublisher PRO. These forms will be used to format records for display and editing. Users
can select different forms in the Web browser to see various views of the records they retrieve.

Summary
You design forms using DB/TextWorks. When you design forms for Web use (as opposed to
desktop use), be sure to choose Tools>Box Properties>HTML and Tools>Form
Properties>Logos/HTML in the Form Designer. These options are intended specifically for
Web use.
Finally, when you save a form in the Form Designer (choose Form Operations>Save Form or
Form Operations>Save Form As), be sure to select the Web check box and at least one other
check box based on the type of form you are designing (Display Window, Report Window, or
Edit Window). Forms must also be saved as Textbase File (Public). This ensures that the
forms will appear in drop-down lists in the Web browser.
Forms are not saved as separate files. They are saved as part of the textbase. The only type of
form that has to be exported to HTML is an edit form you plan to access directly from the Web
(as opposed to from a query screen) to add records to a textbase (for example, a registration
form). For all other types of forms, the software does the HTML processing for you dynamically.

Forms for the Web
For each textbase that you will publish on the Web, use DB/TextWorks to design these types of
forms:
Report forms. Report forms show multiple records found by a search. They usually
summarize the search results. For example, they might show a few fields in a tabular
format (columns and rows). Report forms often include a hypertext link to an expanded
display.
Display forms. Also known as expanded display forms. They show one record at a
time. They usually show most or all of the information about a record.
Edit forms. Edit forms typically show all or most non-hidden fields so that users can
add, edit, or delete records over the Web.
Note: If you only want to add records to a textbase directly from the Web, you can design
an edit form and export it to HTML. This method is for when you do not want users to
have to open a query screen, or submit a search, or display records. The edit screen is
opened directly from its URL (for example, by clicking a link on your intranet).
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Use the Form Designer to decide which information each form will show. For example, a Report
form might include just three fields: Title, Author, and Summary. When you design a form for
expanded display or for editing, you typically include most or all of the fields in the textbase.
Users can select a form from the drop-down list that appears in the Web browser to change the
way records appear. If the textbase does not include any forms marked as Web (in the Save
Form As dialog box), a Basic form is generated automatically and displayed in the browser. This
form shows all of the non-hidden fields in the primary textbase, with minimal formatting. Note: In
order for form drop-down lists to appear in the Web browser, you must select the Show form
list on report/display/edit page check boxes (as applicable) on the Query Screen Properties
dialog box or Menu Screen Properties dialog box.

Instructions
A. Create Report Forms
1. For each textbase that you will publish, use the Form Designer to create at least one
Report form that shows a summary of records found. Tabular forms are good for this
purpose.
2. [Optional] Choose Tools>Form Properties>General, and clear the Highlight search
items check box, as it can make a report look cluttered and be hard to read.
3. Specify which text in the Report form to use as a link to the expanded record.
If you use a text box, do the following:
a. Select the text box, then choose Tools>Box Properties to open the Text Box
Properties dialog box.
b. On the Text tab, in the Text box, enter the text you want as the hypertext link (for
example, type More info).
c. On the HTML tab, from the Treat text as drop-down list, select Expand record link.
Note: If a Report form does not include an Expand record link, users will not be
able to access an expanded display.
If you use a form box, do the following:
a. Select a form box, then choose Tools>Box Properties>HTML.
b. From the Contents list, select the item whose content will be the hypertext link. Note:
You can use field content or other form box content (for example, Fixed Text or the
RECORD NUMBER variable). If you use field content as the hypertext link, choose a
field that holds an item that is present in every record, such as a title of a publication,
a product name, or a person's name.
c. From the Treat content item as drop-down list, select Expand record link.
4. Choose Form Operations>Save Form (or Save Form As). Name the form and specify
these options:
Textbase File (Public). This saves the form inside the textbase.
Report Window. This makes the form available in the drop-down list for displaying
reports.
Web. Only forms that have this check box selected will be available to Web users.
You can also select the Web Only check box, to omit a form from desktop form
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lists, because some forms designed for Web use may not be suitable for desktop
use.
B. Create Display Forms
1. For each textbase that you will publish, create at least one form that shows detailed
information about one record at a time. Typically, you would include most or all of the
fields, plus whatever text formatting, paragraph formatting, HTML formatting, and other
attributes you want.
2. [Optional] Choose Tools>Form Properties>General, and select the Highlight search
items check box (if it is not selected already), as highlighting can be useful on an
expanded display page.
3. Choose Tools>Box Properties>HTML and Tools>Form Properties>Logos/HTML to
format the forms.
4. Choose Form Operations>Save Form for a new form or Form Operations>Save
Form As for an existing form. Name the form and specify these options:
Textbase File (Public). This saves the form inside the textbase.
Display Window. This makes the form available in the drop-down list for singlerecord, expanded display.
Web. Only forms that have this check box selected will be available to Web users.
You can also select the Web Only check box, to omit a form from desktop form
lists, because some forms designed for Web use may not be suitable for desktop
use.
C. Create Edit Forms
1. If you plan to let your clients add, edit, and/or delete records over the Web, create at
least one Edit form for each textbase that you will publish. Design each edit form to show
the fields you want to be able to enter information for and/or edit. Typically, you would
include most or all of the fields. Be sure to include any fields with Field Entry Required
validation.
2. Choose Tools>Box Properties>HTML and Tools>Form Properties>Logos/HTML to
format the forms. Note: If you want to add a password box or apply a validation link, you
must save the form (as explained in the next step) before specifying these features.
3. Choose Form Operations>Save Form for a new form or Form Operations>Save
Form As for an existing form. Name the form and specify these options:
Textbase File (Public). This saves the form inside the textbase.
Edit Window. This makes the form available in the drop-down list on editing
screens.
Web. Only forms that have this check box selected will be available to Web users.
You can also select the Web Only check box, to omit a form from desktop form
lists, because some forms designed for Web use may not be suitable for desktop
use.
D. Specify Initial Forms
The initial Report form is the one that is used in the browser when Web users retrieve
records after a search. The initial Display form is the one that is used for expanded display.
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The initial Edit form is the one that is used for editing on the Web. You specify initial forms in
different places for query screens (choose Tools>Screen Properties>HTML) and menu
screens (choose Tools>Box Properties>Initial Elements for textbase boxes).

Forms Used for Printing
Printed pages use whichever form is selected in the browser when the browser's Print
command is used.

WebPublisher PRO: Form Design Tips
If you have WebPublisher PRO, you can publish textbases, together with forms saved in the
textbase file, on the Internet or an intranet. For the most effective use of forms on the Web,
follow the guidelines below.
Consider designing separate forms for desktop and Web use. Some things that you can
do on the desktop are not supported in HTML. But you can do things in the HTML
version of a form, such as use Raw HTML (for example, for a canned query), that may
not appear correctly on the desktop. Use the Save Form As dialog box to establish form
usage.
In the Form Designer, for form boxes use added text (choose Tools>Box
Properties>Format>Added Text) or fixed text (choose Tools>Box
Properties>Contents>Text) to specify HTML attributes. Then, with the form box
selected, choose Tools>Box Properties>HTML. From the Contents list, select the item
that contains the HTML code, and select Raw HTML from the Treat content item as
drop-down list. Click Apply and Close. In the following example, URL and Title are field
names:
<a href="URL"><b><font size=3>Title</font></b></a>

The initial form that you supply for reports should provide a summary of records found.
Tabular forms are a good choice, showing just a few pieces of information from each
record: Author, Title, Date, Abstract. Include an expand record link so users can expand
each record to see detailed information.
When you export a query screen to HTML, you can specify some form settings. For
example, you can select initial forms and prohibit users from changing forms.
Highlighting the words and terms found by a search can be useful in expanded display
forms, but distracting when used in reports. To specify whether search terms are
highlighted for an individual form, select or clear Highlight search items in the Form
Designer (choose Tools>Form Properties>General).
To specify the highlighting method for report and expanded display, use
Tools>Options>Search. Web reports use the Print highlighting setting (Bold,
Underline, and so forth). Expanded displays on the Web use the Display highlighting
setting (Reverse Video, Color); reverse video appears as bold in the Web browser. The
settings will be saved in the INMAGIC.INI file located on the machine from which this
change was made. Copy this INMAGIC.INI file to the Windows directory on the HTTP
server, to make the selected options available to WebPublisher PRO.
To provide users with a way to return to the query or menu screen, add
WebNewSearchButton=1 to the [WebPublisher] section of the DBTWPub.INI file (or the
[Web] section of the ICSWeb.INI file, if you are using the SQL platform). This will add a
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New Search button with the other navigational controls (for example, form drop-down
lists and Next/Previous buttons).
You can display a horizontal rule between records in a WebPublisher PRO report
(choose Tools>Form Properties>HTML).
You can include logos or other graphics at the top and/or bottom of a form (choose
Tools>Forms Properties>Logos) and/or picture boxes in the body of the form (choose
Edit>Add>Picture Box). The size of the logo is determined by the application used to
generate the image and the size of the picture box is the same as the specifications for it
in the form. The position of the logo is flush left on the page.
When creating tabular forms, you can use box labels for column headings (choose
Tools>Box Properties>Labels).
Sorting. Sort order is determined by the textbase default sort order (choose
Maintain>Edit Textbase Structure) or by the compulsory form sort (in the Form
Designer, choose Report Options>Compulsory Sort). To allow users to sort records,
create several forms, each sorted in a different way (Sort by Title, Sort by Date). Note
that the following compulsory form sort options are ignored: Interfile and Omit Those
Records (click Primary Sort Field Options). Note that exploded sorts are also ignored
by default. If you set the WebAllowExplode=1 option in the DBTWPub.INI file (or the
ICSWeb.INI file, if you are using the SQL platform).to permit exploded sorts, all records
are displayed on one page to avoid paging issues when changing the perceived number
of records in the report.
The number of records retrieved is shown in the browser title bar. If you want the form
itself to indicate how many records were retrieved, include the RECORD COUNT
variable in the form. In a non-tabular form, you can put the variable in a Report Header
or Report Footer box in the Record Area (for example, "This report contains <RECORD
COUNT> records"). You may also want to use other variables, such as date, time, name
of textbase that was searched, and search criteria.
If the textbase does not include any forms marked for use on the Web (select the Web
check box on the Save Form As dialog box), a Basic form is generated automatically
and displayed in the browser. This form shows all of the non-hidden fields in the primary
textbase, with minimal formatting.

Limitations
Some Form Designer features are either unsupported or interpreted differently on the Web than
on the desktop.
Margin Area. Boxes in the Margin Area of a form do not appear when the report is
displayed or printed using a browser.
Page Layout. The browser controls page breaks, numbering, and other marginalia.
Horizontal Spacing. The browser collapses multiple spaces in data to a single space.
Vertical Spacing. Vertical spacing between boxes is interpreted as a line break (<br>)
or paragraph (<p>). To avoid excessive vertical space between items of information on a
form, set the Top Offset for all boxes to zero (choose Tools>Box Properties>Position).
This is the only way to avoid blank lines between boxes. Any value other than 0 is
interpreted as one line.
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Indentation. Indentation settings (choose Tools>Box Properties>Paragraphs) are
ignored.
User Questions. Prompted text in a form (choose Tools>Box
Properties>Contents>Text) is ignored.
Tabular Forms. WebPublisher PRO places borders flush against the information in
table cells.

Designing Tabular Forms
Design a tabular form to present information as a table, in rows and columns. Each row in the
table represents a record. Each column represents a field. Each cell in a row contains one or
more fields or other content items (variables, calculations, and so forth). Use tabular forms to
display a summary of records found by a search, showing just a little information from each
record: Author, Title, Subject, Date.
Tip! Tabular forms are especially useful for forms that will be used on the Web with
WebPublisher PRO.
Creating a Table
1. Outside of the Form Designer, choose Display>Design Form, or from within the Form
Designer, choose Form Operations>Open Form.
2. From the Start With list, select New Tabular Form.
3. On the Choose Initial Tabular Form Fields dialog box, specify which fields you want to
include in the table, by moving fields from the Available Fields list to the Initial Fields list.
4. Click OK.
A table appears, consisting of the fields that you selected. Within the Form Designer, a table
consists of one row, which represents one record. The row contains multiple cells, each of
which contains a content item (a field, a variable, fixed text, and so forth). Rows are records.
Columns are fields. When you use the form, the table will consist of multiple rows, each of which
represents a record retrieved.
Adjusting Table Appearance
For the most part, use the Form Designer options as you would to design a non-tabular form.
For example, to change the size of a cell in the table, click a cell and choose Tools>Box
Properties>Position. To add a cell to the right of the selected cell, choose Edit>Add and click
the type of box you want to add. To delete a cell, choose Edit>Delete Box. You can drag a box
to a new horizontal position using the mouse.
Note that tabular forms are available only for reports, which do not permit scrolling within a box.
Therefore, choose Tools>Box Properties>Position and specify a Maximum height large
enough to accommodate a reasonable amount of text.
To add column headings, choose Edit>Select All>Form Boxes, then choose Tools>Box
Properties>Labels. From the Show group, select the Label check box and click Apply. Default
label text is used. To change the text, select an individual cell then use Tools>Box
Properties>Labels.
Form Designer options that are not supported in a table have been removed from the menus or
disabled. For example, you cannot specify tab order, or that a tabular form be used for single
record display or editing.
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Designing Tabular Forms for Use on the Web
If you have WebPublisher PRO, you can design tabular forms for Internet/intranet use. Here are
some issues specific to use on the Web:
Choose Tools>Form Properties>HTML to specify attributes for forms used on the Web
or File>Write Report to File or File>Send Report as Mail in HTML format. These
options are ignored for forms used on the desktop.
Choose Tools>Box Properties>HTML to treat the contents of a particular field as
hypertext links. Each entry in the specified field generates a separate link.
Box width is ignored in the Web browser. The browser expands the width of each cell as
necessary.
An important, though optional, part of designing a tabular form for the Web is to give the
user a way to see a detailed view of each record. Choose Tools>Box
Properties>HTML and select Expand record link from the Treat content item as
drop-down list.
To include images in a table, use a picture box (choose Edit>Add>Picture Box). An
alternative method of including images in a table is to specify the contents of a particular
cell as the Image field that holds the image you want to display (images should be in a
format supported by the Web browser, such as JPEG or GIF). Images included in a table
can be displayed inline or as a link, depending on the Treat content item as setting
(choose Tools>Box Properties>HTML). For more information about images on the
Web, see the WebPublisher PRO: Images topic.
For related information, see WebPublisher PRO: Form Design Tips.

Expanded Display Forms for Use on the Web
An expanded display form is a form designed for WebPublisher PRO that shows detailed
information about one record at a time. To create a form for expanded display, use the Form
Designer to create a form that includes information from most or all fields in the textbase. When
you save the form, specify that it can be used for the Display Window and Web, and that it
should be saved as Textbase File (Public).
How do users see an expanded display? They click a hypertext link in a Report page.
How does this hypertext link get onto the Report page? You add it when you design the Report
form, by choosing Tools>Box Properties>HTML, and selecting Expand record link. For
example, this Report form specifies the Title field as the Expand record link:
Title

Author

Summary

ABCs of Finance

Ingrid Spy

A beginner's guide.

Financial Trends

Joe Doe

Trend analysis.

Managing Your Moolah

Moe Jones

A perennial favorite.

An alternative to using a field as the Expand record link is to add a box containing fixed text
such as "More" and defining that content item as the Expand record link. The report would
look like this:
Title

Author
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ABCs of Finance

Ingrid Spy

A beginner's guide.

More

Financial Trends

Joe Doe

Trend analysis.

More

Managing Your Moolah

Moe Jones

A perennial favorite.

More

When the user clicks the hypertext link in the browser, a detailed view of the record will appear,
using the specified Display form. You specify the initial Display form using Tools>Screen
Properties>HTML (Query Screen Designer) or when you define Initial Elements for a textbase
box on a menu screen (Menu Screen Designer). If you do not specify an initial Display form at
that time, the textbase defaults are used. If you supply more than one Display form for Web use,
the user can select a different Display form from a drop-down list in the Web browser.
Note: Users can select a different form from the drop-down list in the Web browser if the Show
form list on report/display/edit page check boxes are selected (as applicable) on the Query
Screen Properties dialog box or Menu Screen Properties dialog box. (These options are
disabled for query screens used to search multiple textbases.)

WebPublisher PRO: Initial Forms for Web Use
An initial form is the form that is first used in the browser. The initial Report form is applied when
the user retrieves records. The initial Display form is applied when the user expands a record.
The initial Edit form is applied when the user clicks a New record link, Edit record link, or
Delete record link.
Users can change forms using the drop-down list in the Web browser if the Show form list on
report/display/edit page check boxes are selected (as applicable) on the Query Screen
Properties dialog box or Menu Screen Properties dialog box. (These options are disabled for
query screens used to search multiple textbases.)
You specify which Report, Display, and Edit forms to use as initial forms using Tools>Screen
Properties>HTML in the Query Screen Designer, or when you specify Initial Elements for a
textbase box on a menu screen (in the Menu Screen Designer, choose Tools>Box
Properties>Initial Elements). The form lists for those dialog boxes include only those forms
that have the Web check box selected in the Save Form As dialog box.
If you do not specify initial forms at those times, the textbase default forms will be used (if they
were saved for use on the Web).
If no form has been selected and the textbase default form was not saved as for use on the
Web (with the Web check box selected in the Save Form As dialog box), a Basic form is
generated automatically to display records in the browser. The Basic form shows all of the nonhidden fields in the primary textbase, with minimal formatting.
Note: For menu screens used on the Web, only Initial Elements (forms) for the Report, Display,
and Edit Window need to be specified. All other initial elements are ignored for Internet/intranet
use.

HTML Form Properties
A form designed for Web use can include the properties listed below. These properties only
affect forms used on the Web with WebPublisher PRO, or when writing a report to HTML, or
sending a report as mail in HTML format. They are ignored for forms used on the desktop. To
specify these properties, choose Tools>Form Properties in the Form Designer and use the
Logos and HTML tabs. After specifying the properties you want, click Apply.

334

Inmagic DB/TextWorks v13 Printed Help

WebPublisher PRO
Logos tab. Add a logo or other image to a form. (Logos are ignored for the Send Report
as Mail function.)
HTML tab.
Record separators. Specify whether records are separated by a horizontal line.
Background image. Specify an image file for the page background. (Images are
ignored for the Send Report as Mail function.)
Advanced options. Specify the HTML you want to add to the <head> section of
HTML reports and specify Includes for one or more seams on the page (up to six
seams).

Form/Tabular Form Properties: Logos tab
Use these HTML properties to include a graphic at the top and/or bottom of a form to be used
on the Web with WebPublisher PRO.
In the Leading Logo box, type the file name, including extension, of the image file to display at
the top of the form. For example, type NEWLOGO.JPG.
In the Trailing Logo box, type the file name, including extension, of the image file to display at
the bottom of the form. For example, type MYLOGO.GIF.
Important! WebPublisher PRO expects to find the logos in the location specified in the
[WebPublisher Defaults] section of the DBTWPub.INI file. If you accepted the default during the
installation of WebPublisher PRO, this location is /DBTW-WPD/IMAGES (the HTTP equivalent
to C:\PROGRAM FILES\INMAGIC\WEBPUB\IMAGES).
If you are storing your logos in a different location from the one specified during installation, be
sure to specify it in the [WebPublisher Logo Locations] section of the DBTWPub.INI file.
To display the images, WebPublisher PRO constructs a URL to send to the browser,
prepending that information. For example, if you type MYLOGO.GIF in this dialog, a URL such
as this one might be used:
http://www.inmagic.com/dbtw-wpd/images/mylogo.gif

To specify a different location (that is, a location that is not specified in the DBTWPub.INI file),
you must type a path that includes a forward slash (/) in the Leading Logo and/or Trailing
Logo box. Here are some examples:
http://www.myco.com/logos/mylogo.gif
/jones/mrs.gif
pictures/me.gif

A logo or image location that starts with a forward slash is relative to the server root. A location
without a leading "http://host" or "/" is relative to the location of the query or menu screen that
passed the query to WebPublisher PRO.

Form Properties: HTML tab
Use the HTML tab when designing a form for use on the Web with WebPublisher PRO, or when
writing a report to HTML, or sending a report as mail in HTML format. Note: For tabular forms,
this tab has slightly different settings.
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Options group
Use record separators. When records are retrieved, they are displayed one after
another, in a report. If you want a horizontal rule to appear between records, select the
Use record separators check box. Then specify the Alignment, Height, and Width in
pixels. Click OK when done. The Web browser software controls the final appearance of
the record separator.
Use background image. Check this box to specify an image file to display as the page
background. (Images are ignored for the Send Report as Mail function.) You can use the
Browse button to locate the image file you want to use.
Background images should be in the location specified in DBTWPub.INI (or ICSWeb.INI).
You can specify a single default location for all background images used in forms, or
specify a different location for individual textbases. For more information, see Specifying
Where WebPublisher PRO Looks for Images.
To use a background image whose location is not specified in the INI file, you must type
a path that includes a forward slash (/) in the Image file box. Here are some examples:
http://mydomain.com/newlogos/mylogo.gif
/jones/mrs.gif
pictures/me.gif

A location that starts with a forward slash is relative to the server root. A location without
a leading "http://host" or "/" is relative to the location of the query or menu screen passing
the query to WebPublisher PRO. For edit forms that are exported to HTML, the location
is relative to the edit form.
Note: You can also specify background color for forms using Tools>Form
Properties>General.

Advanced options group
Advanced Options. Click the Advanced Options button to open the Advanced HTML
Options dialog box. Use the tabs on this dialog box to specify advanced HTML options
for your form.
<head> Section tab. Specify information you want included in the <head> section
of the HTML report. The information (<script>, <style>, or other HTML elements you
specify) is inserted after the information added by the software, such as the page
title, and after the first seam for Includes.
Includes tab. Specify Includes for one or more seams on the HTML report. You
can specify up to 1,024 characters per seam (up to six seams). Note that Includes
do not apply to writing a report to HTML or to sending a report as mail in HTML
format.

WebPublisher PRO: Linking to Other Pages
A form, query screen, or menu screen designed for use on the Web with WebPublisher PRO
can include links to other HTML pages.
For Query Screens
1. Choose Search>Design Query Screen, and create a new screen or load an existing
one.
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2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
4. On the HTML tab, from the Treat text as drop-down list, select URL.
5. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
6. Click Apply, then click Close.
7. [Optional] If you want users to be able to add new records to the textbase from the query
screen, add a New record link.
8. Save the query screen.
9. Export the query screen to HTML.
For Forms
1. Choose Display>Design Form, and create a new form or load an existing one.
2. Select the form box with the content item that contains the link destination and choose
Tools>Box Properties to open the Form Box Properties dialog box.
3. On the HTML tab, from the Contents list, select the content item that contains the link
destination, then do the following:
a. From the Treat content item as drop-down list, select URL.
b. [Optional] Select the Use alternate link text check box, then, in the Text box
below it, enter the text you want to appear as the hypertext link. (This check box
becomes enabled after you select URL from the Treat content item as drop-down
list.)
4. Click Apply, then click Close.
5. Save the form.
Approaches that you can use when designing forms
Add a hypertext link to a report form so users can jump to an expanded display of one
record at a time.
Add a hypertext link to a report and/or display form so users can jump to an edit screen
to add, edit, or delete a record. Note that editing over the Web requires WebPublisher
PRO version 7.0 or later.
Use settings from the Treat content item as drop-down list on the HTML tab (choose
Tools>Box Properties>HTML) to generate hypertext links. These settings include: Raw
HTML, URL, e-mail link, HTML file reference, Expand record link, "See Also"
search link, Inline image, Image link, New record link, Edit record link, Delete
record link.
For Menu Screens
1. Close any open textbase.
2. Choose Menu Screens>Design, and create a new screen or open an existing one.

Inmagic DB/TextWorks v13 Printed Help

337

WebPublisher PRO
3. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
4. On the Text tab, in the Text box, type the link destination you want (for example, type
http://www.inmagic.com).
5. On the HTML tab, from the Treat text as drop-down list, select URL.
6. [Optional] Select the Use alternate link text check box, then, in the Text box below it,
enter the text you want to appear as the hypertext link. (This check box becomes
enabled after you select URL from the Treat text as drop-down list.)
7. Click Apply, then click Close.
8. Save the menu screen.
9. Export the menu screen as HTML.

HTML Query Screen Properties
A query screen designed for Web use can include the properties listed below. These properties
only affect query screens exported to HTML for use on the Web with WebPublisher PRO. They
are ignored for query screens used on the desktop. To specify these properties, choose
Tools>Screen Properties in the Query Screen Designer and select the Logos and HTML tabs.
After specifying the desired properties, click the OK button.
Logos tab
Leading/Trailing Logo. Add a logo or other image to the top or bottom of a query
screen. Tip! You can also use picture boxes to add images to query screens.
HTML tab
Show Boolean operators. Show or hide a Boolean drop-down list (AND, OR, NOT) for
searchable boxes.
Use background image. Specify an image file for the page background. Tip! You can
also use Background color on the General tab to specify a page background color.
Initial Report Form. Specify which Report form to use when the user retrieves records.
The selected form will be used every time a new query is submitted.
Initial Display Form. Specify which Display form to use when the user expands a
record in the browser. This form determines the appearance of single-record display.
Initial Edit Form. Specify which Edit form to use when the user adds, edits, or deletes a
record in the browser. Note that editing over the Web requires WebPublisher PRO.
Show form list on report page. Specify whether drop-down lists will appear in reports.
Show form list on display page. Specify whether drop-down lists will appear in an
expanded display page.
Show form list on edit page. Specify whether drop-down lists will appear on edit
screens. Note that editing over the Web requires WebPublisher PRO.
Records per page. Limit the number of records displayed at one time, and specify
where the navigation buttons appear.
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Navigational controls. Specify whether navigational buttons and form drop-down lists
appear on reports, expanded display pages, and edit screens and where on the page
they are placed.

Exporting Editing Forms to HTML
If you have WebPublisher PRO, you can design an edit form in DB/TextWorks, export it to
HTML, and then use it to add records to a textbase over the Web. If you use this method, you
will only be able to add records from a Web browser-- you will not be able to edit or delete
records over the Web using this form.
This is useful if you want to provide users direct access to an edit form on the Web from which
they can submit information (for example, a registration form for an event).
The Export Editing Form to HTML command is an alternative way to add records over the
Web. If you want Web users to have the ability to add, edit, and/or delete records in your
textbase from a browser, use New record, Edit record, and/or Delete record links in your
screens and forms.
Important! When saving the edit form, select the Edit Window check box on the Save Form As
dialog box. This check box must be selected for the form to be exported to HTML.
To export an edit form to HTML
1. In the Form Designer, open the form you want to export.
2. Save the form for use in the Edit Window (choose Form Operations>Save Form As
and select the Edit Window check box), if it has not been done already.
3. Choose Form Operations>Export Editing Form to HTML.
4. A message appears asking if you want to use Cascading Style Sheets to preserve the
formatting you specified in the Form Designer. Click Yes to preserve formatting (for
example, box position and box background color) when the edit form is displayed on the
Web. Click No to have DB/TextWorks use simple HTML to place elements on the edit
form (that is, boxes will be left-justified, box labels will appear on top rather than to the
left, and so forth).
5. On the Save File As dialog box, do the following:
In the File name box, type a name for the HTML editing form.
Navigate the Save in drop-down list to the location in which you want to save the
form. The location should be accessible to the HTTP server on which WebPublisher
PRO is installed.
Click Save.
6. Click OK to dismiss the completion message.
Once your edit form has successfully been exported to HTML, you can add records to the
textbase over the Web. Using a Web browser, open the edit form, enter record information in
the applicable fields, then click the Submit Record button. Notice that the Tab order specified in
the Form Designer is preserved during the export.
Tip! Be sure the textbase for which you have exported an editing form is accessible to
WebPublisher PRO and that your virtual directory DBTW-WPD (or ICS-WPD if you have the
SQL platform) and the account accessing WebPublisher PRO have the appropriate access
rights. See the installation notes for more information about access rights.
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Note that if you plan to add new records from a browser, you can design a Web edit form so that
a default value appears in the field(s) you specify. For more information, see Using Default
Values on a Web Edit Screen.

Includes tab
To access this tab: In the Form Designer, choose Tools>Form Properties>HTML, click the
Advanced Options button and select the Includes tab.
Use this tab to specify Includes for forms used on the Web with WebPublisher PRO. Includes
can be used on report, display, and edit pages used to view, add, and/or modify WebPublisher
PRO results. (They cannot be used on edit forms that are exported to HTML.)
An Include is information that you want to add to one or more seams of an output page. The
information is typically HTML and/or script (for example, JavaScript, Perl, and so forth) that will
impact the appearance of the page.
Adding Includes allows you to:
Enhance the look and feel of an HTML form in the Form Designer. For example, an
Include can change the look of your WebPublisher PRO output to match the design of
your company Web site.
Access areas of a form that were previously not accessible in the Form Designer. For
example, an Include can add controls above or below the navigational controls provided
by WebPublisher PRO. For more information about these special areas (called seams),
including an illustration of an HTML report showing their locations, see the Seams
Illustration.
Change the appearance of many or all forms all at one time. This can be done in the
following ways:
You can create one text file containing the Include you want used, then reference
that file on the Includes tab for each form for which you want it applied. Doing this
enables you to make a change in one place (the text file) and have it affect all forms
that reference this file. This means you do not have to edit each form.
You can specify default Includes information in the DBTWPub.INI (or ICSWeb.INI)
file to appear in all forms. However, the Includes tab in the Form Designer for a
specific form overrides the .INI defaults, as long as the Override Default Include
check box is selected next to the corresponding seam box.
To add information to a seam
1. In the box corresponding to the appropriate seam, type the Include information you want
for that location. For example, to add information at the very top of the page (seam 1),
type information in the 1 box. Separate multiple entries with the pipe character (|).
Include information can be entered in the following ways:
Directly. You can type the Include information directly into the box on the Includes
tab (for example, <h2>Information provided is company confidential.</h2> ). This
example results in the words "Information provided is company confidential."
appearing on the page. Note that there is a 1,024 character limit. (This is the
maximum for the whole text box, not the per-entry limit)
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Indirectly. You can type the name and location of a text file containing the
information you want to use as the Include. You can use the following types of
references:
Absolute or relative HTTP reference. For example, the absolute reference
http://localhost/dbtw-wpd/sample/seam2.htm or the relative HTTP reference
/includes/seam2.htm. In both examples, the content of SEAMS2.HTM is processed
on the server and inserted into the HTML that is streamed to the client browser.
File system reference. For example, C:\PROGRAM
FILES\INMAGIC\WEBPUBPRO\SAMPLE\SEAM2.TXT. If you use this type of file
reference, the content of SEAM2.TXT is processed on the server and inserted in
the HTML that is streamed to the client browser.
Note: If the file does not reside on the same machine as WebPublisher PRO, you
must use a Universal Naming Convention (UNC) file path to reference it.
2. Click OK on the Advanced HTML Options dialog box.

Overriding Default Includes
The Override Default Include check box is selected automatically when you type in a box on
the Includes tab. This means that, for a particular form, what you type in the box will override
any default Include information specified in DBTWPub.INI (or ICSWeb.INI). Note that if you
select this check box and leave the box blank, the default Include for that seam will be ignored
and nothing will appear in the seam. For more information about default Includes, see
Specifying Default Includes for Forms Used on the Web.
Tip! When experimenting with the design of your form, you can clear this check box to remove
the Include from a seam in the output. This is helpful because it means you do not have to
delete the Include you entered for a particular seam to see how the page looks without it, then
re-type it later if you decide you want it back.

Using Advanced Includes
WebPublisher PRO supports server-side includes and script execution.
To do this in WebPublisher PRO, you must modify the calling syntax of the script or file. For
example, to execute the Perl script in the file /scripts/welcome.pl, you would type <!-- #exec
cgi="/scripts/welcome.pl" -->) in an SHTML or ASP page. To execute that script in your
WebPublisher PRO report, just type /scripts/welcome.pl in the appropriate box on the Includes
tab. The results of the server-side command will be included in your WebPublisher PRO output.

Seams Illustration
You can add Includes to seams on an HTML report using the Advanced HTML Options dialog
box.
You can include up to 1,024 characters per seam. To specify multiple entries per seam,
separate entries with the pipe character (|). There are six seams on an HTML report.
The following list describes the location of the seams:
Seam 1 is located at the very beginning of the <head> section, immediately following the
opening <head> tag.
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Seam 2 is located at the very beginning of the <body> section, immediately following the
opening <body> tag. This is before any leading logo you may have on your page.
Seam 3 is located immediately before the WebPublisher PRO report. This is the area
immediately following the upper navigational controls (such as, a form selection dropdown list and Next/Previous buttons), if you specified that these controls appear at the
top of the page.
Seam 4 is located after the WebPublisher PRO report and any trailing logo you may
have on the page. This is before the lower navigational controls, if you specified that
these controls appear at the bottom of the page.
Seam 5 is located immediately after the lower navigational controls, if present, and
before the Inmagic attribution line.
Seam 6 is located after the Inmagic attribution line and immediately before the closing
</body> tag.
Important! Because Inmagic Web products use absolute positioning, HTML rendered in the
seams may not appear positioned as expected. Be sure to test your page to ensure the output
is what you intended.
The following illustration shows the locations of the six seams:
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Allowing Record Editing over the Web
Adding a New Record Link
This topic pertains to WebPublisher PRO.
When designing screens and forms for use on the Web, you can add a New record link to
open an empty edit form from which you can add a new record.
You can add a New record link to query screens, report forms, display forms, and edit forms.
On a query screen, report form, and display form, the New record link opens an empty edit
form from which you can add a new record.
On an edit form, it creates a copy of the current record in the edit screen. The duplicate record
can be edited, as needed, and saved as a new record.
To add a New record link to a query screen
1. Open the query screen in the Query Screen Designer.
2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, in the Text box, enter the text you want to appear as the link text on the
query screen when viewed on the Web. For example, type Add New Record.
4. On the HTML tab, from the Treat text as drop-down list, select New record link.
5. Click Apply, then Close.
To add a New record link to a form
When adding a New record link to a report or display form, you can create the link from content
in a form box or from text you type in a text box.
1. Open the form in the Form Designer.
2. Add a text box or a form box, depending on what you want to do:
If you want to use text you type as the link to an empty edit screen:
a. Choose Edit>Add>Text Box to add a text box and open the Text Box
Properties dialog box.
b. On the Text tab, in the Text box, enter the text you want to appear as the
link to an empty edit screen. For example, type Add New Record.
c. On the HTML tab, from the Treat text as drop-down list, select New record
link.
d. Click Apply, then Close.
If you want to use field content or other form box contents (for example, Fixed Text)
as the link to an empty edit screen:
a. Choose Edit>Add>Form Box to add a form box or select an existing form
box and choose Tools>Box Properties. The Form Box Properties dialog
box opens.
b. Select or add the content item whose content you want to use as the link to
the empty edit screen.
c. On the HTML tab, from the Treat content item as drop-down list, select
New record link.
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d. Click Apply, then Close.
3. Save the form for use on the Web and in the appropriate window (for example, Report
Window, Display Window, Edit Window), depending on the type of form you designed.
(Note that if you save it for use in the Edit Window, the link will make a copy of the
current record in the edit screen, not open an empty edit screen.)
Note that if you plan to add new records from a browser, you can design a Web edit form so that
a default value appears in the field(s) you specify. For more information, see Using Default
Values on a Web Edit Screen.

Editing Records Over the Web
This topic applies to WebPublisher PRO. If you want users to be able to add, edit, and delete
records in your textbase from a Web browser, you need to perform several steps to prepare
your textbase and to design the forms and screens for it.
Important! To edit records over the Web, the account accessing WebPublisher PRO must have
Read-Write access to the folder in which the textbase resides, and JavaScript must be enabled
on the end user's machine.
To enable users to edit your textbase over the Web
1. Modify the textbase structure to enable it for editing over the Web.
a. Open the textbase and choose Maintain>Edit Textbase Structure to open the
Edit Textbase Structure dialog box.
b. Click the XML Match Fields button to open the Specify XML Match Fields dialog
box and specify the fields on which you want to match when editing or deleting
records over the Web.
Tip! To add records over the Web, textbase passwords (if any) must have at least
Read-Only access to the match fields you specify. To edit or delete records over the
Web, textbase passwords need Full Access to the match fields you specify.
2. Design Report and/or Display forms to use when results are displayed on the Web.
There are several things to consider when designing these forms:
When you save each form, on the Save Form As dialog box, select the Textbase
File (Public) option button in the Save In group, and the appropriate check boxes in
the Use For group. For Report forms, save the form for use in the Report Window
and on the Web. For Display forms, save the form for use in the Display Window
and on the Web. Doing this makes the form appear in the appropriate form dropdown lists on the Web.
Add New record, Edit record, and/or Delete record links to the Report and
Display forms. You do not have to add all three types of links to all forms. (You can
add the links using text or form boxes.)
3. Design one or more Edit forms to use on the Web. There are several things to consider
when designing an Edit form for the Web:
When you save each form, on the Save Form As dialog box, select the Textbase
File (Public) option button in the Save In group, and select the Edit Window and
Web check boxes in the Use For group. Doing so makes the form appear in the
appropriate form drop-down lists on the Web.
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Add a New record link to the Edit form to enable you to duplicate a record. Note
that Delete record links and Edit record links do not appear on Edit forms used
on the Web.
[Optional] Add a password box to control who can add, edit, and delete records
from this edit screen. Passwords are defined in the textbase structure.
Note: If a password is specified on the query screen, it is automatically passed to the edit
page and you do not need to add a password box to the edit screen.
4. Design a query screen and specify its default forms:
In the Query Screen Designer, choose Tools>Screen Properties to open the
Screen Properties dialog box. On the HTML tab, click the Initial Report Form,
Initial Display Form, and Initial Edit Form buttons to specify the form you want to
use initially for each page on the Web.
If you want users to be able to add a new record from the query screen, add a New
record link. Note that Delete record links and Edit record links are not available
in the Query Screen Designer.
[Optional] Add a password box to control access to the textbase from this query
screen.
Export the query screen to HTML.
Note that if you plan to add new records from a browser, you can design a Web edit form so that
a default value appears in the field(s) you specify. For more information, see Using Default
Values on a Web Edit Screen.
An alternative
If you only want to add new records to the textbase from the Web (not edit or delete records),
you can use an alternative method.
Design an edit form and export it to HTML. This provides users direct Web access to the edit
screen, from which they can add records (for example, a registration form for an event).
Note that this method is appropriate for when you do not want users to have to open a query
screen, or submit a search, or display records. The edit screen is opened directly from its URL
(for example, by clicking a link on your intranet).

Editing information on the Web
When entering information on the Web, you can type information in the applicable boxes on the
screen or paste information from a validation list (if the designer of the screen provided
validation list links).
Each box represents one field. Click in the box where you want to begin typing, or press Tab or
Shift+Tab to move from box to box. Tab order is preserved on the Web.
To create multiple entries in a field, use the pipe character (|). The pipe character is the Web
equivalent to pressing F11 on the desktop.

Duplicating a Record (WebPublisher PRO)
You can design an edit screen that lets users duplicate the current record when editing records
over the Web. Duplicate records can only be created from an edit screen and are created using
a New record link.
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To create a duplicate record link on the Web
1. In the Form Designer, open the edit form to which you want to add the duplicate record
link.
2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog
box.
3. On the Text tab, in the Text box, enter the text you want to appear as the link that
creates the duplicate record. For example, type Duplicate Record.
4. On the HTML tab, from the Treat text as drop-down list, select New record link.
5. Click Apply, then Close.
6. Choose Form Operations>Save Form As and save the form for use on the Web and in
the Edit Window.
When a user is editing a record using the form you just saved, the phrase Duplicate Record
will appear as a link in the record. Clicking the link will create a copy of the current record in the
edit screen. The new record can be edited, as needed, then saved as a new record.

Adding a Delete Record Link
This topic pertains to WebPublisher PRO.
When designing screens and forms for use on the Web, you can add a Delete record link to
open the current record in an edit screen from which you can delete the record. You can add a
Delete record link to report and display forms.
To add a Delete record link to a form
When adding a Delete record link to a report or display form, you can create the link from
content in a form box or from text you type in a text box.
1. Open the form in the Form Designer.
2. Add a text box or a form box, depending on what you want to do:
If you want to use text you type as the link to a delete record page:
a. Choose Edit>Add>Text Box to add a text box and open the Text Box
Properties dialog box.
b. On the Text tab, in the Text box, enter the text you want to appear as
the link to a delete record page. For example, type Delete Record.
c. On the HTML tab, from the Treat text as drop-down list, select Delete
record link.
d. Click Apply, then Close.
If you want to use field content or other form box contents (for example, Fixed Text)
as the link to a delete record page:
a. Choose Edit>Add>Form Box to add a form box or select an existing form
box and choose Tools>Box Properties. The Form Box Properties dialog
box opens.
b. Select or add the content item whose content you want to use as the link to
the delete record page.
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c. On the HTML tab, from the Treat content item as drop-down list, select
Delete record link.
d. Click Apply, then Close.
3.
Save the form for use on the Web and in the appropriate window (that is, Report Window
and/or Display Window), depending on the type of form you designed.

Adding an Edit Record Link
This topic pertains to WebPublisher PRO.
When designing screens and forms for use on the Web, you can add an Edit record link to
open the current record in an edit screen from which you can make changes.
You can add an Edit record link to report and display forms.
To add an Edit record link to a form
When adding an Edit record link to a report or display form, you can create the link from
content in a form box or from text you type in a text box.
1. Open the form in the Form Designer.
2. To specify the text to use as the link to an edit screen:
a. Choose Edit>Add>Text Box.
b. On the Text tab, in the Text box, enter the text you want to appear as the link to an
edit screen. For example, type Edit Record.
c. On the HTML tab, from the Treat text as drop-down list, select Edit record link.
d. Click Apply, then Close.
3. To use field content or other form box contents (for example, Fixed Text) as the link to
an edit screen:
a. Choose Edit>Add>Form Box to add or select a form box, and choose Tools>Box
Properties.
b. Select or add the content item whose content you want to use as the link to the edit
screen. For example, you may select the Title field so that the title of the publication
appears as an Edit record link that, when clicked, opens the record for that
publication in an edit screen.
c. On the HTML tab, from the Treat content item as drop-down list, select Edit
record link.
d. Click Apply, then Close.
4. Save the form for use on the Web and in the appropriate window (that is, Report Window
and/or Display Window), depending on the type of form you designed.

Using Default Values on a Web Edit Screen
When you design an Edit form for use on the Web, you can specify that default information
automatically appear in a specific field each time the edit screen is used to create new records.
For example, if you are using a Web edit screen to add sales orders to your textbase, you can
design a custom edit form for each sales representative so that his or her name automatically
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appears in the Sales Rep field for each new record. This ensures that this field always has
information in it, and reduces the amount you have to type.
Note: Default values only appear on edit forms used to add new records, they will not appear on
edit forms used to edit existing records.
To specify that default field information appear on a Web edit screen
1. In the Form Designer, open the Edit form you plan to use on the Web to add new
records.
2. Select the form box containing the field for which you want a default value inserted. For
example, on a sales order edit form, select the form box containing the Sales Rep field.
3. Choose Tools>Box Properties to open the Form Box Properties dialog box. (Notice
that the field in the form box you selected in the previous step appears in the Contents
list and is selected in the Fields list.)
Note: To have a default value appear automatically on the screen, the field must be the
first item in the form box.
4. On the Fields subtab of the Contents tab, in the If empty use box, enter the default
information you want to appear in the field when the Web edit screen opens in a
browser. For example, type Marlena Bryce.
5. Click the Replace button.
6. Click Close.
When you use this edit form to create new records on the Web, Marlena Bryce will appear
automatically in the Sales Rep box.
Note: This also applies to editing forms that are exported to HTML.

Submitting XML to WebPublisher PRO
Using XML Input for Queries to WebPublisher PRO
Instead of a query or menu screen or a canned query, you can use XML input to send
commands to WebPublisher PRO. The following example performs a search in the Vehicles
textbase (<TN>vehicles</TN>) and displays the records using the Prices form
(<RF>Prices</RF>) in HTML format (<XM>0</XM>):
<?xml version="1.0" ?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>vehicles</TN>
<QY>Findall</QY>
<RF>Prices</RF>
<XM>0</XM>
</Query>

Notes
Use the <AC> element to specify the action you want the software to take. See
Submitting XML Actions to WebPublisher PRO for a list of the supported actions.
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When you submit XML, output is returned in XML format by default unless you explicitly
specify that you want HTML output (<XM>0</XM>).
You must use the QY (Command Query format) parameter when specifying a query
using XML input. HTML query screen searches still use the QBn/QIn/QFn parameters,
and you can still use this syntax when specifying canned queries.
You can specify how much query detail (about the search you performed) is returned by
using detail= in the opening <Query> tag. For example:
<Query xmlns="http://www.inmagic.com/webpublisher/query" detail="off">

The options are:
qy = shows just the contents of the QY tag (default)
full = shows the entire contents of the <Query> input
off = does not show any query input
You have the following options for specifying what is returned in the output:
Use the <KeyFields> element to list the fields you want returned. You can only specify
fields from the primary textbase. If you need to return secondary fields, use the <RF>
element.
Use the <SortFields> element to sort records. This element lets you specify the type of
sort you want, including the ability to specify a primary sort field, alternate primary sort
field(s), and subsort fields. If no explicit sort order is specified, and the textbase has a
default sort order, that is the order in which records appear in the returned XML. You can
only sort by fields in the primary textbase with the <SortFields> element. If you need to
sort by a secondary textbase field, use the <RF> element.
Example
<?xml version="1.0" ?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<QY>Findall</QY>
<AC>query</AC>
<TN>vehicles</TN>
<KeyFields>
<KeyField>Name</KeyField>
<KeyField>Features</KeyField>
</KeyFields>
<SortFields sort="specify">
<SortField type="sort" reverse="y">DateReleased</SortField>
<SortField type="sort">Name</SortField>
</SortFields>
</Query>

Using Third-Party Tools with WebPublisher PRO
By combining its searching and editing power with Extensible Markup Language (XML),
WebPublisher PRO allows you to integrate your textbases with other applications and create
interactive forms using standard third-party tools (such as Microsoft FrontPage).
Once you have built your own Web interface, use the read-write XML features of WebPublisher
PRO (including the ability to query a DB/TextWorks textbase via the Web using XML) to enable
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that interface to search, add, edit, and/or delete records in your textbase over the Web. This
method is for advanced users, or those with access to a Web designer with XML/XSL skills.
Note: For information about the XML you can submit to WebPublisher PRO, see the input
schema documentation. An HTML version of the schema documentation is located at
http://support.inmagic.com/web.
We strongly recommend you do the following before and/or while you build your custom
interface:
Review the three general phases you need to follow when you design an interface to let
your end users search for, edit, add, and delete records via the Web.
Familiarize yourself with the structure of the WebPublisher PRO input schema.
Ensure that all XML elements and attributes submitted to WebPublisher PRO are well
formed and valid.
Use the required namespace in the <Query> element with any action submitted to
WebPublisher PRO.
Create tag names for fields that meet the requirements of XML and your development
environment.
Use CDATA if you want to preserve white space in the content of a field.

Three Phases for Designing a Web Interface with a Third-party Tool
Before you start designing an interface for WebPublisher PRO, take some time to familiarize
yourself with the read-write features available to you.
There are three general phases you need to follow when you design an interface to let your end
users search for, edit, add, and delete records via the Web.

Phase 1: Create the XML query
Using the <Query> tag as the root element, develop a request to WebPublisher PRO asking it to
perform an action (for example, an insert). The action you request will be enclosed in the
<AC></AC> element.
There are numerous ways to build your XML query, including using JavaScript in an .ASP page.
You can even type the XML in Microsoft Notepad.
For more information about the actions you can submit and for sample code, see Submitting
XML Actions to WebPublisher PRO.

Phase 2: Send the XML query to WebPublisher PRO
Once you have a well-formed, valid query, you can send it to WebPublisher PRO. There are a
variety of ways you can do this.
For example, you can use Microsoft XML Core Services 4.0 (MSXML4), which was installed
with WebPublisher PRO. MSXML4 has an HTTP response-and-request mechanism. You can
also use other methods, such as Microsoft ASP.NET or SOAP.

Phase 3: Get a response back in XML
When you submit an action in XML format (for example, an update), the software returns
results in XML format.
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The XML returned is enclosed in the <inm:Results> root element. The "inm" namespace prefix
is used in all output tags in a WebPublisher PRO response.
For more information about WebPublisher PRO responses and sample output code, see
Submitting XML Actions to WebPublisher PRO.

Schemas for WebPublisher PRO
WebPublisher PRO uses three schemas, one for input and two for output. These schemas
describe the structure of the data that can be submitted to and returned by WebPublisher PRO.

Input Schema
Use the schema_input command in the <AC> element to generate the input schema. This input
schema shows the structure of the XML that can be submitted to WebPublisher PRO.
Any actions you submit to WebPublisher PRO must be enclosed in the <Query> root element
and include the appropriate namespace.
Schema documentation, in HTML format, is provided for this input schema at
http://support.inmagic.com/web.

Output Schemas
WebPublisher PRO has two types of output schemas:
Query output schema. When you search for records using WebPublisher PRO, results
are returned within the <inm:Recordset> root element. There are two "flavors" of the
query output schema that detail the tags that can be included in the root element. They
can be generated using the <AC> element:
tb_schema_query.

This command generates the output schema for the specified
textbase. All fields in the primary textbase are included, except those hidden by a
password.
rf_schema_query.

This command generates the output schema for the specified
report form. A query must be specified. Only fields specified in the form are
included.
Modify output schema. When submitting a request to WebPublisher PRO to modify the
textbase in some way (that is, by adding, editing, or deleting records), results are
returned within the <inm:Records-Processed> root element. To generate the modify
output schema, which details the tags that can be included in the root element, use the
tb_schema_output command.
The two types of output schemas used by WebPublisher PRO do not have schema
documentation provided, as they are not used by the Web designer to enter information. Rather,
these schemas are used by outside applications to understand the XML returned by
WebPublisher PRO.

Using WebPublisher PRO with SOAP
If you plan to use your custom-built WebPublisher PRO interface with SOAP, by default the
XML output is emitted in a format that is compatible with most development environments that
use SOAP. Many third-party development environments impose strict requirements on
identifiers.
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Unless otherwise specified, WebPublisher PRO replaces spaces and hyphens in field names
with underscores in its XML output. In addition, the old <Records-Processed>, <RecordProcessed> and <Record-Error> elements are emitted as <RecordsProcessed>,
<RecordProcessed>, and <RecordError>.
The following example shows XML input for a query that includes field names with underscores
in place of spaces:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>staffing</TN>
<QY>Find Employee_ID =AL4357</QY>
<KeyFields>
<KeyField>Employee_ID</KeyField>
<KeyField>Employee_Name</KeyField>
<KeyField>Job_Title</KeyField>
<KeyField>Hire_Date</KeyField>
</KeyFields>
</Query>

The output from the above query is returned with underscores in place of spaces, as well:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:QY>Find Employee_ID =AL4357</inm:QY>
<inm:Recordset AC="query" setCount="1">
<inm:Record setEntry="0">
<inm:Employee_ID>AL4357</inm:Employee_ID>
<inm:Employee-Name>Mia Alabiso</inm:Employee_Name>
<inm:Job_Title>Staff Accountant</inm:Job_Title>
<inm:Hire_Date>August 7, 2008</inm:Hire_Date>
</inm:Record>
</inm:Recordset>
</inm:Results>

The SQL version of WebPublisher PRO (Content Server) always used underbars by default, but
non-SQL WebPublisher PRO prior to v12 used hyphens instead. If you have any XML
WebPublisher PRO applications developed using hyphens for spaces instead of underbars, you
can set SOAPformat=0 in the [WebPublisher] section of DBTWPUB.INI.

Formatting XML Input
Using Well Formed and Valid XML
When submitting XML to WebPublisher PRO all elements and attributes must be both:
Well Formed. All XML must follow the standard established by the World Wide Web
Consortium (http://www.w3c.org). Note that the W3C standard requires starting and
ending tags to match, including case.
Valid. Elements, attributes, and attribute values must follow the format specified in the
WebPublisher PRO schema. All are case sensitive. For example, <ac>update</ac> is
not valid because the <AC> element is uppercase in the WebPublisher PRO schema.
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Required Namespace
Any action submitted to WebPublisher PRO must declare the following namespace in the
<Query> element:
<Query xmlns="http://www.inmagic.com/webpublisher/query">

All WebPublisher PRO output includes the namespace prefix inm in each element.
If your development environment requires it, you can optionally include the namespace prefix
inm in all input elements. However, for WebPublisher PRO to recognize the input, you must
specify the prefix in the namespace declaration:
<inm:Query xmlns:inm="http://www.inmagic.com/webpublisher/query">

The following example shows the declaration of the inm namespace prefix and its use in input
elements:
<?xml version="1.0"?>
<inm:Query detail="qy"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:AC>query</inm:AC>
<inm:TN>sample</inm:TN>
<inm:QY>Find id=*</inm:QY>
<inm:KeyFields>
<inm:KeyField>ID</inm:KeyField>
</inm:KeyFields>
</inm:Query>

The option to include the namespace prefix in all input tags is not a requirement of
WebPublisher PRO. If you do not want to submit XML with the prefix, do not include the prefix in
the namespace declaration.
The examples in this online help file do not use the namespace prefix in XML input.
Note: The inm prefix is automatically included in all output elements, regardless of whether it
was declared in the input.

Creating Tag Names for XML Input
When submitting field names to WebPublisher PRO in XML, all tags must be valid.
Field names containing characters that are unacceptable in XML should be modified as follows
when being used as XML tags or when referring to the field name in a <MatchField>,
<KeyField>, or <FN> tag:
Replace spaces and hyphens with underbars. For example, if a field in your textbase
is named date added, you must use <date_added>.
Replace extended characters with the equivalent character without the diacritic.
For example, if a field in your textbase is named Société ["Company" in French], you
must use <Societe>.
Precede digits at the beginning of a field name with an underscore. For example, if
a field in your textbase is named 1stqtr, you must use <_1stqtr>. (This is required
regardless of whether you plan to use SOAP.)
The following table shows how field names with unacceptable characters should be submitted to
WebPublisher PRO in XML, depending on whether SOAP formatting is on or off.
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Textbase Field Name

SOAP Formatting ON
(default)

SOAP Formatting OFF (if
specified, not recommended)

First Name

First_Name

First-Name

4th-Qtr Revenue

_4th_Qtr_Revenue

_4th-Qtr-Revenue

-end- date

_end__date

_end--date

Réseau
["Network" in French.]

Reseau

Reseau

If you are unsure of how WebPublisher PRO will treat your special-case field names, ask the
software to return a tb_schema_query (submit the following action: <AC>tb_schema_query</AC>)
and review the field names listed there. For example:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>tb_schema_query</AC>
<TN>vehicles</TN>
</Query>

Preserving White Space in XML Input
When submitting XML to WebPublisher PRO, you can specify that all of the white space in the
content of a field be preserved.
To do this, wrap the content in a CDATA. If you do not use CDATA, leading and trailing white
space will be removed. "White space" consists of spaces as well as line breaks.
Example
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC validation="none">insert</AC>
<TN>vehicles</TN>
<KeyFields>
<KeyField>ProductNumber</KeyField>
</KeyFields>
<Recordset>
<Record>
<ProductNumber>DH0001</ProductNumber>
<Name>Honda Civic</Name>
<Description><![CDATA[ This model car has a working radio.
Sold in CA only.]]></Description>
<Colors>Blue</Colors>
</Record>
</Recordset>
</Query>

Accepted Actions <AC></AC>
Submitting XML Actions to WebPublisher PRO
Enclose any "action" you want WebPublisher PRO to perform between the opening <AC> tag
and closing </AC> tag.
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All actions are submitted within the <Query> root element. All results, except for those that
return schemas, are returned within the <inm:Results> root element.
Important! Do not confuse the <Query> root element with the <AC>query</AC> command. The
<Query> root element tells WebPublisher PRO that you are asking it to do something (for
example, delete a record). The query command is used within the <AC> element to tell
WebPublisher PRO that you are searching for records.
The following table lists the recognized actions and what they do. If the name of an action is a
link in the first column, click it to view more information about that action and see sample code.
This action:

Does this:

query

Searches for records.

update

insert

Modifies one or more existing records. Update behaves like the
DB/TextWorks import feature in that it checks for matching records, then
modifies the records as specified by the matchFound attribute (the
default is to replace fields) when a match is found. If no match is found,
the information is treated according to the matchNotFound attribute
(the default is to add as a new record).
Adds one or more records to the textbase.

delete

Deletes one or more records from the textbase.

batch_delete

Deletes records that satisfy a query from the textbase.

tb_field_info

Returns an overview of field settings for a particular textbase. You can
use <KeyFields> to return information for only the fields you want, or
omit the <KeyFields> tag to return information on all fields in the
textbase.
validation_lists
Returns detailed information on the field validation in a textbase. You
can use <KeyFields> to return validation information for only the fields
you want, or omit the <KeyFields> tag to return information about all
fields in the textbase that have validation lists. If you specify any
<KeyFields> that do not have a validation list, validation information for
that field (if any) will be returned, but no list will appear. Note that if a
thesaurus is used as a validation list, only preferred terms are included.
To see non-preferred terms, submit the validation_lists_thes command
instead.
validation_lists_thes Returns detailed information on the field validation in a textbase,
including non-preferred terms (if a thesaurus is used as a validation list).
You can use <KeyFields> to return validation information for only the
fields you want, or omit the <KeyFields> tag to return information about
all fields in the textbase that have validation lists. If you specify any
<KeyFields> that do not have a validation list, validation information for
that field (if any) will be returned, but no list will appear.
term_index
Returns all existing term index entries for specified field(s). You can use
<KeyFields> to return term index entries for only the fields you want, or
omit the <KeyFields> tag to return information about all fields in the
textbase.
Note that term_index also returns validation information.
Tip! Returning all index entries for a field that contains many entries
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word_index

index_by_key

index_key_greatest

may take several minutes. If this is a concern, consider using
index_by_key instead.
Returns all existing word index entries for specified field(s). You can use
<KeyFields> to return word index entries for only the fields you want, or
omit the <KeyFields> tag to return information about all fields in the
textbase.
Note that word_index also returns validation information.
Tip! Returning all index entries for a field that contains many entries
may take several minutes. If this is a concern, consider using
index_by_key instead.
Returns index information for a single field in sets of 256 entries. Use
this command when you know that a term or word index is very large.
Note that you must specify only one field with the <KeyFields> element
(or use its alternative, the <FN> element). If you specify more than one
field, an error is returned.
Returns the last set of 256 keys in an index. Use this command when
you know that a term or word index is very large. Note that you must
specify only one field with the <KeyFields> element (or use its
alternative, the <FN> element). If you specify more than one field, an
error is returned.

tb_schema_query

Generates the output schema for the specified textbase. All fields in the
textbase are included, except those hidden by a password.

rf_schema_query

Generates the output schema for the specified report form. A query
must be specified. Only fields specified in the <RF> form are included. If
no <RF> is specified, the schema for the textbase default Report
Window form is returned.

tb_schema_output

Generates the output schema for results returned after a record has
been modified using insert, update, delete, or batch_delete. Provides
information about the textbase that you need to know when modifying
records.

schema_input

Generates the input schema.

Using the QUERY Command in XML Input
Use the query command to search for records in a particular textbase and return record
information in XML format.
Use the <QY> element to enclose the search syntax in Command Query format. Also, replace
XML significant characters (for example, >, &) with their encoded equivalents (for example, &gt;,
&amp;).
Sample input for a query command:
Note that the proper namespace must be included in the <Query> root element.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>vehicles</TN>
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<QY>Find Name =supra</QY>
<KeyFields>
<KeyField>Name</KeyField>
<KeyField>RetailPrice</KeyField>
<KeyField>DealerPrice</KeyField>
<KeyField>Features</KeyField>
</KeyFields>
</Query>

Sample output from a query command:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:QY>Find Name =supra</inm:QY>
<inm:Recordset AC="query" setCount="2">
<inm:Record setEntry="0">
<inm:Name>Supra</inm:Name>
<inm:RetailPrice>266</inm:RetailPrice>
<inm:DealerPrice>133</inm:DealerPrice>
<inm:Features>Cleaning kit</inm:Features>
<inm:Features>Independent suspension</inm:Features>
<inm:Features>Interchangeable wheels</inm:Features>
<inm:Features>Oil-filled shocks</inm:Features>
<inm:Features>Tube tires</inm:Features>
<inm:Features>Variable speed</inm:Features>
</inm:Record>
<inm:Record setEntry="1">
<inm:Name>Supra</inm:Name>
<inm:RetailPrice>428</inm:RetailPrice>
<inm:DealerPrice>214</inm:DealerPrice>
<inm:Features>Cleaning kit</inm:Features>
<inm:Features>Independent suspension</inm:Features>
<inm:Features>Interchangeable wheels</inm:Features>
<inm:Features>Oil-filled shocks</inm:Features>
<inm:Features>Tube tires</inm:Features>
<inm:Features>Variable speed</inm:Features>
</inm:Record>
</inm:Recordset>
</inm:Results>

Sample output from a query that finds no records:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:QY>Find name =volkswagen</inm:QY>
<inm:Recordset AC="query" setCount="0">
</inm:Recordset>
</inm:Results>
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Notes about the query command
Use the following elements to specify what is returned after a query:
Use the <KeyFields> element to list the fields you want returned. You can only
specify fields from the primary textbase. If you need to return secondary fields, use
the <RF> element instead.
Use the <SortFields> element to sort records. This element lets you specify the
type of sort you want, including the ability to specify a primary sort field, alternate
primary sort field, and subsort fields. If no explicit sort order is specified, and the
textbase has a default sort order, that is the order in which records appear in the
returned XML. You can only sort by fields in the primary textbase with the
<SortFields> element. If you need to sort by a secondary textbase field, use the
<RF> element instead.
There is an optional attribute for the <Query> root element called detail. This attribute
specifies the amount of <Query> information that you want returned when you perform
an action (<AC>) that searches the textbase (that is, query, or batch_delete). The detail
attribute can have the following values:
"qy" returns only the search criteria submitted in the <QY> element. This is the
default value.
"full" returns all XML input submitted. (That is, all XML contained in the <Query>
root element.)
"off" turns off this feature.
The setCount and setEntry attributes are used to count the number of records in the
set retrieved by a query. The setCount attribute appears within the parent <Recordset>
element and shows the total number of records in the set; the setEntry attribute appears
within each <Record> element and serves as a counter, starting with zero (that is,
setEntry="0" for the first record retrieved).

Using the UPDATE Command in XML Input
Use the update command to update one or more records in a particular textbase.
When updating records, you can specify what the software should do when it finds records that
match on the fields you specify in your input. (The software uses matching to uniquely identify
the record to modify.)
Use the matchFound and matchNotFound attributes in the <AC> element.
Sample input for an update:
Note that the proper namespace must be included in the <Query> root element.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>update</AC>
<TN>vehicles</TN>
<MatchFields>
<MatchField>ProductNumber</MatchField>
</MatchFields>
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<KeyFields>
<KeyField>ProductNumber</KeyField>
</KeyFields>
<Recordset>
<Record>
<ProductNumber>AP3673</ProductNumber>
<RetailPrice>320</RetailPrice>
</Record>
</Recordset>
</Query>

Tip! The <AC> element in the input can contain the optional validation attribute, which lets you
specify whether validation can be overridden and whether validation lists can be updated.
Sample output from an update:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:Records-Processed AC="update" succeeded="1" failed="0" amended="1">
<inm:Record-Processed result="amended">
<ProductNumber>AP3673</ProductNumber>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

Sample error output from an update:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:Records-Processed AC="update" succeeded="0" failed="1" amended="0">
<inm:Record-Processed result="rejected">
<ProductNumber>AP3673</ProductNumber>
<inm:Record-Error code="16458">Found multiple records in textbase
that
match the record in the incoming data.</inm:Record-Error>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

matchFound attribute
The matchFound attribute specifies what the software should do if a match is found. It can
have the following values:
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"replaceFields" to replace the information in the specified fields with the fields being
submitted. This enables you to update or delete information in multiple fields without
replacing the entire record. This is the default value.
"rejectRecord" to reject the incoming record.
"appendFields" to append the entries in the incoming record to the entries in those
fields in the existing record.
"replaceRecord" to replace the existing record with the incoming record.
"deleteRecord" to delete the incoming record.
matchNotFound attribute
The matchNotFound attribute specifies what the software should do if a match is NOT found. It
can have the following values:
"acceptRecord" to accept the incoming record as a new record. This is the default
value.
"rejectRecord" to reject the incoming record.
Notes about the update command
Whenever any records are processed, the <inm:Records-Processed> element contains
the succeeded and failed attributes. This lets you know how many records were
successfully processed and how many failed. The sum of the succeeded and failed
attributes is equal to the total number of records submitted for processing. The
<inm:Records-Processed> element may also include one of the following attributes:
amended, replaced, or deleted. If the succeeded attribute is not equal to this attribute,
then the difference is the number of new records that were added (because no match
was found).
One or more <inm:Record-Processed> elements are nested within the parent
<inm:Records-Processed> element. Each <inm:Record-Processed> element represents
an individual record. It will have a result attribute, which can have the following values:
"added" if the record was added as a new record (because no match was found).
"rejected" if the update failed to happen. To find out why a record was rejected,
refer to the <inm:RecordError> element. One reason this may happen is if multiple
textbase records matching the incoming record were found.
"amended" if the record matched an existing record and was updated
(replaceFields or appendFields) with the new information you supplied.
"replaced" if the record matched an existing record and was replaced with the new
information you supplied.
"deleted" if the record was deleted.
You must specify one or more fields with the <MatchFields> element. If you do not,
WebPublisher PRO will display an error message.
You can specify up to five (5) MatchFields when doing an update.
Use the <KeyFields> element to specify which fields you want included in the
confirmation information returned in the XML output. If you omit the <KeyFields>
element, no fields are included in the XML output.
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Using the INSERT Command in XML Input
Use the insert command to add one or more records to a particular textbase. The insert
command works like the update command. However, when submitting an insert, the software
does not attempt to match records prior to adding the new record. That means you do not use
the <MatchFields> element when doing an insert.
Sample input for an insert:
Note that the proper namespace must be included in the <Query> root element.
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>insert</AC>
<TN>vehicles</TN>
<KeyFields>
<KeyField>ProductNumber</KeyField>
</KeyFields>
<Recordset>
<Record>
<ProductNumber>AP7707</ProductNumber>
<Name>Mini Cooper</Name>
<Features>Display case</Features>
<Features>Glass</Features>
<Colors>Chili Red</Colors>
<Colors>Silk Green</Colors>
<Type>Assembled Painted</Type>
<Scale>1:10</Scale>
<DateReleased>10/07/2002</DateReleased>
<RetailPrice>430</RetailPrice>
<ClubPrice>330</ClubPrice>
</Record>
</Recordset>
</Query>

Sample output from an insert:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:Records-Processed AC="insert" succeeded="1" failed="0">
<inm:Record-Processed result="added">
<inm:ProductNumber>AP7707</inm:ProductNumber>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

Sample error output from an insert:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:Error code="16473" extra="">Unknown KeyField name:
"ProductID".</inm:Error>
<inm:Records-Processed AC="update" succeeded="0" failed="0">
</inm:Records-Processed>
</inm:Results>
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Notes about the insert command
If your textbase has an Automatic ID field, WebPublisher PRO will not automatically
populate this field when creating a new record with the insert command.
To have the next available ID entered by the application, apply Unique Entries Only
validation to the Automatic ID field in DB/TextWorks (using Maintain>Edit Textbase
Structure). Then, when submitting an insert, supply a value for the Automatic ID field
that already exists in the textbase and is lower than the ID you want to add. Because
you are entering a value that already exists, WebPublisher PRO will automatically
increment the field contents to the next available ID.
Whenever any records are processed, the <inm:Records-Processed> element contains
the succeeded and failed attributes. This lets you know how many records were
successfully processed and how many failed. The sum of the succeeded and failed
attributes is equal to the total number of records submitted for processing.
One or more <inm:Record-Processed> elements are nested within the parent element.
Each <inm:Record-Processed> element represents an individual record. It will have a
result attribute, which can have the following values:
"added" if the record was added as a new record.
"rejected" if the insert failed. To find out why a record was rejected, refer to the
<inm:Record-Error> element.

Using the DELETE Command in XML Input
Use the delete command to remove one or more records from a particular textbase.
Sample input for a delete:
Note that the proper namespace must be included in the <Query> root element.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>delete</AC>
<TN>vehicles</TN>
<MatchFields>
<MatchField>ProductNumber</MatchField>
</MatchFields>
<KeyFields>
<KeyField>ProductNumber</KeyField>
</KeyFields>
<Recordset>
<Record>
<ProductNumber>AP3673</ProductNumber>
</Record>
<Record>
<ProductNumber>AP3674</ProductNumber>
</Record>
</Recordset>
</Query>

Sample output from a delete, including one error:
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<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="10.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:Records-Processed AC="delete" succeeded="1" failed="1">
<inm:Record-Processed result="deleted">
<inm:ProductNumber>AP3673</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="rejected">
<inm:ProductNumber>AP3674</inm:ProductNumber>
<inm:Record-Error code="16459">Found no matching record in
textbase to
delete.</inm:Record-Error>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

Notes about the delete command
If the textbase has passwords, you can only delete records if the password you specify
using the <ID> element has full access to all fields in the textbase.
In the above output example, one record was deleted because it was found in the
textbase as a unique record. The other record was not deleted because it was not found
in the textbase. Because of this, the <inm:Records-Processed> element contains the
attributes succeeded="1" failed="1".
Note also that the <Record-Processed> element has a result attribute, which can have
the following values:
"deleted" if the record was deleted.
"rejected" if the record was not deleted for the specified reason.
When deleting records, only specify <KeyFields> that also appear in the <Record>
element. Because the record is deleted, WebPublisher PRO cannot retrieve information
from the textbase record, so it displays the <KeyFields> using the field content from the
input record.

Using the BATCH_DELETE Command in XML Input
Use the batch_delete command to delete records from a textbase that satisfy a query.
Sample input for a batch_delete:
Note that the proper namespace must be included in the <Query> root element.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>batch_delete</AC>
<TN>vehicles</TN>
<QY>Find ProductNumber =KU*</QY>
<KeyFields>
<KeyField>ProductNumber</KeyField>
</KeyFields>
</Query>
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Sample output from a batch_delete:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:QY>Find ProductNumber =KU*</inm:QY>
<inm:Records-Processed AC="batch_delete" succeeded="8" failed="0">
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU1045</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU1087</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU4333</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU1655</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU2001</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU2023</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU2528</inm:ProductNumber>
</inm:Record-Processed>
<inm:Record-Processed result="deleted">
<inm:ProductNumber>KU2909</inm:ProductNumber>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

Sample output from a batch_delete that found no records to delete:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed">
<inm:QY>Find ProductNumber =KU*</inm:QY>
<inm:Records-Processed AC="batch_delete" succeeded="0" failed="0">
</inm:Records-Processed>
</inm:Results>
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Notes about the batch_delete command
If the textbase has passwords, you can only delete records if the password you specify
using the <ID> element has full access to all fields in the textbase.
For batch_delete, the result attribute within the <Record-Processed> element can have
the following values, in addition to those listed above for delete:
"skipped-locked" if the record was not deleted because someone else was editing
it.
"skipped-no-write-access" if the record was not deleted because you do not have
write-access to it (for example, if the textbase has record-level security, and your
password only grants you read access to that record).
"skipped-no-match" if the record was found, but was already deleted by the time
batch_delete got to it.
"skipped-pending-deletion" if the record was found, but was already deleted
using deferred indexing.

Using the BATCH_MODIFY Command in XML Input
Use the batch_modify command to make the same change to the contents of a specified field
in all of the records from a textbase that satisfy a query.
Use attributes on the AC element to specify the action and entry to be modified. You can also
specify what to do in the case of a validation failure, if the field being modified has the
appropriate settings.
Attribute

Possible Values

batchModAction

appendEntry
insertEntry
deleteEntry
substEntry (default)
substText

batchModEntry

first (default for all except substText)
last
all
matching (default for substText)

validation

update
override
none (default)

These additional elements are required:
Use <QY> to specify the command query that will identify the records to be modified
Use <FN> to identify the field to be modified
Depending on the action and entry specified, other elements are needed:
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Use <EN> to specify the new entry or text for all actions except deleteEntry
Use <OE> to specify the old text or entry when specifying matching
Sample input for a batch_modify:
Note that the proper namespace must be included in the <Query> root element.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC batchModAction="appendEntry" batchModEntry="last">batch_modify</AC>
<TN>vehicles</TN>
<QY>Find ProductNumber =KU10*</QY>
<FN>Color</FN>
<EN>purple</EN>
</Query>

Sample output from a batch_modify:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/records-processed" oex="ISO8859-1">
<inm:QY>Find ProductNumber =KU10*</inm:QY>
<inm:Records-Processed AC="batch_modify" succeeded="2" failed="0">
<inm:Record-Processed result="modified">
<inm:Color>red</inm:Color>
<inm:Color>purple</inm:Color>
</inm:Record-Processed>
<inm:Record-Processed result="modified">
<inm:Color>white</inm:Color>
<inm:Color>yellow</inm:Color>
<inm:Color>purple</inm:Color>
</inm:Record-Processed>
</inm:Records-Processed>
</inm:Results>

Notes about the batch_modify command
If the textbase has passwords, you can only modify records if the password you specify
using the <ID> element has full access to the field you are modifying, and any Computed
or Automatic fields that would be affected by the operation.
For batch_modify, the result attribute within the <Record-Processed> element can have
the following values, in addition to those listed above:
"skipped-locked" if the record was not changed because someone else was
editing it.
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"skipped-no-write-access" if the record was not changed because you do not
have write-access to it (for example, if the textbase has record-level security, and
your password only grants you read access to that record).
"skipped-no-match" if the record was found, but was deleted by the time
batch_delete got to it.
"skipped-pending-deletion" if the record was found, but was deleted using
deferred indexing.

Using the VALIDATION_LISTS Command in XML Input
Use the validation_lists command to return detailed information on the field validation in a
textbase. You can specify the field(s) for which you want to see information by using the <FN>
or <KeyFields> element, or you can omit the <FN> and <KeyFields> elements to return
information for all fields in the textbase that have validation lists.
Sample input for the validation_lists command:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>validation_lists</AC>
<TN>Contractors</TN>
<FN>State</FN>
</Query>

The above input is a request for validation information for the State field in the Contractors
textbase.
Sample results from the input submitted above:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:ListSet AC="validation_lists">
<inm:List fieldName="State" type="Text" term="1" word="1"
validation="1" useList="1" useThesaurus="1" required="0" unique="0"
single="1" min="" max="" mask="" mayOverride="0" mayUpdate="0">
<inm:Entries>
<inm:Entry>CA</inm:Entry>
<inm:Entry>MA</inm:Entry>
</inm:Entries>
</inm:List>
</inm:ListSet>
</inm:Results>

The above results show the following about the State field in the Contractors textbase:
It is a Text field (type="Text").
It has a Term and Word index (term="1" and word="1")
It has validation applied (validation="1").
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It has a validation list (useList="1") and that validation list is a thesaurus used as a
validation list (useThesaurus="1").
It is not a required field (required="0"), nor does it require unique entries only
(unique="0").
It permits a single entry only (single="1").
It does not have a minimum or maximum value (min="" and max=""), nor does it have a
mask (mask="") applied.
Users may not override content validation (mayOverride="0"), nor may they update
(mayUpdate="0") the validation list.
It has the following entries: MA and CA.

Using the VALIDATION_LISTS_THES Command in XML Input
Use the validation_lists_thes command to return detailed information on the field validation in a
textbase, including non-preferred (UF) terms if the field uses a thesaurus as a validation list.
You can specify the field(s) for which you want to see information by using the <FN> or
<KeyFields> element, or you can omit the <FN> and <KeyFields> elements to return
information for all fields in the textbase that have a validation list.
Note: You can use the validation_lists_thes command on fields that do not use a thesaurus as a
validation list. It will return the same information as the validation_lists command. The
validation_lists_thes command is useful when you do not know whether a field will have a
thesaurus as a validation list, but, if it does, you want non-preferred terms included in the output.
Sample input for the validation_lists_thes command:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>validation_lists_thes</AC>
<TN>Staffing</TN>
<FN>Position</FN>
</Query>

The above input is a request for validation information for the Position field in the Staffing
textbase.
Sample results from the input submitted above:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="10.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:ListSet AC="validation_lists_thes">
<inm:List fieldName="Position" type="Text" term="1" word="1"
validation="1" useList="1" useThesaurus="1" required="0" unique="0"
single="1" min="" max="" mask="" mayOverride="0" mayUpdate="0">
<inm:Entries>
<inm:Entry use="attorney">lawyer</inm:Entry>
<inm:Entry>attorney</inm:Entry>
</inm:Entries>
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</inm:List>
</inm:ListSet>
</inm:Results>

Because the validation_lists_thes command includes non-preferred terms, the use attribute
shows the preferred (USE) term attorney for the entry lawyer:
<inm:Entry use="attorney">lawyer</inm:Entry>

Using the INDEX_BY_KEY Command in XML Input
When you use the index_by_key command, index information for a single field is returned in sets
of 256 entries. This command is useful when you have a textbase with many records and do not
want to wait for all term or word entries in field to be returned.
When submitting the index_by_key command, you can use the <IX> element to specify whether
you want a word, term, or validation list returned.
For a word list, use <IX>0</IX>.
For a term list, use <IX>1</IX>. This is the default.
For a validation list, use <IX>2</IX>.
You can also use the <EN> element to return a specific part of the index. The <EN> element
lets you specify the word, term, or validation item that you want used as the starting point of the
index list to be returned. If <EN> is omitted, the first 256 keys are returned.
To return the next batch of 256 index entries, specify the last entry of the present batch with the
<EN> element.
For example, in the following code, the word index display will start with the author Hawthorne.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<TN>sample</TN>
<AC>index_by_key</AC>
<KeyFields>
<KeyField>Author</KeyField>
<KeyFields>
<IX>0</IX>
<EN>Hawthorne</EN>
</Query>

Attributes
Using Validation with XML Input
Note: This topic applies to XML submitted to WebPublisher PRO.
If a field entry in the incoming record is not in the validation list for that field or it violates
range/mask validation, you can add the entry to the field in the record with or without adding it to
the validation list.
To do this, use the validation attribute in the <AC> element.
Note: The field must have the appropriate settings specified in the textbase structure (for
example, on the Edit Fields dialog box, Validation tab, select the User May Override Content
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Validation and User May Update Validation List with Override Value check boxes). When
doing an update, the password specified (if any) must allow the editing of validation lists.
The validation attribute can have the following values:
"none" to reject the record if the entry violates validation. This is the default value.
"override" to accept the entry, but not add it to the validation list.
"update" to accept the entry and add it to the validation list.
In the following example, the validation attribute is set to "override":
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC validation="override" matchFound="appendFields">update</AC>
<TN>vehicles</TN>
<MatchFields>
<MatchField>ProductNumber</MatchField>
</MatchFields>
<Recordset>
<Record>
<ProductNumber>AP3673</ProductNumber>
<Features>Working radio</Features>
</Record>
</Recordset>
</Query>

If you want to update the validation list to include the entry, set the validation attribute to
"update". In the sample code above, you would change:
<AC validation="override" matchFound="appendFields">update</AC>

to
<AC validation="update" matchFound="appendFields">update</AC>

Recognizing Validation Settings in Output
When submitting a tb_field_info or validation_lists command in the <AC> element, validation
information is returned using the mayOverride and mayUpdate attributes.
The mayOverride attribute can have the following values:
"1" to allow users to override the validation list or mask/range validation for that field.
"0" to restrict users from overriding the content validation (that is, validation list, range,
or mask) for that field. Users will also be prohibited from updating the validation list,
since they must be able to override in order to update.
The mayUpdate attribute can have the following values:
"1" to allow users to update the validation list (and override the list, since the list cannot
be updated without first being overridden). Note that if passwords are in use, the
password must also permit editing validation lists.
"0" to restrict the user from updating the validation list for that field.
Stripping Leading Spaces (when adding or editing records over the Web)
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When doing an insert or update, you can specify whether WebPublisher PRO strips leading
spaces. Leading spaces are spaces in a record at the beginning of a field entry or after a
carriage return.
To specify whether leading spaces are stripped, use the trim attribute in the <AC> element. The
trim attribute can have the following values:
"y" to strip leading spaces.
"n" to keep leading spaces intact. This is the default value.
For example:
<AC trim="y">insert</AC>

Note: The trim attribute is only necessary if you use CDATA to preserve white space (spaces,
line breaks) at the beginning/end of field content. Using CDATA is recommended, especially if
your data is likely to include characters significant to XML (for example, an ampersand or less
than sign).

XML Output
MatchFields and KeyFields
The <MatchFields> and <KeyFields> elements used with WebPublisher PRO have distinct and
specific functions. However, the same set of fields is often appropriate for both <MatchFields>
and <KeyFields>, serving as record identifiers.
MatchFields
Use the <MatchFields> element to specify one or more fields on which you want WebPublisher
PRO to match when modifying or deleting records (using the update or delete command).
For example, when doing an update, WebPublisher PRO looks for records that match based on
the field(s) you specify. If a match is found, the record information is updated according to the
value specified for the matchFound attribute. If a match is not found, the record is treated
according to the matchNotFound attribute (the default is to add it as a new record).
When updating or deleting records, you must specify one or more <MatchField> elements within
the <MatchFields> parent element. If you do not, the software will return an error.
KeyFields
Use the <KeyFields> element to specify the fields you want returned after an action is submitted
to WebPublisher PRO.
Nested within the parent <KeyFields> element are one or more <KeyField> child elements,
each representing a field name. To include a secondary textbase field when specifying fields to
be returned by a query, use a period instead of an @ character. For example, use
<KeyField>Address.Borrower</KeyField> to include the Address@Borrower field.
Fields are returned in the order in which the <KeyField> elements were specified in the XML
input.
If a field listed as a <KeyField> has multiple entries, all of the entries will be returned.
Note: If you use both the <KeyFields> and <RF> elements, the software uses the <KeyFields>
element to decide which fields to return and the <RF> element for the sort.
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An Alternative to KeyFields
As an alternative to using the <KeyFields> element, you can use the <FN> element.
This element can be useful when you only need to specify one field and do not want to use the
<KeyFields> and <KeyField> elements (for example, when submitting the index_by_key
command, which permits only one field to be specified). For example:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>index_by_key</AC>
<TN>vehicles</TN>
<FN>Name</FN>
</Query>

Tip! You can specify multiple fields with the <FN> element by separating the field names with a
pipe delimiter character ( | ). For example, in the following line of code, three fields—ID, Name,
and State—are specified in the <FN> tag:
<FN>ID|Name|State</FN>

Note: The <FN> element can also be used to find out the total number or records that will be
retrieved by a query, without actually retrieving and displaying the records. In this case, the
<FN> element is not an alternative to the <KeyFields> element.

Sorting Records Returned by an XML Query
When submitting XML to WebPublisher PRO, you can use the <SortFields> element to specify
how to sort the records returned (if you do not want to use the textbase default sort).
To specify sort order, use the sort attribute and set it equal to "specify". This tells the software
that your XML input will contain the fields by which you want to sort.
Nested within the parent <SortFields> element are one or more <SortField> elements. Use the
<SortField> elements to specify the sort order. The field listed first is the primary sort field;
subsequent fields are subsort fields. You can have up to four (4) subsort fields. You can also
specify what you want the software to do if the primary sort field is empty.
Note the following:
XML does not support the Omit Those Records option on the Primary Sort Fields dialog
box.
XML does support Alternate Primary Sort Fields, which you specify by using
type="alternate" instead of type="sort".
For example the following sample code sorts records first by the ClientState field (primary sort
field), then by the ID field (subsort field):
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>sample</TN>
<QY>Find id =*</QY>
<KeyFields>
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<KeyField>ID</KeyField>
<KeyField>ClientState</KeyField>
</KeyFields>
<SortFields sort="specify">
<SortField>ClientState</SortField>
<SortField>ID</SortField>
</SortFields>
</Query>

Note: To sort records by a field in a secondary textbase, use a period instead of an @
character. For example, use <SortField>Address.Borrower</SortField> to include the
Address@Borrower field in the sort specification.

Specifying an Alternate Primary Sort Field on the Web
When defining a sort in XML input submitted to WebPublisher PRO, you can specify what
should occur if the primary sort field is empty. The primary sort field is the first field listed with a
<SortField> element.
To specify an alternate primary field, include a <SortField> element with the type attribute set to
"alternate".
For example, in the following sample code, the Author field is the primary sort field and the Title
field is the alternate primary sort field that will be used if the Author field is empty for a particular
record. The Publisher field is a subsort field.
<?xml version="1.0"?>
<Query detail="qy" xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>sample</TN>
<QY>Find id=*</QY>
<KeyFields>
<KeyField>Title</KeyField>
<KeyField>Author</KeyField>
<KeyField>Summary</KeyField>
<KeyField>PublicationDate</KeyField>
</KeyFields>
<SortFields sort="specify">
<SortField>Author</SortField>
<SortField type="alternate">Title</SortField>
<SortField>Publisher</SortField>
</SortFields>
</Query>

Note: Alternate primary sort fields are only recognized and used if a primary sort field is defined.
If a primary sort field is not defined in the input, then any alternate sort fields are ignored.
Related Topic
Sorting Records in Reverse Order on the Web
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Sorting Records in Reverse Order on the Web
When defining a sort in XML input submitted to WebPublisher PRO, you can specify that results
be sorted in reverse order.
To do this, use the reverse attribute in the <SortField> element. The reverse attribute can have
the following values:
"y" to sort in reverse order.
"n" to sort in ascending order.
Important! As with sorting on the desktop, alternate primary sort fields use the same reverse
attribute value as the primary sort field.

Returning Records in Sets (XML)
You can specify that the software return the results of XML queries in sets. That is, you can
specify the number of record you want per page and specify which page you want displayed (for
example, you want records in sets of 10, but want to display the fourth set of 10 records).
To do this, use the following elements when submitting a query in XML.
Use the <MR> element to specify the number of records per page (that is, number of
records returned in each set of records).
Use the <SP> element to specify which page you want.
In the following XML input example, the set size is 10 records per page (<MR>10</MR>) and
the page that will be returned is the third one (<SP>3</SP>). That means, the third set of 10
records will be returned in XML after your search.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>temps</TN>
<MR>10</MR>
<SP>3</SP>
<QY>Find Skills =accounting</QY>
<KeyFields>
<KeyField>Name</KeyField>
<KeyField>EMail</KeyField>
</KeyFields>
</Query>

To see other sets of records, change the value of the <SP> element. Note that <SP>1</SP>
returns the first set of records.
The XML returned from a query will show the total number of records and the total number of
records displayed on the page.
The following attributes, which appear in the <Recordset> element of the XML output, provide
useful information:
"queryCount" shows the total number of records returned.
Note: The value of the queryCount attribute may be smaller than the number of records
that meet the search criteria if XML output is limited by the <TX> element, TX= in the
query screen, or TotalRecordsforXML= specified in the DBTWPUB.INI (or ICSWeb.INI)
file.
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"setCount" shows the total number of records returned on this page.
"page" shows the current page number. Note that a value of zero indicates an error with
the search.
"pageCount" shows the total number of pages available. Note that a value of zero
indicates an error with the query.
If the values of the queryCount and setCount attributes are not equal, then it means that the
<MR> element was used to specify the maximum number of records per page.
The following example shows the output from a query which had <MR>2</MR> specified in its
input. It shows that 16 records match the criteria that was submitted (queryCount="16"), but
that the page only contains two records (setCount="2"). Other attributes in the results show
that the first page of results is being shown (page="1") and that there are eight total pages
(pageCount="8").
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="10.0"
xmlns:inm="http://www.inmagic.com/webpublisher/query" oex="ISO-8859-1">
<inm:QY>Find Color =red</inm:QY>
<inm:Recordset AC="query" sn="AUTO4629" se="380" queryCount="16" page="1"
pageCount="8" setCount="2">
<inm:Record setEntry="0">
<inm:Name>Supra</inm:Name>
<inm:RetailPrice>266</inm:RetailPrice>
</inm:Record>
<inm:Record setEntry="1">
<inm:Name>Supra</inm:Name>
<inm:RetailPrice>428</inm:RetailPrice>
</inm:Record>
</inm:Recordset>
</inm:Results>

Returning Only the Record Count for a Web Query (XML)
When submitting an XML query, you can find out the total number of records a search will return,
without actually returning all of the records.
To do this, submit <FN>/</FN> in the query input. This returns the total number of records that
would be returned. Note, however, that this value may be limited by the total number of records
setting.
Note: The <FN> element can also be used an alternative to the <KeyFields> element.
The following example is a search for all orders entered on April 14, 2004:
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>orders</TN>
<FN>/</FN>
<QY>Find DateEntered =April 14 2010</QY>
</Query>

Inmagic DB/TextWorks v13 Printed Help

375

WebPublisher PRO
In the results of the above query, the queryCount attribute shows the number of records that
meet the criteria, but no records are actually returned:
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?>
<inm:Results productTitle="Inmagic WebPublisher PRO" productVersion="13.00"
xmlns:inm="http://www.inmagic.com/webpublisher/query">
<inm:QY>Find DateEntered =April 14 2010</inm:QY>
<inm:Recordset AC="query" sn="" se="0" queryCount="214" page="1"
pageCount="22" setCount="10">
</inm:Recordset>
</inm:Results>

Troubleshooting WebPublisher PRO
Before you make your textbases available on the Web, test them from a remote computer
running a browser (not from the server itself) to be sure that everything works the way you
intended. The best way to test is to run through a sample search, retrieval, and display. If you
created a Web edit form for adding, editing, and deleting records from a browser, try adding a
few sample records, editing a few others, and deleting some.
Note: Use a Web browser to access the HTML query or edit screen (for example,
http://company.com/query.htm). Do not open it by double-clicking the file name in Windows
Explorer.
Here are the main things to check for when testing:
Are you using compatible versions of DB/TextWorks and WebPublisher PRO?
Have you handed off all the necessary files to the Webmaster and coordinated issues
about initialization files and textbase and image locations?
Do all your search screens appear as you intended? Try several queries to see if you
retrieve the intended records.
Do all images appear correctly? Check logos, backgrounds, and textbase record images
on forms, query screens, and menu screens.
Do all links go to the correct destinations? Verify that there is a link on your Web site that
takes you to the search screen. Check all links on query screens, menu screens, and
reports.
Does every report include an expand record link, if appropriate? Is the link text available
for every record?
Do all your reports look the way you intended? Try several different searches, to obtain
different record sets. Select each Report form and Display form in the browser. Different
record sets, such as records that lack information in a field, may affect appearance.
If your Web query screen was designed to search multiple textbases, try a search that
should retrieve records in all of the textbases. Try using each query box and click on any
"See Also" search links to verify that you have mapped all the necessary fields. Verify
that the Initial Report Forms specified for the lead and search textbases do not include
any New record, Edit record, or Delete record links.
If you made changes to the supplied help pages (WEB*.HTM), click the Help button on
the query screen to be sure you access the changed help pages. If you renamed the
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pages, test the inter-page links. For example, WEB_BEGIN.HTM includes links to
WEB_MSG.HTM.
Did you choose the correct options when saving forms? For each form that you will use
on the Web, choose Save Form As in the Form Designer, then select these options:
Save In. Select Textbase File (Public) to ensure that the form is saved as part of the
textbase.
Use For. Select Report Window to cause a form to appear in the reports drop-down list
in the Web browser. Select Display Window to cause a form to appear in the expanded
display drop-down list in the Web browser (for single-record display). Select Web to
ensure that the form appears in the specified drop-down list in the Web browser. If you
are saving an edit form for use on the Web, select Edit Window.
If you changed message or button text by creating and connecting a MYMSG.INI file,
verify that your modifications appear when and where you expect them.
If you have specified that expanded records open in a separate browser window and/or
you specified that a New Search button appears on screens, verify that they work as
you intended. Note that these features are specified by adding parameters to
DBTWPub.INI (or ICSWeb.INI).
If your textbase has Link fields, verify that you can search for and display information
from secondary textbases.
If your textbase has passwords, verify that the query screen includes a password box. If
the textbase has a Silent password, verify that it hides the fields or records you expect it
to hide.
If your screens and forms include any New record, Edit record, or Delete record links,
verify that you have specified a unique combination of XML Match Fields in the textbase
structure (choose Maintain>Edit Textbase Structure>XML Match Fields). If you do
not have match fields specified properly, records you edit may be added to the textbase
as new records, instead of being modified.
Do you want all of your pages to have a default page and/or box background color? If
so, specify the colors you want in DB/TextWorks (choose
Tools>Options>Display>More Defaults>Colors). Then exit DB/TextWorks and copy
the [FormSettings] section of the INMAGIC.INI file in your user file path to the
INMAGIC.INI file in your WebPublisher installation folder. (Note that if you do not already
have an INMAGIC.INI with settings you want to retain in your WebPublisher installation
folder, you can copy the entire file.)
Consider doing a usability test to be sure that your search screens and forms are clear
and intuitive. Try having an uninitiated user go to your home page and see if that person
can figure out what to do: how to jump to a search screen, which fields to query, what to
search for, and what syntax to use.
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Configuring Inmagic Browse
InmagicBrowse is an application that supports the Browse Choices feature in WebPublisher
PRO. In query screens, it supports browsing through words and terms in the index for a field. In
edit screens, it supports browsing through terms in a validation list associated with a field, or the
associated field for a Link field.
InmagicBrowse is installed when WebPublisher PRO is installed.
You can configure the following for InmagicBrowse through the Web.CONFIG file, which is
located in the InmagicBrowse subfolder of the main WebPublisher PRO installation folder:
Leading article character (default is a non-breaking space, Alt+160)
Number of keys displayed
Whether terms wrap
Button captions
To configure InmagicBrowse
1. Open the Web.CONFIG file in a text editor (for example, Microsoft Notepad).
2. In the <appSettings> section, depending on what you want to do, make the applicable
change(s):
To change the leading article character, change the value for the
key="SpaceSubst" parameter. The default value (\xA0) is a non-breaking space,
which is presented as a hex value to clearly define the character as such. You do
not have to enter values in hex format.
The leading article character is the character used to replace the first space in
added terms so that terms that, after having punctuation characters removed prior
to being indexed, now appear to begin with a leading article. (For example, "A.
Lincoln" appears in the index list as "A Lincoln" and a search for "A Lincoln" will fail,
as it will actually search for "Lincoln".) Typically, you will not have to change this
value. An example of when you will want to change it if your query screen has an
.ASPX extension. Microsoft Internet Explorer loads .ASPX pages using UTF-8
encoding, which will cause problems with the default character. If you do change
the default, do not use a plain space. We suggest you use a punctuation character,
such as a hyphen, period, or underscore.
To configure the number of keys displayed, change the value for the
key="NumKeys" parameter. For example, enter a higher number if you want to
show more keys. The maximum value for WebPublisher PRO is 255. (Higher
values revert to 10 entries.)
To configure whether terms wrap or not, change the value for the key="WrapKeys"
parameter. If you enter a value of false, text wider than the column will be truncated
in the list display. The entire term will still be pasted.
To configure button caption(s), change the value of the appropriate button key:
AddButtonCaption, ReplaceButtonCaption, PrevButtonCaption, or
NextButtonCaption.
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3. Save your changes.
To change the width of the hits column
Create a file named MyIndex_Browse.css, with the following style defined. Specify the desired
width. This example shows 50 pixels.
.hitColWidth
{
width: 50px;
}

To change the text on the Browse Choices button on a query screen
To change the text for the Browse Choices button, use the BrowseChoicesText parameter in
the [WebPublisher] section of the INMAGIC.INI file.

DBTWPub.INI (or ICSWeb.INI)
The DBTWPub.INI file (or ICSWeb.INI if you are using the SQL platform) contains settings that
are specific to WebPublisher PRO. To specify various settings, add a parameter to the file or
edit an existing parameter.
Note for SQL platform: If you are using the SQL version of WebPublisher, some section
names in ICSWeb.INI differ between versions. "WebPublisher" in non-SQL becomes "Web" in
SQL, e.g., [WebPublisher Defaults] vs. [Web Defaults], and [WebPublisher] vs. [ICSWeb].
This file is required for the Web component to run. Write access is recommended for this file;
though it is not required for the software to run. This file controls:
Where the Web component looks for textbases and images used in reports, singlerecord displays, and on edit and delete pages.
How many temporary query sets are retained.
Whether Cascading Style Sheets (CSS) are used to determine how report/display/edit
pages are formatted.
Whether WebPublisher PRO messages are translated/modified.
Whether each page has a New Search button next to the Next/Previous buttons.
Whether expand record links and edit/delete pages open in a new Web browser window.
ADA Compliance settings.
The total number of records WebPublisher PRO displays for each search.
Whether severe error messages are logged.
Default Includes in output.
XML settings including how to enable or disable XML for textbases and how to specify
the total number of records displayed on the Web.
Whether navigational buttons appear on Web pages.
Whether exploded sorts are supported on the Web.
Whether hit navigation is enabled for records displayed on the Web.
Whether query logging is turned on for queries performed over the Web.
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Specifying Where WebPublisher PRO Looks for Images
The following sections in DBTWPub.INI control where WebPublisher PRO looks for images.

[WebPublisher Defaults]
Note for SQL platform: Use the [Web Defaults] section of the ICSWeb.INI file. The virtual
directory is ics-wpd.
Two parameters in the [WebPublisher Defaults] section specify where WebPublisher PRO looks
for logos/background image files and images referenced from a textbase record.
Default-Logo-Location= the default location for logo and background image files.
Default-Image-Location= the default location for images referenced in textbase
records.
These parameters are automatically set equal to the locations specified during the installation of
WebPublisher PRO. If you accepted the defaults during the install process, both parameters are
set equal to /dbtw-wpd/images/ (or /ics-wpd/images/ for the SQL platform).
This is the default location where the Web component looks for image files for all textbases. If
you store your images in different folders, you must change the parameters.
Example:
In this example, the fixed images used for logos and form/screen backgrounds are stored in the
IMAGES subfolder and the record images referenced in textbase records are stored in the
PICTURES subfolder. (Both are relative to the installation folder, and thus the DBTW-WPD
virtual directory to which it is mapped).
[WebPublisher Defaults]
Default-Textbase-Paths=c:\Program Files\inmagic\webpubpro\textbase\
Default-Logo-Location=/dbtw-wpd/images/
Default-Image-Location=/dbtw-wpd/pictures/

If you are storing images in multiple locations (for example, if you have different image locations
for each textbase), use the [WebPublisher Logo Locations] and [WebPublisher Image
Locations] sections.

[WebPublisher Logo Locations]
Note for SQL platform: Use the [Web Logo Locations] section of the ICSWeb.INI file.
If you are not storing all of your fixed images (logos and background images) in the default logo
location specified in the [WebPublisher Defaults] section (explained above), you can specify
image locations by textbase.
Use the [WebPublisher Logo Locations] section of the DBTWPub.INI file to specify the location
of fixed images for each textbase. This provides the text WebPublisher PRO should use to
construct the URL for fixed images for specific textbases.
Note: The Web component looks for the textbase name in this section and, if it is not found,
uses the default logo location specified in the [WebPublisher Defaults] section.
Example:
The following example specifies the location of fixed images for the Vacation textbase:
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[WebPublisher Logo Locations]
vacation=http://mydomain.org/me/logo/

[WebPublisher Image Locations]
Note for SQL platform: Use the [Web Image Locations] section of the ICSWeb.INI file. The
virtual directory is ics-wpd.
If you are not storing all of your record images in the default image location specified in the
[WebPublisher Defaults] section (explained above), you can specify image locations by
textbase.
To do this, use the [WebPublisher Image Locations] section of the DBTWPub.INI file to specify
the location of record images for each textbase. This provides the text WebPublisher PRO
should use to construct the URL for record images referenced in specific textbases.
Note: The software looks for the textbase name in this section and, if it is not found, uses the
default image location specified in the [WebPublisher Defaults] section.
Example:
The following example specifies the default location of record images for the Cars and Vacation
textbases:
[WebPublisher Image Locations]
cars=/dbtw-wpd/sample/
vacation=http://mydomain.org/me/photos/

Specifying Where WebPublisher PRO Looks for Textbases
When publishing textbases on the Web, you can use the DBTWPub.INI (or ICSWeb.INI if you
are using the SQL platform) to specify the location of any textbase that does not reside in the
default textbase path(s) specified during the installation of WebPublisher PRO. This default path
(or paths, if you specified multiple locations during installation) is the location in which the
software will look for textbases, if no other path is specified. The default textbase path appears
in the [WebPublisher Defaults] section of DBTWPub.INI (or the [Web Defaults] section of the
ICSWeb.INI file for the SQL platform), as shown in the following example:
[WebPublisher Defaults]
Default-Textbase-Paths=c:\Program Files\inmagic\webpubpro\textbase\

For textbases that are in a different location, you can add each textbase and its path to the
[WebPublisher Textbase Paths] section. The following example shows the path for the Cars and
Catalog textbases.
[WebPublisher Textbase Paths]
cars=c:\Program Files\inmagic\webpubpro\sample\
catalog=c:\data\library\

Note for SQL platform: The SQL platform uses ICSWeb.INI instead of DBTWPub.INI, and the
section names use "Web" instead of "WebPublisher". For example, [WebPublisher Defaults] vs.
[Web Defaults], and [WebPublisher Textbase Paths] vs.[Web Textbase Paths].

How this information is used
When a user clicks the Submit Query button, the following occurs:
1. WebPublisher PRO checks the [WebPublisher Textbase Paths] section of the
DBTWPub.INI file for the textbase name, and looks in the specified location.
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2. If the textbase name does not appear in the [WebPublisher Textbase Paths] section or is
not found in the specified location, the software looks in the locations specified in the
Default-Textbase-Paths= line in the [WebPublisher Defaults] section.
3. If the textbase is not found in either location, the software displays a page giving the end
user the option to do a recursive subfolder search on the folders listed in the DefaultTextbase-Paths= line.
4. If the Web component finds the textbase in either step 2 or step 3, it writes the location
to the [WebPublisher Textbase Paths] section, so the search will not be necessary in the
future.
Any account that WebPublisher PRO uses must have Read access to the folders where
textbases are located in order to search them. In order for the textbase search feature to work
properly, this account must also have Full Control access to DBTWPub.INI and at least Read
access to all folders specified in the Default⌀Textbase-Paths= line. (Note that if you plan to
allow users to modify and/or delete textbase information over the Web, the account used by the
Web component must have Full Control access to any folders containing these textbases.)

Specifying the Maximum Number of Query Sets
Records returned by a WebPublisher PRO query are called a set. A set is generated for each
successful query. A set provides the Internet or intranet user with the ability to view successive
subsets of the records retrieved without having to re-execute the query.
Query sets are stored temporarily on the HTTP server in /DBTW-WPD/QSETS (or /ICSWPD/QSETS for the SQL platform), under automatically generated names. Two files track
query sets: .WPD and .WPO. These files have the same name as the textbase. For example, a
textbase called Sales uses SALES.WPD and SALES.WPO.
You can specify the maximum number of sets to retain. When the maximum is reached, slots
will be re-used as needed, beginning with the oldest.
The default value is 2000. Specifying fewer than this number may use less disk space, but may
cause sets to be re-used (thus removed) before users are finished with them. This can result in
users getting messages such as Your current query has expired. Perform the search again. when they
display records or change forms.
To change the value, edit the WebSetMax parameter in the [WebPublisher] section of the
DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if you are using the SQL
platform). This file is located in the WebPublisher PRO installation folder on the HTTP server.
[WebPublisher]
WebSetMax=2000

Note: You must you must restart IIS (the World Wide Web Publishing Service) any time you
make any changes to this parameter in the .INI file. You can use the Services option through the
Windows Computer Management window to restart IIS.

WebPublisher PRO Form layout
By default, WebPublisher uses Cascading Style Sheets (CSS) and absolute positioning, so
report, display, and edit forms look as much as possible as they would look in DB/TextWorks.
WebPublisher detects whether the browser supports Cascading Style Sheets. If not,
WebPublisher uses simple HTML (boxes will be left-justified, box labels will appear on top rather
than to the left, and so forth).
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Forms that contain Raw HTML or inline images are incompatible with absolute positioning.
Forms containing these elements will have overlapping text unless very carefully designed.
Therefore, simple HTML is used for this type of form unless you explicitly set WebCSSOpt=2 in
your DBTWPUB.INI file (or ICSWEB.INI if you are using the SQL version of WebPublisher).
Note: DB/TextWorks tabular forms do not use absolute positioning, so this issue does not affect
them.
You can use picture boxes in place of inline images to retain CSS formatting. The Image size
option specified using Box Properties>Position in the Form Designer is used. In order for the
image sizing to work properly, the images must reside either in the textbase folder (for example,
C:\CATALOG\) or the folder specified in the Image field in the record (for example,
C:\IMAGES\COYOTE.JPG).
To control whether the site uses CSS, set the WebCSSOpt= parameter in the DBTWPUB.INI
file (or ICSWEB.INI) to one of the following:
0 = do not use CSS
1 = the default behavior
2 = use CSS regardless of whether forms contain Raw HTML or inline images
Note: The WebCSSOpt= parameter affects all forms and all textbases, unless you override it
using the CS= parameter in an individual query screen.
Example for DBTWPUB.INI (non-SQL platform)
[WebPublisher]
WebCSSOpt=0

Example for ICSWEB.INI (SQL platform)
[Web]
WebCSSOpt=0

Using Multiple Languages with WebPublisher PRO
WebPublisher PRO supports the ability to specify different sets of messages for different query,
edit, or menu screens. One common use for this feature is for bi-lingual or multi-lingual sites.
You can have several query screens, each for a different language.
Tip! For more information about formatting messages, see Translating or Modifying Messages
and Buttons on the Web.
To specify which message file to use, add the MF= parameter to your exported query, edit, or
menu screen.
For menu screens, add the MF= parameter to the dbtw_m_link() call. You must make this
change after exporting the menu screen to HTML. Example:
dbtw_m_link( "catalog",
"myset","RF=repform&DF=dispform&MR=15&DL=0&RL=1&NP=2&MF=mymsg.ini", "My
Set" );

For exported query or edit screens, add a line to the bottom of the page based on this
example:
<input name="MF" type="hidden" value="mymsg.ini">
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If you add this line using a text box in the Query Screen Designer or Form Designer, be sure to
treat the box contents as Raw HTML. Alternatively, you can simply edit the query or edit screen
after exporting it to HTML to add this line.
If you also want to change the No query criteria specified. message, modify the dbtw_initialize()
line in the exported HTML query screen file to specify the message file name. You need to type
the message file name between the third set of quotes. Example:
dbtw_initialize("", "", "mymsg.ini");

Example
The CARSQMSG.HTM query screen in the SAMPLE subfolder of the WebPublisher PRO
installation folder changes two of the error messages that can be returned.
The No records found by latest query. message has been changed to: Your search
terms were not found. Press Back to return to the query screen and reformulate your
search. To see this new message, type not there in the Model Type box and click the
Submit Query button.
The No query criteria specified. message has been changed to: Please type something
in at least one of the query boxes. To see this new message, click the Submit Query
button without typing anything in any of the boxes.

Translating or Modifying Messages and Buttons on the
Web
You can change the text of many of the messages and buttons that WebPublisher PRO
displays. This allows you to translate them into another language or make them more specific to
your environment.
You have two options when changing messages:
Use the same set of messages for all exported query, edit, and menu screens (see
below).
Specify which set of messages to use with each query, edit, or menu screen (see Using
Multiple Languages with WebPublisher PRO).
When you install WebPublisher PRO, a WPEngMsg.INI file is installed in the root of the
installation folder. WPEngMsg.INI lists all of the WebPublisher PRO messages that can be
copied to another INI file and modified or translated. It is located in the WebPublisher PRO
installation folder.
We recommend leaving the original file intact and making a copy under a new name. You
should copy only the section headings and the messages you want to change to the new
messages INI file. Messages are limited to 250 characters, and must be all on one line. They
can include HTML tags.
Once you have made the changes you want, specify the name of your messages INI file in the
[WebPublisher] section of DBTWPub.INI (or the [Web] section of ICSWeb.INI, if you are using
the SQL platform).
[WebPublisher]
MessageFile=MYWPMSG.INI

For example, you can change the No records found by latest query message to be more
detailed for your users by adding the following to your message INI file:
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msg_110=<br><br><br><center><hr>Your search did not find any
records.<br>Please click your browser's Back button and try
again.<hr></center>

If you also want to change the "No query criteria specified" message, you need to copy this
section to your messages INI file, then change the message text to whatever you like:
[Localized Query Parameters]
qmNoQuery=No query criteria specified.

Adding a New Search Button on the Web
You can specify that a New Search button appears on every page, next to the Next/Previous
buttons. When a user clicks the button, WebPublisher PRO returns to the query screen (or to
the menu screen).
To make the button appear, add the WebNewSearchButton= parameter to the [WebPublisher]
section of the DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if you are using the
SQL platform).
[WebPublisher]
WebNewSearchButton=1

A value of 1 turns the feature on; a value of 0 turns it off.
Note: If you use the WebExpandInSeparate= parameter, the New Search button will not
appear on the expanded records or edit pages because the button could not return them to the
query screen in the original browser window. The New Search button will still appear on the
multiple-record report pages.

Opening Records in a Separate Web Browser Window
You can specify that when a user clicks an expand record link, new record link, edit record link,
or delete record link, the record will open in a new Web browser window. This makes it easy for
the user to return to their report by closing the new window.
To specify this option, add the WebExpandInSeparate= parameter to the [WebPublisher]
section of the DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if you are using the
SQL platform).
[WebPublisher]
WebExpandInSeparate=1

A value of 1 turns the feature on; a value of 0 turns it off.
You can override the WebExpandInSeparate= parameter for searches performed using an
individual query or menu screen by using the ES parameter within the screen. For example, you
could add a line such as the following:
<input name="ES" type="hidden" value="0">

Note: New records links on query screens explicitly set ES=0. Do not change this setting.

ADA Compliance Settings
You can specify that WebPublisher PRO should use links (<noscript> sections) instead of
buttons for commands such as Next Record, New Search, and so forth, to make the pages
accessible to the visually impaired.
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To do this, add the WebScriptButtonsOption= parameter to the [WebPublisher] section of the
DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if you are using the SQL
platform).
[WebPublisher]
WebScriptButtonsOption=2

The values for the WebScriptButtonsOption= parameter are:
0 = always use buttons
1 = always use links
2 = both: buttons and <noscript> section with links
To create the corresponding HTML query screens and menu screens, exit all copies of
DB/TextWorks, add the following line to the [Inmagic DB/TextWorks] section of the Inmagic.INI
file, and restart DB/TextWorks. Then export your menu screen or query screen to HTML.
[Inmagic DB/TextWorks]
ExportQBEtoHTMLOption=2

The values for the ExportQBEtoHTMLOption= parameter are:
0 = normal query and menu screen
1 = no scripts
2 = normal section and <noscript> section
Note: For HTML menu screens exported using a value or 1 or 2, you must manually add the
BU= parameter to the HREF links in the page, if you intend to use the New Search button or
images. Instructions for doing so are included as comments in the HTML source of the page.
Note that the HTML source includes <label> tags around box labels, regardless of the other
options specified.

Specifying the Total Number of Records Displayed on the
Web
You can specify the total number of records WebPublisher PRO will return for a single search.
All of the records are sorted according to any compulsory form sort or textbase default sort
before the set is truncated.
To set the total number of records displayed, add the TotalRecords= parameter to the
[WebPublisher] section of the DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if
you are using the SQL platform).
[WebPublisher]
TotalRecords=100

Even if a search finds more than the specified number of records, the user will only see as many
records as the TotalRecords= parameter allows.
There is no indication that the search retrieved more records than the TotalRecords= value. For
example, the RECORD COUNT variable and the browser title bar will display the TotalRecords
setting.
The records are still broken into multiple pages according to the Records per page setting in
the query screen or menu screen.
You can use the TR= parameter in a query screen, menu screen, or canned query to override
any TotalRecords= parameter specified in the DBTWPub.INI file. For example:
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<input name="TR" type="hidden" value="10">

Specifying the total number of records returned in XML format
Use the TotalRecordsforXML= parameter in DBTWPub.INI (or ICSWeb.INI) to set the total
number of records returned in XML output:
[WebPublisher]
TotalRecordsforXML=100

You can override this value for individual queries by using one of the following:
For searches submitted from a Web query screen, add the TX= parameter to the source
of the screen.
For a canned query, add &TX=10 to the URL or modify the &TX=1000 to be &TX=10,
substituting your own preferred maximum for the number 10.
For submitting XML queries, use the <TX> element in the XML input.
If none of these are specified (including the TotalRecordsforXML= parameter), the default total
number is 1000. To remove the limit on the number of records returned, set the applicable
parameter/element equal to 0 (for example, TotalRecordsforXML=0).

Using the <TX> element in XML input
When submitting a query in XML, use the <TX> element to specify the total number of records
you want returned, regardless of how many records meet the criteria you specify.
In the following XML input example, the total number of records is set to 150. That means the
XML returned will display the first 150 records. The remainder of the records (if the search finds
more than 150 records) will not be returned. If there is a sort applied, the entire set is sorted
before it is truncated to the number of records specified by the <TX> element.
If you do not specify the <TX> element, the default value used is 1000. This default can be
changed in DBTWPub.INI (or ICSWeb.INI), but any <TX> element submitted in the input
overrides the .INI file value.
<?xml version="1.0"?>
<Query xmlns="http://www.inmagic.com/webpublisher/query">
<AC>query</AC>
<TN>temps</TN>
<TX>150</TX>
<QY>Find Skills =accounting</QY>
<KeyFields>
<KeyField>Name</KeyField>
<KeyField>EMail</KeyField>
</KeyFields>
</Query>

Specifying Default Includes for Forms Used on the Web
You can specify that certain Includes appear on all WebPublisher PRO pages displayed.
To do this, add the following parameter(s) to the [WebPublisher Defaults] section of the
DBTWPub.INI file (or the [Web Defaults] section of the ICSWeb.INI file, if you are using the SQL
platform). Each of the six seams you can specify has its own parameter. For information about
the locations of the six seams, see Seams Illustration.
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Default-Seam1-Include=
Default-Seam2-Include=
Default-Seam3-Include=
Default-Seam4-Include=
Default-Seam5-Include=
Default-Seam6-Include=

Set the parameter for the applicable seam equal to the default Include you want. (Note that
there is a 1,024 character limit.) For example, you could specify:
Default-Seam3-Include=<script language="javascript" type="text/javascript"
src="http://www.inmagic.com/includes/inm_search_results.js"></script>

To specify multiple Includes for a particular seam, separate them with the pipe character ( | ).
For example:
Default-Seam1-Include=<script language="javascript" type="text/javascript"
src="http://www.inmagic.com/inm_search_results.js"></script>|<h1>This is a
client-side HTML include</h1>|c:\program
files\inmagic\webpub\sample\report_top.txt

You can override the default Include(s) for a particular form by specifying the Include(s) in the
Form Designer (choose Tools>Form Properties>HTML>Advanced Options>Includes) and
selecting the Override Default Include check box for the applicable seam(s).
Tip! If you have a default Include specified for a particular seam, but do not want it output on a
specific form, select the Override Default Include check box on the Includes tab for the
applicable seam on that form, but do not enter anything in the seam box.
You can also specify that WebPublisher PRO output (that is, report, display, and edit pages)
contains a specific Cascading Style Sheet (CSS) Include. To do this, add the Default-CSSInclude= parameter to the [WebPublisher Defaults] section of DBTWPub.INI (or the [Web
Defaults] section of ICSWeb.INI).
For example:
[WebPublisher Defaults]
Default-CSS-Include=/home/standard.css

Specifying HTTP Header Information
You can use the DT (document type) and XP (expires) parameters to specify the content and
expires settings in the HTTP header information passed to the Web browser. The expires
setting is in seconds. For example, you could add these lines to your HTML query screen:
<input name="XP" type="hidden" value="120">
<input name="DT" type="hidden" value="text/html">
DT is primarily useful with XML output, but can be used with normal WebPublisher PRO reports
in certain situations. If you specify an XML Style Sheet file (XS=) for XML output, DT is ignored
for WebPublisher PRO messages (for example, No records found by latest query.); use the XE
parameter instead.

Turning Off Navigational Controls on Web Screens
When using WebPublisher PRO, certain navigational controls always appear on forms and
screens when viewed over the Web. To turn off these controls for all screens and forms used on
the Web, add the appropriate parameter(s) to the [WebPublisher] section of the DBTWPub.INI
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file (or the [Web] section of the ICSWeb.INI file, if you are using the SQL platform) and set them
equal to 0. All of the controls are turned on by default (that is, they are set equal to 1).
The following table lists each control, what it does, and its applicable parameter:
Button

Description

Parameter in
DBTWPub.INI

Next/Previous

Displays the next or previous page in a report or the next DisabledButtons=
or previous record in an expanded display. These buttons
always appear. By default, if the user is on the first or last
page or record, the appropriate button is disabled.
Note: When set to 0, the disabled button that appears on
the first and last page (for a report) or record (for
expanded display) does not appear. That is, the first
page/record only has a Next button and the last
page/record only has a Previous button.

Back (<)

Returns to the previous page, just as the Back button on
your Web browser toolbar does.

BackButton=

Rewind (<<)

Returns to the last page of a different type.

RewindButton=

Close

If a display page opens in a separate browser window, a
Close button appear so the user can close the new
window to return to the report page.

CloseButton=

OK (on error
messages)

When an error message appears (for example, No records ErrorMsgButton=
found by current query.), the message box includes an OK
button which returns the user to the appropriate place (for
example, back to the query screen to modify the query).
Note: To turn off controls for individual query screens, you can use a message INI file.

Sorting Records (for the Web)
Sort order is determined by the textbase default sort order (Maintain>Edit Textbase Structure)
or by the compulsory form sort specified for the form selected in the Web browser.
The user has no way to sort records, so you should consider adding a compulsory sort to
Report forms that you design for the Web, unless the textbase default sort is suitable. To specify
a compulsory sort, choose Report Options>Compulsory Sort in the Form Designer.
The following Compulsory Sort options are ignored, because they can change the perceived
number of records retrieved: Interfile and Omit Those Records (click Primary Sort Field
Options).
Note that exploded sorts are also ignored by default. If you set the WebAllowExplode=1 option
in the DBTWPub.INI (or ICSWeb.INI) file to permit exploded sorts, all records are displayed on
one page to avoid paging issues when changing the perceived number of records in the report.

Allowing Exploded Sorts on the Web
You can specify that WebPublisher PRO permit exploded sorts that are defined in a report
form's compulsory sort. If such a form includes an exploded sort, paging will be turned off and
all records will be returned after being sorted. Also, the browser title bar will list the number of
records appearing in the report, not the actual number of records found by the search.
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To enable exploded sorts on the Web, add or edit the WebAllowExplode parameter in the
[WebPublisher] section of the DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file for
the SQL platform). This file is located in the WebPublisher PRO installation folder on the HTTP
server.
[WebPublisher]
WebAllowExplode=1

Tip! If you have a report that uses an exploded sort and expand record links, we recommend
that you click the expand record link for the first occurrence of a specific record in the report.
This is to ensure that the Next Record and Previous Record functionality matches the record
order shown in the report.
Note: You must you must restart IIS (the World Wide Web Publishing Service) any time you
make any changes to this parameter in DBTWPub.INI (or ICSWeb.INI). You can use the
Services option through the Windows Computer Management window to restart IIS.

Disable XML (WebPublisher PRO)
You can disable the XML input/output features for all WebPublisher PRO queries, or for those
submitted to an individual textbase.
To disable XML for all Web queries, add the following line to the [WebPublisher Defaults]
section of your DBTWPub.INI file (or ICSWeb.INI if you are using the SQL platform):
Default-DisableXML-Setting=1

Note: XML is enabled by default. However, you cannot have query/menu screen results
returned in XML format until you specify it in a query screen or in a predefined query. If you
submit XML input, results are returned in XML format by default.
To specify that individual textbases have the XML features enabled or disabled, add a
[WebPublisher DisableXML] section to your DBTWPub.INI file, then add each textbase with the
appropriate setting (=1 to disable XML, =0 to enable XML). In the following example, you can
use the XML features with the History textbase, but not with the Orders textbase:
[WebPublisher DisableXML]
Orders=1
History=0

Note: The [WebPublisher DisableXML] section overrides the setting specified using DefaultDisableXML-Setting=.

Enabling Hit Navigation on the Web
You can use the WebHitNavigation= parameter in the DBTWPub.INI file to enable hit navigation
for records displayed on the Web with WebPublisher PRO.
When enabled, highlighted search terms are surrounded by hyperlink arrows that allow you to
move to the previous and next occurrences of the term.
To turn this feature on, add the following to the [WebPublisher] section of the DBTWPub.INI file
(or the [Web] section of ICSWeb.INI if you are using the SQL platform):
[WebPublisher]
WebHitNavigation=1

The values for the parameter are:
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0 = off (default)
1 = on

Enabling Query Logging on the Web
You can turn on query logging for queries submitted over the Web with WebPublisher PRO. The
logged information includes the textbase name, query, start and end times, IP address of the
requestor, and number of hits.
Web queries are logged in a comma separated values (CSV) text file called query.log, in the
QSETS folder.
To enable query logging for WebPublisher PRO
Non-SQL platform: Open DBTWPub.INI and add the following lines to the [WebPublisher] section.
SQL platform: Open ICSWeb.INI and add the following lines to the [ICSWeb] section.
[WebPublisher]
WebLogQueries=1

The values for the parameter are:
0 = off (default)
1 = on

Logging WebPublisher PRO Severe Error Messages
To log severe error messages, add the EnableErrorLog=1 parameter to the [WebPublisher]
section of the DBTWPub.INI file (or the [Web] section of the ICSWeb.INI file, if you are using the
SQL platform). Severe errors will be recorded in WPTCErr.LOG in the QSets subfolder. The
messages will be date and time stamped. The textbase name and path and the action (AC)
performed appear beneath the message.

Parameters for Query Screens, Menu Screens, and
Canned Queries Used on the Web
The following table lists parameters that you can add to the source of a query screen, menu
screen, or canned query used on the Web.
Parameter Purpose
AC

Tells WebPublisher PRO what to do. Examples: QUERY, VALIDATION_LISTS_THES.

BG

Sets background color for message pages. Obtained from background color on page
that generated message.

BU

Specifies the base URL. Points to page used to generate search.

CS

Controls whether report/edit/display pages use Cascading Style Sheets. The equivalent
setting in DBTWPub.INI (or ICSWeb.INI if you are using the SQL platform) is
WebCSSOpt=.

DF

Specifies the expanded display form name.

DL

Specifies whether to show the form selection drop-down list on the expanded display
page.
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DT

Specifies the content setting for the HTTP header information passed to the Web
browser. Called the Document Type.

EF

Specifies the edit form; also used for delete record.

EL

Specifies whether to show the form selection drop-down list on edit and delete pages.

ES

Specifies whether to open the expanded display in a new browser window. This
parameter also affects edit and delete pages. The equivalent setting in DBTWPub.INI (or
ICSWeb.INI if you are using the SQL platform) is WebExpandInSeparate=.

FG

Text color for messages. Obtained from box label font color for first box on page that
generated message.

ID

Specifies the textbase password.

MF

Specifies message file name for message translation. The equivalent setting in
DBTWPub.INI (or ICSWeb.INI if you are using the SQL platform) is MessageFile=.

MQ

Specifies name of query screen from which to read search textbase information for Web
Multiple Textbase Query.

MR

Specifies number of records to display per page.

NP

Specifies the location of the form selection drop-down list and navigational buttons (for
example, the Next, Previous, and New Search buttons).
1 = top
2 = bottom
3 = both
4 = neither

OEH

Specifies the encoding for HTML output returned by this screen or canned query. The
default is ISO-8859-1, which matches the actual output emitted by WebPublisher PRO.

OEX

Specifies the encoding for XML output returned by this screen or canned query. The
default is ISO-8859-1, which matches the actual output emitted by WebPublisher PRO.

QB0
QF0
QI0

Specifies query criteria (Boolean, field name, search criteria) for search; the number (0,
1, and so forth) corresponds to the query screen box number, starting with 0.

QS

Used in conjunction with the textbase password cookie.

QY

Specifies the Command Query criteria for search. Alternative to QB0/QI0/QF0.

RF

Specifies the report form.

RL

Specifies whether to show the form selection drop-down list on the report page.

RN

Specifies the record number in the current set.

SE

Specifies entry in the current set.

SN

Specifies the set name. Textbase set name for menu screen queries. Temporary autoset
name for other queries.

SS

Specify whether to use alternate search syntax in this query screen. 0=original syntax
(default), 1=alternate syntax.

TI

Specifies the textbase index. Used with Web Multiple Textbase Query. Specifies which
textbase the record comes from. 0=lead textbase, 1=first search textbase, and so forth.
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TN

Specifies textbase name.

TR

Sets the total number of records displayed by WebPublisher PRO. The equivalent
setting in DBTWPub.INI (or ICSWeb.INI if you are using the SQL platform) is
TotalRecords=.

TX

Sets the total number of records displayed by WebPublisher PRO when using XML
output. Defaults to 1000 if not specified. Use TX=0 to return all records. The equivalent
setting in DBTWPub.INI (or ICSWeb.INI if you are using the SQL platform) is
TotalRecordsforXML=.

XC

Specifies whether to use CGI. Example: XC=/dbtw-wpd/exec/dbtwcgi.exe

XE

Specifies how errors are returned if an XSL file is specified. For use with XML output.
0 = HTML (default)
1 = XML
2 = XML errors are transformed (if possible) using the XSL and returned as XML.
3 = XML errors are transformed using the XSL and returned as HTML.

XM

Specifies whether to return XML output.
0 = HTML (default)
1 = XML

XP

Specifies the expires setting for the HTTP header information passed to the Web
browser.

XS

Specifies the XSL file to use to transform XML output.
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SQL vs. Non-SQL Platform
DB/TextWorks (the desktop component of Inmagic DB/Text) is available in a SQL-based
version, which requires a Microsoft SQL back-end database for infrastructure and data storage.
Both the SQL and non-SQL platforms provide the same features and functionality, with the
following exceptions:
DB/TextWorks for SQL includes an Administration program, which provides functionality
exclusive to the SQL platform, including Backup, Restore, and Upgrade.
DB/TextWorks for SQL includes the Inmagic Importer for SQL, which runs as a
Windows service to import records in the background. (The non-SQL version does not
include the Importer, but it is available upon request to customers who purchased
WebPublisher Pro.)
DB/TextWorks for SQL does not include deferred indexing because it provides no
performance benefits.
Some menus and dialogs differ slightly. For example, the Manage Textbases menu
includes the SQL-specific options List Textbases and Clear Textbase Record Locks.
Some supplied and generated files and directories differ. See the table below.
Notes

Non-SQL
Platform

SQL
Platform

Software
configuration

DBText.INI

INMCSRV.INI

User
customizations
and
preferences

Inmagic.INI

Inmagic.INI

Platform-specific section names are
different where they need to coexist in the
same file. For example: [Window
Placements] vs. [Content Server Window
Placements]

WebPublisher
settings

DBTWPub.INI

ICSWeb.INI

Some section names differ.
"WebPublisher" in DBTWPub.INI becomes
"Web" in ICSWeb.INI. For example:
[WebPublisher Defaults] vs. [Web
Defaults], and [WebPublisher] vs.
[ICSWeb].

WebPublisher
virtual
directory

dbtw-wpd

ics-wpd

Textbase Files

Textbase
Files (nonSQL)

Textbase
Files (SQL
version)
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Textbase Files (SQL platform)
This topic pertains only to DB/TextWorks for SQL. If you are using the non-SQL platform, see
Textbase Files (non-SQL platform).
A DB/TextWorks for SQL textbase consists of a number of files, all of which have the same
name as the textbase, but different extensions. For example, a textbase called Sales consists of
the files SALES.CAC, SALES.CBA, and so forth.
Important! Records, indexes, and other important files reside inside SQL server. Backing up
the textbase files shown below does not provide a complete backup. For more information, see
Back Up Textbases (Back Up & Restore menu).
Extension
.CAC

Description
Access control file; controls simultaneous access to the textbase by multiple users
or software instances, or applications.

.CBA

Primary textbase definition file, which also contains textbase elements (for
example, forms, query screens, sets, record skeletons) stored in the textbase.

.CBS

Textbase structure file, contains field definitions and other information about the
structure of the textbase.

.HLP

Optional textbase-specific help file.

.INI

<textbase>.INI is an optional file used with Copy Special applications, TextbaseSpecific Help, and the Applications menu.

.LOG

Optional textbase log file; lists changes to records and the textbase structure.

.SLT

Optional file that is created when EnableSlotLog=1 appears in the [Advanced]
section of the INMCSRV.INI or <textbase>.INI file. This option can be set in
INMCSRV.INI during Setup using the Track Textbase Access button on the
Configuration dialog box. The machine name and login name of each user who has
a textbase open is recorded in the .SLT file. The line is cleared when each user
closes the textbase.

TML

Thesaurus maintenance locking file, prevents more than one person at a time from
modifying records in that thesaurus textbase. Note that .TML files do not have to
be backed up. The software automatically creates them if they do not exist.

DB/Text for SQL Administration
DB/Text for SQL includes an Administration program (InmCSAdmin.EXE) that provides a
number of administrative and maintenance tasks specific to the SQL platform.
Important! Access to the Administration program should be restricted, because it provides the
ability to configure SQL Server security rights, change the SQL instance, rename and delete
textbases, and perform similar tasks. You may want to allow certain members of the Information
Technology (IT) department to use the Administration program.
The Administration program is installed with both DB/TextWorks for SQL and the corresponding
WebPublisher for SQL application. If DB/TextWorks and WebPublisher are on different servers,
you will have two (identical) versions of the Administration program (one on each server).
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On the Start menu, the Administration program is identified as follows:
Administration (TW-SQL) indicates the program installed with DB/TextWorks for
SQL.
Administration (WP-SQL) indicates the program installed with WebPublisher for
SQL.
Both Administration options provide the same features; the only difference is that the server on
which the program is installed might have different network access.
The Administration program provides the following menus and commands.

Configure SQL Server
Setup Wizard
Initialize SQL Server>Select/Change SQL Instance
Initialize SQL Server>Create Control Database
Manage Security>Change SQL password
Manage Security>Assign User Rights to SQL Server
Manage Security>Assign User Rights to Textbase

Manage Textbases
Clear Textbase Record Locks
Dump Textbase
Load New Textbase
Analyze Textbase
List Textbases
*Recover Textbase
*Check Textbase
*View Check Textbase Report File
*Copy Textbase
*Rename Textbase
*Delete Textbase
* A Manage Textbases menu appears in both the Main window and the Administration program.
To access commands indicated by an asterisk, you must run the Administration program.

Back Up & Restore
Back Up Textbases
Restore Textbases

Manage Upgrades
Upgrade DB/Text for SQL>Control Database
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Upgrade DB/Text for SQL>Textbases
Upgrade DB/Text for SQL>Menu Screens
Convert from DB/Text>Textbases
Convert from DB/Text>Menu Screens
Convert from DB/Text>Web Components
Related Topics
Convert from DB/TextWorks (non-SQL) to DB/TextWorks for SQL

Replacing the Submit Query Button with an Image (SQL
platform)
This topic only applies to DB/TextWorks for SQL.
When using query screens on the Web, you can replace the Submit Query button with an
image.
To replace the Submit Query button with an image, use a text editor to change the following
line at the bottom the exported query screen:
<input type="submit" value="Submit Query">

Change the value of the type= parameter to image, remove the value= parameter and add a
src= parameter showing the image file name. You must explicitly specify the image location.
For example:
<input type="image" src="/ics-wpd/images/strtsrch.gif">

The above example replaces the Submit Query button with an image named STRTSRCH.GIF.

Configure SQL Server
Setup Wizard
During the installation of DB/TextWorks for SQL you can use the Setup Wizard to select the
SQL instance, assign user rights to that SQL instance, and create the control database for the
SQL instance for DB/TextWorks for SQL.
To use the Setup Wizard
1. Select Configure SQL Server>Setup Wizard.
2. On the Setup Wizard: Select SQL Instance dialog box, specify the SQL Server. Use the
Browse button to choose from a list of available SQL Servers on your network. Then
click Next.
3. Depending on your situation:
If you are using Windows Authentication, on the Setup Wizard: Assign User Rights
to SQL Server dialog box, assign user rights to the SQL Server. Then click Finish.
If you are using SQL Authentication, on the Setup Wizard: Change SQL Password
dialog box, fill in the New password box. Then click Finish.
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4. Once you see the message "DB/TextWorks for SQL has been successfully configured
on SQL Server <name of SQL instance>", the control database has been created. Click
OK to dismiss the message.
If you do not use the Setup Wizard, you will have to use the separate functions to accomplish
what the Setup Wizard does:
Configure SQL Server>Initialize SQL Server>Select SQL Instance
Configure SQL Server>Initialize SQL Server>Create Control Database
Configure SQL Server>Manage Security>Assign User Rights to SQL Server) or
Configure SQL Server>Manage Security>Change SQL Password.

Initialize SQL Server
Create Control Database
Note: This command is available when you use the Inmagic DB/Text for SQL Administration
program (InmCSAdmin.EXE). You must have SQL Server sysadmin privileges to use the Create
Control Database command. (Note that Windows Administrators are automatically sysadmins
on a local SQL Server.)
After installing DB/Text for SQL for the first time, you must run this command (on the Configure
SQL Server>Initialize SQL Server menu) to prepare your Microsoft SQL Server for use with
DB/TextWorks. If you use the Setup Wizard function on the Configure SQL Server menu, you
do not have to use this command, as the control database is created automatically when you
use the Setup Wizard.
This command creates the following required items on the SQL Server:
A control database on the server, called _InmTextbases.
A database table to store IDs for each textbase.
If you are using SQL Authentication, a SQL login name for the server (called
_Inmagic_Content_Server). During installation, a default password is assigned to this
account. We recommend you change the password once DB/TextWorks for SQL is up
and running.
For specific information on the files affected by this command, see the Inmagic DB/Text for SQL
Administrator's Guide.
To set up SQL Server for use with DB/TextWorks for SQL
Note: If you are using DB/TextWorks for SQL, you should have already specified a SQL Server
instance (choose Configure SQL Server>Initialize SQL Server>Select SQL Instance), as
explained in the Inmagic DB/Text for SQL Installation Notes.
1. Choose Configure SQL Server>Initialize SQL Server>Create Control Database to
create the necessary databases and login on your SQL Server.
2. A message informs you when the setup is complete. Click OK to dismiss the message.
You should have to run this procedure only once, when you first install DB/TextWorks for SQL
for your site if you do not use the Setup Wizard.
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If you upgrade to a new version of the software, use the Manage Upgrades>Upgrade DB/Text
for SQL>Control Database command. This step is not always necessary, but does no harm.
Consult the installation notes to determine if this is needed.

Select/Change SQL Instance
Use this dialog box to set or change the default SQL Server.
Important! Back up any textbases you may have before you change to a different SQL Server.
You will not be able to access textbases on the current SQL Server once you have changed to a
different SQL Server. After you have changed to a different SQL Server, you can install your
backed up textbases onto it, if needed.
1. Choose Configure SQL Server>Initialize SQL Server>Select SQL Server or
Configure SQL Server>Initialize SQL Server>Change SQL Server.
2. Specify the SQL Server. If the Browse button is available, you can choose from a list of
available SQL Servers on your network. Otherwise, use one of the following methods to
specify the SQL instance:
IP address followed by a comma and the port number on the SQL Server. If you do
not include a port number, the default port (1433) is used. Example (with port
specified): 192.168.0.199, 1783
Instance name. Example: SQL254
Tip! In some cases, you may be able to type a period in the SQL Instance box to
automatically enter the SQL instance. In other cases, you may need to use the
expanded format, for example, <machinename>\SQLExpress.
Server name followed by a backslash and the instance name. Example:
SQLDATA\SQL254

3. Click OK.

Manage Security
Change SQL Password
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE), and is enabled only if you are using SQL Authentication (instead of
Windows Authentication).
Use this command to change the password for your SQL Server user account for Inmagic
DB/TextWorks for SQL. This user account, _Inmagic_Content_Server (created when you chose
Configure SQL Server>Create Control Database during the installation of the product)
controls access to all DB/TextWorks for SQL textbases.
Important! When you install DB/TextWorks for SQL, a default password is assigned for the
_Inmagic_Content_Server account. If you plan to use both DB/TextWorks for SQL and
WebPublisher PRO for SQL, you must first change this initial SQL password for each
component. You must use the same password for both applications. Be sure to use the copy of
the Administration program that is specific to that component.
If you are using DB/Text for SQL with Windows Authentication, you do not have to change the
SQL password. In this case, the command is disabled because it is only applicable when SQL
Authentication is used.
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To change a SQL Server password
1. Choose Configure SQL Server>Manage Security>Change SQL Password to open
the Change SQL Password dialog box.
2. Type a new password in the New password box.
3. Click OK. Your new password is in effect.
Tip! If you are publishing textbases on the Web and you change the SQL password for
DB/TextWorks for SQL, you must also change it for WebPublisher PRO for SQL. To do this, run
the copy of InmCSAdmin.EXE located in the Exec subfolder of the WebPublisher PRO for SQL
installation folder and specify the same password. Note that you must restart IIS (the World
Wide Web Publishing Service) before the change will take effect on the Web.

Assign User Rights to SQL Server
This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE). This command is only enabled if you are using Windows Authentication to
secure access to the software. For more information, see the Inmagic DB/Text for SQL
Administrator's Guide.
Use the Assign User Rights to SQL Server dialog box to add and remove users of the SQL
Server control database. Each user name is given membership to a DB/TextWorks for SQL role
to determine how much access that user name has to the control database. Note that there are
also some SQL Server fixed server roles that can be assigned for additional access (for
example, to create a new textbase, the user/group must also have membership to the
db_creator fixed server role).
Tip! Before changing the access a user/group has to DB/TextWorks for SQL, be sure that
user/group is not using the software.
To assign or change rights for a DB/TextWorks for SQL user on the SQL Server
1. Choose Configure SQL Server>Manage Security>Assign User Rights to SQL
Server.
2. On the Assign User Rights to SQL Server dialog box, from the Current Database Users
list, select the user name for which you want to set rights. If the user name is not in the
list, click the Add User button to locate and add the user name to the list. (Note that for
a user name to be visible, the user/group must exist in the Windows domain [of which
SQL Server is a member] and have a login on the SQL Server.)
3. From the DB/TextWorks for SQL role membership group, select an option button to
assign the user name membership to the appropriate DB/TextWorks for SQL role. A
user can only be assigned one DB/TextWorks for SQL role. Note: If the user has
sysadmin rights or is a member of db_owner, the options in this group will be disabled
because the user already has administrator rights.
None. The user name does not have membership to any DB/TextWorks for SQL
role and cannot access the SQL Server or the control database. This means that
user name will not be able to open any textbases or perform any operations.
DB/TextWorks for SQL User. The user name has Read and Execute permission.
This is required for any user you plan to let open any DB/TextWorks for SQL
textbase.

400

Inmagic DB/TextWorks v13 Printed Help

DB/TextWorks for SQL
DB/TextWorks for SQL Administrator. The user can perform all textbase
management functions (for example, renaming and deleting a textbase). The user
can also modify tables in the control database. We recommend this user also be a
member of the SQL Server fixed server role of db_creator, which enables textbase
creation.
Note: To set security for individual textbases, use the Assign User Rights to Textbase
dialog box.
4.

Click Apply.

5.
Repeat steps 2 through 4 for each user/group that you want to access
DB/TextWorks for SQL.
6.

Click Close.

To remove a database user from SQL Server
1. Choose Configure SQL Server>Manage Security>Assign User Rights to SQL
Server.
2. Select a database user from the Current Database Users list.
3. Click the Remove User button.
4. Click Yes to confirm removing the database user.
5. Click Close.

Assign User Rights to Textbase
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE), and is enabled only if you are using Windows Authentication. For more
information, see the Inmagic DB/Text for SQL Administrator's Guide.
Use the Assign User Rights to Textbase dialog box to add and remove users of a particular
DB/TextWorks for SQL textbase. Each user name is given membership to a DB/TextWorks for
SQL role to determine how much access they have to the textbase.
Tip! Before changing the access a user/group has to a DB/TextWorks for SQL textbase, be
sure that user/group does not have the textbase open.
To assign or change rights for a DB/TextWorks for SQL user on a DB/TextWorks for SQL
textbase
4. Choose Configure SQL Server>Manage Security>Assign User Rights to Textbase.
5. On the Select Textbase dialog box, select the textbase on which you want to set security
and click the Open button. If the textbase has passwords, you are prompted for the Master
password.
6. On the Assign User Rights to Textbase dialog box, from the Current Database Users list,
select the user name for which you want to set security. If the user name is not listed, click
the Add User button to locate and add the user name to the list. (Note that for a user name
to be visible, the user/group must exist in the Windows domain [of which SQL Server is a
member] and have a login on the SQL Server.)
7. [Optional] If you want the user or group with the user name selected in step 3 to be able to
edit the structure of the textbase, select the Member of db_owner check box from the
Properties group. If you select this option, the user or group will also automatically have
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membership to the DB/TextWorks for SQL Textbase Writer role and the options in the
next step will be disabled. (This is also true if the user or group has sysadmin privileges.)
8. From the DB/TextWorks for SQL role membership group, select an option button to assign
the user name membership to the appropriate DB/TextWorks for SQL role. Note that a user
can only be assigned one DB/TextWorks for SQL role.
None. The user name does not have membership to any DB/TextWorks for SQL
role and cannot access the textbase.
DB/TextWorks for SQL Reader. The user name has Read-Only access to the
textbase. The user name has Select permission in SQL tables.
DB/TextWorks for SQL Data Writer. The user name can search and modify
record information (that is, search for, add, edit, and/or delete records), but cannot
modify validation and substitution lists.
DB/TextWorks for SQL Textbase Writer. The user name can search and modify
record information (that is, search for, add, edit, and/or delete records), and update
validation lists when overriding content validation (if the appropriate options are
selected on the Edit Textbase Structure dialog box).
9. Click Apply.
10. Click Close. The Assign User Rights to Textbase dialog box closes, and the Select
DB/TextWorks for SQL Textbase dialog box opens so that you can select another textbase
for which to specify security. If you do not want to specify security for another textbase, click
Cancel on that dialog box.
To remove a database user from a DB/TextWorks for SQL textbase
1. Choose Configure SQL Server>Manage Security>Assign User Rights to Textbase.
2. On the Select DB/TextWorks for SQL Textbase dialog box, select a textbase and click
the Open button. If the textbase has passwords, you are prompted for the Master
password.
3. On the Assign User Rights to Textbase dialog box, select a user name from the Current
Database Users list.
4. Click the Remove User button.
5. On the confirmation message, click Yes to confirm removing the database user
6. Click Close.

Manage Textbases
Manage Textbases menu (SQL Administration)
This topic pertains only to the SQL platform.
DB/TextWorks for SQL includes a Manage Textbases menu in both the Main window and the
Administration program. The options indicated below by an asterisk (*) are available only on the
Manage Textbases menu in the Administration program.
Clear Textbase Record Locks
Dump Textbase
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Load New Textbase
Analyze Textbase
List Textbases
*Recover Textbase
*Check Textbase
*View Check Textbase Report File
*Copy Textbase
*Rename Textbase
*Delete Textbase

Backup and Restore
Back Up Textbases (Back Up & Restore menu)
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
Use this command to create a backup file set for any DB/TextWorks for SQL textbase. You can
also use this command if you need to copy a textbase where the Copy Textbase command
would not work. For example, if you need to move a textbase to a different Microsoft SQL
Server, you could make a backup copy of the textbase and all the necessary files. Then, move
the backup file set to a location accessible to the other SQL Server (for example, copy all the
files onto a CD) and restore the textbase files to the other SQL Server.
Note: Because the software uses Windows Authentication by default, you must have
membership to the SQL Server fixed database role of db_owner or to the SQL Server fixed
server role of db_backupoperator in order to back up textbases.
To back up a textbase
1. Choose Back Up & Restore>Back Up Textbases to open the Back Up Textbase
Options dialog box.
2. In the Textbases box, click the Browse button and navigate to the textbase(s) you want
to back up. Note that you can select more than one textbase by using Windows
commands to do so (for example, Ctrl+Click). If the machine from which you are
running DB/TextWorks for SQL is different from the one on which the SQL Server
resides, you must use a Universal Naming Convention (UNC) file path.
3. In the Backup path box, type the folder for the backup file set, or click the Browse
button and navigate to it. The folder for the backup file set should be on the same
machine as the SQL Server, or be a public folder on a shared network.
4. Select or clear the Shrink SQL Server database check box depending on whether you
want to shrink the database during the backup process. Shrinking the database will
release unused space in the data files, ultimately helping to prevent your log file from
growing without limit. If selected, the free space after shrinking will be 10 percent. By
default, this check box is selected.
5. Click OK to back up the textbase(s).
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6. Review the information on the Back Up Textbases: Operation Status dialog box and click
Close when you are done.
7. In addition to backing up the textbase, you must back up User Files, Menu Screens,
Images, and Annotations. For instructions, see Backing Up Textbases.
The backup command copies the records, indexes, and other information from the specified
textbase into a .DAT file and creates a copy of all the textbase files in the specified location.
The backup file set is Read-Only, so that the files are not accidentally modified or deleted.
Any changes you make to the original textbase after the backup will not be reflected in the
backup. If you need to restore the textbase from the backup, use the Restore Textbases
command.

Restore Textbases (Backup & Restore menu)
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
Use this command to restore a textbase from a backup file set. Using this command, you can
replace an existing textbase or create a new textbase from a backup.
Also, you can use this command to copy a textbase where the Copy Textbase command will
not work. For example, if you need to move a textbase to a different Microsoft SQL Server, you
could make a backup copy of the textbase and all the necessary files. Then, move the backup
file set to a location accessible to the other SQL Server (for example, copy all the files onto a
CD) and restore the textbase files to the other SQL Server. For more information, see the
Inmagic DB/Text for SQL Administrator's Guide.
Note to DB/TextWorks for SQL users: Because the software uses Windows Authentication by
default, you must have membership to the SQL Server fixed database role of db_owner or to
the SQL Server fixed server role of db_backupoperator in order to restore textbases.
To restore a textbase
1. Choose Back Up & Restore>Restore Textbases to open the Restore Textbase
Options dialog box.
2. In the Backup sets box, click Browse to navigate to the backup set(s). Note that you
can select more than one backup set by using a Windows commands to do so (for
example, Ctrl+Click). The location for the backup file set should be on the same
machine as the SQL Server, or be a public folder on a shared network. If the machine
from which you are running DB/TextWorks for SQL is different from the one on which the
SQL Server resides, you must use a Universal Naming Convention (UNC) file path to the
backup file set.
3. In the Restore path box, click Browse to select the location of the folder where the
textbase(s) should be restored. Note that the SQL Server needs Write access to the
folder.
4. Click OK.
5. If DB/TextWorks for SQL is using Windows Authentication, a message appears when
the restore is complete, to remind you to use the Configure SQL Server>Manage
Security>Assign User Rights to Textbase command to permit users to access the
restore textbase(s). Click OK to dismiss the message.
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6. Review the information on the Restore Textbases: Operation Status dialog box and click
Close when you are done.

Manage Upgrades
Upgrade DB/Text for SQL>Control Database
Note: This command is available when you use the DB/Text for SQL Administration program
(InmCSAdmin.EXE).
When you receive an update to the Inmagic DB/TextWorks for SQL program, you may need to
run the Manage Upgrades>Upgrade DB/Text for SQL>Control Database command to
upgrade the control database on your Microsoft SQL Server.
This command upgrades the control database to the current version of DB/TextWorks for SQL.
You also have the option to upgrade all existing DB/TextWorks for SQL textbases. If you choose
not to, you can use the Manage Upgrades>Upgrade DB/Text for SQL>Textbases command
to upgrade your textbases individually or a few at a time, if you prefer.
Note: If you are installing DB/TextWorks for SQL for the first time at your site, you must choose
Configure SQL Server>Initialize SQL Server>Control Database or use the Setup Wizard
instead of Manage Upgrades>Upgrade DB/TextWorks for SQL>Control Database.
To update a SQL Server and textbases
1. Choose Manage Upgrades>Upgrade DB/Text for SQL>Control Database to start the
upgrade process.
2. A message asks if you want to upgrade all textbases on the SQL Server. Depending on
what you want to do, click one of the following buttons:
Yes to upgrade the textbases. If a textbase has a Master password, you will be
prompted for it before the textbase is upgraded. During the update, the Operation
Status dialog box opens and its Operation log and status bars show the progress of
the update.
No to not upgrade the textbases. Only the control database is updated on the SQL
Server. When this upgrade is complete, a message displays. Click OK to dismiss
the message. You can upgrade individual textbases later by using the Manage
Upgrades>Upgrade DB/Text for SQL>Textbases command.
For specific information on the files affected by this command, refer to the Inmagic DB/Text for
SQL Administrator's Guide.

Upgrade DB/Text for SQL>Textbases
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
This command upgrades existing textbases for use with the latest version of DB/TextWorks for
SQL.
When you choose Manage Upgrades>Upgrade DB/Text for SQL>Textbases, the Select
Textbase dialog box opens so that you can select the textbase(s) you want to upgrade and start
the process.
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You must upgrade textbases when you are upgrading to a new version of Inmagic DB/Text for
SQL and the installation notes specify that this step is needed. Note, however, that if you
upgrade all of your textbases when you upgrade your control database (choose Manage
Upgrades>Upgrade DB/Text for SQL>Control Database and click Yes when prompted to
upgrade your textbases), you do not have to use this Manage Upgrades>Upgrade DB/Text for
SQL>Textbases command.

Upgrade DB/Text for SQL>Menu Screens
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
This command (on the Manage Upgrades menu) upgrades your existing menu screens for use
with the latest version of the DB/TextWorks for SQL platform.
You must upgrade your menu screens when you are upgrading to a new version of Inmagic
DB/TextWorks for SQL and the installation notes for new and upgrade installations specify that
this step is needed.
To upgrade menu screens
1. Choose Manage Upgrades>Upgrade DB/Text for SQL>Menu Screens to open the
Specify Inmagic Menu Screen File dialog box. Select the menu screen(s) you want to
upgrade, then click Open. The menu screens must all be in the same folder.
2. On the Confirm Settings dialog box, review the list of menu screens that will be
upgraded, then click Finish to confirm them and start the upgrade.
3. On the Operation Status dialog box, wait while the upgrade completes and the Operation
log shows what was upgraded. This information is logged to CSUpdates.LOG in the
same folder as the menu screens. We recommend you review this information to ensure
that all of the upgrades completed as intended.

Converting from DB/TextWorks (non-SQL) to DB/TextWorks for SQL
When converting from DB/TextWorks (non-SQL) to an Inmagic product with a SQL Server back
end, you must convert your existing textbases and menu screens. If you are publishing
textbases on the Web with WebPublisher PRO Web, you must also convert your screens,
forms, and other Web-related files for use with your new system. For more information about
this, see the PDF Converting to the Inmagic DB/Text for SQL Platform.
This topic provides an overview of the conversion process.
To update textbases, menu screens, and Web components
Use the following commands in the DB/Text for SQL Administration window:
Manage Upgrades>Convert from DB/Text>Textbases to convert textbases that were
created with the non-SQL platform so that they can be opened with DB/TextWorks for
SQL. This command starts a wizard that takes you through the conversion process. You
can update multiple textbases at once, as long as the textbases are in one folder. If they
are not, you must run the wizard for each folder containing textbases. Before you start
the conversion process, we strongly recommend you back up your existing textbases
using your usual method.
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Manage Upgrades>Convert from DB/Text>Menu Screens to convert menu screens
that were created on the non-SQL platform so that they can be opened with
DB/TextWorks for SQL.
Manage Upgrades>Convert from DB/Text>Web Components to convert Web
components (for example, HTML query screens, script files, and other Web-related files)
for use with WebPublisher PRO for SQL. You only need to use this command if you
have WebPublisher PRO.

Convert from DB/Text>Textbases
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
This command converts existing DB/TextWorks (non-SQL) textbases for use with the latest
version of the DB/TextWorks for SQL platform.
When you choose Manage Upgrades>Convert from DB/TextTextbases, the Select
Textbases to Convert to DB/TextWorks for SQL dialog box opens so that you can select the
textbase(s) you want to convert and start the process.
You must convert textbases when you are converting from DB/TextWorks (non-SQL) to
DB/TextWorks for SQL.
Note: If any of the textbases you plan to update from non-SQL to SQL contain image
annotations that were created with DB/TextWorks version 7.01 or earlier, copy the Art32.DLL
file from your DB/TextWorks installation folder to your DB/TextWorks for SQL installation folder
prior to choosing the Manage Upgrades>Convert from DB/Text>Textbases command.

Convert from DB/Text>Menu Screens
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
This command (located on the Manage Upgrades menu) converts your existing DB/Text menu
screens for use with the SQL platform.
To convert menu screens
1. Choose Manage Upgrades>Convert from DB/Text>Menu Screens to open the Select
Menu Screens to Convert to DB/TextWorks for SQL dialog box. Select the menu
screen(s) you want to update, then click Open. The menu screens must all be in the
same folder.
2. On the Convert Menu Screens from DB/Text: Confirm Settings dialog box, review
the list of menu screens that will be converted, then click Finish to confirm them and
start the conversion.
3. On the Operation Status dialog box, wait while the conversion completes and the
Operation log shows what was updated. This information is logged to CSUpdates.LOG
in the same folder as the menu screens. We recommend you review this information to
ensure that all of the conversion completed as intended.
When you convert your DB/TextWorks menu screens for use with DB/TextWorks for SQL, any
textbase boxes on those menu screens that are pointing to a DB/TextWorks textbase will only
work if both of the following are true:
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You have converted your DB/TextWorks textbases for use with the DB/TextWorks for
SQL platform (choose Manage Upgrades>Convert from DB/Text>Textbases). If you
converted your menu screens first, you can still convert your textbases.
When you converted your textbases, you placed the new copies of the textbases in the
same location as the originals. (Note that doing this did not overwrite your original
textbases, as the new files have different extensions.)
If both of the above requirements are not met, you must open your menu screens in the Menu
Screen Designer and re-direct any textbase boxes to point to your new, converted textbases in
the location to which you converted them.
For more information, see Converting to the Inmagic DB/Text for SQL Platform, a PDF that
explains how to migrate from the non-SQL to SQL platform..

Convert from DB/Text>Web Components
Note: This command is available through the Inmagic DB/Text for SQL Administration program
(InmCSAdmin.EXE).
If you have Inmagic DB/Text WebPublisher PRO, use this command (located on the Manage
Upgrades menu) to convert your existing Web components (for example, HTML query screens,
script files, and so forth) so that they work with the latest version of the DB/TextWorks for SQL
platform. For more information about this, see Converting to the Inmagic DB/Text for SQL
Platform, a PDF that explains how to convert your software.
Your new version of WebPublisher PRO also uses a new virtual directory, named ics-wpd,
instead of dbtw-wpd.
The Manage Upgrades>Convert from DB/Text>Web Components command makes a copy
of certain files, updates them to point to the new virtual directory, and moves them to a new
installation folder (ICSWEB, if you accepted the default folder during installation).
Important! Your existing WebPublisher PRO folder structure and files will remain intact.
Before you can use your converted Web components with the new version of WebPublisher
PRO, you must also convert any textbases that are used on the Web for use with the
DB/TextWorks for SQL platform (choose Manage Upgrades>Convert from
DB/Text>Textbases). You can convert Web components and textbases in any order.
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Distributing Textbases with the Run-time Version
This topic is intended for administrators who are planning to distribute textbases for search-only
use.
The Run-time version software is a standalone, search-only version of DB/TextWorks (non-SQL
platform). Run-time software is included with the full version of DB/TextWorks. You can copy
and distribute the Run-time software together with any textbases that you create, according to
the terms of the Run-time Master License Agreement.
End users who install the Run-time software will then be able to search the provided textbases.
They cannot make any changes to records or the textbase structure or create their own
textbases.
Note that the Runtime software requires exclusive access to a textbase and permits only one
instance of the software to run at a time.

What to Give End-Users
The Run-time license agreement allows you to distribute one (1) copy of the Run-time software
along with each copy of a search-only, stand-alone textbase that you create with
DB/TextWorks.
To distribute textbases for search-only use, provide end-users with the following components:
Run-time software. When you unzip the download for DB/TextWorks, you get an install
kit that includes a folder called Runtime. In that folder is the install kit for the Run-time
version. Provide the contents of that folder to the end-users who will search your
textbase. This will enable users to run Setup to install the Run-time software locally.
Note: You may want to make a master copy of the Run-time software, for safekeeping,
by burning a CD that includes the contents of that directory. You can then copy the
contents of that CD for distribution to end-users.
Textbase files. Give each user the textbase you will allow them to search. Provide of
the files that comprise the textbase. You can use the Copy Textbase command to copy
the files onto a disk, or you can use Windows Explorer to copy the files yourself. You do
not have to include the log file (.LOG). If you are distributing linked textbases, be aware
that the link definitions include path information that may not be appropriate for the enduser's configuration. If possible, keep linked textbases together in the same folder. To
ensure that all of the files will be accessible, consider placing all of the files in the same
folder (for example, at the root if you are going to burn a CD).
Image files. If the textbase includes image file references, provide the image files. Note:
The Image field in the textbase records should include image names only (not drive
letter and path). The referenced images should be in the same folder as the textbase.
Menu screen and icon files. If you are distributing menu screens with your textbases,
place the menu screen file (.TBM) and any icon files used by the menu screen in the
same folder with the textbases referenced by that menu screen. If you are have a single
menu screen, and you want it to be used automatically, name it DBTEXT.TBM. Note:
Before distributing textbases, open each menu screen in the Menu Screen Designer,

Inmagic DB/TextWorks v13 Printed Help

409

Run-time version
choose Tools>Screen Properties>General, and select Do not retain path from the
Path setting drop-down list.
DBTEXT.INI. To ensure that the Run-time software will search textbases using the same
rules as the ones with which the textbases were built, include a copy of your
DBTEXT.INI file.
<textbase>.INI file. If you built the Copy Special capability into your textbases or if you
use the Applications menu, your users will need a copy of your <textbase>.INI file. You
will need to tell users how to use Copy Special. If you created a textbase-specific help
file, you would have specified it in the <textbase>.INI file.
Help file. If your textbase includes textbase-specific help, give end users the compiled
Windows help file. The help file must have the same name as the textbase and reside in
the same folder as the textbase, unless you have specified otherwise in the
<textbase>.INI file.
User files (.TBU). If you store elements in the textbase file, you do not have to supply
the user file. You can easily copy elements from your user file to the textbase file using
the Save As command in the Form Designer or Query Screen Designer. If you do
provide user files, instruct each end-user to copy the .TBU file to their own local user file
folder.
Test the CD before duplicating or distributing it, to ensure that it contains all of the necessary
files. Tip! Test it on a PC that does not have DB/TextWorks installed so that you are emulating
the end user's environment.
End-users will copy all of these files locally, then run the Run-time Setup command to install the
software. They can then search the provided textbases. See Installing and Using the Run-time
Version.

Installing and Using the Run-time Version
This topic is intended for users who have received the Run-time version software along with
textbases to search. The Run-time software enables you to search any textbases that were
provided.
Note: The Runtime software requires exclusive access to a textbase and permits only one
instance of the software to run at a time. Therefore, it may not be installed on a server.
Unless the administrator indicates otherwise (for example, if they provided a customized
installation program), follow these steps to install the Run-time software and begin using the
provided textbases:
1. Copy the provided files onto your computer. Unless otherwise instructed, copy all of the
files into a single directory. (Typically, this folder will include both the Run-time software
and the textbases.)
2. Install the Run-time software locally by running Setup from the local directory where you
copied the files. Note: If the Run-time software will be installed on a Windows Vista
operating system, you must be logged in as an Administrator.
3. Open the Windows Start menu and choose Programs>Inmagic
Applications>DBSearchWorks Run-time.
4. Use the Run-time version to open any of the provided textbases.
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Use the online help to learn how to search. Note that many of the topics in the help do not
pertain to the search-only version.

Run-time Master License - Additional Terms and
Conditions
This topic pertains only to the non-SQL version of DB/TextWorks.
The following terms and conditions supplement and modify the DB/TextWorks license
agreement and apply to the Run-time program.
You may copy the Runtime program at no additional cost, solely for distribution of one (1) such
copy along with each copy of a search-only, stand-alone textbase that you create with
DB/TextWorks, and for no other purpose.
Inmagic, Inc. assumes no responsibility for the content, use, distribution, or any copyright or
other proprietary right of or in information that is reproduced or distributed with copies of the
Run-time program.
Except as modified by these Additional Terms and Conditions, the term and conditions of the
DB/TextWorks license agreement apply to the Run-time program.
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