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Welcome! 

Welcome to Inmagic® DB/TextWorks®! This manual contains procedural and reference 
information, including instructions about how to use the software. It is designed to be 
task-oriented, starting with creating a textbase. 

Conventions and Symbols 
This manual uses the following conventions and symbols. 

Typeface 
This manual uses the following typeface conventions: 

• 

• 

• 

• 

Boldface type indicates menu bar actions; keyboard keys; objects on dialog boxes; buttons 
and boxes on query, form, and menu screens; and emphasis. For example, for: 
– Menu bar actions: choose Tools>Options, choose Edit>Copy Special>Record 
– Keyboard keys: press F1 for help, use F3 and paste items from the indexes 
– Objects on dialog boxes: type a number in the Width box, select the Sort in Reverse 

Order check box, select either the Terms List or Words List option button, click the 
Enlarge button 

– Buttons and boxes on query screens, forms, and menu screens: click the Submit 
Query button, type Inmagic in the Company box 

– Emphasis: close the designer and do not save the file, Tip! 
Italics indicate textbase names and field names. For example, open the Sample1 textbase, 
include the Street, City, State, and Country fields in the Address box. 
Courier type indicates text you should type and examples. For example: type 
02/22/2003 in the Date box, author ct smith/jones 
CAPITAL LETTERS indicate directory and file names, and Boolean operators. Note that 
they do not mean that you must type them in capital letters (unless otherwise stated) or that 
you will see them for real in capital letters. For example: The INMAGIC.INI file may be 
saved in the C:\PROGRAM FILES\INMAGIC directory. The Boolean operators AND, OR, 
and NOT.  
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Numbered Lists and Bulleted Lists 
This manual uses the following conventions for numbered lists and bulleted lists: 

1. Numbered lists indicate that order is important, such as multi-step instructions. 

 A square bullet indicates a single-step instruction. 

• Bulleted lists indicate that the order of the items is not important. This is the first-level 
bullet. 
– This is the second-level bullet. 

 This is the third-level bullet. 

Menu Actions (>) and Mouse and Keyboard Actions (+) 
An arrow (>) indicates sequential menu actions. For example: File>Open means, from the File 
menu, choose the Open command. 

A plus sign (+) indicates that the keys and/or mouse clicks should be pressed simultaneously. 
For example: Alt+F4 and Shift+Click. 
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Getting Help 
In addition to this manual, the following  resources are available: 

• Online help. The help file contains the most up-to-date information and includes more 
details than this manual. To open the help file, start DB/TextWorks and press F1, or choose 
Help>Help Topics from the DB/TextWorks menu bar. For context-sensitive help, click 

 on the DB/TextWorks toolbar, then click the menu command or toolbar button that you 

want to know about. Another useful feature is the Help on this Window button . Click 
the button and a help topic on specific tasks you can perform in that window appears. 

• 

• 

• 

• 

Knowledgebase and Web site. With the software open: 
– To search for solutions to common problems, choose Help>Inmagic on the 

Web>Knowledgebase to go to the Inmagic Product Support knowledgebase on the 
Web. 

– To visit the Inmagic Web site, choose Help>Inmagic on the Web>Home Page or 
Help>Inmagic on the Web>Support Page. 

You must have a Web browser installed to be able to use these features. 

Error messages textbase. The software includes an error messages textbase 
(DBTMSG.TBA) in the DB/TextWorks installation directory. Use it to find out what an 
error message means and what you can do to fix the problem. You can search for any word 
or phrase.  
README file. This file tells you what is new with that particular version of the software; 
lists issues resolved from the previous release and any late-breaking information; and 
contains other important information. The README file is installed in the DB/TextWorks 
installation directory. Open it using a Web browser. 
Installation Notes. This booklet explains how to install the software. This booklet comes 
with the installation CD, and is available as a PDF file on the CD. 
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Contacting Inmagic, Inc. 
If you have tried all the resources listed above and you still need help, you can contact 
Inmagic, Inc. or your local Inmagic dealer. 

If you have a Product Support contract, please have the contract number handy, and try to be at your 
computer when you call. If that is not possible, note exactly what you were doing when you 
encountered the problem, the exact text of any error messages you received, and your software version 
and serial number (choose Help>About DB/TextWorks to look it up). If you do not have a 
Product Support contract, you can contact Inmagic Sales to purchase a support plan. 

Inmagic, Inc. 
200 Unicorn Park Drive 
Fourth Floor 
Woburn, MA 01801 U.S.A. 

Tel: 781-938-4444 or 800-229-8398 
Fax: 781-938-4446 
http://www.inmagic.com 

support@inmagic.com - product support questions and feature requests 
sales@inmagic.com   - sales, product pricing, and custom solution questions 

 
 
If your message is intended for a particular person at Inmagic, Inc. (for example, a Product 
Support representative who is expecting the message or files), please include the name of that 
person in the subject and the message. 

Communicating with Other Users 
You can communicate directly with other Inmagic users by participating in one or more Inmagic 
Web forums. To do so, go to the Inmagic Web site (http://www.inmagic.com). 

 

 

http://www.inmagic.com
http://www.inmagic.com


Chapter 1: Getting Started 

This chapter describes the main features of the Inmagic® DB/TextWorks® software and shows 
you how they fit together as a whole. DB/TextWorks comes with sample textbases that you can 
install during Setup. Use the sample textbases to learn the software. 

Introducing DB/TextWorks 

What is DB/TextWorks? 
DB/TextWorks is a content management system—a type of database software that enables you to 
build networked and standalone textbases to manage text, numbers, dates, and electronic images. 
DB/TextWorks combines traditional database power, including the ability to manipulate data 
and perform arithmetic calculations, with the ability to handle large amounts of text. 

DB/TextWorks also provides you with access to Inmagic.net™, which gives you the ability to 
connect to the Inmagic server from within a DB/TextWorks session to accomplish various tasks 
relating to cataloging, indexing, and disseminating information throughout an 
organization. 

What is DB/Text WebPublisher PRO? 
The software and documentation frequently refer to Inmagic DB/Text® WebPublisher PRO. 
WebPublisher PRO is a separate product that you can purchase. WebPublisher PRO enables you 
to publish textbases on the Internet or an intranet, so Web users can search and modify them 
(that is, add, edit, and delete records via a browser). All WebPublisher products (such as, 
DB/Text WebPublisher and DB/Text WebPublisher Lite) work together with DB/TextWorks, 
which is the “buildware” for creating searchable textbases. The WebPublisher line of products 
has its own user’s manual. Online help for WebPublisher products is integrated with the 
DB/TextWorks online help. If you do not own a WebPublisher product, you can ignore all 
references to it in the software and documentation. 

What is a textbase? 
A textbase is just like a database except that it can handle large amounts of text as well as 
numbers, dates, and images. Each textbase provides an efficient way to organize, update, 
retrieve, and present large amounts of information.  
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Who uses DB/TextWorks? 
DB/TextWorks can help any organization that needs to organize, track, and print the diverse 
types of information encountered daily. Libraries use textbases to catalog books and periodicals. 
Law firms use textbases that contain the complete text of thousands of legal briefs. Businesses 
keep track of production, sales, and distribution information. Marketing departments track 
information about competitors, including internal documents as well as metadata and links to 
Web resources. Government agencies archive letters, faxes, EMail, and policy documents. 
Inmagic, Inc. uses DB/TextWorks to track software development, customer feedback, and 
technical publications. The uses are as varied as the marketplace. 

How is a textbase constructed? 
Every textbase has a structure, which consists of fields and settings that define how the textbase 
will operate. After defining the structure, you populate the textbase by adding records.  

A record is what you find when you search a textbase. Each record represents one item, such as a 
document, a customer, a book, or a deposition. Records are made up of the fields you defined in 
the structure (for example, Name, Address, City, State). Fields in DB/TextWorks do not have 
length limitations, and can be fully indexed. That means you can store long pieces of text, such 
as a 20-page document, and still do a quick search. 

Each field can hold multiple entries. An entry is a piece of information that can be retrieved, 
sorted, or formatted independently. For example, the Phone Number field can hold more than 
one number (such as home, business, and fax numbers). The ability to handle multiple entries in 
one field, instead of requiring separate fields, is one of the unique features of DB/TextWorks. 
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Feature Overview 
With DB/TextWorks, you can build and maintain sophisticated textbases easily and find detailed 
information quickly and accurately. The following illustration shows a few of the key features 
that distinguish DB/TextWorks. 

 

Flexible Textbase Structure 
To create a textbase, you define a textbase structure, which is a list of fields and settings that 
determine how the textbase will operate. A textbase has the following features: 

• Variable-length fields. You never have to define the length of a field. A field can contain 
any number of characters: a 50-page proposal, a 1000-word diagnosis, or a short phrase. 

A field can hold 
multiple 
entries, each of 
which is 
handled as a 
separate item. 

You can display 
data in almost any 
way imaginable. 

Unlimited field 
lengths let you 
store and index 
full text. 

You can 
integrate 
images easily. 

• Multiple (repeating) entries in a field. Fields can include not just one entry, but several. 
For example, you can put the names of several authors in one field and still be able to search 
for, format, and manipulate each name separately. This is an alternative to conventional 
databases that require a separate field for each entry.  

• Relational-like linking. You can store common information in one textbase and access it 
from other textbases. For example, you can store names and addresses in one textbase, but 
search for, display, print, and edit them from another. This reduces the amount of time spent 
entering and editing data and eliminates redundant information. 

• Ability to make changes. You are not locked into the initial textbase design, because you 
can change most aspects of the structure at any time (for example, add and rename fields, 
change indexing and validation). 
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• Comprehensive indexing. An index is a sorted list of information in a field, similar in 
concept to an index in the back of a book. Because every word of every entry can be 
indexed, you can find information quickly and precisely. DB/TextWorks accommodates 
even lengthy documents with ease. 

• Customizable. You can customize DB/TextWorks to your particular needs with a series of 
options provided by the software. You can also re-organize the toolbars, specify languages 
for month and day names, and set many other configuration options. 

• Automated file management operations. Built-in file management operations make it easy 
to copy, rename, and delete textbases and other files. 

• User-definable help. You can include your own online help for each textbase.  

Streamlined Data Entry and Maintenance 
When you need to add information to your textbase, you can enter new records one at a time or 
import thousands of records automatically. Data entry and maintenance features include: 

• Easy information entry and editing. You can add records one at a time or import them 
from a file. Importing records is a fast and easy way to build textbases. You can even import 
the full text of documents, such as letters, memos, and EMail messages. To automate record 
editing, use batch operations to add, edit, and delete information in many records at once. 

• Spell checking. You can quickly check records to eliminate typographical errors, or have 
your spelling checked as you type. 

• Thesaurus. You can create a thesaurus textbase that lets you maintain a controlled 
vocabulary of terms and the relationships among terms, and then connect the thesaurus to a 
field in the textbase. You can also use a thesaurus as a validation list. 

• Validation. You can validate information as it is entered. For example, apply a mask so 
only phone numbers in a specific format are allowed. Or use a validation list to detect 
unauthorized entries, so you have a chance to correct them before they are entered in the 
field, or reject them. 

• Time-saving features. You can use record skeletons (templates) to add information 
automatically to new records. You can define substitution lists to reduce keystrokes (that is, 
just type a few letters and the whole entry will appear). For example, type can and the 
software inserts Canada. You can use scripts in the forms and screens you design to 
perform certain operations when the form or screen is opened or closed, when buttons on 
the form or screen are clicked, or when you leave a box. 

• File conversion and sharing capabilities. You can share information with other textbases 
and applications. You can write formatted record information to a file in Plain Text 
(ASCII), Rich Text Format (RTF), or Hypertext Markup Language (HTML), and you can 
import and export records in text formats, including Extensible Markup Language (XML). 

4 Chapter 1: Getting Started 



Inmagic.net 
Inmagic.net™ gives you the ability to connect to the Inmagic server from within a 
DB/TextWorks session to accomplish various tasks relating to cataloging, indexing, 
and disseminating information throughout an organization. If you catalog Web pages, you can 
use Inmagic.net to capture metadata in a textbase. Inmagic.net also helps you to configure other 
products (such as the Inmagic® Gatherer and Web Forms Library) for use with specific 
textbases. 

Note that Inmagic.net is an evolving feature. New functionality may be presented periodically. 
Therefore, for the latest information, see the on-screen text for the function pages. You may also 
see a Help button on the toolbar and/or the page. 

For Inmagic.net to work, you must have Microsoft Internet Explorer version 5.01 or later 
installed on your machine, and cookies must be enabled in that browser. (Internet Explorer does 
not have to be your default browser.) 
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Fast, Powerful Searching 
Searching a textbase is fast and precise. Even if your textbase grows to millions of records, you 
can expect little or no reduction in search speed. You can define and save sophisticated queries 
to find the information you need. The search features in DB/TextWorks include the following: 

• Multiple search options. You can use a variety of search options, including word, phrase, 
term (exact complete match), word stem (comput*), proximity (red within 2 words of 
wagon), range (1997:2003), comparison (<500), and Boolean (AND, OR, NOT) 
searches. 

• Flexible search methods. You can type information in boxes or use the command 
language. Both methods are fast and accurate. 

• Customized search screens. You can design your own query screens, which you can use to 
search for records. Each box on the screen represents one or more fields. For example, the 
box labeled Name searches the Name field. The box labeled Type any phrase searches all 
fields in the textbase. Type information into the boxes to do a search.  

 
• Guess-proof searching. You can eliminate guesswork during a search by pressing the F3 

key on the keyboard to display actual record information. This is called browsing. For 
example, press F3 in the Name box to see a list of names, then paste a name in the box so 
you can search for it.  

• Reusable record sets. Records found by a search are called a set. You can save sets (search 
criteria and results) to use again. This is convenient if you do the same searches regularly. 

6 Chapter 1: Getting Started 



Varied Display and Print Options 
After you find records, you can display or print them. There are several windows you can use to 
display record information: 

• The Report window shows multiple records, one after another. 
• The Display window shows one record at a time. 
• The Edit window lets you add or edit one record at a time. 
• The Images window displays images referenced in the records. 
• The Thumbnail window displays all of the images in the current record or field, at a reduced 

size, providing a quick way to find and view a particular image. 
The following illustration shows four of the windows open at once. You can display a different 
record in each window or synchronize the windows so they all show the same record. 

 

 Chapter 1: Getting Started 7 



The way records appear when displayed or printed depends on the forms that are selected. A 
form is a layout for displaying or printing record information. DB/TextWorks automatically 
generates Basic forms that you can use until you design your own: 

• The Basic Record form displays one record at a time. 
• The Basic Report form displays multiple records. 
You can design your own forms for each window, and for printing, to lay out your data in 
various ways. For example, you can design almost any type of label. 

  
Forms can do more than just mirror textbase information. They can include calculations, 
variables, sorts (such as sales by territory), subtotals, and other arithmetic operations to help you 
analyze, track, and summarize information. 
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Multiple Sort Options 
After a search, you can sort records so they appear in a certain order when displayed or printed: 

• Relevancy ranking. Sort records in descending order of relevance, with the most relevant 
records appearing first. 

• Sort and subsort options. You can sort records alphabetically, numerically, or by date, and 
specify whether records appear in reverse order. You can subsort by up to four additional 
fields and use a variety of options to order the records precisely the way you want. 

• Exploded sorts. An exploded sort makes a record appear under each entry in the sort field, 
rather than just the first. For example, if the Employees field contains the names of three 
people, an exploded sort makes the record appear three times (once for each employee). 

• Interfiling. You can interfile two or more fields, such as Author and Corporate Author. 
• Hardwired sorts. You can specify a default sort order or hard wire a sort in a form. Using a 

form sort is particularly useful when a form depends on a particular order (for example, 
sales by territory) for totals and calculations. 

• Unsorted. You can specify that records appear unsorted, meaning that they are listed in the 
approximate order they were added to the textbase. Use this option if you want to speed up 
the display of the report or produce a report with records in an as-entered order. 

Convenient Browsing 
When you search or edit, you can display information relevant to the task by using the Browse 
Choices feature. Instead of typing words or terms, you can pick them from a list by pressing F3 
or choosing Edit>Browse Choices in a query or edit box. 

• 

• 

On a query screen, pressing F3 in a query box displays a list of terms, words, and/or 
thesaurus entries for which you can search. Pressing F3 in a sets box on a query screen 
displays a list of saved sets, which you can combine with other criteria. 
On an edit screen, pressing F3 displays the validation list, substitution list, links (terms 
from the associated field in the secondary textbase), and/or thesaurus entries. 

 Chapter 1: Getting Started 9 



Try pressing F3 in various search and edit boxes, to see what it does. 

With your cursor in a 
query box, press F3 when 
searching to see a list of 
all the items in that field. 
Select an entry from the 
Choices List and click the 
Paste button to paste the 
entry into the query box 
as your search term. 

 

Single-User and Multi-User Environments 
DB/TextWorks allows single or shared access to a textbase. There are several features that help 
control access to a textbase: 

• Indexing mode. To organize and retrieve information, DB/TextWorks relies on indexes. 
When you add, edit, and delete record information, DB/TextWorks updates the indexes to 
reflect the changes. You can select an indexing mode to determine when the indexes are 
updated. 

• Password protection. You can assign passwords to protect your textbases by controlling 
who can view and edit information. For example, hide the Salary field and make other fields 
read-only. Use a Silent password to allow anyone to open a textbase (even without knowing 
a password), while still protecting your information by locking out the features you specify. 
You can also specify record-level security to restrict access to individual records. 

• Maximum number of users. To enhance performance, you can limit the number of times a 
textbase can be opened simultaneously. 

• User files. Each person who uses a textbase can save forms, query screens, sets, and record 
skeletons in a private file, to which no other users have access. 
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Textbase Elements and User Files 
DB/TextWorks uses the phrase “textbase elements” as a convenient way of referring to the 
following items: 

• Forms, which dictate how information is displayed or printed. 
• Query screens, in which you enter criteria to conduct a search. 
• Sets, which contain the results of previous searches. 
• Record skeletons, which are templates used to automatically add information to new 

records. 
Textbase elements are never saved as individual files. Instead, they are saved either in the 
textbase so all users sharing a textbase have access to them, or in a user file so only you (or 
someone using your computer) can have access to them. DB/TextWorks dialog boxes use the 
words public and private to distinguish between the two. 

A user file provides a private place for you to keep your elements separate from other users. For 
more information about user files, see the Appendix.  

Direct Access to Your Most-Used Textbases  
When DB/TextWorks starts, it can display a menu screen that lists the textbases you use most 
often. You click an item on the menu screen to open a textbase. 

 
Menu screens provide an alternative to opening a textbase the “Windows” way (File>Open). 
You create a menu screen when you want to: 

• Access textbases easily. By listing textbases on a menu screen, you can just click to open 
them. You do not have to remember the location of multiple textbases. 

• Set up a starting environment. For each textbase listed on the menu, you can specify the 
initial set of forms and query screens to use. For example, you can specify which query 
screen should appear and which forms should be used for editing and printing. You can 
even specify that a particular search be executed when you click the menu item. 
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Integrated Image Management 
Textbase records can have images associated with them, which you can retrieve, display, and 
print. For example, you could include scanned documents or photographs. This function has the 
following features: 

• Multiple formats. DB/TextWorks supports color, grayscale, and black and white images in 
a variety of formats, such as TIFF, PCX, JPEG, BMP, and TGA, giving you instant access 
to photographs, line drawings, 35mm slides, documents, schematics, permits, maps, and 
other types of visual information.  

• Seamless integration. Adding images to a textbase is simple. You add an Image field type 
to the textbase structure, then type or batch-import file names into the field. 

• Open architecture. Designed as an open system, DB/TextWorks is compatible with 
industry-standard monitors, printers, storage devices, and other hardware components. 

• Efficient image storage. Image files are not stored inside the textbase, but externally on 
servers, hard disks, CD-ROMs, DVDs, or other storage devices.  

• Straightforward file management. Batch editing, user-configurable drive letter 
specifications, and flexible naming conventions make image file management easy. 

To learn more about working with images, see Chapter 7, “Working with Images.” 

Installing Inmagic DB/TextWorks 
To install DB/TextWorks, see the separate installation notes included with your software. You 
can install program files, online help, and sample textbases. We recommend installing all 
components, if you have enough disk space. 

DB/TextWorks 
Follow the prompts to install DB/TextWorks. When you get to the DB/TextWorks configuration 
dialog box, take a look at Chapter 10, “Customizing DB/TextWorks,” which explains the 
configuration options. You must specify the number of licensed users when prompted. For 
example, if you purchased a multi-user license agreement to share DB/TextWorks on a network, 
you must specify the number of licensed users, after running Setup (see page 14). 

DB/Text PowerPack Lite 
Optionally, install Inmagic DB/Text® PowerPack™ Lite, which is a set of two utilities that you 
can use on DB/TextWorks textbases to help automate management and maintenance tasks. After 
installing PowerPack Lite, open the Windows Control Panel and double-click one of the icons, 
depending on which program you want to use: 

• DB/Text® Updater, which automatically and continually posts deferred updates using 
background processing. 

• DB/Text® Checker, which analyzes textbase integrity and fixes certain problems. 
You configure and run each utility independently. Each has its own icon in the Windows Control 
Panel, its own dialog boxes, and its own help file, which you can access from the dialog boxes.
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Starting Inmagic DB/TextWorks 
Once the software is installed, you are ready to start DB/TextWorks and open a textbase. 

To start DB/TextWorks 
 Click the Windows Start button and choose Programs>Inmagic Applications>Inmagic 

DBTextWorks>Inmagic DBTextWorks. When you start the software, only a few menu 
options are available. To see more options, create or open a textbase. 

Note: The first time you open the software, the User File Path dialog box opens so you can 
specify a location for your user files. You can accept the default or specify another location. 
For more information about user files, see the Appendix. 

To open a textbase using the File menu 
1. Choose File>Open. 

2. When prompted, select a textbase and click Open. 

The following may happen, depending on the situation: 

• When you open a textbase that does not yet contain any records, a message appears 
indicating that the Edit New Record window will open so that you can create some. 
Tip! If you do not want to be notified when opening an empty textbase, choose 
Tools>Options to open the Options dialog box. On the General tab, clear the Notify when 
opening empty textbase check box, then click OK. When you open an empty textbase, you 
will not be notified and the Query window will open instead of the Edit New Record 
window. 

• When you open a textbase that contains records, the Query window opens so that you can 
begin a search. 

To open a textbase using a menu screen 
Another way to open a textbase is to use a menu screen. A menu screen is a list of items, such as 
the names of often-used textbases. When you click an item, the textbase opens and certain 
options are preselected. Read about menu screens on page 11 of this chapter and in Chapter 6, 
“Working with Menu Screens.” 
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To open a sample textbase 
If you installed the sample textbases, you can use them as you learn the software. Textbases 
Sample1 and Sample2 are located in a subdirectory of the DB/TextWorks installation directory. 
To open a sample textbase, follow the instructions given previously to open a textbase, or click 
the Windows Start button, point to Programs>Inmagic Applications>Inmagic 
DBTextWorks, then click Sample Textbases. When the menu screen appears, click an icon to 
open a textbase. 

To close a textbase 
 Choose File>Close. 

To exit DB/TextWorks 
 Choose File>Exit. 

Specifying the Number of Licensed Users 
If you purchased a multi-user license agreement to share DB/TextWorks on a network, you need 
to perform the steps below to specify the number of licensed users. Do this immediately after 
installing DB/TextWorks or after purchasing additional licenses. 

1. Locate your Network Upgrade Password, which is supplied on a separate sheet of paper. 

2. Log in to your network using an account with full access to the directory where 
DB/TextWorks is installed (for example, Administrator access). 

3. Start DB/TextWorks, but do not open a textbase. 

4. Choose Tools>Enable or Upgrade Network. 

5. The Enable or Upgrade Network dialog box shows your serial number and the current 
number of licensed users. Type the new number of licensed users, and the password 
provided to you by Inmagic, Inc. 

Important! Type the number of licensed users that you expect to have, not the number that 
you are adding. For example, if you have a 20-node network version, and have purchased an 
additional 10 nodes, type 30. 

6. Click OK. 

If you have any existing textbases and you need to have all of your users accessing them, open 
each one and edit the textbase structure to increase the number of maximum users to match or 
exceed the number of licensed users (choose Maintain>Edit Textbase Structure>Maximum 
Users). 
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Using the Run-time Software 
A separate Run-time program is included with every full version of DB/TextWorks that you 
purchase. The Run-time software is a standalone version of DB/TextWorks, which lets users 
search textbases, but not do any editing. You can copy and distribute the Run-time software 
together with any textbases that you create. (See the online help for the license agreement.) 

The Run-time software lets you share your textbases with other people who do not have access 
to DB/TextWorks. Users who install the Run-time software from the disks that you give them 
will be able to open your textbases and search them. They will not be able to make any changes 
to records or the textbase structure, nor can they create their own textbases. 

Note: End users will need a 32-bit Windows operating system to use the Run-time software. In 
addition, they must have Microsoft Internet Explorer 5.01 or later installed on their machines 
before they install the Run-time software in order to use certain features, such as the Thesaurus 
or forms or screens that use scripts. 

You can distribute your textbases using floppy disks or a CD-ROM. To learn how, see the 
DB/TextWorks online help, the “Distributing Textbases with the Run-time Version” topic. 
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Taking a Quick Tour of DB/TextWorks 
When you use DB/TextWorks, you follow these basic steps: 

1. You create a textbase. 

2. You populate the textbase with records. 

3. You search the textbase and retrieve records. 

4. You manipulate the records (for example, display them, print them, edit them). 

Note that you must retrieve records before you can do anything with them. That means whenever 
you open a textbase, the first thing you do is perform a search. However, if you open a textbase 
that does not contain any records, the first thing you do is add records. 

This Quick Tour uses textbases that have already been created for you. In the tour, you will: 

1. Open a textbase. 

2. Search and display the records you find. 

3. Display what you found in a report form, including sorting records. 

4. Build and edit a textbase. 

About the Sample Textbases 
DB/TextWorks includes two sample textbases designed for a fictitious company called 
TechKnow Consulting. The company provides a variety of high-tech services to their client 
companies. The sample textbases are located in a subdirectory of the installation directory. If 
you did not install the sample textbases, do so now by running Setup from the Inmagic 
DB/TextWorks CD. 

• Sample1 is the primary textbase. It contains information about consultants registered with 
TechKnow. Placement counselors at TechKnow use this textbase to locate available 
consultants with skills that match the needs and budgets of their clients. The Sample1 
textbase is linked to Sample2. 

• Sample2 is the secondary textbase. It contains information about companies that employ 
TechKnow consultants. 
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Taking the Tour 
The tour takes about 30 minutes. 

Stage 1: Opening a textbase 
1. Start DB/TextWorks by clicking the Windows Start button, point to Programs>Inmagic 

Applications>Inmagic DBTextWorks, then click Sample Textbases. 

Note: If this is the very first time you open the software, the User File Path dialog box 
opens to let you specify a location for your user files. Accept the default or specify another 
location. For more information about user files, see the Appendix. 

2. When the menu screen appears, click Sample 1 - Consultants to open the Sample1 
textbase. 
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Stage 2: Searching and displaying 
Search criteria can be detailed and precise, to find exactly—and only—the records you want. In 
this exercise, you will do a simple search and display the records that you find, first in the Report 
window and then in the Display window. 

When you open the Sample1 textbase, the Query window displays. The query boxes on this 
window represent fields you can search. 

1. To find all consultants who live in Massachusetts, in the Location box, type MA. 

 
2. Press Enter to start the query, or choose Search>Execute Query, or click the Execute 

Query button . 

3. The Select Search Results Window dialog box opens, showing the number of records found 
and the windows in which you can view them. To choose the window in which you want to 
view the records, select the appropriate option button. For this exercise, accept the default 
setting—Report window—and click OK.  
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The records appear in the Report window, with the word you searched for highlighted.  

 
You can scroll through the report if you want. Note that the form selected for the Report window 
determines how the records appear. This form shows just a few lines for each record. You will 
learn more about forms in a later exercise. 

To display a single record 
Assume you want to see more detailed information about a particular record. 

1. Click any record in the Report window, then choose Display>Display Record or click the 

Display Record toolbar button . The form that is selected for the Display window 

determines how the record appears. Click the Fit Window to Form button . 
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2. Use the arrow buttons on the window’s toolbar to display the next or previous record. To 
see the images associated with the displayed record, choose Display>Show Record Images 

or click the Show Record Images button . You can use the toolbar buttons in the Images 
window to zoom in or out, display other images, and perform other image operations. 

3. Close the Images window. Then close the Display and Report windows. 

To paste from the index—a search alternative 
Instead of guessing at keywords or terms to search for, you can browse indexes to see actual 
record data, which you can paste as search criteria. This is easier than trying to remember 
exactly what is in the textbase and it ensures that the search criteria match actual record 
information. 

This time, you will search for all consultants who know Web design or user interface design. 

1. To clear the query criteria so you can start fresh, choose Search>New Query, or click the 

New Query button . 

2. Click in the Skills box, then press F3 or click the Browse Choices button . The Query 
Choices Browser dialog box opens to show actual record information (all indexed terms in 
the field that you are searching). 

3. In the Find box, type Web to quickly jump to that portion of the Choices List. (You can also 
scroll down in the Choices List until you find the entry you are looking for.) Double-click 
the index entry Web design, then double-click the entry User interface design. This pastes 
both entries into the Skills box. Close the Query Choices Browser dialog box. 
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The search criteria should look like this: 

 
4. Press Enter to start the query, or choose Search>Execute Query, or click the Execute 

Query button . 

5. When the Select Search Results Window dialog box opens, click OK to view records in the 
Report window. After looking at the records, close the Report window. 

Stage 3: Using different forms and sorting records 
After finding records and displaying them in the Report window, you can sort them, or change 
the way they look by selecting a different form, or print them. In the following exercises, you 
will learn how to select a form, sort records, design a form, and print a report. 

To select a form 
A form is a layout that determines how records appear. A form can show or hide textbase 
information, change font and color, and include calculations and subtotals appropriate for 
complex financial reports. Forms can transform dry, ordinary data into vivid, APPEALING 
(and sensible) layouts. You can select a different form whenever you want to see a different 
view of the information. 

For this exercise, we have already created the forms for you. All you have to do is select them.  

1. Click the Find All Records button  on the main toolbar to find all records in the 
textbase and open the Select Search Results Window dialog box. You use this dialog box to 
specify which window you want to use to display your records. You can also use it to 
specify that you do not want to display the records. 

2. Click OK to accept the default, which displays the records in the Report window. 

3. Click the Select Form for this Window button  on the Report window toolbar to display 
a list of forms designed for this window. 

4. Select a form and click OK to see the same records in a different way. 

5. Try choosing different forms (repeat steps 3–4). 

Tip! To quickly resize a window after switching forms, choose Window>Fit Window to 

Form or click the Fit Window to Form button  on the Report window toolbar. 
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To sort records 
You can sort records to organize your information and present it in a useful way. 

1. You should still have records displayed in the Report window from your last search. Click 

the Select Form for this Window button  on the Report window toolbar and select the 
form called Sort Consultant Info (public). 

Note: Typically, you do not need to select a particular form before you sort records. 

2. Select Display>Sort Report. In the Available Fields list, scroll down and double-click 
State to move it into the Sort Fields list. Click OK. Records are now sorted by state. 

3. Select Display>Sort Report again. Click the left arrow button (<) to move State out of the 
Sort Fields list. In the Available Fields list, scroll down and double-click Hourly billing 
rate to move it into the Sort Fields list. In the Settings for This Field group, select the Sort 
in Reverse Order check box, and click OK. Records are now sorted by hourly billing rate, 
from highest to lowest. 

4. Try some other sorts on your own. You can choose up to four fields to do subsorts (for 
example, sort by City and subsort by Consultant name). 

To design a form 
In an earlier exercise, you saw how different forms can change the appearance of records. In the 
following exercise, you will edit a form to make a simple font and color change, to get a sense of 
how easy it is to design your own forms. 

1. Choose Display>Design Form. 

2. On the Open Form dialog box, Sort Consultant Info (public) should be selected. Click OK 
to load it into the Form Designer.  

3. Select any box by clicking it, then choose Tools>Box Properties to open its Form Box 
Properties dialog box. 

4. Select the Labels tab and do the following: 

– Ensure that the Label check box is selected. 
– Click the Set Font button to open the Font dialog box and do the following: 

a. Select a font from the Font list. 

b. From the Color drop-down list, select Red. 

c. Click OK. 

5. On the Form Box Properties dialog, click Apply, then Close. 

6. Choose Form Operations>Save Form. 
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7. Choose Form Operations>Close Form Designer. The Form Designer closes and you can 
see your changes in the Report window. 

If you want to try designing your own form, choose Display>Design Form and select Basic 
Form from the Start With list. Use the Form Designer to make any changes you want. When 
you close the Form Designer, you will be prompted to save and name the form. 

Note: If you want to design a new form based on one you have already designed, open the form 
in the Form Designer, then choose Form Operations>Save Form As, and type a new name in 
the Name box. This will create a copy of the form, which you can then edit to suit your needs 
without losing the form you modeled it after. 

To print a report 
If your computer is connected to a printer (either directly or through a network), you can print a 
report. Do a search, choose whether or not to display the search results, then choose File>Print, 

or click the Print button . If you do not display the results, the report is printed using the 
currently selected Report Printing Form. Note that if the selected report printing form and the 
form that is in use for the active window are different, the Form Used to Print Report dialog box 
opens. Specify whether to print using the form for the selected window; click OK. 

Stage 4: Creating a textbase and editing records 
Now you will create a very simple textbase, add records to it by importing a small text file, then 
edit a record. 

To define the textbase structure  
The textbase structure is a list of fields and settings that determine how the textbase will operate. 
To create a textbase, you define its structure. 

1. Choose File>New Textbase. When prompted for the name of the textbase, type SAMPLE3, 
then specify a location (drive and directory) for it, and click Save. 

2. When the Create Textbase Structure dialog box opens, click OK to accept the default 
option, Define New Textbase. 

3. The Edit Fields dialog box opens, so you can specify the fields that will make up the 
textbase: 

– Type Name and press Enter. 
– Type Company and press Enter. 
– Type Telephone and press Enter. 
– Type Notes and press Enter. 
– Type Follow-up, select Date from the Field Type drop-down list, and click Add. 

(Note that if you already added the field, select Date from the Field Type drop-down 
list and click Change.) 
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4. Click Close to return to the Edit Textbase Structure dialog box, and click OK to save the 
new textbase. 

5. A message displays telling you that the textbase is empty. Click OK to open the Edit 
window. (This window lets you add a new record to the textbase.) 

You have created a textbase! Now you are ready to add records to it. 

To import files into a textbase 
Now you will populate the textbase with records by importing a text file provided with this tour. 
In a real situation, the file would have been downloaded from an online service, exported from 
an Inmagic textbase or other application, or created with a word processor or text editor. 

1. Select File>Import. Find and select file SAMPLE3.DMP (located in a subdirectory of the 
installation directory), and click Open. 

2. On the Import Options dialog box, select the File Format tab, select the Delimited ASCII 
Format option button (do not change any of the default settings), and click OK. 

3. When prompted, click Yes to import the file; then click OK to dismiss the confirmation 
message that displays. 

Your textbase now contains records. In the next exercise, you will edit the records. 
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To edit records interactively 
Now you will edit a record. You want to change Emily Anne Gordon’s area code from 617 to 
508 and add her new mobile phone number. 

1. Find the record that you want to edit by performing a new search. Choose Search>New 
Query. In the Name box, type Emily and press Enter. The Select Search Results Window 
dialog box opens. 

2. Select the Edit window option button and click OK. The Edit window opens. 

3. In the Telephone box, delete 617 and type 508. 

4. Press F7 to add a multiple (repeating) entry—you do not have to move the cursor—then 
type this entry, including the text: 

508-555-4321 (mobile phone) 

Notice how easy and fast it was to add a second and distinct entry to the Telephone field. 
You did not have to modify the data structure or create a table and do a join. You can add as 
many entries as you want to any field at any time without losing reporting and sorting 
distinctions. Remember that F7 is the key to use. Do not confuse it with Enter, which 
simply adds a line break to the data. 

5. Choose Records>Save Record, or press F5, or click the Save Record button . Then 
close the Edit window. The changes will appear in your next search. 

6. If you wanted to make the same change to more than one record, you could do a batch 
modification. For example, you could change all 617 area codes to 508. You would do a 
search for the records, then choose Records>Batch Modify. You can use Batch Modify to 
add, delete, or change entries, and even change text within an entry in multiple records. 
Chapter 3, “Working with Records,” describes the many editing techniques you can use. 

Congratulations! Now that you have a basic understanding of DB/TextWorks, you can try 
creating and searching your own textbases. For specific instructions, follow the instructions in 
each chapter of this book, or consult the online help. 
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Chapter 2: Creating a Textbase 

Follow the instructions in this chapter to create your own textbases. Feel free to experiment. 
Before you start creating a real textbase, create a pilot textbase and “play” with it—for example, 
create an electronic “card file” that contains one record per person. Include just a few fields, 
such as Name, Address, City, State, Postal Code, and Date of Birth. Try to include a variety of 
field types (for example, Text, Number, and Date). Then, add five or ten records and try a few 
searches and design some forms. 

Actually working through the process will uncover many questions that will be resolved by the 
time you are ready to begin your real projects. 

This chapter explains how create a textbase, details the types of fields you can include, and 
covers textbase maintenance activities. 

Overview 
Every textbase is made up of records, fields, and entries.  

• 

• 

• 

Record. What you retrieve when you search. Each record represents a collection of 
information about something, such as a proposal, a company, or a product. For example, a 
library catalog textbase contains one record for each book or similar resource. 
Field. Contains a specific category of information, such as an author’s name or a 
publication date. As a rule, you include one field for each type of information that you want 
to be able to manipulate (for example, sort, search, print) individually. For example, if you 
want to be able to search for documents by title, include a field called Title. Each record 
consists of fields. 
Entries. These are items of information you enter in the field. An important aspect of 
DB/TextWorks is that each field can have one or multiple entries. (A field with multiple 
entries is called a repeating field.) For example, the Author field can hold multiple names, 
each of which is indexed and sorted separately. When you add records, you can use the F7 
key to create new entries in a field. (The Enter key is not equivalent—it just creates a line 
break within the text.) 
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The following illustration shows the relationship between records, fields, and entries. 
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It is often a good strategy to start with something that can be produced rapidly. For example, 
create a small pilot textbase that may eventually be turned into a larger, real textbase. A pilot 
textbase of 10–20 records can introduce potential users to textbase possibilities. If you are 
designing textbases that others will use, enlist their support by including them in the design 
process. It is easier to give people what they want if you know their requirements and 
preferences from the start. 

Testing the reactions of users is important even if you have limited time. Let users see the results 
of what they have said they want, before you invest time and effort in finishing the project. 
Seeing a search carried out and the results printed or displayed provides immediate feedback and 
is a necessary part of the refinement process. 

Textbase Considerations 
Here are some issues to consider before you start creating a textbase: 

• 

• 
• 

• 

• 

• 

• 

Will some of the information you are tracking be common to several textbases, or common 
to a number of records in one textbase? For example, are there names and addresses that you 
may want to access from multiple textbases? If so, consider linking the textbases. For more 
information, see Chapter 8, “Linking Textbases.” 
Which fields should each record include? 
What type of information will each field hold and how will each field be indexed? The 
settings you select for each field will determine how the information can be retrieved, 
sorted, and printed. 
Will you apply validation to any of the fields to control the information that is allowed into 
the textbase? If so, what type of validation will you apply? 
Will you assign passwords for security? You may want to restrict some fields or individual 
records so that they are read-only or hidden. Even if the information is not confidential, you 
may want to impose some limitations on what certain users can do to a textbase. In a shared 
environment, most textbases have a Master password that protects the textbase structure 
from being changed. 
How will you get the record information into the textbase? The most efficient method is to 
prepare a text file that you can import. An alternative is to type each record by hand. 
Will you use the textbase on the Web with a WebPublisher product? If so, consider what 
HTML features you want to give query screens, forms, and menu screens (for example, 
whether to display images as part of the page or as links which bring up a new page). For 
more information about publishing textbases on the Web, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual and the DB/TextWorks online help. 
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An Example 
Assume you work for an environmental consulting firm that submits proposals to prospective 
clients. To keep track of the proposals, you create a textbase called Proposal. 

The textbase contains client names and addresses, document titles, authors, dates, and telephone 
notes recorded after important conversations. It also includes the full text of each proposal, 
imported in one simple operation, so you can search for any word or phrase in the document. It 
includes image file names associated with photographs, drawings, and scanned faxes or memos, 
so you can view and print images along with the other data. 

By organizing these materials into a textbase, you can now do a quick search for all proposals 
written in 2002 for a study of wetlands in the Florida panhandle. Or for all proposals written by 
Joe Thoreau. You can design reports to print the information you want, formatted the way you 
want it. For example, you can print a summary of proposal titles and dates, or the full text of a 
proposal, or a set of architectural site drawings, or generate mailing labels for your client list. 

One of the most important considerations in creating a textbase is deciding what constitutes 
records and fields. For this pilot textbase, each proposal constitutes a record. Each field 
represents a shared characteristic of all proposals, such as Title, Client Company, and Street 
Address. 

The following table shows a partial list of fields used in the textbase, followed by a summary of 
suggested indexing and validation settings. 

Field Name  Field Type  Indexing  Validation and/or Special Filing 
Title Text Term & Word Select Field Entry Required 
Client Company 
(to whom the 
proposal was sent) 

Text Term Select Use Validation List 

ID Automatic 
Number 

Term  

Street Address Text Word  
City Text Term & Word  
State Text Term Select Use Validation List 
Country Text Term Select Use Validation List 
Postal Code Text Term Clear Numbers File Numerically 
Contact Name Text Term & Word Clear Ignore Leading Articles 

Clear Use Stop Word List 
Phone Text Term Clear Numbers File Numerically 
 

30 Chapter 2: Creating a Textbase 



 

Field Name  Field Type  Indexing  Validation and/or Special Filing 
EMail Code Term  
Authors Text Term & Word Clear Ignore Leading Articles 

Clear Use Stop Word List 
Date Completed Date Term Select Require Strictly Correct Type 

Select Allow Trailing Text 
Awarded Text Term Select Use Validation List 

Select Field Entry Required 
Expenses Number Term  
Summary Text Term & Word  
Telephone Notes Text Term & Word  
Full Text (OCR 
proposal text) 

Text Word  

Images (scanned 
photos and 
drawings) 

Image Term  

Record Created Automatic 
Date* 

Term  

Record Modified Automatic 
Date* 

Term  

 
* When used with the Record Created field, Automatic Date is the date the record is created; 
when used with the Record Modified field, it is the date the record is created or last modified. 

As you plan the textbase, keep in mind that each field can hold multiple (repeating) entries of the 
same type of information. You do not need to create separate fields for each entry. For example, 
if a particular client has a home phone, business phone, and fax number, make each number a 
separate entry in the Phone field. To do this, press F7 after typing each entry in the Edit window. 
Each entry can be searched and formatted separately, based on the indexing choices that you 
select. 

Be sure that the field names you assign are clear and unambiguous. For example, will a field 
called Date hold the project’s starting or ending date? To avoid ambiguity, call the field Date 
Completed or Date Started, depending on the information it will hold. 

After creating the textbase and populating it with records, test it. Search for records, display 
them in various windows, and then print some reports using forms that you have designed. 

Despite the most careful planning, you may find that you need to make some changes. 
DB/TextWorks is flexible enough to allow you to change most aspects of the textbase structure 
at any time. For example, you can add, rename, or delete fields and change how they are 
indexed. Knowing in advance that you have this kind of flexibility, you can experiment and 
refine your textbases until they provide the results that you want. 
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Creating a Textbase 
When you create a textbase you specify its structure by adding as many fields as you want (up to 
a maximum of 250). You decide each field’s name and type, and you specify how the software 
will index it and whether it has validation or Special Filing options applied to it. 

To create a textbase from scratch 
1. Choose File>New Textbase to open the Specify New Textbase dialog box. 

2. Type a name for the textbase in the File name box and navigate the Save in drop-down list 
to the location in which you want to save it. Click the Save button when done. 

3. On the Create Textbase Structure dialog box, select the Define New Textbase option button 
and click OK. 

 

Tip! You do not have to create every textbase from scratch. You can model a new textbase 
after another textbase. To do this, select one of the other options available on the Create 
Textbase Structure dialog box, as appropriate. See “

” on page 36 for an explanation of the other options. 
To create a textbase by modeling it after 

an existing one

4. On the Edit Fields dialog box, type a name in the Field Name box and click the Add button. 
Do this for each field you want to add. The fields you add appear in the Field Name list. 

5. Select a field from the Field Name list. 
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6. On the Type and Indexing tab, specify the appropriate options in the Type Information, 
Indexing Information, and Special Filing Options groups for that field. See “

” on page 37 for an explanation of each option. Click the Change button when 
done. 

Type and 
Indexing Tab
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7. [Optional] On the Validation tab, specify the appropriate options in the Entry Validation, 
Content Validation, and Range and Mask groups for the selected field. See “ ” 
on page 53 for an explanation of each option. Click the Change button when done. 

Validation Tab

Note: Validation options will not be enabled for field types that do not support validation. 

 
8. Depending on the type of field selected, one of the following tabs may appear on the Edit 

Fields dialog box. Specify the options you want, as appropriate, then click the Change 
button. 

– Text Options tab. For Text fields, specify whether to use a substitution list (and type 
the entries you want in the list) or connect to a thesaurus textbase if you plan to use one. 
This tab also appears for Code fields. However, only thesaurus options will be enabled, 
as a Code field cannot have a substitution list. 

– Automatic Number Definition tab. For Automatic Number fields, specify how 
numbers appear, including number increment and whether thousand separators are 
used. 

– Automatic Date Definition tab. For Automatic Date fields, specify when dates are 
updated, as well as whether both date and time appear, and in what format. 

– Computed Number Definition tab. For Computed Number fields, specify the formula 
you want to use, as well as how computed numbers are formatted. 

– Computed Date Definition tab. For Computed Date field, specify the formula you 
want to use, as well as how computed dates are formatted. 

– Link Definition tab. For Link fields, specify a secondary textbase and its associated 
field. 
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9. Repeat steps 5–8 for each field in the Field Name list. You can specify different options for 
each field, as applicable. 

Note: You can rename, re-order, or delete any of the fields you added. 

10. Click Close on the Edit Fields dialog box to confirm the options you specified and return to 
the Edit Textbase Structure dialog box. 

Note: Depending on the options you specified, you may be notified of an “incomplete 
definition” (for example, if you selected the Use Validation List option button on the 
Validation tab, but did not create a validation list). 

11. [Optional] Type a description of the textbase (for example, Tracks names of 
borrowers in library) in the Description box. 

 
12. [Optional] In the Textbase Options group, click the Passwords, Sort Order, Stop Words, 

Leading Articles, Log File, Maximum Users, and (if you have WebPublisher PRO and 
plan to edit records over the Web) XML Match Fields buttons to specify the appropriate 
options for the textbase. Each option is explained in this chapter, starting on page 60. 

13. Click OK on the Edit Textbase Structure dialog box. The new textbase has now been 
created, and you are ready to start adding records. 

14. A message displays telling you that the textbase is empty. Click OK to open the Edit 
window. (This window lets you add a new record to the textbase.) 

Note: If you do not want to be notified when you open an empty textbase, clear the Notify 
when opening empty textbase check box on the General tab of the Options dialog box 
(choose Tools>Options>General). 
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To create a textbase by modeling it after an existing one 
1. Choose File>New Textbase to open the Specify New Textbase dialog box. 

2. Type a name for the textbase in the File name box and navigate the Save in drop-down list 
to the location in which you want to save it. Click the Save button when done. 

3. On the Create Textbase Structure dialog box, select one of the following options, then click 
OK. 

– Copy an Existing Inmagic Textbase Structure. You will be prompted to select an 
existing textbase, whose structure will be copied. (Records are not copied. If the 
textbase has an Access Control field, validation and substitution lists are copied 
automatically.) 

– Restore from Textbase Structure Backup File. Use an existing textbase structure 
backup file (.TBB) as the basis of a new textbase. 

36 Chapter 2: Creating a Textbase 



Type and Indexing Tab 
Use the Type and Indexing tab on the Edit Fields dialog box to specify what kind of information 
each field will hold and how the field will be indexed. 

Field Type 
For each field that you create, select a field type from the Field Type drop-down list on the Edit 
Fields dialog box to indicate the type of information that the field will hold. Each field type 
listed in the table below is explained in detail on the following pages. 

Field type What it does 
Text Holds text and numbers 
Number Holds numbers; sorts negative numbers and currency correctly 
Date Holds dates 
Automatic Number Generates a unique number for the record 
Automatic Date Inserts the current date, or date and time 
Automatic ID Generates an editable number that can include text, punctuation, and 

leading zeros 
Computed Number Computes a number using a formula you specify 
Computed Date Computes a date using a formula you specify 
Image References image files 
Link Links to another textbase, so information from it can be accessed 
Code Makes punctuation and case relevant to searching and sorting 
UDC Sorts Universal Decimal Classification System numbers 
Access Control Provides record-level security by letting you restrict access (Full 

Access, Read-Only, or Hidden) to individual records within a textbase 
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Text 
Select Text from the Field Type drop-down list to specify that the field will hold text (for 
example, names and descriptions), as well as numbers that will not be used in calculations (for 
example, phone numbers). A Text field can hold any combination of alphanumeric characters, 
punctuation, spaces, and line breaks. 

For telephone numbers, Social Security Numbers, ZIP Codes or postal codes, or any sequence of 
digits not meant to be used in calculations, use a Text field with alphabetic filing (clear the 
Numbers File Numerically check box in the Special Filing Options group on the Text and 
Indexing tab). If you do not make this change, leading zeros will be removed in a Term index, so 
a phone number such as (02) 555-0089 will be filed as 2 555 89. 

Creating Substitution Lists for Text Fields 
A Text field can have a substitution list to be used during data entry and import. A substitution 
list is a list of short codes that you use in place of longer words or phrases to reduce keystrokes 
and typographical errors. 

To create a substitution list 
1. On the Type and Indexing tab, select Text from the Field Type drop-down list. 

2. On the Text Options tab, select the Use Substitution List check box and click the Edit List 
button. 

3. Type the code, a colon, and the replacement text in the Entry box, then click the Add 
button.  

 

Use the 
Merge File 
into List or 
the Replace 
List with 
File button 
to combine 
or replace 
the list with 
items from 
a text file. 

Note: To edit a substitution list, choose Maintain>Edit Lists>Substitution Lists. 
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Later, when you start editing records, you can type a substitution code from the list. For 
example, type vt and the word Vermont appears after you move the cursor off the field. You 
can choose Edit>Browse Choices or press F3 to see the substitution list (if any) for the current 
field. Then, you can paste entries from the list into the field. During import and batch modify, 
substitutions are made automatically for fields that have a substitution list. 

Number 
Select Number from the Field Type drop-down list to specify that the field will hold digits that 
may be used in calculations or sorted as values, such as quantities or currency. Number fields 
can accommodate negative numbers for sorting, indexing, and calculations. To prohibit non-
numeric information, select the Require Strictly Correct Type check box. (This is called 
making the field strict.) Currency symbols (for example, $) are accepted in strict Number fields. 

Note: For numbers that should not be treated as quantitative values, such as telephone or ISBN 
numbers, use a Text field type with alphabetic filing (clear the Numbers File Numerically 
check box in the Special Filing Options group on the Type and Indexing tab). 

Date 
Select Date from the Field Type drop-down list to specify that the field will hold dates. Dates 
are sorted chronologically, which can be useful in reports. For example, you can sort invoices by 
date, in chronological or reverse-chronological order. To prohibit non-date information, select 
the Require Strictly Correct Type check box. (This is called making the field strict.) If you do 
not make the field strict, users will be able to type non-date information in the field (for 
example, Fred), and that entry cannot be sorted chronologically or used in a calculation. 

Entering and editing information in Date fields 
When adding or editing information in a Date field, you can enter full or partial dates in almost 
any recognizable format, including but not limited to the following examples: 

10-2-03 
Oct 2, 2003 
10/03 
10/2003 
10/02/03 
2003 

You can use forms to make all the dates appear in a consistent format, regardless of how they 
were entered. 

You can include the letter c before a year to indicate “copyright” (for example, c1998) and the 
date will be sorted correctly. You can include AD or BC after a year alone (not including a month 
or day) and the date will be sorted correctly (for example, 267 BC). Case and punctuation do 
not matter. 

When you are editing records, we strongly recommend that you enter years using four digits 
instead of just two, to avoid any ambiguity about the year 2000 and beyond. Run the 
DB/TextWorks Setup program to specify how two-digit years are interpreted across century 
boundaries. For more information, see the online help. 
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DB/TextWorks recognizes month and day names in the language(s) specified during Setup. If 
more than one set of month or day names is specified, all of them will be recognized in a date, 
but only the first set is used for dates generated by the software (for example, when using 
Edit>Insert>Current Date) or reformatted in a report. 

Date formats are interpreted using the Windows Control Panel settings in effect when the date is 
indexed. For example, 12-6-99 may be interpreted as month-day-year or day-month-year. 

Automatic Number 
Select Automatic Number from the Field Type drop-down list if you want a unique number 
generated by the software to be assigned to each record, starting with a value that you specify. 
Automatic Number fields provide a way of uniquely identifying records. To change the 
definition of an Automatic Number field, change the settings on the Automatic Number 
Definition tab on the Edit Fields dialog box. 

Automatic Number fields are maintained by the software. You cannot change automatic values 
in existing records, nor can you dictate what the value will be in a new record (except for the 
initial value that is used). 

Automatic Date 
Select Automatic Date from the Field Type drop-down list if you want DB/TextWorks to place 
the current date or current date and time in this type of field when you create and/or modify the 
record. By using an Automatic Date field, you can identify when each record was created or 
edited, without requiring user input. To change the definition of an Automatic Date field, use the 
options on the Automatic Date Definition tab on the Edit Fields dialog box. 

Generates a date 
only when the record 
is created (the date 
will not be changed 
again). 

Refreshes the date 
whenever the record 
is saved. 
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Automatic ID 
Select Automatic ID from the Field Type drop-down list to use ID values generated by 
DB/TextWorks. You can edit the values to include text, numbers, punctuation, spaces, and 
leading zeros. Use an Automatic ID field if you need an editable, automatically generated 
number with optional surrounding text and/or punctuation. This type of field is commonly used 
in combination with unique validation to generate a unique alphanumeric ID for each record. 

The first time you choose Records>New Record after opening a textbase, it increments the last 
value in the index by one. Thereafter, it increments the last-saved value by one. You can accept 
or change the value. For example, if the number 50 is generated and you change it to 51, the 
next generated value will be 52. If you enter alphabetic characters only, a value will be 
appended. For example, ABC is incremented as ABC1, ABC2, and so forth. If you enter a 
combination of numbers and letters, only the number is incremented. For example, MBP-003 
becomes MBP-004, 2002-Oct becomes 2003-Oct, and G50A becomes G51A. 

For best results, select the Unique Entries Only check box on the Validation tab. Then, if you 
do not recall where a series left off, you can type a low value and the software will substitute the 
next available value. For example, if you have forgotten whether the last record was 98 or 99, 
type any lower value and the software will assign the next unique number in the series when you 
move the cursor to another field, press F9 (to refresh), or save the record. 

Important! If the Edit form does not include a box for the Automatic ID field, this field will not 
be generated for new records. This is because Automatic IDs are only generated in the Edit 
window; they are not generated during import or by scripts. This behavior is different from the 
Automatic Date and Automatic Number field types.  

If you are using Deferred indexing, post deferred updates frequently. DB/TextWorks cannot 
check uniqueness of new entries against unposted updates, so duplicate values may be assigned. 
(They will be detected and rejected when you post deferred updates, so you can fix the problem 
at that time.) 

For more information about Automatic ID fields, see the online help. 

Computed Number 
Select Computed Number from the Field Type drop-down list to have DB/TextWorks 
construct a number according to a formula you specify. The formula must yield a number. For 
example, the following formula subtracts the contents of two fields in the current record to 
determine how many units are backordered: 

ordered - shipped 

The result is a number, which appears in the Computed Number field: 

13 
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You cannot edit a Computed Number field. Computed Numbers are calculated by 
DB/TextWorks. A formula for a Computed Number field can include field names (from the 
primary textbase only), numbers, and Field Functions, joined by arithmetic operators. Use + for 
addition, - for subtraction, * for multiplication, and / for division. You can use parentheses to 
avoid ambiguity (see examples).  

Field Functions are intended for use on fields that contain multiple entries. They include: 

• 
• 
• 
• 
• 

FCOUNT, which counts the number of entries 
FMIN, which finds the lowest value 
FMAX, which finds the highest value 
FTOTAL, which adds the values 
FAVG, which averages the values  

Follow a Field Function with a field name in parentheses. For example, FMIN(Price) finds 
the lowest value in the Price field in the current record. Entries that do not start with a number 
are treated as zero in the computation for all Field Functions except FCOUNT, which counts 
entries regardless of content. For more information, see Chapter 5, “Working with Forms.” 

Note: A Computed Number field will be left blank if any field used in the calculation formula is 
blank. This applies to all Field Functions except FCOUNT. 

To change the definition of a Computed Number field, use the options on the Computed Number 
Definition tab. 

 

Note: If you add a Computed Number field or change the formula of one in a textbase that 
already contains records, rebuild the field index to populate the Computed Number field. Choose 
Maintain>Rebuild a Field Index, select the Computed Number field, select the Recompute 
Field Value check box, and click OK. 
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Examples 
The following table lists some examples of formulas that can be used with a Computed Number 
field, and what they compute. Notice that quotation marks are used around field names that 
include spaces. 

This formula…  Computes this… 
quantity * price * 1.05 Total cost of an order, including 5% 

sales tax. 
"completion date" – "starting date" The number of days required to 

complete a project. Note that the result 
is a number, not a date. 

FCOUNT("sales person") The number of entries in the Sales 
Person field in the current record. 

FTOTAL(expenses) The total of all the entries in the 
Expenses field in the current record. 

FAVG(cost) The average of all entries in the Cost 
field in the current record. 

(price - cost) / (number * 12) Subtracts Cost from Price before 
dividing the results. 

Computed Date 
Select Computed Date from the Field Type drop-down list to have DB/TextWorks construct a 
date based on information in another field, according to a formula that you specify. The formula 
must yield a date. For example, the following formula adds 90 days to the date in the Invoiced 
field: 

Invoiced + 90 

The resulting date appears in the Computed Date field (if the Invoiced field contains the date 
9/16/2002 and you are in the United States): 

12/15/2002 

You cannot directly edit information in Computed Date fields. They are calculated by 
DB/TextWorks when a record is saved, or information referenced in the formula changes. 
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To change the definition of a Computed Date field, use the options on the Computed Date 
Definition tab. 

 

Note: If you add a Computed Date field or change the formula of one in a textbase that already 
contains records, rebuild the field index to populate the Computed Date field. Choose 
Maintain>Rebuild a Field Index, select the Computed Date field, select the Recompute Field 
Value check box, and click OK. 

The formula you type can include fields from the primary textbase, numbers, or Field Functions, 
connected by the arithmetic operator + for addition or - for subtraction.  

Note: Only the Field Functions FMIN and FMAX can be applied to a Date field and return a date 
as a value. 

You can use parentheses to avoid ambiguity. Place quotation marks around field names that include 
spaces. Field Functions are intended for use on fields that contain multiple entries: 

• 
• 

FMIN finds the lowest (earliest) value. 
FMAX finds the highest (latest) value.  

Follow a Field Function with a field name in parentheses. For example, FMIN(received) 
finds the earliest date in the Received field in the current record. For more information, see 
Chapter 5, “Working with Forms.” 
Note: A Computed Date field will be left blank if any field used in the calculation formula is 
blank or a Date field included in the formula does not contain a date. 
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Examples 
The following table lists some examples of formulas that can be used with a Computed Date 
field, and what they compute. Notice that quotation marks are used around field names that 
include spaces. 

This formula…  Computes this… 
due - 14 A date two weeks before the 

scheduled deadline. 
"check out date" + "borrowing period" Adds the values in a Date field 

and a Number field to yield a 
date.  

FMIN(published) The earliest date in the 
Published field in the current 
record. 

FMAX("contact date") + 30 Adds 30 days to the most 
recent contact date. 

Image 
Select Image from the Field Type drop-down list if your textbase will reference image files. 
When you add records to the textbase, you can include the names of the image files in the Image 
field, as shown below. 

 
To display the images after a search, choose Display>Show Record Images, then use the image 
options on the Images window toolbar to zoom, rotate, see multiple images in a thumbnail view, 
and perform other operations. 
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You can store images on external storage devices such as CD-ROMs or DVDs or any local or 
network drives. You can specify the drive letter(s) where images are stored by choosing 
Tools>Options>Imaging. You may want to avoid including the drive letter as part of the image 
name in the Image field, if the images are on a removable disk or a mapped drive. 

If you are not storing images on external storage devices, we recommend you store images in the 
same directory as the textbase. By doing this, you can freely move the textbase and its associated 
images without having to modify records. This is because DB/TextWorks looks for image files 
in the textbase directory if no path is specified. 

However, if necessary, you can store images in a different location than the textbase directory. If 
you do this, you must specify the full or partial path as part of the image name in a record. 
Specify a full directory path, starting with a backslash (\MEMOS\LTR.JPG). If you omit the 
backslash at the beginning of the path, DB/TextWorks looks in the subdirectory of the current 
directory. If you do not specify a path in the image name (LTR.JPG), the software looks for the 
image in the textbase directory or the current directory on the drive(s) listed in the Imaging 
options. For more information, see Chapter 7, “Working with Images.” 

Note: You can also include images on forms (for example, a logo), see Chapter 5, “Working 
with Forms.” 

Link 
Select Link from the Field Type drop-down list if you want to associate this textbase with 
another textbase, so you can access information from the other textbase. For example, you may 
want to link a textbase that tracks sales orders to a textbase of customer names and addresses. 

The textbase containing the Link field is called the primary textbase. The other textbase is called 
the secondary textbase. When you define the Link field, you specify a field in the secondary 
textbase to which you want to link. That field is called the associated field. The Link field and its 
associated field must contain identical information, such as company names. 

Linking is accomplished on a record-by-record basis. When information in both fields matches, 
a link is made for that particular record and you have access to information in both textbases. 

See Chapter 8, “Linking Textbases” for more information about linking. 
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Code 
Select Code from the Field Type drop-down list if you want punctuation and case to be 
considered during searching and sorting. Code fields can be useful when you are working with 
information in which case and punctuation are important (for example, URLs, chemical names, 
scientific formulas, and EMail addresses). 

Spaces sort first, then punctuation. Numbers come before letters and are sorted alphabetically, 
not numerically. (For example, the numbers 1, 2, and 15 would be sorted to appear 1, 15, 2.) 
Upper case letters sort before lower, and case variations are retained in the index. Punctuation is 
retained in the Term index but not in the Word index. Leading articles are never ignored. 

Tip! Do not use a Code field for Library of Congress numbers because they require numeric 
filing. Instead, use a Text field with the Numbers File Numerically check box selected and the 
Ignore Leading Articles check box cleared in the Special Filing Options group on the Text and 
Indexing tab. If you use a Word index, also clear the Use Stop Word List check box. 

See the online help for more information about Code fields. 

UDC 
Select UDC from the Field Type drop-down list to have DB/TextWorks sort fields according to 
the Universal Decimal Classification System, an international numerical system used for 
classifying and retrieving documents. See the online help for the UDC sort order. 

Note: DB/TextWorks can also sort information for other classification systems, such as Library 
of Congress and Dewey Decimal. Unlike UDC, those systems do not require a separate field 
type. Instead, use a Text field with the Numbers File Numerically check box selected and the 
Ignore Leading Articles check box cleared in the Special Filing Options group on the Text and 
Indexing tab. If you use a Word index, also clear the Use Stop Word List check box. 

Access Control 
Select Access Control from the Field Type drop-down list if you want to restrict access to 
particular records using passwords. 

The Access Control field type lets you specify the following record-level security settings for 
each class of records that you define: 

• 

• 

• 

Full Access. Users have full access to records. Records can be viewed, edited, deleted, 
searched, printed, imported, and exported. 
Read-Only. Records can be viewed, searched, printed, and exported. They cannot be edited, 
deleted, or imported. 
Hidden. Records cannot be seen, making them invisible to users. 
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To specify record-level security, you set up “record classes” by adding them to a special 
validation list for the Access Control field type. Once that is done, you can classify the records 
by populating the Access Control field in those records. You can also set up a series of 
passwords (Field Access and/or Silent passwords) to grant appropriate permissions for each class 
of records. For more information about record classes and the special validation list, see the 
online help. 

Note: The special validation list used with an Access Control field can only be modified via the 
Edit Textbase Structure dialog box. It cannot be modified using Maintain>Edit Lists. 

For example, a library with multiple branches can give each branch access to the textbase used 
for cataloging, but restrict access to particular records within it. That means you can allow all 
branches to view all of the records, but only allow a branch to be able to alter its own records, 
not those of other branches. 

You can only have one Access Control field per textbase, and that field accepts only single 
entries and is always Term indexed. Overriding and user-updates are not allowed for the special 
validation list. Security settings are specified on the Record Level Security Settings dialog box. 
To access this dialog box, click the Record Level Security Settings button on the applicable 
password tab (Field Access Passwords or Silent Password) of the Textbase Passwords dialog 
box (choose Maintain>Edit Textbase Structure>Passwords). 

For more information about the Access Control field type, see the online help. For more 
information about restricting access to records and using passwords, see “

” on page 64 and “ ” on page 60. 
Restricting access to 

records Passwords

Require Strictly Correct Type 
You can select the Require Strictly Correct Type check box on the Type and Indexing tab for 
Number, Date, or Link fields. A strict field will accept information only if that information 
conforms to the field type. In other words, Number fields will accept any entry that appears to be 
a numeric value. Date fields will accept any entry that appears to be a date. Link fields will 
accept an entry only if it matches existing information in the associated field in the secondary 
textbase. A strict Link field prevents users from adding entries that do not have a match in the 
secondary textbase. This essentially serves as a validation list for a Link field. 

Allow Trailing Text 
You can select the Allow Trailing Text check box on the Type and Indexing tab to allow 
trailing text in a strict Date or Number field. Trailing text is text that follows a strict date or 
number. The purpose of trailing text is to let you require a strict date or number but still permit 
text after it. In the following examples, trailing text is shown in italics: 

June 6, 1957 first edition 
1500 (estimated number of items to be shipped by year’s end) 

Note: The Allow Trailing Text check box is only enabled if you select the Require Strictly 
Correct Type check box. 
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Term and Word Indexing 
An index is a sorted list of information in a field, conceptually similar to an index in the back of 
a book. DB/TextWorks indexes the information you add to a textbase, and refers to those 
indexes to find records. 

Fields in a textbase can have a Term index, a Word index, both, or neither. When you create a 
textbase, you decide if and how each field should be indexed. To specify indexing, select the 
Term Indexed and/or Word Indexed check box in the Indexing Information group on the Type 
and Indexing tab. 

Note: Fields with neither a Term nor Word index cannot be searched. 

If you Word index a field, every word in that field (except stop words) is placed in the index. If 
you Term index a field, every complete entry (term) is placed in the index. For example, look at 
the indexes for a field that holds book titles: 

Term Index Word Index 
Product Guide 
Widget Reference Guide 
 

guide 
product 
reference 
widget 

Specifying both Term and Word indexing gives you the most flexibility but requires more disk 
space. Choosing neither saves you disk space but means you can never search that field. 

To decide how a field should be indexed, consider the type of information it will hold. For 
example, Date and Number fields and fields that hold city or state names almost always have a 
Term index only. Fields that hold long passages of text should be Word indexed but not Term 
indexed. Book titles and full names are usually Term indexed (and may also be Word indexed). 

Also consider the type of operations you will perform on the field. Word, phrase, and proximity 
searches require Word indexing. Term, comparison, and range searches require Term indexing. 
Term indexing is also required if you want to do matching during an import, or select an 
associated field when defining a Link field, or specify Unique Entries Only validation. 

Tip! New users should not worry too much about indexingjust accept the defaults, which are 
based on field types. You can always change the indexing later with no problems. As you use the 
software, you will begin to understand what type of index is best. 

You can see the indexes when you search a textbase, by placing the cursor in a query box and 
pressing F3 or choosing Edit>Browse Choices. This is called browsing. To ensure accurate 
searches, you can paste words or terms from the index into the field, then search for those items.  
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To select or change indexing settings 
1. Choose Maintain>Edit Textbase Structure and click the Edit Fields button. 

2. Select a field from the Field Name list or specify a new field by typing a name in the Field 
Name box. 

3. On the Type and Indexing tab, select or clear the Term Indexed and Word Indexed check 
boxes. You can use the Special Filing Options group for more specific indexing choices, but 
the default settings are usually sufficient. 

4. Click the Change button if you are modifying an existing field or the Add button to add a 
new field. 

Special Filing Options 
You can specify the order in which items are indexed and sorted by using the Special Filing 
Options on the Type and Indexing tab. All of the options, except the Use Stop Word List 
option, have an effect on the filing order. You can see the indexes when you press F3 in a box on 
the query screen. 

The default Special Filing Options settings depend on the field type and whether Term or Word 
indexing is used. In most cases, the default settings are acceptable. However, in some situations, 
especially for Text fields, you may want to change the settings. 

To change the Special Filing Options settings 
1. Choose Maintain>Edit Textbase Structure and click the Edit Fields button.  

2. Select a field from the Field Name list or specify a new field by typing a name in the Field 
Name box. 

3. On the Type and Indexing tab, select or clear the appropriate options in the Special Filing 
Options group. Each option is explained on the following pages. 

 
4. Click the Change button if you are modifying an existing field or the Add button to add a 

new field. 
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Word by Word 
Select the Word by Word check box if you want each entry in a Term-indexed field to be 
indexed and sorted word-by-word, with spaces sorting before letters. If you clear this check box, 
DB/TextWorks compares each letter in sequence, ignoring spaces. This is called letter-by-letter 
filing. 

Letter-by-Letter Word-by-Word 
Newark 
New Haven 
New London 

New Haven 
New London 
Newark 

 

Ignore Leading Articles 
Select the Ignore Leading Articles check box if you want the current field to use the leading 
article list defined for this textbase. This is the default setting for Text fields. Leading articles are 
words such as A, An, and The. By ignoring leading articles, you avoid having clumps of records 
sorted under meaningless words (for example, A Tree Grows in Brooklyn, filed with 
the A’s). 

Note: If you are using a Text field to hold Library of Congress numbers, clear this check box. 

To edit the leading article list, choose Maintain>Edit Textbase Structure and click the 
Leading Articles button. See “ ” on page 66 for more information.Leading Articles
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Numbers File Numerically 

Select the Numbers File Numerically check box if you want numbers to be indexed and sorted 
as values (for example, 1, 2, 13, 121). Note that truncation searches may not find the 
anticipated records. For example, the search 2* will not find 20. 

When the Numbers File Numerically check box is cleared, numbers are filed alphabetically. 
That is, they are indexed and sorted as if they were words, by comparing each digit in sequence 
(1, 121, 13, 2). Truncation searches do find the anticipated records. 

Both types of filing can be useful, depending on the situation. For example: 

• 

• 

• 

Use numeric filing for publication volume or issue numbers in a Text field, so that 
Memoirs Vol. 2 will file before Memoirs Vol. 13. Numbers preceded by text will 
file numerically (Vol 999 files before Vol 1000) as long as the numbers do not contain 
thousands separators (in which case Vol 1,000 files before Vol 999) and are not 
preceded immediately by letters (ABC101 sorts before ABC2). 
Use alphabetic filing for SICs (Standard Industry Codes) in a Text field so you can do 
truncation searches, such as SIC=12*. 
Use alphabetic filing for telephone numbers, Social Security Numbers, postal codes, or any 
sequence of digits not meant to be filed as numbers in a Text field. If you use numeric 
filing, leading zeros are removed in Term indexes, so the phone number (02) 555-0089 
is indexed as 2 555 89. 

Note: In a Text field where numbers are filed numerically, parentheses and minus signs are 
not considered for filing. For example, -2 is the same as 2. In a Number field, negative 
numbers file as expected (-2, -1, 0, 1, 2). 

Use Stop Word List 
Select the Use Stop Word List check box if you want the current field to use the stop word list 
defined for this textbase. This is the default setting for Text fields. Stop words are common 
words that will not be indexed (for example, a, an, the, in, on, to) to save disk space and 
indexing time. To edit the stop word list, choose Maintain>Edit Textbase Structure, and click 
the Stop Words button. See “ ” on page 66 for more information. Stop Words

Tip! If your textbase contains a field that includes abbreviations for states or provinces, such as 
IN (Indiana) or ON (Ontario), clear the Use Stop Word List check box for that field, or define 
the field as Term indexed only. Otherwise, the software will interpret the abbreviations as stop 
words and will not find records when you search for the words IN or ON. 
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Validation Tab 
Use the Validation tab to specify validation rules for fields in a textbase. Applying validation is 
optional. The purpose of validation is to screen information being added to the textbase during 
data entry, import, and batch modify operations to ensure consistency and reduce typographical 
errors. If information does not meet the validation criteria, DB/TextWorks informs the user and 
does not permit the change to be made (unless content validation overrides are allowed). 

Note: Some validation is implicit if the field is strict. See “ ” on 
page 48 for information about strict fields. 

Require Strictly Correct Type

You can specify validation when you create the textbase, or later by editing the textbase 
structure. Note that if you change validation in a textbase that already contains records, some of 
the existing records may not meet the new validation criteria. 

To specify validation, select a field from the Field Name list on the Edit Fields dialog box. On 
the Validation tab, select or clear the options you want to apply to that field. 

 

Note: If you have WebPublisher PRO and plan to edit records over the Web, fields with a 
validation list specified in the textbase structure will have their box labels turned into validation 
list links which, when clicked, open the Inmagic Choices Browser window. Users can then paste 
entries from a validation list into the Web edit screen. For more information, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual. 
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There are two categories of validation: 

• 
• 

Entry Validation. Determines the number and type of entries allowed. 
Content Validation. Controls the type of information allowed. 

The options you can select on the Validation tab are explained on the following pages. 

Field Entry Required 
Select the Field Entry Required check box to require that the selected field contain an entry. 
You cannot save a record that leaves this field empty, nor can you delete all entries in this field. 
This is sometimes called a required field and is typically used for fields that will hold vital 
information, such as employee names, library classification numbers, or Bates numbers for legal 
documents. If you want to add records, the current password must give you full access to all 
fields that have Field Entry Required validation. If the form selected for the Edit window omits 
any fields that have Field Entry Required validation, DB/TextWorks informs you and changes to 
the Basic Record form. 

Unique Entries Only 
Select the Unique Entries Only check box to require that an entry in the selected field be 
different from every other entry in that field in all other records in the textbase. For example, 
you can make the Employee ID field unique to ensure that you have only one record per 
employee. You can select this option only for fields that have a Term index. 

Single Entry Only 
Select the Single Entry Only check box to prohibit the selected field from holding multiple 
entries. For example, you may want the Primary Contact field to allow only one name. This is 
sometimes called a non-repeating field. 

No Content Validation 
Select the No Content Validation option button if you do not want the selected field validated 
for content. Anything will be allowed in the field, unless it is a strict Date, Number, or Link 
field. 
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Use Range and/or Mask 
Select the Use Range and/or Mask option button to restrict information allowed into a field. 
When you select this option button, the Range and Mask group on the Validation tab on the Edit 
Fields dialog box is enabled. Specify the range and/or mask you want in the boxes provided. 

 

Ranges 
Type values in the Minimum and/or Maximum boxes to set the range of values allowed in the 
selected field. You can specify values, dates, or text, depending on the field type. For example, 
the Percent field could have a minimum of 0 and a maximum of 100. A Number field could use 
a range of 100 to 500. A Date field could use a range of 1-May-2001 to 31-May-2001. 
(Dates entered in the field can be in any recognizable date format, but they must fall within the 
specified range.) To restrict a Text field to items starting with the letters L through Z, type L as 
the minimum and ZZZ as the maximum. Note that if you type only Z as the maximum, items 
such as zebra will be rejected. 
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Masks 
A mask is a pattern that governs how information can be entered in a field. To specify a mask, 
type it in the Mask box. Include one or more of the mask characters shown below. Any spaces 
or punctuation that you include become a part of the mask.  

Symbol   Meaning   Can be omitted in the field entry (Y/N) 
! Upper-case letter. No 
^ Lower-case letter. No 
# Any single digit (0-9). No 
? Any single keyboard or extended 

character, including spaces. 
No 

* Any series of zero or more 
characters, including spaces. 

Yes 

To include a mask character as a literal character, precede it by a backslash. For example, to 
require any two digits followed by a # symbol (for example, 15# or 38#), type ##\# as the 
mask. To include a backslash as part of the mask, type two backslashes (\\). 

The following table lists some examples of masks and what they do. 

This mask… Does this… 
Ace* Accepts Ace alone or followed by other characters (for example, Ace 

Corp.,  Ace 123,  Acetate). 
!* Requires a capital letter followed by any number of characters or words. 
! Requires a capital letter only. It cannot be followed by any other 

characters. 
###-##-#### Requires a number such as 187-33-2627 (dashes are required). 
##-##-#### Requires a numeric date with a four-digit year, such as 08-26-2000 

(dashes and leading zero are required). 
^^ ???? Requires two lowercase letters, followed by a space, followed by any 

four characters, such as ab 12X4. 
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Use Validation List 
Select the Use Validation List option button to specify that the field entries must appear in the 
validation list. A validation list is a list of entries allowed in a Text or Code field. Entries not in 
the list will not be allowed in the field (unless you permit users to override the list, as explained 
in “ ” on page 58). Allowing Users to Override Content Validation

To create the validation list, click the Edit List button to open the Edit Validation List dialog 
box. To edit a validation list later, choose Maintain>Edit Lists>Validation Lists. 

The following illustration shows the validation list created for the State field. 

 
You can use the buttons on the Edit Validation List dialog box to perform various operations on 
the validation list. For example, you can combine the current list with a list in a text file by 
clicking the Merge File into List button. To replace the current list with the list in a text file, 
click the Replace List with File button, then specify the file that you want to use. For more 
information, see the online help. 
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Use Thesaurus as Validation List 
Select the Use Thesaurus as Validation List option button to specify that the thesaurus 
connected to the selected field be used as the validation list. This option button is enabled after 
you specify a new or existing thesaurus textbase on the Text Options tab. 

Note: Only Text and Code fields can use a thesaurus as a validation list. 

Using a thesaurus as a validation list means that you can give your users the ability to browse 
through a network of semantically related terms. A validation list is a list of entries allowed in a 
field. It provides a way of screening information to be added to a textbase. Only entries in the list 
are allowed during data entry or import. When you have specified a thesaurus as a validation list, 
users cannot enter a term that is not found in the thesaurus. Even if no term relationships are 
required, you can use a thesaurus for validation purposes to provide a way to share a single list 
of approved terms among any number of fields and textbases. 

For more information about using a thesaurus as a validation list, see the online help. 

Allowing Users to Override Content Validation 
If a field has mask or range validation or uses a validation list, you can specify the following 
options on the Validation tab on the Edit Fields dialog box: 

• 

• 

User May Override Content Validation. The field will accept entries that are not in the 
validation list, or which violate mask or range validation, upon confirmation by the user. 
User May Update Validation List with Override Value. Same as above, but the new 
entry can be added automatically to the validation list. You can select this check box only if 
the field uses a validation list (other than a thesaurus used as a validation list) and User May 
Override Content Validation is selected. 

58 Chapter 2: Creating a Textbase 



While adding or editing a record, the Content Validation Mismatch dialog box opens if either of 
the following is true: 

• 
• 

The entry is not in the validation list. 
The entry violates a mask or range on a field that allows overrides. 

This button is active if users can 
override content validation. 

This button is active if users can 
update a validation list and the 
password allows editing of 
validation lists. 

 
Depending on the validation settings, a user can browse the validation list and paste an 
acceptable entry, accept the “invalid” entry into the field, or accept it and have it automatically 
added to the validation list. 

Note: You can use Field Access or Silent passwords to prohibit unauthorized users from 
updating validation lists. 
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Specifying Textbase Options 
The textbase options that you select on the Edit Textbase Structure dialog box have an effect on 
the textbase as a whole. You can specify these options when you create a textbase or change 
them later by choosing Maintain>Edit Textbase Structure. 

Use these 
buttons to 
specify 
textbase 
options.  

Each textbase option is summarized on the following pages. For more detailed information, see 
the online help. 

Passwords 
You can assign passwords to protect the textbase structure and information by choosing 
Maintain>Edit Textbase Structure and clicking the Passwords button. There are three types 
of passwords: 

• 
• 
• 

Master  
Field Access  
Silent  

Passwords can contain up to 15 alphanumeric characters, including spaces and punctuation. Case 
is not significant (ABC is the same as abc). Although passwords are encrypted against casual 
view, record information is not encrypted in the textbase and can be seen by file-browsing 
software. If you have a critical need to control unauthorized access, you should explore 
additional system security procedures.
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By typing in a password, a user can be given the ability to access certain software features, fields 
in the textbase, and even specific records in the textbase. Fields and/or records can be Hidden, 
Read-Only (write-protected), or have Full Access. Hidden fields cannot be seen, making them 
invisible to the user. The only clues to their existence may be forms designed without 
consideration for the impact of security (that is, text that identifies such a field is not specified in 
a way that disappears when the field does). Hidden records are never included in sets retrieved 
by searching. A clue to their existence appears when a search for a word or term having a certain 
number of hits in the browse list returns fewer than that number of records. 

Read-Only fields and records can be seen, but not modified; while fields and records with Full 
Access can be seen and modified. 

If a password controls access to both fields and records, the most restrictive permission applies. 
A Read-Only field in a record with full access remains Read-Only. 

Master Password 
You can create one Master password to protect the structure of the textbase. Only someone who 
knows the Master password can edit the textbase structure and perform all operations. If you 
clear (delete) the Master password, all Field Access and Silent passwords are deleted 
automatically. 

To assign a Master password to a textbase 
 Type the password you want in the Master Password box on the Master Password tab, then 

click the Add or Change button to confirm it. 
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Field Access Passwords 
You can create one or more Field Access passwords, for one or more users. Each password can 
provide different rights. For example, a password can hide fields, make some fields read-only, 
and prohibit editing of validation and substitution lists. If you use an Access Control field type in 
a textbase to restrict access to particular records, you can use Field Access passwords to provide 
different levels of access to different users. Tell each user which password to use, depending on 
what rights you want that person to have. 

To specify a Field Access password 
1. Type the password you want in the Access Password box on the Field Access Passwords 

tab and click Add. 

2. Specify the options you want for it, then click OK. 

 

Click the Help
button for details 
about each setting. 
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Silent Password 
Define a Silent password if you want to protect a textbase without requiring that every user have 
a password. When a textbase has a Silent password, anyone can open the textbase, even if the 
password is not known, but the textbase structure cannot be edited and fields will be protected 
per your specifications. If you use an Access Control field type in a textbase to restrict access to 
particular records, you can use a Silent password to control the access everyone will have to the 
various classes of records. 

To add a Silent password to a textbase 
1. Select the Enable Silent Password check box on the Silent Password tab. 

2. Specify the settings you want, then click OK. 

 

Click the Help
button for details 
about each setting. 

Using a Password-Protected Textbase 
Choose Tools>Options>General and use the drop-down lists in the Passwords group to set 
password options for the primary and secondary textbases. The options apply to the current 
workstation only, and they apply to all textbases opened from that workstation. If a textbase has 
a Silent password, you can select Always prompt for password to force DB/TextWorks to 
prompt for a password. This is useful when one workstation requires write access to a textbase, 
but others do not. If you are not prompted, the Silent password will be used. 
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To change the passwords that are in use for the primary and secondary textbases, choose 
File>Use Different Password>Primary/Secondary Textbase. Each command is disabled if 
either of the textbases does not have any passwords, or if the textbase(s) have a Master password 
but no Field Access or Silent passwords. 

To see if a password is in use for the primary textbase, choose Display>Textbase Information. 

To print password information, choose Maintain>Edit Textbase Structure>Print Structure. 

If a textbase has passwords assigned, certain operations will require the Master password. 

Tip! Sometimes a form, not a password, is responsible for hiding fields. If a form does not 
include a field, you cannot see it. Try selecting a different form to see a different view of the 
records (choose Display>Select Forms). The Basic forms show all fields from the primary 
textbase not hidden by the password in use. 

If you are publishing a textbase with passwords on the Web with WebPublisher PRO, you can 
specify that Web query screens and/or edit screens include a password box for users to enter a 
password. For more information, see the Inmagic DB/Text WebPublisher PRO User’s Manual. 

Restricting access to records 
You may have the need to restrict certain classes of users from accessing certain classes of 
records. For example, library users should not see books that have been ordered but not received, 
junior staff should not be able to modify the order records, and senior staff should have full 
access to everything in the textbase. 

The class to which a user belongs is governed by the password they type in. The class to which a 
record belongs is governed by the contents of its Access Control field. The password definition 
specifies what type of access is granted to each of the record classes that have been defined. A 
record class definition is an entry in the special validation list for the Access Control field. A 
record is “assigned” to a class when its Access Control field is populated. Records that have no 
entry in this field belong to the Default class, and the password definition includes the access to 
be granted to such records.  

To specify record-level security  
The following steps provide a general overview on specifying record-level security. For more 
detailed information, see the online help. 

1. Specify a field as an Access Control field for the textbase. 

2. Decide how many record classes you want, then add the record class names to the Access 
Control field’s special validation list. 

3. Specify password(s) granting the appropriate permissions to the record classes. 

4. Classify new and existing records by filling in the Access Control field for each. 

Tip! You can use Batch Modify to fill in the Access Control field for multiple records. 
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Sort Order 
You can specify the order in which records appear in the Report window and printed reports (if 
no other sort is specified) by choosing Maintain>Edit Textbase Structure and clicking the 
Sort Order button. (For example, you may sort alphabetically by name.) The sort method you 
specify is called the textbase default sort. 

 
There are two sort methods you can specify as the textbase default sort: 

• 

• 

Sort Order Shown Below. Uses the sort you specify on the Specify Textbase Sort Order 
dialog box. For detailed information about this dialog box, see the “Textbase Default Sort” 
topic in the online help. 
Relevance-Ranked Order. Sorts records in descending order of their relevance, with the 
most relevant records appearing first. For example, if you search for the word computer, 
the records with the most instances of the word will appear first, followed by records with 
fewer instances, in descending order. This option is seldom recommended as the default 
textbase sort because it only applies to word searches. 

Note: You can sort records at any time after a search by choosing Display>Sort Report, and 
you can define sorts for forms. See Chapter 3, “Working with Records” for more information on 
sorting. 

 Chapter 2: Creating a Textbase 65 



Stop Words 
You can create a list of words to exclude from the Word indexes by choosing Maintain>Edit 
Textbase Structure and clicking the Stop Words button. You can use only one stop word list 
per textbase, but you can apply that list to one or more Word-indexed fields by selecting the Use 
Stop Word List check box in the Special Filing Options group on the Type and Indexing tab on 
the Edit Fields dialog box. 

Using a stop word list reduces the amount of disk space required for the textbase and enables 
faster indexing of records. Phrase searches will find phrases that contain stop words (such as 
Made in the U.S.A.). However, you cannot search for stop words alone because they are 
not indexed.  

If you add, change, or remove words from a stop word list, you should rebuild indexes for any 
fields that use the list (choose Maintain>Rebuild a Field Index). 

Leading Articles 
You can specify a list of words to be ignored (if they come at the beginning of an entry in a 
Term-indexed field) when sorting records by choosing Maintain>Edit Textbase Structure and 
clicking the Leading Articles button. You can use only one leading article list per textbase, but 
you can apply that list to one or more Term-indexed fields by selecting the Ignore Leading 
Articles check box in the Special Filing Options group on the Type and Indexing tab on the Edit 
Fields dialog box. 

Note: Punctuation is significant. For example, L’ is different than L. 

By ignoring leading articles, you prevent clumps of records being sorted under unimportant first 
words, as shown below.  

Leading articles NOT ignored Leading articles ignored 
Catherine the Great The Big Heat 

Manon of the Spring Catherine the Great 

The Big Heat The Last Waltz 

The Last Waltz Manon of the Spring 

The Matchmaker The Matchmaker 
 
You can search for leading articles, should you want to, as long as the field is Word indexed and 
the leading article does not appear in the stop word list. 

If you add, change, or remove words from a leading article list, you should rebuild indexes for 
any fields that use the list (choose Maintain>Rebuild a Field Index). 
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Log File  
A log file is a text file that records textbase activity, including record and structure changes. A 
log file has the same name and location as its textbase, and uses the extension .LOG. For 
example, the textbase C:\SALES\TRACK has a log file called C:\SALES\TRACK.LOG. To 
enable or disable a log file, choose Maintain>Edit Textbase Structure and click the Log File 
button to open the Textbase Log File dialog box. 

 
You can select one or two fields to identify records. Whenever a record is added, edited, or 
deleted, the contents of the specified field(s) will be written to the log file. Select field(s) that 
contain short unique contents, such as a record ID or an Automatic Number field. Here is a log 
file entry that uses the Borrower Number and Name fields as identifiers: 

8/15/2002  10:44:32 AM: Record added 
Borrower Number: TORR198 
Name: Torres, Suzanne D. 

To examine a log file, choose Maintain>View Log File. New information appears at the end of 
the file. 

Log files can grow quite large, so you may want to delete them periodically, after reviewing 
and/or printing them. To delete a log file, choose Maintain>Delete Log File. DB/TextWorks 
generates a new log file automatically. If the textbase has passwords, deleting the log file 
requires the Master password. 
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Maximum Users 
You can specify how many times a textbase can be open simultaneously by choosing 
Maintain>Edit Textbase Structure and clicking the Maximum Users button. For example, if 
you specify 2, then two people can use the textbase at the same time, or one person can open the 
textbase in two instances of DB/TextWorks. Note that services and programs such as 
DB/Text® Updater, DB/Text® Checker, and DB/Text® WebPublisher PRO are counted as users. 

Note: The maximum number of textbase users has nothing to do with the number of licensed 
software users (determined by your license agreement), which can never be exceeded. 

XML Match Fields 
Note: This textbase option applies only to those who have WebPublisher PRO and plan to edit 
records over the Web. 

When editing or deleting records over the Web, WebPublisher PRO uses match fields to 
uniquely identify the record it is being asked to modify in the textbase. XML match fields are 
specified on the Specify XML Match Fields dialog box (choose Maintain>Edit Textbase 
Structure and click the XML Match Fields button). 

When you are editing or deleting a record via a Web browser and click the Submit Record or 
Delete button, the software compares the match field(s) to the records in the textbase to ensure 
that the correct record is updated/deleted. 

You can match on up to five fields; however, in most cases, one field is sufficient. The 
combination of match fields must contain unique contents, such as an Automatic Number or 
other unique identifier (for example, employee identification number). If you match on only one 
field, that field should be present and unique for every record. To be sure, you can use an 
Automatic Number field, or a field with Unique Entries Only and Field Entry Required 
validation applied. 

When editing an existing record over the Web, you cannot edit the contents of any of the match 
fields. 

Note: If you do not specify any match fields on the Specify XML Match Fields dialog box, 
WebPublisher PRO uses the first field specified on the Textbase Log File dialog box. 

For more information about specifying match fields, see the online help or the Inmagic 
DB/Text WebPublisher PRO User’s Manual. 
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Editing the Textbase Structure 
Editing the textbase structure is essentially the same as creating a textbase, which is explained in 
“ ” on page 32. You use the Edit Textbase Structure dialog box (choose 
Maintain>Edit Textbase Structure) and the Edit Fields dialog box. 
Creating a Textbase

Note: If a textbase has passwords assigned, you must use the Master password and have 
exclusive access to the textbase (that is, no one else can have the textbase open). 
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You can change Textbase Options at any time by clicking the buttons on the Edit Textbase 
Structure dialog box. If you edit a stop word or leading article list, rebuild field indexes for any 
fields that use the list (choose Maintain>Rebuild a Field Index). See “

” on page 60 for more information on the available options. 
Specifying Textbase 

Options

You can also click the Edit Fields button to open the Edit Fields dialog box. Use the Type and 
Indexing and Validation tabs to change the field type, indexing, and validation attributes of the 
selected field. 

Depending on 
the field type 
chosen, the 
Edit Fields 
dialog box may 
have a third 
tab with 
additional 
options 
specific to that 
field type.  

 
Changing the field type or making a non-strict field strict could leave non-conforming 
information in the textbase. Note that when you change the field type, all validation, indexing, 
and Special Filing settings for that field revert to the default settings. 

You can also change the Indexing Information and Special Filing Options freely. DB/TextWorks 
will automatically rebuild indexes for the appropriate fields.  

You can add, remove, or edit a substitution list at any time.  

Validation settings can be changed at any time. Be aware that existing records may not meet the 
new validation, because validation is not applied retroactively.  
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Renaming Fields 
To rename a field, select the field you want to rename from the Field Name list, type a new 
name in the Field Name box, and click the Change button. 

Computed field definitions, calculations in forms, and the query criteria for saved sets are based 
on field names. If a renamed field is referenced in the formula for a Computed field, a form 
calculation definition, or the query criteria for a saved set, you must change the formula, or 
calculation, or search to reflect the new field name. Form and screen scripts in this and other 
textbases may also use specific field names, and thus need to be updated. 

Forms, query screens, record skeletons, and sets that were exported using Maintain>Manage 
Textbase Elements contain field names. If you rename fields, you will be able to import 
elements into the textbase, but the imported elements may contain “undefined” information. You 
may want to use a text editor to rename fields in the exported file before importing it. For more 
information, see Chapter 9, “Managing Textbase Elements.” 

Records that have been exported to a file often contain field names, too. You can use a text 
editor to rename fields in exported tagged files (and sometimes in delimited files) before 
importing them. 

Renaming fields does not affect linked textbases in any way.  

Copying Fields 
To copy a field, select a field from the Field Name list, type a new name in the Field Name box, 
and click the Add button. The new field has the same type information, indexing information, 
and substitution and validation settings as the selected field. You can change the settings if you 
want to, then click the Change button. 

Re-ordering Fields 
Forms, query screens, record skeletons, and Link field definitions are defined internally based on 
field order. For that reason, there are restrictions on re-ordering fields, described below. 
However, field order should not be a concern because you can use forms and query screens to 
make fields appear in any order. 

You cannot re-order fields in a textbase that contains records or textbase elements (forms, query 
screens, or record skeletons), except for a set of new fields added to the end of an existing 
structure—and you can re-order the new fields only among themselves. 

If a textbase does not contain any records and if you have not saved any elements in the textbase 
file, you can re-order fields. If you have saved elements in a user file, you can re-order fields, but 
the elements saved in the user file will have problems because forms, query screens, and record 
skeletons are based on field order, not field names. For example, when you use a form that was 
stored in a user file, the Title field may appear in a box labeled Author.  
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To re-order fields, select a field on the Edit Fields dialog box and use the Up and Down buttons 
to move the field in the corresponding direction. If you move the position of an associated field 
in a secondary textbase, you should then open the primary textbase and redefine the Link fields 
(because link definitions are stored internally based on field order). If you re-order any fields in 
a secondary textbase, you may need to fix any forms for the primary textbase that include those 
secondary textbase fields (choose Tools>Box Properties and redefine the box contents). 

Deleting Fields 
To delete a field, select it from the Field Name list, click the Delete button, and respond to the 
confirmation message. If you delete a field in a textbase that contains records, you permanently 
delete all of the information in that field in all of the records in the textbase. The deletion 
occurs when you click OK on the Confirm Textbase Structure Update dialog box. If a textbase 
does not contain records and textbase elements have not been defined, you can delete fields 
freely. 

If the deleted field is referenced in the formula for a Computed field, a form calculation 
definition, or the query criteria for a saved set, you must change the formula, calculation, or 
search set so it no longer references the deleted field. Deleting a field may also have an effect on 
form and screen scripts. 

When you delete a field in a textbase that contains records or textbase elements, the field slot 
remains in the internal definition of the textbase and appears as <Deleted> in the Field Name 
list. This does not cause any problems, but if you want, you can rename the <Deleted> field 
instead of adding a new field. Note that you must close the Edit Textbase Structure dialog box, 
and then re-open it to rename a <Deleted> field. 
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Rebuilding Field Indexes 
In a textbase that contains records, some structural changes may require indexes to be rebuilt so 
they accurately reflect information in the textbase. In most cases, DB/TextWorks automatically 
rebuilds indexes when necessary, but sometimes you may need to rebuild indexes yourself. For 
example, you should rebuild indexes after you add, edit, or remove words from a stop word or 
leading article list. To save time, rebuild the indexes only for those fields that use the list. If you 
have a large textbase, re-indexing may require several minutes or longer. 

To rebuild an index, choose Maintain>Rebuild a Field Index. Select a field from the list and 
specify whether to rebuild the Term index, Word index, or both.  

 
When rebuilding an index for a Computed field, you can select the Recompute Field Value 
check box to do the following: 

• 

• 

Populate Computed fields in records where they are empty. For example, you may have 
just added a new Computed field, or used Manage Textbases>Load New Textbase to 
import record information that did not include the Computed field. 
Update records where the Computed fields are populated with outdated values. For 
example, you may have just changed the formula or formatting options for the Computed 
field. 
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Copying, Renaming, Deleting, and Moving Textbases 
All the files that make up a textbase are stored in the same location (drive and directory), and 
they all have the same file name with different extensions. For example, a textbase called Sales 
consists of SALES.TBA, SALES.DBR, SALES.ACF, and so forth. For more information about 
textbase files, see the Appendix. 

All of the following operations require exclusive access to a textbase (meaning no one else can 
have it open), and the Master password, if the textbase has passwords. 

Note: Renaming, deleting, or moving textbases may have an effect on Recordset scripts, menu 
screens, and Link fields. 

To copy a textbase 
1. If a textbase is open, close it (choose File>Close). 

2. Choose Manage Textbases>Copy Textbase to open the Copy Textbase dialog box. 

3. Type the full path and name of the textbase you want to copy in the Existing Textbase box, 
or click the Browse button and navigate to it. 

4. Type the full path and name of the textbase you want to create in the New Textbase box, or 
click the Browse button to navigate to the location where you want to put the new textbase 
and specify its name. 

Note: The Copy Textbase command will not create a new directory for you. If you type the 
name of a directory that does not exist, a textbase by that name will be created. For 
example, if you type C:\OOPS, a textbase called OOPS will be created. Also note that you 
cannot overwrite an existing textbase. 

 
5. Click OK, then respond to the confirmation prompts. 

If you gave the textbase a new name, and a user file of that name does not exist, DB/TextWorks 
copies the user file as well. 
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To rename a textbase 
1. If a textbase is open, close it (choose File>Close). 

2. Choose Manage Textbases>Rename Textbase to open the Rename Textbase dialog box. 

3. Type the full path name of the textbase you want to rename in the Existing Textbase box, 
or click the Browse button to navigate to it. For example, to rename a textbase called Old, 
type: C:\DIR\OLD. 

4. Type the new full path name you want for the textbase in the New Textbase box, or click 
the Browse button to navigate to the location you want and specify its name. For example, 
to call the new textbase New and keep it in the same location, type: C:\DIR\NEW. 

5. Click OK, then respond to the confirmation prompts. 

6. If you renamed a secondary textbase, open the primary textbase (the one that contains the 
Link field), and edit the textbase structure to redefine the link definition. 

Note: This command automatically renames the local textbase user file. If a textbase is on a 
network and is used by others, remind anyone else who uses the textbase and stores private 
elements in their user files to rename their corresponding user file, using Windows or DOS 
commands. User files are stored locally, so each user must rename his/her own user file.  

To delete a textbase 
1. If a textbase is open, close it (choose File>Close). 

2. Choose Manage Textbases>Delete Textbase to open the Delete Textbase dialog box. 

3. Type the full path name of the textbase you want to delete in the Textbase to Delete box, or 
click the Browse button to navigate to it. 

 
4. Decide whether to delete the user file. User files contain locally-stored forms, query screens, 

sets, and skeletons:  

– Select the Delete user file for this textbase check box if you want to delete the user 
file. 
Note: Selecting this check box also deletes the textbase .IDI and .TBS files. For more 
information about these files, see the Appendix, the “Textbase Files” section. 

– Clear the Delete user file for this textbase check box to preserve the user file. (This is 
the default.) For example, if you just copied a textbase to a new location, and you are 
now deleting the old textbase, do not delete its user file. 

5. Click OK, then respond to the prompts. 
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To move a textbase 
Use the following steps to move a textbase to a different drive. If you want to move a textbase to 
a different directory on the same drive, use Manage Textbases>Rename Textbase. 

1. Copy the textbase to its new location, then delete the old textbase, following the procedures 
explained earlier. Do not delete its user file unless you have given the textbase a new name. 

2. If the textbase that you moved is a secondary textbase, open the primary textbase (the one 
that contains the Link field), and redefine the link definition (by editing the textbase 
structure), so it points to the moved textbase. 

Note: The first time you open the textbase in its new location you may see a message warning 
you that the textbase is not where the user file expects it to be. You can safely ignore this 
message (choose Yes to continue). 

Displaying and Printing Textbase Information 
Open a textbase and choose Display>Textbase Information to see information about its fields, 
indexing, validation, textbase options, the user file directory, and many other settings. While the 
window is open, you can print or save the information to a file by choosing File>Print, and 
using the Print dialog box to select an output type (to printer or file). You can use Edit>Find to 
search for information. 
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Setting Textbase Defaults 
Open a textbase and choose Maintain>Change Textbase Defaults to specify which forms, 
query screens, and record skeletons should be used by default when a user opens that textbase 
for the first time, and there are no initial elements specified in the menu screen (or no menu 
screen being used). 

Note: Initial elements specified in a menu screen override textbase defaults. 

When a user returns to the textbase for a subsequent visit, the last-used, user-specified forms will 
be used, unless there are initial elements specified for the menu screen. The textbase defaults 
will only be used if this textbase has never been opened by the user on a particular workstation. 

Backing Up Files 
You invest a great deal of time and effort in creating a textbase. To protect your information 
against accidental loss or damage, be sure to back it up on a regular basis. If a textbase is of great 
importance to your organization, consider keeping copies of all files off-site.  

Routine Backups 
Back up the following files on a regular basis—that means daily if you are adding, editing, and 
deleting records every day: 

• 
• 

• 
• 

Textbase files 
Image and annotation files 

Back up the following files on a less-regular basis, only when they have been changed: 

Textbase user files 
Menu screen files 
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Textbase Files 
Back up all your textbases on a regular basis (all files with a given name, such as SALES.*). 
You can do this using the Copy Textbase command in DB/TextWorks or using Windows 
Explorer. When you back up these files, you back up the complete textbase, including all 
records, structure information, stop word and leading article lists, validation and substitution 
lists, and elements stored in the textbase (forms, query screens, sets, and record skeletons), and 
the annotation list (which maps annotations to images). If the textbase is ever damaged, you can 
restore it using these files. 

Note: You should back up textbase user files, menu screen files, image files, and annotation files 
(default extension .ART) separately, as explained below. 

Textbase User Files (.TBU) 
Use Windows Explorer or DOS commands to back up your user files. User files contain private 
textbase elements (that is, forms, query screens, record skeletons, and sets) that were not stored 
in the textbase. Each user file has the same name as its textbase, with the extension .TBU. For 
example, a textbase called Sales has a user file called SALES.TBU. To see where your user files 
are stored, open any textbase and choose Display>Textbase Information. 

Tip! You may want to consider backing up your entire user file directory. This will save private 
elements as well as persistent information, such as the last-used import setting. 

Menu Screen Files (.TBM) 
Menu screen files have the extension .TBM and are located in the directory you specified when 
you created them. Use Windows Explorer or DOS commands to back up .TBM files. To print a 
description of a file, open a menu screen in the Menu Screen Designer and choose Menu 
Operations>Print Menu Screen Definition. 

Image Files and Annotation Files 
If your textbase includes references to image files, back up the image files as you would any 
valuable file, using Windows Explorer or DOS commands. If the images are annotated, back up 
the annotation files, too. Each annotated image has its own annotation file (default extension 
.ART) stored outside of the textbase. You supply the file name and location when you save the 
annotations. 
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Precautionary Measures 
Back up the following files from time to time. You may need them if your routine backup files 
are corrupted or lost. 

• 
• 
• 
• 
• 
• 
• 
• 

Textbase structure backup files (.TBB) 
Records (.DMP) 
Textbase elements (.XPF, .XPQ, .XPS, .XPK) 
Stop word lists 
Leading article lists 
Validation lists 
Substitution lists 
Image annotation list (.IAB) 

Textbase Structure Backup Files 
To back up a textbase structure, open a textbase and choose Maintain>Edit Textbase 
Structure. Click the Back Up Structure button and supply a name for the textbase structure 
backup file (.TBB) when prompted. The .TBB file contains all of the information on the Edit 
Textbase Structure dialog box and its subdialog boxes. It does not contain records or textbase 
elements. You can use the .TBB file to create a new, empty textbase by choosing File>New 
Textbase>Restore from Textbase Structure Backup File. 

To print the structure definition 
In addition to backing up the textbase structure, it is a good idea to print the structure definition, 
either by printing it on paper or to a file. Printing the structure provides a description of the 
fields and settings that make up the textbase. If you print to a file, be aware that the file is only a 
description of the structure, and cannot be used as the basis of a new textbase. 

1. Choose Maintain>Edit Textbase Structure and click the Print Structure button. 

2. Use the Print dialog box to print the structure or save it as a file. 

Tip! Printing the structure is the only way to print password definitions. 
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Records and Elements 
The operations listed below create text files that can be used to reconstruct the contents of the 
textbase if necessary: 

• Open a textbase and choose File>Export to write records to a text file. The resulting files 
could be loaded into a new textbase, if your textbase was ever seriously damaged. 
Note: Use Export to export Deferred updates, not Dump Textbase. 

• Open a textbase and choose Maintain>Manage Textbase Elements to export definitions of 
forms, query screens, sets, and record skeletons to text files. If an element is accidentally 
damaged or deleted, you can replace it by importing it (along with all textbase elements for 
that textbase) from the exported file using Maintain>Manage Textbase Elements. 

Stop Word, Leading Article, Validation, and Substitution Lists 
These lists are backed up when you back up the textbase files. An extra level of protection is 
provided if you also print them to text files periodically. Open a textbase and choose 
Maintain>Edit Textbase Structure, click the Stop Words or Leading Articles button, then 
click the Print List button and select the Print to file check box. You can print substitution and 
validation lists to files from the Edit Fields dialog box or by choosing Maintain>Edit 
Lists>Substitution Lists or Maintain>Edit Lists>Validation Lists. 

Image Annotation List 
The image annotation list maps image files to annotation files. Open a textbase and choose 
Maintain>Manage Image Annotations, then click the Back Up Annotation List button. This 
creates an Image Annotation Backup file (.IAB) which you can restore using the Merge File 
into Annotation List or Replace Annotation List with File button on the Manage Image 
Annotations dialog box. 
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Other Management Activities 

Keep a Log File of the Textbase Activity 
A log file is a text file that records changes to the textbase (for example, record additions, 
deletions). Log files are saved in the same location as the textbase and have the same name, with 
the extension .LOG. Edit the textbase structure and be sure the log file is enabled. Information is 
continually appended to the log file. Periodically, after reviewing changes and/or printing the log 
file, you may want to delete a log file by choosing Maintain>Delete Log File. If the textbase 
has passwords, you must use the Master password to delete a log file. DB/TextWorks generates 
a new log file automatically. 

Monitor passwords 
If you are using passwords to manage different levels of access (for example, allowing some 
users to edit records, while others can only view records), establish a process to monitor the 
password assignments (for example, to change them periodically). To see the currently assigned 
passwords and settings, print the textbase structure (choose Maintain>Edit Textbase 
Structure>Print Structure). You need to use the Master password in order to do this. 

Analyze a textbase 
The Analyze Textbase command examines each record in the specified textbase and generates a 
tabular report listing the following information about each field in the textbase: 

• 
• 
• 

Max Entries. The maximum number of entries in a single record. 
Max Entry Length. The maximum length of a single entry. 
Max Record Length. The maximum length of this field in a single record. 

To analyze a textbase, choose Manage Textbases>Analyze Textbase, select the textbase you 
want to analyze, specify a name for the resulting report file, then click OK to start the analysis. 
For more information, see the online help. 
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Checking a Textbase for Problems 
Choose Manage Textbases>Check Textbase to check a textbase or a user file and repair 
certain problems. You can also have DB/TextWorks rebuild indexes found to be damaged. See 
the online help for more information on checking a textbase. 

 
After you check a textbase, a window displays the r
those results again at a later time, choose Manage T
File. 

If a textbase is severely damaged and you are unabl
file lists serious errors that it could not fix, you may
reload the textbase. For instructions on recovering a
with Records.” 
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Chapter 3: Working with Records 

Without records, a textbase is just an empty structure. A record is the basic unit of retrievable 
information—when you search a textbase, you find records. For example, if you search an online 
catalog for Hemingway, you will find several records, each of which represents a book. 

This chapter explains how to add, edit, and delete records on the desktop, including import and 
export operations. It also explains operations related to displaying and managing records, such as 
how to sort records after a search. 

Note: If you have WebPublisher PRO, you can also add, edit, and delete records over the Web 
using a browser. For more information, see the Inmagic DB/Text WebPublisher PRO User’s 
Manual and the DB/TextWorks online help. 

Overview 
Before users can search your textbase, you must populate it with records. DB/TextWorks 
provides several ways to add, modify, and manage records. 

Once you have created a textbase and defined its fields, as explained in the previous chapter, you 
are ready to add records. Users cannot search your textbase unless you populate it with records. 
The following are some of the ways you can add records. Each will be explained later in this 
chapter. 

• 
• 

• 
• 

To add one record at a time, choose Records>New Record. 
To copy an existing record and then edit it to make it unique, choose Records>Duplicate 
Record. 
To import records from a text file, choose File>Import. 
To import electronic documents (for example, letters, memos, and EMail), choose 
File>Import Document. 

Adding New Records One at a Time 
When you add new records manually, you work in the Edit window. The form used for the Edit 
window determines which fields appear. To select a different form, choose Display>Select 

Forms, or use the Select Form for this Window button  on the Edit window toolbar. If you 
have not designed your own Edit forms yet, use the Basic Record form. For more information 
about designing forms, see Chapter 5, “Working with Forms.” 

To add a record, you must have full access to all fields that you will be adding, and to all fields 
that have Field Entry Required validation. 
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To add one record at a time 
1. Choose File>Open and open a textbase. 

2. Choose Records>New Record to open the Edit New Record window. 

Note: New Record is disabled if the textbase is read-only or if any fields that have Field 
Entry Required validation are hidden or read-only. 

3. Click in the box in which you want to enter information and start typing; or, if the field has 
a validation list, substitution list, or thesaurus, press F3 and paste an entry from the list. To 
see if the current field has validation settings, look at the status bar. 

Note: If you want to add another entry in the box, press F7, then type your next entry. 

4. Enter information in all applicable fields by moving from box to box. Click in the box, use 
Tab or Shift+Tab, or choose Edit>Go to Box to move through the boxes. Each editable 
box represents one field. 

 
5. Choose Records>Save Record, press F5, or press Ctrl+S to save the record. 
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Working with Record Skeletons 
Record skeletons are like templates for new records. Information in a record skeleton is put into 
each new record when you create it using the New Record command. All you have to do is 
“flesh out” the record by adding or editing information. 

Skeletons are used for new records only, and are intended to reduce repetitive data entry. They 
are for desktop use only. (If you have WebPublisher PRO and want default information to 
appear on Web edit forms, see the online help, the “Using Default Values on a Web Edit Screen” 
topic.) 

The record skeleton shown below lists Joe Brown as the Salesperson and Open as the status 
for each new record. 

 

To create or edit a record skeleton 
1. Choose Records>Edit Record Skeleton to open the Open Record Skeleton dialog box. 

2. Specify whether you want to edit an existing record skeleton or create a new one by 
selecting the appropriate option from the Start With list. Click OK. 

3. The Record Skeleton Editor displays the selected skeleton or a new record skeleton, using 
the current edit form. Fill in the boxes so the record information appears the way you want 
each new record to appear. 

Note: You can specify literal text only. Avoid including information in a skeleton that does 
not comply with a mask, range, or validation list, as this will cause the Content Validation 
Mismatch dialog box to open each time you save a new record using the skeleton. 
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4. Save the skeleton by choosing Record Skeletons>Save Skeleton or Record 
Skeletons>Save Skeleton As. 

– Save Skeleton. Saves a skeleton under its current name, overwriting the previous 
version. You will see the Save Record Skeleton As dialog box the first time you save 
the skeleton, but not during subsequent saves. Use this option when you are saving a 
new skeleton. 

– Save Skeleton As. Creates a copy of the skeleton under a new name. Use this if you 
edit a skeleton, but want to keep the original version. 

5. Type a name and description for the skeleton in the appropriate boxes. 

6. Depending on how you want the skeleton to be saved, choose: 

– User File (Private) if you want the skeleton to be available only for your personal use. 
– Textbase File (Public) if you want the skeleton to be available to everyone who uses 

this textbase. The current password determines whether you have the right to save 
skeletons in the textbase file. 

7. [Optional] To print a description of the current record skeleton, choose Record 
Skeletons>Print Skeleton.  

8.  [Optional] To load a different record skeleton so you can edit it or to begin creating another 
record skeleton, choose Record Skeletons>Open Skeleton. 

9. To close the Record Skeleton Editor, choose Record Skeletons>Close Skeleton Editor. 

To select a record skeleton 
If you want a particular record skeleton to be used whenever you create a new record, you have 
to select it. Choose Records>Select Record Skeleton and select a skeleton from the Currently 
Saved list. If you want to stop using a skeleton, select <none>. If you want to use the skeleton 
specified as the textbase default, click the Revert to Default button. 

You cannot select a skeleton if the Records>New Record command is disabled. 
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Editing Records One at a Time 
When you edit records manually, you work in the Edit window. The form used for the Edit 
window determines which fields appear. If you have not designed your own Edit forms yet, use 
the Basic Record form (choose Display>Select Forms>Record Edit). For more information 
about designing forms, see Chapter 5, “Working with Forms.” 

To edit one record at a time 
1. Locate the record that you want to edit by doing a search or loading a set. The Select Search 

Results Window dialog box opens. 

2. Select the Edit window option button and click OK to open the Edit window, which uses 
the current Record Edit form. 

3. Edit or add more information in the boxes, as applicable. 

4. To save changes to the current record, choose Records>Save Record, press F5, or press 
Ctrl+S. 

5. Use the arrow buttons on the Edit window toolbar to navigate to the next record to be 
edited. 

Note: If you edit records while the Report window is open, the changes do not appear in the 
Report window until you refresh that window by choosing Display>Display Report. 
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Why You Cannot Edit Information in Some Boxes 
Every form consists of one or more boxes. You can edit information in any box that contains one 
field from the record being edited, as long as that field is not protected by the current password. 
If you try to type information in a non-editable box, a beep sounds. Try changing the form or 
password. 

You cannot add or change information if a box contains: 

• 

• 

• 

• 

• 

Content items other than fields. Box content is determined by the current form. Select the 
Basic Record form if you want to be able to edit every field not protected by passwords. 
Multiple fields. The only exception is if all of the fields are hidden except one, and the field 
that you can see is not marked read-only by the current password. 
A field from a secondary textbase. To edit information from a secondary textbase, choose 
Records>Edit Secondary Record, or open the secondary textbase directly. 
A Computed Date, Computed Number, Automatic Date, or Automatic Number field. 
These fields automatically generate information that cannot be edited. 
A field specified as read-only by the current password. 

Editing Techniques 
Use the techniques described below when you add and edit records in the Edit window. 

Working with Multiple Entries 
Each field describes a particular property of a record, such as the author of a book. A given 
property may have multiple values, such as multiple co-authors of a book. In DB/TextWorks, 
each value is known as an entry in the field. Fields can contain any number of entries. 

For example, say you have a textbase that tracks letters, and some letters are sent to more than 
one person. In a traditional database, you would either have to create separate Recipient1 and 
Recipient2 fields, or “blob” all of the names into one field without having them be recognizable 
as separate entities. 
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With DB/TextWorks, you can enter all of the names in just one field, and have each considered 
its own entry. Each entry is indexed separately, meaning you can search for and sort the names 
independently. Multiple entries in a field are preceded by a bullet, as shown in the following 
illustration. You can delete these bullets to concatenate two entries. The bullets are visual signals 
indicating the field entries. They are not part of the data. 

This field holds one entry. 

 
The ability to include multiple entries in a field, instead of requiring a separate field for each 
item, is one of the unique features of DB/TextWorks. 

Note: Automatic fields, Computed fields, and Link fields cannot hold multiple entries. All other 
fields can have unlimited entries, as long as the validation is not set to Single Entry Only. 

To add multiple entries 
1. To add the first entry, type the text in the appropriate box. For example, type 

Christopher Adams in the box labeled Recipient. 

2. To add another entry, press F7, or choose Edit>New Entry, then type the new entry. The 
cursor’s position determines where the new entry will be added. If the cursor is at the 
beginning of the existing entry, the new entry will be added before the existing entry. If the 
cursor is anywhere else, the new entry will be added after the existing entry. 

3. Repeat step 2 to add as many entries as you want. A bullet precedes each new entry. 

Important! Pressing Enter does not create a new entry and is not equivalent to the F7 key. 
Pressing Enter simply inserts a line break—the additional information will not be indexed 
separately. 

This field holds three entries. 
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To split one entry into multiple entries 
Use the following steps to split a single entry into two separate entries. This is useful if you have 
typed a list of entries on one line and want to make them individual entries; or if you typed a list 
and pressed Enter after each one, instead of F7. 

1. Insert the cursor at the point at which you want to split the entry. In the following 
illustration, two entries have been entered on the same line without a separator. 
DB/TextWorks interprets this as a single entry and indexes it as such. To split them into two 
entries, insert the cursor between Davis and Harold. 

 
2. Press F11 or choose Edit>Insert Entry Mark. The software splits the names into two 

entries, each preceded by a bullet. After the record is saved, each name will be indexed 
individually. 

 

Note: When the cursor is at the beginning or end of an entry, pressing F11 achieves the 
same result as pressing F7. 

To select an entry 
 With the cursor in the entry you want to select, press Ctrl+F7, or choose Edit>Select 

Entry. 

To delete an entry 
 With the cursor in the entry you want to delete, press Shift+F7, or choose Edit>Delete 

Entry. 

To paste an entry 
You can paste information from the Windows Clipboard to create a new entry. 

 Position the cursor, then choose Edit>Paste Entry or press Ctrl+Shift+V. (To paste 
information without making it a new entry, choose Edit>Paste or press Ctrl+V.) 
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Checking Spelling 
There are two ways to check a record to eliminate possible typographical errors. You can run a 
spell check on a record after you have finished creating or editing it, or you can choose to have 
your spelling checked as you type. You can check spelling on the desktop in the following 
windows: Edit Record, Edit Secondary Record, and Record Skeleton Editor. 

The spell checker helps you identify possible misspellings by comparing the text to a dictionary 
of accepted spellings. You can add, edit, and delete items in the dictionary. (For more 
information about modifying items in the dictionary, click the Dictionary button on the Check 
Spelling dialog box [which appears when you are checking spelling in the Edit window], then 
click the Help button on the Dictionaries dialog box.)  

To set up the spell checker 
1. Decide which fields to check and which to skip. By default, DB/TextWorks checks Text 

fields only. To check other types of fields, choose Tools>Spell Check Setup and use the 
arrows to indicate which fields to check and which fields to skip. Automatic and Computed 
Date and Number fields can never be checked because they are not editable fields (but 
Automatic ID fields can be). 

2. [Optional] Select the Check spelling as you type check box on the Spell Check Setup 
dialog box. Note that if you have the Edit window open when you select this option, it will 
not take effect until you close and re-open the Edit window. 

3. Click OK. 

Note: If you want to change the spell check setting while in the Edit Record, Edit Secondary 
Record, or Record Skeleton Editor window, close the window before specifying the new 
settings on the Spell Check Setup dialog box. If you do not, the changes will not apply to 
the record or record skeleton in the active window. 

To run the spell checker 
1. Open a record in the Edit or Edit Secondary Record window, or open a skeleton in the 

Record Skeleton Editor window. For example, search for a record and then choose 
Records>Edit Record. 

2. Select a form that includes all the fields that you want to spell check. For example, click the 

Select Form for this Window button  on the Edit window toolbar and choose the Basic 
Record form.  

3. Place the cursor in the box in which you want to begin the spell check, or select the text that 
you want to spell check. 

4. Choose Tools>Spell Check, press F8, or click the Spell Check button  on the Edit 
window toolbar. 
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5. Use the Check Spelling dialog box to correct spelling errors. Click the Help button on that 
dialog box for more information. DB/TextWorks checks editable boxes only. It skips: 

– Fields that do not appear on the Edit form. 
– Fields that are marked read-only by the current password. 
– Uneditable boxes (for example, boxes that contain Automatic or Computed Date fields, 

Automatic or Computer Number fields, variables, more than one field, and so forth). 
– Fields in the Skip these Fields list on the Spell Check Setup dialog box. 

To check spelling as you type 
1. 

2. 

Create a new record or open a record for editing in the Edit or Edit Secondary Record 
window, or open a skeleton in the Record Skeleton Editor window. As you type, words the 
spell checker considers misspelled will turn red. 

Choose one of the following methods for correcting spelling errors. You can make 
corrections when a red word appears, or when you are done typing. 

– Right-click a red word. A list of suggested alternatives appears in a pop-up list, as well 
as commands to Ignore All (to skip the misspelled word and all other instances of it in 
the record) and Add (to add the word to your personal spell-check dictionary). Choose 
an alternative word, if applicable, and the spell checker will replace the red text with 
the new word, and make the text color black. Note that if you have moved the cursor 
out of the box containing the red word, you must click the left mouse button in the box 
before you right-click the red word in it. 
Note: Once you make a selection from the list of alternatives (or select the Ignore All 
or Add commands), the standard pop-up menu that opens when you right-click appears. 
Click away from it to make it disappear. 

– Select the red word and type the correct word, if the word is one for which you do not 
need an alternative suggested (for example, you typed hte instead of the). The new 
word will appear black if it is spelled correctly. 
Note: Double-clicking a word does not highlight the entire word when using the Check 
spelling as you type option. You must highlight the word with your mouse to select it. 

– Continue typing and run the spell checker when you are done. Choose Tools>Spell 
Check, press F8, or click the Spell Check button on the Edit window toolbar. The spell 
checker will provide alternative spellings for each red word, one at a time, on the Check 
Spelling dialog box and turn each misspelled word black, if an alternative is selected to 
replace it. 

If you choose to check spelling as you type, note that the text you type will only appear red or 
black, no matter what color text you specify for the box. Words spelled correctly while typing 
will appear black and misspelled words will appear red. Words chosen from alternative lists will 
be changed from red to black. This applies to alternatives provided by right-clicking on a red 
word, or on the Check Spelling dialog box. If you want to keep records looking uniform, you 
can use black text for editable boxes in edit forms if you are using the Check spelling as you 
type option. 
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Using Find and Replace 
Choose Edit>Find or press Ctrl+F to open the Find dialog box so you can locate information in 
the active window. 

 
Choose Edit>Replace to open the Replace dialog box so you can change information within a 
record. You can use Replace in editable windows only (such as the Edit or Query window).  

 

Using Undo and Redo 
While you work in the Edit window, you can select Edit>Undo and Edit>Redo to undo and 
redo the most recent edits. You can select Undo and Redo repeatedly to undo or redo multiple 
actions. Note that the cursor must be in the box in which you want to undo or redo actions. 

Using Cut, Copy, and Paste 
To cut, copy, and paste information using the Windows Clipboard, use the Edit menu. You can 
copy and paste information between fields and records or share information among applications. 
When you paste within DB/TextWorks, multiple entries are retained. 
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Inserting the Current Date, Time, or a Series of Dates or 
Numbers 

While adding or editing a record, you can insert the current date or time or an automatically 
generated series of dates or numbers. Inserting a series can be easier than typing multiple 
sequential entries, such as several expected issue dates for a periodical. Each item that you insert 
becomes a separate field entry. The current date or time formats are determined by the Windows 
Control Panel. In DB/TextWorks, you can use a short or long date format by choosing 
Tools>Options>General, and selecting or clearing the Insert date using long format check 
box. Note that Tools>Options>General>Insert date as new entry (which is selected by 
default) affects the insertion of the current date and current time. 

To insert… Do this… 
The current date Put the cursor in a field and choose Edit>Insert>Current Date 

or press F4.  
The current time Put the cursor in a field and choose Edit>Insert>Current Time 

or press Shift+F4. 
A series of dates Put the cursor in a Date field and choose Edit>Insert>Series. 

Use the dialog box to determine how the series will be created. 
You can specify the first entry, the number of entries, and the 
increment unit (days, weeks, half-months, months, or years). 

A series of numbers Put the cursor in any non-Date field (for example, Number, Text) 
and choose Edit>Insert>Series. Use the dialog box to determine 
how the series will be created. You can specify the first entry, the 
number of entries, and how to increment (by 1, for example). 

 
Tip! If you include an Automatic Number field in the textbase structure, DB/TextWorks will 
insert an automatically generated number for each record. For more information, see 
Chapter 2, “Creating a Textbase,” the “Automatic Number” section. 
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Validation Checking 
When you add and edit records or perform batch modify and import operations, DB/TextWorks 
checks the validation to see if there are any restrictions. When the Edit window is active, the status 
bar in the Main window shows the validation of the current field. To see the validation for all 
fields, choose Display>Textbase Information.  

A common validation check is for fields that have Field Entry Required validation. You cannot 
save a record that leaves this type of field empty, nor can you delete all entries in the field. The 
current password must give full access to all fields that have Field Entry Required validation if 
you want to create records. If the form selected for the Edit window omits any fields that have 
Field Entry Required validation, DB/TextWorks informs you and changes to the Basic Record 
form. 

Another common validation check occurs when you type an entry that is not in a validation list. 
When you press F7 or move off the field, the Content Validation Mismatch dialog box opens. 
Depending on the validation settings, you can accept the entry, accept the entry and add it to the 
validation list, or browse the validation list and paste an acceptable entry from it. The Content 
Validation Mismatch dialog box also opens if the field entry violates range or mask validation 
and permits overrides. Read about validation lists below. 

This button is active if users can 
override content validation. 

This button is active if users can update 
a validation list and the password allows 
editing of lists. 
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Using a Validation List 
If a field has a validation list or has a thesaurus connected to it, you can browse the list and paste 
entries from it into the current field while adding or editing a record. This is a convenient way of 
adding entries to new or existing records, and of seeing what entries are allowed in a field.  

1. While adding or editing a record, put the cursor in a box that contains a field that has a 
validation list. If the Browse Choices toolbar button is enabled when you put the cursor in a 
box, you can browse and paste entries from a list. To see if a field has a validation list, you 
can also look at the status bar or choose Display>Textbase Information. 

2. Press F3 or choose Edit>Browse Choices to open the Editing Choices Browser dialog box. 

3. Select the Validation List option button to show the validation list for the selected field. 
Notice that if the field has a thesaurus connected to it, and the thesaurus is specified as the 
validation field for the list, the thesaurus terms will appear as the validation list. 

Note: There are other option buttons that may be enabled, depending on the field selected. 
The Substitution List option button is enabled if the field has a substitution list. The Links 
option button is enabled if the field is a Link field. The Thesaurus option button is enabled 
if a thesaurus is connected to the field, but is not specified as the validation list. These 
options are explained in more detail in the following sections. 

To move quickly to an 
entry, type the first one or 
more letters in the Find 
box. 

Because the Thesaurus option 
button is enabled, it means the 
Skills field has a thesaurus, but it 
is not used as its validation list.  
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4. Select an entry and click the Paste button to add the selected entry to the field, or click the 
Replace button to replace the current field entry with the selected entry. Note that if you are 
browsing thesaurus entries and you paste a term with a USE reference, the preferred term is 
pasted. 

5. Repeat step 4 for each entry you want to add to the field, then click Close. 

To edit a validation list, choose Maintain>Edit Lists>Validation Lists, or use the Edit 
Textbase Structure dialog box. The latter method requires you have exclusive access to the 
textbase. While editing a list, you can also print it, print it to a file, or import a text file into the 
list. For more information, see Chapter 2, “Creating a Textbase.” 

Tip! If needed, you can resize this dialog box by using the standard Windows method for 
resizing. Place your mouse pointer over the right edge until it turns into a two-headed arrow, 
then click and drag, and release the mouse when appropriate. 

Using a Substitution List 
A substitution list is a list of codes and replacement values defined for a Text field. Type the 
code while adding or editing a record. When you press F7, or move the cursor to a different box, 
the substitution is made. For example, type ri and click in another box to see Rhode Island 
appear. Substitution lists can reduce keystrokes and typographical errors. 

If you cannot remember the code, press F3 or choose Edit>Browse Choices. When the Editing 
Choices Browser appears, you may have to select the Substitution List option button from the 
List Shows group, if it is not already selected. You can select and paste an item from the list. 

 

Note: During an import or batch modify, substitutions are made automatically. 
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To edit a substitution list, choose Maintain>Edit Lists>Substitution Lists, or use the Edit 
Textbase Structure dialog box. The latter method requires you have exclusive access to the 
textbase. While editing a list, you can also print it, print it to a file, or import a text file into the 
list. For more information, see Chapter 2, “Creating a Textbase.” 
Tip! If needed, you can resize this dialog box by using the standard Windows method for 
resizing. Place your mouse pointer over the right edge until it turns into a two-headed arrow, 
then click and drag, and release the mouse when appropriate. 

Editing Secondary Records 
If the textbase includes a Link field, you can edit information from the secondary textbase from 
within the primary textbase. Linking is done on a record-by-record basis—a link is established 
when the Link field in a record in the primary textbase and the associated field in a record in the 
secondary textbase contain identical information. For example, if a Link field and its associated 
field contain the entry John Smith, the two records are linked. Linking works on a 
many-to-one relationship. That is, many records in the primary textbase can link to the same 
record in the secondary textbase, but a record in the primary textbase links to only one record in 
the secondary. 

To ensure a match when adding or editing a record in the primary textbase, you can place the 
cursor in a Link field and press F3 or choose Edit>Browse Choices. You can select and paste a 
term from the secondary textbase field index into the current record. 

To edit a secondary record from within the primary textbase, choose Records>Edit Record or 
Records>New Record, then choose Records>Edit Secondary Record. If this menu command 
is grayed out, you may have more than one Link field. Place the cursor in one of them, then 
choose the command. If the Link field is filled in, the corresponding record in the secondary 
textbase opens in the Edit Secondary Record window so you can edit it. If the Link field is 
empty, a blank Edit form opens so you can create a new record in the secondary textbase. 

For more information about linking, see Chapter 8, “Linking Textbases.” 

Using a Thesaurus in the Edit window 
When adding or editing records, you can browse and paste entries from a thesaurus textbase 
attached to a field. A thesaurus lets you maintain a controlled vocabulary of terms. 

To browse the thesaurus, place the cursor in a field that has a thesaurus attached to it and press 
F3 or choose Edit>Browse Choices. When the Editing Choices Browser opens, you may have 
to select the Thesaurus option button from the List Shows group, if it is not already selected. 
You can select and paste a term from the thesaurus. 

Note: If the field has a thesaurus attached and it is specified as a validation list, the Thesaurus 
option button will not be enabled. The thesaurus entries will automatically appear as the 
validation list, and the Validation List option button will be selected. 

For more information about using a thesaurus, see Chapter 4, “Searching a Textbase,” the 
“About DB/TextWorks Thesaurus” section. 

98 Chapter 3: Working with Records 



Refreshing Computed and Linked Information 
While adding or editing a record, you can update the display of Computed fields and fields from 
a secondary textbase (linked information) by simply moving the cursor to a different field, 
choosing Window>Refresh, or pressing F9. This procedure does not refresh boxes that contain 
multiple content items (except multiple secondary textbase fields). To refresh a box that contains 
multiple items, redisplay the window (close and reopen it). 

Tip! You do not have to refresh in order to update Computed fields. They are re-evaluated 
whenever you move off one of the fields included in the formula for the Computed field or save 
the record. Refreshing is intended only as a convenience, to update the display. 

Specifying Textbase Access 
When you add, edit, or delete records, DB/TextWorks makes changes to the Word and Term 
indexes to keep them up to date. 

You can select an indexing mode to determine when the indexing takes place. There are three 
indexing modesImmediate, Shared Immediate, and Deferredeach of which has its own 
advantages. 

To change the indexing mode or set the default 
Important! If you are changing the indexing mode of a textbase with a password(s), you must 
use the Master password to open the textbase. If you do not, the Change Indexing Mode option 
will be disabled. 

1. Open a textbase and choose File>Change Indexing Mode. 

2. Select an indexing option. Each option is explained on the following pages. 

Select the indexing mode 
that you want to use 
during this session. 

Select this check box to make the 
selected mode the textbase 
default for all users. 

 
3. Click OK. The option remains in effect only for the current session, unless you select the 

Use as Textbase Default Indexing Mode check box. Only the Master password gives you 
the right to set or change the default. 
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Immediate Indexing 
With Immediate indexing, only one person can open the textbase at a time. Changes are indexed 
immediately when a new or edited record is saved or when a record is deleted. There is a slight 
delay (usually only several seconds) each time the indexes are updated. The benefit of using 
Immediate indexing is that you can always see and search the most recent version of a record, 
because the indexes are always updated immediately. 

other users of the same textbase are temporarily denied access to operations that involve the 
indexes, such as searching or saving records 

If you are sharing a textbase in a network situation, no one else will be able to open this textbase 
until you close it or change the indexing mode. Before you select Immediate indexing, be sure 
that no one else needs to use the textbase. Immediate indexing also prevents a single user from 
opening the same textbase in multiple instances. 

Immediate indexing ensures the fastest imports and posting of deferred updates. If speed is a 
concern, change to Immediate indexing before performing these operations. 

You cannot select Immediate indexing if the current Field Access or Silent password prohibits 
exclusive access, or if anyone else has the textbase open. To see if any other people are using the 
textbase, choose Display>Textbase Information. 

Shared Immediate Indexing 
Shared Immediate indexing is the same as Immediate indexing, except that multiple people can 
use the textbase at the same time, and a single user can open a textbase in more than one 
instance. When information is being indexed, other users of the same textbase are temporarily 
denied access to operations that involve the indexes, such as searching or saving records. 

Shared Immediate indexing is often the best choice when just a few users are sharing a textbase. 
If you encounter frequent delays while using Shared Immediate, all users sharing the textbase 
should use Deferred indexing. 
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Deferred Indexing 
With Deferred indexing, many people can use the textbase and make changes to it at the same 
time. Deferred indexing eliminates the indexing delays that occur with Immediate or Shared 
Immediate indexing. It is a good choice when many users are sharing a textbase on a network, or 
for single users who want to eliminate indexing delays. 

When more than one person is sharing a textbase, deferred updates may contain not only your 
changes, but changes that other people have made as well. 

The terms “deferred updates,” “unposted changes,” and “pending updates” are used 
interchangeably. They all refer to changes that were made while Deferred indexing was in effect, 
and which have not been incorporated into the textbase yet. Deferred indexing affects the 
options listed in the following table. 

Operation Result of Using Deferred Indexing 
Searching Because deferred updates are not indexed, a search will not find new 

information in records with unposted changes. To find records with 
unposted changes, choose Maintain>Deferred Updates and select 
Get Deferred Updates from the Do This list. 

Displaying, printing, and 
sorting records 

Deferred changes do not appear when you display, print, or sort, 
unless you choose Tools>Options>General and select the Show 
deferred changes in reports and display check box. 

Editing or copying records When you edit or copy a record that has unposted changes, a 
message tells you that updates are pending and asks if you want to 
edit the changed version. Click Yes if you want to edit the record, or 
No to cancel. You can edit only the newest version of a record with 
deferred changes (in other words, you will see deferred changes even 
though they have not been indexed yet). 

Importing records If you import records using Deferred indexing, you will have to post 
the deferred updates later. For maximum speed, change to Immediate 
or Shared Immediate indexing before importing records. If you are 
using matching to modify records already in the textbase, post 
deferred updates before starting the update. 
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Finding, Posting, Printing, or Discarding Deferred Updates 
To find (get), print, post, or discard deferred updates, choose Maintain>Deferred Updates and 
specify what you want on the Deferred Updates dialog box. 

 
Each Deferred indexing option is explained below. For more information, see the online help. 

• Get Deferred Updates. Find records with deferred changes. Although you cannot undo 
deferred changes selectively, you can make additional changes before posting the updates. 
When you get deferred updates, you can request new records (added with Deferred 
indexing), modified records (edited with Deferred indexing), and/or deleted records (deleted 
with Deferred indexing). 

• Print Deferred Updates. Print copies of records with deferred changes or save them in a 
text file. Each record is preceded by a comment showing the type of update (changed fields, 
deleted records, new records) and the affected fields. To print to a file, select the Print to 
File check box on the Print dialog box; the file will be a plain text file. 

• Post Deferred Updates to Textbase. Update the Word and Term indexes to incorporate 
deferred additions, changes, and deletions. If necessary, you can interrupt the update process 
by clicking the Stop button while the Post Updates Status message is displayed. If any 
updates cannot be posted, explanations are written to the textbase log file. 

• Discard Deferred Updates. Permanently discard all changes made while Deferred indexing 
was in effect. As a precaution prior to discarding updates, you may want to copy them to a 
file (using Print Deferred Updates). When you discard deferred updates, all unposted new 
records are discarded, all unposted changes are discarded, and all unposted deleted records 
remain in the textbase. 
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Exporting Deferred Updates 
Backing up record information on a regular basis is an essential part of textbase maintenance. If 
you use Deferred indexing, decide whether to include deferred changes when you export record 
information. You can use the following menu options to achieve the results you want. 

Menu Option Purpose 
File>Export 
 

Writes copies of updated versions of all records in the 
current set or textbase to a text file, as if deferred 
updates had already been posted. This is how you 
export the most recent version of the textbase—either 
the entire textbase or the current record set, depending 
on the export option you select.  

Manage Textbases>Dump Textbase 
 

Writes copies of all records in the textbase to a text 
file, not including pending updates. Deferred 
additions, changes, and deletions are ignored. This is a 
way of backing up a textbase prior to posting deferred 
updates.  

Maintain>Deferred Updates, select 
Print Deferred Updates from the Do 
This list. Select Print to file on the 
Print dialog box. 
 

Writes copies of pending updates only. This is a way 
of retaining a permanent record of deferred changes, 
and is commonly done prior to posting or discarding 
deferred updates.  
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Copying Records 
You can copy an existing record, then edit the copy to make it unique. Copying a record can 
save you valuable editing time if the record you plan to add is very similar to an existing one. 

Important! Only fields included in the Edit form are copied.  

1. Select a record and choose Records>Duplicate Record. 

2. Edit the new record to make it unique. 

3. Choose Records>Save Record. 

The following table shows how certain information is handled when you copy a record. 

If the original record includes… Then… 
Automatic Number or Automatic ID fields The new record is assigned the next automatic 

value, just as if you had chosen Records>New 
Record.  

Automatic Date fields The date or date and time in the new record 
indicate when the copy was made. 

Computed fields Those fields are updated in the copy. 
Hidden or read-only fields Those fields are not copied. 
Fields omitted by the current Edit form Those fields are not copied. 
 

Deleting Records 
Follow the instructions below to permanently delete records from a textbase. You cannot delete 
records unless the current password provides full access to all fields. Note that you can also use 
File>Import to delete records. 

To delete one record at a time, search for the record you want to delete and select it in the Report 
window or display it in the Edit or Display window. Choose Records>Delete Record and 
respond to the confirmation message. 

To delete a batch of records, perform a search or load a set that contains only the records that 
you want to delete. 

Tip! Consider exporting the records to an ASCII file before batch deleting records, in the event 
you need to restore the information after it is deleted. 

To preserve a record in the set, omit it (choose Sets>Omit Record). Choose Records>Batch 
Delete and respond to the confirmation message. All records in the set are permanently deleted 
from the textbase. The records you omitted are no longer part of the set, and are not deleted. 

Tip! If records were deleted using Deferred indexing, it is possible to recover deleted records as 
long as the updates have not been posted. 
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Using Batch Modify 
To change information in more than one record at once, you can perform a batch modification 
on all of the records in the current set. At the end of the batch modification process, a message 
indicates how many records were modified, how many were not, and why. If you want more 
information at that time, you can choose Maintain>View Log File. 

Tip! Consider exporting the set of records to an ASCII file before batch modifying them. 

To change more than one record at a time 
1. Perform a search or load a set that contains the records you want to modify. You may want 

to view the records in either the Report or Display window to verify that they are the ones 
you want to modify. 

2. To remove a record from the set so it will not be modified, select it and choose Sets>Omit 
Record or press Alt+O. Omitting a record does not delete it from the textbase—it simply 
removes it from the set so it will not be affected by the batch modification. 

3. Choose Records>Batch Modify to open the Batch Modify Records in Set dialog box. 

 
4. Select a field to modify from the Field to Modify list. If you select <all fields>, your 

changes will affect all fields shown in the list. Computed and Automatic Number fields, 
Computed and Automatic Date fields, and secondary textbase fields do not appear in the list 
because you cannot change them using Batch Modify. Other fields appear only if the current 
password provides full access to those fields. 
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5. Specify how you want to modify records by selecting an option button in the Operation 
group: 

– Insert Entry Before. Add a new entry before an existing entry in the selected field. 
– Append Entry After. Add a new entry after an existing entry in the selected field. 
– Delete Entry. Delete one or more entries in the selected field. 
– Substitute Entry. Delete an entry in the selected field and replace it with a different 

entry. 
– Substitute Text. Change or delete text in the selected field. This is the only option that 

affects a piece of text, rather than an entry as a whole. 
Tip! To delete a piece of text, select the Substitute Text option button and the 
Matching option button (from the Affects group). When this combination is selected, 
the boxes on the bottom of the dialog box change to show the Find What box and the 
Replace With box. In the Find What box, type the text you want to change. Leave the 
Replace With box empty. You effectively replace the text in the Find What box with 
nothing—in other words, you delete it. 

6. Specify what the operation you selected in step 5 affects by selecting an option in the 
Affects group: 

– First Entry. Affects the first entry in the selected field. For example, inserts an entry 
before the first entry. 

– Last Entry. Affects the last entry in the selected field. 
– All Entries. Affects all entries in the selected field. 
– Matching. Affects the matching entry or text (the value typed in the Old Entry or Find 

What box). For matching entries, you must type the entire entry. 
Note: Case and punctuation in the Old Entry box are not significant unless you are 
modifying a Code field. Old and new entries are considered a match if their indexing is 
the same. For example, Feb 14, 2003 and 2-14-03 are equivalent in a Date field. 

7. If the Choices button on the Batch Modify Records in Set dialog box is active, click it to see 
terms that you can paste into the New Entry or Replace With box. (The box that appears 
on the dialog box depends on what you selected in step 5.) Depending on the field selected, 
the dialog box may show a validation list, substitution list, a thesaurus, or linked 
information from a secondary textbase. 

8. When you return to the Batch Modify Records in Set dialog box, click OK to confirm your 
settings. 

9. A confirmation message appears. Read it carefully before clicking Yes. Clicking No returns 
you to the dialog box so you can make additional changes. 
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Importing and Exporting Information 
You can copy record information into and out of a textbase by importing and exporting files. 
Importing and exporting is a way of sharing information among textbases or other applications, 
and of backing up and restoring record information. The import and export options are 
summarized below and explained in detail on the following pages. 

Menu Option Purpose 
File>Export Writes copies of updated versions of all records in the 

current set or textbase to a text file. Records are exported as 
if deferred updates had already been posted. 

File>Import Loads records from a text file into a textbase. This is how 
you move records from another source into your textbase. 

File>Import Document Loads full text from document files into a field. 
Manage Textbases>Dump 
Textbase 

Writes copies of all records in the textbase to a text file, not 
including pending updates. Deferred additions, changes, and 
deletions are ignored. This provides an easy way to back up 
records. Use it as part of your regular maintenance routine. 

Manage Textbases>Load New 
Textbase 

Intended primarily as a recovery mechanism to load records 
into a new empty textbase. No validation or duplicate record 
checking is done, and all Automatic and Computed fields 
remain exactly as they are in the import file. (They are not 
recomputed.) 

 
Note: The file that you import or export may contain extended characters, such as é, ñ, and £. 
Microsoft Windows and DOS have different extended character sets. To ensure that the 
characters are interpreted properly when sharing files between DOS and Windows applications, 
choose Tools>Options>General before you import or export, and select or clear the 
Read/write extended characters in MS-DOS format check box. The default is the Windows 
format. 

Importing Records 
Importing records is a fast way of building new and larger textbases. You can import records 
into a new, empty textbase or into a textbase that already contains records. The import file must 
be a text file in Inmagic tagged, delimited ASCII, or XML format. During an import, you can 
add records, replace records, modify fields, or delete records. 

Any fields included in the import file must be defined in the DB/TextWorks textbase into which 
you are importing the file. If a record in the import file contains a field that is not in the textbase 
structure, that record will be rejected. By default, DB/TextWorks places rejected records in an 
exception file. If you are copying information between two textbases that have several but not all 
fields in common, export (from the source textbase) a subset of fields to create an import file that 
will be accepted by the target textbase. 
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There are several important issues that you should be aware of before you start importing: 

• Passwords. If your textbase has passwords, be sure to use a password that provides full 
access to all of the fields included in the import file. To delete records during an import, you 
need full access to all fields, meaning no fields can be marked read-only or hidden. 

• Substitutions. During import, substitutions are made automatically for fields that have 
substitution lists or a thesaurus with USE entries.  

• Indexing Mode. You can import using any of the following indexing modes: 
– Immediate. This is fastest, but in a network situation no one else can open or use the 

textbase until the import is done. 
– Shared Immediate. Allows other users to have access to the textbase, but they might 

not be able to search, save records, or perform other operations that require access to 
the indexes. 

– Deferred. Requires you to post deferred updates at a later time. Also, Unique Entries 
Only validation cannot be checked against other records in the import file until the 
updates are posted. 
Note: Express Import is not available because records are not indexed if you are using 
Deferred indexing. 

• Computed and Automatic fields. Automatic and Computed fields are maintained by the 
software. You cannot change Automatic Numbers or creation dates in existing records, and 
you cannot dictate what they will be in a new record. During an import, the contents of 
Automatic and Computed fields in the import file are ignored, except for matching 
purposes. (The exception is Automatic ID fields. See below.) 
Computed fields are updated when a new or changed record is saved. Automatic fields have 
new values assigned when appropriate (for example, an Automatic Date field gets updated 
when a record is created or modified, depending on its field setting). Note that record 
replacement during an import is considered a modification, so Automatic Numbers and 
creation dates in the record in the textbase are retained. 

• Automatic ID fields. Automatic IDs are handled in a special way during import. If the 
incoming record does not have information in the Automatic ID field, the field will not be 
populated automatically when the record is imported into the textbase. If there is 
information in the Automatic ID field in the import file, and that field has Unique Entries 
Only validation, the value in the record will be incremented until it is unique. This means 
all the incoming records can contain, for example, IMP-001 and after the import the 
records will contain IMP-001, IMP-002, and so forth. 

108 Chapter 3: Working with Records 



To import records 
1. Choose File>Open and open the textbase into which you want to import records. 

2. Post deferred updates (if any) by choosing Maintain>Deferred Updates>Post 
Deferred Updates to Textbase. Though not required, this step is recommended, 
particularly if you will use the Add/Replace Options tab to check for matching records, 
or you have any fields with Unique Entries Only validation. 

3. Choose File>Import to open the Select Import File dialog box. 

4. Select the file you want to import, then click Open to open the Import Options dialog 
box. 

5. Use the tabs on the Import Options dialog box to specify how to import the file. The 
options on each tab are explained on the following pages. 

 
6. Click OK on the Import Options dialog box to start the import. 

When the import is complete, you will see a message indicating the import file name and the 
results of the import. If you specified that an exception file be created and any records were 
rejected, the message indicates the name and location of the exception file. When you click OK 
to dismiss the message, the exception file will automatically open in Windows Notepad. You can 
correct and then import the exception file. To see details about an import, choose 
Maintain>View Log File. For more information, see “ ” on page 118. Exception File Tab
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File Format Tab 
Use the File Format tab to indicate the format of the import file. 

Note: If you transfer a file from another system, you may need to convert the file to one of the 
following formats. 

• Inmagic Tagged Format. The text format for sharing files among Inmagic textbases, as 
explained on page 111. 

• Delimited ASCII Format. A text format commonly used to share information with other 
applications, as explained on page 112. When you select this option, the dialog box expands 
to show additional settings. 

• XML. A text format used for structured documents and data on the Web, as explained on 
page 115. When you select this option, the dialog box expands to show additional settings. 
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Inmagic Tagged Format 
Inmagic tagged files are text files in a format specific to Inmagic textbases. A file can include 
one or more records. Each record includes at least one field name followed by one or more 
entries in that field. Field names that include spaces are surrounded by quotation marks. A dollar 
sign on a line by itself indicates the end of a record. 

Example 

 
Characters at the beginning of a line indicate certain items. Each item is explained in the 
following table. 

Item Description 
!  Comment line (ignored during an import). 
Field name Can include letters, digits, hyphens, and underbars. Field names that 

include spaces must be enclosed in quotation marks ('single' or "double"). 
;  Additional entry in a previously named field. 
> Line break to be retained in the data for a previously named field. 
Space or Tab Continuation line for a previously named field (permits wrapping). A Tab 

will be imported as a space. 
$ A dollar sign on a line by itself indicates the end of a record. 
Any other 
character 

An error, which causes the record to be rejected. 
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To create a file in the Inmagic tagged format, use any text editor or use DB/TextWorks (the 
Dump Textbase or Export features). If you create the file yourself, follow these guidelines to 
ensure that the file is in the proper format: 

• Use quotation marks around field names that include spaces. Case is ignored. 
• A line cannot exceed 65,534 characters. To force a line wrap that will not be retained in the 

field data, press Enter and begin the next line with a space or Tab. This is called a 
continuation line. 

• Do not include a space or Tab before a character that represents a multiple entry, paragraph 
break, comment line, or the end of a record (; > ! $). If you do, that character will be 
interpreted as text in the field. 

• Do not include a field more than once in a record. Use a semicolon (;) at the beginning of a 
new line to indicate multiple entries. 

• Blank lines and comment lines are ignored during an import. 
• Records do not have to include every field defined in the structure—just the fields that you 

want to modify. Fields can appear in any order. 
• The file can include any number of records. 

To load Inmagic tagged files, use File>Import. 

Note: The Load New Textbase feature also accepts files in Inmagic tagged format, but should 
be used only in special circumstances (such as, when you do not need to match, do not need 
Automatic and Computed fields updated, and/or want validation or strictness checked). For more 
information about the Load New Textbase command, see “Loading Records into a New 
Textbase” on page 128. 

Delimited ASCII Format 
In a delimited ASCII file, values are separated by commas, tabs, or other characters. If you select 
this option button on the File Format tab, the Import Options dialog box expands to show 
additional settings. 
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Delimiter Options 
Use the drop-down lists in the Delimiter Options group to specify which characters are used in 
the import file to indicate where records, fields, and entries end. You can select options from the 
drop-down lists or type keyboard characters. To indicate a carriage return and line feed, enter 
{CR}{LF}. To indicate a line feed only, enter {LF}. To indicate a Tab, enter {TAB}. To 
indicate another character, type its ASCII value inside curly braces (for example, {29}). The 
previous illustration shows the typically used characters. The following table provides a list of 
delimiter options and their explanations. 

Option Explanation 
Record Separator Indicates where each record ends. The default is {CR}{LF}. 
Entry Separator  Indicates multiple (repeating) entries in a field. The default is a vertical 

bar. The following example shows three entries separated by a vertical 
bar: 

 
Bill Jones|Sue Smith|Tom Williams 

Entry separators are always interpreted as such, even if they are inside 
double quotation marks (or other specified Quote Character), so be sure 
to use a character or sequence of characters that never appears in your 
data. 

Quote Character Encloses field information. A quotation mark (") is used in this 
example: 

 
"Jones","5 Elm Street","Smalltown","CA" 

Select {NONE} if field information is not enclosed in specific characters, 
as shown in this example: 

 
Jones,15 Elm Street,Smalltown,CA 

Note: To embed a Quote Character in the data without having it be 
interpreted as a Quote Character, type it twice. 

Field Separator  Appears between fields, to indicate where each field ends. The default is 
a comma.  

Comment Lines that begin with the specified comment character will be ignored 
during the import. An exclamation point (!) is the default. 

 
Note: If a field name or any field information includes a delimiter, surround it with the Quote 
Characters. Putting a field separator, record separator, or comment character inside the specified 
Quote Characters causes it to be treated as data, not as a separator. Putting an entry separator 
inside Quote Characters does not change its purpose. 
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The example below shows a file that contains four records. The record separator is {CR}{LF}, 
the entry separator is a vertical bar ( | ), the Quote Character is a double quotation mark ("), the 
field separator is a comma (,), and there is one comment line: 

! Sample import file for BOOKS textbase 
"Frederickson","Trout Fishing","1998" 
"Smith, John","Fly Fishing","1987" 
"Jones, M","The ""Real"" Story","1998" 
"Jones, M|Smith, J","Alive and Well","1997" 

Field Names 
Select an option in the Field Names group to determine how to associate information in the 
delimited ASCII import file with fields in the textbase. If you are not sure about the file’s 
format, you can use Microsoft Notepad or WordPad, or any text editor to look at the file. 

• Import Fields in Textbase Structure Order. Select this option button if field names are 
not in the first row, and the fields in the import file are in the same order as the textbase 
structure. For example, if the first three fields in the structure are Product, Quantity, Date, 
this file will import properly: 

Widgets,25,15-Oct-2001 
Gadgets,100,20-Oct-2001 

• First Row Contains Field Names. Select this option button if the first line of the import 
file contains field names. The field order does not have to match the structure order. 

Product,Quantity,Date 
Widgets,25,15-Oct-2001 
Gadgets,100,20-Oct-2001 

• Specify Order in which to Import Fields. Select this option button if field names are not 
in the first row, and the import file has fields in a different order than the textbase structure. 
When you select this option button, the Available Fields and Import Fields lists appear on 
the dialog box. To indicate the proper field order, move fields from the Available Fields list 
to the Import Fields list. The Import Fields list should reflect the order of fields in the 
import file. If necessary, use the Up and Down buttons to change the order of the fields. For 
example, if your import file looks like the following example, move Quantity, Product, and 
Date, in that order, into the Import Fields list. Now the file will import properly, regardless 
of the order of fields in your textbase structure. 

25,Widgets,15-Oct-2001 
100,Gadgets,20-Oct-2001 

If a record in the import file contains more fields than the Import Fields list, the record will 
be rejected. If a record in the import file contains fewer fields than the Import Fields list, the 
fields not represented will not be modified. 
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XML Format 
Extensible Markup Language (XML) uses tags, like HTML, but offers greater flexibility because 
it gives you the ability to define custom tags. When you select this option on the File Format tab, 
the Import Options dialog box expands to show additional settings. 

Formatting Style Sheet to Transform XML File to Inmagic Tagged Format  
When importing XML files, DB/TextWorks uses an XSL style sheet to transform the XML file 
into a temporary Inmagic tagged format file. 

To specify the style sheet used for the transformation, select an option button from the 
Formatting Style Sheet to Transform XML File to Inmagic Tagged Format group. 

• 

• 

Default Formatting Style Sheet. Transforms the XML file using the standard style sheet, 
provided by DB/TextWorks. If you want to save a copy of the default style sheet to use 
again later (for example, to modify it to suit your needs for a future import), click the Save 
As button to open the Save Style Sheet File As dialog box. Specify a name and the location 
in which you want it saved, then click Save. Click OK to dismiss the confirmation message. 
Formatting Style Sheet in File. Transforms the XML file using a style sheet that you 
specify. If you select this option, click the Style Sheet File button to open the Select Style 
Sheet File dialog box. Select the style sheet file (.XSL) you want to use, then click Open. 
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Add/Replace Options Tab 
Use the Add/Replace Options tab to control how records are added, rejected, changed, or deleted 
during an import. 

 

Check for Matching Records 
Matching is the way you determine which records will be changed during an import. If you 
select this option, incoming records (in the import file) are compared to existing records (in the 
textbase) during an import. If they match, the operation you have specified will occur. 

When you select the Check for Matching Records check box, you enable all of the 
Add/Replace matching options. Use the right arrow button (>) to move a field (or multiple 
fields) from the Term-Indexed Fields list into the Incoming Records Must Match list, then 
specify what to do if a match is found or not found. Each matching option is explained on the 
following pages. 

For example, say you use the Product Number field for matching. If an incoming record has 
123 in the Product Number field and an existing record has 123 in the Product Number field, 
the records match. Depending on which Add/Replace options you selected, the incoming record 
will be rejected, or the existing record will be modified, replaced, or deleted. 

To be considered a match, every entry in the matching field in the import record must match an 
entry in a record in the textbase. To ensure that you change only the intended records, it is best 
to use a non-repeating field that is likely to contain unique information. An Automatic Number 
field is ideal, because it contains unique numbers. However, any unique field will do. To ensure 
that the correct record is modified, you can match on more than one field.  
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If you do not check for matching records (that is, you do not select the Check for Matching 
Records check box), all of the records in the import file will be added to the textbase. This is 
appropriate if you are adding records to an empty textbase, or you are sure that the records in the 
import file do not duplicate records in the textbase or import file. 

If Match is Found group 
When checking for matching records, select an option button from this group to specify what 
happens to a record when a match is found: 

• 

• 

Reject New Record. Use this option to avoid duplicating existing records when adding new 
records to a textbase. If any records are rejected, they will be copied to the exception file. 
After the import, you can make corrections to the exception file to ensure that the records 
will be accepted, then import the corrected exception file. 
Append Field Entries. Use this option to add information to a record without changing any 
existing information. This is how you merge fields in duplicate records. If the textbase 
record contains fields that are not in the import file record, those fields remain unchanged. 
Look at the following example to see how an existing record is changed. The ID field is 
used for matching. 

Record before Import Import File Record after Import 
ID 15 
FRUIT Blueberry 
DATE 15-Feb-2003 

ID 15 
FRUIT Apple 
; Orange 
$  

ID 15 
FRUIT Blueberry 
; Apple 
; Orange 
DATE 15-Feb-2003 

• Replace Fields. Use this option to change information in the textbase. Fields in the 
incoming record replace fields in the existing record. Fields that are not in the import file 
remain unchanged. In the following example, the ID field is used for matching. 

Record before Import Import File Record after Import 
ID 15 
FRUIT Blueberry 
DATE 15-Feb-2003 

ID 15 
FRUIT Apple 
; Orange 
$  

ID 15 
FRUIT Apple 
; Orange 
DATE 15-Feb-2003 

• 

• 

Replace Old Record. Use this option to replace existing records with updated versions of 
records. 
Delete Old Record. Use this option to delete existing records from a textbase. The import 
file shown below will delete records with IDs 12 and 43: 

ID 12 
$ 
ID 43 
$ 
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If Match is Not Found group 
Select an option button from this group to specify what happens when a match is not found for a 
record in the import file.  

• 
• 

Accept New Record. Select this option to allow the record into the textbase. 
Reject New Record. Select this option to reject the record (and copy it to the exception file, 
if you are using one). 

Note: DB/TextWorks disables options to prevent combinations that do not make sense. 

Validation Tab 
Use the Validation tab to specify how to handle incoming records that do not conform to the 
content validation applied to one or more fields in the textbase structure. Select one of the 
following option buttons: 

• 
• 
• 

Reject Overrides. The record will be rejected. 
Accept Overrides. The record will be allowed in, even if it does not meet validation. 
Accept Overrides & Update Validation Lists. The record will be allowed in and a new 
entry will be added to the validation list. 

Important! The Accept Overrides and Accept Overrides & Update Validation Lists options 
require that the field(s) permit overrides and/or updating the list (this is specified in the textbase 
structure). In addition, the current password must permit the updating of lists. Click the Help 
button on the Validation tab for more information about each option. 

Exception File Tab 
An exception file is a text file that contains records that are rejected during an import. 
DB/TextWorks copies rejected records, in their entirety, to the file and precedes each record 
with a comment line that explains why it was rejected. You can correct records in the exception 
file and then import the corrected exception file into the textbase. For example, you could fix the 
typographical error in the exception file below and then import the corrected exception file: 

!**Entry in field 'Subject' not found in validation list: Computeers 
Title Cracking the Code 
Author Ortiz, Conrad 
Subject Computeers  

Use the Exception File tab to specify an exception file. The Write Rejected Records in 
Exception File check box is selected by default and is followed by the name and location of the 
file that will be used. By default, exception files have the same name and location as the import 
file, and use file extensions starting with .X01 (such as FILE.X01). To change the name or 
location of the file, click the Exception File button to open the Specify Exception File dialog 
box. 
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If records are rejected during an import operation, the exception file opens automatically when 
you click OK on the completion message. You can also use any text editor or word processor to 
open an exception file. You do not have to edit or delete comment lines, because lines preceded 
by an exclamation point are ignored during an import. Be sure to save the file as a text file after 
editing it. 

You import a corrected exception file the same way you import any file. Choose Exception 
Files (*.x*) from the Files of type drop-down list on the Select Import File dialog box to display 
exception files. 

Strip Leading Spaces Tab 
Use the Strip Leading Spaces tab to specify whether leading spaces appear. Select the Strip 
Leading Spaces check box if you want to remove leading spaces. 

Leading spaces are spaces in the import file at the beginning of continuation lines, immediately 
after a new entry boundary, and after line breaks in the data. Keep leading spaces if you want to 
retain formatting in the import file, such as margins or indentation created by spaces. Strip 
leading spaces if you want to remove the excess spaces. 

Import Method Tab 
Use the Import Method tab to determine the speed of the import and whether other users of the 
textbase can access the indexes while you are doing an import. Specify an import method by 
selecting one of the following option buttons: 

• 

• 

Interruptible Import. This option is the default. Use it in the following situations: 
– To obtain the fastest import when loading small files, or files that contain just one 

record each. 
– To retain the ability to interrupt the import quickly. 
– To allow others sharing the textbase while you are importing to perform operations that 

use the indexes (for example, searching and editing) during the import. 
Express Import. This option is designed for importing large files of new records during 
off-peak hours. It is the fastest method to use when importing files that contain many new 
records, but may make it difficult for others to use the textbase. Do not use Express Import 
if you are checking for matching records because it can result in slower imports. If you 
select Express Import, the settings on the Add/Replace Options tab are disabled. Express 
Import is not available while using Deferred indexing (File>Change Indexing Mode). 
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Express Import does most of its work in memory. Rather than repeatedly writing 
information to disk, Express Import grabs the indexes once and does not release them until 
the entire import is done. This means that others sharing the textbase cannot perform record 
operations, such as searching and saving, until the import is complete. It also means that 
interrupting an import can be time-consuming—it may take a while before an interrupt 
request is processed. 

Note: Decreasing the size of the Express Import buffer may improve Express Import speed. 
Typically, Express Import appropriates as much memory as possible to provide maximum 
speed. However, if you find that Windows is swapping a lot when using Express Import, 
you can change the size of the buffer by adding ExpressImportBuffer= to the 
INMAGIC.INI file. For example, if you set it equal to 4096, the buffer will be 4096KB, 
even if there is more memory available (and less if that amount of memory is not available). 

Interrupting an Import 
There are several reasons why you might want to interrupt an import. You might notice that 
most of the records are being rejected, which could indicate a problem with validation or the 
format of the import file. You might decide that you do not want to wait for the import to finish, 
especially if you are using Express Import, which prevents others from using the textbase. Or 
you might decide that you selected the wrong options or file to import. 

To safely interrupt an import without harming the textbase, click the Stop button on the Import 
Operation Status dialog box or press Enter. You may notice a slight delay while DB/TextWorks 
finishes processing information held in memory and writes it to disk. Note that if you are using 
Express Import, the delay could be more significant. 

Important! Never reboot the machine during an import. Rebooting during an import can 
damage the textbase. 

When an import is interrupted by a power failure or reboot, the textbase may be left in a 
damaged state. DB/TextWorks displays an error message when you open a damaged textbase. 
Damage can involve bad pointers, missing information, or both. These are serious problems that 
affect the integrity of your textbase.  

You can continue to search a damaged textbase without making any of the problems worse. 
However, you should avoid performing maintenance activities (adding, editing, and so 
forth) because of the risk of increasing the damage. The only way to fix the damage is to 
restore a healthy backup and repeat any maintenance activity that occurred since the backup was 
created, or use Recover Textbase. 

Read about diagnosing and fixing problems in Chapter 2, “Creating a Textbase,” the 
“Diagnosing and Fixing Problems” section. 
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Importing Documents 
Use File>Import Document to place the complete text of a document (such as a letter, memo, 
fax, or EMail message) in a field. You can import multiple files at one time. Each file is loaded 
into a separate record, with the complete document text becoming one field entry. Lines can be 
any length and line breaks are retained. 

DB/TextWorks lets you import plain text documents. However, if your workstation operating 
system supports it, you can also extract and import the text from documents in other formats 
(such as, Microsoft Word documents). DB/TextWorks uses IFilter technology to extract text 
from documents. IFilter technology is installed with Microsoft Index Server, which comes with 
Microsoft Windows 2000/XP operating systems. This technology is also supported on Windows 
NT 4.0 systems that have the Windows NT 4.0 Option Pack installed. 

The software will only extract text from documents in formats other than plain text if the 
workstation that initiates the import meets the operating system requirements mentioned above 
and has the appropriate IFilter is installed. 

Besides Microsoft, other vendors have created IFilters for their software products and make 
them available for download. For example, Adobe has an IFilter that lets you import its Portable 
Document Format (PDF) documents. 

If IFilters are installed on the workstation, the Use Word Processing Import Filter check box 
on the Import Method tab (choose File>Import Document) is enabled. Select it to use the 
IFilter that is appropriate for the document(s) you plan to import. 

Besides loading document text, you can also load the file name into a separate field, to associate 
document text with its source file name. If you plan to modify existing records, you must use the 
file name for matching, to determine which records to add or change. Records that you want to 
modify must already include a Term-indexed Text field containing the name of the document 
file. If necessary, edit the textbase structure before importing documents. Then, when you do the 
import, the file name can be loaded into that field for new records, and used for matching to 
modify existing records. 

During an import, records that do not meet validation requirements are rejected. (It would be 
very unusual for a field that holds document text to be validated. However, it is common for a 
field that holds the name of a document to have Unique Entries Only validation, and other 
fields may have Field Entry Required validation.) You cannot override validation, and 
exception files are not used. Rejected documents are noted in the textbase log file. 
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To import document(s) 
1. Choose File>Open and open the textbase into which you want to import one or more 

documents. 

2. Choose File>Import Document to open the Select Document Files dialog box. 

3. Select one or more files to import, then click the Save button to open the Import Document 
Options dialog box. 

Note: You may have to navigate to the file(s) you want to select. If you want to select more 
than one file from the same folder, use Ctrl+Click or Shift+Click to select the files. 

4. On the Document Fields tab, specify the Fields for Document File(s): 

– Field for Text. Select a Text field from this drop-down list to hold incoming document 
text. 

– Field for File Name. Select a Term-indexed Text field from this drop-down list to hold 
the file name. If you choose to check for matching records (using the Add/Replace 
Options tab), the file name will be used for matching, to determine which records 
should be changed. If you do not want to place the file name in a field and you are not 
adding or replacing documents in existing records, select <none> from the Field for 
File Name drop-down list. 

– Include Path for Document Name. Select this check box if you want to include the 
path as part of the file name (if you selected a field for the file name). 
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5. On the Add/Replace Options tab, select the Check for Matching Records check box to 
control how records are modified. (If this option is disabled, go to the Document Fields tab 
and make a selection from the Field for File Name drop-down list.) A match is determined 
by comparing the document file name with information specified in the field selected in 
Field for File Name drop-down list. If a match is found, the document is handled according 
to the option you select in the If Match is Found group. 

Important! If you do not check for matching records, a new record will be created for each 
document, even if there is already a matching record. 
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6. Select the matching option you want from the If Match is Found group: 

– Reject New Record. Adds new documents to the textbase, but avoids duplicates. 
– Append Field Entries. This option is rarely used, because you would not want to 

append the new version of a document to the old. 
– Replace Fields. Replaces an older version of a document with a newer one. All other 

fields remain unchanged. 
– Replace Old Record. Replaces existing records with updated versions of records. 

Important! This option replaces existing records. If you are trying to update old 
versions of documents, and you have any information in the record other than the file 
name and document text, select the Replace Fields option button instead, to ensure that 
you retain the other fields. 

– Delete Old Record. This option is rarely used. If an incoming document matches an 
existing record, the existing record is permanently deleted. 

7. Select the option you want from the If Match is Not Found group: 

– Accept New Record. Adds the new document to the textbase. 
– Reject New Record. Rejects the document if there is not a match in the textbase. 

Exception files are not used. For details about rejected files, examine the textbase log 
file after the import. 

8. On the Strip Leading Spaces tab, select or clear the Strip Leading Spaces check box to 
specify how to handle spaces at the beginning of lines in the document. Keep leading spaces 
to retain formatting such as margins or indentation created by spaces. Strip leading spaces to 
remove excess spaces.  

9. On the Import Method tab, select an option button to specify which type of import to use: 
Interruptible Import or Express Import. See “Import Method Tab” on page 119 for more 
information. 

10. [Optional] If you plan to import documents in formats other than plain text, and you have 
the appropriate IFilter installed, select the Use Word Processing Import Filter check box. 
For more information about IFilters, see the “Importing Documents” section prior to these 
steps. 

11. Click OK to begin the import. When the import is complete, you will see a message 
indicating the import file name (if you only imported one document file) or the directory (if 
you imported multiple document files), and the results of the import. 

Note: You can safely interrupt an import by clicking the Stop button on the Import Operation 
Status dialog box. Note that one or more complete documents may have been successfully 
imported before you stopped the import. Never reboot the machine during an import. See 
“ ” on page 120 for more information. Interrupting an Import
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Exporting Records 
Follow the steps below to export records to a text file. Records are exported in the specified 
format (tagged, delimited ASCII, or XML), and as if deferred updates had already been posted. 
Only information in the primary textbase is exported. Fields hidden by the current password will 
not be exported. 

To export records 
1. Choose File>Open and open the textbase that contains the records you want to export. 

2. If you plan to export records in sorted order, search for the records you want to export, then 
choose Display>Sort Report, and sort the records. For more information, see Chapter 5, 
“Working with Forms,” the “Sorting Records” section. 

3. Choose File>Export to open the Export File As dialog box. 

4. Specify a name (default file extension is .DMP) and location for the export file that will be 
created, then click the Save button to open the Export Options dialog box. 

5. On the File Format tab, specify the appropriate file format: 

– Inmagic Tagged Format. The text format for sharing files among Inmagic textbases, 
explained on page 111. 

– Delimited ASCII Format. Values are separated by commas, tabs, or other characters. 
This format is commonly used to share information with other applications. If you 
select this option button, the dialog box expands so you can specify which characters to 
use to indicate field separators and other delimiters. The options you select depend on 
the application into which you plan to import the file. For an explanation of delimiter 
options see “ ” on page 113. Delimiter Options

– XML. Used for structured documents and data on the Web. Extensible Markup 
Language (XML) uses tags, like HTML, but offers greater flexibility because it gives 
you the ability to define custom tags. 
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6. If you selected Delimited ASCII Format in the previous step, select the Store Field 
Names in First Row check box if you want the first line of the export file to contain field 
names. If you selected a different export file format in the previous step, go to the next step, 
as this check box is not enabled. 

7. On the Records to Export tab, specify whether you want to export the records found by a 
search or all the records in the textbase by selecting the appropriate option button: Export 
Current Record Set or Export Entire Textbase. Select the Use Current Sort check box if 
you want to export the current set using the current user-specified sort. This check box is 
unavailable if there is no user-specified sort. If this box is not selected, records will be 
exported in unsorted order. 

8. On the Fields to Export tab, specify the fields you want to export: 

– Export All Fields. Exports all of the fields in the textbase (except those hidden by a 
password). 

– Export Subset of Fields. Exports only the fields you specify. If you select this option 
button, the remainder of the dialog box becomes enabled. Move the fields you want to 
export from the Available Fields list to the Fields to be Exported list. Fields will be 
exported in the specified order. 

9. Click OK to begin the export. 
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Dumping Records to a File 
Use Manage Textbases>Dump Textbase to copy record information from all fields in all 
records in the primary textbase to a text file in Inmagic tagged format. 

Tip! Dumping a textbase is the easiest way to back up records and should be used as part of your 
regular maintenance routine. Because pending updates are not included, Dump Textbase 
provides a way of backing up a textbase prior to posting deferred updates. 

Dumping a textbase is also a way of retrieving records if the textbase becomes damaged and you 
are unable to open it. In many cases, you can dump records even if you cannot open a textbase. 
Diagnosing and fixing problems is explained in Chapter 2, “Creating a Textbase.” 

To dump records 
1. Close any open textbase (choose File>Close). All other users must also close the textbase 

containing the records you want to dump. 

2. Choose Manage Textbases>Dump Textbase to open the Dump Inmagic DB/TextWorks 
Textbase dialog box. 

3. Select the textbase containing the records you want to dump and click Open. If the textbase 
has passwords assigned, you are prompted for the Master password. The Specify Dump File 
dialog box opens. 

4. Specify a name (default file extension is .DMP) and location for the file that will be created 
and click Save. 

Note: When loading a new textbase, the software looks for the extension .DMP by default. 

5. Click OK to dismiss the message indicating that the dump operation is complete. 
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Loading Records into a New Textbase 
The Load New Textbase feature is intended primarily as a recovery mechanism, to be used on an 
empty textbase or in situations where you are sure records will not be duplicated. For example, if 
you have to recreate a textbase structure, you can use Manage Textbases>Load New Textbase 
to move all of the dumped or exported record information into the new, empty textbase. Load 
New Textbase is commonly used after Dump Textbase. 

Important! Loading a new textbase does not check for matching records or validation. This 
operation may result in duplicate records when used on a textbase that already contains records. 
Loading a new textbase (choose Manage Textbases>Load New Textbase) and importing 
(choose File>Import) are two very different operations. Do not use them interchangeably. 

Load New Textbase automatically adds all of the records to the textbase without checking for 
matching records, validation, or strict fields. It assumes the file is in Inmagic tagged format, and 
uses Express Import and Exclusive Textbase Access, locking others out of the textbase during 
the load. Computed and Automatic fields are treated as text (that is, DB/TextWorks does not 
change incoming values or create new values for Computed and Automatic fields). Rejected 
records are copied to an exception file, which has the same name and location as the dump file 
you loaded, with a file extension such as .X01, .X02, and so forth. 

To load records into a new, empty textbase 
1. If you have a textbase open, close it by choosing File>Close. All other users must also close 

the textbase into which you want to load records. 

2. Choose Manage Textbases>Load New Textbase to open the Load Inmagic 
DB/TextWorks Textbase dialog box. 

3. Select a new, empty textbase and click Open. If the textbase has passwords, you are 
prompted for the Master password. 

4. On the Select Dump File dialog box, select a file to load. DB/TextWorks looks for files with 
the file extension .DMP, but you can specify a different extension, such as .TXT or .ASC. 

5. Click Open to start the loading process. 
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Recovering a Textbase 
Recovering a textbase involves dumping its contents to an ASCII file, making an empty copy of 
the textbase, and loading the ASCII file into the copied textbase. You can perform the necessary 
steps individually, or, if you have enough disk space, DB/TextWorks can perform them for you. 

The Recover Textbase function is most often used when a textbase is damaged. 

The Recover Textbase and Dump Textbase commands ignore any Deferred updates. If you can 
open the textbase, print the Deferred updates to a file (choose Maintain>Deferred Updates) 
before proceeding with the recover operation. 

Tip! Before you attempt to recover a textbase, it is a good idea to back up the textbase or copy it 
(choose Manage Textbases>Copy Textbase) to a safe place, in the event you need it later. 

You can use either the Single-Step Recovery procedure or the Multi-Step Recovery procedure.  

To perform a Single-Step Recovery 
If you have enough space on your hard disk, you can use Manage Textbases>Recover 
Textbase to perform a single-step recovery. You will need about three times as much empty 
space as is currently occupied by the textbase you are recovering, on the same hard disk as the 
one holding that textbase. 

 Close any open textbase, choose Manage Textbases>Recover Textbase, then specify a 
textbase. 

If you cannot free up enough space, follow the procedures described below instead, moving files 
to other devices between steps as needed. 

When the operation is completed, your old textbase will still exist, with a new backup name. 
(The completion message tells you the new name.) Note that if you dumped the textbase before 
performing the recovery, you will have two backups (the .DMP file you created prior to the 
recovery and the one that remains after the recovery). 

If the textbase is large and resides on a network drive, copy the textbase to a local hard drive 
with sufficient space before using Recover Textbase. Then copy the textbase back to the network 
drive when the operation is complete. This will significantly decrease network traffic and 
improve performance. 

Note: If you can open the damaged textbase and it has unposted deferred updates, use 
Maintain>Deferred Updates to export New Records and Modified Records to one file, then 
Deleted Records to another file. After the recovery is complete, import each file with the 
appropriate matching options (Replace Old Record and Delete Old Record, respectively). 
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To perform a Multi-Step Recovery 
Use the Multi-Step Recovery procedure if: 

• 

• 
• 

The damage is in the .TBA file (for example, a public form). You need to clear the Copy 
Public Textbase Elements check box. 
You need to modify the structure before importing the records. 
There is not sufficient space available to perform the single-step recovery explained above. 

Before performing a dump and reload operation, choose Manage Textbases>Check Textbase 
and try to repair problems. If the textbase is still damaged, follow the procedure below to recover 
a damaged textbase. 

1. If you have not already done so, copy records from the damaged textbase using Manage 
Textbases>Dump Textbase. 

2. Create a new textbase by copying the structure of the damaged one. 

– Choose File>New Textbase. On the Specify New Textbase dialog box, name the new 
textbase. You cannot use the same name as the existing damaged textbase, but you can 
rename the new textbase later. Click Save. 

– On the Create Textbase Structure dialog box, select Copy an Existing Inmagic 
Textbase Structure or Restore from Textbase Structure Backup File and click OK. 
Use the next dialog box to select the existing damaged textbase or a .TBB file to use as 
the basis for the new textbase structure, then click Open. (When prompted, copy the 
user file, too.) 

– Follow the prompts to specify a Master password (if required) and to copy validation, 
passwords, elements, and so forth. DB/TextWorks creates a new textbase. The textbase 
does not have any records in it. If you copied textbase elements, the textbase includes 
any forms, query screens, sets, and record skeletons that were saved in the textbase file. 

– Close the textbase by choosing File>Close. 
3. Load records into the new empty textbase. Choose Manage Textbases>Load New 

Textbase and load the dumped file from step 1 into the new empty textbase that you just 
created in step 2. You now have a new textbase, complete with records. See the previous 
section for more specific details about loading a textbase. 

4. Delete the original damaged textbase files by choosing Manage Textbases>Delete 
Textbase. All of the files for a textbase are in the same directory and have the same name, 
differentiated by extensions. (Also delete the user file.) 

5. Rename the new textbase back to its original name by choosing Manage 
Textbases>Rename Textbase, if applicable. 

6. If you have stored sets in your textbase or user file, open the new textbase and choose 
Sets>Refresh Sets to rebuild the sets. If others use this textbase and have private sets, ask 
them to do the same. 

Note: Refresh Sets performs the search again; it does not retain any omissions specified 
using Omit Record. 
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Chapter 4: Searching a Textbase 

Searching in DB/TextWorks is the process of looking for information in a textbase. A search, or 
query, is a request to find all of the records that match specific requirements. For example, you 
might search for all biographies of Mark Twain published between 1990 and 1999. 

Overview 
There are two ways to search a textbase: You can use a query screen, or you can use a simple 
command language. Both methods are introduced below and explained in detail later in this 
chapter. 

Using a Query Screen 
When you open a textbase (choose File>Open) that contains records, the Query window opens 
and displays a query screen (a form for doing searches that contains query boxes). Each query 
box on the screen typically represents one or more indexed fields that you can search. The screen 
may also contain other information, such as fixed text and pictures, as well as script buttons. To 
find records, type information in the query boxes, then choose Search>Execute Query, or press 
the Enter key, or click the Execute Query button on the toolbar. The query illustrated below 
searches for projects about graphics with a budget under $10,000 that are not located in New 
Hampshire.  

You can toggle the Boolean buttons between AND, OR, and NOT.
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Using Command Queries 
Command queries are an alternative to using a query screen. Use a Command query when you 
need to specify especially complex criteria, or simply if you prefer typing commands. Just open 
the Command Query window and type information using the syntax described in this chapter. 

For example, here is the command equivalent of the previous search: 

 
For more information about Command queries, see “ ” on 
page 184. 

Performing a Command Query
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Terminology 
The following table explains the terminology used in this chapter. 

Term Definition 
Word A series of characters without spaces or punctuation. 
Phrase Two or more words separated by spaces (for example, local area 

networks) or, in some cases, punctuation (for example, MS-DOS). 

Term A word or phrase that is also a complete entry in a field. Date and Number 
field types typically are Term indexed, as are fields that hold discrete pieces of 
information, such as a complete name or the title of a book. 

Search item A single search component. Every search is made up of one or more search 
items. An item can be a word, phrase, term, comparison, range, or proximity 
request. For example, >100 (greater than 100) is a search item. You can 
specify one or more search items in a query box, or in multiple boxes, or in a 
Command query. You can connect search items using Boolean symbols (&, /, 
!). 

Search criteria All of the information typed or pasted into a Query or Command Query 
window to find records. 

Set A list of records found in a search, together with the criteria that were used to 
perform the search. Sets can be saved, combined, browsed, printed, and 
re-executed in DB/TextWorks. 

 
Depending on how a field is indexed, you can search for a word, phrase, or term. You cannot 
search unindexed fields. You can use comparisons, ranges, Boolean logic (AND, OR, NOT), and 
many other methods to find exactly the records you want. When you start the search, 
DB/TextWorks looks in the textbase to find records that match. It returns a set of records, which 
you can display, edit, print, and so forth. 
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Using a Query Screen to Search for Records 
The simplest and most common way to search for records is to use a query screen. You just type 
or paste information in the query boxes, then execute the query. Each query box searches one or 
more fields, depending on how the screen was designed. For example, a query box labeled 
Address could search four fields: Street, City, State, and Country. When searching with a query 
box that includes multiple fields, an implicit OR is used between the fields (for example, find 
Elm in the Street OR City OR State OR Country field). 

Tip! A common practice is to design a query screen that includes one query box that searches 
many of the fields in the textbase and to label it something like Type any word or phrase. Use 
a query box like this when you are not sure which field contains the item you want to find. 

Unindexed fields never appear on a query screen because they cannot be searched. Use the 
examples in the table below to help you construct search criteria for the steps on the following 
pages. 

Type this… To find… 
Computer The word computer 
comput* Variations such as computers and computation 
=los angeles That complete term (exact entry, with no other text) 
sales meeting That phrase (those words, in that order) 
sales / marketing Either word (or both) 
sales & marketing Only records that contain both words (Records that contain 

just one of the words will be ignored.) 
java ! coffee Java but not coffee  
sales p5 marketing Sales preceding marketing by 5 words or fewer 
sales w5 marketing Sales within 5 words of marketing (before or after) 
=@DATE-7 The date one week ago 
<1998 Dates before January 1, 1998 (You can use the symbols 

<, <=, >, >= with dates, values, or text.) 
1:99 Values between 1 and 99, inclusive (Use with dates, values, 

or text.) 
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To search for records using a query screen 
1. Choose Search>Query Screen. (If the window is already open, skip this step.) 

2. Type search criteria in a query box (or several query boxes), or, with your cursor in a query 
box, press F3 to select items from a list. Using F3 eliminates guesswork because you can 
choose indexed words and terms on a dialog box. For more information, see “

” on page 138. 
Search 

Techniques

Note: Punctuation and case are not important except when searching a Code or UDC field 
type. 

3. [Optional] Toggle the Boolean buttons (AND, OR, NOT) between boxes to indicate how to 
combine criteria. Read about Boolean searches beginning on page 141. 

4. Choose Search>Execute Query, click the Execute Query button  on the toolbar, or 
press Enter. 

Most queries take only a few seconds. To interrupt a long search, click the Stop Executing 
Query button on the Executing Query dialog box or press the Esc key. 

If the query finds records, the Select Search Results Window dialog box opens. 

 
5. Select an option button to choose the window in which you want to display the search 

results. 

Tip! After you select a window on this dialog box, DB/TextWorks maintains this setting 
until you do another search and choose a different window. The software then maintains the 
new setting. To prevent this dialog box from appearing every time you do a search, select 
the Always use this option without asking check box. If you later want to choose another 
window in which to view records, choose Tools>Options>Display to reset your default. 

6. Click OK. 
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The following illustration shows records in the Report window: 

 

Search 
highlighting 
shows the 
search items 
found. 

Use the 
navigational 
buttons to 
move from 
record to 
record. 

Note: How much information you see and how it is formatted depend on which form is selected. 
To use a different form, choose Display>Select Forms or click the Select Form for this Window 

button  on the current window’s toolbar. You may want to select Window>Fit Window to 
Form after changing forms. 

The Query window remains open until you close it. To do another search, you can click the 

Query window (or choose Search>Query, or use the Query Screen toolbar button ) and edit 
the criteria; or clear the criteria by choosing Search>New Query (or using the New Query 

toolbar button ). 

136 Chapter 4: Searching a Textbase 



Using Records Found by a Search 
Records found by a search make up the current set, even if you choose not to display them. The 
following table shows some of the operations you can perform after a search. 

To… Do this… 
Navigate Use the Display menu options (Next Record, Previous Record, First 

Record, Last Record) or the navigation buttons on the Report window 
toolbar. 

Display one record Select a record in the Report window and choose Display>Display 
Record to see detailed information for that record. The form selected 
for the Display window determines how the information appears. 

Edit records Select a record and choose Records>Edit Record. Or, to make the 
same change to all of the records in the current set, use Records>Batch 
Modify. For more information, see Chapter 3, “Working with Records,” 
the “Using Batch Modify” section. 

Omit a record Choose Sets>Omit Record to remove the selected record from the 
current set. Omitting a record does not delete it from the textbase.  

Sort records Choose Display>Sort Report. 
Print a report Choose File>Print. To print just one record, open the Display or Edit 

window prior to choosing Print. 
Send Report as 
Mail 

Choose File>Send Report as Mail. The Send Report as Mail dialog 
box opens and you have two options. You can send the whole report as 
mail to one or more people. Or, you can send each record in the report 
to the EMail address specified in a field in the record. You can also 
specify attachments. For more information, see Chapter 5, “Working 
with Forms,” the “Sending a Report as Mail” section. 

Write Report to 
File 

Choose File>Write Report to File to write formatted record 
information to a file in Plain Text (ASCII), Rich Text Format (RTF), or 
Hypertext Markup Language (HTML) format. 

Export records Choose File>Export to export records to a file in Inmagic tagged, 
delimited ASCII, or XML format. 

Save the search Choose Sets>Save Set to save the current search results and criteria. 
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Search Techniques 
This section explains the many techniques you can use to perform a query, including using 
search operators. For a table summarizing the search operators you can use, see the online help. 

Searching for Words, Phrases, and Terms 
You can search for a word or phrase if a field has a Word index. You can search for a term if a 
field has a Term index. You cannot search unindexed fields. To see how a field is indexed, 
choose Display>Textbase Information. 

• 

• 

To search for a word or phrase, type a word or phrase, such as animation or web 
design. With your cursor in a query box, you can select words from a list by pressing F3 
or choosing Edit>Browse Choices, and selecting the Word List option button. 
To search for a term, type the term preceded by an equal sign, such as =voice 
recognition. The equal sign tells the software to search the Term index for an exact 
match, except for punctuation and case. To retrieve entries that begin with the term but also 
include other text, type an asterisk (*) as the last character of the search item, such as 
=computer design*. You can also select terms from a list by pressing F3 or choosing 
Edit>Browse Choices, and selecting the Terms List option button. 

Picking Words and Terms from an Index (F3) 
Instead of typing words or terms, you can pick them from a list by placing the cursor in a query 
box and pressing F3. When you press F3, you can see the actual Word and Term indexes for the 
field(s) searched by the current box, or the thesaurus connected to a field. 

In DB/TextWorks, this technique is called browsing. It eliminates guesswork and helps you to 
do more accurate queries because you can see and paste actual record information. The Term or 
Word index is actual indexed information from the textbase. Pasting information normally 
guarantees a match, so you will find the records you want. 

To browse and paste items from indexes 
1. Place the cursor in a query box or the Command Query window and press F3, or choose 

Edit>Browse Choices. The Query Choices Browser opens. 

Tip! You can resize the Query Choices Browser to see long entries. 

2. Select the field you want to search from the Field drop-down list. Note that for query box 
searches, the Field drop-down list only includes the fields in the selected query box. If the 
query box only has one field, it will be selected by default. For a Command query, the Field 
drop-down list includes all indexed fields. 
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3. In the List Shows group, select one of the following option buttons, depending on the type 
of information you want to browse: 

– Terms List. Shows the selected field’s Term index. 
– Words List. Shows the selected field’s Word index. 

Note: When viewing the Words List for a text-like field (that is, a field that is not a 
Number or Date field) in the Query Choices Browser, the list automatically scrolls to 
the start of the A’s if the field contains any numeric words. 

– Thesaurus. Shows the selected field’s thesaurus, if one is connected to it. A thesaurus 
lets you maintain a controlled vocabulary of terms and the relationship among terms. 

Note: You can switch between the indexes and thesaurus, as needed. Note that some fields 
may not have both types of indexes and a thesaurus, so one or more of the option buttons 
may be unavailable. 

4. Depending on the option button you selected in the previous step, select a word, term, or 
thesaurus entry from the Choices List and click the Paste button to paste it into the query 
box on the query screen. (You can also double-click the entry paste it.) You can select and 
paste as many items as you want. 

Note: If a field does not have a Term index (but it does have a Word index), and that field is 
connected to a thesaurus, the Thesaurus option button will not be enabled when browsing 
choices on a query screen. This is because a Term index is required to support exact match 
(=) searches. 

 

Select a field to browse 
(if the query box 
searches more than one 
field). 

Display the Term or Word index, or 
the thesaurus connected to a field.

Optionally, print the list or 
save it as a text file. 

Select a word or term 
and click the Paste 
button. 
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5. The item you paste appears in the query box: 

 
Now you can execute the query or continue pasting words and terms. The Query Choices 
Browser remains open (until you close it or execute the query) so you can click in another 
box to see its indexes. You do not have to close the dialog box first. 

Finding Word Stems 
To find text that begins with specific characters, type an asterisk at the end of a word. For 
example, to find words that start with com (such as, computer and commerce), type com*. 
This type of search is sometimes called a truncation search. You can include an asterisk at the 
end of more than one word (for example, comput* tech*). The asterisk used alone retrieves 
all records with any words in the field. 

Doing Comparison and Range Searches 
You can use the comparison and range operators described below when searching a 
Term-indexed field. 

Operator Example  Meaning 
= =local area networks  Equal to (exact match) 
>  >5500 Greater than 
>=  >=5500 Greater than or equal to 
< <15-Jan-1998 Less than 
<= <=TX  Less than or equal to 
: 1995:2002 Within range 

An equal sign (=) tells DB/TextWorks to search the Term index for an exact match. 

Greater than and less than are typically used with numbers or dates, but you can also use them 
with text. Greater than (>) means “after” when used with dates and “alphabetically after” when 
used with text. Less than (<) means “before” when used with dates and “alphabetically before” 
when used with text. When used with a partial date, these operators search from the beginning of 
the date item. For example, <2003 means before January 1, 2003 and >2003 means after 
January 2, 2003. 

A range search (:) finds information within a range of dates, numbers, or letters. A range consists 
of two values, low and high, separated by a colon. If you use partial dates, DB/TextWorks uses 
the beginning of the low date and the end of the high date. For example, 1995:2002 finds all 
dates from January 1, 1995 through December 31, 2002, inclusive. 
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Using Proximity Searches to Find Words Near Each Other 
You can use proximity operators in a Word-indexed field to find one word within a certain 
distance of another word. Entry boundaries are ignored. 

You can include asterisks (for example, local* w3 network*). You cannot use proximity 
operators with phrases (for example, monroe w3 white house). 

Operator Example Meaning 
w# local w3 networks Find local within 3 words of networks 

(before or after). 
p# red p2 car Find red preceding car by 2 words or fewer. 

Doing Boolean Searches 
A Boolean search is one that combines criteria using logical AND-OR-NOT statements. You can 
use Boolean symbols (& / !) to join criteria within a query box, and you can toggle the Boolean 
buttons in front of query boxes to join multiple statements. 

Boolean 
button 

Boolean 
symbol 

 
Operation 

 
& Finds records only if they meet all of the criteria. AND searches 

find fewer records, because all conditions must be met.  

 
/ Finds records that meet any of the criteria. OR searches usually 

find the most records, because any specified condition can be 
met. 

 
! Excludes records from the search results. 

Using Boolean Symbols in a Query Box 
Use the symbols & / ! to represent Boolean AND, OR, NOT. If a query box contains several 
fields, they will all be searched. You can include or omit spaces around Boolean symbols (read 
about Boolean and range searches in the “ ” section beginning on 
page 191). You can include an asterisk at the end of any word to ensure that you find all 
variations of word stems (for example, sport* ! tennis). The following examples will 
help you get started. 

Troubleshooting Searches

This search finds people only if they speak both languages: 
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This search finds people who speak German or French (or both): 

 
This search finds people who speak German but not French: 

 
To combine Term searches with a Boolean symbol, repeat the equal sign (=) before each term:  

 

Tip! New users often make the mistake of using & (Boolean AND) when they should use / 
(Boolean OR). For example, if you search for dogs & cats, you will find records only if both 
words are present. Instead, search for dogs / cats, to find records about dogs or cats (or 
both). 

Toggling Boolean Buttons 
You can type information in two or more query boxes, then toggle the Boolean button (AND, 
OR, NOT) in front of a query box to determine how the result of the search in that box is 
combined with boxes already evaluated. To toggle a Boolean button, click it with the mouse, or 
use the Tab key to navigate to it and then use the Spacebar on the keyboard. The following 
search will find all books written by Smith that are NOT about baseball AND were published 
before 1995: 

The Boolean 
button for 
the 
Description 
box is set to 
NOT. 
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The person who designs a query screen may hide the Boolean buttons, in which case you cannot 
change them. If Boolean buttons are hidden, look at the status bar to see if the current box is set 
to AND, OR, or NOT. You may want to select a different query screen or redesign the screen to 
show the buttons. 

 

Query Evaluation Order 
Within a query box, criteria are evaluated from left to right. For example, red / white & 
blue finds items that are either red or white, which are also blue. You can use parentheses to 
control evaluation order, such as, red & (white / blue), which finds items that are red 
and white or red and blue. 

When you fill in more than one box, evaluation order matters only if OR searches are mixed 
with AND or NOT searches. In most cases, it makes sense to perform all OR searches before 
AND or NOT searches. To accomplish this, you can add a temporary query box (Search>Add 
Query Box), or you could do a Command query and use parentheses to clarify the order. 

In addition, if a NOT search is first in the query evaluation order, DB/TextWorks finds all 
records in the textbase, then performs the NOT exclusion. 

Boxes are evaluated based on the Tab order specified for the query screen. To avoid confusion, 
use the Query Screen Designer to ensure that the Tab order (Tools>Tab Order) matches the 
visual order of boxes on the screen.  
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Searching for Numbers 
Avoid using truncation (*) searches to find numbers in Number, Computed Number, and 
Automatic Number field types, or Text fields that file numbers numerically (under Special 
Filing). Use truncation searches only to find trailing text. Truncation searches will not find 
numeric values. For example, the search =35* will not find the value 357. In fields that use 
alphabetic filing, truncation searches work as expected. 

In fields where numbers file numerically, the comparison operators (for example, less than, 
greater than) work as expected. But they may return unexpected results in fields where numbers 
are filed alphabetically, because negative signs are ignored in alphabetic fields (-20 is the same 
as 20) and alphabetically filed numbers are interpreted character-by-character (100, 12, 2) not 
value-by-value (2, 12, 100). 

Searching for Dates 
DB/TextWorks is flexible when searching for dates and can retrieve a specified date even if the 
format you use in the query differs from that stored in the textbase.  

To find all dates in a certain month or year, type the partial date in any recognizable format. To 
find a particular date with or without trailing text, include the month, day, and year as part of the 
criteria. To retrieve only the date you specify, precede the date with an equal sign (=).  

To include the current date in a calculation that retrieves records based on dates, use @DATE. For 
example, the following will retrieve records created on the date one week prior to the date the 
search is performed. This type of search is particularly useful if you are saving the query to be 
performed again on a different day. 

 
 

This search… Finds… 
1999 All full or partial dates in 1999 
=1999 Entries that consist of the year 1999 alone 
August 1999 All full or partial dates in August 1999 
=August 1999 Dates that contain that month and year, but no specific dates  

(for example, will not find August 10, 1999) 
Aug 10 1999 That exact date with or without trailing text 
=Aug 10 1999 That exact date with no trailing text 
=@DATE-7 The date one week before today 
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Here are a few strategies to use when searching for dates: 

• Avoid using a forward slash to separate date components (such as, 3/4/1999), because 
the slash is interpreted as a Boolean OR symbol. If you want to use slashes, put quotation 
marks around the date. Otherwise, use spaces, dashes, or punctuation that cannot be 
misinterpreted in place of the forward slashes. For example, search for "3/4/99" or 
3 4 1999 or 3-4-1999. 

Note: To use forward slashes when searching for dates, use the SpacedRelOps=1 
parameter in the INMAGIC.INI file. For more information, see “

” on page 192. 
Boolean and range 

searches do not find the expected records

• 

• 

• 

Avoid using word, phrase, proximity, and truncation searches in Date fields, except to find 
trailing text. 
Comparison and range searches are particularly useful. For example, <June 1999 finds 
all dates before June 1, 1999 and 1996:1999 finds all dates from the beginning of 1996 to 
the end of 1999. 
To search for the current date, press F4, or choose Edit>Insert>Current Date, or type 
@DATE. 
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Searching Code and UDC Field Types 
When you search a Code or UDC field type, the search criteria must exactly match the record 
information as indexed. If you do not capitalize letters correctly or include the proper 
punctuation, you will not find the record. For example, a search for abc will not find ABC and a 
search for A 123 will not find A-123. (UDC field types are sensitive to punctuation, not case. 
Code field types are sensitive to both.) 

Code and UDC field types often include characters that DB/TextWorks interprets as having 
special meanings (for example, & / ! < > = : w# p#). To search for these characters, place single 
or double quotation marks around the search item, as shown in the following table. If you are 
doing a Term search, leave the equal sign outside of the quotation marks (for example, 
="A/Z"). 

If you want an asterisk, backslash, or quotation mark to be interpreted literally, precede it with a 
backslash. For example, to search for ab* without having the asterisk interpreted as a truncation 
symbol, type ab\*. Unless an asterisk is preceded by a backslash, it is interpreted as truncation, 
even inside of quotation marks. 

Tip! Use F3 and paste items from the indexes. The software adds any necessary quotation marks 
or backslashes automatically. 

The following table provides some examples of how to search Code and UDC field types. 

To find… In field type…   Search for… 
017:63 UDC "017:63" 

431.3"2" UDC 431.3\"2\" 

339.5(931) UDC "339.5(931)" 

629.12(*58) UDC "629.12(\*58)" 

d52-60 Code d52-60, or do a truncation search for d5* 
http://www.inmagic.com Code ="http://www.inmagic.com"  
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Punctuation and Case in Search Criteria 
Punctuation and case in query criteria are ignored for searching purposes, except in Code and 
UDC field types. For example, =Maxwell, Stephen finds all versions of the name, 
regardless of case or punctuation. If the search item includes characters that might be 
misinterpreted (for example, & / ! :), surround the item with quotation marks or replace the 
punctuation with a space. For example, search for "AT&T" or AT T to avoid having the & be 
interpreted as a Boolean AND.  

The SpacedRelOps= parameter in the INMAGIC.INI file determines whether spaces are 
required around a Boolean or range symbol (for example, whether you should search for ant / 
bee or ant/bee). For more information about this parameter, see page 192. 

Finding All Records 

To find all records in the textbase, click the Find All Records button  on the Main window 
toolbar or choose Search>Find All Records. Note that new, unposted records added using 
Deferred indexing are not included. 

Finding Populated or Empty Fields 
To find records that contain any information in a particular field, type =* by itself in a query box 
(or * if the field has a Word index but no Term index). For example, you may want to find all 
records that have any entry in the Author field. 

To find empty fields, type =* in a query box (or * if the field has a Word index only) and 
change the Boolean button in front of the box to NOT. For example, you may want to find all 
records in which the Author field is empty. 

Tip! If you frequently need to find empty fields, and you have so many records in your textbase 
that the above search takes a long time, there is a trick you can use. Assume you periodically 
want to find records with nothing in the Author field. Define a new Computed field whose 
formula is FCOUNT(AUTHOR). Populate this field by rebuilding its field index (Maintain menu) 
and selecting the Recompute Field Value check box. This field will then contain a number 
indicating the number of entries in the Author field. To find records having no author, search this 
field for the number 0. (Or, to find all records which do have an author, search this field for 
numbers >0.) 
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Searching a Textbase that Contains Link Fields 
You can search any indexed field in the primary or secondary textbase. To search a secondary 
textbase field, use a query screen that includes a box that searches that field. (Using F3 to paste 
query criteria is a good practice, because it eliminates guesswork when constructing the query.) 

A common misconception is that such a search will retrieve records from the secondary textbase. 
That is not true. Records retrieved by a search executed from within the primary textbase 
are always from the primary textbase, even when you search using a field from a secondary 
textbase. For example, assume you have a primary textbase that contains orders and a secondary 
textbase that contains customer information. Search for all orders placed by customer Fred 
Fripp. No matter which field you search, you are going to retrieve records from the primary 
textbase only. But when you retrieve Fred’s orders, you can see information from both textbases, 
if you want. To see secondary textbase information after you retrieve records, use a form 
that shows fields from the secondary textbase. You should design a special form for this 
purpose. 

Linking is a complex topic. For a better understanding of the issues involved, see Chapter 8, 
“Linking Textbases.” 

About DB/TextWorks Thesaurus 
A DB/TextWorks thesaurus is a textbase that lets you maintain a controlled vocabulary (also 
called an authority list) of terms and the relationships among terms. DB/TextWorks comes with 
a template that you can use to create thesaurus textbases. 

Note the following about DB/TextWorks thesaurus textbases: 

• Important! You must not rename or remove the original fields in a thesaurus textbase. 
Also, do not change the information in the Status field, as it contains information used by 
the thesaurus engine. 

• You should always use the Maintain Thesaurus window to add or modify individual 
thesaurus terms. Using this window assures that reciprocal relationships are established 
when necessary (which will not happen if you try to add or modify a thesaurus record by 
editing the thesaurus textbase directly). For more information about the Maintain Thesaurus 
window, see its help topic (click the Help button in the window) and the online help. 

• You can add more fields to a thesaurus, but keep in mind that they will not appear on any 
thesaurus window, dialog box, or page. 

• You can add a Master password to a thesaurus in order to protect the ability to make 
changes to the textbase structure, but you must also include a Silent password to grant users 
full write access to all thesaurus fields. 

• Only one person at a time can maintain a specific thesaurus textbase. 
• You can use a thesaurus as a validation list. For more information, see Chapter 2, “Creating 

a Textbase,” the “Use Thesaurus as Validation List” section, or the online help. 
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Thesauri can be shared across fields and non-thesaurus textbases. You can use a DB/TextWorks 
thesaurus to do the following: 

• Add new terms that you expect to use in bibliographic or other kinds of records. You can 
add terms by importing a file into the thesaurus, or by typing each term into the thesaurus. 
For more information on importing a file, see Chapter 3, “Working with Records,” the 
“Importing Records” section. 

• Add relationships, a scope note, and general notes. 
• Modify a thesaurus term and its relationships, scope note, and general notes. 
• Delete a term. 
• Reconcile terms and relationships using a Rebuild Thesaurus function. For more 

information about Rebuild Thesaurus, see its help topic (click the Help button in the 
window) and the online help. 

• Access and navigate (browse) a thesaurus from within a non-thesaurus textbase. 
• Select terms while browsing and paste them into a Query window or an Edit window. 

Basic Concepts 
A DB/TextWorks thesaurus has the following characteristics: 

• It is a monohierarchical thesaurus. (A given term may have only one broader term.) 
• DB/TextWorks uses a JavaScript-created user interface to facilitate the addition and 

maintenance of thesaurus records. Using this interface gives you the benefit of a great deal 
of error and validation checking that helps preserve thesaurus integrity. For example, the 
program automatically adds and edits reciprocal relationship records, checks for uniqueness 
of a term, and more. 

• Thesaurus records, called term records, are stored in a DB/TextWorks textbase. Each record 
represents one term, either a preferred term or a non-preferred term. A term may be a 
subject, product, trade name, company, and so forth. 

• Each term record may contain information about other terms that are semantically related. 
The relationships allowed in a DB/TextWorks thesaurus, and their reciprocal relationships, 
are: 
Broader Term (BT) ↔ Narrower Term (NT) 

Related Term (RT) ↔ Related Term (RT) 

Use (USE) ↔ Used For (UF) 

• You can create a complete term record and the program will automatically create the record 
for the reciprocal term(s) if they are not present in the thesaurus. Or, when a relationship 
between two terms is changed in one record, the program automatically updates the record 
for the reciprocal reference. 

• A thesaurus can have an unlimited number of terms. 
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• You use the Set Up Thesaurus dialog box to associate a thesaurus with a field in a textbase. 
You also use the Set Up Thesaurus dialog box to create a new thesaurus. For more 
information, see “ ” on page 151. Set Up Thesaurus

• You can connect one or more thesauri to a textbase, up to the number of Text and Code 
fields listed for that textbase. For example, if you have five Text and Code fields in a 
textbase, you can connect a thesaurus to each of these fields. You can connect a different 
thesaurus to each field, or you can connect the same thesaurus to each field, or any 
combination thereof. However, note that you can connect only one thesaurus per field. 

Thesaurus Construction Rules 
The following rules are applied by the program during thesaurus record creation, editing, or 
deletion. 

General Rules 
These rules apply to all thesaurus terms in a DB/TextWorks thesaurus: 

• Each term must be unique. When you attempt to add a term that already exists, even if the 
new term is a unique concept, the program will prevent the new term from being added. 
You must edit one or all of the terms to make each unique. For example, in the case of a 
homograph you might add parenthetical qualifiers to distinguish one from the other(s): 

Mercury (planet) 

Mercury (metal) 

Mercury (Roman deity) 

• When you add a term to the thesaurus, the program creates reciprocal records to that term or 
edits them as necessary to reflect the correct relationship. 

• When you edit a term record or a relationship to a term, the program automatically updates 
all relationship records, or creates them if they are not present in the thesaurus. Take, for 
example, the following pair of records: 

 

Term: Brakes 
   NT: Antilock brake system 
Term: Antilock brake system 
   BT: Brakes 

 
If you remove “Antilock brake system” as an NT of “Brakes,” the program will 
automatically remove “Brakes” as a BT of “Antilock brake system,” leaving only the two 
main terms with no relationships. 

• When you delete a term, you are deleting the term record only. The program will 
automatically update all the reciprocal term records to reflect the changed/canceled 
relationships, but it does not delete any other records. Relationships may be canceled, but 
term records may only be deleted explicitly by the user. 
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Preferred Terms 
The following statements apply to preferred terms in a DB/TextWorks thesaurus: 

• A preferred term may have only one broader term (BT). 
• It may have unlimited narrower terms (NT), related terms (RT), and equivalent (UF) terms. 
• It may only use other preferred terms for narrower, broader, and related relationships. 
• It may have a scope note and one other note of unlimited length. 
• It is allowed to exist in the thesaurus with no relationships, scope note, and so forth. This 

term will, by definition, be designated a preferred term. 

Non-Preferred Terms 
The following statements apply to all non-preferred terms in a DB/TextWorks thesaurus: 

• Non-preferred terms are defined by the presence of a USE reference in the term record. 
• A non-preferred term can have only one relationship, the USE reference. 
• Only one USE reference is allowed for a non-preferred term and it must refer to a preferred 

term. 

Set Up Thesaurus 
Note: You can open this dialog box only when you have a non-thesaurus textbase open. You 
cannot connect a thesaurus to other thesauri. 

To connect one or more thesauri to a textbase, choose Maintain>Set Up Thesaurus. You can 
do this for up to the number of appropriate fields in that textbase. Notice that only Text and 
Code fields are listed. If you have five such fields in a textbase, you can connect a thesaurus to 
each of these fields. You can connect a different thesaurus to each field, or you can connect the 
same thesaurus to each field, or any combination thereof. However, keep in mind that you can 
connect only one thesaurus to a field. 

Once you have connected a thesaurus to a field, when you use the Query window or the Edit 
window, you can browse the thesaurus for the connected field. With your cursor in the field, 
press F3, or choose Edit>Browse Choices, or click the Browse Choices toolbar button to open 
the applicable Browse Choices window. 
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To create a thesaurus and connect it to a field 
1. 

2. 

3. 

4. 

Choose Maintain>Set Up Thesaurus. 

Select a field from the Fields list. 

Click the Connect to New Thesaurus button to open the Specify New Thesaurus Textbase 
dialog box. 

Specify a name and location for the new thesaurus textbase, then click Save to return to the 
Set Up Thesaurus dialog box. DB/TextWorks creates a new empty thesaurus textbase in the 
specified location, and connects it to the selected field. 

Note: If you create your thesauri in the same directory as your textbases you can more 
easily move all of them to a new location. If thesauri are in a different location than the 
textbases, you may need to respecify the connections if you move them. 

5. 

6. 

Click OK to dismiss the confirmation message. 

Use the Maintain Thesaurus function to populate your new thesaurus. Note that you should 
always use the Maintain Thesaurus window to add or modify individual thesaurus terms. 
Using this window assures that relationships are established when necessary (which will not 
happen if you try to add or modify a thesaurus term by editing the thesaurus textbase 
directly). For more information about the Maintain Thesaurus window, see its help topic 
(click the Help button in the window) and the online help. 

Tip! Once you have created a thesaurus textbase, you can also populate it by importing data 
(for example, a validation list). For more information on importing a file, see Chapter 3, 
“Working with Records,” the “Importing Records” section. After importing records, use the 
Maintain Thesaurus window to build relationships and fill out the thesaurus terms, as 
applicable. 
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To connect an existing thesaurus to a field 
1. 

2. 

3. 

4. 

Choose Maintain>Set Up Thesaurus. 

Select a field from the Fields list. 

Click the Connect to Existing Thesaurus button to open the Select DB/TextWorks 
Thesaurus Textbase dialog box. 

Select a thesaurus textbase, then click Open to return to the Set Up Thesaurus dialog box. 
Notice that the thesaurus textbase name appears next to the field name in the Fields list. 

 
5. Click OK. 

To disconnect a thesaurus from a field 
1. 

2. 

3. 

Choose Maintain>Set Up Thesaurus. 

From the Fields list, select the field whose thesaurus you want to disconnect. 

Click the Disconnect Thesaurus button. The name of the thesaurus no longer appears next 
to the field name in the Fields list. The thesaurus is not deleted. 

Note: You cannot disconnect a thesaurus that is used as a validation list. You must edit the 
textbase structure to remove this setting before you can disconnect the thesaurus. 

4. Click OK to close the Set Up Thesaurus dialog box. 
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Maintain Thesaurus 
To add, search, modify, or delete a thesaurus term, or to review relationships and notes for it, use 
the Maintain Thesaurus window (choose Maintain>Maintain Thesaurus). You also use the 
Maintain Thesaurus window to access other windows that let you add or modify a thesaurus 
term (including its relationships), and rebuild a thesaurus. 

For information on how to accomplish these tasks in the Maintain Thesaurus window, see its 
help topic (click the Help button on the window) and the online help. 

Note that if you have more than one thesaurus connected to your textbase, the Select Thesaurus 
to Maintain dialog box opens first. If you have a thesaurus textbase open, the Maintain 
Thesaurus window for that thesaurus opens. 

Tip! To see if the textbase you have open is a valid thesaurus textbase, choose 
Display>Textbase Information. If “Thesaurus textbase” appears under the textbase name, you 
do. 

Select Thesaurus to Maintain 
If the textbase you have open is connected to more than one thesaurus, when you choose 
Maintain>Maintain Thesaurus, the Select Thesaurus to Maintain dialog box opens. To select 
the thesaurus you want to maintain, highlight the field name/thesaurus name in the Fields with a 
thesaurus list, then click OK to open the Maintain Thesaurus window. 

Rebuild Thesaurus 
Use the Rebuild Thesaurus function when you want the software to examine thesaurus entries 
and establish reciprocal links when necessary. For example, to establish reciprocal thesaurus 
links (for example, if Apple BT Fruit, then Fruit NT Apple) after you import 
thesaurus data from an external system where they did not exist, use the Rebuild Thesaurus 
function. 
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To open the Rebuild Thesaurus window, open a thesaurus textbase directly in DB/TextWorks, 
choose Maintain>Maintain Thesaurus to open the Maintain Thesaurus window, then click the 
Rebuild button. 

For information on how to use the Rebuild Thesaurus function, see its help topic (click the Help 
button on the window) and the online help. 

Important! Do not interrupt a rebuild operation. The status bar shows the progress of the 
rebuild. 

Note that if records could not be automatically repaired through this function, you should view 
the broken records so you can fix them individually. A broken record is a record whose 
relationships may not all be reciprocal. When the software tries to fix a broken record, it wants 
to make all of a broken record’s relationships reciprocal, if possible. This may not always be 
possible. For example, a broken thesaurus record cannot be fixed if it would create incompatible 
references, such as USE and RT under the same term. 

Tip! We recommend that you run Rebuild Thesaurus during off-peak hours if there is a large 
number of records to rebuild. The rebuild process may take a significant amount of time to 
complete. Anyone trying to use a thesaurus that is being rebuilt may notice a slowdown in 
response time. 
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Search Highlighting 
If the current form has search highlighting turned on (Tools>Form Properties>General), words 
and terms retrieved by the search appear in reverse video or a particular color or style (as 
determined by the settings in Tools>Options>Search), so you can quickly see the items for 
which you searched. The Basic forms highlight search items unless you use 
Tools>Options>Search to set display and/or print highlighting to None.  

Note: The Edit window does not show search highlighting because DB/TextWorks strips away 
most formatting so you can more easily see actual record information. 

 

To turn search highlighting on or off for a specific form 

1. Choose Display>Design Form and open a form. 

2. Choose Tools>Form Properties to open the Form Properties dialog box. 

3. On the General tab, select or clear the Highlight search items check box. 

4. Click Apply and save the form. 

Tip! To turn highlighting off for all forms, choose Tools>Options>Search and select None 
from the Display highlighting drop-down list. This gives you an easy way to turn highlighting 
on or off, without having to modify the forms. 
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To specify how highlighting appears 
 Choose Tools>Options and use the Search tab to select options. 

To navigate from highlight to highlight 
In the Report or Display window, press F6 or choose Display>Next Highlighted Term to move 
forward. Press Shift+F6 or choose Display>Previous Highlighted Term to move backward. 

You can also use the Next and Previous Highlighted Term toolbar buttons . 

Customizing a Query Screen 
There are two methods of customizing a query screen: 

• 

• 

You can add and delete boxes temporarily. This provides a quick way of being able to 
search a field that does not appear on the current query screen, or of temporarily removing a 
query box without having to open the Query Screen Designer. 
You can create and save permanent, customized screens using the Query Screen Designer. 

Adding and Deleting Boxes Temporarily 
If the current query screen does not include a field that you want to search (such as a field from a 
secondary textbase), you can add a box without opening the Query Screen Designer. Similarly, if 
the screen looks cluttered, you can delete boxes temporarily. These changes remain in effect 
only until you close the Query window, select a different query screen, or close the textbase. 
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To add a temporary query box 
Follow the steps below to add a temporary query box. Once added, you can type or paste query 
criteria in the new box to do a search. Note that you cannot change the label for a temporary 
query box. 

1. Select the box after which you want the temporary query box to be added.  

2. Click the Add Query Box button  on the Query window toolbar or choose Search>Add 
Query Box. A new query box appears after the selected box, and the Specify Fields to 
Search dialog box opens. The new query box inherits the width of the selected box. 

Box being added.

Select a field 
that the box will 
search, and 
click the Add 
button. 
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3. Use the Specify Fields to Search dialog box to determine which field(s) the new query box 
searches: 

– Select a field from the Fields list and click the Add button to add it to the Contents list. 
Each query box can search one or more fields. Repeat if you want the query box to 
search multiple fields. The query box will search the field(s) you specify, using an 
implicit OR between the fields. For example, if you add City and State, both fields will 
be searched when someone types information in the query box. If either field contains 
the search item, DB/TextWorks will retrieve the record. 
Note: If the textbase is linked to another textbase, you can add a field from a secondary 
textbase. Fields from a secondary textbase are designated by the link indicator (@) and 
are listed after fields in the primary textbase in the Fields list, by default. However, if 
you have selected the Sort textbase fields alphabetically check box on the Display tab 
of the Options dialog box (choose Tools>Options>Display), the secondary textbase 
fields will be interfiled with the primary fields. 

– Use the Replace, Delete, and Change Order buttons (Up and Down) to manipulate the 
contents of the query box. The order of fields does not affect how the search criteria are 
evaluated, but it does determine which index appears first when you use the Query 
Choices Browser (F3). 

4. Click OK to close the Specify Fields to Search dialog box. 

5. The new query box appears on the screen, and its label shows the field(s) it searches. 

To add a temporary sets box 
A sets box is a searchable box in which you can specify set(s) to include in a search. This 
provides a way to combine a saved search with other criteria. Once a temporary sets box added, 
you can type or paste the name of a saved set in the new box to do a search. Note that sets and 
fields cannot be searched in the same box. 

 Choose Search>Add Sets Box to add a sets box (labeled Sets) to the query screen. 

To learn more about sets, see “ ” on page 180. Working with Saved Sets

To remove a box from the screen temporarily 
 Select a box on the query screen and choose Search>Delete Box. The box remains deleted 

only until you close the Query window, select a different query screen, or close the textbase. 

To create a new query screen starting with the changed query screen 
1. Select Search>Design Query Screen to open the Open Query Screen dialog box. 

2. Select Current Query Screen from the Start With list, then click OK. Note that this option 
appears only if you added or deleted boxes, or changed Boolean buttons (AND, OR, NOT). 

3. [Optional] Use any of the editing techniques described in the following sections. 

4. Save the query screen by choosing Screen Operations>Save Query Screen. 
DB/TextWorks saves it as a new query screen. 
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Using the Query Screen Designer 
Use the Query Screen Designer to create, edit, and save query screens that meet various 
searching needs. You can also use scripts, written in JavaScript or Visual Basic Script, to 
automate functions within a query screen. The Query Screen Designer operates much like the 
Form Designer, with a slightly different set of features. You select, move, position, and resize 
boxes just as you would in the Form Designer. For information about the Form Designer, see 
Chapter 5, “Working with Forms.” 

To use the Query Screen Designer 
1. Choose Search>Design Query Screen to open the Open Query Screen dialog box. 

2. Select the query screen you want to work on from the Start With list: 

– Existing Query Screen. Loads a previously saved screen. (The existing query screens 
you can choose from appear in the Currently Saved list. The active query screen is 
selected in the list by default.) 

– Basic Query Screen. Loads the Basic screen, which includes one query box for each 
indexed field in the primary textbase. This is usually the best way to start designing 
your own query screens. 

– Blank Query Screen. Loads a blank screen. Starting with a blank screen can be useful 
if the textbase includes many fields and you prefer to add a few query boxes instead of 
having to delete many query boxes. 

– Existing Record Form. Copies, converts, and loads a form that was designed for the 
Edit or Display window so you can use it in the Query window. See “

” on page 173. 
Converting a 

Form to a Query Screen
– Current Query Screen. Loads the current query screen, if you modified it outside of 

the Query Screen Designer, to save temporary changes in a new query screen. This 
option only appears if you have added or deleted a box on the current query screen or 
changed the state of a Boolean query button. 
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3. Click OK. The selected screen appears in the Query Screen Designer:  

A solid line 
indicates which 
box is selected.  

Dashed lines 
indicate box 
boundaries, to 
help you during 
layout. To hide 
the dashed lines, 
uncheck 
View>Boundaries. 

 
4. Modify the screen using the editing techniques described on the following pages. For 

example, add a query box to search another field, resize it, and change the label text and 
color. 

Note: The Boolean button preceding each query box is attached to the box—it cannot be 
positioned or formatted separately. Choose Tools>Screen Properties to show or hide the 
buttons. See “ ” on page 171. Showing or Hiding Boolean Buttons

5. Choose Screen Operations>Save Query Screen or Screen Operations>Save Query 
Screen As. 

– Save Query Screen. Saves a screen under its current name, overwriting the previous 
version. You will see the Save Query Screen As dialog box the first time you save the 
query screen, but not during subsequent saves. 

– Save Query Screen As. Lets you create a copy of the screen under a new name. You 
can also use the Save Query Screen As dialog box to change the screen’s description 
and/or where it is saved. 
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6. Type a name of up to 20 characters, including spaces and punctuation, in the Name box. 

7. Type an optional query screen description of up to 80 characters, including spaces and 
punctuation, in the Description box. 

 
8. Query screens are not saved as separate files. They are saved as elements within a textbase 

or user file. Depending on what you want to do, select: 

– User File (Private) if you want the query screen to be available only for your personal 
use. Others who share the textbase will not see the query screen in selection lists. Only 
you will be able to use this query screen. 

– Textbase File (Public) if you want the query screen to be available to everyone who 
uses the textbase. 
Note: If the textbase has passwords, the current password determines if you have 
permission to save screens in the textbase file. 

9. Click OK. 

There are several other operations you can perform next, all of which use the Screen Operations 
menu: 

• 

• 

• 
• 

To print a description of the query screen or save the description as a file, choose Print 
Definition. This does not back up the query screen or create a file that you can share. It just 
describes the screen. 
To use the screen on the Web with a WebPublisher product, choose Export Query Screen 
to HTML. For more information, see the documentation provided with your WebPublisher 
product and the online help. 
To create or edit another query screen, choose Open Query Screen. 
To close the Query Screen Designer, choose Close Query Screen Designer. 

To use the query screen that you just created, choose Search>Select Query Screen. 

Query Screen Designer Editing Techniques 
The Query Screen Designer operates much like the Form Designer, with a slightly different set 
of features. The following sections explain the editing operations that you can perform. 
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General Operations 
You select, move, and resize boxes just as you would in the Form Designer. For detailed 
instructions about the operations listed below, see Chapter 5, “Working with Forms.” 

To… Do this… 
Show or hide box boundaries Check or uncheck View>Boundaries. 
Select boxes Click on a box or use Tab, Shift+Tab, or Edit>Go to 

Box. To select multiple boxes, use Shift+Click, or drag a 
lasso with the mouse, or choose Edit>Select All>Boxes. 

Select all boxes of a certain 
type (such as all text boxes 
or all query boxes) 

Choose Edit>Select All, then click the type of box you 
want to select. 

Move boxes Drag selected boxes, or use the arrow keys, or choose 
Tools>Box Properties>Position and change the 
Coordinates or Offsets values. Use Ctrl+arrow keys to 
simulate mouse movement. 

Change box height (query, 
script input, and sets boxes) 

Choose Tools>Box Properties>Position and change the 
Minimum height and Maximum height values.  

Change box width Choose Tools>Box Properties>Position and change the 
Width value, or select one box and drag a resizing 
handle right or left. 

Anchor boxes Choose Tools>Box Properties>Position and change the 
Anchoring setting. Note that boxes float by default. You 
can also anchor boxes by choosing Tools>Align 
Boxes>Anchor and Top. There is not really any reason 
to anchor query boxes, except for anchoring side-by-side 
boxes to each other. 

Add labels, borders, scroll bars (query, 
script input, and sets boxes) 

Choose Tools>Box Properties>Labels. 

Copy a box Choose Edit>Copy. Then choose Edit>Paste.  
Delete a box Choose Edit>Delete Box to delete all selected boxes or 

press the Delete key. 
Specify measurement and grid units Choose Tools>Screen Properties>General to specify 

measurement units. 
Choose View>Grid Settings to specify grid settings. 

Prepare a query screen 
for use on the Web with a 
WebPublisher product 

Choose Tools>Screen Properties>HTML and specify 
settings. Then choose Screen Operations>Export 
Query Screen to HTML. See the online help. 

Search multiple textbases 
with one Web query screen using a 
WebPublisher product 

Choose Tools>WebPublisher Multiple Textbase 
Query and specify settings. See the online help. 
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Adding Boxes – Overview 
A query screen can include the types of items shown below. When you design a query screen, 
the status bar indicates the type of the currently selected box. 

Picture box 

Query box 

Script button 

Sets box 

Text box 
 

Note: The above graphic does not show a script input box. Script input boxes are typically used 
to provide information to a script that does something with the records found by the search. For 
example, you could type your EMail address in a script input box and then press a script button 
to send EMail to each of the borrowers with items overdue. 

• 
• 

• 
• 
• 

• 

Query box. A box used for searching one or more fields. 
Sets box. A box into which you can type or paste the name of a saved set to be combined 
with other search criteria. 
Text box. A box that contains static text, such as a title or instructions. 
Picture box. A box that contains a static image, such as a company logo. 
Script input box. A box that lets the user of the query screen type in information that will 
be used during the processing of a script. A script input box can also be used by a script to 
display information for the user (for example, to provide information on how to use the 
selected query box). 
Script button. A button you add to a query screen to perform additional processing, such as 
moving information among boxes by executing a script. 
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To add a query box 
A query box can search one or more fields from a primary or secondary textbase. You can define 
which fields a query box searches when you add the box (see instructions below), or you can 
select an existing query box in the Query Screen Designer and choose Tools>Box 
Properties>Fields.  

A query screen should include most or all of the fields that will need to be searched. Place the 
query boxes in an order that encourages efficient searching. For example, place frequently 
searched fields near the top of the form. Note that if you select a box on the screen and then add 
a box of any type, the new box will appear below the selected box. 

1. In the Query Screen Designer, click the Add Query Box button  on the toolbar or 
choose Edit>Add>Query Box to add a query box and open the Query Box Properties 
dialog box. 
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2. On the Fields tab, select a field for the query box: 

– To add a field from the primary or secondary textbase. Select a field from the Fields 
list and click the Add button. Repeat if you want the query box to search multiple 
fields. The query box will search the field(s) you specify, using an implicit OR between 
the fields. If the textbase is linked to another textbase, you can add a field from a 
secondary textbase. Fields from a secondary textbase are designated by the link 
indicator (@) and are listed after fields in the primary textbase in the Fields list, by 
default. 
Note: If you have selected the Sort textbase fields alphabetically check box on the 
Display tab of the Options dialog box (choose Tools>Options>Display), the secondary 
textbase fields will be interfiled with the primary fields. 

– To change a field that the query box searches. Select the field that you want to 
replace from the Contents list. Then select the desired field from the Fields list and 
click the Replace button. 

– To remove a field from a query box. Select the field that you want to remove from the 
Contents list, then click the Delete button. 

– To re-order fields in a query box. Select a field from the Contents list and click the 
Change Order buttons (Up or Down). The order of fields does not affect how the 
search criteria are evaluated, but it does determine which index appears first when you 
use the Query Choices Browser (F3). 

3. On the Position tab, specify the size and placement of the query box. 

4. On the Labels tab, specify label and border formatting and Boolean button state. (You can 
also change the button state by clicking the actual button on the query screen.) 

5. On the Font, Color tab, specify text font and color, as well as background color for the box. 

6. [Optional] Use the HTML tab to specify Web options, if you plan to use the query screen on 
the Web with a WebPublisher product. See the online help for more information. 

7. Click Apply, then Close. 
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For More Information 
These tabs contain almost the same options as the tabs on the Form Box Properties dialog box in 
the Form Designer. For more information about each of these tabs, refer to the following 
sections in Chapter 5, “Working with Forms.” 

• 
• 

• 
• 

Fields tab, see “Form Box Content.” 
Position tab, see “Changing form box width” for form and text boxes; “Floating and 
anchored form boxes;” information about offsets and coordinates in “To move boxes;” and 
“Changing form box height.” 
Labels tab, see “Adding labels, borders, and scroll bars to form boxes.”  
Font, Color tab, see “Changing Text Font and Color, and Box Background Color.” 

To add a sets box 
A sets box is a special box that you use when you want to include a saved set as part of your 
search criteria. This provides a way of combining saved sets with other search criteria. (Note that 
you cannot include “regular” search criteria in a sets box.) 

Sets boxes are for desktop use only. 

To add a sets box, choose Edit>Add>Sets Box in the Query Screen Designer. A new sets box is 
added after the selected box. When you use the query screen, you can type or paste the name of a 
saved set in the box. For more information about sets, see “ ” on 
page 180. 

Working with Saved Sets

1. In the Query Screen Designer, choose Edit>Add>Sets Box to add a sets box to the query 
screen. To open the Sets Box Properties dialog box, select the sets box and choose 
Tools>Box Properties. 

Tip! If you regularly add sets boxes to query screens, consider adding the Add Sets Box 
button to your toolbar. Choose Tools>Customize Toolbar to do so. For information about 
customizing toolbars, see Chapter 10, “Customizing DB/TextWorks.” 

2. On the Position tab, specify the size and placement of the sets box. 

3. On the Labels tab, specify label and border formatting and Boolean button state. 

4. On the Font, Color tab, specify text font and color, as well as background color for the box. 

5. Click Apply, then Close. 
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For More Information 
These tabs contain almost the same options as tabs on the Form Box Properties dialog box in the 
Form Designer. For more information about each of these tabs, refer to the online help and the 
following sections in Chapter 5, “Working with Forms.” 

• 

• 
• 

Position tab, see “Changing form box width” for form and text boxes; “Floating and 
anchored form boxes;” information about offsets and coordinates in “To move boxes;” and 
“Changing form box height.” 
Labels tab, see “Adding labels, borders, and scroll bars to form boxes.” 
Font, Color tab, see “Changing Text Font and Color, and Box Background Color.” 

To add a text box 
Add a text box for instructions, titles, and other static information. 

1. In the Query Screen Designer, click the Add Text Box button  or choose 
Edit>Add>Text Box to add a text box and open the Text Box Properties dialog box. 

2. On the Text tab, type the text you want to appear in the Text box, or click the Enlarge 
button to open a larger, resizable text editor dialog box instead. When you click OK on the 
text editor dialog box, your text appears in the Text box on the Text tab automatically. 

3. On the Position tab, specify the size and placement of the text box.  

4. On the Font, Color tab, specify text alignment, font and color, and border display. 

5. [Optional] Use the HTML tab to add links to your query screen, if you plan to export the 
query screen to HTML for use on the Web with a WebPublisher product. For more 
information, see the online help. 

6. Click Apply, then Close. 

For More Information 
These tabs contain almost the same options as the tabs on the Text Box Properties dialog box in 
the Form Designer. For more information about each of these tabs, refer to the online help and 
the following sections in Chapter 5, “Working with Forms.” 

• 
• 

• 
• 

Text tab, see “Text Box Content.”  
Position tab, see “Changing form box width” for form and text boxes; “Floating and 
anchored form boxes;” and information about offsets and coordinates in “To move boxes.” 
Font, Color tab, see “Changing Text Font and Color, and Box Background Color.” 
HTML tab, see “Using HTML in text boxes.” 
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To add a picture box 
A picture box on a query screen is a box that contains a static image. You can use picture boxes 
to insert images from any file (for example, company logos). 

1. In the Query Screen Designer, choose Edit>Add>Picture Box to add a picture box and 
open the Picture Box Properties dialog box. 

Tip! If you regularly add picture boxes to query screens, consider adding the Add Picture 
Box button to your toolbar. Choose Tools>Customize Toolbar to do so. For information 
about customizing toolbars, see Chapter 10, “Customizing DB/TextWorks.” 

2. On the Picture tab, specify the location of the image. 

3. On the Position tab, specify the size and placement of the picture box, and the image size. 
Note that if you plan to export the query screen to HTML for use on the Web, Image size 
settings are ignored and picture boxes are left-justified. 

4. Click Apply, then Close. 

For More Information 
These tabs contain almost the same options as tabs on the Form Box Properties dialog box in the 
Form Designer. For more information about each of these tabs, refer to the online help and the 
following sections in Chapter 5, “Working with Forms.” 

• 
• 

Picture tab, see “Picture Box Content” to read more about inserting images from a file. 
Position tab, see “Floating and anchored form boxes;” information about offsets and 
coordinates in “To move boxes;” and information about picture box height in “To change 
picture box height.”  
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To add a script input box 
Add a script input box when you want users to provide information to be used during the 
processing of a script or to display information provided by a script (for example, as an 
alternative to displaying a message dialog box). 

For example, you can use a script input box in a query screen so a user can type a percentage in 
it to increase the numbers in the Price field in all of the records retrieved by a search. 

Script input boxes are for desktop use only. 

To define a script, you use the Screen Script dialog box, accessed by choosing Tools>Screen 
Script. For more information about defining scripts, see “ ” on page 177. Defining Screen Scripts

1. In the Query Screen Designer, choose Edit>Add>Script Input Box to add a script input 
box and open the Script Input Box Properties dialog box. 

2. On the Position tab, specify the size and placement of the script input box. 

3. On the Labels tab, specify label and border formatting. 

4. On the Font, Color tab, specify text font and color and background color. 

5. Click Apply, then Close. 

For More Information 
These tabs contain almost the same options as the tabs on the Script Input Box Properties dialog 
box in the Form Designer. For more information about each of these tabs, refer to the online help 
and the following sections in Chapter 5, “Working with Forms.” 

• 

• 
• 

Position tab, see “Specifying script input box height, width, and anchoring” and “To move 
boxes.” 
Labels tab, see “Adding labels, borders, and scroll bars to form boxes.”  
Font, Color tab, see “Formatting text in script input boxes.” 
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To add a script button  
You can add script buttons to a query screen to perform additional processing by calling a 
function you have defined using a scripting language. To define a function, you use the Screen 
Script dialog box, accessed by choosing Tools>Screen Script. For more information about 
defining scripts, see “ ” on page 177. Defining Screen Scripts

Script buttons are for desktop use only. 

1. In the Query Screen Designer, choose Edit>Add>Script Button to add a script button and 
open the Script Button Properties dialog box. 

Tip! If you regularly add script buttons to query screens, consider adding the Add Script 
Button button to your Query Screen Designer toolbar. Choose Tools>Customize Toolbar 
to do so. For information about customizing toolbars, see Chapter 10, “Customizing 
DB/TextWorks.” 

2. On the Caption tab, specify the text and font you want on the script button. 

3. On the Position tab, specify the size and placement of the script button.  

4. Click Apply, then Close. 

For More Information 
These tabs contain almost the same options as tabs on the Script Button Properties dialog box in 
the Form Designer. For more information about each of these tabs, refer to the online help and 
the following sections in Chapter 5, “Working with Forms.” 

• 
• 

Caption tab, see “Script button content.” 
Position tab, see “Floating and anchored form boxes;” information about offsets and 
coordinates in “To move boxes;” and “Changing form box width” for form and text boxes. 

Showing or Hiding Boolean Buttons 
You can specify whether the query screen shows or hides Boolean buttons on query screens used 
on the desktop (and on the Web, if you are using a WebPublisher product). 

Boolean buttons on the desktop 
In most cases, you should show query buttons so users can toggle between AND, OR, and NOT 
while constructing a query. However, if you want to force a particular configuration (for 
example, if you want to “hard wire” an OR between two boxes, or if your intended audience is 
uncomfortable with Boolean commands), you may choose to hide the buttons. When you use the 
query screen, the status bar shows the Boolean operator for the current box (AND, OR, NOT), so 
even if buttons are hidden, users will know what operator is being used. 

To show or hide query buttons on the desktop, choose Tools>Screen Properties>General, and 
select or clear the Show query buttons check box. This affects all the buttons on the screen. 
You cannot show or hide individual buttons. 
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Boolean drop-down lists on the Web 
Note: This section applies only to textbases published on the Web with a WebPublisher product. 

To specify whether a query screen used on the Web shows or hides Boolean drop-down lists, 
choose Tools>Screen Properties>HTML, and select or clear the Show Boolean operators 
check boxes. This option is cleared by default. 

Changing the State of a Boolean Button 
Both query boxes and sets boxes have Boolean buttons. When you save a query screen 
containing these types of boxes, the state of each Boolean button is retained. To change the state 
of a button within the Query Screen Designer, click the button, or use the Tab key on the 
keyboard to navigate to it and then press the Spacebar. Another way of changing the button’s 
state (for either a query or sets box) is to select a box, choose Tools>Box Properties>Labels, 
from the Button state drop-down list, select AND, OR, or NOT, then click Apply. 

Changing the Tab Order of Boxes 
Tab order determines the following behavior: 

• 

• 

The order in which query criteria will be evaluated when you fill in more than one query 
box. Query evaluation order can be important to know if you are toggling the Boolean 
buttons to combine ANDs, ORs, and NOTs. For more information, see “

” on page 143. 
Query Evaluation 

Order
The order in which the Tab keyboard key moves from box to box for navigational purposes, 
and which boxes the Tab key will skip.  

Note: DB/TextWorks skips text boxes and picture boxes by default. 

You can specify that Boolean buttons be excluded from tab order by choosing 
Tools>Options>Search and clearing the Allow tabbing to Boolean query buttons check box. 
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To change the Tab order 
1. Choose Tools>Tab Order. Query and set boxes are identified by their labels. Boxes 

without labels (such as text boxes and picture boxes) are identified by the first content item, 
shown in angle brackets. 

 
2. Click the Reset to Default Tab Order button to make the Tab order match the order in 

which boxes are placed on the screen. Another way to re-order boxes is to select a box then 
use the Change Order buttons to move the selected box up or down in the list. 

3. To have the Tab key skip a box, select the box and select the Skip this Box check box. As a 
general rule, do not skip any query boxes or sets boxes. However, if you do, you will still be 
able to access the box by clicking in it or using Edit>Go to Box. Skipping a query box or 
sets box has no effect on query evaluation order—the skipped box will still be evaluated if it 
contains query criteria. 

Converting a Form to a Query Screen 
You can convert an existing Record form (any form designed for the Display or Edit window) so 
you can use it as a query screen:  

1. In the Query Screen Designer, choose Screen Operations>Open Query Screen. (If you are 
not in the Query Designer, choose Search>Design Query Screen.) The Open Query Screen 
dialog box opens. 

2. Choose Existing Record Form from the Start With list, then select a form from the 
Currently Saved list and click OK. 

The form is copied, converted, and loaded into the Query Screen Designer, where you can edit 
and save it. Content information and formatting that are not supported in the Query Screen 
Designer, such as added text, item numbering, calculations, and variables, are removed during 
the conversion. Boolean query buttons do not appear unless you specify them on the General tab 
of the Screen Properties dialog box (Tools>Screen Properties>General). Depending on the 
form you started with, you may also want to use the Labels tab (Tools>Box Properties>Labels) 
to show borders, labels, and scroll bars, and to make sure that the labels clearly indicate which 
fields will be searched. 
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Setting Query Screen Properties 
The query screen properties you select are saved with the query screen and take effect when the 
query screen is used.  

To set query screen properties 
1. In the Query Screen Designer, choose Tools>Screen Properties to open the Screen 

Properties dialog box. 

 
2. Use the General, Logos, and HTML tabs to specify various attributes for the query screen. 

Note that the settings on the Logos and HTML tabs apply only to query screens used on the 
Web with a WebPublisher product, and that the Show query buttons option on the General 
tab applies only to the desktop. Each tab and its settings are described below. 

3. Click OK when finished. 

General Tab 

Options group 
• 

• 

Show query buttons. Select or clear this check box to specify whether to display query 
buttons on query screens used on the desktop.  
Background color. Select this option to choose a color to use for the query screen’s 
background. Click the Select Color button to specify the color (including custom colors). 
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Measurements group 
Use the Measurements settings to specify in which units box position and width, and label width 
are measured. For example, choose inches from the Horizontal units drop-down list and lines 
from the Vertical units drop-down list, so a box could be 4 inches wide and ½ line (.5) below 
the box above it. 

• 

• 

• 

• 

• 

• 

Horizontal units. Use this drop-down list to select the type of units (inches, mm, or points) 
to be used when specifying screen settings such as box positions, box widths, and label 
widths. 
Vertical units. Use this drop-down list to select the type of units (inches, mm, points, or 
lines) to be used when specifying the distance between boxes (not the information within a 
box). Note that information within a box is always measured in lines. 

Logos Tab 
Use the options on this tab when creating query screens for use on the Web with a WebPublisher 
product. For more information, including important information about image file locations, see 
the Inmagic DB/Text WebPublisher PRO User’s Manual or the online help. 

Logos group 
Leading Logo. Use this box to type the file name, including extension, of an image file to 
display at the top of the screen. For example, type NEWLOGO.JPG. 
Trailing Logo. Use this box to type the file name, including extension, of an image file to 
display at the bottom of the screen. For example, type MYLOGO.GIF. 

Note that these logos will only appear on the Web and not on your desktop. 

HTML Tab 
Use the options on this tab when creating query screens for use on the Web with a WebPublisher 
product. For more information about publishing textbases on the Web, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual or the online help. 

Query page group 
Show Boolean operators. Use this option to show or hide Boolean drop-down lists. When a 
query screen is exported to HTML, the Boolean operator (AND, OR, NOT) associated with 
each box is remembered and used in the HTML query screen. If you want Web users to be 
able to change the Boolean operator, select the Show Boolean operators check box. 
Use background image. Select or clear this check box to specify a static image to use as a 
background for the query screen. When you select this option, the Image file box is 
enabled, allowing you to designate the name of the image you want to use. 
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Form settings group 
• Initial Report Form. Click this button to open the Select Report Form dialog box and 

specify which Report form to use when the user retrieves records. This form determines the 
appearance of multiple-record display. 

• Initial Display Form. Click this button to open the Select Record Display Form dialog box 
and specify which Display form to use when the user expands a record in the browser. This 
form determines the appearance of single-record display. 

• Initial Edit Form. Click this button to open the Select Record Edit Form dialog box and 
specify which Edit form to use when the user adds, edits, or deletes a record in the Web 
browser. Note that editing over the Web requires WebPublisher PRO version 7.0 or later. 

• Show form list on report page.  This option determines whether users will be able to 
change report forms in the Web browser. If you select this check box, the form drop-down 
list will appear in the Web browser. (This option is disabled if you are using the 
WebPublisher Multiple Textbase Query feature.) 

• Show form list on display page. This option determines whether users will be able to 
change display forms in the Web browser. If you select this check box, the form drop-down 
list will appear in the Web browser. (This option is disabled if you are using the 
WebPublisher Multiple Textbase Query feature.) 

• Show form list on edit page. This option determines whether users will be able to change 
edit forms in the Web browser. If you select this check box, the form drop-down list will 
appear in the Web browser. (This option is disabled if you are using the WebPublisher 
Multiple Textbase Query feature.) 

• Records per page. Type the maximum number of records you want displayed on one report 
page after a search, or select unlimited from the drop-down list. Limiting the number of 
records displayed per page lets users view the records matching their search criteria in 
batches. This option controls how many records can be displayed at one time. It does not 
restrict the number of records that can be retrieved. 

• Navigational controls. Use this drop-down list to specify where navigational buttons and 
form drop-down lists appear on reports, expanded display pages, and edit screens and where 
on the page they are placed. 



Defining Screen Scripts 
When you are designing a query screen for desktop use, you can use one of two scripting 
languages (JavaScript or Visual Basic Script) to write programs that automate functions within 
DB/TextWorks. For more information about screen scripts, refer to the online help. 

To define a screen script 
1. Choose Tools>Screen Script to open the Screen Script dialog box.  

JavaScript is selected as 
the script language. 

 
2. On the Script tab, select the scripting language you want to use to write the program from 

the Script language drop-down list. For more information about scripting languages, see 
the online help. 

3. Type the script in the Script box. You can paste the program into the box, if you 
constructed it in a different environment. 
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4. On the Names tab, select the box from the Boxes list to which you want to assign a name. 
For more information about this tab, see the online help. 

 
5. Type the new name in the Box Name box. 

6. Click Change. The assigned name appears next to the box in the Names list. 

7. Repeat this process for as many boxes as needed, then click OK. 
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Selecting a Query Screen 
If more than one query screen has been designed for your textbase, you can select the one you 
want to use. 

To specify which query screen to use in the Query window 

1. Open a textbase and click the Select Query Screen button  on the Query window 
toolbar, or choose Search>Select Query Screen. 

Only the Basic Query 
Screen is automatically 
generated by the 
software. Use the Query 
Screen Designer to 
create your own query 
screens. 

 
2. Select the query screen you want to use and click OK. 

Note that screens are listed alphabetically (Basic screen first, then screens saved in the user 
file, then screens saved in the textbase file, which are indicated by the word public in 
parentheses). The Basic Query Screen is generated automatically by the software. It 
provides one query box for each indexed field in the primary textbase. 

3. To quickly resize the window to fit the query screen, choose Window>Fit Window to 

Form or click the Fit Window to Form toolbar button . 
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Working with Saved Sets 
Records found by a search are called a set. You can save a set to use again later. The ability to 
save and re-use sets makes it easy to return to different sets of information extracted from a 
textbase. You can: 

• 
• 
• 
• 

• 
• 
• 
• 

Save sets to keep a permanent record of search criteria and records found. 
Load a set to access records without re-executing the search and retaining omissions. 
Combine sets with other criteria. 
Specify that execution of the query criteria in a saved search is the first action performed 
when you open a textbase from a menu screen. 
Refresh sets to bring them up-to-date. 
Browse sets by pressing F3 in a sets box on a query screen. 
Rename, delete, export, and import sets using Maintain>Manage Textbase Elements. 
Look at the status bar to see the name and the number of records in the current set. 

A saved set is not actually a collection of records. It is a list of records, together with the search 
criteria that found those records. When you load a saved set, DB/TextWorks simply looks at the 
list and retrieves the listed records. It does not re-evaluate the query criteria. To update a set, 
refresh it by choosing Sets>Refresh Sets. 

To save a set 
1. Perform a search.  

2. If you want to remove any records from the set, select a record and choose Sets>Omit 
Record. This does not delete the record from the textbase. Also, if you refresh the set, the 
omitted records will reappear. 

3. Choose Sets>Save Set or Save Set As to open the Save Set As dialog box. 

4. Type a name of up to 20 characters, including spaces and punctuation, in the Name box. 

5. Type an optional description of up to 80 characters, including spaces and punctuation, in the 
Description box. 
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6. Sets are not saved as separate files. They are saved as elements within a textbase or user file. 
Depending on what you want to do, select: 

– User File (Private) if you want the set to be available only for your personal use. 
Others who share the textbase will not see the saved set. Only you will be able to use 
this set. 

– Textbase File (Public) if you want the set to be available to everyone who uses the 
textbase. 
Note: If the textbase has passwords, the current password determines if you have 
permission to save sets in the textbase file. 

7. If you want to see a list of previously saved sets, click Browse. The number of records in 
each set appears in square brackets after the set name. 

8. Click OK. 

To load a set 
Loading a set is a way of accessing records without repeating a query, and can be faster than 
running the same query again on a large textbase. Loading a set also retains omissions. 

1. Choose Sets>Load Set to open the Load Set dialog box. 

 
2. Select a set from the Currently Saved list and click OK. The Select Search Results Window 

dialog box opens. 

3. Specify the window (if any) in which you want to view the loaded set. Whether you view 
them or not, those records become the current set. You can print them, edit them, or perform 
other record operations just as you would after any search. 

When you load a set, the search is not repeated, so the records that are loaded may not reflect the 
most recent changes to the textbase. If you think records may have been added, edited, or deleted 
since the set was saved, refresh the set instead (choose Sets>Refresh Sets). This will re-execute 
the query before loading the set. 

Tip! If you load a set, then change the criteria and perform a new query, and choose Sets>Save 
Set, you will overwrite the original set. To retain the original set, use Sets>Save Set As to name 
the new set.  
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To refresh a set 
If you think records may have been added, edited, or deleted since the set was saved, refresh a 
set instead of loading it. This ensures you have the most recent results. Refreshing the set is 
especially useful if the query criteria contain @DATE. 

1. Choose Sets>Refresh Sets to open the Refresh Sets dialog box. 

2. Select the set(s) you want to refresh from the Currently Saved list. Note that the number in 
square brackets after each set name is the number of records in the set. 

3. [Optional] Select the Print Reports for Refreshed Sets check box to print each selected 
set, after it is refreshed, using the current Report Printing form. 

4. A set can include another set as part of the search criteria. Select Refresh Referenced Sets 
if you want to update any referenced sets. Referenced sets are updated only if they have a 
date other than today’s date. 

5. Click the Refresh button to automatically load, execute, save, and optionally print each 
selected set. 

6. A message indicates how many sets were successfully refreshed. Click OK. The last (or 
only) selected set becomes the current set, and the query criteria are loaded into the current 
query screen. 

7. Choose Display>Display Report to view records in the Report window. 
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Using the Saved Queries Window 
You can use the Saved Queries window as a shortcut to execute a saved query instead of loading 
a set in the Query window and then executing it. The Saved Queries window is also a convenient 
shortcut for people who run the same query frequently. 

1. Choose Search>Saved Queries to open the Saved Queries window. 

2. Select a saved set from the list and click the Execute Query button, or double-click the set 
name, to load it as a new set and execute the query. 

Double-click a set name, 
or select a set and press 
the Enter key, or select a 
set and click the Execute 
Query button to execute 
the query. 

 
To make this window appear automatically when you open a particular textbase using a menu 
screen, specify the Saved Queries window as the initial action for that textbase. In the Menu 
Screen Designer, choose Tools>Box Properties>Initial Action. Select the Window option 
button, then select Saved Queries from the drop-down list. 
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Using a Set in a Search 
You can use a set as part of your search criteria. For example, search for all invoices sent in May 
and save it as a set. The next month, combine that set with a search for all invoices sent in June. 
To include a set as part of a search, type or paste the set name in a sets box. Within a sets box, 
you can use Boolean symbols (& / !) between set names. Type the other search criteria in the 
appropriate query box. (To construct more elaborate searches with sets, use a Command query, 
explained later in this chapter.) 

1. Choose Search>Add Sets Box to add a temporary sets box after the selected box on the 
query screen. 

2. Type the name of a saved set. If you cannot remember the name of a set, press F3 or choose 
Edit>Browse Choices and paste a set name from the list. 

3. Construct your query (for example, type search criteria in a query box), then choose 
Search>Execute Query, press Enter, or use the Execute Query toolbar button. 

Performing a Command Query 
Command queries are an alternative to using query screens. They allow all of the same 
operations, but you can build more complex queries by combining multiple search requests and 
using parentheses to indicate evaluation order. 

Tip! A good way to learn the Command query syntax is to type criteria in the Query window 
then open the Command Query window (Search>Command Query). This converts the criteria 
to the Command query equivalent. 

To perform a Command query 
1. Choose Search>Command Query to open the Command Query dialog box. 

2. Type a command or press F3 to select items from a list. Using F3 eliminates guesswork 
because you can browse and paste actual indexed words and terms. 

3. Press the Enter key on your keyboard, click the Execute Query button, or choose 
Search>Execute Query. 
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Command Query Syntax 
A typical command specifies a field name, a search relation (which tells how to search the field), 
and an item to search for. For example, this search finds records where the Skills field contains 
the term Web design. 

Search item
Search relation 

 

Field name 

Optional FIND command (for clarity only)
 
 

The field name is equivalent to a query box that searches a field. 

Note: Put quotation marks around field names that include significant words (for example, and, 
or, ct). The search relation and search items are equivalent to the information that you would 
type in a query box (except that you must include ct, which means contains, when doing a 
word, phrase, or proximity search). 
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Every Command query includes at least one search relation, which connects a field name and the 
item you are searching for. A search relation is either ct (contains) or a comparison or range 
operator (=, <, <=, >, >=, :).  

Search Relation Searches Examples 
ct Contains word or phrase.  

Also used in proximity  
searches (w# and p#). 

Word index Subject ct fax  
Subject ct fax machine 
Subject ct lewis w3 clark 
Subject ct lewis p3 clark 

= Equal to (exact match) Term index Title=gone with the wind 

> Greater than Term index Price >500 

>= Greater than or equal to Term index Price >=500 

< Less than Term index "Purchase Date"<31-Jan-1999 

<= Less than or equal to Term index Last Name <=Miller 

: Within range Term index Founded =1997:1999 
Quantity =200:300 

Comparison and Range Searches 
To do a comparison search, type a field name followed by a comparison operator (<, <=, >, >=) 
and the search term. For example, Date >2001 finds dates on or after January 1, 2001. To do 
a range search, type a field name followed by an equal sign and the range 
(Date =01-June-2002:30-June-2002). A range consists of two values (dates, numbers, 
text) separated by a colon. See the previous table for more examples of comparisons and ranges. 

Word, Phrase, and Term Searches 
To search a Word-indexed field for a word or phrase, use the format field ct word or 
phrase. For example: subject ct water cooler. To search a Term-indexed field for a 
term, precede the term with an equal sign: publisher =small town press. 

Word Stems 
Use an asterisk at the end of a word (*) to find words, phrases, or terms that start with the 
specified characters. The asterisk is called a wildcard, and it means “any set of characters.” For 
example, abstract ct comput* techn* finds phrases such as computer 
technology and computation techniques. Use an asterisk only at the end of a word, 
not the beginning or middle. 
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Proximity Searches (w# and p#) 
To find words near each other, use the proximity operators (w# and p#) with ct. For example, 
subject ct blue w3 bird* searches the Subject field for blue within 3 words of any 
word starting with bird (before or after). Subject ct blue p2 bird* finds blue 
preceding any word beginning with bird by 2 words or fewer. You can include an asterisk at 
the end of any word, as shown in these examples. You cannot use proximity operators with 
phrases. 

Finding All Records 
To find all records, type findall (all one word). Capitalization does not matter. You can 
follow the command with a NOT statement to exclude records. For example, type findall 
not author ct smith to find everything not written by Smith. 

Finding Empty Fields 
To find empty fields, use the format findall not field =*. For example, to find all 
records where the Author field is empty, type findall not author =*. If the field is not 
Term indexed, omit the equal sign and substitute ct to do a word search (findall not 
author ct *). 

Finding Populated Fields 
To find records that contain any information in a particular field, type =* (or ct * if the field 
does not have a Term index). For example, type Image Name =* to find all records where the 
Image Name field contains at least one entry. 

Finding Deferred Updates 
To find records that were added, changed, or deleted using Deferred indexing, type 
getDeferred (all one word) followed by any combination of the words new, modified, 
deleted. Capitalization does not matter (for example, the “D” in getDeferred is 
capitalized for clarity only). Here are some examples: 

GetDeferred new Finds records that were added 
using Deferred indexing. 

GetDeferred new modified Finds records that were added 
or edited with Deferred indexing. 

GetDeferred deleted Finds records that were deleted 
with Deferred indexing. 

Punctuation and Case in Command Queries 
Punctuation and case are ignored unless you are searching a Code or UDC field type. For more 
information, see “ ” on page 147. Punctuation and Case in Search Criteria
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Use quotation marks around words or phrases that include items that might be misinterpreted 
(<, >, =, :, &, /, !, and, or, not). For example, search for "AT&T" to avoid having the & 
interpreted as Boolean AND. Also use quotation marks around field names that include any of 
those items. For example, "date and time" <15-Jan-1998. In Term searches, the equal 
sign must be outside of the quotes (company ="AT&T"). For linked fields, use quotation 
marks around individual field names that require quotes, not around the entire linked expression. 
For example, "date and time"@ID, but not "date and time@ID". 

Parentheses are optional. They can help clarify evaluation order in complex queries. 

Searching for Numbers and Dates 
To find numbers and dates, you can use the same techniques described earlier. For more 
information, see “ ” on page 144 and “ ” on page 144. Searching for Numbers Searching for Dates

Using F3 in Command Queries 
You can construct a Command query by picking fields, words, and terms from a list: 

1. Press F3 in the Command Query window or click the Browse Choices button to open the 
Query Choices Browser. 

2. Select the field you want to search from the Field drop-down list. 

3. In the List Shows group, select the Terms List, Words List, or Thesaurus option button, 
depending on whether you want to see the field’s Term index, Word index, or Thesaurus (if 
the field has a Term index and a Thesaurus). You can switch between the option buttons, as 
needed. Note that some fields may not have both indexes and/or a Thesaurus, so one or 
more of the options may be unavailable. 

4. Select a word or term from the Choices List and click the Paste button to copy it into the 
Command Query window. (You can also double-click the word or term to paste it.) 

5. The field name and the item appear in the Command Query window. You can edit the 
pasted criteria if you want to, then submit the query by clicking the Execute Query button. 

Boolean Searches in Command Queries 
To search a field for multiple items, use the symbols & / ! to represent Boolean AND, OR, NOT. 
For example: 

Ingredient ct chocolate & nuts Finds recipes only if they contain 
both items. 

Ingredient ct chocolate / nuts Finds recipes that contain either item 
(or both). 

Ingredient ct chocolate ! nuts Finds recipes with chocolate but no 
nuts. 
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When doing a Term search, repeat the = sign after Boolean operator: 

company = acme products / =wilson hardware 

To search multiple fields, use a forward slash (/) between field names. The OR symbol (/) is the 
only one you can use between fields. This search finds letters to or from John Smith: 

author / recipient =john smith 

To combine multiple search statements, use the words AND, OR, NOT. (You do not have to 
capitalize them.) For example, the following search finds all letters written or received by Mary 
Smith that are not about pricing:  

type=letter AND author / recipient =mary smith NOT description 
CT pricing 

To make long commands easier to read, press Ctrl+Enter on the keyboard to insert line breaks: 

type=letter  
AND author / recipient =mary smith  
NOT description CT pricing 

Command searches are evaluated from left to right, top to bottom. Most simple search requests 
do not require parentheses, but you can include them to clarify evaluation order. For example:  

flag ct red / white & blue Finds flags that are red and blue or 
white and blue. 

flag ct (red/white) & blue Same as above. 
flag ct red / (white & blue) Finds flags that are red or flags 

that are both white and blue. 
 
Search criteria that contain parentheses are often referred to as nested Boolean commands. For 
best results, perform OR searches first and AND or NOT searches last, or use parentheses to 
group the OR searches together. 

You can specify whether spaces are required around a Boolean or range symbol (for example, 
whether you should search for ant / bee or ant/bee). This is done by changing a setting in 
the INMAGIC.INI file. Read about Boolean and range searches in the “

” section at the end of this chapter. 
Troubleshooting 

Searches

Using Sets in Command Queries 
To include a set in a Command query, type the name of the set in curly brackets. For example, 
this search example combines a set with other criteria to find proposals not authored by Smith: 

{proposals} NOT author ct smith 

You can use Boolean symbols (& / !) to join multiple set names. This search example uses the 
Boolean NOT symbol between two sets to find all new clients except those located in Canada: 

{new clients} ! {canada} 
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Searching Secondary Textbase Fields with Command Queries 
If the textbase contains a Link field, you can search fields from the secondary textbase using the 
format shown in the illustration below. For more information, see Chapter 8, “Linking 
Textbases.” 

Link field in primary textbase
Link indicator 

Field in secondary textbase

 

Inclusive and Non-Inclusive Searches 
The query illustrated below is the same as the Command query author/editor ct smith 
& jones. 

 
Queries such as these can be interpreted in one of the two ways described below. Choose 
Tools>Options>Search to specify how to interpret such searches. 

• 

• 

Select the Use inclusive search option for multiple fields check box. (Author or Editor 
contains Smith) AND (Author or Editor contains Jones)  
Clear the Use inclusive search option for multiple fields check box. (Author contains both 
Smith and Jones) OR (Editor contains both Smith and Jones) 
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Troubleshooting Searches 
Having trouble with a search? Some common problems and their possible solutions are listed in 
this section. 

Received the message: “Unable to recognize as a correctly formed 
query” 
The program cannot understand the search criteria. 

• 
• 

• 

• 

• 

• 

• 

• 

• 

• 

Look for typographical errors, or mismatched quotes or parentheses. 
Omit any extra Boolean symbols (for example, type car / auto instead of 
car / auto /). 
Surround a URL or time with quotation marks (for example, search for 
"http://www.inmagic.com"). Otherwise, the punctuation may be misinterpreted. 
For more information, see “ ” 
later in this section. 

Boolean and range searches do not find the expected records

Boolean and 
range searches do not find the expected records

If you cannot determine what caused the error, try a simpler search, such as a single word in 
a query box, or use F3 to reconstruct the query. 

Too many records retrieved 
If you used an asterisk, omit it and try an exact search instead (for example, search for 
computer instead of comp*). 
If you are doing a Boolean search, try using & instead of /. For example, red / blue 
finds items that are either red or blue (or both), so it finds more records than red & blue 
(which finds items only if they are both colors). Use ! to exclude records. For example, to 
find articles about Hercules but not cartoons, search for hercules ! cartoon*. 
If the item you are searching for includes punctuation, substitute spaces for punctuation. 
When searching for dates, use dashes or spaces instead of slashes, or enclose the date in 
quotation marks (for example, "10/7/2001"). For more information, see “

” later in this section. 

No records retrieved 
Try using / instead of & between words. Using / means either word can be present (john / 
paul finds John OR Paul). Using & means both words must be present (john & paul 
will not find just John or just Paul). 
If you are not sure of the spelling, use an asterisk after the first few characters (for example, 
colo*) or separate several possible spellings with a forward slash (for example, search for 
color / colour). 
If you did a complex search, try simplifying it to eliminate confusion. Press F3 to view and 
paste items to search for. This eliminates guesswork. 
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• 

• 

• 

• 

If your search includes Boolean symbols (& / !) or the range symbol (:), try putting spaces 
around the symbol (for example, name ct smith / jones instead of name ct 
smith/jones). 
Remember that range searches involving partial dates start from the beginning of the range. 
For example, born >1997 finds dates after Jan. 1, 1997. 

• Examine the contents of the search screen (especially if it is longer than the visible screen) 
to verify that you do not have criteria left over from a previous search. 

Boolean and range searches do not find the expected records 
A setting in the INMAGIC.INI file determines whether spaces are required around Boolean 
symbols (& / !) and the range operator (:). If Boolean and range searches do not seem to be 
retrieving the expected records, try including spaces around search operators (for example, 
search for ant / bee instead of ant/bee). If this works, continue to surround these 
operators with spaces. 

To change the behavior, close DB/TextWorks, then open INMAGIC.INI using a text editor (for 
example, Notepad) and change the following setting in the [Inmagic DB/TextWorks] 
section: 

If SpacedRelOps=0, spaces are not required around search symbols. The symbols 
& / ! and : are always treated as search operators unless embedded within a quoted phrase. 
If SpacedRelOps=1, spaces are required around search symbols. The symbols & / ! and : 
are treated as search operators only if surrounded by spaces. The advantage of 
SpacedRelOps=1 is that you can search for dates such as 12/31/1998 or URLs such 
as http://www.inmagic.com without having to use surrounding quotation marks. 
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Chapter 5: Working with Forms 

A textbase contains unformatted text, numbers, and dates. To format the information, you can 
create your own customized forms. Forms determine how information appears when it is 
displayed on the screen and printed. 

Note: Forms are for displaying and printing information, sending EMail, and writing to a file. 
You do not use forms for queries. To learn how to design query screens, see C  
“Searching a Textbase.” 

Overview 
A form is a layout that affects how information appears when you display, ed
write records to a file, or send a report as EMail. You can design separate for
window (to see multiple records found by a search), the Display window (to 
time), the Edit window, and for printing. 

A form that is designed to display or print multiple records is called a report 
is just like a regular form except that it includes some additional features, suc
numbering of records, that would not make sense for single-record display. 

When you save a form, you decide for which operations it can be used. You c
form for more than one operation. For example, you can design one form for 
display, and another form for printed reports. 

You can create as many forms as you need, and you can select different form

By designing customized forms with DB/TextWorks, you can display and us
your textbases in a multitude of ways, including to: 

• 

• 

• 

• 

• 

Perform calculations, such as totaling purchase orders. 

Add logos or graphics. 

Send customized EMail to one or many recipients. 

Display, edit, add, and delete records over the Web (with a WebPublishe

Sort records, such as sorting sales data by sales representative, region, or
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Basic Forms 
Until you design your own forms, you can use the Basic forms, which are generated 
automatically. The Basic forms show every field from the primary textbase in a simple, 
straightforward format. You do not have to do anything special to use these forms—they are 
used by default until you create your own. There are two Basic forms: 

• 
• 

The Basic Record form is for single-record display. 
The Basic Report form is for multiple-record display. 

Basic forms are generated by the software as needed. They automatically reflect any changes 
you make to the textbase, such as adding fields. 

Basic forms contain one box for each field in the textbase. Fields hidden by passwords and 
secondary textbase fields do not appear. Default settings (choose Tools>Options>Display) 
determine font appearance, box background color, and other options. Multiple entries appear on 
separate lines. You can start designing with a Basic form and save it under a new name, but you 
cannot overwrite or delete a Basic form. 

Customized Forms 
Because you may not want to display all the information in your textbase, you can customize 
forms to show only the fields you want. 

You can add logos and graphics to your form, as well as headers and footers. You can also 
specify that information in a multiple-record report be sorted by particular criteria, or have 
DB/TextWorks perform calculations on your data and display the results on your form. 

The following table lists the various uses for forms. You can design different forms for these 
uses, and have multiple forms available for each.
Design forms for…  To… 
Report window Display multiple records after a search. Forms saved for use in 

the Report window are also available to send a report as EMail 
and write a report to a file. 

Display window Display one record at a time. 
Edit window Add or edit one record at a time. 
Report window Print records found by a search (for example, financial reports or 

mailing labels). 
Web Use on the Internet or an intranet, with a WebPublisher product. 
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Creating a Form 
You have a great deal of flexibility in how you approach form design. 

You use three menus in the Form Designer to do most of the design work. 

  

 

Use the Edit menu 
to add and delete 
boxes. 

Use the Tools menu to 
specify box content 
and appearance. 

Use the Report Options 
menu when designing 
report forms. 

Use the order shown below as a guide while you experiment. Note that steps 2 and 3 should be 
performed at the beginning of the design process and steps 9 and 10 should be performed at the 
end. Some of the steps are optional, and some may be performed in a different order. The form 
attributes specified in the steps below will be explained in detail later in this chapter. 

1. Search for and retrieve records. It helps to have at least a few records in the textbase 
before you start designing forms, so you can see actual record information as you lay out the 
form.  

2. Set form defaults. Choose Tools>Options>Display to specify default settings for the 
forms you create. This is especially helpful if you will be creating many forms that will use 
the same settings. 

3. Open the Form Designer. Choose Display>Design Form and select a form to edit or to 
use as the basis of a new form. You can also start with a blank form. 

4. Set form properties. Choose Tools>Form Properties>General to specify general settings 
that affect how information will appear when the form is used. 

5. View records. Periodically switch between Display>View Records and Display>View 
Content, to toggle between viewing actual record information and content descriptions. 
Viewing record information is like previewing the form. (To see record information, you 
must execute a query or a load a set.) Viewing content descriptions shows how the form is 
constructed.  

6. Show or hide box boundaries. Use View>Boundaries to show or hide dashed lines around 
boxes and anchoring indicators to help you lay out the form.  
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7. Perform design tasks. The first task below is required. The remaining tasks are optional 
and may be performed in any order. Use the Edit and Tools menus to perform these tasks: 

– Add boxes and edit box content. Add form, text, and/or picture boxes and specify 
their contents (for example, fields, variables, text, images). You can also add script 
input boxes and script buttons. Each form box can include one item or several items 
(such as two fields and a variable). Delete any unwanted boxes or script buttons. This 
does not delete record information. Edit box content if needed. For example, change the 
field that a box contains. 

– Format box text. Specify how each content item in a box appears, including font, case, 
color, number and date formatting, and numbering, and whether extra text or 
punctuation appears. For example, make a field bold and italic, and number each entry. 

– Change box size and position. Move and resize boxes and determine whether the box 
position will be anchored or floating. (Most boxes should float.) 

– Show label, border, and scroll bars. Show or hide labels, borders, and scroll bars, and 
specify label text, font, and color. 

– Format paragraphs. Specify paragraph breaks, justification, and indentation to apply 
to all of the content items in the box. For example, make each entry in a field appear on 
a separate line. 

8. Select Report Options. If the form will be used for multiple-record reports, you can use the 
Report Options menu to specify these optional attributes: 

– Compulsory Sort. Specify that records be sorted in a certain way each time that form 
is used. A Compulsory Sort is typically used when a report contains subtotals and totals 
that rely on a specific sort order.  

– Add Headers and Footers. Use a Report Header, which appears only once, at the 
beginning of the report. It typically contains variables, prompted text, fixed text, or a 
combination of these items. Use a Report Footer, which appears only once, at the end of 
the report. It typically contains summary calculations, such as grand totals and 
averages. Use a Sort Header as a group heading under which one or more records are 
listed. Use a Sort Footer to hold a count, subtotal, or other summary calculation for the 
current sort group. 

– Set Up Page. Specify the size, margins, orientation, and page breaks for the form when 
used for printing. 

– Hide Margin Area and Work in Margin Area. Hide the Margin Area from view or 
show the Margin Area and work in it. Information in the Margin Area is only used 
when printing on the desktop. 
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9. Save the form. When you save a form for the first time (or use Save Form As), you specify 
the operations for which the form can be used (for example, Display window, Edit window, 
Report window, printing). You also specify if the form should be saved in the user file or 
the textbase file. While you are first learning to design forms, you may not want your early, 
experimental forms to be seen by others. If this is the case, save the forms in your user file. 
Others who share the textbase will not see them in selection lists or have access to them. If 
you later want others to be able to see a form, use Save Form As and save it as public.  

10. Select the form. After designing a form, choose Display>Select Forms and select the 
forms to use for various operations. 

Opening and Closing the Form Designer 
Use the Form Designer to create and edit forms. After you open the Form Designer, the menus at 
the top of the screen change to provide form-specific options. 

Tip! New forms use the defaults specified on the Options dialog box (Tools>Options) on the 
Display tab in the Form Defaults group. 

To open the Form Designer 
1. Choose Display>Design Form to open the Open Form dialog box. 

2. From the Start With list, select a form: 

– Existing Form. Select an existing form to edit from the Currently Saved list. After 
editing the form, you can save it under its existing name or under a new name (a way of 
copying a form). 

– Basic Form. This is often the easiest way to begin designing a form. The Basic form 
provides one box for each field in the textbase. Select either the Record Form option 
button (if you are designing a form for single-record display in the Display or Edit 
windows) or the Report Form option button (if you are designing a form for multiple-
record display in the Report window). 

– Blank Form. A blank form does not contain any boxes. This can be useful when your 
textbase contains many fields, but you want the form to include only a few of them. 

– New Label Form. Select a label format (for example, Avery, Gaylord, University 
Products). 

– New Tabular Form. A tabular form presents information as a table, in rows and 
columns. After you click OK, you will be prompted to select fields for columns and the 
table will be created for you. You can add, remove, and re-order columns later. 

3. Click OK. 
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To load a different form 
 Once the Form Designer is open, you can load a different form by choosing Form 

Operations>Open Form. 

To close the Form Designer 
 Choose Form Operations>Close Form Designer. 

Changing Display Options 
There are several display options that will help you control how a form appears while you are 
working on it. 

Viewing Records or Content Descriptions 
Periodically toggle between Display>View Records and Display>View Content to view actual 
record information and content descriptions. Viewing record information is like previewing the 
form. Note that you must have done a search first, so you have some records to view. Viewing 
content descriptions reveals how the form displays data, by showing field names, variables, 
calculations, and so forth.  

Showing or Hiding Box Boundaries 
Select or clear View>Boundaries to show or hide dashed lines around boxes. Showing 
boundaries is especially helpful if the boxes do not have borders. Showing boundaries also 
displays arrows between any boxes that are anchored to each other. Boundaries appear only in 
the Form Designer, not in the saved form. 

Previewing a Form 
To preview a form while you are designing it, do a search that finds at least one record, then 
choose Display>Preview in the Form Designer. You see one record at a time. To display 
additional records, use the Display menu options or the arrow buttons on the Preview window 
toolbar. To finish, choose Display>Close Preview. 

Another way to see how the form really looks is to select it for the appropriate window. Save the 
form, even if it is in a preliminary stage. Then select it for a particular window by choosing 
Display>Select Forms from the main menu. (If you cannot find the main menu, see “

” below.) Keep that window (for example, the Report window) open while you work in 
the Form Designer. Each time you save the form, the window will be refreshed using that form, 
so you have constant visual feedback. 

Toggling 
Windows

Toggling Windows 
While the Form Designer window is selected, you have access to form-specific menu options. 
To access a different set of options, select another window. For example, to access the main 
menu options, select the Query window or open the Window menu and select a window from the 
list. 

198 Chapter 5: Working with Forms 



 

Saving a Form 
As you work, save your form frequently, just as you would when working with any important 
file. After you save a form, it remains open in the Form Designer so you can continue working 
on it. 

To save a form 
1. Choose Form Operations>Save Form or Form Operations>Save Form As. 

– Save Form. Saves a form under its current name, overwriting the previous version. 
You will see the Save Form As dialog box the first time you save the form, but not 
during subsequent saves. 

– Save Form As. Creates a copy of the form under a new name that you specify, leaving 
the original intact. You can also change the information about the form (for example, 
the operations for which the form can be used) using the Save Form As dialog box.  

2. Type a form name of up to 20 characters, including spaces and punctuation, in the Name 
box. If the form has a compulsory sort, you may want to indicate that in the form name. For 
example, the name Sales by Region indicates the records are sorted by the Region 
field. 

Note: You can click the Browse button to see the forms that have already been saved. 
Forms saved in the current user file are listed first, alphabetically, followed by forms saved 
in the textbase file, which are identified by the word (public). 

3. Type an optional form description of up to 80 characters, including spaces and punctuation, 
in the Description box. The description appears on dialog boxes when you open, save, and 
browse forms. It is helpful to indicate the form’s purpose and its compulsory sort, if any. 
For example, Print or display report of sales by region. 
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4. Decide where you want to save the form. Depending on what you want to do, select: 

– User File (Private) if you want the form to be available only for your personal use. 
Others who share the textbase will not see the form in selection lists. Only you will be 
able to use this form. Note that forms saved in a user file cannot be selected as the 
textbase default or be used with a WebPublisher product or menu screens. 
Tip! While you are first learning to design forms, you may not want these experimental 
forms to be used by others. In this case, save the forms in your user file. 

– Textbase File (Public) if you want the form to be available to everyone who uses the 
textbase. 
Note: The current password determines if you have permission to save forms in the 
textbase file. 

5. Specify where the form can be used by selecting the appropriate check boxes. For example, 
if you select the Report Window and Report Printing check boxes, the form will appear in 
form selection lists for both operations. 

– Display Window. This form can be used for single-record display. (WebPublisher 
users should select this check box to make the form appear in WebPublisher form drop-
down lists for expanded display.) 

– Edit Window. This form can be used for adding records. (WebPublisher PRO users 
should select this check box if the edit form is going to be used to add, edit, and/or 
delete records over the Web; if the edit form will be exported to HTML; and/or to 
enable the Web box treatment drop-down list on the Form Box Properties dialog box.) 

– Report Window. This form can be used for displaying reports, writing to a file, or 
sending a report as EMail. (WebPublisher users should select this check box to make 
the form appear in WebPublisher form drop-down lists for displaying reports.) 

– Report Printing. This form can be used for printing reports. 
– Web. This option is intended for WebPublisher users. It ensures that the form will 

appear in WebPublisher form drop-down lists. Select it for every form you intend to use 
on the Web.  

– Web Only. This option is intended only for WebPublisher users. It excludes the form 
from desktop picklists. 

6. Click OK. 
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Creating Forms 
Whether it is a Basic form generated automatically, or a customized form complete with your 
company logo, numbered records, and a compulsory sort, DB/TextWorks gives you a wide range 
of options for displaying information. 

Specifying form use 
The following sections provide some helpful hints for designing forms for the Report window, 
Display window, and Edit window; for report printing; and for forms used with WebPublisher 
products. 

Report Window 
Typically, you design at least one form for the Report window to summarize the records found 
by a search. The following form shows a few fields from each record and numbers each record. 

 
Here are some tips for designing forms for the Report window: 

• Summarize search results by showing just a few of the most important fields. The fewer 
fields you show, the more records can be seen at once. Decide which fields you can omit 
without confusing users. For example, if most people search by Name, then the form should 
include that field. 

• To conserve space, combine multiple content items in one box (for example, Address, City, 
State or Province, Postal Code). Choose Tools>Box Properties>Paragraphs and choose 
No added paragraph breaks from the Paragraph breaks drop-down list so items are not 
stacked in a column. Choose Tools>Box Properties>Format>Added Text, and use a 
comma as ending text after the appropriate content items (for example, 123 South St., 
Dallas, TX, 01234). 
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• Consider turning off box labels or specifying that label position is to the left of the box 
(choose Tools>Box Properties>Labels). 

• If you start with the Basic Record form, decide whether to turn off borders and scroll bars 
(choose Tools>Box Properties>Labels). Note that if you start with the Basic Report form 
they are turned off by default.  

• If you start with the Basic Record form, decide whether to increase the height of some boxes 
from the default to unlimited by selecting the box(es) and choosing Tools>Box 
Properties>Position and increasing the Maximum height setting. Otherwise, only the 
default number of lines worth of information will appear. Note that if you start with the 
Basic Report form, the Maximum height setting is set to unlimited by default.  
Note: You can specify the default box height setting before opening the Form Designer by 
choosing Tools>Options>Display and clicking the More Defaults button. 

• Choose Tools>Form Properties>General and set the distance between records. 
• Number records by adding a box whose only content is the RECORD NUMBER variable. See 

“ ” on page 285 for more information. Numbering records
• The Form Designer shows only one record at a time and does not omit empty boxes. To see 

how the form really looks, preview it, as explained in “ ” on page 315. To preview a report
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Display Window 
The Display window shows one record at a time when you choose Display>Display Record. 
Design at least one form for the Display window that shows detailed information for one record 
at a time. 

 
Here are some tips for designing forms for the Display window: 

• Start with the Basic Record form. Include most or all of the fields, as users displaying a 
record usually expect to see them. 

• Increase the height of some boxes from the default setting by choosing Tools>Box 
Properties>Position and increasing the Maximum height setting. 
Note: You can specify the default box height setting before opening the Form Designer to 
create a new form by choosing Tools>Options>Display and clicking the More Defaults 
button. 

• Turn scrollbars on for boxes that may contain a large amount of text. This is because, in 
Display and Edit windows, boxes are never taller than the window—even if the Maximum 
height box setting is set to unlimited. 

• Decide whether to turn search highlighting on or off (choose Tools>Form 
Properties>General). Highlighting words in reverse video or color can be a help or a 
hindrance. 
Tip! If you turn search highlighting on, you can selectively turn it off when you use the 
form by choosing Tools>Options>Search and selecting None from the Display 
highlighting or Print highlighting drop-down lists. 

 Chapter 5: Working with Forms 203 



Edit Window 
You use the Edit window to add or edit a record. 

 
Here are some tips for designing a form for the Edit window: 

• Start with the Basic Record form. This shows all fields, with all boxes having borders and 
scrollbars. 

• Place fields that you edit most frequently at the top of the form. Move fields that you 
seldom edit to the bottom. Then choose Tools>Tab Order and click the Reset to Default 
Tab Order button to reset the tab order to match the order in which boxes appear in the 
form. 

• Increase the height of boxes that include large amounts of text. Choose Tools>Box 
Properties>Position and increase the Maximum height setting to show enough text to 
provide adequate context. If you started with the Basic Report form, use the Labels tab to 
show scroll bars (they are on by default for the Basic Record form). 

• Place only a single field in a box or you will not be able to edit it. The field must be from 
the primary textbase and cannot be hidden or marked read-only by a password. Any other 
type of content can be seen but not be edited. Note that in some cases you may want to 
include information even if it is not editable, such as Automatic or Computed fields or 
information from a linked textbase. Using a different font or color for non-editable 
information (or removing the box’s borders) can assist the user. 

• Be sure the form includes a box for every field that has Field Entry Required validation. Put 
each field in its own box. If each required field does not have its own editable box, you 
cannot use the form in the Edit window. To see which fields have Field Entry Required 
validation, switch back to the Query window, choose Display>Textbase Information, and 
then choose Edit>Find to search for the word required. 
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• If the Check spelling as you type feature will be used on the edit form, use a black text font 
in editable boxes. 

• When a form is used in the Edit window, the following attributes apply for editable boxes, 
no matter how the form was designed: 
– Boxes never disappear when empty (unless the box contents are hidden by a password), 

even if the Minimum height is set to zero (0) on the Form Box Properties dialog box 
(choose Tools>Box Properties>Position). This lets you add information to empty 
fields. 

– All formatting except font and color is removed, so that all you see is the actual field 
data. 

– Entry delimiters (bullet character by default) appear and each paragraph or entry has 
hanging indentation, so you can differentiate between line wrapping, paragraph breaks, 
and entries. 

Note: If you have WebPublisher PRO, you can also design a form to use on the Web to add, 
edit, and/or delete records. If that is the case, when saving the editing form, you must select the 
Edit Window and Web check boxes on the Save Form As dialog box. For more information 
about using an edit form on the Web, see the online help. 
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Printed Reports 
Printed reports can include page numbers, titles, calculations, Sort Headers (such as Sales by 
Territory), and many other sophisticated formatting techniques. 

 
Here are some tips for designing a form for printing: 

• Read about designing forms for the Report window on page 201. Many of the same 
recommendations apply. 

• Use the Report Options menu to specify print-specific settings, including the page size, page 
breaks, and other attributes that have an effect on how the report will appear when printed. 

• Use the Margin Area to add information that will repeat on every page, such as page 
numbers. Use the Record Area to specify how record information appears. Carefully 
consider where to place the different report components and what type of box to use (for 
example, text box, form box, header/footer box). All of these issues are explained later in 
this chapter. 

206 Chapter 5: Working with Forms 



 

Web Reports 
If you have a WebPublisher product, you can design forms to be used with textbases that you 
publish on the Web. Internet or intranet users can use a Web browser to retrieve records, then 
choose one of the report forms that you designed to change the appearance of the information 
that was retrieved. If you have WebPublisher PRO, users can also add, edit, and/or delete 
records over the Web. When designing WebPublisher forms, be sure to choose Tools>Form 
Properties>HTML and Tools>Box Properties>HTML to specify the options you want. When 
you save the form, select the Web check box (and the Web Only check box, if applicable) on 
the Save Form As dialog box to specify that the form can be used on the Web. For more 
information about designing forms for use with a WebPublisher product, see “

” on page 328, or the online help. 
Designing Forms 

for Web Use

Adding Boxes 
You design a form by adding and editing boxes and script buttons (which can be formatted like 
boxes). There are several types of boxes you can add: form boxes, text boxes, picture boxes, 
script input boxes, and script buttons. The following form includes the different types of boxes. 

Picture box 

Form box 

Text box 

Script button 

Form boxes 

 
Script input box Form box Script button 

Because all boxes that you add are empty, you must specify the content properties of each box 
(what is inside the box). The only exception is the script input box, which does not have box 
content. (Script input boxes are used when you want users to type information into a form to use 
during the processing of a script.) The content of a box determines what appears in the box when 
you use the form. Optionally, you can specify position and format settings for each box, as well. 
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To add a box to a form, choose Edit>Add, then select the type of box you want to add.  

• Form box. A box that contains field information, variables, and other information. It may or 
may not have a label, border, and scroll bars. Fields are the most common form box content. 
However, form boxes can also contain variables (such as the current date), calculations 
(such as a subtotal), fixed text (such as a report title), and other information. A form box can 
even contain multiple items, such as two fields, or a field and a variable. You can format 
form box contents and labels, and you can turn scroll bars and borders on or off. For more 
information about form boxes, see “ ” on page 213. Form box content

• 

• 

Text box. A box that contains static, informational text, such as a title or instructions. 
Usually, you hide text box borders. For more information about text boxes, see “

” on page 256. 
Text Box 

Content
Picture box. A box that contains an image. Use picture boxes to display images that are 
either static or referenced in a field in the record. For example, use a picture box to display a 
company logo on a form. For more information about picture boxes, see “Picture box 
content” on page 259. 

• Script input box. A box that users type information into to be used during the processing of 
a script. In an edit screen, this information does not get saved in the record like other 
information typed into form boxes. If you use a script input box, you must define a script to 
use the information a user enters in the box. You can specify position attributes, label 
information (for example, to tell a user what kind of information to type in the script input 
box), and font and color attributes for script input boxes. Note that script input boxes do not 
have box contents because their function is to have the user enter information into them. 
Note that a script can also put information into a script input box. Script input boxes are for 
desktop use only; they are not applicable to the Web. For more information about script 
input boxes, see “ ” on page 303 and “ ” on 
page 298. 

Script Input Boxes Using Scripts with Forms

Using Scripts with Forms

• Script button. A button you place on a form. A script button allows you to access functions 
you have written on the Form Script dialog box. You can specify position properties for 
script buttons, as well as font properties for script button captions. Script buttons are for 
desktop use only; they are not applicable to the Web. For more information about script 
buttons, see “ ” on page 300 and “ ” on page 298. Script Buttons

Each form can contain a combination of box types. The boxes in a form determine what 
information will be displayed when the form is used. After adding a box or script button, you 
can edit it on the corresponding Box Properties dialog box (which opens automatically), and you 
can move or resize it by using the mouse. For an existing box or script button, choose 
Tools>Box Properties to open the corresponding Box Properties dialog box. 

Each dialog box contains tabs that display the settings you use to set the properties of that 
particular box. 

You can cut, copy, and paste boxes and script buttons within the same form for easy 
repositioning (for example, you can copy from the Margin Area and paste in the Record Area). 
You can cut or copy them from one form and paste them into another form. You can even cut or 
copy them from forms and paste them into query and menu screens, as long as the box type is 
common to and supported by all three designers (for example, text boxes, picture boxes, script 
input boxes, script buttons). 
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To add a new box to a form 
1. If you are adding a box to a form that already has boxes on it, select an existing box. The 

new box will appear below the selected box. Otherwise, go to step 2.  

2. Choose Edit>Add, then select the type of box you want to add. The new, empty box 
appears and the appropriate Box Properties dialog box opens. Note that you can add only 
one box at a time using this method. 

3. Use the Box Properties dialog box to specify box contents (for example, fields, image file 
names). 

To copy an existing box 
1. Select the box you want to copy. 

2. Choose Edit>Copy to copy the box. 

3. Select the box below which you want the copied box to appear. Note that DB/TextWorks 
pastes the box below the currently selected box. You can also paste your box into another 
form, or into the menu or query screen designers (if the box type is supported in that 
designer). 

Tip! If you want to paste a box above all other boxes, use the Paste Here command, which 
appears only on the shortcut menu (right-click to display it). When using Paste Here, the 
Top and Left offset settings for the copied box are retained. 

4. Choose Edit>Paste to paste your copied box into the form. The copied box retains the same 
contents and formatting. 

5. Choose Tools>Box Properties to change the properties of the new box, if applicable. 

Note: You can use this method to copy multiple boxes at one time and still retain their 
formatting and contents. When you copy multiple boxes, their positions relative to each other are 
retained. If any of the boxes is anchored to another box, that is retained. For example, if you 
copy boxes A and B and box B is anchored to box A, box B remains anchored to box A when 
you paste the boxes. Anchor to form properties are discarded. For more information, see 
“ ” on page 234. Floating and anchored form boxes

To delete a box or boxes 
1. Select one or more boxes. 

2. Choose Edit>Delete Box, or press the keyboard Delete key. Deleting a box does not delete 
information from the textbase, but prevents information from being displayed when that 
particular form is used. 
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To select boxes 
Use the techniques described in the following table to select different types of boxes. 

To… Do this… 
Select one box Click on it, press Tab or Shift+Tab to move to it, or use 

Edit>Go to Box. 
Select several boxes Hold down the left mouse button and drag the mouse over the 

boxes you want to select. All boxes at least partially within the 
selection “lasso” are selected.  

Add or remove boxes from a 
selection set 

Shift+Click on them. 

Select all boxes Choose Edit>Select All>Boxes. 

Select all boxes of a certain 
type (such as all text boxes or 
all form boxes) 

Choose Edit>Select All, then select the type of box you want to 
select. 

 
In a form that is not blank, at least one box is selected at all times. Selected boxes are surrounded 
by a solid outline. When just one box is selected, the outline includes width handles, which you 
can drag to resize the box. You cannot use the mouse to change the width of multiple boxes at a 
time—instead, use Tools>Box Properties>Position and type a value in the Width box. 

To move boxes 
Use any of the following methods to move boxes when designing a form. When you move a 
box, other boxes may move as well, depending on their position and anchoring. 

• 

• 

• 

Position the cursor anywhere—except over a width handle—and click and hold the left 
mouse button while you drag the box. A four-sided arrow appears, along with a ghost image 
of the selected box. Position the ghost box on the screen and release the mouse and place the 
box. Note that you can cancel a drag operation by pressing Esc before releasing the left 
mouse button. 
Select a box, then press and hold the Ctrl key while you use the arrow keys to move the 
box. This simulates the mouse method described above. Release the Ctrl key to place the 
box. 
Select a box, then press an arrow key on your keyboard. The arrows move the actual box 
rather than a ghost image of the box, so you cannot move a box “across” another box, the 
way you can using the previous two methods. For example, when you move a box up, it will 
not go any higher than the box above it, unless you move it around and then up. 
Tip! To specify the distance a box moves for each press of an arrow key when moving 
boxes, choose View>Grid Settings and type values in the Horizontal grid spacing and 
Vertical grid spacing boxes. For example, when working in inches, a grid setting of .05 
causes the arrow keys to move a box 5/100ths of an inch. The units of measure used for grid 
values are determined by the Measurements settings in Tools>Form Properties>General. 
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• 

• 

• 

• 

• 

Select a box and choose Tools>Box Properties>Position. In the Coordinates group, change 
the value in the X box to move a box left or right. Change the value in the Y box to move a 
box up or down. In the Offsets group, change the values in the Left and Top boxes to 
specify the relative position of a box to either the form or another box. Change the Left 
value to move a box left or right. Change the Top value to move a box up or down. For 
example, to stack all boxes as close to each other as possible, type 0 in the Top box. All 
boxes must float for this to work. 
Select a box and choose Edit>Cut to cut the box. Select the box you want the cut box to be 
placed under and choose Edit>Paste to paste the box in the new location. 

Techniques for Moving Boxes 
Sometimes moving a box can re-order boxes unintentionally. To avoid problems, save the 
form frequently. Then if you try to move a box and the boxes are disordered, just choose 
Form Operations>Open Form. When asked if you want to save the form, select No, then 
reload the form you were working on. The most recent change(s) will be lost, but you will 
have the most recently saved version to begin working on again. 
Avoid using the plain arrow keys to move a box up or down (especially when moving 
between two other boxes), or to move a box to the very top of a form. Instead, drag the box 
with the mouse or use the Ctrl+arrow keys. In some situations, using the plain arrow keys 
is difficult because the selected box either pushes boxes below it down or bumps into boxes 
above it. 
To move a box between two horizontal boxes, move at least one of the other boxes to make 
room. For example, move box B to the right to make room for box C, then move box C up. 

 
• When placing boxes side-by-side, anchor the right-most box to the box immediately to its 

left (choose Tools>Box Properties>Position). You can anchor different type boxes to each 
other. You can also align boxes by choosing Tools>Align Boxes and clicking the alignment 
you want. For more information about anchoring boxes, see “

” on page 234. 
Floating and anchored form 

boxes
Tip! To anchor and align boxes in one step, choose Tools>Align Boxes>Anchor and Top. 

• Sometimes, it is more convenient to swap box contents and labels instead of moving the 
boxes. Select a box and choose Tools>Box Properties to change its content. For form and 
script input boxes, also use the Labels tab to change the box label. 
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To change the Tab order of boxes 
You can change the order in which the Tab key cycles through boxes in forms used in the Edit 
and Display windows. Be sure the Tab key cycles through boxes in a logical order (from the top 
of the form to the bottom) and that it skips any uneditable boxes (for efficiency). DB/TextWorks 
skips picture boxes and text boxes by default. You should also skip uneditable boxes containing 
information such as computed fields or fields from a secondary textbase. 

1. Choose Tools>Tab Order. 

2. Specify the tab order you want: 

– To reset the tab order to match the order in which boxes appear on the screen, click the 
Reset to Default Tab Order button. This is helpful if you have re-ordered boxes and 
you want to quickly reset the tab order.  
Note: The default order will list boxes in top-to-bottom order. However, there is no 
guarantee that boxes positioned next to each other will appear in left-to-right order. 

– To manually re-order boxes, select a box from the Current Tab Order list and use the 
Up and Down buttons to change its order. The Tab key will start at the first box in the 
list and cycle through boxes in the specified order.  
Note: The first box in the list is the one the cursor will be in when you display or edit a 
record using this form. 

– Select the Skip this Box check box if you want the Tab key to skip the selected box. 
For example, you could skip an uneditable box in a form used in the Edit window. You 
usually skip boxes that hold any content except fields, unless they are script input boxes 
or script buttons. For example, skip a text box that holds fixed text, such as instructions 
or a form box that contains a variable. 

3. Click OK. 

212 Chapter 5: Working with Forms 



 

Setting Box Properties 
When you add boxes to a form, there are many properties you can specify. 

• 
• 
• 
• 
• 
• 
• 
• 
• 

Content 
Height 
Width 
Anchoring 
Labels 
Borders 
Scroll bars 
Paragraph format 
Text format 

Because every attribute listed above is not applicable to all types of boxes, each box type is 
discussed individually in this section. 

Form Boxes 
Form boxes are used on a form to display data from one or more fields in a textbase. To add a 
form box, choose Edit>Add>Form Box, then use the Form Box Properties dialog box (which 
opens when the box is added) to specify numerous attributes for it. For an existing form box, 
choose Tools>Box Properties to open the Form Box Properties dialog box. 

Form box content 
A typical form box contains one or more fields, but you could also include fixed text, variables, 
calculations, or other content items (one or more per box). You use the Contents tab on the Form 
Box Properties dialog box to define form box content. Putting multiple items in a box can be 
especially useful in reports. For example, you may want to put the Street, City, State, and Postal 
Code fields in one box. Use ending text (choose Tools>Box Properties>Format>Added Text) 
to insert a comma after each field except State and Postal Code. 

Tip! When you design an Edit form, place only one field in each box in order to be able edit it. 
You can only edit fields from the primary textbase; however, you can place secondary textbase 
fields in a form for display purposes. Secondary textbase fields do not need to be placed in 
separate boxes because they cannot be edited from an Edit form designed in the primary 
textbase. You can place them in a box with no border and show them in a different color or font 
to distinguish them. 
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To specify form box content 
1. Add a form box by choosing Edit>Add>Form Box. The Form Box Properties dialog box 

opens. (If you select an existing box, choose Tools>Box Properties to open the Form Box 
Properties dialog box. Do not select more than one box at a time when specifying box 
content.) 

Note that the Contents tab, which displays by default, contains two main areas: 

– The Contents list shows the contents of the selected form box. The order of items in this 
box reflects the order of items in the form box. If the list is empty, the form box has no 
contents. 

– The five subtabs (Fields, Sort Keys, Variables, Text, and Calculations) contain the 
settings that you use to specify the form box’s content item type. Each subtab and its 
settings are described in detail on the following pages. 

Use the subtabs on 
the Contents tab to 
define the selected 
content item. 

The Contents area shows 
what is in the current 
form box. 

 
2. Select a subtab on the Contents tab and use its settings to specify the form box content item. 

(For example, if you select the Fields subtab, choose a field from the Fields list; if you pick 
the Variables subtab, choose a variable from the Variables list). Click Add. 

3. Repeat step 2 as needed, to place multiple content items in the form box. Multiple items in a 
form box are separated by spaces by default. 
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4. [Optional] Use the Up and Down buttons to move a selected item if you want it to appear in 
a different order in the form box. When you add a content item, it is placed at the bottom of 
the Contents list and positioned last in the form box. The following illustration shows a box 
labeled Info that contains five items: the Type field (indicates the type of document), the 
word from (fixed text), the Author field, the word dated (fixed text), and the Date field. 
Each item appears in the box in the same order as it appears on the Form Box Properties 
dialog box. 

 

Note: You can use paragraph breaks (choose Tools>Box Properties>Paragraphs) to make 
multiple content items appear as a single paragraph (as shown above) or as a list (stacked 
one above another). Also, you can use Tools>Box Properties>Format>Added Text to add 
commas and other formatting. 

5. [Optional] To redefine a content item, select it from the Contents list. Then, use the subtabs 
on the Contents tab to make the change you want and click the Replace button. 
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6. [Optional] To remove an item, select it from the Contents list, then click the Delete button. 

7. Click Close when done. 

Fields Subtab 
Because a form box often contains a field, the Fields subtab is selected by default when the Form 
Box Properties dialog box opens. You can include any field from a primary or linked secondary 
textbase in a form box. 

To include a field in a form 
1. In the Form Designer, choose Edit>Add>Form Box to add a form box and open the Form 

Box Properties dialog box. (If you select an existing form box, choose Tools>Box 
Properties to open the Form Box Properties dialog box.) 

2. On the Fields subtab of the Contents tab (which is selected by default) select a field from the 
Fields list. For example, if you select the Title field, the content of that field (such as, 
Myths and Magic) will appear in the form box when the form is used. 

3. Click the Add button to move the field into the Contents list. 

4. Click Close. 

Fields from a secondary textbase are called linked fields and are designated by the link indicator 
(@). For example, the field Client name@Assignment ID is a linked field. Linked fields in the 
textbase are listed after fields in the primary textbase in the Fields list, by default. However, if 
you have selected the Sort textbase fields alphabetically check box on the Display tab of the 
Options dialog box (choose Tools>Options>Display), the secondary textbase fields will be 
interfiled with the primary fields. 

Add a linked field whenever you want to see information from a secondary textbase. You cannot 
add linked fields unless the textbase contains at least one Link field. For more information about 
linking, see Chapter 8, “Linking Textbases.” 

Optionally, in the If empty use box, type the text you want to appear in the form box if the field 
you specified is empty. For example, if a field is empty, you might want the word unknown to 
appear. The text you specify will not appear when the field contains information. Because the 
text is part of the form, it does not appear when you edit a record, nor can you search for it from 
a query screen. 

Sort Keys Subtab 
A Sort Key is a field by which records are sorted in a report. Sort Keys work like variables. For 
example, if you sort by Department and subsort by Date, the Department field is Sort Level 1 
and the Date field is Sort Level 2. If you later sort by Subject then Date, the Subject field will be 
Sort Level 1. 

Note: Sort Keys do not appear when a form is used in the Display or Edit window because those 
windows display just one record at a time. They also do not appear if you use the Send Report 
as Mail>Mail each record to a different address feature because you are sending only one 
record in each message. 
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To add Sort Keys to a form 
1. In the Form Designer, choose Edit>Add>Form Box to add a form box and open the Form 

Box Properties dialog box. (If you select an existing form box, choose Tools>Box 
Properties to open the Form Box Properties dialog box.) 

2. On the Sort Keys subtab of the Contents tab, select the appropriate level from the Sort keys 
list. 

3. Click Add to move your selection to the Contents list. 

4. Click Close. 

There is no difference between specifying a Sort Key and a field as box contents, if the form has 
a compulsory sort (so it cannot be sorted in any other way) and the sort field never has more than 
one entry. If either of these conditions is not true, use a Sort Key instead of a field. 
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Sort Levels are determined by the current sort order, which may be defined after a search 
(choose Display>Sort Report), as part of the form (choose Report Options>Compulsory 
Sort), or as the textbase default (choose Maintain>Edit Textbase Structure, then click the 
Sort Order button). For example, if the form has a compulsory sort on Date and you add a Sort 
Key Level 1, that box will display dates. 

Note: If you use a form that has a compulsory sort, it is the sort used, regardless of other types of 
sorts that may be specified. If the form does not have a compulsory sort, the current 
user-specified sort takes precedence. If neither of those sorts is specified, the textbase default 
sort is used, if any. Lastly, if no sort of any kind is specified, records appear in the approximate 
order that they were added to the textbase. 

Sort Keys are used primarily in a Sort Header or Sort Footer box in a report (Report Options> 
Headers and Footers). When you insert a Sort Header or Footer, the Sort Level you select is 
added to the form box automatically. You do not have to select it on the Form Box Properties 
dialog box. You can, however, use the Form Box Properties dialog box to change the Sort Key 
setting, add other information to a box, and so forth. 

Each Sort Header will appear before a group of records at that Sort Level. For example, the Sort 
Header might be Sales Person (Sort Level 1) and the Sort Footer would be a subtotal based on 
that sales person (again, Sort Level 1). A compulsory form sort would be added to ensure that 
the report could only be sorted by Sales Person (so Sort Level 1 always equals Sales Person). 

Sort Header Level 1: Sales Person field 

Sort Footer Level 1: a calculation 

 

Tip! For more about Sort Keys, see “ ” on page 270. Sort Headers and Footers

Variables Subtab 
A variable is an item with a value that varies, unrelated to information in the record, depending 
on certain factors. For example, the DATE variable displays the current system date. Some 
variables are intended to be used in a specific area of the form. For example, PAGE NUMBER only 
makes sense in the Margin Area, while RECORD NUMBER only makes sense in the Record Area. 
A variable in the Margin Area of a form is visible only when the report is printed. 

To add a variable to a form box 
1. In the Form Designer, select a form box and choose Tools>Box Properties to open the 

Form Box Properties dialog box. 

2. On the Variables subtab of the Contents tab, select a variable. Each variable is summarized 
in the table in this section. 

218 Chapter 5: Working with Forms 



 

3. Click the Add button to move your selection to the Contents list. 

 
4. Click Close. 
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The following table lists the available variables and their uses. 

Variable Explanation 
DATE and TIME The DATE and TIME variables display the system date and time. Use 

them to indicate when a report was generated or printed. To make the 
date and/or time appear on every printed page, place one or both 
variables in a box in the Margin Area. Date and time formats are 
controlled by the formats selected in the Regional settings of the 
Windows Control Panel. To further change the appearance, use 
Tools>Box Properties>Format. 

PAGE NUMBER The PAGE NUMBER variable generates page numbers in a printed 
report. Put the PAGE NUMBER variable in a box in the Margin Area, 
so it prints on every page. Each page is numbered with Arabic 
numerals, starting with 1 or the number you specify. To change the 
starting page number, see “ ” on page 288. 
Because the page number appears in the Margin Area, you would not 
include the PAGE NUMBER variable in a form not used for printing. 
For more information, see “ ” on page 284. 

RECORD NUMBER The RECORD NUMBER variable numbers each record sequentially in a 
report. Use this variable in the Record Area of a form, typically in a 
separate box to the left of the record information. For more 
information, see “ ” on page 285. 

RECORD COUNT The RECORD COUNT variable displays the total number of records in 
the set. For example: 

 
Use the RECORD COUNT variable in a Report Header or Report Footer 
box in the Record Area of a Report form. Be careful if you use the 
RECORD COUNT and RECORD NUMBER variables together in an 
exploded sort, because you could end up with something like Record 
96 of 53. The RECORD NUMBER variable counts all occurrences of all 
records (and each record may appear multiple times). In this 
situation, use a COUNT(1) calculation instead of the RECORD COUNT 
variable. (Note that this only works in Report Footers.) 

TEXTBASE NAME The TEXTBASE NAME variable displays the name of the current 
textbase. You may find it useful to display the textbase name in a 
Report Header box in a printed report.  

SEARCH The SEARCH variable displays the search criteria that generated the 
set of records in the report. The SEARCH variable is typically used in 
a Report Header box in a report. The SEARCH variable shows the 
search criteria in Command query format. You may want to precede 
the SEARCH variable with text (for example, Search 
Strategy:), which you can enter as beginning text. 

Setting Up the Report Page

Numbering Pages

Numbering records
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Text Subtab 
There are two types of text you can add to a box using the Text subtab: fixed text and prompted 
text. To add fixed or prompted text, select the Text subtab on the Contents tab and select either 
the Fixed text or Prompted text option button. Then type what you want in the Text box. 

Fixed Text 
Fixed text is text that will always appear in the form box exactly as you type it on the Form Box 
Properties dialog box. Fixed text can include and/or combine text, numbers, spaces, line breaks, 
variables, and extended characters, but not the Tab character. 

To add fixed text, select the Fixed text option button on the Text subtab, then type the text you 
want in the Text box or click the Enlarge button to open a larger, resizable text editor dialog 
box instead. When you click OK on the text editor dialog box, what you typed appears in the 
Text box automatically. 

Tip! A text box also contains information that does not change (for example, report title, 
company name). Use a text box instead of fixed text when all you need in the box is text and you 
do not need to combine elements or change the appearance of part of the text (for example, to 
make one word boldface). 

Click the Enlarge button to 
open a larger, resizable text 
editor. This can be helpful 
when typing lengthy fixed 
text. 
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You can combine fixed text with other content items, such as inserting Page in front of the 
PAGE NUMBER variable to achieve an effect such as Page 1. Be careful if you combine fixed 
text with field information, because the fixed text will appear even if the field is empty. For 
example, if you place Written by in front of the Author field, Written by will appear 
even if the Author field is empty. To avoid this situation, make Written by added text, 
instead of fixed text, by specifying it on the Added Text subtab on the Format tab of the Form 
Box Properties dialog box (Tools>Box Properties>Format>Added Text). 

Content items are automatically separated by spaces by default, so you do not have to include a 
space before or after fixed text. 

Tip! If you do not want these spaces to appear, select the Paragraphs tab and clear the Separate 
items or entries with spaces check box. If you want to combine punctuation with space 
separation, use beginning or ending text (Tools>Box Properties>Format>Added Text). To 
specify punctuation, you should use added text rather than fixed text. 

Adding Text and Punctuation to Field Information 
To add text and punctuation to a field in a form, you can define it as fixed text, added text, or as 
a label. Each method has its own benefits. 

 
If you want…                                       Use: 

Fixed 
text 

Added 
text 

Box 
label 

Text to disappear if the field is empty                * 
No space between text and the field        **           
Text to be a different font or color than the field             
The additional text to be visible in an Edit form         
Text and fields for multiple boxes to be aligned         
 
* The label will disappear only if the box is empty and the minimum box height is 0 lines. 

** Use fixed text only if you have cleared the Separate items or entries with spaces check box on 
the Paragraph tab of the Box Properties dialog box. 

When to Use Fixed Text 
Use fixed text for text that should always appear, such as the title of a printed report or 
instructions on a form. Also use fixed text when you want the text to be a different font from the 
other box contents and using a label is not appropriate. In the following example, the fixed text 
Record ID: is a normal font, while the Record ID field is bold: 

Record ID: 0123 

A box that contains fixed text will never disappear (even if its minimum height is set to zero), 
because it will never be empty. 

To add punctuation, use added text instead. 
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When to Use Added Text 
Use added text (Tools>Box Properties>Format>Added Text) to add text or punctuation that 
appears only when the field contains information. When the field is empty, the added text will 
not appear. Compare this to fixed text, which always appears. Added text has the same font as 
the content item it modifies. If this is a problem, use fixed text or a box label instead. Note that 
added text does not appear in the Edit window. For more information, see “

” on page 249. 
Adding Text and 

Punctuation and Separating Multiple Entries

When to Use Labels 
Use labels (choose Tools>Box Properties>Labels) to identify what is in a box. Labels are 
especially useful for Edit forms when one or more of the following conditions exist: 

• 
• 
• 

The field is the only content item or the label is appropriate for everything in the box. 
You want the label text to appear in a different font or color than the content. 
You want the label text outside the box border, if a border is present. 

If you use a box label to add text to a form, and the minimum box height is zero, the label will 
disappear when the field is empty (except in the Edit window, where empty boxes do not 
disappear). For more information, see “ ” on 
page 237. 

Adding labels, borders, and scroll bars to form boxes

Prompted Text 
Prompted text is a question or an instruction that appears when you use the form. The user’s 
response to the prompt will appear in the report. To add prompted text, select the Prompted text 
option button on the Text subtab and type the prompt that you want users to see. For example, 
type Enter the distribution list for this report. Click Add. 

Tip! If you want the response to appear on every page of a printed report, use a box in the 
Margin Area. 

When the report is used on the desktop, the Information Needed dialog box will open. 

prompted text

user’s response
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The user’s response will be included in the report when it is displayed, printed, written to a file, 
sent as EMail, and so forth. Note that prompted text is applicable to desktop use only and is not 
used with WebPublisher products. 

Tip! You can add beginning text (choose Tools>Box Properties>Format>Added Text) in 
front of the prompted text. In the report shown below, the words Distribute to: are 
beginning text. 

 

Calculations Subtab 
Calculations operate on numeric and date information. You can add, subtract, multiply, divide, 
compute averages, subtotals, grand totals, and find the highest or lowest value in a field or group 
of records. To specify a calculation, select the Calculations subtab on the Contents tab and type a 
formula in the Calculation formula box, or click the Enlarge button to open a larger, resizable 
text editor dialog box instead. When you click OK on the text editor dialog box, your text 
appears in the Calculation formula box automatically. Click Add. Then, when you use the 
form, DB/TextWorks performs the calculation and displays the results in the box. 

Tip! Use calculations in the Record Area. Do not use them in the Margin Area. 

User’s response 
preceded by 
beginning text 
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A few examples of the many types of calculations you can use with DB/TextWorks appear in the 
following table. Note that case is not significant when you type a formula. For example, if a field 
is called Date, you can refer to it as date. (Capitalization is used in the following examples for 
clarity only.) Field names that include spaces require quotation marks around them. 

This calculation…   Does this… 
ordered – shipped Calculates how many units are backordered by subtracting the 

quantity shipped (Shipped field) from the quantity ordered 
(Ordered field). The result is a number (such as 20). 

"invoice date"+90 Calculates when an account is overdue by adding 90 days to 
the first date found in the Invoice Date field. The result is a 
date (for example, 10/12/2002). 

MIN(price) Calculates the lowest value in the Price field in a group of 
records. 

FAVG(score) Calculates one student’s grade point average by averaging all 
entries in the Score field in the current record. The result is a 
number, such as 85. 

The results of a numeric or date calculation are formatted based on the formats selected in the 
Regional settings of the Windows Control Panel and the options you select for this content item 
using Tools>Box Properties>Format>Numbers, Dates. 

Tip! A calculation specified in a form cannot be searched or sorted because it is not a field. If 
you want to be able to search or sort computed information, edit the textbase structure to add a 
Computed Number or Computed Date field. 

A calculation can include the following components, which are explained on the following 
pages: 

• 
• 
• 
• 
• 

Field names, including secondary fields 
Numbers 
The current system date (@DATE)  
Field Functions (FCOUNT, FTOTAL, FMIN, FMAX, FAVG)  
Record Functions (COUNT, TOTAL, MIN, MAX, AVG) 

To connect components in a calculation (such as two field names), use the following symbols:  

+ for addition (cost+shipping) 
- for subtraction or to represent negative numbers (gross-net) 
* for multiplication (cost*.15) 
/ for division (cost/12)  

In complex calculations, you can include parentheses for clarity, such as: 

(price-cost)/(number*12) 
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Using Fields in Calculations 
A calculation can include any field from the primary or secondary textbase that contains a 
number or date. For example, this calculation determines how many units are on backorder by 
subtracting the number of units shipped from the number of units ordered: 

ordered - shipped 

Use single or double quotation marks around field names that start with numbers or contain 
spaces, such as '24' or "date sold". 

When a calculation references any non-date field, the software looks for a number at the 
beginning of that field. For example, in this calculation, DB/TextWorks expects to find a number 
at the beginning of the Price field: 

price*2 

The number can be preceded by a space, a currency symbol ($, £, and so on), a minus sign (-), or 
a left parenthesis, and it can contain an embedded thousand separator and decimal separator. The 
number cannot be preceded by any other characters. For example, 345 is a number, and so is 
$345.00, but Commission $345 is not. 

If the field is empty or if it does not start with a number, zero (0) is used in the calculation. 

Tip! Only the first entry in a multiple-entry field is used in a calculation. To compute across 
multiple entries, use a Field Function. For example, use FTOTAL(quantity) to total all the 
entries in the Quantity field in the current record. 

To indicate a secondary textbase field, use the @ symbol field name convention explained in 
Chapter 8, “Linking Textbases.” The following example computes the customer discount by 
multiplying a field in the primary textbase (Price) by the discount amount in a secondary 
textbase: 

price*discount@custID 

Include quotation marks if the field name includes spaces. Do not include the @ sign inside 
quotation marks. For example, this is correct: 

price*"customer discount"@"customer ID" 

Using Numbers in Calculations 
A calculation can include any whole number or fraction. The number is interpreted as a value or 
a number of days, depending on whether the calculation references a Number or Date field. For 
example, consider this calculation: 

sold+30 

If Sold is a Number field (quantity sold), the calculation adds 30 to the quantity to yield a 
number. If Sold is a Date field (or an Automatic Date or Computed Date field), the calculation 
adds 30 days to yield a date. 
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Using Dates in Calculations 
To include dates in a calculation, reference a Date, Automatic Date, or Computed Date field 
("date sold"+1) or use @DATE to represent the current date. If you subtract two dates, the 
result is a number of days. If you add or subtract a number of days from a date (bought-30), 
the result is a date. Do not include a static date as part of a calculation. For example, 
"12-10-98"+1 is not a valid calculation. 

Type @DATE in the Calculation formula box if you want to show the current system date. 
Think carefully before using @DATE as part of a calculation, because the date generated changes 
daily. For example, @DATE+14 yields a different date on June 1 than it does on June 2.  

To generate a constant date, add an Automatic Date field to the textbase structure and specify 
that the entry should be updated only when the record is created (not modified). Then you can 
design a form that includes a calculation based on that static date. For example, the calculation 
"date borrowed"+14 could be used to show that a book is due 14 days after the date 
borrowed. 

Using Field Functions in Calculations 
Use a Field Function for summary calculations on the entries in a field in the current record. You 
usually put a Field Function in a Record box. Follow a Field Function by the name of a field in 
parentheses. For example, FMIN(price) finds the lowest value in the Price field in the current 
record. 

A Field Function computes a value based on the entries in a field in a single record. These 
functions can be used in a calculation defined in a form, or in the formula for a Computed field 
in the textbase structure. 

Field Function Description 
FMIN(field) Determines the lowest value of all entries (numbers and dates only) 

in the specified field for the current record. 
FMAX(field) Determines the highest value of all entries (numbers and dates only) 

in the specified field for the current record. 
FAVG(field) Averages all values in the specified field for the current record. Only 

numbers can be averaged (not dates). 
FCOUNT(field) Counts the number of entries in the specified field for the current 

record. Can be used with textual information, as well as numbers and 
dates. 

FTOTAL(field) Adds all entries in the specified field in the current record. Only 
numbers can be totaled (not dates). 
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Using Record Functions in Calculations 
Unless combined with a Field Function, a Record Function uses only the first entry in a 
particular field across a group of records. Record Functions only make sense when used in a 
report, because they operate across multiple records in a group. A group means all of the records 
in the current report or Sort Level. For more information, see “ ” on 
page 230. 

Where to Place a Calculation

Follow a Record Function with a parenthetical expression. For example, MIN(cost) finds the 
lowest value in the first entry in the Cost field in all records in the group. Unlike Field Functions, 
parenthetical information is not limited to a field name. Record Functions can be followed by an 
entire expression, such as AVG(FMAX(price) - FMIN(price)). 

Record Functions only use the first entry of a field in each record, unless they are combined with 
a Field Function. For example, TOTAL(price) only totals the first entry in each record’s 
Price field, but TOTAL(FAVG(price)) totals the average price in each record. 

Record Function Description 
MIN(field) Determines the lowest value in a group of records (numbers and 

dates only). 
MAX(field) Determines the highest value in a group of records (numbers and 

dates only). 
AVG(field) Averages the specified field across a group of records (numbers 

only). 
COUNT(field) Counts the non-zero numbers in the first entry of the specified 

field, across a group of records. 
COUNT(1) Counts all records, even if they do not start with a number. 
TOTAL(field) Finds the sum of the specified field across a group of records. 
 

Note: All of the Field Functions are similar to Record Functions with the exception of FCOUNT 
and COUNT. While the other functions look only at numbers or dates in the field, FCOUNT 
counts all entries, even alphabetic ones. COUNT looks at non-zero numbers only. 

Finding the Lowest Value 
Use FMIN or MIN to find the lowest number or earliest date, within the guidelines presented in 
the Field Function and Record Function tables shown previously. Here are some examples:  

• 

• 
• 

MIN(price) finds the lowest price among first entries in the Price field in a group of 
records. 
FMIN(price) finds the lowest price in all entries in the Price field in the current record. 
MIN(FMIN(price)) finds the lowest value in any entry in the Price field in the group of 
records. 
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Finding the Highest Value 
Use FMAX or MAX to find the highest value or most recent date, within the guidelines presented 
in the Field Function and Record Function tables. Here are some examples: 

• 

• 
• 

MAX("order date") finds the most recent date that a product was ordered, by looking 
at the first entry in the Order Date field in all the records in the group. Notice that a field 
name that contains a space must be surrounded by quotation marks. 
FMAX(contact) determines when a customer was most recently contacted. 
MAX(FMAX(price)) finds the highest value in any entry in the Price field in the group of 
records. 

Finding Averages 
Use FAVG or AVG to determine averages, within the guidelines presented in the Field Function 
and Record Function tables shown previously.  

Tip! The calculation AVG(field) finds the average value across all records—even those 
containing no number or the number zero in the specified field. To average only numbers greater 
than zero, use TOTAL(field)/COUNT(field). 

To average… Do this… 
Multiple entries in a field Use FAVG. For example, place the calculation 

FAVG(score) in a box. If John Jones has three test 
scores in the Score field (80, 81, 85), the calculation will 
produce his average: 82. 

The first (or only) value  
in a field in a group of records 

Use AVG in a Sort Footer or Report Footer. For example, 
use AVG(price) in a Sort Footer to find the average 
price of records in a sort level. Use AVG(price) in a 
Report Footer box to find the average price of records in a 
set. Use AVG(price*quantity) to find the average 
sale amount. 

All entries in a field in a  
group of records 

Use AVG(FAVG(field)) in a Sort Footer or Report 
Footer. For example, to find the average of all entries in 
the Price field in the current group, use 
AVG(FAVG(price)). 

Counting Records and Field Entries 
Use FCOUNT to count the number of entries in a field in the current record. For example, if a 
record has three entries in the Author field, FCOUNT(author) will return 3.  

Use COUNT to count how many records start with a non-zero number in the specified field in a 
group of records. Fields that do not start with a number will not be counted. To count all records 
(even if they do not start with a number), use the convention COUNT(1). 
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Use COUNT(1) in a Sort Footer box to count all records in that Sort Level. Use COUNT(1) in a 
Report Footer box to count all records in the report. 

Note: In an exploded sort, COUNT(1) counts each occurrence of a record (a record may appear 
more than once in the report), so the number of records counted is almost always greater than the 
number of records in the set. 

Here are some examples: 

• 

• 
• 
• 

• 

• 

• 

• 

COUNT(price) counts the number of records that start with a non-zero number in the first 
entry of the Price field. The result is a number, such as 12. If the Price field in a record 
starts with text or does not contain a number, it is not counted. 
COUNT(1) counts all records.  
FCOUNT(author) counts the number of entries in the Author field in the current record. 
TOTAL(FCOUNT(author)) counts the number of entries in the Author field in all 
records in the group. 
COUNT(FCOUNT(author)) tells you how many records have at least one author. 

Producing Summary Calculations 
You typically place subtotals in a Sort Footer box and grand totals in a Report Footer box. Here 
are some examples:  

TOTAL("total price") in a Sort Footer box totals the price of each order in the 
corresponding Sort Level group. For example, you can calculate the total price of all orders 
in this region. 
TOTAL("total price") in a Report Footer box totals the price of all orders in the 
report. 
AVG(@DATE–"invoice date") in a Report Footer box shows the average age of 
receivables. 

• COUNT(1) in a Sort Footer box shows how many records are in that Sort Level group. 
For more information about subtotals and grand totals, see “ ” on page 272 
and “ ” on page 274. 

Adding Sort Footers
Adding Report Footers

Where to Place a Calculation 
You typically place a calculation in the Record Area of a form, in one of the three box types: 
Record box, Sort Footer box, or Report Footer box. For more information about the different 
box types, see “ ” on page 275. Areas of a Form

Areas of a Form

Record Box 
Use a Record box to calculate information in the current record. For example, 
cost+shipping will add the first entries in each of those two fields, to display a different 
value for each record. To use all entries in a particular field in the current record, use a Field 
Function in a Record box. For more information about Record boxes, see “ ” on 
page 275. 
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Sort Footer Box 
Use a Sort Footer box for subtotals or other summary calculations on records with a particular 
Sort Key. Record Functions in a Sort Footer box operate within the current sort level (on all 
records that share the Sort Key at the specified sort level). For example, if TOTAL(cost) is 
placed in a Sort Footer box, and the report is sorted by the Product field, the calculation finds 
subtotals by product. The result might be $300 in the Widgets category and $500 in the Gadgets 
category. For more information about Sort Footer boxes, see “ ” on 
page 272. 

Adding Sort Footers

Report Footer Box 
Use a Report Footer box for grand totals or other summary calculations on all records in the 
report. When you place a calculation in a Report Footer, it appears only once at the end of the 
report. Record Functions in a Report Footer box operate across all records in the set. For 
example, if TOTAL(cost) is placed in a Report Footer box, the result is a grand total. For 
more information about Report Footer boxes, see “ ” on page 274. Adding Report Footers

Specifying form box height, width, and anchoring 
When designing a form, you can decide how much information will be visible in a box, how the 
boxes look on the form, and how they interact with each other. 

Use the Position tab on the Form Box Properties dialog box (choose Tools>Box 
Properties>Position) to determine the height, width, and anchoring attributes for a form box. 

Changing form box height 
Note: The following information is also applicable to script input boxes. 

An important part of designing a form is deciding the height of each form box. Form box height 
determines how much content is visible. To accommodate variable amounts of information for 
each record, a form box can shrink or grow within the minimum and maximum lines you 
specify. When the minimum and maximum lines are the same, the box remains a fixed height, 
regardless of how much information it contains. Usually, this is not recommended unless you are 
trying to copy the look of a pre-printed form. 

Minimum height 
The Minimum height setting determines how small a form box can shrink. A form box will 
never be shorter than the value you specify. For example, if you specify two lines, the form box 
will always be at least two lines high, regardless of how much or how little information the form 
box contains. If you set Minimum height to zero, the form box will disappear when empty, 
unless it is an editable box on an Edit form. 

Maximum height 
The Maximum height setting determines how large a form box can grow. For example, if you 
specify four lines, the box will never display more than four lines of information. 
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If you want a box to display all of its information, even if it is several paragraphs or pages long, 
select unlimited. This is especially important in displayed and printed reports, where you cannot 
scroll to the information that is not visible. 

In the Display and Edit windows, a box will never be taller than the window, regardless of the 
Maximum height setting. 

Note: Label forms limit printed information to the label size, regardless of the Maximum height 
setting.  

As you decide on the maximum height of a form box, consider the purpose of the form. A 
summary report that shows records found by a search should probably keep the default setting. 
Here are some reasons why you may want to limit form box height: 

• 
• 
• 
• 

To ensure the form will not exceed the page or screen size. 
To limit the amount of information in a summary report. 
To truncate long company names when printing mailing labels. 
To prevent a form box from overlapping a box below it that is anchored to the form. (If 
boxes float, overlapping is not a concern.) 

Hiding empty form boxes 
To hide an empty form box, set Minimum height to zero. When the form is used, the form box 
will disappear when it is empty. You will not see its label, border, or scroll bars. For example, if 
you place the Description field in a form box and that field is empty for a particular record, the 
form box will disappear completely in that record. Any floating form boxes below it will move 
up automatically. 

If the Minimum height is greater than zero and a form box is empty, the form box will still 
appear—but it will be blank. If it has a border or label you will see them. 

Note: While you are working in the Form Designer, form boxes never disappear. If they did, you 
could not edit them. To see how a form looks with disappearing form boxes, choose 
Display>Preview, and display a record with an empty field in a box where the Minimum 
height setting is zero. 

There are several reasons why a form box may be empty: 

• 
• 
• 

• 

It may contain a field that does not have any entries. 
It may contain a field that is hidden by a password. 
It may contain a field from a secondary textbase for which there is no matching record. 

Here are some guidelines to help you decide whether to hide empty form boxes: 

Forms used in the Display or Report windows. Hide empty form boxes so the user does 
not have to look at blank lines. 
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• Forms used in a printed report. Hide empty form boxes to make a printed report shorter 
and more legible. 

Note: In some cases, you may want to show an empty form box to draw attention to the lack of 
content. 

• 

• 

Forms used in the Edit window. Empty form boxes for single fields are never hidden in 
the Edit window, even if you set Minimum height to zero, unless the field is hidden by a 
password. The Edit window needs to show empty form boxes so users can enter information 
when creating or editing a record. 
Any form type. Hide empty form boxes if they contain a field that may be hidden by a 
password. Otherwise, a user whose password hides a field will see an empty area on the 
form where that field would have appeared. If the form box has a label, it may 
unintentionally identify the hidden information. 

Changing form box width 
Note: The information in this section also applies to text and script input boxes. 

Make each form box wide enough to display its contents without unintended wrapping. 
Information wraps to the next line when it reaches the right edge of a box, as shown in the form 
box below. 

• 

• 

 

To change form box width 
Use either of these methods to change form box width: 

Select one box and place the cursor over the left or right box handle. The cursor becomes a 
double-headed arrow. Drag the box handle to the left or right.  
Note: If multiple boxes are selected, you cannot use the mouse to change the width. 

Select one or more boxes, choose Tools>Box Properties>Position and change the value in 
the Width box. 
Note: Use Tools>Form Properties>General to specify the measurement unit for the Width 
settings on all Box Properties dialog boxes. 
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Floating and anchored form boxes 
Note: The information in this section applies to all box types. 

Form boxes in DB/TextWorks can contain variable-length fields, so a field in a form box may be 
very short in one record and very long in another. For example, a Description field may contain 
just a few words about John Smith but three paragraphs about Sue Jones. Because text boxes 
grow with the amount of text they contain, the size of these boxes can vary as well. To 
accommodate variable information, form, picture, and script input boxes in a form can shrink or 
grow within the limits that you specify. As the height of a box changes, it can affect the position 
of the boxes below it. You can specify whether each box should be floating, anchored to the 
form, or anchored to another box. 

Note: A script input box will not grow to accommodate text on Report window forms. However, 
the above applies to script input boxes in the Query, Display, and Edit windows, as well as on 
menu screens. 

Floating boxes 
A floating box is one whose vertical (up or down) position varies, depending on the height of the 
box(es) directly above it. Floating boxes move up or down automatically, depending on the 
amount of information that is displayed in the box above them. As one box grows or shrinks, the 
floating boxes beneath it automatically float down or up. In most cases, let all boxes in the 
Record Area float (they do, by default). This ensures that information in one box will never 
overwrite information in another box. 

 

To make a box float 
1. In the Form Designer, select one or mor

2. Choose Tools>Box Properties to open 

3. On the Position tab, select the Floating 

4. Click Apply. 
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Box B floats down when box A grows.
 

e boxes. 

the Box Properties dialog box. 

option button in the Anchoring group. 

 



 

Anchoring to the form 
When you anchor a box to the form, the box remains fixed in its current position, regardless of 
what the other boxes do. The box can still shrink and grow, but the top left position will not 
change. When you anchor a box to the form, the box never moves. This can be useful when 
laying out information for a pre-printed form, such as an invoice, or for printed labels on 
multiple label stock. By default, the first box added in the Margin Area is anchored to the form, 
because it usually contains information, such as a title, that you want in a fixed position. 

Tip! Because the position of an anchored box is fixed to the form, information in the box may be 
obscured if a box above it grows. To avoid this situation, be sure to limit the maximum height of 
any boxes above the anchored box. 

 

If box C is anchored to the form, and box A or B expands, 
information could be obscured. To avoid this situation, 
limit the maximum height of boxes A and B. 

To anchor a box to a form 
1. In the Form Designer, select the box you want to anchor. 

2. Choose Tools>Box Properties to open the Box Properties dialog box. 

3. On the Position tab, select the Anchor to form option button in the Anchoring group. 

4. Click Apply. 
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Anchoring to another box 
You may want a box to be anchored to another box, so the two boxes move together when the 
form is used. Anchoring a box to another box is useful if you want two or more boxes to float up 
or down together. This keeps the boxes aligned or in the same relative position, even as the 
amount of information above or below those boxes shrinks or grows. For example, anchor box C 
to box B to ensure that both boxes move up and down together. When box A grows, both box B 
and C move down. 

Box C is anchored to box B, so they both 
move down when box A grows. 

 

Tip! Toggle View>Boundaries to show or hide the anchor-to-box arrows in the Form Designer. 
Showing the box boundaries will help you visualize the anchor-to-box relationships. 

Anchoring a box does not restrict its size. It can still shrink and grow vertically. Also, the box to 
which you anchor a box can be a floating box, anchored to the form, or anchored to another box. 
For example, in the above illustration box B is a floating box. 

You can anchor a box to another box only if both of the following conditions are met: 

• 

• 

The box you select must be to the right of the box to which you want to anchor it. For 
example, in the preceding illustration, you could select box C and anchor it to box B, but 
you could not select box B and anchor it to box C. 
The boxes must be next to each other. The boxes cannot be stacked above one another. 

To anchor a box to another box 

Tip! You can anchor boxes and align them along their top boundaries in one step by selecting 
them and choosing Tools>Align Boxes>Anchor and Top instead of using the following steps. 

1. In the Form Designer, select the box that you want to anchor. 

Tip! Always select the right-most box and anchor it to the box immediately to its left. 

2. Choose Tools>Box Properties to open the Box Properties dialog box. 

3. On the Position tab, select the Anchor to box option button in the Anchoring group. 

Note: The Anchor to Box option is disabled if more than one box is selected or if the 
current box cannot be anchored to any boxes. 
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4. Select the box you to which want to anchor the currently selected box from the drop-down 
list. Only boxes to the left of the current box appear in the list. Boxes are identified by their 
labels. Boxes without labels are identified by the first content item, shown in angle brackets, 
such as <field=Product>. 

5. Click Apply. 

Adding labels, borders, and scroll bars to form boxes 
Each form box in a form can have a label, borders, and scroll bars.  

To add labels, borders, and scroll bars 
Note: The information in this section also applies to script input boxes. 

1. Select one or more form boxes.  

2. Choose Tools>Box Properties to open the Form Box Properties dialog box. 

3. On the Labels tab, specify whether to show a label, border, or scroll bar by selecting the 
appropriate check boxes. Each option is explained on the following pages. 

Borders 
A border is a solid box around the contents. You can show or hide the border. 

Scroll bars 
When enabled, a vertical scroll bar appears on the right side of the form box. This lets users 
scroll easily through the information in a form box, even if the form box height is limited to just 
a few lines. Note that scroll bars only appear if you select the Scroll bar check box and the box 
height cannot accommodate the information contained in the box. 

Note: Horizontal scroll bars are not needed, because information always wraps at the right edge 
of a box.  

If you hide scroll bars on a Display or Edit form, users can still click in a box and use keyboard 
keys to scroll through the information. Scroll bars appear only in the Display and Edit windows, 
not in the Report window or on printed reports. 

Labels 
Tip! Before designing a new form, set the default font attributes for labels by choosing 
Tools>Options>Display and clicking the Set Label Font button. Saved forms are not affected. 

Labels identify form boxes. As you decide whether to label form boxes, consider the purpose of 
the form. In forms used for the Edit window, labels can provide instructions, such as Type 
last name only. Note that such a label would not make sense if you used the form for 
another purpose, such as record display. 

If you will not be using labels, it is most efficient to remove them early in the form design. 
When you turn off labels, form box positions are adjusted automatically. For example, if a label 
is at the left of a form box and you remove the label, the form box moves to the left. 
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When you select the Label check box on the Labels tab, the label text is automatically set to the 
first field name in the box. You can accept the default label, or change it by typing what you 
want in the Label box. 

Note: You cannot change label text using the Label box if multiple boxes are selected or if the 
Label check box is not selected. 

Specify where a label appears relative to the box by selecting an option (Top Left, Top Center, 
Top Right, or Left) from the Label position drop-down list. 

Setting Label Justification and Width 
If you select Left from the Label position drop-down list, you can set label justification and 
width. There are three options for justification: Automatic, Left and Right. 

Select Left from the Label 
position drop-down list to 
enable the Label justification 
drop-down list. 
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Automatic 
This is the default setting for label justification. The form box begins immediately after the label, 
and the label width varies to accommodate the label text. If you do not like the “ragged” look, 
select Right or Left from the Label justification drop-down list and specify the same label 
width for all boxes. 

 

 

Left 
This justifies a label to the left. Type a value in the Label width box to specify the width of the 
label. 

 

 

Right 
This justifies a label to the right. Type a value in the Label width box to specify the width of the 
label. 

 

Label position setting is Left and Label justification setting is Automatic.

Label position setting is Left and Label justification setting is Left.

Label position setting is Left and Label justification setting is Right. 

Tip! When justifying labels to the Right or Left, be sure to type a value large enough to 
accommodate the longest label. If you specify an inadequate width for a long label, the label text 
will be cut off. 

Setting Label Font and Color 
Choose Tools>Box Properties>Labels and click the Set Font button to specify a font, style, 
size, and color for the label text. The fonts that appear in the selection list depend on the 
currently selected printer. Printer fonts are shown in the Font list preceded by a printer icon. If 
you choose a printer font and then use the form to print to a different printer that does not 
support that font, the report may not appear as you expect. To change your printer selection, 
choose File>Print Setup. 
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Formatting paragraphs in form boxes 
A paragraph is a body of text ending in a line break. An entry always consists of at least one 
paragraph. A long entry may contain several paragraphs. The line break that defines a paragraph 
may be: 

• Part of the data (inserted using the Enter key) 
• Text formatting (choose Tools>Box Properties>Format>Added Text) 
• Paragraph formatting (choose Tools>Box Properties>Paragraphs) 
Before you start formatting paragraphs, you may find it helpful to: 

• 
• 

Define box contents (choose Tools>Box Properties>Contents). 
View actual record information. On the Display menu, if there is a View Records option, 
select it. If it is present, but unavailable, you have to perform a search first. If the menu has 
a View Content option, you are already viewing records. 

To apply paragraph formatting to a form box 
1. Select a form box and choose Tools>Box Properties>Paragraphs. 

2. Select an option from the Paragraph breaks drop-down list to control how multiple field 
entries or multiple content items appear in a box. 

– No added paragraph breaks. Ensures that no breaks are added between items in a 
form box or entries in a field. 

– Make each item or entry a paragraph. Adds a break after each entry and item in the 
form box. 

– Make each word a paragraph. Places each word on a separate line. 
Note: The options in the Paragraph breaks drop-down list are explained in more detail on 
the following pages. 

3. Select an option (Left, Center, or Right) from the Justification drop-down list to specify 
paragraph justification. 

Note: The options in the Justification drop-down list are explained in more detail on the 
following pages. 

4. Type a value in the Indent first line by box. 

5. Click Apply. 

Note: All options specified above will affect all of the paragraphs in the selected box. 
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Paragraph Breaks 
Use the options in the Paragraph breaks drop-down list (paragraph breaks are also known as 
line breaks or carriage returns) to control how multiple field entries or multiple content items 
appear in a box. 

Tip! If the options do not seem to work as expected, it could be because the record includes line 
breaks inserted with the Enter key. Open the record in the Edit window to see if there are any 
unwanted line breaks, and remove them. You can see where line breaks occur in the data 
because the next line is outdented without a bullet character, which indicates a new entry, or the 
entry ends with a line break, which looks like a blank line after the text. 

No Added Paragraph Breaks 
Choose No added paragraph breaks to ensure that no breaks are added between items in a 
form box or entries in a field. For example, three entries in a field would appear like this: 

Concrete Stucco Brick 

To add a comma or some other text between entries when using No added paragraph breaks, 
choose Tools>Box Properties>Format>Added Text and specify separator text. For example, a 
comma and space were used below: 

Concrete, Stucco, Brick 
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Separate items or entries with spaces 
When you choose No added paragraph breaks from the Paragraph breaks drop-down list, 
this option becomes enabled. Select the Separate items or entries with spaces check box to 
specify whether items in a paragraph should be separated with spaces. This is the default choice. 
If separator text is specified as added text between entries, this option is ignored. (For more 
information about added text, see “

” on page 249.)When this option is cleared, no additional spacing is added between 
entries. 

Adding Text and Punctuation and Separating Multiple 
Entries

The ability to suppress spaces between fields is particularly useful if you want full control over 
their appearance. For example, you may want to show a file path from one field next to a file 
name from another field with no added space between them. 

Another example of this feature is when you want to format two fields in the same box and need 
added text and space formatting to define their relationship. For example, you may want the Title 
and Subtitle fields in the same box so they display results as Title: Subtitle, with a colon 
preceding the Subtitle field and no space preceding the colon. However, you do not want the 
colon to appear if there is no subtitle. To do this, select No added paragraph breaks and clear 
the Separate items or entries with spaces check box. Add a colon and a space to the Subtitle 
field as beginning text (Format>Added Text). 

School Reform: What It Means to You and Your Child 

 

 

 

Tip! This option is also very useful when formatting text that will be interpreted as HTML, 
especially “canned queries” or any text where spacing (or lack thereof) is important. 

The colon is placed before the Subtitle field as beginning text 
and the Separate items or entries with spaces check box is 
cleared.
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Make Each Item or Entry a Paragraph 
Choose Make each item or entry a paragraph to add a break after each entry and item in the 
form box. This can be useful for generating a list, such as the example below: 

Concrete 
Stucco 
Brick 

Make Each Word a Paragraph 
Choose Make each word a paragraph to place each word on a separate line. This is useful for 
printing information such as Library of Congress classification numbers in a columnar format. 
To keep words together on a line (such as Copy 2, below), connect the words with a 
non-breaking space character by pressing Alt+0160 (on the numeric keypad). 

 

Justifying Paragraphs 
The justification that you select is applied to all paragraphs in the form box.  

 

Note: You can justify text in text boxes by selecting the text box, choosing Tools>Box 
Properties>Font, Color, and selecting an option from the Justify text drop-down list. 

Indenting Paragraphs 
To indent the first line of each paragraph, type a positive value in the Indent first line by box. 
Blocks of text (such as long paragraphs with no added paragraph breaks) often look best this 
way. To outdent the first line (that is, to use hanging indentation), type a negative value. 
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Hanging indentation is often used for lists (each item or entry is a paragraph), especially 
numbered lists (choose Tools>Box Properties>Format>Numbering). 

 

Formatting Text in Form Boxes 
You can apply different formatting to every content item in a form box. For example, if a form 
box contains two fields, you can make each of them a different font and color. However, form 
box text formatting is not just about fonts and colors. You can add text, such as the words 
Written by in front of the Author field, and punctuation, such as parentheses, around the 
Date field.  

Note: When you use a form in the Edit window, formatting (except for font) disappears, so that 
the record information and entry boundaries are easy to identify. 

Text formatting is dependent on the box contents. When the contents disappear (for example, if a 
field is empty), the formatting disappears too. This means you will not have unwanted 
formatting around an empty field: 

The parentheses are formatting 
around a Date field. When the Date 
field is empty, its formatting 
disappears—just what you want! 

 
Compare this to fixed text (box contents), which always appears, even if the field is empty. (For 
example, you would have an empty set of parentheses in the above illustration.) See “

” on page 221 for more information. 
Fixed 

Text

To format form box text 
1. In the Form Designer, select one or more form boxes.  

2. Choose Tools>Box Properties>Format. 

3. Select a content item from the Contents list. For example, to format the Date field, select it 
from the list. To affect all items in the box, select <all>. 

4. Use the subtabs to specify the formatting options you want: 

– Numbering. Number multiple entries or box content items. 
– Font, Color. Select font, including size, color, and case. Select box background color. 
– Numbers, Dates. Format numbers, currency, and dates. 
– Added Text. Add text, punctuation, and entry separators. 

5. Click Apply. 

The following sections describe how to use the formatting options on these subtabs. 
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Numbering items within a form box (Item numbering) 
Use the options on the Numbering subtab to number entries and/or items in a form box. 

Use the Item numbering drop-down list (choose Tools>Box Properties>Format>Numbering) 
to number the contents within a form box. (Do not confuse this with the RECORD NUMBER 
variable on the Variables subtab on the Contents tab, which numbers the records in a report.) 
Item numbering always starts with 1 if numbered numerically, or with A if numbered 
alphabetically. The number/letter is followed by a period and a space. Here is an example of 
numbering on a box that contains two entries in the Name field: 

1. Chris Budd 
2. Sue Jones  

Numbers appear even if there is only one entry or item: 

1. John Smith 

You can specify the following numbering options: 

• None (entries are not numbered)  
• Arabic numbers (1, 2, 3)  
• Upper or lower case Roman numerals (I, II, III; or i, ii, iii) 
• Upper or lower case letters of the alphabet (A, B, C; or a, b, c) 

Continuous Numbering Across Content Items 
The Continuous numbering across content items check box is enabled if you specify 
something other than None in the Item numbering drop-down list. 
If a form box contains multiple content items (for example, two or more fields), you may want to 
consider continuous numbering across content items (see examples below). 

Example 1 
A form box contains two fields, Cats and Dogs, each of which has multiple entries. The Cats 
field is numbered, the Dogs field is numbered, and the Continuous numbering across content 
items option is selected for the Dogs field. Make each item or entry a paragraph (to create a 
list) is selected from the Paragraph breaks drop-down list on the Paragraphs tab. 

1. Siamese 
2. Tabby 
3. Tiger 
4. German Shepherd 
5. Great Dane 
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Example 2  
Same as Example 1, except the Continuous numbering across content items check box is 
cleared: 

1. Siamese 
2. Tabby 
3. Tiger 
1. German Shepherd 
2. Great Dane 

Changing Text Font and Color, and Box Background Color 
Use the options on the Font, Color subtab to change text attributes and the background color of 
form boxes. 

• Set Font. Click the Set Font button to access the Font dialog box to specify the font, style, 
size, and color you want. TrueType fonts are indicated by a double-T icon. Printer fonts are 
shown with a printer icon. OpenType fonts are indicated by an O icon. 
Note: The fonts that appear in the Font selection list depend on the selected printer. Printer 
fonts are preceded by a printer icon in the Font list. If you choose a printer font and then use 
the form to print to a different printer that does not support that font, the report may not 
appear as expected. To change your printer selection, choose File>Print Setup. 

• 

• 

Upper case. Select the Upper case check box to make the selected content item appear in 
all capital letters. 
Background color. Select the Background color check box and click the Select Color 
button to specify the background color, including custom colors, you want for the form box.  

Formatting Numbers, Currency, and Dates 
Use the options on the Numbers, Dates subtab to determine how numbers, currency, and dates 
appear in a form.  

The formatting options for numbers are enabled only if the selected content item is not a date 
(for example, Date field, DATE variable, Date calculation). The options affect how all numbers 
will appear in that field or content item.  

Note: The characters used for the decimal and thousand separators are determined by the 
number format specified in the Regional settings of the Windows Control Panel. 
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Number format 
Use the Number format drop-down list to specify the following formatting options: 

• None. Numbers appear exactly as they were entered in the textbase. 
• Currency. All numbers in the field appear as currency (as shown in the Examples box). 

Note that the Omit text check box is enabled when you select Currency from the Number 
format drop-down list. (See below for more information about this check box.) 

• Number. Numbers appear according to the options you specify: 
– # of decimal places. Type a number to indicate how many decimal places to display 

after the decimal point. For example, type 2 to cause the number 35.5 to appear as 
35.50. Numbers will be rounded when necessary. For example, if you type 0 in the # of 
decimal places box, 25.4 becomes 25. The default value is zero. 

– Negative numbers use. Select an option from the drop-down list to indicate how you 
want negative numbers to appear: with a leading minus sign, a trailing minus sign, or 
enclosed in parentheses. 

– Thousand separators. Select this check box if you want numbers to include a thousand 
separator, such as a comma, in the appropriate place. For example: 1,523. Note that the 
character used as the thousand separator is specified in the Regional settings of the 
Windows Control Panel. 

– Leading zero in decimal. Select this check box if you want a zero to appear before a 
number with only decimal digits, for example .75 appears as 0.75. 

– Omit text. Select this check box to hide trailing text (text that follows the number). If 
there is no number in the field—only text—a zero appears in the form box. For 
example, if the field contains the word None, a zero appears in the form box instead of 
the text. If you omit text when using Currency formatting and the field contains text 
only, zero currency ($0.00) appears in the form box.  
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Date format 
The date format options are enabled only if the selected content item is a Date field, a Computed 
Date field, an Automatic Date field, the DATE variable, or a calculation that results in a date. If 
you select any other content item type, or if you select multiple boxes or <all> from the Contents 
list, number formatting options appear. You can format only one date item at a time. 

Use the Date format drop-down list to specify the following options: 

• 

• 
• 
• 

None. Dates appear exactly as they were entered into the textbase. The DATE variable uses 
the short date format (for example, 7/8/2003). 
Short. Dates appear in numeric format (for example, 7/8/2003). 
Long. Dates appear in the long date format (for example, Tuesday, July 08, 2003). 
Long without day. Same as above, but omits the weekday (for example, July 08, 
2003). 

Another Omit text check box (located next to the Date format drop-down list) is enabled when 
an option other than None is selected from the Date format drop-down list. Select this check 
box to hide trailing text. If there is no recognizable date at the beginning of the field—only 
text—an asterisk will appear in the form box. 

An example below the Date format drop-down list shows you how dates will appear. Note that 
the formats are based on the format selected in the Regional settings of the Windows Control 
Panel. For example, if a day-month-year format is selected, the DB/TextWorks Long date 
format would display with days and months written out (such as Wednesday, 21 March 
2003) and the Short date format would display numerically (such as 21/03/2003). Use the 
Windows Control Panel to specify exactly how you want long- and short-format dates to appear. 
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Adding Text and Punctuation and Separating Multiple Entries 
Use the options on the Added Text subtab to add text or punctuation to the beginning or end of a 
content item, and to add punctuation or text between multiple entries. Added text appears before 
or after the box contents when the form is used. In the following example, the words Written 
by are beginning text in front of the Author field: 

 
Added text has the same font attributes as the content item to which it is applied, and does not 
appear when a content item is missing. For example, if the Author field is empty, the words 
Written by will not appear. 
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Beginning text 
Select an item from the Contents list to which you want to add beginning text. Type the text or 
punctuation you want to appear before the content item in the Beginning text box, or click the 
Enlarge button to open a larger, resizable text editor dialog box instead. When you click OK on 
the text editor dialog box, your text appears in the Beginning text box automatically. Include a 
space at the end of the beginning text if you want a space before the information that follows. 

Beginning text has the same font attributes as its content item. For example, if the Author field is 
Helvetica Italic, the beginning text is also Helvetica Italic. 

If a field contains multiple entries, beginning text precedes only the first entry. If beginning text 
is added to an item that is numbered, the numbering starts after the beginning text. (To align 
numbered items in a list in this situation, press Enter at the end of the beginning text.) 

Tip! You can use beginning text to add a left parenthesis in front of an item, and ending text to 
add the right parenthesis after the item.  

Ending text 
Select an item from the Contents list to which you want to add ending text. Type the text or 
punctuation you want to appear after the content item in the Ending text box, or click the 
Enlarge button to open a larger, resizable text editor dialog box instead. When you click OK on 
the text editor dialog box, your text appears in the Ending text box automatically. 

Use ending text to add text or punctuation immediately after a content item. Ending text is 
typically used to add commas between several items in a box. If the content item is a 
multiple-entry field, the ending text follows only the last entry. If the field is empty, the ending 
text does not appear. If you want spaces between the text and the information that precedes it, 
include a space before the ending text (type a space as the first part of the ending text).  

For example, if a box contains several address fields (for example, Street, City), you can use 
ending text to add commas after each field: 

254 Elm Street, Anytown, VT 

Ending text has the same font attributes as its content item. 

Ending punctuation 
Select an item from the Contents list to which you want to add punctuation. Type the text or 
punctuation you want to appear after the last entry in the Ending punctuation box. 

Ending punctuation is text or punctuation that appears after the last (or only) entry. A period is 
most typically used. Ending punctuation appears only if the content item lacks its own 
punctuation. If the content item already has punctuation, ending punctuation is not added. This 
behavior ensures that you will not get duplicate punctuation, and is what distinguishes ending 
punctuation from ending text (which always appears if the field is not empty). 

As with any formatting item, ending punctuation takes on the same font attributes as its content 
item and does not appear if the content item is missing (such as an empty field). 

Ending punctuation always appears before ending text. 
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Separator text 
Select a field from the Contents list to which you want to add separator text. Type the text or 
punctuation you want as the separator text in the Separator text box, or click the Enlarge 
button to open a larger, resizable text editor dialog box instead. When you click OK on the text 
editor dialog box, your text appears in the Separator text box automatically. 

Use separator text to visually distinguish between multiple entries in a field. The text you specify 
will follow each entry except the last. If there is only one entry, the separator text will not 
appear. Separator text appears only for fields, not for other content items. 

Note: In the Edit window, multiple entries are separated by the field entry delimiter specified on 
the Display tab (choose Tools>Options). 

A comma or semi-colon is typically used to separate entries when paragraph breaks are set to No 
added paragraph breaks. For example, say your field appears like this without separator text: 

Red Yellow Blue 

You can use a comma and space as the separator text to make the entries appear like this: 

Red, Yellow, Blue 

Separator text appears regardless of the paragraph breaks setting. For example, if the paragraph 
breaks setting is Make each item or entry a paragraph, the entries would appear like this: 

Red, 
Yellow, 
Blue 

Separator text can be a combination of text and punctuation. For example, a space followed by 
the word and another space looks like this: 

Red and Yellow and Blue 

To add blank lines between entries, use a line break as the separator text (press Enter). If you 
are using No added paragraph breaks, press Enter twice. To add a line before each entry (to 
create a checklist), select No added paragraph breaks, specify an underbar (_) as beginning 
text, and specify a line break (press Enter) and an underbar (_) as the separator text. 

__ Red 
__ Yellow 
__ Blue 

Note: Leave the Separator text box empty if you do not want any separator between entries. A 
single space will appear between entries if you selected No added paragraph breaks from the 
Paragraph breaks drop-down list (Tools>Box Properties>Paragraphs) and accepted the 
default setting of one space between content items. 
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Examples of Combined Formatting 
Beginning text, ending text, ending punctuation, entry separators, and paragraph breaks are often 
combined to format the contents of a box. Examples of combined text formatting appear below. 

Example 1  
The only content item is the Company field. All other information is added text (choose 
Tools>Box Properties>Format>Added Text). The period after the company name is ending 
punctuation. Note that ending text always comes after ending punctuation. 

 Field Beginning text Ending text

 Ending punctuation

Example 2 
This form for printing labels consists of one form box that contains five fields: Name, Address, 
City, State or Province, and Postal Code. The Address field contains multiple entries. The box 
has No added paragraph breaks (choose Tools>Box Properties>Paragraphs) selected for its 
paragraph formatting. The breaks are created by using Enter for ending text and separator text, 
as shown below. Note that one space automatically occurs between the content items City, State 
or Province, and Postal Code. To add an extra space before the Postal Code, use beginning text. 
(Note that the paragraph markers shown below are for illustration purposes only and do not 
appear on the label or on the Form Box Properties dialog box.) 
 

Ending text [¶] forces a line break after name.

Separator text [¶] forces 
each entry in the Address 
field onto a new line. 

Beginning text 
(one extra space)

Ending text 
(comma) 

Ending text [¶] forces a 
line break after address. 

 

Example 3 
To present record information in the Inmagic tagged format, use a form with the following 
formatting: 

• Use Beginning text to specify the field name. 
• Use No added paragraph breaks. 
• Use an Indentation of -.10 inches for each paragraph. 
• Use a line break, semicolon, and space as the Separator text. 
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• Use a line break as Ending text for each field. 
• Enter the dollar sign end-of-record indicator as Fixed text for the box contents. 

 

Using HTML in form boxes 
When designing a form for use on the Web with a WebPublisher product, you can specify how a 
Web browser will treat the content in form boxes. 

To select HTML settings for form boxes 
1. In the Form Designer, select a form box. 

2. Choose Tools>Box Properties to open the Form Box Properties dialog box. 

3. On the HTML tab, select the content item from the Contents list to which you want to apply 
HTML. 

4. Select the appropriate option from the Treat content item as drop-down list: 

– Do not alter. Leaves the content item alone. Use this option for items that contain 
information that you do not want to be interpreted as HTML by the client’s Web 
browser, such as titles and instructions. The text will appear in the browser as it appears 
in the form box. The Web browser will not attempt to interpret any characters as 
HTML. 

– Raw HTML. Causes the content item, including formatting, to be passed through to the 
Web browser. When the form is used on the Web, the browser will attempt to interpret 
the content item as HTML. For this option to work, the content item must be in HTML 
format. For example: 
<a href="searchform.html" target="_blank">Click here to search.</a> 

appears on the report as a hypertext link: 

Click here to search. 

Clicking the link will open the specified search form (SEARCHFORM.HTML) in a 
new browser window. 

The purpose of Raw HTML is to correctly interpret HTML that cannot otherwise be 
specified in the DB/TextWorks designers. For example, in the example above, if you 
did not want to open the form in a new window (that is, you remove 
target="_blank"), you do not need to use Raw HTML. Instead, treat the fixed text 
as a URL and specify alternate link text, as explained in the online help. 
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– URL. Turns URL entries (for example, http://www.inmagic.com) in the 
selected content item into hypertext jumps by adding the necessary HTML tags. The 
URL address entries appear as the text, as well as the target of the link, by default. For 
example: 
http://www.inmagic.com 

becomes: 
<a href="http://www.inmagic.com">http://www.inmagic.com</a> 

If you want to use different text for the link, use alternate link text, as explained in the 
online help. 

– EMail link. Turns EMail address entries in the selected content item into “mailto” 
links. The EMail address appears as the text as well as the target of the link, by default. 
For example: 
joe@mydomain.com 

will be treated as: 

<a href="mailto:joe@mydomain.com">joe@mydomain.com</a> 

If you want to use different text for the link, use alternate link text, as explained in the 
online help. 

– HTML file reference. Enables users to launch applications on a suitably configured 
intranet. A content item that contains one or more file names will have its content 
displayed in the Web browser as a hypertext link. 
If you want to use different text for the link, use alternate link text, as explained in the 
online help. 

For more information about using HTML file references to launch applications on the 
Web, see the Inmagic DB/Text WebPublisher PRO User’s Manual. 

– Expand record link. Designates a hypertext link from a report to a single-record 
display page. After a Web search, records are displayed in the Web browser as a report 
(multiple records that met the search criteria). For users to display just one record at a 
time, they need to click on a link. It is that link that you are defining. The link you 
specify opens a new page (a Display page, which shows detailed information about one 
record at a time). For best results, choose a content item that is present in each record, 
such as a field that holds the title of a publication. The selected item will appear as a 
hypertext link when the report is used. Clicking the link in the report will display an 
expanded version of the record. 

The Display form selected in the browser determines how the expanded record appears. 
Be sure to design a Display form that will give users more information about a record. 
If you do not supply a Display form, the textbase default or Basic form is used. If you 
do not define an expand record link, the ability to expand a record is unavailable. 
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– “See Also” search link. Treats each entry in the field as a search term. The entry is 
then submitted back to WebPublisher PRO to find other records containing the same 
term in that field and produce the results in a formatted report. For example, turn the 
Author field into a “See Also” link that, when clicked, finds all other books by the same 
author. If this option is used and a book has multiple authors, each author becomes a 
link to his/her other works. 

– Inline image and Image link. 
 Inline image. Displays images as part of the page. If you choose this option, be 

sure the image dimensions are an appropriate size. You may have to use a graphics 
or conversion application to reduce the dimensions for images. You can also 
display images using a picture box. For more information, see “

” on page 263. 
Using picture 

boxes on the Web
 Image link. Displays image names as hypertext links. By clicking on the link, a 

user jumps to that image. This option may be preferable to inline display if the 
dimensions of your images are too large to fit well on a page, or if you want users 
to be able to decide whether or not they want to see each image. (If you want to use 
different text for the link, use alternate link text, as explained in the online help.) 

 Select the Use file:// reference for image check box to control where 
WebPublisher PRO looks for textbase image files when displaying records in the 
Web browser. This check box is for intranet use only. If you do not select this box, 
the software will expect to find the image files in the location specified for this 
textbase in DBTWPUB.INI. If you do select this check box, image files can be in 
any directory that is accessible to the Web users by means of a network file system. 
When the check box is selected, the software interprets the image name as a file 
URL. To ensure that everyone has access to the images, the image file names in the 
textbase records should specify the image path as a UNC path (with the server 
name replacing the drive letter). 

– New record link. This option functions differently depending on the type of Web form 
you are designing: 

 On Report and Display forms: Makes the content appear as a link that, when 
clicked, opens an empty edit screen from which you can add a new record. 

 On Edit forms: Makes the content appear as a link that, when clicked, creates a 
copy of the current record and displays it in an edit screen. You can edit the copy 
as needed, and save it as a new record. 

– Edit record link. Makes the content appear as a link that, when clicked, opens the 
current record in an edit screen. This type of link is only applicable to Report forms and 
Display forms used on the Web. Edit record links will not appear on Edit forms used on 
the Web. 

– Delete record link. Makes the content appear as a link that, when clicked, opens the 
current record in an edit screen from which you can delete the record. This type of link 
is only applicable to Report forms and Display forms used on the Web. Delete record 
links will not appear on Edit forms used on the Web. 

5. Click Apply, then Close. 
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Text Boxes 
A text box used on a form acts as a special kind of form box, different in that it contains only 
text. A text box contains a single text item that retains its font and color attributes. Compare that 
to a form box, which can contain multiple items, each with its own font and color. 

To add a text box, choose Edit>Add>Text Box, then use the Text Box Properties dialog box 
(which opens when the box is added) to specify numerous attributes for it. For an existing text 
box, choose Tools>Box Properties to open the Text Box Properties dialog box. 

Text Box Content 
A text box is a box that contains static informational or instructional text, such as the form’s title 
or an explanation of how to use the form. When formatting a text box, note that you generally 
hide the box borders. 

By default, DB/TextWorks excludes text boxes from the tab order (choose Tools>Tab Order). 

Use the Text tab on the Text Box Properties dialog box to type the text you want to appear on 
the form. 

To specify text box contents 
1. Add a text box, or select an existing text box and choose Tools>Box Properties. (You 

cannot specify text box contents if you select more than one text box at a time). The Text 
Box Properties dialog box opens, with the Text tab displayed by default. 

2. On the Text tab, type the text you want in the Text box, or click the Enlarge button to open 
a larger, resizable text editor dialog box instead. When you click OK on the text editor 
dialog box, your text appears in the Text box on the Text tab automatically. 

 
3. Click Apply, then Close. 
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Specifying text box width and anchoring 
You can specify the width of a text box and you can assign the box anchoring attributes by using 
the options on the Position tab (choose Tools>Box Properties>Position). However, you cannot 
designate the height of a text box. The number of lines of text in the text box and the font size 
determine its height. 

You specify text box width and anchoring attributes the same way as for form boxes. For more 
information, see “ ” on page 233 and “

” on page 234. 
Changing form box width Floating and anchored form 

boxes

Adding borders to text boxes 
A text box can have borders. A border is a visible solid box around the contents. To add borders 
to a text box, choose Tools>Box Properties>Font, Color. Select or clear the Show border 
check box, depending on your choice. You cannot add a label or scroll bar to a text box. 

Formatting text in text boxes 
You can apply different formatting to text box content, as well as change the background color 
of the text box for impact. Use the Font, Color tab (Tools>Box Properties) to specify font 
attributes, text box border display, text box background color, and justification settings for text 
box content. Font attributes can affect the height of text boxes, so it is most efficient to decide on 
a font early in the form design. Before designing a form, you may want to choose 
Tools>Options>Display and set the default fonts. Default fonts determine how new forms 
appear. They do not affect saved forms.  
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To format text box text 
1. In the Form Designer, select one or more text boxes.  

2. Choose Tools>Box Properties to open the Text Box Properties dialog box. 

3. On the Font, Color tab, specify the options you want for your form: 

– Set Font. Click this button to open the Font dialog box and specify a font. For more 
information about changing text box formatting, see “Changing Text Font and Color, 
and Box Background Color” on page 246. 

– Show border. Select this check box if you want the text box to have a border. Clear the 
Show border check box if you do not want the text box to have a border. 

– Background color. Select this check box and click the Select Color button to specify 
the box background color, including custom colors, you want. Note that custom colors 
are retained per workstation from session to session. 

– Justify text. Select an option (Left, Right, or Center) from this drop-down list to 
justify text within the text box. If you find that you regularly justify text, you can add 
the appropriate text justification button to the toolbar by choosing Tools>Customize 
Toolbar. 

 

Tip! To center a title on a form, select the text box containing the title, choose 
Tools>Align Boxes>Center, then justify the text within the box. 

4. Click Apply, then Close. 

Using HTML in text boxes 
Note: HTML options for text boxes work the same as for form boxes, except there are fewer 
choices available.  

1. In the Form Designer, select a text box. 

2. Choose Tools>Box Properties to open the Text Box Properties dialog box. 

3. On the HTML tab, select the appropriate option from the Treat text as drop-down list: Do 
not alter, Raw HTML, URL, EMail link, HTML file reference, Expand record link, 
New record link, Edit record link, or Delete record link. These options are explained in 
“ ” on page 253. Note that the “See Also” search link, Inline 
image, and Image link options do not apply to text boxes. Also, note that URL and EMail 
link options are appropriate only if the text box contains a single URL or EMail address. 

Using HTML in form boxes

4. Click Apply, then Close. 
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Picture Boxes 
A picture box is a box that contains an image. Use a picture box to display a static image or an 
image referenced by an image file name in an Image field in the record. For example, use a 
picture box to display a company logo on a form. If the specified Image field contains multiple 
entries, only the first image is shown. 

To add a picture box, choose Edit>Add>Picture Box. A square, gray box appears on the form 
and the Picture Box Properties dialog box opens. For an existing picture box, choose Tools>Box 
Properties to open the Picture Box Properties dialog box. Use the Picture tab to specify the type 
of image you want to appear on the form (fixed image or record image). 

Picture box content 
The content of a picture box can be a static image or a record image. You can use picture boxes 
to insert images from any file or from an Image field referenced in the current record. 

Keep in mind that different image types work on the desktop, the Web, and/or both 
environments. For example, GIF is not supported on the desktop, but JPEG files are supported in 
both places. See the online help for more information. 

To specify picture box content 
1. Add a picture box, or select an existing picture box and choose Tools>Box Properties. 

(You cannot specify picture box content if you select more than one picture box at a time). 
The Picture Box Properties dialog box opens, with the Picture tab displayed by default. 
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2. Select the option button for the type of image file you want to appear in the picture box: 

– Image from file. Places a static image from a file in the picture box, such as a company 
logo. Use the Browse button to locate the file and place it in the Image file box.  

– Image from field. Places an image from an Image field in records in the currently open 
textbase into a picture box. Use the Image field drop-down list to specify the Image 
field to place in the picture box. Select this option when you want to include record 
images in a form. If the field selected contains multiple image references (file names), 
only the first image will appear in the form. 

3. Click Apply, then Close. 

Specifying picture box height, width, and anchoring 
When you place an image in a picture box, you can resize the box and image to suit your needs 
in the form. You can resize it manually by dragging box handles, or you can resize it precisely 
using settings on the Position tab. 

You can either fit the image to the box size, or fit the box to the original image size. 

• 

• 

Use best fit of image to box. Select this option button to fit the image to the size you 
specify for the box. The aspect ratio is preserved. 
Resize box to match image size. Select this option button if you want to retain the size of 
the original image. 

The aspect ratio of an image is locked in DB/TextWorks. If the original image you place in a 
picture box is a rectangle, it will remain a rectangle when you change the width or height. You 
will not be able to change a rectangular image into a square image. The width will change 
proportionately as the height changes, and the height will change proportionately as the width 
changes. The image on the screen reflects how the picture will look in the report, not the size of 
the picture box as specified using the Width and Height settings on the Position tab. 
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To change picture box height 
If you select the Use best fit of image to box option button (choose Tools>Box 
Properties>Position), use either of these methods to change the height of a picture box: 

• 

• 

Select one picture box and place the cursor over the box handle in the lower right corner. 
The cursor becomes a double-headed arrow. Drag the box handle diagonally up or down to 
resize the picture box proportionately. 
Select one or more boxes and choose Tools>Box Properties>Position. Change the value in 
the Height box to the size you want. 

To specify the height of 
a picture box, type a 
value in the Height box. 
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To change picture box width 
Use either of these methods to change the width of a picture box: 

• 

• 

Select one picture box and place the cursor over the left or right box handle. The cursor 
becomes a double-headed arrow. Drag the box handle to the left or right. If you place the 
arrow over the box handle in the lower right corner and drag the box, you change not only 
the width, but also the height proportionately. 
Select one or more boxes and choose Tools>Box Properties>Position. Change the value in 
the Width box to the size you want. 

To specify the 
width of a picture 
box, type a value 
in the Width box. 

 

Specifying picture box anchoring 
Picture box anchoring attributes are specified the same way as for form boxes. For more 
information, see “ ” on page 234. Floating and anchored form boxes
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Using picture boxes on the Web 
Note: This section applies only if you are using a WebPublisher product to publish textbases on 
the Web. 

By default, WebPublisher products use CSS to display reports. If you use a picture box on a 
form that is used on the Web, the software must determine the size of the image in order to 
preserve the aspect ratio or prevent text from overlapping the image. 

The software uses HTTP access to create the image reference in the report, and file access to 
determine the image size. Because of this, you must specify the image location in two ways. 
This ensures the software can find the image so it can then determine the image size. 

• 

• 

HTTP access. WebPublisher looks in the DBTWPUB.INI file to find the HTTP image path 
to construct the URL for the image reference in the report. If this location is not specified, a 
broken image icon appears on the page when it is viewed on the Web. 
File access. WebPublisher uses file access to determine the image size. This location can be 
specified either in the record itself or by selecting the Image from file option button and 
entering the location in the Image file box. (You can use the Browse button to navigate to 
the location.) 

Script Buttons and Script Input Boxes 
Script buttons and script input boxes can be very helpful on a form. Script buttons are used to 
launch a script, while script input boxes are used to provide information to be used during the 
processing of a script. For more information, see “ ” 
on page 300. 

Using Script Buttons and Script Input Boxes
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Setting Form Properties 
The form properties you select are saved with the form and take effect when the form is used. 

To set form properties 
1. In the Form Designer, choose Tools>Form Properties to open the Form Properties dialog 

box. 

 
2. Specify the form properties you want by using the tabs on the dialog box. Each tab is 

explained on the following pages. 

– General tab. Specify general properties, such as whether search items are highlighted 
and the distance between records. (See the following pages for more details on this tab.) 

– Logos tab. Specify an image to appear at the top and/or bottom of the page when the 
form is used on the Web with a WebPublisher product. The settings on this tab also 
apply to Write Report to File in HTML format. For more information, see “

” on page 328. 
Designing 

Forms for Web Use

Designing 
Forms for Web Use

– HTML tab. Specify whether to use record separators, a background image, and other 
attributes for a form that will be used on the Web (with a WebPublisher product). The 
settings on this tab also apply to Write Report to File in HTML format and Send Report 
as Mail in HTML format. (Note that the Use background image option does not apply 
to Send Report as Mail in HTML format.)  For more information, see “

” on page 328. 
3. Click OK when done. 

264 Chapter 5: Working with Forms 



 

General Tab 
The settings on the General tab (choose Tools>Form Properties>General) apply to forms used 
on the desktop and on the Web. 

Options group 
• Highlight search items. Select this check box to highlight words or terms found by a 

search. Search highlighting never appears in the Edit window.  
Note: To determine how search highlighting appears (for example, its color), choose 
Tools>Options>Search. 

• Show underbars as spaces. Select this check box to show underbars (_) as spaces on the 
screen and in printed reports. Underbars may have been included to prevent words from 
breaking across lines, in which case you would want to hide them. If they were included to 
simulate a check list (for example, Yes __ No __ ), you would not want to hide them. 
Note: Underbars may have been included as record data or as part of the form (for example, 
fixed text). You can also use a non-breaking space (Alt+0160) to prevent words from 
breaking across lines. 

• 

• 

Background color. Select this check box to specify a color for the background of the form. 
When selected, the Select Color button is enabled. Click the Select Color button and 
choose a color (including custom colors) on the Color dialog box. 

Measurements group 
Use the Measurements settings to specify the units for box position and width, and label width. 
For example, choose inches from the Horizontal units drop-down list and lines from the 
Vertical units drop-down list, so a box could be 4 inches wide and ½ line (.5) below the box 
above it. 

• Horizontal units. Select a type of units (inches, mm, or points) from this drop-down list to 
use when specifying form settings, such as indentation, box position, and label width. 

• Vertical units. Select a type of units (inches, mm, points, or lines) from this drop-down 
list to use when specifying the vertical distance between boxes or records, and grid settings. 
Vertical units do not affect the information within a box. Information within a box is always 
measured in lines (except for picture boxes). 
Distance between records. Type a value in this box to specify the vertical space between 
records in a report. The unit of measure (for example, inches, lines) is determined by the 
Vertical units setting above. If a box has a Top Offset (choose Tools>Box 
Properties>Position), that value is added to the record spacing amount. The Form Designer 
only shows one record at a time. To see how the spacing looks, save the form, then select it 
for the Report window. 
Tip! To design a report to show summary information only, make each box a Sort Footer or 
Report Footer. To avoid large gaps in such a report, set the distance between records to zero. 
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Logos Tab 
The settings on the Logos tab (choose Tools>Form Properties>Logos) let you specify images 
to appear at the top and/or bottom of a page. The logos you specify only appear when forms are 
used on the Web with a WebPublisher product; they do not appear in DB/TextWorks windows.  

Use this tab when you want to place a picture at the top of a page, above the navigation buttons. 
If you want the picture to appear at the top of the report, but below the navigation buttons, add a 
picture box and change it to a report header. 

To add an image to the top and/or bottom of a form 
1. Choose Tools>Form Properties to open the Form Properties dialog box. 

2. On the Logos tab, type the file name (including extension) of the image file you want to 
appear on the form in the appropriate box: 

– Leading Logo. Displays an image at the top of the page. For example, type 
NEWLOGO.JPG. 

– Trailing Logo. Displays an image at the bottom of the page. For example, type 
MYLOGO.GIF. 

Note: You can also click the Browse button next to the appropriate box to locate the image 
file you want to use. 

3. Click Apply, then Close. 

For more information on image file locations, see the Inmagic DB/Text WebPublisher PRO 
User’s Manual. 
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HTML Tab 
Use this tab when designing a form for use on the Web a WebPublisher product, when writing a 
report to HTML, or when sending a report as mail in HTML format. This tab is not applicable to 
forms used on the desktop. 

The following are options you can specify on the HTML tab. 

Options group 
• Use record separators. Select this check box if you want a horizontal rule to appear 

between records in the HTML report. Then specify the alignment, height, and width. (Note 
that this option does not appear for tabular forms, as records are separated by table borders.) 
Note: The Web browser software controls the final appearance of the record separator. 

– Alignment. Use this drop-down list to specify how to align the record separator. 
– Height/Width. Use these controls to specify the dimensions of the record separator, in 

pixels. 
• Use background image. Select this check box to specify an image file to use as the page 

background for an HTML page when viewed in a Web browser. Most Web browsers handle 
GIF and JPEG files only. For more information about image locations, see the online help or 
the Inmagic DB/Text WebPublisher PRO User’s Manual. 
Note: To use a background color instead of (or in addition to) an image, choose 
Tools>Form Properties>General, select the Background color check box, click the 
Select Color button, and choose a color. 

• Table settings. (This option appears for tabular forms only.) Add a table border by 
specifying a value in the Border width box. Use zero (0) if you do not want to show a 
border. 

Advanced Options group 
Advanced Options. Click the Advanced Options button to specify information you want 
included in the <head> section of the HTML report. The information (<script, <style>, or other 
HTML elements) is inserted after the information added by the software, such as the page title. 
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Designing Report Forms 
Before you begin designing a report form, it may help to review the definition of a report form. 
A report form is a form that is designed to display and/or print multiple records. The records 
appear one after the other on the page, sorted and formatted per your specifications. You can 
print reports, display them in the Report window, write them to a file in a variety of formats, 
send them as EMail, or display them on the Web with a WebPublisher product.  

Designing a report form is similar to designing a form for single-record display (in the Display 
or Edit window). However, a report form can include some additional components that would 
not make sense for single-record display, such as page numbers, special sorting (if required), sort 
headings, subtotals, grand totals, and other options. 

One of the distinguishing features of a printed report is that it can include a Margin Area for 
information that will print on every page. For more information, see “

” on page 283. 
Working in the Margin 

Area
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Task Overview 
Designing a report can be complicated, as there are many possible features. This list summarizes 
the tasks involved. Some tasks are optional, and can be performed in a different order.  

To… Do this… 
Create a report form Choose Display>Design Form and select a form to start with—an 

existing form, the Basic Report form, a blank form, a label form, 
or a tabular form. 

Change the page size and 
margins 

Choose Report Options>Set Up Page and select the page size, 
margins, starting page number, and page breaks. 

Add record information With the Record Area active, choose Edit>Add>Form Box to add 
a Record box. Define and format the box contents using 
Tools>Box Properties. Repeat for each Record box you want in 
the Record Area. Record boxes typically show field content. 

Create column headings If a report includes columns of information, set up the boxes for 
the column headings after adding and sizing the boxes for the 
record information, so the boxes can be aligned vertically. With a 
tabular report, the box labels function as column headings. 

Specify a compulsory sort If you want information to be grouped and subtotaled by specific 
fields, such as Region and Customer, choose Report 
Options>Compulsory Sort. If a compulsory sort is not specified, 
users can sort records by any field they want. If your report 
includes Sort Headers and Footers, consider using a compulsory 
sort to prevent users from sorting records any other way. 

Add Report Headers at the 
beginning of the report 

If you want to print information once at the beginning of the report 
(for example, a report title, the textbase name, search criteria, or 
prompted text), choose Report Options>Headers and Footers, 
add a Report Header box, and specify its contents. 

Add grand totals at the  
end of the report 

Choose Report Options>Headers and Footers, add a Report 
Footer box, and specify its contents as a calculation. 

Add headers before each 
group of records 

Choose Report Options>Headers and Footers, select Sort 
Header, select a Sort Level, add the box, and specify its content as 
a Sort Key and/or text. 

Add subtotals after each 
group of records 

Choose Report Options>Headers and Footers, select Sort 
Footer, select a Sort Level, add the box, and specify its content as 
a calculation.  

Print information in the 
margin of every page 

With the Margin Area active, choose Edit>Add>Form Box to 
add a Margin box. Define the box contents using the subtab 
options on the Contents tab (Tools>Box Properties>Contents). 
For example, add the TEXTBASE NAME variable to show the 
textbase name on every printed page.  

 
You can add the record information (boxes with fields in them) before or after you add the 
report-specific components, such as headers and footers. 
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Sorting with Headers and Footers 
Sorting is a way of grouping records by a particular category. The fields that you sort by are 
referred to as Sort Keys. You can designate up to five fields per sort (Sort Levels 1 through 5). 

Note: You do not have to use all five levels. It is usually sufficient to specify one, two, or three 
levels. 

You can specify the order in which records appear in reports. For example, you might sort 
alphabetically by Name or chronologically by Date. DB/TextWorks provides three methods for 
sorting records: a compulsory sort (hard wired in the form), a user-specified sort (users can 
choose Display>Sort Report after doing a search), or a textbase default sort (specified in the 
textbase structure, to be used if no other sort is specified). Each method has its advantages and 
disadvantages. To determine which sorting method is best for the report you are designing, see 
“ ” on page 304. Sorting Records

Note: If you do a Relevance-Ranked Order sort, Sort Keys do not exist, and Sort Header and 
Sort Footer boxes do not appear. 

Sort Headers and Footers 
Sort Headers and Footers are used at the beginning and end of a group of records sharing a Sort 
Key at the specified Sort Level. 

Typically, you pair a Sort Header with a Sort Footer, using the same Sort Level for both. For 
example, you may want to subtotal sales by region, and you may also want to subtotal sales by 
customer. To see how each box is defined, see the illustration on page 280. 

Tip! If you want to pair other information for a Sort Level with a calculation, both boxes must 
be Sort Footers. You cannot put a Sort Header “next to” a Sort Footer in a report. You can put 
them next to each other in a form, but when you use the form, the boxes will not align. 
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Adding Sort Headers 
Use a Sort Header box to hold a Sort Key field. A Sort Header serves as a group heading under 
which one or more records are listed.  

The following report is sorted by Region (Sort Level 1), Customer (Sort Level 2), and Invoice date 
(Sort Level 3). The first Sort Header box contains Sort Level 1, so it shows the contents of the 
Region field (Northeast). The second Sort Header box contains Sort Level 2, so it shows the 
contents of the Customer field (for example, Concord Miniatures, Kullen’s Crafts). The third Sort 
Level (Invoice date) is not used in a Sort Header box; it just ensures that invoices are listed by 
date. 

Sort Header 
Level 1 

Sort Header 
Level 2 

 

To add a Sort Header 
1. Choose Report Options>Work in Record Area. If you do not see that option, you are 

already working in the Record Area. 

2. Choose Report Options>Headers and Footers to open the Headers and Footers dialog 
box. 

3. Select Sort Header from the Header/Footer list, then select the Sort Level whose field 
contents you want to use. Remember that Sort Levels always refer to the current sort, which 
may be a compulsory form sort, a user-specified sort, or the textbase default sort. 
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4. Click the Insert Header/Footer button. A form box is added to the Record Area, and the 
Form Box Properties dialog box opens. Sort Header boxes are added above normal record 
boxes, but you can move them if you wish. 

5. Format the box label and contents using the Form Box Properties dialog box. For example, 
use the Labels tab to hide the box label, borders, and scroll bars. 

Adding Sort Footers 
Use a Sort Footer box to hold a count, subtotal, or other summary calculation for the current sort 
group. When you add a Sort Footer box, you select its Sort Level. When the Form Box 
Properties dialog box opens, specify a calculation for the box contents, such as 
TOTAL(quantity*"price per unit"). 

To add a Sort Footer 
1. Choose Report Options>Work in Record Area. If you do not see that option, you are 

already working in the Record Area. 

2. Choose Report Options>Headers and Footers to open the Headers and Footers dialog 
box. 

3. Select Sort Footer from the Header/Footer list, then select the Sort Level whose field 
contents you want to use. Remember that Sort Levels always refer to the current sort, which 
may be a compulsory form sort, a user-specified sort, or the textbase default sort. 

4. Click the Insert Header/Footer button. A form box is added to the Record Area, and the 
Form Box Properties dialog box opens. Footer boxes are added below all Record boxes, but 
you can move them anywhere within the Record Area. 

5. On the Calculations subtab on the Contents tab, type the calculation you want in the 
Calculation formula box, or click the Enlarge button to open a larger, resizable text editor 
dialog box instead. When you click OK on the text editor dialog box, your text appears in 
the Calculation formula box automatically. Click Add. 

6. Format the box label and contents using the Form Box Properties dialog box. For example, 
use the Labels tab to hide the box label, borders, and scroll bars. 
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The form pictured on page 271 also includes a form box that shows the Region (Northeast) 
followed by the word SUBTOTAL as ending text (Tools>Box Properties>Format>Added 
Text). 

Here is what the boxes look like in the Form Designer:  

 
And here is what the boxes look like in the report: 

 

Report Headers and Footers 
Report Headers and Footers are used when you want your report to have information appear at 
the top and bottom of the report information. 

Adding Report Headers 
Use a Report Header box for information that you want to appear once at the beginning of the 
report, in the Record Area. You might use a Report Header box for: 

• 
• 

A report title (text box or fixed text in a form box) 
A company logo (picture box) 
The current date, time, textbase name, or search criteria (variables) • 

• Prompted text entered by the user, such as the name of the person who is printing the report 

To add a Report Header 
1. Choose Report Options>Work in Record Area. If you do not see that option, you are 

already working in the Record Area. 

2. Choose Report Options>Headers and Footers to open the Headers and Footers dialog 
box. 

3. Select Report Header from the Header/Footer list, then click the Insert Header/Footer 
button. A form box is added to the Record Area, and the Form Box Properties dialog box 
opens. You can also use text boxes, picture boxes, script input boxes, and script buttons as 
headers/footers. For more information, see “Changing Box Types” on page 274. Note that 
Report Header boxes are added above all Record boxes, but you can move them if you 
want. 
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4. Specify a content item using the subtabs on the Contents tab. Click Add. 

5. Format the box label and contents using the other tabs on the Form Box Properties dialog 
box. 

Adding Report Footers 
Use a Report Footer box for information you want to appear once at the end of a report. Report 
Footer boxes typically show final results, such as:  

• A grand total of a numeric field (calculation) 
• 
• 
• 

An average of a field (calculation) 
The total number of records (RECORD COUNT variable or COUNT(1) if sort is exploded) 
The current date, time, textbase name, or search criteria (variables) or fixed text 

For more information, see “ ” on page 230. Where to Place a Calculation

To add a Report Footer 
1. Choose Report Options>Work in Record Area. If you do not see that option, you are 

already working in the Record Area. 

2. Choose Report Options>Headers and Footers to open the Headers and Footers dialog 
box. 

3. Select Report Footer from the Header/Footer list, then click the Insert Header/Footer 
button. A form box is added to the Record Area, and the Form Box Properties dialog box 
opens. You can also use text boxes, picture boxes, script input boxes, and script buttons as 
headers/footers. For more information, see the next section, “Changing Box Types.” Note 
that Report Footer boxes are added below all Record boxes, but you can move them if you 
want. 

4. Specify a content item using the subtabs on the Contents tab, such as a calculation for a 
grand total. Click Add. 

5. Format the box label and contents using the other tabs on the Form Box Properties dialog 
box. 

Changing Box Types 
In order to have a text box, picture box, script input box, or script button be a Header or Footer 
box, you must first add it (choose Edit>Add), then choose Report Options>Headers and 
Footers to change the box to the appropriate type of header or footer. 

Also, if you inadvertently specify the wrong box type, you can change a Header or Footer box to 
a Record box, and vice versa, rather than having to delete the box and start over. 
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To change a box type 
1. While working in the Record Area, select the box to be changed, then choose Report 

Options>Headers and Footers. The Headers and Footers dialog box opens. 

2. Do the following, depending on the change you want to make to the box: 

– To change to a Header or Footer box, select the box type you want from the 
Header/Footer list. If you select Sort Header or Sort Footer, select a level from the 
Sort Level drop-down list. Click the Change to Header/Footer button. 

– To change from a Header or Footer box to a Record box, click the Change to Record 
Box button. 

Printed Reports 
A report form designed for printing can include page numbers, titles, calculations, Sort Headers 
(such as Sales by Territory), and many other sophisticated formatting techniques. 

A form designed for printing can use the Margin Area to display additional information, such as 
a report title, page numbers, or a company logo that prints on every page of the report. The 
Margin Area is ignored for desktop and Web display. For more information on using this area, 
see “ ” on page 283. Working in the Margin Area

When creating a Report Printing form, you may also want to use Report Header and Report 
Footer boxes to display information in the Record Area. 

Areas of a Form 
Each form has two areas in which you can add boxes to display information: 

• Margin Area. Information in this area appears only in printed reports—and it appears on 
every page. Use the Margin Area for information that you want repeated on every page, 
such as page numbers and the current date. 

• Record Area. Information in this area is used primarily for record information (fields). In a 
report, records appear one after the other, sorted as specified. The Record Area can also 
include, for example, a title on the first page, Sort Headers, and a grand total on the last 
page. 
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When you are working in the Form Designer, you can toggle between the areas as needed. When 
you are showing the Margin Area, all form and box background colors are ignored, since 
background colors are ignored when printing a report. The active area is white. The inactive area 
is gray. You can add boxes only to the active area.  

Boxes in the Margin 
Area appear only 
when you print the 
report. 

Boxes in the Record Area 
always appear. 

Note that Header/Footer 
boxes do not appear in 
the Display or Edit 
windows. 

 

To toggle between the areas 
1. The Record Area is active by default. To make the Margin Area visible, choose Report 

Options>Show Margin Area. 

2. Choose Report Options>Work in Margin Area or Report Options>Work in Record 
Area; or you can click in the inactive area to make it active. 

3. To hide the Margin Area, choose Report Options>Hide Margin Area. 

Using Boxes in the Margin and Record Areas 
When you work in the Margin Area, you can add a Margin box. When you work in the Record 
Area, you can add a Record box or a header/footer box. To summarize:  

• A Margin box is a box that you add in the Margin Area by choosing Edit>Add and clicking 
Form Box, Text Box, or Picture Box. Script input boxes and script buttons are not 
available in the Margin Area. 

• A Record box is a box that you add in the Record Area by choosing Edit>Add and clicking 
Form Box, Text Box, Picture Box, Script Input Box, or Script Button. 
Note: You can look at the status bar at the bottom of the Main window to see the type of 
box that is currently selected (for example, form, text, picture) and the box’s function within 
the form (for example, Record box, Margin box). 

• A header or footer box is a box that you add in the Record Area by choosing Report 
Options>Headers and Footers. When you insert a new header or footer box, a form box is 
added. You can also use the Headers and Footers dialog box to change other types of boxes 
(for example, a picture box) to header or footer boxes. For more information, see “

” on page 274. 
Changing 

Box Types
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The following table lists some typical uses for the box types, and specifies in which form area 
they are applicable.  

Box Type Form Area Use 
Margin box Margin Report title, current date and time, page 

numbers, column headings, company logo. 
(They appear on every page of a printed report.) 

Record box Record Record information, calculations, record images. 
(They appear once for each record in the report.) 

Report Header box Record Search criteria, prompted text, report title, 
column headings. (They appear once, at the 
beginning of the report.) 

Sort Header box Record Sort field contents. (They appear whenever a 
new group of records begins. A Sort Header box 
typically has a Sort Key as its content, but can 
have other content items, such as fixed text.) 

Sort Footer box Record Sort field subtotals. (They appear whenever a 
group of records ends. Typically, a Sort Footer 
box contains a subtotal or other computed value 
for the current group.) 

Report Footer box Record Grand totals, averages, or counts. (They appear 
once, at the end of the report.) 
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The following illustration shows how the box types are used in a printed report: 
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This printed report shows quarterly sales, subtotaled for each customer and region, with a grand 
total for the entire report. The Region field is Sort Level 1 (for example, Northeast, Northwest). 
The Customer field is Sort Level 2 (for example, Concord Miniatures). 

 

Margin boxes in 
the Margin Area 

Report Header 

Sort Header Level 2 

Sort Footer Level 2 

Sort Header Level 1 

Record boxes 
containing record 
information (fields) 

Sort Footer Level 1 

Report Footer
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Here is what the form looks like in the Form Designer: 

 

Here is how to create each box: 

• Quarterly Dealer Sales Report. Place a text box in the margin. You may need to choose 
Report Options>Show Margin Area>Work in Margin Area first. Choose Tools>Box 
Properties>Font, Color to change the font. 

• Date and Time. Use a Margin box with variables. Use Tools>Box Properties>Paragraphs 
to make each item a separate paragraph. 

• Page number. Use a Margin box with variable. Add the word Page as fixed text. 
• Horizontal rule. Place a text box in the margin (containing a line composed of underbar 

characters __ ), set to maximum height =1. 
• Column headings. Add text boxes, then choose Report Options>Headers and Footers 

and change the text boxes to Header boxes. Move the boxes next to each other, select them 
all, then choose Tools>Align Boxes>Anchor and Top to align the boxes. 

• Sort Headers. Define a compulsory sort (choose Report Options>Compulsory Sort) on 
Region (Sort Level 1) and Customer (Sort Level 2). Add a form box and change it to a Level 
1 Sort Header box whose content is Sort Key Level 1 (choose Report Options>Header 
and Footers). Then add another form box and change it to a Level 2 Sort Header box whose 
content is Sort Key Level 2. 

• Fields. Add boxes and anchor them to each other for each field you want to display (Invoice 
Date, ID, Quantity, Price per Unit). To anchor boxes, position them next to each other using 
the mouse, select them all, then choose Tools>Align Boxes>Anchor and Top. The last box 
in this row contains a calculation, not a field. The calculation is: quantity*"price 
per unit". This multiplies two fields together (Quantity and Price per Unit). 
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• Sort Footer Level 2. Add a form box and change it to a Level 2 Sort Footer box whose 
content is Sort Key Level 2. Use ending text to add a space and the word SUBTOTAL 
(choose Tools>Box Properties>Format>Added Text). Add another form box and change 
it to another Level 2 Sort Footer box whose content is a calculation: 
TOTAL(quantity*"price per unit"), then choose Tools>Box 
Properties>Format>Numbers, Dates to set the number format to currency. 

• Sort Footer Level 1. Add a form box and change it to a Level 1 Sort Footer box whose 
content is the Region field. Use added text (Format tab) to add a space and the word 
SUBTOTAL as ending text. Add another form box and change it to another Level 1 Sort 
Footer box whose content is a calculation: TOTAL(quantity*"price per unit"), 
then choose Tools>Box Properties>Format>Numbers, Dates to set the number format to 
currency. 

• Grand total. Add a form box and change it to a Report Footer box whose content is a 
calculation: TOTAL(quantity*"price per unit"). Choose Tools>Box 
Properties>Format>Numbers, Dates to set the number format to Currency. Add a text 
box, type the words GRAND TOTAL, and change it to be a Report Footer box (choose 
Report Options>Headers and Footers). 
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Not all reports include Sort Headers and Footers. For example, the report shown below simply 
lists record information. The title (Consultant Assignment List) is a Report Header 
text box. The distribution list is a Report Header box containing prompted text. Each record in 
the report is numbered using the RECORD NUMBER variable. 

 

282 Chapter 5: Working with Forms 



 

Working in the Margin Area 
The Margin Area contains information that repeats on every page of a printed report. 
Information in the Margin Area is ignored except when the form is used for printing. The 
purpose of the Margin Area is to print information on every page, such as a company logo, page 
numbers, and the report title. Although this type of information typically is placed at the top and 
bottom of the page, you can place boxes on all four sides of the Margin Area. This provides the 
flexibility to design a variety of reports. 

Note: To change the size of the Margin Area, use Report Options>Set Up Page. 

Some typical items that you might place in the Margin Area include: 

• The report title 
• The current date and time 
• Column headings  
• Page numbers 
• Company logo 
Tip! Do not put a count or total calculation in the Margin Area—keep it in the Record Area. 

To add boxes in the Margin Area 
1. Open a form in the Form Designer.  

2. If the Margin Area is not visible, choose Report Options>Show Margin Area. 

3. Choose Report Options>Work in Margin Area or click on the gray area with the mouse 
to enable it. The Form Designer window below shows the Margin Area enabled. 

 

Margin Area

Record Area
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4. Choose Edit>Add and select the type of box you want to use to specify information on 
every page. For example, if you want the current date to appear at the top of every page, add 
a form box and define its content as the DATE variable. If you want a company logo to 
appear at the top of every page, add a picture box and define its content with the appropriate 
image file name. Use the Box Properties dialog box to format the box. Note that script 
buttons and script input boxes are not available for use in the Margin Area. 

Note: If you place a box too close to the outside edge of the Margin Area, you will get a 
warning message when you save the form telling you the box is in a non-printable area of 
the page. The non-printable area is the area around the edges of a sheet of paper into which 
the printer cannot print. On a laser printer, this area is usually ¼ inch or less. 

Specifying a Report Title 
A report title can consist of a text box in the Margin Area. If you open the Basic Report form, a 
form box for the report title appears, containing the fixed text <Report Title Goes 
Here>. You can either change this title to correspond to the report you are designing (choose 
Tools>Box Properties>Contents) or delete the box. If you delete the box, you can add a box at 
any time. Use the Box Properties dialog box to format the text. 

Tip! The Margin Area appears only in printed reports. If you design a form for the Report 
window, Write Report to File, Send Report as Mail, or for use on the Web and you want a report 
title to appear, place the title in a Report Header box in the Record Area. For more information, 
see “ ” on page 273. Report Headers and Footers

Numbering Pages 
You can number pages in a printed report by adding a box anywhere in the Margin Area and 
specifying its contents as the PAGE NUMBER variable. (For information about adding boxes in the 
Margin Area, see page 283). Each page is numbered with Arabic numerals, starting with 1. To 
change the starting page number, choose Report Options>Set Up Page.  

If you open the Basic Report form, a box for the page number appears automatically in the 
bottom of the page’s Margin Area.  

To change the appearance of a page number, such as its font, choose Tools>Box 
Properties>Format>Font, Color. To add the word Page before the page number, select the 
box containing the page number, choose Tools>Box Properties>Format>Added Text and type 
the word Page followed by a space as beginning text. To surround the page number with dashes 
(for example, -1-), enter the preceding dash as beginning text and the ending dash as ending text. 
Include spaces, if you want them. 

To remove the page number box, select it and press the Delete key on the keyboard or choose 
Edit>Delete Box. 
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Working in the Record Area 
The Record Area contains information from records, along with report information, such as 
calculations. It is where the body of the report appears. Header and footer boxes also appear, but 
only in reports. They do not appear in the Edit and Display windows. 

Adding record information 
You add record information to a form by adding Record boxes, then choosing Tools>Box 
Properties to specify attributes such as content, size, position, labels, borders, paragraph 
formatting, and text formatting, as explained earlier in this chapter.  

Numbering records 
You can number each record in a report by adding the RECORD NUMBER variable to a form box 
in the Record Area of a form. 

Note: In an exploded sort, each occurrence of a record, not just each record, is numbered. 
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To number records in a report 
1. Choose Report Options>Work in Record Area. If you do not see that option, you are 

already working in the Record Area. 

2. Add a form box by choosing Edit>Add>Form Box. The Form Box Properties dialog box 
opens. 

3. On the Variables subtab of the Contents tab, select RECORD NUMBER from the 
Variables list and click Add. 

4. On the Labels tab, make sure the Label and Border check boxes are cleared. 

5. On the Added Text subtab of the Format tab, type a period (.) in the Ending text box. 

6. On the Paragraphs tab, select Right from the Justification drop-down list. 

7. Click Apply, then Close on the Form Box Properties dialog box to confirm all the settings 
you specified. 

8. Make the box as narrow as possible by resizing it with the mouse. 

9. Select the box containing the item you want to number (such as the Product Name field) and 
drag it to the right of the box that contains the RECORD NUMBER variable. You will probably 
have to reduce the width of box first. 

10. Align the two boxes by selecting them and choosing Tools>Align Boxes>Anchor and Top. 

11. Choose Tools>Box Properties>Position and change the Left Offset to zero by typing 0 in 
the Left box. Click Apply, then Close. 

12. Re-arrange other boxes as needed. 

Note: If you put the RECORD NUMBER variable in the same box as the record information, the 
text that follows the number will not be aligned vertically from record to record. If this is 
acceptable, specify the variable and the field as content items in the same box. 

Controlling the distance between records 
To specify the vertical space between records in a report, choose Tools>Form 
Properties>General, and type a value in the Distance between records box. If a box at the top 
of the form has a top offset (Tools>Box Properties>Position), that value is added to the 
distance between records. 

Note that the Form Designer only shows one record at a time. To see how the spacing looks, 
save the form, then select it for the Report window. 

Tip! You can design a report to show summary information only, by making each box a Sort 
Footer or Report Footer. To avoid large gaps in such a report, set the distance between records to 
zero. 
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Creating Column Headings 
You can add column headings to any report. Column headings are typically text boxes or form 
boxes containing text. The design of your report determines where you place the column 
headings. Typically, you would add column headings after you add and size the corresponding 
Record boxes. 

To place a column heading… Add a text box in the… 
At the top of every printed page Margin Area 
At the top of the first printed page only or at 
the beginning of a displayed report 

Record Area, then change it to a Report 
Header box 

If you place a column heading in a Margin box in the Margin Area, it will appear on every page 
of a printed report. If you place a column heading in a Report Header box, it will appear once at 
the beginning of the Report window or printed report. 

Tip! In a tabular form, the box labels are the column headings. They print on every page. 

To create column headings on every page 
1. The Margin Area must be active. If it is not, choose Report Options>Show Margin Area, 

then choose Report Options>Work in Margin Area. 

2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog 
box. 

3. On the Text tab, type a column heading in the Text box and click Apply. 

4. Move and size the box, as needed. 

5. Repeat steps 2–4 for each column heading you want to add. 

6. Format the box contents using the Position and Font, Color tabs on the Box Properties 
dialog box. 

7. Click Apply, then Close. 

To create column headings on the first page only 
1. The Record Area must be active. If it is not, choose Report Options>Work in Record 

Area. 

2. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog 
box. 

3. On the Text tab, type a column heading in the Text box and click Apply. 

4. Choose Report Options>Headers and Footers to open the Headers and Footers dialog 
box. 

5. Select Report Header from the Header/Footer list. 

6. Click the Change to Header/Footer button. 

7. Move and size the box, as needed. 
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8. Repeat steps 2–7 for each column heading you want to add. 

9. Format the box contents using the Position and Font, Color tabs on the Box Properties 
dialog box. 

10. Click Apply, then Close. 

Tip! To help align boxes for column headings, select the boxes at the top of all the columns in 
the Record Area, copy them (choose Edit>Copy), switch to the Margin Area, and paste the 
boxes. Then change the contents of each box. 

Underlining Text 
You may want to underline text, especially when creating column headings. 

1. Select a box and choose Tools>Box Properties to open the Form Box Properties dialog 
box. 

2. On the Font, Color subtab of the Format tab, click the Set Font button to open the Font 
dialog box. 

3. Select the Underline check box in the Effects group and click OK. 

4. Click Apply, then Close on the Form Box Properties dialog box. 

By default, an underline is the length of the text only. To extend the underline beyond the text 
(in either direction), type spaces around the text that you are underlining. For example, if you 
added column headings as fixed text, press the Spacebar when defining the fixed text. When 
you apply the underline, it will extend to include the spaces you added. 

Tip! To avoid having to count the exact spaces to the edge of the box, choose Tools>Box 
Properties>Position and set the Maximum height to 1, and then type more spaces than you need 
to reach the edge of the box. This setting will cause any spaces that wrap to the next line to be 
truncated. 

Setting Up the Report Page 
When you design a form for printing, use the Set Up Page dialog box before you begin adding 
boxes. There are also printer-specific settings that control the report output, such as which fonts 
are available and whether landscape orientation is an option. For more information, see “

” on page 316. 
Printing 

a Report
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To set up the page 
1. Choose Report Options>Set Up Page to open the Set Up Page dialog box. 

 
2. Specify the following settings: 

– Size. Type values in the Width and Height boxes to correspond to the dimensions of 
the paper on which you will print. In the United States, the default is 8.5 inches by 
11 inches. 
Note: To change the unit of measure, such as inches, choose Tools>Form Properties> 
General. 

– Margins. Create the Margin Area for printed reports by typing values in the Left, 
Right, Top, and Bottom boxes. 

– Orientation. Select either Portrait or Landscape from this drop-down list. Portrait is 
a vertical page orientation that prints across the narrower dimension of a rectangular 
sheet of paper. Landscape is a horizontal page orientation that prints across the wider 
dimension of a rectangular sheet of paper. 

– Starting page number. Change the value in this box if you want to start numbering 
pages at a number greater than one. To format the page number, see “

” on page 284.  
Numbering 

Pages
– Page Breaks. Specify page breaks by selecting the appropriate check boxes: 

 Break after Each Record. Starts a new page after the end of each record. If a 
record is too large to fit on a single page, DB/TextWorks continues the record on 
the next page, but the subsequent record will be placed on a new page. 

 Break if Record Does Not Fit. Starts a new page when the contents of a record 
cannot fit on the current page. 
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 Break before Sort Header Level 1. Starts a new page when the contents of the 
Sort Header Level 1 changes. For example, if the Sort Header Level 1 box contains 
the Dept field, each time the information in the Dept field changes (for example, 
Sales, Reference, Research), the Sort Header Level 1 and the first record in the new 
group will start on a new page. 

Note: If you do not select a check box, pages break when the printed lines reach the 
bottom of the Record Area. This fits as much information on a page as possible and 
allows pages to break in the middle of a record or form box. 

Special Report Templates 
While you can use the Form Designer to create original and unique customized forms, 
DB/TextWorks also provides some special types of forms to make designing some common 
kinds of forms easier. 

DB/TextWorks provides separate options for tabular forms and label forms. That means you can 
easily create a form that shows information in rows and columns, or design a form to print 
mailing labels, library book labels, and other labels. 

Tabular Forms 
Use a tabular form to present information in rows and columns. Tabular forms are especially 
useful for displaying a summary of records found by a search. Each row represents a record. 
Each column, by default, represents a field. Each cell contains field content from records. 

 

 

 

Each row 
represents a 
record. 

Each cell 
contains 
field 
content. 

Each column represents a field.

 

To design a tabular form 
1. Open a textbase. 

2. Choose Display>Design Form (or, in the Form Designer, choose Form Operations>Open 
Form) to open the Open Form dialog box. 

3. Select New Tabular Form from the Start With list and click OK. 
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4. On the Choose Initial Tabular Form Fields dialog box, select the fields you want to make up 
columns in the table. Do this by selecting a field from the Available Fields list and clicking 
the > button to move it to the Initial Fields list. Do this for each field you want in the table. 
The fields in the list will appear left to right on the tabular form. 

5. Click OK. The illustration below shows how the form above looks in the Form Designer. 

 
6. To customize the tabular report to meet your needs, select a box and choose Tools>Box 

Properties to open the Form Box Properties dialog box. Use the tabs and subtabs on this 
dialog box to specify content, position, label, formatting, and—if you plan to use the form 
on the Web—HTML attributes, as applicable. 

7. Save the form. 

The following are some examples of what you can do to customize a tabular form: 

• 

• 

• 

To change the content of a column (for example, to show the contents of the Features 
field—which is not pictured in this form—instead of the Price field), select that column 
then use the Contents tab to specify the contents you want. You can also specify other 
content besides fields, such as variables or calculations. 
To add column headings, use the Labels tab to add box labels. You can change many 
attributes, including what each heading (label) says, its font, and its justification. Column 
headings appear on each page of printed and Web reports. 
To reorganize columns, select a column, then drag it right or left with the mouse. Be sure 
the cursor is not over a box handle or you will resize the column. Cell height is the same for 
each row, determined by the box size that you set (choose Tools>Box 
Properties>Position). 
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Designing Labels and Cards 
You can create address labels and labels for file folders, rotary cards, library catalog cards, and 
library book label sets. DB/TextWorks includes many blank label formats reflecting the 
dimensions for various stock numbers from numerous companies, including Avery, Gaylord, 
Demco, and University Products. 

Because DB/TextWorks fields are unlimited in length and can include multiple entries, 
designing a label involves some planning. Issues to consider include: 

• What type of box (or combination of boxes) to use. Form boxes, text boxes, and picture 
boxes are all perfectly acceptable and can create customized labels.  

• Whether to use one box or multiple boxes for the label information. 
• Whether to set a maximum height for each box. 
If you are sure that the information in your label will not exceed the label height, you can place 
all textbase fields in one form box, as shown in the following example.  
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Use options to format text and pictures found on the corresponding Box Properties dialog box as 
explained in “ ” on page 252.  Examples of Combined Formatting

All fields in one box

 
If any of the fields are likely to contain multiple lines of information that are not crucial (such as 
the Company field), put those fields in separate boxes and set a small maximum height for each 
box, such as 1 line. This will truncate the information to allow room for the more important 
address information to follow. Set the minimum height of all the boxes to zero (0) lines, so that 
empty boxes will not appear. Also set the Top Offset of all boxes except the first to zero (0), to 
fit the maximum amount of information on the label. (To set box height and position, choose 
Tools>Box Properties>Position.) 

Fields in separate boxes

 

To create a standard label or card 
Note: This section uses predefined label formats provided by DB/TextWorks. 

1. Search for records containing the information you want to include on the label or card. 

2. Choose Display>Design Form to open the Form Designer. The Open Form dialog box 
opens. (If you are already in the Form Designer, choose Form Operations>Open Form.) 
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3. From the Start With list, select New Label Form. 

 
4. From the Stock Number list, select the label format you want to use and click OK. The 

Form Designer window opens. 

 

 
5. Add one or more boxes, and define and format the box content. 

6. Choose Display>View Records to verify that the boxes accommodate your actual data. 

7. Choose Display>Next Record or use the Next Record toolbar button to look at several 
different records. 

8. Choose Form Operations>Save Form As to open the Save Form As dialog box. Type a 
form name and description that clearly identifies the label form’s purpose. 
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9. Preview the labels by closing the Form Designer (choose Form Operations>Close Form 
Designer), selecting the form you just saved as your Report Printing form (choose 
Display>Select Forms), and choosing File>Print Preview. For more information, see 
“Previewing a Printed Report” on page 315. 

Note: When you choose File>Print Preview, the Specify Starting Label dialog box opens. 
Click OK. 

10. Print one or two pages on plain paper and check their layout against the actual label or card 
stock. If necessary, make adjustments prior to printing on actual label stock. The procedures 
for printing labels or cards are the same as the procedures for printing reports. For more 
information, see “ ” on page 316. Printing a Report

To design your own customized label or card 
Use the following steps to design a label or card that does not match the dimensions of any of 
the label formats listed in the Stock Number list on the Open Form dialog box. 

1. Choose Display>Design Form to open the Form Designer. The Open Form dialog box 
opens. (If you are already in the Form Designer, choose Form Operations>Open Form.) 

2. From the Start With list, select New Label Form. 

3. From the Stock Number list, select the label format you want to use as a basis for your 
custom design and click OK. The label format chosen should be the one that most closely 
matches the dimensions of your label stock. 

4. Choose Report Options>Set Up Page to open the Set Up Page dialog box. 
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5. Change the dimensions to correspond to your custom label stock: 

– Page Width and Page Height. Specify the dimensions of the label or card stock. 
– Left Margin. Specify the distance from the left edge of the page to the left edge of the 

first label or card. 
– Top Margin. Specify the distance from the top edge of the page to the top edge of the 

first label or card. 
– Page Orientation. Decide how you want the labels or cards to be placed, relative to the 

page. Portrait is a vertical page orientation that prints across the narrower dimension of 
a rectangular sheet of paper. Landscape is a horizontal page orientation that prints 
across the wider dimension of a rectangular sheet of paper. 

– Label Width. Specify the horizontal distance from the left edge of the first label, card, 
or label set to the left edge of the next label, card, or label set. If the label stock has one 
label per row, this value is the width of one label. 

– Label Height. Specify the vertical distance from the top edge of the first label, card, or 
label set to the top edge of the next label, card, or label set. 

– Number Across. Set the number of labels, cards, or label sets across the page. 
– Number Down. Set the number of labels, cards, or label sets that appear down the 

page. 
6. Click OK. 

7. Add one or more form boxes, and define and format the box content. 

8. Choose Form Operations>Save Form As to open the Save Form As dialog box. Type a 
form name and description that correspond to your custom label or card stock. 

9. Preview and then print the labels. 

Note: When you choose File>Print Preview, the Specify Starting Label dialog box opens. 
Click OK. 
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Designing Label Sets 
A label set contains multiple labels for one textbase record. When you open a label set, such as 
the University Products book label set, the Form Designer window represents the area of all 
labels in a set. In the following example, the label set consists of three labels. 

The inner lines only 
appear when you open 
a new label, so it is 
important to position 
boxes during your first 
session in the Form 
Designer. 

 
 

 
This label set contains three 
labels for each record. 
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Unlike a standard label, a label set typically contains fields that appear more than once. In this 
sample label set form, the Classification number (Class) is repeated in three boxes, and the 
Author and Title fields are repeated in two boxes. To guarantee that the bottom label prints in the 
correct position, determine how many lines will fit on the top label and set Minimum height 
and Maximum height to that value. 

 

Using Scripts with Forms 
When you are designing a form, you can also design a script for use with that form. The script 
can perform certain operations when the form is opened or closed, when buttons on the form are 
pressed, when you leave a box, or in other situations. For example, a script can fill in a box 
automatically or perform extra validation on the contents of a field in an edit form. You can use 
script buttons to bring up field-specific help on an edit form, open a document in its native 
application from a record display, or move or copy information among boxes on the form. Form 
scripts can be written in either JavaScript (JScript) or Visual Basic Scripting Edition (VBScript).  

Important! Scripts are applicable to forms used on the desktop only; they are not applicable to 
those used on the Web with a WebPublisher product. 

Use the Names tab (choose Tools>Form Script>Names) to assign a name to each box in the 
form that you will use in your scripting program. The script cannot access boxes that have no 
script names assigned to them. The script is able to read the contents of the box (and, if 
permitted, modify it and write it back). If you have added script buttons or script input boxes to 
the form, each needs to be assigned a name. 

For detailed information about the functions you can use in a script, including examples, see the 
online help. 
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To define a script 
1. Choose Tools>Form Script to open the Form Script dialog box. 

JavaScript 
(JScript) is 
selected as the 
script language. 

 
2. On the Script tab, select the scripting language (JScript or VBScript) you want to use from 

the Script language drop-down list. 

3. Type the script in the Script box. You can paste the program into the box, if you 
constructed it in a different environment. 
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4. On the Names tab, select the box from the Boxes list to which you want to assign a name. 

 
5. Type the new name in the Box Name box. 

6. Click the Change button. The assigned name appears next to the box in the Names list. 

7. Repeat this process for as many boxes as needed. 

8. Click OK when done. 

Using Script Buttons and Script Input Boxes 
You can use a script button in a form to trigger a script function, and you can use a script input 
box to get information from the user to be used during the processing of a script. 

Script buttons and script input boxes are designed for use in the Record Area of a form. 

Script Buttons 
A script button is a button you place on a form. A script button allows you to call a function you 
have written on the Form Script dialog box (choose Tools>Form Script). A function allows you 
to perform additional processing, such as moving information among boxes or launching other 
applications. You can specify font and position properties for script buttons. 

Script buttons are not boxes, but you can add them to a form the same way you add a box. 
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Like boxes, script buttons have content, positioning, and formatting properties, and you use the 
Script Button Properties dialog box (choose Tools>Box Properties) to specify these properties. 
Script buttons are included in the tab order for navigational ease. 

Note: Depending upon their function, script buttons may only be appropriate for certain 
windows. For example, a script button that calls a script that moves text around is appropriate on 
an edit form in the Edit window, but not on a display form in the Display window. 

Script button content 
Because a script button is not a box, its content appears as a caption on the button.  

To specify script button caption 
1. Add a script button by choosing Edit>Add>Script Button. The Script Button Properties 

dialog box opens. (If you select an existing script button, choose Tools>Box Properties. 
You cannot specify button captions if you select more than one script button at a time.) 

 
2. On the Caption tab, type the wording you want to appear on the script button in the Caption 

box. The caption can be up to a maximum of 50 characters. 

3. Click Apply, then Close. 

Specifying script button anchoring and width 
You can specify the anchoring properties for a script button. Script button anchoring properties 
are specified the same way as for form boxes. For more information, see “

” on page 234. 
Floating and anchored 

form boxes

You can specify the width of a script button, but you cannot specify or change its height. You 
can set the button width to fit the caption or change the width of script buttons by dragging box 
handles or typing a value in the Width box on the Position tab on the Script Button Properties 
dialog box. 
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To change script button width 
Select one or more script buttons and choose Tools>Box Properties. On the Position tab, clear 
the Size button to fit caption check box, then use either of these methods to change script 
button width: 

• Select one script button and place the cursor over the left or right box handle. The cursor 
becomes a double-headed arrow. Drag the box handle to the left or right. 

• On the Position tab, type a value in the Width box, then click Apply. 

 
The button resizes, and the caption retains its font attributes and is centered within the button. 

Tip! Select the Size button to fit caption check box to automatically make the width of the 
script button the same as the caption it contains. 

Formatting text on script buttons 
You can type any text you want, up to 50 characters, on script buttons, as well as format the text. 

To format script button text 
1. In the Form Designer, select one or more script buttons. 

2. Choose Tools>Box Properties to open the Script Button Properties dialog box. 

3. On the Caption tab, click the Set Font button to specify the font, style, and size you want to 
use for the button text. Note that script button captions are always black; you cannot specify 
font color. Click OK to close the Font dialog box. 

4. Click Apply, then Close. 
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Script Input Boxes 
Use a script input box on a form if you want users to provide information to be used during the 
processing of a script. 

For example, you can use a script input box on an edit screen so information can be typed in it 
(such as, volume and issue information) to be used by a script to modify the other fields (for 
example, to generate a series such as, Vol. 2, Issue 1, Vol. 2, Issue 2, and so forth). 

The information typed into a script input box by a user is available as the contents of the box to 
any script. To access the contents, the script input box must be given a name in the Form Script 
dialog box (choose Tools>Form Script), which is where the script is defined. 

Script input boxes can also be used to provide a way for scripts to give information to the user. 
For example, a script could use a script input box to display instructions specific to the edit box 
that currently has focus. 

You can specify position attributes, label information, and font and color attributes for script 
input boxes. However, because users provide the information, script input boxes do not have box 
content. 

Specifying script input box height, width, and anchoring 
The height, width, and anchoring properties of script input boxes are specified the same way as 
for form boxes. For more information, see “ ” 
on page 231 or the online help. 

Specifying form box height, width, and anchoring

Note: When specifying script input box height, the maximum height applies in all windows, 
except the Report window. 

Adding labels, borders, and scroll bars to script input boxes 
You add labels, borders, and scroll bars to script input boxes the same way as form boxes. For 
more information, see “ ” on page 237 or the 
online help. 

Adding labels, borders, and scroll bars to form boxes

Formatting text in script input boxes 
You can apply different formatting to script input box text, as well as change the background 
color of the script input box for impact. Use the Font, Color tab on the Script Input Box 
Properties dialog box (choose Tools>Box Properties) to specify font attributes and background 
color. 
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To format text in script input boxes 
1. Select one or more script input boxes. 

2. Choose Tools>Box Properties to open the Script Input Box Properties dialog box. 

3. On the Font, Color tab, specify the applicable text formatting attributes: 

– Set Font. Click the Set Font button to specify the font, style, size, and color you want 
to use for text. Click OK to close the Font dialog box. To see the font you specified for 
your script input box, type some text into the box. A script input box is the only box 
type that lets you type text into it while in the designer. 

– Background color. Select this option to choose a color for the background of a script 
input box. Click the Select Color button to specify the color (including custom colors). 
Use this option if you always want the form to use the specified color, regardless of any 
colors specified using Tools>Options>Display>More Defaults>Colors. 

4. Click Apply. 

Sorting Records 
You can sort and subsort records to make them appear in a logical order in reports and when 
exporting records. You can use a variety of sort options to order the records precisely the way 
you want. For example, you can sort records alphabetically by name, then subsort by region, 
then by date in reverse chronological order. You can also sort records by their relevance, with 
the most relevant record appearing first. 

There are three ways to apply a sort: after a search, as part of a form, and as the textbase default. 
Each type of sort is summarized below. For more detailed information, see the online help. 

Note: If you use a form that has a compulsory sort, it is the sort used, regardless of other types of 
sorts that may be specified. If the form does not have a compulsory sort, the current 
user-specified sort takes precedence. If neither of those sorts is specified, the textbase default 
sort is used, if any. Lastly, if no sort of any kind is specified, records appear in the approximate 
order that they were added to the textbase. 

User-Specified Sort 
A user-specified sort is one that is done after a search (or after a set is loaded). To sort the 
records found, choose Display>Sort Report, then use the Specify Sort Order dialog box to 
specify how you want them sorted. For more information on the options available on the Specify 
Sort Order dialog box, see “ ” on page 307 and “ ” on page 308. To specify a sort Sort Options

You can change the sort options at any time, to sort the records in a different order. (This is the 
only sort that can affect exports.) The sort remains in effect until you close the textbase or sort 
again. 

For more information, see the online help. 
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Compulsory Form Sort 
If you want records to be sorted in a specific way when a particular form is used for a report, you 
can define a sort to do that. This is called a compulsory form sort. Avoid compulsory form sorts 
except when necessary, because they prevent records from being sorted in any other order. 

On the Web, a compulsory form sort is the only way to specify sort order other than the textbase 
default sort. A Relevance-Ranked Order sort is particularly appropriate for the Web, as it sorts 
records in descending order of their relevance, with the most relevant records appearing first. 

To specify a compulsory form sort, open the form you want to use in the Form Designer. Choose 
Report Options>Compulsory Sort, then use the options on the Specify Compulsory Sort Order 
dialog box to specify how you want records sorted. This dialog box is identical to the Specify 
Sort Order dialog box, which is used for a user-specified sort. The difference is, sorts specified 
on the Specify Compulsory Sort Order dialog box will be used each time the form is used in the 
Report window. For more information on the options available on the Specify Compulsory Sort 
Order dialog box, see “ ” on page 307 and “ ” on page 308. To specify a sort

To specify a sort

Sort Options

Sort Options

Typically, you use a compulsory form sort when a report includes a Sort Header or Sort Footer 
that depends on a specific sort order. For example, if a report contains subtotals that require a 
sort on a specific field (such as Total Sales by Region), a compulsory form sort will prevent the 
records from being sorted in any other order. 

For more information, see the online help. 

Textbase Default Sort 
A textbase default sort specifies the order in which records should appear in reports if no other 
sort is specified. For example, you might sort alphabetically by last name or chronologically by 
date. If you specify a textbase default sort order, you are not limited to it—you will still be able 
to sort records after a search (user-specified sort) by choosing Display>Sort Report, and you 
can still define sorts for forms (compulsory form sort). 

To specify a textbase default sort, open the textbase for which you want to specify the sort and 
choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog box. 
Click the Sort Order button to open the Specify Textbase Sort Order dialog box, then specify 
the sort options you want. For more information on the options available on the Specify 
Textbase Sort Order dialog box, see “ ” on page 307 and “ ” on 
page 308. 

For more information, see the online help. 
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Using the Specify Sort Order dialog boxes 
Once you decide the type of sort you want, you must specify the sort method. Use the applicable 
Specify Sort Order dialog box to specify how you want records sorted. 

This dialog box opens 
when you choose 
Display>Sort Report 
after doing a search. 

 
The dialog box may look a little different (for example, some options may be unavailable) and 
have a different name in its title bar (Specify Sort Order, Specify Compulsory Sort Order, or 
Specify Textbase Sort Order) based on the type of sort you are specifying (user-specified, 
compulsory form, or textbase default sort). 

The following table shows which sort methods are applicable to each type of sort. 

Type of Sort Sort Methods Available 
User-Specified Sort Sort Order Shown Below 

Relevance-Ranked Order 
Textbase Sort Order 
Unsorted Order 

Compulsory Form Sort Sort Order Shown Below 
Relevance-Ranked Order 
Textbase Sort Order 
Unsorted Order 

Textbase Default Sort Sort Order Shown Below 
Relevance-Ranked Order 
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To specify a sort 
1. In the applicable Specify Sort Order dialog box, select the sort method you want to use from 

the Use group. Note that some of the options may not appear, or may not be enabled, 
depending on the type of sort you are specifying. See the table above for a list of which sort 
methods can be used with the three types of sorts. 

– Sort Order Shown Below. Uses the sort you are now defining. This option is the 
default. 

– Relevance-Ranked Order. Sorts records in descending order of their relevance, with 
the most relevant records appearing first. This option can be used with word, phrase, 
and proximity searches. If a query involves term searches only, no relevance sort is 
attempted.  

– Textbase Sort Order. Reverts to the default sort order. 
– Unsorted Order. Causes records to appear in unsorted order (in the approximate order 

in which they were added to the textbase). Use this option if you want to speed up a 
report or produce a report with records in unsorted order. 

2. Do the following, depending on the sort method you selected: 

– If you selected Relevance-Ranked Order, Textbase Sort Order, or Unsorted Order, 
the remaining selections on the Specify Sort Order dialog box are disabled. Click OK 
to confirm your sort order selection. 

– If you selected Sort Order Shown Below, define your sort by choosing options from 
the Sort Specification group: 
a. Select a field from the Available Fields list and click the right arrow button (>) to 

move the field into the Sort Fields list. The field at the top of the Sort Fields list is 
called the primary sort field (Sort Level 1). You can subsort by up to four more 
fields by moving them into the Sort Fields list. This is a way of doing more refined 
sorts, such as alphabetically by region, then by name. The additional sort fields are 
known as Sort Level 2 through Sort Level 5. 

Note: If you do sort on several fields, you can use the Up and Down buttons to 
change the order of the fields in the Sort Fields list. If you change your mind and 
want to remove a field from the Sort Fields list, select the field in that list and click 
the left arrow button (<). To remove all fields from the Sort Fields list, click the 
double left arrow button (<<). 

b. [Optional] Specify the sort options you want. For more information, see the 
following section, “Sort Options.” 

c. Click OK. 
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Sort Options 
If you want to define your own sort order for a user-specified, compulsory form, or textbase 
default sort, select the Sort Order Shown Below option button from the Use group. This 
enables the settings in the Sort Specification group. 

This dialog box is 
used when you 
specify sort options 
for a compulsory 
form sort. 

 
When you define a sort, you can select one or more of the sort options explained below. 

Doing subsorts 
When you sort records, you can select a primary sort field and up to four subsort fields. For 
example, you could sort records by Region (primary sort field) then Company (subsort field). 
Multiple sort levels enable you to do more refined sorts. The field that you place at the top of the 
Sort Fields list is the primary sort field. Any fields you place below it are subsort fields. 

You can select any primary or subsort field and specify that it should be sorted in reverse order 
and/or exploded. You can also interfile fields with the primary sort field and specify what to do 
if the primary sort field is empty. All of those options are explained below. 
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The primary sort field is referred to as Sort Level 1 on the Form Designer dialog boxes, and any 
subsort fields are referred to as Sort Level 2 through Sort Level 5. For more information, see 
“ ” on page 216. Sort Keys Subtab

Sort Keys Subtab

 
In the Form Designer, Level 1 refers to the primary sort field, 
and Levels 2-5 refer to the fields selected for subsorts.  

Sorting in reverse order 
Each field in the Sort Fields list can be sorted in normal (ascending) or reverse (descending) 
order. To sort a field in reverse order, select it in the Sort Fields list, then select the Sort in 
Reverse Order check box in the Settings for this Field group. The selected field will be sorted 
in reverse alphabetic order (Z to A), reverse numeric order (highest to lowest), or reverse date 
order (most recent to oldest). If you reverse-sort the primary sort field, any alternate primary sort 
fields or interfiled fields will also be sorted in reverse order. 

Doing an exploded sort 
By default, records are sorted by the first entry in the selected sort field. If a field has multiple 
entries, you can do an exploded sort. To do an exploded sort, select a field in the Sort Fields list, 
then select the Exploded Sort check box in the Settings for This Field group. 

Note: This option is not available when defining a textbase default sort, and it is ignored for a 
form used on the Web (with a DB/Text WebPublisher product), because it can change the 
perceived number of records retrieved. 

In an exploded sort, the record appears in the report multiple times—once for each entry in the 
exploded sort field. For example, if you do an exploded sort on the Subjects field, and a record 
contains two entries in that field (Television and Comedy), the record will appear twice—
once under “C” for Comedy and again under “T” for Television. Without an exploded sort, each 
record would appear only once, sorted by the first entry in the field (in this case, 
Television). 

For more information about sorting, see “ ” on page 216. 
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For example, exploded sorts are appropriate when printing mailing labels from records 
containing multiple contact names. Say you want to print a label for each contact shown below 
(Mr. Tom Jones and Ms. Victoria Russo): 

 
An unexploded sort would print a label only for Tom Jones, because his name is the first entry in 
the field. To print a label for each entry, use an exploded sort for the Contacts field (Sort Level 
2) and make the box content the Sort Key. Do this in the form, as a compulsory sort. The 
Company field is the primary sort, and the Contacts field is a subsort. 

Label form with 
Sort Key Level 2 
(Contacts) in 
first box. 

Specify Compulsory 
Sort Order dialog 
box with Exploded 
Sort selected for 
the subsort field, 
Contacts (Sort 
Level 2). 
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Now you can use the form to print mailing labels for each entry in the Contacts field:  

This exploded sort 
makes sure that each 
person (entry) at a 
company gets a 
separate label. 

 

Selecting primary sort field options 
You can select up to four fields to be used as alternate primary sort fields, in case the primary 
sort field in a record is empty. The software will substitute the first field in the list of alternates 
that contains an entry. For example, say Author is the primary sort field and Corporate Author is 
the alternate. A record with an empty Author field will be sorted by its Corporate Author field. 

To specify what happens if the primary sort field is empty 
If you specify a primary sort field for a user-specified, compulsory, or textbase default sort, you 
can also specify what happens if the primary sort field is empty. This option is not available if 
you sort records by order of their relevance (by selecting the Relevance-Ranked Order option 
button in the Use group). 

1. On the applicable Specify Sort Order dialog box, click the Primary Sort Field Options 
button to open the Primary Sort Field Options dialog box. (The button is unavailable until 
there is at least one field in the Sort Fields list.) 
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2. Select an option in the Option If Primary Sort Field is Empty group: 

– Sort Those Records First. Any records whose primary sort field and all alternate 
primary sort fields are empty will be placed at the beginning of the sorted records. 
Affected records will appear in the approximate order in which they were added to the 
textbase unless you have defined one or more subsort fields. 

– Omit Those Records. Any records whose primary sort field and all alternate primary 
sort fields are empty will be omitted from the report. This option is referred to in the 
Summary section on the Specify Sort Order dialog box as “omitting empties.” 
Note: This option is not available when defining a textbase default sort, and it is 
ignored for a form used on the Web (with a DB/Text WebPublisher product), because it 
can change the perceived number of records retrieved. 

To specify alternate primary sort fields 
If you want to specify alternate primary sort fields, use the Primary Sort Field Options dialog 
box. To open this dialog box, click the Primary Sort Field Options button on the applicable 
Specify Sort Order dialog box. 

1. In the Alternate Primary Sort Fields group, select a field from the Available Fields list and 
click the right arrow button (>) to move the field into the Alternate Fields list. 

2. Repeat the previous step for each field you want to specify—up to four fields—in 
descending order of preference. If the primary sort field is empty in a particular record, 
DB/TextWorks will substitute the first field in the list of alternates that is found to be 
non-empty. If all are empty, the behavior specified in the previous section occurs. 

3. To sort on each entry in an alternate primary sort field, highlight the field in the Alternate 
Fields list, then select the Exploded Sort check box. The record will appear in the report 
once for each entry in the alternate primary sort field. 

Note: Exploded sorts are not available for textbase default sorts or WebPublisher reports. 

4. Click OK to save your selections. 

Interfiling 
Use interfiling to merge and sort up to five fields. For example, if you have two fields, 
Corporate Author and Personal Author, you can merge the information in both fields and sort 
the combined information alphabetically. Interfiling is for reporting purposes only. Records are 
not actually merged in the textbase. 

Note: This option is not available when defining a textbase default sort, and it is ignored for a 
form used on the Web (with a DB/Text WebPublisher product), because it can change the 
perceived number of records retrieved. 
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The following example was done as a compulsory form sort. The primary sort field is Corporate 
Author, the interfiled field is Personal Author, and the box content is the primary Sort Key 
(Level 1). If either of the interfiled fields have multiple entries, you should use an exploded sort 
to ensure that all the entries are included in the sort. If a record has information in both interfiled 
fields, it will appear twice, as shown below. 

 

To interfile fields 
1. On the applicable Specify Sort Order dialog box, move at least one field into the Sort Fields 

list. The field at the top of the list is the primary sort field (the one that will be interfiled 
with other fields). 

2. Click the Interfile button to open the Sort Order – Interfile Fields dialog box. 

 
3. Select a field from the Available Fields list and click the right arrow button (>) to move the 

field to the Interfiled Fields list. 
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4. Repeat step 3 for each field you want to interfile—up to four fields. The fields you select 
will be merged and sorted with the primary sort field. In the previous illustration, the 
contents of the Personal Author field will be interfiled with the Corporate Author field 
(primary sort field, not shown on this dialog box). 

5. To sort on each entry in an interfiled field, highlight the field in the Interfiled Fields list and 
select the Exploded Sort check box. In the previous illustration, if the Personal Author 
field contains multiple authors, every author will be interfiled with the Corporate Author 
field. If you do not do an exploded sort, only the first entry in the interfiled field will be 
considered in the sort. 

6. Click OK to save your selections. 

How Field Types and Indexing Affect Sort Order 
To determine how to sort records, DB/TextWorks uses the sort options you specify, together 
with the field type and special filing options defined for each field in the textbase structure. For 
example, Number fields are always sorted numerically, but numbers in a Text field could be 
sorted alphabetically if the Numbers File Numerically check box is not selected in the Special 
Filing Options group. Leading articles (such as A, An, The) might be ignored, and terms could 
be sorted word-by-word or letter-by-letter. Field types and special filing options are explained in 
Chapter 2, “Creating a Textbase.” 

Note that if you interfile sort fields or specify alternate primary sort fields that use radically 
different filing rules, the report could be very difficult to navigate. An example would be if you 
interfiled a Number field with a Date field. 

How to Determine if a Sort Exists 
To see if a textbase default sort or user-specified sort exists, choose Display>Textbase 
Information. The Textbase Defaults and Currently in Use sections on the Textbase Information 
window indicate if a textbase default sort or user-specified sort is in use. To find these sections, 
either scroll down or choose Edit>Find and search for the word sort. 

To see if a form has a compulsory sort, you can open it in the Form Designer, then choose 
Report Options>Compulsory Sort and see what options are defined. 

You can also print the form definition by choosing Maintain>Manage Textbase Elements, 
selecting a form from the Currently Saved list, and clicking Print. The sort fields, if any, are 
listed in the Compulsory Form Sort Order section near the end of the form definition. If the form 
does not have a sort, the words <none specified> appear. 

Notes about Sorting 
• The purpose of a sort is to group information and assist the person who will be navigating 

through the report. It is not helpful to sort by a field that does not appear in the report, either 
explicitly or as a Sort Key. 

• If you use an exploded sort, alternate primary sort fields, or interfiled fields, you should use 
Sort Keys as content items because they extract the appropriate field or field entry. 
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• If a form has more Sort Header/Footer levels than there are represented in the sort 
specification (that is, the primary plus the number of subsort fields), the additional Sort 
Header/Footer levels do not appear in the report. 

• The records in a set are not actually sorted until the report is generated. If you display or edit 
a record before displaying the report, the records will not appear in sorted order in the 
Display or Edit windows. 

• For sorting purposes, DB/TextWorks uses approximately the first 250 characters of the 
combined primary sort field and subsort fields. For example, if you sort by a long text field, 
subsort by a long research report title, and subsort again by volume number, the combined 
sort fields may exceed the character limit before the sort reaches the volume number. 

Printing Reports 
Reports generated using DB/TextWorks can be previewed to see how they will look printed, 
before you actually print them. 

Previewing a Printed Report 
Use the Print Preview window to see how a form will look when printed. The print preview 
shows the Margin Area, headers and footers, page breaks, and other report components. 

To preview a report 
1. Select the form you want to preview (choose Display>Select Forms>Report Printing). 

2. Perform a search that finds at least one record. Retrieving several records will give you a 
more realistic preview. The Select Search Results Window dialog box opens. 

3. Select the No window (do not display records) option button or click the Cancel button. 

4. Choose File>Print Preview. If any form box has prompted text specified as a content item, 
the Information Needed dialog box opens. Enter the information needed, then click OK to 
open the Preview window. 

5. The preview window opens. To navigate through the pages, use the toolbar options or press 
the PgUp and PgDn keys on your keyboard. 

6. To exit from Print Preview, click the Close button on the toolbar. 

Note: If you choose to view records after a search (instead of pressing the Cancel button) the 
Form Used to Print Report dialog box may open when you choose File>Print Preview. Select 
the appropriate options, then click OK. 
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Printing a Report 
You can print a report on regular paper or labels or card stock. You can print all pages or 
selected pages. 

Note: You can also print to file. Printing reports or images to a file retains printer codes, but 
most other print-to-file instances (for example, printing a textbase structure definition) create 
plain text files without printer codes. 

To print a report 
1. Select a printing form (choose Display>Select Forms>Report Printing). 

2. Search for the records you want to print. The Select Search Results Window dialog box 
opens. You do not have to view records, although you may want to. 

Important! If the Display or Edit window is selected, only the current record will be 
printed. 

3. [Optional] To omit a record from the report, select it in the Report or Display window and 
choose Sets>Omit Record. This does not delete the record from the textbase. 

4. [Optional] Choose Display>Sort Report to sort records in a particular order. Note that if 
the form used for printing (which is not necessarily the Report Printing form) has a 
compulsory sort, that is the only order in which records can appear. 

316 Chapter 5: Working with Forms 



 

5. Choose File>Print. The Form Used to Print Report dialog box opens if you chose to display 
records after the search and the form used in the window is not the form currently selected 
for printing. Select the form printing options you want and click OK. 

Notice that the names of the 
Report printing form and the 
Current window form are listed in 
the Current settings group. 

 
– Report printing form. Uses the Report printing form selected on the Select Forms 

dialog box. 
– Form for current window. Uses the form displayed in the current window. For 

example, if you are in the Report window, DB/TextWorks will use the Report Window 
form. 

– Always use this option without asking. Sets your selection as the current default form 
for printing. If you select this check box, this dialog box will not appear again. (To 
access it, choose Tools>Options>General and clear the check box in the Report 
options group.) 

6. When the Print dialog box opens, notice that the name of the print form appears on the 
status bar. Select the print options you want and click OK to begin printing. 

There are printer-specific options that have an effect on the report output, such as the page 
orientation (portrait or landscape), and paper size. You can check these settings using either the 
Setup button on the Print dialog box or File>Print Setup. 

To print just one record 
1. Search for the record you want to print. 

2. In the Select Search Results Window dialog box, specify where the record displays by 
choosing the Display window or Edit window option button. Click OK. 

3. Choose File>Print to open the Form Used to Print Report dialog box. Select the form 
printing option(s) you want and click OK. 

4. When the Print dialog box opens, notice that the name of the current print form appears on 
the status bar. Select the print options you want and click OK to begin printing. 
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To print labels 
You print labels the same way you print a report (see above), except you must use a label form 
and specify the label on which to start printing. Being able to specify the starting label is helpful 
because you can print on a partially used label sheet. 

The Specify Starting Label dialog box opens when you choose File>Print and press OK on the 
Print dialog box. Note that if you decide to preview the labels before printing (choose 
File>Print Preview), this dialog box also opens. 

 
1. On the Specify Starting Label dialog box, type the number of the label on which you want 

to start printing. Labels are ordered from left to right, starting from the top row, as shown on 
the Specify Starting Label dialog box. 

2. Click OK. 
Note: The Specify Starting Label dialog box will only let you specify a starting label 
number up to the maximum available for the selected form (that is, the number across 
multiplied by the number down). The default starting label number on the Specify Starting 
Label dialog box is 1, meaning the printing will start with the top left label in the first row, 
unless you specify another number. 

Troubleshooting 
When you try to print a report, you may receive a message box that indicates that the form 
dimensions do not match the page dimensions, or that one or more Margin boxes appear in the 
non-printable area of the page. The non-printable area is the area around the edges of a sheet of 
paper into which the printer cannot write. On a laser printer, this area is usually ¼ inch or less. 

Click Yes to print the report, or No to cancel the report printing. 

Here are some ways you can correct the problem: 

• Move the Margin boxes away from the page edges. Open the form in the Form Designer 
and move the boxes. To access the Margin Area, choose Report Options>Work in Margin 
Area. 

• Change the form dimensions. Open the form in the Form Designer and choose Report 
Options>Set Up Page. 
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Sending a Report as Mail 
You can send out a report as an electronic mail attachment in Plain Text (ASCII), Rich Text 
Format (RTF), or HTML format if you have access to mail services. Depending on your EMail 
program, the HTML attachment may appear in the body of the message. You also can send a 
report in Plain Text format in the body of the message, and you can attach other files (for 
example, document, HTML, image, and text) to the EMail. 

Use the settings on the EMail tab (choose Tools>Options>EMail) to designate how to access 
mail services for the Send Report as Mail feature. You have two options: 

• MAPI (Messaging Application Program Interface). MAPI (which is a program interface 
that lets you send EMail from within Windows programs) uses the EMail program already 
installed on your computer to access mail services. If you experience problems trying to use 
MAPI, then you should use SMTP instead. 
Important! MAPI users must also designate their EMail program as their default simple 
MAPI client. To do so, you must consult the documentation provided with your EMail 
program, as each one is different. 

• SMTP (Simple Mail Transfer Protocol). SMTP accesses mail services directly, without 
the need to use an EMail program. To use this option, you must provide the name or IP 
address of your mail server. Use SMTP if your EMail program does not support MAPI or 
you have difficulty using MAPI. 
Note: If you use SMTP, the maximum amount of text that you can place in the body of an 
EMail is 32,000 characters. 

The currently selected Report window form is used by default, so the output mimics the 
appearance of information displayed in the Report window. You can select another form. The 
resulting file is not paginated and information in the Margin Area of the form is ignored. Note 
that after you send a report as mail for the first time, your form selection is subsequently 
remembered. 

Images in picture boxes or inline images (for example, leading/trailing logos) are not included in 
reports sent via EMail. 
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To send a report as mail 
1. Open a textbase and retrieve one or more records. All of the records in the current set will 

be included. 

2. Choose File>Send Report as Mail, then select one of these message format choices from 
the drop-down list: 

– Plain text in message body. Inserts the report as text into the Message area of your 
EMail program. Retains as much formatting as possible, including some approximation 
of side-by-side boxes. Does not retain font or color. Plain text reports work best with 
certain form characteristics. For details, see the explanation of plain text on page 323. 

– Plain text attachment. Inserts the report as an attachment with a .TXT extension. The 
attachment retains as much formatting as possible, including some approximation of 
side-by-side boxes. Does not retain font or color. The report can be up to a maximum of 
32K. Plain text reports work best with certain form characteristics. For details, see the 
explanation of plain text on page 323. 

– Rich Text Format (RTF) attachment. Inserts the report as an attachment with an 
.RTF extension. Saves as much formatting as possible by converting it to instructions 
that most word processing and layout packages can read and interpret. 

– HTML attachment. Inserts the report as an attachment with an .HTM extension. 
Writes formatted record information to a file in Hypertext Markup Language (HTML), 
the document formatting language used by Web browsers. 

3. Make sure the Mail each record to a different address check box is not selected. 

4. [Optional] Click the Specify Form for Report button if you want to select a different form 
from the one shown on the Send Report as Mail dialog box. When done with the Select 
EMail Report Form dialog box, click OK. 

5. Do the following, depending on how you access mail services: 

– If you use MAPI: 
a. Click OK on the Send Report as Mail dialog box. A new message window for your 

default EMail program appears with the report in the message body or attachment 
field. 

b. Specify who should receive the report and fill in the other fields your EMail 
program may have. 

c. [Optional] Specify file attachments using your EMail program. 

d. Click your EMail program’s Send button. 

320 Chapter 5: Working with Forms 



 

– If you use SMTP: 
a. Fill in mailing information on the Send Report as Mail dialog box. Note that you 

must enter a valid EMail address (for example, name@domain.com) in the 
From box. 

b. [Optional] Click the Select File Attachment button to specify a file to attach to the 
EMail, then click Open. Do this for each file you want to attach. 

Note: Because file attachments are recorded in your textbase .IDI file, the 
attachments from your previous Send Report As Mail sessions are automatically 
attached. This makes it easier to send the same attachment to multiple recipients. 
File attachment lists are textbase-specific. To remove a file from the File 
attachments list, select it and click the Remove Attachment button. 

c. Click OK on the Send Report as Mail dialog box to send the EMail. 

d. Click OK to dismiss the confirmation message box that appears. 

Another way to use this feature is to create a textbase that contains a field that identifies a 
recipient (or recipients) for a record. Then, when you use the Send Report as Mail feature, you 
can quickly and easily send each record (or a notice containing information pertinent to that 
record) to its identified recipients. 

To send each record as mail to recipients identified within the record 
1. Open the textbase and retrieve one or more records. 

2. Choose File>Send Report as Mail. 

3. Select an option from the Message format drop-down list, as described in the previous 
procedure. 

4. Select the Mail each record to a different address check box. 

5. Select a field name from the Field containing EMail ‘To:’ address drop-down list that 
contains EMail addresses in the correct address format (for example, tjones@crafts.com, 
tmallory@carriers.com). 

Note: If a record has multiple EMail addresses, they must be in repeating entries. 

6. Do the following, depending on how you access mail services: 

– If you use MAPI: Type appropriate text in the Subject box. 
– If you use SMTP: Fill in mailing information. Note that you must enter a valid EMail 

address (for example, name@domain.com) in the From box. 
7. [Optional] Click the Specify Form for Report button if you want to select a different form 

from the one shown on the Send Report as Mail dialog box. When done with the Select 
EMail Report Form dialog box, click OK. 
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8. [Optional] Click the Select File Attachment button to specify a file to attach to the EMail, 
then click Open. Do this for each file you want to attach. 

Note: Because all file attachments are recorded in your textbase .IDI file, the attachments 
from your previous Send Report as Mail session are automatically attached. This makes it 
easier to send the same attachment to multiple recipients. File attachment lists are textbase-
specific. To remove a file from the File attachments list, select it and click the Remove 
Attachment button. 

If you are using SMTP, the 
dialog box you see will be 
different from the one shown 
here. While it has the same 
options available, it will also 
include a Mailing information 
section. If you are using MAPI, 
you do not need this section 
because you enter mailing 
information through your 
default EMail program. 

 
9. Click OK on the Send Report as Mail dialog box to send the EMail. 

10. Click OK to dismiss the confirmation message that appears. 
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Writing a Formatted Report to a File 
You can write formatted record information to a file in Plain Text (ASCII), Rich Text Format 
(RTF), or HTML format. The currently selected Report window form is used, so the output 
mimics the appearance of information displayed in the Report window. The resulting file is not 
paginated and information in the Margin Area of the form is ignored. 

To write a report to a file 
1. Open a textbase and retrieve one or more records. All of the records in the current set will 

be included. 

2. Select a Report window form (Display>Select Forms). 

3. Choose File>Write Report to File, then select one of these options: 

– Plain Text (ASCII). Retains as much formatting as possible, including some 
approximation of side-by-side boxes. Does not retain font or color. Plain text reports 
work best with the following form characteristics: 

 Courier New 10 point font for labels and text font (choose Tools>Box 
Properties>Labels and Tools>Box Properties>Formats>Font, Color). 

 Vertical units set to Lines (choose Tools>Form Properties>General). 
 Top Offset for boxes set to whole increments of lines, such as 1 or 2, not .5 

(choose Tools>Box Properties>Position). 
– Rich Text Format (RTF). Saves as much formatting as possible by converting it to 

instructions that most word processing and layout packages can read/interpret. Most 
word processors use tables to emulate side-by-side paragraphs, and this may change 
alignment from the way it appears in DB/TextWorks. Also, avoid the Anchor to Form 
option except at the top of a report. The only box you can anchor to the form (and have 
it work well under RTF) is the top one. If boxes are next to each other, anchor them 
together. 

– HTML. Writes formatted record information to a file in Hypertext Markup Language 
(HTML), the document formatting language used by Web browsers. This provides a 
way of producing pages in HTML that you can publish on your Web site. The entire 
report becomes one HTML page. To generate multiple, smaller pages, do searches that 
generate fewer records and write each report to a separate file. (If you do not have a 
WebPublisher product, this option provides a way of publishing information on the 
Web. Unlike WebPublisher, which produces dynamic reports, writing to HTML 
produces a static report.)When prompted, specify a name and location for the file. This 
is the only option that retains images. It uses “simple” HTML (that is, all boxes are left-
justified, labels are on top of boxes, and font face is ignored) instead of Cascading Style 
Sheets (CSS). 
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Managing Forms 
Follow the instructions below to back up, delete, rename, and perform other operations on forms. 

Converting Forms to Query Screens 
You can convert a Display or Edit form to a query screen. Choose Search>Design Query 
Screen, and select Existing Record Form from the Start With list. 

Backing up and Sharing Forms 
Forms are saved in the textbase or user file. To back up forms saved in the textbase, back up the 
textbase. For example, if you copy the textbase Sales to a network drive, you will automatically 
back up any forms saved in that textbase. To back up forms saved in a user file, back up the user 
file. User files have the same name as the textbase with the extension .TBU. To see where your 
user files are located, choose Display>Textbase Information. 

To export forms to a file (an alternative way to back up forms) or to share forms with other 
users, choose Maintain>Manage Textbase Elements, then select Forms from the Now 
Managing drop-down list. Select one or more forms from the Currently Saved list and click the 
Export button. Name the file when prompted. All of the selected forms will be written to that 
file. If you ever need to restore the forms (for example, if you accidentally delete or damage 
them), you can use the Import button on the Manage Textbase Elements dialog box. 

Tip! Export all forms saved in the textbase to one file. Note that you can tell which forms are 
saved in the textbase because they have the word (public) after the form name. Then export all 
forms saved in the user file to another file. You can easily restore each set of forms to their 
proper places, if need be. 

Deleting Forms 
To delete a form, choose Maintain>Manage Textbase Elements, then select Forms from the 
Now Managing drop-down list. Select one or more forms from the Currently Saved list, click 
the Delete button, then respond to the prompt. Note that you will not be able to delete a form 
stored in the textbase if the password you are using does not allow you to save forms. 

Renaming Forms 
To rename a form, choose Maintain>Manage Textbase Elements, then select Forms from the 
Now Managing drop-down list. Select a form from the Currently Saved list, click the Rename 
button, then respond to the prompt. Note that you will not be able to rename a form stored in the 
textbase if the password you are using does not allow you to save forms. 
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Changing Form Information 
To change a form’s description or purpose (for example, Edit, Display), open it in the Form 
Designer and choose Form Operations>Save Form As. You can also change the form’s name 
and/or location (user file or textbase file), but this will save an additional copy of the form with 
the new name and/or location. Note that your password may prevent you from changing form 
information. 

Printing a Form Definition 
You can print a form description, or save it in a text file that you can view or print using a text 
editor or word processor. Definitions provide a way of saving information about a form and are 
especially useful for analyzing problems.  

To print a definition from within the Form Designer, choose Form Operations>Print 
Definition. You can also print a definition using the Print button on the Manage Textbase 
Elements dialog box (Maintain>Manage Textbase Elements). 

Important! A definition printed to a file is not a backup. It is only a description of form 
attributes. To back up or share forms, use the Export and Import buttons on the Manage 
Textbase Elements dialog box (Maintain>Manage Textbase Elements). 
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Selecting Forms 
To use a form, you have to select it. You can select forms for most operations at once using the 
Select Forms dialog box, or you can select a form for the current operation using a toolbar 
button. 

To select forms for most operations 
1. Choose Display>Select Forms to open the Select Forms dialog box. The forms you are 

using are listed on the dialog box. 

 
2. Specify which forms will be used for various operations: 

– To assign the textbase default forms for all operations, click the Revert to Defaults 
button. 
Note: For information about changing the textbase default forms, see the “Default 
forms” topic in the online help. 

– To select a form for a particular operation, click one of the four buttons: Record 
Display, Record Edit, Report Window, or Report Printing. A dialog box for that 
operation opens. (Note that each operation has its own dialog box.) Do the following, 
depending on the form you want to use: 
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 From the Currently Saved list, select a form to use with the operation and click 
OK. Forms are listed alphabetically within type. Basic forms are listed first, then 
forms saved in the current user file, and then forms saved in the textbase file, 
which are identified by the word (public). The form currently in use is highlighted 
on the dialog box. 

 

Note: When you saved a form, you specified the operations for which it could be 
used (Display, Edit, Report, Printing). Your decision at that time determines which 
forms appear now. If you do not see a form you want to use in the Currently Saved 
list, open the form in the Form Designer and use the Save Form As option to 
change the uses of the form. 

 Click the Revert to Default button to assign the current textbase default form for 
the operation and click OK. 

To select a form for the current window 
1. With a Display, Edit, or Report window open and active, choose Display>Select Forms. 

Note: You can also click the Select Form for this Window button  on the window’s 

toolbar or the Select Report Printing Form button  on the Main window toolbar. 

2. From the Currently Saved list, select a form for the current window (or for printing), or 
click the Revert to Default button to use the current textbase default form. Click OK. 

3. To quickly resize the window to fit the form, choose Window>Fit Window to Form or 

click the Fit Window to Form toolbar button . 

 Chapter 5: Working with Forms 327 



Designing Forms for Web Use 
If you have a WebPublisher product, you can design forms to use with textbases you publish on 
the Internet or an intranet. 

You can design forms for your users to view search results. Using a Web browser, users can 
search your textbase and have their results returned in dynamically generated HTML reports. 

WebPublisher gives you the flexibility to offer users the option to choose their own form from a 
list of Web forms (created by you), or you can specify one form be used with a particular 
textbase or saved query. WebPublisher PRO offers everything that WebPublisher does, but adds 
the ability to add, edit, and/or delete records from a Web browser and the ability to submit and 
return XML. 

Overview 
You design forms for Web use the same way you design forms for the desktop, using the Form 
Designer. (If you have WebPublisher PRO, you can also design an interface using a third-party 
tool, such as Microsoft FrontPage. For more information, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual.) 

Important! When designing a form to display records on the Web, be sure the Web check box 
and the Textbase File (Public) option button are selected on the Save Form As dialog box when 
you save the form. This makes the form available for Web use, and includes it in WebPublisher 
form drop-down lists on the Web. For more information, see “ ” on page 199. Saving a Form

For each textbase that you will publish on the Web, you should design one or more Report forms 
for displaying multiple records retrieved, and one or more Display forms for expanded display of 
one record at a time. If you have WebPublisher PRO version 7.0 or later, you may also want to 
design one or more Edit forms for adding, editing, and deleting records over the Web. 

• 

• 

• 

Report forms. Summarize multiple records found by a search. Tabular forms (described on 
page 290) are ideal for this purpose. Report forms often include a hypertext link (called an 
expand record link) to a display form. 
Display forms. Show detailed information about one record at a time. Used when a user 
clicks on an expand record link. 
Edit forms. Used to add, edit, and/or delete records over the Web. If you want to provide 
your users with direct HTTP access to an edit screen to add records (for example, to submit 
a registration form) you can design an edit form and export it to HTML. For more 
information about editing over the Web, see the Inmagic DB/Text WebPublisher PRO 
User’s Manual or the online help. 

Forms used with WebPublisher products to display records are saved with the textbase, just like 
with DB/TextWorks. However, Web editing forms you plan to have users directly access via 
HTTP must be exported to HTML, like query and menu screens. An exported editing form is 
used only to add records via a browser. For more information about exporting editing forms to 
HTML, see “Adding Records Over the Web” on page 330 or the online help. 
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HTML Properties for Forms 
There are many HTML attributes that can be applied to a form as a whole, as well as to the 
individual text and form boxes within it. For example, you can add a background image to a 
form, or create a hypertext link to another location.  

Note: HTML properties only have an effect on forms used on the Web. They are ignored for 
forms used in DB/TextWorks windows. 

• 

When you design a form for the Web, you can select Web-specific options from the tabs listed 
below: 

• Tools>Form Properties>Logos. Use the Logos tab on the Form Properties dialog box to 
add images to the top and/or bottom of a page. For more information, see “ ” on 
page 266. 

Logos Tab

• Tools>Form Properties>HTML. Use the HTML tab on the Form Properties dialog box to 
add record separators and/or a background image to the form. For more information, see 
“ ” on page 267. HTML Tab
Tools>Box Properties>HTML. Use the HTML tab on the Box Properties dialog boxes for 
form and text boxes when designing forms for the Web. The settings let you specify 
whether and how information will be interpreted as HTML. For form boxes, you must 
specify the content item in the Contents list to which you want to apply HTML. This is 
because a form box can contain several content items (for example, two fields, a variable, 
and fixed text). You also have the option to choose <all> to apply HTML formatting to all 
content items in the form box. For more information, see “ ” on 
page 253 and “ ” on page 258. 

Using HTML in form boxes
Using HTML in text boxes

Tip! You can also use HTML as added text in a form box to wrap around the data in the 
field specified as the box contents. For more information, see the “Added text” topic in the 
online help, or the Inmagic DB/Text WebPublisher PRO User’s Manual. 
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Adding Records Over the Web 
If you have DB/Text WebPublisher PRO, you can design an edit form with DB/TextWorks, 
export it to HTML, and then use it to add records to a textbase over the Web. If you use this 
method, you will only be able to add records from a Web browser—you will not be able to edit 
or delete records over the Web using this exported form. 

This is useful if you want to provide users direct access to an edit form on the Web from which 
they can submit information (for example, a registration form for an event). 

The Export Editing Form to HTML command on the Form Operations menu is an 
alternative way to add records over the Web. If you want Web users to have the ability to add, 
edit, and/or delete records in your textbase from a browser, use New record, Edit record, and/or 
Delete record links in your screens and forms. 

Important! When saving the edit form, select the Edit Window check box on the Save Form 
As dialog box. This check box must be selected for the form to be exported to HTML. 

For more information about exporting an edit form to HTML, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual or the online help. 
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Chapter 6: Working with Menu Screens 

Menu screens provide an easy way of opening your most commonly used textbases, as well as 
setting up a starting environment for DB/TextWorks. A menu screen may appear when you start 
the software, or you can select a menu screen after starting DB/TextWorks but before opening a 
textbase. 

 
A menu screen can control which initial elements (that is, forms, query screen, and/or record 
skeleton) are selected and what initial action occurs when a textbase is opened. 

You can design menu screens that access other menu screens. For example, you can design a 
menu screen that appears when you first open DB/TextWorks. This menu screen can contain 
menu screen boxes, with each menu screen box providing the ability to open an additional menu 
screen accessing multiple textbases. 

If you have a WebPublisher product, you can also use a menu screen on the Web to provide a list 
of hypertext links that launch predefined queries. 
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Opening and Closing the Menu Screen Designer 
Use the Menu Screen Designer to create and edit menu screens. After you open the Menu Screen 
Designer, the menus at the top of the screen change to provide menu-specific options. 

To open the Menu Screen Designer 
1. Start the software, but do not open a textbase. (If a textbase is open, choose File>Close.) 

2. Choose Menu Screens>Design and select an option on the Open Menu Screen dialog box: 

– Open Current Menu Screen File. Open the currently selected menu screen. 
– Create a New Menu Screen File. Open a blank menu screen (no boxes). When 

prompted, specify a name and location for the new menu screen file. The file extension 
.TBM is added automatically. 

– Open an Existing Menu Screen File. Select a previously saved menu screen. (Menu 
screen files have a file extension of .TBM.) 

3. Click OK. 

To close the Menu Screen Designer 
 Choose Menu Operations>Close Menu Screen Designer. 

Adding Boxes to a Menu Screen 
Using the Menu Screen Designer, you can add a variety of boxes to create the effect you want. 

Type of box  Common uses 
Textbase box Specify textbase to open; select forms and screens for initial 

use. 
Menu screen box Specify another menu screen to open without dismissing the 

current one. 
Text box Provide informational text; provide headings for groups of 

textbase boxes. 
Picture box Add a company logo. 
Script input box Receive information from the user to be used during the 

processing of a script. (Note that though a script input box can 
be added to a menu screen, it is not commonly used.) 

Script button Launch a script that opens another menu screen and dismisses 
the current one; open a disk file or launch another application. 
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To add a textbase box to a menu screen 
1. Choose Edit>Add>Textbase Box to add a textbase box and open the Textbase Box 

Properties dialog box. 

 

Note: If you want to access the Textbase Box Properties dialog box later to change box 
properties, select the box, then choose Tools>Box Properties. 

2. Use the tabs on the Textbase Box Properties dialog box to specify the options you want for 
the box: 

– Contents. Select a textbase to add to the menu and type descriptive text to identify the 
item on the menu. Users can click on the text to open the textbase. 

– Position. Optionally position the box by designating width, coordinates, and offsets. 
Width indicates the width of the box. Coordinates indicate the absolute position of the 
box on the menu screen. Offsets indicate the relative position of a box to either the 
screen or another box. Specifying values for these settings allow you to accurately 
position a box on the menu screen. 

– Font, Color. Optionally choose text-formatting attributes for the box. You can choose 
font, font style, size, effects, and font color. You can also choose background colors 
(including custom colors) for the textbase box itself. This flexibility allows you to 
create eye-catching, easy-to-read menu screens. 

– Icon. Optionally select an icon to appear in front of the menu item or remove an 
existing icon from the menu screen. Users can click on the icon to open the textbase. 
Icons will not appear unless the Show menu icons check box is selected on the General 
tab of the Menu Screen Properties dialog box (choose Tools>Screen 
Properties>General). 
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– Initial Elements. Optionally select forms, a query screen, and a record skeleton. 
DB/TextWorks loads your selections when the user performs the appropriate action. 
For example, when someone opens a record in the Edit window, DB/TextWorks uses 
the Record Edit form selected here. 

– Initial Action. Optionally specify what will occur when a user clicks on this menu 
item. You can specify no initial action, or what type of window to open, or to open a 
simple HTML window and load a specified HTML page, or to execute the query 
criteria in a saved query set. Running a saved query is convenient if you often perform 
the same query (for example, at the beginning of every day). For more information, see 
the online help. 
Tip! If you are designing a menu screen for use on the Web with a WebPublisher 
product, you should specify a saved query to launch a predefined search.  

3. Click Close when done. 

To add a menu screen box to a menu screen 
1. Choose Edit>Add>Menu Screen Box to add a menu screen box and open the Menu Screen 

Box Properties dialog box. 

 
2. Use the Contents tab to select a menu screen and type descriptive text to identify it. 

3. Use the other tabs on the Menu Screen Box Properties dialog box to specify the options you 
want for the menu screen. See the previous section for an explanation of each tab. Notice 
that there are fewer tabs on this dialog box. 
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To add a text box to a menu screen 
1. Choose Edit>Add>Text Box to add a text box and open the Text Box Properties dialog 

box. 

 
2. Type the text you want in the Text box, or click the Enlarge button to open a larger, 

resizable text editor dialog box instead. When you click OK on the text editor dialog box, 
your text appears in the Text box automatically. 

3. Use the tabs on the Text Box Properties dialog box to specify other attributes, including 
HTML properties, for text boxes used on menu screens on the Web with a WebPublisher 
product. For information about adding content, formatting, and HTML properties to text 
boxes, see Chapter 5, “Working with Forms,” the “Text Boxes” section, and the online help. 

Note: A text box used on a Web menu screen can have the following options selected from 
the Treat text as drop-down list on the HTML tab: Do not alter, Raw HTML, URL, 
EMail link, HTML file reference. These options are explained in Chapter 5, “Working 
with Forms,” the “To select HTML settings for form boxes” section, and the online help 

 Chapter 6: Working with Menu Screens 335 



To add a picture box to a menu screen 
1. Choose Edit>Add>Picture Box to add a picture box and open the Picture Box Properties 

dialog box. 

 
2. Use the tabs on the Picture Box Properties dialog box to specify the location of fixed images 

and settings for the picture box. For information about picture boxes, see Chapter 5, 
“Working with Forms,” the “Picture Boxes” section, and the online help. 
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To add a script input box to a menu screen 
1. Choose Edit>Add>Script Input Box to add a script input box and open the Script Input 

Box Properties dialog box. 

 
2. Use the tabs on the Script Input Box Properties dialog box to specify the position attributes, 

label information, and font and color attributes for the script input box. For information 
about script input boxes, see Chapter 5, “Working with Forms,” the “Script Input Boxes” 
section, and the online help. 
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To add a script button to a menu screen 
1. Choose Edit>Add>Script Button to add a script button and open the Script Button 

Properties dialog box. 

 
2. Use the tabs on the Script Button Properties dialog box to specify options and settings for 

the script button. For information about script buttons, see Chapter 5, “Working with 
Forms,” the “Script Buttons” section, and the online help. 

338 Chapter 6: Working with Menu Screens 



To perform other operations 
Use the options listed below to edit the menu screen and perform other operations in the Menu 
Screen Designer. Note that you must select a box (click on it) to change its size, position, or 
other attributes. Also note that you can use the mouse to move one or more boxes at a time or 
change the width of one box at a time. 

Menu Commands 
Menu Operations Open or save a menu screen; print a definition of a menu screen; 

export a menu screen to HTML (for use with a WebPublisher 
product); or close the designer. 

Edit Cut, copy, paste boxes; add boxes; delete boxes, go to a box; select 
all boxes. Note that when selecting all boxes, you can choose to 
select all boxes on the menu screen, or you can select all boxes of a 
certain type only (for example, only all textbase boxes). 

Tools Change box properties, including size and position; show or hide 
box borders (for text boxes or script input boxes only); specify a 
background color for boxes; align boxes; change tab order; set 
menu screen properties, including HTML options (for use with a 
WebPublisher product); specify script code for the menu screen. 
Note that if you plan to move the textbase(s) referenced by the 
menu screen, be sure to choose Tools>Screen 
Properties>General. Select Do not retain path from the Path 
setting drop-down list. See the online help for more information. 

View Toggle box boundaries on and off; specify the units to use for 
horizontal and vertical movement when using arrow keys to move 
a box. 
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Setting Menu Screen Properties 
 

The menu properties you select are saved with the menu screen and take effect when the menu is 
used. 

To set menu screen properties 
1. In the Menu Screen Designer, choose Tools>Screen Properties to open the Menu Screen 

Properties dialog box. 

2. Use the General, Logos, and HTML tabs to specify various attributes for the menu screen. 
Note that the settings on the Logos and HTML tabs apply only to menu screens used on the 
Web with a WebPublisher product. Each tab and its settings are described below. 

3. Click OK when finished. 

General Tab 
Note: If you plan to publish your menu screen on the Web with a WebPublisher product, the 
only option on this tab that applies is Background Color. 

Options group 
• 

• 

• 

• 

Screen title. Type the name you want to use as the title for the screen. This title will be 
displayed in the menu screen title bar. If you do not specify a title, DB/TextWorks uses the 
menu screen file name. 
Show menu icons. Select this check box if you specified icons for textbase or menu screen 
boxes. If you select it when no icons are specified, there will be extra space at the left of 
each textbase or menu screen box. Clear the check box to remove the extra space. 
Background Color. Select this check box to choose a color to use for the menu screen’s 
background. This option applies to both desktop menu screens and those used on the Web. 
Click the Select Color button to specify the color (including custom colors). Use this option 
if you always want the menu screen to use the specified color, regardless of any colors 
specified using Tools>Options>Display>More Defaults>Colors. 
Path setting. Use this drop-down list to specify where the menu screen will look for files 
referenced in the menu screen (for example, textbases and images). See the online help for 
more information. 
Note: The Path setting option does not apply to WebPublisher products. Menu screens 
used on the Web use the textbase path specified in the DBTWPUB.INI file. 

340 Chapter 6: Working with Menu Screens 



 Chapter 6: Working with Menu Screens 341 

Measurements group 
• Horizontal units. Use this drop-down list to specify the units to be used when specifying 

box position and width.  
• Vertical units. Use this drop-down list to specify the units to be used when specifying box 

position and width. Vertical units affect the distance between boxes, not the information 
within a box. 

Note: Units are shown in inches, millimeters, points, or lines (lines are available only for vertical 
distances). 

Logos Tab 
Use the Logos tab to add images to the top and/or bottom of a menu screen that will be used on 
the Web. (Note that settings you specify on this tab do not display on the desktop.) 

Most Web browsers support only .JPG and .GIF files. The size of the graphic is determined by 
the application used to generate the image. The position of the graphic is flush left on the page. 

Logos group 
• Leading Logo. In this box, enter the file name, including extension, of the image file to 

display at the top of the menu screen. For example, type NEWLOGO.JPG or click the 
Browse button and navigate to the image. 

• Trailing Logo. In this box, enter the file name, including extension, of the image file to 
display at the bottom of the menu screen. For example, type MYLOGO.GIF or click the 
Browse button and navigate to the image. 

For more information, including important information about image file locations, see the 
DB/Text WebPublisher PRO User’s Manual or the online help. 

HTML Tab 
Use the options on this tab to add the following HTML-related properties to a menu screen that 
will be used on the Web with a WebPublisher product. (Note that settings you specify on this tab 
do not display on the desktop.) 

Menu page group 
• Use background image. Select this check box to specify an image file for the page 

background. If you select this check box, the Image file box is enabled so you can enter the 
image file you want displayed. For more information, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual. 
Note: To specify a color for the menu screen background, choose Tools>Screen 
Properties>General. 



Form settings group 
• Show form list on report page. This option determines whether users will be able to 

change report forms in the Web browser. If you select this check box, the form drop-down 
list will appear in the Web browser. 

• Show form list on display page. This option determines whether users will be able to 
change display forms in the Web browser. If you select this check box, the form drop-down 
list will appear in the Web browser. 

• Show form list on edit page. This option determines whether users will be able to change 
edit forms in the Web browser. If you select this check box, the form drop-down list will 
appear in the Web browser. 

• Records per page. Type the number of records you want displayed on one report page after 
a search, or select unlimited from the Records per page drop-down list. Limiting the 
number of records displayed on a page lets users view the records matching their search 
criteria in batches. 

• Navigational buttons. Specify whether you want navigational buttons and form drop-down 
lists to appear on the top of the page, the bottom of the page, or both. The navigation buttons 
will appear in the Web browser on the page of records found after users do a search. 
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Saving a Menu Screen 
After using the Menu Screen Designer to create or modify a menu screen, save it by choosing an 
option from the Menu Operations menu: 

• 

• 

Save Menu Screen. Save changes to the current menu screen. 

Save Menu Screen As. Save an existing menu screen under a new name and/or in a 
different location. Specify a name and location for the menu file on the Save Inmagic Menu 
Screen File As dialog box. You do not have to include a file extension because the software 
adds extension .TBM automatically (for example, SALES.TBM). 

Selecting a Menu Screen 
After saving the menu screen and closing the Menu Screen Designer, you need to select it. The 
menu screen you select will appear when you start the software. 

To select a menu screen 
1. Start the software but do not open a textbase. (If a textbase is open, choose File>Close.) 

2. Choose Menu Screens>Select. 

3. Select an option on the Select Menu Screen dialog box: 

– Use No Personal Menu Screen. Select this option if you do not want a personal menu 
screen to appear when you start the software. Then click OK to close the dialog box. 
Note that selecting this option does not necessarily mean that you will not see any menu 
screen when you start the software. 
Note: Even if you select the option above, if there is a menu screen called 
DBTEXT.TBM in the Start In directory or the software installation directory, 
DBTEXT.TBM will be used as the menu screen. This special feature enables people 
who share DB/TextWorks on a network to share one menu screen file. 

– Use the Menu Screen in a File. Select this option if you want to use a personal menu 
screen when you start the software. When you click OK, you will be prompted to select 
the menu screen file (.TBM) that you want to use. 

Redisplaying a Menu Screen 
After you open a textbase, the menu screen is no longer visible. To redisplay the menu screen, 
close the textbase. 

If you inadvertently close the menu screen, choose Menu Screens>Display Current.  
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Organizing Menu Screen Files 
You can save menu screens anywhere your computer can access them. You can freely rename, 
move, and copy menu screen files (.TBM) just as you would any other file (for example, by 
using Windows Explorer). 

Some people use just one menu screen, which contains the names of all of their textbases. 
However, you may want to create several different menu screens. To switch between the various 
menu screens, choose Menu Screens>Select. You can also create one menu screen that contains 
menu screen boxes or script buttons that open different menu screens. For more information 
about adding menu screen boxes and script buttons, see “ ” on 
page 332. 

Adding Boxes to a Menu Screen

You can also use Microsoft Windows to create separate shortcuts, each of which references a 
different menu screen file, using the /m command-line switch. When you specify the shortcut 
properties, include the full path name of the DB/TextWorks executable file (DBTEXT32.EXE) 
followed by the /m switch and the name of the menu screen file. For example, to open a menu 
screen called SAMPLE, use this command: 

C:\DBTEXT\DBTEXT32.EXE  /M  SAMPLE 

Because DB/TextWorks accepts both / and – in command line arguments, menu screen names 
containing a hyphen must be enclosed in quotation marks. For example, to open a menu screen 
called SALES-NH, use this command: 

C:\DBTEXT\DBTEXT32.EXE  /M  "SALES-NH" 

If the software is installed on a network server, and all of the workstations will be accessing the 
same set of textbases that are also located on the server, the administrator may want to create one 
menu screen file, named DBTEXT.TBM, and place it in the software installation directory on 
the server. This special feature allows all users to share the same menu screen file. 

If the software is installed on your local hard disk, or if you typically use textbases stored on 
your local hard disk, a personal DBTEXT.TBM file can be created in the Start In directory 
associated with the program icon or shortcut. 
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Chapter 7: Working with Images 
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In addition to text, numbers, and dates, your textbases can include images. You can include 
color, grayscale, and black-and-white images in over 30 of the most common image file formats, 
including TIFF, PCX, JPEG, BMP, and EPS. You can search for, display, and print these 
images, and annotate them using text, graphics, and even sound. 

You can store images in any locations that DB/TextWorks can access. Only the image file names 
are stored in the textbase. The actual image files are stored in external locations, such as network 
servers, CD-ROMs, or your local hard drive. 

To associate images with records, you add an Image field type to the textbase structure and then 
populate that field with image file names. For example, the following record has multiple images 
associated with it. 

 

You can display one image at a time or 
multiple images in a thumbnail view. 

Note: To control certain aspects of image appearance and printing, choose 
Tools>Options>Imaging and set the image options. For more information, see Chapter 10, 
“Customizing DB/TextWorks,” the “Imaging Tab” section. 

 



Difference Between Images Window and Picture Box 
There are distinct differences between picture boxes, which were described in Chapter 5, 
“Working with Forms,” and image windows. 

A picture box lets you include an image in a form or report. It can be used to show static images, 
such as corporate logos, or thumbnail pictures specific to each record. For more information on 
picture boxes, see Chapter 5, “Working with Forms.” 

An image window lets you manipulate an image (for example, zoom and rotate it), annotate an 
image, and show all images associated with a record. This chapter describes all these functions. 

Defining an Image Field 
The first step in associating images with records is to define an Image field. A textbase can 
include more than one Image field. Image fields are Term indexed by default, which means you 
can search them just like any other field. You cannot apply validation to an Image field. 

To define an Image field 
1. Open a textbase, choose Maintain>Edit Textbase Structure, and click the Edit Fields 

button to open the Edit Fields dialog box. 

2. Add a field by typing its name in the Field Name box and clicking the Add button. 

3. On the Type and Indexing tab, select Image from the Field Type drop-down list, then click 
the Change button. 

4. Click Close on the Edit Fields dialog box and OK on the subsequent dialog boxes to save 
your changes. 
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Adding Image File Names to Records 
Once you have created an Image field, use one of the following methods to populate it: 

• Edit a record and type the image file name(s) directly in the Image field. 
• Import a text file. See “ ” on page 349. Importing Image File Names from a Text File
• Scan images directly. See “ ” on page 351. Scanning Images

Image File Names and Locations 
Images can have any standard Windows file name (long or short). DB/TextWorks does not 
require a particular extension to recognize images. This gives you more freedom in naming your 
image files. 

An Image field in a record can contain one or more image file names. Use the F7 key to make 
each file name a separate field entry. For example: 

 
If you have several consecutively named files, you can use just one entry, followed by a counter. 
For example: 

FILE1.JPG 3 

For more information about this shortcut naming convention, see the following section. 

A general guideline when adding image file names to a field is to include the directory path, 
starting with a backslash, but not the drive letter. For example, an Image field might include this 
entry: 

\MEMOS\LETTER1.JPG 

If you omit the backslash at the beginning of the path, DB/TextWorks looks for the image in the 
subdirectory of the current directory (not the textbase directory). For example: 

MEMOS\LETTER1.JPG 

If you prefer, you can specify just the image file name (no path), and the software will look for 
the image in the textbase directory, or the current directory on the drive(s) specified in the 
Imaging options (choose Tools>Options>Imaging). For example: 

LETTER1.JPG 

Note: As a general rule, if the images are located on a CD-ROM or mapped network drive, do 
not include the drive letter as part of the image file name. To specify which drives 
DB/TextWorks should look on, choose Tools>Options>Imaging and specify up to 12 drive 
letters in the Image drive(s) box. For more information on Imaging options, see Chapter 10, 
“Customizing DB/TextWorks,” the “Imaging Tab” section. 
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Shortcut Naming Convention 
To indicate multiple sequentially named images, you can use an image file name followed by a 
counter. This shorthand naming convention lets you reference a number of images without 
having to list each file name separately. For example, instead of using three entries: 

MEMO1.TIF 
MEMO2.TIF 
MEMO3.TIF 

you could use just one: 

MEMO1.TIF 3 

If you prefer, you can enclose the counter in parentheses: 

MEMO1.TIF (3) 

For the shortcut method to work, the file extension or file name must include a number. 
DB/TextWorks increments the last number in the file name or extension. For example, 
CAR.001 2 represents two images: CAR.001 and CAR.002. 

Important! Do not use this shortcut if you plan to use the images with a WebPublisher product, 
or in picture boxes in DB/TextWorks. 

To specify several ranges of images, use multiple entries. For example, the illustration below 
references 16 images (JAY.001 through JAY.012 and SAMP.006 through SAMP.009). 

 
You can use the shortcut naming convention when editing records individually, or when 
specifying image file names in a text file that you plan to import. 
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Importing Image File Names from a Text File 
If you are adding a large number of image file names to a textbase, you do not have to edit each 
record individually. Instead, you can create a text file that contains the image file names. Image 
service bureaus commonly do this by scanning multiple images for import. To create the import 
file, you can use a word processor or text editor. The import file should be in the Inmagic 
tagged, delimited ASCII, or XML format described in Chapter 3, “Working with Records,” the 
“Importing Records” section. 

If you will be adding new records to a textbase, each record in the import file should contain all 
of the information that you want to include. If you will be modifying existing records (for 
example, adding image file names to an empty Image field), each record in the import file should 
contain unique field matching information, such as an ID field (to determine which records to 
modify), and Image field information (to add or change image file names). See the example 
following the steps below. 

Important! To add image file names to existing records, your textbase must contain a field or 
combination of fields that will uniquely identify each record. Match on that field (or those fields) 
during the import, as explained in the following steps. This is how the software determines 
which image file names should be added to which existing records. 

The steps below summarize the import process. For more information, see Chapter 3, “Working 
with Records,” the “Importing Records” section. 

To import image file names from a text file 
1. Open the textbase into which you plan to import image file names. 

2. Choose File>Import to open the Select Import File dialog box. 

3. Select a file to import and click Open. 

4. On the Import Options dialog box, select the File Format, Validation, Exception File, Strip 
Leading Spaces, and Import Method tabs and specify the settings you want, as appropriate. 
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5. On the Add/Replace Options tab, do the following, as applicable: 

– If you want to add new records that contain image file names, and you want to avoid 
duplicating or changing existing records, select the Check for Matching Records 
check box, then select the Reject New Record option button from the If Match is 
Found group. If you are sure that the records in the import file do not duplicate existing 
records, or if it does not matter whether records are duplicated, you can leave Check 
for Matching Records cleared. 

– If you want to add image file names to existing records, select the Check for Matching 
Records check box, then select the Append Field Entries option button from the If 
Match is Found group. 

– If you want to change image file names in existing records, select the Check for 
Matching Records check box, then select the Replace Fields option button from the If 
Match is Found group. 

 
6. If you selected the Check for Matching Records check box, use the arrow buttons to move 

one or more fields from the Term-Indexed Fields list to the Incoming Records Must Match 
list. The field(s) you select indicate which field information DB/TextWorks should compare 
during the import to determine whether a record in the import file matches a record in the 
textbase. Only Term-indexed fields can be used for matching purposes. 
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7. If you selected the Append Field Entries or Replace Fields option button, select one of the 
If Match is Not Found options to determine what to do if a match is not found. 

8. Click OK to begin the import. 

The following example describes a typical import of image file names into existing records. 

Example 
Your textbase includes an Image field called Schematics. The field was recently added to the 
textbase and is empty for most records. You want to add image file names to it. To indicate 
which image(s) go with which records, you will match on a field called Product Number, which 
contains a unique product number for each record in the textbase. On the Add/Replace Options 
tab of the Import Options dialog box, you select the Append Field Entries option button from 
the If Match is Found group. 

Your import file contains just a few lines for each record. The first line specifies the matching 
information. The next line(s) specify the entries (image file names) to place in the Schematics 
field. The dollar sign ($) indicates the end of each record. For example: 

"Product Number" 286 
Schematics \autos\engines\chevy.001 3 
$ 
"Product Number" 287 
Schematics \autos\engines\mustg.001 2 
; \autos\schema\mustassm.001 4 
; \autos\schema\memomfr.pcx 
$ 
"Product Number" 288 
Schematics \ships\ladyblue.001 5 
$ 

When you import this file, DB/TextWorks will add the image file names to each specified 
record. For example, the record for Product Number 286 will have the entry 
\autos\engines\chevy.001 3 added to the Schematics field. 

The numbers following the image file names in the example above indicate multiple sequentially 
named images. This shortcut naming method was explained on page 348. 

Scanning Images 
If you have a TWAIN-compliant scanner, you can scan an image to a file while editing a record 
and DB/TextWorks will insert the file name in the Image field. 

From the Edit window, with the cursor in an Image field, choose Records>Scan Image, and 
follow the prompts to scan the image and name the file. The path will be omitted if it is the same 
as the textbase path. If the Image field already contains information, a new entry is created. 
There is no support for automatic document feeders or compressing a series of image file names 
using the shortcut representation, such as IMAGE001.TIF (3). 
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Finding and Displaying Images 
You can search an indexed Image field for a particular image file name, just as you would search 
any other field. For example, you could search for memo* to find the images discussed in 
“ ” on page 348. A more common way to locate images is to search 
for a particular record or set of records, some or all of which happen to include image references. 
For example, you might search for all widgets manufactured in 2002. 

Shortcut Naming Convention

Tip! To find all records with a populated Image field, search for =* in a box that searches that 
field. To find empty Image fields, do the same search but toggle the Boolean button in front of 
the box to NOT. 

When you retrieve records, you can display one image at a time in the Images window, and use 
the image options to zoom, rotate, display thumbnails, and perform other display operations. 

Note: The Images window is for desktop use only; it is not used on the Web with WebPublisher 
products. 

To display images 
1. Select a record in the Report, Edit, or Display window. 

2. [Edit or Display window only] If you have more than one Image field, put the cursor in the 
Image field whose images you want to see. You will see images from that field only. Put the 
cursor in any other field to see images from all Image fields. (You will not see the images 
until you perform step 3.)  

3. Click the Show Record Images button  on the toolbar, or choose Display>Show 
Record Images.  

Use the toolbar 
buttons to perform 
image operations. 
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The title bar indicates the number of images referenced in the record and the image 
currently shown (for example, Image 1 of 5). The status bar indicates the field that includes 
the image reference, and name of the image file that is currently displayed. 

Tip! Use Window>Synchronize Windows to turn window synchronization on or off. 
When the command has a check mark next to it, all open windows will show the same 
record and/or image. When the command is not selected, you can display a different record 
and/or image in every window. 

Image Display and Navigation 
When an image is displayed in the Images window, you can use the toolbar buttons and the 
Images menu to navigate among images and change how images are displayed. To access the 
Images menu, select the Images window. The following illustration shows the default Images 
window toolbar buttons. 

 Previous Record 
Previous Image 

 Next Image 
Next Record 

 

 
 

Zoom Rotate

Fit to Window 

Help for Window 
 Thumbnail

 Scale to Gray

Invert Colors 

To show or hide the toolbar on the Images window, use the View menu. 
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The following table explains the various ways of navigating among and displaying images. 
Some of the options listed are available only from the Images menu; others can be accessed from 
other menus or the toolbar. Except where noted on the following pages, the display options do 
not have an effect on printing, and they never change the image file stored on disk. 

Option Action 
Previous Record Show the first image in the previous record. 
Next Record Show the first image in the next record. 
Previous Image Show the previous image in the current record. 
Next Image Show the next image in the current record.  
Jump to Image Go to a specific image in the current record. 
Zoom In or Out Enlarge or reduce the image. 
Fit to Window Scale the image to fit the window’s dimensions. 
Rotate Left or Right Change the image orientation in 90-degree increments. 
Invert Colors Make a negative image by inverting colors or reversing black and 

white. 
Scale to Gray Improve the appearance of black-and-white images. 
Despeckle Remove unwanted specks and other “litter” from an image. 
Deskew Straighten a misaligned image (for example, when a page was 

scanned crooked). 
Thumbnail Display all images in the current record, at a reduced size. 
Show/Hide Annotations Show or hide annotations. 
Annotate Current Image Add or edit annotations. 
Remove All Annotations Remove annotations from the current image. 

Navigating 
To navigate among images, use the toolbar buttons described above or the equivalent options on 
the Images menu. 

Scaling Images to Fit the Window 
To size the image to fit the window (for example, after zooming in or out), click the Fit to 
Window toolbar button or choose Images>Fit to Window. This is also useful if an image is cut 
off or is too small because you have resized the Images window. The Fit image to window 
drop-down list (choose Tools>Options>Imaging) lets you specify if and how an image is 
resized when you choose Fit to Window. 
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Zooming In and Out Zooming In and Out 
To zoom in or out, click the Zoom buttons on the Images window toolbar or choose 
Images>Zoom In or Images>Zoom Out. Repeat to continue zooming in or out. Zooming 
affects display only, not printing. 

To zoom in or out, click the Zoom buttons on the Images window toolbar or choose 
Images>Zoom In or Images>Zoom Out. Repeat to continue zooming in or out. Zooming 
affects display only, not printing. 

To zoom in around a particular point, position the cursor over the portion of the image you want 
to see and click. Repeat to continue zooming in. This is called focused zooming. You cannot 
zoom out using this method. 

To zoom in around a particular point, position the cursor over the portion of the image you want 
to see and click. Repeat to continue zooming in. This is called focused zooming. You cannot 
zoom out using this method. 

To redisplay an image at its original size after zooming in or out, click the Fit to Window toolbar 
button or choose Images>Fit to Window. 
To redisplay an image at its original size after zooming in or out, click the Fit to Window toolbar 
button or choose Images>Fit to Window. 

Rotating Images Rotating Images 
You can rotate images right or left in 90-degree increments. This can be useful if an image was 
scanned at the wrong orientation. The currently displayed image as well as all other images that 
you view will appear rotated as long as the Images window remains open or until you change the 
rotation again. Rotation affects printing as well as display. 

You can rotate images right or left in 90-degree increments. This can be useful if an image was 
scanned at the wrong orientation. The currently displayed image as well as all other images that 
you view will appear rotated as long as the Images window remains open or until you change the 
rotation again. Rotation affects printing as well as display. 

To rotate an image, click the Rotate Right or Rotate Left button on the Images window toolbar 
or select one of the following options from the Images menu: Rotate 0 (original orientation), 
Rotate 90 (once clockwise), Rotate 180 (twice clockwise), Rotate 270 (three times clockwise—
equivalent to once counter-clockwise). 

To rotate an image, click the Rotate Right or Rotate Left button on the Images window toolbar 
or select one of the following options from the Images menu: Rotate 0 (original orientation), 
Rotate 90 (once clockwise), Rotate 180 (twice clockwise), Rotate 270 (three times clockwise—
equivalent to once counter-clockwise). 

Inverting Colors Inverting Colors 
To create a “negative” of the current image, click the Invert Colors button or choose 
Images>Invert Colors. Inverting colors is especially useful if black-and-white images were 
inadvertently scanned in reverse. The Invert Colors option affects display only, not printing. 
Colors remain inverted only until you display another image or close the window. 

To create a “negative” of the current image, click the Invert Colors button or choose 
Images>Invert Colors. Inverting colors is especially useful if black-and-white images were 
inadvertently scanned in reverse. The Invert Colors option affects display only, not printing. 
Colors remain inverted only until you display another image or close the window. 

Note: Some print drivers may support a “Print as negative image” property. Click the Note: Some print drivers may support a “Print as negative image” property. Click the 
Properties button on the Print dialog box. 

Scaling to Gray 
To improve the appearance of black-and-white images, click the Scale to Gray toolbar button or 
choose Images>Scale to Gray. Select it again to turn it off. This option affects display only, and 
black-and-white images only. Scale to Gray uses an effect called anti-aliasing, which is 
especially useful on line drawings or scanned documents and can appear to eliminate specks in 
an image. This option remains in effect until you change it. 
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Displaying Multiple Images in a Thumbnail View Displaying Multiple Images in a Thumbnail View 
You can use a thumbnail view to see multiple images simultaneously at a reduced size. With the 
Images window active, click the Thumbnail button on the Images window toolbar or choose 
Images>Thumbnail. 

You can use a thumbnail view to see multiple images simultaneously at a reduced size. With the 
Images window active, click the Thumbnail button on the Images window toolbar or choose 
Images>Thumbnail. 

Use the toolbar 
buttons to perform 
thumbnail operations.

 
The Thumbnail window displays all images in the current record (or in the current field, if there 
are multiple Image fields and the cursor was positioned in an Image field in a Display or Edit 
window). While the Thumbnail window is open, you can use the Thumbnail menu and the 
toolbar buttons to perform the operations listed below. To access the Thumbnail menu, make 
sure the Thumbnail window is selected. 

To… Do this… 
Display an image at full size  Double-click a thumbnail. Or select a thumbnail, then 

click the Show Selected Image button or choose 
Thumbnail>Show Selected Image. 

Sharpen black-and-white images Click the Scale to Gray button or choose 
Thumbnail>Scale to Gray. 

Change the number of rows and 
columns for the window 

Click the Set Rows and Columns button or choose 
Thumbnail>Set Rows and Columns. When prompted, 
type the number of rows and columns you want.  

See images from other records Click the Next Record/Previous Record toolbar button. 
Annotate images Choose Thumbnail>Annotate Current Image. 
Show or hide annotations Choose Thumbnail>Show Annotations or 

Thumbnail>Hide Annotations. 
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Printing Images 
The options used while displaying an image do not affect printing (except for rotation). During 
printing, images are scaled to fit the paper size selected from the Size drop-down list on the Print 
Setup dialog box. 

To print images 
1. With the Images or Thumbnail window active, choose File>Print. 

2. On the Select Images to Print dialog box, select an option button from the Print Range 
group. 

After selecting one of these 
options, select one or more 
Image fields to print. 

 
3. If you selected the Print Images in the Current Record or Print Images in the Current 

Set option button, select one or more Image fields from the Select Image Fields list. If the 
textbase structure includes only one Image field, that field is the only one that appears in the 
list, and it is automatically selected. 

4. Click OK. 

5. Use the standard Print dialog box to specify print options, such as number of copies, then 
click OK to begin printing. 

Tip! Images print significantly faster if you use a non-Postscript printer driver. 

 Chapter 7: Working with Images 357 



Annotating Images 
Annotations are text and graphics that you can add to an image to mark it up, as if the image 
were a sheet of paper. You can even add sound, by referencing a .WAV file. You can display 
and print images with or without annotations. Annotations do not change the image file itself, as 
they are stored as separate files with the default extension .ART. The annotation layer sits on top 
of the image when you display or print it, such as in the following illustration. 

You can add text, 
graphics, and even 
sound to any image, 
such as this image of a 
page of text. 

 
The following pages explain the basics of how to annotate images. For details, see the online 
help. 

To annotate an image 
1. Search for records that have images you want to annotate. 

2. Choose Display>Show Record Images and navigate to the image you want to annotate. 

3. With the Images window selected, choose Images>Annotate Current Image. 

Note: To annotate an image from the Thumbnail window, choose Thumbnail>Annotate 
Current Image. 

4. Use the drawing tools in the floating toolbox or on the Annotations menu to mark up the 
image. See below for more information about the toolbox. 

5. To save the annotations, choose Annotations>Save Annotation. 
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Using the Annotation toolbox 
The tools on the floating toolbox are simple to use. Just click a tool button, then use your mouse 
to draw the object where you want it. 

Select Rectangle 

Line Ellipse 

Arrow Polygon 

Freehand Polyline 

Highlight Text 

Sticky Note 
 
Sound 

For example, draw a black rectangle or other opaque object to redact (black out) a signature on a 
legal document. Annotations do not alter the image file, so the information is not permanently 
hidden. Anyone who opens the textbase can turn off annotations, so areas that you have hidden 
can be seen. Redaction is useful mainly for printing hard copies of images. 

To show or hide the annotations toolbox 
 With the Image Annotation window selected, choose Annotations>Show Annotations 

Toolbox or Annotations>Hide Annotations Toolbox. 

To set default properties for the tools 
1. With the Image Annotation window selected, choose Annotations>Annotation Properties 

to open the Annotation Properties dialog box. 

2. Select the font, line style, line thickness, arrow style, foreground and background colors, 
background mode, and fill pattern you want. The attributes specified here become the 
default properties for the tools and affect any currently selected objects and new annotation 
objects you add. For more information, see the online help. 

3. Click OK. 

To edit text separately 
 Double-click a piece of text to activate editing mode (indicated by a blinking cursor), then 

click the right mouse button to display the shortcut menu. The menu options depend on 
whether you are editing regular text or sticky note text. Possible options include: Choose 
Font, Adjust Angle, Set Background Color, Set Background Mode (transparent, opaque, 
or tinted). Using this method to change text properties affects only the text you currently 
have selected and does not have an effect on any new text annotations you add later. 
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To use the shortcut editing menu To use the shortcut editing menu 
 Select an annotation and click the right mouse button to open a shortcut menu that includes 

the following options: Undo, Cut, Copy, Paste, Delete, Send to Back, Bring to Front. 
 Select an annotation and click the right mouse button to open a shortcut menu that includes 

the following options: Undo, Cut, Copy, Paste, Delete, Send to Back, Bring to Front. 

To show or hide annotations during display and printing To show or hide annotations during display and printing 
 Search for records that contain image references. Choose Display>Show Record Images, 

then choose Images>Show Annotations or Images>Hide Annotations. 
 Search for records that contain image references. Choose Display>Show Record Images, 

then choose Images>Show Annotations or Images>Hide Annotations. 

To prevent users from adding, editing, or deleting annotations To prevent users from adding, editing, or deleting annotations 
1. Select a non-image window and choose Maintain>Edit Textbase Structure to open the 

Edit Textbase Structure dialog box. 
1. Select a non-image window and choose Maintain>Edit Textbase Structure to open the 

Edit Textbase Structure dialog box. 

2. Click the Passwords button to open the Textbase Passwords dialog box. 2. Click the Passwords button to open the Textbase Passwords dialog box. 

3. Select the Enable Silent Password check box, and clear the User May Annotate Images 
check box. You can also assign Field Access passwords that prevent users from editing 
annotations. Users will still be able to show or hide annotations. 

3. Select the Enable Silent Password check box, and clear the User May Annotate Images 
check box. You can also assign Field Access passwords that prevent users from editing 
annotations. Users will still be able to show or hide annotations. 

To remove annotations from an image To remove annotations from an image 
 Display the image in the Images window and choose Images>Remove All Annotations. 

This command breaks the connection between an image and its annotation file, and gives 
you the option of deleting the annotation file (default file extension .ART). 

 Display the image in the Images window and choose Images>Remove All Annotations. 
This command breaks the connection between an image and its annotation file, and gives 
you the option of deleting the annotation file (default file extension .ART). 

To remove annotations from all images in the textbase To remove annotations from all images in the textbase 
 Select a non-image window, choose Maintain>Manage Image Annotations and click the 

Clear Annotation List button. 
 Select a non-image window, choose Maintain>Manage Image Annotations and click the 

Clear Annotation List button. 

Working with Annotation Files Working with Annotation Files 
Each time you annotate an image, you save its annotations to a file (default file extension .ART). 
Annotations for different images are in different files. You supply the file name when you save 
the annotations. Be sure to back up the .ART files when you back up your other important 
information. To keep track of image annotations, DB/TextWorks creates a table, or list, to 
indicate which annotations go with which images. An annotation list does not contain the actual 
annotation objects (for example, arrows, rectangles, text). It is a list of “pointers” connecting 
images to their annotations. To print, back up, clear, merge, or replace lists, select a non-image 
window and choose Maintain>Manage Image Annotations. 

Each time you annotate an image, you save its annotations to a file (default file extension .ART). 
Annotations for different images are in different files. You supply the file name when you save 
the annotations. Be sure to back up the .ART files when you back up your other important 
information. To keep track of image annotations, DB/TextWorks creates a table, or list, to 
indicate which annotations go with which images. An annotation list does not contain the actual 
annotation objects (for example, arrows, rectangles, text). It is a list of “pointers” connecting 
images to their annotations. To print, back up, clear, merge, or replace lists, select a non-image 
window and choose Maintain>Manage Image Annotations. 

Note: Each entry in the annotation list is limited to 250 characters. An annotation list entry Note: Each entry in the annotation list is limited to 250 characters. An annotation list entry 
contains both the image file name and the image annotation file name, including paths (unless 
the files are in the same directory as the textbase). 
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Supported Image File Formats 
DB/TextWorks supports color, grayscale, and black-and-white images in the file formats listed 
below. If you do not see a particular format listed, you can contact Inmagic, Inc. to find out if 
that format has recently been added. 

Amiga IFF HALO Cut Pixmap (XPM) 
ATT (G4) ICO RLE 
BMP IOCA Showpartner GX2 
Brooktrout JPEG Sun Raster 
CALS Kodak Photo CD (read only) TARGA 
CLP Kofax TIFF 
DCX LaserData (LV) WMF (raster only) 
DIB MAC Paint WPG (raster only) 
EPS (screen preview only) Microsoft Paint MSP Xbitmap (XBM) 
G3 PCX XWD 
G4 Photoshop  
GEM IMG PICT (raster only)  
 

 Chapter 7: Working with Images 361 



 

362 Chapter 7: Working with Images 



Chapter 8: Linking Textbases 

Chapter 8: Linking Textbases 

363 

You can link a textbase to one or more other textbases to access the combination of information 
that you need. For example, to print overdue book notices, a library could link a textbase that 
contains book titles to a textbase that contains the names and addresses of patrons. Linking is a 
way of combining and sharing information among textbases. By linking textbases, you can 
reduce or eliminate duplication of effort and conserve disk space. 

Overview 
By storing common information in one textbase, you can reference it from other textbases. 
Typically, you use linking to model a many-to-one relationship between different types of 
records. For example: 

• A legal firm may have many tasks related to one trial. 
• A library may have multiple books on loan to one patron. 
• A manufacturer may have several products that are provided by one supplier. 
For each situation, you would create two textbases. For example, the manufacturer would create 
one textbase that contains product information and another textbase that contains supplier names 
and addresses. By linking Products to Suppliers, you can see, search, sort, edit, and print 
supplier information from within the Products textbase. Now when you search the Products 
textbase for red widgets, you can see product information from the current textbase (for 
example, size, color, description), plus supplier information from the secondary textbase (for 
example, name and address of the company that makes red widgets). 

Linking is done on a record-by-record basis. In other words, to access secondary textbase 
information, two records need to match. The match is established by comparing terms in the 
Link field in the primary textbase with terms in an associated field in the secondary textbase. For 
example, in the situation explained above: 

• The primary textbase—Products—contains a Link field called Company Name. 
• The secondary textbase—Suppliers—contains an associated field called Company Name. 
When a record in each textbase contains an identical term in the Company Name field (For 
example, Widgets R Us), a match is made between those two records. Note that the field 
names do not have to be identical; just the information in the fields. 

Links are one-way only, and only the primary textbase “knows” that a link exists. For example, 
if Products is the primary textbase and Suppliers is the secondary textbase, you can open 
Products and see supplier information. But if you open Suppliers, you will not see product 
information. 

 



Terminology 
The following table explains the terminology used in this chapter. 

Term Definition 
Primary textbase A textbase that contains a Link field. 
Link field A field defined in the primary textbase that is used to identify and 

link to a field in a secondary textbase. 
Secondary textbase A textbase that is linked to the primary textbase by means of an 

associated field.  
Associated field A field in a secondary textbase whose contents are matched 

against the contents of the Link field in the primary textbase in 
order to connect the records. The term “associated field” is just a 
convenient way of referring to the field that is the target of a Link 
field. The associated field can be any type (for example, Text, 
Number). You do not have to do anything in the secondary 
textbase’s structure to indicate that the field is associated (except 
ensure that the field has a Term index). The link definition is done 
solely in the primary textbase. However, we recommend making 
the associated field unique or an Automatic Number field. 

Frequently Asked Questions  
Why should I link textbases? 
The main reason to link textbases is to avoid replicating information that is common to many 
records or to more than one textbase. By storing the common information in one textbase, you 
can reference it from other textbases and keep it up-to-date in one place. 

How do I decide which textbase is primary and which is secondary? 
The secondary textbase should be the one containing information to be shared, such as names 
and addresses that you want to be able to access from other textbases. A record in the primary 
textbase can link to only one record in the secondary textbase using a single Link field, whereas 
a record in the secondary textbase can be associated with any number of records in the primary 
textbase. 

Also, the primary textbase should be the one that you will be working in most frequently. The 
secondary textbase should be the one that contains information that does not need to be revised 
very often, such as names and addresses. 

You always link from the child (for example, the legal task) to the parent (for example, the trial), 
or from the detail level (for example, the book) to the group level (for example, the borrower). 
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What tasks are involved in setting up a link? 
There are three main tasks involved in linking textbases, after you have created both the primary 
and secondary textbases: 

1. Define a Link field in the primary textbase. When you define a Link field, you specify 
the secondary textbase and an associated field in that textbase to which you will link. The 
Link field in the primary textbase and the associated field in the secondary textbase should 
hold identical information, such as company names or employee ID numbers. 

2. Add or edit records. This ensures that you have matching terms in the Link field and its 
associated secondary textbase field. For example, in primary textbase, Products, one record 
or more should have Widgets R Us in the Link field. In the secondary textbase, 
Supplier, only one record should have Widgets R Us in the associated field. (This is a 
many-to-one relationship.) 

3. Create forms for the primary textbase. Create forms that display fields from the 
secondary textbase. For example, design a form for the primary textbase that shows address 
information about suppliers from the secondary textbase. You can also design query screens 
that allow you to search fields from the secondary textbase. 

How does DB/TextWorks determine a link? 
Links are done on a record-by-record basis. To determine a link, DB/TextWorks compares Term 
index entries in the Link (primary textbase) and associated (secondary textbase) fields. When 
terms match, a link is made for that record, and you have access to record information for that 
record in the secondary textbase. 

For example, assume that your telesales department wants to track phone calls. You could log 
each call as an entry in a single field. However, this approach does not allow you to track the 
date of the call, the person who made the call, a summary of the call, and other details 
separately. A better approach would be to have two textbases: 

• The primary textbase—Calls—where each record represents a phone call. 
• The secondary textbase—Customers—where each record represents a customer. 
Each time a call is made or received, you create a record in the Calls textbase. Within both 
textbases, you would have a Customer ID field (or some other unique field) to link the two 
textbases. Now it is easy to track how many calls were made in a particular week, how many 
were made by a particular staff member, and which customers were involved. 

How do I find records in a linked textbase? 
Just open the primary textbase and search for records. You can search any primary or secondary 
field. (To search a secondary field, design a special query screen or choose Edit>Add>Query 
Box, and add a secondary textbase field as the box content.) However, you never retrieve 
records from a secondary textbase. You can only retrieve records in the primary textbase. To 
understand why this is so, read the next question and answer. 
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I know there are records that match my criteria because I saw them when I 
pressed F3. But the search said "No records found." What is going on? 
A common misconception is that a search will retrieve records from the secondary textbase. That 
is not true. Remember that you never retrieve records from a secondary textbase; you can only 
retrieve records from the primary textbase. Here is what can happen: You press F3 in a box that 
searches a field from a secondary textbase. You see the entry blue widgets, so you paste it 
into the query box and search for it. DB/TextWorks finds the record in the secondary textbase 
containing blue widgets. Next, it picks up the content of the associated field in that record 
and uses it to perform a search back in the primary textbase for records which link to the record 
containing blue widgets. There may be many such records, or there may be none. 

Why don’t I see any fields from the secondary textbase? 
Perhaps you did a search that found 10 records. You displayed them in the Report window, but 
all you see is information from the primary textbase. Why? Because you need to design a form 
that shows secondary textbase information. Open the Form Designer (choose Display>Design 
Form) and add some boxes whose contents are secondary textbase fields. Save the form, then 
select it for the appropriate window. Now try your search again. 

Can I link to more than one textbase? 
Yes. See “Characteristics of Link Fields” on page 370. 

How can I tell if two textbases are linked? 
A primary textbase contains a Link field. To see if the current textbase contains a Link field, and 
to see the name of the associated field and textbase, choose Display>Textbase Information and 
look at the Field Summary. A secondary textbase provides no indication about whether it is the 
target of a link. 

When I design a form, should it include both the associated field and Link field? 
No. When you design a form, there is no need to include both the secondary textbase field and 
the Link field, because they contain the same information. A form that includes both fields will 
show redundant information, which will be confusing. Generally, just show the secondary 
textbase field. The reason for this is because the Link field will not necessarily show punctuation 
if Browse Choices was used to help populate that field. 

What happens if no match occurs? 
Fields from a secondary textbase appear only when a match exists between the Link and 
associated fields (and when the form you have designed includes fields from the secondary 
textbase). If a match does not exist for a particular record, that record will not show the 
secondary textbase information. Boxes that you added for secondary fields will either be empty 
or will disappear altogether, depending on their Minimum height setting (choose Tools>Box 
Properties>Position). 
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Using Intermediate Textbases 
Typically, secondary textbases contain information that does not need to be revised very often. 
However, in some situations you may need to make and break relationships between two 
relatively static textbases, such as Books and Patrons, shown below. For example, circulation of 
library materials involves loaning items (connecting a book with a borrower) and checking them 
back in (severing the connection). 

• The Books textbase tracks information about titles, authors, publishers, and ISBN numbers. 
Each record represents one book. 

• The Patrons textbase tracks information about borrowers, including names, addresses, and 
phone numbers. Each record represents one patron. 

Where is the best place to record the transaction information? Sometimes, the most efficient 
solution is to set up a third, or intermediate, textbase. This intermediate textbase will link to both 
of the other textbases, with additional fields for information about the transaction, such as loan 
date and due date. Each record in the textbase will represent one transaction (borrowed and 
returned). This approach protects the other textbases from inadvertent changes, and is more 
efficient because less information is being processed when records are edited. Also, the history 
of the loan transactions can be maintained. 
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How to Link Textbases 
You link two textbases by means of a Link field that is defined in the primary textbase. 

To define a Link field 
1. Open the primary textbase. 

2. Choose Maintain>Edit Textbase Structure>Edit Fields to open the Edit Fields dialog 
box. 

3. You can add a new field or select an existing one. Do one of the following, depending on 
your situation: 

– If you are adding a new field. Add a field and select Link from the Field Type 
drop-down list. The Link Definition tab appears on the Edit Fields dialog box. 

– If you are selecting an existing field. Select an existing field, then select Link from 
the Field Type drop-down list. 

 
4. On the Link Definition tab, click the Specify Textbase button to open the Link to Inmagic 

DB/TextWorks Textbase dialog box. 

5. Select the secondary textbase to which you want to link, then click Open. 
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6. Select a field from the Associated Field list. The fields listed are those with Term indexes 
from the secondary textbase. The one you select, which becomes the associated field, should 
contain the same information as the Link field in the primary textbase (it does not have to 
have the same field name). For best results, the associated field should be unique and 
non-repeating. 

Select a field 
in the 
secondary 
textbase. 

 
7. Depending on what you did in step 3, click Add if you are adding a new field or click 

Change if you are editing a field. 

8. Click Close, then OK to save your changes. 
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Characteristics of Link Fields 
A Link field can have the following characteristics, all of which you define on the Edit Fields 
dialog box when editing the textbase structure. Each tab on the dialog box is listed below with 
the characteristics that can be defined on it. 

Type and Indexing Tab 
You can specify the following characteristics on the Type and Indexing tab: 

• You can make a Link field strict by selecting the Require Strictly Correct Type check 
box. The field will accept information only if it matches information that already exists in 
the associated field. This is a way to ensure that every record has a match. A strict Link field 
will prevent users from typing entries that do not have a matching record in the secondary 
textbase. 
Tip! Do not use strict links if you will be using the textbase with the DB/Text® Importer or 
the DB/Text® ODBC Driver. These products do not open secondary textbases. 

A non-strict Link field will accept information even if there is no matching information in 
the associated field. This introduces the risk of having a primary record without a match in 
the secondary textbase. However, you can always create a matching record in the secondary 
textbase at a later time. 

Tip! When editing a primary record, you can press F3 in the Link field to browse and paste 
entries from the Term index of the associated field into the Link field. This is like a 
validation list for the Link field, and it ensures a match between records. 

• A Link field is Term indexed, but you can select the Word Indexed check box, if you want 
to also be able to do word, phrase, or proximity searches. 

• A Link field uses the same Special Filing rules as its associated field, to ensure matching 
consistency. You cannot select different filing rules. If you change the filing rules of the 
secondary textbase associated field, you should redefine the link so that the primary textbase 
can retrieve the new filing information. 

• A Link field cannot have trailing text. 
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Validation Tab Validation Tab 
A Link field has Single Entry Only validation, to ensure that only one entry will be used to 
determine a match with a record in the secondary textbase. You cannot change this setting. You 
can add Field Entry Required and Unique Entries Only validation by selecting the appropriate 
check boxes. 

A Link field has Single Entry Only validation, to ensure that only one entry will be used to 
determine a match with a record in the secondary textbase. You cannot change this setting. You 
can add Field Entry Required and Unique Entries Only validation by selecting the appropriate 
check boxes. 

Link Definition tab Link Definition tab 
Every Link field has one associated field. A textbase can have more than one Link field. More 
than one Link field can point to the same secondary textbase, and even to the same associated 
field. For example, a book record in a library may have one field linking to the patron who has 
the book, and another linking to the patron waiting for it. A textbase cannot link to more than 
four different secondary textbases. 

Every Link field has one associated field. A textbase can have more than one Link field. More 
than one Link field can point to the same secondary textbase, and even to the same associated 
field. For example, a book record in a library may have one field linking to the patron who has 
the book, and another linking to the patron waiting for it. A textbase cannot link to more than 
four different secondary textbases. 

Characteristics of Associated Fields Characteristics of Associated Fields 
To determine a match, DB/TextWorks compares Term-indexed entries in the associated and 
Link fields. Fields that are not Term indexed do not appear in the list of fields on the Link 
Definition tab (on the Edit Fields dialog box). In this way, DB/TextWorks protects you from 
linking to a field that does not have a Term index. 

For best results, the associated field in a secondary textbase should be unique and non-repeating 
or should be an Automatic Number field. 

If the associated field is… You will… 
Unique and non-repeating or 
Automatic Number  

Link to a record when information in the Link field 
matches information in the associated field 
(recommended). 

Repeating  Link to a record if any one of the entries in the associated 
field matches the entry in the Link field. 

Not unique Link to the first matching record that is found (which may 
not be the one you want). 
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Searching Linked Textbases 
You search linked textbases the way you would search any other textbase—just open the 
primary textbase and search for records. Use F3 (or choose Edit>Browse Choices) to eliminate 
guesswork when constructing a query.  

To find linked records, you can search any primary or secondary textbase field as long as the 
query screen you are using contains boxes that search secondary fields. 

When you add a query box, the list of fields you can select appears on the Specify Fields to 
Search dialog box (when you use Add Query Box outside the designer), and on the Query Box 
Properties dialog box (inside the designers). If you have selected the Sort textbase fields 
alphabetically check box on the Display tab of the Options dialog box (choose 
Tools>Options>Display), the secondary textbase fields will be interfiled with the primary 
fields. If you have not, secondary textbase fields are listed following the primary textbase fields. 
Secondary textbase fields appear with an @ symbol in the middle of the field name (for 
example, Telephone@Supplier). 

Records retrieved by a search are always from the primary textbase, even when you search a 
field from a secondary textbase. If a record in the secondary textbase does not match any records 
in the primary textbase, no records are retrieved. This behavior explains why you sometimes 
retrieve more or fewer records than expected, or no records at all. For a detailed explanation, see 
“I know there are records that match my criteria because I saw them when I pressed F3. But the 
search said "No records found." What is going on?” on page 366. 

To add a secondary textbase field box in the Query Screen Designer 
1. Open the primary textbase. 

2. Choose Search>Design Query Screen and open a query screen. 

3. Choose Edit>Add>Query Box to add a query box and open the Query Box Properties 
dialog box. 

4. On the Fields tab, select the secondary textbase field you want from the Fields list. 
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5. Click the Add button to add the field to the Contents list. Repeat if you want the box to 
search multiple fields. 

 
6. [Optional] Specify position, label, and other attributes, as applicable, for the query box by 

using the tabs on the Query Box Properties dialog box. Then click Apply. For example, if 
you added the Customer, Street Address, City, and State fields to a box, you could change 
the label text to Customer Information. Note that if you closed the Query Box 
Properties dialog box during a prior step, select the query box and choose Tools>Box 
Properties to open it. 

7. Click Close. 

8. Save the query screen, close the Query Screen Designer, then select the new query screen 
for the Query window. 
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To add a secondary textbase field box outside the Query Screen Designer 
You can add a query box while outside the Query Screen Designer so that you can do a quick 
and impromptu search. For more information, see Chapter 4, “Searching a Textbase,” the 
“Adding and Deleting Boxes Temporarily” section. 

1. With the Query window selected, choose Search>Add Query Box to add a query box and 
open the Specify Fields to Search dialog box. 

2. Select the secondary textbase field you want from the Fields list. 

3. Click the Add button to add it to the Contents list. Repeat if you want the box to search 
multiple fields. 

4. Click OK. 

5. Execute a query by typing or pasting criteria in the box, then press Enter. If a matching 
record is found (a match is determined by comparing information in the Link and associated 
fields), then you will be able to see information from both the primary and secondary 
textbases. Remember, to see information from a secondary textbase, you must use a form 
designed to include secondary textbase fields. 

Searching with Command Queries 
You can also use Command queries to search fields from the secondary textbase, using the 
format shown below. 

Link field in primary textbase
Link indicator 

Field in secondary textbase

 
If either part of the field name (Description@Product Name) includes a character or 
word that might be misinterpreted as part of the search syntax, surround that part of the field 
name with single or double quotation marks. The @ symbol must be outside of the quotation 
marks. In the following example, quotation marks around the field name Yes or No prevent the 
word or from being interpreted by the query parser as a Boolean command: 

"yes or no"@customer number =Yes 

For more information, see Chapter 4, “Searching a Textbase,” the “Using Command Queries” 
section. 
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Displaying Fields from a Secondary Textbase 
To see secondary textbase information from within the primary textbase, design a form for the 
primary textbase that includes fields from the secondary textbase. Use the Form Designer tools 
to add and position boxes whose contents are secondary textbase fields. 

The following example shows a form that includes all of the fields in the primary textbase and 
three fields from the secondary textbase: 

These fields 
are from 
the 
secondary 
textbase. 

 
A secondary textbase field is referenced by a combination of the secondary textbase field name, 
an @ symbol, and the Link field name. For example, a field called City@Customer means “City 
field from a secondary textbase, accessed by a Link field called Customer in the primary 
textbase.” Whenever you see a field represented this way, you know that it is from a secondary 
textbase. 
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To add secondary textbase fields to a form  To add secondary textbase fields to a form  
1. Open the primary textbase. 1. Open the primary textbase. 

2. Choose Display>Design Form and open a form. 2. Choose Display>Design Form and open a form. 

3. Choose Edit>Add>Form Box to add a form box and open the Form Box Properties dialog 
box. 

3. Choose Edit>Add>Form Box to add a form box and open the Form Box Properties dialog 
box. 

4. Select the secondary textbase field you want from the Fields list. 4. Select the secondary textbase field you want from the Fields list. 

5. Click the Add button to add it to the Contents list. Repeat if you want the box to display 
multiple fields. 

5. Click the Add button to add it to the Contents list. Repeat if you want the box to display 
multiple fields. 

 
6. [Optional] Specify position, label, HTML and other attributes, as applicable, for the form 

box by using the tabs on the Form Box Properties dialog box, then click Apply. For 
example, if you added the Customer, Street Address, City, and State fields to a box, you 
could change the label text to Customer Information. Note that if you closed the 
Form Box Properties dialog box during a prior step, select the form box and choose 
Tools>Box Properties to open it. 

7. Click Close. 

8. Save the form, close the Form Designer, then select the new form for the appropriate 
window(s). 
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Editing Primary Records Editing Primary Records 
When you add or edit records in the primary textbase, you nearly always want to establish a 
match between the Link field and the secondary textbase associated field. Otherwise, records 
will not be linked. 

You could type information in the Link field and hope it matches information in the associated 
field. However, to guarantee a match, you can position the cursor in a Link field and press F3 or 
choose Edit>Browse Choices. The Editing Choices Browser dialog box appears. It shows terms 
from the associated field in the secondary textbase. Now you can paste a term from the list into 
the Link field, ensuring an exact match between the two records. 

Editing Secondary Records 
You can edit records in a secondary textbase from within the primary textbase. For example, if 
you are using the primary textbase and you notice an incorrect address in a secondary textbase 
record, you can change it. This feature is not intended for large-scale data entry or editing. If you 
have many records to change, open the secondary textbase directly. 

To create or edit a secondary textbase record 
1. Open the primary textbase and select an Edit form that includes the Link field (choose 

Display>Select Forms). 

2. You can add a new secondary textbase record, or edit an existing one. Do one of the 
following, depending on what you want to do: 

– If you are editing an existing record. Find a record in the primary textbase that links 
to that record and choose Records>Edit Record. 

– If you are adding a new record. Choose Records>New Record, or find a record in 
the primary textbase that you want to link to a new secondary textbase record (the 
secondary textbase record has not yet been created). 
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3. Choose Records>Edit Secondary Record to open the Edit Secondary Record window. The 
record will appear in the edit form you last used when editing records directly in the 
secondary textbase. (If you have never opened that textbase, the textbase default edit form is 
used.) The window will appear one of two ways: 

– With information in it. If the Link field (primary record) is filled in, the corresponding 
record in the secondary textbase appears so you can edit it.  

– Blank. If the Link field is blank, a blank Edit form appears so you can create a new 
record in the secondary textbase. (However, some fields may contain information if a 
record skeleton is specified in the secondary textbase.) The record you create should 
correspond to the one you are editing in the primary textbase. For example, if you are 
editing the Red Widgets record, add a secondary record that identifies the widget 
supplier’s name and address. 

Note: The Edit Secondary Record command may be disabled if the primary textbase has 
multiple Link fields. Put the cursor in the Link field for the textbase you want to edit, then 
choose Record>Edit Secondary Record. 

4. Add or edit record information, then choose Records>Save Record. If you created a record 
(because the Link field was blank when you chose Edit Secondary Record), or you 
modified the contents of the associated field, the information that you entered in the 
associated field is automatically copied into the Link field in the primary textbase, to ensure 
that the records are linked. 

Important! The information can be copied only if the Link field is included on the Edit 
form currently used for the primary textbase, and the box containing the Link field can be 
edited. 

378 Chapter 8: Linking Textbases 



Refreshing Linked Information while Editing a Record 
While adding or editing a record, you can update the display of fields from a secondary textbase 
(linked information) by pressing F9 or choosing Window>Refresh. This does not refresh boxes 
that contain multiple content items (except multiple secondary textbase fields). To refresh a box 
with multiple items, redisplay the window (for example, close and re-open it). 

Renaming or Rearranging Fields 
Renaming a Link field in the primary textbase or an associated field in a secondary textbase does 
not affect the link in any way, and is safe to do. 

Because link definitions are stored internally based on field position, not name, avoid changing 
the associated field’s position in a secondary textbase structure. If you do move the associated 
field, open the primary textbase and redefine any affected Link fields. If you re-order any fields 
in the secondary textbase structure, you may also need to fix any forms for the primary textbase 
that include secondary textbase fields (redefine Box Properties). 
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Protecting Secondary Textbase Information 
You can assign passwords to both the primary and secondary textbases. You can even protect a 
secondary textbase by defining passwords in the primary textbase. This gives you a great deal of 
flexibility, and you will need to give some thought to what you want to accomplish. 

From the primary textbase, you can protect primary textbase fields as you normally would. This 
includes making the Link field read-only or hidden. You can also hide all secondary fields. You 
cannot hide them individually. To protect secondary fields individually, assign passwords in the 
secondary textbase. 

To assign passwords in the primary textbase 
1. Choose Maintain>Edit Textbase Structure to open the Edit Textbase Structure dialog 

box. 

2. Click the Passwords button to open the Textbase Passwords dialog box. 

3. Define a Master password. For more information, see Chapter 2, “Creating a Textbase,” the 
“Passwords” section. 
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4. On the Field Access Passwords tab (or Silent Password tab), select the Link field from the 
Field Settings for This Password list, then select an option from the Field Security group. To 
protect the Link field, select either the Read-Only or Hidden option button. Hiding a Link 
field also hides all secondary fields, so users of that password will never see or have access 
to the secondary textbase from within the primary textbase. Making a Link field read-only 
prevents users from changing information that could affect links. 

Tip! To hide secondary textbase fields, select <Linked Information> from the list and 
select the Hidden option button. The <Linked Information> item represents all of the 
information in the secondary textbase accessed through the Link field. When you are 
viewing secondary textbase information from the primary textbase, it is read-only. That 
means your only options are to see it, or not see it (that is, hide it). 

Customer is a Link field. The 
<Linked Information> item 
represents information in the 
secondary textbase. 

 
5. Click OK to close all dialog boxes. For more information about passwords, see the online 

help. 
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To use a different password 
 While using the primary textbase, you can switch to a different password (a password 

defined in the secondary textbase) by choosing File>Use Different Password>Secondary 
Textbase. Note that Secondary Textbase is disabled if the current textbase does not 
contain a Link field or if none of the secondary textbases have passwords. 

To control whether you are prompted for passwords when a textbase is opened 
 If any of the secondary textbases has a Silent password, choose Tools>Options>General 

and select a setting. 
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Chapter 9: Managing Textbase Elements 

Forms, query screens, sets, and record skeletons are called “textbase elements.” This chapter 
explains how to perform management operations on textbase elements. 

Choose Maintain>Manage Textbase Elements to open a dialog box that lets you rename, 
delete, export, import, and print textbase elements. The Now Managing drop-down list 
determines whether you are working with forms, query screens, sets, or record skeletons.  

 

Renaming Elements 
You can rename one form, query screen, set, or skeleton at a time. 

Select an element 
type from the 
Now Managing 
drop-down list. 

Elements identified as 
(public) are saved in 
the textbase. Other 
elements are saved in 
your private user file. 

Note: The current password controls whether you are allowed to rename elements saved in the 
textbase file.  

To rename an element 
1. Choose Maintain>Manage Textbase Elements to open the Manage Textbase Elements 

dialog box. 

2. Select an element type from the Now Managing drop-down list. The names of the 
applicable elements (forms, query screens, sets, or record skeletons) appear in the Currently 
Saved list. 
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3. Select the item you want to rename from the Currently Saved list, and click the Rename 
button. Depending on the element type chosen, the applicable Rename dialog box opens. 

 
4. Type the new name you want, then click OK. 

Note: If you reference a renamed element from a menu screen, you should modify the menu 
screen in the Menu Screen Designer to reflect it. 

Deleting Elements 
If you are sharing a textbase on a network, be aware that if you delete a public element (one 
saved in the textbase), anyone else who shares the textbase will not be able to use that element 
again. The current password controls whether you are allowed to delete elements saved in the 
textbase. Note that deleting a set does not delete records in the textbase. 

To delete an element 
1. Choose Maintain>Manage Textbase Elements to open the Manage Textbase Elements 

dialog box. 

2. Select an element type from the Now Managing drop-down list. The names of the 
applicable elements (forms, query screens, sets, or record skeletons) appear in the Currently 
Saved list. 

3. Select the item you want to delete from the Currently Saved list, and click the Delete button. 
If you want to delete more than one item at once, use Ctrl+Click or Shift+Click to select 
multiple items. 

4. Click Yes when prompted to confirm deleting the element(s). 
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Exporting and Importing Elements 
You can export and import elements to share them with other users or to use with another 
DB/TextWorks textbase that has the same fields. Exporting elements is a good way to back them 
up. The default file extensions used during the export and import operations are listed in the 
following table. 

Element Default Extension 
Forms .XPF 
Query screens .XPQ 
Sets .XPS 
Record skeletons .XPK 
 
Each export or import file can contain multiple items of the same type. For example, a file called 
FORMS.XPF could contain forms called Summary and Daily Report. However, a file cannot 
contain different types of elements (for example, forms and query screens). 

If duplicate names are detected during an import, DB/TextWorks adds a numeric suffix to 
differentiate the items. For example, if a textbase contains a form called Summary, an incoming 
form of the same name will be renamed Summary_1. Elements of a given type can have the 
same name only if one is stored in the textbase and the other in the user file. For example, 
Summary can reside in the user file and Summary (public) in the textbase file. 

The current password controls whether you are allowed to save elements in the textbase file. If 
the password prohibits this ability, elements that you import will be placed in your user file. 

Important! Export or import elements saved in the user file and textbase file separately. For 
example, export all forms saved in the user file to one file, and export all forms saved in the 
textbase file to another file. If you need to restore them, you can import them to the place from 
which they originated (user or textbase file). 

To export elements 
1. Choose Maintain>Manage Textbase Elements to open the Manage Textbase Elements 

dialog box. 

2. Select an element type from the Now Managing drop-down list. The names of the 
applicable elements (forms, query screens, sets, or record skeletons) appear in the Currently 
Saved list. 

3. Select one or more items from the Currently Saved list, then click the Export button. 

4. On the Export dialog box, specify a destination drive, directory, and file name. Click OK. 
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To import elements 
1. Choose Maintain>Manage Textbase Elements to open the Manage Textbase Elements 

dialog box. 

2. Select an element type from the Now Managing drop-down list, then click the Import 
button.  

3. On the Import dialog box, select a file to import and click Open. 

4. On the Save Imported Elements In dialog box, indicate whether you want to save the 
imported element(s) in the user file (so they are available only to you) or in the textbase file 
(so they are available to everyone using the textbase). Then click OK.  

Note: This dialog box does not appear if the current password prohibits saving elements in 
the textbase file. In that case, elements are saved in the user file. 

 
5. After importing sets, choose Sets>Refresh Sets to refresh them. 

Printing Element Definitions 
You can print a description of an element or save it in a text file that you can view or print using 
a text editor or word processor. You can print multiple definitions at once, or save multiple 
definitions in one file. Definitions provide a way of seeing and saving information about an 
element, and are especially helpful for analyzing problems in a form or query screen.  

Important! A definition printed to a file is not a way of backing up or sharing elements. To 
back up or share elements, use the Export and Import buttons on the Manage Textbase 
Elements dialog box, as explained on page 385. 

To print a definition 
1. Choose Maintain>Manage Textbase Elements to open the Manage Textbase Elements 

dialog box. 

2. Select an element type from the Now Managing drop-down list. The names of the 
applicable elements (forms, query screens, sets, or record skeletons) appear in the Currently 
Saved list. 

3. Select one or more items from the Currently Saved list and click the Print button. 
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4. On the Print dialog box, select the options you want and click OK. 

Note: To save the definition(s) in a text file, select the Print to file check box, click OK, 
and, on the Save File As dialog box, specify the full path name. The file extension .TXT is 
used by default. 

Alternative Method 
You can also print a definition from within the appropriate designer. 

In the… Choose… 
Form Designer Form Operations>Print Definition 
Query Screen Designer Screen Operations>Print Definition 
Record Skeleton Editor Record Skeletons>Print Skeleton 
Menu Screen Designer Menu Operations>Print Definition 

Copying and Changing Elements 
To copy an element, use the appropriate Save As dialog box to specify a new name. You can 
also use the Save As dialog box to make certain changes to an element then save it under its 
original name. For example, you can change the description line, or the operations for which a 
form can be used (for example, editing or printing). 

To copy a form 
1. Choose Display>Design Form and open the form that you want to copy. 

2. Choose Form Operations>Save Form As. 

3. Respond to the Save Form As dialog box as detailed in “ ” on 
page 388. 

Using the Save As dialog box

Using the Save As dialog 
box

Using the Save As dialog box

To copy a query screen 
1. Choose Search>Design Query Screen and open the screen that you want to copy. 

2. Choose Screen Operations>Save Query Screen As. 

3. Respond to the Save Query Screen As dialog box as detailed in “
” on page 388. 

To copy a set 
1. Choose Sets>Load Set, select the set that you want to copy and click OK. You do not have 

to view the set in the Report window. 

2. Choose Sets>Save Set As. 

3. Respond to the Save Set As dialog box as detailed in “ ” on 
page 388. 
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To copy a record skeleton 
1. Choose Records>Edit Record Skeleton and open the skeleton that you want to copy. 

2. Choose Record Skeletons>Save Skeleton As. 

3. Respond to the Save Record Skeleton As dialog box as detailed in “
” below. 

Using the Save As 
dialog box

Using the Save As dialog box 
The Save As dialog box that you see depends on which type of element you are copying. You 
can specify the following information: 

• 

• 

• 

• 

Name. A name can include up to 20 characters, including spaces and punctuation. Click the 
Browse button to see the names of elements that have already been saved. Assigning a new 
name makes a copy of the element. 
Description. Specify an optional description of up to 80 characters, including spaces and 
punctuation. The description appears on dialog boxes when you open, save, and browse. 
Save In. Elements are saved within the textbase file or a user file. To make an element 
available to everyone who uses this textbase, select Textbase File (Public). To make the 
element available for your use only, select User File (Private). If you change the Save In 
setting for an existing form, you create a copy. 
Use For. This option appears for forms only, to let you specify the places where the form 
can be used. The Web and Web Only check boxes are for use with WebPublisher products, 
to control whether the forms appear in WebPublisher form lists on the Web. 
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Use the techniques described in this chapter to customize DB/TextWorks. 

Setting Options  
Options are maintained separately for each user. Most options are saved in the INMAGIC.INI 
file and persist across sessions. The options you choose are not textbase specific; rather they are 
specific to DB/TextWorks. The options you choose will apply to any textbase you open in 
DB/TextWorks, until you change the options settings. 

To set options, choose Tools>Options. Click each tab to specify the settings and options you 
want. 

 
The options are summarized in this section. For more detailed information, see the online help. 

 



General Tab 
Options group 
• 

• 

• 

• 

Insert date using long format. Select or clear this check box to specify how dates appear in 
the Edit window when they are inserted using Edit>Insert>Current Date or 
Edit>Insert>Series. 
Insert date as new entry. Select or clear this check box to specify how dates and times will 
be added to records in the Edit window when they are inserted using Edit>Insert>Current 
Date (or by pressing F4) and Edit>Insert>Current Time (or by pressing Shift+F4.) When 
selected (default), DB/TextWorks adds dates as a new entry. When cleared, the date is 
added at the cursor position without creating a new entry. 
Recently used file list. Select or clear this check box to control whether DB/TextWorks 
displays a list of recently used textbases at the bottom of the File menu. You can specify the 
maximum number listed by entering a number, up to a maximum of 10 entries. 
Notify when opening empty textbase. This option determines whether a message notifies 
you when you open a textbase that does not contain any records (for example, when you 
create a new textbase). 
– By default, this check box is selected. A notification message appears when you open 

an empty textbase. When you click OK to dismiss the message, the Edit New Record 
window opens so you can add records. 
Note: If the empty textbase is specified as read-only, you will be notified that it is 
empty, but the Edit New Record window will not open. This is because you do not have 
permission to add records. No window opens. 

• 

– If you clear this check box, you are not warned when you open an empty textbase and 
the Query window opens (unless you use a menu screen box with a different initial 
action specified). 

Read/write extended characters in MS-DOS format. Select this check box if you are 
importing from or exporting to an MS-DOS application. This option indicates how to 
interpret extended characters (for example, codes above ASCII 127, such as é, £, and ¥).  
Note: The Read/write extended characters in MS-DOS format option is reset (cleared) 
each time you open DB/TextWorks. 
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Report options group 
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• 

• 

• 

• 

• 

Print using. Use this drop-down list to choose the source of the form you want to use when 
printing a report. Select Report Printing Form to use the printing form you specify in 
Display>Select Forms, or select Form for current window to use the form for the selected 
window at printing time. Select the Always use this option without asking check box to 
use the selected form type without being prompted. 

Deferred Indexing group 
Show deferred changes in reports and display. Select or clear this check box to specify 
whether to see new or old versions of records with deferred changes when you print reports, 
display records or reports, or sort records.  
If indexes are busy. Use this drop-down list to specify what to do when using Shared 
Immediate indexing if the indexes are temporarily unavailable when you try to save a record 
(when sharing a textbase on a network). The indexing mode will still be Shared Immediate. 
If you select Do not save record, you will have to wait for the indexes to become available 
before you can try saving your changes again, or change to Deferred indexing (choose 
File>Change Indexing Mode). 

Passwords group 
Primary textbase. Select an option from this drop-down list to determine what happens 
when you open a primary textbase that has a Silent password. 
Secondary textbase. Select an option from this drop-down list to determine what happens 
when the primary textbase is linked to a secondary textbase that has a Silent password. 

 



Search Tab 
Options group 
• Display highlighting/Print highlighting. Use these drop-down lists to specify how search 

highlighting should appear for reports during display and printing. If applicable, click the 
Set Highlight Color button to specify a color for the highlighting. For WebPublisher 
products, Display highlighting options affect expanded display on the Web and Print 
highlighting options affect WebPublisher reports. Note that reverse video appears as bold in 
Web browsers. 
Note: The current form specifies whether search highlighting is used. However, you can 
override the setting for a form that has search highlighting on by choosing None for the 
options. 

• 

• 

• 

Use inclusive search option for multiple fields. Select or clear this check box to indicate 
how to interpret Boolean searches, such as Author/Title CT Smith & Jones. For 
more information, see Chapter 4, “Searching a Textbase,” the “Inclusive and Non-Inclusive 
Searches” section. 
Ignore accents on extended characters. Select this check box if you want to search for 
extended characters without having to type the accent. For example, a search for manana 
will find mañana. Equivalence is based on the region selected in the Windows Control 
Panel and applies only to single characters. If you clear this option, you cannot find 
mañana by searching for manana. 
Allow tabbing to Boolean query buttons. Select this check box if you want the Tab key to 
go to Boolean buttons (as well as query boxes) on a query screen. 
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Display Tab 
Options group 
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• 

• 

• 

• 

3-D box borders. Select this check box if you want boxes with borders to appear with a 
three-dimensional effect in the Query, Display, and Edit windows. 
Field entry delimiter. Use this drop-down list to specify the character used to designate 
multiple (repeating) entries in a field in Edit windows. The default is a bullet character. 
Select a character that will never appear in your data. 
After a search view records in. Use this drop-down list to specify the default window in 
which to display records found after a search or when loading a set. After you execute a 
search, the Select Search Results Window dialog box appears with the window choice you 
selected last automatically selected. At this point, you can choose a different window in 
which to view the retrieved records. If you change the setting at this point, the new choice 
becomes the default setting. Select the Always use this option without asking check box to 
prevent the Select Search Results Window dialog box from appearing when you know you 
will always want to view search results in a particular window. 
Detect URLs, EMail links, etc. and convert to hypertext links. Select this check box to 
detect a recognizable URL, EMail link, or file link in text in a box and convert it to a 
hypertext link. By enabling this option, you can click on the link and go directly to your 
Web browser, EMail program, or appropriate file application. For example, 
http://www.inmagic.com launches your Web browser, 
mailto:janedoe@inmagic.com launches your EMail program, and 
file://c:\docs\sales.doc launches the appropriate word processor. Be sure to 
enclose file names and URLs containing spaces in angle brackets (for example, 
<file://c:\sales\monthly report.doc>). 

Note: This option is ignored in editable boxes in an Edit window and script input boxes in 
any window. 

• 

• 

Large buttons on toolbars. Select this check box to use large buttons on all toolbars in 
DB/TextWorks. This check box is cleared by default, meaning toolbar buttons are standard 
size. If you select this check box, only toolbar buttons on new windows will be affected 
during the current DB/TextWorks session. To have the larger buttons appear on the Main 
toolbar, you must quit DB/TextWorks and restart the program. To have the larger buttons 
appear on any other window that is open at the time, close the window and re-open it. 
Sort textbase field lists alphabetically. Select this check box to have field names listed on 
many dialog boxes within DB/TextWorks appear in alphabetical order. If the list includes 
secondary fields, they will be interfiled with the primary fields. For example, if you select 
this check box, the field lists on the Box Properties dialog boxes in the Query Screen 
Designer, Menu Screen Designer, and Form Designer appear alphabetically. By default, this 
check box is not selected. This option does not apply to several field lists. For a complete 
list of the exceptions, search the online help for “Sort textbase field lists alphabetically.” 

 



Form defaults group 
• 

• 

• 

Set Text Font. Click this button to specify which font and font properties DB/TextWorks 
will use by default for box contents in new and Basic forms and query screens. It also 
determines which font is used in the Textbase Information window. 
Set Label Font. Click this button to specify the font and font properties DB/TextWorks will 
use by default for labels in new and Basic forms and query screens.  
More Defaults. Click this button to specify defaults for new and Basic forms and query 
screens. When you click the More Defaults button, the Form Defaults dialog box opens. 

Options on the 
General tab of the 
Form Defaults 
dialog box also 
affect menu screen 
defaults. 

 
This dialog box contains the following subtabs: 

Note: These default options only apply to new and Basic forms and screens. DB/TextWorks 
does not apply these defaults to previously saved forms. However, options on the Colors tab 
can affect how existing forms appear. 

– General. Use the Horizontal and Vertical units drop-down lists to specify the default 
unit of measure DB/TextWorks uses for settings and position values (inches, 
millimeters, points, or [vertical units only] lines). Also, select (default) or clear the 
Highlight search items check box to specify whether DB/TextWorks will highlight 
search items when displaying search results using Basic forms and whether new forms 
will have this check box selected by default. Use the Left and Top offset boxes to 
specify default box position, use the Minimum height box to specify default minimum 
box height, and use the Width box to specify the default box width. 
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– Record. These settings apply to the Basic Record form, or if you start your form design 
with the Basic Record form. Use the Maximum height box to specify the maximum 
height of boxes. Select (default) or clear the Label, Border, and/or Scroll bar check 
boxes to specify the appearance of boxes. Use the Label position drop-down list to 
place and justify labels relative to boxes. 

– Report. These settings apply to the Basic Report form, or if you start your form design 
with a blank form or the Basic Report form. Refer to the Record tab settings for more 
information. Note the default setting for Maximum height is different from the Record 
tab default setting. 

– Query. These settings apply only to query screens. The setting you choose from the 
Vertical unit drop-down list appears as the unit of measure for the Top offset. Use the 
Maximum height box to specify the maximum height of query screen boxes (note the 
default differs from Record and Report default). Select or clear the Label, Border, 
Scroll bar, and/or Query buttons check boxes to specify the appearance of boxes. Use 
the Label position drop-down list to place and justify labels relative to boxes. 

– Colors. Select or clear (default) the Background color check box to specify what 
color, if any, will appear as the background color of the whole form, excluding the 
boxes. (You separately specify box color by selecting or clearing [default] the Text 
background color check box.) If you specify either form or text background color, use 
the Color options group to specify whether to apply color to saved or new forms. If you 
specify that it affects saved forms, it will only affect forms not saved with a specific 
background color already selected. If you apply color to saved forms and design most 
forms without a background color, users can choose their favorite background color. 

– Set Up Page. Use these settings to specify page Width and Height for printing 
purposes. (Note that the units of measure are the same as the ones you specify on the 
General tab.) Also use these settings to specify the Left, Right, Top, and Bottom 
margins and page orientation (Portrait or Landscape).  

Tip! To reset default settings on all tabs, click the Reset to Defaults button. 

For more information about these defaults, see the online help. 
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Imaging Tab 
Options group 
• 

• 

• 

• 

Image drive(s). In this box, type up to 12 drive letters to indicate where you want 
DB/TextWorks to look for image files referenced in records. For example, to look on the 
C:, D:, E: and X: drives, type CDEX. List drives in the order that you want DB/TextWorks 
to look. If you leave this box blank, DB/TextWorks will look for images on the default drive 
(if the image name includes a path) or in the textbase directory (if no path is specified). 
Support multiple page TIFF images. Clear this check box to enhance image display 
performance, if you do not have any multi-image TIFF files. 
Support only short filenames for images. Select this check box if you want to include 
comments after the name of some image files without surrounding the image file name with 
quotation marks. Consider selecting this check box if you added comments to image file 
names with a version of DB/TextWorks prior to version 1.2. 
Fit image to window. Use this drop-down list to specify if and how images are scaled in the 
Images window. You can scale images proportionally, stretch them horizontally or 
vertically, or not scale at all. Select the Leave small images original size check box to 
allow small images to be scaled down but not up when you choose Fit to Window. A small 
image is one that is smaller than the Images window, such as a business card. 
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EMail Tab 
Options group 
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• MAPI (Messaging Application Program Interface). MAPI (which is a program interface 
that lets you send EMail from within Windows programs) uses the EMail program already 
installed on your computer to access mail services. If you experience problems trying to use 
MAPI, then you should use SMTP instead. 
Important! MAPI users must also designate their EMail program as their default simple 
MAPI client. To do so, you must consult the documentation provided with your EMail 
program, as each one is different. 

• SMTP (Simple Mail Transfer Protocol). SMTP accesses mail services directly, without 
the need to use an EMail program. To use this option, you must provide the name or IP 
address of your mail server in the boxes provided. The boxes for this information become 
active when you select the SMTP option. 

 



Customizing the Toolbars 
A toolbar is a row of buttons displayed across the top of a window. The buttons provide a quick 
way to access commonly used menu options with the click of a mouse. You can customize and 
reposition the toolbars for each window. 

Note: The following toolbar buttons provide access to choices not available on any menu: Select 
Form for this Window, Help on this Window, Center Text, Right Justify Text, Left Justify Text, 
and Catalog Current Web Page. 

Toolbar customizations are user-specific and apply for all textbases opened by that user. Your 
custom toolbar settings are stored in the Windows registry.  

The following illustration shows the default toolbar for the Edit window. Note that buttons are 
grouped together by relative function and separated by spaces (called separators). You can 
customize the toolbars with buttons and separators any way you want. To see what a button 
does, rest the cursor over it (do not click), and “Tool Tips” will appear (with a longer 
explanation in the status bar). 

Separators  
 

 

The following illustration shows the Edit window toolbar after being customized. Two 
additional buttons have been added: Go to Box and Insert Current Date. Notice that the user 
chose to group the Go to Box button with the navigational buttons and the Insert Current Date 
button with the Spell Check button. 

Insert Current Date button
Go to Box button
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To customize the toolbar of the current window 
1. Open the window whose toolbar you want to customize. 

2. Choose Tools>Customize Toolbar>Current Window to open the Customize Toolbar 
dialog box. 

Tip! Position the Customize Toolbar dialog box over the window whose toolbar you are 
customizing so that you can see the toolbar. As you perform an action (for example, add a 
button), you can see it happen on the toolbar. 

 
3. Perform the following operations on the Customize Toolbar dialog box, as applicable: 

– Add a button to the toolbar. Select the button from the Available Toolbar Buttons list, 
then click the Add button. The new button is added above the currently selected button 
in the Current Toolbar Buttons list. 

– Move a button to where you want it to appear on a toolbar. Select the button from 
the Current Toolbar Buttons list and use the Move Up or Move Down buttons, as 
applicable, to position the button. 
Tip! You can also reposition a button on the toolbar with the Customize Toolbar dialog 
box closed by holding down the Shift key and using the mouse to drag the button to 
where you want it on the toolbar. 

– Add a separator to the toolbar. Select the Separator button from the top of the 
Available Toolbar Buttons list and click the Add button. Then position the separator to 
where you want it on the Current Toolbar Buttons list, using the Move Up or Move 
Down buttons, as applicable. 

– Remove a button from the toolbar. Select the button from the Current Toolbar 
Buttons list, then click the Remove button. 
Tip! You can remove a button on the toolbar even when the Customize Toolbar dialog 
box is closed. Hold down the Shift key and use the mouse to drag the button off the 
toolbar entirely. 

– Undo custom changes and revert back to the original DB/TextWorks toolbar 
settings. Click the Reset button. 

4. Click Close. 
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To customize the toolbar of the Main window 
1. With any window open, select Tools>Customize Toolbar>Main to open the Customize 

Toolbar dialog box. 

2. Follow steps 3 and 4 in the previous set of instructions. 

Providing Textbase-Specific Online Help 
For each textbase that you create, you can supply a compiled Windows help file that describes 
any topics you want. For example, you might include guidelines for how your organization 
wants reports printed. Textbase-specific help supplements, not replaces, the DB/TextWorks help. 
Users can continue to access the DB/TextWorks help in the usual ways. 

To see an example of textbase-specific help, open the DBTMSG textbase that was installed with 
DB/TextWorks (located by default in the same directory as DB/TextWorks) and choose 
Help>Textbase-Specific Help. 

To supply supplemental online help for a particular textbase 
1. Create a compiled Windows help file, using software from eHelp (RoboHelp), 

ComponentOne (Doc-To-Help), or another program. 

2. Place the compiled help file in the same directory as the textbase or in the location specified 
in the textbase .INI file. 

By default, DB/TextWorks expects the help file to be located in the same directory as the 
textbase and have the same name as the textbase. For example, the help file for a textbase named 
Loans would be called LOANS.HLP. To change this behavior, specify the name and path of the 
textbase-specific help file in the [Help] section of the textbase .INI file. The textbase .INI file 
must be located in the same directory as the textbase. You may have to create this file yourself. 
For example, to point to a help file called C:\DEMO\LIBRARY.HLP, add these lines: 

[Help] 
HelpFilePath=c:\demo 
HelpFileName=library 
Menu=&Catalog Help 

For the HelpFileName= line, an extension of .HLP is assumed. Do not type the .HLP 
extension. If the help file is located in the same directory as the textbase, you can omit the 
HelpFilePath= line. 
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The Menu= line is optional. The text specified replaces Textbase-Specific Help on the Help 
menu. The ampersand (&) appears before the letter used as the new shortcut key. 

This feature is especially useful when you want multiple textbases to point to a single help file, 
or if the help file has a different name or location than its associated textbase. 

To use textbase-specific help 
 Open a textbase and choose Help>Textbase-Specific Help. The command is enabled only 

if that textbase has a help file associated with it (for example, a help file with the same name 
and location as the associated textbase, or with the name/location specified in the textbase 
.INI file). Note that Textbase-Specific Help may have been replaced by a string that is 
more appropriate for your particular application. 

Configuring DB/TextWorks 
To reconfigure DB/TextWorks, click the DB/TextWorks Setup icon in the Inmagic Applications 
folder or program group. You can also use the Windows Run command. For example, if the 
software is installed in 

C:\PROGRAM FILES\INMAGIC\DBTEXTWORKS 

type 

"C:\PROGRAM FILES\INMAGIC\DBTEXTWORKS\SETUP" 

Note: If the installation path includes spaces, such as in the previous example, you must 
surround the path with quotation marks. 

When Setup starts, select the Install or Configure DB/TextWorks option button, then click 
Next until the Choose Installation Option dialog box opens. Click the Configure button, then 
follow the on-screen instructions. Configuration settings are saved in the DBTEXT.INI file in 
the installation directory. By running Setup, you can change the languages for month and day 
names, default Stop Word and Leading Article lists, the interpretation of two-digit years, and 
specify whether the software tracks the machine name and login name of each user who has a 
textbase open. 

Languages for Month and Day Names 
DB/TextWorks can recognize month and day names in more than one language. The language(s) 
it recognizes depend on those specified during Setup. If you specify more than one set of month 
or day names, all of them will be recognized in a date, but only the first set is used for dates 
generated by the software (for example, when you choose Edit>Insert>Current Date) or 
reformatted by a form. 
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Default Stop Word and Leading Article Lists Default Stop Word and Leading Article Lists 
When you create a new textbase, DB/TextWorks supplies a default list of leading articles and 
stop words. Run the DB/TextWorks Setup program to change the default lists. You can edit the 
lists for an existing textbase by editing the textbase structure. 

When you create a new textbase, DB/TextWorks supplies a default list of leading articles and 
stop words. Run the DB/TextWorks Setup program to change the default lists. You can edit the 
lists for an existing textbase by editing the textbase structure. 

Year 2000 Compliance Year 2000 Compliance 
Four-digit years (1998, 2001) are always interpreted correctly. For two-digit years (for 
example, 4-12-01), DB/TextWorks is set, by default, to be Year 2000 compliant up to the year 
2039. 

Four-digit years (1998, 2001) are always interpreted correctly. For two-digit years (for 
example, 4-12-01), DB/TextWorks is set, by default, to be Year 2000 compliant up to the year 
2039. 

Note: This applies to new installations of DB/TextWorks, version 5.0 and later. If you have Note: This applies to new installations of DB/TextWorks, version 5.0 and later. If you have 
upgraded to version 5.0 or later through an InmagicADVANTAGE maintenance download and 
have not changed the setting, dates will be interpreted by default as being prior to the year 2000. 

To extend beyond that date, you can set an option to specify a starting year to indicate a 
100-year range into which two-digit years will be mapped. For example, if you specify 1960, the 
range is 1960-2059, so “96” means 1996 but “55” means 2055. The default is 1940 (1940-2039). 

Important! Before changing this setting, search for all dates prior to the new starting year and 
edit them to ensure that the years are represented by four digits. In other words, open a textbase, 
search each Date field to find dates prior to the new starting year (press F3), and retrieve those 
records. Display each record in the Edit window. If any of the records have two-digit years, 
changed them to four-digit years (for example, change 5-6-20 to 5-6-1920) and save the 
records. 

Textbase-user Identification 
If you select the Track who has textbase open check box on the Track Textbase Access dialog 
box, each time a user opens a textbase, their machine name and login name will be written to a 
line in the textbase .SLT file (providing that they have write-access to the directory containing 
the textbase). When the user closes the textbase, that line will be cleared. At any time, you can 
look at the textbase .SLT file (open it with any text editor) to see who has the textbase open. 

This configuration setting permits you to specify that all textbases opened with this copy of 
DB/TextWorks will have this information recorded. Alternatively, you can leave this option 
unselected, and turn on tracking in any specific textbase by adding a line to the textbase .INI file. 
For more information, see the DB/TextWorks online help. 
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Appendix: Reference Information 

This appendix provides information that will help you get the most out of DB/TextWorks. See 
the online help for more information. 

Navigating in DB/TextWorks 
DB/TextWorks is a Windows program that uses generally accepted Microsoft Windows 
conventions. If you are not familiar with the Windows Graphical User Interface (GUI), see your 
Windows documentation. When you start the software, you see the DB/TextWorks Main 
window. It typically appears with the DB/TextWorks menu bar, toolbar, and status bar, as 
illustrated below. 

Workspace 

Toolbar Title barMenu bar

Status bar 
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Title Bar 
The title bar contains the program name and version. After you open a textbase, the title bar 
indicates the textbase name and shows the indexing mode in angle brackets. 

Menu Bar 
The menu bar shows the menu for the active window. The menu changes depending on whether 
a textbase is open or closed, and which window is selected. The uses for each menu are detailed 
in the appropriate chapters of this manual, and in the online help.  

The View menu is common to all the available menus, and it always has the command to let you 
toggle on and off the toolbar for the active window (choose View>Toolbar). This menu also has 
the command that lets you toggle on and off the status bar for the Main window (choose 
View>Status Bar). Note that in some of the designer windows (for example, the Query Screen 
Designer window), there may be more commands on the View menu. They are mentioned where 
appropriate. 

Note that the File, Window, and Help menus are also common menu names. The commands on 
the File menu can vary depending on the window that you have selected; therefore, they are 
explained elsewhere in this manual where appropriate. The commands on the Window and Help 
menus, when appropriate, are also explained elsewhere in this manual. 

Tip! If you cannot find a particular menu mentioned in this book, try opening or closing a 
textbase (choose File>Close), and try selecting a different window using the DB/TextWorks 
Window menu, if possible. 

Similar to other Windows programs, commands appear dimmed on a menu until they become 
available. For example, the Paste command does not become available on the Edit menu until 
after you have cut or copied text. 

Also, similar to other Windows applications, when you select something (for example, a piece of 
text, a textbase box) and click the right mouse button, a shortcut menu appears with several 
common commands for what you are doing. For example, when you are editing text, the shortcut 
menu appears with the Cut, Copy, and Paste commands. Other commands may appear when 
appropriate. 

Toolbars 
The toolbar contains buttons for frequently performed activities. Besides the main 
DB/TextWorks toolbar, each window that opens within the Main DB/TextWorks window has its 
own toolbar. This manual details the uses for each toolbar in the appropriate chapters. Note that 
you can customize toolbars. For more information, see Chapter 10, “Customizing 
DB/TextWorks,” the “Customizing the Toolbars” section. 
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Workspace 
The workspace is where all of the DB/TextWorks windows, dialog boxes, and messages appear. 

The following illustration shows other windows opened in the Main window. 

 Menu bar for the
Report window 

Toolbar for the 
Application window  

Toolbar for the 
Query window 

Toolbar for the 
Display window 

Toolbar for the 
Edit window 

Toolbar for the 
Report window 

 Status bar on 
the Main window 

 

Windows in the Main Window 
The windows that appear in the Main window appear with their own toolbars, and the menu bar 
on the standard DB/TextWorks window changes to show the menus available for the active 
window. DB/TextWorks windows exhibit the following behavior: 

• 

• 

Resizable. You can resize any of the windows in DB/TextWorks (for example, Query 
window, Form Designer window). Several dialog boxes can also be resized. For example, 
you can make the Editing and Query Choices Browser dialog boxes (choose Edit>Browse 
Choices) wider so you can see more of longer entries, when applicable. 
Scroll bars. When data inside a window exceeds the size of the window, scroll bars appear 
on the window. 

 Appendix: Reference Information 405 



Status Bar 
The status bar at the bottom of the Main window provides helpful information as you work. For 
example, after you perform a search or load a set, the status bar shows the number of records in 
the current set. The View menu lets you toggle on and off the status bar (choose View>Status 
Bar). 

Synchronizing Multiple Windows 
You can open the Edit, Display, Report, Images, and Thumbnail windows at the same time and 
show different records—or the same record—in each window. To turn window synchronization 
on or off, choose Window>Synchronize Windows. When the option has a check mark next to 
it, all open windows will show information from the same record. Synchronizing windows is 
especially useful when displaying images.  

 

Fitting a Window to a Form 
DB/TextWorks preserves window size and position. To quickly resize a window after selecting a 
different form or query screen, choose Window>Fit Window to Form or click the Fit Window 

to Form toolbar button . 
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Using Go to Box 
The Edit>Go to Box option can be a quick way to navigate to a box, and is particularly useful in 
long forms or query screens as an alternative to scrolling through the window or repeatedly 
pressing the Tab key. On the Go to Box dialog box, boxes are identified by their labels or the 
first content item, such as <field=Customer Number>. To move to a box on the current 
screen, double-click a box in the list or select a box and click OK. 

Tip! Type the first letter of a box label to select that item. Press the Home or End key to go to 
the first or last box on the list. 
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Keyboard Shortcuts 
Many of the menu commands in DB/TextWorks can be accessed using keyboard keys, called 
quick keys. The following table lists the quick keys. 

Menu Command Quick Keys 
File New Textbase Ctrl+N 
 Open Ctrl+O 
 Close Ctrl+W 
 Print Ctrl+P 
 Exit Alt+F4 
Edit Undo Ctrl+Z 
 Redo Ctrl+A 
 Cut Ctrl+X 
 Copy Ctrl+C 
 Paste Ctrl+V 
 Paste Entry Ctrl+Shift+V 
 Browse Choices F3 
 Find Ctrl+F 
 New Entry F7 
 Insert Entry Mark F11 
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Menu Command Quick Keys 
 Delete Entry Shift+F7 
 Select Entry Ctrl+F7 
 Insert Current Date F4 
 Insert Current Time Shift+F4 
Records New Record Ctrl+F2 
 Edit Record F2 
 Edit Secondary Record Alt+F2 
 Save Record F5 (or Ctrl+S) 
 Duplicate Record Shift+F2 
Display Next Record Ctrl+R 
 Previous Record Ctrl+Shift+R 
 Next Highlighted Term F6 
 Previous Highlighted Term Shift+F6 
Search New Query Ctrl+Q 
Sets Omit Record Alt+O 
Inmagic.net Place Order Shift+F8 
Tools Spell Check F8 
Window Refresh F9 
Help Help Topics F1 
 Context Help Shift+F1 
 
Tip! Pressing Ctrl+S saves the contents of the active window. For example, with the Edit 
window active, pressing Ctrl+S saves the record; with the Form Designer window active, 
pressing Ctrl+S saves the form. 
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Textbase Files 
A textbase consists of a number of files, all of which have the same name as the textbase, but 
with different extensions. For example, a textbase called Sales consists of SALES.TBA, 
SALES.ACF, and so forth. 

 Extension Description 
.TBA Primary textbase definition file, which also contains textbase elements (for 

example, forms, query screens, sets, record skeletons) stored in the textbase. 
.ACF Access control file; controls simultaneous access to the textbase by multiple users 

or software instances, or applications (for example, DB/Text PowerPack Lite). 
.DBS Textbase structure file; contains field definitions and other information about the 

structure of the textbase. 
.IXL Indexed list file; contains the validation and substitution lists, and the leading 

article and stop word lists. 
.DBR Contains the records (including deferred new, deleted, or changed records). 
.DBO Contains a directory to the records in the .DBR file. 
.SDO Contains a directory to records with deferred updates in the .DBR file. 
.BTX Contains the Term and Word indexes. 
.OCC Contains the lists of records indexed by the terms and words in the .BTX file. 
.LOG Optional textbase log file; lists changes to the textbase structure and records. 
.TML Thesaurus maintenance locking file, prevents more than one person at a time 

from modifying records in that thesaurus textbase. Note that .TML files do not 
have to be backed up. The software automatically creates them if they do not 
exist. 

.HLP Optional textbase-specific help file. 

.INI Optional file used with Copy Special applications, Textbase-Specific Help, the 
DB/Text ODBC Driver, and the Applications menu. 

.SLT Optional file that is created when EnableSlotlog=1 appears in the 
[Advanced] section of the DBTEXT.INI or textbase .INI file. This option can be 
set in DBTEXT.INI during Setup using the Track Textbase Access button on the 
Configuration dialog box. The machine name and login name of each user who 
has a textbase open is recorded in the .SLT file. The line is cleared when each 
closes the textbase. 
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User Files 
A user file is a file maintained on the user’s local hard drive or in their private directory on a 
network drive, serving as a storage place for private elements (for example, forms, query 
screens, sets, and record skeletons). Elements stored in your user files are not accessible to  users 
on different computers. A user is defined as a computer. It is not typically related to your login 
name or password. 

Note: In addition to private elements, there are some files that are both textbase-specific and 
user-specific that are located in the user file directory. These include the .TBS file, which stores 
persistent scripting information, and the .IDI file, which stores last-used settings (for example, 
window size, position, batch modification settings). 

To understand user files, remember that textbase elements are never saved as separate files. 
Instead, they are saved either in the textbase file or in a user file. For example, when you save a 
query screen, you see the dialog box shown below. 

When you save an element, you 
decide whether to save it in 
your user file or the textbase 
file. 

 
Elements saved in the user file are available only to that particular user (or to anyone using that 
computer). When someone else opens the textbase from another PC, those elements will not 
appear in selection lists. 
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Elements saved in the textbase file are available to all users, and are identified by the notation 
(public) when they appear on dialog boxes. The notation (public) is an identifier; it is not part of 
the name. 

 
User files are intended for convenience, not security, and are most useful when sharing textbases 
on a network. For example, if you are practicing designing forms and you do not want other 
users to see your early or not finished attempts, save the forms in your user file. 

Name and Location of User Files 
Each textbase has its own textbase user file. For example, a textbase called Sales has a user file 
called SALES.TBU. If you open 10 different textbases, you have 10 separate user files. All of 
your user files are saved in the same location on your local hard drive. To see your user file path, 
open any textbase and choose Display>Textbase Information. 

Important! You should not rename or move user files. 

The user file location is determined the first time you start DB/TextWorks, when you are asked 
to specify a user file path. You can accept the suggested path or specify a different one. The user 
file path is recorded in your registry. 

Note: On Windows systems before Windows 2000 (for example, Windows 95/98/NT), the user 
file path may be specified in your INMAGIC.INI file. 

Here is a typical example of how one textbase can have multiple user files: 

There is textbase on a shared network drive: \\SERVER\VOL1\PUBLIC\SALES. 
Betsy’s user file is on her local hard drive: C:\PROGRAM FILES\INMAGIC\SALES.TBU. 
John’s user file is on his local hard drive: D:\DBTEXT\USERFILES\SALES.TBU. 
Richard has a diskless workstation, so his user file is on a shared network drive: 
\\SERVER\VOL1\USERS\RICH\SALES.TBU. 
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User File Collisions 
When specifying a user file path on a network drive, be sure to specify a directory that no one 
else uses for his or her user files. Otherwise, you run the risk of overwriting each other’s 
elements in the user files. (The whole user file is not overwritten—just individual elements that 
are changed and saved, such as forms or query screens). 

Because all of your user files are stored in one place, you should not give two textbases the same 
name, even if they are in different directories or on different computers, because they will be 
given identical user file names. For example, if you open C:\COMPANY\SALES, a user file 
called C:\USERFILES\SALES.TBU will be created. If you then open C:\BACKUP\SALES, the 
same user file will be used. When DB/TextWorks detects a potential collision, it displays this 
message: 

 
If you click Yes to continue, the user file will be changed to reference the new path. Elements 
stored in the user file may be inappropriate for the current textbase.  

If you click No, the textbase will not be opened. To avoid future user file collisions, you should 
decide which textbase the user file belongs to and rename the other textbase, so you do not have 
two textbases with the same name. 

Note: The software also maintains corresponding .IDI files where .TBU files are stored. These 
files contain textbase-specific information about the location of various windows (for example, 
Display, Edit, Report windows), and preserve the most recent Import, Export, and Batch Modify 
settings. 
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Using Copy Special 
Use the options on the Copy Special menu (choose Edit>Copy Special) to pass record-specific 
information to the Windows Clipboard. 

Record and Report Options 
You can copy information to the Windows Clipboard so you can paste it into another 
application. The copied information uses plain text format; form layout is retained, but fonts, 
color, picture boxes, and so forth are ignored. You can only copy the first 64K (approximately 
64,000) characters. Only the information that is displayed by the form is copied. If you plan to 
copy records and reports to the Clipboard regularly, you may want to create forms that have the 
following attributes, and select the appropriate form before copying a record or report: 

• 

• 
• 

Courier New 10 point font for labels and text font (choose Tools>Box Properties>Labels 
and Tools>Box Properties>Formats>Font, Color). 
Vertical units set to Lines (choose Tools>Form Properties>General). 
Top Offset for boxes set to whole increments of lines, such as 1 or 2, not .5 (choose 
Tools>Box Properties>Position). 

To copy a record 
1. Do a search or load a set. 

2. Select a record in the Report window, or display a record in the Display or Edit window. 

3. Choose Edit>Copy Special>Record. The form selected for the active window is used. 

To copy a report 
1. Do a search or load a set. 

2. Choose Edit>Copy Special>Report. The form selected for the Report window is used. 
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Application Options 
Use Copy Special to pass record-specific information to other applications by way of the 
Windows Clipboard. The other applications must poll the Clipboard and activate when they find 
something they recognize. 

To enable Copy Special 
1. If the DBTEXT.INI file does not already include a signature text for the target application 

you intend to use, use a text editor (for example, Windows Notepad) to add the necessary 
information. If necessary, edit the software initialization file, DBTEXT.INI, describing the 
signature text that each target application will use for recognition. 

2. Create or edit a textbase .INI file, specifying which field in the textbase will be the source of 
the information, and which application from step 1 to use. Each textbase can have up to two 
target applications. 

3. [Optional] Use Tools>Customize Toolbar>Main to add the Copy Special button(s) to the 
Main DB/TextWorks toolbar. For more information, search the online help 
for “Application Options (Copy Special).” 
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Initialization Files 
Initialization (.INI) files are text files that you can edit. 

DB/TextWorks uses these initialization files: INMAGIC.INI, DBTEXT.INI, and an optional 
<textbase> .INI file. 

WebPublisher products use these initialization files: INMAGIC.INI, DBTEXT.INI, and 
<textbase>.INI (all of which are optional), plus an additional file called DBTWPUB.INI. Note 
that if you are using WebPublisher PRO version 7.0 or later to edit over the Web, the 
<textbase>.INI is required, as it contains XML match field information. 

INMAGIC.INI File 
The INMAGIC.INI file is stored in the user file path specified in the registry, if the user has full 
rights to the Windows directory. If the user does not have full rights to this directory, or if 
DB/TextWorks is installed on an older operating system (for example, Windows NT), the 
INMAGIC.INI file is stored in the Windows directory. 

To find your INMAGIC.INI file, use the Find function in Windows My Computer or Windows 
Explorer, or look at the Textbase Information window for any open textbase. 

INMAGIC.INI contains personal customizations that affect the current user, including but not 
limited to: 

• 
• 
• 

• 

• 
• 

Options. 
The currently selected menu screen (.TBM file). 
A setting for the Express Import Buffer (ExpressImportBuffer=) controls the 
maximum permitted size of the memory buffer used for express imports. Normally, Express 
Import appropriates as much memory as possible to provide maximum speed. However, if 
you find Windows is swapping a lot when using Express Import, you can set the size of the 
import buffer. If you type 4096, then the buffer will be 4096 KB even if there is more 
memory available (and less if that much memory is not available). For more information, 
see the DB/TextWorks online help. 
A setting that determines whether spaces are required around a Boolean or range symbol 
(for example, whether you should search for ant / bee or ant/bee). For more 
information, see Chapter 4, “Searching a Textbase,” the “Troubleshooting Searches” section 
that covers Boolean and range searches. 
Settings specific to DB/Text WebPublisher. 
Other settings described in the DB/TextWorks online help file. 
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Entries are listed by section. Some entries can be set using DB/TextWorks menu options, others 
by editing the INMAGIC.INI file (when DB/TextWorks is not open). 

Dual-boot machines: If you have a dual-boot machine (for example, if you can run both 
Windows NT and Windows 95), make sure the INMAGIC.INI file in both Windows directories 
(or in the location specified in the registry on Windows 2000/XP machines) has the same user 
file directory, and other settings you want to share across platforms (for example, 
SpacedRelOps=). 

DBTEXT.INI File 
The DBTEXT.INI file is located in the DB/TextWorks installation directory. 

The DBTEXT.INI file contains information about the software configuration settings, including 
but not limited to:  

• 
• 

Language(s) used for month and day names. 
Default leading article and stop word lists. 

• 
• 
• 

Setting for interpreting two-digit years. 
Settings for tracking textbase activity. 
Information about the Copy Special menu Application options. 

You can change some of this information (the first four bulleted items) by running the 
DB/TextWorks Setup program and choosing Configure. To make other changes, you will need 
to edit the DBTEXT.INI file directly using a text editor, such as Windows Notepad. For related 
information, see Chapter 10, “Customizing DB/TextWorks.” 

DBTEXT.INI is not required for the software to run. If it is absent, default settings are used (that 
is, English month/day names, leading articles, and stop words; two-digit years interpreted as 
being prior to 2040). 

Note: The date settings chosen when DB/TextWorks is installed are shared with WebPublisher. 

For more information about DBTEXT.INI, see the DB/TextWorks online help. 

Run-time version: If you are distributing textbases to Run-time users and you want to pass 
along the DBTEXT.INI settings, supply a copy of the DBTEXT.INI file to each user. (If both 
DB/TextWorks and Run-time are installed in the same directory, they share the DBTEXT.INI 
file.) See the online help for more information on distributing textbases with Run-time version 
software.
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Textbase .INI File 
The textbase .INI file is an optional text file with the same name and location as the textbase. For 
example, a textbase named Loans can have a LOANS.INI file. You can create or edit this file 
yourself using a text editor. The textbase .INI file is used with the Applications menu, Copy 
Special menu commands, XML match fields, Textbase-Specific Help menu command, the 
DB/Text® ODBC Driver, and other options. It has several sections, including 
[SpecialVendor], which controls the Copy Special function, and [Help], which controls 
the Textbase-Specific Help function. For more information, see the DB/TextWorks 
online help. 

DBTWPUB.INI 
DBTWPUB.INI contains settings used only by WebPublisher products, not shared with 
DB/TextWorks. 

DBTWPUB.INI contains many settings, including, but not limited to: 

• 
• 
• 
• 
• 
• 

The location in which WebPublisher looks for textbase and image files. 
The maximum number of records displayed after a search. 
Americans with Disabilities Act (ADA) compliance settings. 
WebSetMax= and WebCSSOpt= settings. 
Whether a New Search button appears on report pages. 
Whether expanded displays appear in a separate browser window. 

DBTWPUB.INI is created by the WebPublisher installation program. It may also be updated by 
the software when a client submits a query (the textbase location may be written to the file). To 
make further changes, you can edit DBTWPUB.INI directly using a text editor. 

For more information about textbase and image file locations, see the Inmagic 
DB/Text WebPublisher PRO User’s Manual. Information about the other settings controlled by 
the DBTWPUB.INI file is explained in the DB/TextWorks online help. 
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Extensions for Text Files 
The extensions listed below are recommended but not required for text files used with 
DB/TextWorks. For example, when you export records, the file extension .DMP is assigned by 
default, but you can change this extension on the Export File As dialog box.  

Extension Description 
.TBB Textbase structure backup file 
.DMP Exported records 
.ADD or .DMP Records to be imported 
.TXT Text files to be imported using Import Document 
.TXT Validation, substitution, stop word, and leading 

article lists printed to a file 
.TXT Textbase elements and menu screen definitions 

printed to a file 
.X01, .X02, and so forth Exception files 
.XPF Exported form definitions 
.XPQ Exported query screen definitions 
.XPS Exported set definitions 
.XPK Exported record skeleton definitions 

Unregistered File Extensions 
If you notice unusual file names (for example, MYFILE.DMP.TXT), the extension you specified 
when saving a file is not listed in the Windows Registry. You can avoid this problem by 
accepting the default extension shown on the dialog box when you save the file or by using 
double quotation marks when you name the file (for example, "MYFILE.DMP"). 
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Glossary 

abort 
To halt a software program abnormally and abruptly (for example, by rebooting). 

abort flag 
An internal indicator that warns the user that the textbase may have been damaged because it 
was interrupted during a maintenance activity (for example, by a reboot during an import). 

abstract 
A brief text summary of a longer document. 

accelerator key 
See function key. 

Access Control field 
A field type that provides record-level security by letting you restrict access to classes of 
records. The record class is specified by the content of this field. See also record-level security; 
MS-DOS character translation. 

active window 
The window that has focus or is currently selected. 

alphabetic filing  
A Special Filing option (when the Numbers File Numerically check box is cleared), in which 
numbers are indexed and sorted as if they were words instead of values. 

alternate primary sort field 
Field by which a record is sorted if the primary sort field is absent in that record. You can 
designate up to four alternates. 

Analyze Textbase 
A command on the Manage Textbases menu that analyzes each record in the specified 
textbase and generates a tabular report listing the following information about each field: 
maximum number of entries in a single record; maximum length of a single entry; and 
maximum length of this field in a single record. 

anchored box 
Box on a form whose position is fixed on the form or is dependent on the position of another 
box. 

annotations 
Image overlays created by the user to draw attention to, comment upon, or hide areas of an 
image. 
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ANSI character set 
American National Standards Institute character set, consisting of 256 characters represented 
by 8-bit numbers. Microsoft Windows uses the ANSI character set. See also ASCII character 
set; MS-DOS character translation. 

anti-aliasing 
Process which smoothes the jagged appearance of lines and curves in a scanned image. 

Application window 
See DB/TextWorks Application window. 

arithmetic operators 
Symbols that can be incorporated in a calculation formula to denote arithmetic operations: 
addition (+), subtraction (-), multiplication (*) and division (/). 

ASCII character set 
American Standard Code for Information Interchange character set, consisting of characters 
represented by 8-bit numbers. See also ANSI character set; MS-DOS character translation. 

ASCII file 
A file containing ASCII characters, in a format that can be printed, typed, or edited using 
system editors, and can be used by other software. DB/TextWorks can import or export data 
files in ASCII format. Sometimes called a sequential file or text file. 

associated field 
A field in a secondary textbase whose contents are matched against the contents of the Link 
field in the primary textbase in order to “connect” or link the records. 

associative relationship 
See related term. 

authority list 
See validation list; controlled vocabulary. 

Automatic Date 
Field that DB/TextWorks adds to and maintains in every record created or edited. There are 
two kinds of automatic dates: creation dates (added to a record when it is created), and 
modification dates (refreshed every time a record is changed). Automatic Date fields can 
include the time as well. 

automatic field 
A field for which DB/TextWorks generates values. 

Automatic ID 
Field that contains values generated by DB/TextWorks by adding 1 to the last value. Unlike 
other Automatic fields, you can edit Automatic ID fields, and can include text, punctuation, 
spaces, numbers, and leading zeros. 

Automatic Number 
Field that DB/TextWorks adds to every new record, containing a unique number in an 
ascending series. The starting number and increment value can be set in the textbase structure 
definition. 
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average 
In a form calculation or computed field formula, a function that computes the average (mean) 
of a set of values. The AVG function computes the mean value of a field or expression in a set 
of records. The FAVG function computes the mean value of the entries in a field in a single 
record. 

backups 
Copies of important files, kept elsewhere on the computer system as well as away from the 
computer, to protect against data loss from system failure, user error, and catastrophic events. 

Basic form 
Simple form, generated by the software, containing a box for each field in the primary 
textbase. Fields appear in the order in which they are defined in the textbase structure. Select 
the Basic form (choose Display>Select Forms) when you want to see all fields in the primary 
textbase. Can also be used as a starting point in the Form Designer. 

Basic form fonts 
A user option that determines which fonts will be used by default for Basic and new forms and 
query screens, as well as the Textbase Information window, and printed textual information 
(for example, form definitions and validation lists). 

Basic Query Screen 
Simple search screen, generated by the software, containing a box for each indexed field in the 
primary textbase. Select the Basic Query Screen (choose Search>Select Query Screen) when 
you want one searchable box for each indexed field in the primary textbase. Can also be used 
as a starting point in the Query Screen Designer. 

batch deletion 
Process by which records, retrieved by a search, are deleted from the textbase with a single 
command. 

batch modification 
Process by which multiple records are changed in the same way, by the addition, deletion, or 
modification of a field or field entry, or substitution of text. 

beginning text 
Text inserted before the contents of a field in a form. In a multiple entry field, the text only 
precedes the first entry. If the field is empty in a record, beginning text does not appear. 

binary file 
Data file containing binary information (as opposed to strictly character information as may be 
found in an ASCII file). In general, binary files cannot be printed or edited. 

Boolean commands 
Commands (AND, OR, NOT) used to combine search expressions in order to produce a 
desired result. Boolean commands can be controlled by query buttons on a query screen or 
typed in a Command Query window. 

Boolean operators 
Symbols (& / !) used to combine search terms: & represents AND, / represents OR, 
! represents NOT. 
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Boolean query buttons 
Buttons associated with searchable boxes on a query screen, allowing the Boolean command 
associated with that box (AND, OR, NOT) to be changed by the person performing the query. 

borders 
Lines drawn around the four sides of a box. When designing a form, you can choose whether 
or not to show the borders for any specified box when the form or screen is used. 

boundaries 
Dashed lines that you can choose to see while designing a form, query screen, or menu screen 
indicating the location and dimensions of each box. It is especially useful to turn on boundaries 
(check Boundaries on the View menu) if the boxes on the form do not have visible borders. 
Boundaries are a design tool only. They do not appear in the saved form or screen. See also 
entry boundary. 

box name 
Name assigned to a form box, enabling a script to read or write the contents of that box. 

broader term (BT) 
A descriptor that has one or more other descriptors that are subordinate to it in a hierarchy. 
Subordination may mean “more specific” (for example, Cats BT Pets) or “part of” (for 
example, Chicago BT Illinois). The relationship of a term and its narrower term (NT) is 
sometimes called “parent-child.” In the examples, Pets and Illinois are, by definition, broader 
terms. The relationship indicator for this type of term is BT. Its reciprocal is NT. Every BT 
will have a reciprocal NT and vice versa. Example: Fishes BT Aquatic Animals; and Aquatic 
Animals NT Fishes. 

browse 
To peruse a list of terms that you can paste while searching or editing records. 

Browse Choices key 
Key (F3) that displays a list of items that you may want to type or paste in a box. The content 
of the list depends on context. For example, you may see a validation or substitution list while 
you are editing records, or a list of indexed words or terms while you are searching. 

browser 
A program used to view material prepared for the Web. Browsers can interpret URLs and 
HTML, and can understand several Internet protocols, such as HTTP, FTP, and Gopher. 
Examples of browsers are Microsoft Internet Explorer and Netscape Navigator. 

BT 
See broader term. 
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buttons 
See Boolean query buttons; script button. 

calculations 
Arithmetic expressions that are defined in a form to perform computations involving fields in 
the records. The results of the calculations appear when the form is used. 

carriage return 
ASCII character that can be included in the information typed or imported into a record. See 
also line breaks. 

Cascading Style Sheet 
A Web page (for example, WEBSTYLE.CSS) that you create to define styles (for example, 
fonts, colors, spacing) for your Web documents (for example, HELP.HTM). Having a 
cascading style sheet (CSS) gives the Web page creator more control over the appearance of a 
Web page (rather than to the Web browser). Netscape and Internet Explorer version 4.0 or later 
usually support Cascading Style Sheets. 
By default, WebPublisher uses CSS properties to improve absolute positioning, so report and 
display forms look as much as possible as they would look in DB/TextWorks. 

CGI 
Common Gateway Interface. A specification for how an HTTP server communicates with 
external programs. A CGI executable file provides the connection between browser software 
and an application. Most HTTP servers support CGI. 

character translation 
See MS-DOS character translation. 

Check Textbase 
A DB/TextWorks feature that checks a textbase to detect and repair problems in a textbase and 
user file. 

child term 
See narrower term. 

choices drop-down list 
An option that you can select for a field on an HTML query screen, to show a list of indexed 
terms when viewed on the Web. To add a drop-down list in the Query Screen Designer, select 
a box and choose Tools>Box Properties>HTML, then export the screen to HTML. When the 
HTML page is viewed in a Web browser, users can open the drop-down list and select an item 
for which to search. 

Choices key 
See Browse Choices key. 

Clipboard 
A memory resource maintained by Windows to store a copy of the last information that was 
copied or cut. Useful for transferring information between windows or applications. 
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Code field 
A field type that treats case and punctuation as significant for filing purposes.  

Command Query window 
Window in which complex search queries can be typed; an alternative to a query screen. 

comment lines 
Lines in an ASCII file that are ignored when the file is imported into a textbase. Usually, these 
lines begin with an exclamation point (!). 

comparison search 
A search of the Term index, seeking to satisfy an expression such as equals (=), greater than 
(>), less than (<), between (50:100), and so forth. 

compulsory form sort 
Sort description defined for a form, specifying the only way in which records can be sorted 
when that form is used. 

Computed field 
Field whose value is derived from a formula, to compute due dates, sales tax, and so forth. 

concept 
A unit of thought, formed by mentally combining some or all of the characteristics of a 
concrete or abstract, real, or imaginary object. Concepts exist in the mind as abstract entities 
independent of terms used to express them. 

configuration 
Collection of settings that govern the behavior of DB/TextWorks on your system, including 
month names, default stop words and leading articles. Can be changed by running 
DB/TextWorks Setup. 

content validation 
Validation rules governing what can be placed in a field entry, including mask validation, 
minimum and maximum values, or a list of valid terms. 
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context display 
See search highlighting. 

continuation line 
A line break used to force a line wrap when creating a text file in Inmagic tagged format using 
a text editor or word processor. A continuation line is made by pressing Enter and starting the 
next line with a space or Tab. 

controlled vocabulary 
A subset of the lexicon of a natural language in a certain domain. For example, the 
Engineering field (domain) has a language and, within the “natural language” of Engineering, 
a subset of preferred and non-preferred terms is used to index and search for documents. May 
also be called an indexing language. Its purposes are to enable indexers to represent the subject 
matter of documents in a consistent way and to bring the vocabulary used by the searcher into 
coincidence with the vocabulary used by the indexer. To facilitate this, a controlled vocabulary 
is developed, usually by experts in a field. A thesaurus is the tool used to construct, maintain, 
store, and display the controlled vocabulary. 

coordinates 
Absolute position of a form box on the form. You can change the location of a box by 
changing its coordinates or its position offsets. 

copy 
To place information on the Windows Clipboard without removing it from the record. You can 
also copy the boxes in the designers. 

count 
In a form calculation, the COUNT function determines how many records in the set contain a 
non-zero number in the specified field (or expression). In a form calculation or computed field 
formula, the FCOUNT function yields the number of entries (numeric or otherwise) in the 
specified field in a single record. 

cousin 
See related term. 

creation date 
Date when a textbase was defined or a textbase element (form, screen, set, and/or skeleton) 
was last saved. Also, records in a textbase can have creation dates. See also Automatic Date. 

criteria 
See search criteria. 
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cross-reference 
A pointer (or referral) from one term to another term in a thesaurus. Cross-references always 
occur in pairs—the pointer and its reciprocal—and are of three types: 
• 

• 

• 

Hierarchical relationship, which represents generic-specific relationships, or whole-part 
relationships, in the context of the thesaurus. These references are labeled broader term 
and narrower term, respectively. 
Equivalence relationship, meaning the term pairs are synonym, near synonyms, or 
quasi-synonyms in the context of the thesaurus. These types of cross-references are 
designated by the USE and USED FOR references. 
Associative relationship, which leads from one descriptor to other descriptors that are 
related to or associated with it in the context of the thesaurus. These types of 
cross-references are labeled the related term references. 

CSS 
See Cascading Style Sheet. 

CSV format 
See delimited ASCII format. 

currency symbol 
Character(s) used to identify numbers as currency. The character(s) are specified in the 
Windows Regional settings (for example, whether to use $ or £). 

cursor 
A display indicator on the screen, such as a blinking vertical bar, that shows the insertion point 
where the next keystroke will appear when typed or where the contents of the Windows 
Clipboard will be pasted in. 

cut 
To copy highlighted information to the Windows Clipboard and then delete it from the record. 
You can also cut the boxes in the designers. 

DB/Text Import Filter 
As of 2003, DB/Text® Import Filter is a retired Inmagic product. It was an add-on to 
DB/TextWorks that allowed you to import files in formats other than plain text. 
DB/TextWorks now uses IFilter technology to extract text from documents. See IFilter 
technology. 

DB/Text PowerPack Lite 
A set of two utilities that you can use on DB/TextWorks textbases, to help automate 
management and maintenance tasks. The two utilities are DB/Text® Updater, which posts 
deferred updates automatically and continuously using background processing, and 
DB/Text® Checker, which analyzes textbase integrity and can fix some types of problems. 
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DB/Text WebPublisher 
A Web-based application that enables you to publish textbases on the Internet or an intranet, so 
Web users can search them. The software returns results in dynamically generated HTML 
reports or XML. It is used together with DB/TextWorks, which is the “buildware” for creating 
searchable textbases. Compare DB/Text WebPublisher PRO. 

DB/Text WebPublisher PRO 
A Web-based application that enables you to publish textbases on the Internet or an intranet, so 
Web users can search and edit them. WebPublisher PRO accepts queries from standard Web 
browsers, such as Microsoft Internet Explorer, and accepts XML input. The software returns 
results in dynamically generated HTML reports or XML. WebPublisher PRO is used together 
with DB/TextWorks, which is the “buildware” for creating searchable and editable textbases. 
WebPublisher PRO also lets you integrate your DB/TextWorks textbases with other 
applications using standard third-party tools (for example, Microsoft FrontPage). 
Compare DB/Text WebPublisher. 

DB/TextWorks Application window 
An HTML browser window activated by choosing one of the options on the optional 
Applications menu. The options on this menu are specified in the textbase .INI file. 

decimal separator 
Character used to separate the whole and fractional parts of a number, such as a period (for 
example, 98.6). The character depends on the Windows Regional settings. 

default 
Value or condition assumed by DB/TextWorks if no alternative is specified. 

Deferred indexing 
DB/TextWorks indexing mode setting that keeps changes and additions to the textbase in an 
update queue, so they can be incorporated into the indexes at a later time. Compare Immediate 
indexing; Shared Immediate indexing. 

deferred updates 
Changes made to records under Deferred indexing. These changes can be posted (indexed), 
printed (with a list of changed fields), retrieved, or discarded. 

delete 
To remove an item from a textbase. Deletion is a permanent activity. Deleted field entries, 
fields, records, forms, and so forth cannot be recovered. 

delimited ASCII format 
One of the available export/import file formats. By default, fields are separated by commas and 
records are separated by line breaks. 

delimiter 
A character, such as a comma, used to separate items of information. Can be specified in 
DB/TextWorks when preparing to import or export ASCII text files. 
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descending sort 
See reverse sort. 

description 
A line of text that can be saved with a textbase or textbase element, generally used to describe 
its purpose. 

descriptor 
The term chosen from a group of synonyms (or near synonyms) as the preferred expression of 
a concept. For example, Street, Road, Lane, and Drive may be considered nearly 
synonymous; while Avenue, Boulevard, and Expressway each express a similar 
concept (an item on which vehicles are driven). The thesaurus expert might choose Street to 
represent all of them, making it the preferred term or descriptor. Or, the expert might invent a 
totally different, more generic, compound term, such as Streets and Highways, to 
represent the closely related concepts. The other terms become non-preferred terms, would not 
be used in indexing or searching, and would not be considered descriptors. See also preferred 
term. 

deskew 
Straighten a misaligned image (for example, if a page is scanned crooked). 

desktop 
“Desktop use” means running DB/TextWorks under Windows to access a textbase, as opposed 
to running a Web browser and using DB/Text WebPublisher to access a textbase. 

despeckle 
Remove unwanted specks and other “litter” from an image. 

diagnose 
To determine whether problems exist, and how they can be repaired. 

dialog box 
A box in which the user is asked for input or decisions. Contains controls such as text boxes, 
selection lists, check boxes, option buttons, and command buttons. 

discard deferred updates 
To undo all of the record changes made under Deferred indexing. Only unposted updates can 
be discarded. 

Display form 
A form used for the Display window in DB/TextWorks, or for expanded display on the Web 
(with DB/Text WebPublisher). 

Display window 
Window in which you can see, but not edit, a single record. 

documents 
Text files containing information to be imported into one field in one record, and which may 
be many paragraphs or pages in length. 

DOS character translation 
See MS-DOS character translation. 
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drop-down list 
A list of items that appears when you click the drop-down arrow at the end of a box. You can 
click an item on the list to select it. Compare picklist. 

dump textbase 
To copy all of the records in a textbase to a text file, using the Dump Textbase command. 
Deferred updates are ignored. See also load; export. 

Edit form 
A form used for the Edit window in DB/TextWorks that can be exported to HTML for use on 
the Web (with DB/Text WebPublisher). 

Edit window 
Window in which you can edit records, one at a time. 

editable box 
A box on an Edit form in which you can add or change information. The box can contain only 
one field, which cannot be protected by the current password. 

elements 
See textbase elements. 

ending punctuation 
Punctuation appended after the contents of a field in a form if there is no punctuation already 
there. Omitted if the field is empty. 

ending text 
Text appended after the contents of a field in a form. In a multiple entry field, the text only 
follows the last entry. If the field is empty in a record, the ending text does not appear. 

entry 
See field entry. 

entry boundary 
The boundary where one entry ends and another begins. The entry boundary is indicated by an 
entry separator. 

entry separator 
(1) Text specified in a form to separate the entries in a field. 
(2) Text or character that separates the entries in a file exported using delimited ASCII format.  
(3) Bullet character selected to separate entries in an Edit box. 
(4) Internal character used to separate field entries in a field in the textbase; accessible to 
scripts. 

entry term 
A non-preferred term in a cross-reference that leads to a descriptor in a thesaurus. Also known 
as a “lead-in term.” The relationship indicator for this type of term is USE; its reciprocal is 
USED FOR. Example: Cats USE Felines, in which Cats is the non-preferred term. 
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entry validation 
Validation rules governing field entries, such as whether they must be unique across all records 
in the textbase, whether they can repeat within a record, and whether at least one is required in 
a record. 

equivalence relationship 
See USE; USED FOR. 

event 
An event triggers a script to do something. Example of events: clicking on a script button, 
opening a window, moving cursor out of a form box. 

exception file 
A text file that contains copies of records rejected during an import. 

expanded display (WebPublisher products) 
Display of a single record at a time in a Web browser, when a user clicks on a hypertext link in 
a Report page. 

exploded sort 
An exploded sort makes a record appear under each entry in the sort field, rather than just the 
first. For example, if the Employees field contains the names of three people, an exploded sort 
makes the record appear three times (once for each employee). 

export 
To copy information to a text file, as a way of backing up or sharing that information. See also 
dump textbase. 

Express Import 
Import option specifying that records be imported as fast as possible, using index caching 
techniques to provide maximum speed. This method grabs more than its “fair share” of system 
resources in the interests of speed. This option should be used only if speed is important, others 
are not sharing the textbase, you do not need to run other applications while the records are 
loading, and you can accept a long delay if you need to interrupt the import for any reason. 
Compare Interruptible Import. 

extended characters 
Characters in the higher ASCII table, used in languages other than English. These characters 
can be typed into a DB/TextWorks textbase using the Alt key and the numeric keypad. For 
example, type 0233 while holding down the Alt key to create the character é. Extended 
characters may be found on some keyboards. See also filing order. 

extension 
Part of a file name that is commonly used to signal the file’s purpose, such as log files (.LOG) 
and exported forms (.XPF).  

field 
Part of a record containing a specific category of information, such as an author’s name or a 
publication date. DB/TextWorks accepts up to 250 fields per record, with no limit on the 
number of field entries or the size of each field entry. 
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Field Access password 
Password with an associated set of permissions, granting or denying read or read-write access 
to particular fields or records, or to the textbase itself (including textbase elements). 

field entry 
An item of information in a field. A record can contain more than one entry in a field, such as a 
Subject field having multiple subject terms. 

field entry delimiter 
Character used in the Edit Record window to indicate where one entry ends and another begins 
(default is bullet). See also entry separator. 

Field Functions 
Functions (FAVG, FCOUNT, FMAX, FMIN, FTOTAL) that compute a value based upon the 
entries in a field in a single record. These functions can be used in a calculation defined in a 
form or in the formula for a computed field in the textbase definition. 

field name 
Text identifier for a field in a textbase. A name can be up to 20 characters and can contain 
letters, digits, spaces, hyphens, and underbars. 

field type 
Property of a field that governs how its contents are treated. A Date field, for example, is 
expected to contain dates, and will file dates chronologically. 

file 
A collection of related information treated as a unit. 

file URL 
An addressing scheme that does not specify a protocol (such as HTTP) for accessing files. File 
URLs are specific to a local system, such as an intranet. Example: 
file://server1/docs/myfile.htm. See also URL. 

filing order 
The rules governing the order in which items are indexed and sorted, determined by the field 
type and Special Filing options defined in the textbase structure, as well as the Windows 
Regional settings 

fixed text 
Text added to the contents of a box in a form definition. Fixed text always appears when the 
form is used. 

floating box 
Box on a form whose vertical location “floats” depending upon the position and size of boxes 
located above it in the form. 

focus 
A state where an object is currently active and will respond to an action. For example, when a 
button on a dialog box (for example, OK) has focus, pressing Enter will make the button do 
something (for example, close the dialog box). Or, when a box on an edit form has focus, 
whatever you type will appear in that box. 

 Glossary 433 



footer 
Information that follows a group of records in a report. Report Footers appear once only, at the 
end of the report. Sort Footers appear at the end of a group of records that share a Sort Key at 
the specified Sort Level. Footers are commonly used to display summary calculations, such as 
subtotals and grand totals or counts. 

form 
A layout for presentation of some or all of the information in a record. 

form box 
A box on a form containing field information, variables, or other information. 

Form Designer 
The DB/TextWorks tool that you use to create a form, to change the appearance of record 
information (single-record or multiple-record display). 

format 
Style in which information appears. For example, you can specify that numbers appear as 
currency. 

FTP 
File Transfer Protocol used for sending data from one system to another on TCP/IP networks, 
including the Internet.  

function 
An activity that can be initiated by choosing an item from a menu. Also, an operation that can 
be performed inside a calculation, such as a TOTAL or COUNT function, or a component of a 
script that performs a task. 

function key 
Special key on the keyboard that initiates a particular activity in the software. For example, F1 
displays online help. 

grid 
Form parameter, specifying the distance a box moves in the Form Designer, Query Screen 
Designer, or Menu Screen Designer each time an arrow key is pressed on the keyboard. 

<head> section 
The top-most part of an HTML page, often including <title>, <script>, and <style> elements. 

header 
Information that precedes a group of records in a report. Report Headers appear once only, at 
the beginning of the report. Sort Headers appear at the beginning of a group of records sharing 
a Sort Key at the specified Sort Level. 

heading 
A preferred name or term. Types of headings include proper names, subjects, descriptors, trade 
names, product names, and so forth. “Heading” usually refers to descriptors that have actually 
been used to index a document. See also preferred term. 
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help 
Online reference information, available as a general resource or in a particular context. See 
also textbase-specific help. 

hidden field 
Field to which all access is denied by the current password. 

hierarchical relationship 
The relationship of a pair of terms in which one is generic (or broader) and the other specific 
(or narrower). The relationship indicators for this pair are BT and NT, respectively. Example: 
Cats BT Pets, Pets NT Cats. 

hierarchy 
Generic (broader)-specific (narrower) or whole-part relationships, which are generally 
indicated in a thesaurus through codes or indentation. See also broader term; narrower term. 

highlight 
(1) The action of using keyboard keys or the mouse to indicate a menu option, selection list 
entry, or area of text that you want to select. 
(2) In a report/display/printout, items found by a search can be highlighted (shown in an 
enhanced way, such as reverse video, color, boldface, and so forth). 

HTML 
Hypertext Markup Language, a standardized format for hypertext documents. HTML is a 
document formatting language used by Web browsers. Also, an option when writing reports to 
a file, sending EMail, and exporting query or menu screens for use with WebPublisher. 

HTML search page 
See query screen. 

HTTP 
Hypertext Transfer Protocol, which is used for distributing hypertext documents on the 
Internet. HTTP is layered on top of TCP/IP. 

hypertext link 
The connection between one hypertext document and another. When a user clicks on a 
hypertext link, a jump is made to another help topic or HTML page. Hypertext links can be 
enabled in a DB/TextWorks report or display. 

icon 
A picture or bitmap image representing an available choice. 

IFilter technology 
The technology DB/TextWorks uses to extract text from documents. IFilter technology is 
installed with Microsoft Index Server, which comes with Microsoft Windows 2000/XP 
operating systems. This technology is also supported on Windows NT 4.0 systems that have 
the Windows NT 4.0 Option Pack installed. (DB/TextWorks will only extract text from 
documents in formats other than plain text if the workstation that initiates the import meets 
these operating system requirements and has the appropriate IFilter installed.) 
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image 
A file containing a picture, diagram, or scanned document that can be referenced in a textbase 
record and displayed or printed from within DB/TextWorks. 

Images window 
Application window in which the image(s) associated with a record are displayed. 

Immediate indexing 
DB/TextWorks indexing mode setting that provides for all record changes and additions to be 
indexed immediately. Immediate indexing requires exclusive access to the textbase—no one 
else can have the textbase open. Compare Shared Immediate indexing; Deferred indexing. 

import 
To add records to a textbase from a text file. You can also import validation and substitution 
lists, form definitions, and other textbase elements. See also load. 

import filters 
See IFilter technology. 

inclusive search option 
Option, specifying that a search for an intersection of terms in a combination of fields be 
satisfied as if the fields were one field.  

indentation 
Form box property, specifying amount of space to appear before information started on a new 
line; can be a hanging indentation, in which case the space is inserted before wrapped 
information instead. 

index 
A collection of keys (words or terms) derived from field values within the records, and used by 
DB/TextWorks to provide fast access to information. 

indexing language 
See controlled vocabulary. 

index streaming 
Technology that downloads only the portion of information needed, to minimize load on the 
server. The Word Wheel uses index-streaming technology. 

INI file 
Initialization file, which a software application uses to store various settings. DB/TextWorks 
uses several different INI files. For example,DBTEXT.INI, stored with the software, contains 
configuration information. INMAGIC.INI, stored in user file path, contains option settings. 
The textbase .INI file, which has the same name and location as the textbase, contains 
textbase-specific settings. 

initial action 
The action that occurs when a textbase is opened using a particular menu screen option. Menu 
screens exported to HTML for use with WebPublisher ignore all textbase boxes except those 
with an initial action of Saved Query. 
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initial elements 
The forms, query screen, and/or record skeleton that are loaded when a textbase is opened 
using a particular menu screen option. For menu screens, the initial elements control the 
default forms used by WebPublisher. 

initial form/display form (DB/Text WebPublisher) 
The form that is first used in the Web browser. The initial Report form is applied when the 
user retrieves records. The initial Display form is applied when the user expands a record by 
clicking a hypertext link. 

Inline image 
An image that is displayed as part of a Web page, instead of as a separate page. Compare 
picture box. 

InmagicADVANTAGE 
The software maintenance program of Inmagic, Inc. through which new features are made 
available to customers throughout the year as they are implemented, rather than as a 
once-a-year upgrade. New product releases are downloaded directly from the Inmagic Web 
site (www.inmagic.com). For more information, contact Inmagic, Inc. or your authorized 
Inmagic dealer. 

Inmagic.net 
An evolving DB/TextWorks feature that gives you the ability to connect to the Inmagic server 
from within a DB/TextWorks session to accomplish various tasks relating to 
cataloging, indexing, and disseminating information throughout an organization. 

Inmagic tagged format 
Import/export format for sharing text files of records among DB/TextWorks textbases. 

instance 
A copy of the software run by a particular user. A single user may have one or more instances 
of DB/TextWorks running at the same time. 

interfile 
Merge and sort up to five fields for reporting purposes. In a report containing interfiled authors 
and subjects, for example, a record appears once for each author and once for each subject 
within the specified Sort Level. 

Internet 
A collection of computer networks connecting users around the world. 

Interruptible Import 
Import option specifying that records be indexed, one at a time, as they are imported. This 
method consumes less system resources than Express Import, and permits others to share the 
textbase, or you want to run other applications at the same time, (Express Import requires 
exclusive access) or you want to be able to interrupt the import without undue delays. 
Compare Express Import. 

intranet 
A LAN (Local Area Network) or WAN (Wide Area Network) that is used in a manner similar 
to the Internet, using TCP/IP, Web browsers, HTML pages, and so forth. 
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ISAPI 
Internet Server Application Program Interface specification. A high-performance alternative to 
Common Gateway Interface (CGI) executable files. Internet Information Services, the free 
Web server software provided by Microsoft, supports the ISAPI protocol. 

Java 
A platform-independent programming language that is typically used on the World Wide Web. 
Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun 
Microsystems, Inc. in the U.S. and other countries. 

JavaScript (JScript) 
A scripting language created by Netscape that can be embedded into HTML documents for use 
on the Web. It can also be used in form scripts in DB/TextWorks. It is unrelated to Java. 
Compare VBScript. 

jump 
See hypertext link. 

justification 
Alignment of information in a box in a form (for example, left, center, or right). 

key 
Index entry. Consists of a single word in the Word index for a field, or the first 250 significant 
characters of a field entry in the Term index. See also Sort Key. 

labels (box) 
Optional identifying text associated with a box on a form or query screen. 

labels (printing) 
A type of form, used to print multiple mailing labels, file folder labels, rotary cards, library 
catalog cards, book label sets, and so forth. 

landscape orientation 
A horizontal page orientation in which text and/or images are printed “sideways” across the 
wider dimension of a rectangular sheet of paper. Compare portrait orientation. 

last-saved value 
The value most recently entered in an Automatic ID field when a new record was created and 
saved. 

lead textbase 
The textbase containing the query screen for use with DB/Text WebPublisher to search 
multiple textbases. The lead textbase contains the query screen definition and all of the 
pertinent information about the other textbases to be searched. 

leading article 
Article or part of speech occurring at the beginning of a field entry. You can ignore leading 
articles when sorting, to prevent clusters of records sorted under words such as “A” or “The.” 

leading spaces 
Spaces appearing at the beginning of a line in a document, at the beginning of a field entry in a 
delimited text file, or at the beginning of a field entry or continuation line or after a carriage 
return indicator in an Inmagic tagged file. 
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letter-by-letter filing 
The opposite of word-by-word filing, specified by clearing the Word by Word Special Filing 
check box when editing the textbase structure. Letter-by-letter filing sorts entries from left to 
right, ignoring all spaces and punctuation (Newbury precedes New Zealand). 

licensed number of users 
The maximum number of users who may use a particular installed copy of the software 
simultaneously, according to the licensing agreement. 

line breaks 
Characters in text or formatting instructions that dictate that additional information be 
displayed on a new line. Line breaks can be incorporated into the data in a record, added as 
text in a form definition, or specified by a Paragraph Formatting option for a form box. 

link (hypertext) 
See hypertext link. 

Link field 
Field in a primary textbase used to identify and link to a record in a secondary textbase. 

linked textbases 
Textbases that are associated by means of a Link field in the primary textbase and an 
associated field in the secondary textbase. This relational-like linking enables you to access 
record information from the secondary textbase while working in the primary textbase. 

load 
To import records from a text file into a DB/TextWorks textbase. Typically used to recover a 
damaged textbase. See also dump textbase; import. 

log file 
Text file containing a description of changes made to records in a textbase. It also records 
certain changes made to the textbase structure. 

maintenance (textbase) 
See textbase maintenance. 

maintenance (software) 
See InmagicADVANTAGE. 

MAPI 
Messaging Application Program Interface. A program interface that lets you send EMail from 
within Windows programs. 

Margin Area 
The section of a form where you specify information to be printed on every page of the printed 
report, such as page numbers. Information in this area appears only for printed reports. 
Compare Record Area. 

Margin box 
A Margin box is a box that you add in the Margin Area by choosing Edit>Add and clicking 
Form Box, Text Box, or Picture Box. Script input boxes and script buttons are not available 
in the Margin Area. 
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mask 
A character pattern that governs how information can be entered in a field. See also validation. 

Master password 
A textbase-level password that must be defined before any other passwords are created. The 
Master password grants full access to all operations. 

matching records 
Import option specifying that incoming records be matched against records already in the 
textbase based upon the contents of one or more specified fields. If a match is found, that 
record in the textbase may be edited, replaced, or deleted (depending on the selected import 
options). 

maximum (calculation function) 
A function that yields the highest value found. The MAX function yields the highest number 
(or date) found in a set of records. The FMAX function yields the highest number (or date) 
found in the entries of a field in a single record. 

maximum (field validation) 
The highest value that will be accepted in a field. For example, if 99 is the maximum value for 
a Number field, 100 will not be accepted into that field. 

maximum height 
The greatest number of lines that will be displayed or printed in a form box. Also, the greatest 
number of lines to which a query box will expand as query criteria are typed or pasted into it. 
If content exceeds box height, scroll bars may appear. 

maximum textbase users 
A parameter associated with a textbase, specifying the maximum number of times a textbase 
can be opened simultaneously. 

menu 
A list from which you can select an activity to perform. 

menu screen 
For DB/TextWorks - A list of items that may appear when you start DB/TextWorks. Clicking 
an item opens a textbase. For DB/Text WebPublisher - Provides a way to run prespecified 
queries. 

Menu Screen Designer 
The DB/TextWorks tool used to create menu screens. 

merge 
To combine information. You can merge the terms in a text file with the terms already in a list 
inside a textbase, such as a stop word or validation list. You can use the matching records 
option during import to merge the fields in the records in a text file with the records already in 
the textbase. You can merge sorts using the interfile option on the applicable Specify Sort 
Order dialog box. 

message box 
A message that informs you about error conditions, requests confirmation, displays warnings, 
and so forth. 
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minimum (calculation function) 
A function that yields the lowest value found. The MIN function yields the lowest value found 
in a set of records. The FMIN function yields the lowest number (or date) found in the entries 
of a field in a single record. 

minimum (field validation) 
The lowest value that will be accepted in a field. For example, if 10 is the minimum value 
specified as validation for a Number field, 9 will not be accepted into that field. 

minimum height 
The fewest number of lines that will be displayed in a form box, regardless of the amount of 
information available for display. Unless the minimum number of lines is set to zero, the box 
will appear, even if it contains a field absent in a particular record. 

modification date 
Date when a record was last changed. Can be added to the textbase structure as an Automatic 
Date field. Also, the date a textbase definition was last changed. 

monohierarchical thesaurus 
A thesaurus in which a term may belong to only one conceptual category and, thus, have only 
one broader term. Its counterpart is a polyhierarchical thesaurus. DB/TextWorks thesauri are 
monohierarchical. 

MS-DOS character translation 
Option specifying that extended characters will be translated between MS-DOS representation 
and Windows when files are imported or written. Before moving text between DOS and 
Windows applications, choose Tools>Options and specify the desired Read/Write extended 
characters in MS-DOS Format setting. 

multiple entries 
See field entry. 

multi-user 
Property of software, enabling more than one person to use the software simultaneously. 
DB/TextWorks permits up to the licensed number of users to work with the software 
simultaneously. Multiple users can work in the same textbase at the same time, provided they 
use Shared Immediate or Deferred indexing. 

narrower term (NT) 
A descriptor that is subordinate to, either in a generic-specific or whole-part manner, another 
descriptor in a hierarchy. The relationship indicator for this type of term is NT. Example: 
Aquatic Animals NT Fishes. Its reciprocal is broader term (BT). The relationship of a term and 
its broader term is sometimes called “child-parent.” Every NT will have a reciprocal BT and 
vice versa. The BT-NT relationship does not have to be generic-specific. In some thesauri, the 
relationship is more correctly defined as a “whole-part” relationship. Example: Illinois NT 
Chicago. 

nested Boolean 
The use of two or more Boolean commands to construct a search request, possibly with 
parentheses to control the order of operation. See also Boolean commands. 
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network counter 
Counter built into the software that governs simultaneous use of the software by no more than 
the licensed number of users. 

Network Upgrade Password 
The password required to increase the licensed number of users. The password is supplied on a 
separate piece of paper when you purchase DB/TextWorks or additional licensing rights. 

non-preferred term 
One of two or more synonyms or lexical variants that serves as an entry term to the thesaurus. 
Non-preferred terms are not used in indexing, cataloging, or searching of the descriptor field. 

non-printable area 
The area around the edges of a sheet of paper in which the printer cannot write. On a laser 
printer, this area is usually 1/4 inch or less. 

non-repeating field 
A field that is not allowed to have more than one entry in any record, as defined by its 
validation. 

NT 
See narrower term. 

numeric filing 
A Special Filing option governing how numbers in a field are filed for sorting purposes. With 
numeric filing, volume 2 precedes volume 10. With alphabetic filing of numbers, 
volume 10 precedes volume 2. 

object 
A programming term describing a logical structure available for manipulation by a program or 
script. An object may have properties (attributes) and methods (functions). DB/TextWorks 
includes a number of objects that a script can use to manipulate information in a form or 
textbase. For example, a Box object represents a box on the form. One of its properties is 
content (the text within the box). It also has a setFocus() method. 

ODBC 
Open Data Base Connectivity is a programming interface that enables you to extract data from 
databases using third-party tools. The DB/Text® ODBC Driver provides open access to 
Inmagic textbases. 

offset 
See position offset. 

omit (records) 
To remove a record from a set of records retrieved by a search. Omitting a record from a set 
does not remove the record from the textbase. 

omit (empties) 
To omit from a sorted report all records having no information in the field by which the report 
is sorted. This is a property you can set in the sort specification. 
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OpenType fonts 
Cross-platform fonts that work on both Windows and Macintosh systems. The OpenType font 
file format was developed jointly by Adobe and Microsoft. 

orientation 
See page orientation. 

orphan term 
In a DB/TextWorks thesaurus, a term that has no relationships. Terms with no relationships in 
a hierarchically constructed thesaurus should be investigated periodically to determine whether 
they are legitimate terms or orphans that have become inadvertently unlinked from other terms. 
To find orphan terms, on the Maintain Thesaurus window, type @orphan, then click Search. 
See also preferred term. 

override 
Option available with certain types of field validation, enabling the user to accept 
non-conforming information into the textbase after a confirmation message. 

page breaks 
Where one page ends and another one begins. 

page orientation 
Parameter specifying whether a report is designed to be printed in portrait orientation (long 
dimension vertically) or landscape orientation (long dimension horizontally). 

paragraph 
A body of text ending in a paragraph break. The break may be part of the data, or it may have 
been added using Added Text or Paragraphs formatting. 

paragraph breaks 
See line breaks. 

paragraph formatting 
In the Form Designer, an option that specifies whether paragraph breaks are added to the 
information placed in a form box. 

parent 
See broader term. 

password 
A series of characters that you may be asked to type when you open a textbase. Passwords 
control what activities you may perform. 

paste 
To insert text from the Windows Clipboard into an editable window or insert boxes in the 
designers, or to copy a term from the Editing/Query Choices Browser dialog boxes into a 
query or edit box. 
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PDF 
Portable Document Format. PDF is considered the standard for electronic document 
distribution. If you have or download and install the appropriate IFilter from Adobe Systems 
Incorporated (www.adobe.com) and your operating system has support for IFilter technology, 
you can import the text of a PDF document using File>Import Document. 

pending updates 
See deferred updates. 

persistence 
Means by which parameters or information can be remembered for later use. 

phrase 
Two or more words separated by spaces or, in some cases, punctuation, such as local area 
networks or MS-DOS. 

picklist 
A list of items on a dialog box from which you can make a selection. Compare drop-down list. 

picture box 
Box on a form containing a fixed image or logo, or an image referenced in the current record. 
Compare inline image. 

portrait orientation 
A vertical page orientation in which text and/or images are printed across the narrower 
dimension of a rectangular sheet of paper. This is the page orientation typical of most 
documents. Compare landscape orientation. 

position offset 
The horizontal and vertical distance between a form box and either the edge of the form or 
another box. Offsets can be measured in inches, millimeters, points, or (in the case of vertical 
measurements only) lines. 

post deferred updates 
Process by which indexes are updated to reflect changes made to records under Deferred 
indexing. 

preferred term 
The term that is selected from a class of synonyms, near synonyms, and quasi-synonyms to 
designate unequivocally a concept. Usually considered to be synonymous with descriptor. The 
thesaurus compiler (or Authoritarian) chooses one term from among several possible terms, 
and directs the user, by means of references from synonyms and other alternative forms, to 
employ this one in indexing and/or searching. A preferred term in a DB/TextWorks thesaurus 
is one that has any or all of the following relationships: BT, NT, RT, or UF; or, which has no 
relationships. See also orphan term. 

preview 
To see what a form will look like in actual use. 
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primary sort field 
Field used to sort records within a common Sort Level. See also alternate primary sort field. 

primary textbase 
Textbase you open explicitly, and which contains at least one Link field. A primary textbase 
can be linked to one or more secondary textbases, which are opened implicitly when you open 
the primary textbase. 

printer fonts 
Fonts or character styles that are appropriate for selected printers only. To see the available 
printer fonts when designing a form, choose File>Print Setup and select the target printer 
before opening the Form Designer. 

Private 
Denotes that textbase elements (forms, query screens, sets, record skeletons) are stored in the 
user file rather than in a textbase file. Private elements are not available to other users. 

prompted text 
Questions or prompts defined in a form, to be asked whenever the report is run. The user’s 
typed response is inserted in the report. 

proximity search 
A search for two words in a field, specifying how near each other they must be (number of 
words).  

Public 
Denotes textbase elements (forms, query screens, sets, record skeletons) stored in a textbase 
file rather than in the user file. Public elements are available to all users. Forms must be saved 
as public to be used on the Web as textbase default elements or as initial elements in menu 
screens. 

punctuation 
Character that is not a letter, digit, space, or control character. Punctuation characters serve to 
separate words in DB/TextWorks (thus, by-law is considered two words). 

query 
Search criteria intended to retrieve records. 

query box 
Box on a query screen, which searches one or more fields. In a query box, you can type words, 
terms, or comparison expressions in order to search for records. 

query buttons 
See Boolean query buttons. 

query screen 
The query screen contains boxes into which you type words, terms, or comparison expressions. 
It can also contain sets boxes and script buttons (both desktop only), text boxes containing 
instructions and other informational text, picture boxes, and so forth. Each box represents one 
or more fields to be searched. Also called a search screen. 
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Query Screen Designer 
The DB/TextWorks tool used to create query screens for searching a textbase. 

range search 
Search that looks for records that have information in a field that falls within a specified range 
of values, such as dates. For example, 2001:2002 searches for records from 2001 through 
2002. 

read-only field 
Field to which write-access is denied by the textbase password in use or because of the field 
type (Automatic Date, Automatic Number, and Computed fields). The field can be seen but not 
changed, deleted, or added by the user in any record. 

rebuild a field index 
Recreate an index for a field by examining all of the records in the textbase.  

record 
Retrievable unit of information in a textbase, generally associated with some kind of item (for 
example, book, document, customer) or event (for example, sales order, problem report, task). 

Record Area 
The body of a form, consisting mainly of record information. Information in the Record Area 
appears in displayed and printed reports, and in individual record display. Compare Margin 
Area. 

Record box 
A Record box is a box that you add in the Record Area by choosing Edit>Add and clicking 
Form Box, Text Box, Picture Box, Script Input Box, or Script Button. 

record class 
A designation given to a group of records for the purposes of restricting access. The record 
class (for example, the designation Librarian Only) is stored in an Access Control field 
and in a special validation list. Users are given access to records of various classes by way of a 
Field Access or Silent password. 

record-level security 
The ability to restrict access (read/write, read, or none) to classes of records within a textbase. 
Classes are defined with the Access Control field. See also Access Control field. 

record skeleton 
Set of field values to appear in a new record in the Edit window. Record skeletons can be 
named, saved in the textbase or user file, exported, and imported. 

Recover Textbase 
A DB/TextWorks feature that involves dumping the contents of a textbase to an ASCII file, 
making an empty copy of the textbase, and loading the ASCII file into the new textbase. 
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redo 
To undo an Undo operation. 

refresh sets 
Re-execute the search strategy for saved sets, in order to update the list of records retrieved to 
reflect changes in the textbase since the searches were last performed. 

refresh window 
In the Edit window, to cause Computed field values and linked record information to be 
updated on the screen while you are editing a record, if you have changed information that 
affects the computed value or the link. This enables you to see the new information without 
leaving the field. In all other windows, choosing Window>Refresh redisplays the window 
contents (for example redisplays a report). 

related term (RT) 
A descriptor that is associatively but not hierarchically linked to another descriptor in a 
thesaurus, also referred to as an associative relationship. Related terms link together 
descriptors that are semantically related in ways other than the formal genus-species or 
whole-part relationships; these descriptors, in relationship to one another, are neither broader 
nor narrower, but are obviously related in some unspecified way. You might think of these 
pairs of terms as “cousins;” that is, not as closely related as “parent-child.” The related term 
cuts across the hierarchy of the thesaurus. The relationship indicator for this type of 
relationship is RT. The RT indicator says to the indexer and searcher “you may be interested in 
these terms, as well.” Example: Animals RT Wildlife sanctuaries. 

relationship indicator 
A word, phrase, abbreviation, or symbol identifying a semantic relationship between terms. 
Examples of relationship indicators used in a DB/TextWorks thesaurus record are BT, NT, RT, 
USE, and UF. Relationship indicators lead indexers and searchers to the most appropriate term 
they should use in their activity. They also facilitate “housekeeping” in that, if a term is deleted 
from a controlled vocabulary, all references to it must also be deleted. 

relevance-ranked sort 
A sort that displays records in descending order of their relevance, with the most relevant 
records appearing first. It can be used with word, phrase, and proximity searches. If a query 
involves term searches only, no relevance sort is attempted. 

repeating field 
Field that contains more than one entry, such as an Author field with two author names. Most 
editable fields can repeat (unless validation prohibits it). 

report 
Layout for presentation of multiple records; may include headers, footers, and (for printed 
reports) pagination information. A report can be displayed in the Report window or sent to a 
printer, or written to a file or sent as EMail in a variety of formats (for example, RTF, HTML, 
plain text). 
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report footer 
See footer. 

Report form 
A form for displaying multiple records at a time, one after another (for example, as a table). 
Compare Display form. 

report header 
See header. 

Report window 
Window in which multiple records retrieved by a search are displayed one after the other, as 
one continuous report. 

required field 
Field that must exist in every record added to the textbase. This is an optional validation 
setting specified for a field when the textbase structure is defined. 

resolution 
The number of dots used to represent information within a given area on a screen or printer. 
Higher resolution generally produces better visual quality. 

reverse sort 
Sort option that specifies that information appears in descending order, such as Z to A, or 
most-recent-date first. 

rotate 
To turn a displayed image in 90-degree increments. Useful if an image was scanned 
upside-down. 

RT 
See related term. 

RTF 
Rich text format, an option when writing a report to a file or sending EMail. Many word 
processors can read RTF files. 

run-time literals 
See prompted text. 

Run-time version 
A standalone, search-only version of DB/TextWorks, which allows users to perform read-only 
operations on textbases (search, sort, print, but not edit). You can copy and distribute the Run-
time software according to your license agreement, to allow others to search your textbases. 

scale to gray 
Process that smoothes the color transitions in a black-and-white image, improving readability. 
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scaling 
The expansion or contraction of an image to fit a particular window. Initial scaling of images 
can be set as a user option. 

scope note 
For a thesaurus term, a note explaining a descriptor’s coverage, history, specialized usage, or 
rules for assigning it in indexing. 

screen 
See query screen; menu screen. 

script 
Program you write for a form or screen, which can perform prespecified actions when events 
occur. 

script button 
Button you can place on a form or screen, which will initiate a prespecified action when 
clicked.  

script input box 
Box you can place on a query screen, menu screen, or form that lets the user type in 
information to be used during the processing of a script. Script input boxes do not appear on 
WebPublisher forms, query screens, or menu screens. 

scroll bar 
The bar on the edge of a window or form box, containing arrow buttons and a box you can 
move to navigate quickly through the contents of the window. The also appear for picklists and 
drop-down lists on dialog boxes and the Word Wheel. 

search criteria 
All of the information typed or pasted in a Query or Command Query window to find records. 

search screen 
See query screen. 

search highlighting 
The use of font or color in a report to emphasize the words and terms that satisfied the query. 
For example, reverse video may be used. You can turn highlighting on or off for a particular 
form. 

search item 
A single word, phrase, or term that you want to find, or a single comparison, range, or 
proximity search request (for example, >100 or 2001:2002 or red p3 dog). 

search relation 
Symbol that specifies a condition to be satisfied when a field in a record is matched against a 
particular term or value during a search (for example, <  <=  >  >=  ct). 

secondary textbase 
A textbase that is accessed indirectly through a Link field in a primary textbase. See also 
linked textbases. 

 Glossary 449 



selection list 
See picklist. 

separator 
See decimal separator; entry separator. 

sequential file 
See ASCII file. 

serial number 
Unique number associated with each licensed copy of DB/TextWorks. Your serial number is 
visible on the About dialog box and the Textbase Information window. 

series 
Multiple entries, usually in a Date or Number field, automatically generated by the software 
when the Insert Series command is used. The entries are incremented in numerically or 
chronologically ascending order. 

session 
The time during which a program is running. For example, a DB/TextWorks session starts 
when you begin running the software and ends when you choose File>Exit. 

set 
A list of records found by a search, together with the criteria that were used to perform the 
search. Sets can be saved, combined, browsed, printed, and re-executed in DB/TextWorks. 

sets box 
Box added to a query screen for the purpose of combining the records in one or more 
previously saved sets with the current search.  

Setup 
Program included with most software, including DB/TextWorks, to install the software or 
update configuration settings. 

Shared Immediate indexing 
Indexing mode setting that specifies that changes and additions to records in a textbase be 
indexed immediately, but permits multiple users to open the textbase at the same time. 
Compare Immediate indexing; Deferred indexing. 

sibling 
A descriptor that shares the same broader term (one level higher) as other descriptors in a 
thesaurus. 

significant characters 
Characters in a field that are retained in the index and that affect the filing order. For example, 
punctuation characters are significant in Code and UDC fields but not in other field types. 
Alphanumeric characters are significant in all field types. The following are also significant 
characters when searching:  =  &  /  !  :  <  >  (  ) 

Silent password 
Set of permissions granted to a user who does not supply a password when opening a 
password-protected textbase. 
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skeleton 
See record skeleton. 

SMTP 
Simple Mail Transfer Protocol. A program interface that accesses EMail services directly, 
without the need to use an EMail program. 

sort 
To arrange records in a report in a particular order, such as alphabetically by last name. 

sort footer 
See footer. 

sort header 
See header. 

Sort Key 
The specific entry in the sort field by which a copy of a record is filed in a report. The Sort 
Key can be isolated from other entries in the field and, for example, displayed in a Sort Header 
before a group of records filed under that key. 

Sort Level 
Number referencing the position of a field in the sort hierarchy. For example, if a report is 
sorted by Region, then subsorted by Type, the Region field is Sort Level 1 and the Type field is 
Sort Level 2. Sort Levels are used to identify Sort Headers and Sort Keys within a form 
definition. The use of Sort Levels rather than explicit sort field names means the same report 
can be sorted in different ways on different occasions, and the headers and footers will behave 
as you want. 

special characters 
Characters having special meaning to the system or to DB/TextWorks when searching. For 
example, an asterisk (*) signals truncation in a search, and an ampersand (&) indicates a 
Boolean AND. See also significant characters. 

Special Filing 
Option available when defining fields for a textbase, permitting the filing rules to be modified 
for a particular field. For example, you can specify whether stop words should be ignored. See 
also filing order. 

spell checker 
Checks a record to eliminate possible typographical errors by comparing words to a dictionary 
of words, which can be edited. You can run a spell check on a record after creating or editing it 
on the desktop, or have spelling checked as you type in the record. You can check spelling in 
the following windows: Edit Record, Edit Secondary Record, Record Skeleton Editor.  

status bar 
Area near the bottom of the screen, containing useful information, such as a description of the 
highlighted menu selection or the number of records in the current search. 

stem 
Letters at the beginning of a word, which can be used to find the word if truncation (*) is used 
during a search. 
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stop words 
Words that are not added to the Word index for fields using the Use Stop Word List Special 
Filing option. You can choose your own stop words for each textbase structure. 

strict 
Option available for certain field types, specifying that non-conforming information not be 
accepted in a field. See also trailing text. 

structure 
See textbase structure. 

style sheet 
Used to describe how the data in an XML file is to be presented. An XSL style sheet specifies 
where information should appear on a page, as well as which fonts, styles, and other formatting 
attributes should be used. XSL style sheets are used by DB/TextWorks to transform XML files 
into Inmagic tagged format for the purpose of importing XML files. 

subfield 
See field entry. 

subsort field 
Field used to sort the records within a common Sort Level. Up to four subsort fields can be 
defined under the primary sort field. 

substitution list 
List of abbreviations and expanded terms that can be associated with a field in a textbase. The 
format of an entry in the list is abbreviation-colon-expansion (for example, 
MA:Massachusetts). If the abbreviation is typed during data entry or encountered in a 
record being imported, the expanded term is substituted in the record. 

subtab 
A secondary tab on a primary tab. For example, on the Form Box Properties dialog box there 
are six primary tabs (Contents, Position, Labels, Paragraphs, Format, and HTML). When you 
click the Contents tab, five subtabs appear (Fields, Sort Keys, Variables, Text, and 
Calculations). 

Synchronize Windows 
Command on the DB/TextWorks Window menu, specifying that all open windows that are 
displaying records be synchronized to show the same record. 

synonyms 
Terms that are considered sufficiently equivalent to make a distinction unnecessary; one is 
chosen as a descriptor, and a USE reference made from the other(s). The synonyms in a 
thesaurus are synonyms only in this special context, and not “universal” synonyms. Thus, in a 
thesaurus the word “synonym” is used to mean true synonym, near synonym, and 
quasi-synonym. Consider Street, Road, Lane, Avenue, Parkway, Highway, 
Beltway, and so forth, which, in the context of a Transportation Engineering thesaurus, 
would most likely be considered synonymous. One would be chosen as the preferred term, or 
another, new preferred term would be invented to cover the concepts. The other terms would 
become non-preferred. 
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syntax 
A formal description of the arrangement of elements so that they can be recognized by the 
software. For example, the syntax of a Command Query expects the field list to precede the 
search relation and term(s). 

Tab key 
Keyboard key used to navigate among controls on a dialog box, boxes in a form, and so forth. 
Tabs cannot be embedded in a record. If encountered during an import operation, tabs are 
changed to spaces. 

tab order 
The order in which the Tab key moves from box to box for navigational purposes on a form, 
query screen, or menu screen. 

tabular form 
A tabular form presents information as a table, in rows and columns. Each row represents a 
record. Each cell represents a field or other content item (for example, variable, calculation). 
Tabular forms are especially useful when publishing on the Web. 

TCP/IP 
Transmission Control Protocol/Internet Protocol. The basic communication protocols that are 
the foundation of the Internet. TCP/IP allows your computer to talk to the Internet or an 
intranet. All other protocols (for example, HTTP, FTP, Gopher) are layered on top of TCP/IP. 

temporary files 
Files created by the software for sorting and formatting reports and other purposes, and deleted 
automatically after use. 

term 
A word or phrase that is also a complete entry in a field. Date and Number fields typically are 
Term indexed, as are fields that hold discrete pieces of information, such as book titles. 

term (glossary) 
One or more words designating a concept. See also descriptor; entry term. 

Term index 
Index that contains the field values (the first 250 significant characters of a field entry) used for 
comparison and range searches, such as equals, greater than, and so forth. 

term record 
A set of fields of information about a descriptor in a thesaurus, including its relationship to 
other terms. The fields in a term record are: Term, BT, NT, RT, Use, UF, ScopeNote, 
OtherNotes, and Status. 

text box 
Box on a form or screen containing static text. 

text file 
See ASCII file. 

textbase 
A collection of records containing related information. See also record; textbase structure. 
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textbase default sort 
A sort that is defined as part of the textbase structure. You can temporarily change the sort 
order by doing a user-specified sort (choose Display>Sort Report). 

textbase elements 
Forms, query screens, record skeletons, and sets. 

textbase file 
The main textbase definition file (.TBA), which contains public textbase elements (sets, forms, 
query screens, and record skeletons). 

textbase maintenance 
The process of keeping a textbase updated (through edits, imports, and so forth) and backed 
up. Routine integrity checks (choose Manage Textbases>Check Textbase) are also advised. 

textbase-specific help 
A compiled Windows help file supplied by the user, appropriate for a particular textbase. 

textbase structure 
List of fields and settings that define a textbase. 

thesaurus 
A controlled vocabulary arranged in a known order in which equivalence, homographic, 
hierarchical, and associative relationships among terms are clearly displayed and identified by 
standardized relationship indicators, which must be employed reciprocally. Its purpose is to 
promote consistency in the indexing or cataloging of documents and to facilitate searching by 
linking entry terms with descriptors. The thesaurus usually lists descriptors alphabetically, 
endeavors to control synonyms and homographs, and displays generic-specific and other 
relationships between terms. 

thousand separator 
Character used to group digits into thousands in a formatted number. The character is specified 
in the Regional settings of the Windows Control Panel. For example, in the U. S., the thousand 
separator character is a comma (35,000). 

thumbnail display 
The display of multiple images from a single record at one time, scaled down to fit. Useful for 
selecting a particular image to then view at a larger size. 

toolbar 
Area at the top of a window, containing buttons that initiate actions. 

top term 
In a DB/TextWorks thesaurus designed to be hierarchical, a term that has no broader term. 
These are usually terms that represent the top of a “tree” of concepts. 

trailing text 
Text that can appear after a strict date or number in a field. See also strict. 

TrueType fonts 
Scalable fonts included with Microsoft Windows. TrueType fonts print as they appear on the 
screen, and can be scaled to any size. 
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truncate 
To shorten by cutting off the end. In a report, information that does not fit in a form box or on 
a printed label is truncated. In a search, you can use truncation to search for the first few 
characters of a word or term. The asterisk character (*) indicates truncation. For example, a 
search for com* finds computer, commute, and any other words that start with com. 

UDC 
Universal Decimal Classification, an international numbering system used for classification of 
technical documents. DB/TextWorks supports a UDC field type, which files UDC numbers 
correctly. 

UNC 
Universal Naming Convention. The actual name of a drive (for example, \\SERVER\VOL2), 
rather than the drive letter (C:\). Recommended on networks and in other situations where 
drives might be remapped. 
Example: \\server\vol1\database\catalog.tba 

underbar 
The underline character (_), which may be used to hold two words together to prevent them 
from being separated in a report. 

undo 
To cancel the last edit operation(s) performed. 

unindexed field 
Field in the textbase structure to which no index (Term or Word) has been assigned. 
Unindexed fields cannot be searched and do not appear on the query screen. 

unique validation 
Validation option for a field, specifying that no two records can have the same term in this 
field. Terms are considered equivalent if they file the same. For example, June 15, 2002 
and 15-Jun-02 are equivalent in a Date field. 

units of measure 
Form specification dictating the units by which distances (box position offsets and coordinates) 
are measured. Possibilities include inches (to the nearest .01 inch), millimeters (to the nearest 
.1 mm), and points. Vertical measurements can also be given in lines (to the nearest .1 line), 
where the height of a line is font-dependent. 

unposted changes 
Deferred updates (changes that have been made but not indexed). 

updates 
Changes made to records. Deferred updates are changes that have been made but not yet 
indexed. 

URL 
Uniform (or Universal) Resource Locator. The addressing scheme used to locate a site on the 
Web, and to indicate the target of hypertext links. Example: http://www.inmagic.com. 
See also file URL. 
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USE 
An equivalence relationship indicator identifying a synonymous semantic relationship between 
an entry term and the preferred term. Its reciprocal is USED FOR. Example: Cats USE Felines. 
The USE reference directs a person away from a term that is not permitted in indexing or 
searching to a term that may and should be used. The USE reference may also be employed to 
direct users from specific terms not used in indexing or searching to more appropriate generic 
terms. Example: Electrical De-icing USE De-icing Systems. 
If, from the Query/Editing Choices Browser, you try to paste a term that has a USE 
relationship, the USE term is pasted instead. In this way, USE terms behave like substitution 
lists. 

USED FOR (UF) 
An equivalence relationship indicator identifying a synonymous relationship, in the context of 
the thesaurus, between a preferred term and a non-preferred term. Example: Felines USED 
FOR Cats. 
The thesaurus compiler (or Authoritarian) chooses one term from among several possible 
terms, and directs the user to employ this term by means of references from synonyms and 
other alternative forms. The terms not chosen are labeled “non-preferred” and are placed in the 
thesaurus as synonyms. The relationship indicator for equivalence is USE; its reciprocal is 
USED FOR. 

user file 
A private file that contains forms, query screens, sets, and record skeletons, as an alternative to 
storing them in the textbase file. Elements stored in your user file are not accessible by other 
users. 

user options 
A set of parameters maintained separately for each user in the INMAGIC.INI file. 

user-specified sort 
A sort specified by choosing Display>Sort Report after finding records or loading a set. This 
sort remains in effect until you close the textbase or sort again. If the current Report window or 
printing form specifies a compulsory sort, the user-specified sort is ignored. 

validation 
The process that checks the correctness of something. For example, DB/TextWorks checks the 
validity of field names in an import file and the validity of field content if a field has validation 
rules applied in the textbase structure definition. 

validation list 
A list of terms that will be accepted in a field.  

variable-length field 
Field that occupies only as much space in a database or textbase as the information it contains, 
rather than being padded out to some predetermined length. All DB/TextWorks fields are 
variable-length with no size limitation. 
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variables 
Information provided by the software that can be incorporated into a form, such as current 
date, current time, page number, or textbase name. 

VBScript 
A scripting language created by Microsoft that can be embedded into HTML documents for 
use on the Web. It can also be used in form scripts in DB/TextWorks. It is a subset of 
Microsoft’s Visual Basic programming language. Compare JavaScript. 

Web (WWW) 
World Wide Web. A network document delivery system that uses HTML as the authoring 
language and HTTP as the transport protocol. Developed at CERN in Switzerland, the 
European laboratory for particle physics. 

WebPublisher 
See DB/Text WebPublisher. 

WebPublisher PRO 
See DB/Text WebPublisher PRO. 

wildcard 
Character that matches any other character or set of characters. In a search, an asterisk (*) is a 
wildcard character that can be used at the end of a word or term. In a mask used for validation 
purposes, a question mark (?) is a wildcard representing any character. 

word 
A group of characters that does not contain spaces or punctuation (except a decimal separator 
in a number). 

Word index 
Index containing words found in a particular field, enabling fast word-level retrieval. You 
specify in the textbase structure whether or not a field should use a Word index. 

word-by-word filing 
Special Filing option specified in the textbase structure, to sort items from left to right, one 
word at a time, ignoring spaces and punctuation (but treating them as word delimiters). When 
sorted word-by-word, New Zealand precedes Newbury. Compare letter-by-letter filing. 

Word Wheel 
A Java applet that shows indexed words or terms in the current field. DB/Text WebPublisher 
users can include a Word Wheel as part of a query screen by using Tools>Box 
Properties>Browse Choices, then exporting the query screen to HTML. Internet/intranet 
users call the applet by clicking the Word Wheel button next to a query box, while viewing an 
HTML query screen in a Web browser. They can then paste items as search criteria. 

write-protected 
Accessible for reading only. A write-protected file, field, or record cannot be edited or deleted. 
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XML 
Extensible Markup Language. Used for structured documents and data on the Web. XML uses 
tags, like HTML, but offers greater flexibility because it gives you the ability to define custom 
tags. DB/TextWorks can import or export data files in XML format. WebPublisher can accept 
queries in XML and return results in XML. 

XSL 
Extensible Stylesheet Language. Used to create a style sheet to describe the formatting of 
XML data when it is displayed via a Web browser. XSL style sheets are also used to convert 
XML files to Inmagic tagged format when importing. See also style sheet. 

zoom 
To expand or reduce the magnification of an image or portion of an image being displayed. It 
is also available in Print Preview. 
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- Subtraction 

in Computed field formulas, 42 
in form calculations, 225 

! Exclamation point 
Boolean NOT, 141, 188 
comment line indicator, 111, 113 
mask validation upper-case letter, 56 

# Mask validation digit, 56 
$ End-of-record indicator, 111 
& Boolean AND, 141, 188, 191 
( ) Parentheses 

in Command queries, 188 
in form calculations, 225 

* Asterisk 
mask validation series of characters, 56 
multiplication, 42, 225 
truncation, 140, 186 

/ Slash 
Boolean OR, 141, 188 
division, 42, 225 

: Range, 140, 186 
; Multiple entry indicator, 111 
? Mask validation single character, 56 
@ Link indicator, 375 
@DATE, 144, 225, 227, 230 
^ Mask validation lower-case letter, 56 
{} Set indicator, 189 
+ Addition 

in Computed field formulas, 42 
in form calculations, 225 

< Less than, 140, 186 
<= Less than or equal to, 140, 186 
= Term search, exact match, 138, 140, 186 
> Greater than, 140, 186 
> Line break indicator, 111 
>= Greater than or equal to, 140, 186 
2000, 402 
21st century, 402 
2-digit years, 402 
3-D box borders, 393 
 

 

A 
About DB/TextWorks command, x 
Accelerator key. See Quick keys 
Accented characters, 107, 390, 392 
Accept New Record, 118 
Accept validation overrides, 59, 118 
Access Control fields, 47, 64 
Action bar. See Toolbars 
Add Box command, 158, 165, 169, 207, 333 
Add/Replace options during import, 116 
Added text, 223, 249 
Adding records over the Web, 328, 330 
Addition 

in Computed field formulas, 41, 43 
in form calculations, 225 

Address labels. See Labels 
Align Boxes command, 236 
Aligning 

box tops in forms, 236 
boxes (left, center, right), 258 
form box labels, 238 
form paragraphs, 243 
record separators, 267 

Allow 
tabbing to Boolean buttons, 392 
trailing text, 48 

Alphabetic 
filing of numbers, 52, 144 
numbering, 245 

Alternate primary sort fields, 311 
Ampersand (&) in searches, 141, 188, 191 
Analyzing textbases, 81 
Anchored boxes, 163, 234 
AND searches, 141, 188, 191 
Annotating images, 358 
Annotation files, 360 
Anti-aliasing, 355 
Appending field entries during import, 117 
Application options (Copy Special), 415 
Arabic numbers, 245 
Arithmetic calculations 

in Computed field formulas, 41, 43 
in form calculations, 225 

Ascending sort order, 309 
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ASCII files. See Text files 
Associated field 

@ link indicator, 375 
browsing, 372 
characteristics of, 371 
defined, 364 
how indicated, 375 
specifying, 46, 368 
viewing information from, 366 

Asterisk 
mask validation wildcard, 56 
searching for all records, 146 

Asterisk multiplication symbol (*) 
in Computed field formulas, 42 
in form calculations, 225 

Asterisk truncation symbol (*). See Truncation 
searches 

Attaching files to EMail, 321, 322 
Automatic Date Definition tab, 34 
Automatic Date fields 

defining, 40 
what happens during import, 108 
what happens when copying records, 104 

Automatic ID fields 
defining, 41 
what happens during import, 108 
what happens when copying records, 104 

Automatic Number Definition tab, 34 
Automatic Number fields 

defining, 40 
linking to, 369 
what happens during import, 108 
what happens when copying records, 104 

Averages 
in Computed Number fields, 42 
in form calculations, 229 

AVG Record Function, 228, 229 

B 
Background color 

boxes in forms, 244, 246, 258 
boxes in menu screens, 333, 334, 335, 339 
boxes in query screens, 166, 168, 170 
default form and box settings, 395 
forms background, 265 
query screen background, 174 

Background images 
for forms, 264, 267 
for menu screens, 341 
for query screens, 175 

Backing up files, 77, 103, 127 

Backslash 
in mask validation, 56 
in searches, 146 

Basic forms 
Basic Record form, 194 
Basic Report form, 194 
opening, 197 
selecting, 326 
setting defaults, 394 

Basic Query Screen, 160, 179 
Batch operations 

batch delete records, 104 
batch modify records, 105 

Bates numbers, 54 
Beginning text, 250 
Black and white images, 355 
Blank form, opening, 197 
Blank line between multiple entries, 243, 251 
Blank query screen, opening, 160 
Book label sets, 292 
Boolean query buttons, 142, 172 
Boolean searches 

changing Boolean query buttons, 142, 172 
inclusive search option for multiple fields, 

190, 392 
nested Boolean commands, 189 
query evaluation order, 143, 189 
with Command queries, 188 
with Query window searches, 141 

Borders, 163, 202, 237, 258 
3-D, 393 

Boundaries 
field entry, 141 
in Form Designer, 198 
in Query Screen Designer, 161, 163 
showing or hiding, 195, 198, 236 

Boxes. See Form boxes, Menu screen boxes, 
Picture boxes, Query boxes, Script buttons, 
Script input boxes, Sets boxes, Text boxes 

Brackets around set names, 189 
Browsing 

Browse Choices key (F3), 9 
during batch modify, 106 
during editing, 84 
during searching, 138 
indexes, 49, 138, 188 
links, 372, 377 
sets (list of), 184 
substitution lists, 97 
thesaurus, 96, 98 
validation lists, 96 
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Buttons. See Boolean query buttons, Script 
buttons, Toolbars  

Combining searches, 184, 189 
Comma-delimited text files, 113, 125 
Command queries 

performing, 132, 184 C using with linked textbases, 374 
Comment lines, 111, 113 Calculations 
Comparison searches, 140, 186 @DATE, 225, 227 
Compulsory form sort, 196, 305, 306, 314 in Computed fields, 41, 43, 99 
Computations. See Calculations in forms, 224 
Computed Date Definition tab, 34, 44 in query screens, 144 
Computed Date fields Caption tab, 301, 302 

defining, 43 Caret (^) in mask validation, 56 
refreshing, 99, 379 Carriage returns. See Line breaks 
using Field Functions in, 44 Cascading menus. See Menu screen boxes 
what happens during imports, 108 Case 
what happens when copying records, 104 during batch modify operation, 106 

Computed Number Definition tab, 34, 42 for form box text, 246 
Computed Number fields in Code fields, 47 

defining, 41 in Command queries, 187 
refreshing, 99, 379 in Query window searches, 138, 147 
using Field Functions in, 42 Catalog cards, 292 
what happens during imports, 108 Centering paragraphs in form and text boxes, 

243 what happens when copying records, 104 
Configuration, 12, 401 Century, 21st, 402 
Content descriptions, 198 Character translation, 265, 390, 392 
Content validation, 54, 58 Check for matching records, 116 
Contents Checking information. See Validation 

of boxes in forms, 213, 256, 259, 300 Checking spelling, 91 
of boxes in query screens, 159, 165, 169, 171 Checking textbases, 82, 130 
of menu screen boxes, 333, 338 Choices key. See Browsing 

Contents tab Clipboard, 415 
Form Designer, 214 Code fields 
Menu Screen Designer, 333 defining, 47 

Context display. See Highlight search items searching, 146 
Context-sensitive help, ix Colon, range indicator, 140 
Continuation line, 112 Color 
Convenience password. See Silent password background for form boxes, 244, 246, 257, 

258 Conventions, vii 
Converting a form to a query screen, 324 background for menu screen boxes, 333, 334, 

335, 339 Coordinates 
of boxes in forms, 211 background for query screen boxes, 166, 168 
of boxes in menu screens, 333 background for script input boxes, 170 
of boxes in query screens, 163, 168 box background default settings, 395 

Copy command, 93, 209 box label in forms, 239 
Copy Special, 414, 415 form background, 265 
Copy Textbase command, 74, 78 inverting colors in images, 355 
Copyright, 39 query screen background, 174 
COUNT Record Function, 228, 229 search item highlighting, 156, 157 
 Columns 
 adding column headings in forms, 287 
 in reports, 290 
 setting in Thumbnail window, 356 
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international formats, 401 Counting 
languages for month and day names, 401 entries in a field, 42, 227, 229 
long or short date format, 248, 390 number of records in a set, 228 
searching for, 144, 191 records, 229 
strict Date fields, 39, 48 records in a report, 228 
year 2000, 39, 402 Creation date 

DB/Text Checker, 12 of records, 40, 108 
DB/Text PowerPack Lite, 12 of textbase, 76 
DB/Text Updater, 12 Criteria. See Search criteria 
DB/Text WebPublisher. See DB/Text 

WebPublisher PRO 
CSV format. See Delimited ASCII format 
CT (contains), 186 

DB/Text WebPublisher PRO, 328 Curly brackets around set name, 189 
Boolean and range searches, 192 Currency 
defined, 1 formatting, 42, 247, 248 
designing forms for Web use, 200, 207, 267 symbols in number fields, 39 
exporting query screens to HTML, 163 Current date 
logos, 175, 266 formatting, 220 
reports, 200, 207 in search criteria calculations, 134, 145 
saving forms for, 200 inserting as a new entry, 94, 390 
searching multiple textbases, 163 inserting in a record, 94, 390 
textbase user count, 68 pasting in a search, 145 
XML match fields, 68 setting, 220 

DB/TextWorks using in a calculation, 227 
configuring, 12, 401 using in a form, 220 
connecting with other applications, 415 Current time 
defined, 1 formatting, 220 
installing, 12 inserting in a record, 94, 390 
navigating in, 403 setting, 220 
serial number, x, 14 using in a form, 220 
setting options, 389 Customer support, x 
starting, 13 Customize Toolbar command, 399 

DBTEXT.INI file, 401, 417 Customizing DB/TextWorks, 389, 416 
DBTEXT.TBM file, 343 Customizing forms, 194 
DBTMSG (error messages textbase), ix Cut command, 93, 209 
Decimal places, specifying number of, 246, 247 
Decimal separator, 246 D Default 

Basic form and query screen fonts, 394 Damaged textbases, 127, 130 
Basic Report and Record forms, 389, 394 Data entry, 4 
file extensions, 419 Databases. See Textbases 
forms, 77, 326 Dates. See also Current date 
indexing mode, 99 Automatic Date fields, 40 
label font, 394 calculating in a form, 227 
leading article and stop word lists, 401 calculations in search criteria, 134, 144 
menu screen settings, 394 Computed Date fields, 43 
query screen settings, 394 copyright, 39 
record skeleton, 86 Date fields, 39, 48 
sort order, 65, 314 finding the earliest (forms), 228 
tab order, 212 finding the most recent (forms), 229 
textbase settings, 77 formatting in a form, 196, 225, 248 

Deferred indexing mode, 101, 391 inserting, 94 
 inserting as a new entry, 390 
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Deferred updates Display window 
and Find All Records command, 147 defined and illustrated, 203 
deferred indexing options, 391 designing forms for, 203 
defined, 101 effect of sorting on the, 315 
files, 410 search item highlighting, 156 
getting, 102, 187 Distance between records, 202, 265, 286 
posting, 102       Division 
printing, 102 in Computed field formulas, 42 
searching for, 187 in form calculations, 225 
show deferred changes in reports and display, 

391 
Document import, 107, 121 
Dollar amounts, formatting in a form, 247, 248 

what happens when copying records, 101 Dollar sign ($) 
working with, 102 end-of-record indicator, 111 

Delete Box command, 159, 163, 209 in strict Number fields, 39 
Delete button, textbase elements, 384 DOS, extended characters, 107, 390 
Delete Entry command, 90, 408 Dump Textbase command, 107, 127, 130 
Delete Log File command, 67 
Delete Record command, 104 E Delete record link (WebPublisher PRO), 255 
Delete Textbase command, 75 Edit Lists command, 38 
Delete user file option, 75 Edit record link (WebPublisher PRO), 255 
Delete versus Omit, 105 Edit Record Skeleton command, 85 
Deleting records over the Web, 328 Edit Secondary Record command, 377 
Delimited ASCII format Edit Secondary Record window, 378 

exporting, 126 Edit substitution lists, 38 
importing, 113 Edit Textbase Structure command, 60 

Delimiter, 113, 393, See also Field entry 
delimiter 

Edit validation lists, 57 
Edit window 

Descending sort order, 308, 309 defined and illustrated, 204 
Description line designing forms for, 204 

for a form, 199 effect of sorting on the, 315 
for a query screen, 162 refreshing, 99 
for a record skeleton, 86 Editing 
for a set, 180 substitution lists, 98 
for textbase elements, 388 validation lists, 97 

Design Form command, 197 Editing Choices Browser, 96, 97 
Design Menu Screen command, 332 Editing records 
Design Query Screen command, 160 adding one at a time, 83 
Deskew, 354 browsing links, 372 
Despeckle, 354 browsing substitution lists, 97 
Detect URLs, 393 browsing thesaurus, 98 
Dewey Decimal classification, 47 browsing validation lists, 96 
Diacritics, 107, 390, 392 choosing an indexing mode, 99 
Diagnosing and fixing problems, 120, 130 in secondary textbases, 377 
Discarding deferred updates, 102 inserting dates, 94 
Display Current command, 343 inserting times, 94 
Display options over the Web, 193, 200, 207, 328 

for images, 354 replacing records during an import, 117 
Form Properties, 264 spell check, 91 
Query Screen Properties, 163, 171 undo and redo, 93 

Display Record command, 137 why some boxes are not editable, 88 
Display Report command, 87 Editing records over the Web, 328 
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F Elements. See Textbase elements 
EMail 

importing. See Importing documents FAVG Field Function 
links, 254 in Computed Number field formulas, 42 
sending a report as, 193 in form calculations, 227, 229 
sending records as, 321 FCOUNT Field Function 

Empty fields, finding, 147, 187 in Computed Number field formulas, 42 
Empty form boxes, showing or hiding, 232 in form calculations, 227, 229 
Empty password. See Silent password Field Access passwords, 62 
Empty sort fields, 312 Field entries 
Empty textbase, 390 blank line between, 243, 251 
Enable or Upgrade Network command, 14 calculating, 41, 227 
Ending punctuation, 222, 250 creating multiple, 88 
Ending text, 222, 250 defined, 27, 88 
End-of-record indicator ($), 111 deleting, 90 
Entries. See Field entries entry separator, 113, 125, 240, 241, 251 
Entry delimiter. See Field entry delimiter Exploded Sort option, 309 
Entry separator for image file names, 348 

format for imports, 113 formatting, 241 
specifying in a form, 240, 241, 251 inserting a series of dates or numbers, 94 

Entry validation, 54 inserting current date or time, 94 
Equal sign (=), 138, 140, 186 multiple, 25, 27, 88 
Error messages, ix pasting information to create a new entry, 90 
Evaluation order of queries, 143, 172, 189 prohibiting multiple, 54 
Exact match, 138, 140, 186 repeating, 25, 27, 88 
Exception file, 107, 118, 419 selecting, 90 
Exclamation point (!) separating with spaces in the same box, 242 

Boolean NOT, 141, 188 specifications, 28 
comment line indicator, 111, 113 splitting, 90 

Execute Query command, 135 Field entry delimiter, 393 
Existing form, opening, 197 Field Entry Required validation, 54 
Existing menu screen, opening, 343 Field Functions 
Existing query screen, opening, 160 in Computed field formulas, 42, 44 
Existing Record Form, 160 in form calculations, 227 
Existing record skeleton, opening, 85 Field separator 
Expand record link (WebPublisher products), 

254 
during export, 125 
during import, 113 

Exploded Sort option, 309, 312 Field Types 
Exporting Access Control, 47, 64 

deferred updates, 103 adding or changing, 37, 70 
query screens to HTML, 163 Automatic Date, 40 
records, 107, 125 Automatic ID, 41 
textbase elements, 385 Automatic Number, 40 

Exporting edit form to HTML, 330 Code, 47 
Express Import option, 119 Computed Date, 43 
Extended characters, 107, 390, 392 Computed Number, 41 
 Date, 39 

Image, 45, 346 
 Link, 46 

Number, 39 
Text, 38 
UDC, 47 
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Fields FMAX Field Function 
changing settings for, 69 in Computed field formulas, 41, 44 
copying, 71 in form calculations, 227 
creating, 32 FMIN Field Function 
defined, 27 in Computed field formulas, 42, 44 
deleting, 72 in form calculations, 227 
editing in textbase structure, 69 Focused zooming, 355 
finding empty, 147, 187 Font 
finding populated, 147, 187 box label in forms, 239, 394 
hidden, 104, 232 box label in query screens, 394 
maximum number of, 28 box text in forms, 244, 257, 302, 394 
non-repeating, 54 box text in menu screens, 334, 335 
read-only, 62 box text in query screens, 165, 394 
rebuilding indexes, 66, 73 default for Basic forms and query screens, 

394 renaming, 71 
Footers. See Report Headers and Footers, Sort 

Headers and Footers 
reordering, 71 
specifications, 28 
unindexed, 49, 134 Form box types 
unique, 54 aligning, 236 
using in a calculation, 226 changing, 274 
using in a form, 216 Margin box, 277, 283, 287 

Fields tab, Query Screen Designer, 166 offsets, 211 
File folder labels, 292 Record box, 230, 277 
Files Report Footer box, 274, 277 

ASCII files, 110, 125, 387, 419 Report Header box, 273, 277, 287 
displaying recently used file list, 390 Sort Footer box, 272, 277 
dumping to, 127 Sort Header box, 271, 276, 277 
exception, 419 Form boxes 
exporting to, 107, 385 adding, 207 
file formats, 110, 111, 390 anchoring, 234 
importing, 107, 385 borders, 202, 237 
initialization files (.INI), 401, 416 boundaries, 198 
loading, 107, 128 changing height, 231 
log file, 67 changing the box type, 274 
menu screen files (.TBM), 343 changing width, 233 
printed element definition files (.TXT), 387 content description, viewing, 195, 198 
printing or writing to a file, 323 contents, 208, 213, 232 
textbase backup (.TBB), 79 coordinates, 211 
textbase files, 410 default text and label font, 394 
textbase user files (.TBU), 10, 411 defined and illustrated, 208 

Filing, 50 deleting, 209 
Find All Records command, 147, 187 empty, 232 
Find and Replace commands, 93 floating, 234 
Find command, 93 height, 231 
Find in Command queries, 185 including text and punctuation, 222 
Finding. See Searching labels, 202, 222, 237, 394 
Fit to Window command, 354 maximum height, 231 
Fit Window to Form, 406 minimum height, 231 
Fixed text, 221, 284, 287 moving, 210 
Floating boxes, 234 multiple entries, 201 
 paragraph formatting, 240 
 positioning, 211, 286 
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scroll bars, 202, 237 FTOTAL Field Function 
selecting, 210 in Computed Number field formulas, 42 
showing or hiding empty boxes, 232 in form calculations, 227 
sizing, 231 Full text imports, 121 
text formatting, 222, 244 Function keys, 408 
using Cut, Copy, Paste, 209 
width, 233 G Form Designer, 197 

Form name and description, 325 GetDeferred command, 187 
Form Properties, 264 Getting deferred updates, 102, 187 
Form Scripts. See Scripts Global edits. See Batch operations 
Formatting. See Paragraph formatting, Text 

formatting 
Go to Box command, 210, 407 
Grand totals in reports. See Totals 

Forms. See also Reports Graphical User Interface (GUI), 403 
backing up, 324 Greater than (>), 140, 186 
Basic forms, 327 Greater than or equal to (>=), 140, 186 
box types, 276 Grid, horizontal and vertical 
converting to query screens, 173, 324 in forms, 210 
creating, 195, 268 in query screens, 163 
customizing, 194 Group footers in reports. See Sort Headers and 

Footers default, 77, 326 
defined, 193 Grouping information in a report, 271, See also 

Sorting records deleting, 324, 384 
description line, 199, 388 
designing for printing, 206, 268 H designing for the Display window, 203 
designing for the Edit window, 83, 204 

Hanging indentation, 243 designing for the Report window, 201, 268 
Headers. See Report Headers and Footers, Sort 

Headers and Footers 
designing for the Web (WebPublisher PRO), 

207 
Headers and Footers command, 273 drop-down list in Web browser, 342 
Height exporting, 324, 385 

boxes in forms, 257 fitting a window to a form, 406 
boxes on a query screen, 163 for linked textbases, 366, 375 
boxes on forms, 231 importing, 386 
labels and cards, 296 managing, 383 
page, 289, 395 Margin Area, 283 
picture boxes, 261 opening, 197 
record separators, 267 page set-up, 288 

Help, ix, 400 previewing, 198, 315 
Hidden fields printing a definition, 386 

how to hide fields with passwords, 62 properties, 264 
in forms, 232 Record Area, 285 
what happens when copying records, 104 renaming, 324, 383 

Highest value, finding the, 42, 44, 229 saving, 199 
Highlight search items search item highlighting, 156, 265 

moving from highlight to highlight, 157, 203 selecting, 326 
specifying appearance of, 157 tabular, 197, 290 
turning on or off, 156, 265 troubleshooting, 318 

Horizontal and vertical grid Formulas. See Calculations, Computed Date 
fields, Computed Number fields, @DATE in forms, 210 

in query screens, 163  
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HTML Immediate indexing mode, 100 
exporting query screens to, 163 Import fields in textbase structure order, 114 

Import filter. See IFilter technology form properties (Web), 267 
HTML properties, forms, 329 Importing 
options for DB/Text WebPublisher, 267 documents, 107, 121 
options for WebPublisher products, 163, 207 image file names into records, 349 
sending reports as EMail, 320 records, 107, 419 
writing reports to, 323 textbase elements, 385 

HTML file reference (WebPublisher products), 
254 

Importing records, 107 
Inclusive search option, 190, 392 

Hypertext links, 393 Indentation, paragraph, 243 
Indexes 

browsing and pasting from, 49, 138, 188 I defined, 49 
indexing fields, 49, 70 Icons, 333 
leading zeros missing in Term indexes, 52 Identifying field, 67 
rebuilding, 73 IDI file, 411, 413 
Special Filing options, 50 IFilter technology, 121 
Term and Word indexing, 49 Ignore accents on extended characters, 392 
unindexed fields, 49, 134 Ignore Leading Articles, 51, 66 

Indexing mode, 99, 108 Image annotation list, 360 
INI files, 416 Images 
Initial action, 331, 334 adding image file names to records, 347 
Initial elements, 331, 334 annotating, 358 
Initial password handling, 391 anti-aliasing, 355 
Initialization files, 416 defining Image fields, 346 

DBTEXT.INI, 401, 417 deskewing, 354 
DBTWPUB.INI, 418 despeckling, 354 
INMAGIC.INI, 389, 416 difference between Images window and 

picture box, 346 textbase .INI, 418 
Inmagic tagged format, 110, 111, 125 displaying, 352, 396 
Inmagic, Inc., ix fitting to window, 354, 355 
INMAGIC.INI, 389, 416 focused zooming, 355 
Inmagic.net, 5 image drive, 396 
Insert Entry Mark command, 90 image link, 255 
Inserting inline image, 255 

carriage returns, 89, 113, 241 inverting colors, 355 
current date or time, 94, 390 jump to, 354 
date as a new entry, 390 location of, 46, 347, 396 
entry mark, 90 naming, 347 
series of dates or numbers, 94, 390 navigating among, 353 

Installation notes, ix printing, 357 
Installing DB/TextWorks, 12 redacting, 359 
Interfile Fields sort option, 312 rotating, 355 
Intermediate textbase, 367 scaling, 354, 357, 396 
International scanning, 351 

character sets, 390, 392 searching for, 352 
currency format, 246 support multiple page TIFF images, 396 
current date and time settings, 94, 220 support only short filenames for images, 396 
date formats, 248 supported file formats, 361 
separator characters, 246 Thumbnail reduced display, 356 

Internet, ix zooming in and out, 355 
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Interruptible Import option, 119 Library book label sets, 292 
Intersection. See AND searches Library catalog cards, 292 
Inverting colors in images, 355 Library of Congress classification, 47, 51 
Issue numbers, 52 Licensing of software, 14 
Item numbering, 245 Line break indicator, 111 

Line breaks, inserting, 89, 113, 241, See also 
Paragraph formatting J Link Definition tab, 34 

Link fields JavaScript, 177, 298 
characteristics, 370 JScript, 177, 298 
editing secondary textbase information, 98 Jump to Image command, 354 
renaming, 379 Justifying 
re-ordering, 379 boxes, 211, 258 
specifying, 46, 368 form box labels, 238 

Linking textbases, 363 form paragraphs, 243 
assigning passwords, 380 text box paragraphs, 168, 243 
associated fields, 371 
editing secondary textbase records, 377 K intermediate textbases, 367 
refreshing linked information, 379 

Keyboard actions, viii renaming fields, 379 
Keyboard keys, 408 reordering fields, 379 
Knowledgebase, ix searching, 372 

searching with Command queries, 374 
L viewing secondary textbase information, 375 

Links, hypertext, 393 
Labels Lists. See also Leading article list, Stop word 

list, Substitution lists, Validation lists box, 163, 202, 223, 237 
label sets, 297 bulleted, viii 
mailing, 197, 292, 310 fonts used when printing, 394 
printing, 318 formatting information as, 243 

Landscape orientation, 289, 395 indexes, 138, 188 
Languages, month and day names, 401 numbered, viii 
Lasso boxes, 210 printing, 394 
Launching applications on the Web, 254 printing to a file, 80, 97 
Launching other applications, 298, 415 recently used files, 390 
Leading article list Load New Textbase command, 107, 128, 130 

backing up, 80, 419 Load Set command, 181 
creating or editing, 66 Loading records. See Importing records, Load 

New Textbase command default, 402 
Ignore Leading Articles option, 51, 66 Log files, 67, 81, 410 
printing, 80 Logos, 175, 266 
using, 51 forms, 266 

Leading logo, 175, 266 leading, 266 
Leading spaces, 119, 124 trailing, 266 
Leading zeros Long date format 

in form calculations, 247 for inserted dates or series, 390 
missing in term indexes, 38, 52 in forms, 248 

Leave Small Images Original Size option, 396 Look-up files. See Validation lists 
Less than (<), 140, 186 Lower case. See Case 
Less than or equal to (<=), 140, 186 Lowest value, finding the, 42, 228 
Letter-by-letter filing, 51 
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M Menu screens, 331 
backing up, 78 
designing, 332 Mail. See EMail 
form drop-down list in Web browser, 342 Mailing labels. See Labels 
properties, 340 Main window, 403 
properties, 340 Maintain Thesaurus, 154 
saving, 343 Maintenance procedures, 77 

Merging fields, 117, See also Interfile Fields 
sort option 

Manage Textbase Elements command, 383 
Manage Textbases menu, 103, 127, 130 

Messages textbase (DBTMSG). See DBTMSG 
(error messages textbase) 

Many-to-one relationship, 363 
MAPI, 319, 397 

Microsoft Windows, 40, 107, 246, 392 Margin Area, 276, 283, 289 
MIN Record Function, 228 Margin boxes 
Minimum height adding, 283 

designing labels, 293 defined, 276 
of a box, 163, 231, 395 illustrated, 279 

Minimum value, calculating uses for, 284, 287 
across records in a form, 228 Margins, page, 289, 296, 395 
in a Computed field definition, 42, 44 Mask validation, 55, 95 
in a field in a form, 227 Master password, 61 

Minimum value, specified by range validation, 
55 

Match fields, 68 
Matching 

Modification date, 40, 108 case and punctuation during searches, 138, 
147 Money, formatting in a form, 247, 248 

Month names, default, 401 during batch modify, 106 
More defaults, 394 during import, 116, 124 
Mouse actions, viii for linking purposes, 48, 365, 366, 370 
MS-DOS MAX Record Function, 228 

character translation, 390 Maximum 
extended characters, 107, 390 number of fields in a textbase, 28 

Multiple entries, 25, 27, 54, 89, 201, 240, 241, 
393, See also Field entries 

number of users, 14, 68, 76 
value specified by range validation, 55 

Multiple textbase query (WebPublisher 
products), 163 

Maximum height 
designing labels, 293 

Multiplication of a box, 163, 202, 204, 231 
in Computed field formulas, 42 Maximum value, calculating 
in form calculations, 225 across records in a form, 228 

Multi-user in a Computed field definition, 42, 44 
environments, 10 in a field in a form, 227 
indexing settings, 100, 101 Measurement units 
license agreement, 14 in forms, 175, 265 

 in query screens, 163, 175 
Menu actions, viii 

 Menu bar, 403, 404 
Menu screen boxes, 334  
Menu Screen Designer, 331, 333 
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N Numbers 
Automatic Number fields, 40 
Computed Number fields, 41 Navigating 
decimal separator, 246, 247 between boxes, 407 
dollar amounts, 39 between records, 137 
filing alphabetically or numerically, 38, 52, 

144 
between windows, 403 
in a box, 237, 315 

formatting in a form, 246 in the Images window, 353 
including leading zero in decimal, 247 in the Print Preview window, 315 
inserting a series of, 94 in the Report window, 137 
international formats, 225, 246 synchronizing multiple windows, 406 
negative, 39, 247 Navigational buttons, 342 
Number fields, 39 Negative indentation, 243 
postal (ZIP) codes, 38 Negative numbers 
searching for, 52, 144 filing order, 52 
Social Security numbers, 38 formatting in a form, 247 
strict Number fields, 48 in Computed field formulas, 44 
telephone numbers, 38, 39, 52 in Number fields, 39 
thousand separator, 52, 246, 247 indexing, 39 

Numeric filing, 52 order when sorting, 144 
Nested Boolean commands, 189 

O Networks 
maximum number of users permitted, 68 
sharing textbases on, 60, 68, 101 ODBC, 410 
specifying number of licensed users, 14 Offsets. See Position offsets 
user file location, 412 Old version of records, 391 

New Entry command, 89 Omit (trailing) Text option, 247, 248 
New Label Form. See Labels Omit Empty Records sort option, 312 
New Query command, 136 Omitting records 
New Record command, 83, 84 after getting deferred updates, 105 
New record link (WebPublisher PRO), 255 from a set, 137, 180 
New Search button, 418 omit versus delete, 105 
New Textbase command, 32, 36, 72, 79 when sorting, 312 
New version of records, 391 Online help, ix 
Next button, 342 Open (textbase) command, 13 
Next Highlighted Term command, 157 Open Form command, 198 
Non-inclusive search option, 190, 392 Open Query Screen command, 162, 173 
Non-preferred terms, 151 Open Skeleton command, 86 
Non-printable area of a page, 284, 318 Operating systems, 107, 417 
Non-repeating fields, 54 Options, 163, 198, 389, 414 
NOT searches, 141, 187, 188 OR searches, 141, 188 
Notify when opening empty textbase, 13 Overriding 
Number of records, 342 allowing content validation overrides, 58, 118 
Numbering textbase defaults, 326 

entries and items in a form box, 245 validation, 118 
pages in a report, 220, 279, 282, 284, 289  
records in a report, 220, 285 

 records in a textbase, 40 
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P moving, 163, 210 
selecting, 163, 210 
types, 277 Page breaks, 289 

Picture tab, 259 Page margins, 289, 296, 395 
Placement of navigational buttons, 342 Page numbers 
Plain Text, 319 including in a form, 220, 284 
Pop-up menu, 404 selecting a starting, 289 
Portrait orientation, 289, 395 Page orientation, 296 
Position offsets Paragraph breaks. See Line breaks 

designing labels, 293 Paragraph formatting, 240, 251, 265 
form box, 211, 238, 286 Paragraph indentation, 243 
query box, 166 Paragraph justification, 258 
sets box, 168 Parentheses 
text box, 211 in Computed field formulas, 42, 44 

Posting deferred updates, 102 in form calculations, 225 
Precedence in searches, 143, 189 

arithmetic operators, 42, 225 Passwords, 60 
in Boolean queries, 143, 172, 189 default settings, 391 
in Code fields, 47 effect on deleting records, 104 
in UDC fields, 47 effect on importing records, 108 

Preceding by number of words (p#), 141, 187 Field Access, 62 
Preferences. See Options Master, 61 
Preferred terms, 151 network upgrade, 14 
Preview printing, 81 

Preview command (form), 198 protecting image annotations, 360 
Print Preview command (report), 315 secondary textbase fields, assigning to, 380 

Previous button, 342 Silent, 63 
Previous Highlighted Term command, 157 Paste. See also Browsing, Inserting 
Primary sort field, 307, 308, 312 Paste command, 93, 209 
Primary textbase, 364, 377 Paste Entry command, 90 
Print command, 316 Paste Here command, 209 
Print Deferred Updates command, 102 Pending updates, 101, See also Deferred updates 
Print Definition command, 325, 386 Phone numbers. See Telephone numbers 
Print Preview command, 315 Phrases 
Print Setup command, 316 defined, 133 
Print Skeleton command, 86, 387 searching for, 138, 186 
Printed reports Picklist. See Browsing 

form for, 206, 268, 317 Picture boxes 
printing, 316 adding to a form, 207 
search item highlighting, 265 adding to a menu screen, 336 
sorting, 305 adding to a query screen, 169 

Printing anchoring, 169, 234 
an element definition to a text file, 387 changing height, 169, 261 
deferred updates, 102 changing width, 169, 262 
designing forms for, 206, 268 contents, 169, 259 
form definitions, 325 coordinates, 169, 211 
images, 357 defined and illustrated, 164, 208 
indexes, 391 deleting, 163, 209 
labels, 318 difference from Image window, 346 
lists, 80, 97 floating, 234 
menu screen definitions, 78  
query screen definitions, 385  
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adding picture boxes, 169 records, 317 
adding script buttons, 171 reports, 316 
adding script input boxes, 170 skeletons, 86 
adding sets boxes, 167 textbase information, 76, 314, 387 
background color, 168, 170 Private vs. Public 
Basic Query Screen, 160, 179, 394 elements, 412 
boxes that search multiple fields, 134, 140, 

141, 159, 165 
files, 386 

Product Support, x 
changing Boolean query buttons, 142 Prompted text, 223 
creating, 157 Properties 
default text and label fonts, 394 form, 264 
exporting to HTML, 163 menu screens, 340 
illustrated, 131 query screen, 174 
managing, 383 Proximity searches, 141, 187 
Open Query Screen command, 162, 173 Public vs. Private 
properties, 174 elements, 412 
query evaluation order, 143 files, 386 
Query Screen Designer, 160 Publishing textbases, 1, 200, 207 
saving, 161 Punctuation 
searching multiple textbases, 163 during batch modify, 106 
selecting, 179 in Code fields, 47 
setting default label font, 394 in Command queries, 187 

Query window search. See also Searching in forms, 222, 250 
boxes that search multiple fields, 134, 140, 

141, 159, 165 
in searches, 147, 187 
in UDC fields, 146 

converting to Command queries, 184 
customizing query screens, 157 Q how to perform, 134 
query evaluation order, 143, 172 Queries. See Query window search 
viewing records after a search, 135 Query boxes 

Quick keys, 408 adding fields from a secondary textbase, 159 
Quotation marks adding to a query screen, 158, 165 

around field names in form calculations, 226 borders, labels, scroll bars, 163 
around field names in formulas, 42, 44 default text and label font, 394 
around field names in Inmagic tagged files, 

112 
defined, 164 
deleting, 159, 163 

around search items, 147, 188 determining which fields a box searches, 159, 
165 

R text and label color, 167, 168 
Query buttons 

Range searches, 140, 186 changing Boolean state of, 142, 172 
Range validation, 55, 95 default tabbing, 392 
README file, ix show or hide, 171 

Query by Example. See Query window search Read-only 
copying read-only fields, 104 Query Choices Browser, 138, 184, 188 
password access, 62 Query evaluation order, 143, 172, 189 

Rebuild Thesaurus, 154 Query Screen Designer, 160 
Rebuilding field indexes, 66, 73 Query Screen Properties, 161, 163, 171 
Recently used file list, 390 Query screens 
Recompute Field Value, 73 adding a temporary query box, 158 
Record and report options (Copy Special), 414 adding a temporary sets box, 184 
Record Area, 276, 285 adding boxes, 165 
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Record boxes spacing, 286 
adding, 285 specifications, 28 
changing to Header/Footer, 274 spell check, 91 
defined, 276 viewing after a search, default window, 18, 

393 illustrated, 278 
Record class, 48 viewing in the Report window, 18, 87, 135 
Record count, including in a form, 220 Recover Textbase command, 129 
Record Functions in form calculations, 228 Redact images, 359 
Record information, 285 Redo command, 93 
Record numbering Referencing files on the Web, 254 

in forms, 220, 285 Refresh command, 379 
using Automatic Number fields, 40 Refresh Sets command, 182 

Record separators, 113, 267 Refreshing 
Record separators (WebPublisher PRO), 264 computed information, 99, 379 
Record skeletons linked information, 99, 379 

copying, 388 sets, 182 
creating or editing, 85 the Report window, 87 
default, 86 Reject New Record, 118 
deleting, 384 Reject validation overrides 
exporting, 385 defining validation options, 58 
importing, 386 during imports, 118 
printing a definition, 386 Related terms, 58 

Relationalism. See Linking textbases renaming, 383 
saving, 86 Relevance ranking, 65 
selecting, 86 Reloading textbases, 128 
using, 85 Rename Textbase command, 75, 130 

Record spacing, 286 Renaming 
Record-level security, 47, 64 fields, 71 
Records textbase elements, 383 

adding, 83 textbases, 75 
adding over the Web (WebPublisher PRO), 

328, 330 
user files, 75, 412 

Repeating entries. See Multiple entries 
copying, 104 Replace command, 93 

Replacing information in records, 93, 116, See 
also Batch Operations, Importing records 

default settings, 395 
defined, 27 
deleting, 104, 117 Report Headers and Footers 
deleting over the Web (WebPublisher PRO), 

328 
adding, 196, 274 
changing the box type, 274 

displaying, 7, 135, 137 defined, 277 
distance between, 202, 265, 286 illustrated, 279 
dumping and reloading, 107, 127 used for column headings, 287 
editing, 87, 137 when to use, 273 
editing over the Web (WebPublisher PRO), 

328 
Report window 

defined, 201 
editing records in a secondary textbase, 377 designing forms for, 201, 268 
exporting, 107 Display Report command, 87, 135 
importing, 107 illustrated, 135, 201 
numbering, 285 navigating in the, 137 
refreshing linked fields, 87, 99, 379 refreshing, 87 
saving, 78, 84 search item highlighting, 265 
sending as mail, 321 sorting records, 305 
sorting, 304 viewing records after a search, 135, 265 
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S Reports. See also Forms, Printed reports 
column headings, 287 
copying to Clipboard, 414 Sample textbases, 14 
creating, 290 Saved Queries window, 183 
defined, 193, 268 Saving 
displaying, 87, 135, 265 annotation files, 78 
Margin and Record Areas, 276 deferred updates to a file, 103 
numbering pages, 284 forms, 199, 325, 387 
numbering records, 285 image files, 78 
overview, 269 menu screens, 78, 343 
previewing, 315 query screens, 159, 161, 387 
printing, 316 record skeletons, 86, 388 
printing to a file, 323 records, 78, 84 
sending as mail in HTML, RTF, or text 

format, 319 
searches, 180 
sets, 180, 387 

sorting, 304, 305 textbase elements, 78, 80 
tabular, 290 textbases, 78 
title, 284 user files, 78 
writing to HTML, RTF, or text, 323 Scale to Gray option, 355 

Require Strictly Correct Type option Scanning images, 351 
changing from non-strict to strict, 48, 70 Screen Designer. See Menu Screen Designer, 

Query Screen Designer for Date fields, 39 
for Link fields, 48, 370 Screen Preferences. See Screen Properties 

command for Number fields, 39 
making a field strict, 48 Screen Properties command, 163, 171 

Required field, 54 Screen Scripts. See Scripts 
Reset to Default Tab Order, 173, 212 Script buttons 
Reset to Defaults, 395 adding, 207 
Resizing anchoring, 234 

boxes, 97, 98 caption, 301 
windows, 406 changing width, 301 

Reverse the sort order, 309 content, 301 
Reversing colors in images, 355 coordinates, 211 
Revert to Default, 86, 326 defined and illustrated, 208 
Rich Text Format, 319, 323 defined in query screens, 164 
Roman numerals, 245 deleting, 209 
Rotary cards, 292 floating, 234 
Rotating images, 355 moving, 210 
Rows and columns in Thumbnail window, 356 selecting, 210 
RTF, 319, 323 Script input boxes 
Run-time variable. See Prompted text adding, 170, 207, 337 
Run-time version, 15, 417 anchoring, 234 
 coordinates, 211 

defined and illustrated, 208 
 floating, 234 

moving, 210  
selecting, 210 

 text and label font, 170 
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Scripts troubleshooting, 191 
Form, 298 truncation searches, 140, 186, 191 
Screen, 170, 171, 177 UDC fields, 146 

Scroll bars, 163, 202, 237, 405 unindexed fields, 134 
Search criteria Secondary records, editing, 98 

combining, 184 Secondary textbases, 367 
defined, 133 @ link indicator, 375 
including in a form, 220, 273 browsing field indexes while searching, 372 

Search highlighting. See Highlight search items defined, 364 
Search item, defined, 133 displaying information from, 365, 375 
Search relation, defined, 186 editing information in, 98, 377 
Search sets. See Sets how indicated, 375 
Searching. See also Command queries, Query 

window search 
refreshing field information, 99, 379 
searching, 372, 374 

adding predefined search links, 331 specifying, 46, 368 
Boolean searches (and-or-not), 141, 188 spell check, 91 
browsing and pasting from indexes, 138, 188 viewing information from, 375 

Security. See also Passwords Code fields, 146 
combining saved searches, 184 Security, record-level, 47, 64 

“See Also” search link (WebPublisher 
products), 255 

comparison searches, 140, 186 
DB/Text WebPublisher products, 163, 192 
defined, 131 Select All command, 163, 210 
for all records, 147, 187 Select command, 343 
for comparison values, 140, 186 Select Entry command, 90 
for dates, 144 Select Images to Print dialog box, 357 
for deferred updates, 102 Select Search Results Window dialog box, 135 
for empty fields, 147, 187 Select thesaurus, 154 
for linked information, 372 Selecting 
for multiple items, 141, 188 all boxes of a particular type, 163, 210, 339 
for numbers, 52, 144 an entry, 90 
for populated fields, 147, 187 forms, 326 
for time, 191 menu screens, 343 
for URLs, 191 query screens, 179 
for values within a range, 140, 186 record skeletons, 86 

Selection list. See Browsing for word stems, 140, 186, 191 
for words near each other, 141, 187 Send Report as Mail command, 319 
for words, phrases, and terms, 138, 186 Sending each record as mail, 321 
inclusive search option, 190, 392 Separate items or entries with spaces, 242 
interrupting a query, 135 Separator text, 251 

Sequential files. See Text files linked (secondary) textbases, 372 
multiple fields, 140, 141, 159, 165 Serial number, x, 14 
multiple textbases (WebPublisher products), 

163 
Series, inserting dates or numbers, 94, 390 
Set Rows and Columns command, 356 

non-inclusive search option, 190, 392 Set Up Page command, 289, 295 
proximity searches, 141, 187 Set Up Thesaurus command, 151 
punctuation and case, 138, 147 Sets 
query evaluation order, 143, 172, 189 combining with search criteria, 184, 189 
quotation marks, using, 191 creating and using, 180 
search item highlighting, 156 managing, 383 
secondary textbase fields, 372 refreshing, 182 
selecting window to view records, 135, 393 using the Saved Queries window, 183 
techniques explained, 138  
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Sets boxes Special Filing options 
adding, 159, 167 effect on sorting, 50, 314 
borders, labels, and scroll bars, 167, 173 for Link fields, 370 
defined, 159, 164 Ignore Leading Articles, 51 
deleting, 159, 163 Numbers File Numerically, 38, 52 
text font and color, 167 Use Stop Word List, 52, 66 

Setup, 401 Word by Word, 51 
Shared Immediate indexing mode, 100 Specifying starting label, 295, 296, 318 
Short date format Spelling Checker, 91 

for inserted dates or series, 390 Splitting field entries, 90 
in forms, 248 Starting page number, 289 

Shortcut keys. See Quick keys Statistics, 81 
Show deferred changes in reports and display, 

101, 391 
Status bar 

displaying validation settings, 84 
Show form list, 176, 342 illustrated, 403 
Show Record Images command, 352 toggling on and off, 339 
Show Underbars as Spaces option, 265 Stop word list 
SIC codes, 52 backing up, 80, 419 
Silent password, 63, 391 creating or editing, 66 
Single Entry Only validation, 54 default, 402 
Skeletons. See Record skeletons printing, 80 
Skip this Box option using, 52, 66 

Stored searches. See Sets tab order for forms, 212 
tab order for query screens, 173 Strict 

SLT file, 402 Date fields, 39, 48 
SMTP, 319, 397 Link fields, 48, 370 
Software license, 14 making a field strict, 48, 70 
Sort Headers and Footers Number fields, 39, 48 

adding, 196, 271, 272 Strip leading spaces during import, 119, 124 
Structure. See Textbase structure changing the box type, 274 
Subfields. See Field entries defined, 276, 277 

illustrated, 279 Subsort fields 
Sort in Reverse Order option, 309 defined, 308 
Sort order, 65 specifying, 307 
Sort Report command, 316 Substitution lists 
Sorting records backing up, 80, 419 

compulsory form sort, 305 browsing and pasting from, 39, 97 
for export, 125 creating and editing, 38, 70, 98 
how to sort, 304 defined, 38, 97 
in forms, 216, 271 during imports, 39, 97, 108 
sort keys, 216, 271, 314 printing to a file, 80, 97 
sort levels, 216, 271, 309 using when editing records, 39 

Subtotals. See Totals textbase default sort, 65, 305 
user-specified sort, 304 Subtraction 

SpacedRelOps setting, 192 in Computed field formulas, 42, 44 
Spaces around Boolean and range symbols, 192 in form calculations, 225 
Spacing records in a form, 286 Support, x 
Special characters, 390, 392 Symbols, vii 
 arithmetic, 42, 225 
 Boolean, 141, 188 
 comparison and range searches, 140, 186 
 Synchronize Windows command, 406 
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T Text tab, 256 
Textbase backup files (.TBB), 79, 419 
Textbase boxes, 332, 333 Tab order of boxes, 143, 172, 212 
Textbase default sort, 65, 305, 306, 314 Tables (tabular forms), 197, 290 
Textbase elements TBB file, 79, 419 

backing up, 78, 80 TBS file, 411 
file extension when printed to a file, 419 TBU file, 78, 413 
managing, 383 Technical support, x 

Textbase File (Public), 386, 412 Telephone numbers 
Textbase Information, 76, 314, 333 Inmagic, Inc., x 
Textbase name suggested indexing settings for, 38, 52 

assigning, 32, 36 Terms 
changing, 75 browsing Term indexes, 138, 188 
including in a form, 220 defined, 49, 133 

Textbase statistics, 81 effect of Special Filing options on, 50 
Textbase structure leading zeros missing in Term indexes, 38, 52 

backing up, 79 searching for, 138, 186 
copying, 36, 72 Term indexing a field, 49 
creating, 32 Text. See Added text, Beginning text, Ending 

text, Fixed text, Prompted text, Separator text editing, 69 
printing the structure definition, 79 Text background color, applying, 395 
protecting with Master password, 61 Text boxes 
textbase structure file, 410 adding, 168, 207, 335 

Textbase structure backup files (.TBB), 79 anchoring, 234 
Textbase user files (.TBU), 411 borders, 257, 258 
Textbases changing width, 233, 335 

analyzing, 81 contents, 256, 335 
backing up, 77 coordinates, 211 
copying, 74 defined and illustrated, 164, 208 
creating, 28 deleting, 163, 209 
damaged, 127, 130 floating, 163, 234 
DBTMSG (error messages), ix font, 246 
defaults, 77 HTML options, 168, 258, 335 
defined, 1 justifying text in, 243 
deleting, 75 moving, 163, 210 
dumping and reloading, 127 selecting, 163, 210 
editing structure, 69 types, 277 
files, 410 Text fields, 38 
information, 67, 76 Text files 
intermediate, 367 delimited ASCII format, 110, 126 
linking multiple, 28, 363, 367 exporting records to, 107, 125 
maximum number of users, 68 extended characters, 107, 390 
opening, 13 extensions used, 419 
passwords, 60, 391 importing, 107 
planning and creating, 32 Inmagic tagged format, 110 
publishing, 1, 200 printing element definitions to, 387 
recovering, 129 XML, 110 
renaming, 75 Text formatting 
samples, 14 for forms, 222, 223, 244 
saving forms in, 199, 386 for menu screens, 333, 334, 338 
saving query screens in, 162, 386 for query screens, 167, 168, 170 
saving record skeletons in, 86, 386 Text Options tab, 34 
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saving sets in, 386 Troubleshooting 
secondary, 367 forms, 318 
sharing, 10, 15, 68 looking up error messages, ix 
technical specifications, 28 searches, 191 
textbase options, 60 Truncation searches 
user file conflicts, 413 finding empty fields, 147, 187 

Textbase-Specific Help, 400 how to perform, 140, 186 
Textbase-user identification, 402 in Code and UDC fields, 146 
Thesaurus, 148 not finding intended record, 52 

as a validation list, 58, 96 on Term indexed fields, 138 
browsing, 96 TWAIN scanners, 351 
browsing and pasting from, 98 Two-digit years, 402 
connect an existing one to a field, 153 Typeface, vii 
create and connect one to a field, 152 
disconnect one from a field, 153 U Maintain Thesaurus, 154 
non-preferred terms, 151 UDC fields, 47, 146 
preferred terms, 151 Underbars (_) 
Rebuild Thesaurus, 154 in ASCII import files, 111 
select, 154 show as spaces in forms, 265 
Set Up Thesaurus, 151 Underlining, 288 

Thousand separators, 52, 246, 247 Undo command, 93 
Thumbnail window, 356 Uneditable boxes, 88, 91 
TIFF images, 345, 361, 396 Unindexed fields, 49, 134 
Time. See Current time, Automatic Date fields Union. See OR searches 
Title bar, 403, 404 Unique Entries Only validation 
Titles applying to a field, 54 

adding to a form, 273, 283, 284 recommended for an associated field, 369 
adding to a query screen, 168 Units of measure 

Toolbars, 398, 403, 404 in forms, 175, 265 
Tools menu, 14 in query screens, 163, 175 

Customize Toolbar, 399 Universal Decimal Classification. See UDC 
fields forms, 196 

menu screens, 339 Unposted changes. See Deferred updates 
Options, 389 Update. See also Deferred updates 
query screens, 163 Automatic Date field, 108 

TOTAL Record Function, 228, 274 posting deferred updates, 102 
Totals validation lists, 58, 118 

calculating in a report, 230, 272, 274 Upper case. See Case 
calculating within a field, 41 URLs 
grand, 274 DB/Text WebPublisher products, 192, 254 
illustrated, 279 detecting, 393 
subtotals, 230 recommended field type, 47 

Tracking textbase access, 402 searching for, 146 
Trailing logo, 175, 266 Use Current Sort, 126 
Trailing text Use inclusive search option, 392 

allowing, 48 Use record separators, 267 
defined, 48, 247 Use Stop Word List option, 52 
searching for, 144, 145 User File (Private), 386, 411 
using a form to omit, 247, 248  

Transaction log. See Log files  
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View Log File command, 67 User files, 411 
View menu, 404 backing up, 78 
View Records command, 195, 198 copying, 74 
Volume numbers, 52 deleting, 75 

renaming, 75 
saving forms in, 200 W saving imported elements in, 386 
saving query screens in, 162 Warn when opening an empty textbase, 390 
saving record skeletons in, 86 Warning messages. See DBTMSG (error 

messages textbase) saving sets in, 181, 386 
technical information about, 411 Web browsers 

User interface (UI), 403 tables, 290 
User May Override Content Validation Web edit form, exporting to HTML, 330 

defining validation options, 58 Web site, ix 
effect on data entry, 95 WebPublisher. See DB/Text WebPublisher PRO 
effect on imports, 118 WebPublisher PRO, 328, 330, See DB/Text 

WebPublisher PRO User May Update Validation List with Override 
defining validation options, 58 Width 
effect on data entry, 95 changing for boxes, 233, 257 
effect on imports, 118 labels and cards, 296 

User Preferences. See Options page, 289, 395 
Users, maximum number of, 68 record separators, 267 
User-specified sort, 304, 306, 314 reports, 289 

Wildcards 
V for mask validation, 56 

for truncation searches, 140, 186, 191 
Validation Window help, ix 

changing, 70 Windows Clipboard, 415 
content validation mismatch, 95 Windows, Inmagic DB/TextWorks 
during imports, 118 Command Query window, 185 
specifying, 53 Display window, 203 
types of, 54 Edit window, 204 
validation choices browser, 106 fitting to a form, 406 
violating, 95, 118 Form Designer window, 193, 198 
when editing records, 95 Images window, 352, 396 

Validation lists Main window, 403 
backing up, 80, 419 Menu Screen Designer window, 334 
content validation mismatch, 59 Menu Screen window, 331 
creating and editing, 57, 97 navigating between, 403 
entry not found in list, 59, 118 Preview window, 198 
overriding, 58, 118 Print Preview window, 315 
printing, 80 Query Screen Designer window, 161 
updating while editing records, 118 Query window, 131, 134 
using, 96 Report window, 135, 201 

Values, computing, 42, 44, 227 Saved Queries window, 183 
Variables, 218, 284, 285 synchronizing, 406 
VBScript, 177, 298 Thumbnail window, 356 
Vertical and horizontal grid Within number of words (w#), 141, 187 

in forms, 210 Within range (:), 140, 186 
in query screens, 163 Word-by-word filing, 51 

View Check Textbase Report File command, 82  
View Content command, 195  
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Words 
breaking after each, 243, 265 
browsing Word indexes, 49, 138, 188 
defined, 49, 133 
effect of Special Filing options on, 50 
searching for, 138, 186 
stop words, 52, 66 
Word indexing a field, 49 

World Wide Web, 1, 163, 200, 207 
Write Report to File, 323 
Write-protected. See Read-only 
 

X 
XML, 110, 125 
XML match fields, 68 

Y 
Year 2000, 39, 402 

Z 
Zeros 

including leading zero in decimals, 247 
missing in Term indexes, 38, 52 

Zooming in and out, 355 
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