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Introduction 

This document is intended for customers who are moving from the non-SQL platform to the SQL 

platform of Inmagic® DB/TextWorks® and DB/Text® WebPublisher PRO.  

The Inmagic® DB/Text for SQL product includes the following components: 

 DB/TextWorks for SQL (the desktop component), and 

 WebPublisher PRO for SQL (the Web component) 

This guide explains how to convert your existing non-SQL textbases and menu screens (and, if you have 

WebPublisher PRO, your non-SQL Web screens, forms, and other Web-related files) for use on the SQL 

platform.  

Why You Must Convert Textbases, Menu Screens, and Web 
Files 

Instead of using a proprietary file system as the DB/TextWorks product does, DB/Text for SQL uses 

Microsoft SQL Server as its data store.  

Because data is stored inside SQL Server, your existing textbases and Web-related files must be 

converted for use with SQL Server.  

DB/TextWorks for SQL maintains the familiar DB/TextWorks interface; only the back-end platform has 

changed. (There are some differences in the interface; for example, the SQL platform includes the 

Administration program, which provides SQL-specific options.) 

Before You Begin 

Before you start the conversion process:  

1. Back up your existing textbases. We strongly recommend that you back up your existing 

textbases. You can either do this manually now, or you can allow the conversion to do an 

automatic backup as part of the conversion process (explained in the steps that follow).  

2. Review the DB/Text for SQL Support Matrix. The Support Matrix lists system requirements 

and the supported versions of Microsoft SQL Server. It is available via the Product 

Documentation link on the Customer Extranet page.  

3. Install DB/TextWorks for SQL. Follow the instructions in the Inmagic DB/Text for SQL 

Installation and Upgrade Instructions, as if you were doing a new installation (not an upgrade). 

We recommend that you accept the default installation folder (C:\Program 

Files\Inmagic\Content Server ). This will ensure that he SQL-based application is in 

a separate location from your existing non-SQL version.   

4. Install WebPublisher PRO for SQL. Follow the instructions in the Inmagic DB/Text for SQL 

Installation and Upgrade Instructions, as if you were doing a new installation (not an upgrade). 

We recommend that you accept the default installation folder (C:\Program 

Files\Inmagic\ICSWeb), to ensure that the SQL-based application is in a separate location 

from your existing non-SQL version. 
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About the Documentation 

For a list of the documentation available for DB/Text for SQL, please see its README file.  

You can access documentation via the Product Documentation link on the Customer Extranet page. 

Additionally, please check the Documentation subfolder of the installation folder for each installed 

component.  

Contacting Inmagic 

For help, you can contact Inmagic or your local Inmagic dealer.  

If you have a maintenance agreement, please have your customer ID ready, and try to be at your computer 

when you call. If that is not possible, note exactly what you were doing when you encountered the 

problem, the exact text of any error messages you received, and your software version number and serial 

number (use the  Help>About menu to look it up). If you do not have a maintenance agreement, you can 

contact Inmagic Customer Service to purchase one.  

Inmagic  

200 Unicorn Park Drive, Fourth Floor  

Woburn, MA 01801, U.S.A.  

Tel: 781-938-4444  or  800-229-8398  

Fax: 781-938-4446  

http://www.inmagic.com  

support@inmagic.com - Technical support questions  

CustomerSvc@inmagic.com - General company, product, and services questions  

sales@inmagic.com - Sales, product pricing, and custom solution questions  

wishlist@inmagic.com - Feature requests  

If your message is intended for a particular person at Inmagic (for example, a Technical Support 

representative who is expecting the message or files), please include the name of that person in the subject 

and in the message.  
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Using the Administration Program to Convert to the SQL 
Platform  

To convert existing textbases, menu screens, and Web components to the SQL platform, you will use the 

DB/Text for SQL Administration program (InmCSAdmin.EXE), as explained in this document.  

Note: For information about using the Administration program to perform tasks other than those detailed 

in this guide, please see the Inmagic DB/Text for SQL Administrator’s Guide and the online help.  

There are three main operations for moving to the DB/Text for SQL platform, each with its own 

command on the Manage Upgrades>Convert from DB/Text menu in the Administration program:  

 Textbases. This command starts a wizard that takes you through the conversion process. You can 

convert multiple textbases at once, as long as the textbases are in one folder. If they are not, you must 

run the wizard for each folder containing textbases.  

 Menu Screens. Convert menu screens so they can be opened on the SQL platform.  

 Web Components. You only need to use this command if you are using WebPublisher PRO. This 

command converts Web components (HTML query screens, INI files, script files, and so on) for use 

on the SQL platform.  

The following sections explain these operations. 
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Converting Textbases  

To convert your existing textbases for use on the SQL platform, follow the instructions below.  

Your new textbases will have the same names as your original textbases, but will have different 

extensions. For more information, see “What Will Be Different?” on page 18.  

Note: The wizard can convert multiple textbases at once, if they are in the same folder. If the textbases 

are in different folders, you must run the wizard (Manage Upgrades>Convert from 

DB/Text>Textbases) once for each folder containing textbases. 

To convert textbases  

1. On the machine where DB/TextWorks for SQL is installed, click the Windows Start button and 

choose Programs>Inmagic Applications>DBText for SQL>Administration (TW-SQL).  

2. Choose Manage Upgrades>Convert from DB/Text>Textbases. 

3. In the Select Textbases to Convert to DB/Text for SQL dialog box, do the following:  

a. Navigate to the folder containing the textbase(s) you plan to convert. You must have Full Control 

access to this folder.  

b. Select the textbase(s) you want to convert, and click Open.  

Note: If any of the textbases has a Master password, you will be prompted for it during the 

conversion process.  

4. The Convert Textbases from DB/Text: Selected Textbases dialog box lists the selected textbases. 

Review the list, then click Next.  
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5. In the Convert Textbases from DB/Text: Specify Location for Converted Textbases dialog box, 

use the Location field to specify the location for the converted textbases.  

Important! We strongly recommend that you place the converted textbases in the same folder as your 

existing non-SQL DB/TextWorks textbases. 

 Specifying the same location as your existing textbases: This is the default. The original files 

will not be overwritten, because the new files will have different extensions (for example, .TBA 

versus .CBA). Later, you can use the Manage Textbases>Delete Textbase command in the 

Administration window to delete the original textbases, when you are sure that your new 

textbases are up and running on the SQL platform. Putting the converted textbases in the same 

location ensures that file references within the textbases and menu screens remain valid. 

Examples of file references include image or document names, thesaurus links, linked textbase 

names, and textbase references in menu screens. 

 Specifying a different location: If you specify a different location and your textbases have image 

references that consist of just a filename, you will have to copy the image files to the new 

location or re-direct the references to the proper location. You may also need to adjust menu 

screens, as well as access to linked textbases, thesaurus textbases, and so on, after the conversion. 

After specifying a location, click Next.  
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6. If you are using Windows Authentication with your DB/Text for SQL application, the Convert 

Textbases from DB/Text: Determine When to Set Textbase Security dialog box opens. Select one 

of the following options, then click Next.  

 Specify textbase security settings now (applied to all selected textbases). Select this option if 

you want to set security for all of the converted textbases. You will not be able to give a particular 

user or group more access to one textbase than another. When you click Next, you will have the 

opportunity to specify security settings. 

 Specify textbase security settings later (individually for each textbase). If you select this 

option, no textbase security will be set on the converted textbases. After the conversion process is 

complete, before users can access the textbases, you must set security for each textbase by 

choosing Configure SQL Server>Manage Security>Assign User Rights to Textbase in the 

Administration program.  
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7. If you selected Specify textbase security settings now (applied to all selected textbases) in the 

previous step, the Convert Textbases from DB/Text: Add User Rights to Textbases dialog opens.  

 

Select security settings to apply to all of the textbases that will be converted:  

a. Click the Add User button to open the Add Database User dialog box and select a user who will 

be able to access the textbases from the Login Name drop-down list, then click OK.  

Note: The login you use to convert the textbases will not appear in the Add Database User dialog 

box because it is automatically a member of db_owner for all of the converted textbases. For 

other user names to be visible, the user/group must exist in the Windows domain (of which SQL 

Server is a member) and have a login on the SQL Server.  

b. In the Current Database Users list, select the user/group for which you want to set security.  

c. [Optional] If you want the selected user or group to be able to edit the structure of the textbases, 

check Member of db_owner under Properties. If you check this box or if the user/group has 

sysadmin rights, then the options in the next step will be disabled.  

d. Select a DB/Text for SQL role membership option to assign the selected user/group 

membership to the appropriate role. Note that a user/group can only be assigned one DB/Text for 

SQL role.  

 None. The user name does not have membership to any DB/Text for SQL role and cannot 

access any of the textbases.  

 DB/Text for SQL Reader. The user name has Read-Only access to the textbases. The user 

name has Select permission in SQL tables.  

 DB/Text for SQL Data Writer. The user name can search and modify record information 

(search for, add, edit, and/or delete records) but cannot modify validation and substitution 

lists.  



 

Converting to the Inmagic DB/Text for SQL Platform Page 11 

 

 DB/Text for SQL Textbase Writer. The user name can search and modify record 

information (search for, add, edit, and/or delete records) and update validation lists when 

overriding content validation (if the appropriate options are selected in the Edit Textbase 

Structure dialog box).  

e. Repeat the previous step for each user/group that should be allowed to access the textbases. 

f. Click Next. 

8. In the Convert Textbases from DB/Text: Specify Location for Textbase Backup Files dialog box, 

check or clear Automatically back up the selected textbases to specify whether you want the 

conversion process to automatically back up your existing DB/TextWorks textbases. If you check this 

box (the default), the Location box is enabled so that you can specify the path to the folder in which 

you want the textbase backup files to be placed.  

Important! We strongly recommend that you automatically back up the selected textbases.  

Click Next. 
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9. In the Convert Textbases from DB/Text: Specify Record Buffer and Temporary Files Location 

dialog box, enter the following information, then click Next:  

 Maximum records to buffer: Enter the maximum number of records you want prepared before 

loading them into the SQL Server database. This value represents a compromise between 

performance and resource consumption. Larger numbers often result in faster loads but tend to 

consume more disk space in the temporary file path. The default value is 30000.  

 Temp file path: Enter the path to a public folder on the network where you want to store 

temporary files needed for the load operation. This location must be accessible from both this 

computer and the SQL Server (using the UNC format \\server\share\...), and the SQL Server 

account must have Read/Write/Delete access to the folder.  

Note: The Temp file path option is enabled only if the SQL Server is on a machine other than 

the one you are currently using.  
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10. The Convert Textbases from DB/Text: Confirm Settings dialog box opens so that you can review 

the settings you specified for the conversion.  

After reviewing the information, click the Finish button to begin the conversion.  
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11. The Convert Textbases from DB/Text: Operation Status dialog box appears while the process 

completes. The progress bars and the Operation log show the status of the conversion process. This 

information (including whether any textbases did not convert correctly and why) is logged to the 

CSUpdates.LOG file, which is located in the same folder as your converted textbases. Review this 

information to ensure that all textbases were converted as expected, then click Close.  

Note: To cancel the process, click the Stop Convert Textbases Operation button that appears while 

the operation is running.  

  

Important! If your textbases are located in more than one folder, be sure to choose Manage 

Upgrades>Convert from DB/Text>Textbases and repeat the above steps for each different location. 

Your textbases are now ready for use on the DB/Text for SQL platform.  
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Converting Menu Screens  

Follow the instructions below to convert existing menu screens for use on the SQL platform.  

The conversion process redirects the textbase boxes on your menu screens to point to your new, converted 

textbases that have the same name but a different extension (that is, .CBA instead of .TBA). 

You can convert menu screens either before or after you convert textbases. However, the converted menu 

screens will not work until you have successfully converted the textbases to which they point.   

Important! If your converted textbases are not in the same location as your original DB/TextWorks 

textbases, the converted menu screens will not work properly. In this case, you must open your menu 

screens in the Menu Screen Designer and redirect any textbase boxes to point to the new locations of your 

textbases. For more information see, “My Converted Textbases are in a New Location” on page 19.  

To convert menu screens  

1. On the machine where DB/TextWorks for SQL is installed, click the Windows Start button and 

choose Programs>Inmagic Applications>DB/Text for SQL>Administration (TW-SQL).  

2. Choose Manage Upgrades>Convert from DB/Text>Menu Screens. 

3. Use the Select Menu Screens to Convert to DB/Text for SQL dialog box to select the menu 

screen(s) you want to convert. The menu screens must all be in the same folder.  

4. In the Convert Menu Screens from DB/Text: Confirm Settings dialog box, review the list of menu 

screens that will be converted, then click Finish to confirm the information and start the conversion.  

5. The Convert Menu Screens from DB/Text: Operation Status dialog box appears while the process 

completes. The progress bars and the Operation log show the status of the conversion process. This 

information (including whether any menu screens did not convert correctly and why) is logged to the 

CSUpdates.LOG file, which is located in the same folder as the menu screens. Before you close the 

dialog box, we recommend that you review this information to ensure that all of the conversions 

completed as expected.  

Note: To cancel the process, click the Stop Convert Menu Screens Operation button that appears while 

the operation is running.  

6. If you want to convert additional menu screens that are in a different folder, repeat this procedure for 

each folder that contains menu screens that you want to convert. 

You have now completed the menu screen conversion process. 
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Converting WebPublisher PRO Components 

If you are using the non-SQL version of the optional WebPublisher PRO application, you need to convert 

your existing Web screens, forms, and other Web-related files for use on the SQL platform.  

You can convert Web components and textbases in any order. However, you will not be able to use the 

Web components until the textbases have been converted (see “Converting Textbases” on page 7). 

WebPublisher PRO for SQL requires the use of a virtual directory named ics-wpd, which is mapped to 

the WebPublisher PRO for SQL installation folder (C:\Program Files\Inmagic\ICSWeb, by 

default). The ics-wpd virtual directory should already be created and have the appropriate access rights 

assigned, as described in the Inmagic DB/Text for SQL Installation and Upgrade Instructions.  

The conversion process copies your existing Web screens, forms, script files, and other Web-related files, 

converts them for use with the SQL platform (for example, it redirects Web query screens to the new 

virtual directory), then places them into the new installation folder structure. The original screens, forms, 

script files, and so on remain intact in their original locations. They are not overwritten. After your new 

system is up and running on the Web, you can delete the dbtw-wpd virtual directory structure and files.  

Important! The conversion process will only convert items that are located within the dbtw-wpd virtual 

directory structure (which is mapped to your WebPublisher PRO installation folder structure). If you keep 

your Web-related files outside of this folder structure, either copy them into the dbtw-wpd virtual 

directory for the duration of the conversion, or convert them manually. For details on how to do this, see 

“My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure” on page 19.  

To convert WebPublisher PRO components 

1. On the machine where WebPublisher PRO for SQL is installed, click the Windows Start button 

and choose Programs>Inmagic Applications>DB/Text for SQL>Administration (WP-SQL).  

2. Choose Manage Upgrades>Convert from DB/Text>Web Components to access the dialog 

box shown below. 

 

3. Use the Convert Web Components from DB/Text: Specify Virtual Directories dialog box to 
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specify the physical path to each virtual directory root. This is the folder to which that virtual 

directory is mapped. Based on your operating system, these paths may be read from Internet 

Information Services (IIS) and already appear. See the screen shot below. 

 In the Location of dbtw-wpd box, enter the path to the physical folder for the virtual 

directory root used with the non-SQL version of WebPublisher PRO. For example, if you 

accepted the default during installation, the physical path to the WebPublisher PRO virtual 

directory root (dbtw-wpd) is C:\Program Files\Inmagic\WebPubPRO. You can click 

the Browse button and navigate to this location.  

 In the Location of ics-wpd box, enter the path to the physical folder for the virtual directory 

root used with WebPublisher PRO for SQL. For example, if you accepted the default during 

installation, the physical path to the new virtual directory root (ics-wpd) is C:\Program 

Files\Inmagic\ICSWeb. You can click the Browse button and navigate to this location.  

Click Next. 

4. The Convert Web Components from DB/Text: Confirm Settings dialog box opens so that you 

can review the list of subfolders containing Web-related files that will be converted. When you 

are done reviewing the information, click Finish to start the conversion process.  

5. In the Convert Web Components from DB/Text: Operation Status dialog box, wait while the 

conversion completes. The Operation log shows the status of the conversion. This information 

(including whether any Web files did not convert correctly and why) is logged to the 

CSUpdates.LOG file in your user file path. We recommend you review this information to ensure 

that all of the files were converted as intended.  

Note: To cancel the process, click the Stop Convert Web Components Operation button that 

appears while the operation is running.  
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What Will Be Different?  

The following list describes the main changes that you will see after upgrading DB/TextWorks and 

WebPublisher PRO to the SQL platform.   

 There is a new Administration program with its own executable (InmCSAdmin.EXE).  

 There are fewer mandatory textbase files. These files, which reside outside of SQL Server, all have 

.CXX extensions (instead of .TXX extensions): 

 The .CBA file (formerly .TBA) contains public forms, query screens, sets, and skeletons. 

 The .CAC file (formerly .ACF) controls textbase access. 

 The .CBS file (formerly .DBS) contains the textbase structure definition. 

 User files have a .CBU extension instead of a .TBU extension.   

 Menu screen files have a .CBM extension instead of a .TBM extension. (The DBText.TBM file that is 

used by default if no other menu screen is specified is called InmCSrv.CBM.)  

 The records, indexes, and textbase lists (validation lists, record classes, and so on) are stored inside 

SQL Server. You cannot access these files using Windows Explorer.  

 If you are using Windows Authentication, you must apply security settings to the control database on 

the SQL Server and to each textbase. For more information about security, see the Inmagic DB/Text 

for SQL Administrator’s Guide.  

 The DBText.INI file is called InmCSrv.INI.  

 The deferred indexing feature is no longer necessary. Instead, a new Set Exclusive Textbase 

Access/Set Shared Textbase Access command lets you toggle between setting exclusive access and 

setting shared access.  

 Several commands on the Manage Textbases menu have moved to the Administration program. They 

are: Recover Textbase, Check Textbase, Copy Textbase, Rename Textbase, and Delete Textbase.  

 A new command appears on the Manage Textbases menu: Clear Textbase Record Locks. This 

clears the locks on any locked records (for example, locked records may occur if a power outage 

happens while records are being edited).  

 The following commands now use a fast load mechanism and permit you to specify buffer size:  

 In DB/TextWorks for SQL: Manage Textbases>Load New Textbase and File>Import (using the 

Express Import option).  

 In the Administration program: Manage Textbases>Recover Textbase, Manage Textbases>Load 

New Textbase, and Manage Upgrades>Convert from DB/Text>Textbases.  

 Express Import now requires exclusive textbase access.  

 The following are no longer available in the Options dialog box (Tools>Options):  

 Ignore accents on extended characters. To ignore accents for searches, set the SQL collation 

appropriately, either during the SQL Server installation or by using the SQLCollation parameter in 

the InmCSrv.INI file. For information about the SQLCollation parameter, see the online help.  

 Read/write extended characters in MS-DOS format. Extended characters are always written in 

Windows format.  

 If you installed WebPublisher PRO for SQL, your virtual directory is now called ics-wpd and the 

DBTWPub.INI file is now called ICSWeb.INI.  
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Manually Converting Menu Screens and Web Components  

This section is only for customers whose DB/TextWorks and/or WebPublisher PRO configurations do not 

meet the criteria needed to have their menu screens and Web components converted using the 

Administration window. Perform the applicable steps in this section if either of the following is true:  

 When converting your DB/TextWorks textbases, you used the Manage Upgrades>Convert from 

DB/Text>Textbases command in the Administration window, but did not put your converted 

textbases (with the new .CBA extension) in the same location as your original ones (with the .TBA 

extension).  

 You have WebPublisher PRO, and your Web screens, forms, script files, and so on are located in 

folders outside of the WebPublisher PRO installation folder.  

My Converted Textbases are in a New Location  

If you converted your DB/TextWorks textbases and placed the new textbases in a different location from 

the original textbases, you will not be able to properly convert menu screens using the Manage 

Upgrades>Convert from DB/Text>Menu Screens command.  

Instead, you must manually convert each menu screen that accesses these textbases.  

Menu screens used on the DB/TextWorks for SQL platform must have a .CBM extension. Your existing 

DB/TextWorks menu screens have a .TBM extension.  

Important! Before manually converting menu screens, you must have already converted the textbase(s) to 

which they point.  

To manually convert a menu screen  

1. Start DB/TextWorks for SQL.  

2. Choose Menu Screens>Design to open the Menu Screen Designer.  

3. In the Open Menu Screen dialog box, select Open an Existing Menu Screen File and click OK.  

4. In the Open Inmagic Menu Screen File dialog box, select DB/TextWorks Menu Screen Files 

(*.tbm) from the Files of type drop-down list.  

5. Select the .TBM file you want to convert, and click Open.  

6. For menu items that open a textbase, use the Textbase Box Properties dialog box to specify the 

converted textbase (which has the same name as the original textbase, but with a .CBA extension). 

You may also want to replicate any initial actions and/or initial elements.  

7. For menu items that open another menu screen, use the Menu Screen Box properties dialog box to 

specify the converted menu screen (which will have .CBM extension).  

8. Save the menu screen (choose Menu Operations>Save Menu Screen As). Specify the name and 

location for the menu screen file on the Save Inmagic Menu Screen File As dialog box, then click 

Save. The resulting file will have a .CBM extension 

My Web Screens/Forms are Located Outside the 
WebPublisher PRO Folder Structure  

If your existing WebPublisher PRO query screens and edit forms are located in folders outside of the 

WebPublisher PRO folder structure, you must manually convert them before you can use them on the 
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DB/TextWorks for SQL platform with WebPublisher PRO for SQL.  

This means that each Web query screen and edit form must be re-exported to HTML using your new 

software so that the appropriate files and virtual Web names are referenced.  

Note: Before you manually convert screens and forms, you should use Manage Upgrades>Convert 

from DB/Text>Web Components command to convert any other files that may reside within the 

WebPublisher PRO folder structure.  

To manually convert WebPublisher PRO query screens  

1. Start DB/TextWorks for SQL and open the textbase whose query screen you need to re-export.  

2. Choose Search>Design Query Screen.  

3. In the Open Query Screen dialog box, do the following:  

a. From the Start With list, select Existing Query Screen.  

b. From the Currently Saved list, select the Web query screen you want to convert.  

c. Click OK. The query screen opens in the Query Screen Designer.  

4. Choose Screen Operations>Export Query Screen to HTML.  

5. A message box asks if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click 

Yes to preserve box position; click No if you want the software to use simple HTML to lay out the 

screen (for example, all boxes will appear left-justified).  

6. In the Save File As dialog box, enter a name for the Web screen, then click Save.  

7. Click OK to dismiss the completion message.  

To manually convert WebPublisher PRO edit forms  

Note that only edit forms that were exported to HTML must be converted. All other forms are saved 

within the textbase.  

1. Start DB/TextWorks for SQL and open the textbase whose edit form you need to re-export to HTML.  

2. Choose Display>Design Form.  

3. In the Open Form dialog box, do the following:  

a. From the Start With list, select Existing Form.  

b. From the Currently Saved list, select the Web edit form you want to convert.  

c. Click OK. The form opens in the Form Designer.  

4. Choose Form Operations>Export Editing Form to HTML.  

5. A message asks if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click Yes to 

preserve box position when the edit form is displayed on the Web. Click No to have the software use 

simple HTML to place elements on the edit form (that is, boxes will be left-justified, box labels will 

appear on top rather than to the left, and so on).  

6. In the Save File As dialog box, enter a name for the Web edit form, then click Save.  

7. Click OK to dismiss the completion message.  
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Manually Converting Other Web-related Files  

Besides Web query screens and edit forms that are exported to HTML, there are other Web-related files 

that must be converted before you can use them on the DB/Text for SQL platform. Examples include 

XML applications, forms saved within textbases, and files that use canned searches within them.  

You only have to convert these files by hand if either of the following is true:  

 Your converted textbases are not in the same location as your original textbases. If this is the case, 

you must update the ICSWeb.INI file to include the path to the converted textbases.  

 The Web files in question (for example, XML applications) are not located within your existing 

WebPublisher PRO folder structure. If this is the case, use a text editor (such as Microsoft Notepad) 

to make the following text substitutions:  

DB/TextWorks  DB/TextWorks for SQL 

dbtw-wpd  ics-wpd  

DBTWPub.DLL  ICSWPPro.DLL  

DBTWPCGI  ICSPCGI  

iwpp-edit.ASP  icsw-edit.ASP  

jscript/dbtw-  jscript/ics-  

For example, replace instances of “DBTWPub.DLL” with “ICSWPPro.DLL”.  

Important! Check any raw HTML you may have added to reports you designed for Web use. (The easiest 

way to make this change in form definitions is to export all of them to a single file, delete them, use a text 

editor to make these changes globally, and re-import them.)  

You have now completed the conversion process. 

This is the last page in the document. 


