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Introduction 

Inmagic DB/Text for SQL is an enterprise-wide scalable content management system that combines a 

robust and flexible database management environment with high speed search and categorization. Its Web 

publishing capabilities provide the ability to publish, access, and maintain information on corporate 

intranets and the Internet.  

DB/Text for SQL uses Microsoft SQL Server as its data store. DB/Text for SQL makes extensive use of 

open standards and technologies, including Extensible Markup Language (XML), which forms the basis 

for much of its Web publishing functionality. 

Components 

Inmagic DB/Text for SQL (also called "DB/Text") consists of three components: 

 DB/TextWorks for SQL. This is the Windows desktop component. Throughout the rest of this 

document it will be referred to as "DB/TextWorks". 

 WebPublisher PRO for SQL. This component gives your organization the ability to publish 

textbases on the Web. Anyone with a Web browser can point to an HTML screen and submit a query. 

The results are returned dynamically, in forms that your organization can design. Your organization 

can also design an interface so users can add, edit, and delete records in a textbase via the Web. 

Throughout the rest of this document, this component will be referred to as "WebPublisher". 

 The Importer service ("Importer") is a Windows service that runs in the background to import files 

into a textbase. You can set up profiles for as many file types and textbases as you want. For example, 

you can import records, documents, PDF files, XML files, and so on.  

For more information about these features, see the DB/TextWorks online help. 

Another program is installed with both DB/TextWorks and WebPublisher. This program, which will be 

referred to in this document as the "Admin tool", is the primary subject of this document. 

Audience for this Document 

This guide is intended for the DB/Text for SQL Administrator ("Administrator"). It describes 

administrative and maintenance tasks that should be performed.  

The Administrator is the person who will perform the ongoing administrative and maintenance tasks 

necessary to make and keep the SQL Server for DB/Text up and running smoothly. Some of these tasks 

are performed using the Admin Tool.  

The Administrator’s responsibilities may include: 

 Installing and updating the software (this may include installing SQL Server or SQL Server Express, 

as well as the DB/Text software, and any other software required to maintain and administer SQL 

Server and DB/Text). 

 Performing data maintenance duties to monitor and optimize your SQL Server’s performance. 

 Performing routine data preservation duties (for example, backing up files, such as textbase files and 

their related files; and restoring files).  

 Setting up and monitoring security for your DB/Text system. 

The Administrator will find it useful to be familiar with the basic concepts for and how to use the 

DB/Text software. To do so, see the DB/TextWorks online help. For a list of the documentation available 

for the DB/Text for SQL product, see its README file. You received electronic copies of the 

documentation set when you installed the software. You will find them in the Documentation subfolder of 

the DB/TextWorks installation folder and, if applicable, the Documentation subfolder of the 
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WebPublisher installation folder. In addition, you can access the documentation set through the Inmagic 

Customer Extranet. 

Contacting Inmagic 

For help, you can contact Inmagic, Inc. or your local Inmagic dealer. If you have a maintenance 

agreement, please have your customer ID ready, and try to be at your computer when you call. If that is 

not possible, note exactly what you were doing when you encountered the problem, the exact text of any 

error messages you received, and your DB/Text for SQL version number and serial number (open 

DB/TextWorks and choose Help>About DB/TextWorks.) If you do not have a maintenance agreement, 

you can contact Inmagic Customer Service to purchase one. 

Inmagic, Inc. 

200 Unicorn Park Drive, Fourth Floor 

Woburn, MA 01801  U.S.A. 

Tel: 781-938-4444 or 800-229-8398 

Fax: 781-938-4446 

http://www.inmagic.com 

support@inmagic.com - technical support questions 

CustomerSvc@inmagic.com - general company, product, and services questions 

sales@inmagic.com - sales, product pricing, and custom solution questions 

wishlist@inmagic.com - feature requests 

If your message is intended for a particular person, such as a Technical Support representative, please 

include the name of that person in the subject and in the message. 
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Chapter 1: About Installing Software 

This chapter provides information that you should be aware of before you install an instance of Microsoft 

SQL Server or DB/Text for SQL. 

For a list of the system requirements for DB/Text for SQL, see the installation notes for the product. 

About Installing Microsoft SQL Server/SQL Server Express 

To install Microsoft SQL Server, see the installation instructions provided with that product.  

When installing SQL Server, be sure to address the following issues, as appropriate: 

 You can assign SQL Server a named instance, or use the default instance. To use the default instance 

of SQL Server on any machine, reference it by the machine name (the network name). Do not use 

―local‖. 

 Specify the appropriate authentication mode for security. 

 Use SQL Server and Windows Authentication. SQL authentication is the default 

authentication mode for DB/Text. It will not be available for use with DB/Text if it hasn't been 

enabled on the SQL Server instance. 

 Use Windows Authentication. If this is the only authentication mode available on the SQL 

Server instance, it will be the only authentication mode available for use with DB/Text. This may 

prohibit the use of WebPublisher on a public web site. For information on how to change 

authentication mode, see http://msdn.microsoft.com/en-us/library/ms188670.aspx. 

Once SQL Server is installed, be sure to address the following issues, as appropriate: 

 Ensure that the operating system and SQL Server engine are patched with the latest releases and 

upgrades from Microsoft Corporation. The most obvious way to do this is to use the automatic update 

tool provided by Microsoft. However, the DB/Text for SQL Administrator and other involved parties 

should determine ahead of time how your organization will handle SQL Server releases and upgrades 

as related to the DB/Text for SQL product. 

 Create a shared TEMP folder on the server machine and give the SQL Server Full access (that is, the 

ability to read, write, modify, and delete) to it. Inform your DB/Text for SQL users of this location, as 

it will be needed when a staff member tries to use the Express Import or Load New Textbase 

functions in DB/TextWorks. (The software asks where to put temporary files for the SQL Server 

BULK INSERT operation.) 

http://msdn.microsoft.com/en-us/library/ms188670.aspx


 

Page 4  Inmagic DB/Text for SQL Administrator's Guide 
 
 

About Installing DB/Text for SQL 

To install DB/Text for SQL, see the separate installation document that you received with it. 

Note the following about DB/Text for SQL: 

 After the software is installed, you must perform certain operations using the Admin tool 

(InmCSAdmin.EXE) before you can use the software. For more information, see ―Chapter 2: The 

Administration Program‖. 

 The account running the SQL Server service needs Full Control access to the following: 

 Temporary file path for SQL Server Bulk Insert (Express Import, Load New Textbase, and 

Recover Textbase). 

 Paths specified for backup file sets (Back Up Textbase and Restore Textbase). 

 The Administrator must ensure that any DB/Text for SQL releases and upgrades from Inmagic, Inc. 

are installed in a timely and efficient manner. The Administrator and other involved parties should 

determine how your organization will handle this matter.  

Important! If you are upgrading from the non-SQL version of DB/TextWorks to DB/Text for SQL, 

you must use the Admin tool to convert your textbases and menu screens. If you are upgrading from 

the non-SQL version of WebPublisher PRO to WebPublisher PRO for SQL, you can use the Admin 

tool to convert your Web screens, forms, and so forth. The conversion process is described in 

Converting  to the Inmagic DB/Text for SQL Platform, a PDF that was installed with your DB/Text 

for SQL software and is also available on the Inmagic Customer Extranet. 

 The Administrator must monitor SQL Server in relationship to DB/Text for SQL to ensure that 

DB/Text for SQL is running smoothly and efficiently. 

 To see how you can improve index browsing performance in DB/TextWorks, see ―Performance 

Enhancements for Index Browsing‖ on page 40. 
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Chapter 2: The Administration Program 

After you install DB/Text for SQL, you have access to the DB/Text for SQL Administration program 

(InmCSAdmin.EXE), also called the Admin tool in this document. 

The DB/Text for SQL Administrator uses this program to perform a number of administrative and 

maintenance tasks for the DB/Text for SQL system. These tasks—which are explained in the following 

chapters—can be for textbase management (for example, to copy, rename, delete, or move a textbase), as 

well as for backing up DB/Text for SQL textbases. 

The Admin tool also provides the Administrator with tools for other management activities. 

Why are there two DB/Text for SQL Administration programs? 

During installation, the Administration program is installed in both the DB/TextWorks installation folder 

and the WebPublisher Exec subfolder. These two instances are independent. Some tasks performed with 

the Administration program have to be done twice, specifically the Select SQL Instance command or the 

Change SQL Password command. These commands ensure that the software components 

(DB/TextWorks and WebPublisher) have consistent information about the SQL Server hosting the 

textbases.   

As part of the installation process, Setup opens the Administration window so the configuration needed to 

enable database connectivity is done, for example, selecting the SQL Server instance that will be used 

with DB/Text. This process is covered in the installation notes provided with your DB/Text for SQL 

product. 

How do I start the Administration program? 

 For DB/TextWorks, from the Windows Start menu, choose Programs>Inmagic 

Applications>DBText for SQL>Administration (TW-SQL). This shortcut only appears on the 

machine on which DB/TextWorks is installed. Note that you can also double-click 

InmCSAdmin.EXE located in the main DB/TextWorks installation folder. 

 For WebPublisher, from the Windows Start menu, choose Programs>Inmagic 

Applications>DBText for SQL>Administration (WP-SQL). You can also double-click 

InmCSAdmin.EXE located in the Exec subfolder of the main WebPublisher installation folder.  

When the Administration program is running, the title bar indicates whether the program was installed 

with DB/TextWorks or WebPublisher. 

What else should I know about the Administration program? 

The Administration program lets anyone who can start it have access to the functions it performs (for 

example, the ability to delete textbases). Note that some functions require administrator privileges, while 

others do not. Chapter 4 describes the security features of DB/Text for SQL. 

Because the Administrator may not want to make these functions available to the average user, we 

recommend the Administrator secure access to the executable (InmCSAdmin.EXE). 
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Chapter 3: Configuring the Software on SQL Server 

DB/Text for SQL uses SQL Server as its data store, requires a single SQL Server instance to be specified, 

and creates a control database called _InmTextbases. This is the database that tracks each textbase 

created by DB/TextWorks. 

During the DB/Text installation process, Setup will start the Administration program so this can be 

accomplished. 

This chapter explains how to change instances of SQL Server, how to create and upgrade a control 

database on the SQL Server, and how to upgrade textbases on the SQL Server. 

The most efficient way to configure the software on SQL Server the first time you have to do it is to use 

the Setup Wizard in the Administration program (InmCSAdmin.EXE). 

Important! You must have SQL Administrator privileges to be able to use the commands on these menus. 

The Configure SQL Server menu is used after you install the software for the first time, or later if you 

need to move your textbase files to a different SQL instance. Use this command: 

 Setup Wizard. Use this command to start a series of dialogs that take you through the necessary 

steps to connect to a new or different SQL instance. This command performs both functions described 

in the next two bullets. For more information, see ―Using the Setup Wizard‖ on page 7.  

OR, use these commands: 

 Select/Change SQL Instance. Use this command to specify the SQL Server instance that you want 

to use with DB/Text for SQL. For more information, see ―Specifying or Changing the SQL Server 

Instance‖ on page 9. 

 Create Control Database. Use this command to create the necessary databases and log in on your 

SQL Server. For more information, see ―Creating the Control Database‖ on page 7. 

The Manage Upgrades menu is used to perform updates after you receive an upgrade: 

 Upgrade DB/Text for SQL>Control Database. When you receive updates to the DB/Text for SQL 

software, and the upgrade notes specify that this is needed, use this command to update the control 

database and all existing DB/Text for SQL textbases to the latest version of the software. However, 

you have the option to only update the control database—you can use the Upgrade DB/Text for 

SQL>Textbases command (see the next bullet) to update your textbases later. For more information, 

see ―Upgrading the Control Database‖ on page 8. 

 Upgrade DB/Text for SQL>Textbases. If you choose not to upgrade your existing DB/Text for 

SQL textbases when you upgrade the control database (see the previous bullet), use this command to 

upgrade one or more textbases to the latest version of the software. For more information, see 

―Upgrading DB/Text for SQL Textbases‖ on page 8. 

 Upgrade DB/Text for SQL>Menu Screens. When you receive updates to the DB/Text for SQL 

software, use this command to update your existing menu screens to the latest version of the software.  

The Manage Upgrades menu is also used to convert your files from the non-SQL version of 

DB/TextWorks to DB/Text for SQL: 

 Convert from DB/Text>Textbases. Use this command to convert your textbases. 

 Convert from DB/Text>Menu Screens. Use this command to convert your menu screens. 

 Convert from DB/Text>Web Components. Use this command to convert your Web screens, forms, 

and so forth when you upgrade from WebPublisher PRO to WebPublisher PRO for SQL. 
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Note: For more information about upgrading from the non-SQL version of DB/TextWorks and 

WebPublisher PRO to DB/Text for SQL and WebPublisher PRO for SQL, see Converting to the Inmagic 

DB/Text for SQL Platform, a PDF that was installed with your DB/TextWorks for SQL software and is 

also available from the Inmagic Customer Extranet.   

Using the Setup Wizard 

During the installation of DB/TextWorks, you can use the Setup Wizard to select the SQL instance, 

assign user rights to that SQL instance, and create the control database for the DB/Text SQL instance. 

To use the Setup Wizard 

1. Select Configure SQL Server>Setup Wizard. 

2. On the Setup Wizard: Select SQL Instance dialog box, specify the SQL Server. You may be able to 

use the Browse button to choose from a list of available SQL Servers on your network. If Browse 

does not display the SQL Instance you want to use, enter the instance name manually. Then click 

Next. 

3. Depending on your situation: 

 If you are using Windows Authentication, on the Setup Wizard: Assign User Rights to SQL 

Server dialog box, assign user rights to the SQL Server. Then click Finish. 

 If you are using SQL Authentication, on the Setup Wizard: Change SQL Password dialog box, 

fill in the New password box. Then click Finish. 

4. Once you see the message ―DB/Text has been successfully configured on SQL Server <name of SQL 

instance>‖, the control database has been created. Click OK to dismiss the message.  

If you do not use the Setup Wizard, you will have to use the separate functions to accomplish what the 

Setup Wizard does: 

If using SQL Authentication: 

 Configure SQL Server>Initialize SQL Server>Select SQL Instance 

 Configure SQL Server>Initialize SQL Server>Create Control Database 

 Manage Security>Change SQL Password 

If using Windows Authentication: 

 Configure SQL Server>Initialize SQL Server>Select SQL Instance 

 Configure SQL Server>Initialize SQL Server>Create Control Database 

 Configure SQL Server>Manage Security>Assign User Rights to SQL Server  

Creating the Control Database 

If you need to change the SQL instance you are using for your textbases, first change the SQL instance, 

then use this command to create a control database (choose Configure SQL Server>Initialize SQL 

Server>Create Control Database) on your SQL Server. This will prepare the SQL Server for use with 

the DB/Text for SQL software. 

The Create Control Database command creates the following required items on the SQL Server: 

 The control database on the server, called _InmTextbases. This is the database that tracks each 

textbase created in DB/Text for SQL. 

 A database table to store IDs for each textbase. 
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 If you are using SQL Authentication, a SQL login name for the server, called 

_Inmagic_Content_Server. 

To create the control database on your SQL Server 

1. Choose Configure SQL Server>Initialize SQL Server>Create Control Database to start the 

creation process for the current SQL Server. 

2. When the control database has been created, click OK to dismiss the completion message. 

Upgrading the Control Database 

When you receive updates to the DB/Text for SQL software, you may be asked to update the control 

database and your existing textbase tables on your SQL Server.  

Note: If you are installing DB/Text for SQL for the first time, you run the Setup Wizard instead. This 

function will create the control database automatically. See ―Using the Setup Wizard‖ on page 7. 

To upgrade the control database and textbase tables 

1. Choose Manage Upgrades>Upgrade DB/Text for SQL>Control Database to start the upgrade 

process. 

2. A message asks if you also want to upgrade all textbases on the SQL Server. Depending on what you 

want to do, click one of the following buttons: 

 Yes to upgrade the textbases. During the process, the Operation Status dialog box opens and its 

Operation log and progress bars show the status of the upgrade. 

Note: If any of the textbases has passwords, you will be prompted for the Master password 

during the upgrade process. 

 No to not upgrade the textbases. Only the control database is upgraded on the SQL Server. When 

this process is complete, a message appears. Click OK to dismiss the message box. You can 

upgrade textbases later by using the Upgrade DB/Text for SQL>Textbases command. 

Upgrading DB/Text for SQL Textbases 

This step is needed only if the upgrade notes specified it was, and you did not upgrade your DB/Text for 

SQL textbases when you upgraded the control database on your SQL Server (as explained in the previous 

section). 

Some DB/Text for SQL upgrades require that the textbase tables in the SQL databases be up-to-date with 

the current version of the software. If a needed textbase upgrade is not performed, the textbase cannot be 

opened using the new version of the software. 

To upgrade a DB/Text for SQL textbase 

1. Choose Manage Upgrades>Upgrade DB/Text for SQL>Textbases to open the Select DB/Text for 

SQL Textbase dialog box. 

2. Navigate the Look in drop-down list to the folder containing the textbase(s) you plan to update. You 

must have Full Control access to this folder. 

Note: If you plan to upgrade multiple textbases and they are not in the same folder, you must choose 

Manage Upgrades>Upgrade DB/Text for SQL>Textbases on the Administration window for each 

folder containing the textbases. 

3. Select the textbase(s) you want, then click Open. 
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Note: If any of the textbases has a password, you will be prompted for the Master password during 

the upgrade process. 

 The Confirm Update Settings dialog box opens so you can review the textbases that will be 

upgraded and then click Finish to start the process. During the upgrade, the Operation Status 

dialog box opens and its Operation log and progress bars show the status. 

Specifying or Changing the SQL Server Instance 

Use the Select SQL Instance command to specify the SQL Server instance you want to use with 

DB/Text for SQL when you first install the software. Note: This is not recommended, as the Setup 

Wizard will guide you through the appropriate steps, including this one. 

Use the Change SQL Instance command if you need to move your textbases to a different SQL instance. 

(If you have already specified a SQL instance, the Select SQL Instance menu command changes to 

Change SQL Instance.) 

Important! When you change to a different SQL Server, you will not be able to access textbases on the 

previous SQL Server. If you need to move textbases to the new server, first back them up to a folder 

OTHER THAN the one containing their non-SQL files (having extensions CBA, CAC, etc.), delete them 

from the original SQL server, THEN change the SQL instance using this command, and restore them to 

the new server. 

To specify a SQL Server instance 

1. Choose Configure SQL Server>Initialize SQL Server>Select SQL Instance. 

2. Use the Browse button to select the SQL Server instance. If you must enter it manually, use one of 

the following formats: 

 IP address followed by a comma and the port number on the SQL Server. 

Example: 192.168.0.199,1783 

Note: If you do not include a port number, the default port (1433) is used. 

 Server name. 

Example: SQLDATA 

This will connect to the default instance of SQL Server on the named server. 

Tip! If you are running the Administration program from the same machine on which SQL Server 

resides, you can type a period ―.‖ in the SQL Instance box to automatically enter the default SQL 

instance. 

If you are using a version of SQL Server Express, , you may need to append \SQLEXPRESS 

(unless you installed the SQL Express instance independently, with a different instance name).  

 Server name followed by a backslash and the instance name. 

Example: SQLDATA\SQL254 

3. Click OK. 
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Chapter 4: Managing Security 

Security/access settings are specified through the Configure SQL Server>Manage Security menu in the 

Admin tool  

The Manage Security menu contains the following commands: 

 Change SQL Password. This command is only enabled if you are using SQL Authentication. This 

command lets you change the password assigned to the SQL Server account 

(_Inmagic_Content_Server). This account is created automatically during the installation of 

DB/TextWorks. For more information, see ―Changing the SQL Password‖ on page 11. 

 Assign User Rights to SQL Server. This command is only enabled if DB/Text for SQL is using 

Windows Authentication. This command lets you specify the users/groups that can use DB/Text to 

perform operations and whether they can modify the control database. For more information, see 

―Setting DB/Text for SQL Security on SQL Server‖ on page 14. 

 Assign User Rights to Textbase. This command is only enabled if DB/Text for SQL is using 

Windows Authentication. This command lets you specify the users/groups that can open a particular 

textbase and the level of access granted to each. For more information, see ―Setting DB/Text for SQL 

Security on a Textbase‖ on page 15. 

Note: For information about the additional security measures a textbase administrator can apply within a 

textbase (for example, using Master passwords, Field Access/Silent passwords, and record-level security), 

see the DB/TextWorks online help. 
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Using DB/Text with SQL Authentication 

When the control database is created on SQL Server Express, a SQL Server account 

(_Inmagic_Content_Server) is created automatically and a default password is assigned. This account 

controls access to all textbases. All DB/Text users are connected to the SQL databases using this account. 

Important! If you plan to use both DB/TextWorks and WebPublisher, you must first change this initial 

SQL password for each component by using the Change SQL Password command on the Manage 

Security menu for both DB/TextWorks and WebPublisher. You have to use the same password for 

DB/TextWorks and WebPublisher (You do not need to know the default password to change it.) 

Changing the SQL Password 

If you want to change the password assigned to the _Inmagic_Content_Server account, you must do so 

through the Change SQL Password dialog box (start the Admin tool, then choose Configure SQL 

Server>Manage Security>Change SQL Password) in both the DB/TextWorks and WebPublisher 

Administration programs. 

Caution! Changing the password with SQL Server management tools will make your textbases 

inaccessible, as the DB/Text components will still be trying to access SQL Server with the password they 

had previously set. 

To change a SQL Server password 

1. Choose Configure SQL Server>Manage Security>Change SQL Password. 

2. Type a new password in the New password box and click OK. 

3. Confirm your new password and click OK. Your new password is in effect. 

If you change the SQL Server password and you have WebPublisher, you must also run the 

Administration program from where you installed WebPublisher and specify the same SQL password. 

Choose Programs>Inmagic Applications>DB/Text for SQL>Administration (WP-SQL). These 

activities ensure that DB/TextWorks, WebPublisher, and SQL Server remain synchronized. For the new 

password to take effect, you must restart your World Wide Web Publishing Service. 
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Using DB/Text with Windows Authentication 

Windows Authentication helps you protect DB/Text from unauthorized use by authenticating users based 

on their Windows user account. This is done by assigning user/group names to DB/Text for SQL role 

memberships. These roles determine whether a user can access DB/Text and, if so, what operations the 

user can perform. 

To use Windows Authentication with DB/Text, the Administrator must perform several tasks—some 

using SQL Server management tools and others using the Admin tool (specifically, the Configure SQL 

Server>Manage Security menu). 

To set up DB/Text security with Windows Authentication 

You must complete the following tasks before users can be authenticated when logging in to 

DB/TextWorks. 

1. Ensure that all users and/or groups exist in the Windows domain where SQL Server is a member. For 

more information, see your Windows documentation. 

2. On the SQL Server, use the SQL Server Management Studio provided with SQL Server 2005 or 

2008. These are typically accessible from the Start menu. Create SQL Server logins for each user or 

group that should be able to access DB/Text for SQL. For more information about creating SQL 

Server logins, see your Microsoft SQL Server documentation. 

3. Use the Admin tool to grant the login names specified in step 2 a DB/Text role membership for the 

SQL Server. This role determines whether the login name can use DB/Text to perform any operations 

and, if so, whether that login name can modify the control database (which is changed whenever a 

textbase is created or destroyed). To do this, choose Configure SQL Server>Manage 

Security>Assign User Rights to SQL Server. For more information, see ―Setting DB/Text for SQL 

Security on SQL Server‖ on page 14. 

4. Use the Admin tool to grant the database user names created in step 2 a DB/Text role membership for 

each textbase. The role you assign determines whether the user can access a particular textbase and 

the level of access that user has to it (for example, specify that a user can only search and view 

records, but not edit them). To do this, choose Configure SQL Server>Manage Security>Assign 

User Rights to Textbase. For more information, see ―Setting DB/Text for SQL Security on a 

Textbase‖ on page 15. 

5. For users/groups that require broader access than the DB/Text roles allow, grant them membership in 

additional SQL Server fixed server roles and SQL Server fixed database roles, as appropriate. These 

additional roles may be needed for non-admin users/groups that will be doing management activities, 

such as backing up DB/Text for SQL textbases and using Express Import. Note, however, that any 

user/group with sysadmin privileges does not need any role memberships to be able to have full 

access to the software. For more information, see ―Using SQL Server fixed roles‖ on page 13. 
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DB/Text for SQL roles 

Windows Authentication security relies on users having membership in roles. The roles determine which 

operations a user can perform. 

DB/Text for SQL comes with a defined set of roles for the SQL Server control database and for individual 

textbases. Role membership is assigned to users/groups through the Manage Security menu on the 

DB/Text for SQL Administration window (choose Configure SQL Server>Manage Security>Assign 

User Rights to SQL Server and Configure SQL Server>Manage Security>Assign User Rights to 

Textbase). 

Each role is detailed in the following sections:  

―To set or change security on the DB/Text for SQL control database‖ on page 14, and  

―To set or change security for a database user on a DB/Text for SQL textbase‖ on page 15. 

Each user should have one role for the SQL Server (that is, a role specifying whether they can modify the 

control database) and one role for each individual textbase. 

Important! Any user with sysadmin privileges or db_owner role membership does not need any 

DB/Text for SQL roles to be able to access any textbase. 

Using SQL Server fixed roles 

While the DB/Text for SQL roles are sufficient for most users, there may be some who require broader 

access to the software. To accommodate this, you can assign those users membership in specific SQL 

Server fixed server roles and SQL Server fixed database roles. 

Assigned using the SQL Server Enterprise Manager or SQL Server Management Studio, these roles allow 

you to expand the access that a particular user/group has to DB/Text for SQL and its textbases on the 

SQL Server.  

For information about how SQL Server fixed roles can affect a user’s privileges, see the tables and 

discussion on page 16.  

For information about using the SQL Server Enterprise Manager or SQL Server Management Studio, see 

your Microsoft SQL Server documentation. 

Adding a database user 

Once you have created a SQL Server login for each user/group you want to access DB/Text for SQL, you 

must add these login names as users for the individual databases (including the control database). 

Use the DB/Text for SQL Administration program to add users for the control database and the individual 

databases (textbases). 

1. From the Assign User Rights to SQL Server dialog box (for the control database) or from the Assign 

User Rights to Textbase dialog box (for a specific textbase), click the Add User button to open the 

Add Database User dialog box. 

2. Select a SQL Server login name from the Login Name drop-down list. 

Important! For login names other than the SQL 2005 default BUILTIN\Administrators login to 

appear in the Login Name drop-down list, the users/groups must exist in the Windows domain (of 

which SQL Server is a member) and have a login on the SQL Server. If the list is blank, all possible 

login names have already been added. If you are converting textbases from DB/TextWorks to the 

DB/Text for SQL platform (choose Manage Upgrades>Convert from DB/Text>Textbases), the 

login you use to perform the conversion will not appear in the Login Name drop-down list, as it is 

automatically a member of db_owner for all of the textbases being converted. 

3. [Optional] Type a user name in the User Name box. Note that if you specified a user name for this 

login in your domain or on the SQL Server, it will appear here automatically. 
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4. Click OK. Notice that on the applicable dialog box (Assign User Rights to SQL Server or Assign 

User Rights to Textbase) the User Name appears in the Current Database Users list. 

Tip! You can also use this dialog box to remove users from a SQL database (and, therefore, deny them 

access to the textbase). This will not remove the login(s) from the SQL Server. 

Setting DB/Text for SQL Security on SQL Server 

Before any user can use DB/Text for SQL, that user’s SQL Server login must be added as a user for the 

control database. The user name must also have a DB/Text for SQL role assigned. 

The DB/Text for SQL roles for SQL Server grant access to the SQL Server and the DB/Text for SQL 

control database. The control database (named _InmTextbases) is the SQL database that tracks all 

textbases created with DB/Text for SQL. It maps the names of the textbases you create to the SQL 

databases. Each textbase is assigned a SQL Server reference name (used internally by SQL Server only) 

in the format of _InmTB_1, _InmTB_2, and so forth. 

To specify security settings for the SQL Server and the DB/Text for SQL control database, use the Assign 

User Rights to SQL Server dialog box, accessible from the DB/Text for SQL Administration window. 

To set or change security on the DB/Text for SQL control database 

1. Choose Configure SQL Server>Manage Security>Assign User Rights to SQL Server. 

2. On the Assign User Rights to SQL Server dialog box, from the Current Database Users list, select the 

user name for which you want to set security. If the user name is not in the list, click the Add User 

button to locate and add the user name to the list. (Note that for a user name to be visible, the 

user/group must exist in the Windows domain [of which SQL Server is a member] and have a login 

on the SQL Server. To add a user or group to the SQL Server, use the management tools distributed 

with the Microsoft SQL Server software.) For more information about adding a database user, see 

―Adding a database user‖ on page 13. 

3. From the DB/Text for SQL role membership group, select an option to assign the user name 

membership in the appropriate DB/Text for SQL role. A user can only be assigned one DB/Text for 

SQL role.  

 None. The user name does not have membership in any DB/Text for SQL role and cannot access 

the SQL Server or the control database. This means the user name will not be able to use the 

DB/Text for SQL software.  

 DB/Text for SQL User. The user name has Read and Execute permission. This is required for 

any user you plan to let open any DB/Text for SQL textbase. 

 DB/Text for SQL Administrator. The user can perform all textbase management functions (for 

example, renaming and deleting a textbase). The user can also modify tables in the control 

database. We recommend this user also be a member of the SQL Server fixed server role of 

dbcreator, which enables textbase creation. 

Note: To set security for individual textbases, use the Assign User Rights to Textbase dialog box. For 

more information, see ―Setting DB/Text for SQL Security on a Textbase‖ on page 15. 

4. Click Apply. 

5. Repeat steps 2–4 for each user/group that you want to access DB/Text for SQL. 

6. Click Close. 
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Setting DB/Text for SQL Security on a Textbase 

Before users can open any DB/Text for SQL textbases, the DB/Text for SQL Administrator must add 

their SQL Server logins as users for each textbase to which the users should have access. Each user/group 

name must also be given role membership to determine the access they have to each textbase. 

To do this, use the Assign User Rights to Textbase dialog box, accessible from the Administration 

window. 

To set or change security for a database user on a DB/Text for SQL textbase 

1. Choose Configure SQL Server>Manage Security>Assign User Rights to Textbase. 

2. On the Select DB/Text for SQL Textbase dialog box, select the textbase on which you want to set 

security and click the Open button. If the textbase has passwords, you are prompted for the Master 

password. 

3. On the Assign User Rights to Textbase dialog box, from the Current Database Users list, select the 

user name for which you want to set security. If the user name is not listed, click the Add User button 

to locate and add the user name to the list. (Note that for a user name to be visible, the user/group 

must exist in the Windows domain [of which SQL Server is a member] and have a login on the SQL 

Server.) For more information about adding a database user, see ―Adding a database user‖ on 

page 13. 

4. [Optional] If you want the user or group with the user name selected in step 3 to be able to edit the 

structure of the DB/Text for SQL textbase, select the Member of db_owner check box from the 

Properties group. If you select this option, the user or group will automatically have DB/Text for 

SQL Textbase Writer role membership and the options in the next step will be disabled. (This is 

also true if the user has sysadmin privileges.) 

5. From the DB/Text for SQL role membership group, select an option to assign the user name 

membership in the appropriate DB/Text for SQL role. A user can only be assigned one DB/Text for 

SQL role. 

 None. The user name does not have any DB/Text for SQL role membership and cannot access the 

textbase. 

 DB/Text for SQL Reader. The user name has Read-only access to the textbase. The user name 

only has Select permission in SQL tables. 

 DB/Text for SQL Data Writer. The user name can search and modify record information (that 

is, search for, add, edit, and/or delete records), but cannot update validation and substitution lists. 

 DB/Text for SQL Textbase Writer. The user name can search and modify record information 

(search for, add, edit, and/or delete records) and modify validation lists when overriding 

validation, if the appropriate option is checked in Edit Textbase Structure. 

6. Click Apply. 

7. Repeat steps 3-6 for each user/group you want to access this textbase. 

8. Click Close. The Assign User Rights to Textbase dialog box closes, and the Select DB/Text for SQL 

Textbase dialog box opens so that you can select another textbase for which to specify security. If you 

do not want to specify security for another textbase, click Cancel on that dialog box. 
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Minimum Roles Required for DB/Text for SQL Functions 

This section lists the minimum permissions for specific DB/Text for SQL commands. It applies only if DB/Text 

for SQL is using Windows Authentication, not SQL Authentication. (With SQL Authentication, all DB/Text for 

SQL users are members of the fixed SQL Server roles bulkadmin and dbcreator. They may also have sysadmin 

privileges if they are administrators on the machines hosting the SQL instance.) 

DB/Text for SQL Functions 

Function TW for SQL Role Textbase Role 

Create a new textbase CSAdmin  

Edit a textbase structure CSUser db_owner 

Search a textbase CSUser  CSReader 

Edit textbase records CSUser  CSWriter 

Import records  CSUser CSWriter 

Import records using Express method Sysadmin see note (1) 

Edit lists (validation, substitution) CSUser  db_owner 

Update validation lists during edit/import CSUser CSTBWriter 

Administrator Tool Functions 

Function TW for SQL Role Textbase Role 

Configure SQL Server (all functions) Sysadmin  

Recover or Load textbase Sysadmin see note (1) 

Delete a textbase CSAdmin  

Clear record locks CSUser db_owner 

Back up a textbase CSUser db_owner (see note 2)  

Restore textbase, replacing current one from 

a local backup set (see note 3) 

CSAdmin  

Restore textbase, from a backup set created 

elsewhere (see note 4) 

Sysadmin  

Upgrade control database CSAdmin  

Upgrade CS menu screens CSUser  

Convert DB/Text textbases CSAdmin  

Convert DB/Text menu screens CSUser  

Convert DB/Text Web components CSUser  

Notes 

1. Instead of a sysadmin role, this function can be accomplished by a db_owner who has also been 

assigned to the SQL Server bulkadmin role. 

2. An alternative role to db_owner is the SQL Server role db_backupoperator.  

3. A local backup set is one that was created from the textbase being overwritten. Both the textbase 

being replaced and the one replacing it will have the same db_owner, so sysadmin privileges are not 

required. 

4. A backup set created elsewhere, or one that is not being used to replace an existing textbase, may 

need to have its owner changed to the person doing the restore. The ability to change a database 

owner requires sysadmin privileges. This is a SQL Server constraint. 
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Chapter 5: Managing Textbases 

The DB/Text for SQL Administrator can perform a number of administrative tasks for the DB/Text for 

SQL system through the Administration program. These include tasks related to textbase management, 

which are accessed through the Manage Textbases menu on the DB/Text for SQL Administration 

window. 

Keep in mind that data related to DB/Text for SQL resides both inside and outside SQL Server. The 

textbase files that reside outside SQL Server all have the same file name with different extensions. For 

example, a textbase called Sales uses files named SALES.CBA, SALES.CBS, SALES.CAC, and so forth. 

For more information about textbase files, see the DB/TextWorks online help. 

Note: Renaming, deleting, or moving textbases may affect Recordset scripts, menu screens, and Link 

fields. 

Copying, Renaming, and Deleting Textbases 

Use the following procedures to copy, rename, or delete a textbase. 

Note that you cannot copy or rename a textbase that is Read-only. 

Important! Never use Windows Explorer to simply delete, copy, or rename the external files. Deleting, 

copying or renaming the external files does not update the tables inside SQL Server, and can lead to 

orphan databases, multiple external files pointing to the same internal database, or erroneous List 

Textbases information. 

To copy a textbase 

The following steps can only be used to copy a textbase onto the same server. 

For instructions on how to copy a textbase between servers, see ―Example of When You May Use the 

Back Up Textbases Function for Purposes Other Than for a Backup‖ on page 30. 

Note that the copy operation requires exclusive access to a textbase (meaning no one else can have it 

open), and the Master password, if the textbase has passwords. 

When you copy a textbase, a new SQL Server database is created on the SQL Server and external 

textbase files are placed in the location specified in the New Textbase box on the Copy Textbase dialog 

box (see step 4, below). 

1. Make sure the textbase is not in use by anyone. 

2. Choose Manage Textbases>Copy Textbase to open the Copy Textbase dialog box. 

3. Type the full path and name of the textbase you want to copy in the Existing Textbase box, or click 

the Browse button and navigate to it. 
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4. Type the full path and name of the textbase you want to create in the New Textbase box, or click the 

Browse button to navigate to the location where you want to put the new textbase and specify its 

name. 

Note: The Copy Textbase command will not create a new folder for you. If you type the name of a 

folder that does not exist, a textbase by that name will be created. For example, if you type C:\ 

SALES, a textbase called SALES will be created. Also note that you cannot overwrite an existing 

textbase. 

 
 

5. Click OK, then respond to the confirmation prompts. 

If you gave the textbase a new name, and a user file of that name does not exist in your user file path, 

DB/Text for SQL copies your user file to a copy with the new name. 

Tip! The first time a user opens the textbase in its new location, he or she may see a message warning that 

the textbase is not where the user file expects it to be. It is safe to ignore this message (choose Yes to 

continue). 

To rename a textbase 

This operation requires exclusive access to a textbase (meaning no one else can have it open), and the 

Master password, if the textbase has passwords. 

1. Make sure the textbase is not in use by anyone. 

2. Choose Manage Textbases>Rename Textbase. 

3. Type the full path and name of the textbase you want to rename in the Existing Textbase box, or 

click the Browse button to navigate to it. For example, to rename a textbase called Old, type: 

C:\DIR\OLD. 

4. Type the new full path and name you want for the textbase in the New Textbase box, or click the 

Browse button to navigate to the location you want and specify its name. For example, to call the new 

textbase New and keep it in the same location, type: C:\DIR\NEW. 

5. Click OK, then respond to the confirmation prompts. 

6. If you renamed a secondary textbase (that is, a textbase that is accessed indirectly through a Link field 

in a primary textbase), open the primary textbase (the one that contains the Link field), and edit the 

textbase structure to redefine the link definition. 

Note: This command automatically renames the local textbase user file. If a textbase is on a network and 

is used by others, remind anyone else who uses the textbase and stores private elements in their user files 

to rename their corresponding user file, using Windows Explorer. User files are stored locally, so each 

user must rename his/her own user file.  
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To delete a textbase 

This operation requires exclusive access to a textbase (meaning no one else can have it open), and the 

Master password, if the textbase has passwords. It also requires the user to be a SQL administrator. 

1. Make sure the textbase is not in use by anyone. 

2. Choose Manage Textbases>Delete Textbase to open the Delete Textbase dialog box. 

3. Type the full path and name of the textbase you want to delete in the Textbase to Delete box, or click 

the Browse button to navigate to it. 

 
 

Note: If you have upgraded all of your textbases from the non-SQL version of DB/TextWorks to 

DB/Text for SQL, you can use this command to delete each of your old textbases (which have a .TBA 

extension). When you click the Browse button and navigate to the location of a textbase, select 

DB/TextWorks Textbases (*.tba) from the Files of type drop-down list, and select the textbase. 

4. Decide whether to delete the user file. User files contain locally stored forms, query screens, sets, and 

skeletons:  

 Select the Delete user file for this textbase check box if you want to delete the user file. 

Note: Selecting this check box also deletes the textbase .IDI and .TBS files. For more information 

about these files, see the DB/TextWorks online help. 

 Clear the Delete user file for this textbase check box to preserve the user file. (This is the 

default.) For example, if you just copied a textbase to a new location, and you are now deleting 

the old textbase, do not delete its user file. 

5. Click OK, then respond to the prompts. 

Moving a Textbase to a Different Drive 

Use the following procedure to move a textbase to a different drive. This operation requires exclusive 

access to a textbase (meaning no one else can have it open), and the Master password, if the textbase has 

passwords. Note: If you want to move a textbase to a different directory on the same drive, use Manage 

Textbases>Rename Textbase.  

To move a textbase to a different drive 

This operation only moves the external files to a different drive. To move a textbase to a different SQL 

Server, see ―Example of When You May Use the Back Up Textbases Function for Purposes Other Than 

for a Backup‖ on page 30. 

1. Copy the textbase to its new location, then delete the old textbase, following the procedures explained 

above. Do not delete the user file unless you have given the textbase a new name. 

2. If the textbase that you moved is a secondary textbase (that is, a textbase that is accessed indirectly 

through a Link field in a primary textbase), open the primary textbase (the one that contains the Link 

field), and redefine the link definition (by editing the textbase structure), so it points to the moved 

textbase. 

Tip! The first time a user opens the textbase in its new location, he or she may see a message warning that 

the textbase is not where the user file expects it to be. It is safe to ignore this message (choose Yes to 

continue). 
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Dumping and Loading Textbase Records 

Use the Dump Textbase function (Manage Textbases>Dump Textbase) to copy record information 

from all fields in all records in the primary textbase to a text file in Inmagic tagged format. Dump 

Textbase is typically used in conjunction with and before Load New Textbase. 

The Dump Textbase command also writes out the image annotation list at the end of the resulting .DMP 

file. 

Dumping a textbase backs up records, and you may want to use it as part of your regular maintenance 

routine. 

To dump textbase records to a file 

1. Make sure the textbase is not in use by anyone. 

2. Choose Manage Textbases>Dump Textbase to open the Dump DB/Text for SQL Textbase dialog 

box. 

3. Select the textbase containing the records you want to dump and click Open. If the textbase has 

passwords assigned, you are prompted for the Master password. The Specify Dump File dialog box 

opens. 

4. Specify a name (the default file extension is .DMP) and location for the file that will be created and 

click Save. 

Note: When loading a new textbase, the software looks for the extension .DMP by default. 

5. Click OK to dismiss the message indicating that the dump operation is complete. 

To load records into a new, empty textbase 

The Load New Textbase function (Manage Textbases>Load New Textbase) is intended primarily as a 

recovery mechanism, to be used on an empty textbase or in situations where you are sure records will not 

be duplicated. For example, if you have to recreate a textbase, you can use the Load New Textbase 

command to move all of the dumped or exported record information into the new, empty textbase. Load 

New Textbase is typically used in conjunction with and after Dump Textbase. 

Important! The Load New Textbase command does not check for matching records or validation. This 

operation may result in duplicate records when used on a textbase that already contains records. The 

Load New Textbase command and the Import command (File>Import) are two very different 

operations. Do not use them interchangeably. 

The Load New Textbase command automatically adds all of the records to the textbase without 

checking for matching records, validation, or strict fields. It assumes the file is in Inmagic tagged 

format, and uses Express Import and Exclusive Textbase Access, locking others out of the textbase during 

the load. Computed and Automatic fields are treated as text (that is, DB/Text for SQL does not change 

incoming values or create new values for Computed and Automatic fields). Rejected records are copied to 

an exception file, which has the same name and location as the dump file you loaded, with a file extension 

such as .X01, .X02, and so forth. 

1. Make sure the textbase is not in use by anyone. 

2. Choose Manage Textbases>Load New Textbase to open the Load DB/Text for SQL Textbase 

dialog box. 

3. Select a new, empty textbase and click Open. If the textbase has passwords, you are prompted for the 

Master password. 

4. On the Select Dump File dialog box, select a file to load. The software looks for files with the file 

extension .DMP, but you can specify a different extension, such as .TXT or .ASC. 



 

Inmagic DB/Text for SQL Administrator's Guide  Page 21 
 

5. Click Open to open the SQL Server Bulk Insert Options dialog box. 

6. Do the following: 

 In the Maximum records to buffer box, enter the maximum number of records you want 

DB/Text for SQL to prepare before loading them into the SQL Server database. When 

determining the number to use, consider the balance you want between performance and resource 

consumption. Larger numbers often result in faster loads, but tend to consume more disk space in 

the temporary file path. The default value is 30000. 

 Specify the location of your SQL Server by selecting the appropriate option button: 

 SQL Server is local (located on this computer). Select this option if your SQL Server is 

located on this computer. 

 SQL Server is remote (located on different computer). Select this option if your SQL 

Server is located on a computer other than the one you are using now. If you select this 

option, in the Temp file path box, enter the path to the public directory on the network in 

which you want to store temporary files needed for the load operation. Note that this location 

must be accessible from both this computer and the SQL Server (using the format 

\\server\share\...), and your account and the account used by the SQL Server service must 

have read/write/delete access to the directory. 

 Click OK to start the loading process. 

Recovering a Textbase 

Recovering a textbase involves dumping its contents to an ASCII file, making an empty copy of the 

textbase, and loading the ASCII file into the copied textbase. You can perform the necessary steps 

individually, or, if you have enough disk space, DB/Text for SQL can perform them for you. 

The Recover Textbase function is most often used when a textbase is damaged. 

You can use either the single-step recovery procedure or the multi-step recovery procedure. Note, 

however, that the single-step recovery procedure requires access to the DB/Text for SQL Administration 

program, as well as membership in a particular role (see page 16). 

To perform a Single-Step Recovery 

1. Make sure the textbase is not in use by anyone, including a service such as the Importer. 

2. Start the DB/Text for SQL Administration program (InmCSAdmin.EXE). 

3. Choose Manage Textbases>Recover Textbase, specify a textbase, and click Open. Note that you 

will need the Master password if the textbase has passwords. 

4. Click Yes on the confirmation message. 

5. On the SQL Server Bulk Insert Options dialog, specify the maximum number of records to buffer and 

the SQL Server location. If the SQL Server is not located on this machine, also specify the path to a 

shared folder on a network server that is read- and write-accessible from this machine as well as the 

SQL Server (using the format \\server\share\...). This folder will hold temporary files created during 

the operation. Click OK.  

6. When the operation finishes, click OK twice to dismiss the completion messages. Your old textbase 

will still exist, with a new backup name. (The second completion message tells you the new name.) 

To perform a Multi-Step Recovery 

Use the multi-step recovery procedure if: 
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 You do not have sufficient privileges to run the DB/Text for SQL Administration program 

(InmCSAdmin.EXE). If you do not, you will not be able to perform steps 4 and 5 below. However, 

you will have a new textbase that is accessible. 

 The damage is in the .CBA file (for example, a public form). You need to clear the Copy Public 

Textbase Elements check box when you create the new textbase. 

 You need to modify the structure before importing the records. 

 There is insufficient space available to perform the single-step recovery explained above. 

Once you have determined that you need to perform a multi-step recovery, do the following: 

1. If you have not already done so, export records from the damaged textbase using Manage 

Textbases>Dump Textbase. 

2. Use DB/TextWorks to create a new textbase by copying the structure of the damaged one. 

 Choose File>New Textbase. On the Specify New DB/Text for SQL Textbase dialog box, name 

the new textbase. You cannot use the same name as the existing damaged textbase, but you can 

rename the new textbase later. Click Save. 

 On the Create Textbase Structure dialog box, select the Copy an Existing Inmagic Structure 

option and click OK. Use the next dialog box to select the existing damaged textbase to use as the 

basis for the new textbase structure, then click Open. (When prompted, copy the user file, too.) 

Note: Instead of copying the structure of an existing textbase, you can create the new textbase 

structure from a textbase structure definition file (.CBB). For more information, see ―Creating the 

new textbase from a .CBB file,‖ next. 

 Follow the prompts to specify a Master password (if required) and to copy validation lists, 

passwords, textbase elements, and so forth. DB/TextWorks creates a new textbase. The textbase 

does not have any records in it. If you copied textbase elements, the textbase includes any forms, 

query screens, sets, and record skeletons that were saved in the textbase file. 

 Close the textbase by choosing File>Close. 

3. Load records into the new empty textbase. Choose Manage Textbases>Load New Textbase and 

load the dumped file from step 1 into the new empty textbase that you just created in step 2. You now 

have a new textbase, complete with records. For more specific details about loading a textbase, see 

―To load records into a new, empty textbase‖ on page 20. 

4. Delete the original damaged textbase files. Start the DB/Text for SQL Administration program and 

choose Manage Textbases>Delete Textbase. (Do not delete the user file.) Do not use Windows to 

delete the textbase files; this will not delete the SQL database. 

5. Rename the new textbase back to its original name by choosing Manage Textbases>Rename 

Textbase, if applicable. 

6. If you have stored sets in your textbase or user file, open the new textbase in DB/Text for SQL and 

choose Sets>Refresh Sets to rebuild the sets. If others use this textbase and have private sets, ask 

them to do the same. 

Note: Refresh Sets performs the search again; it does not retain any omissions specified using Omit 

Record. 

Creating the new textbase from a .CBB file 

Instead of copying the structure of an existing textbase (as described in the previous set of instructions), 

you can create the new textbase from a textbase structure definition file (.CBB extension). 
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Before doing this, export all of your public elements from the damaged textbase (choose 

Maintain>Manage Textbase Elements). Once your new textbase is created, you can import these public 

elements into the textbase. 

Perform the multi-step recovery process described above, but with the following exception: 

 In step 2, on the Create Textbase Structure dialog box, select Import Structure Definition File. 

Once the new textbase is created with a new name, it will automatically have a corresponding user file 

with the same name (<textbasename>.CBU). This user file will be empty. If you had any private 

elements, they are still located within the damaged textbase’s corresponding .CBU file. 

To recover your private elements (if any), do one of the following: 

 If you are able to rename textbases: Delete the damaged textbase and rename the new one with the 

name of the original, damaged textbase. The .CBU file containing your private elements still exists, 

and—because it now has the same name—is used with the new textbase. (The empty user file that 

was created with the new textbase will be unused and can be deleted using Windows Explorer.) 

 If you are not able to rename textbases: Copy the user file for the damaged textbase over the one 

for the new textbase so that the new .CBU file contains your private elements. 

Clearing Textbase Record Locks 

The Clear Textbase Record Locks command checks for records left locked when a user aborted or lost 

power or connection while editing a record. It unlocks any records found locked. This is safe because 

exclusive access to the textbase is required in order to use this function, guaranteeing that you are not 

clearing a lock held by another active user. 

If you do not clear locks, a user attempting to edit a locked record will be denied access because of a 

non-active lock that was not previously released.  

Non-active locks remain locked for 20 minutes, at which time the lock is automatically cleared. You can 

change the default 20-minute value by adding the RecordLockInterval= parameter to the [Advanced] 

section of the InmCSrv.INI file. Note that the time must be entered in milliseconds (meaning that the 

default is RecordLockInterval=1200000). 

Active locks remain locked indefinitely. For example, when a user is updating a record, it remains locked 

for as long as the record is open in the Edit window. 

This command is safe to run whether or not you have locked records. 

To unlock records in a textbase 

1. Close any textbase that is open. 

2. Choose Manage Textbases>Clear Textbase Record Locks. 

3. Select the textbase whose record locks you want to clear, then click Open. You must have exclusive 

access to the textbase. 

Note: If the textbase has a Master password, you will be prompted for it before the records can be 

unlocked. If you are using Windows Authentication, you must also have either sysadmin privileges 

or be a member of the SQL Server fixed database role of db_owner. 

4. If the textbase has any locks to clear, a confirmation message appears. Review the message, then click 

Yes to unlock the record(s). 

5. Click OK to dismiss the completion message. 
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Analyzing a Textbase 

The Analyze Textbase command analyzes each record in the specified textbase and generates a tabular 

report listing the following information about each field in the textbase: 

 Max Entries. The maximum number of entries in a single record. 

 Max Entry Length. The maximum length of a single entry. 

 Max Record Length. The maximum length of this field in a single record. 

To analyze a textbase 

1. If the textbase you want to analyze is open, close it by choosing File>Close. 

2. Choose Manage Textbases>Analyze Textbase. 

3. Use the Look in list to navigate to the folder where the textbase is located, select it, then click Open. 

4. If the textbase has passwords, you are prompted for the Master password. Type the password in the 

Password box, then click OK. You must use the Master password and have exclusive access to the 

textbase to analyze it. 

5. On the Specify Text File dialog box, do the following: 

 In the File name box, type a name for the report file to be generated. 

 Navigate the Save in drop-down list to the location where you want to save the report file. 

 Click the Save button. 

6. Wait while DB/Text for SQL analyzes the textbase. While the textbase is being analyzed, the Analyze 

Textbase Operation Status dialog box opens. 

Note: If you want to stop the process before it is completed, click the Stop Analyze Textbase 

Operation button. 

7. A completion message appears, detailing the number of records analyzed and the location of the 

resulting report file. Click OK to open the report file in Microsoft Notepad. 

If you want to view the report again later, use a text editor (for example, Microsoft Notepad) to open the 

report file, located in the folder you specified. 

Listing Textbases on the SQL Server 

The List Textbases command lists each textbase on the current SQL Server, its location, and its 

corresponding SQL database name. 

To display a list of textbases on a SQL server 

Choose Manage Textbases>List Textbases. The Textbase List window lists the textbases on your SQL 

Server. You can use the toolbar buttons on the Textbase List window to: 

 Find information in the list. Click the Find toolbar button to locate any text or numeric information 

in the list, such as a specific textbase, directory, or SQL Server database name. 

 Print the list. Click the Print toolbar button to print the list to a printer. 

 Save the list to a file. Click the Print toolbar button and select the option to print the list to a text file 

(.TXT). 
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Chapter 6: Backing Up DB/Text for SQL Files 

To protect your information against accidental loss or damage, be sure to back it up on a regular basis. If a 

textbase is of great importance to your organization, consider keeping copies of all files off-site. 

The DB/Text for SQL Administrator should know and do the following, or have procedures in place that 

get the necessary procedures done. If your organization has a database administrator who performs the 

backups of your organization’s SQL Servers and their data, the DB/Text for SQL Administrator should 

work with this person. If not, the DB/Text for SQL Administrator should have procedures in place to get 

these tasks done: 

 Identify a regular backup strategy that will protect the data produced by DB/Text for SQL that is 

located inside and outside SQL Server. Files required by DB/Text for SQL are stored both inside SQL 

Server (for example, DB/Text for SQL data files) and outside SQL Server (for example, textbase 

elements).  

 Identify an on-site and, if applicable, an off-site backup strategy, including who needs to do what on 

what schedule. 

 Identify what is to be backed up and how frequently. Backup frequency will be dictated by how often 

information changes, how difficult it would be to manually regenerate lost information, and the 

importance of the information to your organization. 

Illustration of Where DB/Text for SQL Files Reside 

The following illustration shows where DB/Text for SQL files reside. 
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DB/Text for SQL Files Outside SQL Server that Should be Backed Up 

This section lists the DB/Text for SQL files that reside outside SQL Server that should be backed up 

when necessary. As noted below, some can be backed up by the Back Up Textbases function provided in 

the DB/Text for SQL Administration program; others only by using Windows Explorer or some other 

backup software. 

Textbase Files (.CBS, .CBA, .CAC) 

Back up all your textbases on a regular basis. We recommend you use the Back Up Textbase function 

(choose Back Up & Restore>Back Up Textbases). 

Log Files (.LOG) 

Optional textbase log file; lists when changes were made to the textbase structure and records. In this 

way, a log file acts as an audit trail. To back up log files, we recommend you use the Back Up Textbases 

function (choose Back Up & Restore>Back Up Textbases). 

User-defined Initialization Files (.INI) 

Initialization (.INI) files are text files that a user can edit. 

DB/Text for SQL uses these initialization files: Inmagic.INI, InmCSrv.INI, and an optional 

<textbase>.INI file. 

WebPublisher uses the same .INI files as DB/TextWorks, plus an additional file called ICSWeb.INI. 

The Importer service uses these initialization files: ICSISrv.INI, InmCSrv.INI, and an optional 

<textbase>.INI file. 

To back up the <textbase>.INI file, we recommend you use the Back Up Textbases function (choose 

Back Up & Restore>Back Up Textbases). To back up the other initialization files, use Windows 

Explorer or other backup software. 

To learn more about the DB/Text for SQL-related INI files, see ―Chapter 10: Initialization Files‖ on 

page 41. 

Menu Screen Files (.CBM) 

Menu screen files have the extension .CBM and are located in the directory you specified when you 

created them. To print a description of a menu screen, open it in the Menu Screen Designer and choose 

Menu Operations>Print Definition. Use Windows Explorer or other backup software to back up .CBM 

files. 

Image Files and Annotation Files 

If your textbase records include references to image files (for example, .JPG, .TIF, .BMP files), back up 

these files as you would any file, using Windows Explorer or other backup software. If the images are 

annotated, back up the annotation files, too. Each annotated image may have its own annotation file 

(default extension .ANN) stored outside of the textbase. You supply the file name and location when you 

save the annotations. 

Do the same for any static images (for example, images used in picture boxes or logos) referenced in 

forms, query screens, or menu screens. 
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Textbase-Specific Help (.HLP) 

For each textbase, your organization can supply one compiled Windows Help file that describes any 

topics you want. For example, you can explain the purpose of a textbase and provide tips on how to 

search, edit, and generate useful reports. Textbase-specific help supplements, not replaces, the 

DB/TextWorks help. Users can continue to access the DB/TextWorks help in the usual ways. If you have 

created any textbase-specific help file, you should back it up when necessary (for example, after it has 

been created and when it gets updated) using Windows Explorer or other backup software. 

Textbase User Files (.CBU) 

User files contain private textbase elements (that is, forms, query screens, record skeletons, and sets) that 

are not stored in the textbase. Each user file has the same name as its textbase, with the extension .CBU. 

For example, a textbase called Sales has a user file called SALES.CBU. To see where your user files are 

stored, open any textbase and choose Display>Textbase Information. Use Windows Explorer or other 

backup software to back up your user files. You do not need to back up textbase user files if your users do 

not save private forms, sets, and so forth. 

Tip! You may want to consider backing up your entire user file directory. This will save private elements 

as well as persistent information, such as the last-used import settings. 

User-Specific File (.IDI) 

In DB/TextWorks, last-used settings (for example, window size and position, batch modification settings, 

import parameters, and so forth) for each textbase are stored in the textbase .IDI file. Backing up .IDI files 

is optional because the settings can easily be recreated the next time someone uses the software. Use 

Windows Explorer or other backup software to back up .IDI files. 

Other Files 

Your organization may have other files used with a textbase that should be backed up (for example, 

HTML files that open in the Application window). Use Windows Explorer or other backup software to 

back up these files. 
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Backup Methods 

Depending on your organization’s needs, you can back up your DB/Text for SQL files using any of the 

following methods: 

 DB/Text for SQL Administration program. Use the Back Up Textbases command on the DB/Text 

for SQL Administration window to back up your SQL Server database and several of the external 

files used by the system. This method allows you to restore your textbase to the point at which it was 

backed up. For more information, see ―Backing Up DB/Text for SQL Files with the Administration 

Program‖ on page 30. 

 SQL Server backup tools. Schedule a SQL Server maintenance plan to back up your SQL Server 

and its transaction log. You must manually back up the bulk of the external DB/Text for SQL files. 

This method allows you to restore your system to the point of failure. For more information, see 

―Backing Up DB/Text for SQL Files with SQL Server Backup Tools‖ on page 32. 

 Automated backup using Windows scheduled batch job. This method requires you have a backup 

server available to you. Use SQL Server backup tools to back up SQL Server and its transaction log 

(as described in the previous bullet), then have a Windows scheduled batch job move the .BAK files 

for the SQL Server and transaction log, as well as copies of your external DB/Text for SQL files, to 

your backup server. This method allows for synchronization between all data, both inside and outside 

of SQL Server. For more information, see ―Automating a Full Textbase Backup‖ on page 33. 
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The following table details where DB/Text for SQL data resides (inside or outside SQL Server) and 

whether the data is backed up by the Back Up Textbases function and/or SQL Server backup tools. 

 
 
Data 

Inside or 
Outside SQL 
Server? 

Backed up by 
Back Up 
Textbases 
Function? 

Backed up 
by SQL 
Server 
Backup 
Tools? 

Records Inside Yes Yes 

Indexes Inside Yes Yes 

Validation lists Inside Yes Yes 

Substitution lists Inside Yes Yes 

Image annotation list Inside Yes Yes 

Textbase structure (.CBS) Outside Yes No 

Textbase elements (.CBA) Outside Yes No 

Access control file (.CAC) Outside Yes No 

Textbase log files (.LOG) Outside Yes No 

User-defined initialization file 

(.INI): <textbase>.INI 

Outside Yes No 

Menu screen files (.CBM) Outside No No 

Image files (.JPG, .TIF, .BMP, 

etc.) 

Outside No No 

Image annotation files (.ANN) Outside No No 

Textbase-specific help file (.HLP) Outside No No 

User-defined initialization files 

(.INI): Inmagic.INI, InmCSrv.INI, 

ICSWeb.INI 

Outside No No 

Textbase user files (.CBU) Outside No No 

Other files (such as .HTM files 

that open in the Application 

window) 

Outside No No 
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Backing Up DB/Text for SQL Files with the Administration Program 

Use the Back Up Textbases function on the Inmagic DB/Text for SQL Administration window to back up 

one or more textbases in the same folder at a time. The Back Up Textbases function creates a backup file 

set for each textbase that contains data from both inside and outside SQL Server. 

Note that while all textbase-related data is backed up, other files that may be referenced by a textbase 

(such as images and document files) are not backed up by this function. You must manually back up these 

types of files. You must also synchronize the manually-created backup files with the corresponding 

textbase backup file set to ensure that if you do have to restore a backup, you have a truly complete 

backup. If you do not back up the files referred to by a textbase, when you restore the textbase your links 

to these files may not work. 

Backup Example  

Say you use the Back Up Textbases function on June 4, 2009 at 3 a.m. At the same time, you should back 

up the other files that are referenced by the backed up textbase (that is, any menu screen, images, and 

textbase-specific help file). Then you must mark the June 4 backup packages (one produced by the Back 

Up Textbases function and the other that you manually did for the files referenced by the textbase) so that 

you have a complete backup that you can use when necessary to restore the textbase and its referenced 

files for June 4. Note that unless you are restoring a textbase and its referenced files to the same locations, 

you will have to redirect references to any new, restored locations for them to work correctly. 

Example of When You May Use the Back Up Textbases Function for Purposes Other Than 

for a Backup 

You should use the Back Up Textbases and Restore Textbases functions in situations where you want to 

copy or move a textbase between SQL Servers. For example, if you are having trouble with a textbase and 

require assistance from Inmagic, Inc., you may have to send a copy of that textbase to an Inmagic support 

representative (for example, by copying all the files onto a CD). In this situation, you would use the Back 

Up Textbases command (not the Copy Textbase command). Using the Back Up Textbases command 

means that the support representative will be able to use the Restore Textbases command to load the 

textbase on his or her machine and be able to access it through his or her instance of SQL Server.  

To make a copy of a textbase on the same server, see ―Copying, Renaming, and Deleting Textbases‖ on 

page 17. 

Sample Backup Routine for Workgroup Configuration 

The following is a sample backup routine if you are using SQL Server Express as your SQL Server: 

1. Back up a textbase using the Back Up Textbases command in the DB/Text for SQL Administration 

program. 

2. Manually back up other related files using Windows Explorer. See the table on page 29 for a list of 

files not covered by the Back Up Textbases function. 

3. Synchronize these two backup file sets. For example, mark them with the date and time of the backup 

and store them together. 
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To back up a textbase with the Back Up Textbases function 

1. Start the DB/Text for SQL Administration program. 

2. Choose Back Up & Restore>Back Up Textbases to open the Back Up Textbase Options dialog box. 

3. In the Textbases box, type the location and name of the textbases to back up, or click the Browse 

button and navigate to them. If the machine from which you are running the Administration program 

is different from the one on which the SQL Server resides, you must use a Universal Naming 

Convention (UNC) file path. 

4. In the Backup path box, type the directory for the backup file set, or click the Browse button and 

navigate to it. The directory for the backup file set should be on the same machine as the SQL Server, 

or be a public directory to which the SQL Server has access on a shared network. If the machine from 

which you are running the Administration program is different from the one on which the SQL Server 

resides, you must use a Universal Naming Convention (UNC) file path. 

5. Select or clear the Shrink SQL Server database check box, depending on whether you want to 

shrink the database during the backup process. Shrinking the database will release unused space in the 

data files and help to prevent your log file from growing without limit. If selected, the free space in 

the data files after shrinking will be 10 percent. By default, this check box is selected. 

6. Click OK to back up the textbases. The Back Up Textbases: Operation Status dialog box opens and 

shows the progress of the backup operation. Click Close when the operation is complete. 

The backup creates a copy of all of the textbase files (.CAC, .CBA, .CBS, .INI, and .LOG) in the 

specified location. The Administration program copies all of the textbase records, indexes, and other 

information from SQL Server into a .DAT file. The backup file set is Read-only, so that the files are not 

accidentally modified or deleted. 

Any changes you make to the original textbase after the backup will not be reflected in the backup. If you 

need to restore the textbase from the backup, use the Restore Textbases command. 

To restore a backup file set using the Restore Textbases function 

Use the Restore Textbase command to restore one or more textbases backed up with the Back Up 

Textbases command. Using Restore Textbases, you can replace an existing textbase or create a new 

textbase from a backup. 

1. Start the DB/Text for SQL Administration program. 

2. Choose Back Up & Restore>Restore Textbases to open the Restore Textbase Options dialog box. 

3. Type the location and name of the textbase backup set(s), or click Browse to locate the backup set(s). 

The location for the backup file set(s) should be on the same machine as the SQL Server, or be a 

public directory to which the SQL Server has access on a shared network. If the machine from which 

you are running the Administration program is different from the one on which the SQL Server 

resides, you must use a Universal Naming Convention (UNC) file path. 

4. Type the location of the directory where the textbase(s) should be restored, or click Browse to select 

the location. Note that SQL Server needs Write access to the directory. If the machine from which 

you are running Administration program is different from the one on which the SQL Server resides, 

you must use a Universal Naming Convention (UNC) file path. 

5. The Restore Textbases: Operation Status dialog box shows the progress of the operation. Click Close 

when it is finished. 
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Backing Up DB/Text for SQL Files with SQL Server Backup Tools 

Note that your IT department, as its standard operating procedure, may back up the SQL Server databases 

related to DB/Text for SQL (in addition to other SQL Server databases your organization may have). That 

backup is not complete and cannot be used to restore DB/Text for SQL textbases. The SQL Server backup 

tools back up only those files that reside inside SQL Server. However, data for DB/Text for SQL 

textbases reside both inside and outside SQL Server. If your organization uses SQL Server backup tools, 

you must manually back up DB/Text for SQL files that reside outside SQL Server. 

Important! Your IT department should be sure to also schedule a regular backup of the transaction log. 

This allows you to restore your SQL Server to the point of failure. 

If you do not have IT support, and want to use an automated backup tool to ensure that backups are 

getting done on a regular basis, you may want to use a SQL backup tool such as Database Maintenance 

Plan Wizard. Once you set up the wizard with a core group of maintenance tasks, you put in place a 

mechanism to ensure that your SQL database is backed up regularly, is performing efficiently, and is 

checked for inconsistencies. The Database Maintenance Plan Wizard includes tasks that rebuild indexes, 

compress data files, back up the database and transaction log files, and so forth. 

Backup Example 

If you decide to use the SQL Server backup procedures you have in place in your organization, you must 

also back up the files that reside outside SQL Server, and be sure to keep the two backup packages 

synchronized. In other words, say your organization backs up the SQL Server files on May 14, 2009 at 

4 a.m. At the same time, you must back up the external DB/Text for SQL textbase files. Mark the 

DB/Text for SQL backup package as such so that later you can match it to the SQL Server backup for 

May 14, 2009 at 4 a.m. If you then have hard disk problems and both the internal and external files are 

not available (and the May 14
th
 backup was your last backup), you need to restore the SQL Server May 14 

backup package, as well as the DB/Text for SQL backup package of May 14. Note that unless you are 

restoring a textbase and its supporting files to the same location, you will have to manually redirect 

supporting files to their new, restored location for them to work correctly. 

To back up DB/Text for SQL data inside and outside SQL Server 

To back up DB/Text for SQL-related data inside SQL Server, use SQL Server backup tools. See your 

SQL Server documentation for details. 

In conjunction with the SQL Server backup, you should back up the files outside SQL Server, as listed in 

the table on page 29. You must keep the SQL Server backup package and the DB/Text for SQL backup 

package synchronized so that you have a complete backup file set that you can use when necessary to 

restore the textbase and its referenced files for the date involved. 

Sample Backup Routine for Standard Configuration 

The following is a sample backup routine if you are using SQL Server backup tools: 

1. Use SQL Server backup tools to back up DB/Text for SQL files that reside inside SQL Server. 

2. Use Windows Explorer to manually back up the DB/Text for SQL files that reside outside SQL 

Server. See the table on page 29 for a list of these files. 

3. Synchronize these two backup file sets. For example, mark them with the date and time of the backup 

and file them away together. 
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Automating a Full Textbase Backup 

To ensure that the backed up SQL database, transaction log, and external textbase files are automatically 

synchronized, you can automate the process. 

To do this, use a Windows scheduled batch job (with copy statements) to move these backup files off the 

database server machine and DB/Text for SQL machine. For example, if the transaction log is backed up 

every half hour, the Windows scheduled batch job should move the transaction log backup file to another 

machine on the network immediately following the process. The batch job should then make a copy of all 

textbase files located outside of the SQL Server and move them to the same location as the backed up 

transaction log. All backup files moved to this ―backup‖ machine should be moved off-site on a regular 

basis. 

For more information about Windows scheduled batch jobs, see your Windows documentation. 

Auxiliary Backup Method 

A textbase owner can use the backup method described below as an auxiliary backup method. This 

method is not recommended to be used as your organization’s regular way to back up your DB/Text for 

SQL textbase and its referenced files. Although this auxiliary backup method provides you with ways to 

back up important portions of DB/Text for SQL data, it does not cover everything. To do a complete 

backup of DB/Text for SQL data, see the backup methods described earlier in this chapter. 

The auxiliary backup method is manually accomplished and ASCII based. It provides a bit of flexibility 

in that it lets you recover specific data. For example, if a specific record was deleted, you can retrieve the 

record through a backup made from this backup method, as ASCII files can be used to regenerate partial 

or complete data. 

Task Explanation Backup Frequency 

Create a dump (.DMP) file for a 

textbase. 

The records for the textbase are 

dumped into an ASCII file. 

Daily 

Create a backup file (.CBB) of 

the textbase structure 

The textbase structure definition is 

put in an ASCII file. 

Anytime you change the 

textbase structure—must 

have exclusive access to the 

textbase 

Back up textbase elements 

(.XPF, .XPQ, .XPS, .XPK) 

Similar to the .CBA file backed up 

when you use the Back Up 

Textbases function. 

Periodically, as needed 

Back up validation and 

substitution lists. Use the Print 

to File option when you print a 

list. 

The list prints to an ASCII text file. Optional—exclusive access 

to a textbase not required 
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Chapter 7: Other Management Activities 

This chapter discusses other management activities that a DB/Text for SQL Administrator may want to 

do. 

The DB/Text for SQL Administrator should maintain manual or computer-based logs of activities that 

allow for the proper evaluation of the management of DB/Text for SQL. (Do not confuse these logs with 

the ones that are produced by DB/Text for SQL or your SQL Server.) These logs may include: 

 System Patch Log, to record when patches or software upgrades are performed for the SQL Server for 

DB/Text for SQL, as well as for DB/Text for SQL itself. 

 Maintenance Log for errors and problems. 

 System Backup Log for the regularly scheduled backups related to the SQL Server data for DB/Text 

for SQL and its external data. 

Keeping an Enhanced Log File of Textbase Activity 

Unless it has been turned off by the textbase designer, there is a log file that records changes to the 

textbase. The log file is saved in the same location as the textbase and has the same name, with the 

extension .LOG. 

If you want to enable enhanced logging (that is, you want to track the machine name and login name 

when a textbase is opened and when records are edited and/or locked), add the following to the 

<textbase>.INI file. 

[LogFile] 
Details=3  
 

The following list shows the values you can use with the Details parameter. 

0 - No enhanced logging 

1 - Logs when user opens or closes the textbase 

2 - Logs when user modifies records (and opens/closes the textbase) 

3 - Logs when user locks/unlocks record (and opens/closes the textbase or modifies records) 

The following example shows a log file section using Details=3:  

6/7/2009 9:52:53 AM: Textbase opened using slot 2 - Inmagic DB/Text for 

SQL(v12.00): LIBRARY:Harold 

6/7/2009 9:53:04 AM: Record 7460 locked - Inmagic DB/Text for SQL(v12.00): 

LIBRARY:Harold 

ID: 7529 

6/7/2009 9:53:49 AM: Record modified - Inmagic DB/Text for SQL(v12.00): 

LIBRARY:Harold 

ID: 7529 

6/7/2009 9:53:50 AM: Record 7460 unlocked - Inmagic C DB/Text for 

SQL(v12.00): LIBRARY:Harold 

ID: 7529 

Note: The record numbers in the locked/unlocked messages are the internal record numbers, not any 

number that appears in the textbase record. 
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Tracking Who has a Textbase Open 

When configuring DB/Text for SQL during Setup, you can specify that the machine name and login name 

be recorded each time a user opens a textbase. On the Track Textbase Access dialog box, select the Track 

who has textbase open check box. Each time a textbase is opened, the user’s information will be written 

to a line in the textbase .SLT file (providing that the user has Write access to the folder containing the 

textbase). At any time, you can look at the textbase .SLT file (open it with any text editor) to see who has 

the textbase open. 

The .SLT file has the same name and directory as the textbase. For example, a textbase named Catalog 

would have a CATALOG.SLT file. The line in the file shows the following information:  

<the slot in use>: <the program used to open the textbase> <the machine 
name>:<the user name>  

For example:  

Slot 2: Inmagic DB/Text for SQL LIBRARY:Harold  

When the user closes the textbase, the line in the .SLT file is cleared.  

Note: If someone turns off or reboots their computer while the textbase is open, the line in the .SLT file 

cannot be cleared. 

If you have already installed DB/TextWorks and did not specify this option, you can turn the feature on 

by adding the following to the <textbase>.INI file (to track for just that textbase) or InmCSrv.INI file (to 

track for all textbases). 

[Advanced] 
EnableSlotLog=1 

When this option is turned on, every time someone opens the textbase, the software writes to the textbase 

.SLT file. 

This option also affects WebPublisher and the Inmagic Importer service, assuming each has full rights to 

the .SLT file. For it to apply on the Web, you must modify the InmCSrv.INI located in the WebPublisher 

installation folder. The Importer service shares the InmCSrv.INI located in the DB/TextWorks installation 

folder. 
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Tracking SQL Server Errors 

You can specify that DB/Text for SQL should track SQL Server errors and write them to a dump file. The 

file lists any SQL errors encountered, with a date/time stamp and the textbase name. 

To do this, add the CSErrorDump=1 parameter to the [Advanced] section of the <textbase>.INI file (to 

track errors for a particular textbase) or the InmCSrv.INI file (to track errors for all textbases). Note that, 

if you add the option to the <textbase>.INI file, you must provide Write access to the textbase folder for 

both DB/TextWorks and for the account used by WebPublisher. If you add the parameter to the 

InmCSrv.INI file, modify the copy of InmCSrv.INI in the WebPublisher PRO for SQL installation folder 

to affect that product. 

[Advanced] 
CSErrorDump=1 

When used in the <textbase>.INI file, SQL Server errors are tracked for that particular textbase. The 

dump file (named <tbname>_CSErrors.DMP) is created in the textbase folder. 

Tip! We recommend you add it to the <textbase>.INI file so that all SQL Server errors from all 

workstations are tracked in one file. 

When used in the InmCSrv.INI file, the dump file (named CSErrors.DMP) is created in the user file path. 

For DB/TextWorks, the user file path is generally on the local hard drive of the workstation. For 

WebPublisher, the user file path is the QSets subfolder of the WebPublisher installation folder. 

Note that SQL Server errors are appended in the dump file. 
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Checking a Textbase for Problems 

Use the Check Textbase function to check a textbase or a user file and repair certain problems. Review 

the report file that the Check Textbase function produces. 

To check a textbase and optionally repair problems 

You can check a textbase to detect and repair problems in a textbase and user file. 

You must have exclusive access to the textbase before you can run the Check Textbase function. 

1. Start the DB/Text for SQL Administration program (InmCSAdmin.EXE). 

2. Choose Manage Textbases>Check Textbase. 

3. Specify a textbase to check and click Open. If the textbase has passwords, you must supply the 

Master password. 

4. Select what you want to do from the following options: 

 Repair Structural Problems. Select this check box if you want to fix problems in the textbase 

and user file. 

 Check User File Only. Select this check box if you want to check your user file only, without 

checking the textbase. Use this option if you are receiving error messages using a form, query 

screen, set, or record skeleton saved in your user file, and you do not have the time to also check 

the textbase. 

5. Specify a name and location in the Specify Problem Report File dialog box for the report file that will 

be created (default extension .CHK). 

6. After the check is done—if any problems were encountered—DB/Text for SQL displays the report 

file, which describes any problems found and suggests how to fix the problems. Perform the 

suggested repair activities and run Check Textbase again, to ensure the textbase is sound. 

7. If the report file lists serious errors that DB/Text for SQL could not fix, you may need to recover the 

damaged textbase. For instructions, see ―Recovering a Textbase‖ on page 21. 

For more information about the Check Textbase command, see the online help. 

To view a Check Textbase report file 

After you check a textbase, if there are errors, a window displays the results of the check. To see those 

results again at a later time, use the View Check Textbase Report File command. 

1. Choose Manage Textbases>View Check Textbase Report File. 

2. When prompted, type or select the name of the file that you want to view. The default extension for 

this type of file is .CHK. 

3. The Check Textbase report file includes recommendations at the bottom of the file.  

 If the report file lists problems, perform the necessary repairs and run Check Textbase again, to 

ensure that the textbase is sound. 

 If the report file lists serious errors that DB/Text for SQL could not fix, you may need to recover 

the textbase. For instructions, see ―Recovering a Textbase‖ on page 21. 
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Chapter 8: Database Maintenance 

To ensure proper performance and prevent data loss, the DB/Text for SQL Administrator must regularly 

maintain the SQL databases. Database maintenance includes the following tasks: 

 Updating information about data optimization. 

 Verifying the integrity of the data. 

 Performing backups of the database. 

 Creating reports and a maintenance history of the database. 

We recommend that the DB/Text for SQL Administrator use the Maintenance Plan support provided with 

Microsoft SQL Server to create an automated maintenance plan that runs on a schedule. For SQL Server 

2000, in the SQL Server Enterprise Manager, choose Tools>Database Maintenance Planner. For SQL 

Server 2005, in the SQL Server Management Studio, navigate to Management>Maintenance Plans. For 

detailed information about these functions, see your SQL Server documentation. 

The following list shows the major areas to consider when specifying a database maintenance plan.  

 Updating data optimization information. As data and index pages fill up, the updating of index 

statistics and rebuilding of indexes requires more time and pages can become fragmented. You can 

improve performance by either re-organizing data and index pages or updating statistics on a regular 

schedule. You can also automate the removal of empty database pages to compress data files. The 

schedule you specify should be daily or weekly, depending on the system usage and transaction 

amount. 

 Checking database integrity. Your maintenance plan can regularly check the allocation and 

structural integrity of all objects in a database. The schedule you specify should be daily or weekly. 

 Backing up databases. You can schedule a database and transaction log backup and specify how 

long to keep the backup files. For a production environment, a full database backup should be done 

daily or weekly, depending on the size of the database and system usage. Back up transaction logs 

between two full database backups. Depending on the transaction amount and fault tolerance, the 

transaction log can be backed up every 15 or 30 minutes, or every hour. 

 



 

Inmagic DB/Text for SQL Administrator's Guide  Page 39 
 

Chapter 9: DB/Text for SQL Performance Guidelines 

This chapter describes guidelines to help you improve and maximize the performance of your DB/Text 

for SQL system. There are several areas that impact the overall performance of DB/Text for SQL. Each is 

covered in this chapter. 

 System usage 

 Textbase size 

 Hardware specifications 

 DB/Text for SQL configuration 

 SQL Server database configuration 

System Usage 

System usage is directly related to the number of concurrent users and the transaction activities they 

perform. If many users are running activities at the same time, system resources are heavily taxed and 

overall system performance slows. 

The following DB/Text for SQL operations are known to consume large amounts of system resources: 

 Batch Modify 

 Import 

 Load New Textbase 

We recommend you perform these types of tasks during off-peak hours, if possible. 

Textbase Size 

DB/Text for SQL can support millions of records. However, obsolete textbase records should be purged 

regularly. 

Hardware Specifications 

The hardware used with your DB/Text for SQL system must meet the minimum system requirements 

outlined in the install notes document. For best performance, we recommend you use hardware with the 

most memory and speed available to you.  
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Performance Enhancements for Index Browsing 

The <textbase>.INI file settings detailed in this section will improve the performance of browsing indexes 

using DB/TextWorks.  

Scroll Bars 

The scroll bar on the Query Choices Browser (on the desktop) can affect performance; this is more 

pronounced the larger the index list. To improve performance we recommend you use the following 

textbase-specific setting to use imprecise but faster scroll bars: 

[LargeQueryLists] 
LargeListOption=3 

A value of 3 applies only to Term and Word indexes on Text and Code fields; all others continue to use 

the precise though slower scroll bar method. You can use a value of 4 to specify the faster scroll bars for 

all field types. (Values of 0, 1, and 2 are ignored.)  

Entry Hits 

By default, the Query Choices Browser (on the desktop) and Inmagic Choices Browser (on the Web) 

show how many hits there are for entries in the Choices List. For larger indexes, you may notice a 

negative impact on performance. If this is an issue for you, you can use the following textbase-specific 

setting to omit the number of hits per entry: 

[LargeQueryLists] 
LargeHitsOption=3 

A value of 3 applies only to Term and Word indexes on Text and Code fields. You can use a value of 4 to 

suppress hit counts for all field types. (Values of 0, 1, and 2 are ignored.) 

SQL Server Database Configuration 

Note: This section applies to DB/Text for SQL Standard edition only. 

We recommend that you specify the following Microsoft SQL Server configuration settings in the 

Database options group. For more information about configuration settings, see your Microsoft SQL 

Server documentation. 

 Auto Shrink. This option should be disabled. Shrinking a database can affect performance on a busy 

system due to data pages movement. We recommend you schedule a ―shrink database‖ operation as a 

batch job and run it during off-peak hours. 

 Recovery Model. This option is typically set to Full for a production environment that provides 

complete protection against media failure. However, to improve performance for large-scale Import 

or Load New Textbase operations, we recommend you set this option to Bulk-Logged while loading 

the data, then reset it to Full when done. Using Bulk-Logged during the operation provides 

protection against media failure, while still allowing for best system performance. 
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Chapter 10: Initialization Files 

Initialization (.INI) files are text files that a user can edit. These files provide you with greater control and 

flexibility over certain settings and let you customize aspects of the software. 

 DB/TextWorks uses the following initialization files: Inmagic.INI, InmCSrv.INI, and an optional 

<textbase>.INI file. 

 WebPublisher uses Inmagic.INI and <textbase>.INI (both of which are optional), plus additional 

required files called ICSWeb.INI and InmCSrv.INI. 

 The Importer service uses ICSISrv.INI, InmCSrv.INI, and an optional <textbase>.INI file. 

Inmagic.INI 

The INMAGIC.INI file includes personal customizations and option settings that affect the current user, 

such as the settings for the currently selected menu screen (.CBM file), and a setting that determines 

whether spaces are required around a Boolean or range symbol when searching. Entries are listed by 

section in the INI file. Some entries can be set using DB/TextWorks menu options, others by editing the 

INMAGIC.INI file (when DB/TextWorks is not open). 

This file is stored in each user’s user file path. For WebPublisher, it is in the installation folder. 

For more information, see the online help. 

InmCSrv.INI 

The InmCSrv.INI file contains information about the software configuration settings, such as the 

language(s) used for month and day names, and how the software interprets two-digit years. It contains 

the name of the SQL instance in use (very important). For DB/Text for SQL Standard, it is also where 

you can specify that DB/Text for SQL should use SQL Authentication (instead of Windows 

Authentication, the default). 

This file is located in the DB/TextWorks installation directory. For the settings in this file to apply to 

WebPublisher, you should modify the copy of the InmCSrv.INI file in the WebPublisher installation 

folder. 

For more information, see the online help. 

<TEXTBASE>.INI 

The <textbase>.INI file is an optional text file with the same name and location as the textbase. For 

example, a textbase named Loans can have a Loans.INI file. You can create or edit this file yourself using 

a text editor. The textbase.INI file is used with the Applications menu, Copy Special menu commands, 

and the Textbase-Specific Help menu command. It has several sections, including [SpecialVendor], 

which controls the Copy Special function, and [Help], which controls the Textbase-Specific Help 

function. 

The <textbase>.INI file is also where you should specify settings to improve index browsing 

performance. For more information about these performance-related settings, see ―Performance 

Enhancements for Index Browsing‖ on page 40. 

In addition, the <textbase>.INI file is where the XML match field information you specify in the textbase 

structure (choose Maintain>Edit Textbase Structure>XML Match Fields) is stored. 

For more information, see the online help. 

ICSWeb.INI 

The ICSWeb.INI file contains settings used only by WebPublisher, not shared with DB/TextWorks. It 

controls several settings, including where WebPublisher looks for textbase and image files, the maximum 

number of records displayed after a search, Americans with Disabilities Act (ADA) settings, WebSetMax 
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and WebCSSOpt settings, whether a New Search button appears on results pages, and whether expanded 

displays appear in a separate browser window. 

The ICSWeb.INI file is created and updated by the WebPublisher Setup program. It may also be updated 

by the software when a client submits a query (the textbase location may be written to the file). To make 

further changes, you can edit ICSWeb.INI directly using a text editor. 

For more information, see ―Publishing and Editing Textbases via the Web‖ in the DB/TextWorks online 

help. 
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