Upgrading to the Inmagic Content Server Platform
This documentation may be used only in accordance with the terms of the Inmagic license agreement.

WARRANTY

INMAGIC, INC. MAKES NO WARRANTY, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS. INMAGIC, INC. SHALL NOT BE LIABLE FOR ANY LOST PROFITS OR ANY OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES. IN PARTICULAR, INMAGIC, INC. SHALL HAVE NO LIABILITY FOR ANY DATA OR PROGRAMS STORED OR USED WITH THIS PRODUCT, INCLUDING THE COSTS OF RECOVERING SUCH PROGRAMS OR DATA.

U.S. GOVERNMENT: If Licensee is acquiring the software on behalf of any unit or agency of the U.S. Government, the following shall apply:

(a) For units of the Department of Defense: RESTRICTED RIGHTS LEGEND: Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data Clause at DFARS 252.227-7013. (b) For any other unit or agency: NOTICE - Notwithstanding any other lease or license agreement that may pertain to, or accompanying the delivery of, the computer software and accompanying documentation, the rights of the Government regarding its use, reproduction and disclosure are as set forth in Clause 52.227-19(c)(2) of the FAR.

Contractor/Manufacturer is Inmagic, Inc., 200 Unicorn Park Drive, Fourth Floor, Woburn, MA 01801, U.S.A.

Questions regarding any Inmagic product should be addressed to Inmagic, Inc., or your local authorized Inmagic dealer.

Inmagic, Inc.
200 Unicorn Park Drive
Fourth Floor
Woburn, MA 01801 U.S.A.
Telephone: 781-938-4444 or 800-229-8398
Fax: 781-938-4446
http://www.inmagic.com
# Contents

**Introduction** ........................................................................................................................... 1  
**Before You Begin** ................................................................................................................. 1  
**Getting Help** ........................................................................................................................ 2  
**Contacting Inmagic, Inc** ...................................................................................................... 3  

**Using the Administration Window to Upgrade to the Content Server Platform** ........... 5  
Updating Textbases ................................................................................................................. 5  
Updating Menu Screens ......................................................................................................... 9  
Updating WebPublisher PRO Components ......................................................................... 10  

**What Will Be Different?** .................................................................................................... 13  
Manually Updating Menu Screens and Web Components .................................................. 15  
My Updated Textbases are in a New Location ...................................................................... 15  
My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure ... 16  
Manually Updating other Web-related files ....................................................................... 17
Introduction

This document is intended for those who are moving from Inmagic® DB/TextWorks® and Inmagic DB/Text® WebPublisher PRO to Inmagic Content Server.

Content Server is made up of CS/TextWorks, the desktop component, and CS/WebPublisher PRO, the Web component. The Standard and Enterprise editions of Content Server include both components, while the Workgroup edition can be purchased with both or just the desktop component.

The instructions in this guide detail how to update your existing textbases, menu screens, and (if you have WebPublisher PRO) your Web screens, forms, and so forth for use on the Content Server platform.

Why must I update my textbases, menu screens, and Web files?

While Content Server maintains the familiar DB/TextWorks interface, it is powered by a different “back end.” Instead of using a proprietary file system as DB/TextWorks does, the Content Server product line uses Microsoft SQL Server 2000 as its data store. Microsoft SQL Server 2000 is an industry-standard database that enhances textbase integrity and provides transaction rollback ability.

Note: Content Server Workgroup only supports Microsoft SQL Server 2000 Desktop Engine (MSDE).

Because data is stored inside SQL Server, your existing textbases, menu screens, and Web screens, forms, and so forth must be updated for use with it.

Before You Begin

Note the following before you begin:

- **Back up existing textbases.** We strongly recommend that you back up all of your existing textbases prior to installing the upgrade. Even though the new software is being installed to a different installation folder than your existing software, having a complete backup is important in the event you experience a problem.

- **You must have CS/TextWorks and CS/WebPublisher PRO already installed.** By default, each component is installed to a different location than your existing DB/TextWorks and WebPublisher PRO software. We recommend you accept the default locations for each component’s installation folder (that is, C:\Program Files\Inmagic\Content Server for CS/TextWorks and C:\Program Files\Inmagic\ICSWEB for CS/WebPublisher PRO). For details about installing these components, see the *Inmagic Content Server Installation Notes*.

  **Note:** If you only have DB/TextWorks and are upgrading to the Workgroup configuration of CS/TextWorks only, ignore all references and instructions relating to WebPublisher PRO and CS/WebPublisher PRO.

- **Review the system requirements detailed in the installation notes booklet.** The most notable change is the Microsoft SQL Server 2000 requirement. Note that if you are upgrading to Content Server Workgroup, you must use the Microsoft SQL Server 2000 Desktop Engine (MSDE). You can install MSDE during the installation of CS/TextWorks (Workgroup edition).

- **If you have image annotations, copy ART32.DLL from your existing DB/TextWorks installation folder to your new CS/TextWorks installation folder.** You must do this if any of the textbases you plan to update contain image annotations.
Getting Help

In addition to this guide, Inmagic, Inc. provides the following resources:

- **Inmagic Content Server User’s Manual.** A user’s manual that covers CS/TextWorks and CS/WebPublisher PRO and is available as a PDF file, which is included with the installation of the software.

- **Online help.** The help file, which covers CS/TextWorks, CS/WebPublisher PRO, and the CS/Importer service, contains the most up-to-date information and includes more details than the Inmagic Content Server User’s Manual. To open the help file:
  - Start CS/TextWorks and press F1, or choose Help>Help Topics from the CS/TextWorks menu bar.

    For context-sensitive help, click the button on the CS/TextWorks toolbar, then click the menu command or toolbar button that you want to know about. Another useful feature is the Help on this Window button . Click the button and a help topic on specific tasks you can perform in that window appears.

  - Start CS/Importer and press the Help button.

- **README file.** This file tells you what is new with that particular version of the software; lists issues resolved from the previous release and any late-breaking information; and contains other important information. The README file is installed in the CS/TextWorks and CS/WebPublisher PRO installation folders. Open it using a Web browser.

- **Installation Notes.** This booklet, which comes with the software, explains how to install the software. It is also available as a PDF file.

- **Inmagic Content Server Administrator’s Guide.** This guide, available as a PDF file, describes ongoing administrative and maintenance tasks for the Content Server system that should be performed by the Content Server Administrator (for example, how to back up and restore a textbase). It is located on the Inmagic Web site at http://support.inmagic.com/web.

- **Knowledgebase and Web site.** Provides information via the Web. With the software open and a Web browser available:

  - To search for solutions to common problems, choose Help>Inmagic on the Web>Knowledgebase to go to the Inmagic Product Support knowledgebase.

  - To visit the Inmagic Web site, choose Help>Inmagic on the Web>Home Page or Help>Inmagic on the Web>Support Page.

- **Inmagic Web Products Input Schema.** This file contains information about each element you can submit in XML to CS/WebPublisher PRO. It is located on the Inmagic Web site at http://support.inmagic.com/web.

- **HTML help pages for CS/WebPublisher PRO.** These files provide help topics for the Web component. See the online help for descriptions of WEB_BEGIN.HTM, WEB_ICHOICES.HTM, WEB_MSG.HTM, and WEB_WW.HTM, which are in the HELP subfolder of the folder in which you installed CS/WebPublisher PRO.
Contacting Inmagic, Inc.

If you have tried all the resources listed on the previous page and you still need help, you can contact Inmagic, Inc. or your local Inmagic dealer.

If you have a Product Support contract, please have the number handy, and try to be at your computer when you call. If that is not possible, note exactly what you were doing when you encountered the problem, the text of any error messages you received, and your Content Server version and serial number (choose Help>About CS/TextWorks to look it up). If you do not have a Product Support contract, you can contact Inmagic Sales to purchase a support plan.

Inmagic, Inc.
200 Unicorn Park Drive, Fourth Floor
Woburn, MA 01801, U.S.A.
Tel: 781-938-4444 or 800-229-8398
Fax: 781-938-4446
http://www.inmagic.com

support@inmagic.com - product support questions
advantage@inmagic.com - for questions from current InmagicADVANTAGE customers
sales@inmagic.com - sales, product pricing, and custom solution questions
marketing@inmagic.com - marketing questions
partners@inmagic.com - new Business Partner inquiries
webmaster@inmagic.com - messages related to the Inmagic Web site
wishlist@inmagic.com - feature requests
inmagic@inmagic.com - other messages

If your message is intended for a particular person at Inmagic, Inc. (for example, a Product Support representative who is expecting the message or files), please include the name of that person in the subject and the message.

Communicating with Other Users

You can communicate directly with other users by participating in one or more Inmagic Web forums. To do so, go to the Inmagic Web site (http://www.inmagic.com) and from the Support menu, click Forums.
Using the Administration Window to Upgrade to the Content Server Platform

Before you can use the new software, you must update your existing textbases, menu screens, and—if you are publishing textbases on the Web with WebPublisher PRO—Web screens, forms, and so forth for use with the Content Server platform and its SQL Server back end.

Use the Content Server Administration window to perform these updates. This window, which is only accessible when using the Content Server Administration program, is used to perform a number of administrative and maintenance tasks relative to your new software. For details about administrative tasks other than those detailed in this guide, see the Inmagic Content Server Administrator’s Guide, located at http://support.inmagic.com/web, and the online help.

There are three operations you can perform to move to the Content Server platform, each with its own command on the Manage Upgrades menu in the Administration window:

- **Update Textbases.** Use this command to update textbases so that they can be opened on the Content Server platform. This command starts a wizard that takes you through the update process. You can update multiple textbases at once, as long as the textbases are in one folder. If they are not, you must run the wizard for each folder containing textbases. We strongly recommend you back up your existing textbases before updating them to the new version of the software.

  **Note:** This command also updates image annotation files by converting your existing annotation files in the image annotation list to a new format (which uses an .ANN extension by default) and then updating the image annotation list to match. Image annotation files must be converted to be viewed on the Content Server platform.

- **Update Menu Screens.** Use this command to update menu screens so that they can be opened on the Content Server platform.

- **Update Web Components.** Use this command to upgrade Web components (for example, HTML query screens, INI files, script files, and so forth) for use on the Content Server platform. You only need to use this command if you are upgrading from WebPublisher PRO.

### Updating Textbases

Before you can use your existing textbases, you must update them for use on the Content Server platform.

To easily update your textbases, we have provided a wizard (choose Manage Upgrades>Update Textbases in the Administration window) to take you through the update process. This process will also convert your image annotation files, if any, so that they can be viewed with your new software.

The wizard can update multiple textbases at once, as long as all of the textbases are in the same folder. If your textbases are in different folders, you must choose Manage Upgrades>Update Textbases for each folder containing textbases.

**Important!** When prompted for a location for your updated textbases, we strongly recommend that you place them in the same location as your DB/TextWorks textbases. They will not be overwritten. Later, you can use the Delete Textbase command in the Administration window to delete your DB/TextWorks textbases once you are confident that your new system is running properly.

Once updated, your new textbases will have the same names as your original DB/TextWorks textbases, but will have different extensions. For more information, see “What Will Be Different?” on page 13.
To update your existing textbases

1. If any of the textbases you plan to update contain image annotations, copy ART32.DLL from your DB/TextWorks installation folder to your CS/TextWorks installation folder (for example, C:\Program Files\Inmagic\Content Server, if you accepted the default location during installation).

2. Open the Administration window. From the machine on which CS/TextWorks is installed, click the Windows Start button and choose Programs>Inmagic Applications>Content Server>Administraton.

3. Choose Manage Upgrades>Update Textbases to open the Select Textbases to Update dialog box and do the following:
   a. From the Files of type drop-down list, ensure that DB/TextWorks Textbases (*.tba) is selected.
   b. Navigate the Look in drop-down list to the folder containing the textbase(s) you plan to update. You must have Full Control access to this folder.
      
      Note: If you plan to update multiple textbases and they are not in the same folder, you must choose Manage Upgrades>Update Textbases in the Content Server Administration window for each folder containing the textbases.
   c. Select the textbase(s) you want, then click Open.
      
      Note: If any of the textbases have a Master password, you will be prompted for it during the update process.

4. The Updating Textbases for the Content Server Platform dialog box opens to summarize the textbases you have selected. Review the list, then click Next to continue specifying settings for the update.

5. On the Specify Location for Updated Textbases dialog box, do the following:
   a. In the Output location group, in the Location box, enter the path to the folder in which you want to place the files required by the updated textbases. By default, this is the same location as your original DB/TextWorks textbases.
      
      Important! We strongly recommend that you place the updated textbase files in the same folder as your DB/TextWorks textbases. The original files will not be overwritten, as the new files will have different extensions (for example, .TBA versus .CBA). Putting the updated textbase files in the same location ensures that image references remain valid. If you specify a different location and you have image references that consist of just a filename in your textbases, you will have to copy the image files to the new location or re-direct the references to the proper location.

At a later date—once you are satisfied that your textbases are up and running on the Content Server platform—you can delete your original DB/TextWorks textbases using the Delete Textbase command in the Content Server Administration window.
b. In the SQL Server group, depending on the edition of Content Server you are upgrading to, do the following:

- **Content Server Workgroup.** If you are using this configuration, you are using MSDE and you do not have to specify an instance. The **Select SQL Instance** button is disabled and your MSDE instance name appears below it.

- **Content Server Standard.** Because this configuration supports only one SQL Server instance, the **Select SQL Instance** button is disabled and your currently selected Microsoft SQL Server instance name appears below it. If you want to use a different SQL Server with Content Server Standard, you must use the Administration window to change the SQL Server instance before you update textbases.

- **Content Server Enterprise.** This configuration supports the use of multiple SQL Server instances. Click the **Select SQL Instance** button to open the Select SQL Instance dialog box and specify the Microsoft SQL Server instance on which you want to create the updated textbases.

c. Click **Next**.

6. If you are upgrading to **Content Server Standard** or **Content Server Enterprise** and you are using Windows Authentication (the default), the Determine When to Set Textbase Security dialog box opens. Select one of the following options, then click **Next**.

   **Note:** You will not see this dialog box if you are upgrading to the Workgroup edition. This is because that configuration only supports SQL Authentication. Continue with step 8.

   - **Specify textbase security settings now (applied to all selected textbases).** If you select this option button, the Specify Textbase Security Settings for Textbases dialog box opens when you click **Next** so that you can set security. If you set security now, it will be applied to all of the textbases you are updating. You will not be able to give a particular user or group more access to one textbase than another.

   - **Specify textbase security settings later (individually for each textbase).** If you select this option button, no textbase security will be set on the textbases you are updating. After the update process is complete, before users can access the textbases, you must set security for each textbase by choosing **Manage Security>Set Security on Textbase** in the Administration window.

7. If you are upgrading to **Content Server Standard** or **Content Server Enterprise** and you selected the **Specify textbase security settings now (applied to all selected textbases)** option button in the previous step, the Specify Textbase Security Settings for Textbases dialog box opens so that you can set security. The security that you set on this dialog box applies to all of the textbases that are being updated. Do the following:

   a. Click the **Add User** button and locate and add the user(s) you want to be able to access the textbases.

   **Note:** The login you use to update the textbases will not appear on the Add Database User dialog box because it is automatically a member of **db_owner** for all of the textbases you are updating. For other user names to be visible, the user/group must exist in the Windows domain (of which SQL Server is a member) and have a login on the SQL Server.

   b. From the Current Database Users list, select the user/group for which you want to set security.

   c. [Optional] If you want the user or group with the user name selected in the previous step to be able to edit the structure of the textbases, select the **Member of db_owner** check box from the Properties group. If you select this check box or if the user/group has sysadmin rights, then the options in the next step will be disabled.
d. From the Content Server role membership group, select an option button to assign the selected user/group membership to the appropriate role. Note that a user/group can only be assigned one Content Server role.
   - **None.** The user name does not have membership to any Content Server role and cannot access any of the textbases.
   - **Content Server Reader.** The user name has Read-Only access to the textbases. The user name has Select permission in SQL tables.
   - **Content Server Data Writer.** The user name can search and modify record information (that is, search for, add, edit, and/or delete records), but cannot modify validation and substitution lists.
   - **Content Server Textbase Writer.** The user name can search and modify record information (that is, search for, add, edit, and/or delete records) and modify validation and substitution lists.

e. Repeat steps a–d for each user/group you want to access the textbases.

f. Click **Next**.

8. On the Specify Location for Textbase Backup Files dialog box, select or clear the **Automatically back up the selected textbases** check box to specify whether you want the update process to automatically back up your existing DB/TextWorks textbases during the update process. If you select this check box (the default), the **Location** box is enabled so that you can enter the path to the folder in which you want the textbase backup files to be placed.

   **Note:** We strongly recommend you use the automated backup feature during the update process, even if you backed up your textbases on your own prior to starting the update process.

9. On the Specify Record Buffer and Temporary Files Location dialog box, enter the following information, then click **Next**:

   - In the **Maximum records to buffer** box, enter the maximum number of records you want prepared before loading them into the SQL Server database. When determining the number you want to use, consider the balance you want between performance and resource consumption. Larger numbers often result in faster loads, but tend to consume more disk space in the temporary file path. The default value is 10000.

   - In the **Temp file path** box, enter the path to a public folder on the network in which you want to store temporary files needed for the load operation. This location must be accessible from both this computer and the SQL Server (using the UNC format \server\share\...), and the SQL Server account must have Read/Write/Delete access to the folder.

   **Note:** The Temporary files (remote SQL Server instance) group is only enabled if the SQL Server specified on the Specify Location for Updated Textbases dialog box in step 5 is on a machine other than the one you are currently using.
10. The Confirm Update Settings dialog box opens so that you can review the settings you specified for the update. The Summary section includes the following information:

- The folder containing the textbases to be updated and a list of the textbases.
- The folder in which you want the files required by the updated textbases placed and the MSDE or SQL Server 2000 instance on which you want the textbases to be located.
- The security settings that will be applied to all of the textbases. (This information will only appear if you are using Content Server Standard or Content Server Enterprise and you specified that you want security set during the update process.)
- The folder in which textbase backup files will be placed. (This information will only appear if you specified that the selected DB/TextWorks textbases be automatically backed up.)
- The maximum number of records to prepare before loading into the new, updated textbases.
- The temporary file path that will be used while the information from your original textbases is being loaded into the updated textbases.

When you are done reviewing the information, click the Finish button to begin the update.

**Note:** To cancel the update, click the Stop Update Textbases Operation button.

11. On the Operation Status dialog box, wait while the update completes. The progress bars and the Operation log show the status of the update. This information (including whether any textbases did not update correctly and why) is logged to CSUpdates.LOG, which is located in the same folder as your updated textbases. Review this information to ensure that all textbases updated as expected, then click Close.

Your textbases are now updated for use on the **Content Server** platform.

---

**Important!** If your textbases are located in more than one folder, be sure to choose Manage Upgrades>Update Textbases and repeat the previous set of steps for each different location.

---

## Updating Menu Screens

Before you can use your existing menu screens, you must update them for use with the **Content Server** platform.

To easily update your menu screens, we have provided a command (choose Manage Upgrades>Update Menu Screens in the Administration window) to take you through the update process. The update process redirects the textbase boxes on your menu screens to point to your new, updated textbases that have the same name, but a different extension (that is, .CBA instead of .TBA).

You can update your menu screens either before or after you update your textbases. However, the updated menu screens will not work until you have successfully updated the textbases to which they point.

**Important!** If your updated CS/TextWorks textbases are not in the same location as your DB/TextWorks textbases, the menu screens will not work properly after you update them using Manage Upgrades>Update Menu Screens. If this is the case, you must open your menu screens in the Menu Screen Designer and redirect any textbase boxes to point to the new locations of your textbases. For more information see, “My Updated Textbases are in a New Location” on page 15.
To update menu screens

1. Open the Administration window. From the machine on which CS/TextWorks is installed, click the Windows Start button and choose Programs>Inmagic Applications>Content Server>Administration.

2. Choose Manage Upgrades>Update Menu Screens to open the Select Menu Screens to Update dialog box. Do the following:
   a. From the Files of type drop-down list, ensure that DB/TextWorks Menu Screen Files (*.tbm) is selected.
   b. Navigate the Look in drop-down list to the folder containing the menu screen(s) you want to update.
   c. Select the menu screen(s) you want to update. The menu screens must all be in the same folder.
      
      Note: If you plan to update multiple menu screens and they are not in the same folder, you must choose Manage Upgrades>Update Menu Screens in the Administration window for each folder containing the menu screens.
   d. Click Open.

3. On the Confirm Update Settings dialog box, review the list of menu screens that will be updated, then click Finish to confirm the information and start the update.
   
   Note: To cancel the update, click the Stop Update Menu Screens Operation button.

4. On the Operation Status dialog box, wait while the update completes. The progress bars and the Operation log show the status of the update. This information (including whether any menu screens did not update correctly and why) is logged to CSUpdates.LOG, which is located in the same folder as the menu screens. We recommend you review this information to ensure that all of the updates completed as expected.

Updating WebPublisher PRO Components

If you have WebPublisher PRO, you must update your Web screens, forms, and so forth before you can use them on the Web with CS/WebPublisher PRO.

CS/WebPublisher PRO requires the use of a virtual directory named ics-wpd, which is mapped to your CS/WebPublisher PRO installation folder (for example, C:\PROGRAM FILES\INMAGIC\ICSWEB, if you accepted the default during the installation).

Note: The ics-wpd virtual directory should already be created and have the appropriate access rights assigned, as described in the Inmagic Content Server Installation Notes booklet.

To easily update your Web components, we have provided a command (choose Manage Upgrades>Update Web Components in the Administration window) to take you through the update process. The update process will make a copy of your existing Web screens, forms, script files and so forth, update them for use with the Content Server platform (for example, it redirects Web query screens to the new virtual directory), and then place them into the new installation folder structure, as appropriate.
Your original screens, forms, script files, and so forth will remain intact in their original locations. They will not be overwritten. Once your new system is up and running on the Web, you can delete the dbtw-wpd virtual directory structure and files.

**Important!** The update process only updates items that are located within the dbtw-wpd virtual directory structure (which is mapped to your WebPublisher PRO installation folder structure). If you keep your Web-related files outside of this folder structure, you must update them manually. For details on how to do this, see “My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure” on page 16.

Before you can use your updated Web components with CS/WebPublisher PRO, you must also update any textbases that are used on the Web for use with the Content Server platform. For more information, see “Updating Textbases” on page 5. You can update Web components and textbases in any order, although you will not be able to use your Web components until the textbases have been properly updated.

**To update WebPublisher PRO components**

1. Open the Administration window. On the machine on which CS/WebPublisher PRO is installed, open the EXEC subfolder of the CS/WebPublisher PRO installation folder (for example, \PROGRAM FILES\INMAGIC\ICSWEB, if you accepted the default during installation) and double-click INMCSADMIN.EXE.

2. Choose Manage Upgrades>Update Web Components to open the Specify Virtual Directories dialog box and specify the “physical” path to each virtual directory root. This is the folder to which that virtual directory is mapped. Depending on your operating system, these paths may be read from Internet Information Services (IIS) and already appear.

   – In the **Location of dbtw-wpd** box, enter the path to the physical folder for the virtual directory root used with WebPublisher PRO. For example, if you accepted the default during installation, the physical path to the WebPublisher PRO virtual directory root (ics-wpd) is \PROGRAM FILES\INMAGIC\WEBPUBPRO. You can click the **Browse** button and navigate to this location.

   – In the **Location of ics-wpd** box, enter the path to the physical folder for the virtual directory root used with CS/WebPublisher PRO. For example, if you accepted the default during installation, the physical path to the new virtual directory root (ics-wpd) is \PROGRAM FILES\INMAGIC\ICSWEB. You can click the **Browse** button and navigate to this location.

   Click **Next**.

3. The Confirm Update Settings dialog box opens so that you can review the list of subfolders containing Web-related files that will be updated. The Summary section includes the following information:

   – The locations of the dbtw-wpd and ics-wpd root folders.

   – The folders within the dbtw-wpd root folder that will have their contents copied, updated, and moved to the ics-wpd root folder.

   When you are done reviewing the information, click **Finish** to start the update process.

   **Note:** To cancel the update, click the **Stop Update Web Components Operation** button.

4. On the Operation Status dialog box, wait while the update completes. The progress bars and the Operation log show the status of the update. This information (including whether any Web files did not update correctly and why) is logged to CSUpdates.LOG in your user file path. We recommend you review this information to ensure that all of the updates completed as intended.
What Will Be Different?

When you upgrade to CS/TextWorks and CS/WebPublisher PRO, you will continue to see the familiar DB/TextWorks interface.

What is different, as explained earlier, is the new “back end” of the software, which is powered by Inmagic Content Server and uses SQL Server 2000 or MSDE (depending on your configuration) as its data store.

The following list details some of the changes you will see after upgrading to CS/TextWorks and CS/WebPublisher PRO.

- There is a new Administration window with its own executable (INMCSADMIN.EXE).
- Because the software now uses SQL Server/MSDE as its data store, there are fewer mandatory textbase files. These files, which reside outside of SQL Server/MSDE, all have .CXX extensions (instead of .TXX extensions):
  - The .CBA file (formerly the .TBA file) contains public forms, query screens, sets, and skeletons.
  - The .CAC file (formerly the .ACF file) controls textbase access.
  - The .CBS file (formerly the .DBS file) contains the textbase structure definition.
- User files now have a .CBU extension instead of a .TBU extension.
- Menu screen files now have a .CBM extension instead of a .TBM extension. (Because of this, the DBTEXT.TBM file that is used by default if no other menu screen is specified is now called INMCSRV.CBM.)
- The records, indexes, and textbase lists (validation lists, record classes, and so forth) are stored inside SQL Server/MSDE. You cannot access these files using Windows Explorer.
- If you are using the Enterprise or Standard editions of Content Server and you are using Windows Authentication (the default authentication mode), you must apply security settings to the control database on the SQL Server and to each textbase. For more information about security, see the Inmagic Content Server Administrator’s Guide, which is located at http://support.inmagic.com/web.
- The DBTEXT.INI file is now called INMCSRV.INI.
- Because of the benefits of SQL Server/MSDE, the deferred indexing feature is no longer necessary. Instead, a new Set Exclusive Textbase Access/Set Shared Textbase Access command lets you toggle between setting exclusive access and setting shared access.
- Several commands on the Manage Textbases menu have moved to the Administration window. They are: Recover Textbase, Check Textbase, Copy Textbase, Rename Textbase, and Delete textbase.
- A new command appears on the Manage Textbases menu: Clear Textbase Record Locks. This command clears the locks on any locked records (for example, locked records may occur if a power outage happens while records are being edited).
- The following commands now use a fast load mechanism and permit you to specify buffer size: Manage Textbases>Load New Textbase and File>Import (using the Express Import option).
- Express Import now requires Exclusive Textbase access.
• The **Import Document** command (choose **File>Import Document**) now only supports IFilters. It no longer supports the DB/Text® **Import Filter**. IFilter technology is installed with Microsoft Index Server, which comes with Microsoft Windows 2000/XP/2003 operating systems. Besides Microsoft, other vendors have created IFilters for their software products and make them available for download. For example, Adobe has an IFilter that lets you import its Portable Document Format (PDF) documents. For more information on IFilters, refer to the online help.

• The following are no longer available on the Options dialog box (choose **Tools>Options**):
  - **Ignore accents on extended characters.** To ignore accents for searches, use SQL Server tools.
  - **Read/write extended characters in MS-DOS format.** Extended characters are always written in Windows format.

• If you have **CS/WebPublisher PRO**, your virtual directory is now called ics-wpd and the DBTWPUB.INI file is now called ICSWEB.INI.

• If you use image annotations, you will notice the following differences:
  - Image annotation files will now have an .ANN extension by default instead of an .ART extension.
  - There are three new annotation objects: Filled Rectangle, Filled Ellipse, and Filled Polygon.
  - The way polylines are created has changed. You now create a polyline by using the Polygon object and not connecting the end point with the starting point, thus leaving the polygon open as a polyline. (Note that if you end the object within 3 pixels of the starting point, the polygon will be automatically connected.) Because of this, the Polyline object does not appear in the Annotation toolbox or on the Annotations menu.
  - The background color specified on the Annotation Properties dialog box (choose **Annotations>Annotation Properties**) affects the background of Sticky Note objects and Text objects (while in edit mode) only. Line objects (that is, lines, arrows, and unfilled rectangles, ellipses, and polygons) with a line style other than solid (applied in DB/TextWorks) may now have a background color applied when viewed on the **Content Server** platform. However, you cannot change the background color of these line objects.
  - The foreground color specified on the Annotation Properties dialog box (choose **Annotations>Annotation Properties**) is the color used to fill an object, for line color, and for text color. Because of this, the **Color** drop-down list on the Font dialog box (choose **Annotations>Annotation Properties**, then click the **Set Font** button) is not needed and has been removed.

  - The following are no longer supported or available:
    ◆ The ability to change the size and style of the arrowhead on an Arrow object.
    ◆ The ability to apply a fill pattern to an object.
    ◆ Sound annotations.
    ◆ The ability to rotate Text and Sticky Note objects.
    ◆ The ability to specify a border for annotation objects.
    ◆ The Strikeout and Underline options on the Font dialog box.
Manually Updating Menu Screens and Web Components

This section is only for those customers whose DB/TextWorks and/or WebPublisher PRO configurations do not meet the criteria needed to have their menu screens and Web components upgraded using the Administration window.

Perform the applicable steps in this section if either of the following is true:

- When updating your DB/TextWorks textbases, you used the **Update Textbases** command in the Administration window, but did not put your updated textbases (with the new .CBA extension) in the same location as your original ones (with the .TBA extension).

- You have *WebPublisher PRO* and your Web screens, forms, script files, and so forth are located in folders outside of the *WebPublisher PRO* installation folder.

My Updated Textbases are in a New Location

If you updated your DB/TextWorks textbases and placed the new textbases in a different location from the original textbases, you will not be able to properly update menu screens using the **Update Menu Screens** command.

Instead, you must manually update each menu screen that accesses these textbases.

Menu screens used on the *Content Server* platform must have a .CBM extension. Your existing DB/TextWorks menu screens have a .TBM extension.

**Important!** Before manually updating menu screens, you must have already updated the textbase(s) to which they point.

To manually update a menu screen

1. Start CS/TextWorks.
2. Choose **Menu Screens>Design** to open the Menu Screen Designer.
3. On the Open Menu Screen dialog box, select the **Open an Existing Menu Screen File** option button, and click **OK**.
4. On the Open Inmagic Menu Screen File dialog box, select *DB/TextWorks Menu Screen Files (*.tbm)* from the **Files of type** drop-down list.
5. Select the .TBM file you want to convert, and click **Open**.
6. For menu items that open a textbase, use the Textbase Box Properties dialog box to specify the updated textbase (which has the same name as the original textbase, but with a .CBA extension). You may also want to replicate any initial actions and/or initial elements.
7. For menu items that open another menu screen, use the Menu Screen Box properties dialog box to specify the updated menu screen (which will have .CBM extension).
8. Save the menu screen (choose **Menu Operations>Save Menu Screen As**). Specify the name and location for the menu screen file on the Save Inmagic Menu Screen File As dialog box, then click **Save**. The resulting file will have a .CBM extension.
My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure

If your existing WebPublisher PRO query screens and edit forms are located in folders outside of the WebPublisher PRO folder structure, you must manually update them before you can use them on the Content Server platform with CS/WebPublisher PRO.

This means that each Web query screen and edit form must be re-exported to HTML using your new software so that the appropriate files and virtual Web names are referenced.

**Note: Before you manually update screens and forms, you should use Update Web Components command to update any other files that may reside within the WebPublisher PRO folder structure.**

---

### To manually update WebPublisher PRO query screens

1. Start CS/TextWorks and open the textbase whose query screen you need to re-export.
2. Choose **Search>Design Query Screen**.
3. On the Open Query Screen dialog box, do the following:
   a. From the Start With list, select **Existing Query Screen**.
   b. From the Currently Saved list, select the Web query screen you want to update.
   c. Click **OK**. The query screen opens in the Query Screen Designer.
4. Choose **Screen Operations>Export Query Screen to HTML**.
5. A message box appears asking if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click **Yes** to preserve formatting (such as, box position); click **No** if you want the software to use simple HTML to format the screen (for example, all boxes will appear left-justified).
6. On the Save File As dialog box, enter a name for the Web screen, then click **Save**.
7. Click **OK** to dismiss the completion message.

### To manually update WebPublisher PRO edit forms

Note that only edit forms that were exported to HTML must be updated. (All other forms are saved within the textbase.)

1. Start CS/TextWorks and open the textbase whose edit form you need to re-export to HTML.
2. Choose **Display>Design Form**.
3. On the Open Form dialog box, do the following:
   a. From the Start With list, select **Existing Form**.
   b. From the Currently Saved list, select the Web edit form you want to update.
   c. Click **OK**. The form opens in the Form Designer.
4. Choose **Form Operations>Export Editing Form to HTML**.
5. A message appears asking if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click **Yes** to preserve formatting (for example, box position) when the edit form is displayed on the Web. Click **No** to have the software use simple HTML to place elements on the edit form (that is, boxes will be left-justified, box labels will appear on top rather than to the left, and so forth).
6. On the Save File As dialog box, enter a name for the Web edit form, then click **Save**.

---

Page 16 Upgrading to the Inmagic Content Server Platform
Manually Updating other Web-related files

Besides Web query screens and edit forms that are exported to HTML, there are other Web-related files that must be updated before you can use them on the Content Server platform (for example, XML applications, forms saved within textbases, files that use canned searches within them).

However, you only have to update these files by hand if either of the following is true:

- **Your updated textbases are not in the same location as your original textbases.** If this is the case, you must update the ICSWEB.INI file to include the path to the updated textbases.

- **The Web files in question (for example, XML applications) are not located within your existing WebPublisher PRO folder structure.** If this is the case, do the following:
  - Use a text editor (for example, Microsoft Notepad) to replace instances of DBTWPPUB.DLL with ICSWPPRO.DLL, and dbtw-wpd with ics-wpd.
  - If you are using CGI, replace DBTWPCGI.EXE with ICSPCGI.EXE.
  - Check any raw HTML you may have added to reports you designed for Web use. (The easiest way to make this change in form definitions is to export all of them to a single file, delete them, use a text editor to make these changes globally, and re-import them.)