Converting to the Inmagic

Content Server Platform

Copyright © 2007 by Inmagic, Inc. All rights reserved.

Inmagic®, the Inmagic logo, DB/Text®, DB/TextWorks®, BiblioTech®, and BiblioTech PRO® are registered trademarks, and Inmagic.net®, BibSpeed®, IntelliMagic®, and PowerPack® are trademarks of Inmagic, Inc.

Other brand and product names are trademarks or registered trademarks of their respective holders. Use of any other product name does not imply endorsement of that product by Inmagic, Inc.

The information in this document is subject to change without notice and should not be construed as a commitment by Inmagic, Inc., which assumes no responsibility for any errors that may appear in this document.

This documentation may be used only in accordance with the terms of the Inmagic license agreement.

WARRANTY

INMAGIC, INC. MAKES NO WARRANTY, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY AND FITNESS. INMAGIC, INC. SHALL NOT BE LIABLE FOR ANY LOST PROFITS OR ANY OTHER INCIDENTAL OR CONSEQUENTIAL DAMAGES. IN PARTICULAR, INMAGIC, INC. SHALL HAVE NO LIABILITY FOR ANY DATA OR PROGRAMS STORED OR USED WITH THIS PRODUCT, INCLUDING THE COSTS OF RECOVERING SUCH PROGRAMS OR DATA.

U.S. GOVERNMENT: If Licensee is acquiring the software on behalf of any unit or agency of the U.S. Government, the following shall apply:

(a) For units of the Department of Defense: RESTRICTED RIGHTS LEGEND: Use, duplication or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data Clause at DFARS 252.227-7013.  

(b) For any other unit or agency: NOTICE - Notwithstanding any other lease or license agreement that may pertain to, or accompanying the delivery of, the computer software and accompanying documentation, the rights of the Government regarding its use, reproduction and disclosure are as set forth in Clause 52.227-19(c)(2) of the FAR.

Contractor/Manufacturer is Inmagic, Inc., 200 Unicorn Park Drive, Fourth Floor, Woburn, MA 01801, U.S.A.

Questions regarding any Inmagic product should be addressed to Inmagic, Inc., or your local authorized Inmagic dealer.

Inmagic, Inc. 200 Unicorn Park Drive Fourth Floor Woburn, MA 01801 U.S.A. Telephone: 781-938-4444 or 800-229-8398 Fax: 781-938-4446 http://www.inmagic.com

0407
Contents

Introduction.........................................................................................................................................................1
Why You Must Convert Your Textbases, Menu Screens, and Web Files.........................................................1
Before You Begin................................................................................................................................................1
About Content Server Documentation..............................................................................................................2
Contacting Inmagic and Communicating with Other Users............................................................................2
Using the Administration Window to Convert to the Content Server Platform..............................................3
Converting Textbases........................................................................................................................................4
Converting Menu Screens..................................................................................................................................14
Converting WebPublisher PRO Components......................................................................................................17
What Will Be Different?.....................................................................................................................................21
Manually Converting Menu Screens and Web Components...............................................................................23
My Converted Textbases are in a New Location..............................................................................................23
My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure..............................24
Index.................................................................................................................................................................27
Introduction

This document is intended for our customers who are moving from Inmagic® DB/TextWorks® and Inmagic DB/Text® WebPublisher PRO to Inmagic Content Server.

The Content Server product is made up of CS/TextWorks, the desktop component, and CS/WebPublisher PRO, the Web component. Content Server Standard includes both components, while Content Server Workgroup can be purchased with both or just the desktop component.

The instructions in this guide detail how to convert your existing DB/TextWorks textbases and menu screens; and, if you have WebPublisher PRO, your Web screens, forms, and other Web-related files for use on the Content Server platform.

Why You Must Convert Your Textbases, Menu Screens, and Web Files

While the Content Server product maintains the familiar DB/TextWorks interface, it is powered by a different “back end.” Instead of using a proprietary file system as the DB/TextWorks product does, the Content Server product line uses Microsoft SQL Server as its data store. Microsoft SQL Server is an industry-standard database that enhances textbase integrity and provides transaction rollback ability.

Note: Content Server Workgroup only supports Microsoft SQL Server 2005 Express Edition (referred to as SQL Server Express throughout the rest of this document) or Microsoft SQL Server 2000 Desktop Engine (MSDE).

Because data is stored inside SQL Server, your existing textbases, menu screens; and Web screens, forms, and other Web-related files must be converted for use with it.

Before You Begin

Before you start the conversion process, do the following:

• **Back up your existing textbases.** We strongly recommend that you back up all of your existing textbases. Even though the new software is being installed to a different installation folder than your existing software, having a complete backup is important in the event you experience a problem.

• **Install CS/TextWorks and CS/WebPublisher PRO.** By default, each component is installed to a different location than your existing DB/TextWorks and WebPublisher PRO software. We recommend that you accept the default locations for each component’s installation folder (that is, C:\Program Files\Inmagic\Content Server for CS/TextWorks, and C:\Program Files\Inmagic\ICSWeb for CS/WebPublisher PRO). For details about installing these components, see the Inmagic Content Server Installation Notes.

  Note: If you only have DB/TextWorks and are upgrading to the Workgroup configuration of CS/TextWorks only, ignore all references and instructions relating to WebPublisher PRO and CS/WebPublisher PRO.

• **Copy the Art32.DLL file.** If you have image annotations and you are currently using DB/TextWorks version 7.01 or earlier, copy the Art32.DLL file from your existing DB/TextWorks installation folder to your new CS/TextWorks installation folder. You must do this if any of the textbases you plan to convert contain image annotations.

• **Review the system requirements detailed in the Content Server installation notes document.** The most notable change is the Microsoft SQL Server requirement. Note that if you are upgrading to Content Server Workgroup, you must use SQL Server Express or MSDE.
About Content Server Documentation

For a list of the documentation available for the Content Server product, see its README file. You received electronic copies of the Content Server documentation set when you installed each component. You will find them in the applicable Documentation subfolder of the installation folder for each installed component. In addition, you can access the available documentation sets through the Inmagic Customer Extranet at http://support.inmagic.com/downloads/extranet.html.

Contacting Inmagic and Communicating with Other Users

For help, you can contact Inmagic, Inc. or your local Inmagic dealer. You can also communicate with other Inmagic users.

If you have a maintenance agreement, please have your customer ID ready, and try to be at your computer when you call. If that is not possible, note exactly what you were doing when you encountered the problem, the exact text of any error messages you received, and your software version number and serial number (choose Help>About CS/TextWorks to look it up). If you do not have a maintenance agreement, you can contact Inmagic Customer Service to purchase one.

Inmagic, Inc. 200 Unicorn Park Drive, Fourth Floor Woburn, MA 01801, U.S.A. Tel: 781-938-4444 or 800-229-8398 Fax: 781-938-4446 http://www.inmagic.com

support@inmagic.com - technical support questions CustomerSvc@inmagic.com - general company, product, and services questions sales@inmagic.com - sales, product pricing, and custom solution questions wishlist@inmagic.com - feature requests

If your message is intended for a particular person at Inmagic, Inc. (for example, a Technical Support representative who is expecting the message or files), please include the name of that person in the subject and in the message.

Communicating with Other Users

You can participate in user-to-user discussions through an Inmagic forum on the Web. Note that the forums are not an official customer or technical support channel for Inmagic products. To participate in a forum, go to the Inmagic Customer Extranet at http://support.inmagic.com/downloads/extranet.html.
Using the Administration Window to Convert to the Content Server Platform

Before you can use the new software, you must convert your existing textbases, menu screens, and—if you are publishing textbases on the Web with WebPublisher PRO—Web screens, forms, and other Web-related files for use with the Content Server platform and its SQL Server back end.

Use the Content Server Administration window to perform these updates. This window, which is only accessible when using the Content Server Administration program (InmCSAdmin.EXE), is used to perform a number of administrative and maintenance tasks relative to your new software. For details about administrative tasks other than those detailed in this guide, see the Inmagic Content Server Administrator’s Guide and the online help.

There are three operations you can perform to move to the Content Server platform, each with its own command on the Manage Upgrades>Convert from DB/Text menu in the Administration window:

- **Textbases.** Use this command to convert textbases so that they can be opened on the Content Server platform. This command starts a wizard that takes you through the conversion process. You can convert multiple textbases at once, as long as the textbases are in one folder. If they are not, you must run the wizard for each folder containing textbases.

  Tip! We strongly recommend that you back up your existing textbases before converting them to the new version of the software. You will have an opportunity to do this during the conversion process. Note: This command also updates image annotation files by converting your existing annotation files in the image annotation list to a new format (which uses an .ANN extension by default) and then updating the image annotation list to match. Image annotation files created using DB/TextWorks version 7.01 or earlier must be converted to be viewed on the Content Server platform. Image annotation files created using DB/TextWorks version 8.0 or later, or converted using the DBTAnnConv.EXE program do not need to be converted.

- **Menu Screens.** Use this command to convert menu screens so that they can be opened on the Content Server platform.

- **Web Components.** Use this command to convert Web components (for example, HTML query screens, INI files, script files, and so forth) for use on the Content Server platform. You only need to use this command if you are converting from WebPublisher PRO.
Converting Textbases

Before you can use your existing textbases, you must convert them for use on the Content Server platform.

To easily convert your textbases, we have provided a wizard to take you through the process. Choose Manage Upgrades>Convert from DB/Text>Textbases in the Administration window. This process will also convert your image annotation files, if necessary, so that they can be viewed with your new software.

The wizard can convert multiple textbases at once, as long as all of the textbases are in the same folder. If your textbases are in different folders, you must choose Manage Upgrades>Convert from DB/Text>Textbases for each folder containing textbases.

Important! When prompted for a location for your converted textbases, we strongly recommend that you place them in the same location as your DB/TextWorks textbases. They will not be overwritten. Later, you can use the Manage Textbases>Delete Textbase command in the Administration window to delete your DB/TextWorks textbases once you are confident that your new system is running properly.

Once converted, your new textbases will have the same names as your original DB/TextWorks textbases, but will have different extensions. For more information, see “What Will Be Different?” on page 21.

To convert your existing textbases

1. If any of the textbases you plan to convert contain image annotations created with DB/TextWorks version 7.01 or earlier, copy the Art32.DLL file from your DB/TextWorks installation folder to your CS/TextWorks installation folder (for example, C:\Program Files\Inmagic\Content Server, if you accepted the default location during installation).

2. Open the Administration window. On the machine on which CS/TextWorks is installed, click the Windows Start button and choose Programs>Inmagic Applications>Content Server> Administration (CSTW).

3. Choose Manage Upgrades>Convert from DB/Text>Textbases to open the Select Textbases to Convert to Content Server dialog box and do the following:

   a. Navigate the Look in drop-down list to the folder containing the textbase(s) you plan to convert. You must have Full Control access to this folder.

      Note: If you plan to convert multiple textbases and they are not in the same folder, you must choose Manage Upgrades>Convert from DB/Text>Textbases in the Content Server Administration window for each folder containing the textbases.

   b. Select the textbase(s) you want, then click Open.

      Note: If any of the textbases has a Master password, you will be prompted for it during the conversion process.

4. The Convert Textbases from DB/Text: Selected Textbases dialog box opens to summarize the textbases you have selected. Review the list, then click Next to continue specifying settings for the conversion.
5. On the Convert Textbases from DB/Text: Specify Location for Converted Textbases dialog box, do the following:

   a. In the Location box, enter the path to the folder in which you want the files for the converted textbases placed. By default, this is the same location as your original DB/TextWorks textbases.

   **Important!** We strongly recommend that you place the converted textbase files in the same folder as your DB/TextWorks textbases. The original files will not be overwritten, as the new files will have different extensions (for example, .TBA versus .CBA). Putting the converted textbase files in the same location ensures that file references within the textbases and menu screens remain valid. Examples of file references include image or document names, thesaurus links, linked textbase names, textbase references in menu screens, and so forth. If you specify a different location and you have image references that consist of just a filename in your textbases, you will have to copy the image files to the new location or redirect the references to the proper location. Also, be sure to check menu screens, as well as access to linked textbases, thesaurus textbases, and so forth after the conversion.

   At a later date—once you are satisfied that your textbases are up and running on the Content Server platform—you can delete your original DB/TextWorks textbases using the **Manage Textbases>Delete Textbase** command in the Content Server Administration window. Click **Next**.
6. If you are upgrading to *Content Server* Standard and you are using Windows Authentication (the default), the Convert Textbases from DB/Text: Determine When to Set Textbase Security dialog box opens. Select one of the following options, then click **Next**.

**Note:** You will not see this dialog box if you are upgrading to the Workgroup configuration. This is because that configuration only supports SQL Authentication. Continue with step 8.

**Specify textbase security settings now (applied to all selected textbases).** If you select this option button, the Convert Textbases from DB/Text: Add User Rights to Textbases dialog box opens after you click **Next** so that you can set security. If you set security now, it will be applied to all of the converted textbases. You will not be able to give a particular user or group more access to one textbase than another.

**Specify textbase security settings later (individually for each textbase).** If you select this option button, no textbase security will be set on the converted textbases. After the conversion process is complete, before users can access the textbases, you must set security for each textbase by choosing *Configure SQL Server* > *Manage Security* > *Assign User Rights to Textbase* in the Administration window.
7. If you are upgrading to *Content Server* Standard and you selected the *Specify textbase security settings now (applied to all selected textbases)* option button in the previous step, the Convert Textbases from DB/Text: Add User Rights to Textbases dialog box opens so that you can set security. The security that you set on this dialog box applies to all of the converted textbases. Do the following:

a. Click the **Add User** button to open the Add Database User dialog box and select a user that you want to be able to access the textbases from the Login Name drop-down list, then click **OK** to return to the Convert Textbases from DB/Text: Add User Rights to Textbases dialog box.

*Note:* The login you use to convert the textbases will not appear on the Add Database User dialog box because it is automatically a member of **db_owner** for all of the converted textbases. For other user names to be visible, the user/group must exist in the Windows domain (of which SQL Server is a member) and have a login on the SQL Server.

b. From the Current Database Users list on the Convert Textbases from DB/Text: Add User Rights to Textbases dialog box, select the user/group for which you want to set security.

c. [Optional] If you want the user or group with the user name selected in step 7a to be able to edit the structure of the textbases, select the **Member of db_owner** check box from the Properties group. If you select this check box or if the user/group has sysadmin rights, then the options in the next step will be disabled.

d. From the Content Server role membership group, select an option button to assign the selected user/group membership to the appropriate role. Note that a user/group can only be assigned one *Content Server* role.

- **None.** The user name does not have membership to any *Content Server* role and cannot access any of the textbases.
- **Content Server Reader.** The user name has Read-Only access to the textbases. The user name has Select permission in SQL tables.
- **Content Server Data Writer.** The user name can search and modify record information (that is, search for, add, edit, and/or delete records), but cannot modify validation and substitution lists.
- **Content Server Textbase Writer.** The user name can search and modify record information (that is, search for, add, edit, and/or delete records) and update validation lists when overriding content validation (if the appropriate options are selected on the Edit Textbase Structure dialog box).
e. Repeat steps 7a–d for each user/group you want to access the textbases.

f. Click Next.

![Figure 4: Convert Textbases from DB/Text: Add User Rights to Textbases dialog box](image)

8. On the Convert Textbases from DB/Text: Specify Location for Textbase Backup Files dialog box, select or clear the **Automatically back up the selected textbases** check box to specify whether you want the conversion process to automatically back up your existing DB/TextWorks textbases. If you select this check box (the default), the **Location** box is enabled so that you can enter the path to the folder in which you want the textbase backup files to be placed. Click Next.

**Note:** We strongly recommend that you use the automated backup feature during the conversion process.

![Figure 5: Convert Textbases from DB/Text: Specify Location for Textbase Backup Files dialog box](image)
9. On the Convert Textbases from DB/Text: Specify Record Buffer and Temporary Files Location dialog box, enter the following information, then click **Next**:

In the **Maximum records to buffer** box, enter the maximum number of records you want prepared before loading them into the SQL Server database. When determining the number you want to use, consider the balance you want between performance and resource consumption. Larger numbers often result in faster loads, but tend to consume more disk space in the temporary file path. The default value is 30000.

In the **Temp file path** box, enter the path to a public folder on the network in which you want to store temporary files needed for the load operation. This location must be accessible from both this computer and the SQL Server (using the UNC format `\server\share\...`), and the SQL Server account must have Read/Write/Delete access to the folder.

**Note:** The Temporary files (remote SQL Server instance) group is only enabled if the SQL Server is on a machine other than the one you are currently using.

![Convert Textbases from DB/Text: Specify Record Buffer and Temporary Files Location dialog box](image)

10. The Convert Textbases from DB/Text: Confirm Settings dialog box opens so that you can review the settings you specified for the conversion. The Summary section includes the following information:

- The folder containing the textbases to be converted and a list of the textbases.
- The folder in which you want the files for the converted textbases placed and the SQL Server instance that will be used.
- The security settings that will be applied to all of the textbases. (This information will only appear if you are using Content Server Standard and you specified that you want security set during this process.)
- The folder in which textbase backup files will be placed. (This information will only appear if you specified that the selected DB/TextWorks textbases be automatically backed up.)
- The maximum number of records to prepare before loading into the new textbases.
- The temporary file path that will be used while the information from your original textbases is being loaded into the new textbases.

When you are done reviewing the information, click the **Finish** button to begin the conversion process.
11. On the Convert Textbases from DB/Text: Operation Status dialog box, wait while the process completes. The progress bars and the Operation log show the status of the conversion process. This information (including whether any textbases did not convert correctly and why) is logged to the CSUpdates.LOG file, which is located in the same folder as your converted textbases. Review this information to ensure that all textbases were converted as expected, then click **Close**.

**Note:** To cancel the process, click the **Stop Convert Textbases Operation** button that appears while the operation is running.
Your textbases are now ready for use on the Content Server platform.

Important! If your textbases are located in more than one folder, be sure to choose Manage Upgrades>Convert from DB/Text>Textbases and repeat the above set of steps for each different location.

Converting Menu Screens

Before you can use your existing menu screens, you must convert them for use with the Content Server platform.

To easily convert your menu screens, we have provided a command to take you through the process. Choose Manage Upgrades>Convert from DB/Text>Menu Screens in the Administration window. The conversion process redirects the textbase boxes on your menu screens to point to your new, converted textbases that have the same name, but a different extension (that is, .CBA instead of .TBA).

You can convert your menu screens either before or after you convert your textbases. However, the converted menu screens will not work until you have successfully converted the textbases to which they point.

Important! If your converted CS/TextWorks textbases are not in the same location as your DB/TextWorks textbases, the menu screens will not work properly after you convert them using Manage Upgrades>Convert from DB/Text>Menu Screens. If this is the case, you must open your menu screens in the Menu Screen Designer and redirect any textbase boxes to point to the new locations of your textbases. For more information see, “My Converted Textbases are in a New Location” on page 23.

To convert menu screens

1. Open the Administration window. On the machine on which CS/TextWorks is installed, click the Windows Start button and choose Programs>Inmagic Applications>Content Server> Administration (CSTW).

2. Choose Manage Upgrades>Convert from DB/Text>Menu Screens to open the Select Menu Screens to Content Server dialog box. Do the following:

   a. Navigate the Look in drop-down list to the folder containing the menu screen(s) you want to convert.

   b. Select the menu screen(s) you want to convert. The menu screens must all be in the same folder.

   Note: If you plan to convert multiple menu screens and they are not in the same folder, you must choose Manage Upgrades>Convert from DB/Text>Menu Screens in the Administration window for each folder containing the menu screens. Click Open.
3. On the Convert Menu Screens from DB/Text: Confirm Settings dialog box, review the list of menu screens that will be converted, then click **Finish** to confirm the information and start the conversion.

4. On the Convert Menu Screens from DB/Text: Operation Status dialog box, wait while the process completes. The progress bar and the Operation log show the status of the process. This information (including whether any menu screens did not convert correctly and why) is logged to the CSUpdates.LOG file, which is located in the same folder as the menu screens. Before you close the dialog box, we recommend that you review this information to ensure that all of the conversions completed as expected.

   **Note:** To cancel the process, click the **Stop Convert Menu Screens Operation** button that appears while the operation is running.
Converting WebPublisher PRO Components

If you have WebPublisher PRO, you must convert your Web screens, forms, and other Web-related files before you can use them on the Web with CS/WebPublisher PRO.

CS/WebPublisher PRO requires the use of a virtual directory named ics-wpd, which is mapped to your CS/WebPublisher PRO installation folder (for example, C:\Program Files\Inmagic\ICSWeb, if you accepted the default during the installation).

*Note:* The ics-wpd virtual directory should already be created and have the appropriate access rights assigned, as described in the Inmagic Content Server Installation Notes.

To easily convert your Web components, we have provided a command to take you through the conversion process. Choose Manage Upgrades>Convert from DB/Text>Web Components in the Administration window. The process will make a copy of your existing Web screens, forms, script files, and other Web-related files, convert them for use with the Content Server platform (for example, it redirects Web query screens to the new virtual directory), and then place them into the new installation folder structure, as appropriate.

Your original screens, forms, script files, and so forth will remain intact in their original locations. They will not be overwritten. Once your new system is up and running on the Web, you can delete the dbtw-wpd virtual directory structure and files.

*Important!* The conversion process only converts items that are located within the dbtw-wpd virtual directory structure (which is mapped to your WebPublisher PRO installation folder structure). If you keep your Web-related files outside of this folder structure, either copy them into the dbtw-wpd virtual directory for the duration of the conversion, or convert them manually. For details on how to do this, see “My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure” on page 24.

Before you can use your converted Web components with CS/WebPublisher PRO, you must also convert any textbases that are used on the Web for use with the Content Server platform. For more information, see “Converting Textbases” on page 4. You can convert Web components and textbases in any order, although you will not be able to use your Web components until the textbases have been properly converted.

To convert WebPublisher PRO components

1. Open the Administration window. On the machine on which CS/WebPublisher PRO is installed, click the Windows Start button and choose Programs>Inmagic Applications>Content Server> Administration (CSWPP).

2. Choose Manage Upgrades>Convert from DB/Text>Web Components to open the Convert Web
Components from DB/Text: Specify Virtual Directories dialog box and specify the “physical” path to each virtual directory root. This is the folder to which that virtual directory is mapped. Depending on your operating system, these paths may be read from Internet Information Services (IIS) and already appear.

In the Location of dbtw-wpd box, enter the path to the physical folder for the virtual directory root used with WebPublisher PRO. For example, if you accepted the default during installation, the physical path to the WebPublisher PRO virtual directory root (dbtw-wpd) is C:\Program Files\Inmagic\WebPubPRO. You can click the Browse button and navigate to this location.

In the Location of ics-wpd box, enter the path to the physical folder for the virtual directory root used with CS/WebPublisher PRO. For example, if you accepted the default during installation, the physical path to the new virtual directory root (ics-wpd) is C:\Program Files\Inmagic\ICSWeb. You can click the Browse button and navigate to this location. Click Next.

![Convert Web Components from DB/Text: Specify Virtual Directories dialog box](image)

**Figure 12: Convert Web Components from DB/Text: Specify Virtual Directories dialog box**

3. The Convert Web Components from DB/Text: Confirm Settings dialog box opens so that you can review the list of subfolders containing Web-related files that will be converted. The Summary section includes the following information:

   The locations of the dbtw-wpd and ics-wpd root folders.

   The folders within the dbtw-wpd root folder that will have their contents copied, converted, and moved to the ics-wpd root folder.
When you are done reviewing the information, click **Finish** to start the conversion process.

4. On the Convert Web Components from DB/Text: Operation Status dialog box, wait while the conversion completes. The Operation log shows the status of the conversion. This information (including whether any Web files did not convert correctly and why) is logged to the CSUpdates.LOG file in your user file path. We recommend you review this information to ensure that all of the files were converted as intended.

   **Note:** To cancel the process, click the **Stop Convert Web Components Operation** button that appears while the operation is running.

**What Will Be Different?**

When you convert to CS/TextWorks and CS/WebPublisher PRO, you will continue to see the familiar DB/TextWorks interface.
What is different, as explained earlier, is the new “back end” of the software, which is powered by Inmagic Content Server and uses SQL Server as its data store.

The following list details some of the changes you will see after upgrading to CS/TextWorks and CS/WebPublisher PRO.

• There is a new Administration window with its own executable (InmCSAdmin.EXE).
• Because the software now uses SQL Server as its data store, there are fewer mandatory textbase files. These files, which reside outside of SQL Server, all have .CXX extensions (instead of .TXX extensions):
  - The .CBA file (formerly the .TBA file) contains public forms, query screens, sets, and skeletons.
  - The .CAC file (formerly the .ACF file) controls textbase access.
  - The .CBS file (formerly the .DBS file) contains the textbase structure definition.
• User files now have a .CBU extension instead of a .TBU extension.
• Menu screen files now have a .CBM extension instead of a .TBM extension. (Because of this, the DBText.TBM file that is used by default if no other menu screen is specified is now called InmCSrv.CBM.)
• The records, indexes, and textbase lists (validation lists, record classes, and so forth) are stored inside SQL Server. You cannot access these files using Windows Explorer.
• If you are using the Standard configuration of Content Server and you are using Windows Authentication (the default authentication mode), you must apply security settings to the control database on the SQL Server and to each textbase. For more information about security, see the Inmagic Content Server Administrator’s Guide.
• The DBText.INI file is now called InmCSrv.INI.
• Because of the benefits of SQL Server, the deferred indexing feature is no longer necessary. Instead, a new Set Exclusive Textbase Access/Set Shared Textbase Access command lets you toggle between setting exclusive access and setting shared access.
• Several commands on the Manage Textbases menu have moved to the Administration window. They are: Recover Textbase, Check Textbase, Copy Textbase, Rename Textbase, and Delete Textbase.
• A new command appears on the Manage Textbases menu: Clear Textbase Record Locks. This command clears the locks on any locked records (for example, locked records may occur if a power outage happens while records are being edited).
• The following commands now use a fast load mechanism and permit you to specify buffer size:
  - In CS/TextWorks: Manage Textbases>Load New Textbase and File>Import (using the Express Import option).
  - In the Content Server Administration program: Manage Textbases>Recover Textbase, Manage Textbases>Load New Textbase, and Manage Upgrades>Convert from DB/Text>Textbases.
• Express Import now requires exclusive textbase access.
• File>Import Document now only supports IFilters. It no longer supports the DB/Text® Import Filter. IFilter technology is installed with Microsoft Index Server, which comes with Microsoft Windows 2000/XP/2003 operating systems. Besides Microsoft, other vendors have created IFilters for their software products and make them available for download. For example, Adobe has an IFilter that lets you import its Portable Document Format (PDF) documents. For more information on IFilters, refer to the online help.
• The following are no longer available on the Options dialog box (choose Tools>Options):
  - Ignore accents on extended characters. To ignore accents for searches, set the SQL collation appropriately, either during the SQL Server installation or by using the SQLCollation parameter in the InmCSrv.INI file. For information about the SQLCollation parameter, see the online help.
  - Read/write extended characters in MS-DOS format. Extended characters are always written in
Manually Converting Menu Screens and Web Components

This section is only for those customers whose DB/TextWorks and/or WebPublisher PRO configurations do not meet the criteria needed to have their menu screens and Web components converted using the Administration window.

Perform the applicable steps in this section if either of the following is true:

• When converting your DB/TextWorks textbases, you used the Manage Upgrades>Convert from DB/Text>Textbases command in the Administration window, but did not put your converted textbases (with the new .CBA extension) in the same location as your original ones (with the .TBA extension).

• You have WebPublisher PRO and your Web screens, forms, script files, and so forth are located in folders outside of the WebPublisher PRO installation folder.

My Converted Textbases are in a New Location

If you converted your DB/TextWorks textbases and placed the new textbases in a different location from the original textbases, you will not be able to properly convert menu screens using the Manage Upgrades>Convert from DB/Text>Menu Screens command.

Instead, you must manually convert each menu screen that accesses these textbases.

Menu screens used on the Content Server platform must have a .CBM extension. Your existing DB/TextWorks menu screens have a .TBM extension.

Important! Before manually converting menu screens, you must have already converted the textbase(s) to which they point.

To manually convert a menu screen

1. Start CS/TextWorks.

2. Choose Menu Screens>Design to open the Menu Screen Designer.

3. On the Open Menu Screen dialog box, select the Open an Existing Menu Screen File option button, and click OK.

4. On the Open Inmagic Menu Screen File dialog box, select DB/TextWorks Menu Screen Files (*.tbm) from the Files of type drop-down list.

5. Select the .TBM file you want to convert, and click Open.

6. For menu items that open a textbase, use the Textbase Box Properties dialog box to specify the converted textbase (which has the same name as the original textbase, but with a .CBA extension). You may also want to replicate any initial actions and/or initial elements.

7. For menu items that open another menu screen, use the Menu Screen Box properties dialog box to specify the converted menu screen (which will have .CBM extension).

8. Save the menu screen (choose Menu Operations>Save Menu Screen As). Specify the name and location for the menu screen file on the Save Inmagic Menu Screen File As dialog box, then click Save. The resulting file will have a .CBM extension.
My Web Screens/Forms are Located Outside the WebPublisher PRO Folder Structure

If your existing WebPublisher PRO query screens and edit forms are located in folders outside of the WebPublisher PRO folder structure, you must manually convert them before you can use them on the Content Server platform with CS/WebPublisher PRO.

This means that each Web query screen and edit form must be re-exported to HTML using your new software so that the appropriate files and virtual Web names are referenced. (Alternatively, if substantial changes have been made to these files since they were originally exported, you can follow the instructions on page 26.)

Note: Before you manually convert screens and forms, you should use Manage Upgrades>Convert from DB/Text>Web Components command to convert any other files that may reside within the WebPublisher PRO folder structure.

To manually convert WebPublisher PRO query screens

1. Start CS/TextWorks and open the textbase whose query screen you need to re-export.
2. Choose Search>Design Query Screen.
3. On the Open Query Screen dialog box, do the following:
   a. From the Start With list, select Existing Query Screen.
   b. From the Currently Saved list, select the Web query screen you want to convert.
   c. Click OK. The query screen opens in the Query Screen Designer.
4. Choose Screen Operations>Export Query Screen to HTML.
5. A message box appears asking if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click Yes to preserve formatting (such as, box position); click No if you want the software to use simple HTML to format the screen (for example, all boxes will appear left-justified).
6. On the Save File As dialog box, enter a name for the Web screen, then click Save.
7. Click OK to dismiss the completion message.

To manually convert WebPublisher PRO edit forms

Note that only edit forms that were exported to HTML must be converted. (All other forms are saved within the textbase.)

1. Start CS/TextWorks and open the textbase whose edit form you need to re-export to HTML.
2. Choose Display>Design Form.
3. On the Open Form dialog box, do the following:
   a. From the Start With list, select Existing Form.
   b. From the Currently Saved list, select the Web edit form you want to convert.
   c. Click OK. The form opens in the Form Designer.
4. Choose Form Operations>Export Editing Form to HTML.
5. A message appears asking if you want to use Cascading Style Sheets (CSS) to preserve formatting. Click Yes to preserve formatting (for example, box position) when the edit form is displayed on the Web. Click No to have the software use simple HTML to place elements on the edit form (that is, boxes will be left-justified, box labels will appear on top rather than to the left, and so forth).
6. On the Save File As dialog box, enter a name for the Web edit form, then click Save.
7. Click OK to dismiss the completion message.
Manually Converting other Web-related files

Besides Web query screens and edit forms that are exported to HTML, there are other Web-related files that must be converted before you can use them on the Content Server platform (for example, XML applications, forms saved within textbases, files that use canned searches within them).

However, you only have to convert these files by hand if either of the following is true:

- **Your converted textbases are not in the same location as your original textbases.** If this is the case, you must update the ICSWeb.INI file to include the path to the converted textbases.

- **The Web files in question (for example, XML applications) are not located within your existing WebPublisher PRO folder structure.** If this is the case, use a text editor (such as Microsoft Notepad) to make the following text substitutions:

<table>
<thead>
<tr>
<th>DB/Text</th>
<th>Content Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>dbtw-wpd</td>
<td>ics-wpd</td>
</tr>
<tr>
<td>DBTWPub.DLL</td>
<td>ICSWPro.DLL</td>
</tr>
<tr>
<td>DBTWPcgi</td>
<td>ICSPcgi</td>
</tr>
<tr>
<td>iwpp-edit.ASP</td>
<td>icsw-edit.ASP</td>
</tr>
<tr>
<td>jscript/dbtw-</td>
<td>jscript/ics-</td>
</tr>
</tbody>
</table>

  For example, replace instances of “DBTWPub.DLL” with “ICSWPro.DLL”.

*Important!* Check any raw HTML you may have added to reports you designed for Web use. (The easiest way to make this change in form definitions is to export all of them to a single file, delete them, use a text editor to make these changes globally, and re-import them.)

Index

.ACFile, 21
.CAC file, 21
.CBA file, 21
.CBM file, 21
.CBS file, 21
.CBU file, 21
.DBS file, 21
.TBA file, 21
.TBM file, 21
.TBU file, 21

A

Accents, ignore on extended characters, 22
Administration window, 3, 21
Annotations, 1, 3, 4
Art32.dll, 1, 4

C

Collation, 22
Communicating with other users, 2
Contacting Inmagic, 2
Content Server, 1
  - Administration window, 3, 21
  - Documentation, 2
  - Standard, 1, 7, 8, 12, 21
  - Workgroup, 1, 7
Convert
  - Menu screens, 14
  - Textbases, 4
  - Web components, 17
Convert, manually
  - Menu screens, 23
  - WebPublisher PRO, 24
  - WebPublisher PRO edit forms, 25
  - WebPublisher PRO query screens, 24
Web-related files, 26
CS/TextWorks, 1, 21
CS/WebPublisher PRO, 1, 21
Customer Extranet, 2

D
DB/TextWorks, 1, 3, 21
DBTAnnConv.EXE, 3
DBText.INI, 21
DBText.TBM, 21
DBTWPcgi, 26
DBTWPub.DLL, 26
DBTWPub.INI, 22
dbtw-wpd, 17, 18, 19, 26
Differences between Content Server and
DB/TextWorks, 21
Documentation, 2

E
Extended characters, ignore accents, 22
Extranet, 2

F
Forums, 2

H
Help, 2
HTML, 26

I
ICSPCGI, 26
ICSWeb.INI, 22, 26
icsw-edit.ASP, 26
ics-wpd, 17, 18, 19, 22, 26
ICSWPPro.DLL, 26
IFilter technology, 22
Image annotations, 1, 3, 4
Import Filter, 22
Inmagic, Inc., 2
InmCSAdmin.EXE, 3, 21

J
jscript/dbtw-, 26
jscript/ics-, 26

M
Menu screens, 1, 14
Microsoft SQL Server, 1
Microsoft SQL Server 2000 Desktop Engine
(MSDE), 1
Microsoft SQL Server 2005 Express Edition, 1
MSDE (Microsoft SQL Server 2000 Desktop
Engine, 1

R
Raw HTML, 26
Record classes, 21

S
SQL collation, 22
SQL Server, 1
SQLCollation parameter, 22

T
Textbases, 1, 4

V
Validation lists, 21

W
Web components, 1, 17
WebPublisher PRO, 1